VisualCron Namespace

VisualCron API documentation
VisualCron Namespace
Namespaces ► VisualCron

[Missing <summary> documentation for N:VisualCron]

Declaration Syntax
C# Visual Basic Visual C++
namespace VisualCron
Namespace VisualCron
namespace VisualCron
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
 | ConditionSetClass..::._ConditionSetClass |
 | JobClass..::._JobClass |
 | ConditionActionClass..::.ActionT |
 | SecPermissionsClass..::.ActionT |
 | ExecutionContextClass..::.AfterExecutionActionT |
 | TaskArchiveClass..::.ArchiveActionT |
 | ArchiveItemClass |
 | TaskArchiveClass..::.ArchiveT |
 | AttachmentClass | The AttachmentClass contains information about an email attachment
 | ConnectionClass..::.AuthenticationT |
 | TaskPrintDocumentClass..::.AutoDetectDocTypeT |
 | BuildInfo |
 | OnTaskErrorClass..::.CausesErrorT |
 | CertificateClass | A generic class for certificates
 | CertificateDeleteClass |
 | CertificateClass..::.CertificateT |
 | MessageClass..::.ChangeT |
 | ConditionVisualCronClass..::.CheckT |
 | ClientConnectionChangeClass |
 | ClientConnectionClass | Represents a control connection to the VisualCron Server
 | ClientSettingsClass |
 | ClientConnectionClass..::.ClientT | Enum that describes different client types
 | clsNetworkAddressChangedTriggerResult |
 | Command | Base class for all macro commands.
 | TaskArchiveClass..::.CompressionLevelT |
 | COMRECT |
 | ConditionActionClass |
 | ConditionClass..::.ConditionCheckT |
 | ConditionClass |
 | DSConditions..::.ConditionCollectionsDataTable | Represents the strongly named DataTable class.
 | DSConditions..::.ConditionCollectionsRow | Represents strongly named DataRow class.
 | DSConditions..::.ConditionCollectionsRowChangeEvent | Row event argument class
 | DSConditions..::.ConditionCollectionsRowChangeEventHandler |
 | ConditionDeleteClass |
 | ConditionFileClass |
 | ConditionFolderClass |
 | ConditionClass..::.ConditionOperatorT |
 | ConditionProcessClass |
 | ConditionResultClass | A result for a single condition
 | DSConditions..::.ConditionsDataTable | Represents the strongly named DataTable class.
 | ConditionSetClass |
 | ConditionSetDeleteClass |
 | ConditionSetResultClass | The total result for the ConditionSetCheck
 | DSConditions..::.ConditionsRow | Represents strongly named DataRow class.
 | DSConditions..::.ConditionsRowChangeEvent | Row event argument class
 | DSConditions..::.ConditionsRowChangeEventHandler |
 | ConditionClass..::.ConditionT |
 | ConditionVisualCronClass | The VisualCron condition
 | ConnectionClass |
 | ConnectionDeleteClass |
 | ClientConnectionClass..::.ConnectionT | Enum that describes different connection types
 | NetworkDriveClass..::.ConnStatus |
 | ConstantsAPI |
 | TaskJobTaskControlClass..::.ControlActionT |
 | DSCopyFiles..::.CopyFilesDataTable | Represents the strongly named DataTable class.
 | DSCopyFiles..::.CopyFilesRow | Represents strongly named DataRow class.
 | DSCopyFiles..::.CopyFilesRowChangeEvent | Row event argument class
 | DSCopyFiles..::.CopyFilesRowChangeEventHandler |
 | CustomWMIEventClass | Custom WMI Event
 | CustomWMITriggerResultClass |
 | SQLConnectionClass..::.DatabaseT | Based on all databases on www.connectionstrings.com
 | ConnectionClass..::.DataConnectionT |
 | SQLConnectionClass..::.DataProviderT | Supporting the 3 data providers
 | DayClass | DayClass
 | Delay | "Delay" macro command.
 | FileFilterClass..::.DestinationFolderT | If the destination file should be stored in Same folder as source or a Custom folder
 | PrinterSettingsClass..::.DocumentType | All supported document types
 | DoNotObfuscate |
 | DSConditions | Represents a strongly typed in-memory cache of data.
 | DSCopyFiles | Represents a strongly typed in-memory cache of data.
 | DSMAC | Represents a strongly typed in-memory cache of data.
 | DSNetworkCredentials | Represents a strongly typed in-memory cache of data.
 | DSMAC..::.DTMACDataTable | Represents the strongly named DataTable class.
 | DSMAC..::.DTMACRow | Represents strongly named DataRow class.
 | DSMAC..::.DTMACRowChangeEvent | Row event argument class
 | DSMAC..::.DTMACRowChangeEventHandler |
 | TaskDTSClass..::.DTSPackageLocationT | Enum that describes where the package is located
 | ExportImportProgressClass..::.EIStatusT |
 | EmailClass |
 | EmailNotificationClass |
 | TaskEmailClass..::.EmailPriorityT | Enum that contains different priorities that is interpreted by the Email Client.
 | EmailSettingClass |
 | TaskPGPClass..::.EncryptionAlgorithmT | Enum contains different encryption algorithms
 | TaskArchiveClass..::.EncryptionMethodT |
 | PrinterSettingsClass..::.EnmOrientation |
 | PrinterSettingsClass..::.EnmPaperKind |
 | PrinterSettingsClass..::.EnmPrintQuality |
 | PrinterSettingsClass..::.EnmPrintRange |
 | PrinterSettingsClass..::.EnmResizeOption |
 | EnumClass | A collection of enumeration classes
 | PingClass..::.EnumPingResult |
 | WinAPI..::.EnumThreadWindowsCallback |
 | OnTaskErrorClass..::.ErrorT |
 | EventClass | Class that contains all kind of events
 | EventLogEventClass | EventLog Event
 | EventLogNotificationClass |
 | EventLogTriggerResultClass |
 | EventClass..::.EventMatchT |
 | EVENTMSG |
 | EventProcessFoundationClass |
 | LogClass..::.EventT |
 | EventClass..::.EventTy |
 | ExecutionContextClass | Class the controls how the task should be executed, either through Service (background) or from Tray application (foreground)
 | ExecutionContextClass..::.ExecutionT | Enum that describes how the Task should be executed
 | EnumClass..::.ExistActionT | Enum that is used to control different behavior
 | TriggerClass..::.ExpireActionT | Enum that describes different behaviors when a Trigger has expired
 | TriggerClass..::.ExpireT | Enum that describes the causes that could affect an expiration of a Trigger
 | ExportImportProgressClass |
 | SysLogNotificationClass..::.FacilityType |
 | FEPasteToServer |
 | TaskSQLOutputSettingsClass..::.FieldSeparatorCharT |
 | ConditionFileClass..::.FileCheckT |
 | ConditionFileClass..::.FileConditionCheckT |
 | FileEventClass | Event that watches for changes in a certain folder or sub folders
 | FileFilterClass |
 | FileFilterResultClass | Class used for testing FileFilter
 | FileNotificationClass |
 | FileTriggerResultClass |
 | TimeClass..::.FirstLastT | Enum that describes specific settings concerning FirstLastWeekDay
 | ConditionFolderClass..::.FolderCheckT |
 | ExecutionContextClass..::.ForegroundExecuteT | Enum that describes how the foreground execution should be done
 | FTPChangeFolderCommandClass |
 | FTPCommandClass |
 | FTPCommandClass..::.FTPCommandT |
 | FTPCreateFolderCommandClass |
 | FTPCustomCommandClass |
 | FTPDeleteFileCommandClass |
 | FTPDeleteFolderCommandClass |
 | FTPDownloadCommandClass |
 | FTPRenameFileCommandClass |
 | FTPRenameFolderCommandClass |
 | FTPUploadCommandClass |
 | GridColumnClass | Is used to remember the column settings
 | GUITHREADINFO |
 | HARDWAREINPUT |
 | RegistryEventClass..::.HiveT | Enum that describes in what scope to watch in the registry
 | WinAPI..::.HookProc |
 | IForegroundTaskProcess |
 | TrayPopupInfoClass..::.ImageT |
 | INPUT |
 | InputType |
 | InstructionsBuilder | Instructions builder is used to construct a sequence of PlayerInstruction
 | TimeClass..::.IntervalT | Enum that describes the Interval type
 | IntervalTimeTriggerResultClass |
 | ITaskProcess |
 | JobClass | The JobClass is the placeholder of Triggers, Tasks, Notifications
 | JobDeleteAllClass |
 | JobDeleteClass | Message for deleting a Job
 | JobRunClass |
 | JobStateClass | Message that changes Job Active state
 | JobStatsClass |
 | VCJobProcessClass..::.JobStatusType |
 | KEYBDINPUT |
 | KeyboardHookStruct |
 | KeyCodesManager | Provides mapping between virtual key codes and keywoards used to represent them.
 | KEYEVENTF |
 | KeyStrokes | "Keystrokes" macro command.
 | KeyStrokeUnit | Represents a single keystoke action (a character, key down event or key up event).
 | TaskKillClass..::.KillT | Enum which contains different termination methods
 | KillVCProcessClass |
 | SysLogNotificationClass..::.LevelType |
 | LicenseClass | Handles licensing
 | LicenseWarningClass |
 | LicenseClass..::.LicStatus |
 | ConditionVisualCronClass..::.LocatorT |
 | LogArrayClass |
 | LogClass |
 | LoginClass |
 | LogInfoClass |
 | LoginResultClass |
 | EnumClass..::.LogoffScope | Enum that defines if all or a certain user should be logged off
 | TaskExecuteClass..::.LogonT | Enum that contains different logon types
 | LogRequestClass |
 | LogSubscribeClass |
 | TaskDesktopMacroClass..::.MacroSpeed |
 | TaskDesktopMacroClass..::.MacroStatus |
 | MailEventClass..::.MailActionT | Enum that describes what happens with the email when it has been downloaded
 | MailEventClass |
 | MailTriggerResultClass |
 | MarginClass | This is a placeholder class. It should not be used. It's usage is not implemented withing PrintingPreference.
 | ConditionClass..::.MatchT |
 | MemoryInfoClass |
 | MessageBoxClass |
 | MessageClass |
 | MessageRequestClass |
 | EnumClass..::.MonitorStateT | Enum that describes a wanted monitor state
 | MonthClass | DayClass
 | MouseClick | "Mouse Click" macro command.
 | MouseClickInstruction |
 | MouseEvents |
 | MouseHookStruct |
 | MOUSEINPUT |
 | MouseLLHookStruct |
 | MouseMove | "Mouse Move" macro command
 | MouseMoveUnit |
 | MessageClass..::.MType |
 | TaskKillClass..::.MultipleActionT | Enum that contains different possibilities to control the behavior when multiple instances of the process is found
 | NetworkAddressChangedEventClass |
 | NetworkAvailabilityChangedEventClass |
 | NetworkAvailabilityChangedTriggerResultClass |
 | NetworkCredentialClass | Contains information about a Credential
 | NetworkCredentialDeleteClass |
 | DSNetworkCredentials..::.NetworkCredentialsDataTable | Represents the strongly named DataTable class.
 | DSNetworkCredentials..::.NetworkCredentialsRow | Represents strongly named DataRow class.
 | DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent | Row event argument class
 | DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler |
 | NetworkCredentialTestResultClass |
 | NetworkDriveClass | Information about a network drive
 | NetworkDriveDeleteClass | A class that is used to delete a network drive
 | NetworkDriveMapClass |
 | TaskSQLOutputSettingsClass..::.NewLineCharT |
 | NotificationClass |
 | NotificationDeleteClass |
 | NotificationClass..::.NType |
 | TaskOfficeMacroClass..::.OfficeApplicationT | Enum that describes different Office applications
 | OfficeMacroParameterClass | A class that is used in the Office Macro Task for supplying parameters
 | OnTaskErrorClass |
 | TaskVariableCalculateClass..::.OperationT | What type of operation
 | OperativeSystemClass |
 | OperativeSystemInfoClass |
 | ServerSettingsClass..::.OperativeSystemT |
 | CustomWMIEventClass..::.OperatorT | Specifies if you want to include or ignore a certain value
 | EventLogEventClass..::.OperatorT | Enum of Operator type
 | PageSettingsClass..::.PageSettings |
 | PageSettingsClass |
 | PaperSizeClass | This class is paritally implemented and rest is left as a place holder. This holds PaperSettings for a document to be printed.
 | PerformanceCounterEventClass |
 | SecPermissionsClass..::.PermissionT |
 | PFConditionType |
 | TaskPGPClass..::.PGPActionT | Enum that describes the type of action that should be performed
 | PGPKeyRingClass |
 | PGPKeyRingDeleteClass |
 | PGPUserItemClass | A class that is used in lists of Signers and Recipients to identify a certain user that belongs to a certain list.
 | PingClass |
 | PlayerInstruction | A low-level action that can be executed by the UniversalPlayer.
 | POINT32 |
 | POINTSTRUCT |
 | PopupNotificationClass |
 | PrintersClass |
 | PrinterSettingsClass |
 | ConditionProcessClass..::.ProcessCheckT |
 | ProcessClass |
 | ProcessesClass |
 | ProcessEventClass |
 | ProcessorInfoClass |
 | ProcessTriggerResultClass |
 | TaskPGPClass..::.ProtectionLevelT | Enum contains different protection levels
 | ConnectionClass..::.ProtocolT |
 | ProxyClass |
 | ProxyClass..::.ProxyServerT |
 | ProxyClass..::.ProxyT | Enum that describes what type of proxy it is
 | RaisePaperSizeCollection |
 | TaskEmailClass..::.RecipientSeparatorT | Enum that contains different ways to separate a list of Recipients
 | TaskEmailClass..::.RecipientSourceT | Enum that contains different ways the Recipient list is built.
 | RECT |
 | RegistryEventClass..::.RegistryChangeT |
 | RegistryEventClass | The registry event - watches changes in the registry
 | TaskRegistryClass..::.RegistryTaskT | Represent the type of the registry task.
 | RegistryTriggerResultClass |
 | RelativeTo |
 | MessageRequestClass..::.RequestT |
 | RestoreWindowInstruction |
 | LoginResultClass..::.ResultT |
 | ConditionResultClass..::.ResultType |
 | ConditionSetResultClass..::.ResultType |
 | TaskExecuteClass..::.RunAsT | Enum that contains different Run As types
 | MailEventClass..::.SaveActionT | Enum that describes where something (mail or attachment) should be saved)
 | EnumClass..::.Scope | Enum that defines if something is used locally or remotely
 | SecPermissionsClass |
 | SecSettingClass |
 | SecSettingClass..::.SecSettingT |
 | TaskEmailClass..::.SecurityMethodT | Enum that contains different security methods
 | SecUserClass |
 | SendInputInstruction |
 | TaskSendKeysClass..::.SendKeysT | Enum that contains ways find a window
 | ServerClass |
 | ServerInfoClass |
 | ServerInfoGetClass |
 | ServerSettingsClass |
 | ServerStatusClass |
 | ServiceArgumentClass |
 | ServiceClass | Message class. Holds a service
 | ServiceEventClass | Event that watches for changes in a certain Service
 | ServiceInfoClass |
 | ServicesClass | Message class. Used for transporting information about services to API
 | ServicesGetClass |
 | ServiceTriggerResultClass |
 | TaskExportSettingsClass..::.SettingsT |
 | FileFilterClass..::.SizeT |
 | SoundNotificationClass |
 | SoundNotificationClass..::.SoundType |
 | LogClass..::.SourceT |
 | TimeClass..::.SpecificT | Enum that describes specific types of the SpecificDaysOfTheMonth setting
 | SQLConnectionClass |
 | SQLConnectionParameterClass |
 | SQLNotificationClass |
 | SQLParameterClass | Contains parameters for a stored procedure
 | SSHCommandClass |
 | TaskSSHClass..::.SSHCommandT | Enum that defines the way the command should be executed
 | SSHSendCommandClass |
 | SSHSendTextClass |
 | TaskSSISClass..::.SSISPackageLocationT | Enum that describes where the package is located
 | JobStatsClass..::.StatusT |
 | SQLConnectionClass..::.StorageT | Based on the 3 types on www.connectionstrings.com
 | SyncClass |
 | SyncClass..::.SyncT |
 | SysLogNotificationClass |
 | TaskArchiveClass |
 | TaskClass | Generic task object that contains general properties for a Task and contains all tasks.
 | TaskCopyFileClass |
 | TaskCopyFileItemClass |
 | TaskDeleteClass | Message that is used to delete a certain Task.
 | TaskDesktopMacroClass | Macro class that holds all the commands as well as other macro properties.
 | TaskDTSClass | The SSIS task can execute Sql Server 2005 Integration Services packages
 | TaskEmailClass | The Email task is able to send one or more emails
 | OnTaskErrorClass..::.TaskErrorActionT |
 | TaskExecuteClass | The Execute task which can start an Executable
 | TaskExecuteScriptClass | The Execute script Task executes vbscript and jscript
 | TaskExportSettingsClass |
 | TaskFileDeleteClass |
 | TaskFileReadClass |
 | TaskFileRenameClass |
 | TaskFileTouchClass |
 | TaskFileWriteClass |
 | TaskFolderCreateClass |
 | TaskFolderDeleteClass |
 | TaskFolderRenameClass |
 | TaskFTPClass | The FTP Task which supports FTP/FTPS/SFTP
 | TaskHTTPClass | A Task that can perform HTTP requests
 | TaskJobTaskControlClass |
 | TaskKillClass | This Task is able to terminate a running process
 | TaskOfficeMacroClass | A Task that can perform Office Macro execution
 | TaskPGPClass | The PGP task is used to encrypt/decrypt files using OpenPGP standard
 | TaskPingClass |
 | TaskPlaySoundClass |
 | TaskPrintDocumentClass |
 | TaskProcessClass |
 | TaskProcessResultClass |
 | TaskRegistryClass |
 | TaskRemoteExecuteClass | The Remote Execute task can start a remote process within the network
 | TaskRemoteKillClass | This Task is able to terminate a remote running process
 | TaskResultClass | Class that is used in API as result for foreground Task Execution
 | TaskRunClass | A class that is used to Run a certain task
 | TaskSendKeysClass | This Task sends keystrokes to another application window
 | TaskServiceRestartClass |
 | TaskServiceStartClass |
 | TaskServiceStopClass |
 | TaskSQLClass | The SQL task can execute a normal SQL query or Stored Procedure
 | TaskSQLOutputSettingsClass |
 | TaskSSHClass | The SSH task can execute commands of a command channel
 | TaskSSISClass | The SSIS task can execute Sql Server 2005 Integration Services packages
 | TaskStateClass | Message that changes Task Active state
 | TaskStatsClass |
 | TaskStatsClass..::.TaskStatusT |
 | VCTaskProcessClass..::.TaskStatusType |
 | TaskSystemControlMonitorClass |
 | TaskSystemHibernateClass |
 | TaskSystemLockClass |
 | TaskSystemLogoffClass |
 | TaskSystemRestartClass |
 | TaskSystemShutdownClass |
 | TaskSystemStandByClass |
 | TaskSystemUnLockClass |
 | TaskSystemWakeUpClass |
 | TaskSystemWakeUpOnLanClass |
 | TaskClass..::.TaskT | Enum that contains the different task types
 | TaskWaitClass | The Wait Task sleeps for a specified time
 | TaskVariableCalculateClass |
 | TaskVariableRemoveClass |
 | TaskVariableSetClass |
 | TestEmailClass |
 | TimeChangedEventClass |
 | TimeChangedTriggerResultClass |
 | TimeClass |
 | TimeExceptionClass | Time Exception - member of a Time Exception Collection
 | TimeExceptionCollectionClass | A collection of Time Exceptions
 | TimeExceptionCollectionDeleteClass |
 | TimeExceptionDeleteClass |
 | TriggerClass..::.TimeOutActionT | Enum that describes different behaviors when a TimeOut has happened
 | TimeOutClass |
 | TimeClass..::.TimeTriggerT | Enum that describes the type of Time Trigger
 | ConnectionClass..::.TransferT |
 | TrayClientSettingsClass | Settings for Tray Client
 | TrayPopupInfoClass |
 | TrialExtensionClass |
 | TriggerClass |
 | TriggerExpirationClass |
 | TriggerResultClass | This class is a part of the Stats of the job. It will display information about the trigger which last triggered the current job
 | TriggerResultCloneClass |
 | TriggerClass..::.TriggerT | Enum that describes what type of trigger the Trigger is
 | UserDeleteClass |
 | UserVariableClass |
 | UserVariableDeleteClass |
 | ConditionActionClass..::.WaitT |
 | EnumClass..::.WakeUpT | Enum that is used in the Wake Up Task
 | TaskVariableCalculateClass..::.VariableChoiceT |
 | ProcessEventClass..::.WatchT | Different watch types of a process
 | VCJobProcessClass |
 | KillVCProcessClass..::.VCKillT |
 | VCTaskProcessClass |
 | ClientSettingsClass..::.ViewStyle |
 | Wildcard | Implements wildcard matching functionality
 | WinAPI | Contains all required Window API functions exports.
 | WindowController | Provides various functionality that manipulates a window or reads its state.
 | WindowDescriptor | Contains all the information required to find a window.
 | WindowNotFoundException |
 | WINDOWPLACEMENT |
 | WindowRestorationException |
 | WindowsLocator | Finds windows based on the provided WindowDescriptor.
 | WindowsLocatorWithMemory | Finds windows based on the provided WindowDescriptor the same way as WindowsLocator. Caches all search results internally so the cached window is returned on subsequent search requests.
 | WindowState |
 | WindowTargetingCommand | Base class for all commands that target a specific window.
 | VisualCronEventClass | VisualCron Event - watches internal events
 | VisualCronProcessInfoClass |
 | VisualCronTriggerResultClass |
 | XMLCommandClass |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron


ArchiveItemClass Class

ArchiveItemClass Class
Namespaces ► VisualCron ► ArchiveItemClass

[Missing <summary> documentation for T:VisualCron.ArchiveItemClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ArchiveItemClass : ICloneable
<SerializableAttribute> _
Public Class ArchiveItemClass _
    Implements ICloneable
[SerializableAttribute]
public ref class ArchiveItemClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ArchiveItemClass()()() | Initializes a new instance of the ArchiveItemClass class
 | Clone()()() |
 | CloneType()()() |
 | DeleteAfter | If the file should be deleted after being added to the zip file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExistAction |
 | FileFilter | Filter object that controls files archive
 | FileMask | Obsolete. Use FileFilter.IncludeFilesMask instead
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | IncludeSubFolders | Obsolete. Use FileFilter.IncludeSubfolders instead.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path | Obsolete. Use FileFilter.SourceFolder instead.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ArchiveItemClass

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCron (Module: VisualCron) Version: 1.0.1.18806


ArchiveItemClass Constructor

ArchiveItemClass Constructor
Namespaces ► VisualCron ► ArchiveItemClass ► ArchiveItemClass()()()
Initializes a new instance of the ArchiveItemClass class
Declaration Syntax
C# Visual Basic Visual C++
public ArchiveItemClass()
Public Sub New
public:
ArchiveItemClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► ArchiveItemClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.ArchiveItemClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.ArchiveItemClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► ArchiveItemClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.ArchiveItemClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public ArchiveItemClass CloneType()
Public Function CloneType As ArchiveItemClass
public:
ArchiveItemClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.ArchiveItemClass.CloneType]


DeleteAfter Property

DeleteAfter Property
Namespaces ► VisualCron ► ArchiveItemClass ► DeleteAfter
If the file should be deleted after being added to the zip file
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteAfter { get; set; }
Public Property DeleteAfter As Boolean
public:
property bool DeleteAfter {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExistAction Field

ExistAction Field
Namespaces ► VisualCron ► ArchiveItemClass ► ExistAction

[Missing <summary> documentation for F:VisualCron.ArchiveItemClass.ExistAction]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.ExistActionT ExistAction
Public ExistAction As EnumClass..::.ExistActionT
public:
EnumClass..::.ExistActionT ExistAction

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► ArchiveItemClass ► FileFilter
Filter object that controls files archive
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileMask Property

FileMask Property
Namespaces ► VisualCron ► ArchiveItemClass ► FileMask
Obsolete. Use FileFilter.IncludeFilesMask instead
Declaration Syntax
C# Visual Basic Visual C++
public string FileMask { get; set; }
Public Property FileMask As String
public:
property String^ FileMask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► ArchiveItemClass ► Id

[Missing <summary> documentation for P:VisualCron.ArchiveItemClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


IncludeSubFolders Property

IncludeSubFolders Property
Namespaces ► VisualCron ► ArchiveItemClass ► IncludeSubFolders
Obsolete. Use FileFilter.IncludeSubfolders instead.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubFolders { get; set; }
Public Property IncludeSubFolders As Boolean
public:
property bool IncludeSubFolders {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Path Property

Path Property
Namespaces ► VisualCron ► ArchiveItemClass ► Path
Obsolete. Use FileFilter.SourceFolder instead.
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; set; }
Public Property Path As String
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AttachmentClass Class

AttachmentClass Class
Namespaces ► VisualCron ► AttachmentClass
The AttachmentClass contains information about an email attachment
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class AttachmentClass
<SerializableAttribute> _
Public Class AttachmentClass
[SerializableAttribute]
public ref class AttachmentClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AttachmentClass()()() | Initializes a new instance of the AttachmentClass class
 | Credential | Gets or sets the Credential that is used to read the attachment
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileFilter | Filter object that controls files to attach
 | FilePath | Obsolete. Use FileFilter instead.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Unique Id of the attachment
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
AttachmentClass

Send comments on this topic to Please email feedback to Support


AttachmentClass Constructor

AttachmentClass Constructor
Namespaces ► VisualCron ► AttachmentClass ► AttachmentClass()()()
Initializes a new instance of the AttachmentClass class
Declaration Syntax
C# Visual Basic Visual C++
public AttachmentClass()
Public Sub New
public:
AttachmentClass()


Credential Property

Credential Property
Namespaces ► VisualCron ► AttachmentClass ► Credential
Gets or sets the Credential that is used to read the attachment
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Default: empty
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► AttachmentClass ► FileFilter
Filter object that controls files to attach
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FilePath Property

FilePath Property
Namespaces ► VisualCron ► AttachmentClass ► FilePath
Obsolete. Use FileFilter instead.
Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► AttachmentClass ► Id
Unique Id of the attachment
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


BuildInfo Class

BuildInfo Class
Namespaces ► VisualCron ► BuildInfo

[Missing <summary> documentation for T:VisualCron.BuildInfo]

Declaration Syntax
C# Visual Basic Visual C++
public class BuildInfo
Public Class BuildInfo
public ref class BuildInfo
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuildInfo()()() | Initializes a new instance of the BuildInfo class
 | BuildDate |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProtocolVersion |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BuildInfo

Send comments on this topic to Please email feedback to Support


BuildInfo Constructor

BuildInfo Constructor
Namespaces ► VisualCron ► BuildInfo ► BuildInfo()()()
Initializes a new instance of the BuildInfo class
Declaration Syntax
C# Visual Basic Visual C++
public BuildInfo()
Public Sub New
public:
BuildInfo()


BuildDate Field

BuildDate Field
Namespaces ► VisualCron ► BuildInfo ► BuildDate

[Missing <summary> documentation for F:VisualCron.BuildInfo.BuildDate]

Declaration Syntax
C# Visual Basic Visual C++
public const string BuildDate
Public Const BuildDate As String
public:
literal String^ BuildDate


ProtocolVersion Field

ProtocolVersion Field
Namespaces ► VisualCron ► BuildInfo ► ProtocolVersion

[Missing <summary> documentation for F:VisualCron.BuildInfo.ProtocolVersion]

Declaration Syntax
C# Visual Basic Visual C++
public const string ProtocolVersion
Public Const ProtocolVersion As String
public:
literal String^ ProtocolVersion


CertificateClass Class

CertificateClass Class
Namespaces ► VisualCron ► CertificateClass
A generic class for certificates
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CertificateClass
<SerializableAttribute> _
Public Class CertificateClass
[SerializableAttribute]
public ref class CertificateClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CertificateClass()()() | Initializes a new instance of the CertificateClass class
 | Approved | If user has aproved certificate
 | Certificate | The byte represenatation of the certificate
 | CertificateType | What type the certificate is
 | Created | Gets or sets when certificate was created
 | EffectiveDate |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpirationDate |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Unique id for the certificate (GUID)
 | IssuerName |
 | Key |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | Status |
 | Text |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CertificateClass

Send comments on this topic to Please email feedback to Support


CertificateClass Constructor

CertificateClass Constructor
Namespaces ► VisualCron ► CertificateClass ► CertificateClass()()()
Initializes a new instance of the CertificateClass class
Declaration Syntax
C# Visual Basic Visual C++
public CertificateClass()
Public Sub New
public:
CertificateClass()


Approved Property

Approved Property
Namespaces ► VisualCron ► CertificateClass ► Approved
If user has aproved certificate
Declaration Syntax
C# Visual Basic Visual C++
public bool Approved { get; set; }
Public Property Approved As Boolean
public:
property bool Approved {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Certificate Property

Certificate Property
Namespaces ► VisualCron ► CertificateClass ► Certificate
The byte represenatation of the certificate
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Certificate { get; set; }
Public Property Certificate As Byte()
public:
property array<unsigned char>^ Certificate {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Only used with Eldos currently

Send comments on this topic to Please email feedback to Support


CertificateType Property

CertificateType Property
Namespaces ► VisualCron ► CertificateClass ► CertificateType
What type the certificate is
Declaration Syntax
C# Visual Basic Visual C++
public CertificateClass..::.CertificateT CertificateType { get; set; }
Public Property CertificateType As CertificateClass..::.CertificateT
public:
property CertificateClass..::.CertificateT CertificateType {
    CertificateClass..::.CertificateT get ();
    void set (CertificateClass..::.CertificateT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Created Property

Created Property
Namespaces ► VisualCron ► CertificateClass ► Created
Gets or sets when certificate was created
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Created { get; set; }
Public Property Created As DateTime
public:
property DateTime Created {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EffectiveDate Property

EffectiveDate Property
Namespaces ► VisualCron ► CertificateClass ► EffectiveDate

[Missing <summary> documentation for P:VisualCron.CertificateClass.EffectiveDate]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime EffectiveDate { get; set; }
Public Property EffectiveDate As DateTime
public:
property DateTime EffectiveDate {
    DateTime get ();
    void set (DateTime value);
}


ExpirationDate Property

ExpirationDate Property
Namespaces ► VisualCron ► CertificateClass ► ExpirationDate

[Missing <summary> documentation for P:VisualCron.CertificateClass.ExpirationDate]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}


Id Property

Id Property
Namespaces ► VisualCron ► CertificateClass ► Id
Unique id for the certificate (GUID)
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IssuerName Property

IssuerName Property
Namespaces ► VisualCron ► CertificateClass ► IssuerName

[Missing <summary> documentation for P:VisualCron.CertificateClass.IssuerName]

Declaration Syntax
C# Visual Basic Visual C++
public string IssuerName { get; set; }
Public Property IssuerName As String
public:
property String^ IssuerName {
    String^ get ();
    void set (String^ value);
}


Key Property

Key Property
Namespaces ► VisualCron ► CertificateClass ► Key

[Missing <summary> documentation for P:VisualCron.CertificateClass.Key]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] Key { get; set; }
Public Property Key As Byte()
public:
property array<unsigned char>^ Key {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


Name Property

Name Property
Namespaces ► VisualCron ► CertificateClass ► Name

[Missing <summary> documentation for P:VisualCron.CertificateClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Status Property

Status Property
Namespaces ► VisualCron ► CertificateClass ► Status

[Missing <summary> documentation for P:VisualCron.CertificateClass.Status]

Declaration Syntax
C# Visual Basic Visual C++
public string Status { get; set; }
Public Property Status As String
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}


Text Property

Text Property
Namespaces ► VisualCron ► CertificateClass ► Text

[Missing <summary> documentation for P:VisualCron.CertificateClass.Text]

Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


CertificateClass.CertificateT Enumeration

CertificateClass..::.CertificateT Enumeration
Namespaces ► VisualCron ► CertificateClass ► CertificateClass..::.CertificateT

[Missing <summary> documentation for T:VisualCron.CertificateClass.CertificateT]

Declaration Syntax
C# Visual Basic Visual C++
public enum CertificateT
Public Enumeration CertificateT
public enum class CertificateT
Members
Member | Description
XceedFTPCertificate |
EldosTElX509Certificate |


CertificateDeleteClass Class

CertificateDeleteClass Class
Namespaces ► VisualCron ► CertificateDeleteClass

[Missing <summary> documentation for T:VisualCron.CertificateDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CertificateDeleteClass
<SerializableAttribute> _
Public Class CertificateDeleteClass
[SerializableAttribute]
public ref class CertificateDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CertificateDeleteClass()()() | Initializes a new instance of the CertificateDeleteClass class
 | Deleted | Indicates if the Certificate was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Certificate to remove
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CertificateDeleteClass

Send comments on this topic to Please email feedback to Support


CertificateDeleteClass Constructor

CertificateDeleteClass Constructor
Namespaces ► VisualCron ► CertificateDeleteClass ► CertificateDeleteClass()()()
Initializes a new instance of the CertificateDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public CertificateDeleteClass()
Public Sub New
public:
CertificateDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► CertificateDeleteClass ► Deleted
Indicates if the Certificate was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► CertificateDeleteClass ► Id
Gets or sets the Id of the Certificate to remove
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ClientConnectionChangeClass Class

ClientConnectionChangeClass Class
Namespaces ► VisualCron ► ClientConnectionChangeClass

[Missing <summary> documentation for T:VisualCron.ClientConnectionChangeClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ClientConnectionChangeClass
<SerializableAttribute> _
Public Class ClientConnectionChangeClass
[SerializableAttribute]
public ref class ClientConnectionChangeClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientConnectionChangeClass()()() | Initializes a new instance of the ClientConnectionChangeClass class
 | CC |
 | ChangeType |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ClientConnectionChangeClass

Send comments on this topic to Please email feedback to Support


ClientConnectionChangeClass Constructor

ClientConnectionChangeClass Constructor
Namespaces ► VisualCron ► ClientConnectionChangeClass ► ClientConnectionChangeClass()()()
Initializes a new instance of the ClientConnectionChangeClass class
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionChangeClass()
Public Sub New
public:
ClientConnectionChangeClass()


CC Field

CC Field
Namespaces ► VisualCron ► ClientConnectionChangeClass ► CC

[Missing <summary> documentation for F:VisualCron.ClientConnectionChangeClass.CC]

Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionClass CC
Public CC As ClientConnectionClass
public:
ClientConnectionClass^ CC

Send comments on this topic to Please email feedback to Support


ChangeType Field

ChangeType Field
Namespaces ► VisualCron ► ClientConnectionChangeClass ► ChangeType

[Missing <summary> documentation for F:VisualCron.ClientConnectionChangeClass.ChangeType]

Declaration Syntax
C# Visual Basic Visual C++
public MessageClass..::.ChangeT ChangeType
Public ChangeType As MessageClass..::.ChangeT
public:
MessageClass..::.ChangeT ChangeType

Send comments on this topic to Please email feedback to Support


ClientConnectionClass Class

ClientConnectionClass Class
Namespaces ► VisualCron ► ClientConnectionClass
Represents a control connection to the VisualCron Server
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ClientConnectionClass
<SerializableAttribute> _
Public Class ClientConnectionClass
[SerializableAttribute]
public ref class ClientConnectionClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientConnectionClass()()() | Initializes a new instance of the ClientConnectionClass class
 | Address | Gets or sets the hostname or ip of the connection
 | ClientType | Gets or sets the client type
 | ConnectionDate |
 | ConnectionType | Gets or sets the connection type
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the connection Id of the client (on server)
 | MachineName | Gets or sets the name of the computer that the client is running on
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SessionID | Gets or sets which session id the client process runs in
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseCompression |
 | UserId | Gets or sets the UserId (SecUser) that has made the connection
 | WindowsUserName | Gets or sets the Windows username that made the connection
Remarks
Inheritance Hierarchy
Object
ClientConnectionClass

Send comments on this topic to Please email feedback to Support


ClientConnectionClass Constructor

ClientConnectionClass Constructor
Namespaces ► VisualCron ► ClientConnectionClass ► ClientConnectionClass()()()
Initializes a new instance of the ClientConnectionClass class
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionClass()
Public Sub New
public:
ClientConnectionClass()


Address Property

Address Property
Namespaces ► VisualCron ► ClientConnectionClass ► Address
Gets or sets the hostname or ip of the connection
Declaration Syntax
C# Visual Basic Visual C++
public string Address { get; set; }
Public Property Address As String
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ClientType Property

ClientType Property
Namespaces ► VisualCron ► ClientConnectionClass ► ClientType
Gets or sets the client type
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionClass..::.ClientT ClientType { get; set; }
Public Property ClientType As ClientConnectionClass..::.ClientT
public:
property ClientConnectionClass..::.ClientT ClientType {
    ClientConnectionClass..::.ClientT get ();
    void set (ClientConnectionClass..::.ClientT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConnectionDate Property

ConnectionDate Property
Namespaces ► VisualCron ► ClientConnectionClass ► ConnectionDate

[Missing <summary> documentation for P:VisualCron.ClientConnectionClass.ConnectionDate]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime ConnectionDate { get; set; }
Public Property ConnectionDate As DateTime
public:
property DateTime ConnectionDate {
    DateTime get ();
    void set (DateTime value);
}


ConnectionType Property

ConnectionType Property
Namespaces ► VisualCron ► ClientConnectionClass ► ConnectionType
Gets or sets the connection type
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionClass..::.ConnectionT ConnectionType { get; set; }
Public Property ConnectionType As ClientConnectionClass..::.ConnectionT
public:
property ClientConnectionClass..::.ConnectionT ConnectionType {
    ClientConnectionClass..::.ConnectionT get ();
    void set (ClientConnectionClass..::.ConnectionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► ClientConnectionClass ► Id
Gets or sets the connection Id of the client (on server)
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MachineName Property

MachineName Property
Namespaces ► VisualCron ► ClientConnectionClass ► MachineName
Gets or sets the name of the computer that the client is running on
Declaration Syntax
C# Visual Basic Visual C++
public string MachineName { get; set; }
Public Property MachineName As String
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SessionID Property

SessionID Property
Namespaces ► VisualCron ► ClientConnectionClass ► SessionID
Gets or sets which session id the client process runs in
Declaration Syntax
C# Visual Basic Visual C++
public int SessionID { get; set; }
Public Property SessionID As Integer
public:
property int SessionID {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseCompression Property

UseCompression Property
Namespaces ► VisualCron ► ClientConnectionClass ► UseCompression

[Missing <summary> documentation for P:VisualCron.ClientConnectionClass.UseCompression]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseCompression { get; set; }
Public Property UseCompression As Boolean
public:
property bool UseCompression {
    bool get ();
    void set (bool value);
}


UserId Property

UserId Property
Namespaces ► VisualCron ► ClientConnectionClass ► UserId
Gets or sets the UserId (SecUser) that has made the connection
Declaration Syntax
C# Visual Basic Visual C++
public string UserId { get; set; }
Public Property UserId As String
public:
property String^ UserId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


WindowsUserName Property

WindowsUserName Property
Namespaces ► VisualCron ► ClientConnectionClass ► WindowsUserName
Gets or sets the Windows username that made the connection
Declaration Syntax
C# Visual Basic Visual C++
public string WindowsUserName { get; set; }
Public Property WindowsUserName As String
public:
property String^ WindowsUserName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ClientConnectionClass.ClientT Enumeration

ClientConnectionClass..::.ClientT Enumeration
Namespaces ► VisualCron ► ClientConnectionClass ► ClientConnectionClass..::.ClientT
Enum that describes different client types
Declaration Syntax
C# Visual Basic Visual C++
public enum ClientT
Public Enumeration ClientT
public enum class ClientT
Members
Member | Description
APIClient |
TrayClient |
VCClient |
Remarks

Send comments on this topic to Please email feedback to Support


ClientConnectionClass.ConnectionT Enumeration

ClientConnectionClass..::.ConnectionT Enumeration
Namespaces ► VisualCron ► ClientConnectionClass ► ClientConnectionClass..::.ConnectionT
Enum that describes different connection types
Declaration Syntax
C# Visual Basic Visual C++
public enum ConnectionT
Public Enumeration ConnectionT
public enum class ConnectionT
Members
Member | Description
IPC |
Socket |
Remarks

Send comments on this topic to Please email feedback to Support


ClientSettingsClass Class

ClientSettingsClass Class
Namespaces ► VisualCron ► ClientSettingsClass

[Missing <summary> documentation for T:VisualCron.ClientSettingsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ClientSettingsClass
<SerializableAttribute> _
Public Class ClientSettingsClass
[SerializableAttribute]
public ref class ClientSettingsClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientSettingsClass()()() | Initializes a new instance of the ClientSettingsClass class
 | AutoConnect |
 | AutoSortOnUpdate |
 | AutoTranslateToUNC |
 | CheckForUpdates |
 | ClientLogToFile |
 | DefaultAccountId |
 | DelayGridUpdate |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilterComm |
 | FilterDebug |
 | FilterError |
 | FilterInfo |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GridUpdateInterval |
 | GuideV1Shown |
 | HasRegistred |
 | ImportantChangesShown |
 | JobColumns |
 | LanguageId | Chosen language for the user, default english languageid
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessUpdateInterval |
 | ProcessViewStyle |
 | Proxy |
 | RibbonMinimized |
 | ShowServerMessageBoxes |
 | ShowToolTips |
 | Startups |
 | TaskColumns |
 | Theme |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WHeight |
 | WPositionX |
 | WPositionY |
 | WWidth |
 | WWindowState |
Inheritance Hierarchy
Object
ClientSettingsClass

Send comments on this topic to Please email feedback to Support


ClientSettingsClass Constructor

ClientSettingsClass Constructor
Namespaces ► VisualCron ► ClientSettingsClass ► ClientSettingsClass()()()
Initializes a new instance of the ClientSettingsClass class
Declaration Syntax
C# Visual Basic Visual C++
public ClientSettingsClass()
Public Sub New
public:
ClientSettingsClass()


AutoConnect Property

AutoConnect Property
Namespaces ► VisualCron ► ClientSettingsClass ► AutoConnect

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.AutoConnect]

Declaration Syntax
C# Visual Basic Visual C++
public bool AutoConnect { get; set; }
Public Property AutoConnect As Boolean
public:
property bool AutoConnect {
    bool get ();
    void set (bool value);
}


AutoSortOnUpdate Property

AutoSortOnUpdate Property
Namespaces ► VisualCron ► ClientSettingsClass ► AutoSortOnUpdate

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.AutoSortOnUpdate]

Declaration Syntax
C# Visual Basic Visual C++
public bool AutoSortOnUpdate { get; set; }
Public Property AutoSortOnUpdate As Boolean
public:
property bool AutoSortOnUpdate {
    bool get ();
    void set (bool value);
}


AutoTranslateToUNC Property

AutoTranslateToUNC Property
Namespaces ► VisualCron ► ClientSettingsClass ► AutoTranslateToUNC

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.AutoTranslateToUNC]

Declaration Syntax
C# Visual Basic Visual C++
public bool AutoTranslateToUNC { get; set; }
Public Property AutoTranslateToUNC As Boolean
public:
property bool AutoTranslateToUNC {
    bool get ();
    void set (bool value);
}


CheckForUpdates Property

CheckForUpdates Property
Namespaces ► VisualCron ► ClientSettingsClass ► CheckForUpdates

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.CheckForUpdates]

Declaration Syntax
C# Visual Basic Visual C++
public bool CheckForUpdates { get; set; }
Public Property CheckForUpdates As Boolean
public:
property bool CheckForUpdates {
    bool get ();
    void set (bool value);
}


ClientLogToFile Property

ClientLogToFile Property
Namespaces ► VisualCron ► ClientSettingsClass ► ClientLogToFile

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.ClientLogToFile]

Declaration Syntax
C# Visual Basic Visual C++
public bool ClientLogToFile { get; set; }
Public Property ClientLogToFile As Boolean
public:
property bool ClientLogToFile {
    bool get ();
    void set (bool value);
}


DefaultAccountId Property

DefaultAccountId Property
Namespaces ► VisualCron ► ClientSettingsClass ► DefaultAccountId

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.DefaultAccountId]

Declaration Syntax
C# Visual Basic Visual C++
public string DefaultAccountId { get; set; }
Public Property DefaultAccountId As String
public:
property String^ DefaultAccountId {
    String^ get ();
    void set (String^ value);
}


DelayGridUpdate Property

DelayGridUpdate Property
Namespaces ► VisualCron ► ClientSettingsClass ► DelayGridUpdate

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.DelayGridUpdate]

Declaration Syntax
C# Visual Basic Visual C++
public bool DelayGridUpdate { get; set; }
Public Property DelayGridUpdate As Boolean
public:
property bool DelayGridUpdate {
    bool get ();
    void set (bool value);
}


FilterComm Property

FilterComm Property
Namespaces ► VisualCron ► ClientSettingsClass ► FilterComm

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.FilterComm]

Declaration Syntax
C# Visual Basic Visual C++
public bool FilterComm { get; set; }
Public Property FilterComm As Boolean
public:
property bool FilterComm {
    bool get ();
    void set (bool value);
}


FilterDebug Property

FilterDebug Property
Namespaces ► VisualCron ► ClientSettingsClass ► FilterDebug

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.FilterDebug]

Declaration Syntax
C# Visual Basic Visual C++
public bool FilterDebug { get; set; }
Public Property FilterDebug As Boolean
public:
property bool FilterDebug {
    bool get ();
    void set (bool value);
}


FilterError Property

FilterError Property
Namespaces ► VisualCron ► ClientSettingsClass ► FilterError

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.FilterError]

Declaration Syntax
C# Visual Basic Visual C++
public bool FilterError { get; set; }
Public Property FilterError As Boolean
public:
property bool FilterError {
    bool get ();
    void set (bool value);
}


FilterInfo Property

FilterInfo Property
Namespaces ► VisualCron ► ClientSettingsClass ► FilterInfo

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.FilterInfo]

Declaration Syntax
C# Visual Basic Visual C++
public bool FilterInfo { get; set; }
Public Property FilterInfo As Boolean
public:
property bool FilterInfo {
    bool get ();
    void set (bool value);
}


GridUpdateInterval Property

GridUpdateInterval Property
Namespaces ► VisualCron ► ClientSettingsClass ► GridUpdateInterval

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.GridUpdateInterval]

Declaration Syntax
C# Visual Basic Visual C++
public int GridUpdateInterval { get; set; }
Public Property GridUpdateInterval As Integer
public:
property int GridUpdateInterval {
    int get ();
    void set (int value);
}


GuideV1Shown Property

GuideV1Shown Property
Namespaces ► VisualCron ► ClientSettingsClass ► GuideV1Shown

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.GuideV1Shown]

Declaration Syntax
C# Visual Basic Visual C++
public bool GuideV1Shown { get; set; }
Public Property GuideV1Shown As Boolean
public:
property bool GuideV1Shown {
    bool get ();
    void set (bool value);
}


HasRegistred Property

HasRegistred Property
Namespaces ► VisualCron ► ClientSettingsClass ► HasRegistred

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.HasRegistred]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasRegistred { get; set; }
Public Property HasRegistred As Boolean
public:
property bool HasRegistred {
    bool get ();
    void set (bool value);
}


ImportantChangesShown Property

ImportantChangesShown Property
Namespaces ► VisualCron ► ClientSettingsClass ► ImportantChangesShown

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.ImportantChangesShown]

Declaration Syntax
C# Visual Basic Visual C++
public bool ImportantChangesShown { get; set; }
Public Property ImportantChangesShown As Boolean
public:
property bool ImportantChangesShown {
    bool get ();
    void set (bool value);
}


JobColumns Property

JobColumns Property
Namespaces ► VisualCron ► ClientSettingsClass ► JobColumns

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.JobColumns]

Declaration Syntax
C# Visual Basic Visual C++
public GridColumnClass[] JobColumns { get; set; }
Public Property JobColumns As GridColumnClass()
public:
property array<GridColumnClass^>^ JobColumns {
    array<GridColumnClass^>^ get ();
    void set (array<GridColumnClass^>^ value);
}


LanguageId Property

LanguageId Property
Namespaces ► VisualCron ► ClientSettingsClass ► LanguageId
Chosen language for the user, default english languageid
Declaration Syntax
C# Visual Basic Visual C++
public int LanguageId { get; set; }
Public Property LanguageId As Integer
public:
property int LanguageId {
    int get ();
    void set (int value);
}
Value
Remarks

Send comments on this topic to Please email feedback to Support


ProcessUpdateInterval Property

ProcessUpdateInterval Property
Namespaces ► VisualCron ► ClientSettingsClass ► ProcessUpdateInterval

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.ProcessUpdateInterval]

Declaration Syntax
C# Visual Basic Visual C++
public int ProcessUpdateInterval { get; set; }
Public Property ProcessUpdateInterval As Integer
public:
property int ProcessUpdateInterval {
    int get ();
    void set (int value);
}


ProcessViewStyle Field

ProcessViewStyle Field
Namespaces ► VisualCron ► ClientSettingsClass ► ProcessViewStyle

[Missing <summary> documentation for F:VisualCron.ClientSettingsClass.ProcessViewStyle]

Declaration Syntax
C# Visual Basic Visual C++
public ClientSettingsClass..::.ViewStyle ProcessViewStyle
Public ProcessViewStyle As ClientSettingsClass..::.ViewStyle
public:
ClientSettingsClass..::.ViewStyle ProcessViewStyle


Proxy Property

Proxy Property
Namespaces ► VisualCron ► ClientSettingsClass ► Proxy

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.Proxy]

Declaration Syntax
C# Visual Basic Visual C++
public ProxyClass Proxy { get; set; }
Public Property Proxy As ProxyClass
public:
property ProxyClass^ Proxy {
    ProxyClass^ get ();
    void set (ProxyClass^ value);
}


RibbonMinimized Property

RibbonMinimized Property
Namespaces ► VisualCron ► ClientSettingsClass ► RibbonMinimized

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.RibbonMinimized]

Declaration Syntax
C# Visual Basic Visual C++
public bool RibbonMinimized { get; set; }
Public Property RibbonMinimized As Boolean
public:
property bool RibbonMinimized {
    bool get ();
    void set (bool value);
}


ShowServerMessageBoxes Property

ShowServerMessageBoxes Property
Namespaces ► VisualCron ► ClientSettingsClass ► ShowServerMessageBoxes

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.ShowServerMessageBoxes]

Declaration Syntax
C# Visual Basic Visual C++
public bool ShowServerMessageBoxes { get; set; }
Public Property ShowServerMessageBoxes As Boolean
public:
property bool ShowServerMessageBoxes {
    bool get ();
    void set (bool value);
}


ShowToolTips Property

ShowToolTips Property
Namespaces ► VisualCron ► ClientSettingsClass ► ShowToolTips

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.ShowToolTips]

Declaration Syntax
C# Visual Basic Visual C++
public bool ShowToolTips { get; set; }
Public Property ShowToolTips As Boolean
public:
property bool ShowToolTips {
    bool get ();
    void set (bool value);
}


Startups Property

Startups Property
Namespaces ► VisualCron ► ClientSettingsClass ► Startups

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.Startups]

Declaration Syntax
C# Visual Basic Visual C++
public int Startups { get; set; }
Public Property Startups As Integer
public:
property int Startups {
    int get ();
    void set (int value);
}


TaskColumns Property

TaskColumns Property
Namespaces ► VisualCron ► ClientSettingsClass ► TaskColumns

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.TaskColumns]

Declaration Syntax
C# Visual Basic Visual C++
public GridColumnClass[] TaskColumns { get; set; }
Public Property TaskColumns As GridColumnClass()
public:
property array<GridColumnClass^>^ TaskColumns {
    array<GridColumnClass^>^ get ();
    void set (array<GridColumnClass^>^ value);
}


Theme Property

Theme Property
Namespaces ► VisualCron ► ClientSettingsClass ► Theme

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.Theme]

Declaration Syntax
C# Visual Basic Visual C++
public string Theme { get; set; }
Public Property Theme As String
public:
property String^ Theme {
    String^ get ();
    void set (String^ value);
}


WHeight Property

WHeight Property
Namespaces ► VisualCron ► ClientSettingsClass ► WHeight

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.WHeight]

Declaration Syntax
C# Visual Basic Visual C++
public int WHeight { get; set; }
Public Property WHeight As Integer
public:
property int WHeight {
    int get ();
    void set (int value);
}


WPositionX Property

WPositionX Property
Namespaces ► VisualCron ► ClientSettingsClass ► WPositionX

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.WPositionX]

Declaration Syntax
C# Visual Basic Visual C++
public int WPositionX { get; set; }
Public Property WPositionX As Integer
public:
property int WPositionX {
    int get ();
    void set (int value);
}


WPositionY Property

WPositionY Property
Namespaces ► VisualCron ► ClientSettingsClass ► WPositionY

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.WPositionY]

Declaration Syntax
C# Visual Basic Visual C++
public int WPositionY { get; set; }
Public Property WPositionY As Integer
public:
property int WPositionY {
    int get ();
    void set (int value);
}


WWidth Property

WWidth Property
Namespaces ► VisualCron ► ClientSettingsClass ► WWidth

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.WWidth]

Declaration Syntax
C# Visual Basic Visual C++
public int WWidth { get; set; }
Public Property WWidth As Integer
public:
property int WWidth {
    int get ();
    void set (int value);
}


WWindowState Property

WWindowState Property
Namespaces ► VisualCron ► ClientSettingsClass ► WWindowState

[Missing <summary> documentation for P:VisualCron.ClientSettingsClass.WWindowState]

Declaration Syntax
C# Visual Basic Visual C++
public FormWindowState WWindowState { get; set; }
Public Property WWindowState As FormWindowState
public:
property FormWindowState WWindowState {
    FormWindowState get ();
    void set (FormWindowState value);
}


ClientSettingsClass.ViewStyle Enumeration

ClientSettingsClass..::.ViewStyle Enumeration
Namespaces ► VisualCron ► ClientSettingsClass ► ClientSettingsClass..::.ViewStyle

[Missing <summary> documentation for T:VisualCron.ClientSettingsClass.ViewStyle]

Declaration Syntax
C# Visual Basic Visual C++
public enum ViewStyle
Public Enumeration ViewStyle
public enum class ViewStyle
Members
Member | Description
JobTaskTaskProcess |
JobProcessTaskProcess |
TaskProcess |


clsNetworkAddressChangedTriggerResult Class

clsNetworkAddressChangedTriggerResult Class
Namespaces ► VisualCron ► clsNetworkAddressChangedTriggerResult

[Missing <summary> documentation for T:VisualCron.clsNetworkAddressChangedTriggerResult]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class clsNetworkAddressChangedTriggerResult
<SerializableAttribute> _
Public Class clsNetworkAddressChangedTriggerResult
[SerializableAttribute]
public ref class clsNetworkAddressChangedTriggerResult
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | clsNetworkAddressChangedTriggerResult()()() | Initializes a new instance of the clsNetworkAddressChangedTriggerResult class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
clsNetworkAddressChangedTriggerResult


clsNetworkAddressChangedTriggerResult Constructor

clsNetworkAddressChangedTriggerResult Constructor
Namespaces ► VisualCron ► clsNetworkAddressChangedTriggerResult ► clsNetworkAddressChangedTriggerResult()()()
Initializes a new instance of the clsNetworkAddressChangedTriggerResult class
Declaration Syntax
C# Visual Basic Visual C++
public clsNetworkAddressChangedTriggerResult()
Public Sub New
public:
clsNetworkAddressChangedTriggerResult()


Command Class

Command Class
Namespaces ► VisualCron ► Command
Base class for all macro commands.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class Command : ICloneable
<SerializableAttribute> _
Public MustInherit Class Command _
    Implements ICloneable
[SerializableAttribute]
public ref class Command abstract : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Command()()() | Initializes a new instance of the Command class
 | Clone()()() |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed) |
Inheritance Hierarchy
Object
 | Command
 |  | Delay
 |  | MouseMove
 |  | WindowTargetingCommand


Command Constructor

Command Constructor
Namespaces ► VisualCron ► Command ► Command()()()
Initializes a new instance of the Command class
Declaration Syntax
C# Visual Basic Visual C++
public Command()
Public Sub New
public:
Command()


Clone Method

Clone Method
Namespaces ► VisualCron ► Command ► Clone()()()

[Missing <summary> documentation for M:VisualCron.Command.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Clone()
Public Overridable Function Clone As Object
public:
virtual Object^ Clone()
Return Value

[Missing <returns> documentation for M:VisualCron.Command.Clone]


Description Property

Description Property
Namespaces ► VisualCron ► Command ► Description

[Missing <summary> documentation for P:VisualCron.Command.Description]

Declaration Syntax
C# Visual Basic Visual C++
public abstract string Description { get; }
Public MustOverride ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () abstract;
}


TranslateToInstructions Method (builder, speed)

TranslateToInstructions Method (builder, speed)
Namespaces ► VisualCron ► Command ► TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed)

[Missing <summary> documentation for M:VisualCron.Command.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract void TranslateToInstructions(
    InstructionsBuilder builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
)
Public MustOverride Sub TranslateToInstructions ( _
    builder As InstructionsBuilder, _
    speed As TaskDesktopMacroClass..::.MacroSpeed _
)
public:
virtual void TranslateToInstructions(
    InstructionsBuilder^ builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
) abstract
Parameters
builder (InstructionsBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.Command.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]

speed (TaskDesktopMacroClass..::.MacroSpeed)

[Missing <param name="speed"/> documentation for "M:VisualCron.Command.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]


COMRECT Class

COMRECT Class
Namespaces ► VisualCron ► COMRECT

[Missing <summary> documentation for T:VisualCron.COMRECT]

Declaration Syntax
C# Visual Basic Visual C++
public class COMRECT
Public Class COMRECT
public ref class COMRECT
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | COMRECT()()() | Initializes a new instance of the COMRECT class
 | COMRECT(Rectangle) | Initializes a new instance of the COMRECT class
 | COMRECT(Int32, Int32, Int32, Int32) | Initializes a new instance of the COMRECT class
 | bottom |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromXYWH(Int32, Int32, Int32, Int32) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | left |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | right |
 | top |
 | ToString()()() | (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
COMRECT

Send comments on this topic to Please email feedback to Support


COMRECT Constructor

COMRECT Constructor
Namespaces ► VisualCron ► COMRECT ► COMRECT()()()
Members
Icon | Member | Description
 | COMRECT()()() | Initializes a new instance of the COMRECT class
 | COMRECT(Rectangle) | Initializes a new instance of the COMRECT class
 | COMRECT(Int32, Int32, Int32, Int32) | Initializes a new instance of the COMRECT class


COMRECT Constructor

COMRECT Constructor
Namespaces ► VisualCron ► COMRECT ► COMRECT()()()
Initializes a new instance of the COMRECT class
Declaration Syntax
C# Visual Basic Visual C++
public COMRECT()
Public Sub New
public:
COMRECT()


COMRECT Constructor (r)

COMRECT Constructor (r)
Namespaces ► VisualCron ► COMRECT ► COMRECT(Rectangle)
Initializes a new instance of the COMRECT class
Declaration Syntax
C# Visual Basic Visual C++
public COMRECT(
    Rectangle r
)
Public Sub New ( _
    r As Rectangle _
)
public:
COMRECT(
    Rectangle r
)
Parameters
r (Rectangle)

[Missing <param name="r"/> documentation for "M:VisualCron.COMRECT.#ctor(System.Drawing.Rectangle)"]


COMRECT Constructor (left, top, right, bottom)

COMRECT Constructor (left, top, right, bottom)
Namespaces ► VisualCron ► COMRECT ► COMRECT(Int32, Int32, Int32, Int32)
Initializes a new instance of the COMRECT class
Declaration Syntax
C# Visual Basic Visual C++
public COMRECT(
    int left,
    int top,
    int right,
    int bottom
)
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
public:
COMRECT(
    int left,
    int top,
    int right,
    int bottom
)
Parameters
left (Int32)

[Missing <param name="left"/> documentation for "M:VisualCron.COMRECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

top (Int32)

[Missing <param name="top"/> documentation for "M:VisualCron.COMRECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

right (Int32)

[Missing <param name="right"/> documentation for "M:VisualCron.COMRECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

bottom (Int32)

[Missing <param name="bottom"/> documentation for "M:VisualCron.COMRECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]


bottom Field

bottom Field
Namespaces ► VisualCron ► COMRECT ► bottom

[Missing <summary> documentation for F:VisualCron.COMRECT.bottom]

Declaration Syntax
C# Visual Basic Visual C++
public int bottom
Public bottom As Integer
public:
int bottom


FromXYWH Method (x, y, width, height)

FromXYWH Method (x, y, width, height)
Namespaces ► VisualCron ► COMRECT ► FromXYWH(Int32, Int32, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.COMRECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static COMRECT FromXYWH(
    int x,
    int y,
    int width,
    int height
)
Public Shared Function FromXYWH ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
) As COMRECT
public:
static COMRECT^ FromXYWH(
    int x,
    int y,
    int width,
    int height
)
Parameters
x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.COMRECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.COMRECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

width (Int32)

[Missing <param name="width"/> documentation for "M:VisualCron.COMRECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

height (Int32)

[Missing <param name="height"/> documentation for "M:VisualCron.COMRECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.COMRECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)]


left Field

left Field
Namespaces ► VisualCron ► COMRECT ► left

[Missing <summary> documentation for F:VisualCron.COMRECT.left]

Declaration Syntax
C# Visual Basic Visual C++
public int left
Public left As Integer
public:
int left


right Field

right Field
Namespaces ► VisualCron ► COMRECT ► right

[Missing <summary> documentation for F:VisualCron.COMRECT.right]

Declaration Syntax
C# Visual Basic Visual C++
public int right
Public right As Integer
public:
int right


top Field

top Field
Namespaces ► VisualCron ► COMRECT ► top

[Missing <summary> documentation for F:VisualCron.COMRECT.top]

Declaration Syntax
C# Visual Basic Visual C++
public int top
Public top As Integer
public:
int top


ToString Method

ToString Method
Namespaces ► VisualCron ► COMRECT ► ToString()()()

[Missing <summary> documentation for M:VisualCron.COMRECT.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:VisualCron.COMRECT.ToString]


ConditionActionClass Class

ConditionActionClass Class
Namespaces ► VisualCron ► ConditionActionClass

[Missing <summary> documentation for T:VisualCron.ConditionActionClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionActionClass
<SerializableAttribute> _
Public Class ConditionActionClass
[SerializableAttribute]
public ref class ConditionActionClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionActionClass()()() | Initializes a new instance of the ConditionActionClass class
 | ActionType |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitHours |
 | WaitMinutes |
 | WaitSeconds |
 | WaitType |
Inheritance Hierarchy
Object
ConditionActionClass

Send comments on this topic to Please email feedback to Support


ConditionActionClass Constructor

ConditionActionClass Constructor
Namespaces ► VisualCron ► ConditionActionClass ► ConditionActionClass()()()
Initializes a new instance of the ConditionActionClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionActionClass()
Public Sub New
public:
ConditionActionClass()


ActionType Field

ActionType Field
Namespaces ► VisualCron ► ConditionActionClass ► ActionType

[Missing <summary> documentation for F:VisualCron.ConditionActionClass.ActionType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionActionClass..::.ActionT ActionType
Public ActionType As ConditionActionClass..::.ActionT
public:
ConditionActionClass..::.ActionT ActionType


JobId Property

JobId Property
Namespaces ► VisualCron ► ConditionActionClass ► JobId

[Missing <summary> documentation for P:VisualCron.ConditionActionClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


TaskId Property

TaskId Property
Namespaces ► VisualCron ► ConditionActionClass ► TaskId

[Missing <summary> documentation for P:VisualCron.ConditionActionClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


WaitHours Property

WaitHours Property
Namespaces ► VisualCron ► ConditionActionClass ► WaitHours

[Missing <summary> documentation for P:VisualCron.ConditionActionClass.WaitHours]

Declaration Syntax
C# Visual Basic Visual C++
public int WaitHours { get; set; }
Public Property WaitHours As Integer
public:
property int WaitHours {
    int get ();
    void set (int value);
}


WaitMinutes Property

WaitMinutes Property
Namespaces ► VisualCron ► ConditionActionClass ► WaitMinutes

[Missing <summary> documentation for P:VisualCron.ConditionActionClass.WaitMinutes]

Declaration Syntax
C# Visual Basic Visual C++
public int WaitMinutes { get; set; }
Public Property WaitMinutes As Integer
public:
property int WaitMinutes {
    int get ();
    void set (int value);
}


WaitSeconds Property

WaitSeconds Property
Namespaces ► VisualCron ► ConditionActionClass ► WaitSeconds

[Missing <summary> documentation for P:VisualCron.ConditionActionClass.WaitSeconds]

Declaration Syntax
C# Visual Basic Visual C++
public int WaitSeconds { get; set; }
Public Property WaitSeconds As Integer
public:
property int WaitSeconds {
    int get ();
    void set (int value);
}


WaitType Field

WaitType Field
Namespaces ► VisualCron ► ConditionActionClass ► WaitType

[Missing <summary> documentation for F:VisualCron.ConditionActionClass.WaitType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionActionClass..::.WaitT WaitType
Public WaitType As ConditionActionClass..::.WaitT
public:
ConditionActionClass..::.WaitT WaitType

Send comments on this topic to Please email feedback to Support


ConditionActionClass.ActionT Enumeration

ConditionActionClass..::.ActionT Enumeration
Namespaces ► VisualCron ► ConditionActionClass ► ConditionActionClass..::.ActionT

[Missing <summary> documentation for T:VisualCron.ConditionActionClass.ActionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ActionT
Public Enumeration ActionT
public enum class ActionT
Members
Member | Description
ActionContinue |
ActionNext |
ActionRetry |
ActionExit |
ActionRunJob |
ActionRunTask |


ConditionActionClass.WaitT Enumeration

ConditionActionClass..::.WaitT Enumeration
Namespaces ► VisualCron ► ConditionActionClass ► ConditionActionClass..::.WaitT

[Missing <summary> documentation for T:VisualCron.ConditionActionClass.WaitT]

Declaration Syntax
C# Visual Basic Visual C++
public enum WaitT
Public Enumeration WaitT
public enum class WaitT
Members
Member | Description
Wait |
NoWait |


ConditionClass Class

ConditionClass Class
Namespaces ► VisualCron ► ConditionClass

[Missing <summary> documentation for T:VisualCron.ConditionClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionClass : ICloneable
<SerializableAttribute> _
Public Class ConditionClass _
    Implements ICloneable
[SerializableAttribute]
public ref class ConditionClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionClass()()() | Initializes a new instance of the ConditionClass class
 | Active |
 | CFile |
 | CFolder |
 | Clone()()() |
 | CloneType()()() |
 | ConditionType |
 | CProcess |
 | CVisualCron |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetId |
 | SetToNothing()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConditionClass

Send comments on this topic to Please email feedback to Support


ConditionClass Constructor

ConditionClass Constructor
Namespaces ► VisualCron ► ConditionClass ► ConditionClass()()()
Initializes a new instance of the ConditionClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass()
Public Sub New
public:
ConditionClass()


Active Property

Active Property
Namespaces ► VisualCron ► ConditionClass ► Active

[Missing <summary> documentation for P:VisualCron.ConditionClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}


CFile Field

CFile Field
Namespaces ► VisualCron ► ConditionClass ► CFile

[Missing <summary> documentation for F:VisualCron.ConditionClass.CFile]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionFileClass CFile
Public CFile As ConditionFileClass
public:
ConditionFileClass^ CFile

Send comments on this topic to Please email feedback to Support


CFolder Field

CFolder Field
Namespaces ► VisualCron ► ConditionClass ► CFolder

[Missing <summary> documentation for F:VisualCron.ConditionClass.CFolder]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionFolderClass CFolder
Public CFolder As ConditionFolderClass
public:
ConditionFolderClass^ CFolder

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► ConditionClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.ConditionClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.ConditionClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► ConditionClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.ConditionClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass CloneType()
Public Function CloneType As ConditionClass
public:
ConditionClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.ConditionClass.CloneType]


ConditionType Field

ConditionType Field
Namespaces ► VisualCron ► ConditionClass ► ConditionType

[Missing <summary> documentation for F:VisualCron.ConditionClass.ConditionType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionT ConditionType
Public ConditionType As ConditionClass..::.ConditionT
public:
ConditionClass..::.ConditionT ConditionType


CProcess Field

CProcess Field
Namespaces ► VisualCron ► ConditionClass ► CProcess

[Missing <summary> documentation for F:VisualCron.ConditionClass.CProcess]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionProcessClass CProcess
Public CProcess As ConditionProcessClass
public:
ConditionProcessClass^ CProcess

Send comments on this topic to Please email feedback to Support


CVisualCron Field

CVisualCron Field
Namespaces ► VisualCron ► ConditionClass ► CVisualCron

[Missing <summary> documentation for F:VisualCron.ConditionClass.CVisualCron]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionVisualCronClass CVisualCron
Public CVisualCron As ConditionVisualCronClass
public:
ConditionVisualCronClass^ CVisualCron

Send comments on this topic to Please email feedback to Support


Description Property

Description Property
Namespaces ► VisualCron ► ConditionClass ► Description

[Missing <summary> documentation for P:VisualCron.ConditionClass.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Id Property

Id Property
Namespaces ► VisualCron ► ConditionClass ► Id

[Missing <summary> documentation for P:VisualCron.ConditionClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


SetId Property

SetId Property
Namespaces ► VisualCron ► ConditionClass ► SetId

[Missing <summary> documentation for P:VisualCron.ConditionClass.SetId]

Declaration Syntax
C# Visual Basic Visual C++
public string SetId { get; set; }
Public Property SetId As String
public:
property String^ SetId {
    String^ get ();
    void set (String^ value);
}


SetToNothing Method

SetToNothing Method
Namespaces ► VisualCron ► ConditionClass ► SetToNothing()()()

[Missing <summary> documentation for M:VisualCron.ConditionClass.SetToNothing]

Declaration Syntax
C# Visual Basic Visual C++
public void SetToNothing()
Public Sub SetToNothing
public:
void SetToNothing()


ConditionClass.ConditionCheckT Enumeration

ConditionClass..::.ConditionCheckT Enumeration
Namespaces ► VisualCron ► ConditionClass ► ConditionClass..::.ConditionCheckT

[Missing <summary> documentation for T:VisualCron.ConditionClass.ConditionCheckT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ConditionCheckT
Public Enumeration ConditionCheckT
public enum class ConditionCheckT
Members
Member | Description
Equal |
NotEqual |
Contains |
Smaller |
Larger |
SmallerOrEqual |
LargerOrEqual |
NotContains |
NotCheck |
RegExMatch |
RegExNoMatch |


ConditionClass.ConditionOperatorT Enumeration

ConditionClass..::.ConditionOperatorT Enumeration
Namespaces ► VisualCron ► ConditionClass ► ConditionClass..::.ConditionOperatorT

[Missing <summary> documentation for T:VisualCron.ConditionClass.ConditionOperatorT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ConditionOperatorT
Public Enumeration ConditionOperatorT
public enum class ConditionOperatorT
Members
Member | Description
AND |
OR |


ConditionClass.ConditionT Enumeration

ConditionClass..::.ConditionT Enumeration
Namespaces ► VisualCron ► ConditionClass ► ConditionClass..::.ConditionT

[Missing <summary> documentation for T:VisualCron.ConditionClass.ConditionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ConditionT
Public Enumeration ConditionT
public enum class ConditionT
Members
Member | Description
VisualCron |
File |
Folder |
Process |


ConditionClass.MatchT Enumeration

ConditionClass..::.MatchT Enumeration
Namespaces ► VisualCron ► ConditionClass ► ConditionClass..::.MatchT

[Missing <summary> documentation for T:VisualCron.ConditionClass.MatchT]

Declaration Syntax
C# Visual Basic Visual C++
public enum MatchT
Public Enumeration MatchT
public enum class MatchT
Members
Member | Description
MatchTrue |
MatchFalse |
MatchIs |
MatchIsNot |
MatchContains |


ConditionDeleteClass Class

ConditionDeleteClass Class
Namespaces ► VisualCron ► ConditionDeleteClass

[Missing <summary> documentation for T:VisualCron.ConditionDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionDeleteClass
<SerializableAttribute> _
Public Class ConditionDeleteClass
[SerializableAttribute]
public ref class ConditionDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionDeleteClass()()() | Initializes a new instance of the ConditionDeleteClass class
 | ConditionSetId | Gets or sets the Id of the Condition set
 | Deleted | Indicates if the Condition was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Condition
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConditionDeleteClass

Send comments on this topic to Please email feedback to Support


ConditionDeleteClass Constructor

ConditionDeleteClass Constructor
Namespaces ► VisualCron ► ConditionDeleteClass ► ConditionDeleteClass()()()
Initializes a new instance of the ConditionDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionDeleteClass()
Public Sub New
public:
ConditionDeleteClass()


ConditionSetId Property

ConditionSetId Property
Namespaces ► VisualCron ► ConditionDeleteClass ► ConditionSetId
Gets or sets the Id of the Condition set
Declaration Syntax
C# Visual Basic Visual C++
public string ConditionSetId { get; set; }
Public Property ConditionSetId As String
public:
property String^ ConditionSetId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Deleted Property

Deleted Property
Namespaces ► VisualCron ► ConditionDeleteClass ► Deleted
Indicates if the Condition was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► ConditionDeleteClass ► Id
Gets or sets the Id of the Condition
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConditionFileClass Class

ConditionFileClass Class
Namespaces ► VisualCron ► ConditionFileClass

[Missing <summary> documentation for T:VisualCron.ConditionFileClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionFileClass
<SerializableAttribute> _
Public Class ConditionFileClass
[SerializableAttribute]
public ref class ConditionFileClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionFileClass()()() | Initializes a new instance of the ConditionFileClass class
 | CheckType |
 | Content |
 | Credential |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchType |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConditionFileClass

Send comments on this topic to Please email feedback to Support


ConditionFileClass Constructor

ConditionFileClass Constructor
Namespaces ► VisualCron ► ConditionFileClass ► ConditionFileClass()()()
Initializes a new instance of the ConditionFileClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionFileClass()
Public Sub New
public:
ConditionFileClass()


CheckType Field

CheckType Field
Namespaces ► VisualCron ► ConditionFileClass ► CheckType

[Missing <summary> documentation for F:VisualCron.ConditionFileClass.CheckType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionFileClass..::.FileCheckT CheckType
Public CheckType As ConditionFileClass..::.FileCheckT
public:
ConditionFileClass..::.FileCheckT CheckType


Content Property

Content Property
Namespaces ► VisualCron ► ConditionFileClass ► Content

[Missing <summary> documentation for P:VisualCron.ConditionFileClass.Content]

Declaration Syntax
C# Visual Basic Visual C++
public string Content { get; set; }
Public Property Content As String
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}


Credential Property

Credential Property
Namespaces ► VisualCron ► ConditionFileClass ► Credential

[Missing <summary> documentation for P:VisualCron.ConditionFileClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


FilePath Property

FilePath Property
Namespaces ► VisualCron ► ConditionFileClass ► FilePath

[Missing <summary> documentation for P:VisualCron.ConditionFileClass.FilePath]

Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}


MatchType Field

MatchType Field
Namespaces ► VisualCron ► ConditionFileClass ► MatchType

[Missing <summary> documentation for F:VisualCron.ConditionFileClass.MatchType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.MatchT MatchType
Public MatchType As ConditionClass..::.MatchT
public:
ConditionClass..::.MatchT MatchType

Send comments on this topic to Please email feedback to Support


ConditionFileClass.FileCheckT Enumeration

ConditionFileClass..::.FileCheckT Enumeration
Namespaces ► VisualCron ► ConditionFileClass ► ConditionFileClass..::.FileCheckT

[Missing <summary> documentation for T:VisualCron.ConditionFileClass.FileCheckT]

Declaration Syntax
C# Visual Basic Visual C++
public enum FileCheckT
Public Enumeration FileCheckT
public enum class FileCheckT
Members
Member | Description
FileExist |
FileContent |


ConditionFileClass.FileConditionCheckT Enumeration

ConditionFileClass..::.FileConditionCheckT Enumeration
Namespaces ► VisualCron ► ConditionFileClass ► ConditionFileClass..::.FileConditionCheckT

[Missing <summary> documentation for T:VisualCron.ConditionFileClass.FileConditionCheckT]

Declaration Syntax
C# Visual Basic Visual C++
public enum FileConditionCheckT
Public Enumeration FileConditionCheckT
public enum class FileConditionCheckT
Members
Member | Description
NotCheck |
ModifiedDate |
CreatedDate |


ConditionFolderClass Class

ConditionFolderClass Class
Namespaces ► VisualCron ► ConditionFolderClass

[Missing <summary> documentation for T:VisualCron.ConditionFolderClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionFolderClass
<SerializableAttribute> _
Public Class ConditionFolderClass
[SerializableAttribute]
public ref class ConditionFolderClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionFolderClass()()() | Initializes a new instance of the ConditionFolderClass class
 | CheckType |
 | Credential |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FolderPath |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchType |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConditionFolderClass

Send comments on this topic to Please email feedback to Support


ConditionFolderClass Constructor

ConditionFolderClass Constructor
Namespaces ► VisualCron ► ConditionFolderClass ► ConditionFolderClass()()()
Initializes a new instance of the ConditionFolderClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionFolderClass()
Public Sub New
public:
ConditionFolderClass()


CheckType Field

CheckType Field
Namespaces ► VisualCron ► ConditionFolderClass ► CheckType

[Missing <summary> documentation for F:VisualCron.ConditionFolderClass.CheckType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionFolderClass..::.FolderCheckT CheckType
Public CheckType As ConditionFolderClass..::.FolderCheckT
public:
ConditionFolderClass..::.FolderCheckT CheckType


Credential Property

Credential Property
Namespaces ► VisualCron ► ConditionFolderClass ► Credential

[Missing <summary> documentation for P:VisualCron.ConditionFolderClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


FolderPath Property

FolderPath Property
Namespaces ► VisualCron ► ConditionFolderClass ► FolderPath

[Missing <summary> documentation for P:VisualCron.ConditionFolderClass.FolderPath]

Declaration Syntax
C# Visual Basic Visual C++
public string FolderPath { get; set; }
Public Property FolderPath As String
public:
property String^ FolderPath {
    String^ get ();
    void set (String^ value);
}


MatchType Field

MatchType Field
Namespaces ► VisualCron ► ConditionFolderClass ► MatchType

[Missing <summary> documentation for F:VisualCron.ConditionFolderClass.MatchType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.MatchT MatchType
Public MatchType As ConditionClass..::.MatchT
public:
ConditionClass..::.MatchT MatchType

Send comments on this topic to Please email feedback to Support


ConditionFolderClass.FolderCheckT Enumeration

ConditionFolderClass..::.FolderCheckT Enumeration
Namespaces ► VisualCron ► ConditionFolderClass ► ConditionFolderClass..::.FolderCheckT

[Missing <summary> documentation for T:VisualCron.ConditionFolderClass.FolderCheckT]

Declaration Syntax
C# Visual Basic Visual C++
public enum FolderCheckT
Public Enumeration FolderCheckT
public enum class FolderCheckT
Members
Member | Description
FolderExist |


ConditionProcessClass Class

ConditionProcessClass Class
Namespaces ► VisualCron ► ConditionProcessClass

[Missing <summary> documentation for T:VisualCron.ConditionProcessClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionProcessClass
<SerializableAttribute> _
Public Class ConditionProcessClass
[SerializableAttribute]
public ref class ConditionProcessClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionProcessClass()()() | Initializes a new instance of the ConditionProcessClass class
 | CheckType |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImageName |
 | MatchType |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConditionProcessClass

Send comments on this topic to Please email feedback to Support


ConditionProcessClass Constructor

ConditionProcessClass Constructor
Namespaces ► VisualCron ► ConditionProcessClass ► ConditionProcessClass()()()
Initializes a new instance of the ConditionProcessClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionProcessClass()
Public Sub New
public:
ConditionProcessClass()


CheckType Field

CheckType Field
Namespaces ► VisualCron ► ConditionProcessClass ► CheckType

[Missing <summary> documentation for F:VisualCron.ConditionProcessClass.CheckType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionProcessClass..::.ProcessCheckT CheckType
Public CheckType As ConditionProcessClass..::.ProcessCheckT
public:
ConditionProcessClass..::.ProcessCheckT CheckType


ImageName Property

ImageName Property
Namespaces ► VisualCron ► ConditionProcessClass ► ImageName

[Missing <summary> documentation for P:VisualCron.ConditionProcessClass.ImageName]

Declaration Syntax
C# Visual Basic Visual C++
public string ImageName { get; set; }
Public Property ImageName As String
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}


MatchType Field

MatchType Field
Namespaces ► VisualCron ► ConditionProcessClass ► MatchType

[Missing <summary> documentation for F:VisualCron.ConditionProcessClass.MatchType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.MatchT MatchType
Public MatchType As ConditionClass..::.MatchT
public:
ConditionClass..::.MatchT MatchType

Send comments on this topic to Please email feedback to Support


ConditionProcessClass.ProcessCheckT Enumeration

ConditionProcessClass..::.ProcessCheckT Enumeration
Namespaces ► VisualCron ► ConditionProcessClass ► ConditionProcessClass..::.ProcessCheckT

[Missing <summary> documentation for T:VisualCron.ConditionProcessClass.ProcessCheckT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ProcessCheckT
Public Enumeration ProcessCheckT
public enum class ProcessCheckT
Members
Member | Description
ProcessRunning |


ConditionResultClass Class

ConditionResultClass Class
Namespaces ► VisualCron ► ConditionResultClass
A result for a single condition
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionResultClass
<SerializableAttribute> _
Public Class ConditionResultClass
[SerializableAttribute]
public ref class ConditionResultClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionResultClass()()() | Initializes a new instance of the ConditionResultClass class
 | Condition |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ConditionResultClass

Send comments on this topic to Please email feedback to Support


ConditionResultClass Constructor

ConditionResultClass Constructor
Namespaces ► VisualCron ► ConditionResultClass ► ConditionResultClass()()()
Initializes a new instance of the ConditionResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionResultClass()
Public Sub New
public:
ConditionResultClass()


Condition Field

Condition Field
Namespaces ► VisualCron ► ConditionResultClass ► Condition

[Missing <summary> documentation for F:VisualCron.ConditionResultClass.Condition]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass Condition
Public Condition As ConditionClass
public:
ConditionClass^ Condition

Send comments on this topic to Please email feedback to Support


Result Field

Result Field
Namespaces ► VisualCron ► ConditionResultClass ► Result

[Missing <summary> documentation for F:VisualCron.ConditionResultClass.Result]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionResultClass..::.ResultType Result
Public Result As ConditionResultClass..::.ResultType
public:
ConditionResultClass..::.ResultType Result


ConditionResultClass.ResultType Enumeration

ConditionResultClass..::.ResultType Enumeration
Namespaces ► VisualCron ► ConditionResultClass ► ConditionResultClass..::.ResultType

[Missing <summary> documentation for T:VisualCron.ConditionResultClass.ResultType]

Declaration Syntax
C# Visual Basic Visual C++
public enum ResultType
Public Enumeration ResultType
public enum class ResultType
Members
Member | Description
Match |
NoMatch |
MatchError |


ConditionSetClass Class

ConditionSetClass Class
Namespaces ► VisualCron ► ConditionSetClass

[Missing <summary> documentation for T:VisualCron.ConditionSetClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionSetClass : ConditionSetClass..::._ConditionSetClass
<SerializableAttribute> _
Public Class ConditionSetClass _
    Implements ConditionSetClass..::._ConditionSetClass
[SerializableAttribute]
public ref class ConditionSetClass : ConditionSetClass..::._ConditionSetClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionSetClass()()() | Initializes a new instance of the ConditionSetClass class
 | ActionMatchAll |
 | ActionMatchAny |
 | ActionMatchError |
 | ActionMatchNone |
 | CloneType()()() |
 | Conditions |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedLogging |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateIds()()() |
Inheritance Hierarchy
Object
ConditionSetClass

Send comments on this topic to Please email feedback to Support


ConditionSetClass Constructor

ConditionSetClass Constructor
Namespaces ► VisualCron ► ConditionSetClass ► ConditionSetClass()()()
Initializes a new instance of the ConditionSetClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetClass()
Public Sub New
public:
ConditionSetClass()


ActionMatchAll Field

ActionMatchAll Field
Namespaces ► VisualCron ► ConditionSetClass ► ActionMatchAll

[Missing <summary> documentation for F:VisualCron.ConditionSetClass.ActionMatchAll]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionActionClass ActionMatchAll
Public ActionMatchAll As ConditionActionClass
public:
ConditionActionClass^ ActionMatchAll

Send comments on this topic to Please email feedback to Support


ActionMatchAny Field

ActionMatchAny Field
Namespaces ► VisualCron ► ConditionSetClass ► ActionMatchAny

[Missing <summary> documentation for F:VisualCron.ConditionSetClass.ActionMatchAny]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionActionClass ActionMatchAny
Public ActionMatchAny As ConditionActionClass
public:
ConditionActionClass^ ActionMatchAny

Send comments on this topic to Please email feedback to Support


ActionMatchError Field

ActionMatchError Field
Namespaces ► VisualCron ► ConditionSetClass ► ActionMatchError

[Missing <summary> documentation for F:VisualCron.ConditionSetClass.ActionMatchError]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionActionClass ActionMatchError
Public ActionMatchError As ConditionActionClass
public:
ConditionActionClass^ ActionMatchError

Send comments on this topic to Please email feedback to Support


ActionMatchNone Field

ActionMatchNone Field
Namespaces ► VisualCron ► ConditionSetClass ► ActionMatchNone

[Missing <summary> documentation for F:VisualCron.ConditionSetClass.ActionMatchNone]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionActionClass ActionMatchNone
Public ActionMatchNone As ConditionActionClass
public:
ConditionActionClass^ ActionMatchNone

Send comments on this topic to Please email feedback to Support


CloneType Method

CloneType Method
Namespaces ► VisualCron ► ConditionSetClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.ConditionSetClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetClass CloneType()
Public Function CloneType As ConditionSetClass
public:
virtual ConditionSetClass^ CloneType() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.ConditionSetClass.CloneType]


Conditions Field

Conditions Field
Namespaces ► VisualCron ► ConditionSetClass ► Conditions

[Missing <summary> documentation for F:VisualCron.ConditionSetClass.Conditions]

Declaration Syntax
C# Visual Basic Visual C++
public List<ConditionClass> Conditions
Public Conditions As List(Of ConditionClass)
public:
List<ConditionClass^>^ Conditions

Send comments on this topic to Please email feedback to Support


Description Property

Description Property
Namespaces ► VisualCron ► ConditionSetClass ► Description

[Missing <summary> documentation for P:VisualCron.ConditionSetClass.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}


ExtendedLogging Property

ExtendedLogging Property
Namespaces ► VisualCron ► ConditionSetClass ► ExtendedLogging

[Missing <summary> documentation for P:VisualCron.ConditionSetClass.ExtendedLogging]

Declaration Syntax
C# Visual Basic Visual C++
public bool ExtendedLogging { get; set; }
Public Property ExtendedLogging As Boolean
public:
virtual property bool ExtendedLogging {
    bool get () sealed;
    void set (bool value) sealed;
}


Id Property

Id Property
Namespaces ► VisualCron ► ConditionSetClass ► Id

[Missing <summary> documentation for P:VisualCron.ConditionSetClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}


UpdateIds Method

UpdateIds Method
Namespaces ► VisualCron ► ConditionSetClass ► UpdateIds()()()

[Missing <summary> documentation for M:VisualCron.ConditionSetClass.UpdateIds]

Declaration Syntax
C# Visual Basic Visual C++
public void UpdateIds()
Public Sub UpdateIds
public:
virtual void UpdateIds() sealed


ConditionSetClass._ConditionSetClass Interface

ConditionSetClass..::._ConditionSetClass Interface
Namespaces ► VisualCron ► ConditionSetClass ► ConditionSetClass..::._ConditionSetClass

[Missing <summary> documentation for T:VisualCron.ConditionSetClass._ConditionSetClass]

Declaration Syntax
C# Visual Basic Visual C++
public interface _ConditionSetClass
Public Interface _ConditionSetClass
public interface class _ConditionSetClass
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CloneType()()() |
 | Description |
 | ExtendedLogging |
 | Id |
 | UpdateIds()()() |


CloneType Method

CloneType Method
Namespaces ► VisualCron ► ConditionSetClass..::._ConditionSetClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.ConditionSetClass._ConditionSetClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
ConditionSetClass CloneType()
Function CloneType As ConditionSetClass
ConditionSetClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.ConditionSetClass._ConditionSetClass.CloneType]


Description Property

Description Property
Namespaces ► VisualCron ► ConditionSetClass..::._ConditionSetClass ► Description

[Missing <summary> documentation for P:VisualCron.ConditionSetClass._ConditionSetClass.Description]

Declaration Syntax
C# Visual Basic Visual C++
string Description { get; set; }
Property Description As String
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ExtendedLogging Property

ExtendedLogging Property
Namespaces ► VisualCron ► ConditionSetClass..::._ConditionSetClass ► ExtendedLogging

[Missing <summary> documentation for P:VisualCron.ConditionSetClass._ConditionSetClass.ExtendedLogging]

Declaration Syntax
C# Visual Basic Visual C++
bool ExtendedLogging { get; set; }
Property ExtendedLogging As Boolean
property bool ExtendedLogging {
    bool get ();
    void set (bool value);
}


Id Property

Id Property
Namespaces ► VisualCron ► ConditionSetClass..::._ConditionSetClass ► Id

[Missing <summary> documentation for P:VisualCron.ConditionSetClass._ConditionSetClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
string Id { get; set; }
Property Id As String
property String^ Id {
    String^ get ();
    void set (String^ value);
}


UpdateIds Method

UpdateIds Method
Namespaces ► VisualCron ► ConditionSetClass..::._ConditionSetClass ► UpdateIds()()()

[Missing <summary> documentation for M:VisualCron.ConditionSetClass._ConditionSetClass.UpdateIds]

Declaration Syntax
C# Visual Basic Visual C++
void UpdateIds()
Sub UpdateIds
void UpdateIds()


ConditionSetDeleteClass Class

ConditionSetDeleteClass Class
Namespaces ► VisualCron ► ConditionSetDeleteClass

[Missing <summary> documentation for T:VisualCron.ConditionSetDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionSetDeleteClass
<SerializableAttribute> _
Public Class ConditionSetDeleteClass
[SerializableAttribute]
public ref class ConditionSetDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionSetDeleteClass()()() | Initializes a new instance of the ConditionSetDeleteClass class
 | Deleted | Indicates if the Condition Set was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Condition set
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConditionSetDeleteClass

Send comments on this topic to Please email feedback to Support


ConditionSetDeleteClass Constructor

ConditionSetDeleteClass Constructor
Namespaces ► VisualCron ► ConditionSetDeleteClass ► ConditionSetDeleteClass()()()
Initializes a new instance of the ConditionSetDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetDeleteClass()
Public Sub New
public:
ConditionSetDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► ConditionSetDeleteClass ► Deleted
Indicates if the Condition Set was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► ConditionSetDeleteClass ► Id
Gets or sets the Id of the Condition set
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConditionSetResultClass Class

ConditionSetResultClass Class
Namespaces ► VisualCron ► ConditionSetResultClass
The total result for the ConditionSetCheck
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionSetResultClass
<SerializableAttribute> _
Public Class ConditionSetResultClass
[SerializableAttribute]
public ref class ConditionSetResultClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionSetResultClass()()() | Initializes a new instance of the ConditionSetResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ConditionSetResultClass

Send comments on this topic to Please email feedback to Support


ConditionSetResultClass Constructor

ConditionSetResultClass Constructor
Namespaces ► VisualCron ► ConditionSetResultClass ► ConditionSetResultClass()()()
Initializes a new instance of the ConditionSetResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetResultClass()
Public Sub New
public:
ConditionSetResultClass()


Result Field

Result Field
Namespaces ► VisualCron ► ConditionSetResultClass ► Result

[Missing <summary> documentation for F:VisualCron.ConditionSetResultClass.Result]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetResultClass..::.ResultType Result
Public Result As ConditionSetResultClass..::.ResultType
public:
ConditionSetResultClass..::.ResultType Result


ConditionSetResultClass.ResultType Enumeration

ConditionSetResultClass..::.ResultType Enumeration
Namespaces ► VisualCron ► ConditionSetResultClass ► ConditionSetResultClass..::.ResultType

[Missing <summary> documentation for T:VisualCron.ConditionSetResultClass.ResultType]

Declaration Syntax
C# Visual Basic Visual C++
public enum ResultType
Public Enumeration ResultType
public enum class ResultType
Members
Member | Description
MatchAll |
MatchAny |
MatchNone |
MatchError |


ConditionVisualCronClass Class

ConditionVisualCronClass Class
Namespaces ► VisualCron ► ConditionVisualCronClass
The VisualCron condition
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionVisualCronClass
<SerializableAttribute> _
Public Class ConditionVisualCronClass
[SerializableAttribute]
public ref class ConditionVisualCronClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConditionVisualCronClass()()() | Initializes a new instance of the ConditionVisualCronClass class
 | CheckType |
 | Contains |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExitCode |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | LocatorType |
 | MatchType |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ConditionVisualCronClass

Send comments on this topic to Please email feedback to Support


ConditionVisualCronClass Constructor

ConditionVisualCronClass Constructor
Namespaces ► VisualCron ► ConditionVisualCronClass ► ConditionVisualCronClass()()()
Initializes a new instance of the ConditionVisualCronClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionVisualCronClass()
Public Sub New
public:
ConditionVisualCronClass()


CheckType Field

CheckType Field
Namespaces ► VisualCron ► ConditionVisualCronClass ► CheckType

[Missing <summary> documentation for F:VisualCron.ConditionVisualCronClass.CheckType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionVisualCronClass..::.CheckT CheckType
Public CheckType As ConditionVisualCronClass..::.CheckT
public:
ConditionVisualCronClass..::.CheckT CheckType


Contains Property

Contains Property
Namespaces ► VisualCron ► ConditionVisualCronClass ► Contains

[Missing <summary> documentation for P:VisualCron.ConditionVisualCronClass.Contains]

Declaration Syntax
C# Visual Basic Visual C++
public string Contains { get; set; }
Public Property Contains As String
public:
property String^ Contains {
    String^ get ();
    void set (String^ value);
}


ExitCode Property

ExitCode Property
Namespaces ► VisualCron ► ConditionVisualCronClass ► ExitCode

[Missing <summary> documentation for P:VisualCron.ConditionVisualCronClass.ExitCode]

Declaration Syntax
C# Visual Basic Visual C++
public int ExitCode { get; set; }
Public Property ExitCode As Integer
public:
property int ExitCode {
    int get ();
    void set (int value);
}


JobId Property

JobId Property
Namespaces ► VisualCron ► ConditionVisualCronClass ► JobId

[Missing <summary> documentation for P:VisualCron.ConditionVisualCronClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


LocatorType Field

LocatorType Field
Namespaces ► VisualCron ► ConditionVisualCronClass ► LocatorType

[Missing <summary> documentation for F:VisualCron.ConditionVisualCronClass.LocatorType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionVisualCronClass..::.LocatorT LocatorType
Public LocatorType As ConditionVisualCronClass..::.LocatorT
public:
ConditionVisualCronClass..::.LocatorT LocatorType


MatchType Field

MatchType Field
Namespaces ► VisualCron ► ConditionVisualCronClass ► MatchType

[Missing <summary> documentation for F:VisualCron.ConditionVisualCronClass.MatchType]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.MatchT MatchType
Public MatchType As ConditionClass..::.MatchT
public:
ConditionClass..::.MatchT MatchType

Send comments on this topic to Please email feedback to Support


TaskId Property

TaskId Property
Namespaces ► VisualCron ► ConditionVisualCronClass ► TaskId

[Missing <summary> documentation for P:VisualCron.ConditionVisualCronClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


ConditionVisualCronClass.CheckT Enumeration

ConditionVisualCronClass..::.CheckT Enumeration
Namespaces ► VisualCron ► ConditionVisualCronClass ► ConditionVisualCronClass..::.CheckT

[Missing <summary> documentation for T:VisualCron.ConditionVisualCronClass.CheckT]

Declaration Syntax
C# Visual Basic Visual C++
public enum CheckT
Public Enumeration CheckT
public enum class CheckT
Members
Member | Description
JobExitCodeIs |
JobIsRunning |
TaskExitCodeIs |
TaskIsRunning |
TaskOutputIs |


ConditionVisualCronClass.LocatorT Enumeration

ConditionVisualCronClass..::.LocatorT Enumeration
Namespaces ► VisualCron ► ConditionVisualCronClass ► ConditionVisualCronClass..::.LocatorT

[Missing <summary> documentation for T:VisualCron.ConditionVisualCronClass.LocatorT]

Declaration Syntax
C# Visual Basic Visual C++
public enum LocatorT
Public Enumeration LocatorT
public enum class LocatorT
Members
Member | Description
Auto |
Specific |


ConnectionClass Class

ConnectionClass Class
Namespaces ► VisualCron ► ConnectionClass

[Missing <summary> documentation for T:VisualCron.ConnectionClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConnectionClass
<SerializableAttribute> _
Public Class ConnectionClass
[SerializableAttribute]
public ref class ConnectionClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionClass()()() | Initializes a new instance of the ConnectionClass class
 | AcceptAllCertificates |
 | Anonymous | Use anonymous login
 | AuthenticationType |
 | CertificateId | The Id of the Certificate
 | CertificatePassword | Password for the Certificate
 | CloneType()()() |
 | ConnectionString | Gets or sets the connection string that is generated from guide
 | DataConnectionType |
 | EncryptCommandChannel | If the command channel should be encrypted or not. Sending a CCC on false
 | EncryptDataChannel | If this property value is True the channel used for data transfer (files, directory listings) will be encrypted). Sending PROT P on true PROT C on false
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Host | Name of the remote Server
 | Id | Internal GUID of the Connection
 | KeyRingId | The Id of the KeyRing
 | LogReceived |
 | LogSent |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of the Connection
 | PassWord |
 | Port | Port of the remote Server
 | PrivateKeyPassWord |
 | PrivateKeyPath |
 | ProtocolType |
 | Proxy |
 | SQLConnection |
 | TimeOut |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseCompression |
 | UserName |
 | UseSSHV1 |
 | UseSSHV2 |
 | UseSSL | This options is only valid for Email connections
Inheritance Hierarchy
Object
ConnectionClass

Send comments on this topic to Please email feedback to Support


ConnectionClass Constructor

ConnectionClass Constructor
Namespaces ► VisualCron ► ConnectionClass ► ConnectionClass()()()
Initializes a new instance of the ConnectionClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass()
Public Sub New
public:
ConnectionClass()


AcceptAllCertificates Property

AcceptAllCertificates Property
Namespaces ► VisualCron ► ConnectionClass ► AcceptAllCertificates

[Missing <summary> documentation for P:VisualCron.ConnectionClass.AcceptAllCertificates]

Declaration Syntax
C# Visual Basic Visual C++
public bool AcceptAllCertificates { get; set; }
Public Property AcceptAllCertificates As Boolean
public:
property bool AcceptAllCertificates {
    bool get ();
    void set (bool value);
}


Anonymous Property

Anonymous Property
Namespaces ► VisualCron ► ConnectionClass ► Anonymous
Use anonymous login
Declaration Syntax
C# Visual Basic Visual C++
public bool Anonymous { get; set; }
Public Property Anonymous As Boolean
public:
property bool Anonymous {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AuthenticationType Field

AuthenticationType Field
Namespaces ► VisualCron ► ConnectionClass ► AuthenticationType

[Missing <summary> documentation for F:VisualCron.ConnectionClass.AuthenticationType]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass..::.AuthenticationT AuthenticationType
Public AuthenticationType As ConnectionClass..::.AuthenticationT
public:
ConnectionClass..::.AuthenticationT AuthenticationType


CertificateId Property

CertificateId Property
Namespaces ► VisualCron ► ConnectionClass ► CertificateId
The Id of the Certificate
Declaration Syntax
C# Visual Basic Visual C++
public string CertificateId { get; set; }
Public Property CertificateId As String
public:
property String^ CertificateId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CertificatePassword Property

CertificatePassword Property
Namespaces ► VisualCron ► ConnectionClass ► CertificatePassword
Password for the Certificate
Declaration Syntax
C# Visual Basic Visual C++
public byte[] CertificatePassword { get; set; }
Public Property CertificatePassword As Byte()
public:
property array<unsigned char>^ CertificatePassword {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CloneType Method

CloneType Method
Namespaces ► VisualCron ► ConnectionClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.ConnectionClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass CloneType()
Public Function CloneType As ConnectionClass
public:
ConnectionClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.ConnectionClass.CloneType]


ConnectionString Property

ConnectionString Property
Namespaces ► VisualCron ► ConnectionClass ► ConnectionString
Gets or sets the connection string that is generated from guide
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionString { get; set; }
Public Property ConnectionString As String
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DataConnectionType Field

DataConnectionType Field
Namespaces ► VisualCron ► ConnectionClass ► DataConnectionType

[Missing <summary> documentation for F:VisualCron.ConnectionClass.DataConnectionType]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass..::.DataConnectionT DataConnectionType
Public DataConnectionType As ConnectionClass..::.DataConnectionT
public:
ConnectionClass..::.DataConnectionT DataConnectionType


EncryptCommandChannel Property

EncryptCommandChannel Property
Namespaces ► VisualCron ► ConnectionClass ► EncryptCommandChannel
If the command channel should be encrypted or not. Sending a CCC on false
Declaration Syntax
C# Visual Basic Visual C++
public bool EncryptCommandChannel { get; set; }
Public Property EncryptCommandChannel As Boolean
public:
property bool EncryptCommandChannel {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EncryptDataChannel Property

EncryptDataChannel Property
Namespaces ► VisualCron ► ConnectionClass ► EncryptDataChannel
If this property value is True the channel used for data transfer (files, directory listings) will be encrypted). Sending PROT P on true PROT C on false
Declaration Syntax
C# Visual Basic Visual C++
public bool EncryptDataChannel { get; set; }
Public Property EncryptDataChannel As Boolean
public:
property bool EncryptDataChannel {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Host Property

Host Property
Namespaces ► VisualCron ► ConnectionClass ► Host
Name of the remote Server
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Host { get; set; }
Public Property Host As Byte()
public:
property array<unsigned char>^ Host {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► ConnectionClass ► Id
Internal GUID of the Connection
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


KeyRingId Property

KeyRingId Property
Namespaces ► VisualCron ► ConnectionClass ► KeyRingId
The Id of the KeyRing
Declaration Syntax
C# Visual Basic Visual C++
public string KeyRingId { get; set; }
Public Property KeyRingId As String
public:
property String^ KeyRingId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LogReceived Property

LogReceived Property
Namespaces ► VisualCron ► ConnectionClass ► LogReceived

[Missing <summary> documentation for P:VisualCron.ConnectionClass.LogReceived]

Declaration Syntax
C# Visual Basic Visual C++
public bool LogReceived { get; set; }
Public Property LogReceived As Boolean
public:
property bool LogReceived {
    bool get ();
    void set (bool value);
}


LogSent Property

LogSent Property
Namespaces ► VisualCron ► ConnectionClass ► LogSent

[Missing <summary> documentation for P:VisualCron.ConnectionClass.LogSent]

Declaration Syntax
C# Visual Basic Visual C++
public bool LogSent { get; set; }
Public Property LogSent As Boolean
public:
property bool LogSent {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► VisualCron ► ConnectionClass ► Name
Name of the Connection
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PassWord Property

PassWord Property
Namespaces ► VisualCron ► ConnectionClass ► PassWord

[Missing <summary> documentation for P:VisualCron.ConnectionClass.PassWord]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] PassWord { get; set; }
Public Property PassWord As Byte()
public:
property array<unsigned char>^ PassWord {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


Port Property

Port Property
Namespaces ► VisualCron ► ConnectionClass ► Port
Port of the remote Server
Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
property int Port {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PrivateKeyPassWord Property

PrivateKeyPassWord Property
Namespaces ► VisualCron ► ConnectionClass ► PrivateKeyPassWord

[Missing <summary> documentation for P:VisualCron.ConnectionClass.PrivateKeyPassWord]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] PrivateKeyPassWord { get; set; }
Public Property PrivateKeyPassWord As Byte()
public:
property array<unsigned char>^ PrivateKeyPassWord {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


PrivateKeyPath Property

PrivateKeyPath Property
Namespaces ► VisualCron ► ConnectionClass ► PrivateKeyPath

[Missing <summary> documentation for P:VisualCron.ConnectionClass.PrivateKeyPath]

Declaration Syntax
C# Visual Basic Visual C++
public string PrivateKeyPath { get; set; }
Public Property PrivateKeyPath As String
public:
property String^ PrivateKeyPath {
    String^ get ();
    void set (String^ value);
}


ProtocolType Field

ProtocolType Field
Namespaces ► VisualCron ► ConnectionClass ► ProtocolType

[Missing <summary> documentation for F:VisualCron.ConnectionClass.ProtocolType]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass..::.ProtocolT ProtocolType
Public ProtocolType As ConnectionClass..::.ProtocolT
public:
ConnectionClass..::.ProtocolT ProtocolType


Proxy Field

Proxy Field
Namespaces ► VisualCron ► ConnectionClass ► Proxy

[Missing <summary> documentation for F:VisualCron.ConnectionClass.Proxy]

Declaration Syntax
C# Visual Basic Visual C++
public ProxyClass Proxy
Public Proxy As ProxyClass
public:
ProxyClass^ Proxy

Send comments on this topic to Please email feedback to Support


SQLConnection Field

SQLConnection Field
Namespaces ► VisualCron ► ConnectionClass ► SQLConnection

[Missing <summary> documentation for F:VisualCron.ConnectionClass.SQLConnection]

Declaration Syntax
C# Visual Basic Visual C++
public SQLConnectionClass SQLConnection
Public SQLConnection As SQLConnectionClass
public:
SQLConnectionClass^ SQLConnection

Send comments on this topic to Please email feedback to Support


TimeOut Property

TimeOut Property
Namespaces ► VisualCron ► ConnectionClass ► TimeOut

[Missing <summary> documentation for P:VisualCron.ConnectionClass.TimeOut]

Declaration Syntax
C# Visual Basic Visual C++
public int TimeOut { get; set; }
Public Property TimeOut As Integer
public:
property int TimeOut {
    int get ();
    void set (int value);
}


UseCompression Property

UseCompression Property
Namespaces ► VisualCron ► ConnectionClass ► UseCompression

[Missing <summary> documentation for P:VisualCron.ConnectionClass.UseCompression]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseCompression { get; set; }
Public Property UseCompression As Boolean
public:
property bool UseCompression {
    bool get ();
    void set (bool value);
}


UserName Property

UserName Property
Namespaces ► VisualCron ► ConnectionClass ► UserName

[Missing <summary> documentation for P:VisualCron.ConnectionClass.UserName]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] UserName { get; set; }
Public Property UserName As Byte()
public:
property array<unsigned char>^ UserName {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


UseSSHV1 Property

UseSSHV1 Property
Namespaces ► VisualCron ► ConnectionClass ► UseSSHV1

[Missing <summary> documentation for P:VisualCron.ConnectionClass.UseSSHV1]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseSSHV1 { get; set; }
Public Property UseSSHV1 As Boolean
public:
property bool UseSSHV1 {
    bool get ();
    void set (bool value);
}


UseSSHV2 Property

UseSSHV2 Property
Namespaces ► VisualCron ► ConnectionClass ► UseSSHV2

[Missing <summary> documentation for P:VisualCron.ConnectionClass.UseSSHV2]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseSSHV2 { get; set; }
Public Property UseSSHV2 As Boolean
public:
property bool UseSSHV2 {
    bool get ();
    void set (bool value);
}


UseSSL Property

UseSSL Property
Namespaces ► VisualCron ► ConnectionClass ► UseSSL
This options is only valid for Email connections
Declaration Syntax
C# Visual Basic Visual C++
public bool UseSSL { get; set; }
Public Property UseSSL As Boolean
public:
property bool UseSSL {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConnectionClass.AuthenticationT Enumeration

ConnectionClass..::.AuthenticationT Enumeration
Namespaces ► VisualCron ► ConnectionClass ► ConnectionClass..::.AuthenticationT

[Missing <summary> documentation for T:VisualCron.ConnectionClass.AuthenticationT]

Declaration Syntax
C# Visual Basic Visual C++
public enum AuthenticationT
Public Enumeration AuthenticationT
public enum class AuthenticationT
Members
Member | Description
Password |
PublicKey |


ConnectionClass.DataConnectionT Enumeration

ConnectionClass..::.DataConnectionT Enumeration
Namespaces ► VisualCron ► ConnectionClass ► ConnectionClass..::.DataConnectionT

[Missing <summary> documentation for T:VisualCron.ConnectionClass.DataConnectionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum DataConnectionT
Public Enumeration DataConnectionT
public enum class DataConnectionT
Members
Member | Description
NA |
PASV |
PORT |


ConnectionClass.ProtocolT Enumeration

ConnectionClass..::.ProtocolT Enumeration
Namespaces ► VisualCron ► ConnectionClass ► ConnectionClass..::.ProtocolT

[Missing <summary> documentation for T:VisualCron.ConnectionClass.ProtocolT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ProtocolT
Public Enumeration ProtocolT
public enum class ProtocolT
Members
Member | Description
FTP |
FTPSSLImplicit |
FTPTLSSSLImplicit |
FTPSSLExplicit |
FTPTLSSSLExplicit |
SFTP |
SSH |
SMTP |
POP3 |
IMAP4 |
SQL |


ConnectionClass.TransferT Enumeration

ConnectionClass..::.TransferT Enumeration
Namespaces ► VisualCron ► ConnectionClass ► ConnectionClass..::.TransferT

[Missing <summary> documentation for T:VisualCron.ConnectionClass.TransferT]

Declaration Syntax
C# Visual Basic Visual C++
public enum TransferT
Public Enumeration TransferT
public enum class TransferT
Members
Member | Description
NA |
Binary |
ASCII |


ConnectionDeleteClass Class

ConnectionDeleteClass Class
Namespaces ► VisualCron ► ConnectionDeleteClass

[Missing <summary> documentation for T:VisualCron.ConnectionDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConnectionDeleteClass
<SerializableAttribute> _
Public Class ConnectionDeleteClass
[SerializableAttribute]
public ref class ConnectionDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConnectionDeleteClass()()() | Initializes a new instance of the ConnectionDeleteClass class
 | Deleted | Indicates if the Connection was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Connection
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConnectionDeleteClass

Send comments on this topic to Please email feedback to Support


ConnectionDeleteClass Constructor

ConnectionDeleteClass Constructor
Namespaces ► VisualCron ► ConnectionDeleteClass ► ConnectionDeleteClass()()()
Initializes a new instance of the ConnectionDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionDeleteClass()
Public Sub New
public:
ConnectionDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► ConnectionDeleteClass ► Deleted
Indicates if the Connection was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► ConnectionDeleteClass ► Id
Gets or sets the Id of the Connection
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConstantsAPI Class

ConstantsAPI Class
Namespaces ► VisualCron ► ConstantsAPI

[Missing <summary> documentation for T:VisualCron.ConstantsAPI]

Declaration Syntax
C# Visual Basic Visual C++
public class ConstantsAPI
Public Class ConstantsAPI
public ref class ConstantsAPI
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConstantsAPI()()() | Initializes a new instance of the ConstantsAPI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrayClientID |
Inheritance Hierarchy
Object
ConstantsAPI

Send comments on this topic to Please email feedback to Support


ConstantsAPI Constructor

ConstantsAPI Constructor
Namespaces ► VisualCron ► ConstantsAPI ► ConstantsAPI()()()
Initializes a new instance of the ConstantsAPI class
Declaration Syntax
C# Visual Basic Visual C++
public ConstantsAPI()
Public Sub New
public:
ConstantsAPI()


TrayClientID Field

TrayClientID Field
Namespaces ► VisualCron ► ConstantsAPI ► TrayClientID

[Missing <summary> documentation for F:VisualCron.ConstantsAPI.TrayClientID]

Declaration Syntax
C# Visual Basic Visual C++
public static string TrayClientID
Public Shared TrayClientID As String
public:
static String^ TrayClientID


CustomWMIEventClass Class

CustomWMIEventClass Class
Namespaces ► VisualCron ► CustomWMIEventClass
Custom WMI Event
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CustomWMIEventClass : ICloneable
<SerializableAttribute> _
Public Class CustomWMIEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class CustomWMIEventClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CustomWMIEventClass()()() | Initializes a new instance of the CustomWMIEventClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventClassName | WMI Class Name
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Machine | Server name/ip
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | Id of Network Credential that will be used to get access
 | Path | WMI namespace path
 | Query | WMI Query
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
CustomWMIEventClass

Send comments on this topic to Please email feedback to Support


CustomWMIEventClass Constructor

CustomWMIEventClass Constructor
Namespaces ► VisualCron ► CustomWMIEventClass ► CustomWMIEventClass()()()
Initializes a new instance of the CustomWMIEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public CustomWMIEventClass()
Public Sub New
public:
CustomWMIEventClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► CustomWMIEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.CustomWMIEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.CustomWMIEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► CustomWMIEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.CustomWMIEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public CustomWMIEventClass CloneType()
Public Function CloneType As CustomWMIEventClass
public:
CustomWMIEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.CustomWMIEventClass.CloneType]


EventClassName Property

EventClassName Property
Namespaces ► VisualCron ► CustomWMIEventClass ► EventClassName
WMI Class Name
Declaration Syntax
C# Visual Basic Visual C++
public string EventClassName { get; set; }
Public Property EventClassName As String
public:
property String^ EventClassName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Specify Class Name if needed

Send comments on this topic to Please email feedback to Support


Machine Property

Machine Property
Namespaces ► VisualCron ► CustomWMIEventClass ► Machine
Server name/ip
Declaration Syntax
C# Visual Basic Visual C++
public string Machine { get; set; }
Public Property Machine As String
public:
property String^ Machine {
    String^ get ();
    void set (String^ value);
}
Value
Default: . = local computer
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► CustomWMIEventClass ► NetworkCredential
Id of Network Credential that will be used to get access
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Path Property

Path Property
Namespaces ► VisualCron ► CustomWMIEventClass ► Path
WMI namespace path
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; set; }
Public Property Path As String
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
Value
\root\CIMV2
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Query Property

Query Property
Namespaces ► VisualCron ► CustomWMIEventClass ► Query
WMI Query
Declaration Syntax
C# Visual Basic Visual C++
public string Query { get; set; }
Public Property Query As String
public:
property String^ Query {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CustomWMIEventClass.OperatorT Enumeration

CustomWMIEventClass..::.OperatorT Enumeration
Namespaces ► VisualCron ► CustomWMIEventClass ► CustomWMIEventClass..::.OperatorT
Specifies if you want to include or ignore a certain value
Declaration Syntax
C# Visual Basic Visual C++
public enum OperatorT
Public Enumeration OperatorT
public enum class OperatorT
Members
Member | Description
Include |
Ignore |
Remarks

Send comments on this topic to Please email feedback to Support


CustomWMITriggerResultClass Class

CustomWMITriggerResultClass Class
Namespaces ► VisualCron ► CustomWMITriggerResultClass

[Missing <summary> documentation for T:VisualCron.CustomWMITriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CustomWMITriggerResultClass
<SerializableAttribute> _
Public Class CustomWMITriggerResultClass
[SerializableAttribute]
public ref class CustomWMITriggerResultClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CustomWMITriggerResultClass()()() | Initializes a new instance of the CustomWMITriggerResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CustomWMITriggerResultClass

Send comments on this topic to Please email feedback to Support


CustomWMITriggerResultClass Constructor

CustomWMITriggerResultClass Constructor
Namespaces ► VisualCron ► CustomWMITriggerResultClass ► CustomWMITriggerResultClass()()()
Initializes a new instance of the CustomWMITriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public CustomWMITriggerResultClass()
Public Sub New
public:
CustomWMITriggerResultClass()


DayClass Class

DayClass Class
Namespaces ► VisualCron ► DayClass
DayClass
Declaration Syntax
C# Visual Basic Visual C++
public class DayClass
Public Class DayClass
public ref class DayClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DayClass()()() | Initializes a new instance of the DayClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Not used in API
Inheritance Hierarchy
Object
DayClass

Send comments on this topic to Please email feedback to Support


DayClass Constructor

DayClass Constructor
Namespaces ► VisualCron ► DayClass ► DayClass()()()
Initializes a new instance of the DayClass class
Declaration Syntax
C# Visual Basic Visual C++
public DayClass()
Public Sub New
public:
DayClass()


Id Property

Id Property
Namespaces ► VisualCron ► DayClass ► Id

[Missing <summary> documentation for P:VisualCron.DayClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public int Id { get; set; }
Public Property Id As Integer
public:
property int Id {
    int get ();
    void set (int value);
}


Name Property

Name Property
Namespaces ► VisualCron ► DayClass ► Name

[Missing <summary> documentation for P:VisualCron.DayClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Delay Class

Delay Class
Namespaces ► VisualCron ► Delay
"Delay" macro command.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class Delay : Command
<SerializableAttribute> _
Public Class Delay _
    Inherits Command
[SerializableAttribute]
public ref class Delay : public Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Delay()()() | Initializes a new instance of the Delay class
 | Clone()()() | (Inherited from Command.)
 | Description | (Overrides Command.Description.)
 | Duration |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Max |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Min |
 | Random |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed) | (Overrides Command.TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed).)
Inheritance Hierarchy
Object
 | Command
 |  | Delay


Delay Constructor

Delay Constructor
Namespaces ► VisualCron ► Delay ► Delay()()()
Initializes a new instance of the Delay class
Declaration Syntax
C# Visual Basic Visual C++
public Delay()
Public Sub New
public:
Delay()


Description Property

Description Property
Namespaces ► VisualCron ► Delay ► Description

[Missing <summary> documentation for P:VisualCron.Delay.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


Duration Property

Duration Property
Namespaces ► VisualCron ► Delay ► Duration

[Missing <summary> documentation for P:VisualCron.Delay.Duration]

Declaration Syntax
C# Visual Basic Visual C++
public int Duration { get; set; }
Public Property Duration As Integer
public:
property int Duration {
    int get ();
    void set (int value);
}


Max Property

Max Property
Namespaces ► VisualCron ► Delay ► Max

[Missing <summary> documentation for P:VisualCron.Delay.Max]

Declaration Syntax
C# Visual Basic Visual C++
public int Max { get; set; }
Public Property Max As Integer
public:
property int Max {
    int get ();
    void set (int value);
}


Min Property

Min Property
Namespaces ► VisualCron ► Delay ► Min

[Missing <summary> documentation for P:VisualCron.Delay.Min]

Declaration Syntax
C# Visual Basic Visual C++
public int Min { get; set; }
Public Property Min As Integer
public:
property int Min {
    int get ();
    void set (int value);
}


Random Property

Random Property
Namespaces ► VisualCron ► Delay ► Random

[Missing <summary> documentation for P:VisualCron.Delay.Random]

Declaration Syntax
C# Visual Basic Visual C++
public bool Random { get; set; }
Public Property Random As Boolean
public:
property bool Random {
    bool get ();
    void set (bool value);
}


TranslateToInstructions Method (builder, speed)

TranslateToInstructions Method (builder, speed)
Namespaces ► VisualCron ► Delay ► TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed)

[Missing <summary> documentation for M:VisualCron.Delay.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)]

Declaration Syntax
C# Visual Basic Visual C++
public override void TranslateToInstructions(
    InstructionsBuilder builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
)
Public Overrides Sub TranslateToInstructions ( _
    builder As InstructionsBuilder, _
    speed As TaskDesktopMacroClass..::.MacroSpeed _
)
public:
virtual void TranslateToInstructions(
    InstructionsBuilder^ builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
) override
Parameters
builder (InstructionsBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.Delay.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]

speed (TaskDesktopMacroClass..::.MacroSpeed)

[Missing <param name="speed"/> documentation for "M:VisualCron.Delay.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]


DoNotObfuscate Class

DoNotObfuscate Class
Namespaces ► VisualCron ► DoNotObfuscate

[Missing <summary> documentation for T:VisualCron.DoNotObfuscate]

Declaration Syntax
C# Visual Basic Visual C++
public class DoNotObfuscate : Attribute
Public Class DoNotObfuscate _
    Inherits Attribute
public ref class DoNotObfuscate : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DoNotObfuscate()()() | Initializes a new instance of the DoNotObfuscate class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | DoNotObfuscate


DoNotObfuscate Constructor

DoNotObfuscate Constructor
Namespaces ► VisualCron ► DoNotObfuscate ► DoNotObfuscate()()()
Initializes a new instance of the DoNotObfuscate class
Declaration Syntax
C# Visual Basic Visual C++
public DoNotObfuscate()
Public Sub New
public:
DoNotObfuscate()


DSConditions Class

DSConditions Class
Namespaces ► VisualCron ► DSConditions
Represents a strongly typed in-memory cache of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DSConditions : DataSet
<SerializableAttribute> _
Public Class DSConditions _
    Inherits DataSet
[SerializableAttribute]
public ref class DSConditions : public DataSet
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSConditions()()() | Initializes a new instance of the DSConditions class
 | DSConditions(SerializationInfo, StreamingContext) | Initializes a new instance of the DSConditions class
 | AcceptChanges()()() | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | BeginInit()()() | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | CaseSensitive | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive. (Inherited from DataSet.)
 | Clear()()() | Clears the DataSet of any data by removing all rows in all tables. (Inherited from DataSet.)
 | Clone()()() | (Overrides DataSet.Clone()()().)
 | ConditionCollections |
 | Conditions |
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataSet. (Inherited from DataSet.)
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection. (Inherited from DataSet.)
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable. (Inherited from DataSet.)
 | DataSetName | Gets or sets the name of the current DataSet. (Inherited from DataSet.)
 | DefaultViewManager | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager. (Inherited from DataSet.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | EndInit()()() | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from DataSet.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from DataSet.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called. (Inherited from DataSet.)
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataSet.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataSet. (Inherited from DataSet.)
 | GetSchemaSerializable()()() | (Overrides DataSet.GetSchemaSerializable()()().)
 | GetSerializationData(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedDataSetSchema(XmlSchemaSet) |
 | GetXml()()() | Returns the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | GetXmlSchema()()() | Returns the XML Schema for the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows. (Inherited from DataSet.)
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState. (Inherited from DataSet.)
 | HasErrors | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet. (Inherited from DataSet.)
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet. (Inherited from DataSet.)
 | Initialized | Occurs after the DataSet is initialized. (Inherited from DataSet.)
 | InitializeDerivedDataSet()()() | (Overrides DataSet.InitializeDerivedDataSet()()().)
 | IsBinarySerialized(SerializationInfo, StreamingContext) | Inspects the format of the serialized representation of the DataSet. (Inherited from DataSet.)
 | IsInitialized | Gets a value that indicates whether the DataSet is initialized. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet. (Inherited from DataSet.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataSet.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument. (Inherited from DataSet.)
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | MergeFailed | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true. (Inherited from DataSet.)
 | Namespace | Gets or sets the namespace of the DataSet. (Inherited from DataSet.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the OnPropertyChanging(PropertyChangedEventArgs) event. (Inherited from DataSet.)
 | OnRemoveRelation(DataRelation) | Occurs when a DataRelation object is removed from a DataTable. (Inherited from DataSet.)
 | OnRemoveTable(DataTable) | Occurs when a DataTable is removed from a DataSet. (Inherited from DataSet.)
 | Prefix | Gets or sets an XML prefix that aliases the namespace of the DataSet. (Inherited from DataSet.)
 | RaisePropertyChanging(String) | Sends a notification that the specified DataSet property is about to change. (Inherited from DataSet.)
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader. (Inherited from DataSet.)
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream. (Inherited from DataSet.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader. (Inherited from DataSet.)
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file. (Inherited from DataSet.)
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode. (Inherited from DataSet.)
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet. (Inherited from DataSet.)
 | ReadXmlSerializable(XmlReader) | (Overrides DataSet.ReadXmlSerializable(XmlReader).)
 | RejectChanges()()() | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | Relations |
 | RemotingFormat | Gets or sets a SerializationFormat for the DataSet used during remoting. (Inherited from DataSet.)
 | Reset()()() | Resets the DataSet to its original state. Subclasses should override Reset()()() to restore a DataSet to its original state. (Inherited from DataSet.)
 | SchemaSerializationMode | (Overrides DataSet.SchemaSerializationMode.)
 | ShouldSerializeRelations()()() | (Overrides DataSet.ShouldSerializeRelations()()().)
 | ShouldSerializeTables()()() | (Overrides DataSet.ShouldSerializeTables()()().)
 | Site | Gets or sets an ISite for the DataSet. (Inherited from DataSet.)
 | Tables |
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream. (Inherited from DataSet.)
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter. (Inherited from DataSet.)
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter. (Inherited from DataSet.)
 | WriteXml(String) | Writes the current data for the DataSet to the specified file. (Inherited from DataSet.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object. (Inherited from DataSet.)
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file. (Inherited from DataSet.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataSet
 |  |  | DSConditions


DSConditions Constructor

DSConditions Constructor
Namespaces ► VisualCron ► DSConditions ► DSConditions()()()
Members
Icon | Member | Description
 | DSConditions()()() | Initializes a new instance of the DSConditions class
 | DSConditions(SerializationInfo, StreamingContext) | Initializes a new instance of the DSConditions class


DSConditions Constructor

DSConditions Constructor
Namespaces ► VisualCron ► DSConditions ► DSConditions()()()
Initializes a new instance of the DSConditions class
Declaration Syntax
C# Visual Basic Visual C++
public DSConditions()
Public Sub New
public:
DSConditions()


DSConditions Constructor (info, context)

DSConditions Constructor (info, context)
Namespaces ► VisualCron ► DSConditions ► DSConditions(SerializationInfo, StreamingContext)
Initializes a new instance of the DSConditions class
Declaration Syntax
C# Visual Basic Visual C++
protected DSConditions(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DSConditions(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSConditions.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSConditions.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSConditions ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataSet Clone()
Public Overrides Function Clone As DataSet
public:
virtual DataSet^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.Clone]


ConditionCollections Property

ConditionCollections Property
Namespaces ► VisualCron ► DSConditions ► ConditionCollections

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollections]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionCollectionsDataTable ConditionCollections { get; }
Public ReadOnly Property ConditionCollections As DSConditions..::.ConditionCollectionsDataTable
public:
property DSConditions..::.ConditionCollectionsDataTable^ ConditionCollections {
    DSConditions..::.ConditionCollectionsDataTable^ get ();
}


Conditions Property

Conditions Property
Namespaces ► VisualCron ► DSConditions ► Conditions

[Missing <summary> documentation for P:VisualCron.DSConditions.Conditions]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionsDataTable Conditions { get; }
Public ReadOnly Property Conditions As DSConditions..::.ConditionsDataTable
public:
property DSConditions..::.ConditionsDataTable^ Conditions {
    DSConditions..::.ConditionsDataTable^ get ();
}


GetSchemaSerializable Method

GetSchemaSerializable Method
Namespaces ► VisualCron ► DSConditions ► GetSchemaSerializable()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.GetSchemaSerializable]

Declaration Syntax
C# Visual Basic Visual C++
protected override XmlSchema GetSchemaSerializable()
Protected Overrides Function GetSchemaSerializable As XmlSchema
protected:
virtual XmlSchema^ GetSchemaSerializable() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.GetSchemaSerializable]


GetTypedDataSetSchema Method (xs)

GetTypedDataSetSchema Method (xs)
Namespaces ► VisualCron ► DSConditions ► GetTypedDataSetSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSConditions.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedDataSetSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedDataSetSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedDataSetSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSConditions.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]


InitializeDerivedDataSet Method

InitializeDerivedDataSet Method
Namespaces ► VisualCron ► DSConditions ► InitializeDerivedDataSet()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.InitializeDerivedDataSet]

Declaration Syntax
C# Visual Basic Visual C++
protected override void InitializeDerivedDataSet()
Protected Overrides Sub InitializeDerivedDataSet
protected:
virtual void InitializeDerivedDataSet() override


ReadXmlSerializable Method (reader)

ReadXmlSerializable Method (reader)
Namespaces ► VisualCron ► DSConditions ► ReadXmlSerializable(XmlReader)

[Missing <summary> documentation for M:VisualCron.DSConditions.ReadXmlSerializable(System.Xml.XmlReader)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void ReadXmlSerializable(
    XmlReader reader
)
Protected Overrides Sub ReadXmlSerializable ( _
    reader As XmlReader _
)
protected:
virtual void ReadXmlSerializable(
    XmlReader^ reader
) override
Parameters
reader (XmlReader)

[Missing <param name="reader"/> documentation for "M:VisualCron.DSConditions.ReadXmlSerializable(System.Xml.XmlReader)"]


Relations Property

Relations Property
Namespaces ► VisualCron ► DSConditions ► Relations

[Missing <summary> documentation for P:VisualCron.DSConditions.Relations]

Declaration Syntax
C# Visual Basic Visual C++
public DataRelationCollection Relations { get; }
Public ReadOnly Property Relations As DataRelationCollection
public:
property DataRelationCollection^ Relations {
    DataRelationCollection^ get ();
}


SchemaSerializationMode Property

SchemaSerializationMode Property
Namespaces ► VisualCron ► DSConditions ► SchemaSerializationMode

[Missing <summary> documentation for P:VisualCron.DSConditions.SchemaSerializationMode]

Declaration Syntax
C# Visual Basic Visual C++
public override SchemaSerializationMode SchemaSerializationMode { get; set; }
Public Overrides Property SchemaSerializationMode As SchemaSerializationMode
public:
virtual property SchemaSerializationMode SchemaSerializationMode {
    SchemaSerializationMode get () override;
    void set (SchemaSerializationMode value) override;
}


ShouldSerializeRelations Method

ShouldSerializeRelations Method
Namespaces ► VisualCron ► DSConditions ► ShouldSerializeRelations()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ShouldSerializeRelations]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeRelations()
Protected Overrides Function ShouldSerializeRelations As Boolean
protected:
virtual bool ShouldSerializeRelations() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ShouldSerializeRelations]


ShouldSerializeTables Method

ShouldSerializeTables Method
Namespaces ► VisualCron ► DSConditions ► ShouldSerializeTables()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ShouldSerializeTables]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeTables()
Protected Overrides Function ShouldSerializeTables As Boolean
protected:
virtual bool ShouldSerializeTables() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ShouldSerializeTables]


Tables Property

Tables Property
Namespaces ► VisualCron ► DSConditions ► Tables

[Missing <summary> documentation for P:VisualCron.DSConditions.Tables]

Declaration Syntax
C# Visual Basic Visual C++
public DataTableCollection Tables { get; }
Public ReadOnly Property Tables As DataTableCollection
public:
property DataTableCollection^ Tables {
    DataTableCollection^ get ();
}


DSConditions.ConditionCollectionsDataTable Class

DSConditions..::.ConditionCollectionsDataTable Class
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionCollectionsDataTable
Represents the strongly named DataTable class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionCollectionsDataTable : DataTable,
    IEnumerable
<SerializableAttribute> _
Public Class ConditionCollectionsDataTable _
    Inherits DataTable _
    Implements IEnumerable
[SerializableAttribute]
public ref class ConditionCollectionsDataTable : public DataTable,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSConditions..::.ConditionCollectionsDataTable()()() | Initializes a new instance of the DSConditions..::.ConditionCollectionsDataTable class
 | DSConditions..::.ConditionCollectionsDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSConditions..::.ConditionCollectionsDataTable class
 | AcceptChanges()()() | Commits all the changes made to this table since the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | AddConditionCollectionsRow(DSConditions..::.ConditionCollectionsRow) |
 | AddConditionCollectionsRow(String, String) |
 | BeginInit()()() | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | BeginLoadData()()() | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from DataTable.)
 | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from DataTable.)
 | ChildRelations | Gets the collection of child relations for this DataTable. (Inherited from DataTable.)
 | Clear()()() | Clears the DataTable of all data. (Inherited from DataTable.)
 | Clone()()() | (Overrides DataTable.Clone()()().)
 | ColumnChanged | Occurs after a value has been changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | ColumnChanging | Occurs when a value is being changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | Columns | Gets the collection of columns that belong to this table. (Inherited from DataTable.)
 | Compute(String, String) | Computes the given expression on the current rows that pass the filter criteria. (Inherited from DataTable.)
 | ConditionCollectionsRowChanged |
 | ConditionCollectionsRowChanging |
 | ConditionCollectionsRowDeleted |
 | ConditionCollectionsRowDeleting |
 | Constraints | Gets the collection of constraints maintained by this table. (Inherited from DataTable.)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataTable. (Inherited from DataTable.)
 | Count |
 | CreateDataReader()()() | Returns a DataTableReader corresponding to the data within this DataTable. (Inherited from DataTable.)
 | CreateInstance()()() | (Overrides DataTable.CreateInstance()()().)
 | DataSet | Gets the DataSet to which this table belongs. (Inherited from DataTable.)
 | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from DataTable.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from DataTable.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | EndInit()()() | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | EndLoadData()()() | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from DataTable.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information. (Inherited from DataTable.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | FindById(String) |
 | fInitInProgress | (Inherited from DataTable.)
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called. (Inherited from DataTable.)
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataTable.)
 | GetEnumerator()()() |
 | GetErrors()()() | Gets an array of DataRow objects that contain errors. (Inherited from DataTable.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataTable. (Inherited from DataTable.)
 | GetRowType()()() | (Overrides DataTable.GetRowType()()().)
 | GetSchema()()() | (Inherited from DataTable.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedTableSchema(XmlSchemaSet) |
 | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs. (Inherited from DataTable.)
 | IdColumn |
 | ImportRow(DataRow) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values. (Inherited from DataTable.)
 | Initialized | Occurs after the DataTable is initialized. (Inherited from DataTable.)
 | IsInitialized | Gets a value that indicates whether the DataTable is initialized. (Inherited from DataTable.)
 | Item[([(Int32])]) |
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataTable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable. (Inherited from DataTable.)
 | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from DataTable.)
 | NameColumn |
 | Namespace | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | NewConditionCollectionsRow()()() |
 | NewRow()()() | Creates a new DataRow with the same schema as the table. (Inherited from DataTable.)
 | NewRowArray(Int32) | (Inherited from DataTable.)
 | NewRowFromBuilder(DataRowBuilder) | (Overrides DataTable.NewRowFromBuilder(DataRowBuilder).)
 | OnColumnChanged(DataColumnChangeEventArgs) | Raises the ColumnChanged event. (Inherited from DataTable.)
 | OnColumnChanging(DataColumnChangeEventArgs) | Raises the ColumnChanging event. (Inherited from DataTable.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the PropertyChanged event. (Inherited from DataTable.)
 | OnRemoveColumn(DataColumn) | Notifies the DataTable that a DataColumn is being removed. (Inherited from DataTable.)
 | OnRowChanged(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanged(DataRowChangeEventArgs).)
 | OnRowChanging(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanging(DataRowChangeEventArgs).)
 | OnRowDeleted(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleted(DataRowChangeEventArgs).)
 | OnRowDeleting(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleting(DataRowChangeEventArgs).)
 | OnTableCleared(DataTableClearEventArgs) | Raises the TableCleared event. (Inherited from DataTable.)
 | OnTableClearing(DataTableClearEventArgs) | Raises the TableClearing event. (Inherited from DataTable.)
 | OnTableNewRow(DataTableNewRowEventArgs) | Raises the TableNewRow event. (Inherited from DataTable.)
 | ParentRelations | Gets the collection of parent relations for this DataTable. (Inherited from DataTable.)
 | Prefix | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table. (Inherited from DataTable.)
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream. (Inherited from DataTable.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream. (Inherited from DataTable.)
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSerializable(XmlReader) | (Inherited from DataTable.)
 | RejectChanges()()() | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | RemotingFormat | Gets or sets the serialization format. (Inherited from DataTable.)
 | RemoveConditionCollectionsRow(DSConditions..::.ConditionCollectionsRow) |
 | Reset()()() | Resets the DataTable to its original state. (Inherited from DataTable.)
 | RowChanged | Occurs after a DataRow has been changed successfully. (Inherited from DataTable.)
 | RowChanging | Occurs when a DataRow is changing. (Inherited from DataTable.)
 | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from DataTable.)
 | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from DataTable.)
 | Rows | Gets the collection of rows that belong to this table. (Inherited from DataTable.)
 | Select()()() | Gets an array of all DataRow objects. (Inherited from DataTable.)
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.) (Inherited from DataTable.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order. (Inherited from DataTable.)
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state. (Inherited from DataTable.)
 | Site | Gets or sets an ISite for the DataTable. (Inherited from DataTable.)
 | TableCleared | Occurs after a DataTable is cleared. (Inherited from DataTable.)
 | TableClearing | Occurs when a DataTable is cleared. (Inherited from DataTable.)
 | TableName | Gets or sets the name of the DataTable. (Inherited from DataTable.)
 | TableNewRow | Occurs when a new DataRow is inserted. (Inherited from DataTable.)
 | ToString()()() | Gets the TableName and DisplayExpression, if there is one as a concatenated string. (Inherited from DataTable.)
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream. (Inherited from DataTable.)
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter. (Inherited from DataTable.)
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file. (Inherited from DataTable.)
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream. (Inherited from DataTable.)
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file. (Inherited from DataTable.)
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataTable
 |  |  | DSConditions..::.ConditionCollectionsDataTable


DSConditions.ConditionCollectionsDataTable Constructor

DSConditions..::.ConditionCollectionsDataTable Constructor
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► DSConditions..::.ConditionCollectionsDataTable()()()
Members
Icon | Member | Description
 | DSConditions..::.ConditionCollectionsDataTable()()() | Initializes a new instance of the DSConditions..::.ConditionCollectionsDataTable class
 | DSConditions..::.ConditionCollectionsDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSConditions..::.ConditionCollectionsDataTable class


DSConditions.ConditionCollectionsDataTable Constructor

DSConditions..::.ConditionCollectionsDataTable Constructor
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► DSConditions..::.ConditionCollectionsDataTable()()()
Initializes a new instance of the DSConditions..::.ConditionCollectionsDataTable class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionCollectionsDataTable()
Public Sub New
public:
ConditionCollectionsDataTable()


DSConditions.ConditionCollectionsDataTable Constructor (info, context)

DSConditions..::.ConditionCollectionsDataTable Constructor (info, context)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► DSConditions..::.ConditionCollectionsDataTable(SerializationInfo, StreamingContext)
Initializes a new instance of the DSConditions..::.ConditionCollectionsDataTable class
Declaration Syntax
C# Visual Basic Visual C++
protected ConditionCollectionsDataTable(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConditionCollectionsDataTable(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


AddConditionCollectionsRow Method

AddConditionCollectionsRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► AddConditionCollectionsRow()()()
Members
Icon | Member | Description
 | AddConditionCollectionsRow(DSConditions..::.ConditionCollectionsRow) |
 | AddConditionCollectionsRow(String, String) |


AddConditionCollectionsRow Method (Id, Name)

AddConditionCollectionsRow Method (Id, Name)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► AddConditionCollectionsRow(String, String)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.AddConditionCollectionsRow(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionCollectionsRow AddConditionCollectionsRow(
    string Id,
    string Name
)
Public Function AddConditionCollectionsRow ( _
    Id As String, _
    Name As String _
) As DSConditions..::.ConditionCollectionsRow
public:
DSConditions..::.ConditionCollectionsRow^ AddConditionCollectionsRow(
    String^ Id,
    String^ Name
)
Parameters
Id (String)

[Missing <param name="Id"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.AddConditionCollectionsRow(System.String,System.String)"]

Name (String)

[Missing <param name="Name"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.AddConditionCollectionsRow(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.AddConditionCollectionsRow(System.String,System.String)]


AddConditionCollectionsRow Method (row)

AddConditionCollectionsRow Method (row)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► AddConditionCollectionsRow(DSConditions..::.ConditionCollectionsRow)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.AddConditionCollectionsRow(VisualCron.DSConditions.ConditionCollectionsRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddConditionCollectionsRow(
    DSConditions..::.ConditionCollectionsRow row
)
Public Sub AddConditionCollectionsRow ( _
    row As DSConditions..::.ConditionCollectionsRow _
)
public:
void AddConditionCollectionsRow(
    DSConditions..::.ConditionCollectionsRow^ row
)
Parameters
row (DSConditions..::.ConditionCollectionsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.AddConditionCollectionsRow(VisualCron.DSConditions.ConditionCollectionsRow)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataTable Clone()
Public Overrides Function Clone As DataTable
public:
virtual DataTable^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.Clone]


ConditionCollectionsRowChanged Event

ConditionCollectionsRowChanged Event
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► ConditionCollectionsRowChanged

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionCollectionsDataTable.ConditionCollectionsRowChanged]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionCollectionsRowChangeEventHandler ConditionCollectionsRowChanged
Public Event ConditionCollectionsRowChanged As DSConditions..::.ConditionCollectionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionCollectionsRowChangeEventHandler^ ConditionCollectionsRowChanged {
    void add (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
}


ConditionCollectionsRowChanging Event

ConditionCollectionsRowChanging Event
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► ConditionCollectionsRowChanging

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionCollectionsDataTable.ConditionCollectionsRowChanging]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionCollectionsRowChangeEventHandler ConditionCollectionsRowChanging
Public Event ConditionCollectionsRowChanging As DSConditions..::.ConditionCollectionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionCollectionsRowChangeEventHandler^ ConditionCollectionsRowChanging {
    void add (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
}


ConditionCollectionsRowDeleted Event

ConditionCollectionsRowDeleted Event
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► ConditionCollectionsRowDeleted

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionCollectionsDataTable.ConditionCollectionsRowDeleted]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionCollectionsRowChangeEventHandler ConditionCollectionsRowDeleted
Public Event ConditionCollectionsRowDeleted As DSConditions..::.ConditionCollectionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionCollectionsRowChangeEventHandler^ ConditionCollectionsRowDeleted {
    void add (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
}


ConditionCollectionsRowDeleting Event

ConditionCollectionsRowDeleting Event
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► ConditionCollectionsRowDeleting

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionCollectionsDataTable.ConditionCollectionsRowDeleting]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionCollectionsRowChangeEventHandler ConditionCollectionsRowDeleting
Public Event ConditionCollectionsRowDeleting As DSConditions..::.ConditionCollectionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionCollectionsRowChangeEventHandler^ ConditionCollectionsRowDeleting {
    void add (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionCollectionsRowChangeEventHandler^ value);
}


Count Property

Count Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► Count

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsDataTable.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


CreateInstance Method

CreateInstance Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► CreateInstance()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.CreateInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataTable CreateInstance()
Protected Overrides Function CreateInstance As DataTable
protected:
virtual DataTable^ CreateInstance() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.CreateInstance]


FindById Method (Id)

FindById Method (Id)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► FindById(String)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.FindById(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionCollectionsRow FindById(
    string Id
)
Public Function FindById ( _
    Id As String _
) As DSConditions..::.ConditionCollectionsRow
public:
DSConditions..::.ConditionCollectionsRow^ FindById(
    String^ Id
)
Parameters
Id (String)

[Missing <param name="Id"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.FindById(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.FindById(System.String)]


GetEnumerator Method

GetEnumerator Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► GetEnumerator()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.GetEnumerator]


GetRowType Method

GetRowType Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► GetRowType()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.GetRowType]

Declaration Syntax
C# Visual Basic Visual C++
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
protected:
virtual Type^ GetRowType() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.GetRowType]


GetTypedTableSchema Method (xs)

GetTypedTableSchema Method (xs)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► GetTypedTableSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedTableSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedTableSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedTableSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]


IdColumn Property

IdColumn Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► IdColumn

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsDataTable.IdColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn IdColumn { get; }
Public ReadOnly Property IdColumn As DataColumn
public:
property DataColumn^ IdColumn {
    DataColumn^ get ();
}


Item Property (index)

Item Property (index)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► Item[([(Int32])])

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsDataTable.Item(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionCollectionsRow this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DSConditions..::.ConditionCollectionsRow
public:
property DSConditions..::.ConditionCollectionsRow^ default[int index] {
    DSConditions..::.ConditionCollectionsRow^ get (int index);
}
Parameters
index (Int32)


NameColumn Property

NameColumn Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► NameColumn

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsDataTable.NameColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn NameColumn { get; }
Public ReadOnly Property NameColumn As DataColumn
public:
property DataColumn^ NameColumn {
    DataColumn^ get ();
}


NewConditionCollectionsRow Method

NewConditionCollectionsRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► NewConditionCollectionsRow()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.NewConditionCollectionsRow]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionCollectionsRow NewConditionCollectionsRow()
Public Function NewConditionCollectionsRow As DSConditions..::.ConditionCollectionsRow
public:
DSConditions..::.ConditionCollectionsRow^ NewConditionCollectionsRow()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.NewConditionCollectionsRow]


NewRowFromBuilder Method (builder)

NewRowFromBuilder Method (builder)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► NewRowFromBuilder(DataRowBuilder)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder ( _
    builder As DataRowBuilder _
) As DataRow
protected:
virtual DataRow^ NewRowFromBuilder(
    DataRowBuilder^ builder
) override
Parameters
builder (DataRowBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]


OnRowChanged Method (e)

OnRowChanged Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► OnRowChanged(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanged(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanged ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanged(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)"]


OnRowChanging Method (e)

OnRowChanging Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► OnRowChanging(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanging(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanging ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanging(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)"]


OnRowDeleted Method (e)

OnRowDeleted Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► OnRowDeleted(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleted(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleted ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleted(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)"]


OnRowDeleting Method (e)

OnRowDeleting Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► OnRowDeleting(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleting(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleting ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleting(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)"]


RemoveConditionCollectionsRow Method (row)

RemoveConditionCollectionsRow Method (row)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► RemoveConditionCollectionsRow(DSConditions..::.ConditionCollectionsRow)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsDataTable.RemoveConditionCollectionsRow(VisualCron.DSConditions.ConditionCollectionsRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void RemoveConditionCollectionsRow(
    DSConditions..::.ConditionCollectionsRow row
)
Public Sub RemoveConditionCollectionsRow ( _
    row As DSConditions..::.ConditionCollectionsRow _
)
public:
void RemoveConditionCollectionsRow(
    DSConditions..::.ConditionCollectionsRow^ row
)
Parameters
row (DSConditions..::.ConditionCollectionsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsDataTable.RemoveConditionCollectionsRow(VisualCron.DSConditions.ConditionCollectionsRow)"]


DSConditions.ConditionCollectionsRow Class

DSConditions..::.ConditionCollectionsRow Class
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionCollectionsRow
Represents strongly named DataRow class.
Declaration Syntax
C# Visual Basic Visual C++
public class ConditionCollectionsRow : DataRow
Public Class ConditionCollectionsRow _
    Inherits DataRow
public ref class ConditionCollectionsRow : public DataRow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()() | Commits all the changes made to this row since the last time AcceptChanges()()() was called. (Inherited from DataRow.)
 | BeginEdit()()() | Starts an edit operation on a DataRow object. (Inherited from DataRow.)
 | CancelEdit()()() | Cancels the current edit on the row. (Inherited from DataRow.)
 | ClearErrors()()() | Clears the errors for the row. This includes the RowError and errors set with SetColumnError(Int32, String). (Inherited from DataRow.)
 | Delete()()() | Deletes the DataRow. (Inherited from DataRow.)
 | EndEdit()()() | Ends the edit occurring on the row. (Inherited from DataRow.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetColumnError(Int32) | Gets the error description for the column specified by index. (Inherited from DataRow.)
 | GetColumnError(String) | Gets the error description for a column, specified by name. (Inherited from DataRow.)
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn. (Inherited from DataRow.)
 | GetColumnsInError()()() | Gets an array of columns that have errors. (Inherited from DataRow.)
 | GetConditionsRows()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasErrors | Gets a value that indicates whether there are errors in a row. (Inherited from DataRow.)
 | HasVersion(DataRowVersion) | Gets a value that indicates whether a specified version exists. (Inherited from DataRow.)
 | Id |
 | IsNameNull()()() |
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value. (Inherited from DataRow.)
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value. (Inherited from DataRow.)
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index. (Inherited from DataRow.)
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name. (Inherited from DataRow.)
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn. (Inherited from DataRow.)
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve. (Inherited from DataRow.)
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column. (Inherited from DataRow.)
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn. (Inherited from DataRow.)
 | ItemArray | Gets or sets all the values for this row through an array. (Inherited from DataRow.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | RejectChanges()()() | Rejects all changes made to the row since AcceptChanges()()() was last called. (Inherited from DataRow.)
 | RowError | Gets or sets the custom error description for a row. (Inherited from DataRow.)
 | RowState | Gets the current state of the row with regard to its relationship to the DataRowCollection. (Inherited from DataRow.)
 | SetAdded()()() | Changes the Rowstate()()() of a DataRow to Added. (Inherited from DataRow.)
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index. (Inherited from DataRow.)
 | SetColumnError(String, String) | Sets the error description for a column specified by name. (Inherited from DataRow.)
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn. (Inherited from DataRow.)
 | SetModified()()() | Changes the Rowstate()()() of a DataRow to Modified. (Inherited from DataRow.)
 | SetNameNull()()() |
 | SetNull(DataColumn) | Sets the value of the specified DataColumn to a null value. (Inherited from DataRow.)
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow. (Inherited from DataRow.)
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation. (Inherited from DataRow.)
 | Table | Gets the DataTable for which this row has a schema. (Inherited from DataRow.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataRow
 |  | DSConditions..::.ConditionCollectionsRow


GetConditionsRows Method

GetConditionsRows Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► GetConditionsRows()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsRow.GetConditionsRows]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionsRow[] GetConditionsRows()
Public Function GetConditionsRows As DSConditions..::.ConditionsRow()
public:
array<DSConditions..::.ConditionsRow^>^ GetConditionsRows()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsRow.GetConditionsRows]


Id Property

Id Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► Id

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsRow.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


IsNameNull Method

IsNameNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► IsNameNull()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsRow.IsNameNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsNameNull()
Public Function IsNameNull As Boolean
public:
bool IsNameNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionCollectionsRow.IsNameNull]


Name Property

Name Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► Name

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsRow.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


SetNameNull Method

SetNameNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► SetNameNull()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionCollectionsRow.SetNameNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetNameNull()
Public Sub SetNameNull
public:
void SetNameNull()


DSConditions.ConditionCollectionsRowChangeEvent Class

DSConditions..::.ConditionCollectionsRowChangeEvent Class
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionCollectionsRowChangeEvent
Row event argument class
Declaration Syntax
C# Visual Basic Visual C++
public class ConditionCollectionsRowChangeEvent : EventArgs
Public Class ConditionCollectionsRowChangeEvent _
    Inherits EventArgs
public ref class ConditionCollectionsRowChangeEvent : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSConditions..::.ConditionCollectionsRowChangeEvent(DSConditions..::.ConditionCollectionsRow, DataRowAction) | Initializes a new instance of the DSConditions..::.ConditionCollectionsRowChangeEvent class
 | Action |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Row |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DSConditions..::.ConditionCollectionsRowChangeEvent


DSConditions.ConditionCollectionsRowChangeEvent Constructor (row, action)

DSConditions..::.ConditionCollectionsRowChangeEvent Constructor (row, action)
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRowChangeEvent ► DSConditions..::.ConditionCollectionsRowChangeEvent(DSConditions..::.ConditionCollectionsRow, DataRowAction)
Initializes a new instance of the DSConditions..::.ConditionCollectionsRowChangeEvent class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionCollectionsRowChangeEvent(
    DSConditions..::.ConditionCollectionsRow row,
    DataRowAction action
)
Public Sub New ( _
    row As DSConditions..::.ConditionCollectionsRow, _
    action As DataRowAction _
)
public:
ConditionCollectionsRowChangeEvent(
    DSConditions..::.ConditionCollectionsRow^ row,
    DataRowAction action
)
Parameters
row (DSConditions..::.ConditionCollectionsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsRowChangeEvent.#ctor(VisualCron.DSConditions.ConditionCollectionsRow,System.Data.DataRowAction)"]

action (DataRowAction)

[Missing <param name="action"/> documentation for "M:VisualCron.DSConditions.ConditionCollectionsRowChangeEvent.#ctor(VisualCron.DSConditions.ConditionCollectionsRow,System.Data.DataRowAction)"]


Action Property

Action Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRowChangeEvent ► Action

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsRowChangeEvent.Action]

Declaration Syntax
C# Visual Basic Visual C++
public DataRowAction Action { get; }
Public ReadOnly Property Action As DataRowAction
public:
property DataRowAction Action {
    DataRowAction get ();
}


Row Property

Row Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRowChangeEvent ► Row

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionCollectionsRowChangeEvent.Row]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionCollectionsRow Row { get; }
Public ReadOnly Property Row As DSConditions..::.ConditionCollectionsRow
public:
property DSConditions..::.ConditionCollectionsRow^ Row {
    DSConditions..::.ConditionCollectionsRow^ get ();
}


DSConditions.ConditionCollectionsRowChangeEventHandler Delegate

DSConditions..::.ConditionCollectionsRowChangeEventHandler Delegate
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionCollectionsRowChangeEventHandler

[Missing <summary> documentation for T:VisualCron.DSConditions.ConditionCollectionsRowChangeEventHandler]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void ConditionCollectionsRowChangeEventHandler(
    Object sender,
    DSConditions..::.ConditionCollectionsRowChangeEvent e
)
Public Delegate Sub ConditionCollectionsRowChangeEventHandler ( _
    sender As Object, _
    e As DSConditions..::.ConditionCollectionsRowChangeEvent _
)
public delegate void ConditionCollectionsRowChangeEventHandler(
    Object^ sender,
    DSConditions..::.ConditionCollectionsRowChangeEvent^ e
)
Parameters
sender (Object)
e (DSConditions..::.ConditionCollectionsRowChangeEvent)


DSConditions.ConditionsDataTable Class

DSConditions..::.ConditionsDataTable Class
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionsDataTable
Represents the strongly named DataTable class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ConditionsDataTable : DataTable,
    IEnumerable
<SerializableAttribute> _
Public Class ConditionsDataTable _
    Inherits DataTable _
    Implements IEnumerable
[SerializableAttribute]
public ref class ConditionsDataTable : public DataTable,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSConditions..::.ConditionsDataTable()()() | Initializes a new instance of the DSConditions..::.ConditionsDataTable class
 | DSConditions..::.ConditionsDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSConditions..::.ConditionsDataTable class
 | AcceptChanges()()() | Commits all the changes made to this table since the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | AddConditionsRow(DSConditions..::.ConditionsRow) |
 | AddConditionsRow(String, DSConditions..::.ConditionCollectionsRow, String) |
 | BeginInit()()() | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | BeginLoadData()()() | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from DataTable.)
 | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from DataTable.)
 | ChildRelations | Gets the collection of child relations for this DataTable. (Inherited from DataTable.)
 | Clear()()() | Clears the DataTable of all data. (Inherited from DataTable.)
 | Clone()()() | (Overrides DataTable.Clone()()().)
 | CollectionIdColumn |
 | ColumnChanged | Occurs after a value has been changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | ColumnChanging | Occurs when a value is being changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | Columns | Gets the collection of columns that belong to this table. (Inherited from DataTable.)
 | Compute(String, String) | Computes the given expression on the current rows that pass the filter criteria. (Inherited from DataTable.)
 | ConditionsRowChanged |
 | ConditionsRowChanging |
 | ConditionsRowDeleted |
 | ConditionsRowDeleting |
 | ConditionTypeImageColumn |
 | Constraints | Gets the collection of constraints maintained by this table. (Inherited from DataTable.)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataTable. (Inherited from DataTable.)
 | Count |
 | CreateDataReader()()() | Returns a DataTableReader corresponding to the data within this DataTable. (Inherited from DataTable.)
 | CreateInstance()()() | (Overrides DataTable.CreateInstance()()().)
 | DataSet | Gets the DataSet to which this table belongs. (Inherited from DataTable.)
 | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from DataTable.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from DataTable.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | EndInit()()() | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | EndLoadData()()() | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from DataTable.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information. (Inherited from DataTable.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | FindById(String) |
 | fInitInProgress | (Inherited from DataTable.)
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called. (Inherited from DataTable.)
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataTable.)
 | GetEnumerator()()() |
 | GetErrors()()() | Gets an array of DataRow objects that contain errors. (Inherited from DataTable.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataTable. (Inherited from DataTable.)
 | GetRowType()()() | (Overrides DataTable.GetRowType()()().)
 | GetSchema()()() | (Inherited from DataTable.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedTableSchema(XmlSchemaSet) |
 | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs. (Inherited from DataTable.)
 | IdColumn |
 | ImportRow(DataRow) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values. (Inherited from DataTable.)
 | Initialized | Occurs after the DataTable is initialized. (Inherited from DataTable.)
 | IsInitialized | Gets a value that indicates whether the DataTable is initialized. (Inherited from DataTable.)
 | Item[([(Int32])]) |
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataTable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable. (Inherited from DataTable.)
 | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from DataTable.)
 | Namespace | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | NewConditionsRow()()() |
 | NewRow()()() | Creates a new DataRow with the same schema as the table. (Inherited from DataTable.)
 | NewRowArray(Int32) | (Inherited from DataTable.)
 | NewRowFromBuilder(DataRowBuilder) | (Overrides DataTable.NewRowFromBuilder(DataRowBuilder).)
 | OnColumnChanged(DataColumnChangeEventArgs) | Raises the ColumnChanged event. (Inherited from DataTable.)
 | OnColumnChanging(DataColumnChangeEventArgs) | Raises the ColumnChanging event. (Inherited from DataTable.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the PropertyChanged event. (Inherited from DataTable.)
 | OnRemoveColumn(DataColumn) | Notifies the DataTable that a DataColumn is being removed. (Inherited from DataTable.)
 | OnRowChanged(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanged(DataRowChangeEventArgs).)
 | OnRowChanging(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanging(DataRowChangeEventArgs).)
 | OnRowDeleted(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleted(DataRowChangeEventArgs).)
 | OnRowDeleting(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleting(DataRowChangeEventArgs).)
 | OnTableCleared(DataTableClearEventArgs) | Raises the TableCleared event. (Inherited from DataTable.)
 | OnTableClearing(DataTableClearEventArgs) | Raises the TableClearing event. (Inherited from DataTable.)
 | OnTableNewRow(DataTableNewRowEventArgs) | Raises the TableNewRow event. (Inherited from DataTable.)
 | ParentRelations | Gets the collection of parent relations for this DataTable. (Inherited from DataTable.)
 | Prefix | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table. (Inherited from DataTable.)
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream. (Inherited from DataTable.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream. (Inherited from DataTable.)
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSerializable(XmlReader) | (Inherited from DataTable.)
 | RejectChanges()()() | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | RemotingFormat | Gets or sets the serialization format. (Inherited from DataTable.)
 | RemoveConditionsRow(DSConditions..::.ConditionsRow) |
 | Reset()()() | Resets the DataTable to its original state. (Inherited from DataTable.)
 | RowChanged | Occurs after a DataRow has been changed successfully. (Inherited from DataTable.)
 | RowChanging | Occurs when a DataRow is changing. (Inherited from DataTable.)
 | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from DataTable.)
 | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from DataTable.)
 | Rows | Gets the collection of rows that belong to this table. (Inherited from DataTable.)
 | Select()()() | Gets an array of all DataRow objects. (Inherited from DataTable.)
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.) (Inherited from DataTable.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order. (Inherited from DataTable.)
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state. (Inherited from DataTable.)
 | Site | Gets or sets an ISite for the DataTable. (Inherited from DataTable.)
 | TableCleared | Occurs after a DataTable is cleared. (Inherited from DataTable.)
 | TableClearing | Occurs when a DataTable is cleared. (Inherited from DataTable.)
 | TableName | Gets or sets the name of the DataTable. (Inherited from DataTable.)
 | TableNewRow | Occurs when a new DataRow is inserted. (Inherited from DataTable.)
 | ToString()()() | Gets the TableName and DisplayExpression, if there is one as a concatenated string. (Inherited from DataTable.)
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream. (Inherited from DataTable.)
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter. (Inherited from DataTable.)
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file. (Inherited from DataTable.)
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream. (Inherited from DataTable.)
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file. (Inherited from DataTable.)
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataTable
 |  |  | DSConditions..::.ConditionsDataTable


DSConditions.ConditionsDataTable Constructor

DSConditions..::.ConditionsDataTable Constructor
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► DSConditions..::.ConditionsDataTable()()()
Members
Icon | Member | Description
 | DSConditions..::.ConditionsDataTable()()() | Initializes a new instance of the DSConditions..::.ConditionsDataTable class
 | DSConditions..::.ConditionsDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSConditions..::.ConditionsDataTable class


DSConditions.ConditionsDataTable Constructor

DSConditions..::.ConditionsDataTable Constructor
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► DSConditions..::.ConditionsDataTable()()()
Initializes a new instance of the DSConditions..::.ConditionsDataTable class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionsDataTable()
Public Sub New
public:
ConditionsDataTable()


DSConditions.ConditionsDataTable Constructor (info, context)

DSConditions..::.ConditionsDataTable Constructor (info, context)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► DSConditions..::.ConditionsDataTable(SerializationInfo, StreamingContext)
Initializes a new instance of the DSConditions..::.ConditionsDataTable class
Declaration Syntax
C# Visual Basic Visual C++
protected ConditionsDataTable(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
ConditionsDataTable(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


AddConditionsRow Method

AddConditionsRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► AddConditionsRow()()()
Members
Icon | Member | Description
 | AddConditionsRow(DSConditions..::.ConditionsRow) |
 | AddConditionsRow(String, DSConditions..::.ConditionCollectionsRow, String) |


AddConditionsRow Method (Id, parentConditionCollectionsRowByFK_ConditionCollections_Conditions, ConditionTypeImage)

AddConditionsRow Method (Id, parentConditionCollectionsRowByFK_ConditionCollections_Conditions, ConditionTypeImage)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► AddConditionsRow(String, DSConditions..::.ConditionCollectionsRow, String)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.AddConditionsRow(System.String,VisualCron.DSConditions.ConditionCollectionsRow,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionsRow AddConditionsRow(
    string Id,
    DSConditions..::.ConditionCollectionsRow parentConditionCollectionsRowByFK_ConditionCollections_Conditions,
    string ConditionTypeImage
)
Public Function AddConditionsRow ( _
    Id As String, _
    parentConditionCollectionsRowByFK_ConditionCollections_Conditions As DSConditions..::.ConditionCollectionsRow, _
    ConditionTypeImage As String _
) As DSConditions..::.ConditionsRow
public:
DSConditions..::.ConditionsRow^ AddConditionsRow(
    String^ Id,
    DSConditions..::.ConditionCollectionsRow^ parentConditionCollectionsRowByFK_ConditionCollections_Conditions,
    String^ ConditionTypeImage
)
Parameters
Id (String)

[Missing <param name="Id"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.AddConditionsRow(System.String,VisualCron.DSConditions.ConditionCollectionsRow,System.String)"]

parentConditionCollectionsRowByFK_ConditionCollections_Conditions (DSConditions..::.ConditionCollectionsRow)

[Missing <param name="parentConditionCollectionsRowByFK_ConditionCollections_Conditions"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.AddConditionsRow(System.String,VisualCron.DSConditions.ConditionCollectionsRow,System.String)"]

ConditionTypeImage (String)

[Missing <param name="ConditionTypeImage"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.AddConditionsRow(System.String,VisualCron.DSConditions.ConditionCollectionsRow,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.AddConditionsRow(System.String,VisualCron.DSConditions.ConditionCollectionsRow,System.String)]


AddConditionsRow Method (row)

AddConditionsRow Method (row)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► AddConditionsRow(DSConditions..::.ConditionsRow)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.AddConditionsRow(VisualCron.DSConditions.ConditionsRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddConditionsRow(
    DSConditions..::.ConditionsRow row
)
Public Sub AddConditionsRow ( _
    row As DSConditions..::.ConditionsRow _
)
public:
void AddConditionsRow(
    DSConditions..::.ConditionsRow^ row
)
Parameters
row (DSConditions..::.ConditionsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.AddConditionsRow(VisualCron.DSConditions.ConditionsRow)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataTable Clone()
Public Overrides Function Clone As DataTable
public:
virtual DataTable^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.Clone]


CollectionIdColumn Property

CollectionIdColumn Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► CollectionIdColumn

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsDataTable.CollectionIdColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn CollectionIdColumn { get; }
Public ReadOnly Property CollectionIdColumn As DataColumn
public:
property DataColumn^ CollectionIdColumn {
    DataColumn^ get ();
}


ConditionsRowChanged Event

ConditionsRowChanged Event
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► ConditionsRowChanged

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionsDataTable.ConditionsRowChanged]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionsRowChangeEventHandler ConditionsRowChanged
Public Event ConditionsRowChanged As DSConditions..::.ConditionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionsRowChangeEventHandler^ ConditionsRowChanged {
    void add (DSConditions..::.ConditionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionsRowChangeEventHandler^ value);
}


ConditionsRowChanging Event

ConditionsRowChanging Event
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► ConditionsRowChanging

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionsDataTable.ConditionsRowChanging]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionsRowChangeEventHandler ConditionsRowChanging
Public Event ConditionsRowChanging As DSConditions..::.ConditionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionsRowChangeEventHandler^ ConditionsRowChanging {
    void add (DSConditions..::.ConditionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionsRowChangeEventHandler^ value);
}


ConditionsRowDeleted Event

ConditionsRowDeleted Event
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► ConditionsRowDeleted

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionsDataTable.ConditionsRowDeleted]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionsRowChangeEventHandler ConditionsRowDeleted
Public Event ConditionsRowDeleted As DSConditions..::.ConditionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionsRowChangeEventHandler^ ConditionsRowDeleted {
    void add (DSConditions..::.ConditionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionsRowChangeEventHandler^ value);
}


ConditionsRowDeleting Event

ConditionsRowDeleting Event
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► ConditionsRowDeleting

[Missing <summary> documentation for E:VisualCron.DSConditions.ConditionsDataTable.ConditionsRowDeleting]

Declaration Syntax
C# Visual Basic Visual C++
public event DSConditions..::.ConditionsRowChangeEventHandler ConditionsRowDeleting
Public Event ConditionsRowDeleting As DSConditions..::.ConditionsRowChangeEventHandler
public:
 event DSConditions..::.ConditionsRowChangeEventHandler^ ConditionsRowDeleting {
    void add (DSConditions..::.ConditionsRowChangeEventHandler^ value);
    void remove (DSConditions..::.ConditionsRowChangeEventHandler^ value);
}


ConditionTypeImageColumn Property

ConditionTypeImageColumn Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► ConditionTypeImageColumn

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsDataTable.ConditionTypeImageColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn ConditionTypeImageColumn { get; }
Public ReadOnly Property ConditionTypeImageColumn As DataColumn
public:
property DataColumn^ ConditionTypeImageColumn {
    DataColumn^ get ();
}


Count Property

Count Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► Count

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsDataTable.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


CreateInstance Method

CreateInstance Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► CreateInstance()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.CreateInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataTable CreateInstance()
Protected Overrides Function CreateInstance As DataTable
protected:
virtual DataTable^ CreateInstance() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.CreateInstance]


FindById Method (Id)

FindById Method (Id)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► FindById(String)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.FindById(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionsRow FindById(
    string Id
)
Public Function FindById ( _
    Id As String _
) As DSConditions..::.ConditionsRow
public:
DSConditions..::.ConditionsRow^ FindById(
    String^ Id
)
Parameters
Id (String)

[Missing <param name="Id"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.FindById(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.FindById(System.String)]


GetEnumerator Method

GetEnumerator Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► GetEnumerator()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.GetEnumerator]


GetRowType Method

GetRowType Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► GetRowType()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.GetRowType]

Declaration Syntax
C# Visual Basic Visual C++
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
protected:
virtual Type^ GetRowType() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.GetRowType]


GetTypedTableSchema Method (xs)

GetTypedTableSchema Method (xs)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► GetTypedTableSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedTableSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedTableSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedTableSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]


IdColumn Property

IdColumn Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► IdColumn

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsDataTable.IdColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn IdColumn { get; }
Public ReadOnly Property IdColumn As DataColumn
public:
property DataColumn^ IdColumn {
    DataColumn^ get ();
}


Item Property (index)

Item Property (index)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► Item[([(Int32])])

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsDataTable.Item(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionsRow this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DSConditions..::.ConditionsRow
public:
property DSConditions..::.ConditionsRow^ default[int index] {
    DSConditions..::.ConditionsRow^ get (int index);
}
Parameters
index (Int32)


NewConditionsRow Method

NewConditionsRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► NewConditionsRow()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.NewConditionsRow]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionsRow NewConditionsRow()
Public Function NewConditionsRow As DSConditions..::.ConditionsRow
public:
DSConditions..::.ConditionsRow^ NewConditionsRow()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.NewConditionsRow]


NewRowFromBuilder Method (builder)

NewRowFromBuilder Method (builder)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► NewRowFromBuilder(DataRowBuilder)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder ( _
    builder As DataRowBuilder _
) As DataRow
protected:
virtual DataRow^ NewRowFromBuilder(
    DataRowBuilder^ builder
) override
Parameters
builder (DataRowBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]


OnRowChanged Method (e)

OnRowChanged Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► OnRowChanged(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanged(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanged ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanged(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)"]


OnRowChanging Method (e)

OnRowChanging Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► OnRowChanging(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanging(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanging ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanging(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)"]


OnRowDeleted Method (e)

OnRowDeleted Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► OnRowDeleted(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleted(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleted ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleted(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)"]


OnRowDeleting Method (e)

OnRowDeleting Method (e)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► OnRowDeleting(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleting(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleting ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleting(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)"]


RemoveConditionsRow Method (row)

RemoveConditionsRow Method (row)
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► RemoveConditionsRow(DSConditions..::.ConditionsRow)

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsDataTable.RemoveConditionsRow(VisualCron.DSConditions.ConditionsRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void RemoveConditionsRow(
    DSConditions..::.ConditionsRow row
)
Public Sub RemoveConditionsRow ( _
    row As DSConditions..::.ConditionsRow _
)
public:
void RemoveConditionsRow(
    DSConditions..::.ConditionsRow^ row
)
Parameters
row (DSConditions..::.ConditionsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSConditions.ConditionsDataTable.RemoveConditionsRow(VisualCron.DSConditions.ConditionsRow)"]


DSConditions.ConditionsRow Class

DSConditions..::.ConditionsRow Class
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionsRow
Represents strongly named DataRow class.
Declaration Syntax
C# Visual Basic Visual C++
public class ConditionsRow : DataRow
Public Class ConditionsRow _
    Inherits DataRow
public ref class ConditionsRow : public DataRow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()() | Commits all the changes made to this row since the last time AcceptChanges()()() was called. (Inherited from DataRow.)
 | BeginEdit()()() | Starts an edit operation on a DataRow object. (Inherited from DataRow.)
 | CancelEdit()()() | Cancels the current edit on the row. (Inherited from DataRow.)
 | ClearErrors()()() | Clears the errors for the row. This includes the RowError and errors set with SetColumnError(Int32, String). (Inherited from DataRow.)
 | CollectionId |
 | ConditionCollectionsRow |
 | ConditionTypeImage |
 | Delete()()() | Deletes the DataRow. (Inherited from DataRow.)
 | EndEdit()()() | Ends the edit occurring on the row. (Inherited from DataRow.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetColumnError(Int32) | Gets the error description for the column specified by index. (Inherited from DataRow.)
 | GetColumnError(String) | Gets the error description for a column, specified by name. (Inherited from DataRow.)
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn. (Inherited from DataRow.)
 | GetColumnsInError()()() | Gets an array of columns that have errors. (Inherited from DataRow.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasErrors | Gets a value that indicates whether there are errors in a row. (Inherited from DataRow.)
 | HasVersion(DataRowVersion) | Gets a value that indicates whether a specified version exists. (Inherited from DataRow.)
 | Id |
 | IsCollectionIdNull()()() |
 | IsConditionTypeImageNull()()() |
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value. (Inherited from DataRow.)
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value. (Inherited from DataRow.)
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index. (Inherited from DataRow.)
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name. (Inherited from DataRow.)
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn. (Inherited from DataRow.)
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve. (Inherited from DataRow.)
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column. (Inherited from DataRow.)
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn. (Inherited from DataRow.)
 | ItemArray | Gets or sets all the values for this row through an array. (Inherited from DataRow.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RejectChanges()()() | Rejects all changes made to the row since AcceptChanges()()() was last called. (Inherited from DataRow.)
 | RowError | Gets or sets the custom error description for a row. (Inherited from DataRow.)
 | RowState | Gets the current state of the row with regard to its relationship to the DataRowCollection. (Inherited from DataRow.)
 | SetAdded()()() | Changes the Rowstate()()() of a DataRow to Added. (Inherited from DataRow.)
 | SetCollectionIdNull()()() |
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index. (Inherited from DataRow.)
 | SetColumnError(String, String) | Sets the error description for a column specified by name. (Inherited from DataRow.)
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn. (Inherited from DataRow.)
 | SetConditionTypeImageNull()()() |
 | SetModified()()() | Changes the Rowstate()()() of a DataRow to Modified. (Inherited from DataRow.)
 | SetNull(DataColumn) | Sets the value of the specified DataColumn to a null value. (Inherited from DataRow.)
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow. (Inherited from DataRow.)
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation. (Inherited from DataRow.)
 | Table | Gets the DataTable for which this row has a schema. (Inherited from DataRow.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataRow
 |  | DSConditions..::.ConditionsRow


CollectionId Property

CollectionId Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► CollectionId

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsRow.CollectionId]

Declaration Syntax
C# Visual Basic Visual C++
public string CollectionId { get; set; }
Public Property CollectionId As String
public:
property String^ CollectionId {
    String^ get ();
    void set (String^ value);
}


ConditionCollectionsRow Property

ConditionCollectionsRow Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► ConditionCollectionsRow

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsRow.ConditionCollectionsRow]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionCollectionsRow ConditionCollectionsRow { get; set; }
Public Property ConditionCollectionsRow As DSConditions..::.ConditionCollectionsRow
public:
property DSConditions..::.ConditionCollectionsRow^ ConditionCollectionsRow {
    DSConditions..::.ConditionCollectionsRow^ get ();
    void set (DSConditions..::.ConditionCollectionsRow^ value);
}


ConditionTypeImage Property

ConditionTypeImage Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► ConditionTypeImage

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsRow.ConditionTypeImage]

Declaration Syntax
C# Visual Basic Visual C++
public string ConditionTypeImage { get; set; }
Public Property ConditionTypeImage As String
public:
property String^ ConditionTypeImage {
    String^ get ();
    void set (String^ value);
}


Id Property

Id Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► Id

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsRow.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


IsCollectionIdNull Method

IsCollectionIdNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► IsCollectionIdNull()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsRow.IsCollectionIdNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsCollectionIdNull()
Public Function IsCollectionIdNull As Boolean
public:
bool IsCollectionIdNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsRow.IsCollectionIdNull]


IsConditionTypeImageNull Method

IsConditionTypeImageNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► IsConditionTypeImageNull()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsRow.IsConditionTypeImageNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsConditionTypeImageNull()
Public Function IsConditionTypeImageNull As Boolean
public:
bool IsConditionTypeImageNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSConditions.ConditionsRow.IsConditionTypeImageNull]


SetCollectionIdNull Method

SetCollectionIdNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► SetCollectionIdNull()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsRow.SetCollectionIdNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetCollectionIdNull()
Public Sub SetCollectionIdNull
public:
void SetCollectionIdNull()


SetConditionTypeImageNull Method

SetConditionTypeImageNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► SetConditionTypeImageNull()()()

[Missing <summary> documentation for M:VisualCron.DSConditions.ConditionsRow.SetConditionTypeImageNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetConditionTypeImageNull()
Public Sub SetConditionTypeImageNull
public:
void SetConditionTypeImageNull()


DSConditions.ConditionsRowChangeEvent Class

DSConditions..::.ConditionsRowChangeEvent Class
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionsRowChangeEvent
Row event argument class
Declaration Syntax
C# Visual Basic Visual C++
public class ConditionsRowChangeEvent : EventArgs
Public Class ConditionsRowChangeEvent _
    Inherits EventArgs
public ref class ConditionsRowChangeEvent : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSConditions..::.ConditionsRowChangeEvent(DSConditions..::.ConditionsRow, DataRowAction) | Initializes a new instance of the DSConditions..::.ConditionsRowChangeEvent class
 | Action |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Row |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DSConditions..::.ConditionsRowChangeEvent


DSConditions.ConditionsRowChangeEvent Constructor (row, action)

DSConditions..::.ConditionsRowChangeEvent Constructor (row, action)
Namespaces ► VisualCron ► DSConditions..::.ConditionsRowChangeEvent ► DSConditions..::.ConditionsRowChangeEvent(DSConditions..::.ConditionsRow, DataRowAction)
Initializes a new instance of the DSConditions..::.ConditionsRowChangeEvent class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionsRowChangeEvent(
    DSConditions..::.ConditionsRow row,
    DataRowAction action
)
Public Sub New ( _
    row As DSConditions..::.ConditionsRow, _
    action As DataRowAction _
)
public:
ConditionsRowChangeEvent(
    DSConditions..::.ConditionsRow^ row,
    DataRowAction action
)
Parameters
row (DSConditions..::.ConditionsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSConditions.ConditionsRowChangeEvent.#ctor(VisualCron.DSConditions.ConditionsRow,System.Data.DataRowAction)"]

action (DataRowAction)

[Missing <param name="action"/> documentation for "M:VisualCron.DSConditions.ConditionsRowChangeEvent.#ctor(VisualCron.DSConditions.ConditionsRow,System.Data.DataRowAction)"]


Action Property

Action Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsRowChangeEvent ► Action

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsRowChangeEvent.Action]

Declaration Syntax
C# Visual Basic Visual C++
public DataRowAction Action { get; }
Public ReadOnly Property Action As DataRowAction
public:
property DataRowAction Action {
    DataRowAction get ();
}


Row Property

Row Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsRowChangeEvent ► Row

[Missing <summary> documentation for P:VisualCron.DSConditions.ConditionsRowChangeEvent.Row]

Declaration Syntax
C# Visual Basic Visual C++
public DSConditions..::.ConditionsRow Row { get; }
Public ReadOnly Property Row As DSConditions..::.ConditionsRow
public:
property DSConditions..::.ConditionsRow^ Row {
    DSConditions..::.ConditionsRow^ get ();
}


DSConditions.ConditionsRowChangeEventHandler Delegate

DSConditions..::.ConditionsRowChangeEventHandler Delegate
Namespaces ► VisualCron ► DSConditions ► DSConditions..::.ConditionsRowChangeEventHandler

[Missing <summary> documentation for T:VisualCron.DSConditions.ConditionsRowChangeEventHandler]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void ConditionsRowChangeEventHandler(
    Object sender,
    DSConditions..::.ConditionsRowChangeEvent e
)
Public Delegate Sub ConditionsRowChangeEventHandler ( _
    sender As Object, _
    e As DSConditions..::.ConditionsRowChangeEvent _
)
public delegate void ConditionsRowChangeEventHandler(
    Object^ sender,
    DSConditions..::.ConditionsRowChangeEvent^ e
)
Parameters
sender (Object)
e (DSConditions..::.ConditionsRowChangeEvent)


DSCopyFiles Class

DSCopyFiles Class
Namespaces ► VisualCron ► DSCopyFiles
Represents a strongly typed in-memory cache of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DSCopyFiles : DataSet
<SerializableAttribute> _
Public Class DSCopyFiles _
    Inherits DataSet
[SerializableAttribute]
public ref class DSCopyFiles : public DataSet
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSCopyFiles()()() | Initializes a new instance of the DSCopyFiles class
 | DSCopyFiles(SerializationInfo, StreamingContext) | Initializes a new instance of the DSCopyFiles class
 | AcceptChanges()()() | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | BeginInit()()() | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | CaseSensitive | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive. (Inherited from DataSet.)
 | Clear()()() | Clears the DataSet of any data by removing all rows in all tables. (Inherited from DataSet.)
 | Clone()()() | (Overrides DataSet.Clone()()().)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataSet. (Inherited from DataSet.)
 | CopyFiles |
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection. (Inherited from DataSet.)
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable. (Inherited from DataSet.)
 | DataSetName | Gets or sets the name of the current DataSet. (Inherited from DataSet.)
 | DefaultViewManager | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager. (Inherited from DataSet.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | EndInit()()() | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from DataSet.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from DataSet.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called. (Inherited from DataSet.)
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataSet.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataSet. (Inherited from DataSet.)
 | GetSchemaSerializable()()() | (Overrides DataSet.GetSchemaSerializable()()().)
 | GetSerializationData(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedDataSetSchema(XmlSchemaSet) |
 | GetXml()()() | Returns the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | GetXmlSchema()()() | Returns the XML Schema for the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows. (Inherited from DataSet.)
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState. (Inherited from DataSet.)
 | HasErrors | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet. (Inherited from DataSet.)
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet. (Inherited from DataSet.)
 | Initialized | Occurs after the DataSet is initialized. (Inherited from DataSet.)
 | InitializeDerivedDataSet()()() | (Overrides DataSet.InitializeDerivedDataSet()()().)
 | IsBinarySerialized(SerializationInfo, StreamingContext) | Inspects the format of the serialized representation of the DataSet. (Inherited from DataSet.)
 | IsInitialized | Gets a value that indicates whether the DataSet is initialized. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet. (Inherited from DataSet.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataSet.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument. (Inherited from DataSet.)
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | MergeFailed | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true. (Inherited from DataSet.)
 | Namespace | Gets or sets the namespace of the DataSet. (Inherited from DataSet.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the OnPropertyChanging(PropertyChangedEventArgs) event. (Inherited from DataSet.)
 | OnRemoveRelation(DataRelation) | Occurs when a DataRelation object is removed from a DataTable. (Inherited from DataSet.)
 | OnRemoveTable(DataTable) | Occurs when a DataTable is removed from a DataSet. (Inherited from DataSet.)
 | Prefix | Gets or sets an XML prefix that aliases the namespace of the DataSet. (Inherited from DataSet.)
 | RaisePropertyChanging(String) | Sends a notification that the specified DataSet property is about to change. (Inherited from DataSet.)
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader. (Inherited from DataSet.)
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream. (Inherited from DataSet.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader. (Inherited from DataSet.)
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file. (Inherited from DataSet.)
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode. (Inherited from DataSet.)
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet. (Inherited from DataSet.)
 | ReadXmlSerializable(XmlReader) | (Overrides DataSet.ReadXmlSerializable(XmlReader).)
 | RejectChanges()()() | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | Relations |
 | RemotingFormat | Gets or sets a SerializationFormat for the DataSet used during remoting. (Inherited from DataSet.)
 | Reset()()() | Resets the DataSet to its original state. Subclasses should override Reset()()() to restore a DataSet to its original state. (Inherited from DataSet.)
 | SchemaSerializationMode | (Overrides DataSet.SchemaSerializationMode.)
 | ShouldSerializeRelations()()() | (Overrides DataSet.ShouldSerializeRelations()()().)
 | ShouldSerializeTables()()() | (Overrides DataSet.ShouldSerializeTables()()().)
 | Site | Gets or sets an ISite for the DataSet. (Inherited from DataSet.)
 | Tables |
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream. (Inherited from DataSet.)
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter. (Inherited from DataSet.)
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter. (Inherited from DataSet.)
 | WriteXml(String) | Writes the current data for the DataSet to the specified file. (Inherited from DataSet.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object. (Inherited from DataSet.)
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file. (Inherited from DataSet.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataSet
 |  |  | DSCopyFiles


DSCopyFiles Constructor

DSCopyFiles Constructor
Namespaces ► VisualCron ► DSCopyFiles ► DSCopyFiles()()()
Members
Icon | Member | Description
 | DSCopyFiles()()() | Initializes a new instance of the DSCopyFiles class
 | DSCopyFiles(SerializationInfo, StreamingContext) | Initializes a new instance of the DSCopyFiles class


DSCopyFiles Constructor

DSCopyFiles Constructor
Namespaces ► VisualCron ► DSCopyFiles ► DSCopyFiles()()()
Initializes a new instance of the DSCopyFiles class
Declaration Syntax
C# Visual Basic Visual C++
public DSCopyFiles()
Public Sub New
public:
DSCopyFiles()


DSCopyFiles Constructor (info, context)

DSCopyFiles Constructor (info, context)
Namespaces ► VisualCron ► DSCopyFiles ► DSCopyFiles(SerializationInfo, StreamingContext)
Initializes a new instance of the DSCopyFiles class
Declaration Syntax
C# Visual Basic Visual C++
protected DSCopyFiles(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DSCopyFiles(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSCopyFiles.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSCopyFiles.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSCopyFiles ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataSet Clone()
Public Overrides Function Clone As DataSet
public:
virtual DataSet^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.Clone]


CopyFiles Property

CopyFiles Property
Namespaces ► VisualCron ► DSCopyFiles ► CopyFiles

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFiles]

Declaration Syntax
C# Visual Basic Visual C++
public DSCopyFiles..::.CopyFilesDataTable CopyFiles { get; }
Public ReadOnly Property CopyFiles As DSCopyFiles..::.CopyFilesDataTable
public:
property DSCopyFiles..::.CopyFilesDataTable^ CopyFiles {
    DSCopyFiles..::.CopyFilesDataTable^ get ();
}


GetSchemaSerializable Method

GetSchemaSerializable Method
Namespaces ► VisualCron ► DSCopyFiles ► GetSchemaSerializable()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.GetSchemaSerializable]

Declaration Syntax
C# Visual Basic Visual C++
protected override XmlSchema GetSchemaSerializable()
Protected Overrides Function GetSchemaSerializable As XmlSchema
protected:
virtual XmlSchema^ GetSchemaSerializable() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.GetSchemaSerializable]


GetTypedDataSetSchema Method (xs)

GetTypedDataSetSchema Method (xs)
Namespaces ► VisualCron ► DSCopyFiles ► GetTypedDataSetSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedDataSetSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedDataSetSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedDataSetSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSCopyFiles.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]


InitializeDerivedDataSet Method

InitializeDerivedDataSet Method
Namespaces ► VisualCron ► DSCopyFiles ► InitializeDerivedDataSet()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.InitializeDerivedDataSet]

Declaration Syntax
C# Visual Basic Visual C++
protected override void InitializeDerivedDataSet()
Protected Overrides Sub InitializeDerivedDataSet
protected:
virtual void InitializeDerivedDataSet() override


ReadXmlSerializable Method (reader)

ReadXmlSerializable Method (reader)
Namespaces ► VisualCron ► DSCopyFiles ► ReadXmlSerializable(XmlReader)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.ReadXmlSerializable(System.Xml.XmlReader)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void ReadXmlSerializable(
    XmlReader reader
)
Protected Overrides Sub ReadXmlSerializable ( _
    reader As XmlReader _
)
protected:
virtual void ReadXmlSerializable(
    XmlReader^ reader
) override
Parameters
reader (XmlReader)

[Missing <param name="reader"/> documentation for "M:VisualCron.DSCopyFiles.ReadXmlSerializable(System.Xml.XmlReader)"]


Relations Property

Relations Property
Namespaces ► VisualCron ► DSCopyFiles ► Relations

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.Relations]

Declaration Syntax
C# Visual Basic Visual C++
public DataRelationCollection Relations { get; }
Public ReadOnly Property Relations As DataRelationCollection
public:
property DataRelationCollection^ Relations {
    DataRelationCollection^ get ();
}


SchemaSerializationMode Property

SchemaSerializationMode Property
Namespaces ► VisualCron ► DSCopyFiles ► SchemaSerializationMode

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.SchemaSerializationMode]

Declaration Syntax
C# Visual Basic Visual C++
public override SchemaSerializationMode SchemaSerializationMode { get; set; }
Public Overrides Property SchemaSerializationMode As SchemaSerializationMode
public:
virtual property SchemaSerializationMode SchemaSerializationMode {
    SchemaSerializationMode get () override;
    void set (SchemaSerializationMode value) override;
}


ShouldSerializeRelations Method

ShouldSerializeRelations Method
Namespaces ► VisualCron ► DSCopyFiles ► ShouldSerializeRelations()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.ShouldSerializeRelations]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeRelations()
Protected Overrides Function ShouldSerializeRelations As Boolean
protected:
virtual bool ShouldSerializeRelations() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.ShouldSerializeRelations]


ShouldSerializeTables Method

ShouldSerializeTables Method
Namespaces ► VisualCron ► DSCopyFiles ► ShouldSerializeTables()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.ShouldSerializeTables]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeTables()
Protected Overrides Function ShouldSerializeTables As Boolean
protected:
virtual bool ShouldSerializeTables() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.ShouldSerializeTables]


Tables Property

Tables Property
Namespaces ► VisualCron ► DSCopyFiles ► Tables

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.Tables]

Declaration Syntax
C# Visual Basic Visual C++
public DataTableCollection Tables { get; }
Public ReadOnly Property Tables As DataTableCollection
public:
property DataTableCollection^ Tables {
    DataTableCollection^ get ();
}


DSCopyFiles.CopyFilesDataTable Class

DSCopyFiles..::.CopyFilesDataTable Class
Namespaces ► VisualCron ► DSCopyFiles ► DSCopyFiles..::.CopyFilesDataTable
Represents the strongly named DataTable class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class CopyFilesDataTable : DataTable,
    IEnumerable
<SerializableAttribute> _
Public Class CopyFilesDataTable _
    Inherits DataTable _
    Implements IEnumerable
[SerializableAttribute]
public ref class CopyFilesDataTable : public DataTable,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSCopyFiles..::.CopyFilesDataTable()()() | Initializes a new instance of the DSCopyFiles..::.CopyFilesDataTable class
 | DSCopyFiles..::.CopyFilesDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSCopyFiles..::.CopyFilesDataTable class
 | AcceptChanges()()() | Commits all the changes made to this table since the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | AddCopyFilesRow(DSCopyFiles..::.CopyFilesRow) |
 | AddCopyFilesRow(String, Int32, String, String, String) |
 | BeginInit()()() | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | BeginLoadData()()() | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from DataTable.)
 | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from DataTable.)
 | ChildRelations | Gets the collection of child relations for this DataTable. (Inherited from DataTable.)
 | Clear()()() | Clears the DataTable of all data. (Inherited from DataTable.)
 | Clone()()() | (Overrides DataTable.Clone()()().)
 | ColumnChanged | Occurs after a value has been changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | ColumnChanging | Occurs when a value is being changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | Columns | Gets the collection of columns that belong to this table. (Inherited from DataTable.)
 | Compute(String, String) | Computes the given expression on the current rows that pass the filter criteria. (Inherited from DataTable.)
 | Constraints | Gets the collection of constraints maintained by this table. (Inherited from DataTable.)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataTable. (Inherited from DataTable.)
 | CopyFileIdColumn |
 | CopyFilesRowChanged |
 | CopyFilesRowChanging |
 | CopyFilesRowDeleted |
 | CopyFilesRowDeleting |
 | Count |
 | CreateDataReader()()() | Returns a DataTableReader corresponding to the data within this DataTable. (Inherited from DataTable.)
 | CreateInstance()()() | (Overrides DataTable.CreateInstance()()().)
 | DataSet | Gets the DataSet to which this table belongs. (Inherited from DataTable.)
 | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from DataTable.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DestinationDirectoryColumn |
 | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from DataTable.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | EndInit()()() | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | EndLoadData()()() | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from DataTable.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information. (Inherited from DataTable.)
 | FileMaskColumn |
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | FindByCopyFileId(String) |
 | fInitInProgress | (Inherited from DataTable.)
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called. (Inherited from DataTable.)
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataTable.)
 | GetEnumerator()()() |
 | GetErrors()()() | Gets an array of DataRow objects that contain errors. (Inherited from DataTable.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataTable. (Inherited from DataTable.)
 | GetRowType()()() | (Overrides DataTable.GetRowType()()().)
 | GetSchema()()() | (Inherited from DataTable.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedTableSchema(XmlSchemaSet) |
 | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs. (Inherited from DataTable.)
 | ImportRow(DataRow) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values. (Inherited from DataTable.)
 | Initialized | Occurs after the DataTable is initialized. (Inherited from DataTable.)
 | IsInitialized | Gets a value that indicates whether the DataTable is initialized. (Inherited from DataTable.)
 | Item[([(Int32])]) |
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataTable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable. (Inherited from DataTable.)
 | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from DataTable.)
 | Namespace | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | NewCopyFilesRow()()() |
 | NewRow()()() | Creates a new DataRow with the same schema as the table. (Inherited from DataTable.)
 | NewRowArray(Int32) | (Inherited from DataTable.)
 | NewRowFromBuilder(DataRowBuilder) | (Overrides DataTable.NewRowFromBuilder(DataRowBuilder).)
 | OnColumnChanged(DataColumnChangeEventArgs) | Raises the ColumnChanged event. (Inherited from DataTable.)
 | OnColumnChanging(DataColumnChangeEventArgs) | Raises the ColumnChanging event. (Inherited from DataTable.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the PropertyChanged event. (Inherited from DataTable.)
 | OnRemoveColumn(DataColumn) | Notifies the DataTable that a DataColumn is being removed. (Inherited from DataTable.)
 | OnRowChanged(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanged(DataRowChangeEventArgs).)
 | OnRowChanging(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanging(DataRowChangeEventArgs).)
 | OnRowDeleted(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleted(DataRowChangeEventArgs).)
 | OnRowDeleting(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleting(DataRowChangeEventArgs).)
 | OnTableCleared(DataTableClearEventArgs) | Raises the TableCleared event. (Inherited from DataTable.)
 | OnTableClearing(DataTableClearEventArgs) | Raises the TableClearing event. (Inherited from DataTable.)
 | OnTableNewRow(DataTableNewRowEventArgs) | Raises the TableNewRow event. (Inherited from DataTable.)
 | OrderColumn |
 | ParentRelations | Gets the collection of parent relations for this DataTable. (Inherited from DataTable.)
 | Prefix | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table. (Inherited from DataTable.)
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream. (Inherited from DataTable.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream. (Inherited from DataTable.)
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSerializable(XmlReader) | (Inherited from DataTable.)
 | RejectChanges()()() | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | RemotingFormat | Gets or sets the serialization format. (Inherited from DataTable.)
 | RemoveCopyFilesRow(DSCopyFiles..::.CopyFilesRow) |
 | Reset()()() | Resets the DataTable to its original state. (Inherited from DataTable.)
 | RowChanged | Occurs after a DataRow has been changed successfully. (Inherited from DataTable.)
 | RowChanging | Occurs when a DataRow is changing. (Inherited from DataTable.)
 | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from DataTable.)
 | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from DataTable.)
 | Rows | Gets the collection of rows that belong to this table. (Inherited from DataTable.)
 | Select()()() | Gets an array of all DataRow objects. (Inherited from DataTable.)
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.) (Inherited from DataTable.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order. (Inherited from DataTable.)
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state. (Inherited from DataTable.)
 | Site | Gets or sets an ISite for the DataTable. (Inherited from DataTable.)
 | SourceDirectoryColumn |
 | TableCleared | Occurs after a DataTable is cleared. (Inherited from DataTable.)
 | TableClearing | Occurs when a DataTable is cleared. (Inherited from DataTable.)
 | TableName | Gets or sets the name of the DataTable. (Inherited from DataTable.)
 | TableNewRow | Occurs when a new DataRow is inserted. (Inherited from DataTable.)
 | ToString()()() | Gets the TableName and DisplayExpression, if there is one as a concatenated string. (Inherited from DataTable.)
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream. (Inherited from DataTable.)
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter. (Inherited from DataTable.)
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file. (Inherited from DataTable.)
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream. (Inherited from DataTable.)
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file. (Inherited from DataTable.)
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataTable
 |  |  | DSCopyFiles..::.CopyFilesDataTable


DSCopyFiles.CopyFilesDataTable Constructor

DSCopyFiles..::.CopyFilesDataTable Constructor
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► DSCopyFiles..::.CopyFilesDataTable()()()
Members
Icon | Member | Description
 | DSCopyFiles..::.CopyFilesDataTable()()() | Initializes a new instance of the DSCopyFiles..::.CopyFilesDataTable class
 | DSCopyFiles..::.CopyFilesDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSCopyFiles..::.CopyFilesDataTable class


DSCopyFiles.CopyFilesDataTable Constructor

DSCopyFiles..::.CopyFilesDataTable Constructor
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► DSCopyFiles..::.CopyFilesDataTable()()()
Initializes a new instance of the DSCopyFiles..::.CopyFilesDataTable class
Declaration Syntax
C# Visual Basic Visual C++
public CopyFilesDataTable()
Public Sub New
public:
CopyFilesDataTable()


DSCopyFiles.CopyFilesDataTable Constructor (info, context)

DSCopyFiles..::.CopyFilesDataTable Constructor (info, context)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► DSCopyFiles..::.CopyFilesDataTable(SerializationInfo, StreamingContext)
Initializes a new instance of the DSCopyFiles..::.CopyFilesDataTable class
Declaration Syntax
C# Visual Basic Visual C++
protected CopyFilesDataTable(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
CopyFilesDataTable(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


AddCopyFilesRow Method

AddCopyFilesRow Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► AddCopyFilesRow()()()
Members
Icon | Member | Description
 | AddCopyFilesRow(DSCopyFiles..::.CopyFilesRow) |
 | AddCopyFilesRow(String, Int32, String, String, String) |


AddCopyFilesRow Method (CopyFileId, Order, SourceDirectory, FileMask, DestinationDirectory)

AddCopyFilesRow Method (CopyFileId, Order, SourceDirectory, FileMask, DestinationDirectory)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► AddCopyFilesRow(String, Int32, String, String, String)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(System.String,System.Int32,System.String,System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSCopyFiles..::.CopyFilesRow AddCopyFilesRow(
    string CopyFileId,
    int Order,
    string SourceDirectory,
    string FileMask,
    string DestinationDirectory
)
Public Function AddCopyFilesRow ( _
    CopyFileId As String, _
    Order As Integer, _
    SourceDirectory As String, _
    FileMask As String, _
    DestinationDirectory As String _
) As DSCopyFiles..::.CopyFilesRow
public:
DSCopyFiles..::.CopyFilesRow^ AddCopyFilesRow(
    String^ CopyFileId,
    int Order,
    String^ SourceDirectory,
    String^ FileMask,
    String^ DestinationDirectory
)
Parameters
CopyFileId (String)

[Missing <param name="CopyFileId"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(System.String,System.Int32,System.String,System.String,System.String)"]

Order (Int32)

[Missing <param name="Order"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(System.String,System.Int32,System.String,System.String,System.String)"]

SourceDirectory (String)

[Missing <param name="SourceDirectory"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(System.String,System.Int32,System.String,System.String,System.String)"]

FileMask (String)

[Missing <param name="FileMask"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(System.String,System.Int32,System.String,System.String,System.String)"]

DestinationDirectory (String)

[Missing <param name="DestinationDirectory"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(System.String,System.Int32,System.String,System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(System.String,System.Int32,System.String,System.String,System.String)]


AddCopyFilesRow Method (row)

AddCopyFilesRow Method (row)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► AddCopyFilesRow(DSCopyFiles..::.CopyFilesRow)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(VisualCron.DSCopyFiles.CopyFilesRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddCopyFilesRow(
    DSCopyFiles..::.CopyFilesRow row
)
Public Sub AddCopyFilesRow ( _
    row As DSCopyFiles..::.CopyFilesRow _
)
public:
void AddCopyFilesRow(
    DSCopyFiles..::.CopyFilesRow^ row
)
Parameters
row (DSCopyFiles..::.CopyFilesRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.AddCopyFilesRow(VisualCron.DSCopyFiles.CopyFilesRow)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataTable Clone()
Public Overrides Function Clone As DataTable
public:
virtual DataTable^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.Clone]


CopyFileIdColumn Property

CopyFileIdColumn Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► CopyFileIdColumn

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesDataTable.CopyFileIdColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn CopyFileIdColumn { get; }
Public ReadOnly Property CopyFileIdColumn As DataColumn
public:
property DataColumn^ CopyFileIdColumn {
    DataColumn^ get ();
}


CopyFilesRowChanged Event

CopyFilesRowChanged Event
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► CopyFilesRowChanged

[Missing <summary> documentation for E:VisualCron.DSCopyFiles.CopyFilesDataTable.CopyFilesRowChanged]

Declaration Syntax
C# Visual Basic Visual C++
public event DSCopyFiles..::.CopyFilesRowChangeEventHandler CopyFilesRowChanged
Public Event CopyFilesRowChanged As DSCopyFiles..::.CopyFilesRowChangeEventHandler
public:
 event DSCopyFiles..::.CopyFilesRowChangeEventHandler^ CopyFilesRowChanged {
    void add (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
    void remove (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
}


CopyFilesRowChanging Event

CopyFilesRowChanging Event
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► CopyFilesRowChanging

[Missing <summary> documentation for E:VisualCron.DSCopyFiles.CopyFilesDataTable.CopyFilesRowChanging]

Declaration Syntax
C# Visual Basic Visual C++
public event DSCopyFiles..::.CopyFilesRowChangeEventHandler CopyFilesRowChanging
Public Event CopyFilesRowChanging As DSCopyFiles..::.CopyFilesRowChangeEventHandler
public:
 event DSCopyFiles..::.CopyFilesRowChangeEventHandler^ CopyFilesRowChanging {
    void add (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
    void remove (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
}


CopyFilesRowDeleted Event

CopyFilesRowDeleted Event
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► CopyFilesRowDeleted

[Missing <summary> documentation for E:VisualCron.DSCopyFiles.CopyFilesDataTable.CopyFilesRowDeleted]

Declaration Syntax
C# Visual Basic Visual C++
public event DSCopyFiles..::.CopyFilesRowChangeEventHandler CopyFilesRowDeleted
Public Event CopyFilesRowDeleted As DSCopyFiles..::.CopyFilesRowChangeEventHandler
public:
 event DSCopyFiles..::.CopyFilesRowChangeEventHandler^ CopyFilesRowDeleted {
    void add (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
    void remove (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
}


CopyFilesRowDeleting Event

CopyFilesRowDeleting Event
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► CopyFilesRowDeleting

[Missing <summary> documentation for E:VisualCron.DSCopyFiles.CopyFilesDataTable.CopyFilesRowDeleting]

Declaration Syntax
C# Visual Basic Visual C++
public event DSCopyFiles..::.CopyFilesRowChangeEventHandler CopyFilesRowDeleting
Public Event CopyFilesRowDeleting As DSCopyFiles..::.CopyFilesRowChangeEventHandler
public:
 event DSCopyFiles..::.CopyFilesRowChangeEventHandler^ CopyFilesRowDeleting {
    void add (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
    void remove (DSCopyFiles..::.CopyFilesRowChangeEventHandler^ value);
}


Count Property

Count Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► Count

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesDataTable.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


CreateInstance Method

CreateInstance Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► CreateInstance()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.CreateInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataTable CreateInstance()
Protected Overrides Function CreateInstance As DataTable
protected:
virtual DataTable^ CreateInstance() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.CreateInstance]


DestinationDirectoryColumn Property

DestinationDirectoryColumn Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► DestinationDirectoryColumn

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesDataTable.DestinationDirectoryColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn DestinationDirectoryColumn { get; }
Public ReadOnly Property DestinationDirectoryColumn As DataColumn
public:
property DataColumn^ DestinationDirectoryColumn {
    DataColumn^ get ();
}


FileMaskColumn Property

FileMaskColumn Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► FileMaskColumn

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesDataTable.FileMaskColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn FileMaskColumn { get; }
Public ReadOnly Property FileMaskColumn As DataColumn
public:
property DataColumn^ FileMaskColumn {
    DataColumn^ get ();
}


FindByCopyFileId Method (CopyFileId)

FindByCopyFileId Method (CopyFileId)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► FindByCopyFileId(String)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.FindByCopyFileId(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSCopyFiles..::.CopyFilesRow FindByCopyFileId(
    string CopyFileId
)
Public Function FindByCopyFileId ( _
    CopyFileId As String _
) As DSCopyFiles..::.CopyFilesRow
public:
DSCopyFiles..::.CopyFilesRow^ FindByCopyFileId(
    String^ CopyFileId
)
Parameters
CopyFileId (String)

[Missing <param name="CopyFileId"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.FindByCopyFileId(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.FindByCopyFileId(System.String)]


GetEnumerator Method

GetEnumerator Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► GetEnumerator()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.GetEnumerator]


GetRowType Method

GetRowType Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► GetRowType()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.GetRowType]

Declaration Syntax
C# Visual Basic Visual C++
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
protected:
virtual Type^ GetRowType() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.GetRowType]


GetTypedTableSchema Method (xs)

GetTypedTableSchema Method (xs)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► GetTypedTableSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedTableSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedTableSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedTableSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]


Item Property (index)

Item Property (index)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► Item[([(Int32])])

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesDataTable.Item(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public DSCopyFiles..::.CopyFilesRow this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DSCopyFiles..::.CopyFilesRow
public:
property DSCopyFiles..::.CopyFilesRow^ default[int index] {
    DSCopyFiles..::.CopyFilesRow^ get (int index);
}
Parameters
index (Int32)


NewCopyFilesRow Method

NewCopyFilesRow Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► NewCopyFilesRow()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.NewCopyFilesRow]

Declaration Syntax
C# Visual Basic Visual C++
public DSCopyFiles..::.CopyFilesRow NewCopyFilesRow()
Public Function NewCopyFilesRow As DSCopyFiles..::.CopyFilesRow
public:
DSCopyFiles..::.CopyFilesRow^ NewCopyFilesRow()
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.NewCopyFilesRow]


NewRowFromBuilder Method (builder)

NewRowFromBuilder Method (builder)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► NewRowFromBuilder(DataRowBuilder)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder ( _
    builder As DataRowBuilder _
) As DataRow
protected:
virtual DataRow^ NewRowFromBuilder(
    DataRowBuilder^ builder
) override
Parameters
builder (DataRowBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]


OnRowChanged Method (e)

OnRowChanged Method (e)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► OnRowChanged(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanged(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanged ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanged(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)"]


OnRowChanging Method (e)

OnRowChanging Method (e)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► OnRowChanging(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanging(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanging ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanging(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)"]


OnRowDeleted Method (e)

OnRowDeleted Method (e)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► OnRowDeleted(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleted(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleted ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleted(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)"]


OnRowDeleting Method (e)

OnRowDeleting Method (e)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► OnRowDeleting(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleting(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleting ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleting(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)"]


OrderColumn Property

OrderColumn Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► OrderColumn

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesDataTable.OrderColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn OrderColumn { get; }
Public ReadOnly Property OrderColumn As DataColumn
public:
property DataColumn^ OrderColumn {
    DataColumn^ get ();
}


RemoveCopyFilesRow Method (row)

RemoveCopyFilesRow Method (row)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► RemoveCopyFilesRow(DSCopyFiles..::.CopyFilesRow)

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesDataTable.RemoveCopyFilesRow(VisualCron.DSCopyFiles.CopyFilesRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void RemoveCopyFilesRow(
    DSCopyFiles..::.CopyFilesRow row
)
Public Sub RemoveCopyFilesRow ( _
    row As DSCopyFiles..::.CopyFilesRow _
)
public:
void RemoveCopyFilesRow(
    DSCopyFiles..::.CopyFilesRow^ row
)
Parameters
row (DSCopyFiles..::.CopyFilesRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesDataTable.RemoveCopyFilesRow(VisualCron.DSCopyFiles.CopyFilesRow)"]


SourceDirectoryColumn Property

SourceDirectoryColumn Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► SourceDirectoryColumn

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesDataTable.SourceDirectoryColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn SourceDirectoryColumn { get; }
Public ReadOnly Property SourceDirectoryColumn As DataColumn
public:
property DataColumn^ SourceDirectoryColumn {
    DataColumn^ get ();
}


DSCopyFiles.CopyFilesRow Class

DSCopyFiles..::.CopyFilesRow Class
Namespaces ► VisualCron ► DSCopyFiles ► DSCopyFiles..::.CopyFilesRow
Represents strongly named DataRow class.
Declaration Syntax
C# Visual Basic Visual C++
public class CopyFilesRow : DataRow
Public Class CopyFilesRow _
    Inherits DataRow
public ref class CopyFilesRow : public DataRow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()() | Commits all the changes made to this row since the last time AcceptChanges()()() was called. (Inherited from DataRow.)
 | BeginEdit()()() | Starts an edit operation on a DataRow object. (Inherited from DataRow.)
 | CancelEdit()()() | Cancels the current edit on the row. (Inherited from DataRow.)
 | ClearErrors()()() | Clears the errors for the row. This includes the RowError and errors set with SetColumnError(Int32, String). (Inherited from DataRow.)
 | CopyFileId |
 | Delete()()() | Deletes the DataRow. (Inherited from DataRow.)
 | DestinationDirectory |
 | EndEdit()()() | Ends the edit occurring on the row. (Inherited from DataRow.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileMask |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetColumnError(Int32) | Gets the error description for the column specified by index. (Inherited from DataRow.)
 | GetColumnError(String) | Gets the error description for a column, specified by name. (Inherited from DataRow.)
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn. (Inherited from DataRow.)
 | GetColumnsInError()()() | Gets an array of columns that have errors. (Inherited from DataRow.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasErrors | Gets a value that indicates whether there are errors in a row. (Inherited from DataRow.)
 | HasVersion(DataRowVersion) | Gets a value that indicates whether a specified version exists. (Inherited from DataRow.)
 | IsDestinationDirectoryNull()()() |
 | IsFileMaskNull()()() |
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value. (Inherited from DataRow.)
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value. (Inherited from DataRow.)
 | IsOrderNull()()() |
 | IsSourceDirectoryNull()()() |
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index. (Inherited from DataRow.)
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name. (Inherited from DataRow.)
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn. (Inherited from DataRow.)
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve. (Inherited from DataRow.)
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column. (Inherited from DataRow.)
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn. (Inherited from DataRow.)
 | ItemArray | Gets or sets all the values for this row through an array. (Inherited from DataRow.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Order |
 | RejectChanges()()() | Rejects all changes made to the row since AcceptChanges()()() was last called. (Inherited from DataRow.)
 | RowError | Gets or sets the custom error description for a row. (Inherited from DataRow.)
 | RowState | Gets the current state of the row with regard to its relationship to the DataRowCollection. (Inherited from DataRow.)
 | SetAdded()()() | Changes the Rowstate()()() of a DataRow to Added. (Inherited from DataRow.)
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index. (Inherited from DataRow.)
 | SetColumnError(String, String) | Sets the error description for a column specified by name. (Inherited from DataRow.)
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn. (Inherited from DataRow.)
 | SetDestinationDirectoryNull()()() |
 | SetFileMaskNull()()() |
 | SetModified()()() | Changes the Rowstate()()() of a DataRow to Modified. (Inherited from DataRow.)
 | SetNull(DataColumn) | Sets the value of the specified DataColumn to a null value. (Inherited from DataRow.)
 | SetOrderNull()()() |
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow. (Inherited from DataRow.)
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation. (Inherited from DataRow.)
 | SetSourceDirectoryNull()()() |
 | SourceDirectory |
 | Table | Gets the DataTable for which this row has a schema. (Inherited from DataRow.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataRow
 |  | DSCopyFiles..::.CopyFilesRow


CopyFileId Property

CopyFileId Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► CopyFileId

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesRow.CopyFileId]

Declaration Syntax
C# Visual Basic Visual C++
public string CopyFileId { get; set; }
Public Property CopyFileId As String
public:
property String^ CopyFileId {
    String^ get ();
    void set (String^ value);
}


DestinationDirectory Property

DestinationDirectory Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► DestinationDirectory

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesRow.DestinationDirectory]

Declaration Syntax
C# Visual Basic Visual C++
public string DestinationDirectory { get; set; }
Public Property DestinationDirectory As String
public:
property String^ DestinationDirectory {
    String^ get ();
    void set (String^ value);
}


FileMask Property

FileMask Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► FileMask

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesRow.FileMask]

Declaration Syntax
C# Visual Basic Visual C++
public string FileMask { get; set; }
Public Property FileMask As String
public:
property String^ FileMask {
    String^ get ();
    void set (String^ value);
}


IsDestinationDirectoryNull Method

IsDestinationDirectoryNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► IsDestinationDirectoryNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsDestinationDirectoryNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsDestinationDirectoryNull()
Public Function IsDestinationDirectoryNull As Boolean
public:
bool IsDestinationDirectoryNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsDestinationDirectoryNull]


IsFileMaskNull Method

IsFileMaskNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► IsFileMaskNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsFileMaskNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsFileMaskNull()
Public Function IsFileMaskNull As Boolean
public:
bool IsFileMaskNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsFileMaskNull]


IsOrderNull Method

IsOrderNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► IsOrderNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsOrderNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsOrderNull()
Public Function IsOrderNull As Boolean
public:
bool IsOrderNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsOrderNull]


IsSourceDirectoryNull Method

IsSourceDirectoryNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► IsSourceDirectoryNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsSourceDirectoryNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsSourceDirectoryNull()
Public Function IsSourceDirectoryNull As Boolean
public:
bool IsSourceDirectoryNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.IsSourceDirectoryNull]


Order Property

Order Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► Order

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesRow.Order]

Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
public:
property int Order {
    int get ();
    void set (int value);
}


SetDestinationDirectoryNull Method

SetDestinationDirectoryNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► SetDestinationDirectoryNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.SetDestinationDirectoryNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDestinationDirectoryNull()
Public Sub SetDestinationDirectoryNull
public:
void SetDestinationDirectoryNull()


SetFileMaskNull Method

SetFileMaskNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► SetFileMaskNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.SetFileMaskNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetFileMaskNull()
Public Sub SetFileMaskNull
public:
void SetFileMaskNull()


SetOrderNull Method

SetOrderNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► SetOrderNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.SetOrderNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetOrderNull()
Public Sub SetOrderNull
public:
void SetOrderNull()


SetSourceDirectoryNull Method

SetSourceDirectoryNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► SetSourceDirectoryNull()()()

[Missing <summary> documentation for M:VisualCron.DSCopyFiles.CopyFilesRow.SetSourceDirectoryNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetSourceDirectoryNull()
Public Sub SetSourceDirectoryNull
public:
void SetSourceDirectoryNull()


SourceDirectory Property

SourceDirectory Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► SourceDirectory

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesRow.SourceDirectory]

Declaration Syntax
C# Visual Basic Visual C++
public string SourceDirectory { get; set; }
Public Property SourceDirectory As String
public:
property String^ SourceDirectory {
    String^ get ();
    void set (String^ value);
}


DSCopyFiles.CopyFilesRowChangeEvent Class

DSCopyFiles..::.CopyFilesRowChangeEvent Class
Namespaces ► VisualCron ► DSCopyFiles ► DSCopyFiles..::.CopyFilesRowChangeEvent
Row event argument class
Declaration Syntax
C# Visual Basic Visual C++
public class CopyFilesRowChangeEvent : EventArgs
Public Class CopyFilesRowChangeEvent _
    Inherits EventArgs
public ref class CopyFilesRowChangeEvent : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSCopyFiles..::.CopyFilesRowChangeEvent(DSCopyFiles..::.CopyFilesRow, DataRowAction) | Initializes a new instance of the DSCopyFiles..::.CopyFilesRowChangeEvent class
 | Action |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Row |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DSCopyFiles..::.CopyFilesRowChangeEvent


DSCopyFiles.CopyFilesRowChangeEvent Constructor (row, action)

DSCopyFiles..::.CopyFilesRowChangeEvent Constructor (row, action)
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRowChangeEvent ► DSCopyFiles..::.CopyFilesRowChangeEvent(DSCopyFiles..::.CopyFilesRow, DataRowAction)
Initializes a new instance of the DSCopyFiles..::.CopyFilesRowChangeEvent class
Declaration Syntax
C# Visual Basic Visual C++
public CopyFilesRowChangeEvent(
    DSCopyFiles..::.CopyFilesRow row,
    DataRowAction action
)
Public Sub New ( _
    row As DSCopyFiles..::.CopyFilesRow, _
    action As DataRowAction _
)
public:
CopyFilesRowChangeEvent(
    DSCopyFiles..::.CopyFilesRow^ row,
    DataRowAction action
)
Parameters
row (DSCopyFiles..::.CopyFilesRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesRowChangeEvent.#ctor(VisualCron.DSCopyFiles.CopyFilesRow,System.Data.DataRowAction)"]

action (DataRowAction)

[Missing <param name="action"/> documentation for "M:VisualCron.DSCopyFiles.CopyFilesRowChangeEvent.#ctor(VisualCron.DSCopyFiles.CopyFilesRow,System.Data.DataRowAction)"]


Action Property

Action Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRowChangeEvent ► Action

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesRowChangeEvent.Action]

Declaration Syntax
C# Visual Basic Visual C++
public DataRowAction Action { get; }
Public ReadOnly Property Action As DataRowAction
public:
property DataRowAction Action {
    DataRowAction get ();
}


Row Property

Row Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRowChangeEvent ► Row

[Missing <summary> documentation for P:VisualCron.DSCopyFiles.CopyFilesRowChangeEvent.Row]

Declaration Syntax
C# Visual Basic Visual C++
public DSCopyFiles..::.CopyFilesRow Row { get; }
Public ReadOnly Property Row As DSCopyFiles..::.CopyFilesRow
public:
property DSCopyFiles..::.CopyFilesRow^ Row {
    DSCopyFiles..::.CopyFilesRow^ get ();
}


DSCopyFiles.CopyFilesRowChangeEventHandler Delegate

DSCopyFiles..::.CopyFilesRowChangeEventHandler Delegate
Namespaces ► VisualCron ► DSCopyFiles ► DSCopyFiles..::.CopyFilesRowChangeEventHandler

[Missing <summary> documentation for T:VisualCron.DSCopyFiles.CopyFilesRowChangeEventHandler]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void CopyFilesRowChangeEventHandler(
    Object sender,
    DSCopyFiles..::.CopyFilesRowChangeEvent e
)
Public Delegate Sub CopyFilesRowChangeEventHandler ( _
    sender As Object, _
    e As DSCopyFiles..::.CopyFilesRowChangeEvent _
)
public delegate void CopyFilesRowChangeEventHandler(
    Object^ sender,
    DSCopyFiles..::.CopyFilesRowChangeEvent^ e
)
Parameters
sender (Object)
e (DSCopyFiles..::.CopyFilesRowChangeEvent)


DSMAC Class

DSMAC Class
Namespaces ► VisualCron ► DSMAC
Represents a strongly typed in-memory cache of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DSMAC : DataSet
<SerializableAttribute> _
Public Class DSMAC _
    Inherits DataSet
[SerializableAttribute]
public ref class DSMAC : public DataSet
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSMAC()()() | Initializes a new instance of the DSMAC class
 | DSMAC(SerializationInfo, StreamingContext) | Initializes a new instance of the DSMAC class
 | AcceptChanges()()() | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | BeginInit()()() | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | CaseSensitive | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive. (Inherited from DataSet.)
 | Clear()()() | Clears the DataSet of any data by removing all rows in all tables. (Inherited from DataSet.)
 | Clone()()() | (Overrides DataSet.Clone()()().)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataSet. (Inherited from DataSet.)
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection. (Inherited from DataSet.)
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable. (Inherited from DataSet.)
 | DataSetName | Gets or sets the name of the current DataSet. (Inherited from DataSet.)
 | DefaultViewManager | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager. (Inherited from DataSet.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | DTMAC |
 | EndInit()()() | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from DataSet.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from DataSet.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called. (Inherited from DataSet.)
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataSet.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataSet. (Inherited from DataSet.)
 | GetSchemaSerializable()()() | (Overrides DataSet.GetSchemaSerializable()()().)
 | GetSerializationData(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedDataSetSchema(XmlSchemaSet) |
 | GetXml()()() | Returns the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | GetXmlSchema()()() | Returns the XML Schema for the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows. (Inherited from DataSet.)
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState. (Inherited from DataSet.)
 | HasErrors | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet. (Inherited from DataSet.)
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet. (Inherited from DataSet.)
 | Initialized | Occurs after the DataSet is initialized. (Inherited from DataSet.)
 | InitializeDerivedDataSet()()() | (Overrides DataSet.InitializeDerivedDataSet()()().)
 | IsBinarySerialized(SerializationInfo, StreamingContext) | Inspects the format of the serialized representation of the DataSet. (Inherited from DataSet.)
 | IsInitialized | Gets a value that indicates whether the DataSet is initialized. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet. (Inherited from DataSet.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataSet.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument. (Inherited from DataSet.)
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | MergeFailed | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true. (Inherited from DataSet.)
 | Namespace | Gets or sets the namespace of the DataSet. (Inherited from DataSet.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the OnPropertyChanging(PropertyChangedEventArgs) event. (Inherited from DataSet.)
 | OnRemoveRelation(DataRelation) | Occurs when a DataRelation object is removed from a DataTable. (Inherited from DataSet.)
 | OnRemoveTable(DataTable) | Occurs when a DataTable is removed from a DataSet. (Inherited from DataSet.)
 | Prefix | Gets or sets an XML prefix that aliases the namespace of the DataSet. (Inherited from DataSet.)
 | RaisePropertyChanging(String) | Sends a notification that the specified DataSet property is about to change. (Inherited from DataSet.)
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader. (Inherited from DataSet.)
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream. (Inherited from DataSet.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader. (Inherited from DataSet.)
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file. (Inherited from DataSet.)
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode. (Inherited from DataSet.)
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet. (Inherited from DataSet.)
 | ReadXmlSerializable(XmlReader) | (Overrides DataSet.ReadXmlSerializable(XmlReader).)
 | RejectChanges()()() | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | Relations |
 | RemotingFormat | Gets or sets a SerializationFormat for the DataSet used during remoting. (Inherited from DataSet.)
 | Reset()()() | Resets the DataSet to its original state. Subclasses should override Reset()()() to restore a DataSet to its original state. (Inherited from DataSet.)
 | SchemaSerializationMode | (Overrides DataSet.SchemaSerializationMode.)
 | ShouldSerializeRelations()()() | (Overrides DataSet.ShouldSerializeRelations()()().)
 | ShouldSerializeTables()()() | (Overrides DataSet.ShouldSerializeTables()()().)
 | Site | Gets or sets an ISite for the DataSet. (Inherited from DataSet.)
 | Tables |
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream. (Inherited from DataSet.)
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter. (Inherited from DataSet.)
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter. (Inherited from DataSet.)
 | WriteXml(String) | Writes the current data for the DataSet to the specified file. (Inherited from DataSet.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object. (Inherited from DataSet.)
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file. (Inherited from DataSet.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataSet
 |  |  | DSMAC


DSMAC Constructor

DSMAC Constructor
Namespaces ► VisualCron ► DSMAC ► DSMAC()()()
Members
Icon | Member | Description
 | DSMAC()()() | Initializes a new instance of the DSMAC class
 | DSMAC(SerializationInfo, StreamingContext) | Initializes a new instance of the DSMAC class


DSMAC Constructor

DSMAC Constructor
Namespaces ► VisualCron ► DSMAC ► DSMAC()()()
Initializes a new instance of the DSMAC class
Declaration Syntax
C# Visual Basic Visual C++
public DSMAC()
Public Sub New
public:
DSMAC()


DSMAC Constructor (info, context)

DSMAC Constructor (info, context)
Namespaces ► VisualCron ► DSMAC ► DSMAC(SerializationInfo, StreamingContext)
Initializes a new instance of the DSMAC class
Declaration Syntax
C# Visual Basic Visual C++
protected DSMAC(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DSMAC(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSMAC.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSMAC.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSMAC ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataSet Clone()
Public Overrides Function Clone As DataSet
public:
virtual DataSet^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.Clone]


DTMAC Property

DTMAC Property
Namespaces ► VisualCron ► DSMAC ► DTMAC

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMAC]

Declaration Syntax
C# Visual Basic Visual C++
public DSMAC..::.DTMACDataTable DTMAC { get; }
Public ReadOnly Property DTMAC As DSMAC..::.DTMACDataTable
public:
property DSMAC..::.DTMACDataTable^ DTMAC {
    DSMAC..::.DTMACDataTable^ get ();
}


GetSchemaSerializable Method

GetSchemaSerializable Method
Namespaces ► VisualCron ► DSMAC ► GetSchemaSerializable()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.GetSchemaSerializable]

Declaration Syntax
C# Visual Basic Visual C++
protected override XmlSchema GetSchemaSerializable()
Protected Overrides Function GetSchemaSerializable As XmlSchema
protected:
virtual XmlSchema^ GetSchemaSerializable() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.GetSchemaSerializable]


GetTypedDataSetSchema Method (xs)

GetTypedDataSetSchema Method (xs)
Namespaces ► VisualCron ► DSMAC ► GetTypedDataSetSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSMAC.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedDataSetSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedDataSetSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedDataSetSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSMAC.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]


InitializeDerivedDataSet Method

InitializeDerivedDataSet Method
Namespaces ► VisualCron ► DSMAC ► InitializeDerivedDataSet()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.InitializeDerivedDataSet]

Declaration Syntax
C# Visual Basic Visual C++
protected override void InitializeDerivedDataSet()
Protected Overrides Sub InitializeDerivedDataSet
protected:
virtual void InitializeDerivedDataSet() override


ReadXmlSerializable Method (reader)

ReadXmlSerializable Method (reader)
Namespaces ► VisualCron ► DSMAC ► ReadXmlSerializable(XmlReader)

[Missing <summary> documentation for M:VisualCron.DSMAC.ReadXmlSerializable(System.Xml.XmlReader)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void ReadXmlSerializable(
    XmlReader reader
)
Protected Overrides Sub ReadXmlSerializable ( _
    reader As XmlReader _
)
protected:
virtual void ReadXmlSerializable(
    XmlReader^ reader
) override
Parameters
reader (XmlReader)

[Missing <param name="reader"/> documentation for "M:VisualCron.DSMAC.ReadXmlSerializable(System.Xml.XmlReader)"]


Relations Property

Relations Property
Namespaces ► VisualCron ► DSMAC ► Relations

[Missing <summary> documentation for P:VisualCron.DSMAC.Relations]

Declaration Syntax
C# Visual Basic Visual C++
public DataRelationCollection Relations { get; }
Public ReadOnly Property Relations As DataRelationCollection
public:
property DataRelationCollection^ Relations {
    DataRelationCollection^ get ();
}


SchemaSerializationMode Property

SchemaSerializationMode Property
Namespaces ► VisualCron ► DSMAC ► SchemaSerializationMode

[Missing <summary> documentation for P:VisualCron.DSMAC.SchemaSerializationMode]

Declaration Syntax
C# Visual Basic Visual C++
public override SchemaSerializationMode SchemaSerializationMode { get; set; }
Public Overrides Property SchemaSerializationMode As SchemaSerializationMode
public:
virtual property SchemaSerializationMode SchemaSerializationMode {
    SchemaSerializationMode get () override;
    void set (SchemaSerializationMode value) override;
}


ShouldSerializeRelations Method

ShouldSerializeRelations Method
Namespaces ► VisualCron ► DSMAC ► ShouldSerializeRelations()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.ShouldSerializeRelations]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeRelations()
Protected Overrides Function ShouldSerializeRelations As Boolean
protected:
virtual bool ShouldSerializeRelations() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.ShouldSerializeRelations]


ShouldSerializeTables Method

ShouldSerializeTables Method
Namespaces ► VisualCron ► DSMAC ► ShouldSerializeTables()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.ShouldSerializeTables]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeTables()
Protected Overrides Function ShouldSerializeTables As Boolean
protected:
virtual bool ShouldSerializeTables() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.ShouldSerializeTables]


Tables Property

Tables Property
Namespaces ► VisualCron ► DSMAC ► Tables

[Missing <summary> documentation for P:VisualCron.DSMAC.Tables]

Declaration Syntax
C# Visual Basic Visual C++
public DataTableCollection Tables { get; }
Public ReadOnly Property Tables As DataTableCollection
public:
property DataTableCollection^ Tables {
    DataTableCollection^ get ();
}


DSMAC.DTMACDataTable Class

DSMAC..::.DTMACDataTable Class
Namespaces ► VisualCron ► DSMAC ► DSMAC..::.DTMACDataTable
Represents the strongly named DataTable class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DTMACDataTable : DataTable,
    IEnumerable
<SerializableAttribute> _
Public Class DTMACDataTable _
    Inherits DataTable _
    Implements IEnumerable
[SerializableAttribute]
public ref class DTMACDataTable : public DataTable,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSMAC..::.DTMACDataTable()()() | Initializes a new instance of the DSMAC..::.DTMACDataTable class
 | DSMAC..::.DTMACDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSMAC..::.DTMACDataTable class
 | AcceptChanges()()() | Commits all the changes made to this table since the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | AddDTMACRow(DSMAC..::.DTMACRow) |
 | AddDTMACRow(String, String, String) |
 | BeginInit()()() | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | BeginLoadData()()() | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from DataTable.)
 | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from DataTable.)
 | ChildRelations | Gets the collection of child relations for this DataTable. (Inherited from DataTable.)
 | Clear()()() | Clears the DataTable of all data. (Inherited from DataTable.)
 | Clone()()() | (Overrides DataTable.Clone()()().)
 | ColumnChanged | Occurs after a value has been changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | ColumnChanging | Occurs when a value is being changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | Columns | Gets the collection of columns that belong to this table. (Inherited from DataTable.)
 | Compute(String, String) | Computes the given expression on the current rows that pass the filter criteria. (Inherited from DataTable.)
 | Constraints | Gets the collection of constraints maintained by this table. (Inherited from DataTable.)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataTable. (Inherited from DataTable.)
 | Count |
 | CreateDataReader()()() | Returns a DataTableReader corresponding to the data within this DataTable. (Inherited from DataTable.)
 | CreateInstance()()() | (Overrides DataTable.CreateInstance()()().)
 | DataSet | Gets the DataSet to which this table belongs. (Inherited from DataTable.)
 | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from DataTable.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from DataTable.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | DTMACRowChanged |
 | DTMACRowChanging |
 | DTMACRowDeleted |
 | DTMACRowDeleting |
 | EndInit()()() | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | EndLoadData()()() | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from DataTable.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information. (Inherited from DataTable.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | fInitInProgress | (Inherited from DataTable.)
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called. (Inherited from DataTable.)
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataTable.)
 | GetEnumerator()()() |
 | GetErrors()()() | Gets an array of DataRow objects that contain errors. (Inherited from DataTable.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataTable. (Inherited from DataTable.)
 | GetRowType()()() | (Overrides DataTable.GetRowType()()().)
 | GetSchema()()() | (Inherited from DataTable.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedTableSchema(XmlSchemaSet) |
 | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs. (Inherited from DataTable.)
 | ImportRow(DataRow) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values. (Inherited from DataTable.)
 | Initialized | Occurs after the DataTable is initialized. (Inherited from DataTable.)
 | IPColumn |
 | IsInitialized | Gets a value that indicates whether the DataTable is initialized. (Inherited from DataTable.)
 | Item[([(Int32])]) |
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataTable.)
 | MACColumn |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable. (Inherited from DataTable.)
 | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from DataTable.)
 | NameColumn |
 | Namespace | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | NewDTMACRow()()() |
 | NewRow()()() | Creates a new DataRow with the same schema as the table. (Inherited from DataTable.)
 | NewRowArray(Int32) | (Inherited from DataTable.)
 | NewRowFromBuilder(DataRowBuilder) | (Overrides DataTable.NewRowFromBuilder(DataRowBuilder).)
 | OnColumnChanged(DataColumnChangeEventArgs) | Raises the ColumnChanged event. (Inherited from DataTable.)
 | OnColumnChanging(DataColumnChangeEventArgs) | Raises the ColumnChanging event. (Inherited from DataTable.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the PropertyChanged event. (Inherited from DataTable.)
 | OnRemoveColumn(DataColumn) | Notifies the DataTable that a DataColumn is being removed. (Inherited from DataTable.)
 | OnRowChanged(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanged(DataRowChangeEventArgs).)
 | OnRowChanging(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanging(DataRowChangeEventArgs).)
 | OnRowDeleted(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleted(DataRowChangeEventArgs).)
 | OnRowDeleting(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleting(DataRowChangeEventArgs).)
 | OnTableCleared(DataTableClearEventArgs) | Raises the TableCleared event. (Inherited from DataTable.)
 | OnTableClearing(DataTableClearEventArgs) | Raises the TableClearing event. (Inherited from DataTable.)
 | OnTableNewRow(DataTableNewRowEventArgs) | Raises the TableNewRow event. (Inherited from DataTable.)
 | ParentRelations | Gets the collection of parent relations for this DataTable. (Inherited from DataTable.)
 | Prefix | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table. (Inherited from DataTable.)
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream. (Inherited from DataTable.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream. (Inherited from DataTable.)
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSerializable(XmlReader) | (Inherited from DataTable.)
 | RejectChanges()()() | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | RemotingFormat | Gets or sets the serialization format. (Inherited from DataTable.)
 | RemoveDTMACRow(DSMAC..::.DTMACRow) |
 | Reset()()() | Resets the DataTable to its original state. (Inherited from DataTable.)
 | RowChanged | Occurs after a DataRow has been changed successfully. (Inherited from DataTable.)
 | RowChanging | Occurs when a DataRow is changing. (Inherited from DataTable.)
 | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from DataTable.)
 | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from DataTable.)
 | Rows | Gets the collection of rows that belong to this table. (Inherited from DataTable.)
 | Select()()() | Gets an array of all DataRow objects. (Inherited from DataTable.)
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.) (Inherited from DataTable.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order. (Inherited from DataTable.)
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state. (Inherited from DataTable.)
 | Site | Gets or sets an ISite for the DataTable. (Inherited from DataTable.)
 | TableCleared | Occurs after a DataTable is cleared. (Inherited from DataTable.)
 | TableClearing | Occurs when a DataTable is cleared. (Inherited from DataTable.)
 | TableName | Gets or sets the name of the DataTable. (Inherited from DataTable.)
 | TableNewRow | Occurs when a new DataRow is inserted. (Inherited from DataTable.)
 | ToString()()() | Gets the TableName and DisplayExpression, if there is one as a concatenated string. (Inherited from DataTable.)
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream. (Inherited from DataTable.)
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter. (Inherited from DataTable.)
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file. (Inherited from DataTable.)
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream. (Inherited from DataTable.)
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file. (Inherited from DataTable.)
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataTable
 |  |  | DSMAC..::.DTMACDataTable


DSMAC.DTMACDataTable Constructor

DSMAC..::.DTMACDataTable Constructor
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► DSMAC..::.DTMACDataTable()()()
Members
Icon | Member | Description
 | DSMAC..::.DTMACDataTable()()() | Initializes a new instance of the DSMAC..::.DTMACDataTable class
 | DSMAC..::.DTMACDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSMAC..::.DTMACDataTable class


DSMAC.DTMACDataTable Constructor

DSMAC..::.DTMACDataTable Constructor
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► DSMAC..::.DTMACDataTable()()()
Initializes a new instance of the DSMAC..::.DTMACDataTable class
Declaration Syntax
C# Visual Basic Visual C++
public DTMACDataTable()
Public Sub New
public:
DTMACDataTable()


DSMAC.DTMACDataTable Constructor (info, context)

DSMAC..::.DTMACDataTable Constructor (info, context)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► DSMAC..::.DTMACDataTable(SerializationInfo, StreamingContext)
Initializes a new instance of the DSMAC..::.DTMACDataTable class
Declaration Syntax
C# Visual Basic Visual C++
protected DTMACDataTable(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DTMACDataTable(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


AddDTMACRow Method

AddDTMACRow Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► AddDTMACRow()()()
Members
Icon | Member | Description
 | AddDTMACRow(DSMAC..::.DTMACRow) |
 | AddDTMACRow(String, String, String) |


AddDTMACRow Method (MAC, Name, IP)

AddDTMACRow Method (MAC, Name, IP)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► AddDTMACRow(String, String, String)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.AddDTMACRow(System.String,System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSMAC..::.DTMACRow AddDTMACRow(
    string MAC,
    string Name,
    string IP
)
Public Function AddDTMACRow ( _
    MAC As String, _
    Name As String, _
    IP As String _
) As DSMAC..::.DTMACRow
public:
DSMAC..::.DTMACRow^ AddDTMACRow(
    String^ MAC,
    String^ Name,
    String^ IP
)
Parameters
MAC (String)

[Missing <param name="MAC"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.AddDTMACRow(System.String,System.String,System.String)"]

Name (String)

[Missing <param name="Name"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.AddDTMACRow(System.String,System.String,System.String)"]

IP (String)

[Missing <param name="IP"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.AddDTMACRow(System.String,System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.AddDTMACRow(System.String,System.String,System.String)]


AddDTMACRow Method (row)

AddDTMACRow Method (row)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► AddDTMACRow(DSMAC..::.DTMACRow)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.AddDTMACRow(VisualCron.DSMAC.DTMACRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddDTMACRow(
    DSMAC..::.DTMACRow row
)
Public Sub AddDTMACRow ( _
    row As DSMAC..::.DTMACRow _
)
public:
void AddDTMACRow(
    DSMAC..::.DTMACRow^ row
)
Parameters
row (DSMAC..::.DTMACRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.AddDTMACRow(VisualCron.DSMAC.DTMACRow)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataTable Clone()
Public Overrides Function Clone As DataTable
public:
virtual DataTable^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.Clone]


Count Property

Count Property
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► Count

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACDataTable.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


CreateInstance Method

CreateInstance Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► CreateInstance()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.CreateInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataTable CreateInstance()
Protected Overrides Function CreateInstance As DataTable
protected:
virtual DataTable^ CreateInstance() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.CreateInstance]


DTMACRowChanged Event

DTMACRowChanged Event
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► DTMACRowChanged

[Missing <summary> documentation for E:VisualCron.DSMAC.DTMACDataTable.DTMACRowChanged]

Declaration Syntax
C# Visual Basic Visual C++
public event DSMAC..::.DTMACRowChangeEventHandler DTMACRowChanged
Public Event DTMACRowChanged As DSMAC..::.DTMACRowChangeEventHandler
public:
 event DSMAC..::.DTMACRowChangeEventHandler^ DTMACRowChanged {
    void add (DSMAC..::.DTMACRowChangeEventHandler^ value);
    void remove (DSMAC..::.DTMACRowChangeEventHandler^ value);
}


DTMACRowChanging Event

DTMACRowChanging Event
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► DTMACRowChanging

[Missing <summary> documentation for E:VisualCron.DSMAC.DTMACDataTable.DTMACRowChanging]

Declaration Syntax
C# Visual Basic Visual C++
public event DSMAC..::.DTMACRowChangeEventHandler DTMACRowChanging
Public Event DTMACRowChanging As DSMAC..::.DTMACRowChangeEventHandler
public:
 event DSMAC..::.DTMACRowChangeEventHandler^ DTMACRowChanging {
    void add (DSMAC..::.DTMACRowChangeEventHandler^ value);
    void remove (DSMAC..::.DTMACRowChangeEventHandler^ value);
}


DTMACRowDeleted Event

DTMACRowDeleted Event
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► DTMACRowDeleted

[Missing <summary> documentation for E:VisualCron.DSMAC.DTMACDataTable.DTMACRowDeleted]

Declaration Syntax
C# Visual Basic Visual C++
public event DSMAC..::.DTMACRowChangeEventHandler DTMACRowDeleted
Public Event DTMACRowDeleted As DSMAC..::.DTMACRowChangeEventHandler
public:
 event DSMAC..::.DTMACRowChangeEventHandler^ DTMACRowDeleted {
    void add (DSMAC..::.DTMACRowChangeEventHandler^ value);
    void remove (DSMAC..::.DTMACRowChangeEventHandler^ value);
}


DTMACRowDeleting Event

DTMACRowDeleting Event
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► DTMACRowDeleting

[Missing <summary> documentation for E:VisualCron.DSMAC.DTMACDataTable.DTMACRowDeleting]

Declaration Syntax
C# Visual Basic Visual C++
public event DSMAC..::.DTMACRowChangeEventHandler DTMACRowDeleting
Public Event DTMACRowDeleting As DSMAC..::.DTMACRowChangeEventHandler
public:
 event DSMAC..::.DTMACRowChangeEventHandler^ DTMACRowDeleting {
    void add (DSMAC..::.DTMACRowChangeEventHandler^ value);
    void remove (DSMAC..::.DTMACRowChangeEventHandler^ value);
}


GetEnumerator Method

GetEnumerator Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► GetEnumerator()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.GetEnumerator]


GetRowType Method

GetRowType Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► GetRowType()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.GetRowType]

Declaration Syntax
C# Visual Basic Visual C++
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
protected:
virtual Type^ GetRowType() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.GetRowType]


GetTypedTableSchema Method (xs)

GetTypedTableSchema Method (xs)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► GetTypedTableSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedTableSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedTableSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedTableSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]


IPColumn Property

IPColumn Property
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► IPColumn

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACDataTable.IPColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn IPColumn { get; }
Public ReadOnly Property IPColumn As DataColumn
public:
property DataColumn^ IPColumn {
    DataColumn^ get ();
}


Item Property (index)

Item Property (index)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► Item[([(Int32])])

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACDataTable.Item(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public DSMAC..::.DTMACRow this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DSMAC..::.DTMACRow
public:
property DSMAC..::.DTMACRow^ default[int index] {
    DSMAC..::.DTMACRow^ get (int index);
}
Parameters
index (Int32)


MACColumn Property

MACColumn Property
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► MACColumn

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACDataTable.MACColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn MACColumn { get; }
Public ReadOnly Property MACColumn As DataColumn
public:
property DataColumn^ MACColumn {
    DataColumn^ get ();
}


NameColumn Property

NameColumn Property
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► NameColumn

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACDataTable.NameColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn NameColumn { get; }
Public ReadOnly Property NameColumn As DataColumn
public:
property DataColumn^ NameColumn {
    DataColumn^ get ();
}


NewDTMACRow Method

NewDTMACRow Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► NewDTMACRow()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.NewDTMACRow]

Declaration Syntax
C# Visual Basic Visual C++
public DSMAC..::.DTMACRow NewDTMACRow()
Public Function NewDTMACRow As DSMAC..::.DTMACRow
public:
DSMAC..::.DTMACRow^ NewDTMACRow()
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.NewDTMACRow]


NewRowFromBuilder Method (builder)

NewRowFromBuilder Method (builder)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► NewRowFromBuilder(DataRowBuilder)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder ( _
    builder As DataRowBuilder _
) As DataRow
protected:
virtual DataRow^ NewRowFromBuilder(
    DataRowBuilder^ builder
) override
Parameters
builder (DataRowBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]


OnRowChanged Method (e)

OnRowChanged Method (e)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► OnRowChanged(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanged(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanged ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanged(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)"]


OnRowChanging Method (e)

OnRowChanging Method (e)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► OnRowChanging(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanging(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanging ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanging(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)"]


OnRowDeleted Method (e)

OnRowDeleted Method (e)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► OnRowDeleted(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleted(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleted ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleted(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)"]


OnRowDeleting Method (e)

OnRowDeleting Method (e)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► OnRowDeleting(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleting(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleting ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleting(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)"]


RemoveDTMACRow Method (row)

RemoveDTMACRow Method (row)
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► RemoveDTMACRow(DSMAC..::.DTMACRow)

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACDataTable.RemoveDTMACRow(VisualCron.DSMAC.DTMACRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void RemoveDTMACRow(
    DSMAC..::.DTMACRow row
)
Public Sub RemoveDTMACRow ( _
    row As DSMAC..::.DTMACRow _
)
public:
void RemoveDTMACRow(
    DSMAC..::.DTMACRow^ row
)
Parameters
row (DSMAC..::.DTMACRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSMAC.DTMACDataTable.RemoveDTMACRow(VisualCron.DSMAC.DTMACRow)"]


DSMAC.DTMACRow Class

DSMAC..::.DTMACRow Class
Namespaces ► VisualCron ► DSMAC ► DSMAC..::.DTMACRow
Represents strongly named DataRow class.
Declaration Syntax
C# Visual Basic Visual C++
public class DTMACRow : DataRow
Public Class DTMACRow _
    Inherits DataRow
public ref class DTMACRow : public DataRow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()() | Commits all the changes made to this row since the last time AcceptChanges()()() was called. (Inherited from DataRow.)
 | BeginEdit()()() | Starts an edit operation on a DataRow object. (Inherited from DataRow.)
 | CancelEdit()()() | Cancels the current edit on the row. (Inherited from DataRow.)
 | ClearErrors()()() | Clears the errors for the row. This includes the RowError and errors set with SetColumnError(Int32, String). (Inherited from DataRow.)
 | Delete()()() | Deletes the DataRow. (Inherited from DataRow.)
 | EndEdit()()() | Ends the edit occurring on the row. (Inherited from DataRow.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetColumnError(Int32) | Gets the error description for the column specified by index. (Inherited from DataRow.)
 | GetColumnError(String) | Gets the error description for a column, specified by name. (Inherited from DataRow.)
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn. (Inherited from DataRow.)
 | GetColumnsInError()()() | Gets an array of columns that have errors. (Inherited from DataRow.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasErrors | Gets a value that indicates whether there are errors in a row. (Inherited from DataRow.)
 | HasVersion(DataRowVersion) | Gets a value that indicates whether a specified version exists. (Inherited from DataRow.)
 | IP |
 | IsIPNull()()() |
 | IsMACNull()()() |
 | IsNameNull()()() |
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value. (Inherited from DataRow.)
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value. (Inherited from DataRow.)
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index. (Inherited from DataRow.)
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name. (Inherited from DataRow.)
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn. (Inherited from DataRow.)
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve. (Inherited from DataRow.)
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column. (Inherited from DataRow.)
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn. (Inherited from DataRow.)
 | ItemArray | Gets or sets all the values for this row through an array. (Inherited from DataRow.)
 | MAC |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | RejectChanges()()() | Rejects all changes made to the row since AcceptChanges()()() was last called. (Inherited from DataRow.)
 | RowError | Gets or sets the custom error description for a row. (Inherited from DataRow.)
 | RowState | Gets the current state of the row with regard to its relationship to the DataRowCollection. (Inherited from DataRow.)
 | SetAdded()()() | Changes the Rowstate()()() of a DataRow to Added. (Inherited from DataRow.)
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index. (Inherited from DataRow.)
 | SetColumnError(String, String) | Sets the error description for a column specified by name. (Inherited from DataRow.)
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn. (Inherited from DataRow.)
 | SetIPNull()()() |
 | SetMACNull()()() |
 | SetModified()()() | Changes the Rowstate()()() of a DataRow to Modified. (Inherited from DataRow.)
 | SetNameNull()()() |
 | SetNull(DataColumn) | Sets the value of the specified DataColumn to a null value. (Inherited from DataRow.)
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow. (Inherited from DataRow.)
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation. (Inherited from DataRow.)
 | Table | Gets the DataTable for which this row has a schema. (Inherited from DataRow.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataRow
 |  | DSMAC..::.DTMACRow


IP Property

IP Property
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► IP

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACRow.IP]

Declaration Syntax
C# Visual Basic Visual C++
public string IP { get; set; }
Public Property IP As String
public:
property String^ IP {
    String^ get ();
    void set (String^ value);
}


IsIPNull Method

IsIPNull Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► IsIPNull()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACRow.IsIPNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsIPNull()
Public Function IsIPNull As Boolean
public:
bool IsIPNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACRow.IsIPNull]


IsMACNull Method

IsMACNull Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► IsMACNull()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACRow.IsMACNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsMACNull()
Public Function IsMACNull As Boolean
public:
bool IsMACNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACRow.IsMACNull]


IsNameNull Method

IsNameNull Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► IsNameNull()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACRow.IsNameNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsNameNull()
Public Function IsNameNull As Boolean
public:
bool IsNameNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSMAC.DTMACRow.IsNameNull]


MAC Property

MAC Property
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► MAC

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACRow.MAC]

Declaration Syntax
C# Visual Basic Visual C++
public string MAC { get; set; }
Public Property MAC As String
public:
property String^ MAC {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► Name

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACRow.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


SetIPNull Method

SetIPNull Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► SetIPNull()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACRow.SetIPNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetIPNull()
Public Sub SetIPNull
public:
void SetIPNull()


SetMACNull Method

SetMACNull Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► SetMACNull()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACRow.SetMACNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetMACNull()
Public Sub SetMACNull
public:
void SetMACNull()


SetNameNull Method

SetNameNull Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► SetNameNull()()()

[Missing <summary> documentation for M:VisualCron.DSMAC.DTMACRow.SetNameNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetNameNull()
Public Sub SetNameNull
public:
void SetNameNull()


DSMAC.DTMACRowChangeEvent Class

DSMAC..::.DTMACRowChangeEvent Class
Namespaces ► VisualCron ► DSMAC ► DSMAC..::.DTMACRowChangeEvent
Row event argument class
Declaration Syntax
C# Visual Basic Visual C++
public class DTMACRowChangeEvent : EventArgs
Public Class DTMACRowChangeEvent _
    Inherits EventArgs
public ref class DTMACRowChangeEvent : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSMAC..::.DTMACRowChangeEvent(DSMAC..::.DTMACRow, DataRowAction) | Initializes a new instance of the DSMAC..::.DTMACRowChangeEvent class
 | Action |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Row |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DSMAC..::.DTMACRowChangeEvent


DSMAC.DTMACRowChangeEvent Constructor (row, action)

DSMAC..::.DTMACRowChangeEvent Constructor (row, action)
Namespaces ► VisualCron ► DSMAC..::.DTMACRowChangeEvent ► DSMAC..::.DTMACRowChangeEvent(DSMAC..::.DTMACRow, DataRowAction)
Initializes a new instance of the DSMAC..::.DTMACRowChangeEvent class
Declaration Syntax
C# Visual Basic Visual C++
public DTMACRowChangeEvent(
    DSMAC..::.DTMACRow row,
    DataRowAction action
)
Public Sub New ( _
    row As DSMAC..::.DTMACRow, _
    action As DataRowAction _
)
public:
DTMACRowChangeEvent(
    DSMAC..::.DTMACRow^ row,
    DataRowAction action
)
Parameters
row (DSMAC..::.DTMACRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSMAC.DTMACRowChangeEvent.#ctor(VisualCron.DSMAC.DTMACRow,System.Data.DataRowAction)"]

action (DataRowAction)

[Missing <param name="action"/> documentation for "M:VisualCron.DSMAC.DTMACRowChangeEvent.#ctor(VisualCron.DSMAC.DTMACRow,System.Data.DataRowAction)"]


Action Property

Action Property
Namespaces ► VisualCron ► DSMAC..::.DTMACRowChangeEvent ► Action

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACRowChangeEvent.Action]

Declaration Syntax
C# Visual Basic Visual C++
public DataRowAction Action { get; }
Public ReadOnly Property Action As DataRowAction
public:
property DataRowAction Action {
    DataRowAction get ();
}


Row Property

Row Property
Namespaces ► VisualCron ► DSMAC..::.DTMACRowChangeEvent ► Row

[Missing <summary> documentation for P:VisualCron.DSMAC.DTMACRowChangeEvent.Row]

Declaration Syntax
C# Visual Basic Visual C++
public DSMAC..::.DTMACRow Row { get; }
Public ReadOnly Property Row As DSMAC..::.DTMACRow
public:
property DSMAC..::.DTMACRow^ Row {
    DSMAC..::.DTMACRow^ get ();
}


DSMAC.DTMACRowChangeEventHandler Delegate

DSMAC..::.DTMACRowChangeEventHandler Delegate
Namespaces ► VisualCron ► DSMAC ► DSMAC..::.DTMACRowChangeEventHandler

[Missing <summary> documentation for T:VisualCron.DSMAC.DTMACRowChangeEventHandler]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DTMACRowChangeEventHandler(
    Object sender,
    DSMAC..::.DTMACRowChangeEvent e
)
Public Delegate Sub DTMACRowChangeEventHandler ( _
    sender As Object, _
    e As DSMAC..::.DTMACRowChangeEvent _
)
public delegate void DTMACRowChangeEventHandler(
    Object^ sender,
    DSMAC..::.DTMACRowChangeEvent^ e
)
Parameters
sender (Object)
e (DSMAC..::.DTMACRowChangeEvent)


DSNetworkCredentials Class

DSNetworkCredentials Class
Namespaces ► VisualCron ► DSNetworkCredentials
Represents a strongly typed in-memory cache of data.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DSNetworkCredentials : DataSet
<SerializableAttribute> _
Public Class DSNetworkCredentials _
    Inherits DataSet
[SerializableAttribute]
public ref class DSNetworkCredentials : public DataSet
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSNetworkCredentials()()() | Initializes a new instance of the DSNetworkCredentials class
 | DSNetworkCredentials(SerializationInfo, StreamingContext) | Initializes a new instance of the DSNetworkCredentials class
 | AcceptChanges()()() | Commits all the changes made to this DataSet since it was loaded or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | BeginInit()()() | Begins the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | CaseSensitive | Gets or sets a value indicating whether string comparisons within DataTable objects are case-sensitive. (Inherited from DataSet.)
 | Clear()()() | Clears the DataSet of any data by removing all rows in all tables. (Inherited from DataSet.)
 | Clone()()() | (Overrides DataSet.Clone()()().)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataSet. (Inherited from DataSet.)
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection. (Inherited from DataSet.)
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable. (Inherited from DataSet.)
 | DataSetName | Gets or sets the name of the current DataSet. (Inherited from DataSet.)
 | DefaultViewManager | Gets a custom view of the data contained in the DataSet to allow filtering, searching, and navigating using a custom DataViewManager. (Inherited from DataSet.)
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet. (Inherited from DataSet.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | EndInit()()() | Ends the initialization of a DataSet that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataSet.)
 | EnforceConstraints | Gets or sets a value indicating whether constraint rules are followed when attempting any update operation. (Inherited from DataSet.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information associated with the DataSet. (Inherited from DataSet.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called. (Inherited from DataSet.)
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataSet.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataSet. (Inherited from DataSet.)
 | GetSchemaSerializable()()() | (Overrides DataSet.GetSchemaSerializable()()().)
 | GetSerializationData(SerializationInfo, StreamingContext) | (Inherited from DataSet.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedDataSetSchema(XmlSchemaSet) |
 | GetXml()()() | Returns the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | GetXmlSchema()()() | Returns the XML Schema for the XML representation of the data stored in the DataSet. (Inherited from DataSet.)
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows. (Inherited from DataSet.)
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState. (Inherited from DataSet.)
 | HasErrors | Gets a value indicating whether there are errors in any of the DataTable objects within this DataSet. (Inherited from DataSet.)
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet. (Inherited from DataSet.)
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet. (Inherited from DataSet.)
 | Initialized | Occurs after the DataSet is initialized. (Inherited from DataSet.)
 | InitializeDerivedDataSet()()() | (Overrides DataSet.InitializeDerivedDataSet()()().)
 | IsBinarySerialized(SerializationInfo, StreamingContext) | Inspects the format of the serialized representation of the DataSet. (Inherited from DataSet.)
 | IsInitialized | Gets a value that indicates whether the DataSet is initialized. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information. (Inherited from DataSet.)
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet. (Inherited from DataSet.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataSet.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument. (Inherited from DataSet.)
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet. (Inherited from DataSet.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet. (Inherited from DataSet.)
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments. (Inherited from DataSet.)
 | MergeFailed | Occurs when a target and source DataRow have the same primary key value, and EnforceConstraints is set to true. (Inherited from DataSet.)
 | Namespace | Gets or sets the namespace of the DataSet. (Inherited from DataSet.)
 | NetworkCredentials |
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the OnPropertyChanging(PropertyChangedEventArgs) event. (Inherited from DataSet.)
 | OnRemoveRelation(DataRelation) | Occurs when a DataRelation object is removed from a DataTable. (Inherited from DataSet.)
 | OnRemoveTable(DataTable) | Occurs when a DataTable is removed from a DataSet. (Inherited from DataSet.)
 | Prefix | Gets or sets an XML prefix that aliases the namespace of the DataSet. (Inherited from DataSet.)
 | RaisePropertyChanging(String) | Sends a notification that the specified DataSet property is about to change. (Inherited from DataSet.)
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader. (Inherited from DataSet.)
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream. (Inherited from DataSet.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader. (Inherited from DataSet.)
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file. (Inherited from DataSet.)
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode. (Inherited from DataSet.)
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode. (Inherited from DataSet.)
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet. (Inherited from DataSet.)
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet. (Inherited from DataSet.)
 | ReadXmlSerializable(XmlReader) | (Overrides DataSet.ReadXmlSerializable(XmlReader).)
 | RejectChanges()()() | Rolls back all the changes made to the DataSet since it was created, or since the last time AcceptChanges()()() was called. (Inherited from DataSet.)
 | Relations |
 | RemotingFormat | Gets or sets a SerializationFormat for the DataSet used during remoting. (Inherited from DataSet.)
 | Reset()()() | Resets the DataSet to its original state. Subclasses should override Reset()()() to restore a DataSet to its original state. (Inherited from DataSet.)
 | SchemaSerializationMode | (Overrides DataSet.SchemaSerializationMode.)
 | ShouldSerializeRelations()()() | (Overrides DataSet.ShouldSerializeRelations()()().)
 | ShouldSerializeTables()()() | (Overrides DataSet.ShouldSerializeTables()()().)
 | Site | Gets or sets an ISite for the DataSet. (Inherited from DataSet.)
 | Tables |
 | ToString()()() | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from MarshalByValueComponent.)
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream. (Inherited from DataSet.)
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter. (Inherited from DataSet.)
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter. (Inherited from DataSet.)
 | WriteXml(String) | Writes the current data for the DataSet to the specified file. (Inherited from DataSet.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataSet.)
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object. (Inherited from DataSet.)
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object. (Inherited from DataSet.)
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file. (Inherited from DataSet.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataSet
 |  |  | DSNetworkCredentials


DSNetworkCredentials Constructor

DSNetworkCredentials Constructor
Namespaces ► VisualCron ► DSNetworkCredentials ► DSNetworkCredentials()()()
Members
Icon | Member | Description
 | DSNetworkCredentials()()() | Initializes a new instance of the DSNetworkCredentials class
 | DSNetworkCredentials(SerializationInfo, StreamingContext) | Initializes a new instance of the DSNetworkCredentials class


DSNetworkCredentials Constructor

DSNetworkCredentials Constructor
Namespaces ► VisualCron ► DSNetworkCredentials ► DSNetworkCredentials()()()
Initializes a new instance of the DSNetworkCredentials class
Declaration Syntax
C# Visual Basic Visual C++
public DSNetworkCredentials()
Public Sub New
public:
DSNetworkCredentials()


DSNetworkCredentials Constructor (info, context)

DSNetworkCredentials Constructor (info, context)
Namespaces ► VisualCron ► DSNetworkCredentials ► DSNetworkCredentials(SerializationInfo, StreamingContext)
Initializes a new instance of the DSNetworkCredentials class
Declaration Syntax
C# Visual Basic Visual C++
protected DSNetworkCredentials(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
DSNetworkCredentials(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSNetworkCredentials.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSNetworkCredentials.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSNetworkCredentials ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataSet Clone()
Public Overrides Function Clone As DataSet
public:
virtual DataSet^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.Clone]


GetSchemaSerializable Method

GetSchemaSerializable Method
Namespaces ► VisualCron ► DSNetworkCredentials ► GetSchemaSerializable()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.GetSchemaSerializable]

Declaration Syntax
C# Visual Basic Visual C++
protected override XmlSchema GetSchemaSerializable()
Protected Overrides Function GetSchemaSerializable As XmlSchema
protected:
virtual XmlSchema^ GetSchemaSerializable() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.GetSchemaSerializable]


GetTypedDataSetSchema Method (xs)

GetTypedDataSetSchema Method (xs)
Namespaces ► VisualCron ► DSNetworkCredentials ► GetTypedDataSetSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedDataSetSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedDataSetSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedDataSetSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSNetworkCredentials.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.GetTypedDataSetSchema(System.Xml.Schema.XmlSchemaSet)]


InitializeDerivedDataSet Method

InitializeDerivedDataSet Method
Namespaces ► VisualCron ► DSNetworkCredentials ► InitializeDerivedDataSet()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.InitializeDerivedDataSet]

Declaration Syntax
C# Visual Basic Visual C++
protected override void InitializeDerivedDataSet()
Protected Overrides Sub InitializeDerivedDataSet
protected:
virtual void InitializeDerivedDataSet() override


NetworkCredentials Property

NetworkCredentials Property
Namespaces ► VisualCron ► DSNetworkCredentials ► NetworkCredentials

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentials]

Declaration Syntax
C# Visual Basic Visual C++
public DSNetworkCredentials..::.NetworkCredentialsDataTable NetworkCredentials { get; }
Public ReadOnly Property NetworkCredentials As DSNetworkCredentials..::.NetworkCredentialsDataTable
public:
property DSNetworkCredentials..::.NetworkCredentialsDataTable^ NetworkCredentials {
    DSNetworkCredentials..::.NetworkCredentialsDataTable^ get ();
}


ReadXmlSerializable Method (reader)

ReadXmlSerializable Method (reader)
Namespaces ► VisualCron ► DSNetworkCredentials ► ReadXmlSerializable(XmlReader)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.ReadXmlSerializable(System.Xml.XmlReader)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void ReadXmlSerializable(
    XmlReader reader
)
Protected Overrides Sub ReadXmlSerializable ( _
    reader As XmlReader _
)
protected:
virtual void ReadXmlSerializable(
    XmlReader^ reader
) override
Parameters
reader (XmlReader)

[Missing <param name="reader"/> documentation for "M:VisualCron.DSNetworkCredentials.ReadXmlSerializable(System.Xml.XmlReader)"]


Relations Property

Relations Property
Namespaces ► VisualCron ► DSNetworkCredentials ► Relations

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.Relations]

Declaration Syntax
C# Visual Basic Visual C++
public DataRelationCollection Relations { get; }
Public ReadOnly Property Relations As DataRelationCollection
public:
property DataRelationCollection^ Relations {
    DataRelationCollection^ get ();
}


SchemaSerializationMode Property

SchemaSerializationMode Property
Namespaces ► VisualCron ► DSNetworkCredentials ► SchemaSerializationMode

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.SchemaSerializationMode]

Declaration Syntax
C# Visual Basic Visual C++
public override SchemaSerializationMode SchemaSerializationMode { get; set; }
Public Overrides Property SchemaSerializationMode As SchemaSerializationMode
public:
virtual property SchemaSerializationMode SchemaSerializationMode {
    SchemaSerializationMode get () override;
    void set (SchemaSerializationMode value) override;
}


ShouldSerializeRelations Method

ShouldSerializeRelations Method
Namespaces ► VisualCron ► DSNetworkCredentials ► ShouldSerializeRelations()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.ShouldSerializeRelations]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeRelations()
Protected Overrides Function ShouldSerializeRelations As Boolean
protected:
virtual bool ShouldSerializeRelations() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.ShouldSerializeRelations]


ShouldSerializeTables Method

ShouldSerializeTables Method
Namespaces ► VisualCron ► DSNetworkCredentials ► ShouldSerializeTables()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.ShouldSerializeTables]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool ShouldSerializeTables()
Protected Overrides Function ShouldSerializeTables As Boolean
protected:
virtual bool ShouldSerializeTables() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.ShouldSerializeTables]


Tables Property

Tables Property
Namespaces ► VisualCron ► DSNetworkCredentials ► Tables

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.Tables]

Declaration Syntax
C# Visual Basic Visual C++
public DataTableCollection Tables { get; }
Public ReadOnly Property Tables As DataTableCollection
public:
property DataTableCollection^ Tables {
    DataTableCollection^ get ();
}


DSNetworkCredentials.NetworkCredentialsDataTable Class

DSNetworkCredentials..::.NetworkCredentialsDataTable Class
Namespaces ► VisualCron ► DSNetworkCredentials ► DSNetworkCredentials..::.NetworkCredentialsDataTable
Represents the strongly named DataTable class.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkCredentialsDataTable : DataTable,
    IEnumerable
<SerializableAttribute> _
Public Class NetworkCredentialsDataTable _
    Inherits DataTable _
    Implements IEnumerable
[SerializableAttribute]
public ref class NetworkCredentialsDataTable : public DataTable,
    IEnumerable
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSNetworkCredentials..::.NetworkCredentialsDataTable()()() | Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsDataTable class
 | DSNetworkCredentials..::.NetworkCredentialsDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsDataTable class
 | AcceptChanges()()() | Commits all the changes made to this table since the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | AddNetworkCredentialsRow(DSNetworkCredentials..::.NetworkCredentialsRow) |
 | AddNetworkCredentialsRow(String, String) |
 | BeginInit()()() | Begins the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | BeginLoadData()()() | Turns off notifications, index maintenance, and constraints while loading data. (Inherited from DataTable.)
 | CaseSensitive | Indicates whether string comparisons within the table are case-sensitive. (Inherited from DataTable.)
 | ChildRelations | Gets the collection of child relations for this DataTable. (Inherited from DataTable.)
 | Clear()()() | Clears the DataTable of all data. (Inherited from DataTable.)
 | Clone()()() | (Overrides DataTable.Clone()()().)
 | ColumnChanged | Occurs after a value has been changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | ColumnChanging | Occurs when a value is being changed for the specified DataColumn in a DataRow. (Inherited from DataTable.)
 | Columns | Gets the collection of columns that belong to this table. (Inherited from DataTable.)
 | Compute(String, String) | Computes the given expression on the current rows that pass the filter criteria. (Inherited from DataTable.)
 | Constraints | Gets the collection of constraints maintained by this table. (Inherited from DataTable.)
 | Container | Gets the container for the component. (Inherited from MarshalByValueComponent.)
 | Copy()()() | Copies both the structure and data for this DataTable. (Inherited from DataTable.)
 | Count |
 | CreateDataReader()()() | Returns a DataTableReader corresponding to the data within this DataTable. (Inherited from DataTable.)
 | CreateInstance()()() | (Overrides DataTable.CreateInstance()()().)
 | DataSet | Gets the DataSet to which this table belongs. (Inherited from DataTable.)
 | DefaultView | Gets a customized view of the table that may include a filtered view, or a cursor position. (Inherited from DataTable.)
 | DescriptionColumn |
 | DesignMode | Gets a value indicating whether the component is currently in design mode. (Inherited from MarshalByValueComponent.)
 | DisplayExpression | Gets or sets the expression that returns a value used to represent this table in the user interface. The DisplayExpression property lets you display the name of this table in a user interface. (Inherited from DataTable.)
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent. (Inherited from MarshalByValueComponent.)
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources. (Inherited from MarshalByValueComponent.)
 | Disposed | Adds an event handler to listen to the Disposed event on the component. (Inherited from MarshalByValueComponent.)
 | EndInit()()() | Ends the initialization of a DataTable that is used on a form or used by another component. The initialization occurs at run time. (Inherited from DataTable.)
 | EndLoadData()()() | Turns on notifications, index maintenance, and constraints after loading data. (Inherited from DataTable.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Events | Gets the list of event handlers that are attached to this component. (Inherited from MarshalByValueComponent.)
 | ExtendedProperties | Gets the collection of customized user information. (Inherited from DataTable.)
 | Finalize()()() | [To be supplied.] (Inherited from MarshalByValueComponent.)
 | FindById(String) |
 | fInitInProgress | (Inherited from DataTable.)
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called. (Inherited from DataTable.)
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState. (Inherited from DataTable.)
 | GetEnumerator()()() |
 | GetErrors()()() | Gets an array of DataRow objects that contain errors. (Inherited from DataTable.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | Populates a serialization information object with the data needed to serialize the DataTable. (Inherited from DataTable.)
 | GetRowType()()() | (Overrides DataTable.GetRowType()()().)
 | GetSchema()()() | (Inherited from DataTable.)
 | GetService(Type) | Gets the implementer of the IServiceProvider. (Inherited from MarshalByValueComponent.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypedTableSchema(XmlSchemaSet) |
 | HasErrors | Gets a value indicating whether there are errors in any of the rows in any of the tables of the DataSet to which the table belongs. (Inherited from DataTable.)
 | IdColumn |
 | ImportRow(DataRow) | Copies a DataRow into a DataTable, preserving any property settings, as well as original and current values. (Inherited from DataTable.)
 | Initialized | Occurs after the DataTable is initialized. (Inherited from DataTable.)
 | IsInitialized | Gets a value that indicates whether the DataTable is initialized. (Inherited from DataTable.)
 | Item[([(Int32])]) |
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter. (Inherited from DataTable.)
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values. (Inherited from DataTable.)
 | Locale | Gets or sets the locale information used to compare strings within the table. (Inherited from DataTable.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable. (Inherited from DataTable.)
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable. (Inherited from DataTable.)
 | MinimumCapacity | Gets or sets the initial starting size for this table. (Inherited from DataTable.)
 | Namespace | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | NetworkCredentialsRowChanged |
 | NetworkCredentialsRowChanging |
 | NetworkCredentialsRowDeleted |
 | NetworkCredentialsRowDeleting |
 | NewNetworkCredentialsRow()()() |
 | NewRow()()() | Creates a new DataRow with the same schema as the table. (Inherited from DataTable.)
 | NewRowArray(Int32) | (Inherited from DataTable.)
 | NewRowFromBuilder(DataRowBuilder) | (Overrides DataTable.NewRowFromBuilder(DataRowBuilder).)
 | OnColumnChanged(DataColumnChangeEventArgs) | Raises the ColumnChanged event. (Inherited from DataTable.)
 | OnColumnChanging(DataColumnChangeEventArgs) | Raises the ColumnChanging event. (Inherited from DataTable.)
 | OnPropertyChanging(PropertyChangedEventArgs) | Raises the PropertyChanged event. (Inherited from DataTable.)
 | OnRemoveColumn(DataColumn) | Notifies the DataTable that a DataColumn is being removed. (Inherited from DataTable.)
 | OnRowChanged(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanged(DataRowChangeEventArgs).)
 | OnRowChanging(DataRowChangeEventArgs) | (Overrides DataTable.OnRowChanging(DataRowChangeEventArgs).)
 | OnRowDeleted(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleted(DataRowChangeEventArgs).)
 | OnRowDeleting(DataRowChangeEventArgs) | (Overrides DataTable.OnRowDeleting(DataRowChangeEventArgs).)
 | OnTableCleared(DataTableClearEventArgs) | Raises the TableCleared event. (Inherited from DataTable.)
 | OnTableClearing(DataTableClearEventArgs) | Raises the TableClearing event. (Inherited from DataTable.)
 | OnTableNewRow(DataTableNewRowEventArgs) | Raises the TableNewRow event. (Inherited from DataTable.)
 | ParentRelations | Gets the collection of parent relations for this DataTable. (Inherited from DataTable.)
 | Prefix | Gets or sets the namespace for the XML representation of the data stored in the DataTable. (Inherited from DataTable.)
 | PrimaryKey | Gets or sets an array of columns that function as primary keys for the data table. (Inherited from DataTable.)
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream. (Inherited from DataTable.)
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream. (Inherited from DataTable.)
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader. (Inherited from DataTable.)
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file. (Inherited from DataTable.)
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader. (Inherited from DataTable.)
 | ReadXmlSerializable(XmlReader) | (Inherited from DataTable.)
 | RejectChanges()()() | Rolls back all changes that have been made to the table since it was loaded, or the last time AcceptChanges()()() was called. (Inherited from DataTable.)
 | RemotingFormat | Gets or sets the serialization format. (Inherited from DataTable.)
 | RemoveNetworkCredentialsRow(DSNetworkCredentials..::.NetworkCredentialsRow) |
 | Reset()()() | Resets the DataTable to its original state. (Inherited from DataTable.)
 | RowChanged | Occurs after a DataRow has been changed successfully. (Inherited from DataTable.)
 | RowChanging | Occurs when a DataRow is changing. (Inherited from DataTable.)
 | RowDeleted | Occurs after a row in the table has been deleted. (Inherited from DataTable.)
 | RowDeleting | Occurs before a row in the table is about to be deleted. (Inherited from DataTable.)
 | Rows | Gets the collection of rows that belong to this table. (Inherited from DataTable.)
 | Select()()() | Gets an array of all DataRow objects. (Inherited from DataTable.)
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.) (Inherited from DataTable.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order. (Inherited from DataTable.)
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state. (Inherited from DataTable.)
 | Site | Gets or sets an ISite for the DataTable. (Inherited from DataTable.)
 | TableCleared | Occurs after a DataTable is cleared. (Inherited from DataTable.)
 | TableClearing | Occurs when a DataTable is cleared. (Inherited from DataTable.)
 | TableName | Gets or sets the name of the DataTable. (Inherited from DataTable.)
 | TableNewRow | Occurs when a new DataRow is inserted. (Inherited from DataTable.)
 | ToString()()() | Gets the TableName and DisplayExpression, if there is one as a concatenated string. (Inherited from DataTable.)
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream. (Inherited from DataTable.)
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter. (Inherited from DataTable.)
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file. (Inherited from DataTable.)
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. (Inherited from DataTable.)
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream. (Inherited from DataTable.)
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. (Inherited from DataTable.)
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. (Inherited from DataTable.)
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file. (Inherited from DataTable.)
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true. (Inherited from DataTable.)
Inheritance Hierarchy
Object
 | MarshalByValueComponent
 |  | DataTable
 |  |  | DSNetworkCredentials..::.NetworkCredentialsDataTable


DSNetworkCredentials.NetworkCredentialsDataTable Constructor

DSNetworkCredentials..::.NetworkCredentialsDataTable Constructor
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► DSNetworkCredentials..::.NetworkCredentialsDataTable()()()
Members
Icon | Member | Description
 | DSNetworkCredentials..::.NetworkCredentialsDataTable()()() | Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsDataTable class
 | DSNetworkCredentials..::.NetworkCredentialsDataTable(SerializationInfo, StreamingContext) | Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsDataTable class


DSNetworkCredentials.NetworkCredentialsDataTable Constructor

DSNetworkCredentials..::.NetworkCredentialsDataTable Constructor
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► DSNetworkCredentials..::.NetworkCredentialsDataTable()()()
Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsDataTable class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialsDataTable()
Public Sub New
public:
NetworkCredentialsDataTable()


DSNetworkCredentials.NetworkCredentialsDataTable Constructor (info, context)

DSNetworkCredentials..::.NetworkCredentialsDataTable Constructor (info, context)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► DSNetworkCredentials..::.NetworkCredentialsDataTable(SerializationInfo, StreamingContext)
Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsDataTable class
Declaration Syntax
C# Visual Basic Visual C++
protected NetworkCredentialsDataTable(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
NetworkCredentialsDataTable(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


AddNetworkCredentialsRow Method

AddNetworkCredentialsRow Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► AddNetworkCredentialsRow()()()
Members
Icon | Member | Description
 | AddNetworkCredentialsRow(DSNetworkCredentials..::.NetworkCredentialsRow) |
 | AddNetworkCredentialsRow(String, String) |


AddNetworkCredentialsRow Method (Id, Description)

AddNetworkCredentialsRow Method (Id, Description)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► AddNetworkCredentialsRow(String, String)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.AddNetworkCredentialsRow(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSNetworkCredentials..::.NetworkCredentialsRow AddNetworkCredentialsRow(
    string Id,
    string Description
)
Public Function AddNetworkCredentialsRow ( _
    Id As String, _
    Description As String _
) As DSNetworkCredentials..::.NetworkCredentialsRow
public:
DSNetworkCredentials..::.NetworkCredentialsRow^ AddNetworkCredentialsRow(
    String^ Id,
    String^ Description
)
Parameters
Id (String)

[Missing <param name="Id"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.AddNetworkCredentialsRow(System.String,System.String)"]

Description (String)

[Missing <param name="Description"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.AddNetworkCredentialsRow(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.AddNetworkCredentialsRow(System.String,System.String)]


AddNetworkCredentialsRow Method (row)

AddNetworkCredentialsRow Method (row)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► AddNetworkCredentialsRow(DSNetworkCredentials..::.NetworkCredentialsRow)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.AddNetworkCredentialsRow(VisualCron.DSNetworkCredentials.NetworkCredentialsRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddNetworkCredentialsRow(
    DSNetworkCredentials..::.NetworkCredentialsRow row
)
Public Sub AddNetworkCredentialsRow ( _
    row As DSNetworkCredentials..::.NetworkCredentialsRow _
)
public:
void AddNetworkCredentialsRow(
    DSNetworkCredentials..::.NetworkCredentialsRow^ row
)
Parameters
row (DSNetworkCredentials..::.NetworkCredentialsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.AddNetworkCredentialsRow(VisualCron.DSNetworkCredentials.NetworkCredentialsRow)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► Clone()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override DataTable Clone()
Public Overrides Function Clone As DataTable
public:
virtual DataTable^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.Clone]


Count Property

Count Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► Count

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


CreateInstance Method

CreateInstance Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► CreateInstance()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.CreateInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataTable CreateInstance()
Protected Overrides Function CreateInstance As DataTable
protected:
virtual DataTable^ CreateInstance() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.CreateInstance]


DescriptionColumn Property

DescriptionColumn Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► DescriptionColumn

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.DescriptionColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn DescriptionColumn { get; }
Public ReadOnly Property DescriptionColumn As DataColumn
public:
property DataColumn^ DescriptionColumn {
    DataColumn^ get ();
}


FindById Method (Id)

FindById Method (Id)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► FindById(String)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.FindById(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DSNetworkCredentials..::.NetworkCredentialsRow FindById(
    string Id
)
Public Function FindById ( _
    Id As String _
) As DSNetworkCredentials..::.NetworkCredentialsRow
public:
DSNetworkCredentials..::.NetworkCredentialsRow^ FindById(
    String^ Id
)
Parameters
Id (String)

[Missing <param name="Id"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.FindById(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.FindById(System.String)]


GetEnumerator Method

GetEnumerator Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► GetEnumerator()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public virtual IEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator()
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.GetEnumerator]


GetRowType Method

GetRowType Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► GetRowType()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.GetRowType]

Declaration Syntax
C# Visual Basic Visual C++
protected override Type GetRowType()
Protected Overrides Function GetRowType As Type
protected:
virtual Type^ GetRowType() override
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.GetRowType]


GetTypedTableSchema Method (xs)

GetTypedTableSchema Method (xs)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► GetTypedTableSchema(XmlSchemaSet)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlSchemaComplexType GetTypedTableSchema(
    XmlSchemaSet xs
)
Public Shared Function GetTypedTableSchema ( _
    xs As XmlSchemaSet _
) As XmlSchemaComplexType
public:
static XmlSchemaComplexType^ GetTypedTableSchema(
    XmlSchemaSet^ xs
)
Parameters
xs (XmlSchemaSet)

[Missing <param name="xs"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.GetTypedTableSchema(System.Xml.Schema.XmlSchemaSet)]


IdColumn Property

IdColumn Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► IdColumn

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.IdColumn]

Declaration Syntax
C# Visual Basic Visual C++
public DataColumn IdColumn { get; }
Public ReadOnly Property IdColumn As DataColumn
public:
property DataColumn^ IdColumn {
    DataColumn^ get ();
}


Item Property (index)

Item Property (index)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► Item[([(Int32])])

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.Item(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public DSNetworkCredentials..::.NetworkCredentialsRow this[
    int index
] { get; }
Public ReadOnly Default Property Item ( _
    index As Integer _
) As DSNetworkCredentials..::.NetworkCredentialsRow
public:
property DSNetworkCredentials..::.NetworkCredentialsRow^ default[int index] {
    DSNetworkCredentials..::.NetworkCredentialsRow^ get (int index);
}
Parameters
index (Int32)


NetworkCredentialsRowChanged Event

NetworkCredentialsRowChanged Event
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► NetworkCredentialsRowChanged

[Missing <summary> documentation for E:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NetworkCredentialsRowChanged]

Declaration Syntax
C# Visual Basic Visual C++
public event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler NetworkCredentialsRowChanged
Public Event NetworkCredentialsRowChanged As DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler
public:
 event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ NetworkCredentialsRowChanged {
    void add (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
    void remove (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
}


NetworkCredentialsRowChanging Event

NetworkCredentialsRowChanging Event
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► NetworkCredentialsRowChanging

[Missing <summary> documentation for E:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NetworkCredentialsRowChanging]

Declaration Syntax
C# Visual Basic Visual C++
public event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler NetworkCredentialsRowChanging
Public Event NetworkCredentialsRowChanging As DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler
public:
 event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ NetworkCredentialsRowChanging {
    void add (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
    void remove (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
}


NetworkCredentialsRowDeleted Event

NetworkCredentialsRowDeleted Event
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► NetworkCredentialsRowDeleted

[Missing <summary> documentation for E:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NetworkCredentialsRowDeleted]

Declaration Syntax
C# Visual Basic Visual C++
public event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler NetworkCredentialsRowDeleted
Public Event NetworkCredentialsRowDeleted As DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler
public:
 event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ NetworkCredentialsRowDeleted {
    void add (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
    void remove (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
}


NetworkCredentialsRowDeleting Event

NetworkCredentialsRowDeleting Event
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► NetworkCredentialsRowDeleting

[Missing <summary> documentation for E:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NetworkCredentialsRowDeleting]

Declaration Syntax
C# Visual Basic Visual C++
public event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler NetworkCredentialsRowDeleting
Public Event NetworkCredentialsRowDeleting As DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler
public:
 event DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ NetworkCredentialsRowDeleting {
    void add (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
    void remove (DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler^ value);
}


NewNetworkCredentialsRow Method

NewNetworkCredentialsRow Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► NewNetworkCredentialsRow()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NewNetworkCredentialsRow]

Declaration Syntax
C# Visual Basic Visual C++
public DSNetworkCredentials..::.NetworkCredentialsRow NewNetworkCredentialsRow()
Public Function NewNetworkCredentialsRow As DSNetworkCredentials..::.NetworkCredentialsRow
public:
DSNetworkCredentials..::.NetworkCredentialsRow^ NewNetworkCredentialsRow()
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NewNetworkCredentialsRow]


NewRowFromBuilder Method (builder)

NewRowFromBuilder Method (builder)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► NewRowFromBuilder(DataRowBuilder)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
protected override DataRow NewRowFromBuilder(
    DataRowBuilder builder
)
Protected Overrides Function NewRowFromBuilder ( _
    builder As DataRowBuilder _
) As DataRow
protected:
virtual DataRow^ NewRowFromBuilder(
    DataRowBuilder^ builder
) override
Parameters
builder (DataRowBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)"]

Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.NewRowFromBuilder(System.Data.DataRowBuilder)]


OnRowChanged Method (e)

OnRowChanged Method (e)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► OnRowChanged(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanged(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanged ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanged(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowChanged(System.Data.DataRowChangeEventArgs)"]


OnRowChanging Method (e)

OnRowChanging Method (e)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► OnRowChanging(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowChanging(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowChanging ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowChanging(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowChanging(System.Data.DataRowChangeEventArgs)"]


OnRowDeleted Method (e)

OnRowDeleted Method (e)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► OnRowDeleted(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleted(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleted ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleted(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowDeleted(System.Data.DataRowChangeEventArgs)"]


OnRowDeleting Method (e)

OnRowDeleting Method (e)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► OnRowDeleting(DataRowChangeEventArgs)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void OnRowDeleting(
    DataRowChangeEventArgs e
)
Protected Overrides Sub OnRowDeleting ( _
    e As DataRowChangeEventArgs _
)
protected:
virtual void OnRowDeleting(
    DataRowChangeEventArgs^ e
) override
Parameters
e (DataRowChangeEventArgs)

[Missing <param name="e"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.OnRowDeleting(System.Data.DataRowChangeEventArgs)"]


RemoveNetworkCredentialsRow Method (row)

RemoveNetworkCredentialsRow Method (row)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► RemoveNetworkCredentialsRow(DSNetworkCredentials..::.NetworkCredentialsRow)

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.RemoveNetworkCredentialsRow(VisualCron.DSNetworkCredentials.NetworkCredentialsRow)]

Declaration Syntax
C# Visual Basic Visual C++
public void RemoveNetworkCredentialsRow(
    DSNetworkCredentials..::.NetworkCredentialsRow row
)
Public Sub RemoveNetworkCredentialsRow ( _
    row As DSNetworkCredentials..::.NetworkCredentialsRow _
)
public:
void RemoveNetworkCredentialsRow(
    DSNetworkCredentials..::.NetworkCredentialsRow^ row
)
Parameters
row (DSNetworkCredentials..::.NetworkCredentialsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsDataTable.RemoveNetworkCredentialsRow(VisualCron.DSNetworkCredentials.NetworkCredentialsRow)"]


DSNetworkCredentials.NetworkCredentialsRow Class

DSNetworkCredentials..::.NetworkCredentialsRow Class
Namespaces ► VisualCron ► DSNetworkCredentials ► DSNetworkCredentials..::.NetworkCredentialsRow
Represents strongly named DataRow class.
Declaration Syntax
C# Visual Basic Visual C++
public class NetworkCredentialsRow : DataRow
Public Class NetworkCredentialsRow _
    Inherits DataRow
public ref class NetworkCredentialsRow : public DataRow
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AcceptChanges()()() | Commits all the changes made to this row since the last time AcceptChanges()()() was called. (Inherited from DataRow.)
 | BeginEdit()()() | Starts an edit operation on a DataRow object. (Inherited from DataRow.)
 | CancelEdit()()() | Cancels the current edit on the row. (Inherited from DataRow.)
 | ClearErrors()()() | Clears the errors for the row. This includes the RowError and errors set with SetColumnError(Int32, String). (Inherited from DataRow.)
 | Delete()()() | Deletes the DataRow. (Inherited from DataRow.)
 | Description |
 | EndEdit()()() | Ends the edit occurring on the row. (Inherited from DataRow.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetColumnError(Int32) | Gets the error description for the column specified by index. (Inherited from DataRow.)
 | GetColumnError(String) | Gets the error description for a column, specified by name. (Inherited from DataRow.)
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn. (Inherited from DataRow.)
 | GetColumnsInError()()() | Gets an array of columns that have errors. (Inherited from DataRow.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation. (Inherited from DataRow.)
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation. (Inherited from DataRow.)
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion. (Inherited from DataRow.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasErrors | Gets a value that indicates whether there are errors in a row. (Inherited from DataRow.)
 | HasVersion(DataRowVersion) | Gets a value that indicates whether a specified version exists. (Inherited from DataRow.)
 | Id |
 | IsDescriptionNull()()() |
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value. (Inherited from DataRow.)
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value. (Inherited from DataRow.)
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value. (Inherited from DataRow.)
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index. (Inherited from DataRow.)
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name. (Inherited from DataRow.)
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn. (Inherited from DataRow.)
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve. (Inherited from DataRow.)
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column. (Inherited from DataRow.)
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn. (Inherited from DataRow.)
 | ItemArray | Gets or sets all the values for this row through an array. (Inherited from DataRow.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RejectChanges()()() | Rejects all changes made to the row since AcceptChanges()()() was last called. (Inherited from DataRow.)
 | RowError | Gets or sets the custom error description for a row. (Inherited from DataRow.)
 | RowState | Gets the current state of the row with regard to its relationship to the DataRowCollection. (Inherited from DataRow.)
 | SetAdded()()() | Changes the Rowstate()()() of a DataRow to Added. (Inherited from DataRow.)
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index. (Inherited from DataRow.)
 | SetColumnError(String, String) | Sets the error description for a column specified by name. (Inherited from DataRow.)
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn. (Inherited from DataRow.)
 | SetDescriptionNull()()() |
 | SetModified()()() | Changes the Rowstate()()() of a DataRow to Modified. (Inherited from DataRow.)
 | SetNull(DataColumn) | Sets the value of the specified DataColumn to a null value. (Inherited from DataRow.)
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow. (Inherited from DataRow.)
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation. (Inherited from DataRow.)
 | Table | Gets the DataTable for which this row has a schema. (Inherited from DataRow.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | DataRow
 |  | DSNetworkCredentials..::.NetworkCredentialsRow


Description Property

Description Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► Description

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsRow.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Id Property

Id Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► Id

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsRow.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


IsDescriptionNull Method

IsDescriptionNull Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► IsDescriptionNull()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsRow.IsDescriptionNull]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsDescriptionNull()
Public Function IsDescriptionNull As Boolean
public:
bool IsDescriptionNull()
Return Value

[Missing <returns> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsRow.IsDescriptionNull]


SetDescriptionNull Method

SetDescriptionNull Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► SetDescriptionNull()()()

[Missing <summary> documentation for M:VisualCron.DSNetworkCredentials.NetworkCredentialsRow.SetDescriptionNull]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDescriptionNull()
Public Sub SetDescriptionNull
public:
void SetDescriptionNull()


DSNetworkCredentials.NetworkCredentialsRowChangeEvent Class

DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent Class
Namespaces ► VisualCron ► DSNetworkCredentials ► DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent
Row event argument class
Declaration Syntax
C# Visual Basic Visual C++
public class NetworkCredentialsRowChangeEvent : EventArgs
Public Class NetworkCredentialsRowChangeEvent _
    Inherits EventArgs
public ref class NetworkCredentialsRowChangeEvent : public EventArgs
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent(DSNetworkCredentials..::.NetworkCredentialsRow, DataRowAction) | Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent class
 | Action |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Row |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | EventArgs
 |  | DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent


DSNetworkCredentials.NetworkCredentialsRowChangeEvent Constructor (row, action)

DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent Constructor (row, action)
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent ► DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent(DSNetworkCredentials..::.NetworkCredentialsRow, DataRowAction)
Initializes a new instance of the DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialsRowChangeEvent(
    DSNetworkCredentials..::.NetworkCredentialsRow row,
    DataRowAction action
)
Public Sub New ( _
    row As DSNetworkCredentials..::.NetworkCredentialsRow, _
    action As DataRowAction _
)
public:
NetworkCredentialsRowChangeEvent(
    DSNetworkCredentials..::.NetworkCredentialsRow^ row,
    DataRowAction action
)
Parameters
row (DSNetworkCredentials..::.NetworkCredentialsRow)

[Missing <param name="row"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsRowChangeEvent.#ctor(VisualCron.DSNetworkCredentials.NetworkCredentialsRow,System.Data.DataRowAction)"]

action (DataRowAction)

[Missing <param name="action"/> documentation for "M:VisualCron.DSNetworkCredentials.NetworkCredentialsRowChangeEvent.#ctor(VisualCron.DSNetworkCredentials.NetworkCredentialsRow,System.Data.DataRowAction)"]


Action Property

Action Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent ► Action

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsRowChangeEvent.Action]

Declaration Syntax
C# Visual Basic Visual C++
public DataRowAction Action { get; }
Public ReadOnly Property Action As DataRowAction
public:
property DataRowAction Action {
    DataRowAction get ();
}


Row Property

Row Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent ► Row

[Missing <summary> documentation for P:VisualCron.DSNetworkCredentials.NetworkCredentialsRowChangeEvent.Row]

Declaration Syntax
C# Visual Basic Visual C++
public DSNetworkCredentials..::.NetworkCredentialsRow Row { get; }
Public ReadOnly Property Row As DSNetworkCredentials..::.NetworkCredentialsRow
public:
property DSNetworkCredentials..::.NetworkCredentialsRow^ Row {
    DSNetworkCredentials..::.NetworkCredentialsRow^ get ();
}


DSNetworkCredentials.NetworkCredentialsRowChangeEventHandler Delegate

DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler Delegate
Namespaces ► VisualCron ► DSNetworkCredentials ► DSNetworkCredentials..::.NetworkCredentialsRowChangeEventHandler

[Missing <summary> documentation for T:VisualCron.DSNetworkCredentials.NetworkCredentialsRowChangeEventHandler]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void NetworkCredentialsRowChangeEventHandler(
    Object sender,
    DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent e
)
Public Delegate Sub NetworkCredentialsRowChangeEventHandler ( _
    sender As Object, _
    e As DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent _
)
public delegate void NetworkCredentialsRowChangeEventHandler(
    Object^ sender,
    DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent^ e
)
Parameters
sender (Object)
e (DSNetworkCredentials..::.NetworkCredentialsRowChangeEvent)


EmailClass Class

EmailClass Class
Namespaces ► VisualCron ► EmailClass

[Missing <summary> documentation for T:VisualCron.EmailClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EmailClass
<SerializableAttribute> _
Public Class EmailClass
[SerializableAttribute]
public ref class EmailClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmailClass()()() | Initializes a new instance of the EmailClass class
 | AuthReq |
 | Body |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromEmail |
 | FromName |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName |
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord |
 | Port |
 | Subject |
 | ToEmail |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName |
Inheritance Hierarchy
Object
EmailClass

Send comments on this topic to Please email feedback to Support


EmailClass Constructor

EmailClass Constructor
Namespaces ► VisualCron ► EmailClass ► EmailClass()()()
Initializes a new instance of the EmailClass class
Declaration Syntax
C# Visual Basic Visual C++
public EmailClass()
Public Sub New
public:
EmailClass()


AuthReq Property

AuthReq Property
Namespaces ► VisualCron ► EmailClass ► AuthReq

[Missing <summary> documentation for P:VisualCron.EmailClass.AuthReq]

Declaration Syntax
C# Visual Basic Visual C++
public bool AuthReq { get; set; }
Public Property AuthReq As Boolean
public:
property bool AuthReq {
    bool get ();
    void set (bool value);
}


Body Property

Body Property
Namespaces ► VisualCron ► EmailClass ► Body

[Missing <summary> documentation for P:VisualCron.EmailClass.Body]

Declaration Syntax
C# Visual Basic Visual C++
public string Body { get; set; }
Public Property Body As String
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}


FromEmail Property

FromEmail Property
Namespaces ► VisualCron ► EmailClass ► FromEmail

[Missing <summary> documentation for P:VisualCron.EmailClass.FromEmail]

Declaration Syntax
C# Visual Basic Visual C++
public string FromEmail { get; set; }
Public Property FromEmail As String
public:
property String^ FromEmail {
    String^ get ();
    void set (String^ value);
}


FromName Property

FromName Property
Namespaces ► VisualCron ► EmailClass ► FromName

[Missing <summary> documentation for P:VisualCron.EmailClass.FromName]

Declaration Syntax
C# Visual Basic Visual C++
public string FromName { get; set; }
Public Property FromName As String
public:
property String^ FromName {
    String^ get ();
    void set (String^ value);
}


HostName Property

HostName Property
Namespaces ► VisualCron ► EmailClass ► HostName

[Missing <summary> documentation for P:VisualCron.EmailClass.HostName]

Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}


Id Property

Id Property
Namespaces ► VisualCron ► EmailClass ► Id

[Missing <summary> documentation for P:VisualCron.EmailClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


PassWord Property

PassWord Property
Namespaces ► VisualCron ► EmailClass ► PassWord

[Missing <summary> documentation for P:VisualCron.EmailClass.PassWord]

Declaration Syntax
C# Visual Basic Visual C++
public string PassWord { get; set; }
Public Property PassWord As String
public:
property String^ PassWord {
    String^ get ();
    void set (String^ value);
}


Port Property

Port Property
Namespaces ► VisualCron ► EmailClass ► Port

[Missing <summary> documentation for P:VisualCron.EmailClass.Port]

Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
property int Port {
    int get ();
    void set (int value);
}


Subject Property

Subject Property
Namespaces ► VisualCron ► EmailClass ► Subject

[Missing <summary> documentation for P:VisualCron.EmailClass.Subject]

Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}


ToEmail Property

ToEmail Property
Namespaces ► VisualCron ► EmailClass ► ToEmail

[Missing <summary> documentation for P:VisualCron.EmailClass.ToEmail]

Declaration Syntax
C# Visual Basic Visual C++
public string ToEmail { get; set; }
Public Property ToEmail As String
public:
property String^ ToEmail {
    String^ get ();
    void set (String^ value);
}


UserName Property

UserName Property
Namespaces ► VisualCron ► EmailClass ► UserName

[Missing <summary> documentation for P:VisualCron.EmailClass.UserName]

Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}


EmailNotificationClass Class

EmailNotificationClass Class
Namespaces ► VisualCron ► EmailNotificationClass

[Missing <summary> documentation for T:VisualCron.EmailNotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EmailNotificationClass
<SerializableAttribute> _
Public Class EmailNotificationClass
[SerializableAttribute]
public ref class EmailNotificationClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmailNotificationClass()()() | Initializes a new instance of the EmailNotificationClass class
 | Attachments |
 | Body |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromEmail |
 | FromName |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Subject |
 | ToEmails |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EmailNotificationClass

Send comments on this topic to Please email feedback to Support


EmailNotificationClass Constructor

EmailNotificationClass Constructor
Namespaces ► VisualCron ► EmailNotificationClass ► EmailNotificationClass()()()
Initializes a new instance of the EmailNotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public EmailNotificationClass()
Public Sub New
public:
EmailNotificationClass()


Attachments Field

Attachments Field
Namespaces ► VisualCron ► EmailNotificationClass ► Attachments

[Missing <summary> documentation for F:VisualCron.EmailNotificationClass.Attachments]

Declaration Syntax
C# Visual Basic Visual C++
public List<AttachmentClass> Attachments
Public Attachments As List(Of AttachmentClass)
public:
List<AttachmentClass^>^ Attachments

Send comments on this topic to Please email feedback to Support


Body Property

Body Property
Namespaces ► VisualCron ► EmailNotificationClass ► Body

[Missing <summary> documentation for P:VisualCron.EmailNotificationClass.Body]

Declaration Syntax
C# Visual Basic Visual C++
public string Body { get; set; }
Public Property Body As String
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}


FromEmail Property

FromEmail Property
Namespaces ► VisualCron ► EmailNotificationClass ► FromEmail

[Missing <summary> documentation for P:VisualCron.EmailNotificationClass.FromEmail]

Declaration Syntax
C# Visual Basic Visual C++
public string FromEmail { get; set; }
Public Property FromEmail As String
public:
property String^ FromEmail {
    String^ get ();
    void set (String^ value);
}


FromName Property

FromName Property
Namespaces ► VisualCron ► EmailNotificationClass ► FromName

[Missing <summary> documentation for P:VisualCron.EmailNotificationClass.FromName]

Declaration Syntax
C# Visual Basic Visual C++
public string FromName { get; set; }
Public Property FromName As String
public:
property String^ FromName {
    String^ get ();
    void set (String^ value);
}


Subject Property

Subject Property
Namespaces ► VisualCron ► EmailNotificationClass ► Subject

[Missing <summary> documentation for P:VisualCron.EmailNotificationClass.Subject]

Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}


ToEmails Property

ToEmails Property
Namespaces ► VisualCron ► EmailNotificationClass ► ToEmails

[Missing <summary> documentation for P:VisualCron.EmailNotificationClass.ToEmails]

Declaration Syntax
C# Visual Basic Visual C++
public string ToEmails { get; set; }
Public Property ToEmails As String
public:
property String^ ToEmails {
    String^ get ();
    void set (String^ value);
}


EmailSettingClass Class

EmailSettingClass Class
Namespaces ► VisualCron ► EmailSettingClass

[Missing <summary> documentation for T:VisualCron.EmailSettingClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EmailSettingClass
<SerializableAttribute> _
Public Class EmailSettingClass
[SerializableAttribute]
public ref class EmailSettingClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EmailSettingClass()()() | Initializes a new instance of the EmailSettingClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EmailSettingClass

Send comments on this topic to Please email feedback to Support


EmailSettingClass Constructor

EmailSettingClass Constructor
Namespaces ► VisualCron ► EmailSettingClass ► EmailSettingClass()()()
Initializes a new instance of the EmailSettingClass class
Declaration Syntax
C# Visual Basic Visual C++
public EmailSettingClass()
Public Sub New
public:
EmailSettingClass()


EnumClass Class

EnumClass Class
Namespaces ► VisualCron ► EnumClass
A collection of enumeration classes
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EnumClass
<SerializableAttribute> _
Public Class EnumClass
[SerializableAttribute]
public ref class EnumClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EnumClass()()() | Initializes a new instance of the EnumClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EnumClass

Send comments on this topic to Please email feedback to Support


EnumClass Constructor

EnumClass Constructor
Namespaces ► VisualCron ► EnumClass ► EnumClass()()()
Initializes a new instance of the EnumClass class
Declaration Syntax
C# Visual Basic Visual C++
public EnumClass()
Public Sub New
public:
EnumClass()


EnumClass.ExistActionT Enumeration

EnumClass..::.ExistActionT Enumeration
Namespaces ► VisualCron ► EnumClass ► EnumClass..::.ExistActionT
Enum that is used to control different behavior
Declaration Syntax
C# Visual Basic Visual C++
public enum ExistActionT
Public Enumeration ExistActionT
public enum class ExistActionT
Members
Member | Description
Overwrite |
OverwriteIfNewer |
Append |
Skip |
AutoNumber |
Remarks

Send comments on this topic to Please email feedback to Support


EnumClass.LogoffScope Enumeration

EnumClass..::.LogoffScope Enumeration
Namespaces ► VisualCron ► EnumClass ► EnumClass..::.LogoffScope
Enum that defines if all or a certain user should be logged off
Declaration Syntax
C# Visual Basic Visual C++
public enum LogoffScope
Public Enumeration LogoffScope
public enum class LogoffScope
Members
Member | Description
LogoffAllUsers | Logs off all users
LogoffCertainUser | Logs off a certain user
Remarks

Send comments on this topic to Please email feedback to Support


EnumClass.MonitorStateT Enumeration

EnumClass..::.MonitorStateT Enumeration
Namespaces ► VisualCron ► EnumClass ► EnumClass..::.MonitorStateT
Enum that describes a wanted monitor state
Declaration Syntax
C# Visual Basic Visual C++
public enum MonitorStateT
Public Enumeration MonitorStateT
public enum class MonitorStateT
Members
Member | Description
On |
Off |
Remarks

Send comments on this topic to Please email feedback to Support


EnumClass.Scope Enumeration

EnumClass..::.Scope Enumeration
Namespaces ► VisualCron ► EnumClass ► EnumClass..::.Scope
Enum that defines if something is used locally or remotely
Declaration Syntax
C# Visual Basic Visual C++
public enum Scope
Public Enumeration Scope
public enum class Scope
Members
Member | Description
Local |
Remote |
Remarks

Send comments on this topic to Please email feedback to Support


EnumClass.WakeUpT Enumeration

EnumClass..::.WakeUpT Enumeration
Namespaces ► VisualCron ► EnumClass ► EnumClass..::.WakeUpT
Enum that is used in the Wake Up Task
Declaration Syntax
C# Visual Basic Visual C++
public enum WakeUpT
Public Enumeration WakeUpT
public enum class WakeUpT
Members
Member | Description
AtDateTime | Wake up at a certain date time
AtTime | Wake up at a certain time
AfterTime | Wake up after a certain time span
Remarks

Send comments on this topic to Please email feedback to Support


EventClass Class

EventClass Class
Namespaces ► VisualCron ► EventClass
Class that contains all kind of events
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EventClass : ICloneable
<SerializableAttribute> _
Public Class EventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class EventClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventClass(EventClass..::.EventTy) | Initializes a new instance of the EventClass class
 | EventClass()()() | Initializes a new instance of the EventClass class
 | Clone()()() |
 | CloneType()()() |
 | CustomWMIEvent | Gets or sets the Custom WMI Event
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventLog | Gets or sets the EventLog Event
 | EventType |
 | FileEvent | Gets or sets the file Event
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MailEvent |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkAddressChangedEvent | Gets or sets the Network Address Changed Event
 | NetworkAvailabilityChangedEvent | Gets or sets the Network Availablity Event
 | PerformanceCounterEvent |
 | ProcessEvent | Gets or sets the Process Event
 | RegistryEvent | Gets or sets the Registry Event
 | ServiceEvent | Gets or sets the Service Event
 | SetToNothing()()() |
 | SetToSomething()()() |
 | TimeChangedEvent | Gets or sets the Time Changed Event
 | TimesUntilExecute | Gets or sets trigger execute delay (1 is execute directly)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VisualCronEvent | Gets or sets the VisualCron Event
Remarks
Inheritance Hierarchy
Object
EventClass

Send comments on this topic to Please email feedback to Support


EventClass Constructor

EventClass Constructor
Namespaces ► VisualCron ► EventClass ► EventClass()()()
Members
Icon | Member | Description
 | EventClass(EventClass..::.EventTy) | Initializes a new instance of the EventClass class
 | EventClass()()() | Initializes a new instance of the EventClass class


EventClass Constructor

EventClass Constructor
Namespaces ► VisualCron ► EventClass ► EventClass()()()
Initializes a new instance of the EventClass class
Declaration Syntax
C# Visual Basic Visual C++
public EventClass()
Public Sub New
public:
EventClass()


EventClass Constructor (tet)

EventClass Constructor (tet)
Namespaces ► VisualCron ► EventClass ► EventClass(EventClass..::.EventTy)
Initializes a new instance of the EventClass class
Declaration Syntax
C# Visual Basic Visual C++
public EventClass(
    EventClass..::.EventTy tet
)
Public Sub New ( _
    tet As EventClass..::.EventTy _
)
public:
EventClass(
    EventClass..::.EventTy tet
)
Parameters
tet (EventClass..::.EventTy)

[Missing <param name="tet"/> documentation for "M:VisualCron.EventClass.#ctor(VisualCron.EventClass.EventTy)"]


Clone Method

Clone Method
Namespaces ► VisualCron ► EventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.EventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.EventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► EventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.EventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public EventClass CloneType()
Public Function CloneType As EventClass
public:
EventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.EventClass.CloneType]


CustomWMIEvent Field

CustomWMIEvent Field
Namespaces ► VisualCron ► EventClass ► CustomWMIEvent
Gets or sets the Custom WMI Event
Declaration Syntax
C# Visual Basic Visual C++
public CustomWMIEventClass CustomWMIEvent
Public CustomWMIEvent As CustomWMIEventClass
public:
CustomWMIEventClass^ CustomWMIEvent
Remarks

Send comments on this topic to Please email feedback to Support


EventLog Field

EventLog Field
Namespaces ► VisualCron ► EventClass ► EventLog
Gets or sets the EventLog Event
Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass EventLog
Public EventLog As EventLogEventClass
public:
EventLogEventClass^ EventLog
Remarks

Send comments on this topic to Please email feedback to Support


EventType Field

EventType Field
Namespaces ► VisualCron ► EventClass ► EventType

[Missing <summary> documentation for F:VisualCron.EventClass.EventType]

Declaration Syntax
C# Visual Basic Visual C++
public EventClass..::.EventTy EventType
Public EventType As EventClass..::.EventTy
public:
EventClass..::.EventTy EventType

Send comments on this topic to Please email feedback to Support


FileEvent Field

FileEvent Field
Namespaces ► VisualCron ► EventClass ► FileEvent
Gets or sets the file Event
Declaration Syntax
C# Visual Basic Visual C++
public FileEventClass FileEvent
Public FileEvent As FileEventClass
public:
FileEventClass^ FileEvent
Remarks

Send comments on this topic to Please email feedback to Support


MailEvent Field

MailEvent Field
Namespaces ► VisualCron ► EventClass ► MailEvent

[Missing <summary> documentation for F:VisualCron.EventClass.MailEvent]

Declaration Syntax
C# Visual Basic Visual C++
public MailEventClass MailEvent
Public MailEvent As MailEventClass
public:
MailEventClass^ MailEvent

Send comments on this topic to Please email feedback to Support


NetworkAddressChangedEvent Field

NetworkAddressChangedEvent Field
Namespaces ► VisualCron ► EventClass ► NetworkAddressChangedEvent
Gets or sets the Network Address Changed Event
Declaration Syntax
C# Visual Basic Visual C++
public NetworkAddressChangedEventClass NetworkAddressChangedEvent
Public NetworkAddressChangedEvent As NetworkAddressChangedEventClass
public:
NetworkAddressChangedEventClass^ NetworkAddressChangedEvent
Remarks

Send comments on this topic to Please email feedback to Support


NetworkAvailabilityChangedEvent Field

NetworkAvailabilityChangedEvent Field
Namespaces ► VisualCron ► EventClass ► NetworkAvailabilityChangedEvent
Gets or sets the Network Availablity Event
Declaration Syntax
C# Visual Basic Visual C++
public NetworkAvailabilityChangedEventClass NetworkAvailabilityChangedEvent
Public NetworkAvailabilityChangedEvent As NetworkAvailabilityChangedEventClass
public:
NetworkAvailabilityChangedEventClass^ NetworkAvailabilityChangedEvent
Remarks

Send comments on this topic to Please email feedback to Support


PerformanceCounterEvent Field

PerformanceCounterEvent Field
Namespaces ► VisualCron ► EventClass ► PerformanceCounterEvent

[Missing <summary> documentation for F:VisualCron.EventClass.PerformanceCounterEvent]

Declaration Syntax
C# Visual Basic Visual C++
public PerformanceCounterEventClass PerformanceCounterEvent
Public PerformanceCounterEvent As PerformanceCounterEventClass
public:
PerformanceCounterEventClass^ PerformanceCounterEvent


ProcessEvent Field

ProcessEvent Field
Namespaces ► VisualCron ► EventClass ► ProcessEvent
Gets or sets the Process Event
Declaration Syntax
C# Visual Basic Visual C++
public ProcessEventClass ProcessEvent
Public ProcessEvent As ProcessEventClass
public:
ProcessEventClass^ ProcessEvent
Remarks

Send comments on this topic to Please email feedback to Support


RegistryEvent Field

RegistryEvent Field
Namespaces ► VisualCron ► EventClass ► RegistryEvent
Gets or sets the Registry Event
Declaration Syntax
C# Visual Basic Visual C++
public RegistryEventClass RegistryEvent
Public RegistryEvent As RegistryEventClass
public:
RegistryEventClass^ RegistryEvent
Remarks

Send comments on this topic to Please email feedback to Support


ServiceEvent Field

ServiceEvent Field
Namespaces ► VisualCron ► EventClass ► ServiceEvent
Gets or sets the Service Event
Declaration Syntax
C# Visual Basic Visual C++
public ServiceEventClass ServiceEvent
Public ServiceEvent As ServiceEventClass
public:
ServiceEventClass^ ServiceEvent
Remarks

Send comments on this topic to Please email feedback to Support


SetToNothing Method

SetToNothing Method
Namespaces ► VisualCron ► EventClass ► SetToNothing()()()

[Missing <summary> documentation for M:VisualCron.EventClass.SetToNothing]

Declaration Syntax
C# Visual Basic Visual C++
public void SetToNothing()
Public Sub SetToNothing
public:
void SetToNothing()


SetToSomething Method

SetToSomething Method
Namespaces ► VisualCron ► EventClass ► SetToSomething()()()

[Missing <summary> documentation for M:VisualCron.EventClass.SetToSomething]

Declaration Syntax
C# Visual Basic Visual C++
public void SetToSomething()
Public Sub SetToSomething
public:
void SetToSomething()


TimeChangedEvent Field

TimeChangedEvent Field
Namespaces ► VisualCron ► EventClass ► TimeChangedEvent
Gets or sets the Time Changed Event
Declaration Syntax
C# Visual Basic Visual C++
public TimeChangedEventClass TimeChangedEvent
Public TimeChangedEvent As TimeChangedEventClass
public:
TimeChangedEventClass^ TimeChangedEvent
Remarks

Send comments on this topic to Please email feedback to Support


TimesUntilExecute Property

TimesUntilExecute Property
Namespaces ► VisualCron ► EventClass ► TimesUntilExecute
Gets or sets trigger execute delay (1 is execute directly)
Declaration Syntax
C# Visual Basic Visual C++
public int TimesUntilExecute { get; set; }
Public Property TimesUntilExecute As Integer
public:
property int TimesUntilExecute {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


VisualCronEvent Field

VisualCronEvent Field
Namespaces ► VisualCron ► EventClass ► VisualCronEvent
Gets or sets the VisualCron Event
Declaration Syntax
C# Visual Basic Visual C++
public VisualCronEventClass VisualCronEvent
Public VisualCronEvent As VisualCronEventClass
public:
VisualCronEventClass^ VisualCronEvent
Remarks

Send comments on this topic to Please email feedback to Support


EventClass.EventMatchT Enumeration

EventClass..::.EventMatchT Enumeration
Namespaces ► VisualCron ► EventClass ► EventClass..::.EventMatchT

[Missing <summary> documentation for T:VisualCron.EventClass.EventMatchT]

Declaration Syntax
C# Visual Basic Visual C++
public enum EventMatchT
Public Enumeration EventMatchT
public enum class EventMatchT
Members
Member | Description
Always |
Never |
AllMatch |
NoMatch |
AnyMatch |


EventClass.EventTy Enumeration

EventClass..::.EventTy Enumeration
Namespaces ► VisualCron ► EventClass ► EventClass..::.EventTy

[Missing <summary> documentation for T:VisualCron.EventClass.EventTy]

Declaration Syntax
C# Visual Basic Visual C++
public enum EventTy
Public Enumeration EventTy
public enum class EventTy
Members
Member | Description
VisualCron |
File |
Process |
Service |
Registry |
EventLog |
CustomWMI |
TimeChanged |
NetworkAvailabilityChanged |
NetworkAddressChanged |
PerformanceCounter |
Mail |


EventLogEventClass Class

EventLogEventClass Class
Namespaces ► VisualCron ► EventLogEventClass
EventLog Event
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EventLogEventClass : ICloneable
<SerializableAttribute> _
Public Class EventLogEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class EventLogEventClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventLogEventClass()()() | Initializes a new instance of the EventLogEventClass class
 | Category | Category of event
 | CategoryOp |
 | CategoryString | String representation of event category
 | CategoryStringOp |
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventCode | Code of event
 | EventCodeOp |
 | EventType |
 | EventTypeOp |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDescription(EventLogEventClass..::.OperatorT) | Descripts a an operator type
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interval | How often it should be queried in the WMI in seconds
 | LogFile |
 | LogFileOp |
 | Machine | Server name/ip of computer
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Actual event category message
 | MessageOp |
 | NetworkCredential | Id of Network Credential that will be used to get access
 | SourceName |
 | SourceNameOp |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
EventLogEventClass

Send comments on this topic to Please email feedback to Support


EventLogEventClass Constructor

EventLogEventClass Constructor
Namespaces ► VisualCron ► EventLogEventClass ► EventLogEventClass()()()
Initializes a new instance of the EventLogEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass()
Public Sub New
public:
EventLogEventClass()


Category Property

Category Property
Namespaces ► VisualCron ► EventLogEventClass ► Category
Category of event
Declaration Syntax
C# Visual Basic Visual C++
public int Category { get; set; }
Public Property Category As Integer
public:
property int Category {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CategoryOp Field

CategoryOp Field
Namespaces ► VisualCron ► EventLogEventClass ► CategoryOp

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.CategoryOp]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass..::.OperatorT CategoryOp
Public CategoryOp As EventLogEventClass..::.OperatorT
public:
EventLogEventClass..::.OperatorT CategoryOp


CategoryString Property

CategoryString Property
Namespaces ► VisualCron ► EventLogEventClass ► CategoryString
String representation of event category
Declaration Syntax
C# Visual Basic Visual C++
public string CategoryString { get; set; }
Public Property CategoryString As String
public:
property String^ CategoryString {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CategoryStringOp Field

CategoryStringOp Field
Namespaces ► VisualCron ► EventLogEventClass ► CategoryStringOp

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.CategoryStringOp]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass..::.OperatorT CategoryStringOp
Public CategoryStringOp As EventLogEventClass..::.OperatorT
public:
EventLogEventClass..::.OperatorT CategoryStringOp


Clone Method

Clone Method
Namespaces ► VisualCron ► EventLogEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.EventLogEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.EventLogEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► EventLogEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.EventLogEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass CloneType()
Public Function CloneType As EventLogEventClass
public:
EventLogEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.EventLogEventClass.CloneType]


EventCode Property

EventCode Property
Namespaces ► VisualCron ► EventLogEventClass ► EventCode
Code of event
Declaration Syntax
C# Visual Basic Visual C++
public int EventCode { get; set; }
Public Property EventCode As Integer
public:
property int EventCode {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EventCodeOp Field

EventCodeOp Field
Namespaces ► VisualCron ► EventLogEventClass ► EventCodeOp

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.EventCodeOp]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass..::.OperatorT EventCodeOp
Public EventCodeOp As EventLogEventClass..::.OperatorT
public:
EventLogEventClass..::.OperatorT EventCodeOp


EventType Field

EventType Field
Namespaces ► VisualCron ► EventLogEventClass ► EventType

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.EventType]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEntryType EventType
Public EventType As EventLogEntryType
public:
EventLogEntryType EventType

Send comments on this topic to Please email feedback to Support


EventTypeOp Field

EventTypeOp Field
Namespaces ► VisualCron ► EventLogEventClass ► EventTypeOp

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.EventTypeOp]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass..::.OperatorT EventTypeOp
Public EventTypeOp As EventLogEventClass..::.OperatorT
public:
EventLogEventClass..::.OperatorT EventTypeOp


GetDescription Method (value)

GetDescription Method (value)
Namespaces ► VisualCron ► EventLogEventClass ► GetDescription(EventLogEventClass..::.OperatorT)
Descripts a an operator type
Declaration Syntax
C# Visual Basic Visual C++
public string GetDescription(
    EventLogEventClass..::.OperatorT value
)
Public Function GetDescription ( _
    value As EventLogEventClass..::.OperatorT _
) As String
public:
String^ GetDescription(
    EventLogEventClass..::.OperatorT value
)
Parameters
value (EventLogEventClass..::.OperatorT)

[Missing <param name="value"/> documentation for "M:VisualCron.EventLogEventClass.GetDescription(VisualCron.EventLogEventClass.OperatorT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.EventLogEventClass.GetDescription(VisualCron.EventLogEventClass.OperatorT)]

Remarks

Send comments on this topic to Please email feedback to Support


Interval Property

Interval Property
Namespaces ► VisualCron ► EventLogEventClass ► Interval
How often it should be queried in the WMI in seconds
Declaration Syntax
C# Visual Basic Visual C++
public int Interval { get; set; }
Public Property Interval As Integer
public:
property int Interval {
    int get ();
    void set (int value);
}
Value
Default: Every 60 seconds
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LogFile Property

LogFile Property
Namespaces ► VisualCron ► EventLogEventClass ► LogFile

[Missing <summary> documentation for P:VisualCron.EventLogEventClass.LogFile]

Declaration Syntax
C# Visual Basic Visual C++
public string LogFile { get; set; }
Public Property LogFile As String
public:
property String^ LogFile {
    String^ get ();
    void set (String^ value);
}


LogFileOp Field

LogFileOp Field
Namespaces ► VisualCron ► EventLogEventClass ► LogFileOp

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.LogFileOp]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass..::.OperatorT LogFileOp
Public LogFileOp As EventLogEventClass..::.OperatorT
public:
EventLogEventClass..::.OperatorT LogFileOp


Machine Property

Machine Property
Namespaces ► VisualCron ► EventLogEventClass ► Machine
Server name/ip of computer
Declaration Syntax
C# Visual Basic Visual C++
public string Machine { get; set; }
Public Property Machine As String
public:
property String^ Machine {
    String^ get ();
    void set (String^ value);
}
Value
Default: . = local computer
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Message Property

Message Property
Namespaces ► VisualCron ► EventLogEventClass ► Message
Actual event category message
Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MessageOp Field

MessageOp Field
Namespaces ► VisualCron ► EventLogEventClass ► MessageOp

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.MessageOp]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass..::.OperatorT MessageOp
Public MessageOp As EventLogEventClass..::.OperatorT
public:
EventLogEventClass..::.OperatorT MessageOp


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► EventLogEventClass ► NetworkCredential
Id of Network Credential that will be used to get access
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SourceName Property

SourceName Property
Namespaces ► VisualCron ► EventLogEventClass ► SourceName

[Missing <summary> documentation for P:VisualCron.EventLogEventClass.SourceName]

Declaration Syntax
C# Visual Basic Visual C++
public string SourceName { get; set; }
Public Property SourceName As String
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}


SourceNameOp Field

SourceNameOp Field
Namespaces ► VisualCron ► EventLogEventClass ► SourceNameOp

[Missing <summary> documentation for F:VisualCron.EventLogEventClass.SourceNameOp]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogEventClass..::.OperatorT SourceNameOp
Public SourceNameOp As EventLogEventClass..::.OperatorT
public:
EventLogEventClass..::.OperatorT SourceNameOp


EventLogEventClass.OperatorT Enumeration

EventLogEventClass..::.OperatorT Enumeration
Namespaces ► VisualCron ► EventLogEventClass ► EventLogEventClass..::.OperatorT
Enum of Operator type
Declaration Syntax
C# Visual Basic Visual C++
public enum OperatorT
Public Enumeration OperatorT
public enum class OperatorT
Members
Member | Description
SQLIGNORE |
SQLAND |
SQLOR |
Remarks

Send comments on this topic to Please email feedback to Support


EventLogNotificationClass Class

EventLogNotificationClass Class
Namespaces ► VisualCron ► EventLogNotificationClass

[Missing <summary> documentation for T:VisualCron.EventLogNotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EventLogNotificationClass
<SerializableAttribute> _
Public Class EventLogNotificationClass
[SerializableAttribute]
public ref class EventLogNotificationClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventLogNotificationClass()()() | Initializes a new instance of the EventLogNotificationClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | Source |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EventLogNotificationClass

Send comments on this topic to Please email feedback to Support


EventLogNotificationClass Constructor

EventLogNotificationClass Constructor
Namespaces ► VisualCron ► EventLogNotificationClass ► EventLogNotificationClass()()()
Initializes a new instance of the EventLogNotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public EventLogNotificationClass()
Public Sub New
public:
EventLogNotificationClass()


Message Property

Message Property
Namespaces ► VisualCron ► EventLogNotificationClass ► Message

[Missing <summary> documentation for P:VisualCron.EventLogNotificationClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


Source Property

Source Property
Namespaces ► VisualCron ► EventLogNotificationClass ► Source

[Missing <summary> documentation for P:VisualCron.EventLogNotificationClass.Source]

Declaration Syntax
C# Visual Basic Visual C++
public string Source { get; set; }
Public Property Source As String
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}


EventLogTriggerResultClass Class

EventLogTriggerResultClass Class
Namespaces ► VisualCron ► EventLogTriggerResultClass

[Missing <summary> documentation for T:VisualCron.EventLogTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class EventLogTriggerResultClass
<SerializableAttribute> _
Public Class EventLogTriggerResultClass
[SerializableAttribute]
public ref class EventLogTriggerResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventLogTriggerResultClass()()() | Initializes a new instance of the EventLogTriggerResultClass class
 | Category |
 | ComputerName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventCode |
 | EventIdentifier |
 | EventType |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Generated |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogFile |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | RecordNumber |
 | SourceName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type |
 | User |
Inheritance Hierarchy
Object
EventLogTriggerResultClass

Send comments on this topic to Please email feedback to Support


EventLogTriggerResultClass Constructor

EventLogTriggerResultClass Constructor
Namespaces ► VisualCron ► EventLogTriggerResultClass ► EventLogTriggerResultClass()()()
Initializes a new instance of the EventLogTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public EventLogTriggerResultClass()
Public Sub New
public:
EventLogTriggerResultClass()


Category Property

Category Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► Category

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.Category]

Declaration Syntax
C# Visual Basic Visual C++
public int Category { get; set; }
Public Property Category As Integer
public:
property int Category {
    int get ();
    void set (int value);
}


ComputerName Property

ComputerName Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► ComputerName

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.ComputerName]

Declaration Syntax
C# Visual Basic Visual C++
public string ComputerName { get; set; }
Public Property ComputerName As String
public:
property String^ ComputerName {
    String^ get ();
    void set (String^ value);
}


EventCode Property

EventCode Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► EventCode

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.EventCode]

Declaration Syntax
C# Visual Basic Visual C++
public int EventCode { get; set; }
Public Property EventCode As Integer
public:
property int EventCode {
    int get ();
    void set (int value);
}


EventIdentifier Property

EventIdentifier Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► EventIdentifier

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.EventIdentifier]

Declaration Syntax
C# Visual Basic Visual C++
public long EventIdentifier { get; set; }
Public Property EventIdentifier As Long
public:
property long long EventIdentifier {
    long long get ();
    void set (long long value);
}


EventType Property

EventType Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► EventType

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.EventType]

Declaration Syntax
C# Visual Basic Visual C++
public int EventType { get; set; }
Public Property EventType As Integer
public:
property int EventType {
    int get ();
    void set (int value);
}


Generated Property

Generated Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► Generated

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.Generated]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime Generated { get; set; }
Public Property Generated As DateTime
public:
property DateTime Generated {
    DateTime get ();
    void set (DateTime value);
}


LogFile Property

LogFile Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► LogFile

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.LogFile]

Declaration Syntax
C# Visual Basic Visual C++
public string LogFile { get; set; }
Public Property LogFile As String
public:
property String^ LogFile {
    String^ get ();
    void set (String^ value);
}


Message Property

Message Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► Message

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


RecordNumber Property

RecordNumber Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► RecordNumber

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.RecordNumber]

Declaration Syntax
C# Visual Basic Visual C++
public int RecordNumber { get; set; }
Public Property RecordNumber As Integer
public:
property int RecordNumber {
    int get ();
    void set (int value);
}


SourceName Property

SourceName Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► SourceName

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.SourceName]

Declaration Syntax
C# Visual Basic Visual C++
public string SourceName { get; set; }
Public Property SourceName As String
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}


Type Property

Type Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► Type

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.Type]

Declaration Syntax
C# Visual Basic Visual C++
public string Type { get; set; }
Public Property Type As String
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}


User Property

User Property
Namespaces ► VisualCron ► EventLogTriggerResultClass ► User

[Missing <summary> documentation for P:VisualCron.EventLogTriggerResultClass.User]

Declaration Syntax
C# Visual Basic Visual C++
public string User { get; set; }
Public Property User As String
public:
property String^ User {
    String^ get ();
    void set (String^ value);
}


EVENTMSG Class

EVENTMSG Class
Namespaces ► VisualCron ► EVENTMSG

[Missing <summary> documentation for T:VisualCron.EVENTMSG]

Declaration Syntax
C# Visual Basic Visual C++
public class EVENTMSG
Public Class EVENTMSG
public ref class EVENTMSG
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EVENTMSG()()() | Initializes a new instance of the EVENTMSG class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | hwnd | Handle to the window which recieves the message
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | message | Message. Can be Keyboard or Mouse message (like WM_LBUTTONDOWN ,WM_MOUSEMOVE etc.)
 | paramH | X coordinate if mouse message, repeat count if keyboard
 | paramL | Y coordinate if mouse message, scan code if keyboard
 | time | Time stamp
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EVENTMSG

Send comments on this topic to Please email feedback to Support


EVENTMSG Constructor

EVENTMSG Constructor
Namespaces ► VisualCron ► EVENTMSG ► EVENTMSG()()()
Initializes a new instance of the EVENTMSG class
Declaration Syntax
C# Visual Basic Visual C++
public EVENTMSG()
Public Sub New
public:
EVENTMSG()


hwnd Field

hwnd Field
Namespaces ► VisualCron ► EVENTMSG ► hwnd
Handle to the window which recieves the message
Declaration Syntax
C# Visual Basic Visual C++
public IntPtr hwnd
Public hwnd As IntPtr
public:
IntPtr hwnd
Remarks

Send comments on this topic to Please email feedback to Support


message Field

message Field
Namespaces ► VisualCron ► EVENTMSG ► message
Message. Can be Keyboard or Mouse message (like WM_LBUTTONDOWN ,WM_MOUSEMOVE etc.)
Declaration Syntax
C# Visual Basic Visual C++
public int message
Public message As Integer
public:
int message
Remarks

Send comments on this topic to Please email feedback to Support


paramH Field

paramH Field
Namespaces ► VisualCron ► EVENTMSG ► paramH
X coordinate if mouse message, repeat count if keyboard
Declaration Syntax
C# Visual Basic Visual C++
public int paramH
Public paramH As Integer
public:
int paramH
Remarks

Send comments on this topic to Please email feedback to Support


paramL Field

paramL Field
Namespaces ► VisualCron ► EVENTMSG ► paramL
Y coordinate if mouse message, scan code if keyboard
Declaration Syntax
C# Visual Basic Visual C++
public int paramL
Public paramL As Integer
public:
int paramL
Remarks

Send comments on this topic to Please email feedback to Support


time Field

time Field
Namespaces ► VisualCron ► EVENTMSG ► time
Time stamp
Declaration Syntax
C# Visual Basic Visual C++
public int time
Public time As Integer
public:
int time
Remarks

Send comments on this topic to Please email feedback to Support


EventProcessFoundationClass Class

EventProcessFoundationClass Class
Namespaces ► VisualCron ► EventProcessFoundationClass

[Missing <summary> documentation for T:VisualCron.EventProcessFoundationClass]

Declaration Syntax
C# Visual Basic Visual C++
public class EventProcessFoundationClass
Public Class EventProcessFoundationClass
public ref class EventProcessFoundationClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EventProcessFoundationClass()()() | Initializes a new instance of the EventProcessFoundationClass class
 | Active |
 | Counter |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasEnded |
 | Job |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SleepTime |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trigger |
Inheritance Hierarchy
Object
EventProcessFoundationClass

Send comments on this topic to Please email feedback to Support


EventProcessFoundationClass Constructor

EventProcessFoundationClass Constructor
Namespaces ► VisualCron ► EventProcessFoundationClass ► EventProcessFoundationClass()()()
Initializes a new instance of the EventProcessFoundationClass class
Declaration Syntax
C# Visual Basic Visual C++
public EventProcessFoundationClass()
Public Sub New
public:
EventProcessFoundationClass()


Active Field

Active Field
Namespaces ► VisualCron ► EventProcessFoundationClass ► Active

[Missing <summary> documentation for F:VisualCron.EventProcessFoundationClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active
Public Active As Boolean
public:
bool Active


Counter Field

Counter Field
Namespaces ► VisualCron ► EventProcessFoundationClass ► Counter

[Missing <summary> documentation for F:VisualCron.EventProcessFoundationClass.Counter]

Declaration Syntax
C# Visual Basic Visual C++
public int Counter
Public Counter As Integer
public:
int Counter


HasEnded Field

HasEnded Field
Namespaces ► VisualCron ► EventProcessFoundationClass ► HasEnded

[Missing <summary> documentation for F:VisualCron.EventProcessFoundationClass.HasEnded]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasEnded
Public HasEnded As Boolean
public:
bool HasEnded


Job Field

Job Field
Namespaces ► VisualCron ► EventProcessFoundationClass ► Job

[Missing <summary> documentation for F:VisualCron.EventProcessFoundationClass.Job]

Declaration Syntax
C# Visual Basic Visual C++
public JobClass Job
Public Job As JobClass
public:
JobClass^ Job

Send comments on this topic to Please email feedback to Support


SleepTime Field

SleepTime Field
Namespaces ► VisualCron ► EventProcessFoundationClass ► SleepTime

[Missing <summary> documentation for F:VisualCron.EventProcessFoundationClass.SleepTime]

Declaration Syntax
C# Visual Basic Visual C++
public int SleepTime
Public SleepTime As Integer
public:
int SleepTime


Trigger Field

Trigger Field
Namespaces ► VisualCron ► EventProcessFoundationClass ► Trigger

[Missing <summary> documentation for F:VisualCron.EventProcessFoundationClass.Trigger]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass Trigger
Public Trigger As TriggerClass
public:
TriggerClass^ Trigger

Send comments on this topic to Please email feedback to Support


ExecutionContextClass Class

ExecutionContextClass Class
Namespaces ► VisualCron ► ExecutionContextClass
Class the controls how the task should be executed, either through Service (background) or from Tray application (foreground)
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ExecutionContextClass : ICloneable
<SerializableAttribute> _
Public Class ExecutionContextClass _
    Implements ICloneable
[SerializableAttribute]
public ref class ExecutionContextClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExecutionContextClass()()() | Initializes a new instance of the ExecutionContextClass class
 | AfterExecutionAction | Gets or sets what action should be taken (lock or logoff) when execution of task has finished
 | AfterUnlockLock | Gets or sets if VisualCron should lock the computer immidiately after unlock
 | AnySessionID | Gets or sets if VisualCron should pick any connected session independent of session ID
 | BeforeExecutionLogon | Gets or sets if a user should be unlock before execution (with specified Credential)
 | BeforeExecutionLogonCredential | Gets or sets the Credential that should be used for unlocking computer
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionType | Gets or sets if the task should be executed from Service (background) or from Tray application (foreground)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForegroundExecuteType | Gets or sets how the foreground execution should be done
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SessionID | Gets or sets the Session ID that is used for finding the correct user session
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets or sets the Windows user name that should be used for finding the correct user session
Remarks
Inheritance Hierarchy
Object
ExecutionContextClass

Send comments on this topic to Please email feedback to Support


ExecutionContextClass Constructor

ExecutionContextClass Constructor
Namespaces ► VisualCron ► ExecutionContextClass ► ExecutionContextClass()()()
Initializes a new instance of the ExecutionContextClass class
Declaration Syntax
C# Visual Basic Visual C++
public ExecutionContextClass()
Public Sub New
public:
ExecutionContextClass()


AfterExecutionAction Property

AfterExecutionAction Property
Namespaces ► VisualCron ► ExecutionContextClass ► AfterExecutionAction
Gets or sets what action should be taken (lock or logoff) when execution of task has finished
Declaration Syntax
C# Visual Basic Visual C++
public ExecutionContextClass..::.AfterExecutionActionT AfterExecutionAction { get; set; }
Public Property AfterExecutionAction As ExecutionContextClass..::.AfterExecutionActionT
public:
property ExecutionContextClass..::.AfterExecutionActionT AfterExecutionAction {
    ExecutionContextClass..::.AfterExecutionActionT get ();
    void set (ExecutionContextClass..::.AfterExecutionActionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AfterUnlockLock Property

AfterUnlockLock Property
Namespaces ► VisualCron ► ExecutionContextClass ► AfterUnlockLock
Gets or sets if VisualCron should lock the computer immidiately after unlock
Declaration Syntax
C# Visual Basic Visual C++
public bool AfterUnlockLock { get; set; }
Public Property AfterUnlockLock As Boolean
public:
property bool AfterUnlockLock {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AnySessionID Property

AnySessionID Property
Namespaces ► VisualCron ► ExecutionContextClass ► AnySessionID
Gets or sets if VisualCron should pick any connected session independent of session ID
Declaration Syntax
C# Visual Basic Visual C++
public bool AnySessionID { get; set; }
Public Property AnySessionID As Boolean
public:
property bool AnySessionID {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
Used only in foreground execution

Send comments on this topic to Please email feedback to Support


BeforeExecutionLogon Property

BeforeExecutionLogon Property
Namespaces ► VisualCron ► ExecutionContextClass ► BeforeExecutionLogon
Gets or sets if a user should be unlock before execution (with specified Credential)
Declaration Syntax
C# Visual Basic Visual C++
public bool BeforeExecutionLogon { get; set; }
Public Property BeforeExecutionLogon As Boolean
public:
property bool BeforeExecutionLogon {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


BeforeExecutionLogonCredential Property

BeforeExecutionLogonCredential Property
Namespaces ► VisualCron ► ExecutionContextClass ► BeforeExecutionLogonCredential
Gets or sets the Credential that should be used for unlocking computer
Declaration Syntax
C# Visual Basic Visual C++
public string BeforeExecutionLogonCredential { get; set; }
Public Property BeforeExecutionLogonCredential As String
public:
property String^ BeforeExecutionLogonCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► ExecutionContextClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.ExecutionContextClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.ExecutionContextClass.Clone]


ExecutionType Property

ExecutionType Property
Namespaces ► VisualCron ► ExecutionContextClass ► ExecutionType
Gets or sets if the task should be executed from Service (background) or from Tray application (foreground)
Declaration Syntax
C# Visual Basic Visual C++
public ExecutionContextClass..::.ExecutionT ExecutionType { get; set; }
Public Property ExecutionType As ExecutionContextClass..::.ExecutionT
public:
property ExecutionContextClass..::.ExecutionT ExecutionType {
    ExecutionContextClass..::.ExecutionT get ();
    void set (ExecutionContextClass..::.ExecutionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ForegroundExecuteType Property

ForegroundExecuteType Property
Namespaces ► VisualCron ► ExecutionContextClass ► ForegroundExecuteType
Gets or sets how the foreground execution should be done
Declaration Syntax
C# Visual Basic Visual C++
public ExecutionContextClass..::.ForegroundExecuteT ForegroundExecuteType { get; set; }
Public Property ForegroundExecuteType As ExecutionContextClass..::.ForegroundExecuteT
public:
property ExecutionContextClass..::.ForegroundExecuteT ForegroundExecuteType {
    ExecutionContextClass..::.ForegroundExecuteT get ();
    void set (ExecutionContextClass..::.ForegroundExecuteT value);
}
Value
Return Value
Remarks
Used only in foreground execution

Send comments on this topic to Please email feedback to Support


SessionID Property

SessionID Property
Namespaces ► VisualCron ► ExecutionContextClass ► SessionID
Gets or sets the Session ID that is used for finding the correct user session
Declaration Syntax
C# Visual Basic Visual C++
public int SessionID { get; set; }
Public Property SessionID As Integer
public:
property int SessionID {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks
Used only in foreground execution

Send comments on this topic to Please email feedback to Support


UserName Property

UserName Property
Namespaces ► VisualCron ► ExecutionContextClass ► UserName
Gets or sets the Windows user name that should be used for finding the correct user session
Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Used only in foreground execution

Send comments on this topic to Please email feedback to Support


ExecutionContextClass.AfterExecutionActionT Enumeration

ExecutionContextClass..::.AfterExecutionActionT Enumeration
Namespaces ► VisualCron ► ExecutionContextClass ► ExecutionContextClass..::.AfterExecutionActionT

[Missing <summary> documentation for T:VisualCron.ExecutionContextClass.AfterExecutionActionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum AfterExecutionActionT
Public Enumeration AfterExecutionActionT
public enum class AfterExecutionActionT
Members
Member | Description
Lock |
Logoff |
DoNothing |


ExecutionContextClass.ExecutionT Enumeration

ExecutionContextClass..::.ExecutionT Enumeration
Namespaces ► VisualCron ► ExecutionContextClass ► ExecutionContextClass..::.ExecutionT
Enum that describes how the Task should be executed
Declaration Syntax
C# Visual Basic Visual C++
public enum ExecutionT
Public Enumeration ExecutionT
public enum class ExecutionT
Members
Member | Description
Background |
Foreground |
Remarks

Send comments on this topic to Please email feedback to Support


ExecutionContextClass.ForegroundExecuteT Enumeration

ExecutionContextClass..::.ForegroundExecuteT Enumeration
Namespaces ► VisualCron ► ExecutionContextClass ► ExecutionContextClass..::.ForegroundExecuteT
Enum that describes how the foreground execution should be done
Declaration Syntax
C# Visual Basic Visual C++
public enum ForegroundExecuteT
Public Enumeration ForegroundExecuteT
public enum class ForegroundExecuteT
Members
Member | Description
Any |
Specified |
Remarks

Send comments on this topic to Please email feedback to Support


ExportImportProgressClass Class

ExportImportProgressClass Class
Namespaces ► VisualCron ► ExportImportProgressClass

[Missing <summary> documentation for T:VisualCron.ExportImportProgressClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ExportImportProgressClass
<SerializableAttribute> _
Public Class ExportImportProgressClass
[SerializableAttribute]
public ref class ExportImportProgressClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExportImportProgressClass()()() | Initializes a new instance of the ExportImportProgressClass class
 | Certificates | List of Certificates - keep null if you want to to export all
 | ClearExisting |
 | Conditions | List of Conditions - keep null if you want to to export all
 | Connections | List of Connections - keep null if you want to to export all
 | Credentials | List of Credentials - keep null if you want to to export all
 | EIStatus |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeAllCertificates | If all of the object type should be included
 | IncludeAllConditions | If all of the object type should be included
 | IncludeAllConnections | If all of the object type should be included
 | IncludeAllCredentials | If all of the object type should be included
 | IncludeAllJobs | If all of the object type should be included
 | IncludeAllNetworkDrives | If all of the object type should be included
 | IncludeAllNotifications | If all of the object type should be included
 | IncludeAllPermissions | If all of the object type should be included
 | IncludeAllPGPKeyRings | If all of the object type should be included
 | IncludeAllServerSettings | If all of the object type should be included
 | IncludeAllTimeExceptions | If all of the object type should be included
 | IncludeAllVariables | If all of the object type should be included
 | Jobs | List of Jobs - keep null if you want to to export all
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkDrives | List of NetworkDrives - keep null if you want to to export all
 | Notifications | List of Notifications - keep null if you want to to export all
 | Permissions | List of Permissions - keep null if you want to to export all
 | PGPKeyRings | List of PGP Key rings - keep null if you want to to export all
 | Settings |
 | TimeExceptions | List of Time exceptions - keep null if you want to to export all
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Variables | List of Variables - keep null if you want to to export all
Inheritance Hierarchy
Object
ExportImportProgressClass

Send comments on this topic to Please email feedback to Support


ExportImportProgressClass Constructor

ExportImportProgressClass Constructor
Namespaces ► VisualCron ► ExportImportProgressClass ► ExportImportProgressClass()()()
Initializes a new instance of the ExportImportProgressClass class
Declaration Syntax
C# Visual Basic Visual C++
public ExportImportProgressClass()
Public Sub New
public:
ExportImportProgressClass()


Certificates Property

Certificates Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Certificates
List of Certificates - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Certificates { get; set; }
Public Property Certificates As List(Of String)
public:
property List<String^>^ Certificates {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ClearExisting Property

ClearExisting Property
Namespaces ► VisualCron ► ExportImportProgressClass ► ClearExisting

[Missing <summary> documentation for P:VisualCron.ExportImportProgressClass.ClearExisting]

Declaration Syntax
C# Visual Basic Visual C++
public bool ClearExisting { get; set; }
Public Property ClearExisting As Boolean
public:
property bool ClearExisting {
    bool get ();
    void set (bool value);
}


Conditions Property

Conditions Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Conditions
List of Conditions - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Conditions { get; set; }
Public Property Conditions As List(Of String)
public:
property List<String^>^ Conditions {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Connections Property

Connections Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Connections
List of Connections - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Connections { get; set; }
Public Property Connections As List(Of String)
public:
property List<String^>^ Connections {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Credentials Property

Credentials Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Credentials
List of Credentials - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Credentials { get; set; }
Public Property Credentials As List(Of String)
public:
property List<String^>^ Credentials {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EIStatus Property

EIStatus Property
Namespaces ► VisualCron ► ExportImportProgressClass ► EIStatus

[Missing <summary> documentation for P:VisualCron.ExportImportProgressClass.EIStatus]

Declaration Syntax
C# Visual Basic Visual C++
public ExportImportProgressClass..::.EIStatusT EIStatus { get; set; }
Public Property EIStatus As ExportImportProgressClass..::.EIStatusT
public:
property ExportImportProgressClass..::.EIStatusT EIStatus {
    ExportImportProgressClass..::.EIStatusT get ();
    void set (ExportImportProgressClass..::.EIStatusT value);
}


File Property

File Property
Namespaces ► VisualCron ► ExportImportProgressClass ► File

[Missing <summary> documentation for P:VisualCron.ExportImportProgressClass.File]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] File { get; set; }
Public Property File As Byte()
public:
property array<unsigned char>^ File {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


IncludeAllCertificates Property

IncludeAllCertificates Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllCertificates
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllCertificates { get; set; }
Public Property IncludeAllCertificates As Boolean
public:
property bool IncludeAllCertificates {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllConditions Property

IncludeAllConditions Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllConditions
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllConditions { get; set; }
Public Property IncludeAllConditions As Boolean
public:
property bool IncludeAllConditions {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllConnections Property

IncludeAllConnections Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllConnections
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllConnections { get; set; }
Public Property IncludeAllConnections As Boolean
public:
property bool IncludeAllConnections {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllCredentials Property

IncludeAllCredentials Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllCredentials
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllCredentials { get; set; }
Public Property IncludeAllCredentials As Boolean
public:
property bool IncludeAllCredentials {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllJobs Property

IncludeAllJobs Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllJobs
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllJobs { get; set; }
Public Property IncludeAllJobs As Boolean
public:
property bool IncludeAllJobs {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllNetworkDrives Property

IncludeAllNetworkDrives Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllNetworkDrives
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllNetworkDrives { get; set; }
Public Property IncludeAllNetworkDrives As Boolean
public:
property bool IncludeAllNetworkDrives {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllNotifications Property

IncludeAllNotifications Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllNotifications
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllNotifications { get; set; }
Public Property IncludeAllNotifications As Boolean
public:
property bool IncludeAllNotifications {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllPermissions Property

IncludeAllPermissions Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllPermissions
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllPermissions { get; set; }
Public Property IncludeAllPermissions As Boolean
public:
property bool IncludeAllPermissions {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllPGPKeyRings Property

IncludeAllPGPKeyRings Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllPGPKeyRings
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllPGPKeyRings { get; set; }
Public Property IncludeAllPGPKeyRings As Boolean
public:
property bool IncludeAllPGPKeyRings {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllServerSettings Property

IncludeAllServerSettings Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllServerSettings
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllServerSettings { get; set; }
Public Property IncludeAllServerSettings As Boolean
public:
property bool IncludeAllServerSettings {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllTimeExceptions Property

IncludeAllTimeExceptions Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllTimeExceptions
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllTimeExceptions { get; set; }
Public Property IncludeAllTimeExceptions As Boolean
public:
property bool IncludeAllTimeExceptions {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllVariables Property

IncludeAllVariables Property
Namespaces ► VisualCron ► ExportImportProgressClass ► IncludeAllVariables
If all of the object type should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllVariables { get; set; }
Public Property IncludeAllVariables As Boolean
public:
property bool IncludeAllVariables {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Jobs Property

Jobs Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Jobs
List of Jobs - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Jobs { get; set; }
Public Property Jobs As List(Of String)
public:
property List<String^>^ Jobs {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkDrives Property

NetworkDrives Property
Namespaces ► VisualCron ► ExportImportProgressClass ► NetworkDrives
List of NetworkDrives - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> NetworkDrives { get; set; }
Public Property NetworkDrives As List(Of String)
public:
property List<String^>^ NetworkDrives {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Notifications Property

Notifications Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Notifications
List of Notifications - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Notifications { get; set; }
Public Property Notifications As List(Of String)
public:
property List<String^>^ Notifications {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Permissions Property

Permissions Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Permissions
List of Permissions - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Permissions { get; set; }
Public Property Permissions As List(Of String)
public:
property List<String^>^ Permissions {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PGPKeyRings Property

PGPKeyRings Property
Namespaces ► VisualCron ► ExportImportProgressClass ► PGPKeyRings
List of PGP Key rings - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> PGPKeyRings { get; set; }
Public Property PGPKeyRings As List(Of String)
public:
property List<String^>^ PGPKeyRings {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Settings Field

Settings Field
Namespaces ► VisualCron ► ExportImportProgressClass ► Settings

[Missing <summary> documentation for F:VisualCron.ExportImportProgressClass.Settings]

Declaration Syntax
C# Visual Basic Visual C++
public List<TaskExportSettingsClass..::.SettingsT> Settings
Public Settings As List(Of TaskExportSettingsClass..::.SettingsT)
public:
List<TaskExportSettingsClass..::.SettingsT>^ Settings


TimeExceptions Property

TimeExceptions Property
Namespaces ► VisualCron ► ExportImportProgressClass ► TimeExceptions
List of Time exceptions - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> TimeExceptions { get; set; }
Public Property TimeExceptions As List(Of String)
public:
property List<String^>^ TimeExceptions {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Variables Property

Variables Property
Namespaces ► VisualCron ► ExportImportProgressClass ► Variables
List of Variables - keep null if you want to to export all
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Variables { get; set; }
Public Property Variables As List(Of String)
public:
property List<String^>^ Variables {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExportImportProgressClass.EIStatusT Enumeration

ExportImportProgressClass..::.EIStatusT Enumeration
Namespaces ► VisualCron ► ExportImportProgressClass ► ExportImportProgressClass..::.EIStatusT

[Missing <summary> documentation for T:VisualCron.ExportImportProgressClass.EIStatusT]

Declaration Syntax
C# Visual Basic Visual C++
public enum EIStatusT
Public Enumeration EIStatusT
public enum class EIStatusT
Members
Member | Description
SendingSettings |
RequestingExport |
PreparingFiles |
TranferingFiles |
TransferDone |
ImportDone |
ErrorOccured |


FEPasteToServer Class

FEPasteToServer Class
Namespaces ► VisualCron ► FEPasteToServer

[Missing <summary> documentation for T:VisualCron.FEPasteToServer]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FEPasteToServer
<SerializableAttribute> _
Public Class FEPasteToServer
[SerializableAttribute]
public ref class FEPasteToServer
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FEPasteToServer()()() | Initializes a new instance of the FEPasteToServer class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NodeToRefresh |
 | TargetDirectory |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ZipBytes |
Inheritance Hierarchy
Object
FEPasteToServer

Send comments on this topic to Please email feedback to Support


FEPasteToServer Constructor

FEPasteToServer Constructor
Namespaces ► VisualCron ► FEPasteToServer ► FEPasteToServer()()()
Initializes a new instance of the FEPasteToServer class
Declaration Syntax
C# Visual Basic Visual C++
public FEPasteToServer()
Public Sub New
public:
FEPasteToServer()


NodeToRefresh Field

NodeToRefresh Field
Namespaces ► VisualCron ► FEPasteToServer ► NodeToRefresh

[Missing <summary> documentation for F:VisualCron.FEPasteToServer.NodeToRefresh]

Declaration Syntax
C# Visual Basic Visual C++
public string NodeToRefresh
Public NodeToRefresh As String
public:
String^ NodeToRefresh

Send comments on this topic to Please email feedback to Support


TargetDirectory Field

TargetDirectory Field
Namespaces ► VisualCron ► FEPasteToServer ► TargetDirectory

[Missing <summary> documentation for F:VisualCron.FEPasteToServer.TargetDirectory]

Declaration Syntax
C# Visual Basic Visual C++
public string TargetDirectory
Public TargetDirectory As String
public:
String^ TargetDirectory

Send comments on this topic to Please email feedback to Support


ZipBytes Field

ZipBytes Field
Namespaces ► VisualCron ► FEPasteToServer ► ZipBytes

[Missing <summary> documentation for F:VisualCron.FEPasteToServer.ZipBytes]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] ZipBytes
Public ZipBytes As Byte()
public:
array<unsigned char>^ ZipBytes


FileEventClass Class

FileEventClass Class
Namespaces ► VisualCron ► FileEventClass
Event that watches for changes in a certain folder or sub folders
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FileEventClass
<SerializableAttribute> _
Public Class FileEventClass
[SerializableAttribute]
public ref class FileEventClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileEventClass()()() | Initializes a new instance of the FileEventClass class
 | ChangeTypes | A list of ChangeTypes
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Filter | Gets or sets the filter string used to determine what files are monitored in a directory.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeSubdirectories | Gets or sets a value indicating whether subdirectories within the specified path should be monitored.
 | Interval | Gets or sets how often the file trigger should be re-evaluated
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | Id of Network Credential that will be used to get access
 | NotifyFilters | A list of NotifyFilters
 | Path | Gets or sets the path of the directory to watch.
 | ReconnectAttempts | Gets or sets the number of attempts that will be made before deactivating the Trigger
 | ReconnectInterval | Number of seconds to wait between reconnecting to a lost connection
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerOnRelease | Gets or sets a value indicating if VisualCron should wait to fire trigger until a file is fully transfered to the folder
 | UsePolling | Gets or sets if file trigger should be Samba compatible (true) or not.
Remarks
Inheritance Hierarchy
Object
FileEventClass

Send comments on this topic to Please email feedback to Support


FileEventClass Constructor

FileEventClass Constructor
Namespaces ► VisualCron ► FileEventClass ► FileEventClass()()()
Initializes a new instance of the FileEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public FileEventClass()
Public Sub New
public:
FileEventClass()


ChangeTypes Field

ChangeTypes Field
Namespaces ► VisualCron ► FileEventClass ► ChangeTypes
A list of ChangeTypes
Declaration Syntax
C# Visual Basic Visual C++
public List<WatcherChangeTypes> ChangeTypes
Public ChangeTypes As List(Of WatcherChangeTypes)
public:
List<WatcherChangeTypes>^ ChangeTypes
Remarks

Send comments on this topic to Please email feedback to Support


CloneType Method

CloneType Method
Namespaces ► VisualCron ► FileEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.FileEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public FileEventClass CloneType()
Public Function CloneType As FileEventClass
public:
FileEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.FileEventClass.CloneType]


Filter Property

Filter Property
Namespaces ► VisualCron ► FileEventClass ► Filter
Gets or sets the filter string used to determine what files are monitored in a directory.
Declaration Syntax
C# Visual Basic Visual C++
public string Filter { get; set; }
Public Property Filter As String
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeSubdirectories Property

IncludeSubdirectories Property
Namespaces ► VisualCron ► FileEventClass ► IncludeSubdirectories
Gets or sets a value indicating whether subdirectories within the specified path should be monitored.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubdirectories { get; set; }
Public Property IncludeSubdirectories As Boolean
public:
property bool IncludeSubdirectories {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Interval Property

Interval Property
Namespaces ► VisualCron ► FileEventClass ► Interval
Gets or sets how often the file trigger should be re-evaluated
Declaration Syntax
C# Visual Basic Visual C++
public int Interval { get; set; }
Public Property Interval As Integer
public:
property int Interval {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► FileEventClass ► NetworkCredential
Id of Network Credential that will be used to get access
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NotifyFilters Field

NotifyFilters Field
Namespaces ► VisualCron ► FileEventClass ► NotifyFilters
A list of NotifyFilters
Declaration Syntax
C# Visual Basic Visual C++
public List<NotifyFilters> NotifyFilters
Public NotifyFilters As List(Of NotifyFilters)
public:
List<NotifyFilters>^ NotifyFilters
Remarks

Send comments on this topic to Please email feedback to Support


Path Property

Path Property
Namespaces ► VisualCron ► FileEventClass ► Path
Gets or sets the path of the directory to watch.
Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; set; }
Public Property Path As String
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ReconnectAttempts Property

ReconnectAttempts Property
Namespaces ► VisualCron ► FileEventClass ► ReconnectAttempts
Gets or sets the number of attempts that will be made before deactivating the Trigger
Declaration Syntax
C# Visual Basic Visual C++
public int ReconnectAttempts { get; set; }
Public Property ReconnectAttempts As Integer
public:
property int ReconnectAttempts {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ReconnectInterval Property

ReconnectInterval Property
Namespaces ► VisualCron ► FileEventClass ► ReconnectInterval
Number of seconds to wait between reconnecting to a lost connection
Declaration Syntax
C# Visual Basic Visual C++
public int ReconnectInterval { get; set; }
Public Property ReconnectInterval As Integer
public:
property int ReconnectInterval {
    int get ();
    void set (int value);
}
Value
Default: 5 seconds
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TriggerOnRelease Property

TriggerOnRelease Property
Namespaces ► VisualCron ► FileEventClass ► TriggerOnRelease
Gets or sets a value indicating if VisualCron should wait to fire trigger until a file is fully transfered to the folder
Declaration Syntax
C# Visual Basic Visual C++
public bool TriggerOnRelease { get; set; }
Public Property TriggerOnRelease As Boolean
public:
property bool TriggerOnRelease {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UsePolling Property

UsePolling Property
Namespaces ► VisualCron ► FileEventClass ► UsePolling
Gets or sets if file trigger should be Samba compatible (true) or not.
Declaration Syntax
C# Visual Basic Visual C++
public bool UsePolling { get; set; }
Public Property UsePolling As Boolean
public:
property bool UsePolling {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
UsePolling = false is more efficient. Does not support Rename event


FileFilterClass Class

FileFilterClass Class
Namespaces ► VisualCron ► FileFilterClass

[Missing <summary> documentation for T:VisualCron.FileFilterClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FileFilterClass : ICloneable
<SerializableAttribute> _
Public Class FileFilterClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FileFilterClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileFilterClass()()() | Initializes a new instance of the FileFilterClass class
 | CaseSensitive | Gets or sets if case sensitive search should be made or not
 | CheckContent | Gets or sets if if content checking should be done
 | Clone()()() |
 | Content | Gets or sets file content string to check for match
 | DateOperator | If dates should be combined in evaluation (AND) or separate (OR)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExcludeFileAttributes | Gets or sets the list of the excluded file attributes
 | ExcludeFileMask | Gets or sets file mask to exlude
 | ExcludeFileMaskIsRegEx | Gets or sets if the exclude file mask contains regex instead of normal string
 | ExcludeFiles | Gets or sets if if files should be excluded or not accodring to ExcludeFileMask
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeAllAttributes | Gets or sets if all attributes should be included
 | IncludeFileAttributes | Gets or sets the list of the included file attributes
 | IncludeFileMask | Gets or sets which files to include.
 | IncludeFileMaskIsRegEx | Gets or sets if the IncludeFileMask contains a regex or not
 | IncludeSubFolders | Gets or sets if sub folders should be searched
 | LargerThanSize | Gets or sets if a file should be larger than a specific size
 | LargerThanSizeType | Gets or sets how the file size should be displayed for the user for the LargerThanSize value
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewerThanCheckType | If file should be checked and if it should be creation or modified date that should be checked for newer
 | NewerThanVariable | Gets or sets the date Variable variable for newer
 | OlderThanCheckType | If file should be checked and if it should be creation or modified date that should be checked for older
 | OlderThanVariable | Gets or sets the date Variable variable for older
 | SizeOperator | If sizes should be combined in evaluation (AND) or separate (OR)
 | SmallerThanSize | Gets or sets if a file should be smaller than a specific size
 | SmallerThanSizeType | Gets or sets how the file size should be displayed for the user for the SmallerThanSize value
 | SourceFolder | Gets or sets the root source folder
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseLargerThanSize | Gets or sets if file should be checked for LargerThanSize property
 | UseSmallerThanSize | Gets or sets if file should be checked for SmallerThanSize property
Inheritance Hierarchy
Object
FileFilterClass

Send comments on this topic to Please email feedback to Support


FileFilterClass Constructor

FileFilterClass Constructor
Namespaces ► VisualCron ► FileFilterClass ► FileFilterClass()()()
Initializes a new instance of the FileFilterClass class
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass()
Public Sub New
public:
FileFilterClass()


CaseSensitive Property

CaseSensitive Property
Namespaces ► VisualCron ► FileFilterClass ► CaseSensitive
Gets or sets if case sensitive search should be made or not
Declaration Syntax
C# Visual Basic Visual C++
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CheckContent Property

CheckContent Property
Namespaces ► VisualCron ► FileFilterClass ► CheckContent
Gets or sets if if content checking should be done
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionCheckT CheckContent { get; set; }
Public Property CheckContent As ConditionClass..::.ConditionCheckT
public:
property ConditionClass..::.ConditionCheckT CheckContent {
    ConditionClass..::.ConditionCheckT get ();
    void set (ConditionClass..::.ConditionCheckT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► FileFilterClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FileFilterClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FileFilterClass.Clone]


Content Property

Content Property
Namespaces ► VisualCron ► FileFilterClass ► Content
Gets or sets file content string to check for match
Declaration Syntax
C# Visual Basic Visual C++
public string Content { get; set; }
Public Property Content As String
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Could be a regex if ContentRegEx is true

Send comments on this topic to Please email feedback to Support


DateOperator Property

DateOperator Property
Namespaces ► VisualCron ► FileFilterClass ► DateOperator
If dates should be combined in evaluation (AND) or separate (OR)
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionOperatorT DateOperator { get; set; }
Public Property DateOperator As ConditionClass..::.ConditionOperatorT
public:
property ConditionClass..::.ConditionOperatorT DateOperator {
    ConditionClass..::.ConditionOperatorT get ();
    void set (ConditionClass..::.ConditionOperatorT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExcludeFileAttributes Property

ExcludeFileAttributes Property
Namespaces ► VisualCron ► FileFilterClass ► ExcludeFileAttributes
Gets or sets the list of the excluded file attributes
Declaration Syntax
C# Visual Basic Visual C++
public List<FileAttributes> ExcludeFileAttributes { get; set; }
Public Property ExcludeFileAttributes As List(Of FileAttributes)
public:
property List<FileAttributes>^ ExcludeFileAttributes {
    List<FileAttributes>^ get ();
    void set (List<FileAttributes>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExcludeFileMask Property

ExcludeFileMask Property
Namespaces ► VisualCron ► FileFilterClass ► ExcludeFileMask
Gets or sets file mask to exlude
Declaration Syntax
C# Visual Basic Visual C++
public string ExcludeFileMask { get; set; }
Public Property ExcludeFileMask As String
public:
property String^ ExcludeFileMask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
This string can be a regex if ExcludeFileMaskIseRegEx is true


ExcludeFileMaskIsRegEx Property

ExcludeFileMaskIsRegEx Property
Namespaces ► VisualCron ► FileFilterClass ► ExcludeFileMaskIsRegEx
Gets or sets if the exclude file mask contains regex instead of normal string
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeFileMaskIsRegEx { get; set; }
Public Property ExcludeFileMaskIsRegEx As Boolean
public:
property bool ExcludeFileMaskIsRegEx {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExcludeFiles Property

ExcludeFiles Property
Namespaces ► VisualCron ► FileFilterClass ► ExcludeFiles
Gets or sets if if files should be excluded or not accodring to ExcludeFileMask
Declaration Syntax
C# Visual Basic Visual C++
public bool ExcludeFiles { get; set; }
Public Property ExcludeFiles As Boolean
public:
property bool ExcludeFiles {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeAllAttributes Property

IncludeAllAttributes Property
Namespaces ► VisualCron ► FileFilterClass ► IncludeAllAttributes
Gets or sets if all attributes should be included
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeAllAttributes { get; set; }
Public Property IncludeAllAttributes As Boolean
public:
property bool IncludeAllAttributes {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeFileAttributes Property

IncludeFileAttributes Property
Namespaces ► VisualCron ► FileFilterClass ► IncludeFileAttributes
Gets or sets the list of the included file attributes
Declaration Syntax
C# Visual Basic Visual C++
public List<FileAttributes> IncludeFileAttributes { get; set; }
Public Property IncludeFileAttributes As List(Of FileAttributes)
public:
property List<FileAttributes>^ IncludeFileAttributes {
    List<FileAttributes>^ get ();
    void set (List<FileAttributes>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeFileMask Property

IncludeFileMask Property
Namespaces ► VisualCron ► FileFilterClass ► IncludeFileMask
Gets or sets which files to include.
Declaration Syntax
C# Visual Basic Visual C++
public string IncludeFileMask { get; set; }
Public Property IncludeFileMask As String
public:
property String^ IncludeFileMask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
This string can be a regex if IncludeFileMaskIseRegEx is true


IncludeFileMaskIsRegEx Property

IncludeFileMaskIsRegEx Property
Namespaces ► VisualCron ► FileFilterClass ► IncludeFileMaskIsRegEx
Gets or sets if the IncludeFileMask contains a regex or not
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeFileMaskIsRegEx { get; set; }
Public Property IncludeFileMaskIsRegEx As Boolean
public:
property bool IncludeFileMaskIsRegEx {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeSubFolders Property

IncludeSubFolders Property
Namespaces ► VisualCron ► FileFilterClass ► IncludeSubFolders
Gets or sets if sub folders should be searched
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubFolders { get; set; }
Public Property IncludeSubFolders As Boolean
public:
property bool IncludeSubFolders {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LargerThanSize Property

LargerThanSize Property
Namespaces ► VisualCron ► FileFilterClass ► LargerThanSize
Gets or sets if a file should be larger than a specific size
Declaration Syntax
C# Visual Basic Visual C++
public long LargerThanSize { get; set; }
Public Property LargerThanSize As Long
public:
property long long LargerThanSize {
    long long get ();
    void set (long long value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LargerThanSizeType Property

LargerThanSizeType Property
Namespaces ► VisualCron ► FileFilterClass ► LargerThanSizeType
Gets or sets how the file size should be displayed for the user for the LargerThanSize value
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass..::.SizeT LargerThanSizeType { get; set; }
Public Property LargerThanSizeType As FileFilterClass..::.SizeT
public:
property FileFilterClass..::.SizeT LargerThanSizeType {
    FileFilterClass..::.SizeT get ();
    void set (FileFilterClass..::.SizeT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NewerThanCheckType Property

NewerThanCheckType Property
Namespaces ► VisualCron ► FileFilterClass ► NewerThanCheckType
If file should be checked and if it should be creation or modified date that should be checked for newer
Declaration Syntax
C# Visual Basic Visual C++
public ConditionFileClass..::.FileConditionCheckT NewerThanCheckType { get; set; }
Public Property NewerThanCheckType As ConditionFileClass..::.FileConditionCheckT
public:
property ConditionFileClass..::.FileConditionCheckT NewerThanCheckType {
    ConditionFileClass..::.FileConditionCheckT get ();
    void set (ConditionFileClass..::.FileConditionCheckT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NewerThanVariable Property

NewerThanVariable Property
Namespaces ► VisualCron ► FileFilterClass ► NewerThanVariable
Gets or sets the date Variable variable for newer
Declaration Syntax
C# Visual Basic Visual C++
public string NewerThanVariable { get; set; }
Public Property NewerThanVariable As String
public:
property String^ NewerThanVariable {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OlderThanCheckType Property

OlderThanCheckType Property
Namespaces ► VisualCron ► FileFilterClass ► OlderThanCheckType
If file should be checked and if it should be creation or modified date that should be checked for older
Declaration Syntax
C# Visual Basic Visual C++
public ConditionFileClass..::.FileConditionCheckT OlderThanCheckType { get; set; }
Public Property OlderThanCheckType As ConditionFileClass..::.FileConditionCheckT
public:
property ConditionFileClass..::.FileConditionCheckT OlderThanCheckType {
    ConditionFileClass..::.FileConditionCheckT get ();
    void set (ConditionFileClass..::.FileConditionCheckT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OlderThanVariable Property

OlderThanVariable Property
Namespaces ► VisualCron ► FileFilterClass ► OlderThanVariable
Gets or sets the date Variable variable for older
Declaration Syntax
C# Visual Basic Visual C++
public string OlderThanVariable { get; set; }
Public Property OlderThanVariable As String
public:
property String^ OlderThanVariable {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SizeOperator Property

SizeOperator Property
Namespaces ► VisualCron ► FileFilterClass ► SizeOperator
If sizes should be combined in evaluation (AND) or separate (OR)
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionOperatorT SizeOperator { get; set; }
Public Property SizeOperator As ConditionClass..::.ConditionOperatorT
public:
property ConditionClass..::.ConditionOperatorT SizeOperator {
    ConditionClass..::.ConditionOperatorT get ();
    void set (ConditionClass..::.ConditionOperatorT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SmallerThanSize Property

SmallerThanSize Property
Namespaces ► VisualCron ► FileFilterClass ► SmallerThanSize
Gets or sets if a file should be smaller than a specific size
Declaration Syntax
C# Visual Basic Visual C++
public long SmallerThanSize { get; set; }
Public Property SmallerThanSize As Long
public:
property long long SmallerThanSize {
    long long get ();
    void set (long long value);
}
Remarks
Always specified in bytes

Send comments on this topic to Please email feedback to Support


SmallerThanSizeType Property

SmallerThanSizeType Property
Namespaces ► VisualCron ► FileFilterClass ► SmallerThanSizeType
Gets or sets how the file size should be displayed for the user for the SmallerThanSize value
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass..::.SizeT SmallerThanSizeType { get; set; }
Public Property SmallerThanSizeType As FileFilterClass..::.SizeT
public:
property FileFilterClass..::.SizeT SmallerThanSizeType {
    FileFilterClass..::.SizeT get ();
    void set (FileFilterClass..::.SizeT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SourceFolder Property

SourceFolder Property
Namespaces ► VisualCron ► FileFilterClass ► SourceFolder
Gets or sets the root source folder
Declaration Syntax
C# Visual Basic Visual C++
public string SourceFolder { get; set; }
Public Property SourceFolder As String
public:
property String^ SourceFolder {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseLargerThanSize Property

UseLargerThanSize Property
Namespaces ► VisualCron ► FileFilterClass ► UseLargerThanSize
Gets or sets if file should be checked for LargerThanSize property
Declaration Syntax
C# Visual Basic Visual C++
public bool UseLargerThanSize { get; set; }
Public Property UseLargerThanSize As Boolean
public:
property bool UseLargerThanSize {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseSmallerThanSize Property

UseSmallerThanSize Property
Namespaces ► VisualCron ► FileFilterClass ► UseSmallerThanSize
Gets or sets if file should be checked for SmallerThanSize property
Declaration Syntax
C# Visual Basic Visual C++
public bool UseSmallerThanSize { get; set; }
Public Property UseSmallerThanSize As Boolean
public:
property bool UseSmallerThanSize {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
Always specifed in bytes.


FileFilterClass.DestinationFolderT Enumeration

FileFilterClass..::.DestinationFolderT Enumeration
Namespaces ► VisualCron ► FileFilterClass ► FileFilterClass..::.DestinationFolderT
If the destination file should be stored in Same folder as source or a Custom folder
Declaration Syntax
C# Visual Basic Visual C++
public enum DestinationFolderT
Public Enumeration DestinationFolderT
public enum class DestinationFolderT
Members
Member | Description
Same |
Custom |
Remarks

Send comments on this topic to Please email feedback to Support


FileFilterClass.SizeT Enumeration

FileFilterClass..::.SizeT Enumeration
Namespaces ► VisualCron ► FileFilterClass ► FileFilterClass..::.SizeT

[Missing <summary> documentation for T:VisualCron.FileFilterClass.SizeT]

Declaration Syntax
C# Visual Basic Visual C++
public enum SizeT
Public Enumeration SizeT
public enum class SizeT
Members
Member | Description
B |
kB |
mB |
gB |
tB |


FileFilterResultClass Class

FileFilterResultClass Class
Namespaces ► VisualCron ► FileFilterResultClass
Class used for testing FileFilter
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FileFilterResultClass
<SerializableAttribute> _
Public Class FileFilterResultClass
[SerializableAttribute]
public ref class FileFilterResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileFilterResultClass()()() | Initializes a new instance of the FileFilterResultClass class
 | CredentialId |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileFilter |
 | Files |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
FileFilterResultClass

Send comments on this topic to Please email feedback to Support


FileFilterResultClass Constructor

FileFilterResultClass Constructor
Namespaces ► VisualCron ► FileFilterResultClass ► FileFilterResultClass()()()
Initializes a new instance of the FileFilterResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterResultClass()
Public Sub New
public:
FileFilterResultClass()


CredentialId Property

CredentialId Property
Namespaces ► VisualCron ► FileFilterResultClass ► CredentialId

[Missing <summary> documentation for P:VisualCron.FileFilterResultClass.CredentialId]

Declaration Syntax
C# Visual Basic Visual C++
public string CredentialId { get; set; }
Public Property CredentialId As String
public:
property String^ CredentialId {
    String^ get ();
    void set (String^ value);
}


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► FileFilterResultClass ► FileFilter

[Missing <summary> documentation for P:VisualCron.FileFilterResultClass.FileFilter]

Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}


Files Property

Files Property
Namespaces ► VisualCron ► FileFilterResultClass ► Files

[Missing <summary> documentation for P:VisualCron.FileFilterResultClass.Files]

Declaration Syntax
C# Visual Basic Visual C++
public List<string> Files { get; set; }
Public Property Files As List(Of String)
public:
property List<String^>^ Files {
    List<String^>^ get ();
    void set (List<String^>^ value);
}


JobId Property

JobId Property
Namespaces ► VisualCron ► FileFilterResultClass ► JobId

[Missing <summary> documentation for P:VisualCron.FileFilterResultClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


TaskId Property

TaskId Property
Namespaces ► VisualCron ► FileFilterResultClass ► TaskId

[Missing <summary> documentation for P:VisualCron.FileFilterResultClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


FileNotificationClass Class

FileNotificationClass Class
Namespaces ► VisualCron ► FileNotificationClass

[Missing <summary> documentation for T:VisualCron.FileNotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FileNotificationClass
<SerializableAttribute> _
Public Class FileNotificationClass
[SerializableAttribute]
public ref class FileNotificationClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileNotificationClass()()() | Initializes a new instance of the FileNotificationClass class
 | Append |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileName |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FileNotificationClass

Send comments on this topic to Please email feedback to Support


FileNotificationClass Constructor

FileNotificationClass Constructor
Namespaces ► VisualCron ► FileNotificationClass ► FileNotificationClass()()()
Initializes a new instance of the FileNotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public FileNotificationClass()
Public Sub New
public:
FileNotificationClass()


Append Property

Append Property
Namespaces ► VisualCron ► FileNotificationClass ► Append

[Missing <summary> documentation for P:VisualCron.FileNotificationClass.Append]

Declaration Syntax
C# Visual Basic Visual C++
public bool Append { get; set; }
Public Property Append As Boolean
public:
property bool Append {
    bool get ();
    void set (bool value);
}


FileName Property

FileName Property
Namespaces ► VisualCron ► FileNotificationClass ► FileName

[Missing <summary> documentation for P:VisualCron.FileNotificationClass.FileName]

Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; set; }
Public Property FileName As String
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}


Message Property

Message Property
Namespaces ► VisualCron ► FileNotificationClass ► Message

[Missing <summary> documentation for P:VisualCron.FileNotificationClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


FileTriggerResultClass Class

FileTriggerResultClass Class
Namespaces ► VisualCron ► FileTriggerResultClass

[Missing <summary> documentation for T:VisualCron.FileTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FileTriggerResultClass
<SerializableAttribute> _
Public Class FileTriggerResultClass
[SerializableAttribute]
public ref class FileTriggerResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FileTriggerResultClass()()() | Initializes a new instance of the FileTriggerResultClass class
 | ChangeType |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileMask |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder |
 | FullPath |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerFolder |
Inheritance Hierarchy
Object
FileTriggerResultClass

Send comments on this topic to Please email feedback to Support


FileTriggerResultClass Constructor

FileTriggerResultClass Constructor
Namespaces ► VisualCron ► FileTriggerResultClass ► FileTriggerResultClass()()()
Initializes a new instance of the FileTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public FileTriggerResultClass()
Public Sub New
public:
FileTriggerResultClass()


ChangeType Property

ChangeType Property
Namespaces ► VisualCron ► FileTriggerResultClass ► ChangeType

[Missing <summary> documentation for P:VisualCron.FileTriggerResultClass.ChangeType]

Declaration Syntax
C# Visual Basic Visual C++
public WatcherChangeTypes ChangeType { get; set; }
Public Property ChangeType As WatcherChangeTypes
public:
property WatcherChangeTypes ChangeType {
    WatcherChangeTypes get ();
    void set (WatcherChangeTypes value);
}


FileMask Property

FileMask Property
Namespaces ► VisualCron ► FileTriggerResultClass ► FileMask

[Missing <summary> documentation for P:VisualCron.FileTriggerResultClass.FileMask]

Declaration Syntax
C# Visual Basic Visual C++
public string FileMask { get; set; }
Public Property FileMask As String
public:
property String^ FileMask {
    String^ get ();
    void set (String^ value);
}


Folder Property

Folder Property
Namespaces ► VisualCron ► FileTriggerResultClass ► Folder

[Missing <summary> documentation for P:VisualCron.FileTriggerResultClass.Folder]

Declaration Syntax
C# Visual Basic Visual C++
public string Folder { get; set; }
Public Property Folder As String
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}


FullPath Property

FullPath Property
Namespaces ► VisualCron ► FileTriggerResultClass ► FullPath

[Missing <summary> documentation for P:VisualCron.FileTriggerResultClass.FullPath]

Declaration Syntax
C# Visual Basic Visual C++
public string FullPath { get; set; }
Public Property FullPath As String
public:
property String^ FullPath {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► VisualCron ► FileTriggerResultClass ► Name

[Missing <summary> documentation for P:VisualCron.FileTriggerResultClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


TriggerFolder Property

TriggerFolder Property
Namespaces ► VisualCron ► FileTriggerResultClass ► TriggerFolder

[Missing <summary> documentation for P:VisualCron.FileTriggerResultClass.TriggerFolder]

Declaration Syntax
C# Visual Basic Visual C++
public string TriggerFolder { get; set; }
Public Property TriggerFolder As String
public:
property String^ TriggerFolder {
    String^ get ();
    void set (String^ value);
}


FTPChangeFolderCommandClass Class

FTPChangeFolderCommandClass Class
Namespaces ► VisualCron ► FTPChangeFolderCommandClass

[Missing <summary> documentation for T:VisualCron.FTPChangeFolderCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPChangeFolderCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPChangeFolderCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPChangeFolderCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPChangeFolderCommandClass()()() | Initializes a new instance of the FTPChangeFolderCommandClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourcePath |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FTPChangeFolderCommandClass

Send comments on this topic to Please email feedback to Support


FTPChangeFolderCommandClass Constructor

FTPChangeFolderCommandClass Constructor
Namespaces ► VisualCron ► FTPChangeFolderCommandClass ► FTPChangeFolderCommandClass()()()
Initializes a new instance of the FTPChangeFolderCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPChangeFolderCommandClass()
Public Sub New
public:
FTPChangeFolderCommandClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPChangeFolderCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPChangeFolderCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPChangeFolderCommandClass.Clone]


SourcePath Property

SourcePath Property
Namespaces ► VisualCron ► FTPChangeFolderCommandClass ► SourcePath

[Missing <summary> documentation for P:VisualCron.FTPChangeFolderCommandClass.SourcePath]

Declaration Syntax
C# Visual Basic Visual C++
public string SourcePath { get; set; }
Public Property SourcePath As String
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}


FTPCommandClass Class

FTPCommandClass Class
Namespaces ► VisualCron ► FTPCommandClass

[Missing <summary> documentation for T:VisualCron.FTPCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPCommandClass : IComparable,
    ICloneable
<SerializableAttribute> _
Public Class FTPCommandClass _
    Implements IComparable, ICloneable
[SerializableAttribute]
public ref class FTPCommandClass : IComparable,
    ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPCommandClass()()() | Initializes a new instance of the FTPCommandClass class
 | ChangeFolder |
 | Clone()()() |
 | CloneType()()() |
 | CommandType |
 | CompareTo(Object) |
 | ConnectionId |
 | CreateFolder |
 | Credential |
 | CustomCommand |
 | DeleteFile |
 | DeleteFolder |
 | Download |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Order |
 | RenameFile |
 | RenameFolder |
 | SetToNothing()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Upload |
Inheritance Hierarchy
Object
FTPCommandClass

Send comments on this topic to Please email feedback to Support


FTPCommandClass Constructor

FTPCommandClass Constructor
Namespaces ► VisualCron ► FTPCommandClass ► FTPCommandClass()()()
Initializes a new instance of the FTPCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPCommandClass()
Public Sub New
public:
FTPCommandClass()


ChangeFolder Field

ChangeFolder Field
Namespaces ► VisualCron ► FTPCommandClass ► ChangeFolder

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.ChangeFolder]

Declaration Syntax
C# Visual Basic Visual C++
public FTPChangeFolderCommandClass ChangeFolder
Public ChangeFolder As FTPChangeFolderCommandClass
public:
FTPChangeFolderCommandClass^ ChangeFolder


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPCommandClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► FTPCommandClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.FTPCommandClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public FTPCommandClass CloneType()
Public Function CloneType As FTPCommandClass
public:
FTPCommandClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.FTPCommandClass.CloneType]


CommandType Field

CommandType Field
Namespaces ► VisualCron ► FTPCommandClass ► CommandType

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.CommandType]

Declaration Syntax
C# Visual Basic Visual C++
public FTPCommandClass..::.FTPCommandT CommandType
Public CommandType As FTPCommandClass..::.FTPCommandT
public:
FTPCommandClass..::.FTPCommandT CommandType


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► VisualCron ► FTPCommandClass ► CompareTo(Object)

[Missing <summary> documentation for M:VisualCron.FTPCommandClass.CompareTo(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCron.FTPCommandClass.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:VisualCron.FTPCommandClass.CompareTo(System.Object)]


ConnectionId Property

ConnectionId Property
Namespaces ► VisualCron ► FTPCommandClass ► ConnectionId

[Missing <summary> documentation for P:VisualCron.FTPCommandClass.ConnectionId]

Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionId { get; set; }
Public Property ConnectionId As String
public:
property String^ ConnectionId {
    String^ get ();
    void set (String^ value);
}


CreateFolder Field

CreateFolder Field
Namespaces ► VisualCron ► FTPCommandClass ► CreateFolder

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.CreateFolder]

Declaration Syntax
C# Visual Basic Visual C++
public FTPCreateFolderCommandClass CreateFolder
Public CreateFolder As FTPCreateFolderCommandClass
public:
FTPCreateFolderCommandClass^ CreateFolder


Credential Property

Credential Property
Namespaces ► VisualCron ► FTPCommandClass ► Credential

[Missing <summary> documentation for P:VisualCron.FTPCommandClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


CustomCommand Field

CustomCommand Field
Namespaces ► VisualCron ► FTPCommandClass ► CustomCommand

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.CustomCommand]

Declaration Syntax
C# Visual Basic Visual C++
public FTPCustomCommandClass CustomCommand
Public CustomCommand As FTPCustomCommandClass
public:
FTPCustomCommandClass^ CustomCommand

Send comments on this topic to Please email feedback to Support


DeleteFile Field

DeleteFile Field
Namespaces ► VisualCron ► FTPCommandClass ► DeleteFile

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.DeleteFile]

Declaration Syntax
C# Visual Basic Visual C++
public FTPDeleteFileCommandClass DeleteFile
Public DeleteFile As FTPDeleteFileCommandClass
public:
FTPDeleteFileCommandClass^ DeleteFile

Send comments on this topic to Please email feedback to Support


DeleteFolder Field

DeleteFolder Field
Namespaces ► VisualCron ► FTPCommandClass ► DeleteFolder

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.DeleteFolder]

Declaration Syntax
C# Visual Basic Visual C++
public FTPDeleteFolderCommandClass DeleteFolder
Public DeleteFolder As FTPDeleteFolderCommandClass
public:
FTPDeleteFolderCommandClass^ DeleteFolder


Download Field

Download Field
Namespaces ► VisualCron ► FTPCommandClass ► Download

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.Download]

Declaration Syntax
C# Visual Basic Visual C++
public FTPDownloadCommandClass Download
Public Download As FTPDownloadCommandClass
public:
FTPDownloadCommandClass^ Download

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► FTPCommandClass ► Id

[Missing <summary> documentation for P:VisualCron.FTPCommandClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


Order Property

Order Property
Namespaces ► VisualCron ► FTPCommandClass ► Order

[Missing <summary> documentation for P:VisualCron.FTPCommandClass.Order]

Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
public:
property int Order {
    int get ();
    void set (int value);
}


RenameFile Field

RenameFile Field
Namespaces ► VisualCron ► FTPCommandClass ► RenameFile

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.RenameFile]

Declaration Syntax
C# Visual Basic Visual C++
public FTPRenameFileCommandClass RenameFile
Public RenameFile As FTPRenameFileCommandClass
public:
FTPRenameFileCommandClass^ RenameFile

Send comments on this topic to Please email feedback to Support


RenameFolder Field

RenameFolder Field
Namespaces ► VisualCron ► FTPCommandClass ► RenameFolder

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.RenameFolder]

Declaration Syntax
C# Visual Basic Visual C++
public FTPRenameFolderCommandClass RenameFolder
Public RenameFolder As FTPRenameFolderCommandClass
public:
FTPRenameFolderCommandClass^ RenameFolder


SetToNothing Method

SetToNothing Method
Namespaces ► VisualCron ► FTPCommandClass ► SetToNothing()()()

[Missing <summary> documentation for M:VisualCron.FTPCommandClass.SetToNothing]

Declaration Syntax
C# Visual Basic Visual C++
public void SetToNothing()
Public Sub SetToNothing
public:
void SetToNothing()


Upload Field

Upload Field
Namespaces ► VisualCron ► FTPCommandClass ► Upload

[Missing <summary> documentation for F:VisualCron.FTPCommandClass.Upload]

Declaration Syntax
C# Visual Basic Visual C++
public FTPUploadCommandClass Upload
Public Upload As FTPUploadCommandClass
public:
FTPUploadCommandClass^ Upload

Send comments on this topic to Please email feedback to Support


FTPCommandClass.FTPCommandT Enumeration

FTPCommandClass..::.FTPCommandT Enumeration
Namespaces ► VisualCron ► FTPCommandClass ► FTPCommandClass..::.FTPCommandT

[Missing <summary> documentation for T:VisualCron.FTPCommandClass.FTPCommandT]

Declaration Syntax
C# Visual Basic Visual C++
public enum FTPCommandT
Public Enumeration FTPCommandT
public enum class FTPCommandT
Members
Member | Description
CreateFolder |
DeleteFolder |
ChangeFolder |
RenameFolder |
DeleteFile |
RenameFile |
Download |
Upload |
CustomCommand |


FTPCreateFolderCommandClass Class

FTPCreateFolderCommandClass Class
Namespaces ► VisualCron ► FTPCreateFolderCommandClass

[Missing <summary> documentation for T:VisualCron.FTPCreateFolderCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPCreateFolderCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPCreateFolderCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPCreateFolderCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPCreateFolderCommandClass()()() | Initializes a new instance of the FTPCreateFolderCommandClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FolderName |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FTPCreateFolderCommandClass

Send comments on this topic to Please email feedback to Support


FTPCreateFolderCommandClass Constructor

FTPCreateFolderCommandClass Constructor
Namespaces ► VisualCron ► FTPCreateFolderCommandClass ► FTPCreateFolderCommandClass()()()
Initializes a new instance of the FTPCreateFolderCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPCreateFolderCommandClass()
Public Sub New
public:
FTPCreateFolderCommandClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPCreateFolderCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPCreateFolderCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPCreateFolderCommandClass.Clone]


FolderName Property

FolderName Property
Namespaces ► VisualCron ► FTPCreateFolderCommandClass ► FolderName

[Missing <summary> documentation for P:VisualCron.FTPCreateFolderCommandClass.FolderName]

Declaration Syntax
C# Visual Basic Visual C++
public string FolderName { get; set; }
Public Property FolderName As String
public:
property String^ FolderName {
    String^ get ();
    void set (String^ value);
}


FTPCustomCommandClass Class

FTPCustomCommandClass Class
Namespaces ► VisualCron ► FTPCustomCommandClass

[Missing <summary> documentation for T:VisualCron.FTPCustomCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPCustomCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPCustomCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPCustomCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPCustomCommandClass()()() | Initializes a new instance of the FTPCustomCommandClass class
 | Clone()()() |
 | Command |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FTPCustomCommandClass

Send comments on this topic to Please email feedback to Support


FTPCustomCommandClass Constructor

FTPCustomCommandClass Constructor
Namespaces ► VisualCron ► FTPCustomCommandClass ► FTPCustomCommandClass()()()
Initializes a new instance of the FTPCustomCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPCustomCommandClass()
Public Sub New
public:
FTPCustomCommandClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPCustomCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPCustomCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPCustomCommandClass.Clone]


Command Property

Command Property
Namespaces ► VisualCron ► FTPCustomCommandClass ► Command

[Missing <summary> documentation for P:VisualCron.FTPCustomCommandClass.Command]

Declaration Syntax
C# Visual Basic Visual C++
public string Command { get; set; }
Public Property Command As String
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}


FTPDeleteFileCommandClass Class

FTPDeleteFileCommandClass Class
Namespaces ► VisualCron ► FTPDeleteFileCommandClass

[Missing <summary> documentation for T:VisualCron.FTPDeleteFileCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPDeleteFileCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPDeleteFileCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPDeleteFileCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPDeleteFileCommandClass()()() | Initializes a new instance of the FTPDeleteFileCommandClass class
 | CaseSensitive |
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FTPDeleteFileCommandClass

Send comments on this topic to Please email feedback to Support


FTPDeleteFileCommandClass Constructor

FTPDeleteFileCommandClass Constructor
Namespaces ► VisualCron ► FTPDeleteFileCommandClass ► FTPDeleteFileCommandClass()()()
Initializes a new instance of the FTPDeleteFileCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPDeleteFileCommandClass()
Public Sub New
public:
FTPDeleteFileCommandClass()


CaseSensitive Property

CaseSensitive Property
Namespaces ► VisualCron ► FTPDeleteFileCommandClass ► CaseSensitive

[Missing <summary> documentation for P:VisualCron.FTPDeleteFileCommandClass.CaseSensitive]

Declaration Syntax
C# Visual Basic Visual C++
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPDeleteFileCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPDeleteFileCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPDeleteFileCommandClass.Clone]


File Property

File Property
Namespaces ► VisualCron ► FTPDeleteFileCommandClass ► File

[Missing <summary> documentation for P:VisualCron.FTPDeleteFileCommandClass.File]

Declaration Syntax
C# Visual Basic Visual C++
public string File { get; set; }
Public Property File As String
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}


FTPDeleteFolderCommandClass Class

FTPDeleteFolderCommandClass Class
Namespaces ► VisualCron ► FTPDeleteFolderCommandClass

[Missing <summary> documentation for T:VisualCron.FTPDeleteFolderCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPDeleteFolderCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPDeleteFolderCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPDeleteFolderCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPDeleteFolderCommandClass()()() | Initializes a new instance of the FTPDeleteFolderCommandClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FTPDeleteFolderCommandClass

Send comments on this topic to Please email feedback to Support


FTPDeleteFolderCommandClass Constructor

FTPDeleteFolderCommandClass Constructor
Namespaces ► VisualCron ► FTPDeleteFolderCommandClass ► FTPDeleteFolderCommandClass()()()
Initializes a new instance of the FTPDeleteFolderCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPDeleteFolderCommandClass()
Public Sub New
public:
FTPDeleteFolderCommandClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPDeleteFolderCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPDeleteFolderCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPDeleteFolderCommandClass.Clone]


Folder Property

Folder Property
Namespaces ► VisualCron ► FTPDeleteFolderCommandClass ► Folder

[Missing <summary> documentation for P:VisualCron.FTPDeleteFolderCommandClass.Folder]

Declaration Syntax
C# Visual Basic Visual C++
public string Folder { get; set; }
Public Property Folder As String
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}


FTPDownloadCommandClass Class

FTPDownloadCommandClass Class
Namespaces ► VisualCron ► FTPDownloadCommandClass

[Missing <summary> documentation for T:VisualCron.FTPDownloadCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPDownloadCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPDownloadCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPDownloadCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPDownloadCommandClass()()() | Initializes a new instance of the FTPDownloadCommandClass class
 | CaseSensitive |
 | Clone()()() |
 | DeleteSource | If the source file should be delete after transfer is done
 | DestinationPath |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExistAction |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeSubFolders |
 | KeepCreatedModifiedDate |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceFileMask |
 | SourcePath |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransferType |
 | TreatUnknownTypesAsFiles |
 | UseRawListing | Gets or sets if listing mode should be compatible with older servers (ftp/ftps)
Inheritance Hierarchy
Object
FTPDownloadCommandClass

Send comments on this topic to Please email feedback to Support


FTPDownloadCommandClass Constructor

FTPDownloadCommandClass Constructor
Namespaces ► VisualCron ► FTPDownloadCommandClass ► FTPDownloadCommandClass()()()
Initializes a new instance of the FTPDownloadCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPDownloadCommandClass()
Public Sub New
public:
FTPDownloadCommandClass()


CaseSensitive Property

CaseSensitive Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► CaseSensitive

[Missing <summary> documentation for P:VisualCron.FTPDownloadCommandClass.CaseSensitive]

Declaration Syntax
C# Visual Basic Visual C++
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPDownloadCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPDownloadCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPDownloadCommandClass.Clone]


DeleteSource Property

DeleteSource Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► DeleteSource
If the source file should be delete after transfer is done
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteSource { get; set; }
Public Property DeleteSource As Boolean
public:
property bool DeleteSource {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DestinationPath Property

DestinationPath Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► DestinationPath

[Missing <summary> documentation for P:VisualCron.FTPDownloadCommandClass.DestinationPath]

Declaration Syntax
C# Visual Basic Visual C++
public string DestinationPath { get; set; }
Public Property DestinationPath As String
public:
property String^ DestinationPath {
    String^ get ();
    void set (String^ value);
}


ExistAction Field

ExistAction Field
Namespaces ► VisualCron ► FTPDownloadCommandClass ► ExistAction

[Missing <summary> documentation for F:VisualCron.FTPDownloadCommandClass.ExistAction]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.ExistActionT ExistAction
Public ExistAction As EnumClass..::.ExistActionT
public:
EnumClass..::.ExistActionT ExistAction

Send comments on this topic to Please email feedback to Support


IncludeSubFolders Property

IncludeSubFolders Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► IncludeSubFolders

[Missing <summary> documentation for P:VisualCron.FTPDownloadCommandClass.IncludeSubFolders]

Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubFolders { get; set; }
Public Property IncludeSubFolders As Boolean
public:
property bool IncludeSubFolders {
    bool get ();
    void set (bool value);
}


KeepCreatedModifiedDate Property

KeepCreatedModifiedDate Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► KeepCreatedModifiedDate

[Missing <summary> documentation for P:VisualCron.FTPDownloadCommandClass.KeepCreatedModifiedDate]

Declaration Syntax
C# Visual Basic Visual C++
public bool KeepCreatedModifiedDate { get; set; }
Public Property KeepCreatedModifiedDate As Boolean
public:
property bool KeepCreatedModifiedDate {
    bool get ();
    void set (bool value);
}


SourceFileMask Property

SourceFileMask Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► SourceFileMask

[Missing <summary> documentation for P:VisualCron.FTPDownloadCommandClass.SourceFileMask]

Declaration Syntax
C# Visual Basic Visual C++
public string SourceFileMask { get; set; }
Public Property SourceFileMask As String
public:
property String^ SourceFileMask {
    String^ get ();
    void set (String^ value);
}


SourcePath Property

SourcePath Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► SourcePath

[Missing <summary> documentation for P:VisualCron.FTPDownloadCommandClass.SourcePath]

Declaration Syntax
C# Visual Basic Visual C++
public string SourcePath { get; set; }
Public Property SourcePath As String
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}


TransferType Field

TransferType Field
Namespaces ► VisualCron ► FTPDownloadCommandClass ► TransferType

[Missing <summary> documentation for F:VisualCron.FTPDownloadCommandClass.TransferType]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass..::.TransferT TransferType
Public TransferType As ConnectionClass..::.TransferT
public:
ConnectionClass..::.TransferT TransferType


TreatUnknownTypesAsFiles Property

TreatUnknownTypesAsFiles Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► TreatUnknownTypesAsFiles

[Missing <summary> documentation for P:VisualCron.FTPDownloadCommandClass.TreatUnknownTypesAsFiles]

Declaration Syntax
C# Visual Basic Visual C++
public bool TreatUnknownTypesAsFiles { get; set; }
Public Property TreatUnknownTypesAsFiles As Boolean
public:
property bool TreatUnknownTypesAsFiles {
    bool get ();
    void set (bool value);
}


UseRawListing Property

UseRawListing Property
Namespaces ► VisualCron ► FTPDownloadCommandClass ► UseRawListing
Gets or sets if listing mode should be compatible with older servers (ftp/ftps)
Declaration Syntax
C# Visual Basic Visual C++
public bool UseRawListing { get; set; }
Public Property UseRawListing As Boolean
public:
property bool UseRawListing {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FTPRenameFileCommandClass Class

FTPRenameFileCommandClass Class
Namespaces ► VisualCron ► FTPRenameFileCommandClass

[Missing <summary> documentation for T:VisualCron.FTPRenameFileCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPRenameFileCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPRenameFileCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPRenameFileCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPRenameFileCommandClass()()() | Initializes a new instance of the FTPRenameFileCommandClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewFile |
 | OriginalFile |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FTPRenameFileCommandClass

Send comments on this topic to Please email feedback to Support


FTPRenameFileCommandClass Constructor

FTPRenameFileCommandClass Constructor
Namespaces ► VisualCron ► FTPRenameFileCommandClass ► FTPRenameFileCommandClass()()()
Initializes a new instance of the FTPRenameFileCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPRenameFileCommandClass()
Public Sub New
public:
FTPRenameFileCommandClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPRenameFileCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPRenameFileCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPRenameFileCommandClass.Clone]


NewFile Property

NewFile Property
Namespaces ► VisualCron ► FTPRenameFileCommandClass ► NewFile

[Missing <summary> documentation for P:VisualCron.FTPRenameFileCommandClass.NewFile]

Declaration Syntax
C# Visual Basic Visual C++
public string NewFile { get; set; }
Public Property NewFile As String
public:
property String^ NewFile {
    String^ get ();
    void set (String^ value);
}


OriginalFile Property

OriginalFile Property
Namespaces ► VisualCron ► FTPRenameFileCommandClass ► OriginalFile

[Missing <summary> documentation for P:VisualCron.FTPRenameFileCommandClass.OriginalFile]

Declaration Syntax
C# Visual Basic Visual C++
public string OriginalFile { get; set; }
Public Property OriginalFile As String
public:
property String^ OriginalFile {
    String^ get ();
    void set (String^ value);
}


FTPRenameFolderCommandClass Class

FTPRenameFolderCommandClass Class
Namespaces ► VisualCron ► FTPRenameFolderCommandClass

[Missing <summary> documentation for T:VisualCron.FTPRenameFolderCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPRenameFolderCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPRenameFolderCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPRenameFolderCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPRenameFolderCommandClass()()() | Initializes a new instance of the FTPRenameFolderCommandClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewFolder |
 | OriginalFolder |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FTPRenameFolderCommandClass

Send comments on this topic to Please email feedback to Support


FTPRenameFolderCommandClass Constructor

FTPRenameFolderCommandClass Constructor
Namespaces ► VisualCron ► FTPRenameFolderCommandClass ► FTPRenameFolderCommandClass()()()
Initializes a new instance of the FTPRenameFolderCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPRenameFolderCommandClass()
Public Sub New
public:
FTPRenameFolderCommandClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPRenameFolderCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPRenameFolderCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPRenameFolderCommandClass.Clone]


NewFolder Property

NewFolder Property
Namespaces ► VisualCron ► FTPRenameFolderCommandClass ► NewFolder

[Missing <summary> documentation for P:VisualCron.FTPRenameFolderCommandClass.NewFolder]

Declaration Syntax
C# Visual Basic Visual C++
public string NewFolder { get; set; }
Public Property NewFolder As String
public:
property String^ NewFolder {
    String^ get ();
    void set (String^ value);
}


OriginalFolder Property

OriginalFolder Property
Namespaces ► VisualCron ► FTPRenameFolderCommandClass ► OriginalFolder

[Missing <summary> documentation for P:VisualCron.FTPRenameFolderCommandClass.OriginalFolder]

Declaration Syntax
C# Visual Basic Visual C++
public string OriginalFolder { get; set; }
Public Property OriginalFolder As String
public:
property String^ OriginalFolder {
    String^ get ();
    void set (String^ value);
}


FTPUploadCommandClass Class

FTPUploadCommandClass Class
Namespaces ► VisualCron ► FTPUploadCommandClass

[Missing <summary> documentation for T:VisualCron.FTPUploadCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class FTPUploadCommandClass : ICloneable
<SerializableAttribute> _
Public Class FTPUploadCommandClass _
    Implements ICloneable
[SerializableAttribute]
public ref class FTPUploadCommandClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | FTPUploadCommandClass()()() | Initializes a new instance of the FTPUploadCommandClass class
 | CaseSensitive | Obsolete. Use FileFilter instead
 | Clone()()() |
 | DeleteSource | If the source file should be delete after transfer is done
 | DestinationPath | Upload path
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExistAction |
 | FileFilter | Filter object that controls source files
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeSubFolders | Obsolete. Use FileFilter instead
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SourceFileMask | Obsolete. Use FileFilter instead
 | SourcePath | Obsolete. Use FileFilter.SourceFolder instead
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TransferType |
Inheritance Hierarchy
Object
FTPUploadCommandClass

Send comments on this topic to Please email feedback to Support


FTPUploadCommandClass Constructor

FTPUploadCommandClass Constructor
Namespaces ► VisualCron ► FTPUploadCommandClass ► FTPUploadCommandClass()()()
Initializes a new instance of the FTPUploadCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public FTPUploadCommandClass()
Public Sub New
public:
FTPUploadCommandClass()


CaseSensitive Property

CaseSensitive Property
Namespaces ► VisualCron ► FTPUploadCommandClass ► CaseSensitive
Obsolete. Use FileFilter instead
Declaration Syntax
C# Visual Basic Visual C++
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► FTPUploadCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.FTPUploadCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.FTPUploadCommandClass.Clone]


DeleteSource Property

DeleteSource Property
Namespaces ► VisualCron ► FTPUploadCommandClass ► DeleteSource
If the source file should be delete after transfer is done
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteSource { get; set; }
Public Property DeleteSource As Boolean
public:
property bool DeleteSource {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DestinationPath Property

DestinationPath Property
Namespaces ► VisualCron ► FTPUploadCommandClass ► DestinationPath
Upload path
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationPath { get; set; }
Public Property DestinationPath As String
public:
property String^ DestinationPath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExistAction Field

ExistAction Field
Namespaces ► VisualCron ► FTPUploadCommandClass ► ExistAction

[Missing <summary> documentation for F:VisualCron.FTPUploadCommandClass.ExistAction]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.ExistActionT ExistAction
Public ExistAction As EnumClass..::.ExistActionT
public:
EnumClass..::.ExistActionT ExistAction

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► FTPUploadCommandClass ► FileFilter
Filter object that controls source files
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeSubFolders Property

IncludeSubFolders Property
Namespaces ► VisualCron ► FTPUploadCommandClass ► IncludeSubFolders
Obsolete. Use FileFilter instead
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubFolders { get; set; }
Public Property IncludeSubFolders As Boolean
public:
property bool IncludeSubFolders {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SourceFileMask Property

SourceFileMask Property
Namespaces ► VisualCron ► FTPUploadCommandClass ► SourceFileMask
Obsolete. Use FileFilter instead
Declaration Syntax
C# Visual Basic Visual C++
public string SourceFileMask { get; set; }
Public Property SourceFileMask As String
public:
property String^ SourceFileMask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SourcePath Property

SourcePath Property
Namespaces ► VisualCron ► FTPUploadCommandClass ► SourcePath
Obsolete. Use FileFilter.SourceFolder instead
Declaration Syntax
C# Visual Basic Visual C++
public string SourcePath { get; set; }
Public Property SourcePath As String
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TransferType Field

TransferType Field
Namespaces ► VisualCron ► FTPUploadCommandClass ► TransferType

[Missing <summary> documentation for F:VisualCron.FTPUploadCommandClass.TransferType]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass..::.TransferT TransferType
Public TransferType As ConnectionClass..::.TransferT
public:
ConnectionClass..::.TransferT TransferType


GridColumnClass Class

GridColumnClass Class
Namespaces ► VisualCron ► GridColumnClass
Is used to remember the column settings
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class GridColumnClass
<SerializableAttribute> _
Public Class GridColumnClass
[SerializableAttribute]
public ref class GridColumnClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GridColumnClass()()() | Initializes a new instance of the GridColumnClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hidden |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | SortIndicator |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Width |
 | VisiblePosition |
Remarks
Not used in the API
Inheritance Hierarchy
Object
GridColumnClass

Send comments on this topic to Please email feedback to Support


GridColumnClass Constructor

GridColumnClass Constructor
Namespaces ► VisualCron ► GridColumnClass ► GridColumnClass()()()
Initializes a new instance of the GridColumnClass class
Declaration Syntax
C# Visual Basic Visual C++
public GridColumnClass()
Public Sub New
public:
GridColumnClass()


Hidden Property

Hidden Property
Namespaces ► VisualCron ► GridColumnClass ► Hidden

[Missing <summary> documentation for P:VisualCron.GridColumnClass.Hidden]

Declaration Syntax
C# Visual Basic Visual C++
public bool Hidden { get; set; }
Public Property Hidden As Boolean
public:
property bool Hidden {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► VisualCron ► GridColumnClass ► Name

[Missing <summary> documentation for P:VisualCron.GridColumnClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


SortIndicator Property

SortIndicator Property
Namespaces ► VisualCron ► GridColumnClass ► SortIndicator

[Missing <summary> documentation for P:VisualCron.GridColumnClass.SortIndicator]

Declaration Syntax
C# Visual Basic Visual C++
public int SortIndicator { get; set; }
Public Property SortIndicator As Integer
public:
property int SortIndicator {
    int get ();
    void set (int value);
}


Width Property

Width Property
Namespaces ► VisualCron ► GridColumnClass ► Width

[Missing <summary> documentation for P:VisualCron.GridColumnClass.Width]

Declaration Syntax
C# Visual Basic Visual C++
public int Width { get; set; }
Public Property Width As Integer
public:
property int Width {
    int get ();
    void set (int value);
}


VisiblePosition Property

VisiblePosition Property
Namespaces ► VisualCron ► GridColumnClass ► VisiblePosition

[Missing <summary> documentation for P:VisualCron.GridColumnClass.VisiblePosition]

Declaration Syntax
C# Visual Basic Visual C++
public int VisiblePosition { get; set; }
Public Property VisiblePosition As Integer
public:
property int VisiblePosition {
    int get ();
    void set (int value);
}


GUITHREADINFO Structure

GUITHREADINFO Structure
Namespaces ► VisualCron ► GUITHREADINFO

[Missing <summary> documentation for T:VisualCron.GUITHREADINFO]

Declaration Syntax
C# Visual Basic Visual C++
public struct GUITHREADINFO
Public Structure GUITHREADINFO
public value class GUITHREADINFO
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | cbSize |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | flags |
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | hwndActive |
 | hwndCapture |
 | hwndCaret |
 | hwndFocus |
 | hwndMenuOwner |
 | hwndMoveSize |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | rcCaret |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


cbSize Field

cbSize Field
Namespaces ► VisualCron ► GUITHREADINFO ► cbSize

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.cbSize]

Declaration Syntax
C# Visual Basic Visual C++
public int cbSize
Public cbSize As Integer
public:
int cbSize


flags Field

flags Field
Namespaces ► VisualCron ► GUITHREADINFO ► flags

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.flags]

Declaration Syntax
C# Visual Basic Visual C++
public int flags
Public flags As Integer
public:
int flags


hwndActive Field

hwndActive Field
Namespaces ► VisualCron ► GUITHREADINFO ► hwndActive

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.hwndActive]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr hwndActive
Public hwndActive As IntPtr
public:
IntPtr hwndActive

Send comments on this topic to Please email feedback to Support


hwndCapture Field

hwndCapture Field
Namespaces ► VisualCron ► GUITHREADINFO ► hwndCapture

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.hwndCapture]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr hwndCapture
Public hwndCapture As IntPtr
public:
IntPtr hwndCapture

Send comments on this topic to Please email feedback to Support


hwndCaret Field

hwndCaret Field
Namespaces ► VisualCron ► GUITHREADINFO ► hwndCaret

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.hwndCaret]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr hwndCaret
Public hwndCaret As IntPtr
public:
IntPtr hwndCaret

Send comments on this topic to Please email feedback to Support


hwndFocus Field

hwndFocus Field
Namespaces ► VisualCron ► GUITHREADINFO ► hwndFocus

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.hwndFocus]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr hwndFocus
Public hwndFocus As IntPtr
public:
IntPtr hwndFocus

Send comments on this topic to Please email feedback to Support


hwndMenuOwner Field

hwndMenuOwner Field
Namespaces ► VisualCron ► GUITHREADINFO ► hwndMenuOwner

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.hwndMenuOwner]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr hwndMenuOwner
Public hwndMenuOwner As IntPtr
public:
IntPtr hwndMenuOwner

Send comments on this topic to Please email feedback to Support


hwndMoveSize Field

hwndMoveSize Field
Namespaces ► VisualCron ► GUITHREADINFO ► hwndMoveSize

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.hwndMoveSize]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr hwndMoveSize
Public hwndMoveSize As IntPtr
public:
IntPtr hwndMoveSize

Send comments on this topic to Please email feedback to Support


rcCaret Field

rcCaret Field
Namespaces ► VisualCron ► GUITHREADINFO ► rcCaret

[Missing <summary> documentation for F:VisualCron.GUITHREADINFO.rcCaret]

Declaration Syntax
C# Visual Basic Visual C++
public RECT rcCaret
Public rcCaret As RECT
public:
RECT rcCaret

Send comments on this topic to Please email feedback to Support


HARDWAREINPUT Structure

HARDWAREINPUT Structure
Namespaces ► VisualCron ► HARDWAREINPUT

[Missing <summary> documentation for T:VisualCron.HARDWAREINPUT]

Declaration Syntax
C# Visual Basic Visual C++
public struct HARDWAREINPUT
Public Structure HARDWAREINPUT
public value class HARDWAREINPUT
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | uMsg |
 | wParamH |
 | wParamL |


uMsg Field

uMsg Field
Namespaces ► VisualCron ► HARDWAREINPUT ► uMsg

[Missing <summary> documentation for F:VisualCron.HARDWAREINPUT.uMsg]

Declaration Syntax
C# Visual Basic Visual C++
public int uMsg
Public uMsg As Integer
public:
int uMsg


wParamH Field

wParamH Field
Namespaces ► VisualCron ► HARDWAREINPUT ► wParamH

[Missing <summary> documentation for F:VisualCron.HARDWAREINPUT.wParamH]

Declaration Syntax
C# Visual Basic Visual C++
public short wParamH
Public wParamH As Short
public:
short wParamH


wParamL Field

wParamL Field
Namespaces ► VisualCron ► HARDWAREINPUT ► wParamL

[Missing <summary> documentation for F:VisualCron.HARDWAREINPUT.wParamL]

Declaration Syntax
C# Visual Basic Visual C++
public short wParamL
Public wParamL As Short
public:
short wParamL


IForegroundTaskProcess Interface

IForegroundTaskProcess Interface
Namespaces ► VisualCron ► IForegroundTaskProcess

[Missing <summary> documentation for T:VisualCron.IForegroundTaskProcess]

Declaration Syntax
C# Visual Basic Visual C++
public interface IForegroundTaskProcess
Public Interface IForegroundTaskProcess
public interface class IForegroundTaskProcess
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EndProcess()()() |
 | Run()()() |


EndProcess Method

EndProcess Method
Namespaces ► VisualCron ► IForegroundTaskProcess ► EndProcess()()()

[Missing <summary> documentation for M:VisualCron.IForegroundTaskProcess.EndProcess]

Declaration Syntax
C# Visual Basic Visual C++
void EndProcess()
Sub EndProcess
void EndProcess()


Run Method

Run Method
Namespaces ► VisualCron ► IForegroundTaskProcess ► Run()()()

[Missing <summary> documentation for M:VisualCron.IForegroundTaskProcess.Run]

Declaration Syntax
C# Visual Basic Visual C++
void Run()
Sub Run
void Run()


INPUT Structure

INPUT Structure
Namespaces ► VisualCron ► INPUT

[Missing <summary> documentation for T:VisualCron.INPUT]

Declaration Syntax
C# Visual Basic Visual C++
public struct INPUT
Public Structure INPUT
public value class INPUT
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | dwType |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | hi |
 | ki |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mi |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


dwType Field

dwType Field
Namespaces ► VisualCron ► INPUT ► dwType

[Missing <summary> documentation for F:VisualCron.INPUT.dwType]

Declaration Syntax
C# Visual Basic Visual C++
public InputType dwType
Public dwType As InputType
public:
InputType dwType

Send comments on this topic to Please email feedback to Support


hi Field

hi Field
Namespaces ► VisualCron ► INPUT ► hi

[Missing <summary> documentation for F:VisualCron.INPUT.hi]

Declaration Syntax
C# Visual Basic Visual C++
public HARDWAREINPUT hi
Public hi As HARDWAREINPUT
public:
HARDWAREINPUT hi

Send comments on this topic to Please email feedback to Support


ki Field

ki Field
Namespaces ► VisualCron ► INPUT ► ki

[Missing <summary> documentation for F:VisualCron.INPUT.ki]

Declaration Syntax
C# Visual Basic Visual C++
public KEYBDINPUT ki
Public ki As KEYBDINPUT
public:
KEYBDINPUT ki

Send comments on this topic to Please email feedback to Support


mi Field

mi Field
Namespaces ► VisualCron ► INPUT ► mi

[Missing <summary> documentation for F:VisualCron.INPUT.mi]

Declaration Syntax
C# Visual Basic Visual C++
public MOUSEINPUT mi
Public mi As MOUSEINPUT
public:
MOUSEINPUT mi

Send comments on this topic to Please email feedback to Support


InputType Enumeration

InputType Enumeration
Namespaces ► VisualCron ► InputType

[Missing <summary> documentation for T:VisualCron.InputType]

Declaration Syntax
C# Visual Basic Visual C++
public enum InputType
Public Enumeration InputType
public enum class InputType
Members
Member | Description
Mouse |
Keyboard |
Hardware |


InstructionsBuilder Class

InstructionsBuilder Class
Namespaces ► VisualCron ► InstructionsBuilder
Instructions builder is used to construct a sequence of PlayerInstruction
Declaration Syntax
C# Visual Basic Visual C++
public class InstructionsBuilder
Public Class InstructionsBuilder
public ref class InstructionsBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstructionsBuilder()()() | Initializes a new instance of the InstructionsBuilder class
 | AddDelay(Int32) |
 | AddInstruction(PlayerInstruction) |
 | CustomData |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetResult()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstructionsBuilder

Send comments on this topic to Please email feedback to Support


InstructionsBuilder Constructor

InstructionsBuilder Constructor
Namespaces ► VisualCron ► InstructionsBuilder ► InstructionsBuilder()()()
Initializes a new instance of the InstructionsBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public InstructionsBuilder()
Public Sub New
public:
InstructionsBuilder()


AddDelay Method (miliseconds)

AddDelay Method (miliseconds)
Namespaces ► VisualCron ► InstructionsBuilder ► AddDelay(Int32)

[Missing <summary> documentation for M:VisualCron.InstructionsBuilder.AddDelay(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddDelay(
    int miliseconds
)
Public Sub AddDelay ( _
    miliseconds As Integer _
)
public:
void AddDelay(
    int miliseconds
)
Parameters
miliseconds (Int32)

[Missing <param name="miliseconds"/> documentation for "M:VisualCron.InstructionsBuilder.AddDelay(System.Int32)"]


AddInstruction Method (instruction)

AddInstruction Method (instruction)
Namespaces ► VisualCron ► InstructionsBuilder ► AddInstruction(PlayerInstruction)

[Missing <summary> documentation for M:VisualCron.InstructionsBuilder.AddInstruction(VisualCron.PlayerInstruction)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddInstruction(
    PlayerInstruction instruction
)
Public Sub AddInstruction ( _
    instruction As PlayerInstruction _
)
public:
void AddInstruction(
    PlayerInstruction^ instruction
)
Parameters
instruction (PlayerInstruction)

[Missing <param name="instruction"/> documentation for "M:VisualCron.InstructionsBuilder.AddInstruction(VisualCron.PlayerInstruction)"]


CustomData Property

CustomData Property
Namespaces ► VisualCron ► InstructionsBuilder ► CustomData

[Missing <summary> documentation for P:VisualCron.InstructionsBuilder.CustomData]

Declaration Syntax
C# Visual Basic Visual C++
public IDictionary CustomData { get; }
Public ReadOnly Property CustomData As IDictionary
public:
property IDictionary^ CustomData {
    IDictionary^ get ();
}


GetResult Method

GetResult Method
Namespaces ► VisualCron ► InstructionsBuilder ► GetResult()()()

[Missing <summary> documentation for M:VisualCron.InstructionsBuilder.GetResult]

Declaration Syntax
C# Visual Basic Visual C++
public List<PlayerInstruction> GetResult()
Public Function GetResult As List(Of PlayerInstruction)
public:
List<PlayerInstruction^>^ GetResult()
Return Value

[Missing <returns> documentation for M:VisualCron.InstructionsBuilder.GetResult]


IntervalTimeTriggerResultClass Class

IntervalTimeTriggerResultClass Class
Namespaces ► VisualCron ► IntervalTimeTriggerResultClass

[Missing <summary> documentation for T:VisualCron.IntervalTimeTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class IntervalTimeTriggerResultClass
<SerializableAttribute> _
Public Class IntervalTimeTriggerResultClass
[SerializableAttribute]
public ref class IntervalTimeTriggerResultClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IntervalTimeTriggerResultClass()()() | Initializes a new instance of the IntervalTimeTriggerResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
IntervalTimeTriggerResultClass

Send comments on this topic to Please email feedback to Support


IntervalTimeTriggerResultClass Constructor

IntervalTimeTriggerResultClass Constructor
Namespaces ► VisualCron ► IntervalTimeTriggerResultClass ► IntervalTimeTriggerResultClass()()()
Initializes a new instance of the IntervalTimeTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public IntervalTimeTriggerResultClass()
Public Sub New
public:
IntervalTimeTriggerResultClass()


ITaskProcess Interface

ITaskProcess Interface
Namespaces ► VisualCron ► ITaskProcess

[Missing <summary> documentation for T:VisualCron.ITaskProcess]

Declaration Syntax
C# Visual Basic Visual C++
public interface ITaskProcess
Public Interface ITaskProcess
public interface class ITaskProcess
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EndProcess()()() |
 | Run()()() |
 | TimeOut(Object) |


EndProcess Method

EndProcess Method
Namespaces ► VisualCron ► ITaskProcess ► EndProcess()()()

[Missing <summary> documentation for M:VisualCron.ITaskProcess.EndProcess]

Declaration Syntax
C# Visual Basic Visual C++
void EndProcess()
Sub EndProcess
void EndProcess()


Run Method

Run Method
Namespaces ► VisualCron ► ITaskProcess ► Run()()()

[Missing <summary> documentation for M:VisualCron.ITaskProcess.Run]

Declaration Syntax
C# Visual Basic Visual C++
void Run()
Sub Run
void Run()


TimeOut Method (state)

TimeOut Method (state)
Namespaces ► VisualCron ► ITaskProcess ► TimeOut(Object)

[Missing <summary> documentation for M:VisualCron.ITaskProcess.TimeOut(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
void TimeOut(
    Object state
)
Sub TimeOut ( _
    state As Object _
)
void TimeOut(
    Object^ state
)
Parameters
state (Object)

[Missing <param name="state"/> documentation for "M:VisualCron.ITaskProcess.TimeOut(System.Object)"]


JobClass Class

JobClass Class
Namespaces ► VisualCron ► JobClass
The JobClass is the placeholder of Triggers, Tasks, Notifications
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JobClass : JobClass..::._JobClass, ICloneable,
    IComparable
<SerializableAttribute> _
Public Class JobClass _
    Implements JobClass..::._JobClass, ICloneable, IComparable
[SerializableAttribute]
public ref class JobClass : JobClass..::._JobClass,
    ICloneable, IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobClass()()() | Initializes a new instance of the JobClass class
 | AddTask(TaskClass..::.TaskT) | Initializes and adds a new Task.
 | AddTrigger(TimeClass..::.TimeTriggerT) | Initializes and adds a Trigger based on TimeTriggerType
 | AddTrigger(EventClass..::.EventTy) | Initializes and adds a Trigger based on EventType
 | Clone()()() | Makes a shallow copy of the Job.
 | CloneType()()() |
 | CompareTo(Object) |
 | CompleteNotifications | An array that contains Id's of all Notifications that should be run when Job is completed
 | Conditions | Gets or sets objects in the list that Contains Id's of all Conditions that are used in this Job.
 | CreatedBy | Gets or sets which user Id created this Job.
 | CreateNewIds()()() | Updates existing Ids on a Job when it has been cloned.
 | Description | Gets or sets the description of the Job
 | DoTriggerExist[([(String])]) | Returns true if a specified Trigger id exists
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorNotifications | An array that contains all Id's of Notifications that should be run when an error has occured in the Job
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasNextTask(TaskClass) |
 | HasPreviousTask(TaskClass) |
 | Id | Gets or sets the unique Id of the Job
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ModifiedBy | Gets or sets which user Id last modified this Job.
 | Name | Gets or sets the name of the Job
 | NewNotification(NotificationClass..::.NType) | Initializes a new Notification based on Notification type
 | NewTask(TaskClass..::.TaskT) | Initializes a new Task.
 | NewTrigger(TriggerClass..::.TriggerT) | Initializes a new Trigger based on TriggerType
 | NewTrigger(TimeClass..::.TimeTriggerT) | Initializes a new TimeTrigger based on TimeTriggerType
 | NewTrigger(EventClass..::.EventTy) | Initializes a new EventTrigger based on EventType
 | NotStartIfRunning | Gets or sets if the the Job should be started or not if it is already running.
 | QueueJobs | If this property is set together with NotStartIfRunning Job will be queued until first Job is finished (if already running)
 | RemoveAfterExecution | Gets or sets if the Job should be removed after executing once.
 | ResetTaskStats()()() |
 | RunMissed | Gets or sets if VisualCron should run this Job if Server is temporary down and during that time misses the last execution.
 | RunOnce | Gets or sets if the Job should be run once and then deactivated.
 | RunRandomValue | Gets or sets a property indicating that the job should not be run every time it is triggered. Using value 2 means that it is "probably" running 1 / 2 = 50% of the times triggered.
 | RunTasksInOrder | Gets or sets if the Tasks within the Job should be run in Order or everyone at the same time, as fast as possible.
 | StartNotifications | An array that contains Id's of all Notifications that should be run at Start of Job
 | Stats | The object that contains statistical information about theJob
 | Task[([(String])]) | Returns a Task based on Task id
 | Tasks | Gets or sets a list of Tasks
 | Test | Gets or sets if this is a test Job running. Test Jobs are not being added.
 | TimeExceptions | Gets or sets a list of TimeExceptions
 | TimeOut | Gets or sets the TimeOut object which control timeout behavior of the Job.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Trigger[([(String])]) | Returns a specific Trigger based on id
 | Triggers | Gets or sets a list of Triggers
 | UniqueRunId | This id will identify a running job status
 | UseRunRandomValue | Gets or sets if the Job should be run randomly, using the RunRandomValue
Remarks
Inheritance Hierarchy
Object
JobClass

Send comments on this topic to Please email feedback to Support


JobClass Constructor

JobClass Constructor
Namespaces ► VisualCron ► JobClass ► JobClass()()()
Initializes a new instance of the JobClass class
Declaration Syntax
C# Visual Basic Visual C++
public JobClass()
Public Sub New
public:
JobClass()


AddTask Method (tt)

AddTask Method (tt)
Namespaces ► VisualCron ► JobClass ► AddTask(TaskClass..::.TaskT)
Initializes and adds a new Task.
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass AddTask(
    TaskClass..::.TaskT tt
)
Public Function AddTask ( _
    tt As TaskClass..::.TaskT _
) As TaskClass
public:
virtual TaskClass^ AddTask(
    TaskClass..::.TaskT tt
) sealed
Parameters
tt (TaskClass..::.TaskT)

[Missing <param name="tt"/> documentation for "M:VisualCron.JobClass.AddTask(VisualCron.TaskClass.TaskT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.AddTask(VisualCron.TaskClass.TaskT)]

Remarks

Send comments on this topic to Please email feedback to Support


AddTrigger Method

AddTrigger Method
Namespaces ► VisualCron ► JobClass ► AddTrigger()()()
Members
Icon | Member | Description
 | AddTrigger(TimeClass..::.TimeTriggerT) | Initializes and adds a Trigger based on TimeTriggerType
 | AddTrigger(EventClass..::.EventTy) | Initializes and adds a Trigger based on EventType


AddTrigger Method (et)

AddTrigger Method (et)
Namespaces ► VisualCron ► JobClass ► AddTrigger(EventClass..::.EventTy)
Initializes and adds a Trigger based on EventType
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass AddTrigger(
    EventClass..::.EventTy et
)
Public Function AddTrigger ( _
    et As EventClass..::.EventTy _
) As TriggerClass
public:
virtual TriggerClass^ AddTrigger(
    EventClass..::.EventTy et
) sealed
Parameters
et (EventClass..::.EventTy)
EventType
Return Value
TriggerClass
Remarks

Send comments on this topic to Please email feedback to Support


AddTrigger Method (ttt)

AddTrigger Method (ttt)
Namespaces ► VisualCron ► JobClass ► AddTrigger(TimeClass..::.TimeTriggerT)
Initializes and adds a Trigger based on TimeTriggerType
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass AddTrigger(
    TimeClass..::.TimeTriggerT ttt
)
Public Function AddTrigger ( _
    ttt As TimeClass..::.TimeTriggerT _
) As TriggerClass
public:
virtual TriggerClass^ AddTrigger(
    TimeClass..::.TimeTriggerT ttt
) sealed
Parameters
ttt (TimeClass..::.TimeTriggerT)
TimeTriggerType
Return Value
TriggerClass
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► JobClass ► Clone()()()
Makes a shallow copy of the Job.
Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.Clone]

Remarks

Send comments on this topic to Please email feedback to Support


CloneType Method

CloneType Method
Namespaces ► VisualCron ► JobClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.JobClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public JobClass CloneType()
Public Function CloneType As JobClass
public:
virtual JobClass^ CloneType() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.CloneType]


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► VisualCron ► JobClass ► CompareTo(Object)

[Missing <summary> documentation for M:VisualCron.JobClass.CompareTo(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCron.JobClass.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.CompareTo(System.Object)]


CompleteNotifications Property

CompleteNotifications Property
Namespaces ► VisualCron ► JobClass ► CompleteNotifications
An array that contains Id's of all Notifications that should be run when Job is completed
Declaration Syntax
C# Visual Basic Visual C++
public List<string> CompleteNotifications { get; set; }
Public Property CompleteNotifications As List(Of String)
public:
property List<String^>^ CompleteNotifications {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support


Conditions Property

Conditions Property
Namespaces ► VisualCron ► JobClass ► Conditions
Gets or sets objects in the list that Contains Id's of all Conditions that are used in this Job.
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Conditions { get; set; }
Public Property Conditions As List(Of String)
public:
property List<String^>^ Conditions {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support


CreatedBy Property

CreatedBy Property
Namespaces ► VisualCron ► JobClass ► CreatedBy
Gets or sets which user Id created this Job.
Declaration Syntax
C# Visual Basic Visual C++
public string CreatedBy { get; set; }
Public Property CreatedBy As String
public:
virtual property String^ CreatedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CreateNewIds Method

CreateNewIds Method
Namespaces ► VisualCron ► JobClass ► CreateNewIds()()()
Updates existing Ids on a Job when it has been cloned.
Declaration Syntax
C# Visual Basic Visual C++
public void CreateNewIds()
Public Sub CreateNewIds
public:
virtual void CreateNewIds() sealed
Remarks

Send comments on this topic to Please email feedback to Support


Description Property

Description Property
Namespaces ► VisualCron ► JobClass ► Description
Gets or sets the description of the Job
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
virtual property String^ Description {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DoTriggerExist Property (strTriggerId)

DoTriggerExist Property (strTriggerId)
Namespaces ► VisualCron ► JobClass ► DoTriggerExist[([(String])])
Returns true if a specified Trigger id exists
Declaration Syntax
C# Visual Basic Visual C++
public bool DoTriggerExist[
    string strTriggerId
] { get; }
Public ReadOnly Property DoTriggerExist ( _
    strTriggerId As String _
) As Boolean
public:
virtual property bool DoTriggerExist[String^ strTriggerId] {
    bool get (String^ strTriggerId) sealed;
}
Parameters
strTriggerId (String)
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ErrorNotifications Property

ErrorNotifications Property
Namespaces ► VisualCron ► JobClass ► ErrorNotifications
An array that contains all Id's of Notifications that should be run when an error has occured in the Job
Declaration Syntax
C# Visual Basic Visual C++
public List<string> ErrorNotifications { get; set; }
Public Property ErrorNotifications As List(Of String)
public:
property List<String^>^ ErrorNotifications {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support


HasNextTask Method (tc)

HasNextTask Method (tc)
Namespaces ► VisualCron ► JobClass ► HasNextTask(TaskClass)

[Missing <summary> documentation for M:VisualCron.JobClass.HasNextTask(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
public TaskClass HasNextTask(
    TaskClass tc
)
Public Function HasNextTask ( _
    tc As TaskClass _
) As TaskClass
public:
virtual TaskClass^ HasNextTask(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCron.JobClass.HasNextTask(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.HasNextTask(VisualCron.TaskClass)]


HasPreviousTask Method (tc)

HasPreviousTask Method (tc)
Namespaces ► VisualCron ► JobClass ► HasPreviousTask(TaskClass)

[Missing <summary> documentation for M:VisualCron.JobClass.HasPreviousTask(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
public TaskClass HasPreviousTask(
    TaskClass tc
)
Public Function HasPreviousTask ( _
    tc As TaskClass _
) As TaskClass
public:
virtual TaskClass^ HasPreviousTask(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCron.JobClass.HasPreviousTask(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.HasPreviousTask(VisualCron.TaskClass)]


Id Property

Id Property
Namespaces ► VisualCron ► JobClass ► Id
Gets or sets the unique Id of the Job
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
virtual property String^ Id {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ModifiedBy Property

ModifiedBy Property
Namespaces ► VisualCron ► JobClass ► ModifiedBy
Gets or sets which user Id last modified this Job.
Declaration Syntax
C# Visual Basic Visual C++
public string ModifiedBy { get; set; }
Public Property ModifiedBy As String
public:
virtual property String^ ModifiedBy {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► JobClass ► Name
Gets or sets the name of the Job
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NewNotification Method (nt)

NewNotification Method (nt)
Namespaces ► VisualCron ► JobClass ► NewNotification(NotificationClass..::.NType)
Initializes a new Notification based on Notification type
Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass NewNotification(
    NotificationClass..::.NType nt
)
Public Function NewNotification ( _
    nt As NotificationClass..::.NType _
) As NotificationClass
public:
virtual NotificationClass^ NewNotification(
    NotificationClass..::.NType nt
) sealed
Parameters
nt (NotificationClass..::.NType)
Notification type
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.NewNotification(VisualCron.NotificationClass.NType)]

Remarks

Send comments on this topic to Please email feedback to Support


NewTask Method (tt)

NewTask Method (tt)
Namespaces ► VisualCron ► JobClass ► NewTask(TaskClass..::.TaskT)
Initializes a new Task.
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass NewTask(
    TaskClass..::.TaskT tt
)
Public Function NewTask ( _
    tt As TaskClass..::.TaskT _
) As TaskClass
public:
virtual TaskClass^ NewTask(
    TaskClass..::.TaskT tt
) sealed
Parameters
tt (TaskClass..::.TaskT)

[Missing <param name="tt"/> documentation for "M:VisualCron.JobClass.NewTask(VisualCron.TaskClass.TaskT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.NewTask(VisualCron.TaskClass.TaskT)]

Remarks

Send comments on this topic to Please email feedback to Support


NewTrigger Method

NewTrigger Method
Namespaces ► VisualCron ► JobClass ► NewTrigger()()()
Members
Icon | Member | Description
 | NewTrigger(TriggerClass..::.TriggerT) | Initializes a new Trigger based on TriggerType
 | NewTrigger(TimeClass..::.TimeTriggerT) | Initializes a new TimeTrigger based on TimeTriggerType
 | NewTrigger(EventClass..::.EventTy) | Initializes a new EventTrigger based on EventType


NewTrigger Method (et)

NewTrigger Method (et)
Namespaces ► VisualCron ► JobClass ► NewTrigger(EventClass..::.EventTy)
Initializes a new EventTrigger based on EventType
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass NewTrigger(
    EventClass..::.EventTy et
)
Public Function NewTrigger ( _
    et As EventClass..::.EventTy _
) As TriggerClass
public:
virtual TriggerClass^ NewTrigger(
    EventClass..::.EventTy et
) sealed
Parameters
et (EventClass..::.EventTy)
EventType
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.NewTrigger(VisualCron.EventClass.EventTy)]

Remarks

Send comments on this topic to Please email feedback to Support


NewTrigger Method (ttt)

NewTrigger Method (ttt)
Namespaces ► VisualCron ► JobClass ► NewTrigger(TimeClass..::.TimeTriggerT)
Initializes a new TimeTrigger based on TimeTriggerType
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass NewTrigger(
    TimeClass..::.TimeTriggerT ttt
)
Public Function NewTrigger ( _
    ttt As TimeClass..::.TimeTriggerT _
) As TriggerClass
public:
virtual TriggerClass^ NewTrigger(
    TimeClass..::.TimeTriggerT ttt
) sealed
Parameters
ttt (TimeClass..::.TimeTriggerT)
TimeTriggerType
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.NewTrigger(VisualCron.TimeClass.TimeTriggerT)]

Remarks

Send comments on this topic to Please email feedback to Support


NewTrigger Method (tt)

NewTrigger Method (tt)
Namespaces ► VisualCron ► JobClass ► NewTrigger(TriggerClass..::.TriggerT)
Initializes a new Trigger based on TriggerType
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass NewTrigger(
    TriggerClass..::.TriggerT tt
)
Public Function NewTrigger ( _
    tt As TriggerClass..::.TriggerT _
) As TriggerClass
public:
virtual TriggerClass^ NewTrigger(
    TriggerClass..::.TriggerT tt
) sealed
Parameters
tt (TriggerClass..::.TriggerT)
TriggerType
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass.NewTrigger(VisualCron.TriggerClass.TriggerT)]

Remarks

Send comments on this topic to Please email feedback to Support


NotStartIfRunning Property

NotStartIfRunning Property
Namespaces ► VisualCron ► JobClass ► NotStartIfRunning
Gets or sets if the the Job should be started or not if it is already running.
Declaration Syntax
C# Visual Basic Visual C++
public bool NotStartIfRunning { get; set; }
Public Property NotStartIfRunning As Boolean
public:
virtual property bool NotStartIfRunning {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


QueueJobs Property

QueueJobs Property
Namespaces ► VisualCron ► JobClass ► QueueJobs
If this property is set together with NotStartIfRunning Job will be queued until first Job is finished (if already running)
Declaration Syntax
C# Visual Basic Visual C++
public bool QueueJobs { get; set; }
Public Property QueueJobs As Boolean
public:
virtual property bool QueueJobs {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RemoveAfterExecution Property

RemoveAfterExecution Property
Namespaces ► VisualCron ► JobClass ► RemoveAfterExecution
Gets or sets if the Job should be removed after executing once.
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveAfterExecution { get; set; }
Public Property RemoveAfterExecution As Boolean
public:
virtual property bool RemoveAfterExecution {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ResetTaskStats Method

ResetTaskStats Method
Namespaces ► VisualCron ► JobClass ► ResetTaskStats()()()

[Missing <summary> documentation for M:VisualCron.JobClass.ResetTaskStats]

Declaration Syntax
C# Visual Basic Visual C++
public void ResetTaskStats()
Public Sub ResetTaskStats
public:
virtual void ResetTaskStats() sealed


RunMissed Property

RunMissed Property
Namespaces ► VisualCron ► JobClass ► RunMissed
Gets or sets if VisualCron should run this Job if Server is temporary down and during that time misses the last execution.
Declaration Syntax
C# Visual Basic Visual C++
public bool RunMissed { get; set; }
Public Property RunMissed As Boolean
public:
virtual property bool RunMissed {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RunOnce Property

RunOnce Property
Namespaces ► VisualCron ► JobClass ► RunOnce
Gets or sets if the Job should be run once and then deactivated.
Declaration Syntax
C# Visual Basic Visual C++
public bool RunOnce { get; set; }
Public Property RunOnce As Boolean
public:
virtual property bool RunOnce {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RunRandomValue Property

RunRandomValue Property
Namespaces ► VisualCron ► JobClass ► RunRandomValue
Gets or sets a property indicating that the job should not be run every time it is triggered. Using value 2 means that it is "probably" running 1 / 2 = 50% of the times triggered.
Declaration Syntax
C# Visual Basic Visual C++
public int RunRandomValue { get; set; }
Public Property RunRandomValue As Integer
public:
virtual property int RunRandomValue {
    int get () sealed;
    void set (int value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RunTasksInOrder Property

RunTasksInOrder Property
Namespaces ► VisualCron ► JobClass ► RunTasksInOrder
Gets or sets if the Tasks within the Job should be run in Order or everyone at the same time, as fast as possible.
Declaration Syntax
C# Visual Basic Visual C++
public bool RunTasksInOrder { get; set; }
Public Property RunTasksInOrder As Boolean
public:
virtual property bool RunTasksInOrder {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks
Cannot be just in conjunction with Conditions on the Task.


StartNotifications Property

StartNotifications Property
Namespaces ► VisualCron ► JobClass ► StartNotifications
An array that contains Id's of all Notifications that should be run at Start of Job
Declaration Syntax
C# Visual Basic Visual C++
public List<string> StartNotifications { get; set; }
Public Property StartNotifications As List(Of String)
public:
property List<String^>^ StartNotifications {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support


Stats Property

Stats Property
Namespaces ► VisualCron ► JobClass ► Stats
The object that contains statistical information about theJob
Declaration Syntax
C# Visual Basic Visual C++
public JobStatsClass Stats { get; set; }
Public Property Stats As JobStatsClass
public:
virtual property JobStatsClass^ Stats {
    JobStatsClass^ get () sealed;
    void set (JobStatsClass^ value) sealed;
}
Remarks

Send comments on this topic to Please email feedback to Support


Task Property (strTaskId)

Task Property (strTaskId)
Namespaces ► VisualCron ► JobClass ► Task[([(String])])
Returns a Task based on Task id
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass Task[
    string strTaskId
] { get; set; }
Public Property Task ( _
    strTaskId As String _
) As TaskClass
public:
virtual property TaskClass^ Task[String^ strTaskId] {
    TaskClass^ get (String^ strTaskId) sealed;
    void set (String^ strTaskId, TaskClass^ value) sealed;
}
Parameters
strTaskId (String)
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Tasks Property

Tasks Property
Namespaces ► VisualCron ► JobClass ► Tasks
Gets or sets a list of Tasks
Declaration Syntax
C# Visual Basic Visual C++
public List<TaskClass> Tasks { get; set; }
Public Property Tasks As List(Of TaskClass)
public:
virtual property List<TaskClass^>^ Tasks {
    List<TaskClass^>^ get () sealed;
    void set (List<TaskClass^>^ value) sealed;
}
Remarks

Send comments on this topic to Please email feedback to Support


Test Property

Test Property
Namespaces ► VisualCron ► JobClass ► Test
Gets or sets if this is a test Job running. Test Jobs are not being added.
Declaration Syntax
C# Visual Basic Visual C++
public bool Test { get; set; }
Public Property Test As Boolean
public:
virtual property bool Test {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeExceptions Property

TimeExceptions Property
Namespaces ► VisualCron ► JobClass ► TimeExceptions
Gets or sets a list of TimeExceptions
Declaration Syntax
C# Visual Basic Visual C++
public List<string> TimeExceptions { get; set; }
Public Property TimeExceptions As List(Of String)
public:
property List<String^>^ TimeExceptions {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support


TimeOut Property

TimeOut Property
Namespaces ► VisualCron ► JobClass ► TimeOut
Gets or sets the TimeOut object which control timeout behavior of the Job.
Declaration Syntax
C# Visual Basic Visual C++
public TimeOutClass TimeOut { get; set; }
Public Property TimeOut As TimeOutClass
public:
virtual property TimeOutClass^ TimeOut {
    TimeOutClass^ get () sealed;
    void set (TimeOutClass^ value) sealed;
}
Remarks

Send comments on this topic to Please email feedback to Support


Trigger Property (strTriggerId)

Trigger Property (strTriggerId)
Namespaces ► VisualCron ► JobClass ► Trigger[([(String])])
Returns a specific Trigger based on id
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass Trigger[
    string strTriggerId
] { get; set; }
Public Property Trigger ( _
    strTriggerId As String _
) As TriggerClass
public:
virtual property TriggerClass^ Trigger[String^ strTriggerId] {
    TriggerClass^ get (String^ strTriggerId) sealed;
    void set (String^ strTriggerId, TriggerClass^ value) sealed;
}
Parameters
strTriggerId (String)
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Triggers Property

Triggers Property
Namespaces ► VisualCron ► JobClass ► Triggers
Gets or sets a list of Triggers
Declaration Syntax
C# Visual Basic Visual C++
public List<TriggerClass> Triggers { get; set; }
Public Property Triggers As List(Of TriggerClass)
public:
property List<TriggerClass^>^ Triggers {
    List<TriggerClass^>^ get ();
    void set (List<TriggerClass^>^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support


UniqueRunId Property

UniqueRunId Property
Namespaces ► VisualCron ► JobClass ► UniqueRunId
This id will identify a running job status
Declaration Syntax
C# Visual Basic Visual C++
public long UniqueRunId { get; set; }
Public Property UniqueRunId As Long
public:
virtual property long long UniqueRunId {
    long long get () sealed;
    void set (long long value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseRunRandomValue Property

UseRunRandomValue Property
Namespaces ► VisualCron ► JobClass ► UseRunRandomValue
Gets or sets if the Job should be run randomly, using the RunRandomValue
Declaration Syntax
C# Visual Basic Visual C++
public bool UseRunRandomValue { get; set; }
Public Property UseRunRandomValue As Boolean
public:
virtual property bool UseRunRandomValue {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobClass._JobClass Interface

JobClass..::._JobClass Interface
Namespaces ► VisualCron ► JobClass ► JobClass..::._JobClass

[Missing <summary> documentation for T:VisualCron.JobClass._JobClass]

Declaration Syntax
C# Visual Basic Visual C++
public interface _JobClass
Public Interface _JobClass
public interface class _JobClass
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddTask(TaskClass..::.TaskT) |
 | AddTrigger(TimeClass..::.TimeTriggerT) |
 | AddTrigger(EventClass..::.EventTy) |
 | Clone()()() |
 | CloneType()()() |
 | CompareTo(Object) |
 | CreatedBy |
 | CreateNewIds()()() |
 | Description |
 | DoTriggerExist[([(String])]) |
 | HasNextTask(TaskClass) |
 | HasPreviousTask(TaskClass) |
 | Id |
 | ModifiedBy |
 | Name |
 | NewNotification(NotificationClass..::.NType) |
 | NewTask(TaskClass..::.TaskT) |
 | NewTrigger(TriggerClass..::.TriggerT) |
 | NewTrigger(TimeClass..::.TimeTriggerT) |
 | NewTrigger(EventClass..::.EventTy) |
 | NotStartIfRunning |
 | QueueJobs |
 | RemoveAfterExecution |
 | ResetTaskStats()()() |
 | RunMissed |
 | RunOnce |
 | RunRandomValue |
 | RunTasksInOrder |
 | Stats |
 | Task[([(String])]) |
 | Tasks |
 | Test |
 | TimeOut |
 | Trigger[([(String])]) |
 | UniqueRunId |
 | UseRunRandomValue |


AddTask Method (tt)

AddTask Method (tt)
Namespaces ► VisualCron ► JobClass..::._JobClass ► AddTask(TaskClass..::.TaskT)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.AddTask(VisualCron.TaskClass.TaskT)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass AddTask(
    TaskClass..::.TaskT tt
)
Function AddTask ( _
    tt As TaskClass..::.TaskT _
) As TaskClass
TaskClass^ AddTask(
    TaskClass..::.TaskT tt
)
Parameters
tt (TaskClass..::.TaskT)

[Missing <param name="tt"/> documentation for "M:VisualCron.JobClass._JobClass.AddTask(VisualCron.TaskClass.TaskT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.AddTask(VisualCron.TaskClass.TaskT)]


AddTrigger Method

AddTrigger Method
Namespaces ► VisualCron ► JobClass..::._JobClass ► AddTrigger()()()
Members
Icon | Member | Description
 | AddTrigger(TimeClass..::.TimeTriggerT) |
 | AddTrigger(EventClass..::.EventTy) |


AddTrigger Method (et)

AddTrigger Method (et)
Namespaces ► VisualCron ► JobClass..::._JobClass ► AddTrigger(EventClass..::.EventTy)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.AddTrigger(VisualCron.EventClass.EventTy)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass AddTrigger(
    EventClass..::.EventTy et
)
Function AddTrigger ( _
    et As EventClass..::.EventTy _
) As TriggerClass
TriggerClass^ AddTrigger(
    EventClass..::.EventTy et
)
Parameters
et (EventClass..::.EventTy)

[Missing <param name="et"/> documentation for "M:VisualCron.JobClass._JobClass.AddTrigger(VisualCron.EventClass.EventTy)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.AddTrigger(VisualCron.EventClass.EventTy)]


AddTrigger Method (ttt)

AddTrigger Method (ttt)
Namespaces ► VisualCron ► JobClass..::._JobClass ► AddTrigger(TimeClass..::.TimeTriggerT)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.AddTrigger(VisualCron.TimeClass.TimeTriggerT)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass AddTrigger(
    TimeClass..::.TimeTriggerT ttt
)
Function AddTrigger ( _
    ttt As TimeClass..::.TimeTriggerT _
) As TriggerClass
TriggerClass^ AddTrigger(
    TimeClass..::.TimeTriggerT ttt
)
Parameters
ttt (TimeClass..::.TimeTriggerT)

[Missing <param name="ttt"/> documentation for "M:VisualCron.JobClass._JobClass.AddTrigger(VisualCron.TimeClass.TimeTriggerT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.AddTrigger(VisualCron.TimeClass.TimeTriggerT)]


Clone Method

Clone Method
Namespaces ► VisualCron ► JobClass..::._JobClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
Object Clone()
Function Clone As Object
Object^ Clone()
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► JobClass..::._JobClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
JobClass CloneType()
Function CloneType As JobClass
JobClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.CloneType]


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► VisualCron ► JobClass..::._JobClass ► CompareTo(Object)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.CompareTo(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
int CompareTo(
    Object obj
)
Function CompareTo ( _
    obj As Object _
) As Integer
int CompareTo(
    Object^ obj
)
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCron.JobClass._JobClass.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.CompareTo(System.Object)]


CreatedBy Property

CreatedBy Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► CreatedBy

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.CreatedBy]

Declaration Syntax
C# Visual Basic Visual C++
string CreatedBy { get; set; }
Property CreatedBy As String
property String^ CreatedBy {
    String^ get ();
    void set (String^ value);
}


CreateNewIds Method

CreateNewIds Method
Namespaces ► VisualCron ► JobClass..::._JobClass ► CreateNewIds()()()

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.CreateNewIds]

Declaration Syntax
C# Visual Basic Visual C++
void CreateNewIds()
Sub CreateNewIds
void CreateNewIds()


Description Property

Description Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► Description

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Description]

Declaration Syntax
C# Visual Basic Visual C++
string Description { get; set; }
Property Description As String
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DoTriggerExist Property (strTriggerId)

DoTriggerExist Property (strTriggerId)
Namespaces ► VisualCron ► JobClass..::._JobClass ► DoTriggerExist[([(String])])

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.DoTriggerExist(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool DoTriggerExist[
    string strTriggerId
] { get; }
ReadOnly Property DoTriggerExist ( _
    strTriggerId As String _
) As Boolean
property bool DoTriggerExist[String^ strTriggerId] {
    bool get (String^ strTriggerId);
}
Parameters
strTriggerId (String)


HasNextTask Method (tc)

HasNextTask Method (tc)
Namespaces ► VisualCron ► JobClass..::._JobClass ► HasNextTask(TaskClass)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.HasNextTask(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass HasNextTask(
    TaskClass tc
)
Function HasNextTask ( _
    tc As TaskClass _
) As TaskClass
TaskClass^ HasNextTask(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCron.JobClass._JobClass.HasNextTask(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.HasNextTask(VisualCron.TaskClass)]


HasPreviousTask Method (tc)

HasPreviousTask Method (tc)
Namespaces ► VisualCron ► JobClass..::._JobClass ► HasPreviousTask(TaskClass)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.HasPreviousTask(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass HasPreviousTask(
    TaskClass tc
)
Function HasPreviousTask ( _
    tc As TaskClass _
) As TaskClass
TaskClass^ HasPreviousTask(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCron.JobClass._JobClass.HasPreviousTask(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.HasPreviousTask(VisualCron.TaskClass)]


Id Property

Id Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► Id

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
string Id { get; set; }
Property Id As String
property String^ Id {
    String^ get ();
    void set (String^ value);
}


ModifiedBy Property

ModifiedBy Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► ModifiedBy

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.ModifiedBy]

Declaration Syntax
C# Visual Basic Visual C++
string ModifiedBy { get; set; }
Property ModifiedBy As String
property String^ ModifiedBy {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► Name

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
string Name { get; set; }
Property Name As String
property String^ Name {
    String^ get ();
    void set (String^ value);
}


NewNotification Method (nt)

NewNotification Method (nt)
Namespaces ► VisualCron ► JobClass..::._JobClass ► NewNotification(NotificationClass..::.NType)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.NewNotification(VisualCron.NotificationClass.NType)]

Declaration Syntax
C# Visual Basic Visual C++
NotificationClass NewNotification(
    NotificationClass..::.NType nt
)
Function NewNotification ( _
    nt As NotificationClass..::.NType _
) As NotificationClass
NotificationClass^ NewNotification(
    NotificationClass..::.NType nt
)
Parameters
nt (NotificationClass..::.NType)

[Missing <param name="nt"/> documentation for "M:VisualCron.JobClass._JobClass.NewNotification(VisualCron.NotificationClass.NType)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.NewNotification(VisualCron.NotificationClass.NType)]


NewTask Method (tt)

NewTask Method (tt)
Namespaces ► VisualCron ► JobClass..::._JobClass ► NewTask(TaskClass..::.TaskT)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.NewTask(VisualCron.TaskClass.TaskT)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass NewTask(
    TaskClass..::.TaskT tt
)
Function NewTask ( _
    tt As TaskClass..::.TaskT _
) As TaskClass
TaskClass^ NewTask(
    TaskClass..::.TaskT tt
)
Parameters
tt (TaskClass..::.TaskT)

[Missing <param name="tt"/> documentation for "M:VisualCron.JobClass._JobClass.NewTask(VisualCron.TaskClass.TaskT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.NewTask(VisualCron.TaskClass.TaskT)]


NewTrigger Method

NewTrigger Method
Namespaces ► VisualCron ► JobClass..::._JobClass ► NewTrigger()()()
Members
Icon | Member | Description
 | NewTrigger(TriggerClass..::.TriggerT) |
 | NewTrigger(TimeClass..::.TimeTriggerT) |
 | NewTrigger(EventClass..::.EventTy) |


NewTrigger Method (et)

NewTrigger Method (et)
Namespaces ► VisualCron ► JobClass..::._JobClass ► NewTrigger(EventClass..::.EventTy)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.EventClass.EventTy)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass NewTrigger(
    EventClass..::.EventTy et
)
Function NewTrigger ( _
    et As EventClass..::.EventTy _
) As TriggerClass
TriggerClass^ NewTrigger(
    EventClass..::.EventTy et
)
Parameters
et (EventClass..::.EventTy)

[Missing <param name="et"/> documentation for "M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.EventClass.EventTy)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.EventClass.EventTy)]


NewTrigger Method (ttt)

NewTrigger Method (ttt)
Namespaces ► VisualCron ► JobClass..::._JobClass ► NewTrigger(TimeClass..::.TimeTriggerT)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.TimeClass.TimeTriggerT)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass NewTrigger(
    TimeClass..::.TimeTriggerT ttt
)
Function NewTrigger ( _
    ttt As TimeClass..::.TimeTriggerT _
) As TriggerClass
TriggerClass^ NewTrigger(
    TimeClass..::.TimeTriggerT ttt
)
Parameters
ttt (TimeClass..::.TimeTriggerT)

[Missing <param name="ttt"/> documentation for "M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.TimeClass.TimeTriggerT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.TimeClass.TimeTriggerT)]


NewTrigger Method (tt)

NewTrigger Method (tt)
Namespaces ► VisualCron ► JobClass..::._JobClass ► NewTrigger(TriggerClass..::.TriggerT)

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.TriggerClass.TriggerT)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass NewTrigger(
    TriggerClass..::.TriggerT tt
)
Function NewTrigger ( _
    tt As TriggerClass..::.TriggerT _
) As TriggerClass
TriggerClass^ NewTrigger(
    TriggerClass..::.TriggerT tt
)
Parameters
tt (TriggerClass..::.TriggerT)

[Missing <param name="tt"/> documentation for "M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.TriggerClass.TriggerT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobClass._JobClass.NewTrigger(VisualCron.TriggerClass.TriggerT)]


NotStartIfRunning Property

NotStartIfRunning Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► NotStartIfRunning

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.NotStartIfRunning]

Declaration Syntax
C# Visual Basic Visual C++
bool NotStartIfRunning { get; set; }
Property NotStartIfRunning As Boolean
property bool NotStartIfRunning {
    bool get ();
    void set (bool value);
}


QueueJobs Property

QueueJobs Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► QueueJobs

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.QueueJobs]

Declaration Syntax
C# Visual Basic Visual C++
bool QueueJobs { get; set; }
Property QueueJobs As Boolean
property bool QueueJobs {
    bool get ();
    void set (bool value);
}


RemoveAfterExecution Property

RemoveAfterExecution Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► RemoveAfterExecution

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.RemoveAfterExecution]

Declaration Syntax
C# Visual Basic Visual C++
bool RemoveAfterExecution { get; set; }
Property RemoveAfterExecution As Boolean
property bool RemoveAfterExecution {
    bool get ();
    void set (bool value);
}


ResetTaskStats Method

ResetTaskStats Method
Namespaces ► VisualCron ► JobClass..::._JobClass ► ResetTaskStats()()()

[Missing <summary> documentation for M:VisualCron.JobClass._JobClass.ResetTaskStats]

Declaration Syntax
C# Visual Basic Visual C++
void ResetTaskStats()
Sub ResetTaskStats
void ResetTaskStats()


RunMissed Property

RunMissed Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► RunMissed

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.RunMissed]

Declaration Syntax
C# Visual Basic Visual C++
bool RunMissed { get; set; }
Property RunMissed As Boolean
property bool RunMissed {
    bool get ();
    void set (bool value);
}


RunOnce Property

RunOnce Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► RunOnce

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.RunOnce]

Declaration Syntax
C# Visual Basic Visual C++
bool RunOnce { get; set; }
Property RunOnce As Boolean
property bool RunOnce {
    bool get ();
    void set (bool value);
}


RunRandomValue Property

RunRandomValue Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► RunRandomValue

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.RunRandomValue]

Declaration Syntax
C# Visual Basic Visual C++
int RunRandomValue { get; set; }
Property RunRandomValue As Integer
property int RunRandomValue {
    int get ();
    void set (int value);
}


RunTasksInOrder Property

RunTasksInOrder Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► RunTasksInOrder

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.RunTasksInOrder]

Declaration Syntax
C# Visual Basic Visual C++
bool RunTasksInOrder { get; set; }
Property RunTasksInOrder As Boolean
property bool RunTasksInOrder {
    bool get ();
    void set (bool value);
}


Stats Property

Stats Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► Stats

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Stats]

Declaration Syntax
C# Visual Basic Visual C++
JobStatsClass Stats { get; set; }
Property Stats As JobStatsClass
property JobStatsClass^ Stats {
    JobStatsClass^ get ();
    void set (JobStatsClass^ value);
}


Task Property (strTaskId)

Task Property (strTaskId)
Namespaces ► VisualCron ► JobClass..::._JobClass ► Task[([(String])])

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Task(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass Task[
    string strTaskId
] { get; set; }
Property Task ( _
    strTaskId As String _
) As TaskClass
property TaskClass^ Task[String^ strTaskId] {
    TaskClass^ get (String^ strTaskId);
    void set (String^ strTaskId, TaskClass^ value);
}
Parameters
strTaskId (String)


Tasks Property

Tasks Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► Tasks

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Tasks]

Declaration Syntax
C# Visual Basic Visual C++
List<TaskClass> Tasks { get; set; }
Property Tasks As List(Of TaskClass)
property List<TaskClass^>^ Tasks {
    List<TaskClass^>^ get ();
    void set (List<TaskClass^>^ value);
}


Test Property

Test Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► Test

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Test]

Declaration Syntax
C# Visual Basic Visual C++
bool Test { get; set; }
Property Test As Boolean
property bool Test {
    bool get ();
    void set (bool value);
}


TimeOut Property

TimeOut Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► TimeOut

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.TimeOut]

Declaration Syntax
C# Visual Basic Visual C++
TimeOutClass TimeOut { get; set; }
Property TimeOut As TimeOutClass
property TimeOutClass^ TimeOut {
    TimeOutClass^ get ();
    void set (TimeOutClass^ value);
}


Trigger Property (strTriggerId)

Trigger Property (strTriggerId)
Namespaces ► VisualCron ► JobClass..::._JobClass ► Trigger[([(String])])

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.Trigger(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass Trigger[
    string strTriggerId
] { get; set; }
Property Trigger ( _
    strTriggerId As String _
) As TriggerClass
property TriggerClass^ Trigger[String^ strTriggerId] {
    TriggerClass^ get (String^ strTriggerId);
    void set (String^ strTriggerId, TriggerClass^ value);
}
Parameters
strTriggerId (String)


UniqueRunId Property

UniqueRunId Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► UniqueRunId

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.UniqueRunId]

Declaration Syntax
C# Visual Basic Visual C++
long UniqueRunId { get; set; }
Property UniqueRunId As Long
property long long UniqueRunId {
    long long get ();
    void set (long long value);
}


UseRunRandomValue Property

UseRunRandomValue Property
Namespaces ► VisualCron ► JobClass..::._JobClass ► UseRunRandomValue

[Missing <summary> documentation for P:VisualCron.JobClass._JobClass.UseRunRandomValue]

Declaration Syntax
C# Visual Basic Visual C++
bool UseRunRandomValue { get; set; }
Property UseRunRandomValue As Boolean
property bool UseRunRandomValue {
    bool get ();
    void set (bool value);
}


JobDeleteAllClass Class

JobDeleteAllClass Class
Namespaces ► VisualCron ► JobDeleteAllClass

[Missing <summary> documentation for T:VisualCron.JobDeleteAllClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JobDeleteAllClass
<SerializableAttribute> _
Public Class JobDeleteAllClass
[SerializableAttribute]
public ref class JobDeleteAllClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobDeleteAllClass()()() | Initializes a new instance of the JobDeleteAllClass class
 | Deleted | Gets or sets if the Jobs was deleted succesfully
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
JobDeleteAllClass

Send comments on this topic to Please email feedback to Support


JobDeleteAllClass Constructor

JobDeleteAllClass Constructor
Namespaces ► VisualCron ► JobDeleteAllClass ► JobDeleteAllClass()()()
Initializes a new instance of the JobDeleteAllClass class
Declaration Syntax
C# Visual Basic Visual C++
public JobDeleteAllClass()
Public Sub New
public:
JobDeleteAllClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► JobDeleteAllClass ► Deleted
Gets or sets if the Jobs was deleted succesfully
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobDeleteClass Class

JobDeleteClass Class
Namespaces ► VisualCron ► JobDeleteClass
Message for deleting a Job
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JobDeleteClass
<SerializableAttribute> _
Public Class JobDeleteClass
[SerializableAttribute]
public ref class JobDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobDeleteClass()()() | Initializes a new instance of the JobDeleteClass class
 | Deleted | Gets or sets if the Job was deleted succesfully
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Job that should be deleted
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
JobDeleteClass

Send comments on this topic to Please email feedback to Support


JobDeleteClass Constructor

JobDeleteClass Constructor
Namespaces ► VisualCron ► JobDeleteClass ► JobDeleteClass()()()
Initializes a new instance of the JobDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public JobDeleteClass()
Public Sub New
public:
JobDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► JobDeleteClass ► Deleted
Gets or sets if the Job was deleted succesfully
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► JobDeleteClass ► Id
Gets or sets the Id of the Job that should be deleted
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobRunClass Class

JobRunClass Class
Namespaces ► VisualCron ► JobRunClass

[Missing <summary> documentation for T:VisualCron.JobRunClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JobRunClass
<SerializableAttribute> _
Public Class JobRunClass
[SerializableAttribute]
public ref class JobRunClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobRunClass()()() | Initializes a new instance of the JobRunClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Job that should be started
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WasStarted | Gets or sets if the Job was started succesfully
Inheritance Hierarchy
Object
JobRunClass

Send comments on this topic to Please email feedback to Support


JobRunClass Constructor

JobRunClass Constructor
Namespaces ► VisualCron ► JobRunClass ► JobRunClass()()()
Initializes a new instance of the JobRunClass class
Declaration Syntax
C# Visual Basic Visual C++
public JobRunClass()
Public Sub New
public:
JobRunClass()


Id Property

Id Property
Namespaces ► VisualCron ► JobRunClass ► Id
Gets or sets the Id of the Job that should be started
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


WasStarted Property

WasStarted Property
Namespaces ► VisualCron ► JobRunClass ► WasStarted
Gets or sets if the Job was started succesfully
Declaration Syntax
C# Visual Basic Visual C++
public bool WasStarted { get; set; }
Public Property WasStarted As Boolean
public:
property bool WasStarted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobStateClass Class

JobStateClass Class
Namespaces ► VisualCron ► JobStateClass
Message that changes Job Active state
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JobStateClass
<SerializableAttribute> _
Public Class JobStateClass
[SerializableAttribute]
public ref class JobStateClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobStateClass()()() | Initializes a new instance of the JobStateClass class
 | Active |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
JobStateClass

Send comments on this topic to Please email feedback to Support


JobStateClass Constructor

JobStateClass Constructor
Namespaces ► VisualCron ► JobStateClass ► JobStateClass()()()
Initializes a new instance of the JobStateClass class
Declaration Syntax
C# Visual Basic Visual C++
public JobStateClass()
Public Sub New
public:
JobStateClass()


Active Property

Active Property
Namespaces ► VisualCron ► JobStateClass ► Active

[Missing <summary> documentation for P:VisualCron.JobStateClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}


JobId Property

JobId Property
Namespaces ► VisualCron ► JobStateClass ► JobId

[Missing <summary> documentation for P:VisualCron.JobStateClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


JobStatsClass Class

JobStatsClass Class
Namespaces ► VisualCron ► JobStatsClass

[Missing <summary> documentation for T:VisualCron.JobStatsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class JobStatsClass : ICloneable
<SerializableAttribute> _
Public Class JobStatsClass _
    Implements ICloneable
[SerializableAttribute]
public ref class JobStatsClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | JobStatsClass()()() | Initializes a new instance of the JobStatsClass class
 | Active |
 | Clone()()() |
 | CloneType(Boolean) |
 | DateCreated |
 | DateLastExecution |
 | DateLastExited |
 | DateModified |
 | DateNextExecution |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionTime |
 | ExitCode | Contains exit code ne 0 if any task should fail
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | LastTriggerId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoExecutes |
 | Reset()()() |
 | Status |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
JobStatsClass

Send comments on this topic to Please email feedback to Support


JobStatsClass Constructor

JobStatsClass Constructor
Namespaces ► VisualCron ► JobStatsClass ► JobStatsClass()()()
Initializes a new instance of the JobStatsClass class
Declaration Syntax
C# Visual Basic Visual C++
public JobStatsClass()
Public Sub New
public:
JobStatsClass()


Active Property

Active Property
Namespaces ► VisualCron ► JobStatsClass ► Active

[Missing <summary> documentation for P:VisualCron.JobStatsClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► JobStatsClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.JobStatsClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.JobStatsClass.Clone]


CloneType Method (bolClear)

CloneType Method (bolClear)
Namespaces ► VisualCron ► JobStatsClass ► CloneType(Boolean)

[Missing <summary> documentation for M:VisualCron.JobStatsClass.CloneType(System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public JobStatsClass CloneType(
    bool bolClear
)
Public Function CloneType ( _
    bolClear As Boolean _
) As JobStatsClass
public:
JobStatsClass^ CloneType(
    bool bolClear
)
Parameters
bolClear (Boolean)

[Missing <param name="bolClear"/> documentation for "M:VisualCron.JobStatsClass.CloneType(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCron.JobStatsClass.CloneType(System.Boolean)]


DateCreated Property

DateCreated Property
Namespaces ► VisualCron ► JobStatsClass ► DateCreated

[Missing <summary> documentation for P:VisualCron.JobStatsClass.DateCreated]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateCreated { get; set; }
Public Property DateCreated As DateTime
public:
property DateTime DateCreated {
    DateTime get ();
    void set (DateTime value);
}


DateLastExecution Property

DateLastExecution Property
Namespaces ► VisualCron ► JobStatsClass ► DateLastExecution

[Missing <summary> documentation for P:VisualCron.JobStatsClass.DateLastExecution]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateLastExecution { get; set; }
Public Property DateLastExecution As DateTime
public:
property DateTime DateLastExecution {
    DateTime get ();
    void set (DateTime value);
}


DateLastExited Property

DateLastExited Property
Namespaces ► VisualCron ► JobStatsClass ► DateLastExited

[Missing <summary> documentation for P:VisualCron.JobStatsClass.DateLastExited]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateLastExited { get; set; }
Public Property DateLastExited As DateTime
public:
property DateTime DateLastExited {
    DateTime get ();
    void set (DateTime value);
}


DateModified Property

DateModified Property
Namespaces ► VisualCron ► JobStatsClass ► DateModified

[Missing <summary> documentation for P:VisualCron.JobStatsClass.DateModified]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateModified { get; set; }
Public Property DateModified As DateTime
public:
property DateTime DateModified {
    DateTime get ();
    void set (DateTime value);
}


DateNextExecution Property

DateNextExecution Property
Namespaces ► VisualCron ► JobStatsClass ► DateNextExecution

[Missing <summary> documentation for P:VisualCron.JobStatsClass.DateNextExecution]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateNextExecution { get; set; }
Public Property DateNextExecution As DateTime
public:
property DateTime DateNextExecution {
    DateTime get ();
    void set (DateTime value);
}


ExecutionTime Property

ExecutionTime Property
Namespaces ► VisualCron ► JobStatsClass ► ExecutionTime

[Missing <summary> documentation for P:VisualCron.JobStatsClass.ExecutionTime]

Declaration Syntax
C# Visual Basic Visual C++
public double ExecutionTime { get; set; }
Public Property ExecutionTime As Double
public:
property double ExecutionTime {
    double get ();
    void set (double value);
}


ExitCode Property

ExitCode Property
Namespaces ► VisualCron ► JobStatsClass ► ExitCode
Contains exit code ne 0 if any task should fail
Declaration Syntax
C# Visual Basic Visual C++
public int ExitCode { get; set; }
Public Property ExitCode As Integer
public:
property int ExitCode {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobId Property

JobId Property
Namespaces ► VisualCron ► JobStatsClass ► JobId

[Missing <summary> documentation for P:VisualCron.JobStatsClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


LastTriggerId Property

LastTriggerId Property
Namespaces ► VisualCron ► JobStatsClass ► LastTriggerId

[Missing <summary> documentation for P:VisualCron.JobStatsClass.LastTriggerId]

Declaration Syntax
C# Visual Basic Visual C++
public string LastTriggerId { get; set; }
Public Property LastTriggerId As String
public:
property String^ LastTriggerId {
    String^ get ();
    void set (String^ value);
}


NoExecutes Property

NoExecutes Property
Namespaces ► VisualCron ► JobStatsClass ► NoExecutes

[Missing <summary> documentation for P:VisualCron.JobStatsClass.NoExecutes]

Declaration Syntax
C# Visual Basic Visual C++
public long NoExecutes { get; set; }
Public Property NoExecutes As Long
public:
property long long NoExecutes {
    long long get ();
    void set (long long value);
}


Reset Method

Reset Method
Namespaces ► VisualCron ► JobStatsClass ► Reset()()()

[Missing <summary> documentation for M:VisualCron.JobStatsClass.Reset]

Declaration Syntax
C# Visual Basic Visual C++
public void Reset()
Public Sub Reset
public:
void Reset()


Status Field

Status Field
Namespaces ► VisualCron ► JobStatsClass ► Status

[Missing <summary> documentation for F:VisualCron.JobStatsClass.Status]

Declaration Syntax
C# Visual Basic Visual C++
public JobStatsClass..::.StatusT Status
Public Status As JobStatsClass..::.StatusT
public:
JobStatsClass..::.StatusT Status

Send comments on this topic to Please email feedback to Support


JobStatsClass.StatusT Enumeration

JobStatsClass..::.StatusT Enumeration
Namespaces ► VisualCron ► JobStatsClass ► JobStatsClass..::.StatusT

[Missing <summary> documentation for T:VisualCron.JobStatsClass.StatusT]

Declaration Syntax
C# Visual Basic Visual C++
public enum StatusT
Public Enumeration StatusT
public enum class StatusT
Members
Member | Description
Running |
Waiting |


KEYBDINPUT Structure

KEYBDINPUT Structure
Namespaces ► VisualCron ► KEYBDINPUT

[Missing <summary> documentation for T:VisualCron.KEYBDINPUT]

Declaration Syntax
C# Visual Basic Visual C++
public struct KEYBDINPUT
Public Structure KEYBDINPUT
public value class KEYBDINPUT
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | dwExtraInfo |
 | dwFlags |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | time |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | wScan |
 | wVk |


dwExtraInfo Field

dwExtraInfo Field
Namespaces ► VisualCron ► KEYBDINPUT ► dwExtraInfo

[Missing <summary> documentation for F:VisualCron.KEYBDINPUT.dwExtraInfo]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr dwExtraInfo
Public dwExtraInfo As IntPtr
public:
IntPtr dwExtraInfo

Send comments on this topic to Please email feedback to Support


dwFlags Field

dwFlags Field
Namespaces ► VisualCron ► KEYBDINPUT ► dwFlags

[Missing <summary> documentation for F:VisualCron.KEYBDINPUT.dwFlags]

Declaration Syntax
C# Visual Basic Visual C++
public KEYEVENTF dwFlags
Public dwFlags As KEYEVENTF
public:
KEYEVENTF dwFlags

Send comments on this topic to Please email feedback to Support


time Field

time Field
Namespaces ► VisualCron ► KEYBDINPUT ► time

[Missing <summary> documentation for F:VisualCron.KEYBDINPUT.time]

Declaration Syntax
C# Visual Basic Visual C++
public int time
Public time As Integer
public:
int time


wScan Field

wScan Field
Namespaces ► VisualCron ► KEYBDINPUT ► wScan

[Missing <summary> documentation for F:VisualCron.KEYBDINPUT.wScan]

Declaration Syntax
C# Visual Basic Visual C++
public short wScan
Public wScan As Short
public:
short wScan


wVk Field

wVk Field
Namespaces ► VisualCron ► KEYBDINPUT ► wVk

[Missing <summary> documentation for F:VisualCron.KEYBDINPUT.wVk]

Declaration Syntax
C# Visual Basic Visual C++
public short wVk
Public wVk As Short
public:
short wVk


KeyboardHookStruct Class

KeyboardHookStruct Class
Namespaces ► VisualCron ► KeyboardHookStruct

[Missing <summary> documentation for T:VisualCron.KeyboardHookStruct]

Declaration Syntax
C# Visual Basic Visual C++
public class KeyboardHookStruct
Public Class KeyboardHookStruct
public ref class KeyboardHookStruct
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyboardHookStruct()()() | Initializes a new instance of the KeyboardHookStruct class
 | dwExtraInfo |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | flags |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | scanCode |
 | time |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | vkCode |
Inheritance Hierarchy
Object
KeyboardHookStruct

Send comments on this topic to Please email feedback to Support


KeyboardHookStruct Constructor

KeyboardHookStruct Constructor
Namespaces ► VisualCron ► KeyboardHookStruct ► KeyboardHookStruct()()()
Initializes a new instance of the KeyboardHookStruct class
Declaration Syntax
C# Visual Basic Visual C++
public KeyboardHookStruct()
Public Sub New
public:
KeyboardHookStruct()


dwExtraInfo Field

dwExtraInfo Field
Namespaces ► VisualCron ► KeyboardHookStruct ► dwExtraInfo

[Missing <summary> documentation for F:VisualCron.KeyboardHookStruct.dwExtraInfo]

Declaration Syntax
C# Visual Basic Visual C++
public int dwExtraInfo
Public dwExtraInfo As Integer
public:
int dwExtraInfo


flags Field

flags Field
Namespaces ► VisualCron ► KeyboardHookStruct ► flags

[Missing <summary> documentation for F:VisualCron.KeyboardHookStruct.flags]

Declaration Syntax
C# Visual Basic Visual C++
public int flags
Public flags As Integer
public:
int flags


scanCode Field

scanCode Field
Namespaces ► VisualCron ► KeyboardHookStruct ► scanCode

[Missing <summary> documentation for F:VisualCron.KeyboardHookStruct.scanCode]

Declaration Syntax
C# Visual Basic Visual C++
public int scanCode
Public scanCode As Integer
public:
int scanCode


time Field

time Field
Namespaces ► VisualCron ► KeyboardHookStruct ► time

[Missing <summary> documentation for F:VisualCron.KeyboardHookStruct.time]

Declaration Syntax
C# Visual Basic Visual C++
public int time
Public time As Integer
public:
int time


vkCode Field

vkCode Field
Namespaces ► VisualCron ► KeyboardHookStruct ► vkCode

[Missing <summary> documentation for F:VisualCron.KeyboardHookStruct.vkCode]

Declaration Syntax
C# Visual Basic Visual C++
public int vkCode
Public vkCode As Integer
public:
int vkCode


KeyCodesManager Class

KeyCodesManager Class
Namespaces ► VisualCron ► KeyCodesManager
Provides mapping between virtual key codes and keywoards used to represent them.
Declaration Syntax
C# Visual Basic Visual C++
public class KeyCodesManager
Public Class KeyCodesManager
public ref class KeyCodesManager
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | KeyCodesManager()()() | Initializes a new instance of the KeyCodesManager class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCodeByKeyword(String) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeywordByCode(Byte) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
KeyCodesManager

Send comments on this topic to Please email feedback to Support


KeyCodesManager Constructor

KeyCodesManager Constructor
Namespaces ► VisualCron ► KeyCodesManager ► KeyCodesManager()()()
Initializes a new instance of the KeyCodesManager class
Declaration Syntax
C# Visual Basic Visual C++
public KeyCodesManager()
Public Sub New
public:
KeyCodesManager()


GetCodeByKeyword Method (keyword)

GetCodeByKeyword Method (keyword)
Namespaces ► VisualCron ► KeyCodesManager ► GetCodeByKeyword(String)

[Missing <summary> documentation for M:VisualCron.KeyCodesManager.GetCodeByKeyword(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetCodeByKeyword(
    string keyword
)
Public Shared Function GetCodeByKeyword ( _
    keyword As String _
) As Integer
public:
static int GetCodeByKeyword(
    String^ keyword
)
Parameters
keyword (String)

[Missing <param name="keyword"/> documentation for "M:VisualCron.KeyCodesManager.GetCodeByKeyword(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.KeyCodesManager.GetCodeByKeyword(System.String)]


GetKeywordByCode Method (code)

GetKeywordByCode Method (code)
Namespaces ► VisualCron ► KeyCodesManager ► GetKeywordByCode(Byte)

[Missing <summary> documentation for M:VisualCron.KeyCodesManager.GetKeywordByCode(System.Byte)]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetKeywordByCode(
    byte code
)
Public Shared Function GetKeywordByCode ( _
    code As Byte _
) As String
public:
static String^ GetKeywordByCode(
    unsigned char code
)
Parameters
code (Byte)

[Missing <param name="code"/> documentation for "M:VisualCron.KeyCodesManager.GetKeywordByCode(System.Byte)"]

Return Value

[Missing <returns> documentation for M:VisualCron.KeyCodesManager.GetKeywordByCode(System.Byte)]


KEYEVENTF Enumeration

KEYEVENTF Enumeration
Namespaces ► VisualCron ► KEYEVENTF

[Missing <summary> documentation for T:VisualCron.KEYEVENTF]

Declaration Syntax
C# Visual Basic Visual C++
[FlagsAttribute]
public enum KEYEVENTF
<FlagsAttribute> _
Public Enumeration KEYEVENTF
[FlagsAttribute]
public enum class KEYEVENTF
Members
Member | Description
EXTENDEDKEY |
KEYUP |
UNICODE |
SCANCODE |


KeyStrokes Class

KeyStrokes Class
Namespaces ► VisualCron ► KeyStrokes
"Keystrokes" macro command.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class KeyStrokes : WindowTargetingCommand
<SerializableAttribute> _
Public Class KeyStrokes _
    Inherits WindowTargetingCommand
[SerializableAttribute]
public ref class KeyStrokes : public WindowTargetingCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyStrokes()()() | Initializes a new instance of the KeyStrokes class
 | Clone()()() | (Inherited from WindowTargetingCommand.)
 | Description | (Overrides Command.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Items |
 | ItemsFromText(String) | Creates a command from a textual represenation. Delays between individual instructions are set to zero.
 | ItemsToText()()() | Translates the command to its textual representation.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TargetWindow | (Inherited from WindowTargetingCommand.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed) | (Overrides Command.TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed).)
 | WindowState | (Inherited from WindowTargetingCommand.)
Inheritance Hierarchy
Object
 | Command
 |  | WindowTargetingCommand
 |  |  | KeyStrokes


KeyStrokes Constructor

KeyStrokes Constructor
Namespaces ► VisualCron ► KeyStrokes ► KeyStrokes()()()
Initializes a new instance of the KeyStrokes class
Declaration Syntax
C# Visual Basic Visual C++
public KeyStrokes()
Public Sub New
public:
KeyStrokes()


Description Property

Description Property
Namespaces ► VisualCron ► KeyStrokes ► Description

[Missing <summary> documentation for P:VisualCron.KeyStrokes.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


Items Property

Items Property
Namespaces ► VisualCron ► KeyStrokes ► Items

[Missing <summary> documentation for P:VisualCron.KeyStrokes.Items]

Declaration Syntax
C# Visual Basic Visual C++
public List<KeyStrokeUnit> Items { get; set; }
Public Property Items As List(Of KeyStrokeUnit)
public:
property List<KeyStrokeUnit^>^ Items {
    List<KeyStrokeUnit^>^ get ();
    void set (List<KeyStrokeUnit^>^ value);
}


ItemsFromText Method (str)

ItemsFromText Method (str)
Namespaces ► VisualCron ► KeyStrokes ► ItemsFromText(String)
Creates a command from a textual represenation. Delays between individual instructions are set to zero.
Declaration Syntax
C# Visual Basic Visual C++
public void ItemsFromText(
    string str
)
Public Sub ItemsFromText ( _
    str As String _
)
public:
void ItemsFromText(
    String^ str
)
Parameters
str (String)

[Missing <param name="str"/> documentation for "M:VisualCron.KeyStrokes.ItemsFromText(System.String)"]


ItemsToText Method

ItemsToText Method
Namespaces ► VisualCron ► KeyStrokes ► ItemsToText()()()
Translates the command to its textual representation.
Declaration Syntax
C# Visual Basic Visual C++
public string ItemsToText()
Public Function ItemsToText As String
public:
String^ ItemsToText()
Return Value

[Missing <returns> documentation for M:VisualCron.KeyStrokes.ItemsToText]


TranslateToInstructions Method (builder, speed)

TranslateToInstructions Method (builder, speed)
Namespaces ► VisualCron ► KeyStrokes ► TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed)

[Missing <summary> documentation for M:VisualCron.KeyStrokes.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)]

Declaration Syntax
C# Visual Basic Visual C++
public override void TranslateToInstructions(
    InstructionsBuilder builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
)
Public Overrides Sub TranslateToInstructions ( _
    builder As InstructionsBuilder, _
    speed As TaskDesktopMacroClass..::.MacroSpeed _
)
public:
virtual void TranslateToInstructions(
    InstructionsBuilder^ builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
) override
Parameters
builder (InstructionsBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.KeyStrokes.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]

speed (TaskDesktopMacroClass..::.MacroSpeed)

[Missing <param name="speed"/> documentation for "M:VisualCron.KeyStrokes.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]


KeyStrokeUnit Class

KeyStrokeUnit Class
Namespaces ► VisualCron ► KeyStrokeUnit
Represents a single keystoke action (a character, key down event or key up event).
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class KeyStrokeUnit
<SerializableAttribute> _
Public Class KeyStrokeUnit
[SerializableAttribute]
public ref class KeyStrokeUnit
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KeyStrokeUnit()()() | Initializes a new instance of the KeyStrokeUnit class
 | Action |
 | Delay |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
KeyStrokeUnit

Send comments on this topic to Please email feedback to Support


KeyStrokeUnit Constructor

KeyStrokeUnit Constructor
Namespaces ► VisualCron ► KeyStrokeUnit ► KeyStrokeUnit()()()
Initializes a new instance of the KeyStrokeUnit class
Declaration Syntax
C# Visual Basic Visual C++
public KeyStrokeUnit()
Public Sub New
public:
KeyStrokeUnit()


Action Property

Action Property
Namespaces ► VisualCron ► KeyStrokeUnit ► Action

[Missing <summary> documentation for P:VisualCron.KeyStrokeUnit.Action]

Declaration Syntax
C# Visual Basic Visual C++
public string Action { get; set; }
Public Property Action As String
public:
property String^ Action {
    String^ get ();
    void set (String^ value);
}


Delay Property

Delay Property
Namespaces ► VisualCron ► KeyStrokeUnit ► Delay

[Missing <summary> documentation for P:VisualCron.KeyStrokeUnit.Delay]

Declaration Syntax
C# Visual Basic Visual C++
public int Delay { get; set; }
Public Property Delay As Integer
public:
property int Delay {
    int get ();
    void set (int value);
}


KillVCProcessClass Class

KillVCProcessClass Class
Namespaces ► VisualCron ► KillVCProcessClass

[Missing <summary> documentation for T:VisualCron.KillVCProcessClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class KillVCProcessClass
<SerializableAttribute> _
Public Class KillVCProcessClass
[SerializableAttribute]
public ref class KillVCProcessClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | KillVCProcessClass()()() | Initializes a new instance of the KillVCProcessClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | KillType |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VCPId |
Inheritance Hierarchy
Object
KillVCProcessClass

Send comments on this topic to Please email feedback to Support


KillVCProcessClass Constructor

KillVCProcessClass Constructor
Namespaces ► VisualCron ► KillVCProcessClass ► KillVCProcessClass()()()
Initializes a new instance of the KillVCProcessClass class
Declaration Syntax
C# Visual Basic Visual C++
public KillVCProcessClass()
Public Sub New
public:
KillVCProcessClass()


JobId Property

JobId Property
Namespaces ► VisualCron ► KillVCProcessClass ► JobId

[Missing <summary> documentation for P:VisualCron.KillVCProcessClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


KillType Field

KillType Field
Namespaces ► VisualCron ► KillVCProcessClass ► KillType

[Missing <summary> documentation for F:VisualCron.KillVCProcessClass.KillType]

Declaration Syntax
C# Visual Basic Visual C++
public KillVCProcessClass..::.VCKillT KillType
Public KillType As KillVCProcessClass..::.VCKillT
public:
KillVCProcessClass..::.VCKillT KillType

Send comments on this topic to Please email feedback to Support


TaskId Property

TaskId Property
Namespaces ► VisualCron ► KillVCProcessClass ► TaskId

[Missing <summary> documentation for P:VisualCron.KillVCProcessClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


VCPId Property

VCPId Property
Namespaces ► VisualCron ► KillVCProcessClass ► VCPId

[Missing <summary> documentation for P:VisualCron.KillVCProcessClass.VCPId]

Declaration Syntax
C# Visual Basic Visual C++
public int VCPId { get; set; }
Public Property VCPId As Integer
public:
property int VCPId {
    int get ();
    void set (int value);
}


KillVCProcessClass.VCKillT Enumeration

KillVCProcessClass..::.VCKillT Enumeration
Namespaces ► VisualCron ► KillVCProcessClass ► KillVCProcessClass..::.VCKillT

[Missing <summary> documentation for T:VisualCron.KillVCProcessClass.VCKillT]

Declaration Syntax
C# Visual Basic Visual C++
public enum VCKillT
Public Enumeration VCKillT
public enum class VCKillT
Members
Member | Description
KillJobProcesses |
KillTaskProcesses |
KillJobProcess |
KillTaskProcess |


LicenseClass Class

LicenseClass Class
Namespaces ► VisualCron ► LicenseClass
Handles licensing
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LicenseClass
<SerializableAttribute> _
Public Class LicenseClass
[SerializableAttribute]
public ref class LicenseClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LicenseClass()()() | Initializes a new instance of the LicenseClass class
 | A |
 | AID |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LS |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | S |
 | SID |
 | SN |
 | TE |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | V |
Remarks
Not used in the API
Inheritance Hierarchy
Object
LicenseClass

Send comments on this topic to Please email feedback to Support


LicenseClass Constructor

LicenseClass Constructor
Namespaces ► VisualCron ► LicenseClass ► LicenseClass()()()
Initializes a new instance of the LicenseClass class
Declaration Syntax
C# Visual Basic Visual C++
public LicenseClass()
Public Sub New
public:
LicenseClass()


A Property

A Property
Namespaces ► VisualCron ► LicenseClass ► A

[Missing <summary> documentation for P:VisualCron.LicenseClass.A]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] A { get; set; }
Public Property A As Byte()
public:
property array<unsigned char>^ A {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


AID Property

AID Property
Namespaces ► VisualCron ► LicenseClass ► AID

[Missing <summary> documentation for P:VisualCron.LicenseClass.AID]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] AID { get; set; }
Public Property AID As Byte()
public:
property array<unsigned char>^ AID {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


LS Property

LS Property
Namespaces ► VisualCron ► LicenseClass ► LS

[Missing <summary> documentation for P:VisualCron.LicenseClass.LS]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] LS { get; set; }
Public Property LS As Byte()
public:
property array<unsigned char>^ LS {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


S Property

S Property
Namespaces ► VisualCron ► LicenseClass ► S

[Missing <summary> documentation for P:VisualCron.LicenseClass.S]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] S { get; set; }
Public Property S As Byte()
public:
property array<unsigned char>^ S {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


SID Property

SID Property
Namespaces ► VisualCron ► LicenseClass ► SID

[Missing <summary> documentation for P:VisualCron.LicenseClass.SID]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] SID { get; set; }
Public Property SID As Byte()
public:
property array<unsigned char>^ SID {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


SN Property

SN Property
Namespaces ► VisualCron ► LicenseClass ► SN

[Missing <summary> documentation for P:VisualCron.LicenseClass.SN]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] SN { get; set; }
Public Property SN As Byte()
public:
property array<unsigned char>^ SN {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


TE Property

TE Property
Namespaces ► VisualCron ► LicenseClass ► TE

[Missing <summary> documentation for P:VisualCron.LicenseClass.TE]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] TE { get; set; }
Public Property TE As Byte()
public:
property array<unsigned char>^ TE {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


V Property

V Property
Namespaces ► VisualCron ► LicenseClass ► V

[Missing <summary> documentation for P:VisualCron.LicenseClass.V]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] V { get; set; }
Public Property V As Byte()
public:
property array<unsigned char>^ V {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


LicenseClass.LicStatus Enumeration

LicenseClass..::.LicStatus Enumeration
Namespaces ► VisualCron ► LicenseClass ► LicenseClass..::.LicStatus

[Missing <summary> documentation for T:VisualCron.LicenseClass.LicStatus]

Declaration Syntax
C# Visual Basic Visual C++
public enum LicStatus
Public Enumeration LicStatus
public enum class LicStatus
Members
Member | Description
Activated |
Trial |


LicenseWarningClass Class

LicenseWarningClass Class
Namespaces ► VisualCron ► LicenseWarningClass

[Missing <summary> documentation for T:VisualCron.LicenseWarningClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LicenseWarningClass
<SerializableAttribute> _
Public Class LicenseWarningClass
[SerializableAttribute]
public ref class LicenseWarningClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LicenseWarningClass()()() | Initializes a new instance of the LicenseWarningClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrialEndTime | Gets or sets when the license has has epxired
Inheritance Hierarchy
Object
LicenseWarningClass

Send comments on this topic to Please email feedback to Support


LicenseWarningClass Constructor

LicenseWarningClass Constructor
Namespaces ► VisualCron ► LicenseWarningClass ► LicenseWarningClass()()()
Initializes a new instance of the LicenseWarningClass class
Declaration Syntax
C# Visual Basic Visual C++
public LicenseWarningClass()
Public Sub New
public:
LicenseWarningClass()


TrialEndTime Property

TrialEndTime Property
Namespaces ► VisualCron ► LicenseWarningClass ► TrialEndTime
Gets or sets when the license has has epxired
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TrialEndTime { get; set; }
Public Property TrialEndTime As DateTime
public:
property DateTime TrialEndTime {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LogArrayClass Class

LogArrayClass Class
Namespaces ► VisualCron ► LogArrayClass

[Missing <summary> documentation for T:VisualCron.LogArrayClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LogArrayClass
<SerializableAttribute> _
Public Class LogArrayClass
[SerializableAttribute]
public ref class LogArrayClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogArrayClass()()() | Initializes a new instance of the LogArrayClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Log |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LogArrayClass

Send comments on this topic to Please email feedback to Support


LogArrayClass Constructor

LogArrayClass Constructor
Namespaces ► VisualCron ► LogArrayClass ► LogArrayClass()()()
Initializes a new instance of the LogArrayClass class
Declaration Syntax
C# Visual Basic Visual C++
public LogArrayClass()
Public Sub New
public:
LogArrayClass()


Log Property

Log Property
Namespaces ► VisualCron ► LogArrayClass ► Log

[Missing <summary> documentation for P:VisualCron.LogArrayClass.Log]

Declaration Syntax
C# Visual Basic Visual C++
public List<LogClass> Log { get; set; }
Public Property Log As List(Of LogClass)
public:
property List<LogClass^>^ Log {
    List<LogClass^>^ get ();
    void set (List<LogClass^>^ value);
}


LogClass Class

LogClass Class
Namespaces ► VisualCron ► LogClass

[Missing <summary> documentation for T:VisualCron.LogClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LogClass
<SerializableAttribute> _
Public Class LogClass
[SerializableAttribute]
public ref class LogClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogClass()()() | Initializes a new instance of the LogClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventDate |
 | EventType |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | Source |
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UniqueId |
Inheritance Hierarchy
Object
LogClass

Send comments on this topic to Please email feedback to Support


LogClass Constructor

LogClass Constructor
Namespaces ► VisualCron ► LogClass ► LogClass()()()
Initializes a new instance of the LogClass class
Declaration Syntax
C# Visual Basic Visual C++
public LogClass()
Public Sub New
public:
LogClass()


EventDate Property

EventDate Property
Namespaces ► VisualCron ► LogClass ► EventDate

[Missing <summary> documentation for P:VisualCron.LogClass.EventDate]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime EventDate { get; set; }
Public Property EventDate As DateTime
public:
property DateTime EventDate {
    DateTime get ();
    void set (DateTime value);
}


EventType Field

EventType Field
Namespaces ► VisualCron ► LogClass ► EventType

[Missing <summary> documentation for F:VisualCron.LogClass.EventType]

Declaration Syntax
C# Visual Basic Visual C++
public LogClass..::.EventT EventType
Public EventType As LogClass..::.EventT
public:
LogClass..::.EventT EventType

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► LogClass ► Id

[Missing <summary> documentation for P:VisualCron.LogClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public long Id { get; set; }
Public Property Id As Long
public:
property long long Id {
    long long get ();
    void set (long long value);
}


JobId Property

JobId Property
Namespaces ► VisualCron ► LogClass ► JobId

[Missing <summary> documentation for P:VisualCron.LogClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


Message Property

Message Property
Namespaces ► VisualCron ► LogClass ► Message

[Missing <summary> documentation for P:VisualCron.LogClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


Source Field

Source Field
Namespaces ► VisualCron ► LogClass ► Source

[Missing <summary> documentation for F:VisualCron.LogClass.Source]

Declaration Syntax
C# Visual Basic Visual C++
public LogClass..::.SourceT Source
Public Source As LogClass..::.SourceT
public:
LogClass..::.SourceT Source

Send comments on this topic to Please email feedback to Support


TaskId Property

TaskId Property
Namespaces ► VisualCron ► LogClass ► TaskId

[Missing <summary> documentation for P:VisualCron.LogClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


UniqueId Property

UniqueId Property
Namespaces ► VisualCron ► LogClass ► UniqueId

[Missing <summary> documentation for P:VisualCron.LogClass.UniqueId]

Declaration Syntax
C# Visual Basic Visual C++
public long UniqueId { get; set; }
Public Property UniqueId As Long
public:
property long long UniqueId {
    long long get ();
    void set (long long value);
}


LogClass.EventT Enumeration

LogClass..::.EventT Enumeration
Namespaces ► VisualCron ► LogClass ► LogClass..::.EventT

[Missing <summary> documentation for T:VisualCron.LogClass.EventT]

Declaration Syntax
C# Visual Basic Visual C++
public enum EventT
Public Enumeration EventT
public enum class EventT
Members
Member | Description
Info |
Err |
Debug |
Comm |


LogClass.SourceT Enumeration

LogClass..::.SourceT Enumeration
Namespaces ► VisualCron ► LogClass ► LogClass..::.SourceT

[Missing <summary> documentation for T:VisualCron.LogClass.SourceT]

Declaration Syntax
C# Visual Basic Visual C++
public enum SourceT
Public Enumeration SourceT
public enum class SourceT
Members
Member | Description
Server |
Client |


LoginClass Class

LoginClass Class
Namespaces ► VisualCron ► LoginClass

[Missing <summary> documentation for T:VisualCron.LoginClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LoginClass
<SerializableAttribute> _
Public Class LoginClass
[SerializableAttribute]
public ref class LoginClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginClass()()() | Initializes a new instance of the LoginClass class
 | ClientType |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MachineName |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord |
 | SessionID |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseCompression |
 | UserName |
 | WindowsUserName |
Inheritance Hierarchy
Object
LoginClass

Send comments on this topic to Please email feedback to Support


LoginClass Constructor

LoginClass Constructor
Namespaces ► VisualCron ► LoginClass ► LoginClass()()()
Initializes a new instance of the LoginClass class
Declaration Syntax
C# Visual Basic Visual C++
public LoginClass()
Public Sub New
public:
LoginClass()


ClientType Property

ClientType Property
Namespaces ► VisualCron ► LoginClass ► ClientType

[Missing <summary> documentation for P:VisualCron.LoginClass.ClientType]

Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionClass..::.ClientT ClientType { get; set; }
Public Property ClientType As ClientConnectionClass..::.ClientT
public:
property ClientConnectionClass..::.ClientT ClientType {
    ClientConnectionClass..::.ClientT get ();
    void set (ClientConnectionClass..::.ClientT value);
}


MachineName Property

MachineName Property
Namespaces ► VisualCron ► LoginClass ► MachineName

[Missing <summary> documentation for P:VisualCron.LoginClass.MachineName]

Declaration Syntax
C# Visual Basic Visual C++
public string MachineName { get; set; }
Public Property MachineName As String
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}


PassWord Property

PassWord Property
Namespaces ► VisualCron ► LoginClass ► PassWord

[Missing <summary> documentation for P:VisualCron.LoginClass.PassWord]

Declaration Syntax
C# Visual Basic Visual C++
public string PassWord { get; set; }
Public Property PassWord As String
public:
property String^ PassWord {
    String^ get ();
    void set (String^ value);
}


SessionID Property

SessionID Property
Namespaces ► VisualCron ► LoginClass ► SessionID

[Missing <summary> documentation for P:VisualCron.LoginClass.SessionID]

Declaration Syntax
C# Visual Basic Visual C++
public int SessionID { get; set; }
Public Property SessionID As Integer
public:
property int SessionID {
    int get ();
    void set (int value);
}


UseCompression Property

UseCompression Property
Namespaces ► VisualCron ► LoginClass ► UseCompression

[Missing <summary> documentation for P:VisualCron.LoginClass.UseCompression]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseCompression { get; set; }
Public Property UseCompression As Boolean
public:
property bool UseCompression {
    bool get ();
    void set (bool value);
}


UserName Property

UserName Property
Namespaces ► VisualCron ► LoginClass ► UserName

[Missing <summary> documentation for P:VisualCron.LoginClass.UserName]

Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}


WindowsUserName Property

WindowsUserName Property
Namespaces ► VisualCron ► LoginClass ► WindowsUserName

[Missing <summary> documentation for P:VisualCron.LoginClass.WindowsUserName]

Declaration Syntax
C# Visual Basic Visual C++
public string WindowsUserName { get; set; }
Public Property WindowsUserName As String
public:
property String^ WindowsUserName {
    String^ get ();
    void set (String^ value);
}


LogInfoClass Class

LogInfoClass Class
Namespaces ► VisualCron ► LogInfoClass

[Missing <summary> documentation for T:VisualCron.LogInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LogInfoClass
<SerializableAttribute> _
Public Class LogInfoClass
[SerializableAttribute]
public ref class LogInfoClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogInfoClass()()() | Initializes a new instance of the LogInfoClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogStart |
 | LogStartId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LogInfoClass

Send comments on this topic to Please email feedback to Support


LogInfoClass Constructor

LogInfoClass Constructor
Namespaces ► VisualCron ► LogInfoClass ► LogInfoClass()()()
Initializes a new instance of the LogInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public LogInfoClass()
Public Sub New
public:
LogInfoClass()


LogStart Property

LogStart Property
Namespaces ► VisualCron ► LogInfoClass ► LogStart

[Missing <summary> documentation for P:VisualCron.LogInfoClass.LogStart]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime LogStart { get; set; }
Public Property LogStart As DateTime
public:
property DateTime LogStart {
    DateTime get ();
    void set (DateTime value);
}


LogStartId Property

LogStartId Property
Namespaces ► VisualCron ► LogInfoClass ► LogStartId

[Missing <summary> documentation for P:VisualCron.LogInfoClass.LogStartId]

Declaration Syntax
C# Visual Basic Visual C++
public long LogStartId { get; set; }
Public Property LogStartId As Long
public:
property long long LogStartId {
    long long get ();
    void set (long long value);
}


LoginResultClass Class

LoginResultClass Class
Namespaces ► VisualCron ► LoginResultClass

[Missing <summary> documentation for T:VisualCron.LoginResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LoginResultClass
<SerializableAttribute> _
Public Class LoginResultClass
[SerializableAttribute]
public ref class LoginResultClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LoginResultClass()()() | Initializes a new instance of the LoginResultClass class
 | CurrentUser |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoginResult |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LoginResultClass

Send comments on this topic to Please email feedback to Support


LoginResultClass Constructor

LoginResultClass Constructor
Namespaces ► VisualCron ► LoginResultClass ► LoginResultClass()()()
Initializes a new instance of the LoginResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public LoginResultClass()
Public Sub New
public:
LoginResultClass()


CurrentUser Field

CurrentUser Field
Namespaces ► VisualCron ► LoginResultClass ► CurrentUser

[Missing <summary> documentation for F:VisualCron.LoginResultClass.CurrentUser]

Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass CurrentUser
Public CurrentUser As SecUserClass
public:
SecUserClass^ CurrentUser

Send comments on this topic to Please email feedback to Support


LoginResult Field

LoginResult Field
Namespaces ► VisualCron ► LoginResultClass ► LoginResult

[Missing <summary> documentation for F:VisualCron.LoginResultClass.LoginResult]

Declaration Syntax
C# Visual Basic Visual C++
public LoginResultClass..::.ResultT LoginResult
Public LoginResult As LoginResultClass..::.ResultT
public:
LoginResultClass..::.ResultT LoginResult

Send comments on this topic to Please email feedback to Support


LoginResultClass.ResultT Enumeration

LoginResultClass..::.ResultT Enumeration
Namespaces ► VisualCron ► LoginResultClass ► LoginResultClass..::.ResultT

[Missing <summary> documentation for T:VisualCron.LoginResultClass.ResultT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ResultT
Public Enumeration ResultT
public enum class ResultT
Members
Member | Description
WrongPassWord |
NoSuchUser |
Inactive |
OK |
OnlyLocal |


LogRequestClass Class

LogRequestClass Class
Namespaces ► VisualCron ► LogRequestClass

[Missing <summary> documentation for T:VisualCron.LogRequestClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LogRequestClass
<SerializableAttribute> _
Public Class LogRequestClass
[SerializableAttribute]
public ref class LogRequestClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogRequestClass()()() | Initializes a new instance of the LogRequestClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastUniqueId | The last unique log id that the client holds
 | Limit | Maximum number of log items to be retrieved
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StartDate | Date to start to fetch logs from
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LogRequestClass

Send comments on this topic to Please email feedback to Support


LogRequestClass Constructor

LogRequestClass Constructor
Namespaces ► VisualCron ► LogRequestClass ► LogRequestClass()()()
Initializes a new instance of the LogRequestClass class
Declaration Syntax
C# Visual Basic Visual C++
public LogRequestClass()
Public Sub New
public:
LogRequestClass()


LastUniqueId Property

LastUniqueId Property
Namespaces ► VisualCron ► LogRequestClass ► LastUniqueId
The last unique log id that the client holds
Declaration Syntax
C# Visual Basic Visual C++
public long LastUniqueId { get; set; }
Public Property LastUniqueId As Long
public:
property long long LastUniqueId {
    long long get ();
    void set (long long value);
}
Value
Return Value
0 if the Client has no previous log items
Remarks

Send comments on this topic to Please email feedback to Support


Limit Property

Limit Property
Namespaces ► VisualCron ► LogRequestClass ► Limit
Maximum number of log items to be retrieved
Declaration Syntax
C# Visual Basic Visual C++
public int Limit { get; set; }
Public Property Limit As Integer
public:
property int Limit {
    int get ();
    void set (int value);
}
Value
Return Value
0 if no limit (fetch all)
Remarks

Send comments on this topic to Please email feedback to Support


StartDate Property

StartDate Property
Namespaces ► VisualCron ► LogRequestClass ► StartDate
Date to start to fetch logs from
Declaration Syntax
C# Visual Basic Visual C++
public DateTime StartDate { get; set; }
Public Property StartDate As DateTime
public:
property DateTime StartDate {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LogSubscribeClass Class

LogSubscribeClass Class
Namespaces ► VisualCron ► LogSubscribeClass

[Missing <summary> documentation for T:VisualCron.LogSubscribeClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class LogSubscribeClass
<SerializableAttribute> _
Public Class LogSubscribeClass
[SerializableAttribute]
public ref class LogSubscribeClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogSubscribeClass()()() | Initializes a new instance of the LogSubscribeClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | On |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LogSubscribeClass

Send comments on this topic to Please email feedback to Support


LogSubscribeClass Constructor

LogSubscribeClass Constructor
Namespaces ► VisualCron ► LogSubscribeClass ► LogSubscribeClass()()()
Initializes a new instance of the LogSubscribeClass class
Declaration Syntax
C# Visual Basic Visual C++
public LogSubscribeClass()
Public Sub New
public:
LogSubscribeClass()


On Property

On Property
Namespaces ► VisualCron ► LogSubscribeClass ► On

[Missing <summary> documentation for P:VisualCron.LogSubscribeClass.On]

Declaration Syntax
C# Visual Basic Visual C++
public bool On { get; set; }
Public Property On As Boolean
public:
property bool On {
    bool get ();
    void set (bool value);
}


MailEventClass Class

MailEventClass Class
Namespaces ► VisualCron ► MailEventClass

[Missing <summary> documentation for T:VisualCron.MailEventClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MailEventClass
<SerializableAttribute> _
Public Class MailEventClass
[SerializableAttribute]
public ref class MailEventClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MailEventClass()()() | Initializes a new instance of the MailEventClass class
 | AttachmentAction | Controls what happens with the attachment depending on Conditions
 | Body | The body string that is used with the BodyCondition
 | BodyCondition | Controls the body Condition
 | CheckedIds | Contains a list of already checked email id:s
 | ConnectionId | The Id of the Connection
 | CopyToFolder | Name of folder to copy to
 | CustomFolder | If UseDefaultFolder is false this property is used to specify folder to check
 | DecryptionId | Id of Certificate that is used for decryption of message (S/MIME)
 | EmailCopyAction | Controls if the email should be copied to another folder or not
 | EmailSaveAction | Controls what happens with the aemail depending on Conditions
 | EmailSaveLocation | Get or set where the email should be saved (folder)
 | EmailSaveType | Controls where the attachement is saved
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromAddress | The from address string that is used with tthe FromAddressCondition
 | FromAddressCondition | Controls the from address Condition
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interval | How often the mailbox should be polled
 | MailAction | Controls what happens when the email has been downloaded
 | MarkAsRead | If the Mail on the Server should be marked as read
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageOnServerAction | Controls the MailAction depending on Conditions
 | NetworkCredential | Id of Network Credential that will be used to get access
 | ReceivedDateCondition | Contains the received date condition
 | ReceivedDateVariable | The variable used for comparision
 | Subject | The subject string that is used with the SubjectCondition
 | SubjectCondition | Controls the subject Condition
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerAction | Controls if the Trigger should trigger or not depending on Conditions
 | UseDefaultFolder | If startup folder should be used or not
Inheritance Hierarchy
Object
MailEventClass

Send comments on this topic to Please email feedback to Support


MailEventClass Constructor

MailEventClass Constructor
Namespaces ► VisualCron ► MailEventClass ► MailEventClass()()()
Initializes a new instance of the MailEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public MailEventClass()
Public Sub New
public:
MailEventClass()


AttachmentAction Property

AttachmentAction Property
Namespaces ► VisualCron ► MailEventClass ► AttachmentAction
Controls what happens with the attachment depending on Conditions
Declaration Syntax
C# Visual Basic Visual C++
public EventClass..::.EventMatchT AttachmentAction { get; set; }
Public Property AttachmentAction As EventClass..::.EventMatchT
public:
property EventClass..::.EventMatchT AttachmentAction {
    EventClass..::.EventMatchT get ();
    void set (EventClass..::.EventMatchT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Body Property

Body Property
Namespaces ► VisualCron ► MailEventClass ► Body
The body string that is used with the BodyCondition
Declaration Syntax
C# Visual Basic Visual C++
public string Body { get; set; }
Public Property Body As String
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


BodyCondition Property

BodyCondition Property
Namespaces ► VisualCron ► MailEventClass ► BodyCondition
Controls the body Condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionCheckT BodyCondition { get; set; }
Public Property BodyCondition As ConditionClass..::.ConditionCheckT
public:
property ConditionClass..::.ConditionCheckT BodyCondition {
    ConditionClass..::.ConditionCheckT get ();
    void set (ConditionClass..::.ConditionCheckT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CheckedIds Property

CheckedIds Property
Namespaces ► VisualCron ► MailEventClass ► CheckedIds
Contains a list of already checked email id:s
Declaration Syntax
C# Visual Basic Visual C++
public List<string> CheckedIds { get; set; }
Public Property CheckedIds As List(Of String)
public:
property List<String^>^ CheckedIds {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConnectionId Property

ConnectionId Property
Namespaces ► VisualCron ► MailEventClass ► ConnectionId
The Id of the Connection
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionId { get; set; }
Public Property ConnectionId As String
public:
property String^ ConnectionId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CopyToFolder Property

CopyToFolder Property
Namespaces ► VisualCron ► MailEventClass ► CopyToFolder
Name of folder to copy to
Declaration Syntax
C# Visual Basic Visual C++
public string CopyToFolder { get; set; }
Public Property CopyToFolder As String
public:
property String^ CopyToFolder {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Used together with EmailCopyAction

Send comments on this topic to Please email feedback to Support


CustomFolder Property

CustomFolder Property
Namespaces ► VisualCron ► MailEventClass ► CustomFolder
If UseDefaultFolder is false this property is used to specify folder to check
Declaration Syntax
C# Visual Basic Visual C++
public string CustomFolder { get; set; }
Public Property CustomFolder As String
public:
property String^ CustomFolder {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DecryptionId Property

DecryptionId Property
Namespaces ► VisualCron ► MailEventClass ► DecryptionId
Id of Certificate that is used for decryption of message (S/MIME)
Declaration Syntax
C# Visual Basic Visual C++
public string DecryptionId { get; set; }
Public Property DecryptionId As String
public:
property String^ DecryptionId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EmailCopyAction Property

EmailCopyAction Property
Namespaces ► VisualCron ► MailEventClass ► EmailCopyAction
Controls if the email should be copied to another folder or not
Declaration Syntax
C# Visual Basic Visual C++
public EventClass..::.EventMatchT EmailCopyAction { get; set; }
Public Property EmailCopyAction As EventClass..::.EventMatchT
public:
property EventClass..::.EventMatchT EmailCopyAction {
    EventClass..::.EventMatchT get ();
    void set (EventClass..::.EventMatchT value);
}
Value
Return Value
Remarks
Only valid for IMAP4

Send comments on this topic to Please email feedback to Support


EmailSaveAction Property

EmailSaveAction Property
Namespaces ► VisualCron ► MailEventClass ► EmailSaveAction
Controls what happens with the aemail depending on Conditions
Declaration Syntax
C# Visual Basic Visual C++
public EventClass..::.EventMatchT EmailSaveAction { get; set; }
Public Property EmailSaveAction As EventClass..::.EventMatchT
public:
property EventClass..::.EventMatchT EmailSaveAction {
    EventClass..::.EventMatchT get ();
    void set (EventClass..::.EventMatchT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EmailSaveLocation Property

EmailSaveLocation Property
Namespaces ► VisualCron ► MailEventClass ► EmailSaveLocation
Get or set where the email should be saved (folder)
Declaration Syntax
C# Visual Basic Visual C++
public string EmailSaveLocation { get; set; }
Public Property EmailSaveLocation As String
public:
property String^ EmailSaveLocation {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EmailSaveType Property

EmailSaveType Property
Namespaces ► VisualCron ► MailEventClass ► EmailSaveType
Controls where the attachement is saved
Declaration Syntax
C# Visual Basic Visual C++
public MailEventClass..::.SaveActionT EmailSaveType { get; set; }
Public Property EmailSaveType As MailEventClass..::.SaveActionT
public:
property MailEventClass..::.SaveActionT EmailSaveType {
    MailEventClass..::.SaveActionT get ();
    void set (MailEventClass..::.SaveActionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FromAddress Property

FromAddress Property
Namespaces ► VisualCron ► MailEventClass ► FromAddress
The from address string that is used with tthe FromAddressCondition
Declaration Syntax
C# Visual Basic Visual C++
public string FromAddress { get; set; }
Public Property FromAddress As String
public:
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FromAddressCondition Property

FromAddressCondition Property
Namespaces ► VisualCron ► MailEventClass ► FromAddressCondition
Controls the from address Condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionCheckT FromAddressCondition { get; set; }
Public Property FromAddressCondition As ConditionClass..::.ConditionCheckT
public:
property ConditionClass..::.ConditionCheckT FromAddressCondition {
    ConditionClass..::.ConditionCheckT get ();
    void set (ConditionClass..::.ConditionCheckT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Interval Property

Interval Property
Namespaces ► VisualCron ► MailEventClass ► Interval
How often the mailbox should be polled
Declaration Syntax
C# Visual Basic Visual C++
public int Interval { get; set; }
Public Property Interval As Integer
public:
property int Interval {
    int get ();
    void set (int value);
}
Value
Default: Every 60 seconds
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MailAction Property

MailAction Property
Namespaces ► VisualCron ► MailEventClass ► MailAction
Controls what happens when the email has been downloaded
Declaration Syntax
C# Visual Basic Visual C++
public MailEventClass..::.MailActionT MailAction { get; set; }
Public Property MailAction As MailEventClass..::.MailActionT
public:
property MailEventClass..::.MailActionT MailAction {
    MailEventClass..::.MailActionT get ();
    void set (MailEventClass..::.MailActionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MarkAsRead Property

MarkAsRead Property
Namespaces ► VisualCron ► MailEventClass ► MarkAsRead
If the Mail on the Server should be marked as read
Declaration Syntax
C# Visual Basic Visual C++
public bool MarkAsRead { get; set; }
Public Property MarkAsRead As Boolean
public:
property bool MarkAsRead {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
Only available when MailAction = LeaveMessage


MessageOnServerAction Property

MessageOnServerAction Property
Namespaces ► VisualCron ► MailEventClass ► MessageOnServerAction
Controls the MailAction depending on Conditions
Declaration Syntax
C# Visual Basic Visual C++
public EventClass..::.EventMatchT MessageOnServerAction { get; set; }
Public Property MessageOnServerAction As EventClass..::.EventMatchT
public:
property EventClass..::.EventMatchT MessageOnServerAction {
    EventClass..::.EventMatchT get ();
    void set (EventClass..::.EventMatchT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► MailEventClass ► NetworkCredential
Id of Network Credential that will be used to get access
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ReceivedDateCondition Property

ReceivedDateCondition Property
Namespaces ► VisualCron ► MailEventClass ► ReceivedDateCondition
Contains the received date condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionCheckT ReceivedDateCondition { get; set; }
Public Property ReceivedDateCondition As ConditionClass..::.ConditionCheckT
public:
property ConditionClass..::.ConditionCheckT ReceivedDateCondition {
    ConditionClass..::.ConditionCheckT get ();
    void set (ConditionClass..::.ConditionCheckT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ReceivedDateVariable Property

ReceivedDateVariable Property
Namespaces ► VisualCron ► MailEventClass ► ReceivedDateVariable
The variable used for comparision
Declaration Syntax
C# Visual Basic Visual C++
public string ReceivedDateVariable { get; set; }
Public Property ReceivedDateVariable As String
public:
property String^ ReceivedDateVariable {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Subject Property

Subject Property
Namespaces ► VisualCron ► MailEventClass ► Subject
The subject string that is used with the SubjectCondition
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SubjectCondition Property

SubjectCondition Property
Namespaces ► VisualCron ► MailEventClass ► SubjectCondition
Controls the subject Condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass..::.ConditionCheckT SubjectCondition { get; set; }
Public Property SubjectCondition As ConditionClass..::.ConditionCheckT
public:
property ConditionClass..::.ConditionCheckT SubjectCondition {
    ConditionClass..::.ConditionCheckT get ();
    void set (ConditionClass..::.ConditionCheckT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TriggerAction Property

TriggerAction Property
Namespaces ► VisualCron ► MailEventClass ► TriggerAction
Controls if the Trigger should trigger or not depending on Conditions
Declaration Syntax
C# Visual Basic Visual C++
public EventClass..::.EventMatchT TriggerAction { get; set; }
Public Property TriggerAction As EventClass..::.EventMatchT
public:
property EventClass..::.EventMatchT TriggerAction {
    EventClass..::.EventMatchT get ();
    void set (EventClass..::.EventMatchT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseDefaultFolder Property

UseDefaultFolder Property
Namespaces ► VisualCron ► MailEventClass ► UseDefaultFolder
If startup folder should be used or not
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultFolder { get; set; }
Public Property UseDefaultFolder As Boolean
public:
property bool UseDefaultFolder {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MailEventClass.MailActionT Enumeration

MailEventClass..::.MailActionT Enumeration
Namespaces ► VisualCron ► MailEventClass ► MailEventClass..::.MailActionT
Enum that describes what happens with the email when it has been downloaded
Declaration Syntax
C# Visual Basic Visual C++
public enum MailActionT
Public Enumeration MailActionT
public enum class MailActionT
Members
Member | Description
LeaveMessage |
DeleteMessage |
Remarks

Send comments on this topic to Please email feedback to Support


MailEventClass.SaveActionT Enumeration

MailEventClass..::.SaveActionT Enumeration
Namespaces ► VisualCron ► MailEventClass ► MailEventClass..::.SaveActionT
Enum that describes where something (mail or attachment) should be saved)
Declaration Syntax
C# Visual Basic Visual C++
public enum SaveActionT
Public Enumeration SaveActionT
public enum class SaveActionT
Members
Member | Description
SaveDefault |
SaveCustom |
Remarks

Send comments on this topic to Please email feedback to Support


MailTriggerResultClass Class

MailTriggerResultClass Class
Namespaces ► VisualCron ► MailTriggerResultClass

[Missing <summary> documentation for T:VisualCron.MailTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MailTriggerResultClass
<SerializableAttribute> _
Public Class MailTriggerResultClass
[SerializableAttribute]
public ref class MailTriggerResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MailTriggerResultClass()()() | Initializes a new instance of the MailTriggerResultClass class
 | AttachmentFolder | The folder path to the attachments
 | CCAddresses | Semi-colon separated list of CC-addresses
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromAddress |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HTMLBody | The HTML body of the message (if existing)
 | IsEncrypted | If the message is encrypted
 | IsSigned | If the message is signed
 | MailFolder | The folder path to the email
 | MailPath | The full path to the email
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageId | The unique ID of the message
 | NoAttachments | Number of attachments
 | Received | Which date the email was received
 | Subject | The subject of the message
 | TextBody | The text body of the message
 | ToAddresses | Semi-colon separated list of To-addresses
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidSignature | If the message is signed this property will tell if the signature is valid
Inheritance Hierarchy
Object
MailTriggerResultClass

Send comments on this topic to Please email feedback to Support


MailTriggerResultClass Constructor

MailTriggerResultClass Constructor
Namespaces ► VisualCron ► MailTriggerResultClass ► MailTriggerResultClass()()()
Initializes a new instance of the MailTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public MailTriggerResultClass()
Public Sub New
public:
MailTriggerResultClass()


AttachmentFolder Property

AttachmentFolder Property
Namespaces ► VisualCron ► MailTriggerResultClass ► AttachmentFolder
The folder path to the attachments
Declaration Syntax
C# Visual Basic Visual C++
public string AttachmentFolder { get; set; }
Public Property AttachmentFolder As String
public:
property String^ AttachmentFolder {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Only valid if the user chooses to save attachment


CCAddresses Property

CCAddresses Property
Namespaces ► VisualCron ► MailTriggerResultClass ► CCAddresses
Semi-colon separated list of CC-addresses
Declaration Syntax
C# Visual Basic Visual C++
public string CCAddresses { get; set; }
Public Property CCAddresses As String
public:
property String^ CCAddresses {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FromAddress Property

FromAddress Property
Namespaces ► VisualCron ► MailTriggerResultClass ► FromAddress

[Missing <summary> documentation for P:VisualCron.MailTriggerResultClass.FromAddress]

Declaration Syntax
C# Visual Basic Visual C++
public string FromAddress { get; set; }
Public Property FromAddress As String
public:
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}


HTMLBody Property

HTMLBody Property
Namespaces ► VisualCron ► MailTriggerResultClass ► HTMLBody
The HTML body of the message (if existing)
Declaration Syntax
C# Visual Basic Visual C++
public string HTMLBody { get; set; }
Public Property HTMLBody As String
public:
property String^ HTMLBody {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IsEncrypted Property

IsEncrypted Property
Namespaces ► VisualCron ► MailTriggerResultClass ► IsEncrypted
If the message is encrypted
Declaration Syntax
C# Visual Basic Visual C++
public bool IsEncrypted { get; set; }
Public Property IsEncrypted As Boolean
public:
property bool IsEncrypted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IsSigned Property

IsSigned Property
Namespaces ► VisualCron ► MailTriggerResultClass ► IsSigned
If the message is signed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSigned { get; set; }
Public Property IsSigned As Boolean
public:
property bool IsSigned {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MailFolder Property

MailFolder Property
Namespaces ► VisualCron ► MailTriggerResultClass ► MailFolder
The folder path to the email
Declaration Syntax
C# Visual Basic Visual C++
public string MailFolder { get; set; }
Public Property MailFolder As String
public:
property String^ MailFolder {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Only valid if the user chooses to save message


MailPath Property

MailPath Property
Namespaces ► VisualCron ► MailTriggerResultClass ► MailPath
The full path to the email
Declaration Syntax
C# Visual Basic Visual C++
public string MailPath { get; set; }
Public Property MailPath As String
public:
property String^ MailPath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Only valid if the user chooses to save message


MessageId Property

MessageId Property
Namespaces ► VisualCron ► MailTriggerResultClass ► MessageId
The unique ID of the message
Declaration Syntax
C# Visual Basic Visual C++
public string MessageId { get; set; }
Public Property MessageId As String
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NoAttachments Property

NoAttachments Property
Namespaces ► VisualCron ► MailTriggerResultClass ► NoAttachments
Number of attachments
Declaration Syntax
C# Visual Basic Visual C++
public int NoAttachments { get; set; }
Public Property NoAttachments As Integer
public:
property int NoAttachments {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Received Property

Received Property
Namespaces ► VisualCron ► MailTriggerResultClass ► Received
Which date the email was received
Declaration Syntax
C# Visual Basic Visual C++
public DateTime Received { get; set; }
Public Property Received As DateTime
public:
property DateTime Received {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Subject Property

Subject Property
Namespaces ► VisualCron ► MailTriggerResultClass ► Subject
The subject of the message
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TextBody Property

TextBody Property
Namespaces ► VisualCron ► MailTriggerResultClass ► TextBody
The text body of the message
Declaration Syntax
C# Visual Basic Visual C++
public string TextBody { get; set; }
Public Property TextBody As String
public:
property String^ TextBody {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ToAddresses Property

ToAddresses Property
Namespaces ► VisualCron ► MailTriggerResultClass ► ToAddresses
Semi-colon separated list of To-addresses
Declaration Syntax
C# Visual Basic Visual C++
public string ToAddresses { get; set; }
Public Property ToAddresses As String
public:
property String^ ToAddresses {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ValidSignature Property

ValidSignature Property
Namespaces ► VisualCron ► MailTriggerResultClass ► ValidSignature
If the message is signed this property will tell if the signature is valid
Declaration Syntax
C# Visual Basic Visual C++
public bool ValidSignature { get; set; }
Public Property ValidSignature As Boolean
public:
property bool ValidSignature {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MarginClass Class

MarginClass Class
Namespaces ► VisualCron ► MarginClass
This is a placeholder class. It should not be used. It's usage is not implemented withing PrintingPreference.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MarginClass
<SerializableAttribute> _
Public Class MarginClass
[SerializableAttribute]
public ref class MarginClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MarginClass(Double, Double, Double, Double) | Initializes a new instance of the MarginClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetValues(Double, Double, Double, Double) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
MarginClass

Send comments on this topic to Please email feedback to Support


MarginClass Constructor (left, right, top, bottom)

MarginClass Constructor (left, right, top, bottom)
Namespaces ► VisualCron ► MarginClass ► MarginClass(Double, Double, Double, Double)
Initializes a new instance of the MarginClass class
Declaration Syntax
C# Visual Basic Visual C++
public MarginClass(
    double left,
    double right,
    double top,
    double bottom
)
Public Sub New ( _
    left As Double, _
    right As Double, _
    top As Double, _
    bottom As Double _
)
public:
MarginClass(
    double left,
    double right,
    double top,
    double bottom
)
Parameters
left (Double)

[Missing <param name="left"/> documentation for "M:VisualCron.MarginClass.#ctor(System.Double,System.Double,System.Double,System.Double)"]

right (Double)

[Missing <param name="right"/> documentation for "M:VisualCron.MarginClass.#ctor(System.Double,System.Double,System.Double,System.Double)"]

top (Double)

[Missing <param name="top"/> documentation for "M:VisualCron.MarginClass.#ctor(System.Double,System.Double,System.Double,System.Double)"]

bottom (Double)

[Missing <param name="bottom"/> documentation for "M:VisualCron.MarginClass.#ctor(System.Double,System.Double,System.Double,System.Double)"]


SetValues Method (left, right, top, bottom)

SetValues Method (left, right, top, bottom)
Namespaces ► VisualCron ► MarginClass ► SetValues(Double, Double, Double, Double)

[Missing <summary> documentation for M:VisualCron.MarginClass.SetValues(System.Double,System.Double,System.Double,System.Double)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetValues(
    double left,
    double right,
    double top,
    double bottom
)
Public Sub SetValues ( _
    left As Double, _
    right As Double, _
    top As Double, _
    bottom As Double _
)
public:
void SetValues(
    double left,
    double right,
    double top,
    double bottom
)
Parameters
left (Double)

[Missing <param name="left"/> documentation for "M:VisualCron.MarginClass.SetValues(System.Double,System.Double,System.Double,System.Double)"]

right (Double)

[Missing <param name="right"/> documentation for "M:VisualCron.MarginClass.SetValues(System.Double,System.Double,System.Double,System.Double)"]

top (Double)

[Missing <param name="top"/> documentation for "M:VisualCron.MarginClass.SetValues(System.Double,System.Double,System.Double,System.Double)"]

bottom (Double)

[Missing <param name="bottom"/> documentation for "M:VisualCron.MarginClass.SetValues(System.Double,System.Double,System.Double,System.Double)"]


MemoryInfoClass Class

MemoryInfoClass Class
Namespaces ► VisualCron ► MemoryInfoClass

[Missing <summary> documentation for T:VisualCron.MemoryInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MemoryInfoClass
<SerializableAttribute> _
Public Class MemoryInfoClass
[SerializableAttribute]
public ref class MemoryInfoClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MemoryInfoClass()()() | Initializes a new instance of the MemoryInfoClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FreeMemory | Free memory on server
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TotalMemory | Total memory on server
Inheritance Hierarchy
Object
MemoryInfoClass

Send comments on this topic to Please email feedback to Support


MemoryInfoClass Constructor

MemoryInfoClass Constructor
Namespaces ► VisualCron ► MemoryInfoClass ► MemoryInfoClass()()()
Initializes a new instance of the MemoryInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public MemoryInfoClass()
Public Sub New
public:
MemoryInfoClass()


FreeMemory Property

FreeMemory Property
Namespaces ► VisualCron ► MemoryInfoClass ► FreeMemory
Free memory on server
Declaration Syntax
C# Visual Basic Visual C++
public int FreeMemory { get; set; }
Public Property FreeMemory As Integer
public:
property int FreeMemory {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TotalMemory Property

TotalMemory Property
Namespaces ► VisualCron ► MemoryInfoClass ► TotalMemory
Total memory on server
Declaration Syntax
C# Visual Basic Visual C++
public int TotalMemory { get; set; }
Public Property TotalMemory As Integer
public:
property int TotalMemory {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MessageBoxClass Class

MessageBoxClass Class
Namespaces ► VisualCron ► MessageBoxClass

[Missing <summary> documentation for T:VisualCron.MessageBoxClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MessageBoxClass
<SerializableAttribute> _
Public Class MessageBoxClass
[SerializableAttribute]
public ref class MessageBoxClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageBoxClass()()() | Initializes a new instance of the MessageBoxClass class
 | Buttons |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Icon |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | Title |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MessageBoxClass

Send comments on this topic to Please email feedback to Support


MessageBoxClass Constructor

MessageBoxClass Constructor
Namespaces ► VisualCron ► MessageBoxClass ► MessageBoxClass()()()
Initializes a new instance of the MessageBoxClass class
Declaration Syntax
C# Visual Basic Visual C++
public MessageBoxClass()
Public Sub New
public:
MessageBoxClass()


Buttons Property

Buttons Property
Namespaces ► VisualCron ► MessageBoxClass ► Buttons

[Missing <summary> documentation for P:VisualCron.MessageBoxClass.Buttons]

Declaration Syntax
C# Visual Basic Visual C++
public MessageBoxButtons Buttons { get; set; }
Public Property Buttons As MessageBoxButtons
public:
property MessageBoxButtons Buttons {
    MessageBoxButtons get ();
    void set (MessageBoxButtons value);
}


Icon Property

Icon Property
Namespaces ► VisualCron ► MessageBoxClass ► Icon

[Missing <summary> documentation for P:VisualCron.MessageBoxClass.Icon]

Declaration Syntax
C# Visual Basic Visual C++
public MessageBoxIcon Icon { get; set; }
Public Property Icon As MessageBoxIcon
public:
property MessageBoxIcon Icon {
    MessageBoxIcon get ();
    void set (MessageBoxIcon value);
}


Message Property

Message Property
Namespaces ► VisualCron ► MessageBoxClass ► Message

[Missing <summary> documentation for P:VisualCron.MessageBoxClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


Title Property

Title Property
Namespaces ► VisualCron ► MessageBoxClass ► Title

[Missing <summary> documentation for P:VisualCron.MessageBoxClass.Title]

Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; set; }
Public Property Title As String
public:
property String^ Title {
    String^ get ();
    void set (String^ value);
}


MessageClass Class

MessageClass Class
Namespaces ► VisualCron ► MessageClass

[Missing <summary> documentation for T:VisualCron.MessageClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MessageClass
<SerializableAttribute> _
Public Class MessageClass
[SerializableAttribute]
public ref class MessageClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageClass()()() | Initializes a new instance of the MessageClass class
 | Certificate |
 | CertificateDelete |
 | CertificateList |
 | ClientConnectionChange |
 | ClientConnectionList |
 | Condition |
 | ConditionDelete |
 | ConditionSet |
 | ConditionSetDelete |
 | ConditionSetList |
 | Connection |
 | ConnectionArray |
 | ConnectionDelete |
 | EIProgress |
 | EmailSetting |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FEDelete |
 | FEDeleteResult |
 | FEDirectoryContentResult |
 | FEFilePropertiesResult |
 | FEGetDirectoryContent |
 | FEGetFileProperties |
 | FEGetLogicalDrives |
 | FEGetSearch |
 | FELogicalDrivesResult |
 | FENewFolder |
 | FENewFolderResult |
 | FEPasteResult |
 | FEPasteToServer |
 | FERemoteCopy |
 | FERename |
 | FERenameResult |
 | FESearchResult |
 | FESetFileAttributes |
 | FileFilterResult |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | Job |
 | JobArray |
 | JobDelete |
 | JobDeleteAll |
 | JobRun |
 | JobState |
 | JobStats |
 | KillProcess |
 | License |
 | LicenseWarning |
 | Log |
 | LogChunk |
 | Login |
 | LogInfo |
 | LoginResult |
 | LogSubscribe |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MessageBox |
 | MessageRequest |
 | MessageType |
 | NetworkCredential |
 | NetworkCredentialDelete |
 | NetworkCredentialList |
 | NetworkCredentialTestResult |
 | NetworkDrive |
 | NetworkDriveDelete |
 | NetworkDriveList |
 | Notification |
 | NotificationDelete |
 | NotificationList |
 | PGPKeyRing |
 | PGPKeyRingDelete |
 | PGPKeyRingList |
 | Ping |
 | Printers |
 | Processes |
 | SecUser |
 | SecUsers |
 | ServerInfo |
 | ServerInfoGet |
 | ServerSettings |
 | ServerStatus |
 | SetId()()() |
 | Sync |
 | Task |
 | TaskDelete |
 | TaskProcess |
 | TaskResult |
 | TaskRun |
 | TaskState |
 | TaskStats |
 | TestEmail |
 | TimeException |
 | TimeExceptionCollection |
 | TimeExceptionCollectionArray |
 | TimeExceptionCollectionDelete |
 | TimeExceptionDelete |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrialExtension |
 | Trigger |
 | TriggerExpiration |
 | TriggerResult |
 | TriggerResultClone |
 | UserDelete |
 | UserVariable |
 | UserVariableDelete |
 | UserVariableList |
 | VCJobProcess |
 | VCJobProcessArray |
 | VCTaskProcess |
 | VCTaskProcessArray |
 | XMLCommand |
Inheritance Hierarchy
Object
MessageClass

Send comments on this topic to Please email feedback to Support


MessageClass Constructor

MessageClass Constructor
Namespaces ► VisualCron ► MessageClass ► MessageClass()()()
Initializes a new instance of the MessageClass class
Declaration Syntax
C# Visual Basic Visual C++
public MessageClass()
Public Sub New
public:
MessageClass()


Certificate Field

Certificate Field
Namespaces ► VisualCron ► MessageClass ► Certificate

[Missing <summary> documentation for F:VisualCron.MessageClass.Certificate]

Declaration Syntax
C# Visual Basic Visual C++
public CertificateClass Certificate
Public Certificate As CertificateClass
public:
CertificateClass^ Certificate

Send comments on this topic to Please email feedback to Support


CertificateDelete Field

CertificateDelete Field
Namespaces ► VisualCron ► MessageClass ► CertificateDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.CertificateDelete]

Declaration Syntax
C# Visual Basic Visual C++
public CertificateDeleteClass CertificateDelete
Public CertificateDelete As CertificateDeleteClass
public:
CertificateDeleteClass^ CertificateDelete


CertificateList Field

CertificateList Field
Namespaces ► VisualCron ► MessageClass ► CertificateList

[Missing <summary> documentation for F:VisualCron.MessageClass.CertificateList]

Declaration Syntax
C# Visual Basic Visual C++
public List<CertificateClass> CertificateList
Public CertificateList As List(Of CertificateClass)
public:
List<CertificateClass^>^ CertificateList

Send comments on this topic to Please email feedback to Support


ClientConnectionChange Field

ClientConnectionChange Field
Namespaces ► VisualCron ► MessageClass ► ClientConnectionChange

[Missing <summary> documentation for F:VisualCron.MessageClass.ClientConnectionChange]

Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionChangeClass ClientConnectionChange
Public ClientConnectionChange As ClientConnectionChangeClass
public:
ClientConnectionChangeClass^ ClientConnectionChange


ClientConnectionList Field

ClientConnectionList Field
Namespaces ► VisualCron ► MessageClass ► ClientConnectionList

[Missing <summary> documentation for F:VisualCron.MessageClass.ClientConnectionList]

Declaration Syntax
C# Visual Basic Visual C++
public List<ClientConnectionClass> ClientConnectionList
Public ClientConnectionList As List(Of ClientConnectionClass)
public:
List<ClientConnectionClass^>^ ClientConnectionList


Condition Field

Condition Field
Namespaces ► VisualCron ► MessageClass ► Condition

[Missing <summary> documentation for F:VisualCron.MessageClass.Condition]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass Condition
Public Condition As ConditionClass
public:
ConditionClass^ Condition

Send comments on this topic to Please email feedback to Support


ConditionDelete Field

ConditionDelete Field
Namespaces ► VisualCron ► MessageClass ► ConditionDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.ConditionDelete]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionDeleteClass ConditionDelete
Public ConditionDelete As ConditionDeleteClass
public:
ConditionDeleteClass^ ConditionDelete

Send comments on this topic to Please email feedback to Support


ConditionSet Field

ConditionSet Field
Namespaces ► VisualCron ► MessageClass ► ConditionSet

[Missing <summary> documentation for F:VisualCron.MessageClass.ConditionSet]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetClass ConditionSet
Public ConditionSet As ConditionSetClass
public:
ConditionSetClass^ ConditionSet

Send comments on this topic to Please email feedback to Support


ConditionSetDelete Field

ConditionSetDelete Field
Namespaces ► VisualCron ► MessageClass ► ConditionSetDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.ConditionSetDelete]

Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetDeleteClass ConditionSetDelete
Public ConditionSetDelete As ConditionSetDeleteClass
public:
ConditionSetDeleteClass^ ConditionSetDelete


ConditionSetList Field

ConditionSetList Field
Namespaces ► VisualCron ► MessageClass ► ConditionSetList

[Missing <summary> documentation for F:VisualCron.MessageClass.ConditionSetList]

Declaration Syntax
C# Visual Basic Visual C++
public List<ConditionSetClass> ConditionSetList
Public ConditionSetList As List(Of ConditionSetClass)
public:
List<ConditionSetClass^>^ ConditionSetList


Connection Field

Connection Field
Namespaces ► VisualCron ► MessageClass ► Connection

[Missing <summary> documentation for F:VisualCron.MessageClass.Connection]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass Connection
Public Connection As ConnectionClass
public:
ConnectionClass^ Connection

Send comments on this topic to Please email feedback to Support


ConnectionArray Field

ConnectionArray Field
Namespaces ► VisualCron ► MessageClass ► ConnectionArray

[Missing <summary> documentation for F:VisualCron.MessageClass.ConnectionArray]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass[] ConnectionArray
Public ConnectionArray As ConnectionClass()
public:
array<ConnectionClass^>^ ConnectionArray


ConnectionDelete Field

ConnectionDelete Field
Namespaces ► VisualCron ► MessageClass ► ConnectionDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.ConnectionDelete]

Declaration Syntax
C# Visual Basic Visual C++
public ConnectionDeleteClass ConnectionDelete
Public ConnectionDelete As ConnectionDeleteClass
public:
ConnectionDeleteClass^ ConnectionDelete

Send comments on this topic to Please email feedback to Support


EIProgress Field

EIProgress Field
Namespaces ► VisualCron ► MessageClass ► EIProgress

[Missing <summary> documentation for F:VisualCron.MessageClass.EIProgress]

Declaration Syntax
C# Visual Basic Visual C++
public ExportImportProgressClass EIProgress
Public EIProgress As ExportImportProgressClass
public:
ExportImportProgressClass^ EIProgress

Send comments on this topic to Please email feedback to Support


EmailSetting Field

EmailSetting Field
Namespaces ► VisualCron ► MessageClass ► EmailSetting

[Missing <summary> documentation for F:VisualCron.MessageClass.EmailSetting]

Declaration Syntax
C# Visual Basic Visual C++
public EmailSettingClass EmailSetting
Public EmailSetting As EmailSettingClass
public:
EmailSettingClass^ EmailSetting

Send comments on this topic to Please email feedback to Support


FEDelete Field

FEDelete Field
Namespaces ► VisualCron ► MessageClass ► FEDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.FEDelete]

Declaration Syntax
C# Visual Basic Visual C++
public FEDelete FEDelete
Public FEDelete As FEDelete
public:
FEDelete^ FEDelete

Send comments on this topic to Please email feedback to Support


FEDeleteResult Field

FEDeleteResult Field
Namespaces ► VisualCron ► MessageClass ► FEDeleteResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FEDeleteResult]

Declaration Syntax
C# Visual Basic Visual C++
public FEDeleteResult FEDeleteResult
Public FEDeleteResult As FEDeleteResult
public:
FEDeleteResult^ FEDeleteResult

Send comments on this topic to Please email feedback to Support


FEDirectoryContentResult Field

FEDirectoryContentResult Field
Namespaces ► VisualCron ► MessageClass ► FEDirectoryContentResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FEDirectoryContentResult]

Declaration Syntax
C# Visual Basic Visual C++
public FEDirectoryContentResult FEDirectoryContentResult
Public FEDirectoryContentResult As FEDirectoryContentResult
public:
FEDirectoryContentResult^ FEDirectoryContentResult


FEFilePropertiesResult Field

FEFilePropertiesResult Field
Namespaces ► VisualCron ► MessageClass ► FEFilePropertiesResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FEFilePropertiesResult]

Declaration Syntax
C# Visual Basic Visual C++
public FEFilePropertiesResult FEFilePropertiesResult
Public FEFilePropertiesResult As FEFilePropertiesResult
public:
FEFilePropertiesResult^ FEFilePropertiesResult


FEGetDirectoryContent Field

FEGetDirectoryContent Field
Namespaces ► VisualCron ► MessageClass ► FEGetDirectoryContent

[Missing <summary> documentation for F:VisualCron.MessageClass.FEGetDirectoryContent]

Declaration Syntax
C# Visual Basic Visual C++
public FEGetDirectoryContent FEGetDirectoryContent
Public FEGetDirectoryContent As FEGetDirectoryContent
public:
FEGetDirectoryContent^ FEGetDirectoryContent


FEGetFileProperties Field

FEGetFileProperties Field
Namespaces ► VisualCron ► MessageClass ► FEGetFileProperties

[Missing <summary> documentation for F:VisualCron.MessageClass.FEGetFileProperties]

Declaration Syntax
C# Visual Basic Visual C++
public FEGetFileProperties FEGetFileProperties
Public FEGetFileProperties As FEGetFileProperties
public:
FEGetFileProperties^ FEGetFileProperties

Send comments on this topic to Please email feedback to Support


FEGetLogicalDrives Field

FEGetLogicalDrives Field
Namespaces ► VisualCron ► MessageClass ► FEGetLogicalDrives

[Missing <summary> documentation for F:VisualCron.MessageClass.FEGetLogicalDrives]

Declaration Syntax
C# Visual Basic Visual C++
public FEGetLogicalDrives FEGetLogicalDrives
Public FEGetLogicalDrives As FEGetLogicalDrives
public:
FEGetLogicalDrives^ FEGetLogicalDrives

Send comments on this topic to Please email feedback to Support


FEGetSearch Field

FEGetSearch Field
Namespaces ► VisualCron ► MessageClass ► FEGetSearch

[Missing <summary> documentation for F:VisualCron.MessageClass.FEGetSearch]

Declaration Syntax
C# Visual Basic Visual C++
public FEGetSearch FEGetSearch
Public FEGetSearch As FEGetSearch
public:
FEGetSearch^ FEGetSearch

Send comments on this topic to Please email feedback to Support


FELogicalDrivesResult Field

FELogicalDrivesResult Field
Namespaces ► VisualCron ► MessageClass ► FELogicalDrivesResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FELogicalDrivesResult]

Declaration Syntax
C# Visual Basic Visual C++
public FELogicalDrivesResult FELogicalDrivesResult
Public FELogicalDrivesResult As FELogicalDrivesResult
public:
FELogicalDrivesResult^ FELogicalDrivesResult


FENewFolder Field

FENewFolder Field
Namespaces ► VisualCron ► MessageClass ► FENewFolder

[Missing <summary> documentation for F:VisualCron.MessageClass.FENewFolder]

Declaration Syntax
C# Visual Basic Visual C++
public FENewFolder FENewFolder
Public FENewFolder As FENewFolder
public:
FENewFolder^ FENewFolder

Send comments on this topic to Please email feedback to Support


FENewFolderResult Field

FENewFolderResult Field
Namespaces ► VisualCron ► MessageClass ► FENewFolderResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FENewFolderResult]

Declaration Syntax
C# Visual Basic Visual C++
public FENewFolderResult FENewFolderResult
Public FENewFolderResult As FENewFolderResult
public:
FENewFolderResult^ FENewFolderResult

Send comments on this topic to Please email feedback to Support


FEPasteResult Field

FEPasteResult Field
Namespaces ► VisualCron ► MessageClass ► FEPasteResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FEPasteResult]

Declaration Syntax
C# Visual Basic Visual C++
public FEPasteResult FEPasteResult
Public FEPasteResult As FEPasteResult
public:
FEPasteResult^ FEPasteResult

Send comments on this topic to Please email feedback to Support


FEPasteToServer Field

FEPasteToServer Field
Namespaces ► VisualCron ► MessageClass ► FEPasteToServer

[Missing <summary> documentation for F:VisualCron.MessageClass.FEPasteToServer]

Declaration Syntax
C# Visual Basic Visual C++
public FEPasteToServer FEPasteToServer
Public FEPasteToServer As FEPasteToServer
public:
FEPasteToServer^ FEPasteToServer

Send comments on this topic to Please email feedback to Support


FERemoteCopy Field

FERemoteCopy Field
Namespaces ► VisualCron ► MessageClass ► FERemoteCopy

[Missing <summary> documentation for F:VisualCron.MessageClass.FERemoteCopy]

Declaration Syntax
C# Visual Basic Visual C++
public FERemoteCopy FERemoteCopy
Public FERemoteCopy As FERemoteCopy
public:
FERemoteCopy^ FERemoteCopy

Send comments on this topic to Please email feedback to Support


FERename Field

FERename Field
Namespaces ► VisualCron ► MessageClass ► FERename

[Missing <summary> documentation for F:VisualCron.MessageClass.FERename]

Declaration Syntax
C# Visual Basic Visual C++
public FERename FERename
Public FERename As FERename
public:
FERename^ FERename

Send comments on this topic to Please email feedback to Support


FERenameResult Field

FERenameResult Field
Namespaces ► VisualCron ► MessageClass ► FERenameResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FERenameResult]

Declaration Syntax
C# Visual Basic Visual C++
public FERenameResult FERenameResult
Public FERenameResult As FERenameResult
public:
FERenameResult^ FERenameResult

Send comments on this topic to Please email feedback to Support


FESearchResult Field

FESearchResult Field
Namespaces ► VisualCron ► MessageClass ► FESearchResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FESearchResult]

Declaration Syntax
C# Visual Basic Visual C++
public FESearchResult FESearchResult
Public FESearchResult As FESearchResult
public:
FESearchResult^ FESearchResult

Send comments on this topic to Please email feedback to Support


FESetFileAttributes Field

FESetFileAttributes Field
Namespaces ► VisualCron ► MessageClass ► FESetFileAttributes

[Missing <summary> documentation for F:VisualCron.MessageClass.FESetFileAttributes]

Declaration Syntax
C# Visual Basic Visual C++
public FESetFileAttributes FESetFileAttributes
Public FESetFileAttributes As FESetFileAttributes
public:
FESetFileAttributes^ FESetFileAttributes

Send comments on this topic to Please email feedback to Support


FileFilterResult Field

FileFilterResult Field
Namespaces ► VisualCron ► MessageClass ► FileFilterResult

[Missing <summary> documentation for F:VisualCron.MessageClass.FileFilterResult]

Declaration Syntax
C# Visual Basic Visual C++
public FileFilterResultClass FileFilterResult
Public FileFilterResult As FileFilterResultClass
public:
FileFilterResultClass^ FileFilterResult

Send comments on this topic to Please email feedback to Support


Id Field

Id Field
Namespaces ► VisualCron ► MessageClass ► Id

[Missing <summary> documentation for F:VisualCron.MessageClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id
Public Id As String
public:
String^ Id

Send comments on this topic to Please email feedback to Support


Job Field

Job Field
Namespaces ► VisualCron ► MessageClass ► Job

[Missing <summary> documentation for F:VisualCron.MessageClass.Job]

Declaration Syntax
C# Visual Basic Visual C++
public JobClass Job
Public Job As JobClass
public:
JobClass^ Job

Send comments on this topic to Please email feedback to Support


JobArray Field

JobArray Field
Namespaces ► VisualCron ► MessageClass ► JobArray

[Missing <summary> documentation for F:VisualCron.MessageClass.JobArray]

Declaration Syntax
C# Visual Basic Visual C++
public JobClass[] JobArray
Public JobArray As JobClass()
public:
array<JobClass^>^ JobArray


JobDelete Field

JobDelete Field
Namespaces ► VisualCron ► MessageClass ► JobDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.JobDelete]

Declaration Syntax
C# Visual Basic Visual C++
public JobDeleteClass JobDelete
Public JobDelete As JobDeleteClass
public:
JobDeleteClass^ JobDelete

Send comments on this topic to Please email feedback to Support


JobDeleteAll Field

JobDeleteAll Field
Namespaces ► VisualCron ► MessageClass ► JobDeleteAll

[Missing <summary> documentation for F:VisualCron.MessageClass.JobDeleteAll]

Declaration Syntax
C# Visual Basic Visual C++
public JobDeleteAllClass JobDeleteAll
Public JobDeleteAll As JobDeleteAllClass
public:
JobDeleteAllClass^ JobDeleteAll

Send comments on this topic to Please email feedback to Support


JobRun Field

JobRun Field
Namespaces ► VisualCron ► MessageClass ► JobRun

[Missing <summary> documentation for F:VisualCron.MessageClass.JobRun]

Declaration Syntax
C# Visual Basic Visual C++
public JobRunClass JobRun
Public JobRun As JobRunClass
public:
JobRunClass^ JobRun

Send comments on this topic to Please email feedback to Support


JobState Field

JobState Field
Namespaces ► VisualCron ► MessageClass ► JobState

[Missing <summary> documentation for F:VisualCron.MessageClass.JobState]

Declaration Syntax
C# Visual Basic Visual C++
public JobStateClass JobState
Public JobState As JobStateClass
public:
JobStateClass^ JobState

Send comments on this topic to Please email feedback to Support


JobStats Field

JobStats Field
Namespaces ► VisualCron ► MessageClass ► JobStats

[Missing <summary> documentation for F:VisualCron.MessageClass.JobStats]

Declaration Syntax
C# Visual Basic Visual C++
public JobStatsClass JobStats
Public JobStats As JobStatsClass
public:
JobStatsClass^ JobStats

Send comments on this topic to Please email feedback to Support


KillProcess Field

KillProcess Field
Namespaces ► VisualCron ► MessageClass ► KillProcess

[Missing <summary> documentation for F:VisualCron.MessageClass.KillProcess]

Declaration Syntax
C# Visual Basic Visual C++
public KillVCProcessClass KillProcess
Public KillProcess As KillVCProcessClass
public:
KillVCProcessClass^ KillProcess

Send comments on this topic to Please email feedback to Support


License Field

License Field
Namespaces ► VisualCron ► MessageClass ► License

[Missing <summary> documentation for F:VisualCron.MessageClass.License]

Declaration Syntax
C# Visual Basic Visual C++
public LicenseClass License
Public License As LicenseClass
public:
LicenseClass^ License

Send comments on this topic to Please email feedback to Support


LicenseWarning Field

LicenseWarning Field
Namespaces ► VisualCron ► MessageClass ► LicenseWarning

[Missing <summary> documentation for F:VisualCron.MessageClass.LicenseWarning]

Declaration Syntax
C# Visual Basic Visual C++
public LicenseWarningClass LicenseWarning
Public LicenseWarning As LicenseWarningClass
public:
LicenseWarningClass^ LicenseWarning

Send comments on this topic to Please email feedback to Support


Log Field

Log Field
Namespaces ► VisualCron ► MessageClass ► Log

[Missing <summary> documentation for F:VisualCron.MessageClass.Log]

Declaration Syntax
C# Visual Basic Visual C++
public LogClass Log
Public Log As LogClass
public:
LogClass^ Log

Send comments on this topic to Please email feedback to Support


LogChunk Field

LogChunk Field
Namespaces ► VisualCron ► MessageClass ► LogChunk

[Missing <summary> documentation for F:VisualCron.MessageClass.LogChunk]

Declaration Syntax
C# Visual Basic Visual C++
public LogArrayClass LogChunk
Public LogChunk As LogArrayClass
public:
LogArrayClass^ LogChunk

Send comments on this topic to Please email feedback to Support


Login Field

Login Field
Namespaces ► VisualCron ► MessageClass ► Login

[Missing <summary> documentation for F:VisualCron.MessageClass.Login]

Declaration Syntax
C# Visual Basic Visual C++
public LoginClass Login
Public Login As LoginClass
public:
LoginClass^ Login

Send comments on this topic to Please email feedback to Support


LogInfo Field

LogInfo Field
Namespaces ► VisualCron ► MessageClass ► LogInfo

[Missing <summary> documentation for F:VisualCron.MessageClass.LogInfo]

Declaration Syntax
C# Visual Basic Visual C++
public LogInfoClass LogInfo
Public LogInfo As LogInfoClass
public:
LogInfoClass^ LogInfo

Send comments on this topic to Please email feedback to Support


LoginResult Field

LoginResult Field
Namespaces ► VisualCron ► MessageClass ► LoginResult

[Missing <summary> documentation for F:VisualCron.MessageClass.LoginResult]

Declaration Syntax
C# Visual Basic Visual C++
public LoginResultClass LoginResult
Public LoginResult As LoginResultClass
public:
LoginResultClass^ LoginResult

Send comments on this topic to Please email feedback to Support


LogSubscribe Field

LogSubscribe Field
Namespaces ► VisualCron ► MessageClass ► LogSubscribe

[Missing <summary> documentation for F:VisualCron.MessageClass.LogSubscribe]

Declaration Syntax
C# Visual Basic Visual C++
public LogSubscribeClass LogSubscribe
Public LogSubscribe As LogSubscribeClass
public:
LogSubscribeClass^ LogSubscribe

Send comments on this topic to Please email feedback to Support


MessageBox Field

MessageBox Field
Namespaces ► VisualCron ► MessageClass ► MessageBox

[Missing <summary> documentation for F:VisualCron.MessageClass.MessageBox]

Declaration Syntax
C# Visual Basic Visual C++
public MessageBoxClass MessageBox
Public MessageBox As MessageBoxClass
public:
MessageBoxClass^ MessageBox

Send comments on this topic to Please email feedback to Support


MessageRequest Field

MessageRequest Field
Namespaces ► VisualCron ► MessageClass ► MessageRequest

[Missing <summary> documentation for F:VisualCron.MessageClass.MessageRequest]

Declaration Syntax
C# Visual Basic Visual C++
public MessageRequestClass MessageRequest
Public MessageRequest As MessageRequestClass
public:
MessageRequestClass^ MessageRequest

Send comments on this topic to Please email feedback to Support


MessageType Field

MessageType Field
Namespaces ► VisualCron ► MessageClass ► MessageType

[Missing <summary> documentation for F:VisualCron.MessageClass.MessageType]

Declaration Syntax
C# Visual Basic Visual C++
public MessageClass..::.MType MessageType
Public MessageType As MessageClass..::.MType
public:
MessageClass..::.MType MessageType

Send comments on this topic to Please email feedback to Support


NetworkCredential Field

NetworkCredential Field
Namespaces ► VisualCron ► MessageClass ► NetworkCredential

[Missing <summary> documentation for F:VisualCron.MessageClass.NetworkCredential]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialClass NetworkCredential
Public NetworkCredential As NetworkCredentialClass
public:
NetworkCredentialClass^ NetworkCredential


NetworkCredentialDelete Field

NetworkCredentialDelete Field
Namespaces ► VisualCron ► MessageClass ► NetworkCredentialDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.NetworkCredentialDelete]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialDeleteClass NetworkCredentialDelete
Public NetworkCredentialDelete As NetworkCredentialDeleteClass
public:
NetworkCredentialDeleteClass^ NetworkCredentialDelete


NetworkCredentialList Field

NetworkCredentialList Field
Namespaces ► VisualCron ► MessageClass ► NetworkCredentialList

[Missing <summary> documentation for F:VisualCron.MessageClass.NetworkCredentialList]

Declaration Syntax
C# Visual Basic Visual C++
public List<NetworkCredentialClass> NetworkCredentialList
Public NetworkCredentialList As List(Of NetworkCredentialClass)
public:
List<NetworkCredentialClass^>^ NetworkCredentialList


NetworkCredentialTestResult Field

NetworkCredentialTestResult Field
Namespaces ► VisualCron ► MessageClass ► NetworkCredentialTestResult

[Missing <summary> documentation for F:VisualCron.MessageClass.NetworkCredentialTestResult]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialTestResultClass NetworkCredentialTestResult
Public NetworkCredentialTestResult As NetworkCredentialTestResultClass
public:
NetworkCredentialTestResultClass^ NetworkCredentialTestResult


NetworkDrive Field

NetworkDrive Field
Namespaces ► VisualCron ► MessageClass ► NetworkDrive

[Missing <summary> documentation for F:VisualCron.MessageClass.NetworkDrive]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass NetworkDrive
Public NetworkDrive As NetworkDriveClass
public:
NetworkDriveClass^ NetworkDrive

Send comments on this topic to Please email feedback to Support


NetworkDriveDelete Field

NetworkDriveDelete Field
Namespaces ► VisualCron ► MessageClass ► NetworkDriveDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.NetworkDriveDelete]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveDeleteClass NetworkDriveDelete
Public NetworkDriveDelete As NetworkDriveDeleteClass
public:
NetworkDriveDeleteClass^ NetworkDriveDelete


NetworkDriveList Field

NetworkDriveList Field
Namespaces ► VisualCron ► MessageClass ► NetworkDriveList

[Missing <summary> documentation for F:VisualCron.MessageClass.NetworkDriveList]

Declaration Syntax
C# Visual Basic Visual C++
public List<NetworkDriveClass> NetworkDriveList
Public NetworkDriveList As List(Of NetworkDriveClass)
public:
List<NetworkDriveClass^>^ NetworkDriveList


Notification Field

Notification Field
Namespaces ► VisualCron ► MessageClass ► Notification

[Missing <summary> documentation for F:VisualCron.MessageClass.Notification]

Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass Notification
Public Notification As NotificationClass
public:
NotificationClass^ Notification

Send comments on this topic to Please email feedback to Support


NotificationDelete Field

NotificationDelete Field
Namespaces ► VisualCron ► MessageClass ► NotificationDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.NotificationDelete]

Declaration Syntax
C# Visual Basic Visual C++
public NotificationDeleteClass NotificationDelete
Public NotificationDelete As NotificationDeleteClass
public:
NotificationDeleteClass^ NotificationDelete


NotificationList Field

NotificationList Field
Namespaces ► VisualCron ► MessageClass ► NotificationList

[Missing <summary> documentation for F:VisualCron.MessageClass.NotificationList]

Declaration Syntax
C# Visual Basic Visual C++
public List<NotificationClass> NotificationList
Public NotificationList As List(Of NotificationClass)
public:
List<NotificationClass^>^ NotificationList


PGPKeyRing Field

PGPKeyRing Field
Namespaces ► VisualCron ► MessageClass ► PGPKeyRing

[Missing <summary> documentation for F:VisualCron.MessageClass.PGPKeyRing]

Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingClass PGPKeyRing
Public PGPKeyRing As PGPKeyRingClass
public:
PGPKeyRingClass^ PGPKeyRing

Send comments on this topic to Please email feedback to Support


PGPKeyRingDelete Field

PGPKeyRingDelete Field
Namespaces ► VisualCron ► MessageClass ► PGPKeyRingDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.PGPKeyRingDelete]

Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingDeleteClass PGPKeyRingDelete
Public PGPKeyRingDelete As PGPKeyRingDeleteClass
public:
PGPKeyRingDeleteClass^ PGPKeyRingDelete

Send comments on this topic to Please email feedback to Support


PGPKeyRingList Field

PGPKeyRingList Field
Namespaces ► VisualCron ► MessageClass ► PGPKeyRingList

[Missing <summary> documentation for F:VisualCron.MessageClass.PGPKeyRingList]

Declaration Syntax
C# Visual Basic Visual C++
public List<PGPKeyRingClass> PGPKeyRingList
Public PGPKeyRingList As List(Of PGPKeyRingClass)
public:
List<PGPKeyRingClass^>^ PGPKeyRingList

Send comments on this topic to Please email feedback to Support


Ping Field

Ping Field
Namespaces ► VisualCron ► MessageClass ► Ping

[Missing <summary> documentation for F:VisualCron.MessageClass.Ping]

Declaration Syntax
C# Visual Basic Visual C++
public PingClass Ping
Public Ping As PingClass
public:
PingClass^ Ping

Send comments on this topic to Please email feedback to Support


Printers Field

Printers Field
Namespaces ► VisualCron ► MessageClass ► Printers

[Missing <summary> documentation for F:VisualCron.MessageClass.Printers]

Declaration Syntax
C# Visual Basic Visual C++
public PrintersClass Printers
Public Printers As PrintersClass
public:
PrintersClass^ Printers

Send comments on this topic to Please email feedback to Support


Processes Field

Processes Field
Namespaces ► VisualCron ► MessageClass ► Processes

[Missing <summary> documentation for F:VisualCron.MessageClass.Processes]

Declaration Syntax
C# Visual Basic Visual C++
public ProcessesClass Processes
Public Processes As ProcessesClass
public:
ProcessesClass^ Processes

Send comments on this topic to Please email feedback to Support


SecUser Field

SecUser Field
Namespaces ► VisualCron ► MessageClass ► SecUser

[Missing <summary> documentation for F:VisualCron.MessageClass.SecUser]

Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass SecUser
Public SecUser As SecUserClass
public:
SecUserClass^ SecUser

Send comments on this topic to Please email feedback to Support


SecUsers Field

SecUsers Field
Namespaces ► VisualCron ► MessageClass ► SecUsers

[Missing <summary> documentation for F:VisualCron.MessageClass.SecUsers]

Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass[] SecUsers
Public SecUsers As SecUserClass()
public:
array<SecUserClass^>^ SecUsers


ServerInfo Field

ServerInfo Field
Namespaces ► VisualCron ► MessageClass ► ServerInfo

[Missing <summary> documentation for F:VisualCron.MessageClass.ServerInfo]

Declaration Syntax
C# Visual Basic Visual C++
public ServerInfoClass ServerInfo
Public ServerInfo As ServerInfoClass
public:
ServerInfoClass^ ServerInfo

Send comments on this topic to Please email feedback to Support


ServerInfoGet Field

ServerInfoGet Field
Namespaces ► VisualCron ► MessageClass ► ServerInfoGet

[Missing <summary> documentation for F:VisualCron.MessageClass.ServerInfoGet]

Declaration Syntax
C# Visual Basic Visual C++
public ServerInfoGetClass ServerInfoGet
Public ServerInfoGet As ServerInfoGetClass
public:
ServerInfoGetClass^ ServerInfoGet

Send comments on this topic to Please email feedback to Support


ServerSettings Field

ServerSettings Field
Namespaces ► VisualCron ► MessageClass ► ServerSettings

[Missing <summary> documentation for F:VisualCron.MessageClass.ServerSettings]

Declaration Syntax
C# Visual Basic Visual C++
public ServerSettingsClass ServerSettings
Public ServerSettings As ServerSettingsClass
public:
ServerSettingsClass^ ServerSettings

Send comments on this topic to Please email feedback to Support


ServerStatus Field

ServerStatus Field
Namespaces ► VisualCron ► MessageClass ► ServerStatus

[Missing <summary> documentation for F:VisualCron.MessageClass.ServerStatus]

Declaration Syntax
C# Visual Basic Visual C++
public ServerStatusClass ServerStatus
Public ServerStatus As ServerStatusClass
public:
ServerStatusClass^ ServerStatus

Send comments on this topic to Please email feedback to Support


SetId Method

SetId Method
Namespaces ► VisualCron ► MessageClass ► SetId()()()

[Missing <summary> documentation for M:VisualCron.MessageClass.SetId]

Declaration Syntax
C# Visual Basic Visual C++
public string SetId()
Public Function SetId As String
public:
String^ SetId()
Return Value

[Missing <returns> documentation for M:VisualCron.MessageClass.SetId]


Sync Field

Sync Field
Namespaces ► VisualCron ► MessageClass ► Sync

[Missing <summary> documentation for F:VisualCron.MessageClass.Sync]

Declaration Syntax
C# Visual Basic Visual C++
public SyncClass Sync
Public Sync As SyncClass
public:
SyncClass^ Sync

Send comments on this topic to Please email feedback to Support


Task Field

Task Field
Namespaces ► VisualCron ► MessageClass ► Task

[Missing <summary> documentation for F:VisualCron.MessageClass.Task]

Declaration Syntax
C# Visual Basic Visual C++
public TaskClass Task
Public Task As TaskClass
public:
TaskClass^ Task

Send comments on this topic to Please email feedback to Support


TaskDelete Field

TaskDelete Field
Namespaces ► VisualCron ► MessageClass ► TaskDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.TaskDelete]

Declaration Syntax
C# Visual Basic Visual C++
public TaskDeleteClass TaskDelete
Public TaskDelete As TaskDeleteClass
public:
TaskDeleteClass^ TaskDelete

Send comments on this topic to Please email feedback to Support


TaskProcess Field

TaskProcess Field
Namespaces ► VisualCron ► MessageClass ► TaskProcess

[Missing <summary> documentation for F:VisualCron.MessageClass.TaskProcess]

Declaration Syntax
C# Visual Basic Visual C++
public TaskProcessClass TaskProcess
Public TaskProcess As TaskProcessClass
public:
TaskProcessClass^ TaskProcess

Send comments on this topic to Please email feedback to Support


TaskResult Field

TaskResult Field
Namespaces ► VisualCron ► MessageClass ► TaskResult

[Missing <summary> documentation for F:VisualCron.MessageClass.TaskResult]

Declaration Syntax
C# Visual Basic Visual C++
public TaskResultClass TaskResult
Public TaskResult As TaskResultClass
public:
TaskResultClass^ TaskResult

Send comments on this topic to Please email feedback to Support


TaskRun Field

TaskRun Field
Namespaces ► VisualCron ► MessageClass ► TaskRun

[Missing <summary> documentation for F:VisualCron.MessageClass.TaskRun]

Declaration Syntax
C# Visual Basic Visual C++
public TaskRunClass TaskRun
Public TaskRun As TaskRunClass
public:
TaskRunClass^ TaskRun

Send comments on this topic to Please email feedback to Support


TaskState Field

TaskState Field
Namespaces ► VisualCron ► MessageClass ► TaskState

[Missing <summary> documentation for F:VisualCron.MessageClass.TaskState]

Declaration Syntax
C# Visual Basic Visual C++
public TaskStateClass TaskState
Public TaskState As TaskStateClass
public:
TaskStateClass^ TaskState

Send comments on this topic to Please email feedback to Support


TaskStats Field

TaskStats Field
Namespaces ► VisualCron ► MessageClass ► TaskStats

[Missing <summary> documentation for F:VisualCron.MessageClass.TaskStats]

Declaration Syntax
C# Visual Basic Visual C++
public TaskStatsClass TaskStats
Public TaskStats As TaskStatsClass
public:
TaskStatsClass^ TaskStats

Send comments on this topic to Please email feedback to Support


TestEmail Field

TestEmail Field
Namespaces ► VisualCron ► MessageClass ► TestEmail

[Missing <summary> documentation for F:VisualCron.MessageClass.TestEmail]

Declaration Syntax
C# Visual Basic Visual C++
public TestEmailClass TestEmail
Public TestEmail As TestEmailClass
public:
TestEmailClass^ TestEmail

Send comments on this topic to Please email feedback to Support


TimeException Field

TimeException Field
Namespaces ► VisualCron ► MessageClass ► TimeException

[Missing <summary> documentation for F:VisualCron.MessageClass.TimeException]

Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionClass TimeException
Public TimeException As TimeExceptionClass
public:
TimeExceptionClass^ TimeException

Send comments on this topic to Please email feedback to Support


TimeExceptionCollection Field

TimeExceptionCollection Field
Namespaces ► VisualCron ► MessageClass ► TimeExceptionCollection

[Missing <summary> documentation for F:VisualCron.MessageClass.TimeExceptionCollection]

Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionClass TimeExceptionCollection
Public TimeExceptionCollection As TimeExceptionCollectionClass
public:
TimeExceptionCollectionClass^ TimeExceptionCollection


TimeExceptionCollectionArray Field

TimeExceptionCollectionArray Field
Namespaces ► VisualCron ► MessageClass ► TimeExceptionCollectionArray

[Missing <summary> documentation for F:VisualCron.MessageClass.TimeExceptionCollectionArray]

Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionClass[] TimeExceptionCollectionArray
Public TimeExceptionCollectionArray As TimeExceptionCollectionClass()
public:
array<TimeExceptionCollectionClass^>^ TimeExceptionCollectionArray


TimeExceptionCollectionDelete Field

TimeExceptionCollectionDelete Field
Namespaces ► VisualCron ► MessageClass ► TimeExceptionCollectionDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.TimeExceptionCollectionDelete]

Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionDeleteClass TimeExceptionCollectionDelete
Public TimeExceptionCollectionDelete As TimeExceptionCollectionDeleteClass
public:
TimeExceptionCollectionDeleteClass^ TimeExceptionCollectionDelete


TimeExceptionDelete Field

TimeExceptionDelete Field
Namespaces ► VisualCron ► MessageClass ► TimeExceptionDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.TimeExceptionDelete]

Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionDeleteClass TimeExceptionDelete
Public TimeExceptionDelete As TimeExceptionDeleteClass
public:
TimeExceptionDeleteClass^ TimeExceptionDelete


TrialExtension Field

TrialExtension Field
Namespaces ► VisualCron ► MessageClass ► TrialExtension

[Missing <summary> documentation for F:VisualCron.MessageClass.TrialExtension]

Declaration Syntax
C# Visual Basic Visual C++
public TrialExtensionClass TrialExtension
Public TrialExtension As TrialExtensionClass
public:
TrialExtensionClass^ TrialExtension

Send comments on this topic to Please email feedback to Support


Trigger Field

Trigger Field
Namespaces ► VisualCron ► MessageClass ► Trigger

[Missing <summary> documentation for F:VisualCron.MessageClass.Trigger]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass Trigger
Public Trigger As TriggerClass
public:
TriggerClass^ Trigger

Send comments on this topic to Please email feedback to Support


TriggerExpiration Field

TriggerExpiration Field
Namespaces ► VisualCron ► MessageClass ► TriggerExpiration

[Missing <summary> documentation for F:VisualCron.MessageClass.TriggerExpiration]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerExpirationClass TriggerExpiration
Public TriggerExpiration As TriggerExpirationClass
public:
TriggerExpirationClass^ TriggerExpiration


TriggerResult Field

TriggerResult Field
Namespaces ► VisualCron ► MessageClass ► TriggerResult

[Missing <summary> documentation for F:VisualCron.MessageClass.TriggerResult]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerResultClass TriggerResult
Public TriggerResult As TriggerResultClass
public:
TriggerResultClass^ TriggerResult

Send comments on this topic to Please email feedback to Support


TriggerResultClone Field

TriggerResultClone Field
Namespaces ► VisualCron ► MessageClass ► TriggerResultClone

[Missing <summary> documentation for F:VisualCron.MessageClass.TriggerResultClone]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerResultCloneClass TriggerResultClone
Public TriggerResultClone As TriggerResultCloneClass
public:
TriggerResultCloneClass^ TriggerResultClone


UserDelete Field

UserDelete Field
Namespaces ► VisualCron ► MessageClass ► UserDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.UserDelete]

Declaration Syntax
C# Visual Basic Visual C++
public UserDeleteClass UserDelete
Public UserDelete As UserDeleteClass
public:
UserDeleteClass^ UserDelete

Send comments on this topic to Please email feedback to Support


UserVariable Field

UserVariable Field
Namespaces ► VisualCron ► MessageClass ► UserVariable

[Missing <summary> documentation for F:VisualCron.MessageClass.UserVariable]

Declaration Syntax
C# Visual Basic Visual C++
public UserVariableClass UserVariable
Public UserVariable As UserVariableClass
public:
UserVariableClass^ UserVariable

Send comments on this topic to Please email feedback to Support


UserVariableDelete Field

UserVariableDelete Field
Namespaces ► VisualCron ► MessageClass ► UserVariableDelete

[Missing <summary> documentation for F:VisualCron.MessageClass.UserVariableDelete]

Declaration Syntax
C# Visual Basic Visual C++
public UserVariableDeleteClass UserVariableDelete
Public UserVariableDelete As UserVariableDeleteClass
public:
UserVariableDeleteClass^ UserVariableDelete


UserVariableList Field

UserVariableList Field
Namespaces ► VisualCron ► MessageClass ► UserVariableList

[Missing <summary> documentation for F:VisualCron.MessageClass.UserVariableList]

Declaration Syntax
C# Visual Basic Visual C++
public List<UserVariableClass> UserVariableList
Public UserVariableList As List(Of UserVariableClass)
public:
List<UserVariableClass^>^ UserVariableList


VCJobProcess Field

VCJobProcess Field
Namespaces ► VisualCron ► MessageClass ► VCJobProcess

[Missing <summary> documentation for F:VisualCron.MessageClass.VCJobProcess]

Declaration Syntax
C# Visual Basic Visual C++
public VCJobProcessClass VCJobProcess
Public VCJobProcess As VCJobProcessClass
public:
VCJobProcessClass^ VCJobProcess

Send comments on this topic to Please email feedback to Support


VCJobProcessArray Field

VCJobProcessArray Field
Namespaces ► VisualCron ► MessageClass ► VCJobProcessArray

[Missing <summary> documentation for F:VisualCron.MessageClass.VCJobProcessArray]

Declaration Syntax
C# Visual Basic Visual C++
public VCJobProcessClass[] VCJobProcessArray
Public VCJobProcessArray As VCJobProcessClass()
public:
array<VCJobProcessClass^>^ VCJobProcessArray


VCTaskProcess Field

VCTaskProcess Field
Namespaces ► VisualCron ► MessageClass ► VCTaskProcess

[Missing <summary> documentation for F:VisualCron.MessageClass.VCTaskProcess]

Declaration Syntax
C# Visual Basic Visual C++
public VCTaskProcessClass VCTaskProcess
Public VCTaskProcess As VCTaskProcessClass
public:
VCTaskProcessClass^ VCTaskProcess

Send comments on this topic to Please email feedback to Support


VCTaskProcessArray Field

VCTaskProcessArray Field
Namespaces ► VisualCron ► MessageClass ► VCTaskProcessArray

[Missing <summary> documentation for F:VisualCron.MessageClass.VCTaskProcessArray]

Declaration Syntax
C# Visual Basic Visual C++
public VCTaskProcessClass[] VCTaskProcessArray
Public VCTaskProcessArray As VCTaskProcessClass()
public:
array<VCTaskProcessClass^>^ VCTaskProcessArray


XMLCommand Field

XMLCommand Field
Namespaces ► VisualCron ► MessageClass ► XMLCommand

[Missing <summary> documentation for F:VisualCron.MessageClass.XMLCommand]

Declaration Syntax
C# Visual Basic Visual C++
public XMLCommandClass XMLCommand
Public XMLCommand As XMLCommandClass
public:
XMLCommandClass^ XMLCommand

Send comments on this topic to Please email feedback to Support


MessageClass.ChangeT Enumeration

MessageClass..::.ChangeT Enumeration
Namespaces ► VisualCron ► MessageClass ► MessageClass..::.ChangeT

[Missing <summary> documentation for T:VisualCron.MessageClass.ChangeT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ChangeT
Public Enumeration ChangeT
public enum class ChangeT
Members
Member | Description
Insert |
Update |
Delete |


MessageClass.MType Enumeration

MessageClass..::.MType Enumeration
Namespaces ► VisualCron ► MessageClass ► MessageClass..::.MType

[Missing <summary> documentation for T:VisualCron.MessageClass.MType]

Declaration Syntax
C# Visual Basic Visual C++
public enum MType
Public Enumeration MType
public enum class MType
Members
Member | Description
Certificate |
CertificateDelete |
CertificateList |
ClientConnectionList |
ClientConnectionChange |
Condition |
ConditionDelete |
ConditionSet |
ConditionSetList |
ConditionSetDelete |
EIProgress |
FileFilterResult |
FEFileResult |
FEGetLogicalDrives |
FELogicalDrivesResult |
FEGetDirectoryContent |
FEDirectoryContentResult |
FEPasteToServer |
FEPasteResult |
FEGetFileProperties |
FEFilePropertiesResult |
FESetFileAttributes |
FEGetSearch |
FESearchResult |
FERemoteCopy |
FERename |
FERenameResult |
FEDelete |
FEDeleteResult |
FENewFolder |
FENewFolderResult |
Connection |
ConnectionDelete |
ConnectionList |
Job |
JobList |
JobDelete |
JobDeleteAll |
JobRun |
JobState |
JobStats |
KillProcess |
License |
LicenseWarning |
Login |
LoginResult |
Log |
LogList |
LogSubscribe |
LogInfo |
MessageBox |
NetworkCredential |
NetworkCredentialList |
NetworkCredentialDelete |
NetworkCredentialTestResult |
Notification |
NotificationDelete |
NotificationList |
PGPKeyRing |
PGPKeyRingList |
PGPKeyRingDelete |
Ping |
Printers |
Processes |
ProcessesGet |
MessageRequest |
NetworkDrive |
NetworkDriveList |
NetworkDriveDelete |
SecUser |
UserDelete |
SecUsers |
ServerInfoGet |
ServerInfo |
ServerSettings |
ServerStatus |
Sync |
Task |
TaskDelete |
TaskProcess |
TaskResult |
TaskRun |
TaskState |
TaskStats |
TestEmail |
TimeException |
TimeExceptionDelete |
TimeExceptionCollection |
TimeExceptionCollectionDelete |
TimeExceptionCollectionList |
TrialExtension |
TriggerExpiration |
TriggerResult |
TriggerResultClone |
UserVariable |
UserVariableList |
UserVariableDelete |
VCJobProcess |
VCJobProcessList |
VCTaskProcess |
VCTaskProcessList |
XMLCommand |


MessageRequestClass Class

MessageRequestClass Class
Namespaces ► VisualCron ► MessageRequestClass

[Missing <summary> documentation for T:VisualCron.MessageRequestClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MessageRequestClass
<SerializableAttribute> _
Public Class MessageRequestClass
[SerializableAttribute]
public ref class MessageRequestClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageRequestClass()()() | Initializes a new instance of the MessageRequestClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Info |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RequestType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MessageRequestClass

Send comments on this topic to Please email feedback to Support


MessageRequestClass Constructor

MessageRequestClass Constructor
Namespaces ► VisualCron ► MessageRequestClass ► MessageRequestClass()()()
Initializes a new instance of the MessageRequestClass class
Declaration Syntax
C# Visual Basic Visual C++
public MessageRequestClass()
Public Sub New
public:
MessageRequestClass()


Info Field

Info Field
Namespaces ► VisualCron ► MessageRequestClass ► Info

[Missing <summary> documentation for F:VisualCron.MessageRequestClass.Info]

Declaration Syntax
C# Visual Basic Visual C++
public string Info
Public Info As String
public:
String^ Info

Send comments on this topic to Please email feedback to Support


RequestType Field

RequestType Field
Namespaces ► VisualCron ► MessageRequestClass ► RequestType

[Missing <summary> documentation for F:VisualCron.MessageRequestClass.RequestType]

Declaration Syntax
C# Visual Basic Visual C++
public MessageRequestClass..::.RequestT RequestType
Public RequestType As MessageRequestClass..::.RequestT
public:
MessageRequestClass..::.RequestT RequestType


MessageRequestClass.RequestT Enumeration

MessageRequestClass..::.RequestT Enumeration
Namespaces ► VisualCron ► MessageRequestClass ► MessageRequestClass..::.RequestT

[Missing <summary> documentation for T:VisualCron.MessageRequestClass.RequestT]

Declaration Syntax
C# Visual Basic Visual C++
public enum RequestT
Public Enumeration RequestT
public enum class RequestT
Members
Member | Description
FTPConnectionsArray |
CertificatesArray |
PGPKeyRingArray |
ClientConnectionArray |
Printers |
Protocol |
VariablesArray |


MonthClass Class

MonthClass Class
Namespaces ► VisualCron ► MonthClass
DayClass
Declaration Syntax
C# Visual Basic Visual C++
public class MonthClass
Public Class MonthClass
public ref class MonthClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MonthClass()()() | Initializes a new instance of the MonthClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ShortName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Not used in the API
Inheritance Hierarchy
Object
MonthClass

Send comments on this topic to Please email feedback to Support


MonthClass Constructor

MonthClass Constructor
Namespaces ► VisualCron ► MonthClass ► MonthClass()()()
Initializes a new instance of the MonthClass class
Declaration Syntax
C# Visual Basic Visual C++
public MonthClass()
Public Sub New
public:
MonthClass()


Id Property

Id Property
Namespaces ► VisualCron ► MonthClass ► Id

[Missing <summary> documentation for P:VisualCron.MonthClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public int Id { get; set; }
Public Property Id As Integer
public:
property int Id {
    int get ();
    void set (int value);
}


Name Property

Name Property
Namespaces ► VisualCron ► MonthClass ► Name

[Missing <summary> documentation for P:VisualCron.MonthClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


ShortName Property

ShortName Property
Namespaces ► VisualCron ► MonthClass ► ShortName

[Missing <summary> documentation for P:VisualCron.MonthClass.ShortName]

Declaration Syntax
C# Visual Basic Visual C++
public string ShortName { get; set; }
Public Property ShortName As String
public:
property String^ ShortName {
    String^ get ();
    void set (String^ value);
}


MouseClick Class

MouseClick Class
Namespaces ► VisualCron ► MouseClick
"Mouse Click" macro command.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MouseClick : WindowTargetingCommand
<SerializableAttribute> _
Public Class MouseClick _
    Inherits WindowTargetingCommand
[SerializableAttribute]
public ref class MouseClick : public WindowTargetingCommand
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MouseClick()()() | Initializes a new instance of the MouseClick class
 | Button |
 | Clone()()() | (Inherited from WindowTargetingCommand.)
 | Description | (Overrides Command.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Location |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MouseEvent |
 | RelativeTo |
 | TargetWindow | (Inherited from WindowTargetingCommand.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed) | (Overrides Command.TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed).)
 | WindowState | (Inherited from WindowTargetingCommand.)
Inheritance Hierarchy
Object
 | Command
 |  | WindowTargetingCommand
 |  |  | MouseClick


MouseClick Constructor

MouseClick Constructor
Namespaces ► VisualCron ► MouseClick ► MouseClick()()()
Initializes a new instance of the MouseClick class
Declaration Syntax
C# Visual Basic Visual C++
public MouseClick()
Public Sub New
public:
MouseClick()


Button Property

Button Property
Namespaces ► VisualCron ► MouseClick ► Button

[Missing <summary> documentation for P:VisualCron.MouseClick.Button]

Declaration Syntax
C# Visual Basic Visual C++
public MouseButtons Button { get; set; }
Public Property Button As MouseButtons
public:
property MouseButtons Button {
    MouseButtons get ();
    void set (MouseButtons value);
}


Description Property

Description Property
Namespaces ► VisualCron ► MouseClick ► Description

[Missing <summary> documentation for P:VisualCron.MouseClick.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


Location Property

Location Property
Namespaces ► VisualCron ► MouseClick ► Location

[Missing <summary> documentation for P:VisualCron.MouseClick.Location]

Declaration Syntax
C# Visual Basic Visual C++
public Point Location { get; set; }
Public Property Location As Point
public:
property Point Location {
    Point get ();
    void set (Point value);
}


MouseEvent Property

MouseEvent Property
Namespaces ► VisualCron ► MouseClick ► MouseEvent

[Missing <summary> documentation for P:VisualCron.MouseClick.MouseEvent]

Declaration Syntax
C# Visual Basic Visual C++
public MouseEvents MouseEvent { get; set; }
Public Property MouseEvent As MouseEvents
public:
property MouseEvents MouseEvent {
    MouseEvents get ();
    void set (MouseEvents value);
}


RelativeTo Property

RelativeTo Property
Namespaces ► VisualCron ► MouseClick ► RelativeTo

[Missing <summary> documentation for P:VisualCron.MouseClick.RelativeTo]

Declaration Syntax
C# Visual Basic Visual C++
public RelativeTo RelativeTo { get; set; }
Public Property RelativeTo As RelativeTo
public:
property RelativeTo RelativeTo {
    RelativeTo get ();
    void set (RelativeTo value);
}


TranslateToInstructions Method (builder, speed)

TranslateToInstructions Method (builder, speed)
Namespaces ► VisualCron ► MouseClick ► TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed)

[Missing <summary> documentation for M:VisualCron.MouseClick.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)]

Declaration Syntax
C# Visual Basic Visual C++
public override void TranslateToInstructions(
    InstructionsBuilder builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
)
Public Overrides Sub TranslateToInstructions ( _
    builder As InstructionsBuilder, _
    speed As TaskDesktopMacroClass..::.MacroSpeed _
)
public:
virtual void TranslateToInstructions(
    InstructionsBuilder^ builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
) override
Parameters
builder (InstructionsBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.MouseClick.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]

speed (TaskDesktopMacroClass..::.MacroSpeed)

[Missing <param name="speed"/> documentation for "M:VisualCron.MouseClick.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]


MouseClickInstruction Class

MouseClickInstruction Class
Namespaces ► VisualCron ► MouseClickInstruction

[Missing <summary> documentation for T:VisualCron.MouseClickInstruction]

Declaration Syntax
C# Visual Basic Visual C++
public class MouseClickInstruction : PlayerInstruction
Public Class MouseClickInstruction _
    Inherits PlayerInstruction
public ref class MouseClickInstruction : public PlayerInstruction
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MouseClickInstruction(WindowDescriptor, Point, List<(Of <(Int32>)>), Boolean) | Initializes a new instance of the MouseClickInstruction class
 | Delay | (Inherited from PlayerInstruction.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(IDictionary) | (Overrides PlayerInstruction.Execute(IDictionary).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PlayerInstruction
 |  | MouseClickInstruction


MouseClickInstruction Constructor (targetWindow, coordinates, messages, relative)

MouseClickInstruction Constructor (targetWindow, coordinates, messages, relative)
Namespaces ► VisualCron ► MouseClickInstruction ► MouseClickInstruction(WindowDescriptor, Point, List<(Of <(Int32>)>), Boolean)
Initializes a new instance of the MouseClickInstruction class
Declaration Syntax
C# Visual Basic Visual C++
public MouseClickInstruction(
    WindowDescriptor targetWindow,
    Point coordinates,
    List<int> messages,
    bool relative
)
Public Sub New ( _
    targetWindow As WindowDescriptor, _
    coordinates As Point, _
    messages As List(Of Integer), _
    relative As Boolean _
)
public:
MouseClickInstruction(
    WindowDescriptor^ targetWindow,
    Point coordinates,
    List<int>^ messages,
    bool relative
)
Parameters
targetWindow (WindowDescriptor)

[Missing <param name="targetWindow"/> documentation for "M:VisualCron.MouseClickInstruction.#ctor(VisualCron.WindowDescriptor,System.Drawing.Point,System.Collections.Generic.List{System.Int32},System.Boolean)"]

coordinates (Point)

[Missing <param name="coordinates"/> documentation for "M:VisualCron.MouseClickInstruction.#ctor(VisualCron.WindowDescriptor,System.Drawing.Point,System.Collections.Generic.List{System.Int32},System.Boolean)"]

messages (List <(Of <( Int32 >)>))

[Missing <param name="messages"/> documentation for "M:VisualCron.MouseClickInstruction.#ctor(VisualCron.WindowDescriptor,System.Drawing.Point,System.Collections.Generic.List{System.Int32},System.Boolean)"]

relative (Boolean)

[Missing <param name="relative"/> documentation for "M:VisualCron.MouseClickInstruction.#ctor(VisualCron.WindowDescriptor,System.Drawing.Point,System.Collections.Generic.List{System.Int32},System.Boolean)"]


Execute Method (context)

Execute Method (context)
Namespaces ► VisualCron ► MouseClickInstruction ► Execute(IDictionary)

[Missing <summary> documentation for M:VisualCron.MouseClickInstruction.Execute(System.Collections.IDictionary)]

Declaration Syntax
C# Visual Basic Visual C++
public override void Execute(
    IDictionary context
)
Public Overrides Sub Execute ( _
    context As IDictionary _
)
public:
virtual void Execute(
    IDictionary^ context
) override
Parameters
context (IDictionary)

[Missing <param name="context"/> documentation for "M:VisualCron.MouseClickInstruction.Execute(System.Collections.IDictionary)"]


MouseEvents Enumeration

MouseEvents Enumeration
Namespaces ► VisualCron ► MouseEvents

[Missing <summary> documentation for T:VisualCron.MouseEvents]

Declaration Syntax
C# Visual Basic Visual C++
public enum MouseEvents
Public Enumeration MouseEvents
public enum class MouseEvents
Members
Member | Description
Click |
DoubleClick |
ButtonDown |
ButtonUp |


MouseHookStruct Class

MouseHookStruct Class
Namespaces ► VisualCron ► MouseHookStruct

[Missing <summary> documentation for T:VisualCron.MouseHookStruct]

Declaration Syntax
C# Visual Basic Visual C++
public class MouseHookStruct
Public Class MouseHookStruct
public ref class MouseHookStruct
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MouseHookStruct()()() | Initializes a new instance of the MouseHookStruct class
 | dwExtraInfo |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | hwnd |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | pt |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | wHitTestCode |
Inheritance Hierarchy
Object
MouseHookStruct

Send comments on this topic to Please email feedback to Support


MouseHookStruct Constructor

MouseHookStruct Constructor
Namespaces ► VisualCron ► MouseHookStruct ► MouseHookStruct()()()
Initializes a new instance of the MouseHookStruct class
Declaration Syntax
C# Visual Basic Visual C++
public MouseHookStruct()
Public Sub New
public:
MouseHookStruct()


dwExtraInfo Field

dwExtraInfo Field
Namespaces ► VisualCron ► MouseHookStruct ► dwExtraInfo

[Missing <summary> documentation for F:VisualCron.MouseHookStruct.dwExtraInfo]

Declaration Syntax
C# Visual Basic Visual C++
public int dwExtraInfo
Public dwExtraInfo As Integer
public:
int dwExtraInfo


hwnd Field

hwnd Field
Namespaces ► VisualCron ► MouseHookStruct ► hwnd

[Missing <summary> documentation for F:VisualCron.MouseHookStruct.hwnd]

Declaration Syntax
C# Visual Basic Visual C++
public int hwnd
Public hwnd As Integer
public:
int hwnd


pt Field

pt Field
Namespaces ► VisualCron ► MouseHookStruct ► pt

[Missing <summary> documentation for F:VisualCron.MouseHookStruct.pt]

Declaration Syntax
C# Visual Basic Visual C++
public Point pt
Public pt As Point
public:
Point pt

Send comments on this topic to Please email feedback to Support


wHitTestCode Field

wHitTestCode Field
Namespaces ► VisualCron ► MouseHookStruct ► wHitTestCode

[Missing <summary> documentation for F:VisualCron.MouseHookStruct.wHitTestCode]

Declaration Syntax
C# Visual Basic Visual C++
public int wHitTestCode
Public wHitTestCode As Integer
public:
int wHitTestCode


MOUSEINPUT Structure

MOUSEINPUT Structure
Namespaces ► VisualCron ► MOUSEINPUT

[Missing <summary> documentation for T:VisualCron.MOUSEINPUT]

Declaration Syntax
C# Visual Basic Visual C++
public struct MOUSEINPUT
Public Structure MOUSEINPUT
public value class MOUSEINPUT
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | dwExtraInfo |
 | dwFlags |
 | dx |
 | dy |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mouseData |
 | time |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


dwExtraInfo Field

dwExtraInfo Field
Namespaces ► VisualCron ► MOUSEINPUT ► dwExtraInfo

[Missing <summary> documentation for F:VisualCron.MOUSEINPUT.dwExtraInfo]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr dwExtraInfo
Public dwExtraInfo As IntPtr
public:
IntPtr dwExtraInfo

Send comments on this topic to Please email feedback to Support


dwFlags Field

dwFlags Field
Namespaces ► VisualCron ► MOUSEINPUT ► dwFlags

[Missing <summary> documentation for F:VisualCron.MOUSEINPUT.dwFlags]

Declaration Syntax
C# Visual Basic Visual C++
public int dwFlags
Public dwFlags As Integer
public:
int dwFlags


dx Field

dx Field
Namespaces ► VisualCron ► MOUSEINPUT ► dx

[Missing <summary> documentation for F:VisualCron.MOUSEINPUT.dx]

Declaration Syntax
C# Visual Basic Visual C++
public int dx
Public dx As Integer
public:
int dx


dy Field

dy Field
Namespaces ► VisualCron ► MOUSEINPUT ► dy

[Missing <summary> documentation for F:VisualCron.MOUSEINPUT.dy]

Declaration Syntax
C# Visual Basic Visual C++
public int dy
Public dy As Integer
public:
int dy


mouseData Field

mouseData Field
Namespaces ► VisualCron ► MOUSEINPUT ► mouseData

[Missing <summary> documentation for F:VisualCron.MOUSEINPUT.mouseData]

Declaration Syntax
C# Visual Basic Visual C++
public int mouseData
Public mouseData As Integer
public:
int mouseData


time Field

time Field
Namespaces ► VisualCron ► MOUSEINPUT ► time

[Missing <summary> documentation for F:VisualCron.MOUSEINPUT.time]

Declaration Syntax
C# Visual Basic Visual C++
public int time
Public time As Integer
public:
int time


MouseLLHookStruct Class

MouseLLHookStruct Class
Namespaces ► VisualCron ► MouseLLHookStruct

[Missing <summary> documentation for T:VisualCron.MouseLLHookStruct]

Declaration Syntax
C# Visual Basic Visual C++
public class MouseLLHookStruct
Public Class MouseLLHookStruct
public ref class MouseLLHookStruct
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MouseLLHookStruct()()() | Initializes a new instance of the MouseLLHookStruct class
 | dwExtraInfo |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | flags |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mouseData |
 | pt |
 | time |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MouseLLHookStruct

Send comments on this topic to Please email feedback to Support


MouseLLHookStruct Constructor

MouseLLHookStruct Constructor
Namespaces ► VisualCron ► MouseLLHookStruct ► MouseLLHookStruct()()()
Initializes a new instance of the MouseLLHookStruct class
Declaration Syntax
C# Visual Basic Visual C++
public MouseLLHookStruct()
Public Sub New
public:
MouseLLHookStruct()


dwExtraInfo Field

dwExtraInfo Field
Namespaces ► VisualCron ► MouseLLHookStruct ► dwExtraInfo

[Missing <summary> documentation for F:VisualCron.MouseLLHookStruct.dwExtraInfo]

Declaration Syntax
C# Visual Basic Visual C++
public int dwExtraInfo
Public dwExtraInfo As Integer
public:
int dwExtraInfo


flags Field

flags Field
Namespaces ► VisualCron ► MouseLLHookStruct ► flags

[Missing <summary> documentation for F:VisualCron.MouseLLHookStruct.flags]

Declaration Syntax
C# Visual Basic Visual C++
public int flags
Public flags As Integer
public:
int flags


mouseData Field

mouseData Field
Namespaces ► VisualCron ► MouseLLHookStruct ► mouseData

[Missing <summary> documentation for F:VisualCron.MouseLLHookStruct.mouseData]

Declaration Syntax
C# Visual Basic Visual C++
public int mouseData
Public mouseData As Integer
public:
int mouseData


pt Field

pt Field
Namespaces ► VisualCron ► MouseLLHookStruct ► pt

[Missing <summary> documentation for F:VisualCron.MouseLLHookStruct.pt]

Declaration Syntax
C# Visual Basic Visual C++
public Point pt
Public pt As Point
public:
Point pt

Send comments on this topic to Please email feedback to Support


time Field

time Field
Namespaces ► VisualCron ► MouseLLHookStruct ► time

[Missing <summary> documentation for F:VisualCron.MouseLLHookStruct.time]

Declaration Syntax
C# Visual Basic Visual C++
public int time
Public time As Integer
public:
int time


MouseMove Class

MouseMove Class
Namespaces ► VisualCron ► MouseMove
"Mouse Move" macro command
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MouseMove : Command
<SerializableAttribute> _
Public Class MouseMove _
    Inherits Command
[SerializableAttribute]
public ref class MouseMove : public Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MouseMove()()() | Initializes a new instance of the MouseMove class
 | Clone()()() | (Inherited from Command.)
 | Description | (Overrides Command.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromDestinationPoint(Point) |
 | GetDestinationPoint()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Items |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed) | (Overrides Command.TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed).)
Inheritance Hierarchy
Object
 | Command
 |  | MouseMove


MouseMove Constructor

MouseMove Constructor
Namespaces ► VisualCron ► MouseMove ► MouseMove()()()
Initializes a new instance of the MouseMove class
Declaration Syntax
C# Visual Basic Visual C++
public MouseMove()
Public Sub New
public:
MouseMove()


Description Property

Description Property
Namespaces ► VisualCron ► MouseMove ► Description

[Missing <summary> documentation for P:VisualCron.MouseMove.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


FromDestinationPoint Method (pt)

FromDestinationPoint Method (pt)
Namespaces ► VisualCron ► MouseMove ► FromDestinationPoint(Point)

[Missing <summary> documentation for M:VisualCron.MouseMove.FromDestinationPoint(System.Drawing.Point)]

Declaration Syntax
C# Visual Basic Visual C++
public void FromDestinationPoint(
    Point pt
)
Public Sub FromDestinationPoint ( _
    pt As Point _
)
public:
void FromDestinationPoint(
    Point pt
)
Parameters
pt (Point)

[Missing <param name="pt"/> documentation for "M:VisualCron.MouseMove.FromDestinationPoint(System.Drawing.Point)"]


GetDestinationPoint Method

GetDestinationPoint Method
Namespaces ► VisualCron ► MouseMove ► GetDestinationPoint()()()

[Missing <summary> documentation for M:VisualCron.MouseMove.GetDestinationPoint]

Declaration Syntax
C# Visual Basic Visual C++
public Point GetDestinationPoint()
Public Function GetDestinationPoint As Point
public:
Point GetDestinationPoint()
Return Value

[Missing <returns> documentation for M:VisualCron.MouseMove.GetDestinationPoint]


Items Property

Items Property
Namespaces ► VisualCron ► MouseMove ► Items

[Missing <summary> documentation for P:VisualCron.MouseMove.Items]

Declaration Syntax
C# Visual Basic Visual C++
public List<MouseMoveUnit> Items { get; set; }
Public Property Items As List(Of MouseMoveUnit)
public:
property List<MouseMoveUnit^>^ Items {
    List<MouseMoveUnit^>^ get ();
    void set (List<MouseMoveUnit^>^ value);
}


TranslateToInstructions Method (builder, speed)

TranslateToInstructions Method (builder, speed)
Namespaces ► VisualCron ► MouseMove ► TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed)

[Missing <summary> documentation for M:VisualCron.MouseMove.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)]

Declaration Syntax
C# Visual Basic Visual C++
public override void TranslateToInstructions(
    InstructionsBuilder builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
)
Public Overrides Sub TranslateToInstructions ( _
    builder As InstructionsBuilder, _
    speed As TaskDesktopMacroClass..::.MacroSpeed _
)
public:
virtual void TranslateToInstructions(
    InstructionsBuilder^ builder,
    TaskDesktopMacroClass..::.MacroSpeed speed
) override
Parameters
builder (InstructionsBuilder)

[Missing <param name="builder"/> documentation for "M:VisualCron.MouseMove.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]

speed (TaskDesktopMacroClass..::.MacroSpeed)

[Missing <param name="speed"/> documentation for "M:VisualCron.MouseMove.TranslateToInstructions(VisualCron.InstructionsBuilder,VisualCron.TaskDesktopMacroClass.MacroSpeed)"]


MouseMoveUnit Class

MouseMoveUnit Class
Namespaces ► VisualCron ► MouseMoveUnit

[Missing <summary> documentation for T:VisualCron.MouseMoveUnit]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MouseMoveUnit
<SerializableAttribute> _
Public Class MouseMoveUnit
[SerializableAttribute]
public ref class MouseMoveUnit
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MouseMoveUnit()()() | Initializes a new instance of the MouseMoveUnit class
 | Delay |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Point |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MouseMoveUnit

Send comments on this topic to Please email feedback to Support


MouseMoveUnit Constructor

MouseMoveUnit Constructor
Namespaces ► VisualCron ► MouseMoveUnit ► MouseMoveUnit()()()
Initializes a new instance of the MouseMoveUnit class
Declaration Syntax
C# Visual Basic Visual C++
public MouseMoveUnit()
Public Sub New
public:
MouseMoveUnit()


Delay Property

Delay Property
Namespaces ► VisualCron ► MouseMoveUnit ► Delay

[Missing <summary> documentation for P:VisualCron.MouseMoveUnit.Delay]

Declaration Syntax
C# Visual Basic Visual C++
public int Delay { get; set; }
Public Property Delay As Integer
public:
property int Delay {
    int get ();
    void set (int value);
}


Point Property

Point Property
Namespaces ► VisualCron ► MouseMoveUnit ► Point

[Missing <summary> documentation for P:VisualCron.MouseMoveUnit.Point]

Declaration Syntax
C# Visual Basic Visual C++
public Point Point { get; set; }
Public Property Point As Point
public:
property Point Point {
    Point get ();
    void set (Point value);
}


NetworkAddressChangedEventClass Class

NetworkAddressChangedEventClass Class
Namespaces ► VisualCron ► NetworkAddressChangedEventClass

[Missing <summary> documentation for T:VisualCron.NetworkAddressChangedEventClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkAddressChangedEventClass : ICloneable
<SerializableAttribute> _
Public Class NetworkAddressChangedEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class NetworkAddressChangedEventClass : ICloneable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetworkAddressChangedEventClass()()() | Initializes a new instance of the NetworkAddressChangedEventClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NetworkAddressChangedEventClass

Send comments on this topic to Please email feedback to Support


NetworkAddressChangedEventClass Constructor

NetworkAddressChangedEventClass Constructor
Namespaces ► VisualCron ► NetworkAddressChangedEventClass ► NetworkAddressChangedEventClass()()()
Initializes a new instance of the NetworkAddressChangedEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkAddressChangedEventClass()
Public Sub New
public:
NetworkAddressChangedEventClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► NetworkAddressChangedEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.NetworkAddressChangedEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.NetworkAddressChangedEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► NetworkAddressChangedEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.NetworkAddressChangedEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkAddressChangedEventClass CloneType()
Public Function CloneType As NetworkAddressChangedEventClass
public:
NetworkAddressChangedEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.NetworkAddressChangedEventClass.CloneType]


NetworkAvailabilityChangedEventClass Class

NetworkAvailabilityChangedEventClass Class
Namespaces ► VisualCron ► NetworkAvailabilityChangedEventClass

[Missing <summary> documentation for T:VisualCron.NetworkAvailabilityChangedEventClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkAvailabilityChangedEventClass : ICloneable
<SerializableAttribute> _
Public Class NetworkAvailabilityChangedEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class NetworkAvailabilityChangedEventClass : ICloneable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetworkAvailabilityChangedEventClass()()() | Initializes a new instance of the NetworkAvailabilityChangedEventClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NetworkAvailabilityChangedEventClass

Send comments on this topic to Please email feedback to Support


NetworkAvailabilityChangedEventClass Constructor

NetworkAvailabilityChangedEventClass Constructor
Namespaces ► VisualCron ► NetworkAvailabilityChangedEventClass ► NetworkAvailabilityChangedEventClass()()()
Initializes a new instance of the NetworkAvailabilityChangedEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkAvailabilityChangedEventClass()
Public Sub New
public:
NetworkAvailabilityChangedEventClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► NetworkAvailabilityChangedEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.NetworkAvailabilityChangedEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.NetworkAvailabilityChangedEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► NetworkAvailabilityChangedEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.NetworkAvailabilityChangedEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkAvailabilityChangedEventClass CloneType()
Public Function CloneType As NetworkAvailabilityChangedEventClass
public:
NetworkAvailabilityChangedEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.NetworkAvailabilityChangedEventClass.CloneType]


NetworkAvailabilityChangedTriggerResultClass Class

NetworkAvailabilityChangedTriggerResultClass Class
Namespaces ► VisualCron ► NetworkAvailabilityChangedTriggerResultClass

[Missing <summary> documentation for T:VisualCron.NetworkAvailabilityChangedTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkAvailabilityChangedTriggerResultClass
<SerializableAttribute> _
Public Class NetworkAvailabilityChangedTriggerResultClass
[SerializableAttribute]
public ref class NetworkAvailabilityChangedTriggerResultClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetworkAvailabilityChangedTriggerResultClass()()() | Initializes a new instance of the NetworkAvailabilityChangedTriggerResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NetworkAvailabilityChangedTriggerResultClass


NetworkAvailabilityChangedTriggerResultClass Constructor

NetworkAvailabilityChangedTriggerResultClass Constructor
Namespaces ► VisualCron ► NetworkAvailabilityChangedTriggerResultClass ► NetworkAvailabilityChangedTriggerResultClass()()()
Initializes a new instance of the NetworkAvailabilityChangedTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkAvailabilityChangedTriggerResultClass()
Public Sub New
public:
NetworkAvailabilityChangedTriggerResultClass()


NetworkCredentialClass Class

NetworkCredentialClass Class
Namespaces ► VisualCron ► NetworkCredentialClass
Contains information about a Credential
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkCredentialClass
<SerializableAttribute> _
Public Class NetworkCredentialClass
[SerializableAttribute]
public ref class NetworkCredentialClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkCredentialClass()()() | Initializes a new instance of the NetworkCredentialClass class
 | Domain | The domain/computer name of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Unique Id for a Credential (GUID)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord | The password of the Credential
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | The username of the Credential
Remarks
Inheritance Hierarchy
Object
NetworkCredentialClass

Send comments on this topic to Please email feedback to Support


NetworkCredentialClass Constructor

NetworkCredentialClass Constructor
Namespaces ► VisualCron ► NetworkCredentialClass ► NetworkCredentialClass()()()
Initializes a new instance of the NetworkCredentialClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialClass()
Public Sub New
public:
NetworkCredentialClass()


Domain Property

Domain Property
Namespaces ► VisualCron ► NetworkCredentialClass ► Domain
The domain/computer name of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Domain { get; set; }
Public Property Domain As Byte()
public:
property array<unsigned char>^ Domain {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Needs to be encrypted/decrypted

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► NetworkCredentialClass ► Id
Unique Id for a Credential (GUID)
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PassWord Property

PassWord Property
Namespaces ► VisualCron ► NetworkCredentialClass ► PassWord
The password of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public byte[] PassWord { get; set; }
Public Property PassWord As Byte()
public:
property array<unsigned char>^ PassWord {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Needs to be encrypted/decrypted

Send comments on this topic to Please email feedback to Support


UserName Property

UserName Property
Namespaces ► VisualCron ► NetworkCredentialClass ► UserName
The username of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public byte[] UserName { get; set; }
Public Property UserName As Byte()
public:
property array<unsigned char>^ UserName {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Needs to be encrypted/decrypted

Send comments on this topic to Please email feedback to Support


NetworkCredentialDeleteClass Class

NetworkCredentialDeleteClass Class
Namespaces ► VisualCron ► NetworkCredentialDeleteClass

[Missing <summary> documentation for T:VisualCron.NetworkCredentialDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkCredentialDeleteClass
<SerializableAttribute> _
Public Class NetworkCredentialDeleteClass
[SerializableAttribute]
public ref class NetworkCredentialDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkCredentialDeleteClass()()() | Initializes a new instance of the NetworkCredentialDeleteClass class
 | Deleted | Indicates if the Network Credential was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Network Credential that should be deleted
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NetworkCredentialDeleteClass

Send comments on this topic to Please email feedback to Support


NetworkCredentialDeleteClass Constructor

NetworkCredentialDeleteClass Constructor
Namespaces ► VisualCron ► NetworkCredentialDeleteClass ► NetworkCredentialDeleteClass()()()
Initializes a new instance of the NetworkCredentialDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialDeleteClass()
Public Sub New
public:
NetworkCredentialDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► NetworkCredentialDeleteClass ► Deleted
Indicates if the Network Credential was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► NetworkCredentialDeleteClass ► Id
Gets or sets the Id of the Network Credential that should be deleted
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredentialTestResultClass Class

NetworkCredentialTestResultClass Class
Namespaces ► VisualCron ► NetworkCredentialTestResultClass

[Missing <summary> documentation for T:VisualCron.NetworkCredentialTestResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkCredentialTestResultClass
<SerializableAttribute> _
Public Class NetworkCredentialTestResultClass
[SerializableAttribute]
public ref class NetworkCredentialTestResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkCredentialTestResultClass()()() | Initializes a new instance of the NetworkCredentialTestResultClass class
 | Credential | Either specify the Id (CredentialId) or send the full Credential object
 | CredentialId | The Id of the Credential that needs to be tested
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Success | True if VisualCron could login/impersonate with the given Credential
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NetworkCredentialTestResultClass

Send comments on this topic to Please email feedback to Support


NetworkCredentialTestResultClass Constructor

NetworkCredentialTestResultClass Constructor
Namespaces ► VisualCron ► NetworkCredentialTestResultClass ► NetworkCredentialTestResultClass()()()
Initializes a new instance of the NetworkCredentialTestResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialTestResultClass()
Public Sub New
public:
NetworkCredentialTestResultClass()


Credential Property

Credential Property
Namespaces ► VisualCron ► NetworkCredentialTestResultClass ► Credential
Either specify the Id (CredentialId) or send the full Credential object
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialClass Credential { get; set; }
Public Property Credential As NetworkCredentialClass
public:
property NetworkCredentialClass^ Credential {
    NetworkCredentialClass^ get ();
    void set (NetworkCredentialClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CredentialId Property

CredentialId Property
Namespaces ► VisualCron ► NetworkCredentialTestResultClass ► CredentialId
The Id of the Credential that needs to be tested
Declaration Syntax
C# Visual Basic Visual C++
public string CredentialId { get; set; }
Public Property CredentialId As String
public:
property String^ CredentialId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ErrorMessage Property

ErrorMessage Property
Namespaces ► VisualCron ► NetworkCredentialTestResultClass ► ErrorMessage

[Missing <summary> documentation for P:VisualCron.NetworkCredentialTestResultClass.ErrorMessage]

Declaration Syntax
C# Visual Basic Visual C++
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Success Property

Success Property
Namespaces ► VisualCron ► NetworkCredentialTestResultClass ► Success
True if VisualCron could login/impersonate with the given Credential
Declaration Syntax
C# Visual Basic Visual C++
public bool Success { get; set; }
Public Property Success As Boolean
public:
property bool Success {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkDriveClass Class

NetworkDriveClass Class
Namespaces ► VisualCron ► NetworkDriveClass
Information about a network drive
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkDriveClass
<SerializableAttribute> _
Public Class NetworkDriveClass
[SerializableAttribute]
public ref class NetworkDriveClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkDriveClass()()() | Initializes a new instance of the NetworkDriveClass class
 | Added | If the Drive was added on the server
 | Controlled |
 | Credential |
 | Drive |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path |
 | Status |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NetworkDriveClass

Send comments on this topic to Please email feedback to Support


NetworkDriveClass Constructor

NetworkDriveClass Constructor
Namespaces ► VisualCron ► NetworkDriveClass ► NetworkDriveClass()()()
Initializes a new instance of the NetworkDriveClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass()
Public Sub New
public:
NetworkDriveClass()


Added Property

Added Property
Namespaces ► VisualCron ► NetworkDriveClass ► Added
If the Drive was added on the server
Declaration Syntax
C# Visual Basic Visual C++
public bool Added { get; set; }
Public Property Added As Boolean
public:
property bool Added {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Controlled Property

Controlled Property
Namespaces ► VisualCron ► NetworkDriveClass ► Controlled

[Missing <summary> documentation for P:VisualCron.NetworkDriveClass.Controlled]

Declaration Syntax
C# Visual Basic Visual C++
public bool Controlled { get; set; }
Public Property Controlled As Boolean
public:
property bool Controlled {
    bool get ();
    void set (bool value);
}


Credential Property

Credential Property
Namespaces ► VisualCron ► NetworkDriveClass ► Credential

[Missing <summary> documentation for P:VisualCron.NetworkDriveClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


Drive Property

Drive Property
Namespaces ► VisualCron ► NetworkDriveClass ► Drive

[Missing <summary> documentation for P:VisualCron.NetworkDriveClass.Drive]

Declaration Syntax
C# Visual Basic Visual C++
public string Drive { get; set; }
Public Property Drive As String
public:
property String^ Drive {
    String^ get ();
    void set (String^ value);
}


Path Property

Path Property
Namespaces ► VisualCron ► NetworkDriveClass ► Path

[Missing <summary> documentation for P:VisualCron.NetworkDriveClass.Path]

Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; set; }
Public Property Path As String
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}


Status Field

Status Field
Namespaces ► VisualCron ► NetworkDriveClass ► Status

[Missing <summary> documentation for F:VisualCron.NetworkDriveClass.Status]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass..::.ConnStatus Status
Public Status As NetworkDriveClass..::.ConnStatus
public:
NetworkDriveClass..::.ConnStatus Status

Send comments on this topic to Please email feedback to Support


NetworkDriveClass.ConnStatus Enumeration

NetworkDriveClass..::.ConnStatus Enumeration
Namespaces ► VisualCron ► NetworkDriveClass ► NetworkDriveClass..::.ConnStatus

[Missing <summary> documentation for T:VisualCron.NetworkDriveClass.ConnStatus]

Declaration Syntax
C# Visual Basic Visual C++
public enum ConnStatus
Public Enumeration ConnStatus
public enum class ConnStatus
Members
Member | Description
Connected |
Disconnected |


NetworkDriveDeleteClass Class

NetworkDriveDeleteClass Class
Namespaces ► VisualCron ► NetworkDriveDeleteClass
A class that is used to delete a network drive
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkDriveDeleteClass
<SerializableAttribute> _
Public Class NetworkDriveDeleteClass
[SerializableAttribute]
public ref class NetworkDriveDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkDriveDeleteClass()()() | Initializes a new instance of the NetworkDriveDeleteClass class
 | Deleted | Indicates if the drive was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkDrive |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
NetworkDriveDeleteClass

Send comments on this topic to Please email feedback to Support


NetworkDriveDeleteClass Constructor

NetworkDriveDeleteClass Constructor
Namespaces ► VisualCron ► NetworkDriveDeleteClass ► NetworkDriveDeleteClass()()()
Initializes a new instance of the NetworkDriveDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveDeleteClass()
Public Sub New
public:
NetworkDriveDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► NetworkDriveDeleteClass ► Deleted
Indicates if the drive was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkDrive Property

NetworkDrive Property
Namespaces ► VisualCron ► NetworkDriveDeleteClass ► NetworkDrive

[Missing <summary> documentation for P:VisualCron.NetworkDriveDeleteClass.NetworkDrive]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass NetworkDrive { get; set; }
Public Property NetworkDrive As NetworkDriveClass
public:
property NetworkDriveClass^ NetworkDrive {
    NetworkDriveClass^ get ();
    void set (NetworkDriveClass^ value);
}


NetworkDriveMapClass Class

NetworkDriveMapClass Class
Namespaces ► VisualCron ► NetworkDriveMapClass

[Missing <summary> documentation for T:VisualCron.NetworkDriveMapClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NetworkDriveMapClass
<SerializableAttribute> _
Public Class NetworkDriveMapClass
[SerializableAttribute]
public ref class NetworkDriveMapClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkDriveMapClass()()() | Initializes a new instance of the NetworkDriveMapClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkDrive |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NetworkDriveMapClass

Send comments on this topic to Please email feedback to Support


NetworkDriveMapClass Constructor

NetworkDriveMapClass Constructor
Namespaces ► VisualCron ► NetworkDriveMapClass ► NetworkDriveMapClass()()()
Initializes a new instance of the NetworkDriveMapClass class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveMapClass()
Public Sub New
public:
NetworkDriveMapClass()


NetworkDrive Field

NetworkDrive Field
Namespaces ► VisualCron ► NetworkDriveMapClass ► NetworkDrive

[Missing <summary> documentation for F:VisualCron.NetworkDriveMapClass.NetworkDrive]

Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass NetworkDrive
Public NetworkDrive As NetworkDriveClass
public:
NetworkDriveClass^ NetworkDrive

Send comments on this topic to Please email feedback to Support


NotificationClass Class

NotificationClass Class
Namespaces ► VisualCron ► NotificationClass

[Missing <summary> documentation for T:VisualCron.NotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NotificationClass
<SerializableAttribute> _
Public Class NotificationClass
[SerializableAttribute]
public ref class NotificationClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationClass()()() | Initializes a new instance of the NotificationClass class
 | NotificationClass(NotificationClass..::.NType) | Initializes a new instance of the NotificationClass class
 | Description |
 | Email |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EvLog |
 | File |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | Init()()() | In editmode we construct all items and dispose the ones that are not used after. The reason for this is to save space when sending messages and storing messages.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential |
 | NotificationType |
 | Popup |
 | Sound |
 | SQL |
 | SysLog |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NotificationClass

Send comments on this topic to Please email feedback to Support


NotificationClass Constructor

NotificationClass Constructor
Namespaces ► VisualCron ► NotificationClass ► NotificationClass()()()
Members
Icon | Member | Description
 | NotificationClass()()() | Initializes a new instance of the NotificationClass class
 | NotificationClass(NotificationClass..::.NType) | Initializes a new instance of the NotificationClass class


NotificationClass Constructor

NotificationClass Constructor
Namespaces ► VisualCron ► NotificationClass ► NotificationClass()()()
Initializes a new instance of the NotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass()
Public Sub New
public:
NotificationClass()


NotificationClass Constructor (nt)

NotificationClass Constructor (nt)
Namespaces ► VisualCron ► NotificationClass ► NotificationClass(NotificationClass..::.NType)
Initializes a new instance of the NotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass(
    NotificationClass..::.NType nt
)
Public Sub New ( _
    nt As NotificationClass..::.NType _
)
public:
NotificationClass(
    NotificationClass..::.NType nt
)
Parameters
nt (NotificationClass..::.NType)

[Missing <param name="nt"/> documentation for "M:VisualCron.NotificationClass.#ctor(VisualCron.NotificationClass.NType)"]


Description Property

Description Property
Namespaces ► VisualCron ► NotificationClass ► Description

[Missing <summary> documentation for P:VisualCron.NotificationClass.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


Email Field

Email Field
Namespaces ► VisualCron ► NotificationClass ► Email

[Missing <summary> documentation for F:VisualCron.NotificationClass.Email]

Declaration Syntax
C# Visual Basic Visual C++
public EmailNotificationClass Email
Public Email As EmailNotificationClass
public:
EmailNotificationClass^ Email

Send comments on this topic to Please email feedback to Support


EvLog Field

EvLog Field
Namespaces ► VisualCron ► NotificationClass ► EvLog

[Missing <summary> documentation for F:VisualCron.NotificationClass.EvLog]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogNotificationClass EvLog
Public EvLog As EventLogNotificationClass
public:
EventLogNotificationClass^ EvLog

Send comments on this topic to Please email feedback to Support


File Field

File Field
Namespaces ► VisualCron ► NotificationClass ► File

[Missing <summary> documentation for F:VisualCron.NotificationClass.File]

Declaration Syntax
C# Visual Basic Visual C++
public FileNotificationClass File
Public File As FileNotificationClass
public:
FileNotificationClass^ File

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► NotificationClass ► Id

[Missing <summary> documentation for P:VisualCron.NotificationClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


Init Method

Init Method
Namespaces ► VisualCron ► NotificationClass ► Init()()()
In editmode we construct all items and dispose the ones that are not used after. The reason for this is to save space when sending messages and storing messages.
Declaration Syntax
C# Visual Basic Visual C++
public void Init()
Public Sub Init
public:
void Init()
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► NotificationClass ► NetworkCredential

[Missing <summary> documentation for P:VisualCron.NotificationClass.NetworkCredential]

Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}


NotificationType Property

NotificationType Property
Namespaces ► VisualCron ► NotificationClass ► NotificationType

[Missing <summary> documentation for P:VisualCron.NotificationClass.NotificationType]

Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass..::.NType NotificationType { get; set; }
Public Property NotificationType As NotificationClass..::.NType
public:
property NotificationClass..::.NType NotificationType {
    NotificationClass..::.NType get ();
    void set (NotificationClass..::.NType value);
}


Popup Field

Popup Field
Namespaces ► VisualCron ► NotificationClass ► Popup

[Missing <summary> documentation for F:VisualCron.NotificationClass.Popup]

Declaration Syntax
C# Visual Basic Visual C++
public PopupNotificationClass Popup
Public Popup As PopupNotificationClass
public:
PopupNotificationClass^ Popup

Send comments on this topic to Please email feedback to Support


Sound Field

Sound Field
Namespaces ► VisualCron ► NotificationClass ► Sound

[Missing <summary> documentation for F:VisualCron.NotificationClass.Sound]

Declaration Syntax
C# Visual Basic Visual C++
public SoundNotificationClass Sound
Public Sound As SoundNotificationClass
public:
SoundNotificationClass^ Sound

Send comments on this topic to Please email feedback to Support


SQL Field

SQL Field
Namespaces ► VisualCron ► NotificationClass ► SQL

[Missing <summary> documentation for F:VisualCron.NotificationClass.SQL]

Declaration Syntax
C# Visual Basic Visual C++
public SQLNotificationClass SQL
Public SQL As SQLNotificationClass
public:
SQLNotificationClass^ SQL

Send comments on this topic to Please email feedback to Support


SysLog Field

SysLog Field
Namespaces ► VisualCron ► NotificationClass ► SysLog

[Missing <summary> documentation for F:VisualCron.NotificationClass.SysLog]

Declaration Syntax
C# Visual Basic Visual C++
public SysLogNotificationClass SysLog
Public SysLog As SysLogNotificationClass
public:
SysLogNotificationClass^ SysLog

Send comments on this topic to Please email feedback to Support


NotificationClass.NType Enumeration

NotificationClass..::.NType Enumeration
Namespaces ► VisualCron ► NotificationClass ► NotificationClass..::.NType

[Missing <summary> documentation for T:VisualCron.NotificationClass.NType]

Declaration Syntax
C# Visual Basic Visual C++
public enum NType
Public Enumeration NType
public enum class NType
Members
Member | Description
Undefined |
EventLog |
Email |
SysLog |
Popup |
File |
NetSend |
Sound |
SQL |


NotificationDeleteClass Class

NotificationDeleteClass Class
Namespaces ► VisualCron ► NotificationDeleteClass

[Missing <summary> documentation for T:VisualCron.NotificationDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class NotificationDeleteClass
<SerializableAttribute> _
Public Class NotificationDeleteClass
[SerializableAttribute]
public ref class NotificationDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NotificationDeleteClass()()() | Initializes a new instance of the NotificationDeleteClass class
 | Deleted | Indicates if the Notification was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Notification that should be deleted
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NotificationDeleteClass

Send comments on this topic to Please email feedback to Support


NotificationDeleteClass Constructor

NotificationDeleteClass Constructor
Namespaces ► VisualCron ► NotificationDeleteClass ► NotificationDeleteClass()()()
Initializes a new instance of the NotificationDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public NotificationDeleteClass()
Public Sub New
public:
NotificationDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► NotificationDeleteClass ► Deleted
Indicates if the Notification was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► NotificationDeleteClass ► Id
Gets or sets the Id of the Notification that should be deleted
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OfficeMacroParameterClass Class

OfficeMacroParameterClass Class
Namespaces ► VisualCron ► OfficeMacroParameterClass
A class that is used in the Office Macro Task for supplying parameters
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class OfficeMacroParameterClass
<SerializableAttribute> _
Public Class OfficeMacroParameterClass
[SerializableAttribute]
public ref class OfficeMacroParameterClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OfficeMacroParameterClass()()() | Initializes a new instance of the OfficeMacroParameterClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type |
 | Value |
Remarks
Inheritance Hierarchy
Object
OfficeMacroParameterClass

Send comments on this topic to Please email feedback to Support


OfficeMacroParameterClass Constructor

OfficeMacroParameterClass Constructor
Namespaces ► VisualCron ► OfficeMacroParameterClass ► OfficeMacroParameterClass()()()
Initializes a new instance of the OfficeMacroParameterClass class
Declaration Syntax
C# Visual Basic Visual C++
public OfficeMacroParameterClass()
Public Sub New
public:
OfficeMacroParameterClass()


Id Property

Id Property
Namespaces ► VisualCron ► OfficeMacroParameterClass ► Id

[Missing <summary> documentation for P:VisualCron.OfficeMacroParameterClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


Type Property

Type Property
Namespaces ► VisualCron ► OfficeMacroParameterClass ► Type

[Missing <summary> documentation for P:VisualCron.OfficeMacroParameterClass.Type]

Declaration Syntax
C# Visual Basic Visual C++
public TypeCode Type { get; set; }
Public Property Type As TypeCode
public:
property TypeCode Type {
    TypeCode get ();
    void set (TypeCode value);
}


Value Property

Value Property
Namespaces ► VisualCron ► OfficeMacroParameterClass ► Value

[Missing <summary> documentation for P:VisualCron.OfficeMacroParameterClass.Value]

Declaration Syntax
C# Visual Basic Visual C++
public Object Value { get; set; }
Public Property Value As Object
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}


OnTaskErrorClass Class

OnTaskErrorClass Class
Namespaces ► VisualCron ► OnTaskErrorClass

[Missing <summary> documentation for T:VisualCron.OnTaskErrorClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class OnTaskErrorClass : ICloneable
<SerializableAttribute> _
Public Class OnTaskErrorClass _
    Implements ICloneable
[SerializableAttribute]
public ref class OnTaskErrorClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OnTaskErrorClass()()() | Initializes a new instance of the OnTaskErrorClass class
 | CausesError | Gets or sets what error should be considered as an error
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorAction | Gets or sets what VisualCron should do if Task fail due to error
 | ErrorList | Gets or sets the typ of errors that is affected by CausesError property
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetErrorsForTask(TaskClass..::.TaskT) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId | Gets or sets the Id of the Job that should be run if ErrorAction = RunJob
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minutes |
 | RaiseError(OnTaskErrorClass..::.ErrorT) |
 | RetryTimes | Gets or sets the number of times to retry the Task before stopping the Job when ErrorAction = RetryTask
 | RunFollowingTasks | Gets or sets if the Tasks in ErrorAction = GotoTask should be executed after specified Task or if just the specified Task should be executed
 | Seconds |
 | TaskId | Gets or sets the Id of the Task that should be run if ErrorAction = GotoTask
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
OnTaskErrorClass

Send comments on this topic to Please email feedback to Support


OnTaskErrorClass Constructor

OnTaskErrorClass Constructor
Namespaces ► VisualCron ► OnTaskErrorClass ► OnTaskErrorClass()()()
Initializes a new instance of the OnTaskErrorClass class
Declaration Syntax
C# Visual Basic Visual C++
public OnTaskErrorClass()
Public Sub New
public:
OnTaskErrorClass()


CausesError Property

CausesError Property
Namespaces ► VisualCron ► OnTaskErrorClass ► CausesError
Gets or sets what error should be considered as an error
Declaration Syntax
C# Visual Basic Visual C++
public OnTaskErrorClass..::.CausesErrorT CausesError { get; set; }
Public Property CausesError As OnTaskErrorClass..::.CausesErrorT
public:
property OnTaskErrorClass..::.CausesErrorT CausesError {
    OnTaskErrorClass..::.CausesErrorT get ();
    void set (OnTaskErrorClass..::.CausesErrorT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► OnTaskErrorClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.OnTaskErrorClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.OnTaskErrorClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► OnTaskErrorClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.OnTaskErrorClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public OnTaskErrorClass CloneType()
Public Function CloneType As OnTaskErrorClass
public:
OnTaskErrorClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.OnTaskErrorClass.CloneType]


ErrorAction Property

ErrorAction Property
Namespaces ► VisualCron ► OnTaskErrorClass ► ErrorAction
Gets or sets what VisualCron should do if Task fail due to error
Declaration Syntax
C# Visual Basic Visual C++
public OnTaskErrorClass..::.TaskErrorActionT ErrorAction { get; set; }
Public Property ErrorAction As OnTaskErrorClass..::.TaskErrorActionT
public:
property OnTaskErrorClass..::.TaskErrorActionT ErrorAction {
    OnTaskErrorClass..::.TaskErrorActionT get ();
    void set (OnTaskErrorClass..::.TaskErrorActionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ErrorList Property

ErrorList Property
Namespaces ► VisualCron ► OnTaskErrorClass ► ErrorList
Gets or sets the typ of errors that is affected by CausesError property
Declaration Syntax
C# Visual Basic Visual C++
public List<OnTaskErrorClass..::.ErrorT> ErrorList { get; set; }
Public Property ErrorList As List(Of OnTaskErrorClass..::.ErrorT)
public:
property List<OnTaskErrorClass..::.ErrorT>^ ErrorList {
    List<OnTaskErrorClass..::.ErrorT>^ get ();
    void set (List<OnTaskErrorClass..::.ErrorT>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


GetErrorsForTask Method (tt)

GetErrorsForTask Method (tt)
Namespaces ► VisualCron ► OnTaskErrorClass ► GetErrorsForTask(TaskClass..::.TaskT)

[Missing <summary> documentation for M:VisualCron.OnTaskErrorClass.GetErrorsForTask(VisualCron.TaskClass.TaskT)]

Declaration Syntax
C# Visual Basic Visual C++
public List<OnTaskErrorClass..::.ErrorT> GetErrorsForTask(
    TaskClass..::.TaskT tt
)
Public Function GetErrorsForTask ( _
    tt As TaskClass..::.TaskT _
) As List(Of OnTaskErrorClass..::.ErrorT)
public:
List<OnTaskErrorClass..::.ErrorT>^ GetErrorsForTask(
    TaskClass..::.TaskT tt
)
Parameters
tt (TaskClass..::.TaskT)

[Missing <param name="tt"/> documentation for "M:VisualCron.OnTaskErrorClass.GetErrorsForTask(VisualCron.TaskClass.TaskT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.OnTaskErrorClass.GetErrorsForTask(VisualCron.TaskClass.TaskT)]


JobId Property

JobId Property
Namespaces ► VisualCron ► OnTaskErrorClass ► JobId
Gets or sets the Id of the Job that should be run if ErrorAction = RunJob
Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Minutes Property

Minutes Property
Namespaces ► VisualCron ► OnTaskErrorClass ► Minutes

[Missing <summary> documentation for P:VisualCron.OnTaskErrorClass.Minutes]

Declaration Syntax
C# Visual Basic Visual C++
public int Minutes { get; set; }
Public Property Minutes As Integer
public:
property int Minutes {
    int get ();
    void set (int value);
}


RaiseError Method (et)

RaiseError Method (et)
Namespaces ► VisualCron ► OnTaskErrorClass ► RaiseError(OnTaskErrorClass..::.ErrorT)

[Missing <summary> documentation for M:VisualCron.OnTaskErrorClass.RaiseError(VisualCron.OnTaskErrorClass.ErrorT)]

Declaration Syntax
C# Visual Basic Visual C++
public bool RaiseError(
    OnTaskErrorClass..::.ErrorT et
)
Public Function RaiseError ( _
    et As OnTaskErrorClass..::.ErrorT _
) As Boolean
public:
bool RaiseError(
    OnTaskErrorClass..::.ErrorT et
)
Parameters
et (OnTaskErrorClass..::.ErrorT)

[Missing <param name="et"/> documentation for "M:VisualCron.OnTaskErrorClass.RaiseError(VisualCron.OnTaskErrorClass.ErrorT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.OnTaskErrorClass.RaiseError(VisualCron.OnTaskErrorClass.ErrorT)]


RetryTimes Property

RetryTimes Property
Namespaces ► VisualCron ► OnTaskErrorClass ► RetryTimes
Gets or sets the number of times to retry the Task before stopping the Job when ErrorAction = RetryTask
Declaration Syntax
C# Visual Basic Visual C++
public int RetryTimes { get; set; }
Public Property RetryTimes As Integer
public:
property int RetryTimes {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RunFollowingTasks Property

RunFollowingTasks Property
Namespaces ► VisualCron ► OnTaskErrorClass ► RunFollowingTasks
Gets or sets if the Tasks in ErrorAction = GotoTask should be executed after specified Task or if just the specified Task should be executed
Declaration Syntax
C# Visual Basic Visual C++
public bool RunFollowingTasks { get; set; }
Public Property RunFollowingTasks As Boolean
public:
property bool RunFollowingTasks {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Seconds Property

Seconds Property
Namespaces ► VisualCron ► OnTaskErrorClass ► Seconds

[Missing <summary> documentation for P:VisualCron.OnTaskErrorClass.Seconds]

Declaration Syntax
C# Visual Basic Visual C++
public int Seconds { get; set; }
Public Property Seconds As Integer
public:
property int Seconds {
    int get ();
    void set (int value);
}


TaskId Property

TaskId Property
Namespaces ► VisualCron ► OnTaskErrorClass ► TaskId
Gets or sets the Id of the Task that should be run if ErrorAction = GotoTask
Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OnTaskErrorClass.CausesErrorT Enumeration

OnTaskErrorClass..::.CausesErrorT Enumeration
Namespaces ► VisualCron ► OnTaskErrorClass ► OnTaskErrorClass..::.CausesErrorT

[Missing <summary> documentation for T:VisualCron.OnTaskErrorClass.CausesErrorT]

Declaration Syntax
C# Visual Basic Visual C++
public enum CausesErrorT
Public Enumeration CausesErrorT
public enum class CausesErrorT
Members
Member | Description
All |
Selected |
AllExceptSelected |


OnTaskErrorClass.ErrorT Enumeration

OnTaskErrorClass..::.ErrorT Enumeration
Namespaces ► VisualCron ► OnTaskErrorClass ► OnTaskErrorClass..::.ErrorT

[Missing <summary> documentation for T:VisualCron.OnTaskErrorClass.ErrorT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ErrorT
Public Enumeration ErrorT
public enum class ErrorT
Members
Member | Description
Unhandled |
TaskTimeout |
JobTimeout |
FileNotFound |
DirectoryNotFound |
DirectoryAlreadyExist |
PermissionDenied |
NoError |


OnTaskErrorClass.TaskErrorActionT Enumeration

OnTaskErrorClass..::.TaskErrorActionT Enumeration
Namespaces ► VisualCron ► OnTaskErrorClass ► OnTaskErrorClass..::.TaskErrorActionT

[Missing <summary> documentation for T:VisualCron.OnTaskErrorClass.TaskErrorActionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum TaskErrorActionT
Public Enumeration TaskErrorActionT
public enum class TaskErrorActionT
Members
Member | Description
ContinueNextTask |
StopJob |
RetryTask |
GotoTask |
RunJob |


OperativeSystemClass Class

OperativeSystemClass Class
Namespaces ► VisualCron ► OperativeSystemClass

[Missing <summary> documentation for T:VisualCron.OperativeSystemClass]

Declaration Syntax
C# Visual Basic Visual C++
public class OperativeSystemClass
Public Class OperativeSystemClass
public ref class OperativeSystemClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | OperativeSystemClass()()() | Initializes a new instance of the OperativeSystemClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
OperativeSystemClass

Send comments on this topic to Please email feedback to Support


OperativeSystemClass Constructor

OperativeSystemClass Constructor
Namespaces ► VisualCron ► OperativeSystemClass ► OperativeSystemClass()()()
Initializes a new instance of the OperativeSystemClass class
Declaration Syntax
C# Visual Basic Visual C++
public OperativeSystemClass()
Public Sub New
public:
OperativeSystemClass()


OperativeSystemInfoClass Class

OperativeSystemInfoClass Class
Namespaces ► VisualCron ► OperativeSystemInfoClass

[Missing <summary> documentation for T:VisualCron.OperativeSystemInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class OperativeSystemInfoClass
<SerializableAttribute> _
Public Class OperativeSystemInfoClass
[SerializableAttribute]
public ref class OperativeSystemInfoClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OperativeSystemInfoClass()()() | Initializes a new instance of the OperativeSystemInfoClass class
 | Architecture | 32 or 64 bit?
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | the name of the operative system
 | ServicePack | The service pack of the operating system
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
OperativeSystemInfoClass

Send comments on this topic to Please email feedback to Support


OperativeSystemInfoClass Constructor

OperativeSystemInfoClass Constructor
Namespaces ► VisualCron ► OperativeSystemInfoClass ► OperativeSystemInfoClass()()()
Initializes a new instance of the OperativeSystemInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public OperativeSystemInfoClass()
Public Sub New
public:
OperativeSystemInfoClass()


Architecture Property

Architecture Property
Namespaces ► VisualCron ► OperativeSystemInfoClass ► Architecture
32 or 64 bit?
Declaration Syntax
C# Visual Basic Visual C++
public string Architecture { get; set; }
Public Property Architecture As String
public:
property String^ Architecture {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► OperativeSystemInfoClass ► Name
the name of the operative system
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServicePack Property

ServicePack Property
Namespaces ► VisualCron ► OperativeSystemInfoClass ► ServicePack
The service pack of the operating system
Declaration Syntax
C# Visual Basic Visual C++
public string ServicePack { get; set; }
Public Property ServicePack As String
public:
property String^ ServicePack {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PageSettingsClass Class

PageSettingsClass Class
Namespaces ► VisualCron ► PageSettingsClass

[Missing <summary> documentation for T:VisualCron.PageSettingsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PageSettingsClass
<SerializableAttribute> _
Public Class PageSettingsClass
[SerializableAttribute]
public ref class PageSettingsClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PageSettingsClass()()() | Initializes a new instance of the PageSettingsClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageSettingsClass

Send comments on this topic to Please email feedback to Support


PageSettingsClass Constructor

PageSettingsClass Constructor
Namespaces ► VisualCron ► PageSettingsClass ► PageSettingsClass()()()
Initializes a new instance of the PageSettingsClass class
Declaration Syntax
C# Visual Basic Visual C++
public PageSettingsClass()
Public Sub New
public:
PageSettingsClass()


PageSettingsClass.PageSettings Class

PageSettingsClass..::.PageSettings Class
Namespaces ► VisualCron ► PageSettingsClass ► PageSettingsClass..::.PageSettings

[Missing <summary> documentation for T:VisualCron.PageSettingsClass.PageSettings]

Declaration Syntax
C# Visual Basic Visual C++
public class PageSettings
Public Class PageSettings
public ref class PageSettings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PageSettingsClass..::.PageSettings()()() | Initializes a new instance of the PageSettingsClass..::.PageSettings class
 | BlackAndWhite |
 | CustomSize |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaperMargin |
 | PaperOrientation |
 | PaperSize |
 | ResizeOption |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PageSettingsClass..::.PageSettings

Send comments on this topic to Please email feedback to Support


PageSettingsClass.PageSettings Constructor

PageSettingsClass..::.PageSettings Constructor
Namespaces ► VisualCron ► PageSettingsClass..::.PageSettings ► PageSettingsClass..::.PageSettings()()()
Initializes a new instance of the PageSettingsClass..::.PageSettings class
Declaration Syntax
C# Visual Basic Visual C++
public PageSettings()
Public Sub New
public:
PageSettings()


BlackAndWhite Property

BlackAndWhite Property
Namespaces ► VisualCron ► PageSettingsClass..::.PageSettings ► BlackAndWhite

[Missing <summary> documentation for P:VisualCron.PageSettingsClass.PageSettings.BlackAndWhite]

Declaration Syntax
C# Visual Basic Visual C++
public bool BlackAndWhite { get; set; }
Public Property BlackAndWhite As Boolean
public:
property bool BlackAndWhite {
    bool get ();
    void set (bool value);
}


CustomSize Property

CustomSize Property
Namespaces ► VisualCron ► PageSettingsClass..::.PageSettings ► CustomSize

[Missing <summary> documentation for P:VisualCron.PageSettingsClass.PageSettings.CustomSize]

Declaration Syntax
C# Visual Basic Visual C++
public short CustomSize { get; set; }
Public Property CustomSize As Short
public:
property short CustomSize {
    short get ();
    void set (short value);
}


PaperMargin Property

PaperMargin Property
Namespaces ► VisualCron ► PageSettingsClass..::.PageSettings ► PaperMargin

[Missing <summary> documentation for P:VisualCron.PageSettingsClass.PageSettings.PaperMargin]

Declaration Syntax
C# Visual Basic Visual C++
public MarginClass PaperMargin { get; set; }
Public Property PaperMargin As MarginClass
public:
property MarginClass^ PaperMargin {
    MarginClass^ get ();
    void set (MarginClass^ value);
}


PaperOrientation Property

PaperOrientation Property
Namespaces ► VisualCron ► PageSettingsClass..::.PageSettings ► PaperOrientation

[Missing <summary> documentation for P:VisualCron.PageSettingsClass.PageSettings.PaperOrientation]

Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass..::.EnmOrientation PaperOrientation { get; set; }
Public Property PaperOrientation As PrinterSettingsClass..::.EnmOrientation
public:
property PrinterSettingsClass..::.EnmOrientation PaperOrientation {
    PrinterSettingsClass..::.EnmOrientation get ();
    void set (PrinterSettingsClass..::.EnmOrientation value);
}


PaperSize Property

PaperSize Property
Namespaces ► VisualCron ► PageSettingsClass..::.PageSettings ► PaperSize

[Missing <summary> documentation for P:VisualCron.PageSettingsClass.PageSettings.PaperSize]

Declaration Syntax
C# Visual Basic Visual C++
public PaperSizeClass PaperSize { get; set; }
Public Property PaperSize As PaperSizeClass
public:
property PaperSizeClass^ PaperSize {
    PaperSizeClass^ get ();
    void set (PaperSizeClass^ value);
}


ResizeOption Property

ResizeOption Property
Namespaces ► VisualCron ► PageSettingsClass..::.PageSettings ► ResizeOption

[Missing <summary> documentation for P:VisualCron.PageSettingsClass.PageSettings.ResizeOption]

Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass..::.EnmResizeOption ResizeOption { get; set; }
Public Property ResizeOption As PrinterSettingsClass..::.EnmResizeOption
public:
property PrinterSettingsClass..::.EnmResizeOption ResizeOption {
    PrinterSettingsClass..::.EnmResizeOption get ();
    void set (PrinterSettingsClass..::.EnmResizeOption value);
}


PaperSizeClass Class

PaperSizeClass Class
Namespaces ► VisualCron ► PaperSizeClass
This class is paritally implemented and rest is left as a place holder. This holds PaperSettings for a document to be printed.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PaperSizeClass
<SerializableAttribute> _
Public Class PaperSizeClass
[SerializableAttribute]
public ref class PaperSizeClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PaperSizeClass()()() | Initializes a new instance of the PaperSizeClass class
 | PaperSizeClass(PrinterSettingsClass..::.EnmPaperKind, Double, Double) | Initializes a new instance of the PaperSizeClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PaperKind |
 | SetValues(PrinterSettingsClass..::.EnmPaperKind, Double, Double) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
As of now, with this version only the blank constructor is being used.
Inheritance Hierarchy
Object
PaperSizeClass

Send comments on this topic to Please email feedback to Support


PaperSizeClass Constructor

PaperSizeClass Constructor
Namespaces ► VisualCron ► PaperSizeClass ► PaperSizeClass()()()
Members
Icon | Member | Description
 | PaperSizeClass()()() | Initializes a new instance of the PaperSizeClass class
 | PaperSizeClass(PrinterSettingsClass..::.EnmPaperKind, Double, Double) | Initializes a new instance of the PaperSizeClass class


PaperSizeClass Constructor

PaperSizeClass Constructor
Namespaces ► VisualCron ► PaperSizeClass ► PaperSizeClass()()()
Initializes a new instance of the PaperSizeClass class
Declaration Syntax
C# Visual Basic Visual C++
public PaperSizeClass()
Public Sub New
public:
PaperSizeClass()


PaperSizeClass Constructor (paperKind, width, height)

PaperSizeClass Constructor (paperKind, width, height)
Namespaces ► VisualCron ► PaperSizeClass ► PaperSizeClass(PrinterSettingsClass..::.EnmPaperKind, Double, Double)
Initializes a new instance of the PaperSizeClass class
Declaration Syntax
C# Visual Basic Visual C++
public PaperSizeClass(
    PrinterSettingsClass..::.EnmPaperKind paperKind,
    double width,
    double height
)
Public Sub New ( _
    paperKind As PrinterSettingsClass..::.EnmPaperKind, _
    width As Double, _
    height As Double _
)
public:
PaperSizeClass(
    PrinterSettingsClass..::.EnmPaperKind paperKind,
    double width,
    double height
)
Parameters
paperKind (PrinterSettingsClass..::.EnmPaperKind)

[Missing <param name="paperKind"/> documentation for "M:VisualCron.PaperSizeClass.#ctor(VisualCron.PrinterSettingsClass.EnmPaperKind,System.Double,System.Double)"]

width (Double)

[Missing <param name="width"/> documentation for "M:VisualCron.PaperSizeClass.#ctor(VisualCron.PrinterSettingsClass.EnmPaperKind,System.Double,System.Double)"]

height (Double)

[Missing <param name="height"/> documentation for "M:VisualCron.PaperSizeClass.#ctor(VisualCron.PrinterSettingsClass.EnmPaperKind,System.Double,System.Double)"]


PaperKind Property

PaperKind Property
Namespaces ► VisualCron ► PaperSizeClass ► PaperKind

[Missing <summary> documentation for P:VisualCron.PaperSizeClass.PaperKind]

Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass..::.EnmPaperKind PaperKind { get; set; }
Public Property PaperKind As PrinterSettingsClass..::.EnmPaperKind
public:
property PrinterSettingsClass..::.EnmPaperKind PaperKind {
    PrinterSettingsClass..::.EnmPaperKind get ();
    void set (PrinterSettingsClass..::.EnmPaperKind value);
}


SetValues Method (paperKind, width, height)

SetValues Method (paperKind, width, height)
Namespaces ► VisualCron ► PaperSizeClass ► SetValues(PrinterSettingsClass..::.EnmPaperKind, Double, Double)

[Missing <summary> documentation for M:VisualCron.PaperSizeClass.SetValues(VisualCron.PrinterSettingsClass.EnmPaperKind,System.Double,System.Double)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetValues(
    PrinterSettingsClass..::.EnmPaperKind paperKind,
    double width,
    double height
)
Public Sub SetValues ( _
    paperKind As PrinterSettingsClass..::.EnmPaperKind, _
    width As Double, _
    height As Double _
)
public:
void SetValues(
    PrinterSettingsClass..::.EnmPaperKind paperKind,
    double width,
    double height
)
Parameters
paperKind (PrinterSettingsClass..::.EnmPaperKind)

[Missing <param name="paperKind"/> documentation for "M:VisualCron.PaperSizeClass.SetValues(VisualCron.PrinterSettingsClass.EnmPaperKind,System.Double,System.Double)"]

width (Double)

[Missing <param name="width"/> documentation for "M:VisualCron.PaperSizeClass.SetValues(VisualCron.PrinterSettingsClass.EnmPaperKind,System.Double,System.Double)"]

height (Double)

[Missing <param name="height"/> documentation for "M:VisualCron.PaperSizeClass.SetValues(VisualCron.PrinterSettingsClass.EnmPaperKind,System.Double,System.Double)"]


PerformanceCounterEventClass Class

PerformanceCounterEventClass Class
Namespaces ► VisualCron ► PerformanceCounterEventClass

[Missing <summary> documentation for T:VisualCron.PerformanceCounterEventClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PerformanceCounterEventClass : ICloneable
<SerializableAttribute> _
Public Class PerformanceCounterEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class PerformanceCounterEventClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PerformanceCounterEventClass()()() | Initializes a new instance of the PerformanceCounterEventClass class
 | Category |
 | Clone()()() |
 | Condition |
 | Counter |
 | Credential |
 | DurationHours |
 | DurationMinutes |
 | DurationSeconds |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Host |
 | Instance |
 | IsAverage |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
Inheritance Hierarchy
Object
PerformanceCounterEventClass

Send comments on this topic to Please email feedback to Support


PerformanceCounterEventClass Constructor

PerformanceCounterEventClass Constructor
Namespaces ► VisualCron ► PerformanceCounterEventClass ► PerformanceCounterEventClass()()()
Initializes a new instance of the PerformanceCounterEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public PerformanceCounterEventClass()
Public Sub New
public:
PerformanceCounterEventClass()


Category Property

Category Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Category

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.Category]

Declaration Syntax
C# Visual Basic Visual C++
public string Category { get; set; }
Public Property Category As String
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.PerformanceCounterEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.PerformanceCounterEventClass.Clone]


Condition Property

Condition Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Condition

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.Condition]

Declaration Syntax
C# Visual Basic Visual C++
public PFConditionType Condition { get; set; }
Public Property Condition As PFConditionType
public:
property PFConditionType Condition {
    PFConditionType get ();
    void set (PFConditionType value);
}


Counter Property

Counter Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Counter

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.Counter]

Declaration Syntax
C# Visual Basic Visual C++
public string Counter { get; set; }
Public Property Counter As String
public:
property String^ Counter {
    String^ get ();
    void set (String^ value);
}


Credential Property

Credential Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Credential

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


DurationHours Property

DurationHours Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► DurationHours

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.DurationHours]

Declaration Syntax
C# Visual Basic Visual C++
public int DurationHours { get; set; }
Public Property DurationHours As Integer
public:
property int DurationHours {
    int get ();
    void set (int value);
}


DurationMinutes Property

DurationMinutes Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► DurationMinutes

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.DurationMinutes]

Declaration Syntax
C# Visual Basic Visual C++
public int DurationMinutes { get; set; }
Public Property DurationMinutes As Integer
public:
property int DurationMinutes {
    int get ();
    void set (int value);
}


DurationSeconds Property

DurationSeconds Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► DurationSeconds

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.DurationSeconds]

Declaration Syntax
C# Visual Basic Visual C++
public int DurationSeconds { get; set; }
Public Property DurationSeconds As Integer
public:
property int DurationSeconds {
    int get ();
    void set (int value);
}


Host Property

Host Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Host

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.Host]

Declaration Syntax
C# Visual Basic Visual C++
public string Host { get; set; }
Public Property Host As String
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}


Instance Property

Instance Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Instance

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.Instance]

Declaration Syntax
C# Visual Basic Visual C++
public string Instance { get; set; }
Public Property Instance As String
public:
property String^ Instance {
    String^ get ();
    void set (String^ value);
}


IsAverage Property

IsAverage Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► IsAverage

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.IsAverage]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsAverage { get; set; }
Public Property IsAverage As Boolean
public:
property bool IsAverage {
    bool get ();
    void set (bool value);
}


Value Property

Value Property
Namespaces ► VisualCron ► PerformanceCounterEventClass ► Value

[Missing <summary> documentation for P:VisualCron.PerformanceCounterEventClass.Value]

Declaration Syntax
C# Visual Basic Visual C++
public double Value { get; set; }
Public Property Value As Double
public:
property double Value {
    double get ();
    void set (double value);
}


PFConditionType Enumeration

PFConditionType Enumeration
Namespaces ► VisualCron ► PFConditionType

[Missing <summary> documentation for T:VisualCron.PFConditionType]

Declaration Syntax
C# Visual Basic Visual C++
public enum PFConditionType
Public Enumeration PFConditionType
public enum class PFConditionType
Members
Member | Description
Greater |
GreaterOrEqual |
Less |
LessOrEqual |
Equal |


PGPKeyRingClass Class

PGPKeyRingClass Class
Namespaces ► VisualCron ► PGPKeyRingClass

[Missing <summary> documentation for T:VisualCron.PGPKeyRingClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PGPKeyRingClass
<SerializableAttribute> _
Public Class PGPKeyRingClass
[SerializableAttribute]
public ref class PGPKeyRingClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PGPKeyRingClass()()() | Initializes a new instance of the PGPKeyRingClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PrivateKeys |
 | PublicKeys |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PGPKeyRingClass

Send comments on this topic to Please email feedback to Support


PGPKeyRingClass Constructor

PGPKeyRingClass Constructor
Namespaces ► VisualCron ► PGPKeyRingClass ► PGPKeyRingClass()()()
Initializes a new instance of the PGPKeyRingClass class
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingClass()
Public Sub New
public:
PGPKeyRingClass()


Id Property

Id Property
Namespaces ► VisualCron ► PGPKeyRingClass ► Id

[Missing <summary> documentation for P:VisualCron.PGPKeyRingClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► VisualCron ► PGPKeyRingClass ► Name

[Missing <summary> documentation for P:VisualCron.PGPKeyRingClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


PrivateKeys Property

PrivateKeys Property
Namespaces ► VisualCron ► PGPKeyRingClass ► PrivateKeys

[Missing <summary> documentation for P:VisualCron.PGPKeyRingClass.PrivateKeys]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] PrivateKeys { get; set; }
Public Property PrivateKeys As Byte()
public:
property array<unsigned char>^ PrivateKeys {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


PublicKeys Property

PublicKeys Property
Namespaces ► VisualCron ► PGPKeyRingClass ► PublicKeys

[Missing <summary> documentation for P:VisualCron.PGPKeyRingClass.PublicKeys]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] PublicKeys { get; set; }
Public Property PublicKeys As Byte()
public:
property array<unsigned char>^ PublicKeys {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


PGPKeyRingDeleteClass Class

PGPKeyRingDeleteClass Class
Namespaces ► VisualCron ► PGPKeyRingDeleteClass

[Missing <summary> documentation for T:VisualCron.PGPKeyRingDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PGPKeyRingDeleteClass
<SerializableAttribute> _
Public Class PGPKeyRingDeleteClass
[SerializableAttribute]
public ref class PGPKeyRingDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PGPKeyRingDeleteClass()()() | Initializes a new instance of the PGPKeyRingDeleteClass class
 | Deleted | Indicates if the PGP Key Ring was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PGPKeyRingDeleteClass

Send comments on this topic to Please email feedback to Support


PGPKeyRingDeleteClass Constructor

PGPKeyRingDeleteClass Constructor
Namespaces ► VisualCron ► PGPKeyRingDeleteClass ► PGPKeyRingDeleteClass()()()
Initializes a new instance of the PGPKeyRingDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingDeleteClass()
Public Sub New
public:
PGPKeyRingDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► PGPKeyRingDeleteClass ► Deleted
Indicates if the PGP Key Ring was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► PGPKeyRingDeleteClass ► Id

[Missing <summary> documentation for P:VisualCron.PGPKeyRingDeleteClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


PGPUserItemClass Class

PGPUserItemClass Class
Namespaces ► VisualCron ► PGPUserItemClass
A class that is used in lists of Signers and Recipients to identify a certain user that belongs to a certain list.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PGPUserItemClass : ICloneable
<SerializableAttribute> _
Public Class PGPUserItemClass _
    Implements ICloneable
[SerializableAttribute]
public ref class PGPUserItemClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PGPUserItemClass()()() | Initializes a new instance of the PGPUserItemClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyId | Gets or sets the Id of the user key
 | KeyRingId | Gets or sets the Id of the VisualCron key ring
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
PGPUserItemClass

Send comments on this topic to Please email feedback to Support


PGPUserItemClass Constructor

PGPUserItemClass Constructor
Namespaces ► VisualCron ► PGPUserItemClass ► PGPUserItemClass()()()
Initializes a new instance of the PGPUserItemClass class
Declaration Syntax
C# Visual Basic Visual C++
public PGPUserItemClass()
Public Sub New
public:
PGPUserItemClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► PGPUserItemClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.PGPUserItemClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.PGPUserItemClass.Clone]


KeyId Property

KeyId Property
Namespaces ► VisualCron ► PGPUserItemClass ► KeyId
Gets or sets the Id of the user key
Declaration Syntax
C# Visual Basic Visual C++
public string KeyId { get; set; }
Public Property KeyId As String
public:
property String^ KeyId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


KeyRingId Property

KeyRingId Property
Namespaces ► VisualCron ► PGPUserItemClass ► KeyRingId
Gets or sets the Id of the VisualCron key ring
Declaration Syntax
C# Visual Basic Visual C++
public string KeyRingId { get; set; }
Public Property KeyRingId As String
public:
property String^ KeyRingId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PingClass Class

PingClass Class
Namespaces ► VisualCron ► PingClass

[Missing <summary> documentation for T:VisualCron.PingClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PingClass
<SerializableAttribute> _
Public Class PingClass
[SerializableAttribute]
public ref class PingClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PingClass()()() | Initializes a new instance of the PingClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PingClass

Send comments on this topic to Please email feedback to Support


PingClass Constructor

PingClass Constructor
Namespaces ► VisualCron ► PingClass ► PingClass()()()
Initializes a new instance of the PingClass class
Declaration Syntax
C# Visual Basic Visual C++
public PingClass()
Public Sub New
public:
PingClass()


PingClass.EnumPingResult Enumeration

PingClass..::.EnumPingResult Enumeration
Namespaces ► VisualCron ► PingClass ► PingClass..::.EnumPingResult

[Missing <summary> documentation for T:VisualCron.PingClass.EnumPingResult]

Declaration Syntax
C# Visual Basic Visual C++
public enum EnumPingResult
Public Enumeration EnumPingResult
public enum class EnumPingResult
Members
Member | Description
OK |
Failed |


PlayerInstruction Class

PlayerInstruction Class
Namespaces ► VisualCron ► PlayerInstruction
A low-level action that can be executed by the UniversalPlayer.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class PlayerInstruction
Public MustInherit Class PlayerInstruction
public ref class PlayerInstruction abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PlayerInstruction()()() | Initializes a new instance of the PlayerInstruction class
 | Delay |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(IDictionary) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PlayerInstruction
 |  | MouseClickInstruction
 |  | RestoreWindowInstruction
 |  | SendInputInstruction


PlayerInstruction Constructor

PlayerInstruction Constructor
Namespaces ► VisualCron ► PlayerInstruction ► PlayerInstruction()()()
Initializes a new instance of the PlayerInstruction class
Declaration Syntax
C# Visual Basic Visual C++
public PlayerInstruction()
Public Sub New
public:
PlayerInstruction()


Delay Property

Delay Property
Namespaces ► VisualCron ► PlayerInstruction ► Delay

[Missing <summary> documentation for P:VisualCron.PlayerInstruction.Delay]

Declaration Syntax
C# Visual Basic Visual C++
public int Delay { get; set; }
Public Property Delay As Integer
public:
property int Delay {
    int get ();
    void set (int value);
}


Execute Method (context)

Execute Method (context)
Namespaces ► VisualCron ► PlayerInstruction ► Execute(IDictionary)

[Missing <summary> documentation for M:VisualCron.PlayerInstruction.Execute(System.Collections.IDictionary)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract void Execute(
    IDictionary context
)
Public MustOverride Sub Execute ( _
    context As IDictionary _
)
public:
virtual void Execute(
    IDictionary^ context
) abstract
Parameters
context (IDictionary)

[Missing <param name="context"/> documentation for "M:VisualCron.PlayerInstruction.Execute(System.Collections.IDictionary)"]


POINT32 Structure

POINT32 Structure
Namespaces ► VisualCron ► POINT32

[Missing <summary> documentation for T:VisualCron.POINT32]

Declaration Syntax
C# Visual Basic Visual C++
public struct POINT32
Public Structure POINT32
public value class POINT32
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | x |
 | y |


x Field

x Field
Namespaces ► VisualCron ► POINT32 ► x

[Missing <summary> documentation for F:VisualCron.POINT32.x]

Declaration Syntax
C# Visual Basic Visual C++
public int x
Public x As Integer
public:
int x


y Field

y Field
Namespaces ► VisualCron ► POINT32 ► y

[Missing <summary> documentation for F:VisualCron.POINT32.y]

Declaration Syntax
C# Visual Basic Visual C++
public int y
Public y As Integer
public:
int y


POINTSTRUCT Structure

POINTSTRUCT Structure
Namespaces ► VisualCron ► POINTSTRUCT

[Missing <summary> documentation for T:VisualCron.POINTSTRUCT]

Declaration Syntax
C# Visual Basic Visual C++
public struct POINTSTRUCT
Public Structure POINTSTRUCT
public value class POINTSTRUCT
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | POINTSTRUCT(Int32, Int32) | Initializes a new instance of the POINTSTRUCT class
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
 | x |
 | y |


POINTSTRUCT Constructor (x, y)

POINTSTRUCT Constructor (x, y)
Namespaces ► VisualCron ► POINTSTRUCT ► POINTSTRUCT(Int32, Int32)
Initializes a new instance of the POINTSTRUCT class
Declaration Syntax
C# Visual Basic Visual C++
public POINTSTRUCT(
    int x,
    int y
)
Public Sub New ( _
    x As Integer, _
    y As Integer _
)
public:
POINTSTRUCT(
    int x,
    int y
)
Parameters
x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.POINTSTRUCT.#ctor(System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.POINTSTRUCT.#ctor(System.Int32,System.Int32)"]


x Field

x Field
Namespaces ► VisualCron ► POINTSTRUCT ► x

[Missing <summary> documentation for F:VisualCron.POINTSTRUCT.x]

Declaration Syntax
C# Visual Basic Visual C++
public int x
Public x As Integer
public:
int x


y Field

y Field
Namespaces ► VisualCron ► POINTSTRUCT ► y

[Missing <summary> documentation for F:VisualCron.POINTSTRUCT.y]

Declaration Syntax
C# Visual Basic Visual C++
public int y
Public y As Integer
public:
int y


PopupNotificationClass Class

PopupNotificationClass Class
Namespaces ► VisualCron ► PopupNotificationClass

[Missing <summary> documentation for T:VisualCron.PopupNotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PopupNotificationClass
<SerializableAttribute> _
Public Class PopupNotificationClass
[SerializableAttribute]
public ref class PopupNotificationClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PopupNotificationClass()()() | Initializes a new instance of the PopupNotificationClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FlashWindow |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PopupNotificationClass

Send comments on this topic to Please email feedback to Support


PopupNotificationClass Constructor

PopupNotificationClass Constructor
Namespaces ► VisualCron ► PopupNotificationClass ► PopupNotificationClass()()()
Initializes a new instance of the PopupNotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public PopupNotificationClass()
Public Sub New
public:
PopupNotificationClass()


FlashWindow Property

FlashWindow Property
Namespaces ► VisualCron ► PopupNotificationClass ► FlashWindow

[Missing <summary> documentation for P:VisualCron.PopupNotificationClass.FlashWindow]

Declaration Syntax
C# Visual Basic Visual C++
public bool FlashWindow { get; set; }
Public Property FlashWindow As Boolean
public:
property bool FlashWindow {
    bool get ();
    void set (bool value);
}


Message Property

Message Property
Namespaces ► VisualCron ► PopupNotificationClass ► Message

[Missing <summary> documentation for P:VisualCron.PopupNotificationClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


PrintersClass Class

PrintersClass Class
Namespaces ► VisualCron ► PrintersClass

[Missing <summary> documentation for T:VisualCron.PrintersClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PrintersClass
<SerializableAttribute> _
Public Class PrintersClass
[SerializableAttribute]
public ref class PrintersClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PrintersClass()()() | Initializes a new instance of the PrintersClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Names |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PrintersClass

Send comments on this topic to Please email feedback to Support


PrintersClass Constructor

PrintersClass Constructor
Namespaces ► VisualCron ► PrintersClass ► PrintersClass()()()
Initializes a new instance of the PrintersClass class
Declaration Syntax
C# Visual Basic Visual C++
public PrintersClass()
Public Sub New
public:
PrintersClass()


Names Field

Names Field
Namespaces ► VisualCron ► PrintersClass ► Names

[Missing <summary> documentation for F:VisualCron.PrintersClass.Names]

Declaration Syntax
C# Visual Basic Visual C++
public List<string> Names
Public Names As List(Of String)
public:
List<String^>^ Names

Send comments on this topic to Please email feedback to Support


PrinterSettingsClass Class

PrinterSettingsClass Class
Namespaces ► VisualCron ► PrinterSettingsClass

[Missing <summary> documentation for T:VisualCron.PrinterSettingsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PrinterSettingsClass
<SerializableAttribute> _
Public Class PrinterSettingsClass
[SerializableAttribute]
public ref class PrinterSettingsClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PrinterSettingsClass(Boolean, PageSettingsClass..::.PageSettings, PrinterSettingsClass..::.EnmPrintRange, Int16, Int16, String) | Initializes a new instance of the PrinterSettingsClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromPage |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoOfCopies |
 | PageSettings |
 | PrintRange |
 | SelectedPages |
 | SelectedPrinter |
 | ToPage |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseDefaultSettings |
Inheritance Hierarchy
Object
PrinterSettingsClass

Send comments on this topic to Please email feedback to Support


PrinterSettingsClass Constructor (useDefaultSettings, pageSettings, printRange, fromPage, toPage, selectedPages)

PrinterSettingsClass Constructor (useDefaultSettings, pageSettings, printRange, fromPage, toPage, selectedPages)
Namespaces ► VisualCron ► PrinterSettingsClass ► PrinterSettingsClass(Boolean, PageSettingsClass..::.PageSettings, PrinterSettingsClass..::.EnmPrintRange, Int16, Int16, String)
Initializes a new instance of the PrinterSettingsClass class
Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass(
    bool useDefaultSettings,
    PageSettingsClass..::.PageSettings pageSettings,
    PrinterSettingsClass..::.EnmPrintRange printRange,
    short fromPage,
    short toPage,
    string selectedPages
)
Public Sub New ( _
    useDefaultSettings As Boolean, _
    pageSettings As PageSettingsClass..::.PageSettings, _
    printRange As PrinterSettingsClass..::.EnmPrintRange, _
    fromPage As Short, _
    toPage As Short, _
    selectedPages As String _
)
public:
PrinterSettingsClass(
    bool useDefaultSettings,
    PageSettingsClass..::.PageSettings^ pageSettings,
    PrinterSettingsClass..::.EnmPrintRange printRange,
    short fromPage,
    short toPage,
    String^ selectedPages
)
Parameters
useDefaultSettings (Boolean)

[Missing <param name="useDefaultSettings"/> documentation for "M:VisualCron.PrinterSettingsClass.#ctor(System.Boolean,VisualCron.PageSettingsClass.PageSettings,VisualCron.PrinterSettingsClass.EnmPrintRange,System.Int16,System.Int16,System.String)"]

pageSettings (PageSettingsClass..::.PageSettings)

[Missing <param name="pageSettings"/> documentation for "M:VisualCron.PrinterSettingsClass.#ctor(System.Boolean,VisualCron.PageSettingsClass.PageSettings,VisualCron.PrinterSettingsClass.EnmPrintRange,System.Int16,System.Int16,System.String)"]

printRange (PrinterSettingsClass..::.EnmPrintRange)

[Missing <param name="printRange"/> documentation for "M:VisualCron.PrinterSettingsClass.#ctor(System.Boolean,VisualCron.PageSettingsClass.PageSettings,VisualCron.PrinterSettingsClass.EnmPrintRange,System.Int16,System.Int16,System.String)"]

fromPage (Int16)

[Missing <param name="fromPage"/> documentation for "M:VisualCron.PrinterSettingsClass.#ctor(System.Boolean,VisualCron.PageSettingsClass.PageSettings,VisualCron.PrinterSettingsClass.EnmPrintRange,System.Int16,System.Int16,System.String)"]

toPage (Int16)

[Missing <param name="toPage"/> documentation for "M:VisualCron.PrinterSettingsClass.#ctor(System.Boolean,VisualCron.PageSettingsClass.PageSettings,VisualCron.PrinterSettingsClass.EnmPrintRange,System.Int16,System.Int16,System.String)"]

selectedPages (String)

[Missing <param name="selectedPages"/> documentation for "M:VisualCron.PrinterSettingsClass.#ctor(System.Boolean,VisualCron.PageSettingsClass.PageSettings,VisualCron.PrinterSettingsClass.EnmPrintRange,System.Int16,System.Int16,System.String)"]


FromPage Property

FromPage Property
Namespaces ► VisualCron ► PrinterSettingsClass ► FromPage

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.FromPage]

Declaration Syntax
C# Visual Basic Visual C++
public short FromPage { get; set; }
Public Property FromPage As Short
public:
property short FromPage {
    short get ();
    void set (short value);
}


NoOfCopies Property

NoOfCopies Property
Namespaces ► VisualCron ► PrinterSettingsClass ► NoOfCopies

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.NoOfCopies]

Declaration Syntax
C# Visual Basic Visual C++
public short NoOfCopies { get; set; }
Public Property NoOfCopies As Short
public:
property short NoOfCopies {
    short get ();
    void set (short value);
}


PageSettings Property

PageSettings Property
Namespaces ► VisualCron ► PrinterSettingsClass ► PageSettings

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.PageSettings]

Declaration Syntax
C# Visual Basic Visual C++
public PageSettingsClass..::.PageSettings PageSettings { get; set; }
Public Property PageSettings As PageSettingsClass..::.PageSettings
public:
property PageSettingsClass..::.PageSettings^ PageSettings {
    PageSettingsClass..::.PageSettings^ get ();
    void set (PageSettingsClass..::.PageSettings^ value);
}


PrintRange Property

PrintRange Property
Namespaces ► VisualCron ► PrinterSettingsClass ► PrintRange

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.PrintRange]

Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass..::.EnmPrintRange PrintRange { get; set; }
Public Property PrintRange As PrinterSettingsClass..::.EnmPrintRange
public:
property PrinterSettingsClass..::.EnmPrintRange PrintRange {
    PrinterSettingsClass..::.EnmPrintRange get ();
    void set (PrinterSettingsClass..::.EnmPrintRange value);
}


SelectedPages Property

SelectedPages Property
Namespaces ► VisualCron ► PrinterSettingsClass ► SelectedPages

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.SelectedPages]

Declaration Syntax
C# Visual Basic Visual C++
public string SelectedPages { get; set; }
Public Property SelectedPages As String
public:
property String^ SelectedPages {
    String^ get ();
    void set (String^ value);
}


SelectedPrinter Property

SelectedPrinter Property
Namespaces ► VisualCron ► PrinterSettingsClass ► SelectedPrinter

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.SelectedPrinter]

Declaration Syntax
C# Visual Basic Visual C++
public string SelectedPrinter { get; set; }
Public Property SelectedPrinter As String
public:
property String^ SelectedPrinter {
    String^ get ();
    void set (String^ value);
}


ToPage Property

ToPage Property
Namespaces ► VisualCron ► PrinterSettingsClass ► ToPage

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.ToPage]

Declaration Syntax
C# Visual Basic Visual C++
public short ToPage { get; set; }
Public Property ToPage As Short
public:
property short ToPage {
    short get ();
    void set (short value);
}


UseDefaultSettings Property

UseDefaultSettings Property
Namespaces ► VisualCron ► PrinterSettingsClass ► UseDefaultSettings

[Missing <summary> documentation for P:VisualCron.PrinterSettingsClass.UseDefaultSettings]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultSettings { get; set; }
Public Property UseDefaultSettings As Boolean
public:
property bool UseDefaultSettings {
    bool get ();
    void set (bool value);
}


PrinterSettingsClass.DocumentType Enumeration

PrinterSettingsClass..::.DocumentType Enumeration
Namespaces ► VisualCron ► PrinterSettingsClass ► PrinterSettingsClass..::.DocumentType
All supported document types
Declaration Syntax
C# Visual Basic Visual C++
public enum DocumentType
Public Enumeration DocumentType
public enum class DocumentType
Members
Member | Description
PDF |
WORD |
IMAGE |
EXCEL |
POWPOINT |
TEXT |
HTML |
Remarks

Send comments on this topic to Please email feedback to Support


PrinterSettingsClass.EnmOrientation Enumeration

PrinterSettingsClass..::.EnmOrientation Enumeration
Namespaces ► VisualCron ► PrinterSettingsClass ► PrinterSettingsClass..::.EnmOrientation

[Missing <summary> documentation for T:VisualCron.PrinterSettingsClass.EnmOrientation]

Declaration Syntax
C# Visual Basic Visual C++
public enum EnmOrientation
Public Enumeration EnmOrientation
public enum class EnmOrientation
Members
Member | Description
Landscape |
Portrait |
RotateBy_180 |


PrinterSettingsClass.EnmPaperKind Enumeration

PrinterSettingsClass..::.EnmPaperKind Enumeration
Namespaces ► VisualCron ► PrinterSettingsClass ► PrinterSettingsClass..::.EnmPaperKind

[Missing <summary> documentation for T:VisualCron.PrinterSettingsClass.EnmPaperKind]

Declaration Syntax
C# Visual Basic Visual C++
public enum EnmPaperKind
Public Enumeration EnmPaperKind
public enum class EnmPaperKind
Members
Member | Description
Paper10x14 |
Paper11x17 |
PaperA3 |
PaperA4 |
PaperA4Small |
PaperA5 |
PaperB4 |
PaperB5 |
PaperCSheet |
PaperCustom |
PaperDSheet |
PaperEnvelope10 |
PaperEnvelope11 |
PaperEnvelope12 |
PaperEnvelope14 |
PaperEnvelope9 |
PaperEnvelopeB4 |
PaperEnvelopeB5 |
PaperEnvelopeB6 |
PaperEnvelopeC3 |
PaperEnvelopeC4 |
PaperEnvelopeC5 |
PaperEnvelopeC6 |
PaperEnvelopeC65 |
PaperEnvelopeDL |
PaperEnvelopeItaly |
PaperEnvelopeMonarch |
PaperEnvelopePersonal |
PaperESheet |
PaperExecutive |
PaperFanfoldLegalGerman |
PaperFanfoldStdGerman |
PaperFanfoldUS |
PaperFolio |
PaperLedger |
PaperLegal |
PaperLetter |
PaperLetterSmall |
PaperNote |
PaperQuarto |
PaperStatement |
PaperTabloid |


PrinterSettingsClass.EnmPrintQuality Enumeration

PrinterSettingsClass..::.EnmPrintQuality Enumeration
Namespaces ► VisualCron ► PrinterSettingsClass ► PrinterSettingsClass..::.EnmPrintQuality

[Missing <summary> documentation for T:VisualCron.PrinterSettingsClass.EnmPrintQuality]

Declaration Syntax
C# Visual Basic Visual C++
public enum EnmPrintQuality
Public Enumeration EnmPrintQuality
public enum class EnmPrintQuality
Members
Member | Description
FastRes |
ProRes_1200 |
dpi_600 |


PrinterSettingsClass.EnmPrintRange Enumeration

PrinterSettingsClass..::.EnmPrintRange Enumeration
Namespaces ► VisualCron ► PrinterSettingsClass ► PrinterSettingsClass..::.EnmPrintRange

[Missing <summary> documentation for T:VisualCron.PrinterSettingsClass.EnmPrintRange]

Declaration Syntax
C# Visual Basic Visual C++
public enum EnmPrintRange
Public Enumeration EnmPrintRange
public enum class EnmPrintRange
Members
Member | Description
AllPages |
CurrentPage |
Selection |
SomePages |


PrinterSettingsClass.EnmResizeOption Enumeration

PrinterSettingsClass..::.EnmResizeOption Enumeration
Namespaces ► VisualCron ► PrinterSettingsClass ► PrinterSettingsClass..::.EnmResizeOption

[Missing <summary> documentation for T:VisualCron.PrinterSettingsClass.EnmResizeOption]

Declaration Syntax
C# Visual Basic Visual C++
public enum EnmResizeOption
Public Enumeration EnmResizeOption
public enum class EnmResizeOption
Members
Member | Description
ActualSize |
ScaleToFit |
CustomSize |


ProcessClass Class

ProcessClass Class
Namespaces ► VisualCron ► ProcessClass

[Missing <summary> documentation for T:VisualCron.ProcessClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ProcessClass
<SerializableAttribute> _
Public Class ProcessClass
[SerializableAttribute]
public ref class ProcessClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessClass()()() | Initializes a new instance of the ProcessClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WindowTitle |
Inheritance Hierarchy
Object
ProcessClass

Send comments on this topic to Please email feedback to Support


ProcessClass Constructor

ProcessClass Constructor
Namespaces ► VisualCron ► ProcessClass ► ProcessClass()()()
Initializes a new instance of the ProcessClass class
Declaration Syntax
C# Visual Basic Visual C++
public ProcessClass()
Public Sub New
public:
ProcessClass()


ProcessName Property

ProcessName Property
Namespaces ► VisualCron ► ProcessClass ► ProcessName

[Missing <summary> documentation for P:VisualCron.ProcessClass.ProcessName]

Declaration Syntax
C# Visual Basic Visual C++
public string ProcessName { get; set; }
Public Property ProcessName As String
public:
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}


WindowTitle Property

WindowTitle Property
Namespaces ► VisualCron ► ProcessClass ► WindowTitle

[Missing <summary> documentation for P:VisualCron.ProcessClass.WindowTitle]

Declaration Syntax
C# Visual Basic Visual C++
public string WindowTitle { get; set; }
Public Property WindowTitle As String
public:
property String^ WindowTitle {
    String^ get ();
    void set (String^ value);
}


ProcessesClass Class

ProcessesClass Class
Namespaces ► VisualCron ► ProcessesClass

[Missing <summary> documentation for T:VisualCron.ProcessesClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ProcessesClass
<SerializableAttribute> _
Public Class ProcessesClass
[SerializableAttribute]
public ref class ProcessesClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessesClass()()() | Initializes a new instance of the ProcessesClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Processes |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProcessesClass

Send comments on this topic to Please email feedback to Support


ProcessesClass Constructor

ProcessesClass Constructor
Namespaces ► VisualCron ► ProcessesClass ► ProcessesClass()()()
Initializes a new instance of the ProcessesClass class
Declaration Syntax
C# Visual Basic Visual C++
public ProcessesClass()
Public Sub New
public:
ProcessesClass()


Processes Field

Processes Field
Namespaces ► VisualCron ► ProcessesClass ► Processes

[Missing <summary> documentation for F:VisualCron.ProcessesClass.Processes]

Declaration Syntax
C# Visual Basic Visual C++
public List<ProcessClass> Processes
Public Processes As List(Of ProcessClass)
public:
List<ProcessClass^>^ Processes

Send comments on this topic to Please email feedback to Support


ProcessEventClass Class

ProcessEventClass Class
Namespaces ► VisualCron ► ProcessEventClass

[Missing <summary> documentation for T:VisualCron.ProcessEventClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ProcessEventClass : ICloneable
<SerializableAttribute> _
Public Class ProcessEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class ProcessEventClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessEventClass()()() | Initializes a new instance of the ProcessEventClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interval | How often it should be queried in the WMI in seconds
 | Machine | Server name/ip of computer
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | Id of Network Credential that will be used to get access
 | ProcessName | Process image name
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WatchType | What kind of process event should be watched
Inheritance Hierarchy
Object
ProcessEventClass

Send comments on this topic to Please email feedback to Support


ProcessEventClass Constructor

ProcessEventClass Constructor
Namespaces ► VisualCron ► ProcessEventClass ► ProcessEventClass()()()
Initializes a new instance of the ProcessEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public ProcessEventClass()
Public Sub New
public:
ProcessEventClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► ProcessEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.ProcessEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.ProcessEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► ProcessEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.ProcessEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public ProcessEventClass CloneType()
Public Function CloneType As ProcessEventClass
public:
ProcessEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.ProcessEventClass.CloneType]


Interval Property

Interval Property
Namespaces ► VisualCron ► ProcessEventClass ► Interval
How often it should be queried in the WMI in seconds
Declaration Syntax
C# Visual Basic Visual C++
public int Interval { get; set; }
Public Property Interval As Integer
public:
property int Interval {
    int get ();
    void set (int value);
}
Value
Default: Every 60 seconds
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Machine Property

Machine Property
Namespaces ► VisualCron ► ProcessEventClass ► Machine
Server name/ip of computer
Declaration Syntax
C# Visual Basic Visual C++
public string Machine { get; set; }
Public Property Machine As String
public:
property String^ Machine {
    String^ get ();
    void set (String^ value);
}
Value
Default: . = local computer
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► ProcessEventClass ► NetworkCredential
Id of Network Credential that will be used to get access
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProcessName Property

ProcessName Property
Namespaces ► VisualCron ► ProcessEventClass ► ProcessName
Process image name
Declaration Syntax
C# Visual Basic Visual C++
public string ProcessName { get; set; }
Public Property ProcessName As String
public:
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


WatchType Field

WatchType Field
Namespaces ► VisualCron ► ProcessEventClass ► WatchType
What kind of process event should be watched
Declaration Syntax
C# Visual Basic Visual C++
public ProcessEventClass..::.WatchT WatchType
Public WatchType As ProcessEventClass..::.WatchT
public:
ProcessEventClass..::.WatchT WatchType
Remarks

Send comments on this topic to Please email feedback to Support


ProcessEventClass.WatchT Enumeration

ProcessEventClass..::.WatchT Enumeration
Namespaces ► VisualCron ► ProcessEventClass ► ProcessEventClass..::.WatchT
Different watch types of a process
Declaration Syntax
C# Visual Basic Visual C++
public enum WatchT
Public Enumeration WatchT
public enum class WatchT
Members
Member | Description
ProcessStart |
ProcessStop |
Remarks

Send comments on this topic to Please email feedback to Support


ProcessorInfoClass Class

ProcessorInfoClass Class
Namespaces ► VisualCron ► ProcessorInfoClass

[Missing <summary> documentation for T:VisualCron.ProcessorInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ProcessorInfoClass
<SerializableAttribute> _
Public Class ProcessorInfoClass
[SerializableAttribute]
public ref class ProcessorInfoClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessorInfoClass()()() | Initializes a new instance of the ProcessorInfoClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | The name of the CPU
 | NoLogicalProcessors | Number of logical processors
 | NoProcessors | Number of processors
 | Speed | The speed in MHz of each CPU
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProcessorInfoClass

Send comments on this topic to Please email feedback to Support


ProcessorInfoClass Constructor

ProcessorInfoClass Constructor
Namespaces ► VisualCron ► ProcessorInfoClass ► ProcessorInfoClass()()()
Initializes a new instance of the ProcessorInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public ProcessorInfoClass()
Public Sub New
public:
ProcessorInfoClass()


Name Property

Name Property
Namespaces ► VisualCron ► ProcessorInfoClass ► Name
The name of the CPU
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NoLogicalProcessors Property

NoLogicalProcessors Property
Namespaces ► VisualCron ► ProcessorInfoClass ► NoLogicalProcessors
Number of logical processors
Declaration Syntax
C# Visual Basic Visual C++
public int NoLogicalProcessors { get; set; }
Public Property NoLogicalProcessors As Integer
public:
property int NoLogicalProcessors {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NoProcessors Property

NoProcessors Property
Namespaces ► VisualCron ► ProcessorInfoClass ► NoProcessors
Number of processors
Declaration Syntax
C# Visual Basic Visual C++
public int NoProcessors { get; set; }
Public Property NoProcessors As Integer
public:
property int NoProcessors {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Speed Property

Speed Property
Namespaces ► VisualCron ► ProcessorInfoClass ► Speed
The speed in MHz of each CPU
Declaration Syntax
C# Visual Basic Visual C++
public int Speed { get; set; }
Public Property Speed As Integer
public:
property int Speed {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProcessTriggerResultClass Class

ProcessTriggerResultClass Class
Namespaces ► VisualCron ► ProcessTriggerResultClass

[Missing <summary> documentation for T:VisualCron.ProcessTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ProcessTriggerResultClass
<SerializableAttribute> _
Public Class ProcessTriggerResultClass
[SerializableAttribute]
public ref class ProcessTriggerResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProcessTriggerResultClass()()() | Initializes a new instance of the ProcessTriggerResultClass class
 | CommandLine |
 | CreationDate |
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutablePath |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ProcessId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProcessTriggerResultClass

Send comments on this topic to Please email feedback to Support


ProcessTriggerResultClass Constructor

ProcessTriggerResultClass Constructor
Namespaces ► VisualCron ► ProcessTriggerResultClass ► ProcessTriggerResultClass()()()
Initializes a new instance of the ProcessTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public ProcessTriggerResultClass()
Public Sub New
public:
ProcessTriggerResultClass()


CommandLine Property

CommandLine Property
Namespaces ► VisualCron ► ProcessTriggerResultClass ► CommandLine

[Missing <summary> documentation for P:VisualCron.ProcessTriggerResultClass.CommandLine]

Declaration Syntax
C# Visual Basic Visual C++
public string CommandLine { get; set; }
Public Property CommandLine As String
public:
property String^ CommandLine {
    String^ get ();
    void set (String^ value);
}


CreationDate Property

CreationDate Property
Namespaces ► VisualCron ► ProcessTriggerResultClass ► CreationDate

[Missing <summary> documentation for P:VisualCron.ProcessTriggerResultClass.CreationDate]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime CreationDate { get; set; }
Public Property CreationDate As DateTime
public:
property DateTime CreationDate {
    DateTime get ();
    void set (DateTime value);
}


Description Property

Description Property
Namespaces ► VisualCron ► ProcessTriggerResultClass ► Description

[Missing <summary> documentation for P:VisualCron.ProcessTriggerResultClass.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


ExecutablePath Property

ExecutablePath Property
Namespaces ► VisualCron ► ProcessTriggerResultClass ► ExecutablePath

[Missing <summary> documentation for P:VisualCron.ProcessTriggerResultClass.ExecutablePath]

Declaration Syntax
C# Visual Basic Visual C++
public string ExecutablePath { get; set; }
Public Property ExecutablePath As String
public:
property String^ ExecutablePath {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► VisualCron ► ProcessTriggerResultClass ► Name

[Missing <summary> documentation for P:VisualCron.ProcessTriggerResultClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


ProcessId Property

ProcessId Property
Namespaces ► VisualCron ► ProcessTriggerResultClass ► ProcessId

[Missing <summary> documentation for P:VisualCron.ProcessTriggerResultClass.ProcessId]

Declaration Syntax
C# Visual Basic Visual C++
public int ProcessId { get; set; }
Public Property ProcessId As Integer
public:
property int ProcessId {
    int get ();
    void set (int value);
}


ProxyClass Class

ProxyClass Class
Namespaces ► VisualCron ► ProxyClass

[Missing <summary> documentation for T:VisualCron.ProxyClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ProxyClass
<SerializableAttribute> _
Public Class ProxyClass
[SerializableAttribute]
public ref class ProxyClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProxyClass()()() | Initializes a new instance of the ProxyClass class
 | Domain | Domain for the proxy
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Host | Host for the proxy
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord | Password for the proxy
 | Port | Port for the proxy
 | ProxyServerType |
 | ProxyType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseCredentials | If Credentials are required for using the proxy
 | UserName | User name for the proxy
Inheritance Hierarchy
Object
ProxyClass

Send comments on this topic to Please email feedback to Support


ProxyClass Constructor

ProxyClass Constructor
Namespaces ► VisualCron ► ProxyClass ► ProxyClass()()()
Initializes a new instance of the ProxyClass class
Declaration Syntax
C# Visual Basic Visual C++
public ProxyClass()
Public Sub New
public:
ProxyClass()


Domain Property

Domain Property
Namespaces ► VisualCron ► ProxyClass ► Domain
Domain for the proxy
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Domain { get; set; }
Public Property Domain As Byte()
public:
property array<unsigned char>^ Domain {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Encrypted

Send comments on this topic to Please email feedback to Support


Host Property

Host Property
Namespaces ► VisualCron ► ProxyClass ► Host
Host for the proxy
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Host { get; set; }
Public Property Host As Byte()
public:
property array<unsigned char>^ Host {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Encrypted

Send comments on this topic to Please email feedback to Support


PassWord Property

PassWord Property
Namespaces ► VisualCron ► ProxyClass ► PassWord
Password for the proxy
Declaration Syntax
C# Visual Basic Visual C++
public byte[] PassWord { get; set; }
Public Property PassWord As Byte()
public:
property array<unsigned char>^ PassWord {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Encrypted

Send comments on this topic to Please email feedback to Support


Port Property

Port Property
Namespaces ► VisualCron ► ProxyClass ► Port
Port for the proxy
Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
property int Port {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProxyServerType Field

ProxyServerType Field
Namespaces ► VisualCron ► ProxyClass ► ProxyServerType

[Missing <summary> documentation for F:VisualCron.ProxyClass.ProxyServerType]

Declaration Syntax
C# Visual Basic Visual C++
public ProxyClass..::.ProxyServerT ProxyServerType
Public ProxyServerType As ProxyClass..::.ProxyServerT
public:
ProxyClass..::.ProxyServerT ProxyServerType


ProxyType Field

ProxyType Field
Namespaces ► VisualCron ► ProxyClass ► ProxyType

[Missing <summary> documentation for F:VisualCron.ProxyClass.ProxyType]

Declaration Syntax
C# Visual Basic Visual C++
public ProxyClass..::.ProxyT ProxyType
Public ProxyType As ProxyClass..::.ProxyT
public:
ProxyClass..::.ProxyT ProxyType

Send comments on this topic to Please email feedback to Support


UseCredentials Property

UseCredentials Property
Namespaces ► VisualCron ► ProxyClass ► UseCredentials
If Credentials are required for using the proxy
Declaration Syntax
C# Visual Basic Visual C++
public bool UseCredentials { get; set; }
Public Property UseCredentials As Boolean
public:
property bool UseCredentials {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UserName Property

UserName Property
Namespaces ► VisualCron ► ProxyClass ► UserName
User name for the proxy
Declaration Syntax
C# Visual Basic Visual C++
public byte[] UserName { get; set; }
Public Property UserName As Byte()
public:
property array<unsigned char>^ UserName {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Encrypted

Send comments on this topic to Please email feedback to Support


ProxyClass.ProxyServerT Enumeration

ProxyClass..::.ProxyServerT Enumeration
Namespaces ► VisualCron ► ProxyClass ► ProxyClass..::.ProxyServerT

[Missing <summary> documentation for T:VisualCron.ProxyClass.ProxyServerT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ProxyServerT
Public Enumeration ProxyServerT
public enum class ProxyServerT
Members
Member | Description
NoProxy |
UserSite |
Site |
Open |
UserPass |
Transparent |


ProxyClass.ProxyT Enumeration

ProxyClass..::.ProxyT Enumeration
Namespaces ► VisualCron ► ProxyClass ► ProxyClass..::.ProxyT
Enum that describes what type of proxy it is
Declaration Syntax
C# Visual Basic Visual C++
public enum ProxyT
Public Enumeration ProxyT
public enum class ProxyT
Members
Member | Description
NoProxy |
HTTP |
SOCKS4 |
SOCKS5 |
Remarks

Send comments on this topic to Please email feedback to Support


RaisePaperSizeCollection Class

RaisePaperSizeCollection Class
Namespaces ► VisualCron ► RaisePaperSizeCollection

[Missing <summary> documentation for T:VisualCron.RaisePaperSizeCollection]

Declaration Syntax
C# Visual Basic Visual C++
public class RaisePaperSizeCollection
Public Class RaisePaperSizeCollection
public ref class RaisePaperSizeCollection
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | RaisePaperSizeCollection()()() | Initializes a new instance of the RaisePaperSizeCollection class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
RaisePaperSizeCollection

Send comments on this topic to Please email feedback to Support


RaisePaperSizeCollection Constructor

RaisePaperSizeCollection Constructor
Namespaces ► VisualCron ► RaisePaperSizeCollection ► RaisePaperSizeCollection()()()
Initializes a new instance of the RaisePaperSizeCollection class
Declaration Syntax
C# Visual Basic Visual C++
public RaisePaperSizeCollection()
Public Sub New
public:
RaisePaperSizeCollection()


RECT Structure

RECT Structure
Namespaces ► VisualCron ► RECT

[Missing <summary> documentation for T:VisualCron.RECT]

Declaration Syntax
C# Visual Basic Visual C++
public struct RECT
Public Structure RECT
public value class RECT
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RECT(Rectangle) | Initializes a new instance of the RECT class
 | RECT(Int32, Int32, Int32, Int32) | Initializes a new instance of the RECT class
 | bottom |
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromXYWH(Int32, Int32, Int32, Int32) |
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | left |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | right |
 | Size |
 | top |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


RECT Constructor

RECT Constructor
Namespaces ► VisualCron ► RECT ► RECT()()()
Members
Icon | Member | Description
 | RECT(Rectangle) | Initializes a new instance of the RECT class
 | RECT(Int32, Int32, Int32, Int32) | Initializes a new instance of the RECT class


RECT Constructor (r)

RECT Constructor (r)
Namespaces ► VisualCron ► RECT ► RECT(Rectangle)
Initializes a new instance of the RECT class
Declaration Syntax
C# Visual Basic Visual C++
public RECT(
    Rectangle r
)
Public Sub New ( _
    r As Rectangle _
)
public:
RECT(
    Rectangle r
)
Parameters
r (Rectangle)

[Missing <param name="r"/> documentation for "M:VisualCron.RECT.#ctor(System.Drawing.Rectangle)"]


RECT Constructor (left, top, right, bottom)

RECT Constructor (left, top, right, bottom)
Namespaces ► VisualCron ► RECT ► RECT(Int32, Int32, Int32, Int32)
Initializes a new instance of the RECT class
Declaration Syntax
C# Visual Basic Visual C++
public RECT(
    int left,
    int top,
    int right,
    int bottom
)
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
public:
RECT(
    int left,
    int top,
    int right,
    int bottom
)
Parameters
left (Int32)

[Missing <param name="left"/> documentation for "M:VisualCron.RECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

top (Int32)

[Missing <param name="top"/> documentation for "M:VisualCron.RECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

right (Int32)

[Missing <param name="right"/> documentation for "M:VisualCron.RECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]

bottom (Int32)

[Missing <param name="bottom"/> documentation for "M:VisualCron.RECT.#ctor(System.Int32,System.Int32,System.Int32,System.Int32)"]


bottom Field

bottom Field
Namespaces ► VisualCron ► RECT ► bottom

[Missing <summary> documentation for F:VisualCron.RECT.bottom]

Declaration Syntax
C# Visual Basic Visual C++
public int bottom
Public bottom As Integer
public:
int bottom


FromXYWH Method (x, y, width, height)

FromXYWH Method (x, y, width, height)
Namespaces ► VisualCron ► RECT ► FromXYWH(Int32, Int32, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.RECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static RECT FromXYWH(
    int x,
    int y,
    int width,
    int height
)
Public Shared Function FromXYWH ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
) As RECT
public:
static RECT FromXYWH(
    int x,
    int y,
    int width,
    int height
)
Parameters
x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.RECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.RECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

width (Int32)

[Missing <param name="width"/> documentation for "M:VisualCron.RECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

height (Int32)

[Missing <param name="height"/> documentation for "M:VisualCron.RECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.RECT.FromXYWH(System.Int32,System.Int32,System.Int32,System.Int32)]


left Field

left Field
Namespaces ► VisualCron ► RECT ► left

[Missing <summary> documentation for F:VisualCron.RECT.left]

Declaration Syntax
C# Visual Basic Visual C++
public int left
Public left As Integer
public:
int left


right Field

right Field
Namespaces ► VisualCron ► RECT ► right

[Missing <summary> documentation for F:VisualCron.RECT.right]

Declaration Syntax
C# Visual Basic Visual C++
public int right
Public right As Integer
public:
int right


Size Property

Size Property
Namespaces ► VisualCron ► RECT ► Size

[Missing <summary> documentation for P:VisualCron.RECT.Size]

Declaration Syntax
C# Visual Basic Visual C++
public Size Size { get; }
Public ReadOnly Property Size As Size
public:
property Size Size {
    Size get ();
}


top Field

top Field
Namespaces ► VisualCron ► RECT ► top

[Missing <summary> documentation for F:VisualCron.RECT.top]

Declaration Syntax
C# Visual Basic Visual C++
public int top
Public top As Integer
public:
int top


RegistryEventClass Class

RegistryEventClass Class
Namespaces ► VisualCron ► RegistryEventClass
The registry event - watches changes in the registry
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class RegistryEventClass : ICloneable
<SerializableAttribute> _
Public Class RegistryEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class RegistryEventClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegistryEventClass()()() | Initializes a new instance of the RegistryEventClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HiveType |
 | Interval | How often it should be queried in the WMI in seconds
 | KeyPath | A path to a registry key
 | Machine | Server name/ip of computer
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | Id of Network Credential that will be used to get access
 | RegistryChangeType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value | A registry value
Remarks
Inheritance Hierarchy
Object
RegistryEventClass

Send comments on this topic to Please email feedback to Support


RegistryEventClass Constructor

RegistryEventClass Constructor
Namespaces ► VisualCron ► RegistryEventClass ► RegistryEventClass()()()
Initializes a new instance of the RegistryEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public RegistryEventClass()
Public Sub New
public:
RegistryEventClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► RegistryEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.RegistryEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.RegistryEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► RegistryEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.RegistryEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public RegistryEventClass CloneType()
Public Function CloneType As RegistryEventClass
public:
RegistryEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.RegistryEventClass.CloneType]


HiveType Field

HiveType Field
Namespaces ► VisualCron ► RegistryEventClass ► HiveType

[Missing <summary> documentation for F:VisualCron.RegistryEventClass.HiveType]

Declaration Syntax
C# Visual Basic Visual C++
public RegistryEventClass..::.HiveT HiveType
Public HiveType As RegistryEventClass..::.HiveT
public:
RegistryEventClass..::.HiveT HiveType

Send comments on this topic to Please email feedback to Support


Interval Property

Interval Property
Namespaces ► VisualCron ► RegistryEventClass ► Interval
How often it should be queried in the WMI in seconds
Declaration Syntax
C# Visual Basic Visual C++
public int Interval { get; set; }
Public Property Interval As Integer
public:
property int Interval {
    int get ();
    void set (int value);
}
Value
Default: Every 60 seconds
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


KeyPath Property

KeyPath Property
Namespaces ► VisualCron ► RegistryEventClass ► KeyPath
A path to a registry key
Declaration Syntax
C# Visual Basic Visual C++
public string KeyPath { get; set; }
Public Property KeyPath As String
public:
property String^ KeyPath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Machine Property

Machine Property
Namespaces ► VisualCron ► RegistryEventClass ► Machine
Server name/ip of computer
Declaration Syntax
C# Visual Basic Visual C++
public string Machine { get; set; }
Public Property Machine As String
public:
property String^ Machine {
    String^ get ();
    void set (String^ value);
}
Value
Default: . = local computer
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► RegistryEventClass ► NetworkCredential
Id of Network Credential that will be used to get access
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RegistryChangeType Field

RegistryChangeType Field
Namespaces ► VisualCron ► RegistryEventClass ► RegistryChangeType

[Missing <summary> documentation for F:VisualCron.RegistryEventClass.RegistryChangeType]

Declaration Syntax
C# Visual Basic Visual C++
public RegistryEventClass..::.RegistryChangeT RegistryChangeType
Public RegistryChangeType As RegistryEventClass..::.RegistryChangeT
public:
RegistryEventClass..::.RegistryChangeT RegistryChangeType


Value Property

Value Property
Namespaces ► VisualCron ► RegistryEventClass ► Value
A registry value
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RegistryEventClass.HiveT Enumeration

RegistryEventClass..::.HiveT Enumeration
Namespaces ► VisualCron ► RegistryEventClass ► RegistryEventClass..::.HiveT
Enum that describes in what scope to watch in the registry
Declaration Syntax
C# Visual Basic Visual C++
public enum HiveT
Public Enumeration HiveT
public enum class HiveT
Members
Member | Description
HKEY_CLASSES_ROOT |
HKEY_CURRENT_USER |
HKEY_LOCAL_MACHINE |
HKEY_USERS |
HKEY_CURRENT_CONFIG |
Remarks
The RegistryKeyChangeEvent class represents changes to a specific key. The changes apply only to the key, not its subkeys.


RegistryEventClass.RegistryChangeT Enumeration

RegistryEventClass..::.RegistryChangeT Enumeration
Namespaces ► VisualCron ► RegistryEventClass ► RegistryEventClass..::.RegistryChangeT

[Missing <summary> documentation for T:VisualCron.RegistryEventClass.RegistryChangeT]

Declaration Syntax
C# Visual Basic Visual C++
public enum RegistryChangeT
Public Enumeration RegistryChangeT
public enum class RegistryChangeT
Members
Member | Description
RegistryKeyChange |
RegistryTreeChange |
RegistryValueChange |


RegistryTriggerResultClass Class

RegistryTriggerResultClass Class
Namespaces ► VisualCron ► RegistryTriggerResultClass

[Missing <summary> documentation for T:VisualCron.RegistryTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class RegistryTriggerResultClass
<SerializableAttribute> _
Public Class RegistryTriggerResultClass
[SerializableAttribute]
public ref class RegistryTriggerResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RegistryTriggerResultClass()()() | Initializes a new instance of the RegistryTriggerResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hive |
 | KeyPath |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Value |
 | ValueName |
Inheritance Hierarchy
Object
RegistryTriggerResultClass

Send comments on this topic to Please email feedback to Support


RegistryTriggerResultClass Constructor

RegistryTriggerResultClass Constructor
Namespaces ► VisualCron ► RegistryTriggerResultClass ► RegistryTriggerResultClass()()()
Initializes a new instance of the RegistryTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public RegistryTriggerResultClass()
Public Sub New
public:
RegistryTriggerResultClass()


Hive Property

Hive Property
Namespaces ► VisualCron ► RegistryTriggerResultClass ► Hive

[Missing <summary> documentation for P:VisualCron.RegistryTriggerResultClass.Hive]

Declaration Syntax
C# Visual Basic Visual C++
public string Hive { get; set; }
Public Property Hive As String
public:
property String^ Hive {
    String^ get ();
    void set (String^ value);
}


KeyPath Property

KeyPath Property
Namespaces ► VisualCron ► RegistryTriggerResultClass ► KeyPath

[Missing <summary> documentation for P:VisualCron.RegistryTriggerResultClass.KeyPath]

Declaration Syntax
C# Visual Basic Visual C++
public string KeyPath { get; set; }
Public Property KeyPath As String
public:
property String^ KeyPath {
    String^ get ();
    void set (String^ value);
}


Value Property

Value Property
Namespaces ► VisualCron ► RegistryTriggerResultClass ► Value

[Missing <summary> documentation for P:VisualCron.RegistryTriggerResultClass.Value]

Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}


ValueName Property

ValueName Property
Namespaces ► VisualCron ► RegistryTriggerResultClass ► ValueName

[Missing <summary> documentation for P:VisualCron.RegistryTriggerResultClass.ValueName]

Declaration Syntax
C# Visual Basic Visual C++
public string ValueName { get; set; }
Public Property ValueName As String
public:
property String^ ValueName {
    String^ get ();
    void set (String^ value);
}


RelativeTo Enumeration

RelativeTo Enumeration
Namespaces ► VisualCron ► RelativeTo

[Missing <summary> documentation for T:VisualCron.RelativeTo]

Declaration Syntax
C# Visual Basic Visual C++
public enum RelativeTo
Public Enumeration RelativeTo
public enum class RelativeTo
Members
Member | Description
Screen |
Window |


RestoreWindowInstruction Class

RestoreWindowInstruction Class
Namespaces ► VisualCron ► RestoreWindowInstruction

[Missing <summary> documentation for T:VisualCron.RestoreWindowInstruction]

Declaration Syntax
C# Visual Basic Visual C++
public class RestoreWindowInstruction : PlayerInstruction
Public Class RestoreWindowInstruction _
    Inherits PlayerInstruction
public ref class RestoreWindowInstruction : public PlayerInstruction
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | RestoreWindowInstruction(WindowDescriptor, WindowState) | Initializes a new instance of the RestoreWindowInstruction class
 | Delay | (Inherited from PlayerInstruction.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(IDictionary) | (Overrides PlayerInstruction.Execute(IDictionary).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PlayerInstruction
 |  | RestoreWindowInstruction


RestoreWindowInstruction Constructor (targetWindow, windowState)

RestoreWindowInstruction Constructor (targetWindow, windowState)
Namespaces ► VisualCron ► RestoreWindowInstruction ► RestoreWindowInstruction(WindowDescriptor, WindowState)
Initializes a new instance of the RestoreWindowInstruction class
Declaration Syntax
C# Visual Basic Visual C++
public RestoreWindowInstruction(
    WindowDescriptor targetWindow,
    WindowState windowState
)
Public Sub New ( _
    targetWindow As WindowDescriptor, _
    windowState As WindowState _
)
public:
RestoreWindowInstruction(
    WindowDescriptor^ targetWindow,
    WindowState^ windowState
)
Parameters
targetWindow (WindowDescriptor)

[Missing <param name="targetWindow"/> documentation for "M:VisualCron.RestoreWindowInstruction.#ctor(VisualCron.WindowDescriptor,VisualCron.WindowState)"]

windowState (WindowState)

[Missing <param name="windowState"/> documentation for "M:VisualCron.RestoreWindowInstruction.#ctor(VisualCron.WindowDescriptor,VisualCron.WindowState)"]


Execute Method (context)

Execute Method (context)
Namespaces ► VisualCron ► RestoreWindowInstruction ► Execute(IDictionary)

[Missing <summary> documentation for M:VisualCron.RestoreWindowInstruction.Execute(System.Collections.IDictionary)]

Declaration Syntax
C# Visual Basic Visual C++
public override void Execute(
    IDictionary context
)
Public Overrides Sub Execute ( _
    context As IDictionary _
)
public:
virtual void Execute(
    IDictionary^ context
) override
Parameters
context (IDictionary)

[Missing <param name="context"/> documentation for "M:VisualCron.RestoreWindowInstruction.Execute(System.Collections.IDictionary)"]


SecPermissionsClass Class

SecPermissionsClass Class
Namespaces ► VisualCron ► SecPermissionsClass

[Missing <summary> documentation for T:VisualCron.SecPermissionsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SecPermissionsClass
<SerializableAttribute> _
Public Class SecPermissionsClass
[SerializableAttribute]
public ref class SecPermissionsClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecPermissionsClass()()() | Initializes a new instance of the SecPermissionsClass class
 | Certificates |
 | ClientConnections |
 | ClientSettings |
 | Conditions |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportSettings |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FTPConnections |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImportSettings |
 | Jobs |
 | Log |
 | ManageServers |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredentials |
 | NetworkDrives |
 | Notifications |
 | PGPKeyRings |
 | Processes |
 | RemoteFileExplorer |
 | ServerSettings |
 | Tasks |
 | TECollections |
 | TEExceptions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Triggers |
 | UserAdministration |
 | Variables |
Inheritance Hierarchy
Object
SecPermissionsClass

Send comments on this topic to Please email feedback to Support


SecPermissionsClass Constructor

SecPermissionsClass Constructor
Namespaces ► VisualCron ► SecPermissionsClass ► SecPermissionsClass()()()
Initializes a new instance of the SecPermissionsClass class
Declaration Syntax
C# Visual Basic Visual C++
public SecPermissionsClass()
Public Sub New
public:
SecPermissionsClass()


Certificates Field

Certificates Field
Namespaces ► VisualCron ► SecPermissionsClass ► Certificates

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Certificates]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Certificates
Public Certificates As SecSettingClass
public:
SecSettingClass^ Certificates

Send comments on this topic to Please email feedback to Support


ClientConnections Field

ClientConnections Field
Namespaces ► VisualCron ► SecPermissionsClass ► ClientConnections

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.ClientConnections]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass ClientConnections
Public ClientConnections As SecSettingClass
public:
SecSettingClass^ ClientConnections

Send comments on this topic to Please email feedback to Support


ClientSettings Field

ClientSettings Field
Namespaces ► VisualCron ► SecPermissionsClass ► ClientSettings

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.ClientSettings]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass ClientSettings
Public ClientSettings As SecSettingClass
public:
SecSettingClass^ ClientSettings

Send comments on this topic to Please email feedback to Support


Conditions Field

Conditions Field
Namespaces ► VisualCron ► SecPermissionsClass ► Conditions

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Conditions]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Conditions
Public Conditions As SecSettingClass
public:
SecSettingClass^ Conditions

Send comments on this topic to Please email feedback to Support


ExportSettings Field

ExportSettings Field
Namespaces ► VisualCron ► SecPermissionsClass ► ExportSettings

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.ExportSettings]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass ExportSettings
Public ExportSettings As SecSettingClass
public:
SecSettingClass^ ExportSettings

Send comments on this topic to Please email feedback to Support


FTPConnections Field

FTPConnections Field
Namespaces ► VisualCron ► SecPermissionsClass ► FTPConnections

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.FTPConnections]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass FTPConnections
Public FTPConnections As SecSettingClass
public:
SecSettingClass^ FTPConnections

Send comments on this topic to Please email feedback to Support


ImportSettings Field

ImportSettings Field
Namespaces ► VisualCron ► SecPermissionsClass ► ImportSettings

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.ImportSettings]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass ImportSettings
Public ImportSettings As SecSettingClass
public:
SecSettingClass^ ImportSettings

Send comments on this topic to Please email feedback to Support


Jobs Field

Jobs Field
Namespaces ► VisualCron ► SecPermissionsClass ► Jobs

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Jobs]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Jobs
Public Jobs As SecSettingClass
public:
SecSettingClass^ Jobs

Send comments on this topic to Please email feedback to Support


Log Field

Log Field
Namespaces ► VisualCron ► SecPermissionsClass ► Log

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Log]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Log
Public Log As SecSettingClass
public:
SecSettingClass^ Log

Send comments on this topic to Please email feedback to Support


ManageServers Field

ManageServers Field
Namespaces ► VisualCron ► SecPermissionsClass ► ManageServers

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.ManageServers]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass ManageServers
Public ManageServers As SecSettingClass
public:
SecSettingClass^ ManageServers

Send comments on this topic to Please email feedback to Support


NetworkCredentials Field

NetworkCredentials Field
Namespaces ► VisualCron ► SecPermissionsClass ► NetworkCredentials

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.NetworkCredentials]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass NetworkCredentials
Public NetworkCredentials As SecSettingClass
public:
SecSettingClass^ NetworkCredentials

Send comments on this topic to Please email feedback to Support


NetworkDrives Field

NetworkDrives Field
Namespaces ► VisualCron ► SecPermissionsClass ► NetworkDrives

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.NetworkDrives]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass NetworkDrives
Public NetworkDrives As SecSettingClass
public:
SecSettingClass^ NetworkDrives

Send comments on this topic to Please email feedback to Support


Notifications Field

Notifications Field
Namespaces ► VisualCron ► SecPermissionsClass ► Notifications

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Notifications]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Notifications
Public Notifications As SecSettingClass
public:
SecSettingClass^ Notifications

Send comments on this topic to Please email feedback to Support


PGPKeyRings Field

PGPKeyRings Field
Namespaces ► VisualCron ► SecPermissionsClass ► PGPKeyRings

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.PGPKeyRings]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass PGPKeyRings
Public PGPKeyRings As SecSettingClass
public:
SecSettingClass^ PGPKeyRings

Send comments on this topic to Please email feedback to Support


Processes Field

Processes Field
Namespaces ► VisualCron ► SecPermissionsClass ► Processes

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Processes]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Processes
Public Processes As SecSettingClass
public:
SecSettingClass^ Processes

Send comments on this topic to Please email feedback to Support


RemoteFileExplorer Field

RemoteFileExplorer Field
Namespaces ► VisualCron ► SecPermissionsClass ► RemoteFileExplorer

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.RemoteFileExplorer]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass RemoteFileExplorer
Public RemoteFileExplorer As SecSettingClass
public:
SecSettingClass^ RemoteFileExplorer

Send comments on this topic to Please email feedback to Support


ServerSettings Field

ServerSettings Field
Namespaces ► VisualCron ► SecPermissionsClass ► ServerSettings

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.ServerSettings]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass ServerSettings
Public ServerSettings As SecSettingClass
public:
SecSettingClass^ ServerSettings

Send comments on this topic to Please email feedback to Support


Tasks Field

Tasks Field
Namespaces ► VisualCron ► SecPermissionsClass ► Tasks

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Tasks]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Tasks
Public Tasks As SecSettingClass
public:
SecSettingClass^ Tasks

Send comments on this topic to Please email feedback to Support


TECollections Field

TECollections Field
Namespaces ► VisualCron ► SecPermissionsClass ► TECollections

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.TECollections]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass TECollections
Public TECollections As SecSettingClass
public:
SecSettingClass^ TECollections

Send comments on this topic to Please email feedback to Support


TEExceptions Field

TEExceptions Field
Namespaces ► VisualCron ► SecPermissionsClass ► TEExceptions

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.TEExceptions]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass TEExceptions
Public TEExceptions As SecSettingClass
public:
SecSettingClass^ TEExceptions

Send comments on this topic to Please email feedback to Support


Triggers Field

Triggers Field
Namespaces ► VisualCron ► SecPermissionsClass ► Triggers

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Triggers]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Triggers
Public Triggers As SecSettingClass
public:
SecSettingClass^ Triggers

Send comments on this topic to Please email feedback to Support


UserAdministration Field

UserAdministration Field
Namespaces ► VisualCron ► SecPermissionsClass ► UserAdministration

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.UserAdministration]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass UserAdministration
Public UserAdministration As SecSettingClass
public:
SecSettingClass^ UserAdministration

Send comments on this topic to Please email feedback to Support


Variables Field

Variables Field
Namespaces ► VisualCron ► SecPermissionsClass ► Variables

[Missing <summary> documentation for F:VisualCron.SecPermissionsClass.Variables]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass Variables
Public Variables As SecSettingClass
public:
SecSettingClass^ Variables

Send comments on this topic to Please email feedback to Support


SecPermissionsClass.ActionT Enumeration

SecPermissionsClass..::.ActionT Enumeration
Namespaces ► VisualCron ► SecPermissionsClass ► SecPermissionsClass..::.ActionT

[Missing <summary> documentation for T:VisualCron.SecPermissionsClass.ActionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ActionT
Public Enumeration ActionT
public enum class ActionT
Members
Member | Description
Add |
Edit |
Delete |
Execute |
Read |


SecPermissionsClass.PermissionT Enumeration

SecPermissionsClass..::.PermissionT Enumeration
Namespaces ► VisualCron ► SecPermissionsClass ► SecPermissionsClass..::.PermissionT

[Missing <summary> documentation for T:VisualCron.SecPermissionsClass.PermissionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum PermissionT
Public Enumeration PermissionT
public enum class PermissionT
Members
Member | Description
Jobs |
Tasks |
Triggers |
Conditions |
Certificates |
Notifications |
TECollections |
TEExceptions |
ClientSettings |
ServerSettings |
PGPKeyRings |
Processes |
NetworkCrendentials |
ManageServers |
UserAdministration |
Log |
FTPConnections |
Variables |
ExportSettings |
ImportSettings |
RemoteFileExplorer |


SecSettingClass Class

SecSettingClass Class
Namespaces ► VisualCron ► SecSettingClass

[Missing <summary> documentation for T:VisualCron.SecSettingClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SecSettingClass
<SerializableAttribute> _
Public Class SecSettingClass
[SerializableAttribute]
public ref class SecSettingClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecSettingClass()()() | Initializes a new instance of the SecSettingClass class
 | Add |
 | Delete |
 | Edit |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SecSettingClass

Send comments on this topic to Please email feedback to Support


SecSettingClass Constructor

SecSettingClass Constructor
Namespaces ► VisualCron ► SecSettingClass ► SecSettingClass()()()
Initializes a new instance of the SecSettingClass class
Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass()
Public Sub New
public:
SecSettingClass()


Add Field

Add Field
Namespaces ► VisualCron ► SecSettingClass ► Add

[Missing <summary> documentation for F:VisualCron.SecSettingClass.Add]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass..::.SecSettingT Add
Public Add As SecSettingClass..::.SecSettingT
public:
SecSettingClass..::.SecSettingT Add

Send comments on this topic to Please email feedback to Support


Delete Field

Delete Field
Namespaces ► VisualCron ► SecSettingClass ► Delete

[Missing <summary> documentation for F:VisualCron.SecSettingClass.Delete]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass..::.SecSettingT Delete
Public Delete As SecSettingClass..::.SecSettingT
public:
SecSettingClass..::.SecSettingT Delete

Send comments on this topic to Please email feedback to Support


Edit Field

Edit Field
Namespaces ► VisualCron ► SecSettingClass ► Edit

[Missing <summary> documentation for F:VisualCron.SecSettingClass.Edit]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass..::.SecSettingT Edit
Public Edit As SecSettingClass..::.SecSettingT
public:
SecSettingClass..::.SecSettingT Edit

Send comments on this topic to Please email feedback to Support


Execute Field

Execute Field
Namespaces ► VisualCron ► SecSettingClass ► Execute

[Missing <summary> documentation for F:VisualCron.SecSettingClass.Execute]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass..::.SecSettingT Execute
Public Execute As SecSettingClass..::.SecSettingT
public:
SecSettingClass..::.SecSettingT Execute

Send comments on this topic to Please email feedback to Support


Read Field

Read Field
Namespaces ► VisualCron ► SecSettingClass ► Read

[Missing <summary> documentation for F:VisualCron.SecSettingClass.Read]

Declaration Syntax
C# Visual Basic Visual C++
public SecSettingClass..::.SecSettingT Read
Public Read As SecSettingClass..::.SecSettingT
public:
SecSettingClass..::.SecSettingT Read

Send comments on this topic to Please email feedback to Support


SecSettingClass.SecSettingT Enumeration

SecSettingClass..::.SecSettingT Enumeration
Namespaces ► VisualCron ► SecSettingClass ► SecSettingClass..::.SecSettingT

[Missing <summary> documentation for T:VisualCron.SecSettingClass.SecSettingT]

Declaration Syntax
C# Visual Basic Visual C++
public enum SecSettingT
Public Enumeration SecSettingT
public enum class SecSettingT
Members
Member | Description
Yes |
No |
NAYes |
NaNo |


SecUserClass Class

SecUserClass Class
Namespaces ► VisualCron ► SecUserClass

[Missing <summary> documentation for T:VisualCron.SecUserClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SecUserClass
<SerializableAttribute> _
Public Class SecUserClass
[SerializableAttribute]
public ref class SecUserClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SecUserClass()()() | Initializes a new instance of the SecUserClass class
 | Active |
 | CloneType()()() |
 | Email |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PassWord |
 | Sec |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName |
Inheritance Hierarchy
Object
SecUserClass

Send comments on this topic to Please email feedback to Support


SecUserClass Constructor

SecUserClass Constructor
Namespaces ► VisualCron ► SecUserClass ► SecUserClass()()()
Initializes a new instance of the SecUserClass class
Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass()
Public Sub New
public:
SecUserClass()


Active Property

Active Property
Namespaces ► VisualCron ► SecUserClass ► Active

[Missing <summary> documentation for P:VisualCron.SecUserClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}


CloneType Method

CloneType Method
Namespaces ► VisualCron ► SecUserClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.SecUserClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass CloneType()
Public Function CloneType As SecUserClass
public:
SecUserClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.SecUserClass.CloneType]


Email Property

Email Property
Namespaces ► VisualCron ► SecUserClass ► Email

[Missing <summary> documentation for P:VisualCron.SecUserClass.Email]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] Email { get; set; }
Public Property Email As Byte()
public:
property array<unsigned char>^ Email {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


Id Property

Id Property
Namespaces ► VisualCron ► SecUserClass ► Id

[Missing <summary> documentation for P:VisualCron.SecUserClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


Name Property

Name Property
Namespaces ► VisualCron ► SecUserClass ► Name

[Missing <summary> documentation for P:VisualCron.SecUserClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] Name { get; set; }
Public Property Name As Byte()
public:
property array<unsigned char>^ Name {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


PassWord Property

PassWord Property
Namespaces ► VisualCron ► SecUserClass ► PassWord

[Missing <summary> documentation for P:VisualCron.SecUserClass.PassWord]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] PassWord { get; set; }
Public Property PassWord As Byte()
public:
property array<unsigned char>^ PassWord {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


Sec Field

Sec Field
Namespaces ► VisualCron ► SecUserClass ► Sec

[Missing <summary> documentation for F:VisualCron.SecUserClass.Sec]

Declaration Syntax
C# Visual Basic Visual C++
public SecPermissionsClass Sec
Public Sec As SecPermissionsClass
public:
SecPermissionsClass^ Sec

Send comments on this topic to Please email feedback to Support


UserName Property

UserName Property
Namespaces ► VisualCron ► SecUserClass ► UserName

[Missing <summary> documentation for P:VisualCron.SecUserClass.UserName]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] UserName { get; set; }
Public Property UserName As Byte()
public:
property array<unsigned char>^ UserName {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


SendInputInstruction Class

SendInputInstruction Class
Namespaces ► VisualCron ► SendInputInstruction

[Missing <summary> documentation for T:VisualCron.SendInputInstruction]

Declaration Syntax
C# Visual Basic Visual C++
public class SendInputInstruction : PlayerInstruction
Public Class SendInputInstruction _
    Inherits PlayerInstruction
public ref class SendInputInstruction : public PlayerInstruction
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SendInputInstruction(INPUT) | Initializes a new instance of the SendInputInstruction class
 | SendInputInstruction(INPUT, Int32) | Initializes a new instance of the SendInputInstruction class
 | Delay | (Inherited from PlayerInstruction.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute(IDictionary) | (Overrides PlayerInstruction.Execute(IDictionary).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | PlayerInstruction
 |  | SendInputInstruction


SendInputInstruction Constructor

SendInputInstruction Constructor
Namespaces ► VisualCron ► SendInputInstruction ► SendInputInstruction()()()
Members
Icon | Member | Description
 | SendInputInstruction(INPUT) | Initializes a new instance of the SendInputInstruction class
 | SendInputInstruction(INPUT, Int32) | Initializes a new instance of the SendInputInstruction class


SendInputInstruction Constructor (input)

SendInputInstruction Constructor (input)
Namespaces ► VisualCron ► SendInputInstruction ► SendInputInstruction(INPUT)
Initializes a new instance of the SendInputInstruction class
Declaration Syntax
C# Visual Basic Visual C++
public SendInputInstruction(
    INPUT input
)
Public Sub New ( _
    input As INPUT _
)
public:
SendInputInstruction(
    INPUT input
)
Parameters
input (INPUT)

[Missing <param name="input"/> documentation for "M:VisualCron.SendInputInstruction.#ctor(VisualCron.INPUT)"]


SendInputInstruction Constructor (input, del)

SendInputInstruction Constructor (input, del)
Namespaces ► VisualCron ► SendInputInstruction ► SendInputInstruction(INPUT, Int32)
Initializes a new instance of the SendInputInstruction class
Declaration Syntax
C# Visual Basic Visual C++
public SendInputInstruction(
    INPUT input,
    int del
)
Public Sub New ( _
    input As INPUT, _
    del As Integer _
)
public:
SendInputInstruction(
    INPUT input,
    int del
)
Parameters
input (INPUT)

[Missing <param name="input"/> documentation for "M:VisualCron.SendInputInstruction.#ctor(VisualCron.INPUT,System.Int32)"]

del (Int32)

[Missing <param name="del"/> documentation for "M:VisualCron.SendInputInstruction.#ctor(VisualCron.INPUT,System.Int32)"]


Execute Method (context)

Execute Method (context)
Namespaces ► VisualCron ► SendInputInstruction ► Execute(IDictionary)

[Missing <summary> documentation for M:VisualCron.SendInputInstruction.Execute(System.Collections.IDictionary)]

Declaration Syntax
C# Visual Basic Visual C++
public override void Execute(
    IDictionary context
)
Public Overrides Sub Execute ( _
    context As IDictionary _
)
public:
virtual void Execute(
    IDictionary^ context
) override
Parameters
context (IDictionary)

[Missing <param name="context"/> documentation for "M:VisualCron.SendInputInstruction.Execute(System.Collections.IDictionary)"]


ServerClass Class

ServerClass Class
Namespaces ► VisualCron ► ServerClass

[Missing <summary> documentation for T:VisualCron.ServerClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServerClass
<SerializableAttribute> _
Public Class ServerClass
[SerializableAttribute]
public ref class ServerClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServerClass()()() | Initializes a new instance of the ServerClass class
 | AutoDetectProxy |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkDomain |
 | NetworkPassword |
 | NetworkUsername |
 | Password |
 | Port |
 | ProxyPort |
 | ProxyServer |
 | Server |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseNetworkCredentials |
 | Username |
Inheritance Hierarchy
Object
ServerClass

Send comments on this topic to Please email feedback to Support


ServerClass Constructor

ServerClass Constructor
Namespaces ► VisualCron ► ServerClass ► ServerClass()()()
Initializes a new instance of the ServerClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServerClass()
Public Sub New
public:
ServerClass()


AutoDetectProxy Property

AutoDetectProxy Property
Namespaces ► VisualCron ► ServerClass ► AutoDetectProxy

[Missing <summary> documentation for P:VisualCron.ServerClass.AutoDetectProxy]

Declaration Syntax
C# Visual Basic Visual C++
public bool AutoDetectProxy { get; set; }
Public Property AutoDetectProxy As Boolean
public:
property bool AutoDetectProxy {
    bool get ();
    void set (bool value);
}


Id Property

Id Property
Namespaces ► VisualCron ► ServerClass ► Id

[Missing <summary> documentation for P:VisualCron.ServerClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


NetworkDomain Property

NetworkDomain Property
Namespaces ► VisualCron ► ServerClass ► NetworkDomain

[Missing <summary> documentation for P:VisualCron.ServerClass.NetworkDomain]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] NetworkDomain { get; set; }
Public Property NetworkDomain As Byte()
public:
property array<unsigned char>^ NetworkDomain {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


NetworkPassword Property

NetworkPassword Property
Namespaces ► VisualCron ► ServerClass ► NetworkPassword

[Missing <summary> documentation for P:VisualCron.ServerClass.NetworkPassword]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] NetworkPassword { get; set; }
Public Property NetworkPassword As Byte()
public:
property array<unsigned char>^ NetworkPassword {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


NetworkUsername Property

NetworkUsername Property
Namespaces ► VisualCron ► ServerClass ► NetworkUsername

[Missing <summary> documentation for P:VisualCron.ServerClass.NetworkUsername]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] NetworkUsername { get; set; }
Public Property NetworkUsername As Byte()
public:
property array<unsigned char>^ NetworkUsername {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


Password Property

Password Property
Namespaces ► VisualCron ► ServerClass ► Password

[Missing <summary> documentation for P:VisualCron.ServerClass.Password]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] Password { get; set; }
Public Property Password As Byte()
public:
property array<unsigned char>^ Password {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


Port Property

Port Property
Namespaces ► VisualCron ► ServerClass ► Port

[Missing <summary> documentation for P:VisualCron.ServerClass.Port]

Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
property int Port {
    int get ();
    void set (int value);
}


ProxyPort Property

ProxyPort Property
Namespaces ► VisualCron ► ServerClass ► ProxyPort

[Missing <summary> documentation for P:VisualCron.ServerClass.ProxyPort]

Declaration Syntax
C# Visual Basic Visual C++
public int ProxyPort { get; set; }
Public Property ProxyPort As Integer
public:
property int ProxyPort {
    int get ();
    void set (int value);
}


ProxyServer Property

ProxyServer Property
Namespaces ► VisualCron ► ServerClass ► ProxyServer

[Missing <summary> documentation for P:VisualCron.ServerClass.ProxyServer]

Declaration Syntax
C# Visual Basic Visual C++
public string ProxyServer { get; set; }
Public Property ProxyServer As String
public:
property String^ ProxyServer {
    String^ get ();
    void set (String^ value);
}


Server Property

Server Property
Namespaces ► VisualCron ► ServerClass ► Server

[Missing <summary> documentation for P:VisualCron.ServerClass.Server]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] Server { get; set; }
Public Property Server As Byte()
public:
property array<unsigned char>^ Server {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


UseNetworkCredentials Property

UseNetworkCredentials Property
Namespaces ► VisualCron ► ServerClass ► UseNetworkCredentials

[Missing <summary> documentation for P:VisualCron.ServerClass.UseNetworkCredentials]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseNetworkCredentials { get; set; }
Public Property UseNetworkCredentials As Boolean
public:
property bool UseNetworkCredentials {
    bool get ();
    void set (bool value);
}


Username Property

Username Property
Namespaces ► VisualCron ► ServerClass ► Username

[Missing <summary> documentation for P:VisualCron.ServerClass.Username]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] Username { get; set; }
Public Property Username As Byte()
public:
property array<unsigned char>^ Username {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


ServerInfoClass Class

ServerInfoClass Class
Namespaces ► VisualCron ► ServerInfoClass

[Missing <summary> documentation for T:VisualCron.ServerInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServerInfoClass
<SerializableAttribute> _
Public Class ServerInfoClass
[SerializableAttribute]
public ref class ServerInfoClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServerInfoClass()()() | Initializes a new instance of the ServerInfoClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Memory |
 | OperativeSystem |
 | Processor |
 | Service |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Updated |
 | VisualCronProcess |
Inheritance Hierarchy
Object
ServerInfoClass

Send comments on this topic to Please email feedback to Support


ServerInfoClass Constructor

ServerInfoClass Constructor
Namespaces ► VisualCron ► ServerInfoClass ► ServerInfoClass()()()
Initializes a new instance of the ServerInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServerInfoClass()
Public Sub New
public:
ServerInfoClass()


Memory Property

Memory Property
Namespaces ► VisualCron ► ServerInfoClass ► Memory

[Missing <summary> documentation for P:VisualCron.ServerInfoClass.Memory]

Declaration Syntax
C# Visual Basic Visual C++
public MemoryInfoClass Memory { get; set; }
Public Property Memory As MemoryInfoClass
public:
property MemoryInfoClass^ Memory {
    MemoryInfoClass^ get ();
    void set (MemoryInfoClass^ value);
}


OperativeSystem Property

OperativeSystem Property
Namespaces ► VisualCron ► ServerInfoClass ► OperativeSystem

[Missing <summary> documentation for P:VisualCron.ServerInfoClass.OperativeSystem]

Declaration Syntax
C# Visual Basic Visual C++
public OperativeSystemInfoClass OperativeSystem { get; set; }
Public Property OperativeSystem As OperativeSystemInfoClass
public:
property OperativeSystemInfoClass^ OperativeSystem {
    OperativeSystemInfoClass^ get ();
    void set (OperativeSystemInfoClass^ value);
}


Processor Property

Processor Property
Namespaces ► VisualCron ► ServerInfoClass ► Processor

[Missing <summary> documentation for P:VisualCron.ServerInfoClass.Processor]

Declaration Syntax
C# Visual Basic Visual C++
public ProcessorInfoClass Processor { get; set; }
Public Property Processor As ProcessorInfoClass
public:
property ProcessorInfoClass^ Processor {
    ProcessorInfoClass^ get ();
    void set (ProcessorInfoClass^ value);
}


Service Property

Service Property
Namespaces ► VisualCron ► ServerInfoClass ► Service

[Missing <summary> documentation for P:VisualCron.ServerInfoClass.Service]

Declaration Syntax
C# Visual Basic Visual C++
public ServiceInfoClass Service { get; set; }
Public Property Service As ServiceInfoClass
public:
property ServiceInfoClass^ Service {
    ServiceInfoClass^ get ();
    void set (ServiceInfoClass^ value);
}


Updated Property

Updated Property
Namespaces ► VisualCron ► ServerInfoClass ► Updated

[Missing <summary> documentation for P:VisualCron.ServerInfoClass.Updated]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime Updated { get; set; }
Public Property Updated As DateTime
public:
property DateTime Updated {
    DateTime get ();
    void set (DateTime value);
}


VisualCronProcess Property

VisualCronProcess Property
Namespaces ► VisualCron ► ServerInfoClass ► VisualCronProcess

[Missing <summary> documentation for P:VisualCron.ServerInfoClass.VisualCronProcess]

Declaration Syntax
C# Visual Basic Visual C++
public VisualCronProcessInfoClass VisualCronProcess { get; set; }
Public Property VisualCronProcess As VisualCronProcessInfoClass
public:
property VisualCronProcessInfoClass^ VisualCronProcess {
    VisualCronProcessInfoClass^ get ();
    void set (VisualCronProcessInfoClass^ value);
}


ServerInfoGetClass Class

ServerInfoGetClass Class
Namespaces ► VisualCron ► ServerInfoGetClass

[Missing <summary> documentation for T:VisualCron.ServerInfoGetClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServerInfoGetClass
<SerializableAttribute> _
Public Class ServerInfoGetClass
[SerializableAttribute]
public ref class ServerInfoGetClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServerInfoGetClass()()() | Initializes a new instance of the ServerInfoGetClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Refresh | If server info should be refreshed when asked for (takes a couple of seconds extra)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ServerInfoGetClass

Send comments on this topic to Please email feedback to Support


ServerInfoGetClass Constructor

ServerInfoGetClass Constructor
Namespaces ► VisualCron ► ServerInfoGetClass ► ServerInfoGetClass()()()
Initializes a new instance of the ServerInfoGetClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServerInfoGetClass()
Public Sub New
public:
ServerInfoGetClass()


Refresh Property

Refresh Property
Namespaces ► VisualCron ► ServerInfoGetClass ► Refresh
If server info should be refreshed when asked for (takes a couple of seconds extra)
Declaration Syntax
C# Visual Basic Visual C++
public bool Refresh { get; set; }
Public Property Refresh As Boolean
public:
property bool Refresh {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServerSettingsClass Class

ServerSettingsClass Class
Namespaces ► VisualCron ► ServerSettingsClass

[Missing <summary> documentation for T:VisualCron.ServerSettingsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServerSettingsClass
<SerializableAttribute> _
Public Class ServerSettingsClass
[SerializableAttribute]
public ref class ServerSettingsClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServerSettingsClass()()() | Initializes a new instance of the ServerSettingsClass class
 | AllowLocalConnectionsOnly |
 | BackupJobAdded |
 | DeleteJobLogsAdded |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedDebugging |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCluster |
 | LimitOutput |
 | LimitOutputSize |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperativeSystem |
 | Proxy |
 | ServerLanguageId |
 | ServerLogToFile |
 | ServerOn |
 | ServerPort |
 | ServerTime |
 | ServerVersion |
 | SMTPFromEmail |
 | SMTPFromName |
 | SMTPHost |
 | SMTPPassWord |
 | SMTPPort |
 | SMTPToEmail |
 | SMTPUseAuthentication |
 | SMTPUserName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ServerSettingsClass

Send comments on this topic to Please email feedback to Support


ServerSettingsClass Constructor

ServerSettingsClass Constructor
Namespaces ► VisualCron ► ServerSettingsClass ► ServerSettingsClass()()()
Initializes a new instance of the ServerSettingsClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServerSettingsClass()
Public Sub New
public:
ServerSettingsClass()


AllowLocalConnectionsOnly Property

AllowLocalConnectionsOnly Property
Namespaces ► VisualCron ► ServerSettingsClass ► AllowLocalConnectionsOnly

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.AllowLocalConnectionsOnly]

Declaration Syntax
C# Visual Basic Visual C++
public bool AllowLocalConnectionsOnly { get; set; }
Public Property AllowLocalConnectionsOnly As Boolean
public:
property bool AllowLocalConnectionsOnly {
    bool get ();
    void set (bool value);
}


BackupJobAdded Property

BackupJobAdded Property
Namespaces ► VisualCron ► ServerSettingsClass ► BackupJobAdded

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.BackupJobAdded]

Declaration Syntax
C# Visual Basic Visual C++
public bool BackupJobAdded { get; set; }
Public Property BackupJobAdded As Boolean
public:
property bool BackupJobAdded {
    bool get ();
    void set (bool value);
}


DeleteJobLogsAdded Property

DeleteJobLogsAdded Property
Namespaces ► VisualCron ► ServerSettingsClass ► DeleteJobLogsAdded

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.DeleteJobLogsAdded]

Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteJobLogsAdded { get; set; }
Public Property DeleteJobLogsAdded As Boolean
public:
property bool DeleteJobLogsAdded {
    bool get ();
    void set (bool value);
}


ExtendedDebugging Property

ExtendedDebugging Property
Namespaces ► VisualCron ► ServerSettingsClass ► ExtendedDebugging

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.ExtendedDebugging]

Declaration Syntax
C# Visual Basic Visual C++
public bool ExtendedDebugging { get; set; }
Public Property ExtendedDebugging As Boolean
public:
property bool ExtendedDebugging {
    bool get ();
    void set (bool value);
}


IsCluster Property

IsCluster Property
Namespaces ► VisualCron ► ServerSettingsClass ► IsCluster

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.IsCluster]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsCluster { get; set; }
Public Property IsCluster As Boolean
public:
property bool IsCluster {
    bool get ();
    void set (bool value);
}


LimitOutput Property

LimitOutput Property
Namespaces ► VisualCron ► ServerSettingsClass ► LimitOutput

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.LimitOutput]

Declaration Syntax
C# Visual Basic Visual C++
public bool LimitOutput { get; set; }
Public Property LimitOutput As Boolean
public:
property bool LimitOutput {
    bool get ();
    void set (bool value);
}


LimitOutputSize Property

LimitOutputSize Property
Namespaces ► VisualCron ► ServerSettingsClass ► LimitOutputSize

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.LimitOutputSize]

Declaration Syntax
C# Visual Basic Visual C++
public int LimitOutputSize { get; set; }
Public Property LimitOutputSize As Integer
public:
property int LimitOutputSize {
    int get ();
    void set (int value);
}


OperativeSystem Property

OperativeSystem Property
Namespaces ► VisualCron ► ServerSettingsClass ► OperativeSystem

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.OperativeSystem]

Declaration Syntax
C# Visual Basic Visual C++
public ServerSettingsClass..::.OperativeSystemT OperativeSystem { get; set; }
Public Property OperativeSystem As ServerSettingsClass..::.OperativeSystemT
public:
property ServerSettingsClass..::.OperativeSystemT OperativeSystem {
    ServerSettingsClass..::.OperativeSystemT get ();
    void set (ServerSettingsClass..::.OperativeSystemT value);
}


Proxy Property

Proxy Property
Namespaces ► VisualCron ► ServerSettingsClass ► Proxy

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.Proxy]

Declaration Syntax
C# Visual Basic Visual C++
public ProxyClass Proxy { get; set; }
Public Property Proxy As ProxyClass
public:
property ProxyClass^ Proxy {
    ProxyClass^ get ();
    void set (ProxyClass^ value);
}


ServerLanguageId Property

ServerLanguageId Property
Namespaces ► VisualCron ► ServerSettingsClass ► ServerLanguageId

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.ServerLanguageId]

Declaration Syntax
C# Visual Basic Visual C++
public int ServerLanguageId { get; set; }
Public Property ServerLanguageId As Integer
public:
property int ServerLanguageId {
    int get ();
    void set (int value);
}


ServerLogToFile Property

ServerLogToFile Property
Namespaces ► VisualCron ► ServerSettingsClass ► ServerLogToFile

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.ServerLogToFile]

Declaration Syntax
C# Visual Basic Visual C++
public bool ServerLogToFile { get; set; }
Public Property ServerLogToFile As Boolean
public:
property bool ServerLogToFile {
    bool get ();
    void set (bool value);
}


ServerOn Property

ServerOn Property
Namespaces ► VisualCron ► ServerSettingsClass ► ServerOn

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.ServerOn]

Declaration Syntax
C# Visual Basic Visual C++
public bool ServerOn { get; set; }
Public Property ServerOn As Boolean
public:
property bool ServerOn {
    bool get ();
    void set (bool value);
}


ServerPort Property

ServerPort Property
Namespaces ► VisualCron ► ServerSettingsClass ► ServerPort

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.ServerPort]

Declaration Syntax
C# Visual Basic Visual C++
public int ServerPort { get; set; }
Public Property ServerPort As Integer
public:
property int ServerPort {
    int get ();
    void set (int value);
}


ServerTime Property

ServerTime Property
Namespaces ► VisualCron ► ServerSettingsClass ► ServerTime

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.ServerTime]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime ServerTime { get; set; }
Public Property ServerTime As DateTime
public:
property DateTime ServerTime {
    DateTime get ();
    void set (DateTime value);
}


ServerVersion Property

ServerVersion Property
Namespaces ► VisualCron ► ServerSettingsClass ► ServerVersion

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.ServerVersion]

Declaration Syntax
C# Visual Basic Visual C++
public string ServerVersion { get; set; }
Public Property ServerVersion As String
public:
property String^ ServerVersion {
    String^ get ();
    void set (String^ value);
}


SMTPFromEmail Property

SMTPFromEmail Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPFromEmail

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPFromEmail]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPFromEmail { get; set; }
Public Property SMTPFromEmail As String
public:
property String^ SMTPFromEmail {
    String^ get ();
    void set (String^ value);
}


SMTPFromName Property

SMTPFromName Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPFromName

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPFromName]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPFromName { get; set; }
Public Property SMTPFromName As String
public:
property String^ SMTPFromName {
    String^ get ();
    void set (String^ value);
}


SMTPHost Property

SMTPHost Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPHost

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPHost]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] SMTPHost { get; set; }
Public Property SMTPHost As Byte()
public:
property array<unsigned char>^ SMTPHost {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


SMTPPassWord Property

SMTPPassWord Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPPassWord

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPPassWord]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] SMTPPassWord { get; set; }
Public Property SMTPPassWord As Byte()
public:
property array<unsigned char>^ SMTPPassWord {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


SMTPPort Property

SMTPPort Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPPort

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPPort]

Declaration Syntax
C# Visual Basic Visual C++
public int SMTPPort { get; set; }
Public Property SMTPPort As Integer
public:
property int SMTPPort {
    int get ();
    void set (int value);
}


SMTPToEmail Property

SMTPToEmail Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPToEmail

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPToEmail]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPToEmail { get; set; }
Public Property SMTPToEmail As String
public:
property String^ SMTPToEmail {
    String^ get ();
    void set (String^ value);
}


SMTPUseAuthentication Property

SMTPUseAuthentication Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPUseAuthentication

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPUseAuthentication]

Declaration Syntax
C# Visual Basic Visual C++
public bool SMTPUseAuthentication { get; set; }
Public Property SMTPUseAuthentication As Boolean
public:
property bool SMTPUseAuthentication {
    bool get ();
    void set (bool value);
}


SMTPUserName Property

SMTPUserName Property
Namespaces ► VisualCron ► ServerSettingsClass ► SMTPUserName

[Missing <summary> documentation for P:VisualCron.ServerSettingsClass.SMTPUserName]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] SMTPUserName { get; set; }
Public Property SMTPUserName As Byte()
public:
property array<unsigned char>^ SMTPUserName {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


ServerSettingsClass.OperativeSystemT Enumeration

ServerSettingsClass..::.OperativeSystemT Enumeration
Namespaces ► VisualCron ► ServerSettingsClass ► ServerSettingsClass..::.OperativeSystemT

[Missing <summary> documentation for T:VisualCron.ServerSettingsClass.OperativeSystemT]

Declaration Syntax
C# Visual Basic Visual C++
public enum OperativeSystemT
Public Enumeration OperativeSystemT
public enum class OperativeSystemT
Members
Member | Description
WindowsCE |
Windows31 |
WindowsNT351 |
WindowsNT4 |
Windows95 |
Windows98 |
WindowsME |
Windows2000 |
Windows2003 |
Windows2008 |
WindowsXP |
WindowsVista |
WindowsUnknown |


ServerStatusClass Class

ServerStatusClass Class
Namespaces ► VisualCron ► ServerStatusClass

[Missing <summary> documentation for T:VisualCron.ServerStatusClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServerStatusClass
<SerializableAttribute> _
Public Class ServerStatusClass
[SerializableAttribute]
public ref class ServerStatusClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServerStatusClass()()() | Initializes a new instance of the ServerStatusClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | On | If Server state is On
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ServerStatusClass

Send comments on this topic to Please email feedback to Support


ServerStatusClass Constructor

ServerStatusClass Constructor
Namespaces ► VisualCron ► ServerStatusClass ► ServerStatusClass()()()
Initializes a new instance of the ServerStatusClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServerStatusClass()
Public Sub New
public:
ServerStatusClass()


On Property

On Property
Namespaces ► VisualCron ► ServerStatusClass ► On
If Server state is On
Declaration Syntax
C# Visual Basic Visual C++
public bool On { get; set; }
Public Property On As Boolean
public:
property bool On {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServiceArgumentClass Class

ServiceArgumentClass Class
Namespaces ► VisualCron ► ServiceArgumentClass

[Missing <summary> documentation for T:VisualCron.ServiceArgumentClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServiceArgumentClass : ICloneable,
    IComparable
<SerializableAttribute> _
Public Class ServiceArgumentClass _
    Implements ICloneable, IComparable
[SerializableAttribute]
public ref class ServiceArgumentClass : ICloneable,
    IComparable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceArgumentClass()()() | Initializes a new instance of the ServiceArgumentClass class
 | Argument |
 | Clone()()() |
 | CompareTo(Object) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Order |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ServiceArgumentClass

Send comments on this topic to Please email feedback to Support


ServiceArgumentClass Constructor

ServiceArgumentClass Constructor
Namespaces ► VisualCron ► ServiceArgumentClass ► ServiceArgumentClass()()()
Initializes a new instance of the ServiceArgumentClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServiceArgumentClass()
Public Sub New
public:
ServiceArgumentClass()


Argument Property

Argument Property
Namespaces ► VisualCron ► ServiceArgumentClass ► Argument

[Missing <summary> documentation for P:VisualCron.ServiceArgumentClass.Argument]

Declaration Syntax
C# Visual Basic Visual C++
public string Argument { get; set; }
Public Property Argument As String
public:
property String^ Argument {
    String^ get ();
    void set (String^ value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► ServiceArgumentClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.ServiceArgumentClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.ServiceArgumentClass.Clone]


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► VisualCron ► ServiceArgumentClass ► CompareTo(Object)

[Missing <summary> documentation for M:VisualCron.ServiceArgumentClass.CompareTo(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCron.ServiceArgumentClass.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:VisualCron.ServiceArgumentClass.CompareTo(System.Object)]


Order Property

Order Property
Namespaces ► VisualCron ► ServiceArgumentClass ► Order

[Missing <summary> documentation for P:VisualCron.ServiceArgumentClass.Order]

Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
public:
property int Order {
    int get ();
    void set (int value);
}


ServiceClass Class

ServiceClass Class
Namespaces ► VisualCron ► ServiceClass
Message class. Holds a service
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServiceClass
<SerializableAttribute> _
Public Class ServiceClass
[SerializableAttribute]
public ref class ServiceClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceClass()()() | Initializes a new instance of the ServiceClass class
 | DisplayName | The verbose name
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ServiceName | The service name
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ServiceClass

Send comments on this topic to Please email feedback to Support


ServiceClass Constructor

ServiceClass Constructor
Namespaces ► VisualCron ► ServiceClass ► ServiceClass()()()
Initializes a new instance of the ServiceClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServiceClass()
Public Sub New
public:
ServiceClass()


DisplayName Property

DisplayName Property
Namespaces ► VisualCron ► ServiceClass ► DisplayName
The verbose name
Declaration Syntax
C# Visual Basic Visual C++
public string DisplayName { get; set; }
Public Property DisplayName As String
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServiceName Property

ServiceName Property
Namespaces ► VisualCron ► ServiceClass ► ServiceName
The service name
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceName { get; set; }
Public Property ServiceName As String
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServiceEventClass Class

ServiceEventClass Class
Namespaces ► VisualCron ► ServiceEventClass
Event that watches for changes in a certain Service
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServiceEventClass : ICloneable
<SerializableAttribute> _
Public Class ServiceEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class ServiceEventClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceEventClass()()() | Initializes a new instance of the ServiceEventClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interval | How often it should be queried in the WMI in seconds
 | Machine | Server name/ip of computer
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | Id of Network Credential that will be used to get access
 | ServiceName | Name of the Service to query
 | ServiceStatusArray |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ServiceEventClass

Send comments on this topic to Please email feedback to Support


ServiceEventClass Constructor

ServiceEventClass Constructor
Namespaces ► VisualCron ► ServiceEventClass ► ServiceEventClass()()()
Initializes a new instance of the ServiceEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServiceEventClass()
Public Sub New
public:
ServiceEventClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► ServiceEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.ServiceEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.ServiceEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► ServiceEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.ServiceEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public ServiceEventClass CloneType()
Public Function CloneType As ServiceEventClass
public:
ServiceEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.ServiceEventClass.CloneType]


Interval Property

Interval Property
Namespaces ► VisualCron ► ServiceEventClass ► Interval
How often it should be queried in the WMI in seconds
Declaration Syntax
C# Visual Basic Visual C++
public int Interval { get; set; }
Public Property Interval As Integer
public:
property int Interval {
    int get ();
    void set (int value);
}
Value
Default: Every 60 seconds
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Machine Property

Machine Property
Namespaces ► VisualCron ► ServiceEventClass ► Machine
Server name/ip of computer
Declaration Syntax
C# Visual Basic Visual C++
public string Machine { get; set; }
Public Property Machine As String
public:
property String^ Machine {
    String^ get ();
    void set (String^ value);
}
Value
Default: . = local computer
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► ServiceEventClass ► NetworkCredential
Id of Network Credential that will be used to get access
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServiceName Property

ServiceName Property
Namespaces ► VisualCron ► ServiceEventClass ► ServiceName
Name of the Service to query
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceName { get; set; }
Public Property ServiceName As String
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServiceStatusArray Field

ServiceStatusArray Field
Namespaces ► VisualCron ► ServiceEventClass ► ServiceStatusArray

[Missing <summary> documentation for F:VisualCron.ServiceEventClass.ServiceStatusArray]

Declaration Syntax
C# Visual Basic Visual C++
public ArrayList ServiceStatusArray
Public ServiceStatusArray As ArrayList
public:
ArrayList^ ServiceStatusArray

Send comments on this topic to Please email feedback to Support


ServiceInfoClass Class

ServiceInfoClass Class
Namespaces ► VisualCron ► ServiceInfoClass

[Missing <summary> documentation for T:VisualCron.ServiceInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServiceInfoClass
<SerializableAttribute> _
Public Class ServiceInfoClass
[SerializableAttribute]
public ref class ServiceInfoClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceInfoClass()()() | Initializes a new instance of the ServiceInfoClass class
 | Domain | The domain the server resides in
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | The user name the service is running as
Inheritance Hierarchy
Object
ServiceInfoClass

Send comments on this topic to Please email feedback to Support


ServiceInfoClass Constructor

ServiceInfoClass Constructor
Namespaces ► VisualCron ► ServiceInfoClass ► ServiceInfoClass()()()
Initializes a new instance of the ServiceInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServiceInfoClass()
Public Sub New
public:
ServiceInfoClass()


Domain Property

Domain Property
Namespaces ► VisualCron ► ServiceInfoClass ► Domain
The domain the server resides in
Declaration Syntax
C# Visual Basic Visual C++
public string Domain { get; set; }
Public Property Domain As String
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UserName Property

UserName Property
Namespaces ► VisualCron ► ServiceInfoClass ► UserName
The user name the service is running as
Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServicesClass Class

ServicesClass Class
Namespaces ► VisualCron ► ServicesClass
Message class. Used for transporting information about services to API
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServicesClass
<SerializableAttribute> _
Public Class ServicesClass
[SerializableAttribute]
public ref class ServicesClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServicesClass()()() | Initializes a new instance of the ServicesClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Services | Contains a list of ServiceClass
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ServicesClass

Send comments on this topic to Please email feedback to Support


ServicesClass Constructor

ServicesClass Constructor
Namespaces ► VisualCron ► ServicesClass ► ServicesClass()()()
Initializes a new instance of the ServicesClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServicesClass()
Public Sub New
public:
ServicesClass()


Services Property

Services Property
Namespaces ► VisualCron ► ServicesClass ► Services
Contains a list of ServiceClass
Declaration Syntax
C# Visual Basic Visual C++
public List<ServiceClass> Services { get; set; }
Public Property Services As List(Of ServiceClass)
public:
property List<ServiceClass^>^ Services {
    List<ServiceClass^>^ get ();
    void set (List<ServiceClass^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServicesGetClass Class

ServicesGetClass Class
Namespaces ► VisualCron ► ServicesGetClass

[Missing <summary> documentation for T:VisualCron.ServicesGetClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServicesGetClass
<SerializableAttribute> _
Public Class ServicesGetClass
[SerializableAttribute]
public ref class ServicesGetClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServicesGetClass()()() | Initializes a new instance of the ServicesGetClass class
 | CredentialId | If IsLocal is false the CredentialId will be used for login at remote server
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | The name of the remote server if IsLocal = false
 | IsLocal | If the services are local or remote
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ServicesGetClass

Send comments on this topic to Please email feedback to Support


ServicesGetClass Constructor

ServicesGetClass Constructor
Namespaces ► VisualCron ► ServicesGetClass ► ServicesGetClass()()()
Initializes a new instance of the ServicesGetClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServicesGetClass()
Public Sub New
public:
ServicesGetClass()


CredentialId Property

CredentialId Property
Namespaces ► VisualCron ► ServicesGetClass ► CredentialId
If IsLocal is false the CredentialId will be used for login at remote server
Declaration Syntax
C# Visual Basic Visual C++
public string CredentialId { get; set; }
Public Property CredentialId As String
public:
property String^ CredentialId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HostName Property

HostName Property
Namespaces ► VisualCron ► ServicesGetClass ► HostName
The name of the remote server if IsLocal = false
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IsLocal Property

IsLocal Property
Namespaces ► VisualCron ► ServicesGetClass ► IsLocal
If the services are local or remote
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLocal { get; set; }
Public Property IsLocal As Boolean
public:
property bool IsLocal {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ServiceTriggerResultClass Class

ServiceTriggerResultClass Class
Namespaces ► VisualCron ► ServiceTriggerResultClass

[Missing <summary> documentation for T:VisualCron.ServiceTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class ServiceTriggerResultClass
<SerializableAttribute> _
Public Class ServiceTriggerResultClass
[SerializableAttribute]
public ref class ServiceTriggerResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ServiceTriggerResultClass()()() | Initializes a new instance of the ServiceTriggerResultClass class
 | Description |
 | DisplayName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExitCode |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | PathName |
 | ProcessId |
 | ServiceSpecificExitCode |
 | State |
 | Status |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ServiceTriggerResultClass

Send comments on this topic to Please email feedback to Support


ServiceTriggerResultClass Constructor

ServiceTriggerResultClass Constructor
Namespaces ► VisualCron ► ServiceTriggerResultClass ► ServiceTriggerResultClass()()()
Initializes a new instance of the ServiceTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public ServiceTriggerResultClass()
Public Sub New
public:
ServiceTriggerResultClass()


Description Property

Description Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► Description

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}


DisplayName Property

DisplayName Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► DisplayName

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.DisplayName]

Declaration Syntax
C# Visual Basic Visual C++
public string DisplayName { get; set; }
Public Property DisplayName As String
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}


ExitCode Property

ExitCode Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► ExitCode

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.ExitCode]

Declaration Syntax
C# Visual Basic Visual C++
public int ExitCode { get; set; }
Public Property ExitCode As Integer
public:
property int ExitCode {
    int get ();
    void set (int value);
}


Name Property

Name Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► Name

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


PathName Property

PathName Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► PathName

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.PathName]

Declaration Syntax
C# Visual Basic Visual C++
public string PathName { get; set; }
Public Property PathName As String
public:
property String^ PathName {
    String^ get ();
    void set (String^ value);
}


ProcessId Property

ProcessId Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► ProcessId

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.ProcessId]

Declaration Syntax
C# Visual Basic Visual C++
public int ProcessId { get; set; }
Public Property ProcessId As Integer
public:
property int ProcessId {
    int get ();
    void set (int value);
}


ServiceSpecificExitCode Property

ServiceSpecificExitCode Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► ServiceSpecificExitCode

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.ServiceSpecificExitCode]

Declaration Syntax
C# Visual Basic Visual C++
public int ServiceSpecificExitCode { get; set; }
Public Property ServiceSpecificExitCode As Integer
public:
property int ServiceSpecificExitCode {
    int get ();
    void set (int value);
}


State Property

State Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► State

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.State]

Declaration Syntax
C# Visual Basic Visual C++
public ServiceControllerStatus State { get; set; }
Public Property State As ServiceControllerStatus
public:
property ServiceControllerStatus State {
    ServiceControllerStatus get ();
    void set (ServiceControllerStatus value);
}


Status Property

Status Property
Namespaces ► VisualCron ► ServiceTriggerResultClass ► Status

[Missing <summary> documentation for P:VisualCron.ServiceTriggerResultClass.Status]

Declaration Syntax
C# Visual Basic Visual C++
public string Status { get; set; }
Public Property Status As String
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}


SoundNotificationClass Class

SoundNotificationClass Class
Namespaces ► VisualCron ► SoundNotificationClass

[Missing <summary> documentation for T:VisualCron.SoundNotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SoundNotificationClass
<SerializableAttribute> _
Public Class SoundNotificationClass
[SerializableAttribute]
public ref class SoundNotificationClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SoundNotificationClass()()() | Initializes a new instance of the SoundNotificationClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SoundPath |
 | SoundToPlay |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SoundNotificationClass

Send comments on this topic to Please email feedback to Support


SoundNotificationClass Constructor

SoundNotificationClass Constructor
Namespaces ► VisualCron ► SoundNotificationClass ► SoundNotificationClass()()()
Initializes a new instance of the SoundNotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public SoundNotificationClass()
Public Sub New
public:
SoundNotificationClass()


SoundPath Property

SoundPath Property
Namespaces ► VisualCron ► SoundNotificationClass ► SoundPath

[Missing <summary> documentation for P:VisualCron.SoundNotificationClass.SoundPath]

Declaration Syntax
C# Visual Basic Visual C++
public string SoundPath { get; set; }
Public Property SoundPath As String
public:
property String^ SoundPath {
    String^ get ();
    void set (String^ value);
}


SoundToPlay Field

SoundToPlay Field
Namespaces ► VisualCron ► SoundNotificationClass ► SoundToPlay

[Missing <summary> documentation for F:VisualCron.SoundNotificationClass.SoundToPlay]

Declaration Syntax
C# Visual Basic Visual C++
public SoundNotificationClass..::.SoundType SoundToPlay
Public SoundToPlay As SoundNotificationClass..::.SoundType
public:
SoundNotificationClass..::.SoundType SoundToPlay


SoundNotificationClass.SoundType Enumeration

SoundNotificationClass..::.SoundType Enumeration
Namespaces ► VisualCron ► SoundNotificationClass ► SoundNotificationClass..::.SoundType

[Missing <summary> documentation for T:VisualCron.SoundNotificationClass.SoundType]

Declaration Syntax
C# Visual Basic Visual C++
public enum SoundType
Public Enumeration SoundType
public enum class SoundType
Members
Member | Description
OwnSound |
Reminder1 |
Reminder2 |
Reminder3 |


SQLConnectionClass Class

SQLConnectionClass Class
Namespaces ► VisualCron ► SQLConnectionClass

[Missing <summary> documentation for T:VisualCron.SQLConnectionClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SQLConnectionClass
<SerializableAttribute> _
Public Class SQLConnectionClass
[SerializableAttribute]
public ref class SQLConnectionClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SQLConnectionClass()()() | Initializes a new instance of the SQLConnectionClass class
 | ConnectionParameters |
 | ConnectionString | Gets or sets the connection string that is generated from guide
 | ConnectionTypeId | Value based on dictionary file, set 65 by default
 | DataBaseType | Gets or sets the type of database
 | DataProvider | Gets or sets the data provider type
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | StorageType | Gets or sets the StorageT
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WizardId | If the connection was created by the wizard
Inheritance Hierarchy
Object
SQLConnectionClass

Send comments on this topic to Please email feedback to Support


SQLConnectionClass Constructor

SQLConnectionClass Constructor
Namespaces ► VisualCron ► SQLConnectionClass ► SQLConnectionClass()()()
Initializes a new instance of the SQLConnectionClass class
Declaration Syntax
C# Visual Basic Visual C++
public SQLConnectionClass()
Public Sub New
public:
SQLConnectionClass()


ConnectionParameters Property

ConnectionParameters Property
Namespaces ► VisualCron ► SQLConnectionClass ► ConnectionParameters

[Missing <summary> documentation for P:VisualCron.SQLConnectionClass.ConnectionParameters]

Declaration Syntax
C# Visual Basic Visual C++
public List<SQLConnectionParameterClass> ConnectionParameters { get; set; }
Public Property ConnectionParameters As List(Of SQLConnectionParameterClass)
public:
property List<SQLConnectionParameterClass^>^ ConnectionParameters {
    List<SQLConnectionParameterClass^>^ get ();
    void set (List<SQLConnectionParameterClass^>^ value);
}


ConnectionString Property

ConnectionString Property
Namespaces ► VisualCron ► SQLConnectionClass ► ConnectionString
Gets or sets the connection string that is generated from guide
Declaration Syntax
C# Visual Basic Visual C++
public byte[] ConnectionString { get; set; }
Public Property ConnectionString As Byte()
public:
property array<unsigned char>^ ConnectionString {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConnectionTypeId Property

ConnectionTypeId Property
Namespaces ► VisualCron ► SQLConnectionClass ► ConnectionTypeId
Value based on dictionary file, set 65 by default
Declaration Syntax
C# Visual Basic Visual C++
public int ConnectionTypeId { get; set; }
Public Property ConnectionTypeId As Integer
public:
property int ConnectionTypeId {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DataBaseType Property

DataBaseType Property
Namespaces ► VisualCron ► SQLConnectionClass ► DataBaseType
Gets or sets the type of database
Declaration Syntax
C# Visual Basic Visual C++
public SQLConnectionClass..::.DatabaseT DataBaseType { get; set; }
Public Property DataBaseType As SQLConnectionClass..::.DatabaseT
public:
property SQLConnectionClass..::.DatabaseT DataBaseType {
    SQLConnectionClass..::.DatabaseT get ();
    void set (SQLConnectionClass..::.DatabaseT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DataProvider Property

DataProvider Property
Namespaces ► VisualCron ► SQLConnectionClass ► DataProvider
Gets or sets the data provider type
Declaration Syntax
C# Visual Basic Visual C++
public SQLConnectionClass..::.DataProviderT DataProvider { get; set; }
Public Property DataProvider As SQLConnectionClass..::.DataProviderT
public:
property SQLConnectionClass..::.DataProviderT DataProvider {
    SQLConnectionClass..::.DataProviderT get ();
    void set (SQLConnectionClass..::.DataProviderT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


StorageType Property

StorageType Property
Namespaces ► VisualCron ► SQLConnectionClass ► StorageType
Gets or sets the StorageT
Declaration Syntax
C# Visual Basic Visual C++
public SQLConnectionClass..::.StorageT StorageType { get; set; }
Public Property StorageType As SQLConnectionClass..::.StorageT
public:
property SQLConnectionClass..::.StorageT StorageType {
    SQLConnectionClass..::.StorageT get ();
    void set (SQLConnectionClass..::.StorageT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


WizardId Property

WizardId Property
Namespaces ► VisualCron ► SQLConnectionClass ► WizardId
If the connection was created by the wizard
Declaration Syntax
C# Visual Basic Visual C++
public int WizardId { get; set; }
Public Property WizardId As Integer
public:
property int WizardId {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SQLConnectionClass.DatabaseT Enumeration

SQLConnectionClass..::.DatabaseT Enumeration
Namespaces ► VisualCron ► SQLConnectionClass ► SQLConnectionClass..::.DatabaseT
Based on all databases on www.connectionstrings.com
Declaration Syntax
C# Visual Basic Visual C++
public enum DatabaseT
Public Enumeration DatabaseT
public enum class DatabaseT
Members
Member | Description
MSSQL |
MSSQL2005 |
MSSQL2005CompactEdition |
Oracle |
MySQL |
Interbase |
IBMDB2 |
SybaseAdvantageDatabaseServer |
SybaseAdaptiveServerEnterprise |
Informix |
Ingres |
MimerSQL |
Lightbase |
Postgres |
Paradox |
Firebird |
AS400ISeries |
Pervasive |
SQLBase |
Progress |
Cache |
Teradata |
VistaDB |
Excel2007 |
Excel |
Textfile |
Access2007 |
Access |
VisualFoxProAndFoxPro2 |
DBFAndFoxPro |
SQLite |
Filemaker |
HTMLTable |
MSProject |
ActiveDirectory |
Exchange |
IntuitQuickBase |
LotusNotes |
DSN |
UDL |
IndexServer |
FileDSN |
Remarks

Send comments on this topic to Please email feedback to Support


SQLConnectionClass.DataProviderT Enumeration

SQLConnectionClass..::.DataProviderT Enumeration
Namespaces ► VisualCron ► SQLConnectionClass ► SQLConnectionClass..::.DataProviderT
Supporting the 3 data providers
Declaration Syntax
C# Visual Basic Visual C++
public enum DataProviderT
Public Enumeration DataProviderT
public enum class DataProviderT
Members
Member | Description
ODBC |
OLEDB |
DirectMSSQL |
DirectMySQL |
DirectOracle |
TypeCode |
Remarks

Send comments on this topic to Please email feedback to Support


SQLConnectionClass.StorageT Enumeration

SQLConnectionClass..::.StorageT Enumeration
Namespaces ► VisualCron ► SQLConnectionClass ► SQLConnectionClass..::.StorageT
Based on the 3 types on www.connectionstrings.com
Declaration Syntax
C# Visual Basic Visual C++
public enum StorageT
Public Enumeration StorageT
public enum class StorageT
Members
Member | Description
Database |
File |
Other |
Remarks

Send comments on this topic to Please email feedback to Support


SQLConnectionParameterClass Class

SQLConnectionParameterClass Class
Namespaces ► VisualCron ► SQLConnectionParameterClass

[Missing <summary> documentation for T:VisualCron.SQLConnectionParameterClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SQLConnectionParameterClass
<SerializableAttribute> _
Public Class SQLConnectionParameterClass
[SerializableAttribute]
public ref class SQLConnectionParameterClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SQLConnectionParameterClass()()() | Initializes a new instance of the SQLConnectionParameterClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParameterName |
 | ParameterValue |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SQLConnectionParameterClass

Send comments on this topic to Please email feedback to Support


SQLConnectionParameterClass Constructor

SQLConnectionParameterClass Constructor
Namespaces ► VisualCron ► SQLConnectionParameterClass ► SQLConnectionParameterClass()()()
Initializes a new instance of the SQLConnectionParameterClass class
Declaration Syntax
C# Visual Basic Visual C++
public SQLConnectionParameterClass()
Public Sub New
public:
SQLConnectionParameterClass()


ParameterName Property

ParameterName Property
Namespaces ► VisualCron ► SQLConnectionParameterClass ► ParameterName

[Missing <summary> documentation for P:VisualCron.SQLConnectionParameterClass.ParameterName]

Declaration Syntax
C# Visual Basic Visual C++
public string ParameterName { get; set; }
Public Property ParameterName As String
public:
property String^ ParameterName {
    String^ get ();
    void set (String^ value);
}


ParameterValue Property

ParameterValue Property
Namespaces ► VisualCron ► SQLConnectionParameterClass ► ParameterValue

[Missing <summary> documentation for P:VisualCron.SQLConnectionParameterClass.ParameterValue]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] ParameterValue { get; set; }
Public Property ParameterValue As Byte()
public:
property array<unsigned char>^ ParameterValue {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


SQLNotificationClass Class

SQLNotificationClass Class
Namespaces ► VisualCron ► SQLNotificationClass

[Missing <summary> documentation for T:VisualCron.SQLNotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SQLNotificationClass
<SerializableAttribute> _
Public Class SQLNotificationClass
[SerializableAttribute]
public ref class SQLNotificationClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SQLNotificationClass()()() | Initializes a new instance of the SQLNotificationClass class
 | Command |
 | CommandTimeout |
 | CommandType |
 | ConnectionId |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parameters |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SQLNotificationClass

Send comments on this topic to Please email feedback to Support


SQLNotificationClass Constructor

SQLNotificationClass Constructor
Namespaces ► VisualCron ► SQLNotificationClass ► SQLNotificationClass()()()
Initializes a new instance of the SQLNotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public SQLNotificationClass()
Public Sub New
public:
SQLNotificationClass()


Command Property

Command Property
Namespaces ► VisualCron ► SQLNotificationClass ► Command

[Missing <summary> documentation for P:VisualCron.SQLNotificationClass.Command]

Declaration Syntax
C# Visual Basic Visual C++
public string Command { get; set; }
Public Property Command As String
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}


CommandTimeout Property

CommandTimeout Property
Namespaces ► VisualCron ► SQLNotificationClass ► CommandTimeout

[Missing <summary> documentation for P:VisualCron.SQLNotificationClass.CommandTimeout]

Declaration Syntax
C# Visual Basic Visual C++
public int CommandTimeout { get; set; }
Public Property CommandTimeout As Integer
public:
property int CommandTimeout {
    int get ();
    void set (int value);
}


CommandType Property

CommandType Property
Namespaces ► VisualCron ► SQLNotificationClass ► CommandType

[Missing <summary> documentation for P:VisualCron.SQLNotificationClass.CommandType]

Declaration Syntax
C# Visual Basic Visual C++
public CommandType CommandType { get; set; }
Public Property CommandType As CommandType
public:
property CommandType CommandType {
    CommandType get ();
    void set (CommandType value);
}


ConnectionId Property

ConnectionId Property
Namespaces ► VisualCron ► SQLNotificationClass ► ConnectionId

[Missing <summary> documentation for P:VisualCron.SQLNotificationClass.ConnectionId]

Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionId { get; set; }
Public Property ConnectionId As String
public:
property String^ ConnectionId {
    String^ get ();
    void set (String^ value);
}


Parameters Property

Parameters Property
Namespaces ► VisualCron ► SQLNotificationClass ► Parameters

[Missing <summary> documentation for P:VisualCron.SQLNotificationClass.Parameters]

Declaration Syntax
C# Visual Basic Visual C++
public List<SQLParameterClass> Parameters { get; set; }
Public Property Parameters As List(Of SQLParameterClass)
public:
property List<SQLParameterClass^>^ Parameters {
    List<SQLParameterClass^>^ get ();
    void set (List<SQLParameterClass^>^ value);
}


SQLParameterClass Class

SQLParameterClass Class
Namespaces ► VisualCron ► SQLParameterClass
Contains parameters for a stored procedure
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SQLParameterClass
<SerializableAttribute> _
Public Class SQLParameterClass
[SerializableAttribute]
public ref class SQLParameterClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SQLParameterClass()()() | Initializes a new instance of the SQLParameterClass class
 | Direction |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Unique Id of the ParameterClass (GUID)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MSSQLDataType | Data type of MSSQL parameter value
 | Name | Name of the Parameter in the Stored Procedure
 | ODBCDataType | Data type of ODBC parameter value
 | OLEDBDataType | Data type of OLEDB parameter value
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeCode | Data type for the DTS task
 | Value | Value that will be sent in the Parameter to the Stored Procedure
Remarks
Inheritance Hierarchy
Object
SQLParameterClass

Send comments on this topic to Please email feedback to Support


SQLParameterClass Constructor

SQLParameterClass Constructor
Namespaces ► VisualCron ► SQLParameterClass ► SQLParameterClass()()()
Initializes a new instance of the SQLParameterClass class
Declaration Syntax
C# Visual Basic Visual C++
public SQLParameterClass()
Public Sub New
public:
SQLParameterClass()


Direction Field

Direction Field
Namespaces ► VisualCron ► SQLParameterClass ► Direction

[Missing <summary> documentation for F:VisualCron.SQLParameterClass.Direction]

Declaration Syntax
C# Visual Basic Visual C++
public ParameterDirection Direction
Public Direction As ParameterDirection
public:
ParameterDirection Direction

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► SQLParameterClass ► Id
Unique Id of the ParameterClass (GUID)
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MSSQLDataType Field

MSSQLDataType Field
Namespaces ► VisualCron ► SQLParameterClass ► MSSQLDataType
Data type of MSSQL parameter value
Declaration Syntax
C# Visual Basic Visual C++
public SqlDbType MSSQLDataType
Public MSSQLDataType As SqlDbType
public:
SqlDbType MSSQLDataType
Remarks

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► SQLParameterClass ► Name
Name of the Parameter in the Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ODBCDataType Field

ODBCDataType Field
Namespaces ► VisualCron ► SQLParameterClass ► ODBCDataType
Data type of ODBC parameter value
Declaration Syntax
C# Visual Basic Visual C++
public OdbcType ODBCDataType
Public ODBCDataType As OdbcType
public:
OdbcType ODBCDataType
Remarks

Send comments on this topic to Please email feedback to Support


OLEDBDataType Field

OLEDBDataType Field
Namespaces ► VisualCron ► SQLParameterClass ► OLEDBDataType
Data type of OLEDB parameter value
Declaration Syntax
C# Visual Basic Visual C++
public OleDbType OLEDBDataType
Public OLEDBDataType As OleDbType
public:
OleDbType OLEDBDataType
Remarks

Send comments on this topic to Please email feedback to Support


TypeCode Field

TypeCode Field
Namespaces ► VisualCron ► SQLParameterClass ► TypeCode
Data type for the DTS task
Declaration Syntax
C# Visual Basic Visual C++
public TypeCode TypeCode
Public TypeCode As TypeCode
public:
TypeCode TypeCode
Remarks

Send comments on this topic to Please email feedback to Support


Value Property

Value Property
Namespaces ► VisualCron ► SQLParameterClass ► Value
Value that will be sent in the Parameter to the Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
public string Value { get; set; }
Public Property Value As String
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SSHCommandClass Class

SSHCommandClass Class
Namespaces ► VisualCron ► SSHCommandClass

[Missing <summary> documentation for T:VisualCron.SSHCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SSHCommandClass : IComparable,
    ICloneable
<SerializableAttribute> _
Public Class SSHCommandClass _
    Implements IComparable, ICloneable
[SerializableAttribute]
public ref class SSHCommandClass : IComparable,
    ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SSHCommandClass()()() | Initializes a new instance of the SSHCommandClass class
 | Clone()()() |
 | CloneType()()() |
 | CompareTo(Object) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Order |
 | SetToNothing()()() |
 | Text |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SSHCommandClass

Send comments on this topic to Please email feedback to Support


SSHCommandClass Constructor

SSHCommandClass Constructor
Namespaces ► VisualCron ► SSHCommandClass ► SSHCommandClass()()()
Initializes a new instance of the SSHCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public SSHCommandClass()
Public Sub New
public:
SSHCommandClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► SSHCommandClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.SSHCommandClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.SSHCommandClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► SSHCommandClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.SSHCommandClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public SSHCommandClass CloneType()
Public Function CloneType As SSHCommandClass
public:
SSHCommandClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.SSHCommandClass.CloneType]


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► VisualCron ► SSHCommandClass ► CompareTo(Object)

[Missing <summary> documentation for M:VisualCron.SSHCommandClass.CompareTo(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCron.SSHCommandClass.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:VisualCron.SSHCommandClass.CompareTo(System.Object)]


Id Property

Id Property
Namespaces ► VisualCron ► SSHCommandClass ► Id

[Missing <summary> documentation for P:VisualCron.SSHCommandClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


Order Property

Order Property
Namespaces ► VisualCron ► SSHCommandClass ► Order

[Missing <summary> documentation for P:VisualCron.SSHCommandClass.Order]

Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
public:
property int Order {
    int get ();
    void set (int value);
}


SetToNothing Method

SetToNothing Method
Namespaces ► VisualCron ► SSHCommandClass ► SetToNothing()()()

[Missing <summary> documentation for M:VisualCron.SSHCommandClass.SetToNothing]

Declaration Syntax
C# Visual Basic Visual C++
public void SetToNothing()
Public Sub SetToNothing
public:
void SetToNothing()


Text Property

Text Property
Namespaces ► VisualCron ► SSHCommandClass ► Text

[Missing <summary> documentation for P:VisualCron.SSHCommandClass.Text]

Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


SSHSendCommandClass Class

SSHSendCommandClass Class
Namespaces ► VisualCron ► SSHSendCommandClass

[Missing <summary> documentation for T:VisualCron.SSHSendCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SSHSendCommandClass
<SerializableAttribute> _
Public Class SSHSendCommandClass
[SerializableAttribute]
public ref class SSHSendCommandClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | SSHSendCommandClass()()() | Initializes a new instance of the SSHSendCommandClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SSHSendCommandClass

Send comments on this topic to Please email feedback to Support


SSHSendCommandClass Constructor

SSHSendCommandClass Constructor
Namespaces ► VisualCron ► SSHSendCommandClass ► SSHSendCommandClass()()()
Initializes a new instance of the SSHSendCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public SSHSendCommandClass()
Public Sub New
public:
SSHSendCommandClass()


SSHSendTextClass Class

SSHSendTextClass Class
Namespaces ► VisualCron ► SSHSendTextClass

[Missing <summary> documentation for T:VisualCron.SSHSendTextClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SSHSendTextClass : ICloneable
<SerializableAttribute> _
Public Class SSHSendTextClass _
    Implements ICloneable
[SerializableAttribute]
public ref class SSHSendTextClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SSHSendTextClass()()() | Initializes a new instance of the SSHSendTextClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Text |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SSHSendTextClass

Send comments on this topic to Please email feedback to Support


SSHSendTextClass Constructor

SSHSendTextClass Constructor
Namespaces ► VisualCron ► SSHSendTextClass ► SSHSendTextClass()()()
Initializes a new instance of the SSHSendTextClass class
Declaration Syntax
C# Visual Basic Visual C++
public SSHSendTextClass()
Public Sub New
public:
SSHSendTextClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► SSHSendTextClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.SSHSendTextClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.SSHSendTextClass.Clone]


Text Property

Text Property
Namespaces ► VisualCron ► SSHSendTextClass ► Text

[Missing <summary> documentation for P:VisualCron.SSHSendTextClass.Text]

Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


SyncClass Class

SyncClass Class
Namespaces ► VisualCron ► SyncClass

[Missing <summary> documentation for T:VisualCron.SyncClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SyncClass
<SerializableAttribute> _
Public Class SyncClass
[SerializableAttribute]
public ref class SyncClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SyncClass()()() | Initializes a new instance of the SyncClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SyncType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SyncClass

Send comments on this topic to Please email feedback to Support


SyncClass Constructor

SyncClass Constructor
Namespaces ► VisualCron ► SyncClass ► SyncClass()()()
Initializes a new instance of the SyncClass class
Declaration Syntax
C# Visual Basic Visual C++
public SyncClass()
Public Sub New
public:
SyncClass()


SyncType Field

SyncType Field
Namespaces ► VisualCron ► SyncClass ► SyncType

[Missing <summary> documentation for F:VisualCron.SyncClass.SyncType]

Declaration Syntax
C# Visual Basic Visual C++
public SyncClass..::.SyncT SyncType
Public SyncType As SyncClass..::.SyncT
public:
SyncClass..::.SyncT SyncType

Send comments on this topic to Please email feedback to Support


SyncClass.SyncT Enumeration

SyncClass..::.SyncT Enumeration
Namespaces ► VisualCron ► SyncClass ► SyncClass..::.SyncT

[Missing <summary> documentation for T:VisualCron.SyncClass.SyncT]

Declaration Syntax
C# Visual Basic Visual C++
public enum SyncT
Public Enumeration SyncT
public enum class SyncT
Members
Member | Description
All |
Done |


SysLogNotificationClass Class

SysLogNotificationClass Class
Namespaces ► VisualCron ► SysLogNotificationClass

[Missing <summary> documentation for T:VisualCron.SysLogNotificationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class SysLogNotificationClass
<SerializableAttribute> _
Public Class SysLogNotificationClass
[SerializableAttribute]
public ref class SysLogNotificationClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SysLogNotificationClass()()() | Initializes a new instance of the SysLogNotificationClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Facility |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Host |
 | Level |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SysLogNotificationClass

Send comments on this topic to Please email feedback to Support


SysLogNotificationClass Constructor

SysLogNotificationClass Constructor
Namespaces ► VisualCron ► SysLogNotificationClass ► SysLogNotificationClass()()()
Initializes a new instance of the SysLogNotificationClass class
Declaration Syntax
C# Visual Basic Visual C++
public SysLogNotificationClass()
Public Sub New
public:
SysLogNotificationClass()


Facility Field

Facility Field
Namespaces ► VisualCron ► SysLogNotificationClass ► Facility

[Missing <summary> documentation for F:VisualCron.SysLogNotificationClass.Facility]

Declaration Syntax
C# Visual Basic Visual C++
public SysLogNotificationClass..::.FacilityType Facility
Public Facility As SysLogNotificationClass..::.FacilityType
public:
SysLogNotificationClass..::.FacilityType Facility


Host Property

Host Property
Namespaces ► VisualCron ► SysLogNotificationClass ► Host

[Missing <summary> documentation for P:VisualCron.SysLogNotificationClass.Host]

Declaration Syntax
C# Visual Basic Visual C++
public string Host { get; set; }
Public Property Host As String
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}


Level Field

Level Field
Namespaces ► VisualCron ► SysLogNotificationClass ► Level

[Missing <summary> documentation for F:VisualCron.SysLogNotificationClass.Level]

Declaration Syntax
C# Visual Basic Visual C++
public SysLogNotificationClass..::.LevelType Level
Public Level As SysLogNotificationClass..::.LevelType
public:
SysLogNotificationClass..::.LevelType Level


Message Property

Message Property
Namespaces ► VisualCron ► SysLogNotificationClass ► Message

[Missing <summary> documentation for P:VisualCron.SysLogNotificationClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


SysLogNotificationClass.FacilityType Enumeration

SysLogNotificationClass..::.FacilityType Enumeration
Namespaces ► VisualCron ► SysLogNotificationClass ► SysLogNotificationClass..::.FacilityType

[Missing <summary> documentation for T:VisualCron.SysLogNotificationClass.FacilityType]

Declaration Syntax
C# Visual Basic Visual C++
public enum FacilityType
Public Enumeration FacilityType
public enum class FacilityType
Members
Member | Description
Kernel |
User |
Mail |
Daemon |
Auth |
Syslog |
Lpr |
News |
UUCP |
Cron |
Local0 |
Local1 |
Local2 |
Local3 |
Local4 |
Local5 |
Local6 |
Local7 |


SysLogNotificationClass.LevelType Enumeration

SysLogNotificationClass..::.LevelType Enumeration
Namespaces ► VisualCron ► SysLogNotificationClass ► SysLogNotificationClass..::.LevelType

[Missing <summary> documentation for T:VisualCron.SysLogNotificationClass.LevelType]

Declaration Syntax
C# Visual Basic Visual C++
public enum LevelType
Public Enumeration LevelType
public enum class LevelType
Members
Member | Description
Emergency |
Alert |
Critical |
LevelError |
Warning |
Notice |
Information |
Debug |


TaskArchiveClass Class

TaskArchiveClass Class
Namespaces ► VisualCron ► TaskArchiveClass

[Missing <summary> documentation for T:VisualCron.TaskArchiveClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskArchiveClass : ICloneable
<SerializableAttribute> _
Public Class TaskArchiveClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskArchiveClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskArchiveClass()()() | Initializes a new instance of the TaskArchiveClass class
 | ArchiveAction |
 | ArchiveItems |
 | ArchivePath |
 | ArchiveType |
 | Clone()()() |
 | CloneType()()() |
 | CompressionLevel |
 | Credential |
 | EncryptionMethod |
 | EncryptionStrength |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExistAction |
 | ExtractPath |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | IncludeSubfolders |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskArchiveClass

Send comments on this topic to Please email feedback to Support


TaskArchiveClass Constructor

TaskArchiveClass Constructor
Namespaces ► VisualCron ► TaskArchiveClass ► TaskArchiveClass()()()
Initializes a new instance of the TaskArchiveClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskArchiveClass()
Public Sub New
public:
TaskArchiveClass()


ArchiveAction Field

ArchiveAction Field
Namespaces ► VisualCron ► TaskArchiveClass ► ArchiveAction

[Missing <summary> documentation for F:VisualCron.TaskArchiveClass.ArchiveAction]

Declaration Syntax
C# Visual Basic Visual C++
public TaskArchiveClass..::.ArchiveActionT ArchiveAction
Public ArchiveAction As TaskArchiveClass..::.ArchiveActionT
public:
TaskArchiveClass..::.ArchiveActionT ArchiveAction


ArchiveItems Field

ArchiveItems Field
Namespaces ► VisualCron ► TaskArchiveClass ► ArchiveItems

[Missing <summary> documentation for F:VisualCron.TaskArchiveClass.ArchiveItems]

Declaration Syntax
C# Visual Basic Visual C++
public List<ArchiveItemClass> ArchiveItems
Public ArchiveItems As List(Of ArchiveItemClass)
public:
List<ArchiveItemClass^>^ ArchiveItems

Send comments on this topic to Please email feedback to Support


ArchivePath Property

ArchivePath Property
Namespaces ► VisualCron ► TaskArchiveClass ► ArchivePath

[Missing <summary> documentation for P:VisualCron.TaskArchiveClass.ArchivePath]

Declaration Syntax
C# Visual Basic Visual C++
public string ArchivePath { get; set; }
Public Property ArchivePath As String
public:
property String^ ArchivePath {
    String^ get ();
    void set (String^ value);
}


ArchiveType Field

ArchiveType Field
Namespaces ► VisualCron ► TaskArchiveClass ► ArchiveType

[Missing <summary> documentation for F:VisualCron.TaskArchiveClass.ArchiveType]

Declaration Syntax
C# Visual Basic Visual C++
public TaskArchiveClass..::.ArchiveT ArchiveType
Public ArchiveType As TaskArchiveClass..::.ArchiveT
public:
TaskArchiveClass..::.ArchiveT ArchiveType


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskArchiveClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskArchiveClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskArchiveClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TaskArchiveClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.TaskArchiveClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public TaskArchiveClass CloneType()
Public Function CloneType As TaskArchiveClass
public:
TaskArchiveClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TaskArchiveClass.CloneType]


CompressionLevel Field

CompressionLevel Field
Namespaces ► VisualCron ► TaskArchiveClass ► CompressionLevel

[Missing <summary> documentation for F:VisualCron.TaskArchiveClass.CompressionLevel]

Declaration Syntax
C# Visual Basic Visual C++
public TaskArchiveClass..::.CompressionLevelT CompressionLevel
Public CompressionLevel As TaskArchiveClass..::.CompressionLevelT
public:
TaskArchiveClass..::.CompressionLevelT CompressionLevel


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskArchiveClass ► Credential

[Missing <summary> documentation for P:VisualCron.TaskArchiveClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


EncryptionMethod Field

EncryptionMethod Field
Namespaces ► VisualCron ► TaskArchiveClass ► EncryptionMethod

[Missing <summary> documentation for F:VisualCron.TaskArchiveClass.EncryptionMethod]

Declaration Syntax
C# Visual Basic Visual C++
public TaskArchiveClass..::.EncryptionMethodT EncryptionMethod
Public EncryptionMethod As TaskArchiveClass..::.EncryptionMethodT
public:
TaskArchiveClass..::.EncryptionMethodT EncryptionMethod


EncryptionStrength Property

EncryptionStrength Property
Namespaces ► VisualCron ► TaskArchiveClass ► EncryptionStrength

[Missing <summary> documentation for P:VisualCron.TaskArchiveClass.EncryptionStrength]

Declaration Syntax
C# Visual Basic Visual C++
public int EncryptionStrength { get; set; }
Public Property EncryptionStrength As Integer
public:
property int EncryptionStrength {
    int get ();
    void set (int value);
}


ExistAction Field

ExistAction Field
Namespaces ► VisualCron ► TaskArchiveClass ► ExistAction

[Missing <summary> documentation for F:VisualCron.TaskArchiveClass.ExistAction]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.ExistActionT ExistAction
Public ExistAction As EnumClass..::.ExistActionT
public:
EnumClass..::.ExistActionT ExistAction

Send comments on this topic to Please email feedback to Support


ExtractPath Property

ExtractPath Property
Namespaces ► VisualCron ► TaskArchiveClass ► ExtractPath

[Missing <summary> documentation for P:VisualCron.TaskArchiveClass.ExtractPath]

Declaration Syntax
C# Visual Basic Visual C++
public string ExtractPath { get; set; }
Public Property ExtractPath As String
public:
property String^ ExtractPath {
    String^ get ();
    void set (String^ value);
}


Id Property

Id Property
Namespaces ► VisualCron ► TaskArchiveClass ► Id

[Missing <summary> documentation for P:VisualCron.TaskArchiveClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}


IncludeSubfolders Property

IncludeSubfolders Property
Namespaces ► VisualCron ► TaskArchiveClass ► IncludeSubfolders

[Missing <summary> documentation for P:VisualCron.TaskArchiveClass.IncludeSubfolders]

Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubfolders { get; set; }
Public Property IncludeSubfolders As Boolean
public:
property bool IncludeSubfolders {
    bool get ();
    void set (bool value);
}


PassWord Property

PassWord Property
Namespaces ► VisualCron ► TaskArchiveClass ► PassWord

[Missing <summary> documentation for P:VisualCron.TaskArchiveClass.PassWord]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] PassWord { get; set; }
Public Property PassWord As Byte()
public:
property array<unsigned char>^ PassWord {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


TaskArchiveClass.ArchiveActionT Enumeration

TaskArchiveClass..::.ArchiveActionT Enumeration
Namespaces ► VisualCron ► TaskArchiveClass ► TaskArchiveClass..::.ArchiveActionT

[Missing <summary> documentation for T:VisualCron.TaskArchiveClass.ArchiveActionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ArchiveActionT
Public Enumeration ArchiveActionT
public enum class ArchiveActionT
Members
Member | Description
Compress |
Decompress |


TaskArchiveClass.ArchiveT Enumeration

TaskArchiveClass..::.ArchiveT Enumeration
Namespaces ► VisualCron ► TaskArchiveClass ► TaskArchiveClass..::.ArchiveT

[Missing <summary> documentation for T:VisualCron.TaskArchiveClass.ArchiveT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ArchiveT
Public Enumeration ArchiveT
public enum class ArchiveT
Members
Member | Description
Zip |
Tar |
TarGZip |


TaskArchiveClass.CompressionLevelT Enumeration

TaskArchiveClass..::.CompressionLevelT Enumeration
Namespaces ► VisualCron ► TaskArchiveClass ► TaskArchiveClass..::.CompressionLevelT

[Missing <summary> documentation for T:VisualCron.TaskArchiveClass.CompressionLevelT]

Declaration Syntax
C# Visual Basic Visual C++
public enum CompressionLevelT
Public Enumeration CompressionLevelT
public enum class CompressionLevelT
Members
Member | Description
High |
Normal |
Low |
None |


TaskArchiveClass.EncryptionMethodT Enumeration

TaskArchiveClass..::.EncryptionMethodT Enumeration
Namespaces ► VisualCron ► TaskArchiveClass ► TaskArchiveClass..::.EncryptionMethodT

[Missing <summary> documentation for T:VisualCron.TaskArchiveClass.EncryptionMethodT]

Declaration Syntax
C# Visual Basic Visual C++
public enum EncryptionMethodT
Public Enumeration EncryptionMethodT
public enum class EncryptionMethodT
Members
Member | Description
Compatible |
WinZipAES |


TaskClass Class

TaskClass Class
Namespaces ► VisualCron ► TaskClass
Generic task object that contains general properties for a Task and contains all tasks.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskClass : IComparable
<SerializableAttribute> _
Public Class TaskClass _
    Implements IComparable
[SerializableAttribute]
public ref class TaskClass : IComparable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskClass()()() | Initializes a new instance of the TaskClass class
 | Archive |
 | CloneType()()() | Clones the task
 | CodePage | Gets or sets the CodePage that the task should use for all operations
 | CompareTo(Object) |
 | CompleteNotifications | An array that contains Id's of all Notifications that should be run when task is completed
 | Conditions | Gets or sets objects in the list that Contains Id's of all Conditions that are used in this task.
 | ConditionsArray | Gets or sets objects in the list that Contains Id's of all Conditions that are used in this task.
 | CopyFile |
 | CreateEmptyTasks()()() | Constructs empty tasks. Used for initializing the tasks.
 | CreateTaskTypeObject()()() |
 | DesktopMacro |
 | DTS |
 | Email |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorNotifications | An array that contains all Id's of Notifications that should be run when an error has occured in the task.
 | Execute |
 | ExecuteScript |
 | ExecutionContext | Gets or sets in which context the Task should be run
 | ExportSettings |
 | FileDelete |
 | FileRead |
 | FileRename |
 | FileTouch |
 | FileWrite |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FolderCreate |
 | FolderDelete |
 | FolderRename |
 | FTP |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HTTP |
 | Id | Gets or sets the unique Id of the Task
 | JobId | Gets or sets the Id of the parent JobClass
 | JobTaskControl |
 | Kill |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the task
 | NetPing |
 | OfficeMacro |
 | OnError | Gets or sets what should happen if an error occurs in the Task
 | Order | Gets or sets the order which the task will be run at
 | PGP |
 | PlaySound |
 | PrintDocument |
 | Registry |
 | RemoteExecute |
 | RemoteKill |
 | ResetStats()()() |
 | SendKeys |
 | ServiceRestart |
 | ServiceStart |
 | ServiceStop |
 | SetToNothing()()() | Removes information from Task objects that are not used in this Task
 | SQL |
 | SSH |
 | SSIS |
 | StartNotifications | An array that contains Id's of all Notifications that should be run at Start of task
 | Stats | The object that contains statistical information about the Task
 | StoreSTDErr | Gets or sets if the Standard Error information should be stored or not
 | StoreSTDOut | Gets or sets if the Standard Output information should be stored or not
 | SystemControlMonitor |
 | SystemHibernate |
 | SystemLock |
 | SystemLogoff |
 | SystemRestart |
 | SystemShutdown |
 | SystemStandby |
 | SystemUnLock |
 | SystemWakeUp |
 | SystemWakeUpOnLan |
 | TaskType | Gets or sets the Task type
 | TimeOut | Gets or sets the TimeOut object which control timeout behavior of the Task.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Wait |
 | VariableCalculate |
 | VariableRemove |
 | VariableSet |
Remarks
Inheritance Hierarchy
Object
TaskClass

Send comments on this topic to Please email feedback to Support


TaskClass Constructor

TaskClass Constructor
Namespaces ► VisualCron ► TaskClass ► TaskClass()()()
Initializes a new instance of the TaskClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass()
Public Sub New
public:
TaskClass()


Archive Field

Archive Field
Namespaces ► VisualCron ► TaskClass ► Archive

[Missing <summary> documentation for F:VisualCron.TaskClass.Archive]

Declaration Syntax
C# Visual Basic Visual C++
public TaskArchiveClass Archive
Public Archive As TaskArchiveClass
public:
TaskArchiveClass^ Archive

Send comments on this topic to Please email feedback to Support


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TaskClass ► CloneType()()()
Clones the task
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass CloneType()
Public Function CloneType As TaskClass
public:
TaskClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TaskClass.CloneType]

Remarks

Send comments on this topic to Please email feedback to Support


CodePage Property

CodePage Property
Namespaces ► VisualCron ► TaskClass ► CodePage
Gets or sets the CodePage that the task should use for all operations
Declaration Syntax
C# Visual Basic Visual C++
public int CodePage { get; set; }
Public Property CodePage As Integer
public:
property int CodePage {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CompareTo Method (obj)

CompareTo Method (obj)
Namespaces ► VisualCron ► TaskClass ► CompareTo(Object)

[Missing <summary> documentation for M:VisualCron.TaskClass.CompareTo(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    Object obj
)
Public Function CompareTo ( _
    obj As Object _
) As Integer
public:
virtual int CompareTo(
    Object^ obj
) sealed
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCron.TaskClass.CompareTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:VisualCron.TaskClass.CompareTo(System.Object)]


CompleteNotifications Field

CompleteNotifications Field
Namespaces ► VisualCron ► TaskClass ► CompleteNotifications
An array that contains Id's of all Notifications that should be run when task is completed
Declaration Syntax
C# Visual Basic Visual C++
public List<string> CompleteNotifications
Public CompleteNotifications As List(Of String)
public:
List<String^>^ CompleteNotifications
Remarks

Send comments on this topic to Please email feedback to Support


Conditions Field

Conditions Field
Namespaces ► VisualCron ► TaskClass ► Conditions
Gets or sets objects in the list that Contains Id's of all Conditions that are used in this task.
Declaration Syntax
C# Visual Basic Visual C++
public List<string> Conditions
Public Conditions As List(Of String)
public:
List<String^>^ Conditions
Remarks

Send comments on this topic to Please email feedback to Support


ConditionsArray Property

ConditionsArray Property
Namespaces ► VisualCron ► TaskClass ► ConditionsArray
Gets or sets objects in the list that Contains Id's of all Conditions that are used in this task.
Declaration Syntax
C# Visual Basic Visual C++
public string[] ConditionsArray { get; }
Public ReadOnly Property ConditionsArray As String()
public:
property array<String^>^ ConditionsArray {
    array<String^>^ get ();
}
Remarks

Send comments on this topic to Please email feedback to Support


CopyFile Field

CopyFile Field
Namespaces ► VisualCron ► TaskClass ► CopyFile

[Missing <summary> documentation for F:VisualCron.TaskClass.CopyFile]

Declaration Syntax
C# Visual Basic Visual C++
public TaskCopyFileClass CopyFile
Public CopyFile As TaskCopyFileClass
public:
TaskCopyFileClass^ CopyFile

Send comments on this topic to Please email feedback to Support


CreateEmptyTasks Method

CreateEmptyTasks Method
Namespaces ► VisualCron ► TaskClass ► CreateEmptyTasks()()()
Constructs empty tasks. Used for initializing the tasks.
Declaration Syntax
C# Visual Basic Visual C++
public void CreateEmptyTasks()
Public Sub CreateEmptyTasks
public:
void CreateEmptyTasks()
Remarks

Send comments on this topic to Please email feedback to Support


CreateTaskTypeObject Method

CreateTaskTypeObject Method
Namespaces ► VisualCron ► TaskClass ► CreateTaskTypeObject()()()

[Missing <summary> documentation for M:VisualCron.TaskClass.CreateTaskTypeObject]

Declaration Syntax
C# Visual Basic Visual C++
public void CreateTaskTypeObject()
Public Sub CreateTaskTypeObject
public:
void CreateTaskTypeObject()


DesktopMacro Field

DesktopMacro Field
Namespaces ► VisualCron ► TaskClass ► DesktopMacro

[Missing <summary> documentation for F:VisualCron.TaskClass.DesktopMacro]

Declaration Syntax
C# Visual Basic Visual C++
public TaskDesktopMacroClass DesktopMacro
Public DesktopMacro As TaskDesktopMacroClass
public:
TaskDesktopMacroClass^ DesktopMacro

Send comments on this topic to Please email feedback to Support


DTS Field

DTS Field
Namespaces ► VisualCron ► TaskClass ► DTS

[Missing <summary> documentation for F:VisualCron.TaskClass.DTS]

Declaration Syntax
C# Visual Basic Visual C++
public TaskDTSClass DTS
Public DTS As TaskDTSClass
public:
TaskDTSClass^ DTS

Send comments on this topic to Please email feedback to Support


Email Field

Email Field
Namespaces ► VisualCron ► TaskClass ► Email

[Missing <summary> documentation for F:VisualCron.TaskClass.Email]

Declaration Syntax
C# Visual Basic Visual C++
public TaskEmailClass Email
Public Email As TaskEmailClass
public:
TaskEmailClass^ Email

Send comments on this topic to Please email feedback to Support


ErrorNotifications Field

ErrorNotifications Field
Namespaces ► VisualCron ► TaskClass ► ErrorNotifications
An array that contains all Id's of Notifications that should be run when an error has occured in the task.
Declaration Syntax
C# Visual Basic Visual C++
public List<string> ErrorNotifications
Public ErrorNotifications As List(Of String)
public:
List<String^>^ ErrorNotifications
Remarks

Send comments on this topic to Please email feedback to Support


Execute Field

Execute Field
Namespaces ► VisualCron ► TaskClass ► Execute

[Missing <summary> documentation for F:VisualCron.TaskClass.Execute]

Declaration Syntax
C# Visual Basic Visual C++
public TaskExecuteClass Execute
Public Execute As TaskExecuteClass
public:
TaskExecuteClass^ Execute

Send comments on this topic to Please email feedback to Support


ExecuteScript Field

ExecuteScript Field
Namespaces ► VisualCron ► TaskClass ► ExecuteScript

[Missing <summary> documentation for F:VisualCron.TaskClass.ExecuteScript]

Declaration Syntax
C# Visual Basic Visual C++
public TaskExecuteScriptClass ExecuteScript
Public ExecuteScript As TaskExecuteScriptClass
public:
TaskExecuteScriptClass^ ExecuteScript

Send comments on this topic to Please email feedback to Support


ExecutionContext Property

ExecutionContext Property
Namespaces ► VisualCron ► TaskClass ► ExecutionContext
Gets or sets in which context the Task should be run
Declaration Syntax
C# Visual Basic Visual C++
public ExecutionContextClass ExecutionContext { get; set; }
Public Property ExecutionContext As ExecutionContextClass
public:
property ExecutionContextClass^ ExecutionContext {
    ExecutionContextClass^ get ();
    void set (ExecutionContextClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExportSettings Field

ExportSettings Field
Namespaces ► VisualCron ► TaskClass ► ExportSettings

[Missing <summary> documentation for F:VisualCron.TaskClass.ExportSettings]

Declaration Syntax
C# Visual Basic Visual C++
public TaskExportSettingsClass ExportSettings
Public ExportSettings As TaskExportSettingsClass
public:
TaskExportSettingsClass^ ExportSettings

Send comments on this topic to Please email feedback to Support


FileDelete Field

FileDelete Field
Namespaces ► VisualCron ► TaskClass ► FileDelete

[Missing <summary> documentation for F:VisualCron.TaskClass.FileDelete]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFileDeleteClass FileDelete
Public FileDelete As TaskFileDeleteClass
public:
TaskFileDeleteClass^ FileDelete

Send comments on this topic to Please email feedback to Support


FileRead Field

FileRead Field
Namespaces ► VisualCron ► TaskClass ► FileRead

[Missing <summary> documentation for F:VisualCron.TaskClass.FileRead]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFileReadClass FileRead
Public FileRead As TaskFileReadClass
public:
TaskFileReadClass^ FileRead

Send comments on this topic to Please email feedback to Support


FileRename Field

FileRename Field
Namespaces ► VisualCron ► TaskClass ► FileRename

[Missing <summary> documentation for F:VisualCron.TaskClass.FileRename]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFileRenameClass FileRename
Public FileRename As TaskFileRenameClass
public:
TaskFileRenameClass^ FileRename

Send comments on this topic to Please email feedback to Support


FileTouch Field

FileTouch Field
Namespaces ► VisualCron ► TaskClass ► FileTouch

[Missing <summary> documentation for F:VisualCron.TaskClass.FileTouch]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFileTouchClass FileTouch
Public FileTouch As TaskFileTouchClass
public:
TaskFileTouchClass^ FileTouch

Send comments on this topic to Please email feedback to Support


FileWrite Field

FileWrite Field
Namespaces ► VisualCron ► TaskClass ► FileWrite

[Missing <summary> documentation for F:VisualCron.TaskClass.FileWrite]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFileWriteClass FileWrite
Public FileWrite As TaskFileWriteClass
public:
TaskFileWriteClass^ FileWrite

Send comments on this topic to Please email feedback to Support


FolderCreate Field

FolderCreate Field
Namespaces ► VisualCron ► TaskClass ► FolderCreate

[Missing <summary> documentation for F:VisualCron.TaskClass.FolderCreate]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFolderCreateClass FolderCreate
Public FolderCreate As TaskFolderCreateClass
public:
TaskFolderCreateClass^ FolderCreate

Send comments on this topic to Please email feedback to Support


FolderDelete Field

FolderDelete Field
Namespaces ► VisualCron ► TaskClass ► FolderDelete

[Missing <summary> documentation for F:VisualCron.TaskClass.FolderDelete]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFolderDeleteClass FolderDelete
Public FolderDelete As TaskFolderDeleteClass
public:
TaskFolderDeleteClass^ FolderDelete

Send comments on this topic to Please email feedback to Support


FolderRename Field

FolderRename Field
Namespaces ► VisualCron ► TaskClass ► FolderRename

[Missing <summary> documentation for F:VisualCron.TaskClass.FolderRename]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFolderRenameClass FolderRename
Public FolderRename As TaskFolderRenameClass
public:
TaskFolderRenameClass^ FolderRename

Send comments on this topic to Please email feedback to Support


FTP Field

FTP Field
Namespaces ► VisualCron ► TaskClass ► FTP

[Missing <summary> documentation for F:VisualCron.TaskClass.FTP]

Declaration Syntax
C# Visual Basic Visual C++
public TaskFTPClass FTP
Public FTP As TaskFTPClass
public:
TaskFTPClass^ FTP

Send comments on this topic to Please email feedback to Support


HTTP Field

HTTP Field
Namespaces ► VisualCron ► TaskClass ► HTTP

[Missing <summary> documentation for F:VisualCron.TaskClass.HTTP]

Declaration Syntax
C# Visual Basic Visual C++
public TaskHTTPClass HTTP
Public HTTP As TaskHTTPClass
public:
TaskHTTPClass^ HTTP

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► TaskClass ► Id
Gets or sets the unique Id of the Task
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobId Property

JobId Property
Namespaces ► VisualCron ► TaskClass ► JobId
Gets or sets the Id of the parent JobClass
Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobTaskControl Field

JobTaskControl Field
Namespaces ► VisualCron ► TaskClass ► JobTaskControl

[Missing <summary> documentation for F:VisualCron.TaskClass.JobTaskControl]

Declaration Syntax
C# Visual Basic Visual C++
public TaskJobTaskControlClass JobTaskControl
Public JobTaskControl As TaskJobTaskControlClass
public:
TaskJobTaskControlClass^ JobTaskControl

Send comments on this topic to Please email feedback to Support


Kill Field

Kill Field
Namespaces ► VisualCron ► TaskClass ► Kill

[Missing <summary> documentation for F:VisualCron.TaskClass.Kill]

Declaration Syntax
C# Visual Basic Visual C++
public TaskKillClass Kill
Public Kill As TaskKillClass
public:
TaskKillClass^ Kill

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► TaskClass ► Name
Gets or sets the name of the task
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetPing Field

NetPing Field
Namespaces ► VisualCron ► TaskClass ► NetPing

[Missing <summary> documentation for F:VisualCron.TaskClass.NetPing]

Declaration Syntax
C# Visual Basic Visual C++
public TaskPingClass NetPing
Public NetPing As TaskPingClass
public:
TaskPingClass^ NetPing

Send comments on this topic to Please email feedback to Support


OfficeMacro Field

OfficeMacro Field
Namespaces ► VisualCron ► TaskClass ► OfficeMacro

[Missing <summary> documentation for F:VisualCron.TaskClass.OfficeMacro]

Declaration Syntax
C# Visual Basic Visual C++
public TaskOfficeMacroClass OfficeMacro
Public OfficeMacro As TaskOfficeMacroClass
public:
TaskOfficeMacroClass^ OfficeMacro

Send comments on this topic to Please email feedback to Support


OnError Field

OnError Field
Namespaces ► VisualCron ► TaskClass ► OnError
Gets or sets what should happen if an error occurs in the Task
Declaration Syntax
C# Visual Basic Visual C++
public OnTaskErrorClass OnError
Public OnError As OnTaskErrorClass
public:
OnTaskErrorClass^ OnError
Remarks

Send comments on this topic to Please email feedback to Support


Order Property

Order Property
Namespaces ► VisualCron ► TaskClass ► Order
Gets or sets the order which the task will be run at
Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
public:
property int Order {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PGP Field

PGP Field
Namespaces ► VisualCron ► TaskClass ► PGP

[Missing <summary> documentation for F:VisualCron.TaskClass.PGP]

Declaration Syntax
C# Visual Basic Visual C++
public TaskPGPClass PGP
Public PGP As TaskPGPClass
public:
TaskPGPClass^ PGP

Send comments on this topic to Please email feedback to Support


PlaySound Field

PlaySound Field
Namespaces ► VisualCron ► TaskClass ► PlaySound

[Missing <summary> documentation for F:VisualCron.TaskClass.PlaySound]

Declaration Syntax
C# Visual Basic Visual C++
public TaskPlaySoundClass PlaySound
Public PlaySound As TaskPlaySoundClass
public:
TaskPlaySoundClass^ PlaySound

Send comments on this topic to Please email feedback to Support


PrintDocument Field

PrintDocument Field
Namespaces ► VisualCron ► TaskClass ► PrintDocument

[Missing <summary> documentation for F:VisualCron.TaskClass.PrintDocument]

Declaration Syntax
C# Visual Basic Visual C++
public TaskPrintDocumentClass PrintDocument
Public PrintDocument As TaskPrintDocumentClass
public:
TaskPrintDocumentClass^ PrintDocument

Send comments on this topic to Please email feedback to Support


Registry Field

Registry Field
Namespaces ► VisualCron ► TaskClass ► Registry

[Missing <summary> documentation for F:VisualCron.TaskClass.Registry]

Declaration Syntax
C# Visual Basic Visual C++
public TaskRegistryClass Registry
Public Registry As TaskRegistryClass
public:
TaskRegistryClass^ Registry

Send comments on this topic to Please email feedback to Support


RemoteExecute Field

RemoteExecute Field
Namespaces ► VisualCron ► TaskClass ► RemoteExecute

[Missing <summary> documentation for F:VisualCron.TaskClass.RemoteExecute]

Declaration Syntax
C# Visual Basic Visual C++
public TaskRemoteExecuteClass RemoteExecute
Public RemoteExecute As TaskRemoteExecuteClass
public:
TaskRemoteExecuteClass^ RemoteExecute

Send comments on this topic to Please email feedback to Support


RemoteKill Field

RemoteKill Field
Namespaces ► VisualCron ► TaskClass ► RemoteKill

[Missing <summary> documentation for F:VisualCron.TaskClass.RemoteKill]

Declaration Syntax
C# Visual Basic Visual C++
public TaskRemoteKillClass RemoteKill
Public RemoteKill As TaskRemoteKillClass
public:
TaskRemoteKillClass^ RemoteKill

Send comments on this topic to Please email feedback to Support


ResetStats Method

ResetStats Method
Namespaces ► VisualCron ► TaskClass ► ResetStats()()()

[Missing <summary> documentation for M:VisualCron.TaskClass.ResetStats]

Declaration Syntax
C# Visual Basic Visual C++
public void ResetStats()
Public Sub ResetStats
public:
void ResetStats()


SendKeys Field

SendKeys Field
Namespaces ► VisualCron ► TaskClass ► SendKeys

[Missing <summary> documentation for F:VisualCron.TaskClass.SendKeys]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSendKeysClass SendKeys
Public SendKeys As TaskSendKeysClass
public:
TaskSendKeysClass^ SendKeys

Send comments on this topic to Please email feedback to Support


ServiceRestart Field

ServiceRestart Field
Namespaces ► VisualCron ► TaskClass ► ServiceRestart

[Missing <summary> documentation for F:VisualCron.TaskClass.ServiceRestart]

Declaration Syntax
C# Visual Basic Visual C++
public TaskServiceRestartClass ServiceRestart
Public ServiceRestart As TaskServiceRestartClass
public:
TaskServiceRestartClass^ ServiceRestart

Send comments on this topic to Please email feedback to Support


ServiceStart Field

ServiceStart Field
Namespaces ► VisualCron ► TaskClass ► ServiceStart

[Missing <summary> documentation for F:VisualCron.TaskClass.ServiceStart]

Declaration Syntax
C# Visual Basic Visual C++
public TaskServiceStartClass ServiceStart
Public ServiceStart As TaskServiceStartClass
public:
TaskServiceStartClass^ ServiceStart

Send comments on this topic to Please email feedback to Support


ServiceStop Field

ServiceStop Field
Namespaces ► VisualCron ► TaskClass ► ServiceStop

[Missing <summary> documentation for F:VisualCron.TaskClass.ServiceStop]

Declaration Syntax
C# Visual Basic Visual C++
public TaskServiceStopClass ServiceStop
Public ServiceStop As TaskServiceStopClass
public:
TaskServiceStopClass^ ServiceStop

Send comments on this topic to Please email feedback to Support


SetToNothing Method

SetToNothing Method
Namespaces ► VisualCron ► TaskClass ► SetToNothing()()()
Removes information from Task objects that are not used in this Task
Declaration Syntax
C# Visual Basic Visual C++
public void SetToNothing()
Public Sub SetToNothing
public:
void SetToNothing()
Remarks

Send comments on this topic to Please email feedback to Support


SQL Field

SQL Field
Namespaces ► VisualCron ► TaskClass ► SQL

[Missing <summary> documentation for F:VisualCron.TaskClass.SQL]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSQLClass SQL
Public SQL As TaskSQLClass
public:
TaskSQLClass^ SQL

Send comments on this topic to Please email feedback to Support


SSH Field

SSH Field
Namespaces ► VisualCron ► TaskClass ► SSH

[Missing <summary> documentation for F:VisualCron.TaskClass.SSH]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSSHClass SSH
Public SSH As TaskSSHClass
public:
TaskSSHClass^ SSH

Send comments on this topic to Please email feedback to Support


SSIS Field

SSIS Field
Namespaces ► VisualCron ► TaskClass ► SSIS

[Missing <summary> documentation for F:VisualCron.TaskClass.SSIS]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSSISClass SSIS
Public SSIS As TaskSSISClass
public:
TaskSSISClass^ SSIS

Send comments on this topic to Please email feedback to Support


StartNotifications Field

StartNotifications Field
Namespaces ► VisualCron ► TaskClass ► StartNotifications
An array that contains Id's of all Notifications that should be run at Start of task
Declaration Syntax
C# Visual Basic Visual C++
public List<string> StartNotifications
Public StartNotifications As List(Of String)
public:
List<String^>^ StartNotifications
Remarks

Send comments on this topic to Please email feedback to Support


Stats Field

Stats Field
Namespaces ► VisualCron ► TaskClass ► Stats
The object that contains statistical information about the Task
Declaration Syntax
C# Visual Basic Visual C++
public TaskStatsClass Stats
Public Stats As TaskStatsClass
public:
TaskStatsClass^ Stats
Remarks

Send comments on this topic to Please email feedback to Support


StoreSTDErr Property

StoreSTDErr Property
Namespaces ► VisualCron ► TaskClass ► StoreSTDErr
Gets or sets if the Standard Error information should be stored or not
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreSTDErr { get; set; }
Public Property StoreSTDErr As Boolean
public:
property bool StoreSTDErr {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


StoreSTDOut Property

StoreSTDOut Property
Namespaces ► VisualCron ► TaskClass ► StoreSTDOut
Gets or sets if the Standard Output information should be stored or not
Declaration Syntax
C# Visual Basic Visual C++
public bool StoreSTDOut { get; set; }
Public Property StoreSTDOut As Boolean
public:
property bool StoreSTDOut {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SystemControlMonitor Field

SystemControlMonitor Field
Namespaces ► VisualCron ► TaskClass ► SystemControlMonitor

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemControlMonitor]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemControlMonitorClass SystemControlMonitor
Public SystemControlMonitor As TaskSystemControlMonitorClass
public:
TaskSystemControlMonitorClass^ SystemControlMonitor


SystemHibernate Field

SystemHibernate Field
Namespaces ► VisualCron ► TaskClass ► SystemHibernate

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemHibernate]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemHibernateClass SystemHibernate
Public SystemHibernate As TaskSystemHibernateClass
public:
TaskSystemHibernateClass^ SystemHibernate


SystemLock Field

SystemLock Field
Namespaces ► VisualCron ► TaskClass ► SystemLock

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemLock]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemLockClass SystemLock
Public SystemLock As TaskSystemLockClass
public:
TaskSystemLockClass^ SystemLock

Send comments on this topic to Please email feedback to Support


SystemLogoff Field

SystemLogoff Field
Namespaces ► VisualCron ► TaskClass ► SystemLogoff

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemLogoff]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemLogoffClass SystemLogoff
Public SystemLogoff As TaskSystemLogoffClass
public:
TaskSystemLogoffClass^ SystemLogoff

Send comments on this topic to Please email feedback to Support


SystemRestart Field

SystemRestart Field
Namespaces ► VisualCron ► TaskClass ► SystemRestart

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemRestart]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemRestartClass SystemRestart
Public SystemRestart As TaskSystemRestartClass
public:
TaskSystemRestartClass^ SystemRestart

Send comments on this topic to Please email feedback to Support


SystemShutdown Field

SystemShutdown Field
Namespaces ► VisualCron ► TaskClass ► SystemShutdown

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemShutdown]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemShutdownClass SystemShutdown
Public SystemShutdown As TaskSystemShutdownClass
public:
TaskSystemShutdownClass^ SystemShutdown

Send comments on this topic to Please email feedback to Support


SystemStandby Field

SystemStandby Field
Namespaces ► VisualCron ► TaskClass ► SystemStandby

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemStandby]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemStandByClass SystemStandby
Public SystemStandby As TaskSystemStandByClass
public:
TaskSystemStandByClass^ SystemStandby

Send comments on this topic to Please email feedback to Support


SystemUnLock Field

SystemUnLock Field
Namespaces ► VisualCron ► TaskClass ► SystemUnLock

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemUnLock]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemUnLockClass SystemUnLock
Public SystemUnLock As TaskSystemUnLockClass
public:
TaskSystemUnLockClass^ SystemUnLock

Send comments on this topic to Please email feedback to Support


SystemWakeUp Field

SystemWakeUp Field
Namespaces ► VisualCron ► TaskClass ► SystemWakeUp

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemWakeUp]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemWakeUpClass SystemWakeUp
Public SystemWakeUp As TaskSystemWakeUpClass
public:
TaskSystemWakeUpClass^ SystemWakeUp

Send comments on this topic to Please email feedback to Support


SystemWakeUpOnLan Field

SystemWakeUpOnLan Field
Namespaces ► VisualCron ► TaskClass ► SystemWakeUpOnLan

[Missing <summary> documentation for F:VisualCron.TaskClass.SystemWakeUpOnLan]

Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemWakeUpOnLanClass SystemWakeUpOnLan
Public SystemWakeUpOnLan As TaskSystemWakeUpOnLanClass
public:
TaskSystemWakeUpOnLanClass^ SystemWakeUpOnLan


TaskType Field

TaskType Field
Namespaces ► VisualCron ► TaskClass ► TaskType
Gets or sets the Task type
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass..::.TaskT TaskType
Public TaskType As TaskClass..::.TaskT
public:
TaskClass..::.TaskT TaskType
Remarks

Send comments on this topic to Please email feedback to Support


TimeOut Field

TimeOut Field
Namespaces ► VisualCron ► TaskClass ► TimeOut
Gets or sets the TimeOut object which control timeout behavior of the Task.
Declaration Syntax
C# Visual Basic Visual C++
public TimeOutClass TimeOut
Public TimeOut As TimeOutClass
public:
TimeOutClass^ TimeOut
Remarks

Send comments on this topic to Please email feedback to Support


Wait Field

Wait Field
Namespaces ► VisualCron ► TaskClass ► Wait

[Missing <summary> documentation for F:VisualCron.TaskClass.Wait]

Declaration Syntax
C# Visual Basic Visual C++
public TaskWaitClass Wait
Public Wait As TaskWaitClass
public:
TaskWaitClass^ Wait

Send comments on this topic to Please email feedback to Support


VariableCalculate Field

VariableCalculate Field
Namespaces ► VisualCron ► TaskClass ► VariableCalculate

[Missing <summary> documentation for F:VisualCron.TaskClass.VariableCalculate]

Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableCalculateClass VariableCalculate
Public VariableCalculate As TaskVariableCalculateClass
public:
TaskVariableCalculateClass^ VariableCalculate


VariableRemove Field

VariableRemove Field
Namespaces ► VisualCron ► TaskClass ► VariableRemove

[Missing <summary> documentation for F:VisualCron.TaskClass.VariableRemove]

Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableRemoveClass VariableRemove
Public VariableRemove As TaskVariableRemoveClass
public:
TaskVariableRemoveClass^ VariableRemove

Send comments on this topic to Please email feedback to Support


VariableSet Field

VariableSet Field
Namespaces ► VisualCron ► TaskClass ► VariableSet

[Missing <summary> documentation for F:VisualCron.TaskClass.VariableSet]

Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableSetClass VariableSet
Public VariableSet As TaskVariableSetClass
public:
TaskVariableSetClass^ VariableSet

Send comments on this topic to Please email feedback to Support


TaskClass.TaskT Enumeration

TaskClass..::.TaskT Enumeration
Namespaces ► VisualCron ► TaskClass ► TaskClass..::.TaskT
Enum that contains the different task types
Declaration Syntax
C# Visual Basic Visual C++
public enum TaskT
Public Enumeration TaskT
public enum class TaskT
Members
Member | Description
Execute |
ExecuteScript |
RemoteExecute |
HTTP |
Kill |
RemoteKill |
SendKeys |
SQL |
SSIS |
DTS |
CopyFile |
Archive |
FTP |
PGP |
Wait |
FileDelete |
FileRename |
FileRead |
FileWrite |
FileTouch |
FolderCreate |
FolderDelete |
FolderRename |
ExportSettings |
JobTaskControl |
Email |
SSH |
SystemShutdown |
SystemRestart |
SystemLogoff |
SystemHibernate |
SystemStandby |
SystemWakeUp |
SystemWakeUpOnLan |
SystemUnlock |
SystemLock |
SystemControlMonitor |
StartService |
StopService |
VariableSet |
VariableRemove |
VariableCalculate |
RestartService |
PrintDocument |
Ping |
DesktopMacro |
PlaySound |
Registry |
OfficeMacro |
Remarks

Send comments on this topic to Please email feedback to Support


TaskCopyFileClass Class

TaskCopyFileClass Class
Namespaces ► VisualCron ► TaskCopyFileClass

[Missing <summary> documentation for T:VisualCron.TaskCopyFileClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskCopyFileClass : ICloneable
<SerializableAttribute> _
Public Class TaskCopyFileClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskCopyFileClass : ICloneable
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskCopyFileClass()()() | Initializes a new instance of the TaskCopyFileClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileCopyItems |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskCopyFileClass

Send comments on this topic to Please email feedback to Support


TaskCopyFileClass Constructor

TaskCopyFileClass Constructor
Namespaces ► VisualCron ► TaskCopyFileClass ► TaskCopyFileClass()()()
Initializes a new instance of the TaskCopyFileClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskCopyFileClass()
Public Sub New
public:
TaskCopyFileClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskCopyFileClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskCopyFileClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskCopyFileClass.Clone]


FileCopyItems Field

FileCopyItems Field
Namespaces ► VisualCron ► TaskCopyFileClass ► FileCopyItems

[Missing <summary> documentation for F:VisualCron.TaskCopyFileClass.FileCopyItems]

Declaration Syntax
C# Visual Basic Visual C++
public List<TaskCopyFileItemClass> FileCopyItems
Public FileCopyItems As List(Of TaskCopyFileItemClass)
public:
List<TaskCopyFileItemClass^>^ FileCopyItems


TaskCopyFileItemClass Class

TaskCopyFileItemClass Class
Namespaces ► VisualCron ► TaskCopyFileItemClass

[Missing <summary> documentation for T:VisualCron.TaskCopyFileItemClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskCopyFileItemClass : ICloneable
<SerializableAttribute> _
Public Class TaskCopyFileItemClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskCopyFileItemClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskCopyFileItemClass()()() | Initializes a new instance of the TaskCopyFileItemClass class
 | Clone()()() |
 | CopyFileId | Unique Id of the Copy File item
 | DeleteSourceFileAfterCopy |
 | DestinationDirectory | Destionation directory of the copied files
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileFilter | The filter object for the Item
 | FileMask | Obsolete. Use FileFilter.IncludeFileMask
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeSubfolders | Obsolete. Use FileFilter.IncludeSubfolders
 | LogToOutput |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | The Id of the Credential that is used
 | Order | Which order the item has
 | OverwriteIfExisting |
 | OverwriteIfNewer |
 | SourceDirectory | Obsolete. Use FileFilter.SourceFolder instead
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskCopyFileItemClass

Send comments on this topic to Please email feedback to Support


TaskCopyFileItemClass Constructor

TaskCopyFileItemClass Constructor
Namespaces ► VisualCron ► TaskCopyFileItemClass ► TaskCopyFileItemClass()()()
Initializes a new instance of the TaskCopyFileItemClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskCopyFileItemClass()
Public Sub New
public:
TaskCopyFileItemClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskCopyFileItemClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskCopyFileItemClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskCopyFileItemClass.Clone]


CopyFileId Property

CopyFileId Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► CopyFileId
Unique Id of the Copy File item
Declaration Syntax
C# Visual Basic Visual C++
public string CopyFileId { get; set; }
Public Property CopyFileId As String
public:
property String^ CopyFileId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DeleteSourceFileAfterCopy Property

DeleteSourceFileAfterCopy Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► DeleteSourceFileAfterCopy

[Missing <summary> documentation for P:VisualCron.TaskCopyFileItemClass.DeleteSourceFileAfterCopy]

Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteSourceFileAfterCopy { get; set; }
Public Property DeleteSourceFileAfterCopy As Boolean
public:
property bool DeleteSourceFileAfterCopy {
    bool get ();
    void set (bool value);
}


DestinationDirectory Property

DestinationDirectory Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► DestinationDirectory
Destionation directory of the copied files
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationDirectory { get; set; }
Public Property DestinationDirectory As String
public:
property String^ DestinationDirectory {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► FileFilter
The filter object for the Item
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileMask Property

FileMask Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► FileMask
Obsolete. Use FileFilter.IncludeFileMask
Declaration Syntax
C# Visual Basic Visual C++
public string FileMask { get; set; }
Public Property FileMask As String
public:
property String^ FileMask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeSubfolders Property

IncludeSubfolders Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► IncludeSubfolders
Obsolete. Use FileFilter.IncludeSubfolders
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubfolders { get; set; }
Public Property IncludeSubfolders As Boolean
public:
property bool IncludeSubfolders {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LogToOutput Property

LogToOutput Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► LogToOutput

[Missing <summary> documentation for P:VisualCron.TaskCopyFileItemClass.LogToOutput]

Declaration Syntax
C# Visual Basic Visual C++
public bool LogToOutput { get; set; }
Public Property LogToOutput As Boolean
public:
property bool LogToOutput {
    bool get ();
    void set (bool value);
}


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► NetworkCredential
The Id of the Credential that is used
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Order Property

Order Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► Order
Which order the item has
Declaration Syntax
C# Visual Basic Visual C++
public int Order { get; set; }
Public Property Order As Integer
public:
property int Order {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OverwriteIfExisting Property

OverwriteIfExisting Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► OverwriteIfExisting

[Missing <summary> documentation for P:VisualCron.TaskCopyFileItemClass.OverwriteIfExisting]

Declaration Syntax
C# Visual Basic Visual C++
public bool OverwriteIfExisting { get; set; }
Public Property OverwriteIfExisting As Boolean
public:
property bool OverwriteIfExisting {
    bool get ();
    void set (bool value);
}


OverwriteIfNewer Property

OverwriteIfNewer Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► OverwriteIfNewer

[Missing <summary> documentation for P:VisualCron.TaskCopyFileItemClass.OverwriteIfNewer]

Declaration Syntax
C# Visual Basic Visual C++
public bool OverwriteIfNewer { get; set; }
Public Property OverwriteIfNewer As Boolean
public:
property bool OverwriteIfNewer {
    bool get ();
    void set (bool value);
}


SourceDirectory Property

SourceDirectory Property
Namespaces ► VisualCron ► TaskCopyFileItemClass ► SourceDirectory
Obsolete. Use FileFilter.SourceFolder instead
Declaration Syntax
C# Visual Basic Visual C++
public string SourceDirectory { get; set; }
Public Property SourceDirectory As String
public:
property String^ SourceDirectory {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskDeleteClass Class

TaskDeleteClass Class
Namespaces ► VisualCron ► TaskDeleteClass
Message that is used to delete a certain Task.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskDeleteClass
<SerializableAttribute> _
Public Class TaskDeleteClass
[SerializableAttribute]
public ref class TaskDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskDeleteClass()()() | Initializes a new instance of the TaskDeleteClass class
 | Deleted | Indicates if the Task was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId | Id of the JobClass
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId | Id of the TaskClass
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskDeleteClass

Send comments on this topic to Please email feedback to Support


TaskDeleteClass Constructor

TaskDeleteClass Constructor
Namespaces ► VisualCron ► TaskDeleteClass ► TaskDeleteClass()()()
Initializes a new instance of the TaskDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskDeleteClass()
Public Sub New
public:
TaskDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► TaskDeleteClass ► Deleted
Indicates if the Task was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobId Property

JobId Property
Namespaces ► VisualCron ► TaskDeleteClass ► JobId
Id of the JobClass
Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskId Property

TaskId Property
Namespaces ► VisualCron ► TaskDeleteClass ► TaskId
Id of the TaskClass
Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskDesktopMacroClass Class

TaskDesktopMacroClass Class
Namespaces ► VisualCron ► TaskDesktopMacroClass
Macro class that holds all the commands as well as other macro properties.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskDesktopMacroClass : ICloneable
<SerializableAttribute> _
Public Class TaskDesktopMacroClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskDesktopMacroClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskDesktopMacroClass()()() | Initializes a new instance of the TaskDesktopMacroClass class
 | AbortIfWindowNotFound |
 | Clone()()() |
 | Commands |
 | Duration |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShowPlayBackWindow |
 | ShowRecordStopDialog |
 | Speed |
 | SuppressMessageBoxes |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | XMLDuration |
Inheritance Hierarchy
Object
TaskDesktopMacroClass

Send comments on this topic to Please email feedback to Support


TaskDesktopMacroClass Constructor

TaskDesktopMacroClass Constructor
Namespaces ► VisualCron ► TaskDesktopMacroClass ► TaskDesktopMacroClass()()()
Initializes a new instance of the TaskDesktopMacroClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskDesktopMacroClass()
Public Sub New
public:
TaskDesktopMacroClass()


AbortIfWindowNotFound Property

AbortIfWindowNotFound Property
Namespaces ► VisualCron ► TaskDesktopMacroClass ► AbortIfWindowNotFound

[Missing <summary> documentation for P:VisualCron.TaskDesktopMacroClass.AbortIfWindowNotFound]

Declaration Syntax
C# Visual Basic Visual C++
public bool AbortIfWindowNotFound { get; set; }
Public Property AbortIfWindowNotFound As Boolean
public:
property bool AbortIfWindowNotFound {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskDesktopMacroClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskDesktopMacroClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskDesktopMacroClass.Clone]


Commands Property

Commands Property
Namespaces ► VisualCron ► TaskDesktopMacroClass ► Commands

[Missing <summary> documentation for P:VisualCron.TaskDesktopMacroClass.Commands]

Declaration Syntax
C# Visual Basic Visual C++
public List<Command> Commands { get; set; }
Public Property Commands As List(Of Command)
public:
property List<Command^>^ Commands {
    List<Command^>^ get ();
    void set (List<Command^>^ value);
}


Duration Field

Duration Field
Namespaces ► VisualCron ► TaskDesktopMacroClass ► Duration

[Missing <summary> documentation for F:VisualCron.TaskDesktopMacroClass.Duration]

Declaration Syntax
C# Visual Basic Visual C++
public TimeSpan Duration
Public Duration As TimeSpan
public:
TimeSpan Duration

Send comments on this topic to Please email feedback to Support


ShowPlayBackWindow Property

ShowPlayBackWindow Property
Namespaces ► VisualCron ► TaskDesktopMacroClass ► ShowPlayBackWindow

[Missing <summary> documentation for P:VisualCron.TaskDesktopMacroClass.ShowPlayBackWindow]

Declaration Syntax
C# Visual Basic Visual C++
public bool ShowPlayBackWindow { get; set; }
Public Property ShowPlayBackWindow As Boolean
public:
property bool ShowPlayBackWindow {
    bool get ();
    void set (bool value);
}


ShowRecordStopDialog Property

ShowRecordStopDialog Property
Namespaces ► VisualCron ► TaskDesktopMacroClass ► ShowRecordStopDialog

[Missing <summary> documentation for P:VisualCron.TaskDesktopMacroClass.ShowRecordStopDialog]

Declaration Syntax
C# Visual Basic Visual C++
public bool ShowRecordStopDialog { get; set; }
Public Property ShowRecordStopDialog As Boolean
public:
property bool ShowRecordStopDialog {
    bool get ();
    void set (bool value);
}


Speed Property

Speed Property
Namespaces ► VisualCron ► TaskDesktopMacroClass ► Speed

[Missing <summary> documentation for P:VisualCron.TaskDesktopMacroClass.Speed]

Declaration Syntax
C# Visual Basic Visual C++
public TaskDesktopMacroClass..::.MacroSpeed Speed { get; set; }
Public Property Speed As TaskDesktopMacroClass..::.MacroSpeed
public:
property TaskDesktopMacroClass..::.MacroSpeed Speed {
    TaskDesktopMacroClass..::.MacroSpeed get ();
    void set (TaskDesktopMacroClass..::.MacroSpeed value);
}


SuppressMessageBoxes Property

SuppressMessageBoxes Property
Namespaces ► VisualCron ► TaskDesktopMacroClass ► SuppressMessageBoxes

[Missing <summary> documentation for P:VisualCron.TaskDesktopMacroClass.SuppressMessageBoxes]

Declaration Syntax
C# Visual Basic Visual C++
public bool SuppressMessageBoxes { get; set; }
Public Property SuppressMessageBoxes As Boolean
public:
property bool SuppressMessageBoxes {
    bool get ();
    void set (bool value);
}


XMLDuration Property

XMLDuration Property
Namespaces ► VisualCron ► TaskDesktopMacroClass ► XMLDuration

[Missing <summary> documentation for P:VisualCron.TaskDesktopMacroClass.XMLDuration]

Declaration Syntax
C# Visual Basic Visual C++
public string XMLDuration { get; set; }
Public Property XMLDuration As String
public:
property String^ XMLDuration {
    String^ get ();
    void set (String^ value);
}


TaskDesktopMacroClass.MacroSpeed Enumeration

TaskDesktopMacroClass..::.MacroSpeed Enumeration
Namespaces ► VisualCron ► TaskDesktopMacroClass ► TaskDesktopMacroClass..::.MacroSpeed

[Missing <summary> documentation for T:VisualCron.TaskDesktopMacroClass.MacroSpeed]

Declaration Syntax
C# Visual Basic Visual C++
public enum MacroSpeed
Public Enumeration MacroSpeed
public enum class MacroSpeed
Members
Member | Description
Normal |
High |
Ultra |


TaskDesktopMacroClass.MacroStatus Enumeration

TaskDesktopMacroClass..::.MacroStatus Enumeration
Namespaces ► VisualCron ► TaskDesktopMacroClass ► TaskDesktopMacroClass..::.MacroStatus

[Missing <summary> documentation for T:VisualCron.TaskDesktopMacroClass.MacroStatus]

Declaration Syntax
C# Visual Basic Visual C++
public enum MacroStatus
Public Enumeration MacroStatus
public enum class MacroStatus
Members
Member | Description
None |
Playing |
Paused |


TaskDTSClass Class

TaskDTSClass Class
Namespaces ► VisualCron ► TaskDTSClass
The SSIS task can execute Sql Server 2005 Integration Services packages
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskDTSClass : ICloneable
<SerializableAttribute> _
Public Class TaskDTSClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskDTSClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskDTSClass()()() | Initializes a new instance of the TaskDTSClass class
 | Clone()()() |
 | Credential | Gets or sets the Credential Id that will be used for Integrated Windows Security
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PackageLocation | Gets or sets where the package is located
 | PackageName | Gets or sets the name of the package
 | PackagePath | Gets or sets the patch to the package
 | Parameters | A list of parameters (SQLParameterClass) that is used for the Stored Procedure
 | SQLCredential | Gets or sets the Credential Id that will be used when loading the package from the SQL Server
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskDTSClass

Send comments on this topic to Please email feedback to Support


TaskDTSClass Constructor

TaskDTSClass Constructor
Namespaces ► VisualCron ► TaskDTSClass ► TaskDTSClass()()()
Initializes a new instance of the TaskDTSClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskDTSClass()
Public Sub New
public:
TaskDTSClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskDTSClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskDTSClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskDTSClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskDTSClass ► Credential
Gets or sets the Credential Id that will be used for Integrated Windows Security
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PackageLocation Property

PackageLocation Property
Namespaces ► VisualCron ► TaskDTSClass ► PackageLocation
Gets or sets where the package is located
Declaration Syntax
C# Visual Basic Visual C++
public TaskDTSClass..::.DTSPackageLocationT PackageLocation { get; set; }
Public Property PackageLocation As TaskDTSClass..::.DTSPackageLocationT
public:
property TaskDTSClass..::.DTSPackageLocationT PackageLocation {
    TaskDTSClass..::.DTSPackageLocationT get ();
    void set (TaskDTSClass..::.DTSPackageLocationT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PackageName Property

PackageName Property
Namespaces ► VisualCron ► TaskDTSClass ► PackageName
Gets or sets the name of the package
Declaration Syntax
C# Visual Basic Visual C++
public string PackageName { get; set; }
Public Property PackageName As String
public:
property String^ PackageName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PackagePath Property

PackagePath Property
Namespaces ► VisualCron ► TaskDTSClass ► PackagePath
Gets or sets the patch to the package
Declaration Syntax
C# Visual Basic Visual C++
public string PackagePath { get; set; }
Public Property PackagePath As String
public:
property String^ PackagePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
When Database as DTSLocationT is used

Send comments on this topic to Please email feedback to Support


Parameters Field

Parameters Field
Namespaces ► VisualCron ► TaskDTSClass ► Parameters
A list of parameters (SQLParameterClass) that is used for the Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
public List<SQLParameterClass> Parameters
Public Parameters As List(Of SQLParameterClass)
public:
List<SQLParameterClass^>^ Parameters
Remarks

Send comments on this topic to Please email feedback to Support


SQLCredential Property

SQLCredential Property
Namespaces ► VisualCron ► TaskDTSClass ► SQLCredential
Gets or sets the Credential Id that will be used when loading the package from the SQL Server
Declaration Syntax
C# Visual Basic Visual C++
public string SQLCredential { get; set; }
Public Property SQLCredential As String
public:
property String^ SQLCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskDTSClass.DTSPackageLocationT Enumeration

TaskDTSClass..::.DTSPackageLocationT Enumeration
Namespaces ► VisualCron ► TaskDTSClass ► TaskDTSClass..::.DTSPackageLocationT
Enum that describes where the package is located
Declaration Syntax
C# Visual Basic Visual C++
public enum DTSPackageLocationT
Public Enumeration DTSPackageLocationT
public enum class DTSPackageLocationT
Members
Member | Description
File |
Database |
DTSServer |
Repository |
Remarks

Send comments on this topic to Please email feedback to Support


TaskEmailClass Class

TaskEmailClass Class
Namespaces ► VisualCron ► TaskEmailClass
The Email task is able to send one or more emails
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskEmailClass : ICloneable
<SerializableAttribute> _
Public Class TaskEmailClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskEmailClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskEmailClass()()() | Initializes a new instance of the TaskEmailClass class
 | Attachments | Gets or sets the list of Attachments that should be used in the Email.
 | Clone()()() |
 | Connection | Gets or sets the Id of the Connection that is used when connecting to the SMTP server
 | EmailPriority | Gets or sets the priority of the email message.
 | Encrypt | Gets or sets if email should be encrypted
 | EncryptionIdList | List of id of key OR certificate that is used for encryption
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromEmail | Gets or sets the from email address of the message.
 | FromName | Gets or sets the from name of the message.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HTMLToSend | Gets or sets the string (that should contain HTML) that is sent as HTML.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PGPPrivateKeyRingId | PGP private key ring for signing
 | PGPPublicKeyRingId | PGP public key ring id for encryption
 | PGPUseNewFeatures | Use this property for compatibility with old versions of PGP-compatible software. If this property is set to True, then newer and stronger algorithms will be used. If the property is set to False, then the result will be compatible with PGP 2.6.x, while the keys are compatible (i.e. don't use features not supported by PGP 2.6.x).
 | RecipientFile | Gets or sets the file with Recipients.
 | RecipientSeparator | Gets or sets the Recipient separator.
 | RecipientSource | Gets or sets the where the Recipients are taken from.
 | RecipientString | Gets or sets the string with Recipients.
 | ReplyToEmail | Gets or sets the ReplyTo email that should be used in the message.
 | RequestDeliveryReceipt | Gets or sets if a delivery receipt should be requested from the SMTP server.
 | RequestReadReceipt | Gets or sets if a read receipt should be requested from the receiver.
 | SecurityMethod | Gets or sets what kind of security method should be used
 | SendHTML | Gets or sets if the email should be sent as HTML
 | SendSeparateEmails | Gets or sets if recipeients should receive one same email or separate
 | SendText | Gets or sets if the email should be sent as Text
 | Sign | Gets or sets if email should be signed
 | SignClearFormat | There are two possible types of message signing. If the first type is used any user will be able to read the message. If program that can't process signatures is used there is no way to check signature but it is still possible to read the message. When this type is used content-type of the message is 'multipart/signed'. When second type is used, such program will be only able to show attachment with no meaning. But the second type is more protected against damages during passing the mail servers. When this type is used, content-type of the message is 'application/pksc7-mime; smime-type=signed-data'. Default value is True which corresponds to the first type.
 | SignId | Single id of key OR certificate that is used for signing
 | SignPassword | The private key password ( for signing )
 | SignRootHeader | Use this property to specify whether to sign root header of the message.
 | Subject | Gets or sets the subject of the message.
 | TextToSend | Gets or sets the string that should be sent as text.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskEmailClass

Send comments on this topic to Please email feedback to Support


TaskEmailClass Constructor

TaskEmailClass Constructor
Namespaces ► VisualCron ► TaskEmailClass ► TaskEmailClass()()()
Initializes a new instance of the TaskEmailClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskEmailClass()
Public Sub New
public:
TaskEmailClass()


Attachments Field

Attachments Field
Namespaces ► VisualCron ► TaskEmailClass ► Attachments
Gets or sets the list of Attachments that should be used in the Email.
Declaration Syntax
C# Visual Basic Visual C++
public List<AttachmentClass> Attachments
Public Attachments As List(Of AttachmentClass)
public:
List<AttachmentClass^>^ Attachments
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskEmailClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskEmailClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskEmailClass.Clone]


Connection Property

Connection Property
Namespaces ► VisualCron ► TaskEmailClass ► Connection
Gets or sets the Id of the Connection that is used when connecting to the SMTP server
Declaration Syntax
C# Visual Basic Visual C++
public string Connection { get; set; }
Public Property Connection As String
public:
property String^ Connection {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EmailPriority Property

EmailPriority Property
Namespaces ► VisualCron ► TaskEmailClass ► EmailPriority
Gets or sets the priority of the email message.
Declaration Syntax
C# Visual Basic Visual C++
public TaskEmailClass..::.EmailPriorityT EmailPriority { get; set; }
Public Property EmailPriority As TaskEmailClass..::.EmailPriorityT
public:
property TaskEmailClass..::.EmailPriorityT EmailPriority {
    TaskEmailClass..::.EmailPriorityT get ();
    void set (TaskEmailClass..::.EmailPriorityT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Encrypt Property

Encrypt Property
Namespaces ► VisualCron ► TaskEmailClass ► Encrypt
Gets or sets if email should be encrypted
Declaration Syntax
C# Visual Basic Visual C++
public bool Encrypt { get; set; }
Public Property Encrypt As Boolean
public:
property bool Encrypt {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EncryptionIdList Property

EncryptionIdList Property
Namespaces ► VisualCron ► TaskEmailClass ► EncryptionIdList
List of id of key OR certificate that is used for encryption
Declaration Syntax
C# Visual Basic Visual C++
public List<string> EncryptionIdList { get; set; }
Public Property EncryptionIdList As List(Of String)
public:
property List<String^>^ EncryptionIdList {
    List<String^>^ get ();
    void set (List<String^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FromEmail Property

FromEmail Property
Namespaces ► VisualCron ► TaskEmailClass ► FromEmail
Gets or sets the from email address of the message.
Declaration Syntax
C# Visual Basic Visual C++
public string FromEmail { get; set; }
Public Property FromEmail As String
public:
property String^ FromEmail {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FromName Property

FromName Property
Namespaces ► VisualCron ► TaskEmailClass ► FromName
Gets or sets the from name of the message.
Declaration Syntax
C# Visual Basic Visual C++
public string FromName { get; set; }
Public Property FromName As String
public:
property String^ FromName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HTMLToSend Property

HTMLToSend Property
Namespaces ► VisualCron ► TaskEmailClass ► HTMLToSend
Gets or sets the string (that should contain HTML) that is sent as HTML.
Declaration Syntax
C# Visual Basic Visual C++
public string HTMLToSend { get; set; }
Public Property HTMLToSend As String
public:
property String^ HTMLToSend {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PGPPrivateKeyRingId Property

PGPPrivateKeyRingId Property
Namespaces ► VisualCron ► TaskEmailClass ► PGPPrivateKeyRingId
PGP private key ring for signing
Declaration Syntax
C# Visual Basic Visual C++
public string PGPPrivateKeyRingId { get; set; }
Public Property PGPPrivateKeyRingId As String
public:
property String^ PGPPrivateKeyRingId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PGPPublicKeyRingId Property

PGPPublicKeyRingId Property
Namespaces ► VisualCron ► TaskEmailClass ► PGPPublicKeyRingId
PGP public key ring id for encryption
Declaration Syntax
C# Visual Basic Visual C++
public string PGPPublicKeyRingId { get; set; }
Public Property PGPPublicKeyRingId As String
public:
property String^ PGPPublicKeyRingId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PGPUseNewFeatures Property

PGPUseNewFeatures Property
Namespaces ► VisualCron ► TaskEmailClass ► PGPUseNewFeatures
Use this property for compatibility with old versions of PGP-compatible software. If this property is set to True, then newer and stronger algorithms will be used. If the property is set to False, then the result will be compatible with PGP 2.6.x, while the keys are compatible (i.e. don't use features not supported by PGP 2.6.x).
Declaration Syntax
C# Visual Basic Visual C++
public bool PGPUseNewFeatures { get; set; }
Public Property PGPUseNewFeatures As Boolean
public:
property bool PGPUseNewFeatures {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RecipientFile Property

RecipientFile Property
Namespaces ► VisualCron ► TaskEmailClass ► RecipientFile
Gets or sets the file with Recipients.
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientFile { get; set; }
Public Property RecipientFile As String
public:
property String^ RecipientFile {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RecipientSeparator Field

RecipientSeparator Field
Namespaces ► VisualCron ► TaskEmailClass ► RecipientSeparator
Gets or sets the Recipient separator.
Declaration Syntax
C# Visual Basic Visual C++
public TaskEmailClass..::.RecipientSeparatorT RecipientSeparator
Public RecipientSeparator As TaskEmailClass..::.RecipientSeparatorT
public:
TaskEmailClass..::.RecipientSeparatorT RecipientSeparator
Remarks

Send comments on this topic to Please email feedback to Support


RecipientSource Field

RecipientSource Field
Namespaces ► VisualCron ► TaskEmailClass ► RecipientSource
Gets or sets the where the Recipients are taken from.
Declaration Syntax
C# Visual Basic Visual C++
public TaskEmailClass..::.RecipientSourceT RecipientSource
Public RecipientSource As TaskEmailClass..::.RecipientSourceT
public:
TaskEmailClass..::.RecipientSourceT RecipientSource
Remarks

Send comments on this topic to Please email feedback to Support


RecipientString Property

RecipientString Property
Namespaces ► VisualCron ► TaskEmailClass ► RecipientString
Gets or sets the string with Recipients.
Declaration Syntax
C# Visual Basic Visual C++
public string RecipientString { get; set; }
Public Property RecipientString As String
public:
property String^ RecipientString {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ReplyToEmail Property

ReplyToEmail Property
Namespaces ► VisualCron ► TaskEmailClass ► ReplyToEmail
Gets or sets the ReplyTo email that should be used in the message.
Declaration Syntax
C# Visual Basic Visual C++
public string ReplyToEmail { get; set; }
Public Property ReplyToEmail As String
public:
property String^ ReplyToEmail {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RequestDeliveryReceipt Property

RequestDeliveryReceipt Property
Namespaces ► VisualCron ► TaskEmailClass ► RequestDeliveryReceipt
Gets or sets if a delivery receipt should be requested from the SMTP server.
Declaration Syntax
C# Visual Basic Visual C++
public bool RequestDeliveryReceipt { get; set; }
Public Property RequestDeliveryReceipt As Boolean
public:
property bool RequestDeliveryReceipt {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RequestReadReceipt Property

RequestReadReceipt Property
Namespaces ► VisualCron ► TaskEmailClass ► RequestReadReceipt
Gets or sets if a read receipt should be requested from the receiver.
Declaration Syntax
C# Visual Basic Visual C++
public bool RequestReadReceipt { get; set; }
Public Property RequestReadReceipt As Boolean
public:
property bool RequestReadReceipt {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SecurityMethod Property

SecurityMethod Property
Namespaces ► VisualCron ► TaskEmailClass ► SecurityMethod
Gets or sets what kind of security method should be used
Declaration Syntax
C# Visual Basic Visual C++
public TaskEmailClass..::.SecurityMethodT SecurityMethod { get; set; }
Public Property SecurityMethod As TaskEmailClass..::.SecurityMethodT
public:
property TaskEmailClass..::.SecurityMethodT SecurityMethod {
    TaskEmailClass..::.SecurityMethodT get ();
    void set (TaskEmailClass..::.SecurityMethodT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SendHTML Property

SendHTML Property
Namespaces ► VisualCron ► TaskEmailClass ► SendHTML
Gets or sets if the email should be sent as HTML
Declaration Syntax
C# Visual Basic Visual C++
public bool SendHTML { get; set; }
Public Property SendHTML As Boolean
public:
property bool SendHTML {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
You need to specify HTMLToSend when this is set to true


SendSeparateEmails Property

SendSeparateEmails Property
Namespaces ► VisualCron ► TaskEmailClass ► SendSeparateEmails
Gets or sets if recipeients should receive one same email or separate
Declaration Syntax
C# Visual Basic Visual C++
public bool SendSeparateEmails { get; set; }
Public Property SendSeparateEmails As Boolean
public:
property bool SendSeparateEmails {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SendText Property

SendText Property
Namespaces ► VisualCron ► TaskEmailClass ► SendText
Gets or sets if the email should be sent as Text
Declaration Syntax
C# Visual Basic Visual C++
public bool SendText { get; set; }
Public Property SendText As Boolean
public:
property bool SendText {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
You need to specify TextToSend when this is set to true


Sign Property

Sign Property
Namespaces ► VisualCron ► TaskEmailClass ► Sign
Gets or sets if email should be signed
Declaration Syntax
C# Visual Basic Visual C++
public bool Sign { get; set; }
Public Property Sign As Boolean
public:
property bool Sign {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SignClearFormat Property

SignClearFormat Property
Namespaces ► VisualCron ► TaskEmailClass ► SignClearFormat
There are two possible types of message signing. If the first type is used any user will be able to read the message. If program that can't process signatures is used there is no way to check signature but it is still possible to read the message. When this type is used content-type of the message is 'multipart/signed'. When second type is used, such program will be only able to show attachment with no meaning. But the second type is more protected against damages during passing the mail servers. When this type is used, content-type of the message is 'application/pksc7-mime; smime-type=signed-data'. Default value is True which corresponds to the first type.
Declaration Syntax
C# Visual Basic Visual C++
public bool SignClearFormat { get; set; }
Public Property SignClearFormat As Boolean
public:
property bool SignClearFormat {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SignId Property

SignId Property
Namespaces ► VisualCron ► TaskEmailClass ► SignId
Single id of key OR certificate that is used for signing
Declaration Syntax
C# Visual Basic Visual C++
public string SignId { get; set; }
Public Property SignId As String
public:
property String^ SignId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SignPassword Property

SignPassword Property
Namespaces ► VisualCron ► TaskEmailClass ► SignPassword
The private key password ( for signing )
Declaration Syntax
C# Visual Basic Visual C++
public byte[] SignPassword { get; set; }
Public Property SignPassword As Byte()
public:
property array<unsigned char>^ SignPassword {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SignRootHeader Property

SignRootHeader Property
Namespaces ► VisualCron ► TaskEmailClass ► SignRootHeader
Use this property to specify whether to sign root header of the message.
Declaration Syntax
C# Visual Basic Visual C++
public bool SignRootHeader { get; set; }
Public Property SignRootHeader As Boolean
public:
property bool SignRootHeader {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Subject Property

Subject Property
Namespaces ► VisualCron ► TaskEmailClass ► Subject
Gets or sets the subject of the message.
Declaration Syntax
C# Visual Basic Visual C++
public string Subject { get; set; }
Public Property Subject As String
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TextToSend Property

TextToSend Property
Namespaces ► VisualCron ► TaskEmailClass ► TextToSend
Gets or sets the string that should be sent as text.
Declaration Syntax
C# Visual Basic Visual C++
public string TextToSend { get; set; }
Public Property TextToSend As String
public:
property String^ TextToSend {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskEmailClass.EmailPriorityT Enumeration

TaskEmailClass..::.EmailPriorityT Enumeration
Namespaces ► VisualCron ► TaskEmailClass ► TaskEmailClass..::.EmailPriorityT
Enum that contains different priorities that is interpreted by the Email Client.
Declaration Syntax
C# Visual Basic Visual C++
public enum EmailPriorityT
Public Enumeration EmailPriorityT
public enum class EmailPriorityT
Members
Member | Description
Low |
Normal |
High |
Remarks

Send comments on this topic to Please email feedback to Support


TaskEmailClass.RecipientSeparatorT Enumeration

TaskEmailClass..::.RecipientSeparatorT Enumeration
Namespaces ► VisualCron ► TaskEmailClass ► TaskEmailClass..::.RecipientSeparatorT
Enum that contains different ways to separate a list of Recipients
Declaration Syntax
C# Visual Basic Visual C++
public enum RecipientSeparatorT
Public Enumeration RecipientSeparatorT
public enum class RecipientSeparatorT
Members
Member | Description
Semicolon |
Comma |
Newline |
Remarks

Send comments on this topic to Please email feedback to Support


TaskEmailClass.RecipientSourceT Enumeration

TaskEmailClass..::.RecipientSourceT Enumeration
Namespaces ► VisualCron ► TaskEmailClass ► TaskEmailClass..::.RecipientSourceT
Enum that contains different ways the Recipient list is built.
Declaration Syntax
C# Visual Basic Visual C++
public enum RecipientSourceT
Public Enumeration RecipientSourceT
public enum class RecipientSourceT
Members
Member | Description
File |
Manual |
List |
Remarks

Send comments on this topic to Please email feedback to Support


TaskEmailClass.SecurityMethodT Enumeration

TaskEmailClass..::.SecurityMethodT Enumeration
Namespaces ► VisualCron ► TaskEmailClass ► TaskEmailClass..::.SecurityMethodT
Enum that contains different security methods
Declaration Syntax
C# Visual Basic Visual C++
public enum SecurityMethodT
Public Enumeration SecurityMethodT
public enum class SecurityMethodT
Members
Member | Description
NoMethod |
PGP |
SMIME |
Remarks

Send comments on this topic to Please email feedback to Support


TaskExecuteClass Class

TaskExecuteClass Class
Namespaces ► VisualCron ► TaskExecuteClass
The Execute task which can start an Executable
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskExecuteClass : ICloneable
<SerializableAttribute> _
Public Class TaskExecuteClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskExecuteClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskExecuteClass()()() | Initializes a new instance of the TaskExecuteClass class
 | Arguments | Gets or sets the arguments that should be used when starting the process
 | CheckIfRunning | Gets or sets if a check should be made if a certain process is already running
 | Clone()()() |
 | CmdLine | Gets or sets the path to the executable
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogonType | Gets or sets the Logon type
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | Gets or sets the Id of the Credential
 | Priority | Gets or sets the process priority.
 | ProcessName | Gets or sets the process image name that should not be running (if CheckIfRunning is set to true)
 | RunAsType | Gets or sets the Run As type
 | RunHidden | Gets or sets the property which controls if the process should be running in visible or hidden mode
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseCredentials | Gets or sets if the specified Credential Id should be used
 | UseShellExecute | This setting concerns whether or not to use the operating system shell to start the process. Default is unchecked which means that the process is created directly from the executable file instead of (true) use the shell when starting the process.
 | UseWorkingDirectory | Gets or sets if the working directory of the process.
 | WorkingDirectory | Gets or sets the working directory.
Remarks
Inheritance Hierarchy
Object
TaskExecuteClass

Send comments on this topic to Please email feedback to Support


TaskExecuteClass Constructor

TaskExecuteClass Constructor
Namespaces ► VisualCron ► TaskExecuteClass ► TaskExecuteClass()()()
Initializes a new instance of the TaskExecuteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskExecuteClass()
Public Sub New
public:
TaskExecuteClass()


Arguments Property

Arguments Property
Namespaces ► VisualCron ► TaskExecuteClass ► Arguments
Gets or sets the arguments that should be used when starting the process
Declaration Syntax
C# Visual Basic Visual C++
public string Arguments { get; set; }
Public Property Arguments As String
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CheckIfRunning Property

CheckIfRunning Property
Namespaces ► VisualCron ► TaskExecuteClass ► CheckIfRunning
Gets or sets if a check should be made if a certain process is already running
Declaration Syntax
C# Visual Basic Visual C++
public bool CheckIfRunning { get; set; }
Public Property CheckIfRunning As Boolean
public:
property bool CheckIfRunning {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskExecuteClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskExecuteClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskExecuteClass.Clone]


CmdLine Property

CmdLine Property
Namespaces ► VisualCron ► TaskExecuteClass ► CmdLine
Gets or sets the path to the executable
Declaration Syntax
C# Visual Basic Visual C++
public string CmdLine { get; set; }
Public Property CmdLine As String
public:
property String^ CmdLine {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LogonType Property

LogonType Property
Namespaces ► VisualCron ► TaskExecuteClass ► LogonType
Gets or sets the Logon type
Declaration Syntax
C# Visual Basic Visual C++
public TaskExecuteClass..::.LogonT LogonType { get; set; }
Public Property LogonType As TaskExecuteClass..::.LogonT
public:
property TaskExecuteClass..::.LogonT LogonType {
    TaskExecuteClass..::.LogonT get ();
    void set (TaskExecuteClass..::.LogonT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► TaskExecuteClass ► NetworkCredential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Priority Property

Priority Property
Namespaces ► VisualCron ► TaskExecuteClass ► Priority
Gets or sets the process priority.
Declaration Syntax
C# Visual Basic Visual C++
public ProcessPriorityClass Priority { get; set; }
Public Property Priority As ProcessPriorityClass
public:
property ProcessPriorityClass Priority {
    ProcessPriorityClass get ();
    void set (ProcessPriorityClass value);
}
Value
Return Value
Remarks
http://msdn2.microsoft.com/en-us/library/system.diagnostics.processpriorityclass.aspx


ProcessName Property

ProcessName Property
Namespaces ► VisualCron ► TaskExecuteClass ► ProcessName
Gets or sets the process image name that should not be running (if CheckIfRunning is set to true)
Declaration Syntax
C# Visual Basic Visual C++
public string ProcessName { get; set; }
Public Property ProcessName As String
public:
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RunAsType Property

RunAsType Property
Namespaces ► VisualCron ► TaskExecuteClass ► RunAsType
Gets or sets the Run As type
Declaration Syntax
C# Visual Basic Visual C++
public TaskExecuteClass..::.RunAsT RunAsType { get; set; }
Public Property RunAsType As TaskExecuteClass..::.RunAsT
public:
property TaskExecuteClass..::.RunAsT RunAsType {
    TaskExecuteClass..::.RunAsT get ();
    void set (TaskExecuteClass..::.RunAsT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RunHidden Property

RunHidden Property
Namespaces ► VisualCron ► TaskExecuteClass ► RunHidden
Gets or sets the property which controls if the process should be running in visible or hidden mode
Declaration Syntax
C# Visual Basic Visual C++
public bool RunHidden { get; set; }
Public Property RunHidden As Boolean
public:
property bool RunHidden {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseCredentials Property

UseCredentials Property
Namespaces ► VisualCron ► TaskExecuteClass ► UseCredentials
Gets or sets if the specified Credential Id should be used
Declaration Syntax
C# Visual Basic Visual C++
public bool UseCredentials { get; set; }
Public Property UseCredentials As Boolean
public:
property bool UseCredentials {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseShellExecute Property

UseShellExecute Property
Namespaces ► VisualCron ► TaskExecuteClass ► UseShellExecute
This setting concerns whether or not to use the operating system shell to start the process. Default is unchecked which means that the process is created directly from the executable file instead of (true) use the shell when starting the process.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseShellExecute { get; set; }
Public Property UseShellExecute As Boolean
public:
property bool UseShellExecute {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseWorkingDirectory Property

UseWorkingDirectory Property
Namespaces ► VisualCron ► TaskExecuteClass ► UseWorkingDirectory
Gets or sets if the working directory of the process.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseWorkingDirectory { get; set; }
Public Property UseWorkingDirectory As Boolean
public:
property bool UseWorkingDirectory {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
The Working Directory property behaves differently when Use shell execute is true than when Use shell execute is false. When Use shell execute is true, Working Directory specifies the location of the executable. If Working Directory is an empty string, the current directory is understood to contain the executable. When Use shell execute is false, the Working Directory property is not used to find the executable. Instead, it is used by the process that is launched and only has meaning within the context of the new process.


WorkingDirectory Property

WorkingDirectory Property
Namespaces ► VisualCron ► TaskExecuteClass ► WorkingDirectory
Gets or sets the working directory.
Declaration Syntax
C# Visual Basic Visual C++
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
The Working Directory property behaves differently when Use shell execute is true than when Use shell execute is false. When Use shell execute is true, Working Directory specifies the location of the executable. If Working Directory is an empty string, the current directory is understood to contain the executable. When Use shell execute is false, the Working Directory property is not used to find the executable. Instead, it is used by the process that is launched and only has meaning within the context of the new process.


TaskExecuteClass.LogonT Enumeration

TaskExecuteClass..::.LogonT Enumeration
Namespaces ► VisualCron ► TaskExecuteClass ► TaskExecuteClass..::.LogonT
Enum that contains different logon types
Declaration Syntax
C# Visual Basic Visual C++
public enum LogonT
Public Enumeration LogonT
public enum class LogonT
Members
Member | Description
NetworkCredentialsOnly |
WithProfile |
Remarks

Send comments on this topic to Please email feedback to Support


TaskExecuteClass.RunAsT Enumeration

TaskExecuteClass..::.RunAsT Enumeration
Namespaces ► VisualCron ► TaskExecuteClass ► TaskExecuteClass..::.RunAsT
Enum that contains different Run As types
Declaration Syntax
C# Visual Basic Visual C++
public enum RunAsT
Public Enumeration RunAsT
public enum class RunAsT
Members
Member | Description
API |
Managed |
Remarks

Send comments on this topic to Please email feedback to Support


TaskExecuteScriptClass Class

TaskExecuteScriptClass Class
Namespaces ► VisualCron ► TaskExecuteScriptClass
The Execute script Task executes vbscript and jscript
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskExecuteScriptClass : ICloneable
<SerializableAttribute> _
Public Class TaskExecuteScriptClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskExecuteScriptClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskExecuteScriptClass()()() | Initializes a new instance of the TaskExecuteScriptClass class
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Path to file
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskExecuteScriptClass

Send comments on this topic to Please email feedback to Support


TaskExecuteScriptClass Constructor

TaskExecuteScriptClass Constructor
Namespaces ► VisualCron ► TaskExecuteScriptClass ► TaskExecuteScriptClass()()()
Initializes a new instance of the TaskExecuteScriptClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskExecuteScriptClass()
Public Sub New
public:
TaskExecuteScriptClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskExecuteScriptClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskExecuteScriptClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskExecuteScriptClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskExecuteScriptClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FilePath Property

FilePath Property
Namespaces ► VisualCron ► TaskExecuteScriptClass ► FilePath
Path to file
Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskExportSettingsClass Class

TaskExportSettingsClass Class
Namespaces ► VisualCron ► TaskExportSettingsClass

[Missing <summary> documentation for T:VisualCron.TaskExportSettingsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskExportSettingsClass : ICloneable
<SerializableAttribute> _
Public Class TaskExportSettingsClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskExportSettingsClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskExportSettingsClass()()() | Initializes a new instance of the TaskExportSettingsClass class
 | Clone()()() |
 | Credential |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExportAllSettings |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Path |
 | Settings |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseDefaultPath |
Inheritance Hierarchy
Object
TaskExportSettingsClass

Send comments on this topic to Please email feedback to Support


TaskExportSettingsClass Constructor

TaskExportSettingsClass Constructor
Namespaces ► VisualCron ► TaskExportSettingsClass ► TaskExportSettingsClass()()()
Initializes a new instance of the TaskExportSettingsClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskExportSettingsClass()
Public Sub New
public:
TaskExportSettingsClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskExportSettingsClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskExportSettingsClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskExportSettingsClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskExportSettingsClass ► Credential

[Missing <summary> documentation for P:VisualCron.TaskExportSettingsClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


ExportAllSettings Property

ExportAllSettings Property
Namespaces ► VisualCron ► TaskExportSettingsClass ► ExportAllSettings

[Missing <summary> documentation for P:VisualCron.TaskExportSettingsClass.ExportAllSettings]

Declaration Syntax
C# Visual Basic Visual C++
public bool ExportAllSettings { get; set; }
Public Property ExportAllSettings As Boolean
public:
property bool ExportAllSettings {
    bool get ();
    void set (bool value);
}


Path Property

Path Property
Namespaces ► VisualCron ► TaskExportSettingsClass ► Path

[Missing <summary> documentation for P:VisualCron.TaskExportSettingsClass.Path]

Declaration Syntax
C# Visual Basic Visual C++
public string Path { get; set; }
Public Property Path As String
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}


Settings Field

Settings Field
Namespaces ► VisualCron ► TaskExportSettingsClass ► Settings

[Missing <summary> documentation for F:VisualCron.TaskExportSettingsClass.Settings]

Declaration Syntax
C# Visual Basic Visual C++
public List<TaskExportSettingsClass..::.SettingsT> Settings
Public Settings As List(Of TaskExportSettingsClass..::.SettingsT)
public:
List<TaskExportSettingsClass..::.SettingsT>^ Settings


UseDefaultPath Property

UseDefaultPath Property
Namespaces ► VisualCron ► TaskExportSettingsClass ► UseDefaultPath

[Missing <summary> documentation for P:VisualCron.TaskExportSettingsClass.UseDefaultPath]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultPath { get; set; }
Public Property UseDefaultPath As Boolean
public:
property bool UseDefaultPath {
    bool get ();
    void set (bool value);
}


TaskExportSettingsClass.SettingsT Enumeration

TaskExportSettingsClass..::.SettingsT Enumeration
Namespaces ► VisualCron ► TaskExportSettingsClass ► TaskExportSettingsClass..::.SettingsT

[Missing <summary> documentation for T:VisualCron.TaskExportSettingsClass.SettingsT]

Declaration Syntax
C# Visual Basic Visual C++
public enum SettingsT
Public Enumeration SettingsT
public enum class SettingsT
Members
Member | Description
Conditions |
Jobs |
Notifications |
TimeExceptions |
Credentials |
InternalSettings |
UserPermissions |
Connections |
PGPKeyRings |
Certificates |
NetworkDrives |
Variables |


TaskFileDeleteClass Class

TaskFileDeleteClass Class
Namespaces ► VisualCron ► TaskFileDeleteClass

[Missing <summary> documentation for T:VisualCron.TaskFileDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFileDeleteClass : ICloneable
<SerializableAttribute> _
Public Class TaskFileDeleteClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFileDeleteClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFileDeleteClass()()() | Initializes a new instance of the TaskFileDeleteClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | DeleteEmptySubFolders | If empty sub folders should be deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileFilter | Filter object that controls files to delete
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder | Obsolete. Please use the FileFilter.SourceFolder property instead.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeSubfolders | Obsolete. Please use the FileFilter.IncludeSubFolders property instead.
 | Mask | Obsolete. Please use the FileFilter.IncludeFileMask property instead.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskFileDeleteClass

Send comments on this topic to Please email feedback to Support


TaskFileDeleteClass Constructor

TaskFileDeleteClass Constructor
Namespaces ► VisualCron ► TaskFileDeleteClass ► TaskFileDeleteClass()()()
Initializes a new instance of the TaskFileDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFileDeleteClass()
Public Sub New
public:
TaskFileDeleteClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFileDeleteClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFileDeleteClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFileDeleteClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFileDeleteClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DeleteEmptySubFolders Property

DeleteEmptySubFolders Property
Namespaces ► VisualCron ► TaskFileDeleteClass ► DeleteEmptySubFolders
If empty sub folders should be deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool DeleteEmptySubFolders { get; set; }
Public Property DeleteEmptySubFolders As Boolean
public:
property bool DeleteEmptySubFolders {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► TaskFileDeleteClass ► FileFilter
Filter object that controls files to delete
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Folder Property

Folder Property
Namespaces ► VisualCron ► TaskFileDeleteClass ► Folder
Obsolete. Please use the FileFilter.SourceFolder property instead.
Declaration Syntax
C# Visual Basic Visual C++
public string Folder { get; set; }
Public Property Folder As String
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeSubfolders Property

IncludeSubfolders Property
Namespaces ► VisualCron ► TaskFileDeleteClass ► IncludeSubfolders
Obsolete. Please use the FileFilter.IncludeSubFolders property instead.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeSubfolders { get; set; }
Public Property IncludeSubfolders As Boolean
public:
property bool IncludeSubfolders {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Mask Property

Mask Property
Namespaces ► VisualCron ► TaskFileDeleteClass ► Mask
Obsolete. Please use the FileFilter.IncludeFileMask property instead.
Declaration Syntax
C# Visual Basic Visual C++
public string Mask { get; set; }
Public Property Mask As String
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskFileReadClass Class

TaskFileReadClass Class
Namespaces ► VisualCron ► TaskFileReadClass

[Missing <summary> documentation for T:VisualCron.TaskFileReadClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFileReadClass : ICloneable
<SerializableAttribute> _
Public Class TaskFileReadClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFileReadClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFileReadClass()()() | Initializes a new instance of the TaskFileReadClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath | Path to file
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskFileReadClass

Send comments on this topic to Please email feedback to Support


TaskFileReadClass Constructor

TaskFileReadClass Constructor
Namespaces ► VisualCron ► TaskFileReadClass ► TaskFileReadClass()()()
Initializes a new instance of the TaskFileReadClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFileReadClass()
Public Sub New
public:
TaskFileReadClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFileReadClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFileReadClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFileReadClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFileReadClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FilePath Property

FilePath Property
Namespaces ► VisualCron ► TaskFileReadClass ► FilePath
Path to file
Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskFileRenameClass Class

TaskFileRenameClass Class
Namespaces ► VisualCron ► TaskFileRenameClass

[Missing <summary> documentation for T:VisualCron.TaskFileRenameClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFileRenameClass : ICloneable
<SerializableAttribute> _
Public Class TaskFileRenameClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFileRenameClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFileRenameClass()()() | Initializes a new instance of the TaskFileRenameClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExistAction |
 | FileFilter | Filter object that controls files to rename
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewNameMask | Mask property for renaming the source file. See documentation for usage.
 | NewPath | Obsolete, use NewNameMask instead
 | OldPath | Obsolete, use FileFilter property instead
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskFileRenameClass

Send comments on this topic to Please email feedback to Support


TaskFileRenameClass Constructor

TaskFileRenameClass Constructor
Namespaces ► VisualCron ► TaskFileRenameClass ► TaskFileRenameClass()()()
Initializes a new instance of the TaskFileRenameClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFileRenameClass()
Public Sub New
public:
TaskFileRenameClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFileRenameClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFileRenameClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFileRenameClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFileRenameClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExistAction Field

ExistAction Field
Namespaces ► VisualCron ► TaskFileRenameClass ► ExistAction

[Missing <summary> documentation for F:VisualCron.TaskFileRenameClass.ExistAction]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.ExistActionT ExistAction
Public ExistAction As EnumClass..::.ExistActionT
public:
EnumClass..::.ExistActionT ExistAction

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► TaskFileRenameClass ► FileFilter
Filter object that controls files to rename
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NewNameMask Property

NewNameMask Property
Namespaces ► VisualCron ► TaskFileRenameClass ► NewNameMask
Mask property for renaming the source file. See documentation for usage.
Declaration Syntax
C# Visual Basic Visual C++
public string NewNameMask { get; set; }
Public Property NewNameMask As String
public:
property String^ NewNameMask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NewPath Property

NewPath Property
Namespaces ► VisualCron ► TaskFileRenameClass ► NewPath
Obsolete, use NewNameMask instead
Declaration Syntax
C# Visual Basic Visual C++
public string NewPath { get; set; }
Public Property NewPath As String
public:
property String^ NewPath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OldPath Property

OldPath Property
Namespaces ► VisualCron ► TaskFileRenameClass ► OldPath
Obsolete, use FileFilter property instead
Declaration Syntax
C# Visual Basic Visual C++
public string OldPath { get; set; }
Public Property OldPath As String
public:
property String^ OldPath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskFileTouchClass Class

TaskFileTouchClass Class
Namespaces ► VisualCron ► TaskFileTouchClass

[Missing <summary> documentation for T:VisualCron.TaskFileTouchClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFileTouchClass : ICloneable
<SerializableAttribute> _
Public Class TaskFileTouchClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFileTouchClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFileTouchClass()()() | Initializes a new instance of the TaskFileTouchClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileFilter | Filter object that controls files to touch
 | FilePath | Obsolete. Use FileFilter instead.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskFileTouchClass

Send comments on this topic to Please email feedback to Support


TaskFileTouchClass Constructor

TaskFileTouchClass Constructor
Namespaces ► VisualCron ► TaskFileTouchClass ► TaskFileTouchClass()()()
Initializes a new instance of the TaskFileTouchClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFileTouchClass()
Public Sub New
public:
TaskFileTouchClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFileTouchClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFileTouchClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFileTouchClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFileTouchClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► TaskFileTouchClass ► FileFilter
Filter object that controls files to touch
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FilePath Property

FilePath Property
Namespaces ► VisualCron ► TaskFileTouchClass ► FilePath
Obsolete. Use FileFilter instead.
Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskFileWriteClass Class

TaskFileWriteClass Class
Namespaces ► VisualCron ► TaskFileWriteClass

[Missing <summary> documentation for T:VisualCron.TaskFileWriteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFileWriteClass : ICloneable
<SerializableAttribute> _
Public Class TaskFileWriteClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFileWriteClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFileWriteClass()()() | Initializes a new instance of the TaskFileWriteClass class
 | Append |
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WriteValue |
Inheritance Hierarchy
Object
TaskFileWriteClass

Send comments on this topic to Please email feedback to Support


TaskFileWriteClass Constructor

TaskFileWriteClass Constructor
Namespaces ► VisualCron ► TaskFileWriteClass ► TaskFileWriteClass()()()
Initializes a new instance of the TaskFileWriteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFileWriteClass()
Public Sub New
public:
TaskFileWriteClass()


Append Property

Append Property
Namespaces ► VisualCron ► TaskFileWriteClass ► Append

[Missing <summary> documentation for P:VisualCron.TaskFileWriteClass.Append]

Declaration Syntax
C# Visual Basic Visual C++
public bool Append { get; set; }
Public Property Append As Boolean
public:
property bool Append {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFileWriteClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFileWriteClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFileWriteClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFileWriteClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FilePath Property

FilePath Property
Namespaces ► VisualCron ► TaskFileWriteClass ► FilePath

[Missing <summary> documentation for P:VisualCron.TaskFileWriteClass.FilePath]

Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}


WriteValue Property

WriteValue Property
Namespaces ► VisualCron ► TaskFileWriteClass ► WriteValue

[Missing <summary> documentation for P:VisualCron.TaskFileWriteClass.WriteValue]

Declaration Syntax
C# Visual Basic Visual C++
public string WriteValue { get; set; }
Public Property WriteValue As String
public:
property String^ WriteValue {
    String^ get ();
    void set (String^ value);
}


TaskFolderCreateClass Class

TaskFolderCreateClass Class
Namespaces ► VisualCron ► TaskFolderCreateClass

[Missing <summary> documentation for T:VisualCron.TaskFolderCreateClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFolderCreateClass : ICloneable
<SerializableAttribute> _
Public Class TaskFolderCreateClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFolderCreateClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFolderCreateClass()()() | Initializes a new instance of the TaskFolderCreateClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskFolderCreateClass

Send comments on this topic to Please email feedback to Support


TaskFolderCreateClass Constructor

TaskFolderCreateClass Constructor
Namespaces ► VisualCron ► TaskFolderCreateClass ► TaskFolderCreateClass()()()
Initializes a new instance of the TaskFolderCreateClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFolderCreateClass()
Public Sub New
public:
TaskFolderCreateClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFolderCreateClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFolderCreateClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFolderCreateClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFolderCreateClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Folder Property

Folder Property
Namespaces ► VisualCron ► TaskFolderCreateClass ► Folder

[Missing <summary> documentation for P:VisualCron.TaskFolderCreateClass.Folder]

Declaration Syntax
C# Visual Basic Visual C++
public string Folder { get; set; }
Public Property Folder As String
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}


TaskFolderDeleteClass Class

TaskFolderDeleteClass Class
Namespaces ► VisualCron ► TaskFolderDeleteClass

[Missing <summary> documentation for T:VisualCron.TaskFolderDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFolderDeleteClass : ICloneable
<SerializableAttribute> _
Public Class TaskFolderDeleteClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFolderDeleteClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFolderDeleteClass()()() | Initializes a new instance of the TaskFolderDeleteClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Folder |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PlaceInRecycleBin |
 | Recursive | True to remove subdirectories and files
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskFolderDeleteClass

Send comments on this topic to Please email feedback to Support


TaskFolderDeleteClass Constructor

TaskFolderDeleteClass Constructor
Namespaces ► VisualCron ► TaskFolderDeleteClass ► TaskFolderDeleteClass()()()
Initializes a new instance of the TaskFolderDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFolderDeleteClass()
Public Sub New
public:
TaskFolderDeleteClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFolderDeleteClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFolderDeleteClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFolderDeleteClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFolderDeleteClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Folder Property

Folder Property
Namespaces ► VisualCron ► TaskFolderDeleteClass ► Folder

[Missing <summary> documentation for P:VisualCron.TaskFolderDeleteClass.Folder]

Declaration Syntax
C# Visual Basic Visual C++
public string Folder { get; set; }
Public Property Folder As String
public:
property String^ Folder {
    String^ get ();
    void set (String^ value);
}


PlaceInRecycleBin Property

PlaceInRecycleBin Property
Namespaces ► VisualCron ► TaskFolderDeleteClass ► PlaceInRecycleBin

[Missing <summary> documentation for P:VisualCron.TaskFolderDeleteClass.PlaceInRecycleBin]

Declaration Syntax
C# Visual Basic Visual C++
public bool PlaceInRecycleBin { get; set; }
Public Property PlaceInRecycleBin As Boolean
public:
property bool PlaceInRecycleBin {
    bool get ();
    void set (bool value);
}


Recursive Property

Recursive Property
Namespaces ► VisualCron ► TaskFolderDeleteClass ► Recursive
True to remove subdirectories and files
Declaration Syntax
C# Visual Basic Visual C++
public bool Recursive { get; set; }
Public Property Recursive As Boolean
public:
property bool Recursive {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskFolderRenameClass Class

TaskFolderRenameClass Class
Namespaces ► VisualCron ► TaskFolderRenameClass

[Missing <summary> documentation for T:VisualCron.TaskFolderRenameClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFolderRenameClass : ICloneable
<SerializableAttribute> _
Public Class TaskFolderRenameClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFolderRenameClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFolderRenameClass()()() | Initializes a new instance of the TaskFolderRenameClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewPath |
 | OldPath |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskFolderRenameClass

Send comments on this topic to Please email feedback to Support


TaskFolderRenameClass Constructor

TaskFolderRenameClass Constructor
Namespaces ► VisualCron ► TaskFolderRenameClass ► TaskFolderRenameClass()()()
Initializes a new instance of the TaskFolderRenameClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFolderRenameClass()
Public Sub New
public:
TaskFolderRenameClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFolderRenameClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFolderRenameClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFolderRenameClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskFolderRenameClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NewPath Property

NewPath Property
Namespaces ► VisualCron ► TaskFolderRenameClass ► NewPath

[Missing <summary> documentation for P:VisualCron.TaskFolderRenameClass.NewPath]

Declaration Syntax
C# Visual Basic Visual C++
public string NewPath { get; set; }
Public Property NewPath As String
public:
property String^ NewPath {
    String^ get ();
    void set (String^ value);
}


OldPath Property

OldPath Property
Namespaces ► VisualCron ► TaskFolderRenameClass ► OldPath

[Missing <summary> documentation for P:VisualCron.TaskFolderRenameClass.OldPath]

Declaration Syntax
C# Visual Basic Visual C++
public string OldPath { get; set; }
Public Property OldPath As String
public:
property String^ OldPath {
    String^ get ();
    void set (String^ value);
}


TaskFTPClass Class

TaskFTPClass Class
Namespaces ► VisualCron ► TaskFTPClass
The FTP Task which supports FTP/FTPS/SFTP
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskFTPClass : ICloneable
<SerializableAttribute> _
Public Class TaskFTPClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskFTPClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskFTPClass()()() | Initializes a new instance of the TaskFTPClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindFTPCommandOrder()()() | Retrieves the order id of the next FTPCommandClass
 | FTPCommands | A list of FTPCommandClasses
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the unique Id of the Task
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskFTPClass

Send comments on this topic to Please email feedback to Support


TaskFTPClass Constructor

TaskFTPClass Constructor
Namespaces ► VisualCron ► TaskFTPClass ► TaskFTPClass()()()
Initializes a new instance of the TaskFTPClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskFTPClass()
Public Sub New
public:
TaskFTPClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskFTPClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskFTPClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFTPClass.Clone]


FindFTPCommandOrder Method

FindFTPCommandOrder Method
Namespaces ► VisualCron ► TaskFTPClass ► FindFTPCommandOrder()()()
Retrieves the order id of the next FTPCommandClass
Declaration Syntax
C# Visual Basic Visual C++
public int FindFTPCommandOrder()
Public Function FindFTPCommandOrder As Integer
public:
int FindFTPCommandOrder()
Return Value

[Missing <returns> documentation for M:VisualCron.TaskFTPClass.FindFTPCommandOrder]

Remarks

Send comments on this topic to Please email feedback to Support


FTPCommands Field

FTPCommands Field
Namespaces ► VisualCron ► TaskFTPClass ► FTPCommands
A list of FTPCommandClasses
Declaration Syntax
C# Visual Basic Visual C++
public List<FTPCommandClass> FTPCommands
Public FTPCommands As List(Of FTPCommandClass)
public:
List<FTPCommandClass^>^ FTPCommands
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► TaskFTPClass ► Id
Gets or sets the unique Id of the Task
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskHTTPClass Class

TaskHTTPClass Class
Namespaces ► VisualCron ► TaskHTTPClass
A Task that can perform HTTP requests
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskHTTPClass : ICloneable
<SerializableAttribute> _
Public Class TaskHTTPClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskHTTPClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskHTTPClass()()() | Initializes a new instance of the TaskHTTPClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExistAction |
 | FileAutoName |
 | FileCredential |
 | FileFolder |
 | FileName |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Method | HTTP method, use either "GET" or "POST"
 | NetworkCredential | Gets or sets the Id of the Credential that is used to access the URL
 | Parameters | Gets or sets the parameters used
 | SaveContent |
 | TimeOut | Gets or sets the HTTP timeout
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | URL | Gets or sets the URL for POST or GET
 | UserAgent | UserAgent that will be used for connection
Remarks
Inheritance Hierarchy
Object
TaskHTTPClass

Send comments on this topic to Please email feedback to Support


TaskHTTPClass Constructor

TaskHTTPClass Constructor
Namespaces ► VisualCron ► TaskHTTPClass ► TaskHTTPClass()()()
Initializes a new instance of the TaskHTTPClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskHTTPClass()
Public Sub New
public:
TaskHTTPClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskHTTPClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskHTTPClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskHTTPClass.Clone]


ExistAction Field

ExistAction Field
Namespaces ► VisualCron ► TaskHTTPClass ► ExistAction

[Missing <summary> documentation for F:VisualCron.TaskHTTPClass.ExistAction]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.ExistActionT ExistAction
Public ExistAction As EnumClass..::.ExistActionT
public:
EnumClass..::.ExistActionT ExistAction

Send comments on this topic to Please email feedback to Support


FileAutoName Property

FileAutoName Property
Namespaces ► VisualCron ► TaskHTTPClass ► FileAutoName

[Missing <summary> documentation for P:VisualCron.TaskHTTPClass.FileAutoName]

Declaration Syntax
C# Visual Basic Visual C++
public bool FileAutoName { get; set; }
Public Property FileAutoName As Boolean
public:
property bool FileAutoName {
    bool get ();
    void set (bool value);
}


FileCredential Property

FileCredential Property
Namespaces ► VisualCron ► TaskHTTPClass ► FileCredential

[Missing <summary> documentation for P:VisualCron.TaskHTTPClass.FileCredential]

Declaration Syntax
C# Visual Basic Visual C++
public string FileCredential { get; set; }
Public Property FileCredential As String
public:
property String^ FileCredential {
    String^ get ();
    void set (String^ value);
}


FileFolder Property

FileFolder Property
Namespaces ► VisualCron ► TaskHTTPClass ► FileFolder

[Missing <summary> documentation for P:VisualCron.TaskHTTPClass.FileFolder]

Declaration Syntax
C# Visual Basic Visual C++
public string FileFolder { get; set; }
Public Property FileFolder As String
public:
property String^ FileFolder {
    String^ get ();
    void set (String^ value);
}


FileName Property

FileName Property
Namespaces ► VisualCron ► TaskHTTPClass ► FileName

[Missing <summary> documentation for P:VisualCron.TaskHTTPClass.FileName]

Declaration Syntax
C# Visual Basic Visual C++
public string FileName { get; set; }
Public Property FileName As String
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}


Method Property

Method Property
Namespaces ► VisualCron ► TaskHTTPClass ► Method
HTTP method, use either "GET" or "POST"
Declaration Syntax
C# Visual Basic Visual C++
public string Method { get; set; }
Public Property Method As String
public:
property String^ Method {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► TaskHTTPClass ► NetworkCredential
Gets or sets the Id of the Credential that is used to access the URL
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Parameters Property

Parameters Property
Namespaces ► VisualCron ► TaskHTTPClass ► Parameters
Gets or sets the parameters used
Declaration Syntax
C# Visual Basic Visual C++
public string Parameters { get; set; }
Public Property Parameters As String
public:
property String^ Parameters {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SaveContent Property

SaveContent Property
Namespaces ► VisualCron ► TaskHTTPClass ► SaveContent

[Missing <summary> documentation for P:VisualCron.TaskHTTPClass.SaveContent]

Declaration Syntax
C# Visual Basic Visual C++
public bool SaveContent { get; set; }
Public Property SaveContent As Boolean
public:
property bool SaveContent {
    bool get ();
    void set (bool value);
}


TimeOut Property

TimeOut Property
Namespaces ► VisualCron ► TaskHTTPClass ► TimeOut
Gets or sets the HTTP timeout
Declaration Syntax
C# Visual Basic Visual C++
public int TimeOut { get; set; }
Public Property TimeOut As Integer
public:
property int TimeOut {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


URL Property

URL Property
Namespaces ► VisualCron ► TaskHTTPClass ► URL
Gets or sets the URL for POST or GET
Declaration Syntax
C# Visual Basic Visual C++
public string URL { get; set; }
Public Property URL As String
public:
property String^ URL {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UserAgent Property

UserAgent Property
Namespaces ► VisualCron ► TaskHTTPClass ► UserAgent
UserAgent that will be used for connection
Declaration Syntax
C# Visual Basic Visual C++
public string UserAgent { get; set; }
Public Property UserAgent As String
public:
property String^ UserAgent {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskJobTaskControlClass Class

TaskJobTaskControlClass Class
Namespaces ► VisualCron ► TaskJobTaskControlClass

[Missing <summary> documentation for T:VisualCron.TaskJobTaskControlClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskJobTaskControlClass : ICloneable
<SerializableAttribute> _
Public Class TaskJobTaskControlClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskJobTaskControlClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskJobTaskControlClass()()() | Initializes a new instance of the TaskJobTaskControlClass class
 | Action |
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskJobTaskControlClass

Send comments on this topic to Please email feedback to Support


TaskJobTaskControlClass Constructor

TaskJobTaskControlClass Constructor
Namespaces ► VisualCron ► TaskJobTaskControlClass ► TaskJobTaskControlClass()()()
Initializes a new instance of the TaskJobTaskControlClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskJobTaskControlClass()
Public Sub New
public:
TaskJobTaskControlClass()


Action Property

Action Property
Namespaces ► VisualCron ► TaskJobTaskControlClass ► Action

[Missing <summary> documentation for P:VisualCron.TaskJobTaskControlClass.Action]

Declaration Syntax
C# Visual Basic Visual C++
public TaskJobTaskControlClass..::.ControlActionT Action { get; set; }
Public Property Action As TaskJobTaskControlClass..::.ControlActionT
public:
property TaskJobTaskControlClass..::.ControlActionT Action {
    TaskJobTaskControlClass..::.ControlActionT get ();
    void set (TaskJobTaskControlClass..::.ControlActionT value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskJobTaskControlClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskJobTaskControlClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskJobTaskControlClass.Clone]


JobId Property

JobId Property
Namespaces ► VisualCron ► TaskJobTaskControlClass ► JobId

[Missing <summary> documentation for P:VisualCron.TaskJobTaskControlClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


TaskId Property

TaskId Property
Namespaces ► VisualCron ► TaskJobTaskControlClass ► TaskId

[Missing <summary> documentation for P:VisualCron.TaskJobTaskControlClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


TaskJobTaskControlClass.ControlActionT Enumeration

TaskJobTaskControlClass..::.ControlActionT Enumeration
Namespaces ► VisualCron ► TaskJobTaskControlClass ► TaskJobTaskControlClass..::.ControlActionT

[Missing <summary> documentation for T:VisualCron.TaskJobTaskControlClass.ControlActionT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ControlActionT
Public Enumeration ControlActionT
public enum class ControlActionT
Members
Member | Description
RunJob |
StopJob |
ActivateJob |
InactivateJob |
RunTask |
StopTask |
ActivateTask |
InactivateTask |


TaskKillClass Class

TaskKillClass Class
Namespaces ► VisualCron ► TaskKillClass
This Task is able to terminate a running process
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskKillClass : ICloneable
<SerializableAttribute> _
Public Class TaskKillClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskKillClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskKillClass()()() | Initializes a new instance of the TaskKillClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KillType | Gets or sets the way to terminate a process
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultipleAction | Gets or sets multiple instance behavior
 | ProcessToKill | Gets or sets the process image name which will be terminated
 | ProcessToKillCaseSensitive | Gets or sets if the match should be case sensitive
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskKillClass

Send comments on this topic to Please email feedback to Support


TaskKillClass Constructor

TaskKillClass Constructor
Namespaces ► VisualCron ► TaskKillClass ► TaskKillClass()()()
Initializes a new instance of the TaskKillClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskKillClass()
Public Sub New
public:
TaskKillClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskKillClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskKillClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskKillClass.Clone]


KillType Property

KillType Property
Namespaces ► VisualCron ► TaskKillClass ► KillType
Gets or sets the way to terminate a process
Declaration Syntax
C# Visual Basic Visual C++
public TaskKillClass..::.KillT KillType { get; set; }
Public Property KillType As TaskKillClass..::.KillT
public:
property TaskKillClass..::.KillT KillType {
    TaskKillClass..::.KillT get ();
    void set (TaskKillClass..::.KillT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MultipleAction Property

MultipleAction Property
Namespaces ► VisualCron ► TaskKillClass ► MultipleAction
Gets or sets multiple instance behavior
Declaration Syntax
C# Visual Basic Visual C++
public TaskKillClass..::.MultipleActionT MultipleAction { get; set; }
Public Property MultipleAction As TaskKillClass..::.MultipleActionT
public:
property TaskKillClass..::.MultipleActionT MultipleAction {
    TaskKillClass..::.MultipleActionT get ();
    void set (TaskKillClass..::.MultipleActionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProcessToKill Property

ProcessToKill Property
Namespaces ► VisualCron ► TaskKillClass ► ProcessToKill
Gets or sets the process image name which will be terminated
Declaration Syntax
C# Visual Basic Visual C++
public string ProcessToKill { get; set; }
Public Property ProcessToKill As String
public:
property String^ ProcessToKill {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProcessToKillCaseSensitive Property

ProcessToKillCaseSensitive Property
Namespaces ► VisualCron ► TaskKillClass ► ProcessToKillCaseSensitive
Gets or sets if the match should be case sensitive
Declaration Syntax
C# Visual Basic Visual C++
public bool ProcessToKillCaseSensitive { get; set; }
Public Property ProcessToKillCaseSensitive As Boolean
public:
property bool ProcessToKillCaseSensitive {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskKillClass.KillT Enumeration

TaskKillClass..::.KillT Enumeration
Namespaces ► VisualCron ► TaskKillClass ► TaskKillClass..::.KillT
Enum which contains different termination methods
Declaration Syntax
C# Visual Basic Visual C++
public enum KillT
Public Enumeration KillT
public enum class KillT
Members
Member | Description
CloseMainWindow |
Kill |
Remarks

Send comments on this topic to Please email feedback to Support


TaskKillClass.MultipleActionT Enumeration

TaskKillClass..::.MultipleActionT Enumeration
Namespaces ► VisualCron ► TaskKillClass ► TaskKillClass..::.MultipleActionT
Enum that contains different possibilities to control the behavior when multiple instances of the process is found
Declaration Syntax
C# Visual Basic Visual C++
public enum MultipleActionT
Public Enumeration MultipleActionT
public enum class MultipleActionT
Members
Member | Description
TerminateAll |
TerminateOldest |
TerminateNewest |
Skip |
Remarks

Send comments on this topic to Please email feedback to Support


TaskOfficeMacroClass Class

TaskOfficeMacroClass Class
Namespaces ► VisualCron ► TaskOfficeMacroClass
A Task that can perform Office Macro execution
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskOfficeMacroClass : ICloneable
<SerializableAttribute> _
Public Class TaskOfficeMacroClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskOfficeMacroClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskOfficeMacroClass()()() | Initializes a new instance of the TaskOfficeMacroClass class
 | Clone()()() |
 | Credential | Gets or sets the Credential Id that is used for accessing file
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | Gets or sets the type of application that has the Macro
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the macro
 | OfficeApplicationType | Gets or sets the type of application that has the Macro
 | Parameters | Gets or sets the list of parameters
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskOfficeMacroClass

Send comments on this topic to Please email feedback to Support


TaskOfficeMacroClass Constructor

TaskOfficeMacroClass Constructor
Namespaces ► VisualCron ► TaskOfficeMacroClass ► TaskOfficeMacroClass()()()
Initializes a new instance of the TaskOfficeMacroClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskOfficeMacroClass()
Public Sub New
public:
TaskOfficeMacroClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskOfficeMacroClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskOfficeMacroClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskOfficeMacroClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskOfficeMacroClass ► Credential
Gets or sets the Credential Id that is used for accessing file
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


File Property

File Property
Namespaces ► VisualCron ► TaskOfficeMacroClass ► File
Gets or sets the type of application that has the Macro
Declaration Syntax
C# Visual Basic Visual C++
public string File { get; set; }
Public Property File As String
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► TaskOfficeMacroClass ► Name
Gets or sets the name of the macro
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OfficeApplicationType Property

OfficeApplicationType Property
Namespaces ► VisualCron ► TaskOfficeMacroClass ► OfficeApplicationType
Gets or sets the type of application that has the Macro
Declaration Syntax
C# Visual Basic Visual C++
public TaskOfficeMacroClass..::.OfficeApplicationT OfficeApplicationType { get; set; }
Public Property OfficeApplicationType As TaskOfficeMacroClass..::.OfficeApplicationT
public:
property TaskOfficeMacroClass..::.OfficeApplicationT OfficeApplicationType {
    TaskOfficeMacroClass..::.OfficeApplicationT get ();
    void set (TaskOfficeMacroClass..::.OfficeApplicationT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Parameters Property

Parameters Property
Namespaces ► VisualCron ► TaskOfficeMacroClass ► Parameters
Gets or sets the list of parameters
Declaration Syntax
C# Visual Basic Visual C++
public List<OfficeMacroParameterClass> Parameters { get; set; }
Public Property Parameters As List(Of OfficeMacroParameterClass)
public:
property List<OfficeMacroParameterClass^>^ Parameters {
    List<OfficeMacroParameterClass^>^ get ();
    void set (List<OfficeMacroParameterClass^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskOfficeMacroClass.OfficeApplicationT Enumeration

TaskOfficeMacroClass..::.OfficeApplicationT Enumeration
Namespaces ► VisualCron ► TaskOfficeMacroClass ► TaskOfficeMacroClass..::.OfficeApplicationT
Enum that describes different Office applications
Declaration Syntax
C# Visual Basic Visual C++
public enum OfficeApplicationT
Public Enumeration OfficeApplicationT
public enum class OfficeApplicationT
Members
Member | Description
Excel |
Powerpoint |
Access |
Word |
Remarks

Send comments on this topic to Please email feedback to Support


TaskPGPClass Class

TaskPGPClass Class
Namespaces ► VisualCron ► TaskPGPClass
The PGP task is used to encrypt/decrypt files using OpenPGP standard
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskPGPClass : ICloneable
<SerializableAttribute> _
Public Class TaskPGPClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskPGPClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskPGPClass()()() | Initializes a new instance of the TaskPGPClass class
 | ActionType | Gets or sets if this is a encrypt or decrypt PGP Task
 | Armor | Use this property to determine if resulting data should be armored, i.e. wrapped into base64-cover.
 | ArmorBoundary | Use this property to specify the text that will appear around base64-armored data. For example if the value of this property is 'PGP MESSAGE', then the borders will be '-----BEGIN PGP MESSAGE-----' and '-----END PGP MESSAGE-----'.
 | Clone()()() |
 | CompressData | Specifies if the data should be compressed before encryption.
 | Credential | An Id of a Credential that will be used to access a network drive or similar
 | DestinationFile | Obsolete. Use DestinationFileMask instead.
 | DestinationFileMask | File mask for the destination file
 | DestinationFolder | If DestinationFolderType is Custom this folder will we used
 | DestinationFolderType | If the destination file should be stored in Same folder as source or a Custom folder
 | EncryptionAlgorithm | Gets or sets what type of encryption algorithm should be used
 | EncryptSource | Gets or sets if the file should be encrypted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FileFilter | Filter object for finding files
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Password | Use this property to get or set passwords used for data encryption/decryption.
 | PrivateKeyRingId | Gets or sets the Id of the KeyRing (GUID)
 | ProtectionLevel | This property specifies the level of protection, i.e. the way in which the key is derived from password.
 | PublicKeyRingId | Gets or sets the Id of the KeyRing (GUID)
 | Recipients | A list of Recipients (public keys)
 | Signers | A list of Signers (private keys)
 | SignPassword | Gets or sets the password that is used for signing
 | SignSource | Gets or sets if the file should be signed or not
 | SourceFile | Obsolete. Use FileFilter instead.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TreatInputAsText | Use this property when you want to specify that input data must be interpreted as text
 | UseConventionalEncryption | Gets or sets if a password will be used for encryption. Enter a password in the password field.
 | UseDefaultDestinationNaming | Obsolete. Use DestinationFileMask instead. Gets or sets if default naming should be used. When DestinationFile is empty the path from SourceFile will be used (with original name in PGP message). When DestinationFile is not empty and this is true the folder will be used from DestinationFile and name of file from PGP message
 | UseNewFeatures | Use this property for compatibility with old versions of PGP-compatible software. If this property is set to True, then newer and stronger algorithms will be used. In this case ClearTextSign andSign will be compatible with PGP 2.6.x, while Encrypt and EncryptAndSign will not. If the property is set to False, then the result will be compatible with PGP 2.6.x, while the keys are compatible (i.e. don't use features not supported by PGP 2.6.x.
Remarks
Inheritance Hierarchy
Object
TaskPGPClass

Send comments on this topic to Please email feedback to Support


TaskPGPClass Constructor

TaskPGPClass Constructor
Namespaces ► VisualCron ► TaskPGPClass ► TaskPGPClass()()()
Initializes a new instance of the TaskPGPClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskPGPClass()
Public Sub New
public:
TaskPGPClass()


ActionType Property

ActionType Property
Namespaces ► VisualCron ► TaskPGPClass ► ActionType
Gets or sets if this is a encrypt or decrypt PGP Task
Declaration Syntax
C# Visual Basic Visual C++
public TaskPGPClass..::.PGPActionT ActionType { get; set; }
Public Property ActionType As TaskPGPClass..::.PGPActionT
public:
property TaskPGPClass..::.PGPActionT ActionType {
    TaskPGPClass..::.PGPActionT get ();
    void set (TaskPGPClass..::.PGPActionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Armor Property

Armor Property
Namespaces ► VisualCron ► TaskPGPClass ► Armor
Use this property to determine if resulting data should be armored, i.e. wrapped into base64-cover.
Declaration Syntax
C# Visual Basic Visual C++
public bool Armor { get; set; }
Public Property Armor As Boolean
public:
property bool Armor {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ArmorBoundary Property

ArmorBoundary Property
Namespaces ► VisualCron ► TaskPGPClass ► ArmorBoundary
Use this property to specify the text that will appear around base64-armored data. For example if the value of this property is 'PGP MESSAGE', then the borders will be '-----BEGIN PGP MESSAGE-----' and '-----END PGP MESSAGE-----'.
Declaration Syntax
C# Visual Basic Visual C++
public string ArmorBoundary { get; set; }
Public Property ArmorBoundary As String
public:
property String^ ArmorBoundary {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskPGPClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskPGPClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskPGPClass.Clone]


CompressData Property

CompressData Property
Namespaces ► VisualCron ► TaskPGPClass ► CompressData
Specifies if the data should be compressed before encryption.
Declaration Syntax
C# Visual Basic Visual C++
public bool CompressData { get; set; }
Public Property CompressData As Boolean
public:
property bool CompressData {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskPGPClass ► Credential
An Id of a Credential that will be used to access a network drive or similar
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DestinationFile Property

DestinationFile Property
Namespaces ► VisualCron ► TaskPGPClass ► DestinationFile
Obsolete. Use DestinationFileMask instead.
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationFile { get; set; }
Public Property DestinationFile As String
public:
property String^ DestinationFile {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DestinationFileMask Property

DestinationFileMask Property
Namespaces ► VisualCron ► TaskPGPClass ► DestinationFileMask
File mask for the destination file
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationFileMask { get; set; }
Public Property DestinationFileMask As String
public:
property String^ DestinationFileMask {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DestinationFolder Property

DestinationFolder Property
Namespaces ► VisualCron ► TaskPGPClass ► DestinationFolder
If DestinationFolderType is Custom this folder will we used
Declaration Syntax
C# Visual Basic Visual C++
public string DestinationFolder { get; set; }
Public Property DestinationFolder As String
public:
property String^ DestinationFolder {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DestinationFolderType Property

DestinationFolderType Property
Namespaces ► VisualCron ► TaskPGPClass ► DestinationFolderType
If the destination file should be stored in Same folder as source or a Custom folder
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass..::.DestinationFolderT DestinationFolderType { get; set; }
Public Property DestinationFolderType As FileFilterClass..::.DestinationFolderT
public:
property FileFilterClass..::.DestinationFolderT DestinationFolderType {
    FileFilterClass..::.DestinationFolderT get ();
    void set (FileFilterClass..::.DestinationFolderT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EncryptionAlgorithm Property

EncryptionAlgorithm Property
Namespaces ► VisualCron ► TaskPGPClass ► EncryptionAlgorithm
Gets or sets what type of encryption algorithm should be used
Declaration Syntax
C# Visual Basic Visual C++
public TaskPGPClass..::.EncryptionAlgorithmT EncryptionAlgorithm { get; set; }
Public Property EncryptionAlgorithm As TaskPGPClass..::.EncryptionAlgorithmT
public:
property TaskPGPClass..::.EncryptionAlgorithmT EncryptionAlgorithm {
    TaskPGPClass..::.EncryptionAlgorithmT get ();
    void set (TaskPGPClass..::.EncryptionAlgorithmT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


EncryptSource Property

EncryptSource Property
Namespaces ► VisualCron ► TaskPGPClass ► EncryptSource
Gets or sets if the file should be encrypted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool EncryptSource { get; set; }
Public Property EncryptSource As Boolean
public:
property bool EncryptSource {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► TaskPGPClass ► FileFilter
Filter object for finding files
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Password Property

Password Property
Namespaces ► VisualCron ► TaskPGPClass ► Password
Use this property to get or set passwords used for data encryption/decryption.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Password { get; set; }
Public Property Password As Byte()
public:
property array<unsigned char>^ Password {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Must be encrypted/decrypted

Send comments on this topic to Please email feedback to Support


PrivateKeyRingId Property

PrivateKeyRingId Property
Namespaces ► VisualCron ► TaskPGPClass ► PrivateKeyRingId
Gets or sets the Id of the KeyRing (GUID)
Declaration Syntax
C# Visual Basic Visual C++
public string PrivateKeyRingId { get; set; }
Public Property PrivateKeyRingId As String
public:
property String^ PrivateKeyRingId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProtectionLevel Property

ProtectionLevel Property
Namespaces ► VisualCron ► TaskPGPClass ► ProtectionLevel
This property specifies the level of protection, i.e. the way in which the key is derived from password.
Declaration Syntax
C# Visual Basic Visual C++
public TaskPGPClass..::.ProtectionLevelT ProtectionLevel { get; set; }
Public Property ProtectionLevel As TaskPGPClass..::.ProtectionLevelT
public:
property TaskPGPClass..::.ProtectionLevelT ProtectionLevel {
    TaskPGPClass..::.ProtectionLevelT get ();
    void set (TaskPGPClass..::.ProtectionLevelT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PublicKeyRingId Property

PublicKeyRingId Property
Namespaces ► VisualCron ► TaskPGPClass ► PublicKeyRingId
Gets or sets the Id of the KeyRing (GUID)
Declaration Syntax
C# Visual Basic Visual C++
public string PublicKeyRingId { get; set; }
Public Property PublicKeyRingId As String
public:
property String^ PublicKeyRingId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Recipients Field

Recipients Field
Namespaces ► VisualCron ► TaskPGPClass ► Recipients
A list of Recipients (public keys)
Declaration Syntax
C# Visual Basic Visual C++
public List<PGPUserItemClass> Recipients
Public Recipients As List(Of PGPUserItemClass)
public:
List<PGPUserItemClass^>^ Recipients
Remarks

Send comments on this topic to Please email feedback to Support


Signers Field

Signers Field
Namespaces ► VisualCron ► TaskPGPClass ► Signers
A list of Signers (private keys)
Declaration Syntax
C# Visual Basic Visual C++
public List<PGPUserItemClass> Signers
Public Signers As List(Of PGPUserItemClass)
public:
List<PGPUserItemClass^>^ Signers
Remarks

Send comments on this topic to Please email feedback to Support


SignPassword Property

SignPassword Property
Namespaces ► VisualCron ► TaskPGPClass ► SignPassword
Gets or sets the password that is used for signing
Declaration Syntax
C# Visual Basic Visual C++
public byte[] SignPassword { get; set; }
Public Property SignPassword As Byte()
public:
property array<unsigned char>^ SignPassword {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Must be encrypted/decrypted

Send comments on this topic to Please email feedback to Support


SignSource Property

SignSource Property
Namespaces ► VisualCron ► TaskPGPClass ► SignSource
Gets or sets if the file should be signed or not
Declaration Syntax
C# Visual Basic Visual C++
public bool SignSource { get; set; }
Public Property SignSource As Boolean
public:
property bool SignSource {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SourceFile Property

SourceFile Property
Namespaces ► VisualCron ► TaskPGPClass ► SourceFile
Obsolete. Use FileFilter instead.
Declaration Syntax
C# Visual Basic Visual C++
public string SourceFile { get; set; }
Public Property SourceFile As String
public:
property String^ SourceFile {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TreatInputAsText Property

TreatInputAsText Property
Namespaces ► VisualCron ► TaskPGPClass ► TreatInputAsText
Use this property when you want to specify that input data must be interpreted as text
Declaration Syntax
C# Visual Basic Visual C++
public bool TreatInputAsText { get; set; }
Public Property TreatInputAsText As Boolean
public:
property bool TreatInputAsText {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseConventionalEncryption Property

UseConventionalEncryption Property
Namespaces ► VisualCron ► TaskPGPClass ► UseConventionalEncryption
Gets or sets if a password will be used for encryption. Enter a password in the password field.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseConventionalEncryption { get; set; }
Public Property UseConventionalEncryption As Boolean
public:
property bool UseConventionalEncryption {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseDefaultDestinationNaming Property

UseDefaultDestinationNaming Property
Namespaces ► VisualCron ► TaskPGPClass ► UseDefaultDestinationNaming
Obsolete. Use DestinationFileMask instead. Gets or sets if default naming should be used. When DestinationFile is empty the path from SourceFile will be used (with original name in PGP message). When DestinationFile is not empty and this is true the folder will be used from DestinationFile and name of file from PGP message
Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultDestinationNaming { get; set; }
Public Property UseDefaultDestinationNaming As Boolean
public:
property bool UseDefaultDestinationNaming {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseNewFeatures Property

UseNewFeatures Property
Namespaces ► VisualCron ► TaskPGPClass ► UseNewFeatures
Use this property for compatibility with old versions of PGP-compatible software. If this property is set to True, then newer and stronger algorithms will be used. In this case ClearTextSign andSign will be compatible with PGP 2.6.x, while Encrypt and EncryptAndSign will not. If the property is set to False, then the result will be compatible with PGP 2.6.x, while the keys are compatible (i.e. don't use features not supported by PGP 2.6.x.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseNewFeatures { get; set; }
Public Property UseNewFeatures As Boolean
public:
property bool UseNewFeatures {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskPGPClass.EncryptionAlgorithmT Enumeration

TaskPGPClass..::.EncryptionAlgorithmT Enumeration
Namespaces ► VisualCron ► TaskPGPClass ► TaskPGPClass..::.EncryptionAlgorithmT
Enum contains different encryption algorithms
Declaration Syntax
C# Visual Basic Visual C++
public enum EncryptionAlgorithmT
Public Enumeration EncryptionAlgorithmT
public enum class EncryptionAlgorithmT
Members
Member | Description
CAST5 |
TRIDES |
AES128 |
AES256 |
IDEA |
BLOWFISH |
TWOFISH256 |
Remarks

Send comments on this topic to Please email feedback to Support


TaskPGPClass.PGPActionT Enumeration

TaskPGPClass..::.PGPActionT Enumeration
Namespaces ► VisualCron ► TaskPGPClass ► TaskPGPClass..::.PGPActionT
Enum that describes the type of action that should be performed
Declaration Syntax
C# Visual Basic Visual C++
public enum PGPActionT
Public Enumeration PGPActionT
public enum class PGPActionT
Members
Member | Description
Encrypt |
Decrypt |
Remarks

Send comments on this topic to Please email feedback to Support


TaskPGPClass.ProtectionLevelT Enumeration

TaskPGPClass..::.ProtectionLevelT Enumeration
Namespaces ► VisualCron ► TaskPGPClass ► TaskPGPClass..::.ProtectionLevelT
Enum contains different protection levels
Declaration Syntax
C# Visual Basic Visual C++
public enum ProtectionLevelT
Public Enumeration ProtectionLevelT
public enum class ProtectionLevelT
Members
Member | Description
Low |
Normal |
High |
Remarks

Send comments on this topic to Please email feedback to Support


TaskPingClass Class

TaskPingClass Class
Namespaces ► VisualCron ► TaskPingClass

[Missing <summary> documentation for T:VisualCron.TaskPingClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskPingClass : ICloneable
<SerializableAttribute> _
Public Class TaskPingClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskPingClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskPingClass()()() | Initializes a new instance of the TaskPingClass class
 | Clone()()() |
 | DataSize |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TimeOut |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TTL |
Inheritance Hierarchy
Object
TaskPingClass

Send comments on this topic to Please email feedback to Support


TaskPingClass Constructor

TaskPingClass Constructor
Namespaces ► VisualCron ► TaskPingClass ► TaskPingClass()()()
Initializes a new instance of the TaskPingClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskPingClass()
Public Sub New
public:
TaskPingClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskPingClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskPingClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskPingClass.Clone]


DataSize Property

DataSize Property
Namespaces ► VisualCron ► TaskPingClass ► DataSize

[Missing <summary> documentation for P:VisualCron.TaskPingClass.DataSize]

Declaration Syntax
C# Visual Basic Visual C++
public long DataSize { get; set; }
Public Property DataSize As Long
public:
property long long DataSize {
    long long get ();
    void set (long long value);
}


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskPingClass ► HostName

[Missing <summary> documentation for P:VisualCron.TaskPingClass.HostName]

Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}


TimeOut Property

TimeOut Property
Namespaces ► VisualCron ► TaskPingClass ► TimeOut

[Missing <summary> documentation for P:VisualCron.TaskPingClass.TimeOut]

Declaration Syntax
C# Visual Basic Visual C++
public int TimeOut { get; set; }
Public Property TimeOut As Integer
public:
property int TimeOut {
    int get ();
    void set (int value);
}


TTL Property

TTL Property
Namespaces ► VisualCron ► TaskPingClass ► TTL

[Missing <summary> documentation for P:VisualCron.TaskPingClass.TTL]

Declaration Syntax
C# Visual Basic Visual C++
public byte TTL { get; set; }
Public Property TTL As Byte
public:
property unsigned char TTL {
    unsigned char get ();
    void set (unsigned char value);
}


TaskPlaySoundClass Class

TaskPlaySoundClass Class
Namespaces ► VisualCron ► TaskPlaySoundClass

[Missing <summary> documentation for T:VisualCron.TaskPlaySoundClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskPlaySoundClass : ICloneable
<SerializableAttribute> _
Public Class TaskPlaySoundClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskPlaySoundClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskPlaySoundClass()()() | Initializes a new instance of the TaskPlaySoundClass class
 | Clone()()() |
 | Credential |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskPlaySoundClass

Send comments on this topic to Please email feedback to Support


TaskPlaySoundClass Constructor

TaskPlaySoundClass Constructor
Namespaces ► VisualCron ► TaskPlaySoundClass ► TaskPlaySoundClass()()()
Initializes a new instance of the TaskPlaySoundClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskPlaySoundClass()
Public Sub New
public:
TaskPlaySoundClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskPlaySoundClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskPlaySoundClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskPlaySoundClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskPlaySoundClass ► Credential

[Missing <summary> documentation for P:VisualCron.TaskPlaySoundClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


FilePath Property

FilePath Property
Namespaces ► VisualCron ► TaskPlaySoundClass ► FilePath

[Missing <summary> documentation for P:VisualCron.TaskPlaySoundClass.FilePath]

Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}


TaskPrintDocumentClass Class

TaskPrintDocumentClass Class
Namespaces ► VisualCron ► TaskPrintDocumentClass

[Missing <summary> documentation for T:VisualCron.TaskPrintDocumentClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskPrintDocumentClass : ICloneable
<SerializableAttribute> _
Public Class TaskPrintDocumentClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskPrintDocumentClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskPrintDocumentClass()()() | Initializes a new instance of the TaskPrintDocumentClass class
 | AutoDetectDocType | What type of document you want to print. Specifying yes will print doc type according to extension of file name.
 | Clone()()() |
 | DocType | Which type of document to print. This property is used when specifying AutoDetectDocType = false
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | File | Obsolete, use FileFilter instead
 | FileFilter | Filter object that controls files to print
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoCopies | Number of copies to print of the document
 | Orientation | Which orientation that printed page should have
 | Pages | Which pages to print. Uses if PrintRange != AllPages
 | PrinterName | The exact name of the printer to use for printing
 | PrintRange | If all pages should be printed or if Pages property should be used
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskPrintDocumentClass

Send comments on this topic to Please email feedback to Support


TaskPrintDocumentClass Constructor

TaskPrintDocumentClass Constructor
Namespaces ► VisualCron ► TaskPrintDocumentClass ► TaskPrintDocumentClass()()()
Initializes a new instance of the TaskPrintDocumentClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskPrintDocumentClass()
Public Sub New
public:
TaskPrintDocumentClass()


AutoDetectDocType Property

AutoDetectDocType Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► AutoDetectDocType
What type of document you want to print. Specifying yes will print doc type according to extension of file name.
Declaration Syntax
C# Visual Basic Visual C++
public TaskPrintDocumentClass..::.AutoDetectDocTypeT AutoDetectDocType { get; set; }
Public Property AutoDetectDocType As TaskPrintDocumentClass..::.AutoDetectDocTypeT
public:
property TaskPrintDocumentClass..::.AutoDetectDocTypeT AutoDetectDocType {
    TaskPrintDocumentClass..::.AutoDetectDocTypeT get ();
    void set (TaskPrintDocumentClass..::.AutoDetectDocTypeT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskPrintDocumentClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskPrintDocumentClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskPrintDocumentClass.Clone]


DocType Property

DocType Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► DocType
Which type of document to print. This property is used when specifying AutoDetectDocType = false
Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass..::.DocumentType DocType { get; set; }
Public Property DocType As PrinterSettingsClass..::.DocumentType
public:
property PrinterSettingsClass..::.DocumentType DocType {
    PrinterSettingsClass..::.DocumentType get ();
    void set (PrinterSettingsClass..::.DocumentType value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


File Property

File Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► File
Obsolete, use FileFilter instead
Declaration Syntax
C# Visual Basic Visual C++
public string File { get; set; }
Public Property File As String
public:
property String^ File {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FileFilter Property

FileFilter Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► FileFilter
Filter object that controls files to print
Declaration Syntax
C# Visual Basic Visual C++
public FileFilterClass FileFilter { get; set; }
Public Property FileFilter As FileFilterClass
public:
property FileFilterClass^ FileFilter {
    FileFilterClass^ get ();
    void set (FileFilterClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NoCopies Property

NoCopies Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► NoCopies
Number of copies to print of the document
Declaration Syntax
C# Visual Basic Visual C++
public short NoCopies { get; set; }
Public Property NoCopies As Short
public:
property short NoCopies {
    short get ();
    void set (short value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Orientation Property

Orientation Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► Orientation
Which orientation that printed page should have
Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass..::.EnmOrientation Orientation { get; set; }
Public Property Orientation As PrinterSettingsClass..::.EnmOrientation
public:
property PrinterSettingsClass..::.EnmOrientation Orientation {
    PrinterSettingsClass..::.EnmOrientation get ();
    void set (PrinterSettingsClass..::.EnmOrientation value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Pages Property

Pages Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► Pages
Which pages to print. Uses if PrintRange != AllPages
Declaration Syntax
C# Visual Basic Visual C++
public string Pages { get; set; }
Public Property Pages As String
public:
property String^ Pages {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PrinterName Property

PrinterName Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► PrinterName
The exact name of the printer to use for printing
Declaration Syntax
C# Visual Basic Visual C++
public string PrinterName { get; set; }
Public Property PrinterName As String
public:
property String^ PrinterName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PrintRange Property

PrintRange Property
Namespaces ► VisualCron ► TaskPrintDocumentClass ► PrintRange
If all pages should be printed or if Pages property should be used
Declaration Syntax
C# Visual Basic Visual C++
public PrinterSettingsClass..::.EnmPrintRange PrintRange { get; set; }
Public Property PrintRange As PrinterSettingsClass..::.EnmPrintRange
public:
property PrinterSettingsClass..::.EnmPrintRange PrintRange {
    PrinterSettingsClass..::.EnmPrintRange get ();
    void set (PrinterSettingsClass..::.EnmPrintRange value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskPrintDocumentClass.AutoDetectDocTypeT Enumeration

TaskPrintDocumentClass..::.AutoDetectDocTypeT Enumeration
Namespaces ► VisualCron ► TaskPrintDocumentClass ► TaskPrintDocumentClass..::.AutoDetectDocTypeT

[Missing <summary> documentation for T:VisualCron.TaskPrintDocumentClass.AutoDetectDocTypeT]

Declaration Syntax
C# Visual Basic Visual C++
public enum AutoDetectDocTypeT
Public Enumeration AutoDetectDocTypeT
public enum class AutoDetectDocTypeT
Members
Member | Description
Yes |
No |


TaskProcessClass Class

TaskProcessClass Class
Namespaces ► VisualCron ► TaskProcessClass

[Missing <summary> documentation for T:VisualCron.TaskProcessClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskProcessClass
<SerializableAttribute> _
Public Class TaskProcessClass
[SerializableAttribute]
public ref class TaskProcessClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskProcessClass()()() | Initializes a new instance of the TaskProcessClass class
 | Active |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Init()()() |
 | Job |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrevTask |
 | Task |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TPCResult |
 | TriggerResultId |
 | VCProcess |
Inheritance Hierarchy
Object
TaskProcessClass

Send comments on this topic to Please email feedback to Support


TaskProcessClass Constructor

TaskProcessClass Constructor
Namespaces ► VisualCron ► TaskProcessClass ► TaskProcessClass()()()
Initializes a new instance of the TaskProcessClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskProcessClass()
Public Sub New
public:
TaskProcessClass()


Active Field

Active Field
Namespaces ► VisualCron ► TaskProcessClass ► Active

[Missing <summary> documentation for F:VisualCron.TaskProcessClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active
Public Active As Boolean
public:
bool Active


Init Method

Init Method
Namespaces ► VisualCron ► TaskProcessClass ► Init()()()

[Missing <summary> documentation for M:VisualCron.TaskProcessClass.Init]

Declaration Syntax
C# Visual Basic Visual C++
public void Init()
Public Sub Init
public:
void Init()


Job Field

Job Field
Namespaces ► VisualCron ► TaskProcessClass ► Job

[Missing <summary> documentation for F:VisualCron.TaskProcessClass.Job]

Declaration Syntax
C# Visual Basic Visual C++
public JobClass Job
Public Job As JobClass
public:
JobClass^ Job

Send comments on this topic to Please email feedback to Support


PrevTask Field

PrevTask Field
Namespaces ► VisualCron ► TaskProcessClass ► PrevTask

[Missing <summary> documentation for F:VisualCron.TaskProcessClass.PrevTask]

Declaration Syntax
C# Visual Basic Visual C++
public TaskClass PrevTask
Public PrevTask As TaskClass
public:
TaskClass^ PrevTask

Send comments on this topic to Please email feedback to Support


Task Field

Task Field
Namespaces ► VisualCron ► TaskProcessClass ► Task

[Missing <summary> documentation for F:VisualCron.TaskProcessClass.Task]

Declaration Syntax
C# Visual Basic Visual C++
public TaskClass Task
Public Task As TaskClass
public:
TaskClass^ Task

Send comments on this topic to Please email feedback to Support


TPCResult Field

TPCResult Field
Namespaces ► VisualCron ► TaskProcessClass ► TPCResult

[Missing <summary> documentation for F:VisualCron.TaskProcessClass.TPCResult]

Declaration Syntax
C# Visual Basic Visual C++
[NonSerializedAttribute]
public TaskProcessResultClass TPCResult
<NonSerializedAttribute> _
Public TPCResult As TaskProcessResultClass
[NonSerializedAttribute]
public:
TaskProcessResultClass^ TPCResult

Send comments on this topic to Please email feedback to Support


TriggerResultId Field

TriggerResultId Field
Namespaces ► VisualCron ► TaskProcessClass ► TriggerResultId

[Missing <summary> documentation for F:VisualCron.TaskProcessClass.TriggerResultId]

Declaration Syntax
C# Visual Basic Visual C++
public string TriggerResultId
Public TriggerResultId As String
public:
String^ TriggerResultId

Send comments on this topic to Please email feedback to Support


VCProcess Field

VCProcess Field
Namespaces ► VisualCron ► TaskProcessClass ► VCProcess

[Missing <summary> documentation for F:VisualCron.TaskProcessClass.VCProcess]

Declaration Syntax
C# Visual Basic Visual C++
public VCTaskProcessClass VCProcess
Public VCProcess As VCTaskProcessClass
public:
VCTaskProcessClass^ VCProcess

Send comments on this topic to Please email feedback to Support


TaskProcessResultClass Class

TaskProcessResultClass Class
Namespaces ► VisualCron ► TaskProcessResultClass

[Missing <summary> documentation for T:VisualCron.TaskProcessResultClass]

Declaration Syntax
C# Visual Basic Visual C++
public class TaskProcessResultClass
Public Class TaskProcessResultClass
public ref class TaskProcessResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskProcessResultClass()()() | Initializes a new instance of the TaskProcessResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception |
 | ExitCode |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskProcessResultClass

Send comments on this topic to Please email feedback to Support


TaskProcessResultClass Constructor

TaskProcessResultClass Constructor
Namespaces ► VisualCron ► TaskProcessResultClass ► TaskProcessResultClass()()()
Initializes a new instance of the TaskProcessResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskProcessResultClass()
Public Sub New
public:
TaskProcessResultClass()


Exception Property

Exception Property
Namespaces ► VisualCron ► TaskProcessResultClass ► Exception

[Missing <summary> documentation for P:VisualCron.TaskProcessResultClass.Exception]

Declaration Syntax
C# Visual Basic Visual C++
public OnTaskErrorClass..::.ErrorT Exception { get; set; }
Public Property Exception As OnTaskErrorClass..::.ErrorT
public:
property OnTaskErrorClass..::.ErrorT Exception {
    OnTaskErrorClass..::.ErrorT get ();
    void set (OnTaskErrorClass..::.ErrorT value);
}


ExitCode Property

ExitCode Property
Namespaces ► VisualCron ► TaskProcessResultClass ► ExitCode

[Missing <summary> documentation for P:VisualCron.TaskProcessResultClass.ExitCode]

Declaration Syntax
C# Visual Basic Visual C++
public int ExitCode { get; set; }
Public Property ExitCode As Integer
public:
property int ExitCode {
    int get ();
    void set (int value);
}


TaskRegistryClass Class

TaskRegistryClass Class
Namespaces ► VisualCron ► TaskRegistryClass

[Missing <summary> documentation for T:VisualCron.TaskRegistryClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskRegistryClass : ICloneable
<SerializableAttribute> _
Public Class TaskRegistryClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskRegistryClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskRegistryClass()()() | Initializes a new instance of the TaskRegistryClass class
 | Clone()()() |
 | CreateChangeValue(String, String, String, RegistryValueKind) | Creates a new registry value or modifies existing.
 | CreateKey(String) | Creates a registry key.
 | DataMode | Gets/Sets the datamode.
 | DeleteKey(String) | Deletes a registry key.
 | DeleteValue(String, String) | Deletes a registry value.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Execute()()() | Executes the task with the stored arguments.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewName | Gets/Sets the new name for the key/value.
 | ReadValue(String, String) | Reads a registry value data.
 | RegistryKey | Gets/Sets the registry key path. Relevant for all task types.
 | RegistryKeyExists(String) | Checks whether a registry key with the specified path exists.
 | RegistryTaskType | Gets/Sets the registry task type.
 | RenameKey(String, String) | Renames a registry key.
 | RenameValue(String, String, String) | Renames a registry value.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueData | Gets/Sets the registry value data. Relevant for task type.
 | ValueName | Gets/Sets the registry value name. Relevant for task types.
Inheritance Hierarchy
Object
TaskRegistryClass

Send comments on this topic to Please email feedback to Support


TaskRegistryClass Constructor

TaskRegistryClass Constructor
Namespaces ► VisualCron ► TaskRegistryClass ► TaskRegistryClass()()()
Initializes a new instance of the TaskRegistryClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskRegistryClass()
Public Sub New
public:
TaskRegistryClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskRegistryClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskRegistryClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskRegistryClass.Clone]


CreateChangeValue Method (keyPath, valueName, valueData, valueKind)

CreateChangeValue Method (keyPath, valueName, valueData, valueKind)
Namespaces ► VisualCron ► TaskRegistryClass ► CreateChangeValue(String, String, String, RegistryValueKind)
Creates a new registry value or modifies existing.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateChangeValue(
    string keyPath,
    string valueName,
    string valueData,
    RegistryValueKind valueKind
)
Public Shared Sub CreateChangeValue ( _
    keyPath As String, _
    valueName As String, _
    valueData As String, _
    valueKind As RegistryValueKind _
)
public:
static void CreateChangeValue(
    String^ keyPath,
    String^ valueName,
    String^ valueData,
    RegistryValueKind valueKind
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.CreateChangeValue(System.String,System.String,System.String,Microsoft.Win32.RegistryValueKind)"]

valueName (String)

[Missing <param name="valueName"/> documentation for "M:VisualCron.TaskRegistryClass.CreateChangeValue(System.String,System.String,System.String,Microsoft.Win32.RegistryValueKind)"]

valueData (String)

[Missing <param name="valueData"/> documentation for "M:VisualCron.TaskRegistryClass.CreateChangeValue(System.String,System.String,System.String,Microsoft.Win32.RegistryValueKind)"]

valueKind (RegistryValueKind)

[Missing <param name="valueKind"/> documentation for "M:VisualCron.TaskRegistryClass.CreateChangeValue(System.String,System.String,System.String,Microsoft.Win32.RegistryValueKind)"]


CreateKey Method (keyPath)

CreateKey Method (keyPath)
Namespaces ► VisualCron ► TaskRegistryClass ► CreateKey(String)
Creates a registry key.
Declaration Syntax
C# Visual Basic Visual C++
public static void CreateKey(
    string keyPath
)
Public Shared Sub CreateKey ( _
    keyPath As String _
)
public:
static void CreateKey(
    String^ keyPath
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.CreateKey(System.String)"]


DataMode Property

DataMode Property
Namespaces ► VisualCron ► TaskRegistryClass ► DataMode
Gets/Sets the datamode.
Declaration Syntax
C# Visual Basic Visual C++
public RegistryValueKind DataMode { get; set; }
Public Property DataMode As RegistryValueKind
public:
property RegistryValueKind DataMode {
    RegistryValueKind get ();
    void set (RegistryValueKind value);
}


DeleteKey Method (keyPath)

DeleteKey Method (keyPath)
Namespaces ► VisualCron ► TaskRegistryClass ► DeleteKey(String)
Deletes a registry key.
Declaration Syntax
C# Visual Basic Visual C++
public static void DeleteKey(
    string keyPath
)
Public Shared Sub DeleteKey ( _
    keyPath As String _
)
public:
static void DeleteKey(
    String^ keyPath
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.DeleteKey(System.String)"]


DeleteValue Method (keyPath, valueName)

DeleteValue Method (keyPath, valueName)
Namespaces ► VisualCron ► TaskRegistryClass ► DeleteValue(String, String)
Deletes a registry value.
Declaration Syntax
C# Visual Basic Visual C++
public static void DeleteValue(
    string keyPath,
    string valueName
)
Public Shared Sub DeleteValue ( _
    keyPath As String, _
    valueName As String _
)
public:
static void DeleteValue(
    String^ keyPath,
    String^ valueName
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.DeleteValue(System.String,System.String)"]

valueName (String)

[Missing <param name="valueName"/> documentation for "M:VisualCron.TaskRegistryClass.DeleteValue(System.String,System.String)"]


Execute Method

Execute Method
Namespaces ► VisualCron ► TaskRegistryClass ► Execute()()()
Executes the task with the stored arguments.
Declaration Syntax
C# Visual Basic Visual C++
public Object Execute()
Public Function Execute As Object
public:
Object^ Execute()
Return Value
Nothing if the task does not have a return value. A value if the task has a return value. Throws an exception if the task execution failed.


NewName Property

NewName Property
Namespaces ► VisualCron ► TaskRegistryClass ► NewName
Gets/Sets the new name for the key/value.
Declaration Syntax
C# Visual Basic Visual C++
public string NewName { get; set; }
Public Property NewName As String
public:
property String^ NewName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ReadValue Method (keyPath, valueName)

ReadValue Method (keyPath, valueName)
Namespaces ► VisualCron ► TaskRegistryClass ► ReadValue(String, String)
Reads a registry value data.
Declaration Syntax
C# Visual Basic Visual C++
public static Object ReadValue(
    string keyPath,
    string valueName
)
Public Shared Function ReadValue ( _
    keyPath As String, _
    valueName As String _
) As Object
public:
static Object^ ReadValue(
    String^ keyPath,
    String^ valueName
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.ReadValue(System.String,System.String)"]

valueName (String)

[Missing <param name="valueName"/> documentation for "M:VisualCron.TaskRegistryClass.ReadValue(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.TaskRegistryClass.ReadValue(System.String,System.String)]


RegistryKey Property

RegistryKey Property
Namespaces ► VisualCron ► TaskRegistryClass ► RegistryKey
Gets/Sets the registry key path. Relevant for all task types.
Declaration Syntax
C# Visual Basic Visual C++
public string RegistryKey { get; set; }
Public Property RegistryKey As String
public:
property String^ RegistryKey {
    String^ get ();
    void set (String^ value);
}


RegistryKeyExists Method (keyPath)

RegistryKeyExists Method (keyPath)
Namespaces ► VisualCron ► TaskRegistryClass ► RegistryKeyExists(String)
Checks whether a registry key with the specified path exists.
Declaration Syntax
C# Visual Basic Visual C++
public static bool RegistryKeyExists(
    string keyPath
)
Public Shared Function RegistryKeyExists ( _
    keyPath As String _
) As Boolean
public:
static bool RegistryKeyExists(
    String^ keyPath
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.RegistryKeyExists(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.TaskRegistryClass.RegistryKeyExists(System.String)]


RegistryTaskType Property

RegistryTaskType Property
Namespaces ► VisualCron ► TaskRegistryClass ► RegistryTaskType
Gets/Sets the registry task type.
Declaration Syntax
C# Visual Basic Visual C++
public TaskRegistryClass..::.RegistryTaskT RegistryTaskType { get; set; }
Public Property RegistryTaskType As TaskRegistryClass..::.RegistryTaskT
public:
property TaskRegistryClass..::.RegistryTaskT RegistryTaskType {
    TaskRegistryClass..::.RegistryTaskT get ();
    void set (TaskRegistryClass..::.RegistryTaskT value);
}


RenameKey Method (keyPath, newName)

RenameKey Method (keyPath, newName)
Namespaces ► VisualCron ► TaskRegistryClass ► RenameKey(String, String)
Renames a registry key.
Declaration Syntax
C# Visual Basic Visual C++
public static void RenameKey(
    string keyPath,
    string newName
)
Public Shared Sub RenameKey ( _
    keyPath As String, _
    newName As String _
)
public:
static void RenameKey(
    String^ keyPath,
    String^ newName
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.RenameKey(System.String,System.String)"]

newName (String)

[Missing <param name="newName"/> documentation for "M:VisualCron.TaskRegistryClass.RenameKey(System.String,System.String)"]

Remarks
Rename operation is not supported by the Windows registry. Rename is achieved by copying the entire registry (the whole tree).


RenameValue Method (keyPath, valueName, newName)

RenameValue Method (keyPath, valueName, newName)
Namespaces ► VisualCron ► TaskRegistryClass ► RenameValue(String, String, String)
Renames a registry value.
Declaration Syntax
C# Visual Basic Visual C++
public static void RenameValue(
    string keyPath,
    string valueName,
    string newName
)
Public Shared Sub RenameValue ( _
    keyPath As String, _
    valueName As String, _
    newName As String _
)
public:
static void RenameValue(
    String^ keyPath,
    String^ valueName,
    String^ newName
)
Parameters
keyPath (String)

[Missing <param name="keyPath"/> documentation for "M:VisualCron.TaskRegistryClass.RenameValue(System.String,System.String,System.String)"]

valueName (String)

[Missing <param name="valueName"/> documentation for "M:VisualCron.TaskRegistryClass.RenameValue(System.String,System.String,System.String)"]

newName (String)

[Missing <param name="newName"/> documentation for "M:VisualCron.TaskRegistryClass.RenameValue(System.String,System.String,System.String)"]


ValueData Property

ValueData Property
Namespaces ► VisualCron ► TaskRegistryClass ► ValueData
Gets/Sets the registry value data. Relevant for task type.
Declaration Syntax
C# Visual Basic Visual C++
public string ValueData { get; set; }
Public Property ValueData As String
public:
property String^ ValueData {
    String^ get ();
    void set (String^ value);
}


ValueName Property

ValueName Property
Namespaces ► VisualCron ► TaskRegistryClass ► ValueName
Gets/Sets the registry value name. Relevant for task types.
Declaration Syntax
C# Visual Basic Visual C++
public string ValueName { get; set; }
Public Property ValueName As String
public:
property String^ ValueName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskRegistryClass.RegistryTaskT Enumeration

TaskRegistryClass..::.RegistryTaskT Enumeration
Namespaces ► VisualCron ► TaskRegistryClass ► TaskRegistryClass..::.RegistryTaskT
Represent the type of the registry task.
Declaration Syntax
C# Visual Basic Visual C++
public enum RegistryTaskT
Public Enumeration RegistryTaskT
public enum class RegistryTaskT
Members
Member | Description
ReadValue |
CreateChangeValue |
DeleteValue |
RenameValue |
CreateKey |
DeleteKey |
RenameKey |


TaskRemoteExecuteClass Class

TaskRemoteExecuteClass Class
Namespaces ► VisualCron ► TaskRemoteExecuteClass
The Remote Execute task can start a remote process within the network
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskRemoteExecuteClass : ICloneable
<SerializableAttribute> _
Public Class TaskRemoteExecuteClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskRemoteExecuteClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskRemoteExecuteClass()()() | Initializes a new instance of the TaskRemoteExecuteClass class
 | Arguments | Gets or sets the arguments that should be used when starting the process
 | Clone()()() |
 | CloneType()()() |
 | CmdLine | Gets or sets the path to the executable
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address of the remote server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkCredential | Gets or sets the Id of the Credential
 | Priority | Gets or sets the process priority.
 | RunHidden | Gets or sets the property which controls if the process should be running in visible or hidden mode
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseWorkingDirectory | Gets or sets if the working directory of the process.
 | WorkingDirectory | Gets or sets the working directory.
Remarks
Inheritance Hierarchy
Object
TaskRemoteExecuteClass

Send comments on this topic to Please email feedback to Support


TaskRemoteExecuteClass Constructor

TaskRemoteExecuteClass Constructor
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► TaskRemoteExecuteClass()()()
Initializes a new instance of the TaskRemoteExecuteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskRemoteExecuteClass()
Public Sub New
public:
TaskRemoteExecuteClass()


Arguments Property

Arguments Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► Arguments
Gets or sets the arguments that should be used when starting the process
Declaration Syntax
C# Visual Basic Visual C++
public string Arguments { get; set; }
Public Property Arguments As String
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskRemoteExecuteClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskRemoteExecuteClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.TaskRemoteExecuteClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public TaskRemoteExecuteClass CloneType()
Public Function CloneType As TaskRemoteExecuteClass
public:
TaskRemoteExecuteClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TaskRemoteExecuteClass.CloneType]


CmdLine Property

CmdLine Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► CmdLine
Gets or sets the path to the executable
Declaration Syntax
C# Visual Basic Visual C++
public string CmdLine { get; set; }
Public Property CmdLine As String
public:
property String^ CmdLine {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► HostName
Gets or sets the address of the remote server
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► NetworkCredential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Priority Property

Priority Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► Priority
Gets or sets the process priority.
Declaration Syntax
C# Visual Basic Visual C++
public ProcessPriorityClass Priority { get; set; }
Public Property Priority As ProcessPriorityClass
public:
property ProcessPriorityClass Priority {
    ProcessPriorityClass get ();
    void set (ProcessPriorityClass value);
}
Value
Return Value
Remarks
http://msdn2.microsoft.com/en-us/library/system.diagnostics.processpriorityclass.aspx


RunHidden Property

RunHidden Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► RunHidden
Gets or sets the property which controls if the process should be running in visible or hidden mode
Declaration Syntax
C# Visual Basic Visual C++
public bool RunHidden { get; set; }
Public Property RunHidden As Boolean
public:
property bool RunHidden {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UseWorkingDirectory Property

UseWorkingDirectory Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► UseWorkingDirectory
Gets or sets if the working directory of the process.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseWorkingDirectory { get; set; }
Public Property UseWorkingDirectory As Boolean
public:
property bool UseWorkingDirectory {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks
The Working Directory property behaves differently when Use shell execute is true than when Use shell execute is false. When Use shell execute is true, Working Directory specifies the location of the executable. If Working Directory is an empty string, the current directory is understood to contain the executable. When Use shell execute is false, the Working Directory property is not used to find the executable. Instead, it is used by the process that is launched and only has meaning within the context of the new process.


WorkingDirectory Property

WorkingDirectory Property
Namespaces ► VisualCron ► TaskRemoteExecuteClass ► WorkingDirectory
Gets or sets the working directory.
Declaration Syntax
C# Visual Basic Visual C++
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
The Working Directory property behaves differently when Use shell execute is true than when Use shell execute is false. When Use shell execute is true, Working Directory specifies the location of the executable. If Working Directory is an empty string, the current directory is understood to contain the executable. When Use shell execute is false, the Working Directory property is not used to find the executable. Instead, it is used by the process that is launched and only has meaning within the context of the new process.


TaskRemoteKillClass Class

TaskRemoteKillClass Class
Namespaces ► VisualCron ► TaskRemoteKillClass
This Task is able to terminate a remote running process
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskRemoteKillClass : ICloneable
<SerializableAttribute> _
Public Class TaskRemoteKillClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskRemoteKillClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskRemoteKillClass()()() | Initializes a new instance of the TaskRemoteKillClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address of the remote server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MultipleAction | Gets or sets multiple instance behavior
 | NetworkCredential | Gets or sets the Id of the Credential
 | ProcessToKill | Gets or sets the process image name which will be terminated
 | ProcessToKillCaseSensitive | Gets or sets if the match should be case sensitive
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskRemoteKillClass

Send comments on this topic to Please email feedback to Support


TaskRemoteKillClass Constructor

TaskRemoteKillClass Constructor
Namespaces ► VisualCron ► TaskRemoteKillClass ► TaskRemoteKillClass()()()
Initializes a new instance of the TaskRemoteKillClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskRemoteKillClass()
Public Sub New
public:
TaskRemoteKillClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskRemoteKillClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskRemoteKillClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskRemoteKillClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TaskRemoteKillClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.TaskRemoteKillClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public TaskRemoteKillClass CloneType()
Public Function CloneType As TaskRemoteKillClass
public:
TaskRemoteKillClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TaskRemoteKillClass.CloneType]


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskRemoteKillClass ► HostName
Gets or sets the address of the remote server
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MultipleAction Property

MultipleAction Property
Namespaces ► VisualCron ► TaskRemoteKillClass ► MultipleAction
Gets or sets multiple instance behavior
Declaration Syntax
C# Visual Basic Visual C++
public TaskKillClass..::.MultipleActionT MultipleAction { get; set; }
Public Property MultipleAction As TaskKillClass..::.MultipleActionT
public:
property TaskKillClass..::.MultipleActionT MultipleAction {
    TaskKillClass..::.MultipleActionT get ();
    void set (TaskKillClass..::.MultipleActionT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NetworkCredential Property

NetworkCredential Property
Namespaces ► VisualCron ► TaskRemoteKillClass ► NetworkCredential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string NetworkCredential { get; set; }
Public Property NetworkCredential As String
public:
property String^ NetworkCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProcessToKill Property

ProcessToKill Property
Namespaces ► VisualCron ► TaskRemoteKillClass ► ProcessToKill
Gets or sets the process image name which will be terminated
Declaration Syntax
C# Visual Basic Visual C++
public string ProcessToKill { get; set; }
Public Property ProcessToKill As String
public:
property String^ ProcessToKill {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ProcessToKillCaseSensitive Property

ProcessToKillCaseSensitive Property
Namespaces ► VisualCron ► TaskRemoteKillClass ► ProcessToKillCaseSensitive
Gets or sets if the match should be case sensitive
Declaration Syntax
C# Visual Basic Visual C++
public bool ProcessToKillCaseSensitive { get; set; }
Public Property ProcessToKillCaseSensitive As Boolean
public:
property bool ProcessToKillCaseSensitive {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskResultClass Class

TaskResultClass Class
Namespaces ► VisualCron ► TaskResultClass
Class that is used in API as result for foreground Task Execution
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskResultClass
<SerializableAttribute> _
Public Class TaskResultClass
[SerializableAttribute]
public ref class TaskResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskResultClass()()() | Initializes a new instance of the TaskResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExitCode | Gets or sets exit code of task
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result | Gets or sets the results of the task
 | STDError | Gets or sets standard error of task
 | STDOut | Gets or sets standard output of task
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskResultClass

Send comments on this topic to Please email feedback to Support


TaskResultClass Constructor

TaskResultClass Constructor
Namespaces ► VisualCron ► TaskResultClass ► TaskResultClass()()()
Initializes a new instance of the TaskResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskResultClass()
Public Sub New
public:
TaskResultClass()


ExitCode Property

ExitCode Property
Namespaces ► VisualCron ► TaskResultClass ► ExitCode
Gets or sets exit code of task
Declaration Syntax
C# Visual Basic Visual C++
public int ExitCode { get; set; }
Public Property ExitCode As Integer
public:
property int ExitCode {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Result Property

Result Property
Namespaces ► VisualCron ► TaskResultClass ► Result
Gets or sets the results of the task
Declaration Syntax
C# Visual Basic Visual C++
public string Result { get; set; }
Public Property Result As String
public:
property String^ Result {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


STDError Property

STDError Property
Namespaces ► VisualCron ► TaskResultClass ► STDError
Gets or sets standard error of task
Declaration Syntax
C# Visual Basic Visual C++
public string STDError { get; set; }
Public Property STDError As String
public:
property String^ STDError {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


STDOut Property

STDOut Property
Namespaces ► VisualCron ► TaskResultClass ► STDOut
Gets or sets standard output of task
Declaration Syntax
C# Visual Basic Visual C++
public string STDOut { get; set; }
Public Property STDOut As String
public:
property String^ STDOut {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskRunClass Class

TaskRunClass Class
Namespaces ► VisualCron ► TaskRunClass
A class that is used to Run a certain task
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskRunClass
<SerializableAttribute> _
Public Class TaskRunClass
[SerializableAttribute]
public ref class TaskRunClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskRunClass()()() | Initializes a new instance of the TaskRunClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Not used in the API
Inheritance Hierarchy
Object
TaskRunClass

Send comments on this topic to Please email feedback to Support


TaskRunClass Constructor

TaskRunClass Constructor
Namespaces ► VisualCron ► TaskRunClass ► TaskRunClass()()()
Initializes a new instance of the TaskRunClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskRunClass()
Public Sub New
public:
TaskRunClass()


JobId Property

JobId Property
Namespaces ► VisualCron ► TaskRunClass ► JobId

[Missing <summary> documentation for P:VisualCron.TaskRunClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


TaskId Property

TaskId Property
Namespaces ► VisualCron ► TaskRunClass ► TaskId

[Missing <summary> documentation for P:VisualCron.TaskRunClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


TaskSendKeysClass Class

TaskSendKeysClass Class
Namespaces ► VisualCron ► TaskSendKeysClass
This Task sends keystrokes to another application window
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSendKeysClass : ICloneable
<SerializableAttribute> _
Public Class TaskSendKeysClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSendKeysClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSendKeysClass()()() | Initializes a new instance of the TaskSendKeysClass class
 | AppName | Gets or sets the application window name
 | CaseSensitive | Gets or sets if VisualCron should try to match a window or process in case sensitive mode or not
 | ClassName | Gets or sets the window class name
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Keys | Gets or sets the keys that will be sent
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ProcessName | Gets or sets the process image name
 | SendKeysType | Gets or sets how to find the application window
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskSendKeysClass

Send comments on this topic to Please email feedback to Support


TaskSendKeysClass Constructor

TaskSendKeysClass Constructor
Namespaces ► VisualCron ► TaskSendKeysClass ► TaskSendKeysClass()()()
Initializes a new instance of the TaskSendKeysClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSendKeysClass()
Public Sub New
public:
TaskSendKeysClass()


AppName Property

AppName Property
Namespaces ► VisualCron ► TaskSendKeysClass ► AppName
Gets or sets the application window name
Declaration Syntax
C# Visual Basic Visual C++
public string AppName { get; set; }
Public Property AppName As String
public:
property String^ AppName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Only used in conjunction with SendKeysT.ApplicationTitle


CaseSensitive Property

CaseSensitive Property
Namespaces ► VisualCron ► TaskSendKeysClass ► CaseSensitive
Gets or sets if VisualCron should try to match a window or process in case sensitive mode or not
Declaration Syntax
C# Visual Basic Visual C++
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ClassName Property

ClassName Property
Namespaces ► VisualCron ► TaskSendKeysClass ► ClassName
Gets or sets the window class name
Declaration Syntax
C# Visual Basic Visual C++
public string ClassName { get; set; }
Public Property ClassName As String
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Optional but makes it easier to find the actual window. Only used in conjunction with SendKeysT.ApplicationTitle


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSendKeysClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSendKeysClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSendKeysClass.Clone]


Keys Property

Keys Property
Namespaces ► VisualCron ► TaskSendKeysClass ► Keys
Gets or sets the keys that will be sent
Declaration Syntax
C# Visual Basic Visual C++
public string Keys { get; set; }
Public Property Keys As String
public:
property String^ Keys {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
See a list of special key codes here http://msdn2.microsoft.com/en-us/library/8c6yea83.aspx


ProcessName Property

ProcessName Property
Namespaces ► VisualCron ► TaskSendKeysClass ► ProcessName
Gets or sets the process image name
Declaration Syntax
C# Visual Basic Visual C++
public string ProcessName { get; set; }
Public Property ProcessName As String
public:
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Only used in conjunction with SendKeysT.ProcessName


SendKeysType Property

SendKeysType Property
Namespaces ► VisualCron ► TaskSendKeysClass ► SendKeysType
Gets or sets how to find the application window
Declaration Syntax
C# Visual Basic Visual C++
public TaskSendKeysClass..::.SendKeysT SendKeysType { get; set; }
Public Property SendKeysType As TaskSendKeysClass..::.SendKeysT
public:
property TaskSendKeysClass..::.SendKeysT SendKeysType {
    TaskSendKeysClass..::.SendKeysT get ();
    void set (TaskSendKeysClass..::.SendKeysT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskSendKeysClass.SendKeysT Enumeration

TaskSendKeysClass..::.SendKeysT Enumeration
Namespaces ► VisualCron ► TaskSendKeysClass ► TaskSendKeysClass..::.SendKeysT
Enum that contains ways find a window
Declaration Syntax
C# Visual Basic Visual C++
public enum SendKeysT
Public Enumeration SendKeysT
public enum class SendKeysT
Members
Member | Description
ProcessName |
ApplicationTitle |
Remarks

Send comments on this topic to Please email feedback to Support


TaskServiceRestartClass Class

TaskServiceRestartClass Class
Namespaces ► VisualCron ► TaskServiceRestartClass

[Missing <summary> documentation for T:VisualCron.TaskServiceRestartClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskServiceRestartClass : ICloneable
<SerializableAttribute> _
Public Class TaskServiceRestartClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskServiceRestartClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskServiceRestartClass()()() | Initializes a new instance of the TaskServiceRestartClass class
 | Arguments | List of arguments for Starting the service
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address to the server which contains the service
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ServiceName | Gets or sets the name of the Service
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskServiceRestartClass

Send comments on this topic to Please email feedback to Support


TaskServiceRestartClass Constructor

TaskServiceRestartClass Constructor
Namespaces ► VisualCron ► TaskServiceRestartClass ► TaskServiceRestartClass()()()
Initializes a new instance of the TaskServiceRestartClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskServiceRestartClass()
Public Sub New
public:
TaskServiceRestartClass()


Arguments Field

Arguments Field
Namespaces ► VisualCron ► TaskServiceRestartClass ► Arguments
List of arguments for Starting the service
Declaration Syntax
C# Visual Basic Visual C++
public List<ServiceArgumentClass> Arguments
Public Arguments As List(Of ServiceArgumentClass)
public:
List<ServiceArgumentClass^>^ Arguments
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskServiceRestartClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskServiceRestartClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskServiceRestartClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskServiceRestartClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskServiceRestartClass ► HostName
Gets or sets the address to the server which contains the service
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskServiceRestartClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskServiceRestartClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


ServiceName Property

ServiceName Property
Namespaces ► VisualCron ► TaskServiceRestartClass ► ServiceName
Gets or sets the name of the Service
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceName { get; set; }
Public Property ServiceName As String
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskServiceStartClass Class

TaskServiceStartClass Class
Namespaces ► VisualCron ► TaskServiceStartClass

[Missing <summary> documentation for T:VisualCron.TaskServiceStartClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskServiceStartClass : ICloneable
<SerializableAttribute> _
Public Class TaskServiceStartClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskServiceStartClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskServiceStartClass()()() | Initializes a new instance of the TaskServiceStartClass class
 | Arguments | List of arguments for Starting the service
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address to the server which contains the service
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ServiceName | Gets or sets the name of the Service
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskServiceStartClass

Send comments on this topic to Please email feedback to Support


TaskServiceStartClass Constructor

TaskServiceStartClass Constructor
Namespaces ► VisualCron ► TaskServiceStartClass ► TaskServiceStartClass()()()
Initializes a new instance of the TaskServiceStartClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskServiceStartClass()
Public Sub New
public:
TaskServiceStartClass()


Arguments Field

Arguments Field
Namespaces ► VisualCron ► TaskServiceStartClass ► Arguments
List of arguments for Starting the service
Declaration Syntax
C# Visual Basic Visual C++
public List<ServiceArgumentClass> Arguments
Public Arguments As List(Of ServiceArgumentClass)
public:
List<ServiceArgumentClass^>^ Arguments
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskServiceStartClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskServiceStartClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskServiceStartClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskServiceStartClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskServiceStartClass ► HostName
Gets or sets the address to the server which contains the service
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskServiceStartClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskServiceStartClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


ServiceName Property

ServiceName Property
Namespaces ► VisualCron ► TaskServiceStartClass ► ServiceName
Gets or sets the name of the Service
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceName { get; set; }
Public Property ServiceName As String
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskServiceStopClass Class

TaskServiceStopClass Class
Namespaces ► VisualCron ► TaskServiceStopClass

[Missing <summary> documentation for T:VisualCron.TaskServiceStopClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskServiceStopClass : ICloneable
<SerializableAttribute> _
Public Class TaskServiceStopClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskServiceStopClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskServiceStopClass()()() | Initializes a new instance of the TaskServiceStopClass class
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address to the server which contains the service
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ServiceName | Gets or sets the name of the Service
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskServiceStopClass

Send comments on this topic to Please email feedback to Support


TaskServiceStopClass Constructor

TaskServiceStopClass Constructor
Namespaces ► VisualCron ► TaskServiceStopClass ► TaskServiceStopClass()()()
Initializes a new instance of the TaskServiceStopClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskServiceStopClass()
Public Sub New
public:
TaskServiceStopClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskServiceStopClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskServiceStopClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskServiceStopClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskServiceStopClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskServiceStopClass ► HostName
Gets or sets the address to the server which contains the service
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskServiceStopClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskServiceStopClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


ServiceName Property

ServiceName Property
Namespaces ► VisualCron ► TaskServiceStopClass ► ServiceName
Gets or sets the name of the Service
Declaration Syntax
C# Visual Basic Visual C++
public string ServiceName { get; set; }
Public Property ServiceName As String
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskSQLClass Class

TaskSQLClass Class
Namespaces ► VisualCron ► TaskSQLClass
The SQL task can execute a normal SQL query or Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSQLClass : ICloneable
<SerializableAttribute> _
Public Class TaskSQLClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSQLClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSQLClass()()() | Initializes a new instance of the TaskSQLClass class
 | Clone()()() |
 | Command | The actual SQL string or name of Stored Procedure
 | CommandTimeout | Gets or sets the timeout in seconds that the command has to be executed within
 | CommandType | Gets or sets if you want to execute a normal SQL or a Stored Procedure
 | ConnectionId | The Id of the Connection that is used
 | Credential | Gets or sets the Credential Id that is used for integrated security
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsStoredProcedureJob | Gets or sets if the stored procedure is a Job type
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Output | Gets or sets the objec that contains the output settings for the Task
 | Parameters | A list of parameters (SQLParameterClass) that is used for the Stored Procedure
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskSQLClass

Send comments on this topic to Please email feedback to Support


TaskSQLClass Constructor

TaskSQLClass Constructor
Namespaces ► VisualCron ► TaskSQLClass ► TaskSQLClass()()()
Initializes a new instance of the TaskSQLClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSQLClass()
Public Sub New
public:
TaskSQLClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSQLClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSQLClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSQLClass.Clone]


Command Property

Command Property
Namespaces ► VisualCron ► TaskSQLClass ► Command
The actual SQL string or name of Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
public string Command { get; set; }
Public Property Command As String
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CommandTimeout Property

CommandTimeout Property
Namespaces ► VisualCron ► TaskSQLClass ► CommandTimeout
Gets or sets the timeout in seconds that the command has to be executed within
Declaration Syntax
C# Visual Basic Visual C++
public int CommandTimeout { get; set; }
Public Property CommandTimeout As Integer
public:
property int CommandTimeout {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


CommandType Property

CommandType Property
Namespaces ► VisualCron ► TaskSQLClass ► CommandType
Gets or sets if you want to execute a normal SQL or a Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
public CommandType CommandType { get; set; }
Public Property CommandType As CommandType
public:
property CommandType CommandType {
    CommandType get ();
    void set (CommandType value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ConnectionId Property

ConnectionId Property
Namespaces ► VisualCron ► TaskSQLClass ► ConnectionId
The Id of the Connection that is used
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionId { get; set; }
Public Property ConnectionId As String
public:
property String^ ConnectionId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSQLClass ► Credential
Gets or sets the Credential Id that is used for integrated security
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IsStoredProcedureJob Property

IsStoredProcedureJob Property
Namespaces ► VisualCron ► TaskSQLClass ► IsStoredProcedureJob
Gets or sets if the stored procedure is a Job type
Declaration Syntax
C# Visual Basic Visual C++
public bool IsStoredProcedureJob { get; set; }
Public Property IsStoredProcedureJob As Boolean
public:
property bool IsStoredProcedureJob {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Output Property

Output Property
Namespaces ► VisualCron ► TaskSQLClass ► Output
Gets or sets the objec that contains the output settings for the Task
Declaration Syntax
C# Visual Basic Visual C++
public TaskSQLOutputSettingsClass Output { get; set; }
Public Property Output As TaskSQLOutputSettingsClass
public:
property TaskSQLOutputSettingsClass^ Output {
    TaskSQLOutputSettingsClass^ get ();
    void set (TaskSQLOutputSettingsClass^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Parameters Field

Parameters Field
Namespaces ► VisualCron ► TaskSQLClass ► Parameters
A list of parameters (SQLParameterClass) that is used for the Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
public List<SQLParameterClass> Parameters
Public Parameters As List(Of SQLParameterClass)
public:
List<SQLParameterClass^>^ Parameters
Remarks

Send comments on this topic to Please email feedback to Support


TaskSQLOutputSettingsClass Class

TaskSQLOutputSettingsClass Class
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass

[Missing <summary> documentation for T:VisualCron.TaskSQLOutputSettingsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSQLOutputSettingsClass : ICloneable
<SerializableAttribute> _
Public Class TaskSQLOutputSettingsClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSQLOutputSettingsClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSQLOutputSettingsClass()()() | Initializes a new instance of the TaskSQLOutputSettingsClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FieldSeparatorChar | Gets or sets the field/column separator
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IncludeColumnNames | Gets or sets if column names should be included in output
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewLineChar | Gets or sets the new line character
 | TextQualifierChar | Gets or sets the sorrounding characters of the fields
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskSQLOutputSettingsClass

Send comments on this topic to Please email feedback to Support


TaskSQLOutputSettingsClass Constructor

TaskSQLOutputSettingsClass Constructor
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► TaskSQLOutputSettingsClass()()()
Initializes a new instance of the TaskSQLOutputSettingsClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSQLOutputSettingsClass()
Public Sub New
public:
TaskSQLOutputSettingsClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSQLOutputSettingsClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSQLOutputSettingsClass.Clone]


FieldSeparatorChar Property

FieldSeparatorChar Property
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► FieldSeparatorChar
Gets or sets the field/column separator
Declaration Syntax
C# Visual Basic Visual C++
public TaskSQLOutputSettingsClass..::.FieldSeparatorCharT FieldSeparatorChar { get; set; }
Public Property FieldSeparatorChar As TaskSQLOutputSettingsClass..::.FieldSeparatorCharT
public:
property TaskSQLOutputSettingsClass..::.FieldSeparatorCharT FieldSeparatorChar {
    TaskSQLOutputSettingsClass..::.FieldSeparatorCharT get ();
    void set (TaskSQLOutputSettingsClass..::.FieldSeparatorCharT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IncludeColumnNames Property

IncludeColumnNames Property
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► IncludeColumnNames
Gets or sets if column names should be included in output
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeColumnNames { get; set; }
Public Property IncludeColumnNames As Boolean
public:
property bool IncludeColumnNames {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NewLineChar Property

NewLineChar Property
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► NewLineChar
Gets or sets the new line character
Declaration Syntax
C# Visual Basic Visual C++
public TaskSQLOutputSettingsClass..::.NewLineCharT NewLineChar { get; set; }
Public Property NewLineChar As TaskSQLOutputSettingsClass..::.NewLineCharT
public:
property TaskSQLOutputSettingsClass..::.NewLineCharT NewLineChar {
    TaskSQLOutputSettingsClass..::.NewLineCharT get ();
    void set (TaskSQLOutputSettingsClass..::.NewLineCharT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TextQualifierChar Property

TextQualifierChar Property
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► TextQualifierChar
Gets or sets the sorrounding characters of the fields
Declaration Syntax
C# Visual Basic Visual C++
public string TextQualifierChar { get; set; }
Public Property TextQualifierChar As String
public:
property String^ TextQualifierChar {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskSQLOutputSettingsClass.FieldSeparatorCharT Enumeration

TaskSQLOutputSettingsClass..::.FieldSeparatorCharT Enumeration
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► TaskSQLOutputSettingsClass..::.FieldSeparatorCharT

[Missing <summary> documentation for T:VisualCron.TaskSQLOutputSettingsClass.FieldSeparatorCharT]

Declaration Syntax
C# Visual Basic Visual C++
public enum FieldSeparatorCharT
Public Enumeration FieldSeparatorCharT
public enum class FieldSeparatorCharT
Members
Member | Description
Colon |
Semicolon |
Comma |
Pipe |
Tab |
Blankspace |


TaskSQLOutputSettingsClass.NewLineCharT Enumeration

TaskSQLOutputSettingsClass..::.NewLineCharT Enumeration
Namespaces ► VisualCron ► TaskSQLOutputSettingsClass ► TaskSQLOutputSettingsClass..::.NewLineCharT

[Missing <summary> documentation for T:VisualCron.TaskSQLOutputSettingsClass.NewLineCharT]

Declaration Syntax
C# Visual Basic Visual C++
public enum NewLineCharT
Public Enumeration NewLineCharT
public enum class NewLineCharT
Members
Member | Description
Cr |
CrLf |
Lf |


TaskSSHClass Class

TaskSSHClass Class
Namespaces ► VisualCron ► TaskSSHClass
The SSH task can execute commands of a command channel
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSSHClass : ICloneable
<SerializableAttribute> _
Public Class TaskSSHClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSSHClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSSHClass()()() | Initializes a new instance of the TaskSSHClass class
 | Clone()()() |
 | Commands | A list of SSHCommandClass that is executed in order
 | CommandType | What command type is currently used
 | ConnectionId | Id of the ConnectionClass that is used
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindCommandOrder()()() | Gets the next free available order of the SSHCommandClass in the Commands list
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskSSHClass

Send comments on this topic to Please email feedback to Support


TaskSSHClass Constructor

TaskSSHClass Constructor
Namespaces ► VisualCron ► TaskSSHClass ► TaskSSHClass()()()
Initializes a new instance of the TaskSSHClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSSHClass()
Public Sub New
public:
TaskSSHClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSSHClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSSHClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSSHClass.Clone]


Commands Field

Commands Field
Namespaces ► VisualCron ► TaskSSHClass ► Commands
A list of SSHCommandClass that is executed in order
Declaration Syntax
C# Visual Basic Visual C++
public List<SSHCommandClass> Commands
Public Commands As List(Of SSHCommandClass)
public:
List<SSHCommandClass^>^ Commands
Remarks

Send comments on this topic to Please email feedback to Support


CommandType Field

CommandType Field
Namespaces ► VisualCron ► TaskSSHClass ► CommandType
What command type is currently used
Declaration Syntax
C# Visual Basic Visual C++
public TaskSSHClass..::.SSHCommandT CommandType
Public CommandType As TaskSSHClass..::.SSHCommandT
public:
TaskSSHClass..::.SSHCommandT CommandType
Remarks
Currently only SendCommand is available

Send comments on this topic to Please email feedback to Support


ConnectionId Property

ConnectionId Property
Namespaces ► VisualCron ► TaskSSHClass ► ConnectionId
Id of the ConnectionClass that is used
Declaration Syntax
C# Visual Basic Visual C++
public string ConnectionId { get; set; }
Public Property ConnectionId As String
public:
property String^ ConnectionId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FindCommandOrder Method

FindCommandOrder Method
Namespaces ► VisualCron ► TaskSSHClass ► FindCommandOrder()()()
Gets the next free available order of the SSHCommandClass in the Commands list
Declaration Syntax
C# Visual Basic Visual C++
public int FindCommandOrder()
Public Function FindCommandOrder As Integer
public:
int FindCommandOrder()
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSSHClass.FindCommandOrder]

Remarks

Send comments on this topic to Please email feedback to Support


TaskSSHClass.SSHCommandT Enumeration

TaskSSHClass..::.SSHCommandT Enumeration
Namespaces ► VisualCron ► TaskSSHClass ► TaskSSHClass..::.SSHCommandT
Enum that defines the way the command should be executed
Declaration Syntax
C# Visual Basic Visual C++
public enum SSHCommandT
Public Enumeration SSHCommandT
public enum class SSHCommandT
Members
Member | Description
SendText |
SendCommand |
Remarks

Send comments on this topic to Please email feedback to Support


TaskSSISClass Class

TaskSSISClass Class
Namespaces ► VisualCron ► TaskSSISClass
The SSIS task can execute Sql Server 2005 Integration Services packages
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSSISClass : ICloneable
<SerializableAttribute> _
Public Class TaskSSISClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSSISClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSSISClass()()() | Initializes a new instance of the TaskSSISClass class
 | Clone()()() |
 | ConfigFilePath | Gets or sets the path to the configuration file
 | Credential | Gets or sets the Credential Id that will be used for Integrated Windows Security
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LoadConfigFile | Gets or sets whether the config file should be loaded or not
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PackageLocation | Gets or sets where the package is located
 | PackageName | Gets or sets the name of the package
 | PackagePath | Gets or sets the patch to the package
 | Parameters | A list of parameters (SQLParameterClass) that is used for the Stored Procedure
 | Password | Gets or sets the password for the package
 | SQLCredential | Gets or sets the Credential Id that will be used when loading the package from the SQL Server
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskSSISClass

Send comments on this topic to Please email feedback to Support


TaskSSISClass Constructor

TaskSSISClass Constructor
Namespaces ► VisualCron ► TaskSSISClass ► TaskSSISClass()()()
Initializes a new instance of the TaskSSISClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSSISClass()
Public Sub New
public:
TaskSSISClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSSISClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSSISClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSSISClass.Clone]


ConfigFilePath Property

ConfigFilePath Property
Namespaces ► VisualCron ► TaskSSISClass ► ConfigFilePath
Gets or sets the path to the configuration file
Declaration Syntax
C# Visual Basic Visual C++
public string ConfigFilePath { get; set; }
Public Property ConfigFilePath As String
public:
property String^ ConfigFilePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSSISClass ► Credential
Gets or sets the Credential Id that will be used for Integrated Windows Security
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LoadConfigFile Property

LoadConfigFile Property
Namespaces ► VisualCron ► TaskSSISClass ► LoadConfigFile
Gets or sets whether the config file should be loaded or not
Declaration Syntax
C# Visual Basic Visual C++
public bool LoadConfigFile { get; set; }
Public Property LoadConfigFile As Boolean
public:
property bool LoadConfigFile {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PackageLocation Property

PackageLocation Property
Namespaces ► VisualCron ► TaskSSISClass ► PackageLocation
Gets or sets where the package is located
Declaration Syntax
C# Visual Basic Visual C++
public TaskSSISClass..::.SSISPackageLocationT PackageLocation { get; set; }
Public Property PackageLocation As TaskSSISClass..::.SSISPackageLocationT
public:
property TaskSSISClass..::.SSISPackageLocationT PackageLocation {
    TaskSSISClass..::.SSISPackageLocationT get ();
    void set (TaskSSISClass..::.SSISPackageLocationT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PackageName Property

PackageName Property
Namespaces ► VisualCron ► TaskSSISClass ► PackageName
Gets or sets the name of the package
Declaration Syntax
C# Visual Basic Visual C++
public string PackageName { get; set; }
Public Property PackageName As String
public:
property String^ PackageName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


PackagePath Property

PackagePath Property
Namespaces ► VisualCron ► TaskSSISClass ► PackagePath
Gets or sets the patch to the package
Declaration Syntax
C# Visual Basic Visual C++
public string PackagePath { get; set; }
Public Property PackagePath As String
public:
property String^ PackagePath {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
When Database as DTSLocationT is used

Send comments on this topic to Please email feedback to Support


Parameters Field

Parameters Field
Namespaces ► VisualCron ► TaskSSISClass ► Parameters
A list of parameters (SQLParameterClass) that is used for the Stored Procedure
Declaration Syntax
C# Visual Basic Visual C++
public List<SQLParameterClass> Parameters
Public Parameters As List(Of SQLParameterClass)
public:
List<SQLParameterClass^>^ Parameters
Remarks

Send comments on this topic to Please email feedback to Support


Password Property

Password Property
Namespaces ► VisualCron ► TaskSSISClass ► Password
Gets or sets the password for the package
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Password { get; set; }
Public Property Password As Byte()
public:
property array<unsigned char>^ Password {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks
Encrypted

Send comments on this topic to Please email feedback to Support


SQLCredential Property

SQLCredential Property
Namespaces ► VisualCron ► TaskSSISClass ► SQLCredential
Gets or sets the Credential Id that will be used when loading the package from the SQL Server
Declaration Syntax
C# Visual Basic Visual C++
public string SQLCredential { get; set; }
Public Property SQLCredential As String
public:
property String^ SQLCredential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskSSISClass.SSISPackageLocationT Enumeration

TaskSSISClass..::.SSISPackageLocationT Enumeration
Namespaces ► VisualCron ► TaskSSISClass ► TaskSSISClass..::.SSISPackageLocationT
Enum that describes where the package is located
Declaration Syntax
C# Visual Basic Visual C++
public enum SSISPackageLocationT
Public Enumeration SSISPackageLocationT
public enum class SSISPackageLocationT
Members
Member | Description
File |
Database |
DTSServer |
Repository |
Remarks

Send comments on this topic to Please email feedback to Support


TaskStateClass Class

TaskStateClass Class
Namespaces ► VisualCron ► TaskStateClass
Message that changes Task Active state
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskStateClass
<SerializableAttribute> _
Public Class TaskStateClass
[SerializableAttribute]
public ref class TaskStateClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskStateClass()()() | Initializes a new instance of the TaskStateClass class
 | Active |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskStateClass

Send comments on this topic to Please email feedback to Support


TaskStateClass Constructor

TaskStateClass Constructor
Namespaces ► VisualCron ► TaskStateClass ► TaskStateClass()()()
Initializes a new instance of the TaskStateClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskStateClass()
Public Sub New
public:
TaskStateClass()


Active Property

Active Property
Namespaces ► VisualCron ► TaskStateClass ► Active

[Missing <summary> documentation for P:VisualCron.TaskStateClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}


JobId Property

JobId Property
Namespaces ► VisualCron ► TaskStateClass ► JobId

[Missing <summary> documentation for P:VisualCron.TaskStateClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


TaskId Property

TaskId Property
Namespaces ► VisualCron ► TaskStateClass ► TaskId

[Missing <summary> documentation for P:VisualCron.TaskStateClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


TaskStatsClass Class

TaskStatsClass Class
Namespaces ► VisualCron ► TaskStatsClass

[Missing <summary> documentation for T:VisualCron.TaskStatsClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskStatsClass
<SerializableAttribute> _
Public Class TaskStatsClass
[SerializableAttribute]
public ref class TaskStatsClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskStatsClass()()() | Initializes a new instance of the TaskStatsClass class
 | Active |
 | CloneType()()() |
 | DateLastExecution |
 | DateLastExited |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExecutionTime |
 | ExitCode |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NoExecutes |
 | Result |
 | StandardError |
 | StandardOutput |
 | Status |
 | TaskId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskStatsClass

Send comments on this topic to Please email feedback to Support


TaskStatsClass Constructor

TaskStatsClass Constructor
Namespaces ► VisualCron ► TaskStatsClass ► TaskStatsClass()()()
Initializes a new instance of the TaskStatsClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskStatsClass()
Public Sub New
public:
TaskStatsClass()


Active Property

Active Property
Namespaces ► VisualCron ► TaskStatsClass ► Active

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.Active]

Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TaskStatsClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.TaskStatsClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public TaskStatsClass CloneType()
Public Function CloneType As TaskStatsClass
public:
TaskStatsClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TaskStatsClass.CloneType]


DateLastExecution Property

DateLastExecution Property
Namespaces ► VisualCron ► TaskStatsClass ► DateLastExecution

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.DateLastExecution]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateLastExecution { get; set; }
Public Property DateLastExecution As DateTime
public:
property DateTime DateLastExecution {
    DateTime get ();
    void set (DateTime value);
}


DateLastExited Property

DateLastExited Property
Namespaces ► VisualCron ► TaskStatsClass ► DateLastExited

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.DateLastExited]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateLastExited { get; set; }
Public Property DateLastExited As DateTime
public:
property DateTime DateLastExited {
    DateTime get ();
    void set (DateTime value);
}


ExecutionTime Property

ExecutionTime Property
Namespaces ► VisualCron ► TaskStatsClass ► ExecutionTime

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.ExecutionTime]

Declaration Syntax
C# Visual Basic Visual C++
public double ExecutionTime { get; set; }
Public Property ExecutionTime As Double
public:
property double ExecutionTime {
    double get ();
    void set (double value);
}


ExitCode Property

ExitCode Property
Namespaces ► VisualCron ► TaskStatsClass ► ExitCode

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.ExitCode]

Declaration Syntax
C# Visual Basic Visual C++
public int ExitCode { get; set; }
Public Property ExitCode As Integer
public:
property int ExitCode {
    int get ();
    void set (int value);
}


JobId Property

JobId Property
Namespaces ► VisualCron ► TaskStatsClass ► JobId

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


NoExecutes Property

NoExecutes Property
Namespaces ► VisualCron ► TaskStatsClass ► NoExecutes

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.NoExecutes]

Declaration Syntax
C# Visual Basic Visual C++
public long NoExecutes { get; set; }
Public Property NoExecutes As Long
public:
property long long NoExecutes {
    long long get ();
    void set (long long value);
}


Result Property

Result Property
Namespaces ► VisualCron ► TaskStatsClass ► Result

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.Result]

Declaration Syntax
C# Visual Basic Visual C++
public string Result { get; set; }
Public Property Result As String
public:
property String^ Result {
    String^ get ();
    void set (String^ value);
}


StandardError Property

StandardError Property
Namespaces ► VisualCron ► TaskStatsClass ► StandardError

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.StandardError]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] StandardError { get; set; }
Public Property StandardError As Byte()
public:
property array<unsigned char>^ StandardError {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


StandardOutput Property

StandardOutput Property
Namespaces ► VisualCron ► TaskStatsClass ► StandardOutput

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.StandardOutput]

Declaration Syntax
C# Visual Basic Visual C++
public byte[] StandardOutput { get; set; }
Public Property StandardOutput As Byte()
public:
property array<unsigned char>^ StandardOutput {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}


Status Field

Status Field
Namespaces ► VisualCron ► TaskStatsClass ► Status

[Missing <summary> documentation for F:VisualCron.TaskStatsClass.Status]

Declaration Syntax
C# Visual Basic Visual C++
public TaskStatsClass..::.TaskStatusT Status
Public Status As TaskStatsClass..::.TaskStatusT
public:
TaskStatsClass..::.TaskStatusT Status

Send comments on this topic to Please email feedback to Support


TaskId Property

TaskId Property
Namespaces ► VisualCron ► TaskStatsClass ► TaskId

[Missing <summary> documentation for P:VisualCron.TaskStatsClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


TaskStatsClass.TaskStatusT Enumeration

TaskStatsClass..::.TaskStatusT Enumeration
Namespaces ► VisualCron ► TaskStatsClass ► TaskStatsClass..::.TaskStatusT

[Missing <summary> documentation for T:VisualCron.TaskStatsClass.TaskStatusT]

Declaration Syntax
C# Visual Basic Visual C++
public enum TaskStatusT
Public Enumeration TaskStatusT
public enum class TaskStatusT
Members
Member | Description
Running |
Waiting |


TaskSystemControlMonitorClass Class

TaskSystemControlMonitorClass Class
Namespaces ► VisualCron ► TaskSystemControlMonitorClass

[Missing <summary> documentation for T:VisualCron.TaskSystemControlMonitorClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemControlMonitorClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemControlMonitorClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemControlMonitorClass : ICloneable
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemControlMonitorClass()()() | Initializes a new instance of the TaskSystemControlMonitorClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MonitorState |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskSystemControlMonitorClass

Send comments on this topic to Please email feedback to Support


TaskSystemControlMonitorClass Constructor

TaskSystemControlMonitorClass Constructor
Namespaces ► VisualCron ► TaskSystemControlMonitorClass ► TaskSystemControlMonitorClass()()()
Initializes a new instance of the TaskSystemControlMonitorClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemControlMonitorClass()
Public Sub New
public:
TaskSystemControlMonitorClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemControlMonitorClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemControlMonitorClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemControlMonitorClass.Clone]


MonitorState Field

MonitorState Field
Namespaces ► VisualCron ► TaskSystemControlMonitorClass ► MonitorState

[Missing <summary> documentation for F:VisualCron.TaskSystemControlMonitorClass.MonitorState]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.MonitorStateT MonitorState
Public MonitorState As EnumClass..::.MonitorStateT
public:
EnumClass..::.MonitorStateT MonitorState

Send comments on this topic to Please email feedback to Support


TaskSystemHibernateClass Class

TaskSystemHibernateClass Class
Namespaces ► VisualCron ► TaskSystemHibernateClass

[Missing <summary> documentation for T:VisualCron.TaskSystemHibernateClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemHibernateClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemHibernateClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemHibernateClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemHibernateClass()()() | Initializes a new instance of the TaskSystemHibernateClass class
 | Clone()()() |
 | Credential |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Force |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WakeUp |
 | WakeUpAfterHours |
 | WakeUpAfterMinutes |
 | WakeUpAfterSeconds |
 | WakeUpAt |
 | WakeUpType |
Inheritance Hierarchy
Object
TaskSystemHibernateClass

Send comments on this topic to Please email feedback to Support


TaskSystemHibernateClass Constructor

TaskSystemHibernateClass Constructor
Namespaces ► VisualCron ► TaskSystemHibernateClass ► TaskSystemHibernateClass()()()
Initializes a new instance of the TaskSystemHibernateClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemHibernateClass()
Public Sub New
public:
TaskSystemHibernateClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemHibernateClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemHibernateClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemHibernateClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► Credential

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.Credential]

Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}


Force Property

Force Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► Force

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.Force]

Declaration Syntax
C# Visual Basic Visual C++
public bool Force { get; set; }
Public Property Force As Boolean
public:
property bool Force {
    bool get ();
    void set (bool value);
}


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► HostName

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.HostName]

Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskSystemHibernateClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskSystemHibernateClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


WakeUp Property

WakeUp Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► WakeUp

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.WakeUp]

Declaration Syntax
C# Visual Basic Visual C++
public bool WakeUp { get; set; }
Public Property WakeUp As Boolean
public:
property bool WakeUp {
    bool get ();
    void set (bool value);
}


WakeUpAfterHours Property

WakeUpAfterHours Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► WakeUpAfterHours

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.WakeUpAfterHours]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterHours { get; set; }
Public Property WakeUpAfterHours As Integer
public:
property int WakeUpAfterHours {
    int get ();
    void set (int value);
}


WakeUpAfterMinutes Property

WakeUpAfterMinutes Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► WakeUpAfterMinutes

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.WakeUpAfterMinutes]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterMinutes { get; set; }
Public Property WakeUpAfterMinutes As Integer
public:
property int WakeUpAfterMinutes {
    int get ();
    void set (int value);
}


WakeUpAfterSeconds Property

WakeUpAfterSeconds Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► WakeUpAfterSeconds

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.WakeUpAfterSeconds]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterSeconds { get; set; }
Public Property WakeUpAfterSeconds As Integer
public:
property int WakeUpAfterSeconds {
    int get ();
    void set (int value);
}


WakeUpAt Property

WakeUpAt Property
Namespaces ► VisualCron ► TaskSystemHibernateClass ► WakeUpAt

[Missing <summary> documentation for P:VisualCron.TaskSystemHibernateClass.WakeUpAt]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime WakeUpAt { get; set; }
Public Property WakeUpAt As DateTime
public:
property DateTime WakeUpAt {
    DateTime get ();
    void set (DateTime value);
}


WakeUpType Field

WakeUpType Field
Namespaces ► VisualCron ► TaskSystemHibernateClass ► WakeUpType

[Missing <summary> documentation for F:VisualCron.TaskSystemHibernateClass.WakeUpType]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.WakeUpT WakeUpType
Public WakeUpType As EnumClass..::.WakeUpT
public:
EnumClass..::.WakeUpT WakeUpType

Send comments on this topic to Please email feedback to Support


TaskSystemLockClass Class

TaskSystemLockClass Class
Namespaces ► VisualCron ► TaskSystemLockClass

[Missing <summary> documentation for T:VisualCron.TaskSystemLockClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemLockClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemLockClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemLockClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemLockClass()()() | Initializes a new instance of the TaskSystemLockClass class
 | Clone()()() |
 | Credential | An Id of a Credential that will be used to unlock (Vista only)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskSystemLockClass

Send comments on this topic to Please email feedback to Support


TaskSystemLockClass Constructor

TaskSystemLockClass Constructor
Namespaces ► VisualCron ► TaskSystemLockClass ► TaskSystemLockClass()()()
Initializes a new instance of the TaskSystemLockClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemLockClass()
Public Sub New
public:
TaskSystemLockClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemLockClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemLockClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemLockClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSystemLockClass ► Credential
An Id of a Credential that will be used to unlock (Vista only)
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskSystemLogoffClass Class

TaskSystemLogoffClass Class
Namespaces ► VisualCron ► TaskSystemLogoffClass

[Missing <summary> documentation for T:VisualCron.TaskSystemLogoffClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemLogoffClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemLogoffClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemLogoffClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemLogoffClass()()() | Initializes a new instance of the TaskSystemLogoffClass class
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Force |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address of the remote server
 | LogOffScope |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserName | Gets or sets the user name of the user to log off
Inheritance Hierarchy
Object
TaskSystemLogoffClass

Send comments on this topic to Please email feedback to Support


TaskSystemLogoffClass Constructor

TaskSystemLogoffClass Constructor
Namespaces ► VisualCron ► TaskSystemLogoffClass ► TaskSystemLogoffClass()()()
Initializes a new instance of the TaskSystemLogoffClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemLogoffClass()
Public Sub New
public:
TaskSystemLogoffClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemLogoffClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemLogoffClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemLogoffClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSystemLogoffClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Force Property

Force Property
Namespaces ► VisualCron ► TaskSystemLogoffClass ► Force

[Missing <summary> documentation for P:VisualCron.TaskSystemLogoffClass.Force]

Declaration Syntax
C# Visual Basic Visual C++
public bool Force { get; set; }
Public Property Force As Boolean
public:
property bool Force {
    bool get ();
    void set (bool value);
}


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskSystemLogoffClass ► HostName
Gets or sets the address of the remote server
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LogOffScope Field

LogOffScope Field
Namespaces ► VisualCron ► TaskSystemLogoffClass ► LogOffScope

[Missing <summary> documentation for F:VisualCron.TaskSystemLogoffClass.LogOffScope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.LogoffScope LogOffScope
Public LogOffScope As EnumClass..::.LogoffScope
public:
EnumClass..::.LogoffScope LogOffScope

Send comments on this topic to Please email feedback to Support


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskSystemLogoffClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskSystemLogoffClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


UserName Property

UserName Property
Namespaces ► VisualCron ► TaskSystemLogoffClass ► UserName
Gets or sets the user name of the user to log off
Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskSystemRestartClass Class

TaskSystemRestartClass Class
Namespaces ► VisualCron ► TaskSystemRestartClass

[Missing <summary> documentation for T:VisualCron.TaskSystemRestartClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemRestartClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemRestartClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemRestartClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemRestartClass()()() | Initializes a new instance of the TaskSystemRestartClass class
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address of the remote server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskSystemRestartClass

Send comments on this topic to Please email feedback to Support


TaskSystemRestartClass Constructor

TaskSystemRestartClass Constructor
Namespaces ► VisualCron ► TaskSystemRestartClass ► TaskSystemRestartClass()()()
Initializes a new instance of the TaskSystemRestartClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemRestartClass()
Public Sub New
public:
TaskSystemRestartClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemRestartClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemRestartClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemRestartClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSystemRestartClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskSystemRestartClass ► HostName
Gets or sets the address of the remote server
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskSystemRestartClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskSystemRestartClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


TaskSystemShutdownClass Class

TaskSystemShutdownClass Class
Namespaces ► VisualCron ► TaskSystemShutdownClass

[Missing <summary> documentation for T:VisualCron.TaskSystemShutdownClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemShutdownClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemShutdownClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemShutdownClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemShutdownClass()()() | Initializes a new instance of the TaskSystemShutdownClass class
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address of the remote server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskSystemShutdownClass

Send comments on this topic to Please email feedback to Support


TaskSystemShutdownClass Constructor

TaskSystemShutdownClass Constructor
Namespaces ► VisualCron ► TaskSystemShutdownClass ► TaskSystemShutdownClass()()()
Initializes a new instance of the TaskSystemShutdownClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemShutdownClass()
Public Sub New
public:
TaskSystemShutdownClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemShutdownClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemShutdownClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemShutdownClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSystemShutdownClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskSystemShutdownClass ► HostName
Gets or sets the address of the remote server
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskSystemShutdownClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskSystemShutdownClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


TaskSystemStandByClass Class

TaskSystemStandByClass Class
Namespaces ► VisualCron ► TaskSystemStandByClass

[Missing <summary> documentation for T:VisualCron.TaskSystemStandByClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemStandByClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemStandByClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemStandByClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemStandByClass()()() | Initializes a new instance of the TaskSystemStandByClass class
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Force |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HostName | Gets or sets the address of the remote server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WakeUp |
 | WakeUpAfterHours |
 | WakeUpAfterMinutes |
 | WakeUpAfterSeconds |
 | WakeUpAt |
 | WakeUpType |
Inheritance Hierarchy
Object
TaskSystemStandByClass

Send comments on this topic to Please email feedback to Support


TaskSystemStandByClass Constructor

TaskSystemStandByClass Constructor
Namespaces ► VisualCron ► TaskSystemStandByClass ► TaskSystemStandByClass()()()
Initializes a new instance of the TaskSystemStandByClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemStandByClass()
Public Sub New
public:
TaskSystemStandByClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemStandByClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemStandByClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemStandByClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Force Property

Force Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► Force

[Missing <summary> documentation for P:VisualCron.TaskSystemStandByClass.Force]

Declaration Syntax
C# Visual Basic Visual C++
public bool Force { get; set; }
Public Property Force As Boolean
public:
property bool Force {
    bool get ();
    void set (bool value);
}


HostName Property

HostName Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► HostName
Gets or sets the address of the remote server
Declaration Syntax
C# Visual Basic Visual C++
public string HostName { get; set; }
Public Property HostName As String
public:
property String^ HostName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Scope Field

Scope Field
Namespaces ► VisualCron ► TaskSystemStandByClass ► Scope

[Missing <summary> documentation for F:VisualCron.TaskSystemStandByClass.Scope]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.Scope Scope
Public Scope As EnumClass..::.Scope
public:
EnumClass..::.Scope Scope

Send comments on this topic to Please email feedback to Support


WakeUp Property

WakeUp Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► WakeUp

[Missing <summary> documentation for P:VisualCron.TaskSystemStandByClass.WakeUp]

Declaration Syntax
C# Visual Basic Visual C++
public bool WakeUp { get; set; }
Public Property WakeUp As Boolean
public:
property bool WakeUp {
    bool get ();
    void set (bool value);
}


WakeUpAfterHours Property

WakeUpAfterHours Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► WakeUpAfterHours

[Missing <summary> documentation for P:VisualCron.TaskSystemStandByClass.WakeUpAfterHours]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterHours { get; set; }
Public Property WakeUpAfterHours As Integer
public:
property int WakeUpAfterHours {
    int get ();
    void set (int value);
}


WakeUpAfterMinutes Property

WakeUpAfterMinutes Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► WakeUpAfterMinutes

[Missing <summary> documentation for P:VisualCron.TaskSystemStandByClass.WakeUpAfterMinutes]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterMinutes { get; set; }
Public Property WakeUpAfterMinutes As Integer
public:
property int WakeUpAfterMinutes {
    int get ();
    void set (int value);
}


WakeUpAfterSeconds Property

WakeUpAfterSeconds Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► WakeUpAfterSeconds

[Missing <summary> documentation for P:VisualCron.TaskSystemStandByClass.WakeUpAfterSeconds]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterSeconds { get; set; }
Public Property WakeUpAfterSeconds As Integer
public:
property int WakeUpAfterSeconds {
    int get ();
    void set (int value);
}


WakeUpAt Property

WakeUpAt Property
Namespaces ► VisualCron ► TaskSystemStandByClass ► WakeUpAt

[Missing <summary> documentation for P:VisualCron.TaskSystemStandByClass.WakeUpAt]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime WakeUpAt { get; set; }
Public Property WakeUpAt As DateTime
public:
property DateTime WakeUpAt {
    DateTime get ();
    void set (DateTime value);
}


WakeUpType Field

WakeUpType Field
Namespaces ► VisualCron ► TaskSystemStandByClass ► WakeUpType

[Missing <summary> documentation for F:VisualCron.TaskSystemStandByClass.WakeUpType]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.WakeUpT WakeUpType
Public WakeUpType As EnumClass..::.WakeUpT
public:
EnumClass..::.WakeUpT WakeUpType

Send comments on this topic to Please email feedback to Support


TaskSystemUnLockClass Class

TaskSystemUnLockClass Class
Namespaces ► VisualCron ► TaskSystemUnLockClass

[Missing <summary> documentation for T:VisualCron.TaskSystemUnLockClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemUnLockClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemUnLockClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemUnLockClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemUnLockClass()()() | Initializes a new instance of the TaskSystemUnLockClass class
 | Clone()()() |
 | Credential | Gets or sets the Id of the Credential
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LockAfter | Locks the workstation after successful login
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskSystemUnLockClass

Send comments on this topic to Please email feedback to Support


TaskSystemUnLockClass Constructor

TaskSystemUnLockClass Constructor
Namespaces ► VisualCron ► TaskSystemUnLockClass ► TaskSystemUnLockClass()()()
Initializes a new instance of the TaskSystemUnLockClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemUnLockClass()
Public Sub New
public:
TaskSystemUnLockClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemUnLockClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemUnLockClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemUnLockClass.Clone]


Credential Property

Credential Property
Namespaces ► VisualCron ► TaskSystemUnLockClass ► Credential
Gets or sets the Id of the Credential
Declaration Syntax
C# Visual Basic Visual C++
public string Credential { get; set; }
Public Property Credential As String
public:
property String^ Credential {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LockAfter Property

LockAfter Property
Namespaces ► VisualCron ► TaskSystemUnLockClass ► LockAfter
Locks the workstation after successful login
Declaration Syntax
C# Visual Basic Visual C++
public bool LockAfter { get; set; }
Public Property LockAfter As Boolean
public:
property bool LockAfter {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskSystemWakeUpClass Class

TaskSystemWakeUpClass Class
Namespaces ► VisualCron ► TaskSystemWakeUpClass

[Missing <summary> documentation for T:VisualCron.TaskSystemWakeUpClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemWakeUpClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemWakeUpClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemWakeUpClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemWakeUpClass()()() | Initializes a new instance of the TaskSystemWakeUpClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WakeUp |
 | WakeUpAfterHours |
 | WakeUpAfterMinutes |
 | WakeUpAfterSeconds |
 | WakeUpAt |
 | WakeUpType |
Inheritance Hierarchy
Object
TaskSystemWakeUpClass

Send comments on this topic to Please email feedback to Support


TaskSystemWakeUpClass Constructor

TaskSystemWakeUpClass Constructor
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► TaskSystemWakeUpClass()()()
Initializes a new instance of the TaskSystemWakeUpClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemWakeUpClass()
Public Sub New
public:
TaskSystemWakeUpClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemWakeUpClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemWakeUpClass.Clone]


WakeUp Property

WakeUp Property
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► WakeUp

[Missing <summary> documentation for P:VisualCron.TaskSystemWakeUpClass.WakeUp]

Declaration Syntax
C# Visual Basic Visual C++
public bool WakeUp { get; set; }
Public Property WakeUp As Boolean
public:
property bool WakeUp {
    bool get ();
    void set (bool value);
}


WakeUpAfterHours Property

WakeUpAfterHours Property
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► WakeUpAfterHours

[Missing <summary> documentation for P:VisualCron.TaskSystemWakeUpClass.WakeUpAfterHours]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterHours { get; set; }
Public Property WakeUpAfterHours As Integer
public:
property int WakeUpAfterHours {
    int get ();
    void set (int value);
}


WakeUpAfterMinutes Property

WakeUpAfterMinutes Property
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► WakeUpAfterMinutes

[Missing <summary> documentation for P:VisualCron.TaskSystemWakeUpClass.WakeUpAfterMinutes]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterMinutes { get; set; }
Public Property WakeUpAfterMinutes As Integer
public:
property int WakeUpAfterMinutes {
    int get ();
    void set (int value);
}


WakeUpAfterSeconds Property

WakeUpAfterSeconds Property
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► WakeUpAfterSeconds

[Missing <summary> documentation for P:VisualCron.TaskSystemWakeUpClass.WakeUpAfterSeconds]

Declaration Syntax
C# Visual Basic Visual C++
public int WakeUpAfterSeconds { get; set; }
Public Property WakeUpAfterSeconds As Integer
public:
property int WakeUpAfterSeconds {
    int get ();
    void set (int value);
}


WakeUpAt Property

WakeUpAt Property
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► WakeUpAt

[Missing <summary> documentation for P:VisualCron.TaskSystemWakeUpClass.WakeUpAt]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime WakeUpAt { get; set; }
Public Property WakeUpAt As DateTime
public:
property DateTime WakeUpAt {
    DateTime get ();
    void set (DateTime value);
}


WakeUpType Field

WakeUpType Field
Namespaces ► VisualCron ► TaskSystemWakeUpClass ► WakeUpType

[Missing <summary> documentation for F:VisualCron.TaskSystemWakeUpClass.WakeUpType]

Declaration Syntax
C# Visual Basic Visual C++
public EnumClass..::.WakeUpT WakeUpType
Public WakeUpType As EnumClass..::.WakeUpT
public:
EnumClass..::.WakeUpT WakeUpType

Send comments on this topic to Please email feedback to Support


TaskSystemWakeUpOnLanClass Class

TaskSystemWakeUpOnLanClass Class
Namespaces ► VisualCron ► TaskSystemWakeUpOnLanClass

[Missing <summary> documentation for T:VisualCron.TaskSystemWakeUpOnLanClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskSystemWakeUpOnLanClass : ICloneable
<SerializableAttribute> _
Public Class TaskSystemWakeUpOnLanClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskSystemWakeUpOnLanClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskSystemWakeUpOnLanClass()()() | Initializes a new instance of the TaskSystemWakeUpOnLanClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MAC |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskSystemWakeUpOnLanClass

Send comments on this topic to Please email feedback to Support


TaskSystemWakeUpOnLanClass Constructor

TaskSystemWakeUpOnLanClass Constructor
Namespaces ► VisualCron ► TaskSystemWakeUpOnLanClass ► TaskSystemWakeUpOnLanClass()()()
Initializes a new instance of the TaskSystemWakeUpOnLanClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskSystemWakeUpOnLanClass()
Public Sub New
public:
TaskSystemWakeUpOnLanClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskSystemWakeUpOnLanClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskSystemWakeUpOnLanClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskSystemWakeUpOnLanClass.Clone]


MAC Property

MAC Property
Namespaces ► VisualCron ► TaskSystemWakeUpOnLanClass ► MAC

[Missing <summary> documentation for P:VisualCron.TaskSystemWakeUpOnLanClass.MAC]

Declaration Syntax
C# Visual Basic Visual C++
public string MAC { get; set; }
Public Property MAC As String
public:
property String^ MAC {
    String^ get ();
    void set (String^ value);
}


TaskWaitClass Class

TaskWaitClass Class
Namespaces ► VisualCron ► TaskWaitClass
The Wait Task sleeps for a specified time
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskWaitClass : ICloneable
<SerializableAttribute> _
Public Class TaskWaitClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskWaitClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskWaitClass()()() | Initializes a new instance of the TaskWaitClass class
 | Clone()()() |
 | Days | Number of days to sleep
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hours | Number of hours to sleep
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MilliSeconds | Number of milliseconds to sleep
 | Minutes | Number of minutes to sleep
 | Seconds | Number of seconds to sleep
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TaskWaitClass

Send comments on this topic to Please email feedback to Support


TaskWaitClass Constructor

TaskWaitClass Constructor
Namespaces ► VisualCron ► TaskWaitClass ► TaskWaitClass()()()
Initializes a new instance of the TaskWaitClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskWaitClass()
Public Sub New
public:
TaskWaitClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskWaitClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskWaitClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskWaitClass.Clone]


Days Property

Days Property
Namespaces ► VisualCron ► TaskWaitClass ► Days
Number of days to sleep
Declaration Syntax
C# Visual Basic Visual C++
public int Days { get; set; }
Public Property Days As Integer
public:
property int Days {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Hours Property

Hours Property
Namespaces ► VisualCron ► TaskWaitClass ► Hours
Number of hours to sleep
Declaration Syntax
C# Visual Basic Visual C++
public int Hours { get; set; }
Public Property Hours As Integer
public:
property int Hours {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MilliSeconds Property

MilliSeconds Property
Namespaces ► VisualCron ► TaskWaitClass ► MilliSeconds
Number of milliseconds to sleep
Declaration Syntax
C# Visual Basic Visual C++
public int MilliSeconds { get; set; }
Public Property MilliSeconds As Integer
public:
property int MilliSeconds {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Minutes Property

Minutes Property
Namespaces ► VisualCron ► TaskWaitClass ► Minutes
Number of minutes to sleep
Declaration Syntax
C# Visual Basic Visual C++
public int Minutes { get; set; }
Public Property Minutes As Integer
public:
property int Minutes {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Seconds Property

Seconds Property
Namespaces ► VisualCron ► TaskWaitClass ► Seconds
Number of seconds to sleep
Declaration Syntax
C# Visual Basic Visual C++
public int Seconds { get; set; }
Public Property Seconds As Integer
public:
property int Seconds {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskVariableCalculateClass Class

TaskVariableCalculateClass Class
Namespaces ► VisualCron ► TaskVariableCalculateClass

[Missing <summary> documentation for T:VisualCron.TaskVariableCalculateClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskVariableCalculateClass : ICloneable
<SerializableAttribute> _
Public Class TaskVariableCalculateClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskVariableCalculateClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskVariableCalculateClass()()() | Initializes a new instance of the TaskVariableCalculateClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LeftHandChoice | Gets or sets if the left hand value should be a variable or other value
 | LeftHandName | Gets or sets the left hand name of the Variable
 | LeftHandObjectType | Gets or sets what kind of data type the custom left hand value is
 | LeftHandValue | Gets or sets the left hand value
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the Variable to store result in
 | OperationType | Gets or sets what type of operation to perform
 | RightHandChoice | Gets or sets if the right hand value should be a variable or other value
 | RightHandName | Gets or sets the right hand name of the Variable
 | RightHandObjectType | Gets or sets what kind of data type the custom right hand value is
 | RightHandValue | Gets or sets the right hand value
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskVariableCalculateClass

Send comments on this topic to Please email feedback to Support


TaskVariableCalculateClass Constructor

TaskVariableCalculateClass Constructor
Namespaces ► VisualCron ► TaskVariableCalculateClass ► TaskVariableCalculateClass()()()
Initializes a new instance of the TaskVariableCalculateClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableCalculateClass()
Public Sub New
public:
TaskVariableCalculateClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskVariableCalculateClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskVariableCalculateClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskVariableCalculateClass.Clone]


LeftHandChoice Property

LeftHandChoice Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► LeftHandChoice
Gets or sets if the left hand value should be a variable or other value
Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableCalculateClass..::.VariableChoiceT LeftHandChoice { get; set; }
Public Property LeftHandChoice As TaskVariableCalculateClass..::.VariableChoiceT
public:
property TaskVariableCalculateClass..::.VariableChoiceT LeftHandChoice {
    TaskVariableCalculateClass..::.VariableChoiceT get ();
    void set (TaskVariableCalculateClass..::.VariableChoiceT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LeftHandName Property

LeftHandName Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► LeftHandName
Gets or sets the left hand name of the Variable
Declaration Syntax
C# Visual Basic Visual C++
public string LeftHandName { get; set; }
Public Property LeftHandName As String
public:
property String^ LeftHandName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LeftHandObjectType Property

LeftHandObjectType Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► LeftHandObjectType
Gets or sets what kind of data type the custom left hand value is
Declaration Syntax
C# Visual Basic Visual C++
public TypeCode LeftHandObjectType { get; set; }
Public Property LeftHandObjectType As TypeCode
public:
property TypeCode LeftHandObjectType {
    TypeCode get ();
    void set (TypeCode value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LeftHandValue Property

LeftHandValue Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► LeftHandValue
Gets or sets the left hand value
Declaration Syntax
C# Visual Basic Visual C++
public string LeftHandValue { get; set; }
Public Property LeftHandValue As String
public:
property String^ LeftHandValue {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
When VariableChoiceT = CustomValue

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► Name
Gets or sets the name of the Variable to store result in
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


OperationType Property

OperationType Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► OperationType
Gets or sets what type of operation to perform
Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableCalculateClass..::.OperationT OperationType { get; set; }
Public Property OperationType As TaskVariableCalculateClass..::.OperationT
public:
property TaskVariableCalculateClass..::.OperationT OperationType {
    TaskVariableCalculateClass..::.OperationT get ();
    void set (TaskVariableCalculateClass..::.OperationT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RightHandChoice Property

RightHandChoice Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► RightHandChoice
Gets or sets if the right hand value should be a variable or other value
Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableCalculateClass..::.VariableChoiceT RightHandChoice { get; set; }
Public Property RightHandChoice As TaskVariableCalculateClass..::.VariableChoiceT
public:
property TaskVariableCalculateClass..::.VariableChoiceT RightHandChoice {
    TaskVariableCalculateClass..::.VariableChoiceT get ();
    void set (TaskVariableCalculateClass..::.VariableChoiceT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RightHandName Property

RightHandName Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► RightHandName
Gets or sets the right hand name of the Variable
Declaration Syntax
C# Visual Basic Visual C++
public string RightHandName { get; set; }
Public Property RightHandName As String
public:
property String^ RightHandName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RightHandObjectType Property

RightHandObjectType Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► RightHandObjectType
Gets or sets what kind of data type the custom right hand value is
Declaration Syntax
C# Visual Basic Visual C++
public TypeCode RightHandObjectType { get; set; }
Public Property RightHandObjectType As TypeCode
public:
property TypeCode RightHandObjectType {
    TypeCode get ();
    void set (TypeCode value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


RightHandValue Property

RightHandValue Property
Namespaces ► VisualCron ► TaskVariableCalculateClass ► RightHandValue
Gets or sets the right hand value
Declaration Syntax
C# Visual Basic Visual C++
public string RightHandValue { get; set; }
Public Property RightHandValue As String
public:
property String^ RightHandValue {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
When VariableChoiceT = CustomValue

Send comments on this topic to Please email feedback to Support


TaskVariableCalculateClass.OperationT Enumeration

TaskVariableCalculateClass..::.OperationT Enumeration
Namespaces ► VisualCron ► TaskVariableCalculateClass ► TaskVariableCalculateClass..::.OperationT
What type of operation
Declaration Syntax
C# Visual Basic Visual C++
public enum OperationT
Public Enumeration OperationT
public enum class OperationT
Members
Member | Description
Addition |
Subtraction |
Division |
Multiplication |
Remarks

Send comments on this topic to Please email feedback to Support


TaskVariableCalculateClass.VariableChoiceT Enumeration

TaskVariableCalculateClass..::.VariableChoiceT Enumeration
Namespaces ► VisualCron ► TaskVariableCalculateClass ► TaskVariableCalculateClass..::.VariableChoiceT

[Missing <summary> documentation for T:VisualCron.TaskVariableCalculateClass.VariableChoiceT]

Declaration Syntax
C# Visual Basic Visual C++
public enum VariableChoiceT
Public Enumeration VariableChoiceT
public enum class VariableChoiceT
Members
Member | Description
Variable |
CustomValue |


TaskVariableRemoveClass Class

TaskVariableRemoveClass Class
Namespaces ► VisualCron ► TaskVariableRemoveClass

[Missing <summary> documentation for T:VisualCron.TaskVariableRemoveClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskVariableRemoveClass : ICloneable
<SerializableAttribute> _
Public Class TaskVariableRemoveClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskVariableRemoveClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskVariableRemoveClass()()() | Initializes a new instance of the TaskVariableRemoveClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the name of the Variable to Remove
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TaskVariableRemoveClass

Send comments on this topic to Please email feedback to Support


TaskVariableRemoveClass Constructor

TaskVariableRemoveClass Constructor
Namespaces ► VisualCron ► TaskVariableRemoveClass ► TaskVariableRemoveClass()()()
Initializes a new instance of the TaskVariableRemoveClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableRemoveClass()
Public Sub New
public:
TaskVariableRemoveClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskVariableRemoveClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskVariableRemoveClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskVariableRemoveClass.Clone]


Name Property

Name Property
Namespaces ► VisualCron ► TaskVariableRemoveClass ► Name
Gets or sets the name of the Variable to Remove
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TaskVariableSetClass Class

TaskVariableSetClass Class
Namespaces ► VisualCron ► TaskVariableSetClass

[Missing <summary> documentation for T:VisualCron.TaskVariableSetClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TaskVariableSetClass : ICloneable
<SerializableAttribute> _
Public Class TaskVariableSetClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TaskVariableSetClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TaskVariableSetClass()()() | Initializes a new instance of the TaskVariableSetClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UserVariable |
Inheritance Hierarchy
Object
TaskVariableSetClass

Send comments on this topic to Please email feedback to Support


TaskVariableSetClass Constructor

TaskVariableSetClass Constructor
Namespaces ► VisualCron ► TaskVariableSetClass ► TaskVariableSetClass()()()
Initializes a new instance of the TaskVariableSetClass class
Declaration Syntax
C# Visual Basic Visual C++
public TaskVariableSetClass()
Public Sub New
public:
TaskVariableSetClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TaskVariableSetClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TaskVariableSetClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TaskVariableSetClass.Clone]


UserVariable Property

UserVariable Property
Namespaces ► VisualCron ► TaskVariableSetClass ► UserVariable

[Missing <summary> documentation for P:VisualCron.TaskVariableSetClass.UserVariable]

Declaration Syntax
C# Visual Basic Visual C++
public UserVariableClass UserVariable { get; set; }
Public Property UserVariable As UserVariableClass
public:
property UserVariableClass^ UserVariable {
    UserVariableClass^ get ();
    void set (UserVariableClass^ value);
}


TestEmailClass Class

TestEmailClass Class
Namespaces ► VisualCron ► TestEmailClass

[Missing <summary> documentation for T:VisualCron.TestEmailClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TestEmailClass
<SerializableAttribute> _
Public Class TestEmailClass
[SerializableAttribute]
public ref class TestEmailClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TestEmailClass()()() | Initializes a new instance of the TestEmailClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SMTPFromEmail |
 | SMTPFromName |
 | SMTPHost |
 | SMTPPassWord |
 | SMTPPort |
 | SMTPToEmail |
 | SMTPUseAuthentication |
 | SMTPUserName |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TestEmailClass

Send comments on this topic to Please email feedback to Support


TestEmailClass Constructor

TestEmailClass Constructor
Namespaces ► VisualCron ► TestEmailClass ► TestEmailClass()()()
Initializes a new instance of the TestEmailClass class
Declaration Syntax
C# Visual Basic Visual C++
public TestEmailClass()
Public Sub New
public:
TestEmailClass()


SMTPFromEmail Property

SMTPFromEmail Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPFromEmail

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPFromEmail]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPFromEmail { get; set; }
Public Property SMTPFromEmail As String
public:
property String^ SMTPFromEmail {
    String^ get ();
    void set (String^ value);
}


SMTPFromName Property

SMTPFromName Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPFromName

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPFromName]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPFromName { get; set; }
Public Property SMTPFromName As String
public:
property String^ SMTPFromName {
    String^ get ();
    void set (String^ value);
}


SMTPHost Property

SMTPHost Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPHost

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPHost]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPHost { get; set; }
Public Property SMTPHost As String
public:
property String^ SMTPHost {
    String^ get ();
    void set (String^ value);
}


SMTPPassWord Property

SMTPPassWord Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPPassWord

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPPassWord]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPPassWord { get; set; }
Public Property SMTPPassWord As String
public:
property String^ SMTPPassWord {
    String^ get ();
    void set (String^ value);
}


SMTPPort Property

SMTPPort Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPPort

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPPort]

Declaration Syntax
C# Visual Basic Visual C++
public int SMTPPort { get; set; }
Public Property SMTPPort As Integer
public:
property int SMTPPort {
    int get ();
    void set (int value);
}


SMTPToEmail Property

SMTPToEmail Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPToEmail

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPToEmail]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPToEmail { get; set; }
Public Property SMTPToEmail As String
public:
property String^ SMTPToEmail {
    String^ get ();
    void set (String^ value);
}


SMTPUseAuthentication Property

SMTPUseAuthentication Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPUseAuthentication

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPUseAuthentication]

Declaration Syntax
C# Visual Basic Visual C++
public bool SMTPUseAuthentication { get; set; }
Public Property SMTPUseAuthentication As Boolean
public:
property bool SMTPUseAuthentication {
    bool get ();
    void set (bool value);
}


SMTPUserName Property

SMTPUserName Property
Namespaces ► VisualCron ► TestEmailClass ► SMTPUserName

[Missing <summary> documentation for P:VisualCron.TestEmailClass.SMTPUserName]

Declaration Syntax
C# Visual Basic Visual C++
public string SMTPUserName { get; set; }
Public Property SMTPUserName As String
public:
property String^ SMTPUserName {
    String^ get ();
    void set (String^ value);
}


TimeChangedEventClass Class

TimeChangedEventClass Class
Namespaces ► VisualCron ► TimeChangedEventClass

[Missing <summary> documentation for T:VisualCron.TimeChangedEventClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeChangedEventClass : ICloneable
<SerializableAttribute> _
Public Class TimeChangedEventClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TimeChangedEventClass : ICloneable
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TimeChangedEventClass()()() | Initializes a new instance of the TimeChangedEventClass class
 | Clone()()() |
 | CloneType()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TimeChangedEventClass

Send comments on this topic to Please email feedback to Support


TimeChangedEventClass Constructor

TimeChangedEventClass Constructor
Namespaces ► VisualCron ► TimeChangedEventClass ► TimeChangedEventClass()()()
Initializes a new instance of the TimeChangedEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeChangedEventClass()
Public Sub New
public:
TimeChangedEventClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TimeChangedEventClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TimeChangedEventClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TimeChangedEventClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TimeChangedEventClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.TimeChangedEventClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public TimeChangedEventClass CloneType()
Public Function CloneType As TimeChangedEventClass
public:
TimeChangedEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TimeChangedEventClass.CloneType]


TimeChangedTriggerResultClass Class

TimeChangedTriggerResultClass Class
Namespaces ► VisualCron ► TimeChangedTriggerResultClass

[Missing <summary> documentation for T:VisualCron.TimeChangedTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeChangedTriggerResultClass
<SerializableAttribute> _
Public Class TimeChangedTriggerResultClass
[SerializableAttribute]
public ref class TimeChangedTriggerResultClass
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TimeChangedTriggerResultClass()()() | Initializes a new instance of the TimeChangedTriggerResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TimeChangedTriggerResultClass

Send comments on this topic to Please email feedback to Support


TimeChangedTriggerResultClass Constructor

TimeChangedTriggerResultClass Constructor
Namespaces ► VisualCron ► TimeChangedTriggerResultClass ► TimeChangedTriggerResultClass()()()
Initializes a new instance of the TimeChangedTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeChangedTriggerResultClass()
Public Sub New
public:
TimeChangedTriggerResultClass()


TimeClass Class

TimeClass Class
Namespaces ► VisualCron ► TimeClass

[Missing <summary> documentation for T:VisualCron.TimeClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeClass : ICloneable
<SerializableAttribute> _
Public Class TimeClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TimeClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeClass()()() | Initializes a new instance of the TimeClass class
 | TimeClass(TimeClass..::.TimeTriggerT) | Initializes a new instance of the TimeClass class
 | AllDays | Gets or sets if all days should be triggered
 | AllHours | Gets or sets if all hours should be triggered
 | AllMinutes | Gets or sets if all minutes should be triggered
 | AllMonths | Gets or sets if all months should be triggered
 | AllSeconds | Gets or sets if all seconds should be triggered
 | AllYears | Gets or sets if all years should be triggered
 | Clone()()() |
 | CloneType()()() |
 | DateNextExecution | Gets or sets the next execution of the Trigger
 | DayBetweenStart | Gets or sets what start day to used in combination with DayIsBetween set to true
 | DayBetweenStop | Gets or sets what stop day to used in combination with DayIsBetween set to true
 | Days | Gets or sets the array of days to use
 | DaysIsBetween | Gets or sets if a start and stop day is used. Use DayBetweenStart and DayBetweenStop
 | DayType | Gets or sets if the custom triggers should be based on days or weekdays. True if 1-31 (days)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FirstLastType | Gets or sets the FirstLastType
 | FirstLastWeekDay | Gets or sets what day of week to use when using FirstLastType
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HourBetweenStart | Gets or sets what start hour to used in combination with HourIsBetween set to true
 | HourBetweenStop | Gets or sets what stop hour to used in combination with HourIsBetween set to true
 | Hours | Gets or sets the array of hours to use
 | HoursIsBetween | Gets or sets if a start and stop hour is used. Use HourBetweenStart and HourBetweenStop
 | InitDate | Gets or sets the start date/time when using an Interval Time Trigger. Next executions will be calculated from this date.
 | IntervalDays | Gets or sets the array which specifies which days should be used (0-30)
 | IntervalType | Gets or sets the IntervalType when using the Interval type trigger
 | IntervalValue | Gets or sets the Interval Value - how often it should be run
 | IntervalWeekDays | Gets or sets the array which specifies which weekdays should be used (0-6)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinuteBetweenStart | Gets or sets what start minute to used in combination with MinuteIsBetween set to true
 | MinuteBetweenStop | Gets or sets what stop minute to used in combination with MinuteIsBetween set to true
 | Minutes | Gets or sets the array of minutes to use
 | MinutesIsBetween | Gets or sets if a start and stop minute is used. Use MinuteBetweenStart and MinuteBetweenStop
 | MonthBetweenStart | Gets or sets what start month to used in combination with MonthsIsBetween set to true
 | MonthBetweenStop | Gets or sets what stop month to used in combination with MonthsIsBetween set to true
 | Months | Gets or sets the array of months to use
 | MonthsIsBetween | Gets or sets if a start and stop month is used. Use MonthBetweenStart and MonthBetweenStop
 | SecondBetweenStart | Gets or sets what start second to used in combination with SecondIsBetween set to true
 | SecondBetweenStop | Gets or sets what stop second to used in combination with SecondIsBetween set to true
 | Seconds | Gets or sets the array of seconds to use
 | SecondsIsBetween | Gets or sets if a start and stop second is used. Use SecondBetweenStart and SecondBetweenStop
 | SpecificType | Gets or set the what specifc type to use
 | TimeTriggerType | Gets or sets what kind of Time Trigger type to use
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | YearBetweenStart | Gets or sets what start year to used in combination with YearIsBetween set to true
 | YearBetweenStop | Gets or sets what stop year to used in combination with YearIsBetween set to true
 | YearIsBetween | Gets or sets if a start and stop year is used. Use YearBetweenStart and YearBetweenStop
 | Years | Gets or sets the array of years to use.
Inheritance Hierarchy
Object
TimeClass

Send comments on this topic to Please email feedback to Support


TimeClass Constructor

TimeClass Constructor
Namespaces ► VisualCron ► TimeClass ► TimeClass()()()
Members
Icon | Member | Description
 | TimeClass()()() | Initializes a new instance of the TimeClass class
 | TimeClass(TimeClass..::.TimeTriggerT) | Initializes a new instance of the TimeClass class


TimeClass Constructor

TimeClass Constructor
Namespaces ► VisualCron ► TimeClass ► TimeClass()()()
Initializes a new instance of the TimeClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeClass()
Public Sub New
public:
TimeClass()


TimeClass Constructor (ttt)

TimeClass Constructor (ttt)
Namespaces ► VisualCron ► TimeClass ► TimeClass(TimeClass..::.TimeTriggerT)
Initializes a new instance of the TimeClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeClass(
    TimeClass..::.TimeTriggerT ttt
)
Public Sub New ( _
    ttt As TimeClass..::.TimeTriggerT _
)
public:
TimeClass(
    TimeClass..::.TimeTriggerT ttt
)
Parameters
ttt (TimeClass..::.TimeTriggerT)

[Missing <param name="ttt"/> documentation for "M:VisualCron.TimeClass.#ctor(VisualCron.TimeClass.TimeTriggerT)"]


AllDays Property

AllDays Property
Namespaces ► VisualCron ► TimeClass ► AllDays
Gets or sets if all days should be triggered
Declaration Syntax
C# Visual Basic Visual C++
public bool AllDays { get; set; }
Public Property AllDays As Boolean
public:
property bool AllDays {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AllHours Property

AllHours Property
Namespaces ► VisualCron ► TimeClass ► AllHours
Gets or sets if all hours should be triggered
Declaration Syntax
C# Visual Basic Visual C++
public bool AllHours { get; set; }
Public Property AllHours As Boolean
public:
property bool AllHours {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AllMinutes Property

AllMinutes Property
Namespaces ► VisualCron ► TimeClass ► AllMinutes
Gets or sets if all minutes should be triggered
Declaration Syntax
C# Visual Basic Visual C++
public bool AllMinutes { get; set; }
Public Property AllMinutes As Boolean
public:
property bool AllMinutes {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AllMonths Property

AllMonths Property
Namespaces ► VisualCron ► TimeClass ► AllMonths
Gets or sets if all months should be triggered
Declaration Syntax
C# Visual Basic Visual C++
public bool AllMonths { get; set; }
Public Property AllMonths As Boolean
public:
property bool AllMonths {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AllSeconds Property

AllSeconds Property
Namespaces ► VisualCron ► TimeClass ► AllSeconds
Gets or sets if all seconds should be triggered
Declaration Syntax
C# Visual Basic Visual C++
public bool AllSeconds { get; set; }
Public Property AllSeconds As Boolean
public:
property bool AllSeconds {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


AllYears Property

AllYears Property
Namespaces ► VisualCron ► TimeClass ► AllYears
Gets or sets if all years should be triggered
Declaration Syntax
C# Visual Basic Visual C++
public bool AllYears { get; set; }
Public Property AllYears As Boolean
public:
property bool AllYears {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TimeClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TimeClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TimeClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TimeClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.TimeClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public TimeClass CloneType()
Public Function CloneType As TimeClass
public:
TimeClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TimeClass.CloneType]


DateNextExecution Property

DateNextExecution Property
Namespaces ► VisualCron ► TimeClass ► DateNextExecution
Gets or sets the next execution of the Trigger
Declaration Syntax
C# Visual Basic Visual C++
public DateTime DateNextExecution { get; set; }
Public Property DateNextExecution As DateTime
public:
property DateTime DateNextExecution {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks
This property is set by VisualCron - do not set it by yourself.


DayBetweenStart Property

DayBetweenStart Property
Namespaces ► VisualCron ► TimeClass ► DayBetweenStart
Gets or sets what start day to used in combination with DayIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int DayBetweenStart { get; set; }
Public Property DayBetweenStart As Integer
public:
property int DayBetweenStart {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DayBetweenStop Property

DayBetweenStop Property
Namespaces ► VisualCron ► TimeClass ► DayBetweenStop
Gets or sets what stop day to used in combination with DayIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int DayBetweenStop { get; set; }
Public Property DayBetweenStop As Integer
public:
property int DayBetweenStop {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Days Property

Days Property
Namespaces ► VisualCron ► TimeClass ► Days
Gets or sets the array of days to use
Declaration Syntax
C# Visual Basic Visual C++
public bool[] Days { get; set; }
Public Property Days As Boolean()
public:
property array<bool>^ Days {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
Value
Return Value
Remarks
Use space 0 - 30.


DaysIsBetween Property

DaysIsBetween Property
Namespaces ► VisualCron ► TimeClass ► DaysIsBetween
Gets or sets if a start and stop day is used. Use DayBetweenStart and DayBetweenStop
Declaration Syntax
C# Visual Basic Visual C++
public bool DaysIsBetween { get; set; }
Public Property DaysIsBetween As Boolean
public:
property bool DaysIsBetween {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DayType Property

DayType Property
Namespaces ► VisualCron ► TimeClass ► DayType
Gets or sets if the custom triggers should be based on days or weekdays. True if 1-31 (days)
Declaration Syntax
C# Visual Basic Visual C++
public bool DayType { get; set; }
Public Property DayType As Boolean
public:
property bool DayType {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


FirstLastType Field

FirstLastType Field
Namespaces ► VisualCron ► TimeClass ► FirstLastType
Gets or sets the FirstLastType
Declaration Syntax
C# Visual Basic Visual C++
public TimeClass..::.FirstLastT FirstLastType
Public FirstLastType As TimeClass..::.FirstLastT
public:
TimeClass..::.FirstLastT FirstLastType
Remarks

Send comments on this topic to Please email feedback to Support


FirstLastWeekDay Field

FirstLastWeekDay Field
Namespaces ► VisualCron ► TimeClass ► FirstLastWeekDay
Gets or sets what day of week to use when using FirstLastType
Declaration Syntax
C# Visual Basic Visual C++
public DayOfWeek FirstLastWeekDay
Public FirstLastWeekDay As DayOfWeek
public:
DayOfWeek FirstLastWeekDay
Remarks

Send comments on this topic to Please email feedback to Support


HourBetweenStart Property

HourBetweenStart Property
Namespaces ► VisualCron ► TimeClass ► HourBetweenStart
Gets or sets what start hour to used in combination with HourIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int HourBetweenStart { get; set; }
Public Property HourBetweenStart As Integer
public:
property int HourBetweenStart {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HourBetweenStop Property

HourBetweenStop Property
Namespaces ► VisualCron ► TimeClass ► HourBetweenStop
Gets or sets what stop hour to used in combination with HourIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int HourBetweenStop { get; set; }
Public Property HourBetweenStop As Integer
public:
property int HourBetweenStop {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Hours Property

Hours Property
Namespaces ► VisualCron ► TimeClass ► Hours
Gets or sets the array of hours to use
Declaration Syntax
C# Visual Basic Visual C++
public bool[] Hours { get; set; }
Public Property Hours As Boolean()
public:
property array<bool>^ Hours {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
Value
Return Value
Remarks
Use space 0 - 23.


HoursIsBetween Property

HoursIsBetween Property
Namespaces ► VisualCron ► TimeClass ► HoursIsBetween
Gets or sets if a start and stop hour is used. Use HourBetweenStart and HourBetweenStop
Declaration Syntax
C# Visual Basic Visual C++
public bool HoursIsBetween { get; set; }
Public Property HoursIsBetween As Boolean
public:
property bool HoursIsBetween {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


InitDate Field

InitDate Field
Namespaces ► VisualCron ► TimeClass ► InitDate
Gets or sets the start date/time when using an Interval Time Trigger. Next executions will be calculated from this date.
Declaration Syntax
C# Visual Basic Visual C++
public DateTime InitDate
Public InitDate As DateTime
public:
DateTime InitDate
Remarks

Send comments on this topic to Please email feedback to Support


IntervalDays Property

IntervalDays Property
Namespaces ► VisualCron ► TimeClass ► IntervalDays
Gets or sets the array which specifies which days should be used (0-30)
Declaration Syntax
C# Visual Basic Visual C++
public bool[] IntervalDays { get; set; }
Public Property IntervalDays As Boolean()
public:
property array<bool>^ IntervalDays {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


IntervalType Field

IntervalType Field
Namespaces ► VisualCron ► TimeClass ► IntervalType
Gets or sets the IntervalType when using the Interval type trigger
Declaration Syntax
C# Visual Basic Visual C++
public TimeClass..::.IntervalT IntervalType
Public IntervalType As TimeClass..::.IntervalT
public:
TimeClass..::.IntervalT IntervalType
Remarks

Send comments on this topic to Please email feedback to Support


IntervalValue Field

IntervalValue Field
Namespaces ► VisualCron ► TimeClass ► IntervalValue
Gets or sets the Interval Value - how often it should be run
Declaration Syntax
C# Visual Basic Visual C++
public int IntervalValue
Public IntervalValue As Integer
public:
int IntervalValue
Remarks
Value 1 - every time, value 2 - every second time


IntervalWeekDays Property

IntervalWeekDays Property
Namespaces ► VisualCron ► TimeClass ► IntervalWeekDays
Gets or sets the array which specifies which weekdays should be used (0-6)
Declaration Syntax
C# Visual Basic Visual C++
public bool[] IntervalWeekDays { get; set; }
Public Property IntervalWeekDays As Boolean()
public:
property array<bool>^ IntervalWeekDays {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MinuteBetweenStart Property

MinuteBetweenStart Property
Namespaces ► VisualCron ► TimeClass ► MinuteBetweenStart
Gets or sets what start minute to used in combination with MinuteIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int MinuteBetweenStart { get; set; }
Public Property MinuteBetweenStart As Integer
public:
property int MinuteBetweenStart {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MinuteBetweenStop Property

MinuteBetweenStop Property
Namespaces ► VisualCron ► TimeClass ► MinuteBetweenStop
Gets or sets what stop minute to used in combination with MinuteIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int MinuteBetweenStop { get; set; }
Public Property MinuteBetweenStop As Integer
public:
property int MinuteBetweenStop {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Minutes Property

Minutes Property
Namespaces ► VisualCron ► TimeClass ► Minutes
Gets or sets the array of minutes to use
Declaration Syntax
C# Visual Basic Visual C++
public bool[] Minutes { get; set; }
Public Property Minutes As Boolean()
public:
property array<bool>^ Minutes {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
Value
Return Value
Remarks
Use space 0 - 59.


MinutesIsBetween Property

MinutesIsBetween Property
Namespaces ► VisualCron ► TimeClass ► MinutesIsBetween
Gets or sets if a start and stop minute is used. Use MinuteBetweenStart and MinuteBetweenStop
Declaration Syntax
C# Visual Basic Visual C++
public bool MinutesIsBetween { get; set; }
Public Property MinutesIsBetween As Boolean
public:
property bool MinutesIsBetween {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MonthBetweenStart Property

MonthBetweenStart Property
Namespaces ► VisualCron ► TimeClass ► MonthBetweenStart
Gets or sets what start month to used in combination with MonthsIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int MonthBetweenStart { get; set; }
Public Property MonthBetweenStart As Integer
public:
property int MonthBetweenStart {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


MonthBetweenStop Property

MonthBetweenStop Property
Namespaces ► VisualCron ► TimeClass ► MonthBetweenStop
Gets or sets what stop month to used in combination with MonthsIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int MonthBetweenStop { get; set; }
Public Property MonthBetweenStop As Integer
public:
property int MonthBetweenStop {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Months Property

Months Property
Namespaces ► VisualCron ► TimeClass ► Months
Gets or sets the array of months to use
Declaration Syntax
C# Visual Basic Visual C++
public bool[] Months { get; set; }
Public Property Months As Boolean()
public:
property array<bool>^ Months {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
Value
Return Value
Remarks
Use space 0 - 11.


MonthsIsBetween Property

MonthsIsBetween Property
Namespaces ► VisualCron ► TimeClass ► MonthsIsBetween
Gets or sets if a start and stop month is used. Use MonthBetweenStart and MonthBetweenStop
Declaration Syntax
C# Visual Basic Visual C++
public bool MonthsIsBetween { get; set; }
Public Property MonthsIsBetween As Boolean
public:
property bool MonthsIsBetween {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SecondBetweenStart Property

SecondBetweenStart Property
Namespaces ► VisualCron ► TimeClass ► SecondBetweenStart
Gets or sets what start second to used in combination with SecondIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int SecondBetweenStart { get; set; }
Public Property SecondBetweenStart As Integer
public:
property int SecondBetweenStart {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SecondBetweenStop Property

SecondBetweenStop Property
Namespaces ► VisualCron ► TimeClass ► SecondBetweenStop
Gets or sets what stop second to used in combination with SecondIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int SecondBetweenStop { get; set; }
Public Property SecondBetweenStop As Integer
public:
property int SecondBetweenStop {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Seconds Property

Seconds Property
Namespaces ► VisualCron ► TimeClass ► Seconds
Gets or sets the array of seconds to use
Declaration Syntax
C# Visual Basic Visual C++
public bool[] Seconds { get; set; }
Public Property Seconds As Boolean()
public:
property array<bool>^ Seconds {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
Value
Return Value
Remarks
Use space 0 - 59.


SecondsIsBetween Property

SecondsIsBetween Property
Namespaces ► VisualCron ► TimeClass ► SecondsIsBetween
Gets or sets if a start and stop second is used. Use SecondBetweenStart and SecondBetweenStop
Declaration Syntax
C# Visual Basic Visual C++
public bool SecondsIsBetween { get; set; }
Public Property SecondsIsBetween As Boolean
public:
property bool SecondsIsBetween {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SpecificType Field

SpecificType Field
Namespaces ► VisualCron ► TimeClass ► SpecificType
Gets or set the what specifc type to use
Declaration Syntax
C# Visual Basic Visual C++
public TimeClass..::.SpecificT SpecificType
Public SpecificType As TimeClass..::.SpecificT
public:
TimeClass..::.SpecificT SpecificType
Remarks

Send comments on this topic to Please email feedback to Support


TimeTriggerType Field

TimeTriggerType Field
Namespaces ► VisualCron ► TimeClass ► TimeTriggerType
Gets or sets what kind of Time Trigger type to use
Declaration Syntax
C# Visual Basic Visual C++
public TimeClass..::.TimeTriggerT TimeTriggerType
Public TimeTriggerType As TimeClass..::.TimeTriggerT
public:
TimeClass..::.TimeTriggerT TimeTriggerType
Remarks

Send comments on this topic to Please email feedback to Support


YearBetweenStart Property

YearBetweenStart Property
Namespaces ► VisualCron ► TimeClass ► YearBetweenStart
Gets or sets what start year to used in combination with YearIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int YearBetweenStart { get; set; }
Public Property YearBetweenStart As Integer
public:
property int YearBetweenStart {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


YearBetweenStop Property

YearBetweenStop Property
Namespaces ► VisualCron ► TimeClass ► YearBetweenStop
Gets or sets what stop year to used in combination with YearIsBetween set to true
Declaration Syntax
C# Visual Basic Visual C++
public int YearBetweenStop { get; set; }
Public Property YearBetweenStop As Integer
public:
property int YearBetweenStop {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


YearIsBetween Property

YearIsBetween Property
Namespaces ► VisualCron ► TimeClass ► YearIsBetween
Gets or sets if a start and stop year is used. Use YearBetweenStart and YearBetweenStop
Declaration Syntax
C# Visual Basic Visual C++
public bool YearIsBetween { get; set; }
Public Property YearIsBetween As Boolean
public:
property bool YearIsBetween {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Years Property

Years Property
Namespaces ► VisualCron ► TimeClass ► Years
Gets or sets the array of years to use.
Declaration Syntax
C# Visual Basic Visual C++
public int[] Years { get; set; }
Public Property Years As Integer()
public:
property array<int>^ Years {
    array<int>^ get ();
    void set (array<int>^ value);
}
Value
Return Value
Remarks
Use space 0 - 19.


TimeClass.FirstLastT Enumeration

TimeClass..::.FirstLastT Enumeration
Namespaces ► VisualCron ► TimeClass ► TimeClass..::.FirstLastT
Enum that describes specific settings concerning FirstLastWeekDay
Declaration Syntax
C# Visual Basic Visual C++
public enum FirstLastT
Public Enumeration FirstLastT
public enum class FirstLastT
Members
Member | Description
First |
Second |
Third |
Fourth |
Last |
Remarks

Send comments on this topic to Please email feedback to Support


TimeClass.IntervalT Enumeration

TimeClass..::.IntervalT Enumeration
Namespaces ► VisualCron ► TimeClass ► TimeClass..::.IntervalT
Enum that describes the Interval type
Declaration Syntax
C# Visual Basic Visual C++
public enum IntervalT
Public Enumeration IntervalT
public enum class IntervalT
Members
Member | Description
Daily |
Hourly |
Minutely |
Secondly |
SpecificDaysOfTheWeek |
SpecificDaysOfTheMonth |
Remarks

Send comments on this topic to Please email feedback to Support


TimeClass.SpecificT Enumeration

TimeClass..::.SpecificT Enumeration
Namespaces ► VisualCron ► TimeClass ► TimeClass..::.SpecificT
Enum that describes specific types of the SpecificDaysOfTheMonth setting
Declaration Syntax
C# Visual Basic Visual C++
public enum SpecificT
Public Enumeration SpecificT
public enum class SpecificT
Members
Member | Description
Days |
LastDayOfTheMonth |
LastWorkDayOfTheMonth |
FirstLastWeekDay |
Remarks

Send comments on this topic to Please email feedback to Support


TimeClass.TimeTriggerT Enumeration

TimeClass..::.TimeTriggerT Enumeration
Namespaces ► VisualCron ► TimeClass ► TimeClass..::.TimeTriggerT
Enum that describes the type of Time Trigger
Declaration Syntax
C# Visual Basic Visual C++
public enum TimeTriggerT
Public Enumeration TimeTriggerT
public enum class TimeTriggerT
Members
Member | Description
Custom |
Interval |
Remarks

Send comments on this topic to Please email feedback to Support


TimeExceptionClass Class

TimeExceptionClass Class
Namespaces ► VisualCron ► TimeExceptionClass
Time Exception - member of a Time Exception Collection
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeExceptionClass : ICloneable
<SerializableAttribute> _
Public Class TimeExceptionClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TimeExceptionClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeExceptionClass()()() | Initializes a new instance of the TimeExceptionClass class
 | AllDays |
 | AllHours |
 | AllMinutes |
 | AllMonths |
 | AllSeconds |
 | AllYears |
 | Clone()()() |
 | CollectionId | Id of the parent Time Exception Collection
 | DayBetweenStart |
 | DayBetweenStop |
 | Days |
 | DaysIsBetween |
 | DayType |
 | Description | Description of Time Exception
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HourBetweenStart |
 | HourBetweenStop |
 | Hours |
 | HoursIsBetween |
 | Id | Unique Id of the Time Exception (GUID)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MinuteBetweenStart |
 | MinuteBetweenStop |
 | Minutes |
 | MinutesIsBetween |
 | MonthBetweenStart |
 | MonthBetweenStop |
 | Months |
 | MonthsIsBetween |
 | Name | Name of Time Exception
 | SecondBetweenStart |
 | SecondBetweenStop |
 | Seconds |
 | SecondsIsBetween |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | YearBetweenStart |
 | YearBetweenStop |
 | YearIsBetween |
 | Years |
Remarks
Inheritance Hierarchy
Object
TimeExceptionClass

Send comments on this topic to Please email feedback to Support


TimeExceptionClass Constructor

TimeExceptionClass Constructor
Namespaces ► VisualCron ► TimeExceptionClass ► TimeExceptionClass()()()
Initializes a new instance of the TimeExceptionClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionClass()
Public Sub New
public:
TimeExceptionClass()


AllDays Property

AllDays Property
Namespaces ► VisualCron ► TimeExceptionClass ► AllDays

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.AllDays]

Declaration Syntax
C# Visual Basic Visual C++
public bool AllDays { get; set; }
Public Property AllDays As Boolean
public:
property bool AllDays {
    bool get ();
    void set (bool value);
}


AllHours Property

AllHours Property
Namespaces ► VisualCron ► TimeExceptionClass ► AllHours

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.AllHours]

Declaration Syntax
C# Visual Basic Visual C++
public bool AllHours { get; set; }
Public Property AllHours As Boolean
public:
property bool AllHours {
    bool get ();
    void set (bool value);
}


AllMinutes Property

AllMinutes Property
Namespaces ► VisualCron ► TimeExceptionClass ► AllMinutes

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.AllMinutes]

Declaration Syntax
C# Visual Basic Visual C++
public bool AllMinutes { get; set; }
Public Property AllMinutes As Boolean
public:
property bool AllMinutes {
    bool get ();
    void set (bool value);
}


AllMonths Property

AllMonths Property
Namespaces ► VisualCron ► TimeExceptionClass ► AllMonths

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.AllMonths]

Declaration Syntax
C# Visual Basic Visual C++
public bool AllMonths { get; set; }
Public Property AllMonths As Boolean
public:
property bool AllMonths {
    bool get ();
    void set (bool value);
}


AllSeconds Property

AllSeconds Property
Namespaces ► VisualCron ► TimeExceptionClass ► AllSeconds

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.AllSeconds]

Declaration Syntax
C# Visual Basic Visual C++
public bool AllSeconds { get; set; }
Public Property AllSeconds As Boolean
public:
property bool AllSeconds {
    bool get ();
    void set (bool value);
}


AllYears Property

AllYears Property
Namespaces ► VisualCron ► TimeExceptionClass ► AllYears

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.AllYears]

Declaration Syntax
C# Visual Basic Visual C++
public bool AllYears { get; set; }
Public Property AllYears As Boolean
public:
property bool AllYears {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► TimeExceptionClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TimeExceptionClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TimeExceptionClass.Clone]


CollectionId Property

CollectionId Property
Namespaces ► VisualCron ► TimeExceptionClass ► CollectionId
Id of the parent Time Exception Collection
Declaration Syntax
C# Visual Basic Visual C++
public string CollectionId { get; set; }
Public Property CollectionId As String
public:
property String^ CollectionId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


DayBetweenStart Property

DayBetweenStart Property
Namespaces ► VisualCron ► TimeExceptionClass ► DayBetweenStart

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.DayBetweenStart]

Declaration Syntax
C# Visual Basic Visual C++
public int DayBetweenStart { get; set; }
Public Property DayBetweenStart As Integer
public:
property int DayBetweenStart {
    int get ();
    void set (int value);
}


DayBetweenStop Property

DayBetweenStop Property
Namespaces ► VisualCron ► TimeExceptionClass ► DayBetweenStop

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.DayBetweenStop]

Declaration Syntax
C# Visual Basic Visual C++
public int DayBetweenStop { get; set; }
Public Property DayBetweenStop As Integer
public:
property int DayBetweenStop {
    int get ();
    void set (int value);
}


Days Property

Days Property
Namespaces ► VisualCron ► TimeExceptionClass ► Days

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.Days]

Declaration Syntax
C# Visual Basic Visual C++
public bool[] Days { get; set; }
Public Property Days As Boolean()
public:
property array<bool>^ Days {
    array<bool>^ get ();
    void set (array<bool>^ value);
}


DaysIsBetween Property

DaysIsBetween Property
Namespaces ► VisualCron ► TimeExceptionClass ► DaysIsBetween

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.DaysIsBetween]

Declaration Syntax
C# Visual Basic Visual C++
public bool DaysIsBetween { get; set; }
Public Property DaysIsBetween As Boolean
public:
property bool DaysIsBetween {
    bool get ();
    void set (bool value);
}


DayType Property

DayType Property
Namespaces ► VisualCron ► TimeExceptionClass ► DayType

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.DayType]

Declaration Syntax
C# Visual Basic Visual C++
public bool DayType { get; set; }
Public Property DayType As Boolean
public:
property bool DayType {
    bool get ();
    void set (bool value);
}


Description Property

Description Property
Namespaces ► VisualCron ► TimeExceptionClass ► Description
Description of Time Exception
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


HourBetweenStart Property

HourBetweenStart Property
Namespaces ► VisualCron ► TimeExceptionClass ► HourBetweenStart

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.HourBetweenStart]

Declaration Syntax
C# Visual Basic Visual C++
public int HourBetweenStart { get; set; }
Public Property HourBetweenStart As Integer
public:
property int HourBetweenStart {
    int get ();
    void set (int value);
}


HourBetweenStop Property

HourBetweenStop Property
Namespaces ► VisualCron ► TimeExceptionClass ► HourBetweenStop

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.HourBetweenStop]

Declaration Syntax
C# Visual Basic Visual C++
public int HourBetweenStop { get; set; }
Public Property HourBetweenStop As Integer
public:
property int HourBetweenStop {
    int get ();
    void set (int value);
}


Hours Property

Hours Property
Namespaces ► VisualCron ► TimeExceptionClass ► Hours

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.Hours]

Declaration Syntax
C# Visual Basic Visual C++
public bool[] Hours { get; set; }
Public Property Hours As Boolean()
public:
property array<bool>^ Hours {
    array<bool>^ get ();
    void set (array<bool>^ value);
}


HoursIsBetween Property

HoursIsBetween Property
Namespaces ► VisualCron ► TimeExceptionClass ► HoursIsBetween

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.HoursIsBetween]

Declaration Syntax
C# Visual Basic Visual C++
public bool HoursIsBetween { get; set; }
Public Property HoursIsBetween As Boolean
public:
property bool HoursIsBetween {
    bool get ();
    void set (bool value);
}


Id Property

Id Property
Namespaces ► VisualCron ► TimeExceptionClass ► Id
Unique Id of the Time Exception (GUID)
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks
Has to be added manually (may change in the future)


MinuteBetweenStart Property

MinuteBetweenStart Property
Namespaces ► VisualCron ► TimeExceptionClass ► MinuteBetweenStart

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.MinuteBetweenStart]

Declaration Syntax
C# Visual Basic Visual C++
public int MinuteBetweenStart { get; set; }
Public Property MinuteBetweenStart As Integer
public:
property int MinuteBetweenStart {
    int get ();
    void set (int value);
}


MinuteBetweenStop Property

MinuteBetweenStop Property
Namespaces ► VisualCron ► TimeExceptionClass ► MinuteBetweenStop

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.MinuteBetweenStop]

Declaration Syntax
C# Visual Basic Visual C++
public int MinuteBetweenStop { get; set; }
Public Property MinuteBetweenStop As Integer
public:
property int MinuteBetweenStop {
    int get ();
    void set (int value);
}


Minutes Property

Minutes Property
Namespaces ► VisualCron ► TimeExceptionClass ► Minutes

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.Minutes]

Declaration Syntax
C# Visual Basic Visual C++
public bool[] Minutes { get; set; }
Public Property Minutes As Boolean()
public:
property array<bool>^ Minutes {
    array<bool>^ get ();
    void set (array<bool>^ value);
}


MinutesIsBetween Property

MinutesIsBetween Property
Namespaces ► VisualCron ► TimeExceptionClass ► MinutesIsBetween

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.MinutesIsBetween]

Declaration Syntax
C# Visual Basic Visual C++
public bool MinutesIsBetween { get; set; }
Public Property MinutesIsBetween As Boolean
public:
property bool MinutesIsBetween {
    bool get ();
    void set (bool value);
}


MonthBetweenStart Property

MonthBetweenStart Property
Namespaces ► VisualCron ► TimeExceptionClass ► MonthBetweenStart

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.MonthBetweenStart]

Declaration Syntax
C# Visual Basic Visual C++
public int MonthBetweenStart { get; set; }
Public Property MonthBetweenStart As Integer
public:
property int MonthBetweenStart {
    int get ();
    void set (int value);
}


MonthBetweenStop Property

MonthBetweenStop Property
Namespaces ► VisualCron ► TimeExceptionClass ► MonthBetweenStop

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.MonthBetweenStop]

Declaration Syntax
C# Visual Basic Visual C++
public int MonthBetweenStop { get; set; }
Public Property MonthBetweenStop As Integer
public:
property int MonthBetweenStop {
    int get ();
    void set (int value);
}


Months Property

Months Property
Namespaces ► VisualCron ► TimeExceptionClass ► Months

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.Months]

Declaration Syntax
C# Visual Basic Visual C++
public bool[] Months { get; set; }
Public Property Months As Boolean()
public:
property array<bool>^ Months {
    array<bool>^ get ();
    void set (array<bool>^ value);
}


MonthsIsBetween Property

MonthsIsBetween Property
Namespaces ► VisualCron ► TimeExceptionClass ► MonthsIsBetween

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.MonthsIsBetween]

Declaration Syntax
C# Visual Basic Visual C++
public bool MonthsIsBetween { get; set; }
Public Property MonthsIsBetween As Boolean
public:
property bool MonthsIsBetween {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► VisualCron ► TimeExceptionClass ► Name
Name of Time Exception
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


SecondBetweenStart Property

SecondBetweenStart Property
Namespaces ► VisualCron ► TimeExceptionClass ► SecondBetweenStart

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.SecondBetweenStart]

Declaration Syntax
C# Visual Basic Visual C++
public int SecondBetweenStart { get; set; }
Public Property SecondBetweenStart As Integer
public:
property int SecondBetweenStart {
    int get ();
    void set (int value);
}


SecondBetweenStop Property

SecondBetweenStop Property
Namespaces ► VisualCron ► TimeExceptionClass ► SecondBetweenStop

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.SecondBetweenStop]

Declaration Syntax
C# Visual Basic Visual C++
public int SecondBetweenStop { get; set; }
Public Property SecondBetweenStop As Integer
public:
property int SecondBetweenStop {
    int get ();
    void set (int value);
}


Seconds Property

Seconds Property
Namespaces ► VisualCron ► TimeExceptionClass ► Seconds

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.Seconds]

Declaration Syntax
C# Visual Basic Visual C++
public bool[] Seconds { get; set; }
Public Property Seconds As Boolean()
public:
property array<bool>^ Seconds {
    array<bool>^ get ();
    void set (array<bool>^ value);
}


SecondsIsBetween Property

SecondsIsBetween Property
Namespaces ► VisualCron ► TimeExceptionClass ► SecondsIsBetween

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.SecondsIsBetween]

Declaration Syntax
C# Visual Basic Visual C++
public bool SecondsIsBetween { get; set; }
Public Property SecondsIsBetween As Boolean
public:
property bool SecondsIsBetween {
    bool get ();
    void set (bool value);
}


YearBetweenStart Property

YearBetweenStart Property
Namespaces ► VisualCron ► TimeExceptionClass ► YearBetweenStart

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.YearBetweenStart]

Declaration Syntax
C# Visual Basic Visual C++
public int YearBetweenStart { get; set; }
Public Property YearBetweenStart As Integer
public:
property int YearBetweenStart {
    int get ();
    void set (int value);
}


YearBetweenStop Property

YearBetweenStop Property
Namespaces ► VisualCron ► TimeExceptionClass ► YearBetweenStop

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.YearBetweenStop]

Declaration Syntax
C# Visual Basic Visual C++
public int YearBetweenStop { get; set; }
Public Property YearBetweenStop As Integer
public:
property int YearBetweenStop {
    int get ();
    void set (int value);
}


YearIsBetween Property

YearIsBetween Property
Namespaces ► VisualCron ► TimeExceptionClass ► YearIsBetween

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.YearIsBetween]

Declaration Syntax
C# Visual Basic Visual C++
public bool YearIsBetween { get; set; }
Public Property YearIsBetween As Boolean
public:
property bool YearIsBetween {
    bool get ();
    void set (bool value);
}


Years Property

Years Property
Namespaces ► VisualCron ► TimeExceptionClass ► Years

[Missing <summary> documentation for P:VisualCron.TimeExceptionClass.Years]

Declaration Syntax
C# Visual Basic Visual C++
public int[] Years { get; set; }
Public Property Years As Integer()
public:
property array<int>^ Years {
    array<int>^ get ();
    void set (array<int>^ value);
}


TimeExceptionCollectionClass Class

TimeExceptionCollectionClass Class
Namespaces ► VisualCron ► TimeExceptionCollectionClass
A collection of Time Exceptions
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeExceptionCollectionClass : ICloneable
<SerializableAttribute> _
Public Class TimeExceptionCollectionClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TimeExceptionCollectionClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeExceptionCollectionClass()()() | Initializes a new instance of the TimeExceptionCollectionClass class
 | Clone()()() |
 | Description | Description of the Collection
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Unique Id of the Collection
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Name of the Collection
 | TimeExceptions | List of Time Exceptions class
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TimeExceptionCollectionClass

Send comments on this topic to Please email feedback to Support


TimeExceptionCollectionClass Constructor

TimeExceptionCollectionClass Constructor
Namespaces ► VisualCron ► TimeExceptionCollectionClass ► TimeExceptionCollectionClass()()()
Initializes a new instance of the TimeExceptionCollectionClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionClass()
Public Sub New
public:
TimeExceptionCollectionClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TimeExceptionCollectionClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TimeExceptionCollectionClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TimeExceptionCollectionClass.Clone]


Description Property

Description Property
Namespaces ► VisualCron ► TimeExceptionCollectionClass ► Description
Description of the Collection
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► TimeExceptionCollectionClass ► Id
Unique Id of the Collection
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► TimeExceptionCollectionClass ► Name
Name of the Collection
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeExceptions Property

TimeExceptions Property
Namespaces ► VisualCron ► TimeExceptionCollectionClass ► TimeExceptions
List of Time Exceptions class
Declaration Syntax
C# Visual Basic Visual C++
public List<TimeExceptionClass> TimeExceptions { get; set; }
Public Property TimeExceptions As List(Of TimeExceptionClass)
public:
property List<TimeExceptionClass^>^ TimeExceptions {
    List<TimeExceptionClass^>^ get ();
    void set (List<TimeExceptionClass^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeExceptionCollectionDeleteClass Class

TimeExceptionCollectionDeleteClass Class
Namespaces ► VisualCron ► TimeExceptionCollectionDeleteClass

[Missing <summary> documentation for T:VisualCron.TimeExceptionCollectionDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeExceptionCollectionDeleteClass
<SerializableAttribute> _
Public Class TimeExceptionCollectionDeleteClass
[SerializableAttribute]
public ref class TimeExceptionCollectionDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeExceptionCollectionDeleteClass()()() | Initializes a new instance of the TimeExceptionCollectionDeleteClass class
 | Deleted | Indicates if the Time Exception collection was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Time Exception Collecton that should be deleted
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TimeExceptionCollectionDeleteClass

Send comments on this topic to Please email feedback to Support


TimeExceptionCollectionDeleteClass Constructor

TimeExceptionCollectionDeleteClass Constructor
Namespaces ► VisualCron ► TimeExceptionCollectionDeleteClass ► TimeExceptionCollectionDeleteClass()()()
Initializes a new instance of the TimeExceptionCollectionDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionDeleteClass()
Public Sub New
public:
TimeExceptionCollectionDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► TimeExceptionCollectionDeleteClass ► Deleted
Indicates if the Time Exception collection was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► TimeExceptionCollectionDeleteClass ► Id
Gets or sets the Id of the Time Exception Collecton that should be deleted
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeExceptionDeleteClass Class

TimeExceptionDeleteClass Class
Namespaces ► VisualCron ► TimeExceptionDeleteClass

[Missing <summary> documentation for T:VisualCron.TimeExceptionDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeExceptionDeleteClass
<SerializableAttribute> _
Public Class TimeExceptionDeleteClass
[SerializableAttribute]
public ref class TimeExceptionDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeExceptionDeleteClass()()() | Initializes a new instance of the TimeExceptionDeleteClass class
 | CollectionId | Gets or sets the Id of the Time Exception Collection that should be deleted
 | Deleted | Indicates if the Time Exception was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the Time Exception that should be deleted
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TimeExceptionDeleteClass

Send comments on this topic to Please email feedback to Support


TimeExceptionDeleteClass Constructor

TimeExceptionDeleteClass Constructor
Namespaces ► VisualCron ► TimeExceptionDeleteClass ► TimeExceptionDeleteClass()()()
Initializes a new instance of the TimeExceptionDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionDeleteClass()
Public Sub New
public:
TimeExceptionDeleteClass()


CollectionId Property

CollectionId Property
Namespaces ► VisualCron ► TimeExceptionDeleteClass ► CollectionId
Gets or sets the Id of the Time Exception Collection that should be deleted
Declaration Syntax
C# Visual Basic Visual C++
public string CollectionId { get; set; }
Public Property CollectionId As String
public:
property String^ CollectionId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Deleted Property

Deleted Property
Namespaces ► VisualCron ► TimeExceptionDeleteClass ► Deleted
Indicates if the Time Exception was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► TimeExceptionDeleteClass ► Id
Gets or sets the Id of the Time Exception that should be deleted
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeOutClass Class

TimeOutClass Class
Namespaces ► VisualCron ► TimeOutClass

[Missing <summary> documentation for T:VisualCron.TimeOutClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TimeOutClass
<SerializableAttribute> _
Public Class TimeOutClass
[SerializableAttribute]
public ref class TimeOutClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeOutClass()()() | Initializes a new instance of the TimeOutClass class
 | CloneType()()() |
 | ConsiderError |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Hours |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Minutes |
 | Seconds |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Use |
Inheritance Hierarchy
Object
TimeOutClass

Send comments on this topic to Please email feedback to Support


TimeOutClass Constructor

TimeOutClass Constructor
Namespaces ► VisualCron ► TimeOutClass ► TimeOutClass()()()
Initializes a new instance of the TimeOutClass class
Declaration Syntax
C# Visual Basic Visual C++
public TimeOutClass()
Public Sub New
public:
TimeOutClass()


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TimeOutClass ► CloneType()()()

[Missing <summary> documentation for M:VisualCron.TimeOutClass.CloneType]

Declaration Syntax
C# Visual Basic Visual C++
public TimeOutClass CloneType()
Public Function CloneType As TimeOutClass
public:
TimeOutClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TimeOutClass.CloneType]


ConsiderError Property

ConsiderError Property
Namespaces ► VisualCron ► TimeOutClass ► ConsiderError

[Missing <summary> documentation for P:VisualCron.TimeOutClass.ConsiderError]

Declaration Syntax
C# Visual Basic Visual C++
public bool ConsiderError { get; set; }
Public Property ConsiderError As Boolean
public:
property bool ConsiderError {
    bool get ();
    void set (bool value);
}


Hours Property

Hours Property
Namespaces ► VisualCron ► TimeOutClass ► Hours

[Missing <summary> documentation for P:VisualCron.TimeOutClass.Hours]

Declaration Syntax
C# Visual Basic Visual C++
public int Hours { get; set; }
Public Property Hours As Integer
public:
property int Hours {
    int get ();
    void set (int value);
}


Minutes Property

Minutes Property
Namespaces ► VisualCron ► TimeOutClass ► Minutes

[Missing <summary> documentation for P:VisualCron.TimeOutClass.Minutes]

Declaration Syntax
C# Visual Basic Visual C++
public int Minutes { get; set; }
Public Property Minutes As Integer
public:
property int Minutes {
    int get ();
    void set (int value);
}


Seconds Property

Seconds Property
Namespaces ► VisualCron ► TimeOutClass ► Seconds

[Missing <summary> documentation for P:VisualCron.TimeOutClass.Seconds]

Declaration Syntax
C# Visual Basic Visual C++
public int Seconds { get; set; }
Public Property Seconds As Integer
public:
property int Seconds {
    int get ();
    void set (int value);
}


Use Property

Use Property
Namespaces ► VisualCron ► TimeOutClass ► Use

[Missing <summary> documentation for P:VisualCron.TimeOutClass.Use]

Declaration Syntax
C# Visual Basic Visual C++
public bool Use { get; set; }
Public Property Use As Boolean
public:
property bool Use {
    bool get ();
    void set (bool value);
}


TrayClientSettingsClass Class

TrayClientSettingsClass Class
Namespaces ► VisualCron ► TrayClientSettingsClass
Settings for Tray Client
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TrayClientSettingsClass : ICloneable
<SerializableAttribute> _
Public Class TrayClientSettingsClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TrayClientSettingsClass : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TrayClientSettingsClass()()() | Initializes a new instance of the TrayClientSettingsClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogToFile | Gets or sets if the client should log to file
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ShowJobStartNotification |
 | ShowJobStopNotification |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
TrayClientSettingsClass

Send comments on this topic to Please email feedback to Support


TrayClientSettingsClass Constructor

TrayClientSettingsClass Constructor
Namespaces ► VisualCron ► TrayClientSettingsClass ► TrayClientSettingsClass()()()
Initializes a new instance of the TrayClientSettingsClass class
Declaration Syntax
C# Visual Basic Visual C++
public TrayClientSettingsClass()
Public Sub New
public:
TrayClientSettingsClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TrayClientSettingsClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TrayClientSettingsClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TrayClientSettingsClass.Clone]


LogToFile Property

LogToFile Property
Namespaces ► VisualCron ► TrayClientSettingsClass ► LogToFile
Gets or sets if the client should log to file
Declaration Syntax
C# Visual Basic Visual C++
public bool LogToFile { get; set; }
Public Property LogToFile As Boolean
public:
property bool LogToFile {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ShowJobStartNotification Property

ShowJobStartNotification Property
Namespaces ► VisualCron ► TrayClientSettingsClass ► ShowJobStartNotification

[Missing <summary> documentation for P:VisualCron.TrayClientSettingsClass.ShowJobStartNotification]

Declaration Syntax
C# Visual Basic Visual C++
public bool ShowJobStartNotification { get; set; }
Public Property ShowJobStartNotification As Boolean
public:
property bool ShowJobStartNotification {
    bool get ();
    void set (bool value);
}


ShowJobStopNotification Property

ShowJobStopNotification Property
Namespaces ► VisualCron ► TrayClientSettingsClass ► ShowJobStopNotification

[Missing <summary> documentation for P:VisualCron.TrayClientSettingsClass.ShowJobStopNotification]

Declaration Syntax
C# Visual Basic Visual C++
public bool ShowJobStopNotification { get; set; }
Public Property ShowJobStopNotification As Boolean
public:
property bool ShowJobStopNotification {
    bool get ();
    void set (bool value);
}


TrayPopupInfoClass Class

TrayPopupInfoClass Class
Namespaces ► VisualCron ► TrayPopupInfoClass

[Missing <summary> documentation for T:VisualCron.TrayPopupInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TrayPopupInfoClass
<SerializableAttribute> _
Public Class TrayPopupInfoClass
[SerializableAttribute]
public ref class TrayPopupInfoClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TrayPopupInfoClass()()() | Initializes a new instance of the TrayPopupInfoClass class
 | Caption |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FirstCall |
 | FooterText |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImageType |
 | Key |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PinButtonVisisble |
 | Pinned |
 | Text |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TrayPopupInfoClass

Send comments on this topic to Please email feedback to Support


TrayPopupInfoClass Constructor

TrayPopupInfoClass Constructor
Namespaces ► VisualCron ► TrayPopupInfoClass ► TrayPopupInfoClass()()()
Initializes a new instance of the TrayPopupInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public TrayPopupInfoClass()
Public Sub New
public:
TrayPopupInfoClass()


Caption Property

Caption Property
Namespaces ► VisualCron ► TrayPopupInfoClass ► Caption

[Missing <summary> documentation for P:VisualCron.TrayPopupInfoClass.Caption]

Declaration Syntax
C# Visual Basic Visual C++
public string Caption { get; set; }
Public Property Caption As String
public:
property String^ Caption {
    String^ get ();
    void set (String^ value);
}


FirstCall Field

FirstCall Field
Namespaces ► VisualCron ► TrayPopupInfoClass ► FirstCall

[Missing <summary> documentation for F:VisualCron.TrayPopupInfoClass.FirstCall]

Declaration Syntax
C# Visual Basic Visual C++
[NonSerializedAttribute]
public bool FirstCall
<NonSerializedAttribute> _
Public FirstCall As Boolean
[NonSerializedAttribute]
public:
bool FirstCall


FooterText Property

FooterText Property
Namespaces ► VisualCron ► TrayPopupInfoClass ► FooterText

[Missing <summary> documentation for P:VisualCron.TrayPopupInfoClass.FooterText]

Declaration Syntax
C# Visual Basic Visual C++
public string FooterText { get; set; }
Public Property FooterText As String
public:
property String^ FooterText {
    String^ get ();
    void set (String^ value);
}


ImageType Field

ImageType Field
Namespaces ► VisualCron ► TrayPopupInfoClass ► ImageType

[Missing <summary> documentation for F:VisualCron.TrayPopupInfoClass.ImageType]

Declaration Syntax
C# Visual Basic Visual C++
public TrayPopupInfoClass..::.ImageT ImageType
Public ImageType As TrayPopupInfoClass..::.ImageT
public:
TrayPopupInfoClass..::.ImageT ImageType

Send comments on this topic to Please email feedback to Support


Key Property

Key Property
Namespaces ► VisualCron ► TrayPopupInfoClass ► Key

[Missing <summary> documentation for P:VisualCron.TrayPopupInfoClass.Key]

Declaration Syntax
C# Visual Basic Visual C++
public string Key { get; set; }
Public Property Key As String
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}


PinButtonVisisble Property

PinButtonVisisble Property
Namespaces ► VisualCron ► TrayPopupInfoClass ► PinButtonVisisble

[Missing <summary> documentation for P:VisualCron.TrayPopupInfoClass.PinButtonVisisble]

Declaration Syntax
C# Visual Basic Visual C++
public bool PinButtonVisisble { get; set; }
Public Property PinButtonVisisble As Boolean
public:
property bool PinButtonVisisble {
    bool get ();
    void set (bool value);
}


Pinned Property

Pinned Property
Namespaces ► VisualCron ► TrayPopupInfoClass ► Pinned

[Missing <summary> documentation for P:VisualCron.TrayPopupInfoClass.Pinned]

Declaration Syntax
C# Visual Basic Visual C++
public bool Pinned { get; set; }
Public Property Pinned As Boolean
public:
property bool Pinned {
    bool get ();
    void set (bool value);
}


Text Property

Text Property
Namespaces ► VisualCron ► TrayPopupInfoClass ► Text

[Missing <summary> documentation for P:VisualCron.TrayPopupInfoClass.Text]

Declaration Syntax
C# Visual Basic Visual C++
public string Text { get; set; }
Public Property Text As String
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}


TrayPopupInfoClass.ImageT Enumeration

TrayPopupInfoClass..::.ImageT Enumeration
Namespaces ► VisualCron ► TrayPopupInfoClass ► TrayPopupInfoClass..::.ImageT

[Missing <summary> documentation for T:VisualCron.TrayPopupInfoClass.ImageT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ImageT
Public Enumeration ImageT
public enum class ImageT
Members
Member | Description
AlertImage |
InfoImage |
NoImage |


TrialExtensionClass Class

TrialExtensionClass Class
Namespaces ► VisualCron ► TrialExtensionClass

[Missing <summary> documentation for T:VisualCron.TrialExtensionClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TrialExtensionClass
<SerializableAttribute> _
Public Class TrialExtensionClass
[SerializableAttribute]
public ref class TrialExtensionClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TrialExtensionClass()()() | Initializes a new instance of the TrialExtensionClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrialEndTime |
Inheritance Hierarchy
Object
TrialExtensionClass

Send comments on this topic to Please email feedback to Support


TrialExtensionClass Constructor

TrialExtensionClass Constructor
Namespaces ► VisualCron ► TrialExtensionClass ► TrialExtensionClass()()()
Initializes a new instance of the TrialExtensionClass class
Declaration Syntax
C# Visual Basic Visual C++
public TrialExtensionClass()
Public Sub New
public:
TrialExtensionClass()


TrialEndTime Field

TrialEndTime Field
Namespaces ► VisualCron ► TrialExtensionClass ► TrialEndTime

[Missing <summary> documentation for F:VisualCron.TrialExtensionClass.TrialEndTime]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime TrialEndTime
Public TrialEndTime As DateTime
public:
DateTime TrialEndTime

Send comments on this topic to Please email feedback to Support


TriggerClass Class

TriggerClass Class
Namespaces ► VisualCron ► TriggerClass

[Missing <summary> documentation for T:VisualCron.TriggerClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TriggerClass : ICloneable
<SerializableAttribute> _
Public Class TriggerClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TriggerClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TriggerClass()()() | Initializes a new instance of the TriggerClass class
 | Active | Gets or sets if a Trigger is Active (can be triggered) or not
 | Clone()()() |
 | CloneType()()() | Clones a Trigger
 | Description | Gets or sets the Description of a Trigger
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpirationDate | Gets or sets what date the Trigger should expire
 | ExpirationEnabled | Gets or sets if Trigger can Expire
 | ExpireActionType |
 | ExpireType |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FirstRun | Not used
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets unique Id of Trigger
 | JobId | Gets or sets the Id of the parent Job
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result | Gets or sets the result of the last trigger
 | TEvent | Gets or sets the object containing all settings for an Event Trigger
 | TimeOutHours | Gets or sets number of hours before timeout
 | TimeOutMinutes | Gets or sets number of minutes before timeout
 | TimeOutSeconds | Gets or sets number of seconds before timeout
 | TimeOutTime | Gets or sets a specific date and time when the tTrigger should time out
 | TimesUntilExpire | Gets or sets number of times before an expiration
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerType | Gets or sets what kind of type the Trigger is
 | TTime | Gets or sets the object containing all settings for a Time Trigger
 | UseTimeOut | Gets or sets if the trigger can time out
Inheritance Hierarchy
Object
TriggerClass

Send comments on this topic to Please email feedback to Support


TriggerClass Constructor

TriggerClass Constructor
Namespaces ► VisualCron ► TriggerClass ► TriggerClass()()()
Initializes a new instance of the TriggerClass class
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass()
Public Sub New
public:
TriggerClass()


Active Property

Active Property
Namespaces ► VisualCron ► TriggerClass ► Active
Gets or sets if a Trigger is Active (can be triggered) or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
property bool Active {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Clone Method

Clone Method
Namespaces ► VisualCron ► TriggerClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TriggerClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TriggerClass.Clone]


CloneType Method

CloneType Method
Namespaces ► VisualCron ► TriggerClass ► CloneType()()()
Clones a Trigger
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass CloneType()
Public Function CloneType As TriggerClass
public:
TriggerClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.TriggerClass.CloneType]

Remarks

Send comments on this topic to Please email feedback to Support


Description Property

Description Property
Namespaces ► VisualCron ► TriggerClass ► Description
Gets or sets the Description of a Trigger
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExpirationDate Property

ExpirationDate Property
Namespaces ► VisualCron ► TriggerClass ► ExpirationDate
Gets or sets what date the Trigger should expire
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExpirationEnabled Property

ExpirationEnabled Property
Namespaces ► VisualCron ► TriggerClass ► ExpirationEnabled
Gets or sets if Trigger can Expire
Declaration Syntax
C# Visual Basic Visual C++
public bool ExpirationEnabled { get; set; }
Public Property ExpirationEnabled As Boolean
public:
property bool ExpirationEnabled {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ExpireActionType Field

ExpireActionType Field
Namespaces ► VisualCron ► TriggerClass ► ExpireActionType

[Missing <summary> documentation for F:VisualCron.TriggerClass.ExpireActionType]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass..::.ExpireActionT ExpireActionType
Public ExpireActionType As TriggerClass..::.ExpireActionT
public:
TriggerClass..::.ExpireActionT ExpireActionType


ExpireType Field

ExpireType Field
Namespaces ► VisualCron ► TriggerClass ► ExpireType

[Missing <summary> documentation for F:VisualCron.TriggerClass.ExpireType]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass..::.ExpireT ExpireType
Public ExpireType As TriggerClass..::.ExpireT
public:
TriggerClass..::.ExpireT ExpireType

Send comments on this topic to Please email feedback to Support


FirstRun Property

FirstRun Property
Namespaces ► VisualCron ► TriggerClass ► FirstRun
Not used
Declaration Syntax
C# Visual Basic Visual C++
public DateTime FirstRun { get; set; }
Public Property FirstRun As DateTime
public:
property DateTime FirstRun {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► TriggerClass ► Id
Gets or sets unique Id of Trigger
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


JobId Property

JobId Property
Namespaces ► VisualCron ► TriggerClass ► JobId
Gets or sets the Id of the parent Job
Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Result Field

Result Field
Namespaces ► VisualCron ► TriggerClass ► Result
Gets or sets the result of the last trigger
Declaration Syntax
C# Visual Basic Visual C++
public TriggerResultClass Result
Public Result As TriggerResultClass
public:
TriggerResultClass^ Result
Remarks

Send comments on this topic to Please email feedback to Support


TEvent Field

TEvent Field
Namespaces ► VisualCron ► TriggerClass ► TEvent
Gets or sets the object containing all settings for an Event Trigger
Declaration Syntax
C# Visual Basic Visual C++
public EventClass TEvent
Public TEvent As EventClass
public:
EventClass^ TEvent
Remarks

Send comments on this topic to Please email feedback to Support


TimeOutHours Property

TimeOutHours Property
Namespaces ► VisualCron ► TriggerClass ► TimeOutHours
Gets or sets number of hours before timeout
Declaration Syntax
C# Visual Basic Visual C++
public int TimeOutHours { get; set; }
Public Property TimeOutHours As Integer
public:
property int TimeOutHours {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeOutMinutes Property

TimeOutMinutes Property
Namespaces ► VisualCron ► TriggerClass ► TimeOutMinutes
Gets or sets number of minutes before timeout
Declaration Syntax
C# Visual Basic Visual C++
public int TimeOutMinutes { get; set; }
Public Property TimeOutMinutes As Integer
public:
property int TimeOutMinutes {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeOutSeconds Property

TimeOutSeconds Property
Namespaces ► VisualCron ► TriggerClass ► TimeOutSeconds
Gets or sets number of seconds before timeout
Declaration Syntax
C# Visual Basic Visual C++
public int TimeOutSeconds { get; set; }
Public Property TimeOutSeconds As Integer
public:
property int TimeOutSeconds {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimeOutTime Property

TimeOutTime Property
Namespaces ► VisualCron ► TriggerClass ► TimeOutTime
Gets or sets a specific date and time when the tTrigger should time out
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TimeOutTime { get; set; }
Public Property TimeOutTime As DateTime
public:
property DateTime TimeOutTime {
    DateTime get ();
    void set (DateTime value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TimesUntilExpire Property

TimesUntilExpire Property
Namespaces ► VisualCron ► TriggerClass ► TimesUntilExpire
Gets or sets number of times before an expiration
Declaration Syntax
C# Visual Basic Visual C++
public int TimesUntilExpire { get; set; }
Public Property TimesUntilExpire As Integer
public:
property int TimesUntilExpire {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TriggerType Field

TriggerType Field
Namespaces ► VisualCron ► TriggerClass ► TriggerType
Gets or sets what kind of type the Trigger is
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass..::.TriggerT TriggerType
Public TriggerType As TriggerClass..::.TriggerT
public:
TriggerClass..::.TriggerT TriggerType
Remarks

Send comments on this topic to Please email feedback to Support


TTime Field

TTime Field
Namespaces ► VisualCron ► TriggerClass ► TTime
Gets or sets the object containing all settings for a Time Trigger
Declaration Syntax
C# Visual Basic Visual C++
public TimeClass TTime
Public TTime As TimeClass
public:
TimeClass^ TTime
Remarks

Send comments on this topic to Please email feedback to Support


UseTimeOut Property

UseTimeOut Property
Namespaces ► VisualCron ► TriggerClass ► UseTimeOut
Gets or sets if the trigger can time out
Declaration Syntax
C# Visual Basic Visual C++
public bool UseTimeOut { get; set; }
Public Property UseTimeOut As Boolean
public:
property bool UseTimeOut {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


TriggerClass.ExpireActionT Enumeration

TriggerClass..::.ExpireActionT Enumeration
Namespaces ► VisualCron ► TriggerClass ► TriggerClass..::.ExpireActionT
Enum that describes different behaviors when a Trigger has expired
Declaration Syntax
C# Visual Basic Visual C++
public enum ExpireActionT
Public Enumeration ExpireActionT
public enum class ExpireActionT
Members
Member | Description
Inactivate |
Delete |
Remarks

Send comments on this topic to Please email feedback to Support


TriggerClass.ExpireT Enumeration

TriggerClass..::.ExpireT Enumeration
Namespaces ► VisualCron ► TriggerClass ► TriggerClass..::.ExpireT
Enum that describes the causes that could affect an expiration of a Trigger
Declaration Syntax
C# Visual Basic Visual C++
public enum ExpireT
Public Enumeration ExpireT
public enum class ExpireT
Members
Member | Description
Times |
DateTime |
Remarks

Send comments on this topic to Please email feedback to Support


TriggerClass.TimeOutActionT Enumeration

TriggerClass..::.TimeOutActionT Enumeration
Namespaces ► VisualCron ► TriggerClass ► TriggerClass..::.TimeOutActionT
Enum that describes different behaviors when a TimeOut has happened
Declaration Syntax
C# Visual Basic Visual C++
public enum TimeOutActionT
Public Enumeration TimeOutActionT
public enum class TimeOutActionT
Members
Member | Description
FireTrigger |
ResetCounter |
Remarks

Send comments on this topic to Please email feedback to Support


TriggerClass.TriggerT Enumeration

TriggerClass..::.TriggerT Enumeration
Namespaces ► VisualCron ► TriggerClass ► TriggerClass..::.TriggerT
Enum that describes what type of trigger the Trigger is
Declaration Syntax
C# Visual Basic Visual C++
public enum TriggerT
Public Enumeration TriggerT
public enum class TriggerT
Members
Member | Description
TimeType |
EventType |
Remarks

Send comments on this topic to Please email feedback to Support


TriggerExpirationClass Class

TriggerExpirationClass Class
Namespaces ► VisualCron ► TriggerExpirationClass

[Missing <summary> documentation for T:VisualCron.TriggerExpirationClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TriggerExpirationClass
<SerializableAttribute> _
Public Class TriggerExpirationClass
[SerializableAttribute]
public ref class TriggerExpirationClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TriggerExpirationClass()()() | Initializes a new instance of the TriggerExpirationClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExpireActionType |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerId |
Inheritance Hierarchy
Object
TriggerExpirationClass

Send comments on this topic to Please email feedback to Support


TriggerExpirationClass Constructor

TriggerExpirationClass Constructor
Namespaces ► VisualCron ► TriggerExpirationClass ► TriggerExpirationClass()()()
Initializes a new instance of the TriggerExpirationClass class
Declaration Syntax
C# Visual Basic Visual C++
public TriggerExpirationClass()
Public Sub New
public:
TriggerExpirationClass()


ExpireActionType Field

ExpireActionType Field
Namespaces ► VisualCron ► TriggerExpirationClass ► ExpireActionType

[Missing <summary> documentation for F:VisualCron.TriggerExpirationClass.ExpireActionType]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass..::.ExpireActionT ExpireActionType
Public ExpireActionType As TriggerClass..::.ExpireActionT
public:
TriggerClass..::.ExpireActionT ExpireActionType


JobId Field

JobId Field
Namespaces ► VisualCron ► TriggerExpirationClass ► JobId

[Missing <summary> documentation for F:VisualCron.TriggerExpirationClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId
Public JobId As String
public:
String^ JobId

Send comments on this topic to Please email feedback to Support


TriggerId Field

TriggerId Field
Namespaces ► VisualCron ► TriggerExpirationClass ► TriggerId

[Missing <summary> documentation for F:VisualCron.TriggerExpirationClass.TriggerId]

Declaration Syntax
C# Visual Basic Visual C++
public string TriggerId
Public TriggerId As String
public:
String^ TriggerId

Send comments on this topic to Please email feedback to Support


TriggerResultClass Class

TriggerResultClass Class
Namespaces ► VisualCron ► TriggerResultClass
This class is a part of the Stats of the job. It will display information about the trigger which last triggered the current job
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TriggerResultClass : ICloneable
<SerializableAttribute> _
Public Class TriggerResultClass _
    Implements ICloneable
[SerializableAttribute]
public ref class TriggerResultClass : ICloneable
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TriggerResultClass()()() | Initializes a new instance of the TriggerResultClass class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventLog |
 | File |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Id of trigger which last triggered this job
 | LastRun |
 | Mail |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process |
 | Registry |
 | Service |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | VisualCron |
Remarks
Inheritance Hierarchy
Object
TriggerResultClass

Send comments on this topic to Please email feedback to Support


TriggerResultClass Constructor

TriggerResultClass Constructor
Namespaces ► VisualCron ► TriggerResultClass ► TriggerResultClass()()()
Initializes a new instance of the TriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public TriggerResultClass()
Public Sub New
public:
TriggerResultClass()


Clone Method

Clone Method
Namespaces ► VisualCron ► TriggerResultClass ► Clone()()()

[Missing <summary> documentation for M:VisualCron.TriggerResultClass.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.TriggerResultClass.Clone]


EventLog Field

EventLog Field
Namespaces ► VisualCron ► TriggerResultClass ► EventLog

[Missing <summary> documentation for F:VisualCron.TriggerResultClass.EventLog]

Declaration Syntax
C# Visual Basic Visual C++
public EventLogTriggerResultClass EventLog
Public EventLog As EventLogTriggerResultClass
public:
EventLogTriggerResultClass^ EventLog

Send comments on this topic to Please email feedback to Support


File Field

File Field
Namespaces ► VisualCron ► TriggerResultClass ► File

[Missing <summary> documentation for F:VisualCron.TriggerResultClass.File]

Declaration Syntax
C# Visual Basic Visual C++
public FileTriggerResultClass File
Public File As FileTriggerResultClass
public:
FileTriggerResultClass^ File

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► TriggerResultClass ► Id
Id of trigger which last triggered this job
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


LastRun Property

LastRun Property
Namespaces ► VisualCron ► TriggerResultClass ► LastRun

[Missing <summary> documentation for P:VisualCron.TriggerResultClass.LastRun]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastRun { get; set; }
Public Property LastRun As DateTime
public:
property DateTime LastRun {
    DateTime get ();
    void set (DateTime value);
}


Mail Field

Mail Field
Namespaces ► VisualCron ► TriggerResultClass ► Mail

[Missing <summary> documentation for F:VisualCron.TriggerResultClass.Mail]

Declaration Syntax
C# Visual Basic Visual C++
public MailTriggerResultClass Mail
Public Mail As MailTriggerResultClass
public:
MailTriggerResultClass^ Mail

Send comments on this topic to Please email feedback to Support


Process Field

Process Field
Namespaces ► VisualCron ► TriggerResultClass ► Process

[Missing <summary> documentation for F:VisualCron.TriggerResultClass.Process]

Declaration Syntax
C# Visual Basic Visual C++
public ProcessTriggerResultClass Process
Public Process As ProcessTriggerResultClass
public:
ProcessTriggerResultClass^ Process

Send comments on this topic to Please email feedback to Support


Registry Field

Registry Field
Namespaces ► VisualCron ► TriggerResultClass ► Registry

[Missing <summary> documentation for F:VisualCron.TriggerResultClass.Registry]

Declaration Syntax
C# Visual Basic Visual C++
public RegistryTriggerResultClass Registry
Public Registry As RegistryTriggerResultClass
public:
RegistryTriggerResultClass^ Registry

Send comments on this topic to Please email feedback to Support


Service Field

Service Field
Namespaces ► VisualCron ► TriggerResultClass ► Service

[Missing <summary> documentation for F:VisualCron.TriggerResultClass.Service]

Declaration Syntax
C# Visual Basic Visual C++
public ServiceTriggerResultClass Service
Public Service As ServiceTriggerResultClass
public:
ServiceTriggerResultClass^ Service

Send comments on this topic to Please email feedback to Support


VisualCron Field

VisualCron Field
Namespaces ► VisualCron ► TriggerResultClass ► VisualCron

[Missing <summary> documentation for F:VisualCron.TriggerResultClass.VisualCron]

Declaration Syntax
C# Visual Basic Visual C++
public VisualCronTriggerResultClass VisualCron
Public VisualCron As VisualCronTriggerResultClass
public:
VisualCronTriggerResultClass^ VisualCron

Send comments on this topic to Please email feedback to Support


TriggerResultCloneClass Class

TriggerResultCloneClass Class
Namespaces ► VisualCron ► TriggerResultCloneClass

[Missing <summary> documentation for T:VisualCron.TriggerResultCloneClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TriggerResultCloneClass
<SerializableAttribute> _
Public Class TriggerResultCloneClass
[SerializableAttribute]
public ref class TriggerResultCloneClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TriggerResultCloneClass()()() | Initializes a new instance of the TriggerResultCloneClass class
 | Done |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | LastRun |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TriggerResultCloneClass

Send comments on this topic to Please email feedback to Support


TriggerResultCloneClass Constructor

TriggerResultCloneClass Constructor
Namespaces ► VisualCron ► TriggerResultCloneClass ► TriggerResultCloneClass()()()
Initializes a new instance of the TriggerResultCloneClass class
Declaration Syntax
C# Visual Basic Visual C++
public TriggerResultCloneClass()
Public Sub New
public:
TriggerResultCloneClass()


Done Field

Done Field
Namespaces ► VisualCron ► TriggerResultCloneClass ► Done

[Missing <summary> documentation for F:VisualCron.TriggerResultCloneClass.Done]

Declaration Syntax
C# Visual Basic Visual C++
public bool Done
Public Done As Boolean
public:
bool Done


Id Field

Id Field
Namespaces ► VisualCron ► TriggerResultCloneClass ► Id

[Missing <summary> documentation for F:VisualCron.TriggerResultCloneClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id
Public Id As String
public:
String^ Id

Send comments on this topic to Please email feedback to Support


LastRun Field

LastRun Field
Namespaces ► VisualCron ► TriggerResultCloneClass ► LastRun

[Missing <summary> documentation for F:VisualCron.TriggerResultCloneClass.LastRun]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastRun
Public LastRun As DateTime
public:
DateTime LastRun

Send comments on this topic to Please email feedback to Support


Result Field

Result Field
Namespaces ► VisualCron ► TriggerResultCloneClass ► Result

[Missing <summary> documentation for F:VisualCron.TriggerResultCloneClass.Result]

Declaration Syntax
C# Visual Basic Visual C++
public TriggerResultClass Result
Public Result As TriggerResultClass
public:
TriggerResultClass^ Result

Send comments on this topic to Please email feedback to Support


UserDeleteClass Class

UserDeleteClass Class
Namespaces ► VisualCron ► UserDeleteClass

[Missing <summary> documentation for T:VisualCron.UserDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class UserDeleteClass
<SerializableAttribute> _
Public Class UserDeleteClass
[SerializableAttribute]
public ref class UserDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserDeleteClass()()() | Initializes a new instance of the UserDeleteClass class
 | Deleted | Gets or sets if the User was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id | Gets or sets the Id of the User to be deleted
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserDeleteClass

Send comments on this topic to Please email feedback to Support


UserDeleteClass Constructor

UserDeleteClass Constructor
Namespaces ► VisualCron ► UserDeleteClass ► UserDeleteClass()()()
Initializes a new instance of the UserDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public UserDeleteClass()
Public Sub New
public:
UserDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► UserDeleteClass ► Deleted
Gets or sets if the User was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Id Property

Id Property
Namespaces ► VisualCron ► UserDeleteClass ► Id
Gets or sets the Id of the User to be deleted
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; set; }
Public Property Id As String
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UserVariableClass Class

UserVariableClass Class
Namespaces ► VisualCron ► UserVariableClass

[Missing <summary> documentation for T:VisualCron.UserVariableClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class UserVariableClass : IComparable<UserVariableClass>
<SerializableAttribute> _
Public Class UserVariableClass _
    Implements IComparable(Of UserVariableClass)
[SerializableAttribute]
public ref class UserVariableClass : IComparable<UserVariableClass^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserVariableClass()()() | Initializes a new instance of the UserVariableClass class
 | CompareTo(UserVariableClass) |
 | Description | Gets or sets a decription of the Variable
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | Gets or sets the unique name of the Variable
 | ObjectType | Gets or sets what type tue
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValueObject | Gets or sets the holder of the Variable
Inheritance Hierarchy
Object
UserVariableClass

Send comments on this topic to Please email feedback to Support


UserVariableClass Constructor

UserVariableClass Constructor
Namespaces ► VisualCron ► UserVariableClass ► UserVariableClass()()()
Initializes a new instance of the UserVariableClass class
Declaration Syntax
C# Visual Basic Visual C++
public UserVariableClass()
Public Sub New
public:
UserVariableClass()


CompareTo Method (other)

CompareTo Method (other)
Namespaces ► VisualCron ► UserVariableClass ► CompareTo(UserVariableClass)

[Missing <summary> documentation for M:VisualCron.UserVariableClass.CompareTo(VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
public int CompareTo(
    UserVariableClass other
)
Public Function CompareTo ( _
    other As UserVariableClass _
) As Integer
public:
virtual int CompareTo(
    UserVariableClass^ other
) sealed
Parameters
other (UserVariableClass)

[Missing <param name="other"/> documentation for "M:VisualCron.UserVariableClass.CompareTo(VisualCron.UserVariableClass)"]

Return Value

[Missing <returns> documentation for M:VisualCron.UserVariableClass.CompareTo(VisualCron.UserVariableClass)]


Description Property

Description Property
Namespaces ► VisualCron ► UserVariableClass ► Description
Gets or sets a decription of the Variable
Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; set; }
Public Property Description As String
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► UserVariableClass ► Name
Gets or sets the unique name of the Variable
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ObjectType Property

ObjectType Property
Namespaces ► VisualCron ► UserVariableClass ► ObjectType
Gets or sets what type tue
Declaration Syntax
C# Visual Basic Visual C++
public TypeCode ObjectType { get; set; }
Public Property ObjectType As TypeCode
public:
property TypeCode ObjectType {
    TypeCode get ();
    void set (TypeCode value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


ValueObject Property

ValueObject Property
Namespaces ► VisualCron ► UserVariableClass ► ValueObject
Gets or sets the holder of the Variable
Declaration Syntax
C# Visual Basic Visual C++
public byte[] ValueObject { get; set; }
Public Property ValueObject As Byte()
public:
property array<unsigned char>^ ValueObject {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


UserVariableDeleteClass Class

UserVariableDeleteClass Class
Namespaces ► VisualCron ► UserVariableDeleteClass

[Missing <summary> documentation for T:VisualCron.UserVariableDeleteClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class UserVariableDeleteClass
<SerializableAttribute> _
Public Class UserVariableDeleteClass
[SerializableAttribute]
public ref class UserVariableDeleteClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserVariableDeleteClass()()() | Initializes a new instance of the UserVariableDeleteClass class
 | Deleted | Indicates if the Variable was deleted or not
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
UserVariableDeleteClass

Send comments on this topic to Please email feedback to Support


UserVariableDeleteClass Constructor

UserVariableDeleteClass Constructor
Namespaces ► VisualCron ► UserVariableDeleteClass ► UserVariableDeleteClass()()()
Initializes a new instance of the UserVariableDeleteClass class
Declaration Syntax
C# Visual Basic Visual C++
public UserVariableDeleteClass()
Public Sub New
public:
UserVariableDeleteClass()


Deleted Property

Deleted Property
Namespaces ► VisualCron ► UserVariableDeleteClass ► Deleted
Indicates if the Variable was deleted or not
Declaration Syntax
C# Visual Basic Visual C++
public bool Deleted { get; set; }
Public Property Deleted As Boolean
public:
property bool Deleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


Name Property

Name Property
Namespaces ► VisualCron ► UserVariableDeleteClass ► Name

[Missing <summary> documentation for P:VisualCron.UserVariableDeleteClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


VCJobProcessClass Class

VCJobProcessClass Class
Namespaces ► VisualCron ► VCJobProcessClass

[Missing <summary> documentation for T:VisualCron.VCJobProcessClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class VCJobProcessClass
<SerializableAttribute> _
Public Class VCJobProcessClass
[SerializableAttribute]
public ref class VCJobProcessClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VCJobProcessClass()()() | Initializes a new instance of the VCJobProcessClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | JobId | Job Id
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Started |
 | Status |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
VCJobProcessClass

Send comments on this topic to Please email feedback to Support


VCJobProcessClass Constructor

VCJobProcessClass Constructor
Namespaces ► VisualCron ► VCJobProcessClass ► VCJobProcessClass()()()
Initializes a new instance of the VCJobProcessClass class
Declaration Syntax
C# Visual Basic Visual C++
public VCJobProcessClass()
Public Sub New
public:
VCJobProcessClass()


Id Property

Id Property
Namespaces ► VisualCron ► VCJobProcessClass ► Id

[Missing <summary> documentation for P:VisualCron.VCJobProcessClass.Id]

Declaration Syntax
C# Visual Basic Visual C++
public int Id { get; set; }
Public Property Id As Integer
public:
property int Id {
    int get ();
    void set (int value);
}


JobId Property

JobId Property
Namespaces ► VisualCron ► VCJobProcessClass ► JobId
Job Id
Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


Started Property

Started Property
Namespaces ► VisualCron ► VCJobProcessClass ► Started

[Missing <summary> documentation for P:VisualCron.VCJobProcessClass.Started]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime Started { get; set; }
Public Property Started As DateTime
public:
property DateTime Started {
    DateTime get ();
    void set (DateTime value);
}


Status Field

Status Field
Namespaces ► VisualCron ► VCJobProcessClass ► Status

[Missing <summary> documentation for F:VisualCron.VCJobProcessClass.Status]

Declaration Syntax
C# Visual Basic Visual C++
public VCJobProcessClass..::.JobStatusType Status
Public Status As VCJobProcessClass..::.JobStatusType
public:
VCJobProcessClass..::.JobStatusType Status


VCJobProcessClass.JobStatusType Enumeration

VCJobProcessClass..::.JobStatusType Enumeration
Namespaces ► VisualCron ► VCJobProcessClass ► VCJobProcessClass..::.JobStatusType

[Missing <summary> documentation for T:VisualCron.VCJobProcessClass.JobStatusType]

Declaration Syntax
C# Visual Basic Visual C++
public enum JobStatusType
Public Enumeration JobStatusType
public enum class JobStatusType
Members
Member | Description
Running |
Terminated |


VCTaskProcessClass Class

VCTaskProcessClass Class
Namespaces ► VisualCron ► VCTaskProcessClass

[Missing <summary> documentation for T:VisualCron.VCTaskProcessClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class VCTaskProcessClass
<SerializableAttribute> _
Public Class VCTaskProcessClass
[SerializableAttribute]
public ref class VCTaskProcessClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VCTaskProcessClass()()() | Initializes a new instance of the VCTaskProcessClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId | Job Id
 | JobPId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | Started |
 | Status |
 | TaskId |
 | TaskPId |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WId |
Inheritance Hierarchy
Object
VCTaskProcessClass

Send comments on this topic to Please email feedback to Support


VCTaskProcessClass Constructor

VCTaskProcessClass Constructor
Namespaces ► VisualCron ► VCTaskProcessClass ► VCTaskProcessClass()()()
Initializes a new instance of the VCTaskProcessClass class
Declaration Syntax
C# Visual Basic Visual C++
public VCTaskProcessClass()
Public Sub New
public:
VCTaskProcessClass()


JobId Property

JobId Property
Namespaces ► VisualCron ► VCTaskProcessClass ► JobId
Job Id
Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


JobPId Property

JobPId Property
Namespaces ► VisualCron ► VCTaskProcessClass ► JobPId

[Missing <summary> documentation for P:VisualCron.VCTaskProcessClass.JobPId]

Declaration Syntax
C# Visual Basic Visual C++
public int JobPId { get; set; }
Public Property JobPId As Integer
public:
property int JobPId {
    int get ();
    void set (int value);
}


Name Property

Name Property
Namespaces ► VisualCron ► VCTaskProcessClass ► Name

[Missing <summary> documentation for P:VisualCron.VCTaskProcessClass.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}


Started Property

Started Property
Namespaces ► VisualCron ► VCTaskProcessClass ► Started

[Missing <summary> documentation for P:VisualCron.VCTaskProcessClass.Started]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime Started { get; set; }
Public Property Started As DateTime
public:
property DateTime Started {
    DateTime get ();
    void set (DateTime value);
}


Status Field

Status Field
Namespaces ► VisualCron ► VCTaskProcessClass ► Status

[Missing <summary> documentation for F:VisualCron.VCTaskProcessClass.Status]

Declaration Syntax
C# Visual Basic Visual C++
public VCTaskProcessClass..::.TaskStatusType Status
Public Status As VCTaskProcessClass..::.TaskStatusType
public:
VCTaskProcessClass..::.TaskStatusType Status


TaskId Property

TaskId Property
Namespaces ► VisualCron ► VCTaskProcessClass ► TaskId

[Missing <summary> documentation for P:VisualCron.VCTaskProcessClass.TaskId]

Declaration Syntax
C# Visual Basic Visual C++
public string TaskId { get; set; }
Public Property TaskId As String
public:
property String^ TaskId {
    String^ get ();
    void set (String^ value);
}


TaskPId Property

TaskPId Property
Namespaces ► VisualCron ► VCTaskProcessClass ► TaskPId

[Missing <summary> documentation for P:VisualCron.VCTaskProcessClass.TaskPId]

Declaration Syntax
C# Visual Basic Visual C++
public int TaskPId { get; set; }
Public Property TaskPId As Integer
public:
property int TaskPId {
    int get ();
    void set (int value);
}


WId Property

WId Property
Namespaces ► VisualCron ► VCTaskProcessClass ► WId

[Missing <summary> documentation for P:VisualCron.VCTaskProcessClass.WId]

Declaration Syntax
C# Visual Basic Visual C++
public int WId { get; set; }
Public Property WId As Integer
public:
property int WId {
    int get ();
    void set (int value);
}


VCTaskProcessClass.TaskStatusType Enumeration

VCTaskProcessClass..::.TaskStatusType Enumeration
Namespaces ► VisualCron ► VCTaskProcessClass ► VCTaskProcessClass..::.TaskStatusType

[Missing <summary> documentation for T:VisualCron.VCTaskProcessClass.TaskStatusType]

Declaration Syntax
C# Visual Basic Visual C++
public enum TaskStatusType
Public Enumeration TaskStatusType
public enum class TaskStatusType
Members
Member | Description
Running |
Terminated |


Wildcard Class

Wildcard Class
Namespaces ► VisualCron ► Wildcard
Implements wildcard matching functionality
Declaration Syntax
C# Visual Basic Visual C++
public class Wildcard
Public Class Wildcard
public ref class Wildcard
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Match(String, String) |
 | Match(String, String, Boolean) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Wildcard

Send comments on this topic to Please email feedback to Support


Match Method

Match Method
Namespaces ► VisualCron ► Wildcard ► Match()()()
Members
Icon | Member | Description
 | Match(String, String) |
 | Match(String, String, Boolean) |


Match Method (pattern, s)

Match Method (pattern, s)
Namespaces ► VisualCron ► Wildcard ► Match(String, String)

[Missing <summary> documentation for M:VisualCron.Wildcard.Match(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool Match(
    string pattern,
    string s
)
Public Shared Function Match ( _
    pattern As String, _
    s As String _
) As Boolean
public:
static bool Match(
    String^ pattern,
    String^ s
)
Parameters
pattern (String)

[Missing <param name="pattern"/> documentation for "M:VisualCron.Wildcard.Match(System.String,System.String)"]

s (String)

[Missing <param name="s"/> documentation for "M:VisualCron.Wildcard.Match(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.Wildcard.Match(System.String,System.String)]


Match Method (pattern, s, caseSensitive)

Match Method (pattern, s, caseSensitive)
Namespaces ► VisualCron ► Wildcard ► Match(String, String, Boolean)

[Missing <summary> documentation for M:VisualCron.Wildcard.Match(System.String,System.String,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool Match(
    string pattern,
    string s,
    bool caseSensitive
)
Public Shared Function Match ( _
    pattern As String, _
    s As String, _
    caseSensitive As Boolean _
) As Boolean
public:
static bool Match(
    String^ pattern,
    String^ s,
    bool caseSensitive
)
Parameters
pattern (String)

[Missing <param name="pattern"/> documentation for "M:VisualCron.Wildcard.Match(System.String,System.String,System.Boolean)"]

s (String)

[Missing <param name="s"/> documentation for "M:VisualCron.Wildcard.Match(System.String,System.String,System.Boolean)"]

caseSensitive (Boolean)

[Missing <param name="caseSensitive"/> documentation for "M:VisualCron.Wildcard.Match(System.String,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCron.Wildcard.Match(System.String,System.String,System.Boolean)]


WinAPI Class

WinAPI Class
Namespaces ► VisualCron ► WinAPI
Contains all required Window API functions exports.
Declaration Syntax
C# Visual Basic Visual C++
public class WinAPI
Public Class WinAPI
public ref class WinAPI
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WinAPI()()() | Initializes a new instance of the WinAPI class
 | AttachThreadInput(Int32, Int32, Int32) |
 | BitBlt(HandleRef, Int32, Int32, Int32, Int32, HandleRef, Int32, Int32, Int32) |
 | CallNextHookEx(HandleRef, Int32, IntPtr, IntPtr) |
 | CreateDC(String, String, String, HandleRef) |
 | CreatePen(Int32, Int32, Int32) |
 | DeleteObject(HandleRef) |
 | DrawFocusRect(HandleRef, RECT%) |
 | EnumWindows(WinAPI..::.EnumThreadWindowsCallback, IntPtr) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindWindow(String, String) |
 | GA_PARENT |
 | GA_ROOT |
 | GA_ROOTOWNER |
 | GetActiveWindow()()() |
 | GetAncestor(IntPtr, Int32) |
 | GetAsyncKeyState(Int32) |
 | GetClassName(HandleRef, StringBuilder, Int32) |
 | GetCurrentProcessId()()() |
 | GetCurrentThreadId()()() |
 | GetCursorPos(POINTSTRUCT%) |
 | GetDC(HandleRef) |
 | GetDCEx(HandleRef, HandleRef, Int32) |
 | GetDesktopWindow()()() |
 | GetFocus()()() |
 | GetForegroundWindow()()() |
 | GetGUIThreadInfo(Int32, GUITHREADINFO%) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKeyboardLayout(Int32) |
 | GetKeyboardState(array<Byte>[]()[]) |
 | GetModuleHandle(String) |
 | GetStockObject(Int32) |
 | GetTickCount()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWindowLong(HandleRef, Int32) |
 | GetWindowLong32(HandleRef, Int32) |
 | GetWindowLongPtr64(HandleRef, Int32) |
 | GetWindowPlacement(IntPtr, WINDOWPLACEMENT%) |
 | GetWindowRect(HandleRef, RECT%) |
 | GetWindowText(HandleRef, StringBuilder, Int32) |
 | GetWindowTextLength(HandleRef) |
 | GetWindowThreadProcessId(IntPtr, Int32%) |
 | GUI_16BITTASK |
 | GUI_CARETBLINKING |
 | GUI_INMENUMODE |
 | GUI_INMOVESIZE |
 | GUI_POPUPMENUMODE |
 | GUI_SYSTEMMENUMODE |
 | GWL_STYLE |
 | HiByte(Int32) |
 | HTCAPTION |
 | InflateRect(RECT%, Int32, Int32) |
 | INPUT_HARDWARE |
 | INPUT_KEYBOARD |
 | INPUT_MOUSE |
 | InvalidateRect(HandleRef, RECT%, Boolean) |
 | InvalidateRect(HandleRef, COMRECT, Boolean) |
 | IsWindowVisible(HandleRef) |
 | KEYEVENTF_EXTENDEDKEY |
 | KEYEVENTF_KEYUP |
 | KEYEVENTF_SCANCODE |
 | KEYEVENTF_UNICODE |
 | LineTo(HandleRef, Int32, Int32) |
 | LoByte(Int32) |
 | MAKELPARAM(Int32, Int32) |
 | MakeWord(Byte, Byte) |
 | MapWindowPoints(HandleRef, HandleRef, POINTSTRUCT, Int32) |
 | MapVirtualKey(Int32, Int32) |
 | MapVirtualKeyEx(Int32, Int32, IntPtr) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MOUSEEVENTF_ABSOLUTE |
 | MOUSEEVENTF_LEFTDOWN |
 | MOUSEEVENTF_LEFTUP |
 | MOUSEEVENTF_MIDDLEDOWN |
 | MOUSEEVENTF_MIDDLEUP |
 | MOUSEEVENTF_MOVE |
 | MOUSEEVENTF_RIGHTDOWN |
 | MOUSEEVENTF_RIGHTUP |
 | MOUSEEVENTF_WHEEL |
 | MOUSEEVENTF_VIRTUALDESK |
 | MOUSEEVENTF_XDOWN |
 | MOUSEEVENTF_XUP |
 | MoveToEx(HandleRef, Int32, Int32, Point) |
 | MoveWindow(HandleRef, Int32, Int32, Int32, Int32, Boolean) |
 | NullHandleRef |
 | OemKeyScan(Int16) |
 | PostMessage(HandleRef, Int32, IntPtr, IntPtr) |
 | PtInRect(RECT%, Int32, Int32) |
 | R2_NOT |
 | RDW_ALLCHILDREN |
 | RDW_ERASE |
 | RDW_ERASENOW |
 | RDW_FRAME |
 | RDW_INVALIDATE |
 | RDW_UPDATENOW |
 | RedrawWindow(HandleRef, RECT, HandleRef, Int32) |
 | RedrawWindow(HandleRef, COMRECT, HandleRef, Int32) |
 | ReleaseCapture()()() |
 | ReleaseDC(HandleRef, HandleRef) |
 | SelectObject(HandleRef, HandleRef) |
 | SendInput(Int32, INPUT%, Int32) |
 | SendMessage(HandleRef, Int32, Boolean, Int32) |
 | SetActiveWindow(HandleRef) |
 | SetCapture(HandleRef) |
 | SetCursor(HandleRef) |
 | SetCursorPos(Int32, Int32) |
 | SetForegroundWindow(HandleRef) |
 | SetKeyboardState(array<Byte>[]()[]) |
 | SetROP2(HandleRef, Int32) |
 | SetWindowLong(HandleRef, Int32, HandleRef) |
 | SetWindowLongPtr32(HandleRef, Int32, HandleRef) |
 | SetWindowLongPtr64(HandleRef, Int32, HandleRef) |
 | SetWindowPlacement(IntPtr, WINDOWPLACEMENT%) |
 | SetWindowPos(HandleRef, HandleRef, Int32, Int32, Int32, Int32, Int32) |
 | SetWindowsHookEx(Int32, WinAPI..::.HookProc, HandleRef, Int32) |
 | ShowWindow(HandleRef, Int32) |
 | SignedHIWORD(IntPtr) |
 | SignedHIWORD(Int32) |
 | SignedLOWORD(IntPtr) |
 | SignedLOWORD(Int32) |
 | SW_SHOWNOACTIVATE |
 | ToAscii(Int32, Int32, array<Byte>[]()[], Int16%, Int32) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ToUnicode(Int32, Int32, array<Byte>[]()[], StringBuilder, Int32, Int32) |
 | ToUnicodeEx(Int32, Int32, array<Byte>[]()[], StringBuilder, Int32, Int32, IntPtr) |
 | UnhookWindowsHookEx(HandleRef) |
 | UpdateWindow(HandleRef) |
 | WH_JOURNALPLAYBACK |
 | WH_JOURNALRECORD |
 | WH_KEYBOARD_LL |
 | WH_MOUSE |
 | WH_MOUSE_LL |
 | WindowFromPoint(POINTSTRUCT) |
 | VK_CONTROL |
 | VK_LWIN |
 | VK_MENU |
 | VK_RWIN |
 | VK_SHIFT |
 | VkKeyScan(Char) |
 | WM_CHAR |
 | WM_KEYDOWN |
 | WM_KEYUP |
 | WM_LBUTTONDBLCLK | Left button double click
 | WM_LBUTTONDOWN | Left button down
 | WM_LBUTTONUP | Left button up
 | WM_MBUTTONDBLCLK | Middle button double click
 | WM_MBUTTONDOWN | Middle button down
 | WM_MBUTTONUP | Middle button up
 | WM_MOUSEMOVE | Mouse move
 | WM_MOUSEWHEEL |
 | WM_NCLBUTTONDOWN |
 | WM_NCMOUSEMOVE |
 | WM_RBUTTONDBLCLK | Right button double click
 | WM_RBUTTONDOWN | Right button down
 | WM_RBUTTONUP | Right button up
 | WM_SYSKEYDOWN |
 | WM_SYSKEYUP |
 | WS_MAXIMIZE |
 | WS_MINIMIZE |
 | XBUTTON1 |
 | XBUTTON2 |
Inheritance Hierarchy
Object
WinAPI

Send comments on this topic to Please email feedback to Support


WinAPI Constructor

WinAPI Constructor
Namespaces ► VisualCron ► WinAPI ► WinAPI()()()
Initializes a new instance of the WinAPI class
Declaration Syntax
C# Visual Basic Visual C++
public WinAPI()
Public Sub New
public:
WinAPI()


AttachThreadInput Method (idAttach, idAttachTo, fAttach)

AttachThreadInput Method (idAttach, idAttachTo, fAttach)
Namespaces ► VisualCron ► WinAPI ► AttachThreadInput(Int32, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.AttachThreadInput(System.Int32,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int AttachThreadInput(
    int idAttach,
    int idAttachTo,
    int fAttach
)
Public Shared Function AttachThreadInput ( _
    idAttach As Integer, _
    idAttachTo As Integer, _
    fAttach As Integer _
) As Integer
public:
static int AttachThreadInput(
    int idAttach,
    int idAttachTo,
    int fAttach
)
Parameters
idAttach (Int32)

[Missing <param name="idAttach"/> documentation for "M:VisualCron.WinAPI.AttachThreadInput(System.Int32,System.Int32,System.Int32)"]

idAttachTo (Int32)

[Missing <param name="idAttachTo"/> documentation for "M:VisualCron.WinAPI.AttachThreadInput(System.Int32,System.Int32,System.Int32)"]

fAttach (Int32)

[Missing <param name="fAttach"/> documentation for "M:VisualCron.WinAPI.AttachThreadInput(System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.AttachThreadInput(System.Int32,System.Int32,System.Int32)]


BitBlt Method (hDC, x, y, nWidth, nHeight, hSrcDC, xSrc, ySrc, dwRop)

BitBlt Method (hDC, x, y, nWidth, nHeight, hSrcDC, xSrc, ySrc, dwRop)
Namespaces ► VisualCron ► WinAPI ► BitBlt(HandleRef, Int32, Int32, Int32, Int32, HandleRef, Int32, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int BitBlt(
    HandleRef hDC,
    int x,
    int y,
    int nWidth,
    int nHeight,
    HandleRef hSrcDC,
    int xSrc,
    int ySrc,
    int dwRop
)
Public Shared Function BitBlt ( _
    hDC As HandleRef, _
    x As Integer, _
    y As Integer, _
    nWidth As Integer, _
    nHeight As Integer, _
    hSrcDC As HandleRef, _
    xSrc As Integer, _
    ySrc As Integer, _
    dwRop As Integer _
) As Integer
public:
static int BitBlt(
    HandleRef hDC,
    int x,
    int y,
    int nWidth,
    int nHeight,
    HandleRef hSrcDC,
    int xSrc,
    int ySrc,
    int dwRop
)
Parameters
hDC (HandleRef)

[Missing <param name="hDC"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

nWidth (Int32)

[Missing <param name="nWidth"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

nHeight (Int32)

[Missing <param name="nHeight"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

hSrcDC (HandleRef)

[Missing <param name="hSrcDC"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

xSrc (Int32)

[Missing <param name="xSrc"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

ySrc (Int32)

[Missing <param name="ySrc"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

dwRop (Int32)

[Missing <param name="dwRop"/> documentation for "M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.BitBlt(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32)]


CallNextHookEx Method (hhook, code, wparam, lparam)

CallNextHookEx Method (hhook, code, wparam, lparam)
Namespaces ► VisualCron ► WinAPI ► CallNextHookEx(HandleRef, Int32, IntPtr, IntPtr)

[Missing <summary> documentation for M:VisualCron.WinAPI.CallNextHookEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr CallNextHookEx(
    HandleRef hhook,
    int code,
    IntPtr wparam,
    IntPtr lparam
)
Public Shared Function CallNextHookEx ( _
    hhook As HandleRef, _
    code As Integer, _
    wparam As IntPtr, _
    lparam As IntPtr _
) As IntPtr
public:
static IntPtr CallNextHookEx(
    HandleRef hhook,
    int code,
    IntPtr wparam,
    IntPtr lparam
)
Parameters
hhook (HandleRef)

[Missing <param name="hhook"/> documentation for "M:VisualCron.WinAPI.CallNextHookEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

code (Int32)

[Missing <param name="code"/> documentation for "M:VisualCron.WinAPI.CallNextHookEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

wparam (IntPtr)

[Missing <param name="wparam"/> documentation for "M:VisualCron.WinAPI.CallNextHookEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

lparam (IntPtr)

[Missing <param name="lparam"/> documentation for "M:VisualCron.WinAPI.CallNextHookEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.CallNextHookEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)]


CreateDC Method (lpszDriver, lpszDeviceName, lpszOutput, devMode)

CreateDC Method (lpszDriver, lpszDeviceName, lpszOutput, devMode)
Namespaces ► VisualCron ► WinAPI ► CreateDC(String, String, String, HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.CreateDC(System.String,System.String,System.String,System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr CreateDC(
    string lpszDriver,
    string lpszDeviceName,
    string lpszOutput,
    HandleRef devMode
)
Public Shared Function CreateDC ( _
    lpszDriver As String, _
    lpszDeviceName As String, _
    lpszOutput As String, _
    devMode As HandleRef _
) As IntPtr
public:
static IntPtr CreateDC(
    String^ lpszDriver,
    String^ lpszDeviceName,
    String^ lpszOutput,
    HandleRef devMode
)
Parameters
lpszDriver (String)

[Missing <param name="lpszDriver"/> documentation for "M:VisualCron.WinAPI.CreateDC(System.String,System.String,System.String,System.Runtime.InteropServices.HandleRef)"]

lpszDeviceName (String)

[Missing <param name="lpszDeviceName"/> documentation for "M:VisualCron.WinAPI.CreateDC(System.String,System.String,System.String,System.Runtime.InteropServices.HandleRef)"]

lpszOutput (String)

[Missing <param name="lpszOutput"/> documentation for "M:VisualCron.WinAPI.CreateDC(System.String,System.String,System.String,System.Runtime.InteropServices.HandleRef)"]

devMode (HandleRef)

[Missing <param name="devMode"/> documentation for "M:VisualCron.WinAPI.CreateDC(System.String,System.String,System.String,System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.CreateDC(System.String,System.String,System.String,System.Runtime.InteropServices.HandleRef)]


CreatePen Method (nStyle, nWidth, crColor)

CreatePen Method (nStyle, nWidth, crColor)
Namespaces ► VisualCron ► WinAPI ► CreatePen(Int32, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.CreatePen(System.Int32,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr CreatePen(
    int nStyle,
    int nWidth,
    int crColor
)
Public Shared Function CreatePen ( _
    nStyle As Integer, _
    nWidth As Integer, _
    crColor As Integer _
) As IntPtr
public:
static IntPtr CreatePen(
    int nStyle,
    int nWidth,
    int crColor
)
Parameters
nStyle (Int32)

[Missing <param name="nStyle"/> documentation for "M:VisualCron.WinAPI.CreatePen(System.Int32,System.Int32,System.Int32)"]

nWidth (Int32)

[Missing <param name="nWidth"/> documentation for "M:VisualCron.WinAPI.CreatePen(System.Int32,System.Int32,System.Int32)"]

crColor (Int32)

[Missing <param name="crColor"/> documentation for "M:VisualCron.WinAPI.CreatePen(System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.CreatePen(System.Int32,System.Int32,System.Int32)]


DeleteObject Method (hObject)

DeleteObject Method (hObject)
Namespaces ► VisualCron ► WinAPI ► DeleteObject(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.DeleteObject(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool DeleteObject(
    HandleRef hObject
)
Public Shared Function DeleteObject ( _
    hObject As HandleRef _
) As Boolean
public:
static bool DeleteObject(
    HandleRef hObject
)
Parameters
hObject (HandleRef)

[Missing <param name="hObject"/> documentation for "M:VisualCron.WinAPI.DeleteObject(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.DeleteObject(System.Runtime.InteropServices.HandleRef)]


DrawFocusRect Method (hWnd, rect)

DrawFocusRect Method (hWnd, rect)
Namespaces ► VisualCron ► WinAPI ► DrawFocusRect(HandleRef, RECT%)

[Missing <summary> documentation for M:VisualCron.WinAPI.DrawFocusRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool DrawFocusRect(
    HandleRef hWnd,
    out RECT rect
)
Public Shared Function DrawFocusRect ( _
    hWnd As HandleRef, _
    <OutAttribute> ByRef rect As RECT _
) As Boolean
public:
static bool DrawFocusRect(
    HandleRef hWnd,
    [InAttribute] [OutAttribute] RECT% rect
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.DrawFocusRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)"]

rect ( RECT %)

[Missing <param name="rect"/> documentation for "M:VisualCron.WinAPI.DrawFocusRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.DrawFocusRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)]


EnumWindows Method (callback, extraData)

EnumWindows Method (callback, extraData)
Namespaces ► VisualCron ► WinAPI ► EnumWindows(WinAPI..::.EnumThreadWindowsCallback, IntPtr)

[Missing <summary> documentation for M:VisualCron.WinAPI.EnumWindows(VisualCron.WinAPI.EnumThreadWindowsCallback,System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool EnumWindows(
    WinAPI..::.EnumThreadWindowsCallback callback,
    IntPtr extraData
)
Public Shared Function EnumWindows ( _
    callback As WinAPI..::.EnumThreadWindowsCallback, _
    extraData As IntPtr _
) As Boolean
public:
static bool EnumWindows(
    WinAPI..::.EnumThreadWindowsCallback^ callback,
    IntPtr extraData
)
Parameters
callback (WinAPI..::.EnumThreadWindowsCallback)

[Missing <param name="callback"/> documentation for "M:VisualCron.WinAPI.EnumWindows(VisualCron.WinAPI.EnumThreadWindowsCallback,System.IntPtr)"]

extraData (IntPtr)

[Missing <param name="extraData"/> documentation for "M:VisualCron.WinAPI.EnumWindows(VisualCron.WinAPI.EnumThreadWindowsCallback,System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.EnumWindows(VisualCron.WinAPI.EnumThreadWindowsCallback,System.IntPtr)]


FindWindow Method (className, windowName)

FindWindow Method (className, windowName)
Namespaces ► VisualCron ► WinAPI ► FindWindow(String, String)

[Missing <summary> documentation for M:VisualCron.WinAPI.FindWindow(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr FindWindow(
    string className,
    string windowName
)
Public Shared Function FindWindow ( _
    className As String, _
    windowName As String _
) As IntPtr
public:
static IntPtr FindWindow(
    String^ className,
    String^ windowName
)
Parameters
className (String)

[Missing <param name="className"/> documentation for "M:VisualCron.WinAPI.FindWindow(System.String,System.String)"]

windowName (String)

[Missing <param name="windowName"/> documentation for "M:VisualCron.WinAPI.FindWindow(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.FindWindow(System.String,System.String)]


GA_PARENT Field

GA_PARENT Field
Namespaces ► VisualCron ► WinAPI ► GA_PARENT

[Missing <summary> documentation for F:VisualCron.WinAPI.GA_PARENT]

Declaration Syntax
C# Visual Basic Visual C++
public const int GA_PARENT
Public Const GA_PARENT As Integer
public:
literal int GA_PARENT


GA_ROOT Field

GA_ROOT Field
Namespaces ► VisualCron ► WinAPI ► GA_ROOT

[Missing <summary> documentation for F:VisualCron.WinAPI.GA_ROOT]

Declaration Syntax
C# Visual Basic Visual C++
public const int GA_ROOT
Public Const GA_ROOT As Integer
public:
literal int GA_ROOT


GA_ROOTOWNER Field

GA_ROOTOWNER Field
Namespaces ► VisualCron ► WinAPI ► GA_ROOTOWNER

[Missing <summary> documentation for F:VisualCron.WinAPI.GA_ROOTOWNER]

Declaration Syntax
C# Visual Basic Visual C++
public const int GA_ROOTOWNER
Public Const GA_ROOTOWNER As Integer
public:
literal int GA_ROOTOWNER


GetActiveWindow Method

GetActiveWindow Method
Namespaces ► VisualCron ► WinAPI ► GetActiveWindow()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.GetActiveWindow]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetActiveWindow()
Public Shared Function GetActiveWindow As IntPtr
public:
static IntPtr GetActiveWindow()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetActiveWindow]


GetAncestor Method (hWnd, flags)

GetAncestor Method (hWnd, flags)
Namespaces ► VisualCron ► WinAPI ► GetAncestor(IntPtr, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetAncestor(System.IntPtr,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetAncestor(
    IntPtr hWnd,
    int flags
)
Public Shared Function GetAncestor ( _
    hWnd As IntPtr, _
    flags As Integer _
) As IntPtr
public:
static IntPtr GetAncestor(
    IntPtr hWnd,
    int flags
)
Parameters
hWnd (IntPtr)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetAncestor(System.IntPtr,System.Int32)"]

flags (Int32)

[Missing <param name="flags"/> documentation for "M:VisualCron.WinAPI.GetAncestor(System.IntPtr,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetAncestor(System.IntPtr,System.Int32)]


GetAsyncKeyState Method (vkey)

GetAsyncKeyState Method (vkey)
Namespaces ► VisualCron ► WinAPI ► GetAsyncKeyState(Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetAsyncKeyState(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static short GetAsyncKeyState(
    int vkey
)
Public Shared Function GetAsyncKeyState ( _
    vkey As Integer _
) As Short
public:
static short GetAsyncKeyState(
    int vkey
)
Parameters
vkey (Int32)

[Missing <param name="vkey"/> documentation for "M:VisualCron.WinAPI.GetAsyncKeyState(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetAsyncKeyState(System.Int32)]


GetClassName Method (hwnd, lpClassName, nMaxCount)

GetClassName Method (hwnd, lpClassName, nMaxCount)
Namespaces ► VisualCron ► WinAPI ► GetClassName(HandleRef, StringBuilder, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetClassName(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetClassName(
    HandleRef hwnd,
    StringBuilder lpClassName,
    int nMaxCount
)
Public Shared Function GetClassName ( _
    hwnd As HandleRef, _
    lpClassName As StringBuilder, _
    nMaxCount As Integer _
) As Integer
public:
static int GetClassName(
    HandleRef hwnd,
    StringBuilder^ lpClassName,
    int nMaxCount
)
Parameters
hwnd (HandleRef)

[Missing <param name="hwnd"/> documentation for "M:VisualCron.WinAPI.GetClassName(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)"]

lpClassName (StringBuilder)

[Missing <param name="lpClassName"/> documentation for "M:VisualCron.WinAPI.GetClassName(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)"]

nMaxCount (Int32)

[Missing <param name="nMaxCount"/> documentation for "M:VisualCron.WinAPI.GetClassName(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetClassName(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)]


GetCurrentProcessId Method

GetCurrentProcessId Method
Namespaces ► VisualCron ► WinAPI ► GetCurrentProcessId()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.GetCurrentProcessId]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetCurrentProcessId()
Public Shared Function GetCurrentProcessId As Integer
public:
static int GetCurrentProcessId()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetCurrentProcessId]


GetCurrentThreadId Method

GetCurrentThreadId Method
Namespaces ► VisualCron ► WinAPI ► GetCurrentThreadId()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.GetCurrentThreadId]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetCurrentThreadId()
Public Shared Function GetCurrentThreadId As Integer
public:
static int GetCurrentThreadId()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetCurrentThreadId]


GetCursorPos Method (lpPoint)

GetCursorPos Method (lpPoint)
Namespaces ► VisualCron ► WinAPI ► GetCursorPos(POINTSTRUCT%)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetCursorPos(VisualCron.POINTSTRUCT@)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool GetCursorPos(
    ref POINTSTRUCT lpPoint
)
Public Shared Function GetCursorPos ( _
    ByRef lpPoint As POINTSTRUCT _
) As Boolean
public:
static bool GetCursorPos(
    POINTSTRUCT% lpPoint
)
Parameters
lpPoint ( POINTSTRUCT %)

[Missing <param name="lpPoint"/> documentation for "M:VisualCron.WinAPI.GetCursorPos(VisualCron.POINTSTRUCT@)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetCursorPos(VisualCron.POINTSTRUCT@)]


GetDC Method (hWnd)

GetDC Method (hWnd)
Namespaces ► VisualCron ► WinAPI ► GetDC(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetDC(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetDC(
    HandleRef hWnd
)
Public Shared Function GetDC ( _
    hWnd As HandleRef _
) As IntPtr
public:
static IntPtr GetDC(
    HandleRef hWnd
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetDC(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetDC(System.Runtime.InteropServices.HandleRef)]


GetDCEx Method (hWnd, hrgnClip, flags)

GetDCEx Method (hWnd, hrgnClip, flags)
Namespaces ► VisualCron ► WinAPI ► GetDCEx(HandleRef, HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetDCEx(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetDCEx(
    HandleRef hWnd,
    HandleRef hrgnClip,
    int flags
)
Public Shared Function GetDCEx ( _
    hWnd As HandleRef, _
    hrgnClip As HandleRef, _
    flags As Integer _
) As IntPtr
public:
static IntPtr GetDCEx(
    HandleRef hWnd,
    HandleRef hrgnClip,
    int flags
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetDCEx(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32)"]

hrgnClip (HandleRef)

[Missing <param name="hrgnClip"/> documentation for "M:VisualCron.WinAPI.GetDCEx(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32)"]

flags (Int32)

[Missing <param name="flags"/> documentation for "M:VisualCron.WinAPI.GetDCEx(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetDCEx(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32)]


GetDesktopWindow Method

GetDesktopWindow Method
Namespaces ► VisualCron ► WinAPI ► GetDesktopWindow()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.GetDesktopWindow]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetDesktopWindow()
Public Shared Function GetDesktopWindow As IntPtr
public:
static IntPtr GetDesktopWindow()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetDesktopWindow]


GetFocus Method

GetFocus Method
Namespaces ► VisualCron ► WinAPI ► GetFocus()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.GetFocus]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetFocus()
Public Shared Function GetFocus As IntPtr
public:
static IntPtr GetFocus()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetFocus]


GetForegroundWindow Method

GetForegroundWindow Method
Namespaces ► VisualCron ► WinAPI ► GetForegroundWindow()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.GetForegroundWindow]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetForegroundWindow()
Public Shared Function GetForegroundWindow As IntPtr
public:
static IntPtr GetForegroundWindow()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetForegroundWindow]


GetGUIThreadInfo Method (idThread, lpgui)

GetGUIThreadInfo Method (idThread, lpgui)
Namespaces ► VisualCron ► WinAPI ► GetGUIThreadInfo(Int32, GUITHREADINFO%)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetGUIThreadInfo(System.Int32,VisualCron.GUITHREADINFO@)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool GetGUIThreadInfo(
    int idThread,
    ref GUITHREADINFO lpgui
)
Public Shared Function GetGUIThreadInfo ( _
    idThread As Integer, _
    ByRef lpgui As GUITHREADINFO _
) As Boolean
public:
static bool GetGUIThreadInfo(
    int idThread,
    GUITHREADINFO% lpgui
)
Parameters
idThread (Int32)

[Missing <param name="idThread"/> documentation for "M:VisualCron.WinAPI.GetGUIThreadInfo(System.Int32,VisualCron.GUITHREADINFO@)"]

lpgui ( GUITHREADINFO %)

[Missing <param name="lpgui"/> documentation for "M:VisualCron.WinAPI.GetGUIThreadInfo(System.Int32,VisualCron.GUITHREADINFO@)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetGUIThreadInfo(System.Int32,VisualCron.GUITHREADINFO@)]


GetKeyboardLayout Method (dwLayout)

GetKeyboardLayout Method (dwLayout)
Namespaces ► VisualCron ► WinAPI ► GetKeyboardLayout(Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetKeyboardLayout(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetKeyboardLayout(
    int dwLayout
)
Public Shared Function GetKeyboardLayout ( _
    dwLayout As Integer _
) As IntPtr
public:
static IntPtr GetKeyboardLayout(
    int dwLayout
)
Parameters
dwLayout (Int32)

[Missing <param name="dwLayout"/> documentation for "M:VisualCron.WinAPI.GetKeyboardLayout(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetKeyboardLayout(System.Int32)]


GetKeyboardState Method (keystate)

GetKeyboardState Method (keystate)
Namespaces ► VisualCron ► WinAPI ► GetKeyboardState(array<Byte>[]()[])

[Missing <summary> documentation for M:VisualCron.WinAPI.GetKeyboardState(System.Byte[])]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetKeyboardState(
    byte[] keystate
)
Public Shared Function GetKeyboardState ( _
    keystate As Byte() _
) As Integer
public:
static int GetKeyboardState(
    array<unsigned char>^ keystate
)
Parameters
keystate (array< Byte >[]()[])

[Missing <param name="keystate"/> documentation for "M:VisualCron.WinAPI.GetKeyboardState(System.Byte[])"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetKeyboardState(System.Byte[])]


GetModuleHandle Method (modName)

GetModuleHandle Method (modName)
Namespaces ► VisualCron ► WinAPI ► GetModuleHandle(String)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetModuleHandle(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetModuleHandle(
    string modName
)
Public Shared Function GetModuleHandle ( _
    modName As String _
) As IntPtr
public:
static IntPtr GetModuleHandle(
    String^ modName
)
Parameters
modName (String)

[Missing <param name="modName"/> documentation for "M:VisualCron.WinAPI.GetModuleHandle(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetModuleHandle(System.String)]


GetStockObject Method (nIndex)

GetStockObject Method (nIndex)
Namespaces ► VisualCron ► WinAPI ► GetStockObject(Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetStockObject(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetStockObject(
    int nIndex
)
Public Shared Function GetStockObject ( _
    nIndex As Integer _
) As IntPtr
public:
static IntPtr GetStockObject(
    int nIndex
)
Parameters
nIndex (Int32)

[Missing <param name="nIndex"/> documentation for "M:VisualCron.WinAPI.GetStockObject(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetStockObject(System.Int32)]


GetTickCount Method

GetTickCount Method
Namespaces ► VisualCron ► WinAPI ► GetTickCount()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.GetTickCount]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetTickCount()
Public Shared Function GetTickCount As Integer
public:
static int GetTickCount()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetTickCount]


GetWindowLong Method (hWnd, nIndex)

GetWindowLong Method (hWnd, nIndex)
Namespaces ► VisualCron ► WinAPI ► GetWindowLong(HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetWindowLong(
    HandleRef hWnd,
    int nIndex
)
Public Shared Function GetWindowLong ( _
    hWnd As HandleRef, _
    nIndex As Integer _
) As IntPtr
public:
static IntPtr GetWindowLong(
    HandleRef hWnd,
    int nIndex
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32)"]

nIndex (Int32)

[Missing <param name="nIndex"/> documentation for "M:VisualCron.WinAPI.GetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32)]


GetWindowLong32 Method (hWnd, nIndex)

GetWindowLong32 Method (hWnd, nIndex)
Namespaces ► VisualCron ► WinAPI ► GetWindowLong32(HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowLong32(System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetWindowLong32(
    HandleRef hWnd,
    int nIndex
)
Public Shared Function GetWindowLong32 ( _
    hWnd As HandleRef, _
    nIndex As Integer _
) As IntPtr
public:
static IntPtr GetWindowLong32(
    HandleRef hWnd,
    int nIndex
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowLong32(System.Runtime.InteropServices.HandleRef,System.Int32)"]

nIndex (Int32)

[Missing <param name="nIndex"/> documentation for "M:VisualCron.WinAPI.GetWindowLong32(System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowLong32(System.Runtime.InteropServices.HandleRef,System.Int32)]


GetWindowLongPtr64 Method (hWnd, nIndex)

GetWindowLongPtr64 Method (hWnd, nIndex)
Namespaces ► VisualCron ► WinAPI ► GetWindowLongPtr64(HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr GetWindowLongPtr64(
    HandleRef hWnd,
    int nIndex
)
Public Shared Function GetWindowLongPtr64 ( _
    hWnd As HandleRef, _
    nIndex As Integer _
) As IntPtr
public:
static IntPtr GetWindowLongPtr64(
    HandleRef hWnd,
    int nIndex
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32)"]

nIndex (Int32)

[Missing <param name="nIndex"/> documentation for "M:VisualCron.WinAPI.GetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32)]


GetWindowPlacement Method (hWnd, lpwndpl)

GetWindowPlacement Method (hWnd, lpwndpl)
Namespaces ► VisualCron ► WinAPI ► GetWindowPlacement(IntPtr, WINDOWPLACEMENT%)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetWindowPlacement(
    IntPtr hWnd,
    ref WINDOWPLACEMENT lpwndpl
)
Public Shared Function GetWindowPlacement ( _
    hWnd As IntPtr, _
    ByRef lpwndpl As WINDOWPLACEMENT _
) As Integer
public:
static int GetWindowPlacement(
    IntPtr hWnd,
    WINDOWPLACEMENT% lpwndpl
)
Parameters
hWnd (IntPtr)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)"]

lpwndpl ( WINDOWPLACEMENT %)

[Missing <param name="lpwndpl"/> documentation for "M:VisualCron.WinAPI.GetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)]


GetWindowRect Method (hWnd, rect)

GetWindowRect Method (hWnd, rect)
Namespaces ► VisualCron ► WinAPI ► GetWindowRect(HandleRef, RECT%)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool GetWindowRect(
    HandleRef hWnd,
    out RECT rect
)
Public Shared Function GetWindowRect ( _
    hWnd As HandleRef, _
    <OutAttribute> ByRef rect As RECT _
) As Boolean
public:
static bool GetWindowRect(
    HandleRef hWnd,
    [InAttribute] [OutAttribute] RECT% rect
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)"]

rect ( RECT %)

[Missing <param name="rect"/> documentation for "M:VisualCron.WinAPI.GetWindowRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@)]


GetWindowText Method (hWnd, lpString, nMaxCount)

GetWindowText Method (hWnd, lpString, nMaxCount)
Namespaces ► VisualCron ► WinAPI ► GetWindowText(HandleRef, StringBuilder, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowText(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetWindowText(
    HandleRef hWnd,
    StringBuilder lpString,
    int nMaxCount
)
Public Shared Function GetWindowText ( _
    hWnd As HandleRef, _
    lpString As StringBuilder, _
    nMaxCount As Integer _
) As Integer
public:
static int GetWindowText(
    HandleRef hWnd,
    StringBuilder^ lpString,
    int nMaxCount
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowText(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)"]

lpString (StringBuilder)

[Missing <param name="lpString"/> documentation for "M:VisualCron.WinAPI.GetWindowText(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)"]

nMaxCount (Int32)

[Missing <param name="nMaxCount"/> documentation for "M:VisualCron.WinAPI.GetWindowText(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowText(System.Runtime.InteropServices.HandleRef,System.Text.StringBuilder,System.Int32)]


GetWindowTextLength Method (hWnd)

GetWindowTextLength Method (hWnd)
Namespaces ► VisualCron ► WinAPI ► GetWindowTextLength(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowTextLength(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetWindowTextLength(
    HandleRef hWnd
)
Public Shared Function GetWindowTextLength ( _
    hWnd As HandleRef _
) As Integer
public:
static int GetWindowTextLength(
    HandleRef hWnd
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowTextLength(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowTextLength(System.Runtime.InteropServices.HandleRef)]


GetWindowThreadProcessId Method (hWnd, lpdwProcessId)

GetWindowThreadProcessId Method (hWnd, lpdwProcessId)
Namespaces ► VisualCron ► WinAPI ► GetWindowThreadProcessId(IntPtr, Int32%)

[Missing <summary> documentation for M:VisualCron.WinAPI.GetWindowThreadProcessId(System.IntPtr,System.Int32@)]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetWindowThreadProcessId(
    IntPtr hWnd,
    out int lpdwProcessId
)
Public Shared Function GetWindowThreadProcessId ( _
    hWnd As IntPtr, _
    <OutAttribute> ByRef lpdwProcessId As Integer _
) As Integer
public:
static int GetWindowThreadProcessId(
    IntPtr hWnd,
    [OutAttribute] int% lpdwProcessId
)
Parameters
hWnd (IntPtr)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.GetWindowThreadProcessId(System.IntPtr,System.Int32@)"]

lpdwProcessId ( Int32 %)

[Missing <param name="lpdwProcessId"/> documentation for "M:VisualCron.WinAPI.GetWindowThreadProcessId(System.IntPtr,System.Int32@)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.GetWindowThreadProcessId(System.IntPtr,System.Int32@)]


GUI_16BITTASK Field

GUI_16BITTASK Field
Namespaces ► VisualCron ► WinAPI ► GUI_16BITTASK

[Missing <summary> documentation for F:VisualCron.WinAPI.GUI_16BITTASK]

Declaration Syntax
C# Visual Basic Visual C++
public const int GUI_16BITTASK
Public Const GUI_16BITTASK As Integer
public:
literal int GUI_16BITTASK


GUI_CARETBLINKING Field

GUI_CARETBLINKING Field
Namespaces ► VisualCron ► WinAPI ► GUI_CARETBLINKING

[Missing <summary> documentation for F:VisualCron.WinAPI.GUI_CARETBLINKING]

Declaration Syntax
C# Visual Basic Visual C++
public const int GUI_CARETBLINKING
Public Const GUI_CARETBLINKING As Integer
public:
literal int GUI_CARETBLINKING


GUI_INMENUMODE Field

GUI_INMENUMODE Field
Namespaces ► VisualCron ► WinAPI ► GUI_INMENUMODE

[Missing <summary> documentation for F:VisualCron.WinAPI.GUI_INMENUMODE]

Declaration Syntax
C# Visual Basic Visual C++
public const int GUI_INMENUMODE
Public Const GUI_INMENUMODE As Integer
public:
literal int GUI_INMENUMODE


GUI_INMOVESIZE Field

GUI_INMOVESIZE Field
Namespaces ► VisualCron ► WinAPI ► GUI_INMOVESIZE

[Missing <summary> documentation for F:VisualCron.WinAPI.GUI_INMOVESIZE]

Declaration Syntax
C# Visual Basic Visual C++
public const int GUI_INMOVESIZE
Public Const GUI_INMOVESIZE As Integer
public:
literal int GUI_INMOVESIZE


GUI_POPUPMENUMODE Field

GUI_POPUPMENUMODE Field
Namespaces ► VisualCron ► WinAPI ► GUI_POPUPMENUMODE

[Missing <summary> documentation for F:VisualCron.WinAPI.GUI_POPUPMENUMODE]

Declaration Syntax
C# Visual Basic Visual C++
public const int GUI_POPUPMENUMODE
Public Const GUI_POPUPMENUMODE As Integer
public:
literal int GUI_POPUPMENUMODE


GUI_SYSTEMMENUMODE Field

GUI_SYSTEMMENUMODE Field
Namespaces ► VisualCron ► WinAPI ► GUI_SYSTEMMENUMODE

[Missing <summary> documentation for F:VisualCron.WinAPI.GUI_SYSTEMMENUMODE]

Declaration Syntax
C# Visual Basic Visual C++
public const int GUI_SYSTEMMENUMODE
Public Const GUI_SYSTEMMENUMODE As Integer
public:
literal int GUI_SYSTEMMENUMODE


GWL_STYLE Field

GWL_STYLE Field
Namespaces ► VisualCron ► WinAPI ► GWL_STYLE

[Missing <summary> documentation for F:VisualCron.WinAPI.GWL_STYLE]

Declaration Syntax
C# Visual Basic Visual C++
public const int GWL_STYLE
Public Const GWL_STYLE As Integer
public:
literal int GWL_STYLE


HiByte Method (w)

HiByte Method (w)
Namespaces ► VisualCron ► WinAPI ► HiByte(Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.HiByte(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static byte HiByte(
    int w
)
Public Shared Function HiByte ( _
    w As Integer _
) As Byte
public:
static unsigned char HiByte(
    int w
)
Parameters
w (Int32)

[Missing <param name="w"/> documentation for "M:VisualCron.WinAPI.HiByte(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.HiByte(System.Int32)]


HTCAPTION Field

HTCAPTION Field
Namespaces ► VisualCron ► WinAPI ► HTCAPTION

[Missing <summary> documentation for F:VisualCron.WinAPI.HTCAPTION]

Declaration Syntax
C# Visual Basic Visual C++
public const int HTCAPTION
Public Const HTCAPTION As Integer
public:
literal int HTCAPTION


InflateRect Method (rect, x, y)

InflateRect Method (rect, x, y)
Namespaces ► VisualCron ► WinAPI ► InflateRect(RECT%, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.InflateRect(VisualCron.RECT@,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool InflateRect(
    out RECT rect,
    int x,
    int y
)
Public Shared Function InflateRect ( _
    <OutAttribute> ByRef rect As RECT, _
    x As Integer, _
    y As Integer _
) As Boolean
public:
static bool InflateRect(
    [OutAttribute] RECT% rect,
    int x,
    int y
)
Parameters
rect ( RECT %)

[Missing <param name="rect"/> documentation for "M:VisualCron.WinAPI.InflateRect(VisualCron.RECT@,System.Int32,System.Int32)"]

x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.WinAPI.InflateRect(VisualCron.RECT@,System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.WinAPI.InflateRect(VisualCron.RECT@,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.InflateRect(VisualCron.RECT@,System.Int32,System.Int32)]


INPUT_HARDWARE Field

INPUT_HARDWARE Field
Namespaces ► VisualCron ► WinAPI ► INPUT_HARDWARE

[Missing <summary> documentation for F:VisualCron.WinAPI.INPUT_HARDWARE]

Declaration Syntax
C# Visual Basic Visual C++
public const int INPUT_HARDWARE
Public Const INPUT_HARDWARE As Integer
public:
literal int INPUT_HARDWARE


INPUT_KEYBOARD Field

INPUT_KEYBOARD Field
Namespaces ► VisualCron ► WinAPI ► INPUT_KEYBOARD

[Missing <summary> documentation for F:VisualCron.WinAPI.INPUT_KEYBOARD]

Declaration Syntax
C# Visual Basic Visual C++
public const int INPUT_KEYBOARD
Public Const INPUT_KEYBOARD As Integer
public:
literal int INPUT_KEYBOARD


INPUT_MOUSE Field

INPUT_MOUSE Field
Namespaces ► VisualCron ► WinAPI ► INPUT_MOUSE

[Missing <summary> documentation for F:VisualCron.WinAPI.INPUT_MOUSE]

Declaration Syntax
C# Visual Basic Visual C++
public const int INPUT_MOUSE
Public Const INPUT_MOUSE As Integer
public:
literal int INPUT_MOUSE


InvalidateRect Method

InvalidateRect Method
Namespaces ► VisualCron ► WinAPI ► InvalidateRect()()()
Members
Icon | Member | Description
 | InvalidateRect(HandleRef, RECT%, Boolean) |
 | InvalidateRect(HandleRef, COMRECT, Boolean) |


InvalidateRect Method (hWnd, rect, erase)

InvalidateRect Method (hWnd, rect, erase)
Namespaces ► VisualCron ► WinAPI ► InvalidateRect(HandleRef, COMRECT, Boolean)

[Missing <summary> documentation for M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool InvalidateRect(
    HandleRef hWnd,
    COMRECT rect,
    bool erase
)
Public Shared Function InvalidateRect ( _
    hWnd As HandleRef, _
    rect As COMRECT, _
    erase As Boolean _
) As Boolean
public:
static bool InvalidateRect(
    HandleRef hWnd,
    COMRECT^ rect,
    bool erase
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Boolean)"]

rect (COMRECT)

[Missing <param name="rect"/> documentation for "M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Boolean)"]

erase (Boolean)

[Missing <param name="erase"/> documentation for "M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Boolean)]


InvalidateRect Method (hWnd, rect, erase)

InvalidateRect Method (hWnd, rect, erase)
Namespaces ► VisualCron ► WinAPI ► InvalidateRect(HandleRef, RECT%, Boolean)

[Missing <summary> documentation for M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool InvalidateRect(
    HandleRef hWnd,
    ref RECT rect,
    bool erase
)
Public Shared Function InvalidateRect ( _
    hWnd As HandleRef, _
    ByRef rect As RECT, _
    erase As Boolean _
) As Boolean
public:
static bool InvalidateRect(
    HandleRef hWnd,
    RECT% rect,
    bool erase
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@,System.Boolean)"]

rect ( RECT %)

[Missing <param name="rect"/> documentation for "M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@,System.Boolean)"]

erase (Boolean)

[Missing <param name="erase"/> documentation for "M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.InvalidateRect(System.Runtime.InteropServices.HandleRef,VisualCron.RECT@,System.Boolean)]


IsWindowVisible Method (hWnd)

IsWindowVisible Method (hWnd)
Namespaces ► VisualCron ► WinAPI ► IsWindowVisible(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.IsWindowVisible(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool IsWindowVisible(
    HandleRef hWnd
)
Public Shared Function IsWindowVisible ( _
    hWnd As HandleRef _
) As Boolean
public:
static bool IsWindowVisible(
    HandleRef hWnd
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.IsWindowVisible(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.IsWindowVisible(System.Runtime.InteropServices.HandleRef)]


KEYEVENTF_EXTENDEDKEY Field

KEYEVENTF_EXTENDEDKEY Field
Namespaces ► VisualCron ► WinAPI ► KEYEVENTF_EXTENDEDKEY

[Missing <summary> documentation for F:VisualCron.WinAPI.KEYEVENTF_EXTENDEDKEY]

Declaration Syntax
C# Visual Basic Visual C++
public const int KEYEVENTF_EXTENDEDKEY
Public Const KEYEVENTF_EXTENDEDKEY As Integer
public:
literal int KEYEVENTF_EXTENDEDKEY


KEYEVENTF_KEYUP Field

KEYEVENTF_KEYUP Field
Namespaces ► VisualCron ► WinAPI ► KEYEVENTF_KEYUP

[Missing <summary> documentation for F:VisualCron.WinAPI.KEYEVENTF_KEYUP]

Declaration Syntax
C# Visual Basic Visual C++
public const int KEYEVENTF_KEYUP
Public Const KEYEVENTF_KEYUP As Integer
public:
literal int KEYEVENTF_KEYUP


KEYEVENTF_SCANCODE Field

KEYEVENTF_SCANCODE Field
Namespaces ► VisualCron ► WinAPI ► KEYEVENTF_SCANCODE

[Missing <summary> documentation for F:VisualCron.WinAPI.KEYEVENTF_SCANCODE]

Declaration Syntax
C# Visual Basic Visual C++
public const int KEYEVENTF_SCANCODE
Public Const KEYEVENTF_SCANCODE As Integer
public:
literal int KEYEVENTF_SCANCODE


KEYEVENTF_UNICODE Field

KEYEVENTF_UNICODE Field
Namespaces ► VisualCron ► WinAPI ► KEYEVENTF_UNICODE

[Missing <summary> documentation for F:VisualCron.WinAPI.KEYEVENTF_UNICODE]

Declaration Syntax
C# Visual Basic Visual C++
public const int KEYEVENTF_UNICODE
Public Const KEYEVENTF_UNICODE As Integer
public:
literal int KEYEVENTF_UNICODE


LineTo Method (hdc, x, y)

LineTo Method (hdc, x, y)
Namespaces ► VisualCron ► WinAPI ► LineTo(HandleRef, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.LineTo(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool LineTo(
    HandleRef hdc,
    int x,
    int y
)
Public Shared Function LineTo ( _
    hdc As HandleRef, _
    x As Integer, _
    y As Integer _
) As Boolean
public:
static bool LineTo(
    HandleRef hdc,
    int x,
    int y
)
Parameters
hdc (HandleRef)

[Missing <param name="hdc"/> documentation for "M:VisualCron.WinAPI.LineTo(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32)"]

x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.WinAPI.LineTo(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.WinAPI.LineTo(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.LineTo(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32)]


LoByte Method (w)

LoByte Method (w)
Namespaces ► VisualCron ► WinAPI ► LoByte(Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.LoByte(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static byte LoByte(
    int w
)
Public Shared Function LoByte ( _
    w As Integer _
) As Byte
public:
static unsigned char LoByte(
    int w
)
Parameters
w (Int32)

[Missing <param name="w"/> documentation for "M:VisualCron.WinAPI.LoByte(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.LoByte(System.Int32)]


MAKELPARAM Method (low, high)

MAKELPARAM Method (low, high)
Namespaces ► VisualCron ► WinAPI ► MAKELPARAM(Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.MAKELPARAM(System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr MAKELPARAM(
    int low,
    int high
)
Public Shared Function MAKELPARAM ( _
    low As Integer, _
    high As Integer _
) As IntPtr
public:
static IntPtr MAKELPARAM(
    int low,
    int high
)
Parameters
low (Int32)

[Missing <param name="low"/> documentation for "M:VisualCron.WinAPI.MAKELPARAM(System.Int32,System.Int32)"]

high (Int32)

[Missing <param name="high"/> documentation for "M:VisualCron.WinAPI.MAKELPARAM(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.MAKELPARAM(System.Int32,System.Int32)]


MakeWord Method (lo, hi)

MakeWord Method (lo, hi)
Namespaces ► VisualCron ► WinAPI ► MakeWord(Byte, Byte)

[Missing <summary> documentation for M:VisualCron.WinAPI.MakeWord(System.Byte,System.Byte)]

Declaration Syntax
C# Visual Basic Visual C++
public static short MakeWord(
    byte lo,
    byte hi
)
Public Shared Function MakeWord ( _
    lo As Byte, _
    hi As Byte _
) As Short
public:
static short MakeWord(
    unsigned char lo,
    unsigned char hi
)
Parameters
lo (Byte)

[Missing <param name="lo"/> documentation for "M:VisualCron.WinAPI.MakeWord(System.Byte,System.Byte)"]

hi (Byte)

[Missing <param name="hi"/> documentation for "M:VisualCron.WinAPI.MakeWord(System.Byte,System.Byte)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.MakeWord(System.Byte,System.Byte)]


MapWindowPoints Method (hWndFrom, hWndTo, pt, cPoints)

MapWindowPoints Method (hWndFrom, hWndTo, pt, cPoints)
Namespaces ► VisualCron ► WinAPI ► MapWindowPoints(HandleRef, HandleRef, POINTSTRUCT, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.MapWindowPoints(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,VisualCron.POINTSTRUCT,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int MapWindowPoints(
    HandleRef hWndFrom,
    HandleRef hWndTo,
    POINTSTRUCT pt,
    int cPoints
)
Public Shared Function MapWindowPoints ( _
    hWndFrom As HandleRef, _
    hWndTo As HandleRef, _
    <OutAttribute> pt As POINTSTRUCT, _
    cPoints As Integer _
) As Integer
public:
static int MapWindowPoints(
    HandleRef hWndFrom,
    HandleRef hWndTo,
    [InAttribute] [OutAttribute] POINTSTRUCT pt,
    int cPoints
)
Parameters
hWndFrom (HandleRef)

[Missing <param name="hWndFrom"/> documentation for "M:VisualCron.WinAPI.MapWindowPoints(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,VisualCron.POINTSTRUCT,System.Int32)"]

hWndTo (HandleRef)

[Missing <param name="hWndTo"/> documentation for "M:VisualCron.WinAPI.MapWindowPoints(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,VisualCron.POINTSTRUCT,System.Int32)"]

pt (POINTSTRUCT)

[Missing <param name="pt"/> documentation for "M:VisualCron.WinAPI.MapWindowPoints(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,VisualCron.POINTSTRUCT,System.Int32)"]

cPoints (Int32)

[Missing <param name="cPoints"/> documentation for "M:VisualCron.WinAPI.MapWindowPoints(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,VisualCron.POINTSTRUCT,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.MapWindowPoints(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,VisualCron.POINTSTRUCT,System.Int32)]


MapVirtualKey Method (nVirtKey, nMapType)

MapVirtualKey Method (nVirtKey, nMapType)
Namespaces ► VisualCron ► WinAPI ► MapVirtualKey(Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.MapVirtualKey(System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int MapVirtualKey(
    int nVirtKey,
    int nMapType
)
Public Shared Function MapVirtualKey ( _
    nVirtKey As Integer, _
    nMapType As Integer _
) As Integer
public:
static int MapVirtualKey(
    int nVirtKey,
    int nMapType
)
Parameters
nVirtKey (Int32)

[Missing <param name="nVirtKey"/> documentation for "M:VisualCron.WinAPI.MapVirtualKey(System.Int32,System.Int32)"]

nMapType (Int32)

[Missing <param name="nMapType"/> documentation for "M:VisualCron.WinAPI.MapVirtualKey(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.MapVirtualKey(System.Int32,System.Int32)]


MapVirtualKeyEx Method (uCode, uMapType, dwhkl)

MapVirtualKeyEx Method (uCode, uMapType, dwhkl)
Namespaces ► VisualCron ► WinAPI ► MapVirtualKeyEx(Int32, Int32, IntPtr)

[Missing <summary> documentation for M:VisualCron.WinAPI.MapVirtualKeyEx(System.Int32,System.Int32,System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static int MapVirtualKeyEx(
    int uCode,
    int uMapType,
    IntPtr dwhkl
)
Public Shared Function MapVirtualKeyEx ( _
    uCode As Integer, _
    uMapType As Integer, _
    dwhkl As IntPtr _
) As Integer
public:
static int MapVirtualKeyEx(
    int uCode,
    int uMapType,
    IntPtr dwhkl
)
Parameters
uCode (Int32)

[Missing <param name="uCode"/> documentation for "M:VisualCron.WinAPI.MapVirtualKeyEx(System.Int32,System.Int32,System.IntPtr)"]

uMapType (Int32)

[Missing <param name="uMapType"/> documentation for "M:VisualCron.WinAPI.MapVirtualKeyEx(System.Int32,System.Int32,System.IntPtr)"]

dwhkl (IntPtr)

[Missing <param name="dwhkl"/> documentation for "M:VisualCron.WinAPI.MapVirtualKeyEx(System.Int32,System.Int32,System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.MapVirtualKeyEx(System.Int32,System.Int32,System.IntPtr)]


MOUSEEVENTF_ABSOLUTE Field

MOUSEEVENTF_ABSOLUTE Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_ABSOLUTE

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_ABSOLUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_ABSOLUTE
Public Const MOUSEEVENTF_ABSOLUTE As Integer
public:
literal int MOUSEEVENTF_ABSOLUTE


MOUSEEVENTF_LEFTDOWN Field

MOUSEEVENTF_LEFTDOWN Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_LEFTDOWN

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_LEFTDOWN]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_LEFTDOWN
Public Const MOUSEEVENTF_LEFTDOWN As Integer
public:
literal int MOUSEEVENTF_LEFTDOWN


MOUSEEVENTF_LEFTUP Field

MOUSEEVENTF_LEFTUP Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_LEFTUP

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_LEFTUP]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_LEFTUP
Public Const MOUSEEVENTF_LEFTUP As Integer
public:
literal int MOUSEEVENTF_LEFTUP


MOUSEEVENTF_MIDDLEDOWN Field

MOUSEEVENTF_MIDDLEDOWN Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_MIDDLEDOWN

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_MIDDLEDOWN]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_MIDDLEDOWN
Public Const MOUSEEVENTF_MIDDLEDOWN As Integer
public:
literal int MOUSEEVENTF_MIDDLEDOWN


MOUSEEVENTF_MIDDLEUP Field

MOUSEEVENTF_MIDDLEUP Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_MIDDLEUP

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_MIDDLEUP]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_MIDDLEUP
Public Const MOUSEEVENTF_MIDDLEUP As Integer
public:
literal int MOUSEEVENTF_MIDDLEUP


MOUSEEVENTF_MOVE Field

MOUSEEVENTF_MOVE Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_MOVE

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_MOVE]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_MOVE
Public Const MOUSEEVENTF_MOVE As Integer
public:
literal int MOUSEEVENTF_MOVE


MOUSEEVENTF_RIGHTDOWN Field

MOUSEEVENTF_RIGHTDOWN Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_RIGHTDOWN

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_RIGHTDOWN]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_RIGHTDOWN
Public Const MOUSEEVENTF_RIGHTDOWN As Integer
public:
literal int MOUSEEVENTF_RIGHTDOWN


MOUSEEVENTF_RIGHTUP Field

MOUSEEVENTF_RIGHTUP Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_RIGHTUP

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_RIGHTUP]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_RIGHTUP
Public Const MOUSEEVENTF_RIGHTUP As Integer
public:
literal int MOUSEEVENTF_RIGHTUP


MOUSEEVENTF_WHEEL Field

MOUSEEVENTF_WHEEL Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_WHEEL

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_WHEEL]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_WHEEL
Public Const MOUSEEVENTF_WHEEL As Integer
public:
literal int MOUSEEVENTF_WHEEL


MOUSEEVENTF_VIRTUALDESK Field

MOUSEEVENTF_VIRTUALDESK Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_VIRTUALDESK

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_VIRTUALDESK]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_VIRTUALDESK
Public Const MOUSEEVENTF_VIRTUALDESK As Integer
public:
literal int MOUSEEVENTF_VIRTUALDESK


MOUSEEVENTF_XDOWN Field

MOUSEEVENTF_XDOWN Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_XDOWN

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_XDOWN]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_XDOWN
Public Const MOUSEEVENTF_XDOWN As Integer
public:
literal int MOUSEEVENTF_XDOWN


MOUSEEVENTF_XUP Field

MOUSEEVENTF_XUP Field
Namespaces ► VisualCron ► WinAPI ► MOUSEEVENTF_XUP

[Missing <summary> documentation for F:VisualCron.WinAPI.MOUSEEVENTF_XUP]

Declaration Syntax
C# Visual Basic Visual C++
public const int MOUSEEVENTF_XUP
Public Const MOUSEEVENTF_XUP As Integer
public:
literal int MOUSEEVENTF_XUP


MoveToEx Method (hdc, x, y, pt)

MoveToEx Method (hdc, x, y, pt)
Namespaces ► VisualCron ► WinAPI ► MoveToEx(HandleRef, Int32, Int32, Point)

[Missing <summary> documentation for M:VisualCron.WinAPI.MoveToEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Drawing.Point)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool MoveToEx(
    HandleRef hdc,
    int x,
    int y,
    Point pt
)
Public Shared Function MoveToEx ( _
    hdc As HandleRef, _
    x As Integer, _
    y As Integer, _
    pt As Point _
) As Boolean
public:
static bool MoveToEx(
    HandleRef hdc,
    int x,
    int y,
    Point pt
)
Parameters
hdc (HandleRef)

[Missing <param name="hdc"/> documentation for "M:VisualCron.WinAPI.MoveToEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Drawing.Point)"]

x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.WinAPI.MoveToEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Drawing.Point)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.WinAPI.MoveToEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Drawing.Point)"]

pt (Point)

[Missing <param name="pt"/> documentation for "M:VisualCron.WinAPI.MoveToEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Drawing.Point)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.MoveToEx(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Drawing.Point)]


MoveWindow Method (hWnd, x, y, nWidth, nHeight, bRepaint)

MoveWindow Method (hWnd, x, y, nWidth, nHeight, bRepaint)
Namespaces ► VisualCron ► WinAPI ► MoveWindow(HandleRef, Int32, Int32, Int32, Int32, Boolean)

[Missing <summary> documentation for M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool MoveWindow(
    HandleRef hWnd,
    int x,
    int y,
    int nWidth,
    int nHeight,
    bool bRepaint
)
Public Shared Function MoveWindow ( _
    hWnd As HandleRef, _
    x As Integer, _
    y As Integer, _
    nWidth As Integer, _
    nHeight As Integer, _
    bRepaint As Boolean _
) As Boolean
public:
static bool MoveWindow(
    HandleRef hWnd,
    int x,
    int y,
    int nWidth,
    int nHeight,
    bool bRepaint
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

nWidth (Int32)

[Missing <param name="nWidth"/> documentation for "M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

nHeight (Int32)

[Missing <param name="nHeight"/> documentation for "M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

bRepaint (Boolean)

[Missing <param name="bRepaint"/> documentation for "M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.MoveWindow(System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Boolean)]


NullHandleRef Field

NullHandleRef Field
Namespaces ► VisualCron ► WinAPI ► NullHandleRef

[Missing <summary> documentation for F:VisualCron.WinAPI.NullHandleRef]

Declaration Syntax
C# Visual Basic Visual C++
public static HandleRef NullHandleRef
Public Shared NullHandleRef As HandleRef
public:
static HandleRef NullHandleRef


OemKeyScan Method (wAsciiVal)

OemKeyScan Method (wAsciiVal)
Namespaces ► VisualCron ► WinAPI ► OemKeyScan(Int16)

[Missing <summary> documentation for M:VisualCron.WinAPI.OemKeyScan(System.Int16)]

Declaration Syntax
C# Visual Basic Visual C++
public static int OemKeyScan(
    short wAsciiVal
)
Public Shared Function OemKeyScan ( _
    wAsciiVal As Short _
) As Integer
public:
static int OemKeyScan(
    short wAsciiVal
)
Parameters
wAsciiVal (Int16)

[Missing <param name="wAsciiVal"/> documentation for "M:VisualCron.WinAPI.OemKeyScan(System.Int16)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.OemKeyScan(System.Int16)]


PostMessage Method (hwnd, msg, wparam, lparam)

PostMessage Method (hwnd, msg, wparam, lparam)
Namespaces ► VisualCron ► WinAPI ► PostMessage(HandleRef, Int32, IntPtr, IntPtr)

[Missing <summary> documentation for M:VisualCron.WinAPI.PostMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool PostMessage(
    HandleRef hwnd,
    int msg,
    IntPtr wparam,
    IntPtr lparam
)
Public Shared Function PostMessage ( _
    hwnd As HandleRef, _
    msg As Integer, _
    wparam As IntPtr, _
    lparam As IntPtr _
) As Boolean
public:
static bool PostMessage(
    HandleRef hwnd,
    int msg,
    IntPtr wparam,
    IntPtr lparam
)
Parameters
hwnd (HandleRef)

[Missing <param name="hwnd"/> documentation for "M:VisualCron.WinAPI.PostMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

msg (Int32)

[Missing <param name="msg"/> documentation for "M:VisualCron.WinAPI.PostMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

wparam (IntPtr)

[Missing <param name="wparam"/> documentation for "M:VisualCron.WinAPI.PostMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

lparam (IntPtr)

[Missing <param name="lparam"/> documentation for "M:VisualCron.WinAPI.PostMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.PostMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.IntPtr,System.IntPtr)]


PtInRect Method (rect, ptx, pty)

PtInRect Method (rect, ptx, pty)
Namespaces ► VisualCron ► WinAPI ► PtInRect(RECT%, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.PtInRect(VisualCron.RECT@,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool PtInRect(
    out RECT rect,
    int ptx,
    int pty
)
Public Shared Function PtInRect ( _
    <OutAttribute> ByRef rect As RECT, _
    ptx As Integer, _
    pty As Integer _
) As Boolean
public:
static bool PtInRect(
    [OutAttribute] RECT% rect,
    int ptx,
    int pty
)
Parameters
rect ( RECT %)

[Missing <param name="rect"/> documentation for "M:VisualCron.WinAPI.PtInRect(VisualCron.RECT@,System.Int32,System.Int32)"]

ptx (Int32)

[Missing <param name="ptx"/> documentation for "M:VisualCron.WinAPI.PtInRect(VisualCron.RECT@,System.Int32,System.Int32)"]

pty (Int32)

[Missing <param name="pty"/> documentation for "M:VisualCron.WinAPI.PtInRect(VisualCron.RECT@,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.PtInRect(VisualCron.RECT@,System.Int32,System.Int32)]


R2_NOT Field

R2_NOT Field
Namespaces ► VisualCron ► WinAPI ► R2_NOT

[Missing <summary> documentation for F:VisualCron.WinAPI.R2_NOT]

Declaration Syntax
C# Visual Basic Visual C++
public const int R2_NOT
Public Const R2_NOT As Integer
public:
literal int R2_NOT


RDW_ALLCHILDREN Field

RDW_ALLCHILDREN Field
Namespaces ► VisualCron ► WinAPI ► RDW_ALLCHILDREN

[Missing <summary> documentation for F:VisualCron.WinAPI.RDW_ALLCHILDREN]

Declaration Syntax
C# Visual Basic Visual C++
public const int RDW_ALLCHILDREN
Public Const RDW_ALLCHILDREN As Integer
public:
literal int RDW_ALLCHILDREN


RDW_ERASE Field

RDW_ERASE Field
Namespaces ► VisualCron ► WinAPI ► RDW_ERASE

[Missing <summary> documentation for F:VisualCron.WinAPI.RDW_ERASE]

Declaration Syntax
C# Visual Basic Visual C++
public const int RDW_ERASE
Public Const RDW_ERASE As Integer
public:
literal int RDW_ERASE


RDW_ERASENOW Field

RDW_ERASENOW Field
Namespaces ► VisualCron ► WinAPI ► RDW_ERASENOW

[Missing <summary> documentation for F:VisualCron.WinAPI.RDW_ERASENOW]

Declaration Syntax
C# Visual Basic Visual C++
public const int RDW_ERASENOW
Public Const RDW_ERASENOW As Integer
public:
literal int RDW_ERASENOW


RDW_FRAME Field

RDW_FRAME Field
Namespaces ► VisualCron ► WinAPI ► RDW_FRAME

[Missing <summary> documentation for F:VisualCron.WinAPI.RDW_FRAME]

Declaration Syntax
C# Visual Basic Visual C++
public const int RDW_FRAME
Public Const RDW_FRAME As Integer
public:
literal int RDW_FRAME


RDW_INVALIDATE Field

RDW_INVALIDATE Field
Namespaces ► VisualCron ► WinAPI ► RDW_INVALIDATE

[Missing <summary> documentation for F:VisualCron.WinAPI.RDW_INVALIDATE]

Declaration Syntax
C# Visual Basic Visual C++
public const int RDW_INVALIDATE
Public Const RDW_INVALIDATE As Integer
public:
literal int RDW_INVALIDATE


RDW_UPDATENOW Field

RDW_UPDATENOW Field
Namespaces ► VisualCron ► WinAPI ► RDW_UPDATENOW

[Missing <summary> documentation for F:VisualCron.WinAPI.RDW_UPDATENOW]

Declaration Syntax
C# Visual Basic Visual C++
public const int RDW_UPDATENOW
Public Const RDW_UPDATENOW As Integer
public:
literal int RDW_UPDATENOW


RedrawWindow Method

RedrawWindow Method
Namespaces ► VisualCron ► WinAPI ► RedrawWindow()()()
Members
Icon | Member | Description
 | RedrawWindow(HandleRef, RECT, HandleRef, Int32) |
 | RedrawWindow(HandleRef, COMRECT, HandleRef, Int32) |


RedrawWindow Method (hwnd, rcUpdate, hrgnUpdate, flags)

RedrawWindow Method (hwnd, rcUpdate, hrgnUpdate, flags)
Namespaces ► VisualCron ► WinAPI ► RedrawWindow(HandleRef, COMRECT, HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool RedrawWindow(
    HandleRef hwnd,
    COMRECT rcUpdate,
    HandleRef hrgnUpdate,
    int flags
)
Public Shared Function RedrawWindow ( _
    hwnd As HandleRef, _
    rcUpdate As COMRECT, _
    hrgnUpdate As HandleRef, _
    flags As Integer _
) As Boolean
public:
static bool RedrawWindow(
    HandleRef hwnd,
    COMRECT^ rcUpdate,
    HandleRef hrgnUpdate,
    int flags
)
Parameters
hwnd (HandleRef)

[Missing <param name="hwnd"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

rcUpdate (COMRECT)

[Missing <param name="rcUpdate"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

hrgnUpdate (HandleRef)

[Missing <param name="hrgnUpdate"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

flags (Int32)

[Missing <param name="flags"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.COMRECT,System.Runtime.InteropServices.HandleRef,System.Int32)]


RedrawWindow Method (hwnd, rcUpdate, hrgnUpdate, flags)

RedrawWindow Method (hwnd, rcUpdate, hrgnUpdate, flags)
Namespaces ► VisualCron ► WinAPI ► RedrawWindow(HandleRef, RECT, HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.RECT,System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool RedrawWindow(
    HandleRef hwnd,
    RECT rcUpdate,
    HandleRef hrgnUpdate,
    int flags
)
Public Shared Function RedrawWindow ( _
    hwnd As HandleRef, _
    rcUpdate As RECT, _
    hrgnUpdate As HandleRef, _
    flags As Integer _
) As Boolean
public:
static bool RedrawWindow(
    HandleRef hwnd,
    RECT rcUpdate,
    HandleRef hrgnUpdate,
    int flags
)
Parameters
hwnd (HandleRef)

[Missing <param name="hwnd"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.RECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

rcUpdate (RECT)

[Missing <param name="rcUpdate"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.RECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

hrgnUpdate (HandleRef)

[Missing <param name="hrgnUpdate"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.RECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

flags (Int32)

[Missing <param name="flags"/> documentation for "M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.RECT,System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.RedrawWindow(System.Runtime.InteropServices.HandleRef,VisualCron.RECT,System.Runtime.InteropServices.HandleRef,System.Int32)]


ReleaseCapture Method

ReleaseCapture Method
Namespaces ► VisualCron ► WinAPI ► ReleaseCapture()()()

[Missing <summary> documentation for M:VisualCron.WinAPI.ReleaseCapture]

Declaration Syntax
C# Visual Basic Visual C++
public static bool ReleaseCapture()
Public Shared Function ReleaseCapture As Boolean
public:
static bool ReleaseCapture()
Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.ReleaseCapture]


ReleaseDC Method (hWnd, hDC)

ReleaseDC Method (hWnd, hDC)
Namespaces ► VisualCron ► WinAPI ► ReleaseDC(HandleRef, HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.ReleaseDC(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static int ReleaseDC(
    HandleRef hWnd,
    HandleRef hDC
)
Public Shared Function ReleaseDC ( _
    hWnd As HandleRef, _
    hDC As HandleRef _
) As Integer
public:
static int ReleaseDC(
    HandleRef hWnd,
    HandleRef hDC
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.ReleaseDC(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)"]

hDC (HandleRef)

[Missing <param name="hDC"/> documentation for "M:VisualCron.WinAPI.ReleaseDC(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.ReleaseDC(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)]


SelectObject Method (hDC, hObject)

SelectObject Method (hDC, hObject)
Namespaces ► VisualCron ► WinAPI ► SelectObject(HandleRef, HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SelectObject(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SelectObject(
    HandleRef hDC,
    HandleRef hObject
)
Public Shared Function SelectObject ( _
    hDC As HandleRef, _
    hObject As HandleRef _
) As IntPtr
public:
static IntPtr SelectObject(
    HandleRef hDC,
    HandleRef hObject
)
Parameters
hDC (HandleRef)

[Missing <param name="hDC"/> documentation for "M:VisualCron.WinAPI.SelectObject(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)"]

hObject (HandleRef)

[Missing <param name="hObject"/> documentation for "M:VisualCron.WinAPI.SelectObject(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SelectObject(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef)]


SendInput Method (cInputs, pInputs, cbSize)

SendInput Method (cInputs, pInputs, cbSize)
Namespaces ► VisualCron ► WinAPI ► SendInput(Int32, INPUT%, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SendInput(System.Int32,VisualCron.INPUT@,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int SendInput(
    int cInputs,
    ref INPUT pInputs,
    int cbSize
)
Public Shared Function SendInput ( _
    cInputs As Integer, _
    ByRef pInputs As INPUT, _
    cbSize As Integer _
) As Integer
public:
static int SendInput(
    int cInputs,
    INPUT% pInputs,
    int cbSize
)
Parameters
cInputs (Int32)

[Missing <param name="cInputs"/> documentation for "M:VisualCron.WinAPI.SendInput(System.Int32,VisualCron.INPUT@,System.Int32)"]

pInputs ( INPUT %)

[Missing <param name="pInputs"/> documentation for "M:VisualCron.WinAPI.SendInput(System.Int32,VisualCron.INPUT@,System.Int32)"]

cbSize (Int32)

[Missing <param name="cbSize"/> documentation for "M:VisualCron.WinAPI.SendInput(System.Int32,VisualCron.INPUT@,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SendInput(System.Int32,VisualCron.INPUT@,System.Int32)]


SendMessage Method (hWnd, msg, wParam, lParam)

SendMessage Method (hWnd, msg, wParam, lParam)
Namespaces ► VisualCron ► WinAPI ► SendMessage(HandleRef, Int32, Boolean, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SendMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.Boolean,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SendMessage(
    HandleRef hWnd,
    int msg,
    bool wParam,
    int lParam
)
Public Shared Function SendMessage ( _
    hWnd As HandleRef, _
    msg As Integer, _
    wParam As Boolean, _
    lParam As Integer _
) As IntPtr
public:
static IntPtr SendMessage(
    HandleRef hWnd,
    int msg,
    bool wParam,
    int lParam
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SendMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.Boolean,System.Int32)"]

msg (Int32)

[Missing <param name="msg"/> documentation for "M:VisualCron.WinAPI.SendMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.Boolean,System.Int32)"]

wParam (Boolean)

[Missing <param name="wParam"/> documentation for "M:VisualCron.WinAPI.SendMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.Boolean,System.Int32)"]

lParam (Int32)

[Missing <param name="lParam"/> documentation for "M:VisualCron.WinAPI.SendMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.Boolean,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SendMessage(System.Runtime.InteropServices.HandleRef,System.Int32,System.Boolean,System.Int32)]


SetActiveWindow Method (hWnd)

SetActiveWindow Method (hWnd)
Namespaces ► VisualCron ► WinAPI ► SetActiveWindow(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetActiveWindow(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SetActiveWindow(
    HandleRef hWnd
)
Public Shared Function SetActiveWindow ( _
    hWnd As HandleRef _
) As IntPtr
public:
static IntPtr SetActiveWindow(
    HandleRef hWnd
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SetActiveWindow(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetActiveWindow(System.Runtime.InteropServices.HandleRef)]


SetCapture Method (hwnd)

SetCapture Method (hwnd)
Namespaces ► VisualCron ► WinAPI ► SetCapture(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetCapture(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SetCapture(
    HandleRef hwnd
)
Public Shared Function SetCapture ( _
    hwnd As HandleRef _
) As IntPtr
public:
static IntPtr SetCapture(
    HandleRef hwnd
)
Parameters
hwnd (HandleRef)

[Missing <param name="hwnd"/> documentation for "M:VisualCron.WinAPI.SetCapture(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetCapture(System.Runtime.InteropServices.HandleRef)]


SetCursor Method (hcursor)

SetCursor Method (hcursor)
Namespaces ► VisualCron ► WinAPI ► SetCursor(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetCursor(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SetCursor(
    HandleRef hcursor
)
Public Shared Function SetCursor ( _
    hcursor As HandleRef _
) As IntPtr
public:
static IntPtr SetCursor(
    HandleRef hcursor
)
Parameters
hcursor (HandleRef)

[Missing <param name="hcursor"/> documentation for "M:VisualCron.WinAPI.SetCursor(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetCursor(System.Runtime.InteropServices.HandleRef)]


SetCursorPos Method (x, y)

SetCursorPos Method (x, y)
Namespaces ► VisualCron ► WinAPI ► SetCursorPos(Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetCursorPos(System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool SetCursorPos(
    int x,
    int y
)
Public Shared Function SetCursorPos ( _
    x As Integer, _
    y As Integer _
) As Boolean
public:
static bool SetCursorPos(
    int x,
    int y
)
Parameters
x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.WinAPI.SetCursorPos(System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.WinAPI.SetCursorPos(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetCursorPos(System.Int32,System.Int32)]


SetForegroundWindow Method (hWnd)

SetForegroundWindow Method (hWnd)
Namespaces ► VisualCron ► WinAPI ► SetForegroundWindow(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetForegroundWindow(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool SetForegroundWindow(
    HandleRef hWnd
)
Public Shared Function SetForegroundWindow ( _
    hWnd As HandleRef _
) As Boolean
public:
static bool SetForegroundWindow(
    HandleRef hWnd
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SetForegroundWindow(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetForegroundWindow(System.Runtime.InteropServices.HandleRef)]


SetKeyboardState Method (keystate)

SetKeyboardState Method (keystate)
Namespaces ► VisualCron ► WinAPI ► SetKeyboardState(array<Byte>[]()[])

[Missing <summary> documentation for M:VisualCron.WinAPI.SetKeyboardState(System.Byte[])]

Declaration Syntax
C# Visual Basic Visual C++
public static int SetKeyboardState(
    byte[] keystate
)
Public Shared Function SetKeyboardState ( _
    keystate As Byte() _
) As Integer
public:
static int SetKeyboardState(
    array<unsigned char>^ keystate
)
Parameters
keystate (array< Byte >[]()[])

[Missing <param name="keystate"/> documentation for "M:VisualCron.WinAPI.SetKeyboardState(System.Byte[])"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetKeyboardState(System.Byte[])]


SetROP2 Method (hDC, nDrawMode)

SetROP2 Method (hDC, nDrawMode)
Namespaces ► VisualCron ► WinAPI ► SetROP2(HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetROP2(System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int SetROP2(
    HandleRef hDC,
    int nDrawMode
)
Public Shared Function SetROP2 ( _
    hDC As HandleRef, _
    nDrawMode As Integer _
) As Integer
public:
static int SetROP2(
    HandleRef hDC,
    int nDrawMode
)
Parameters
hDC (HandleRef)

[Missing <param name="hDC"/> documentation for "M:VisualCron.WinAPI.SetROP2(System.Runtime.InteropServices.HandleRef,System.Int32)"]

nDrawMode (Int32)

[Missing <param name="nDrawMode"/> documentation for "M:VisualCron.WinAPI.SetROP2(System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetROP2(System.Runtime.InteropServices.HandleRef,System.Int32)]


SetWindowLong Method (hWnd, nIndex, dwNewLong)

SetWindowLong Method (hWnd, nIndex, dwNewLong)
Namespaces ► VisualCron ► WinAPI ► SetWindowLong(HandleRef, Int32, HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SetWindowLong(
    HandleRef hWnd,
    int nIndex,
    HandleRef dwNewLong
)
Public Shared Function SetWindowLong ( _
    hWnd As HandleRef, _
    nIndex As Integer, _
    dwNewLong As HandleRef _
) As IntPtr
public:
static IntPtr SetWindowLong(
    HandleRef hWnd,
    int nIndex,
    HandleRef dwNewLong
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

nIndex (Int32)

[Missing <param name="nIndex"/> documentation for "M:VisualCron.WinAPI.SetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

dwNewLong (HandleRef)

[Missing <param name="dwNewLong"/> documentation for "M:VisualCron.WinAPI.SetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetWindowLong(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)]


SetWindowLongPtr32 Method (hWnd, nIndex, dwNewLong)

SetWindowLongPtr32 Method (hWnd, nIndex, dwNewLong)
Namespaces ► VisualCron ► WinAPI ► SetWindowLongPtr32(HandleRef, Int32, HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetWindowLongPtr32(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SetWindowLongPtr32(
    HandleRef hWnd,
    int nIndex,
    HandleRef dwNewLong
)
Public Shared Function SetWindowLongPtr32 ( _
    hWnd As HandleRef, _
    nIndex As Integer, _
    dwNewLong As HandleRef _
) As IntPtr
public:
static IntPtr SetWindowLongPtr32(
    HandleRef hWnd,
    int nIndex,
    HandleRef dwNewLong
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SetWindowLongPtr32(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

nIndex (Int32)

[Missing <param name="nIndex"/> documentation for "M:VisualCron.WinAPI.SetWindowLongPtr32(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

dwNewLong (HandleRef)

[Missing <param name="dwNewLong"/> documentation for "M:VisualCron.WinAPI.SetWindowLongPtr32(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetWindowLongPtr32(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)]


SetWindowLongPtr64 Method (hWnd, nIndex, dwNewLong)

SetWindowLongPtr64 Method (hWnd, nIndex, dwNewLong)
Namespaces ► VisualCron ► WinAPI ► SetWindowLongPtr64(HandleRef, Int32, HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SetWindowLongPtr64(
    HandleRef hWnd,
    int nIndex,
    HandleRef dwNewLong
)
Public Shared Function SetWindowLongPtr64 ( _
    hWnd As HandleRef, _
    nIndex As Integer, _
    dwNewLong As HandleRef _
) As IntPtr
public:
static IntPtr SetWindowLongPtr64(
    HandleRef hWnd,
    int nIndex,
    HandleRef dwNewLong
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

nIndex (Int32)

[Missing <param name="nIndex"/> documentation for "M:VisualCron.WinAPI.SetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

dwNewLong (HandleRef)

[Missing <param name="dwNewLong"/> documentation for "M:VisualCron.WinAPI.SetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetWindowLongPtr64(System.Runtime.InteropServices.HandleRef,System.Int32,System.Runtime.InteropServices.HandleRef)]


SetWindowPlacement Method (hWnd, lpwndpl)

SetWindowPlacement Method (hWnd, lpwndpl)
Namespaces ► VisualCron ► WinAPI ► SetWindowPlacement(IntPtr, WINDOWPLACEMENT%)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)]

Declaration Syntax
C# Visual Basic Visual C++
public static int SetWindowPlacement(
    IntPtr hWnd,
    ref WINDOWPLACEMENT lpwndpl
)
Public Shared Function SetWindowPlacement ( _
    hWnd As IntPtr, _
    ByRef lpwndpl As WINDOWPLACEMENT _
) As Integer
public:
static int SetWindowPlacement(
    IntPtr hWnd,
    WINDOWPLACEMENT% lpwndpl
)
Parameters
hWnd (IntPtr)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)"]

lpwndpl ( WINDOWPLACEMENT %)

[Missing <param name="lpwndpl"/> documentation for "M:VisualCron.WinAPI.SetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetWindowPlacement(System.IntPtr,VisualCron.WINDOWPLACEMENT@)]


SetWindowPos Method (hWnd, hWndInsertAfter, x, y, cx, cy, flags)

SetWindowPos Method (hWnd, hWndInsertAfter, x, y, cx, cy, flags)
Namespaces ► VisualCron ► WinAPI ► SetWindowPos(HandleRef, HandleRef, Int32, Int32, Int32, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool SetWindowPos(
    HandleRef hWnd,
    HandleRef hWndInsertAfter,
    int x,
    int y,
    int cx,
    int cy,
    int flags
)
Public Shared Function SetWindowPos ( _
    hWnd As HandleRef, _
    hWndInsertAfter As HandleRef, _
    x As Integer, _
    y As Integer, _
    cx As Integer, _
    cy As Integer, _
    flags As Integer _
) As Boolean
public:
static bool SetWindowPos(
    HandleRef hWnd,
    HandleRef hWndInsertAfter,
    int x,
    int y,
    int cx,
    int cy,
    int flags
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

hWndInsertAfter (HandleRef)

[Missing <param name="hWndInsertAfter"/> documentation for "M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

x (Int32)

[Missing <param name="x"/> documentation for "M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

y (Int32)

[Missing <param name="y"/> documentation for "M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

cx (Int32)

[Missing <param name="cx"/> documentation for "M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

cy (Int32)

[Missing <param name="cy"/> documentation for "M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

flags (Int32)

[Missing <param name="flags"/> documentation for "M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetWindowPos(System.Runtime.InteropServices.HandleRef,System.Runtime.InteropServices.HandleRef,System.Int32,System.Int32,System.Int32,System.Int32,System.Int32)]


SetWindowsHookEx Method (hookid, pfnhook, hinst, threadid)

SetWindowsHookEx Method (hookid, pfnhook, hinst, threadid)
Namespaces ► VisualCron ► WinAPI ► SetWindowsHookEx(Int32, WinAPI..::.HookProc, HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SetWindowsHookEx(System.Int32,VisualCron.WinAPI.HookProc,System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr SetWindowsHookEx(
    int hookid,
    WinAPI..::.HookProc pfnhook,
    HandleRef hinst,
    int threadid
)
Public Shared Function SetWindowsHookEx ( _
    hookid As Integer, _
    pfnhook As WinAPI..::.HookProc, _
    hinst As HandleRef, _
    threadid As Integer _
) As IntPtr
public:
static IntPtr SetWindowsHookEx(
    int hookid,
    WinAPI..::.HookProc^ pfnhook,
    HandleRef hinst,
    int threadid
)
Parameters
hookid (Int32)

[Missing <param name="hookid"/> documentation for "M:VisualCron.WinAPI.SetWindowsHookEx(System.Int32,VisualCron.WinAPI.HookProc,System.Runtime.InteropServices.HandleRef,System.Int32)"]

pfnhook (WinAPI..::.HookProc)

[Missing <param name="pfnhook"/> documentation for "M:VisualCron.WinAPI.SetWindowsHookEx(System.Int32,VisualCron.WinAPI.HookProc,System.Runtime.InteropServices.HandleRef,System.Int32)"]

hinst (HandleRef)

[Missing <param name="hinst"/> documentation for "M:VisualCron.WinAPI.SetWindowsHookEx(System.Int32,VisualCron.WinAPI.HookProc,System.Runtime.InteropServices.HandleRef,System.Int32)"]

threadid (Int32)

[Missing <param name="threadid"/> documentation for "M:VisualCron.WinAPI.SetWindowsHookEx(System.Int32,VisualCron.WinAPI.HookProc,System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SetWindowsHookEx(System.Int32,VisualCron.WinAPI.HookProc,System.Runtime.InteropServices.HandleRef,System.Int32)]


ShowWindow Method (hWnd, nCmdShow)

ShowWindow Method (hWnd, nCmdShow)
Namespaces ► VisualCron ► WinAPI ► ShowWindow(HandleRef, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.ShowWindow(System.Runtime.InteropServices.HandleRef,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool ShowWindow(
    HandleRef hWnd,
    int nCmdShow
)
Public Shared Function ShowWindow ( _
    hWnd As HandleRef, _
    nCmdShow As Integer _
) As Boolean
public:
static bool ShowWindow(
    HandleRef hWnd,
    int nCmdShow
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.ShowWindow(System.Runtime.InteropServices.HandleRef,System.Int32)"]

nCmdShow (Int32)

[Missing <param name="nCmdShow"/> documentation for "M:VisualCron.WinAPI.ShowWindow(System.Runtime.InteropServices.HandleRef,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.ShowWindow(System.Runtime.InteropServices.HandleRef,System.Int32)]


SignedHIWORD Method

SignedHIWORD Method
Namespaces ► VisualCron ► WinAPI ► SignedHIWORD()()()
Members
Icon | Member | Description
 | SignedHIWORD(IntPtr) |
 | SignedHIWORD(Int32) |


SignedHIWORD Method (n)

SignedHIWORD Method (n)
Namespaces ► VisualCron ► WinAPI ► SignedHIWORD(Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SignedHIWORD(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int SignedHIWORD(
    int n
)
Public Shared Function SignedHIWORD ( _
    n As Integer _
) As Integer
public:
static int SignedHIWORD(
    int n
)
Parameters
n (Int32)

[Missing <param name="n"/> documentation for "M:VisualCron.WinAPI.SignedHIWORD(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SignedHIWORD(System.Int32)]


SignedHIWORD Method (n)

SignedHIWORD Method (n)
Namespaces ► VisualCron ► WinAPI ► SignedHIWORD(IntPtr)

[Missing <summary> documentation for M:VisualCron.WinAPI.SignedHIWORD(System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static int SignedHIWORD(
    IntPtr n
)
Public Shared Function SignedHIWORD ( _
    n As IntPtr _
) As Integer
public:
static int SignedHIWORD(
    IntPtr n
)
Parameters
n (IntPtr)

[Missing <param name="n"/> documentation for "M:VisualCron.WinAPI.SignedHIWORD(System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SignedHIWORD(System.IntPtr)]


SignedLOWORD Method

SignedLOWORD Method
Namespaces ► VisualCron ► WinAPI ► SignedLOWORD()()()
Members
Icon | Member | Description
 | SignedLOWORD(IntPtr) |
 | SignedLOWORD(Int32) |


SignedLOWORD Method (n)

SignedLOWORD Method (n)
Namespaces ► VisualCron ► WinAPI ► SignedLOWORD(Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.SignedLOWORD(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int SignedLOWORD(
    int n
)
Public Shared Function SignedLOWORD ( _
    n As Integer _
) As Integer
public:
static int SignedLOWORD(
    int n
)
Parameters
n (Int32)

[Missing <param name="n"/> documentation for "M:VisualCron.WinAPI.SignedLOWORD(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SignedLOWORD(System.Int32)]


SignedLOWORD Method (n)

SignedLOWORD Method (n)
Namespaces ► VisualCron ► WinAPI ► SignedLOWORD(IntPtr)

[Missing <summary> documentation for M:VisualCron.WinAPI.SignedLOWORD(System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static int SignedLOWORD(
    IntPtr n
)
Public Shared Function SignedLOWORD ( _
    n As IntPtr _
) As Integer
public:
static int SignedLOWORD(
    IntPtr n
)
Parameters
n (IntPtr)

[Missing <param name="n"/> documentation for "M:VisualCron.WinAPI.SignedLOWORD(System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.SignedLOWORD(System.IntPtr)]


SW_SHOWNOACTIVATE Field

SW_SHOWNOACTIVATE Field
Namespaces ► VisualCron ► WinAPI ► SW_SHOWNOACTIVATE

[Missing <summary> documentation for F:VisualCron.WinAPI.SW_SHOWNOACTIVATE]

Declaration Syntax
C# Visual Basic Visual C++
public const int SW_SHOWNOACTIVATE
Public Const SW_SHOWNOACTIVATE As Integer
public:
literal int SW_SHOWNOACTIVATE


ToAscii Method (uVirtKey, uScanCode, lpKeyState, lpwTransKey, uFlags)

ToAscii Method (uVirtKey, uScanCode, lpKeyState, lpwTransKey, uFlags)
Namespaces ► VisualCron ► WinAPI ► ToAscii(Int32, Int32, array<Byte>[]()[], Int16%, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.ToAscii(System.Int32,System.Int32,System.Byte[],System.Int16@,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int ToAscii(
    int uVirtKey,
    int uScanCode,
    byte[] lpKeyState,
    ref short lpwTransKey,
    int uFlags
)
Public Shared Function ToAscii ( _
    uVirtKey As Integer, _
    uScanCode As Integer, _
    lpKeyState As Byte(), _
    ByRef lpwTransKey As Short, _
    uFlags As Integer _
) As Integer
public:
static int ToAscii(
    int uVirtKey,
    int uScanCode,
    array<unsigned char>^ lpKeyState,
    short% lpwTransKey,
    int uFlags
)
Parameters
uVirtKey (Int32)

[Missing <param name="uVirtKey"/> documentation for "M:VisualCron.WinAPI.ToAscii(System.Int32,System.Int32,System.Byte[],System.Int16@,System.Int32)"]

uScanCode (Int32)

[Missing <param name="uScanCode"/> documentation for "M:VisualCron.WinAPI.ToAscii(System.Int32,System.Int32,System.Byte[],System.Int16@,System.Int32)"]

lpKeyState (array< Byte >[]()[])

[Missing <param name="lpKeyState"/> documentation for "M:VisualCron.WinAPI.ToAscii(System.Int32,System.Int32,System.Byte[],System.Int16@,System.Int32)"]

lpwTransKey ( Int16 %)

[Missing <param name="lpwTransKey"/> documentation for "M:VisualCron.WinAPI.ToAscii(System.Int32,System.Int32,System.Byte[],System.Int16@,System.Int32)"]

uFlags (Int32)

[Missing <param name="uFlags"/> documentation for "M:VisualCron.WinAPI.ToAscii(System.Int32,System.Int32,System.Byte[],System.Int16@,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.ToAscii(System.Int32,System.Int32,System.Byte[],System.Int16@,System.Int32)]


ToUnicode Method (wVirtKey, wScanCode, lpKeyState, pwszBuff, cchBuff, wFlags)

ToUnicode Method (wVirtKey, wScanCode, lpKeyState, pwszBuff, cchBuff, wFlags)
Namespaces ► VisualCron ► WinAPI ► ToUnicode(Int32, Int32, array<Byte>[]()[], StringBuilder, Int32, Int32)

[Missing <summary> documentation for M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static int ToUnicode(
    int wVirtKey,
    int wScanCode,
    byte[] lpKeyState,
    StringBuilder pwszBuff,
    int cchBuff,
    int wFlags
)
Public Shared Function ToUnicode ( _
    wVirtKey As Integer, _
    wScanCode As Integer, _
    lpKeyState As Byte(), _
    <OutAttribute> pwszBuff As StringBuilder, _
    cchBuff As Integer, _
    wFlags As Integer _
) As Integer
public:
static int ToUnicode(
    int wVirtKey,
    int wScanCode,
    array<unsigned char>^ lpKeyState,
    [OutAttribute] StringBuilder^ pwszBuff,
    int cchBuff,
    int wFlags
)
Parameters
wVirtKey (Int32)

[Missing <param name="wVirtKey"/> documentation for "M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)"]

wScanCode (Int32)

[Missing <param name="wScanCode"/> documentation for "M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)"]

lpKeyState (array< Byte >[]()[])

[Missing <param name="lpKeyState"/> documentation for "M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)"]

pwszBuff (StringBuilder)

[Missing <param name="pwszBuff"/> documentation for "M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)"]

cchBuff (Int32)

[Missing <param name="cchBuff"/> documentation for "M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)"]

wFlags (Int32)

[Missing <param name="wFlags"/> documentation for "M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.ToUnicode(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32)]


ToUnicodeEx Method (wVirtKey, wScanCode, lpKeyState, pwszBuff, cchBuff, wFlags, dwhkl)

ToUnicodeEx Method (wVirtKey, wScanCode, lpKeyState, pwszBuff, cchBuff, wFlags, dwhkl)
Namespaces ► VisualCron ► WinAPI ► ToUnicodeEx(Int32, Int32, array<Byte>[]()[], StringBuilder, Int32, Int32, IntPtr)

[Missing <summary> documentation for M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static int ToUnicodeEx(
    int wVirtKey,
    int wScanCode,
    byte[] lpKeyState,
    StringBuilder pwszBuff,
    int cchBuff,
    int wFlags,
    IntPtr dwhkl
)
Public Shared Function ToUnicodeEx ( _
    wVirtKey As Integer, _
    wScanCode As Integer, _
    lpKeyState As Byte(), _
    <OutAttribute> pwszBuff As StringBuilder, _
    cchBuff As Integer, _
    wFlags As Integer, _
    dwhkl As IntPtr _
) As Integer
public:
static int ToUnicodeEx(
    int wVirtKey,
    int wScanCode,
    array<unsigned char>^ lpKeyState,
    [OutAttribute] StringBuilder^ pwszBuff,
    int cchBuff,
    int wFlags,
    IntPtr dwhkl
)
Parameters
wVirtKey (Int32)

[Missing <param name="wVirtKey"/> documentation for "M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)"]

wScanCode (Int32)

[Missing <param name="wScanCode"/> documentation for "M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)"]

lpKeyState (array< Byte >[]()[])

[Missing <param name="lpKeyState"/> documentation for "M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)"]

pwszBuff (StringBuilder)

[Missing <param name="pwszBuff"/> documentation for "M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)"]

cchBuff (Int32)

[Missing <param name="cchBuff"/> documentation for "M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)"]

wFlags (Int32)

[Missing <param name="wFlags"/> documentation for "M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)"]

dwhkl (IntPtr)

[Missing <param name="dwhkl"/> documentation for "M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.ToUnicodeEx(System.Int32,System.Int32,System.Byte[],System.Text.StringBuilder,System.Int32,System.Int32,System.IntPtr)]


UnhookWindowsHookEx Method (hhook)

UnhookWindowsHookEx Method (hhook)
Namespaces ► VisualCron ► WinAPI ► UnhookWindowsHookEx(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.UnhookWindowsHookEx(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool UnhookWindowsHookEx(
    HandleRef hhook
)
Public Shared Function UnhookWindowsHookEx ( _
    hhook As HandleRef _
) As Boolean
public:
static bool UnhookWindowsHookEx(
    HandleRef hhook
)
Parameters
hhook (HandleRef)

[Missing <param name="hhook"/> documentation for "M:VisualCron.WinAPI.UnhookWindowsHookEx(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.UnhookWindowsHookEx(System.Runtime.InteropServices.HandleRef)]


UpdateWindow Method (hWnd)

UpdateWindow Method (hWnd)
Namespaces ► VisualCron ► WinAPI ► UpdateWindow(HandleRef)

[Missing <summary> documentation for M:VisualCron.WinAPI.UpdateWindow(System.Runtime.InteropServices.HandleRef)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool UpdateWindow(
    HandleRef hWnd
)
Public Shared Function UpdateWindow ( _
    hWnd As HandleRef _
) As Boolean
public:
static bool UpdateWindow(
    HandleRef hWnd
)
Parameters
hWnd (HandleRef)

[Missing <param name="hWnd"/> documentation for "M:VisualCron.WinAPI.UpdateWindow(System.Runtime.InteropServices.HandleRef)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.UpdateWindow(System.Runtime.InteropServices.HandleRef)]


WH_JOURNALPLAYBACK Field

WH_JOURNALPLAYBACK Field
Namespaces ► VisualCron ► WinAPI ► WH_JOURNALPLAYBACK

[Missing <summary> documentation for F:VisualCron.WinAPI.WH_JOURNALPLAYBACK]

Declaration Syntax
C# Visual Basic Visual C++
public const int WH_JOURNALPLAYBACK
Public Const WH_JOURNALPLAYBACK As Integer
public:
literal int WH_JOURNALPLAYBACK


WH_JOURNALRECORD Field

WH_JOURNALRECORD Field
Namespaces ► VisualCron ► WinAPI ► WH_JOURNALRECORD

[Missing <summary> documentation for F:VisualCron.WinAPI.WH_JOURNALRECORD]

Declaration Syntax
C# Visual Basic Visual C++
public const int WH_JOURNALRECORD
Public Const WH_JOURNALRECORD As Integer
public:
literal int WH_JOURNALRECORD


WH_KEYBOARD_LL Field

WH_KEYBOARD_LL Field
Namespaces ► VisualCron ► WinAPI ► WH_KEYBOARD_LL

[Missing <summary> documentation for F:VisualCron.WinAPI.WH_KEYBOARD_LL]

Declaration Syntax
C# Visual Basic Visual C++
public const int WH_KEYBOARD_LL
Public Const WH_KEYBOARD_LL As Integer
public:
literal int WH_KEYBOARD_LL


WH_MOUSE Field

WH_MOUSE Field
Namespaces ► VisualCron ► WinAPI ► WH_MOUSE

[Missing <summary> documentation for F:VisualCron.WinAPI.WH_MOUSE]

Declaration Syntax
C# Visual Basic Visual C++
public const int WH_MOUSE
Public Const WH_MOUSE As Integer
public:
literal int WH_MOUSE


WH_MOUSE_LL Field

WH_MOUSE_LL Field
Namespaces ► VisualCron ► WinAPI ► WH_MOUSE_LL

[Missing <summary> documentation for F:VisualCron.WinAPI.WH_MOUSE_LL]

Declaration Syntax
C# Visual Basic Visual C++
public const int WH_MOUSE_LL
Public Const WH_MOUSE_LL As Integer
public:
literal int WH_MOUSE_LL


WindowFromPoint Method (pt)

WindowFromPoint Method (pt)
Namespaces ► VisualCron ► WinAPI ► WindowFromPoint(POINTSTRUCT)

[Missing <summary> documentation for M:VisualCron.WinAPI.WindowFromPoint(VisualCron.POINTSTRUCT)]

Declaration Syntax
C# Visual Basic Visual C++
public static IntPtr WindowFromPoint(
    POINTSTRUCT pt
)
Public Shared Function WindowFromPoint ( _
    pt As POINTSTRUCT _
) As IntPtr
public:
static IntPtr WindowFromPoint(
    POINTSTRUCT pt
)
Parameters
pt (POINTSTRUCT)

[Missing <param name="pt"/> documentation for "M:VisualCron.WinAPI.WindowFromPoint(VisualCron.POINTSTRUCT)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.WindowFromPoint(VisualCron.POINTSTRUCT)]


VK_CONTROL Field

VK_CONTROL Field
Namespaces ► VisualCron ► WinAPI ► VK_CONTROL

[Missing <summary> documentation for F:VisualCron.WinAPI.VK_CONTROL]

Declaration Syntax
C# Visual Basic Visual C++
public const int VK_CONTROL
Public Const VK_CONTROL As Integer
public:
literal int VK_CONTROL


VK_LWIN Field

VK_LWIN Field
Namespaces ► VisualCron ► WinAPI ► VK_LWIN

[Missing <summary> documentation for F:VisualCron.WinAPI.VK_LWIN]

Declaration Syntax
C# Visual Basic Visual C++
public const int VK_LWIN
Public Const VK_LWIN As Integer
public:
literal int VK_LWIN


VK_MENU Field

VK_MENU Field
Namespaces ► VisualCron ► WinAPI ► VK_MENU

[Missing <summary> documentation for F:VisualCron.WinAPI.VK_MENU]

Declaration Syntax
C# Visual Basic Visual C++
public const int VK_MENU
Public Const VK_MENU As Integer
public:
literal int VK_MENU


VK_RWIN Field

VK_RWIN Field
Namespaces ► VisualCron ► WinAPI ► VK_RWIN

[Missing <summary> documentation for F:VisualCron.WinAPI.VK_RWIN]

Declaration Syntax
C# Visual Basic Visual C++
public const int VK_RWIN
Public Const VK_RWIN As Integer
public:
literal int VK_RWIN


VK_SHIFT Field

VK_SHIFT Field
Namespaces ► VisualCron ► WinAPI ► VK_SHIFT

[Missing <summary> documentation for F:VisualCron.WinAPI.VK_SHIFT]

Declaration Syntax
C# Visual Basic Visual C++
public const int VK_SHIFT
Public Const VK_SHIFT As Integer
public:
literal int VK_SHIFT


VkKeyScan Method (key)

VkKeyScan Method (key)
Namespaces ► VisualCron ► WinAPI ► VkKeyScan(Char)

[Missing <summary> documentation for M:VisualCron.WinAPI.VkKeyScan(System.Char)]

Declaration Syntax
C# Visual Basic Visual C++
public static short VkKeyScan(
    char key
)
Public Shared Function VkKeyScan ( _
    key As Char _
) As Short
public:
static short VkKeyScan(
    wchar_t key
)
Parameters
key (Char)

[Missing <param name="key"/> documentation for "M:VisualCron.WinAPI.VkKeyScan(System.Char)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WinAPI.VkKeyScan(System.Char)]


WM_CHAR Field

WM_CHAR Field
Namespaces ► VisualCron ► WinAPI ► WM_CHAR

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_CHAR]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_CHAR
Public Const WM_CHAR As Integer
public:
literal int WM_CHAR


WM_KEYDOWN Field

WM_KEYDOWN Field
Namespaces ► VisualCron ► WinAPI ► WM_KEYDOWN

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_KEYDOWN]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_KEYDOWN
Public Const WM_KEYDOWN As Integer
public:
literal int WM_KEYDOWN


WM_KEYUP Field

WM_KEYUP Field
Namespaces ► VisualCron ► WinAPI ► WM_KEYUP

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_KEYUP]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_KEYUP
Public Const WM_KEYUP As Integer
public:
literal int WM_KEYUP


WM_LBUTTONDBLCLK Field

WM_LBUTTONDBLCLK Field
Namespaces ► VisualCron ► WinAPI ► WM_LBUTTONDBLCLK
Left button double click
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_LBUTTONDBLCLK
Public Const WM_LBUTTONDBLCLK As Integer
public:
literal int WM_LBUTTONDBLCLK
Remarks

Send comments on this topic to Please email feedback to Support


WM_LBUTTONDOWN Field

WM_LBUTTONDOWN Field
Namespaces ► VisualCron ► WinAPI ► WM_LBUTTONDOWN
Left button down
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_LBUTTONDOWN
Public Const WM_LBUTTONDOWN As Integer
public:
literal int WM_LBUTTONDOWN
Remarks

Send comments on this topic to Please email feedback to Support


WM_LBUTTONUP Field

WM_LBUTTONUP Field
Namespaces ► VisualCron ► WinAPI ► WM_LBUTTONUP
Left button up
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_LBUTTONUP
Public Const WM_LBUTTONUP As Integer
public:
literal int WM_LBUTTONUP
Remarks

Send comments on this topic to Please email feedback to Support


WM_MBUTTONDBLCLK Field

WM_MBUTTONDBLCLK Field
Namespaces ► VisualCron ► WinAPI ► WM_MBUTTONDBLCLK
Middle button double click
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_MBUTTONDBLCLK
Public Const WM_MBUTTONDBLCLK As Integer
public:
literal int WM_MBUTTONDBLCLK
Remarks

Send comments on this topic to Please email feedback to Support


WM_MBUTTONDOWN Field

WM_MBUTTONDOWN Field
Namespaces ► VisualCron ► WinAPI ► WM_MBUTTONDOWN
Middle button down
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_MBUTTONDOWN
Public Const WM_MBUTTONDOWN As Integer
public:
literal int WM_MBUTTONDOWN
Remarks

Send comments on this topic to Please email feedback to Support


WM_MBUTTONUP Field

WM_MBUTTONUP Field
Namespaces ► VisualCron ► WinAPI ► WM_MBUTTONUP
Middle button up
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_MBUTTONUP
Public Const WM_MBUTTONUP As Integer
public:
literal int WM_MBUTTONUP
Remarks

Send comments on this topic to Please email feedback to Support


WM_MOUSEMOVE Field

WM_MOUSEMOVE Field
Namespaces ► VisualCron ► WinAPI ► WM_MOUSEMOVE
Mouse move
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_MOUSEMOVE
Public Const WM_MOUSEMOVE As Integer
public:
literal int WM_MOUSEMOVE
Remarks

Send comments on this topic to Please email feedback to Support


WM_MOUSEWHEEL Field

WM_MOUSEWHEEL Field
Namespaces ► VisualCron ► WinAPI ► WM_MOUSEWHEEL

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_MOUSEWHEEL]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_MOUSEWHEEL
Public Const WM_MOUSEWHEEL As Integer
public:
literal int WM_MOUSEWHEEL


WM_NCLBUTTONDOWN Field

WM_NCLBUTTONDOWN Field
Namespaces ► VisualCron ► WinAPI ► WM_NCLBUTTONDOWN

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_NCLBUTTONDOWN]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_NCLBUTTONDOWN
Public Const WM_NCLBUTTONDOWN As Integer
public:
literal int WM_NCLBUTTONDOWN


WM_NCMOUSEMOVE Field

WM_NCMOUSEMOVE Field
Namespaces ► VisualCron ► WinAPI ► WM_NCMOUSEMOVE

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_NCMOUSEMOVE]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_NCMOUSEMOVE
Public Const WM_NCMOUSEMOVE As Integer
public:
literal int WM_NCMOUSEMOVE


WM_RBUTTONDBLCLK Field

WM_RBUTTONDBLCLK Field
Namespaces ► VisualCron ► WinAPI ► WM_RBUTTONDBLCLK
Right button double click
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_RBUTTONDBLCLK
Public Const WM_RBUTTONDBLCLK As Integer
public:
literal int WM_RBUTTONDBLCLK
Remarks

Send comments on this topic to Please email feedback to Support


WM_RBUTTONDOWN Field

WM_RBUTTONDOWN Field
Namespaces ► VisualCron ► WinAPI ► WM_RBUTTONDOWN
Right button down
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_RBUTTONDOWN
Public Const WM_RBUTTONDOWN As Integer
public:
literal int WM_RBUTTONDOWN
Remarks

Send comments on this topic to Please email feedback to Support


WM_RBUTTONUP Field

WM_RBUTTONUP Field
Namespaces ► VisualCron ► WinAPI ► WM_RBUTTONUP
Right button up
Declaration Syntax
C# Visual Basic Visual C++
public const int WM_RBUTTONUP
Public Const WM_RBUTTONUP As Integer
public:
literal int WM_RBUTTONUP
Remarks

Send comments on this topic to Please email feedback to Support


WM_SYSKEYDOWN Field

WM_SYSKEYDOWN Field
Namespaces ► VisualCron ► WinAPI ► WM_SYSKEYDOWN

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_SYSKEYDOWN]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_SYSKEYDOWN
Public Const WM_SYSKEYDOWN As Integer
public:
literal int WM_SYSKEYDOWN


WM_SYSKEYUP Field

WM_SYSKEYUP Field
Namespaces ► VisualCron ► WinAPI ► WM_SYSKEYUP

[Missing <summary> documentation for F:VisualCron.WinAPI.WM_SYSKEYUP]

Declaration Syntax
C# Visual Basic Visual C++
public const int WM_SYSKEYUP
Public Const WM_SYSKEYUP As Integer
public:
literal int WM_SYSKEYUP


WS_MAXIMIZE Field

WS_MAXIMIZE Field
Namespaces ► VisualCron ► WinAPI ► WS_MAXIMIZE

[Missing <summary> documentation for F:VisualCron.WinAPI.WS_MAXIMIZE]

Declaration Syntax
C# Visual Basic Visual C++
public const int WS_MAXIMIZE
Public Const WS_MAXIMIZE As Integer
public:
literal int WS_MAXIMIZE


WS_MINIMIZE Field

WS_MINIMIZE Field
Namespaces ► VisualCron ► WinAPI ► WS_MINIMIZE

[Missing <summary> documentation for F:VisualCron.WinAPI.WS_MINIMIZE]

Declaration Syntax
C# Visual Basic Visual C++
public const int WS_MINIMIZE
Public Const WS_MINIMIZE As Integer
public:
literal int WS_MINIMIZE


XBUTTON1 Field

XBUTTON1 Field
Namespaces ► VisualCron ► WinAPI ► XBUTTON1

[Missing <summary> documentation for F:VisualCron.WinAPI.XBUTTON1]

Declaration Syntax
C# Visual Basic Visual C++
public const int XBUTTON1
Public Const XBUTTON1 As Integer
public:
literal int XBUTTON1


XBUTTON2 Field

XBUTTON2 Field
Namespaces ► VisualCron ► WinAPI ► XBUTTON2

[Missing <summary> documentation for F:VisualCron.WinAPI.XBUTTON2]

Declaration Syntax
C# Visual Basic Visual C++
public const int XBUTTON2
Public Const XBUTTON2 As Integer
public:
literal int XBUTTON2


WinAPI.EnumThreadWindowsCallback Delegate

WinAPI..::.EnumThreadWindowsCallback Delegate
Namespaces ► VisualCron ► WinAPI ► WinAPI..::.EnumThreadWindowsCallback

[Missing <summary> documentation for T:VisualCron.WinAPI.EnumThreadWindowsCallback]

Declaration Syntax
C# Visual Basic Visual C++
public delegate bool EnumThreadWindowsCallback(
    IntPtr hWnd,
    IntPtr lParam
)
Public Delegate Function EnumThreadWindowsCallback ( _
    hWnd As IntPtr, _
    lParam As IntPtr _
) As Boolean
public delegate bool EnumThreadWindowsCallback(
    IntPtr hWnd,
    IntPtr lParam
)
Parameters
hWnd (IntPtr)
lParam (IntPtr)


WinAPI.HookProc Delegate

WinAPI..::.HookProc Delegate
Namespaces ► VisualCron ► WinAPI ► WinAPI..::.HookProc

[Missing <summary> documentation for T:VisualCron.WinAPI.HookProc]

Declaration Syntax
C# Visual Basic Visual C++
public delegate IntPtr HookProc(
    int nCode,
    IntPtr wParam,
    IntPtr lParam
)
Public Delegate Function HookProc ( _
    nCode As Integer, _
    wParam As IntPtr, _
    lParam As IntPtr _
) As IntPtr
public delegate IntPtr HookProc(
    int nCode,
    IntPtr wParam,
    IntPtr lParam
)
Parameters
nCode (Int32)
wParam (IntPtr)
lParam (IntPtr)


WindowController Class

WindowController Class
Namespaces ► VisualCron ► WindowController
Provides various functionality that manipulates a window or reads its state.
Declaration Syntax
C# Visual Basic Visual C++
public class WindowController
Public Class WindowController
public ref class WindowController
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowController(IntPtr) | Initializes a new instance of the WindowController class
 | Bounds |
 | ClassName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Title |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WindowState |
Inheritance Hierarchy
Object
WindowController

Send comments on this topic to Please email feedback to Support


WindowController Constructor (handle)

WindowController Constructor (handle)
Namespaces ► VisualCron ► WindowController ► WindowController(IntPtr)
Initializes a new instance of the WindowController class
Declaration Syntax
C# Visual Basic Visual C++
public WindowController(
    IntPtr handle
)
Public Sub New ( _
    handle As IntPtr _
)
public:
WindowController(
    IntPtr handle
)
Parameters
handle (IntPtr)

[Missing <param name="handle"/> documentation for "M:VisualCron.WindowController.#ctor(System.IntPtr)"]


Bounds Property

Bounds Property
Namespaces ► VisualCron ► WindowController ► Bounds

[Missing <summary> documentation for P:VisualCron.WindowController.Bounds]

Declaration Syntax
C# Visual Basic Visual C++
public Rectangle Bounds { get; set; }
Public Property Bounds As Rectangle
public:
property Rectangle Bounds {
    Rectangle get ();
    void set (Rectangle value);
}


ClassName Property

ClassName Property
Namespaces ► VisualCron ► WindowController ► ClassName

[Missing <summary> documentation for P:VisualCron.WindowController.ClassName]

Declaration Syntax
C# Visual Basic Visual C++
public string ClassName { get; }
Public ReadOnly Property ClassName As String
public:
property String^ ClassName {
    String^ get ();
}


Title Property

Title Property
Namespaces ► VisualCron ► WindowController ► Title

[Missing <summary> documentation for P:VisualCron.WindowController.Title]

Declaration Syntax
C# Visual Basic Visual C++
public string Title { get; }
Public ReadOnly Property Title As String
public:
property String^ Title {
    String^ get ();
}


WindowState Property

WindowState Property
Namespaces ► VisualCron ► WindowController ► WindowState

[Missing <summary> documentation for P:VisualCron.WindowController.WindowState]

Declaration Syntax
C# Visual Basic Visual C++
public FormWindowState WindowState { get; set; }
Public Property WindowState As FormWindowState
public:
property FormWindowState WindowState {
    FormWindowState get ();
    void set (FormWindowState value);
}


WindowDescriptor Class

WindowDescriptor Class
Namespaces ► VisualCron ► WindowDescriptor
Contains all the information required to find a window.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class WindowDescriptor : ICloneable
<SerializableAttribute> _
Public Class WindowDescriptor _
    Implements ICloneable
[SerializableAttribute]
public ref class WindowDescriptor : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowDescriptor()()() | Initializes a new instance of the WindowDescriptor class
 | WindowDescriptor(String) | Initializes a new instance of the WindowDescriptor class
 | WindowDescriptor(String, Boolean, Boolean) | Initializes a new instance of the WindowDescriptor class
 | CaseSensitive | Get/Sets the value indicating whether the search by the title pattern is case sensitive.
 | Clone()()() |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TitlePattern | Used when we need to search the window by title. Wildcards are allowed if the UseWildCards property value is true.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseWildcards | Get/Sets the value indicating whether wildcards are allowed in the title pattern.
Inheritance Hierarchy
Object
WindowDescriptor

Send comments on this topic to Please email feedback to Support


WindowDescriptor Constructor

WindowDescriptor Constructor
Namespaces ► VisualCron ► WindowDescriptor ► WindowDescriptor()()()
Members
Icon | Member | Description
 | WindowDescriptor()()() | Initializes a new instance of the WindowDescriptor class
 | WindowDescriptor(String) | Initializes a new instance of the WindowDescriptor class
 | WindowDescriptor(String, Boolean, Boolean) | Initializes a new instance of the WindowDescriptor class


WindowDescriptor Constructor

WindowDescriptor Constructor
Namespaces ► VisualCron ► WindowDescriptor ► WindowDescriptor()()()
Initializes a new instance of the WindowDescriptor class
Declaration Syntax
C# Visual Basic Visual C++
public WindowDescriptor()
Public Sub New
public:
WindowDescriptor()


WindowDescriptor Constructor (titlePattern)

WindowDescriptor Constructor (titlePattern)
Namespaces ► VisualCron ► WindowDescriptor ► WindowDescriptor(String)
Initializes a new instance of the WindowDescriptor class
Declaration Syntax
C# Visual Basic Visual C++
public WindowDescriptor(
    string titlePattern
)
Public Sub New ( _
    titlePattern As String _
)
public:
WindowDescriptor(
    String^ titlePattern
)
Parameters
titlePattern (String)

[Missing <param name="titlePattern"/> documentation for "M:VisualCron.WindowDescriptor.#ctor(System.String)"]


WindowDescriptor Constructor (titlePattern, useWildcards, _caseSensitive)

WindowDescriptor Constructor (titlePattern, useWildcards, _caseSensitive)
Namespaces ► VisualCron ► WindowDescriptor ► WindowDescriptor(String, Boolean, Boolean)
Initializes a new instance of the WindowDescriptor class
Declaration Syntax
C# Visual Basic Visual C++
public WindowDescriptor(
    string titlePattern,
    bool useWildcards,
    bool _caseSensitive
)
Public Sub New ( _
    titlePattern As String, _
    useWildcards As Boolean, _
    _caseSensitive As Boolean _
)
public:
WindowDescriptor(
    String^ titlePattern,
    bool useWildcards,
    bool _caseSensitive
)
Parameters
titlePattern (String)

[Missing <param name="titlePattern"/> documentation for "M:VisualCron.WindowDescriptor.#ctor(System.String,System.Boolean,System.Boolean)"]

useWildcards (Boolean)

[Missing <param name="useWildcards"/> documentation for "M:VisualCron.WindowDescriptor.#ctor(System.String,System.Boolean,System.Boolean)"]

_caseSensitive (Boolean)

[Missing <param name="_caseSensitive"/> documentation for "M:VisualCron.WindowDescriptor.#ctor(System.String,System.Boolean,System.Boolean)"]


CaseSensitive Property

CaseSensitive Property
Namespaces ► VisualCron ► WindowDescriptor ► CaseSensitive
Get/Sets the value indicating whether the search by the title pattern is case sensitive.
Declaration Syntax
C# Visual Basic Visual C++
public bool CaseSensitive { get; set; }
Public Property CaseSensitive As Boolean
public:
property bool CaseSensitive {
    bool get ();
    void set (bool value);
}


Clone Method

Clone Method
Namespaces ► VisualCron ► WindowDescriptor ► Clone()()()

[Missing <summary> documentation for M:VisualCron.WindowDescriptor.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.WindowDescriptor.Clone]


Equals Method (obj)

Equals Method (obj)
Namespaces ► VisualCron ► WindowDescriptor ► Equals(Object)

[Missing <summary> documentation for M:VisualCron.WindowDescriptor.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCron.WindowDescriptor.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WindowDescriptor.Equals(System.Object)]


GetHashCode Method

GetHashCode Method
Namespaces ► VisualCron ► WindowDescriptor ► GetHashCode()()()

[Missing <summary> documentation for M:VisualCron.WindowDescriptor.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:VisualCron.WindowDescriptor.GetHashCode]


TitlePattern Property

TitlePattern Property
Namespaces ► VisualCron ► WindowDescriptor ► TitlePattern
Used when we need to search the window by title. Wildcards are allowed if the UseWildCards property value is true.
Declaration Syntax
C# Visual Basic Visual C++
public string TitlePattern { get; set; }
Public Property TitlePattern As String
public:
property String^ TitlePattern {
    String^ get ();
    void set (String^ value);
}


UseWildcards Property

UseWildcards Property
Namespaces ► VisualCron ► WindowDescriptor ► UseWildcards
Get/Sets the value indicating whether wildcards are allowed in the title pattern.
Declaration Syntax
C# Visual Basic Visual C++
public bool UseWildcards { get; set; }
Public Property UseWildcards As Boolean
public:
property bool UseWildcards {
    bool get ();
    void set (bool value);
}


WindowNotFoundException Class

WindowNotFoundException Class
Namespaces ► VisualCron ► WindowNotFoundException

[Missing <summary> documentation for T:VisualCron.WindowNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class WindowNotFoundException : Exception
Public Class WindowNotFoundException _
    Inherits Exception
public ref class WindowNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowNotFoundException(WindowDescriptor) | Initializes a new instance of the WindowNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Descriptor |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | WindowNotFoundException


WindowNotFoundException Constructor (descriptor)

WindowNotFoundException Constructor (descriptor)
Namespaces ► VisualCron ► WindowNotFoundException ► WindowNotFoundException(WindowDescriptor)
Initializes a new instance of the WindowNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public WindowNotFoundException(
    WindowDescriptor descriptor
)
Public Sub New ( _
    descriptor As WindowDescriptor _
)
public:
WindowNotFoundException(
    WindowDescriptor^ descriptor
)
Parameters
descriptor (WindowDescriptor)

[Missing <param name="descriptor"/> documentation for "M:VisualCron.WindowNotFoundException.#ctor(VisualCron.WindowDescriptor)"]


Descriptor Property

Descriptor Property
Namespaces ► VisualCron ► WindowNotFoundException ► Descriptor

[Missing <summary> documentation for P:VisualCron.WindowNotFoundException.Descriptor]

Declaration Syntax
C# Visual Basic Visual C++
public WindowDescriptor Descriptor { get; }
Public ReadOnly Property Descriptor As WindowDescriptor
public:
property WindowDescriptor^ Descriptor {
    WindowDescriptor^ get ();
}


WINDOWPLACEMENT Structure

WINDOWPLACEMENT Structure
Namespaces ► VisualCron ► WINDOWPLACEMENT

[Missing <summary> documentation for T:VisualCron.WINDOWPLACEMENT]

Declaration Syntax
C# Visual Basic Visual C++
public struct WINDOWPLACEMENT
Public Structure WINDOWPLACEMENT
public value class WINDOWPLACEMENT
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | flags |
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Length |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ptMaxPosition |
 | ptMinPosition |
 | rcNormalPosition |
 | showCmd |
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)


flags Field

flags Field
Namespaces ► VisualCron ► WINDOWPLACEMENT ► flags

[Missing <summary> documentation for F:VisualCron.WINDOWPLACEMENT.flags]

Declaration Syntax
C# Visual Basic Visual C++
public int flags
Public flags As Integer
public:
int flags


Length Field

Length Field
Namespaces ► VisualCron ► WINDOWPLACEMENT ► Length

[Missing <summary> documentation for F:VisualCron.WINDOWPLACEMENT.Length]

Declaration Syntax
C# Visual Basic Visual C++
public int Length
Public Length As Integer
public:
int Length


ptMaxPosition Field

ptMaxPosition Field
Namespaces ► VisualCron ► WINDOWPLACEMENT ► ptMaxPosition

[Missing <summary> documentation for F:VisualCron.WINDOWPLACEMENT.ptMaxPosition]

Declaration Syntax
C# Visual Basic Visual C++
public POINT32 ptMaxPosition
Public ptMaxPosition As POINT32
public:
POINT32 ptMaxPosition

Send comments on this topic to Please email feedback to Support


ptMinPosition Field

ptMinPosition Field
Namespaces ► VisualCron ► WINDOWPLACEMENT ► ptMinPosition

[Missing <summary> documentation for F:VisualCron.WINDOWPLACEMENT.ptMinPosition]

Declaration Syntax
C# Visual Basic Visual C++
public POINT32 ptMinPosition
Public ptMinPosition As POINT32
public:
POINT32 ptMinPosition

Send comments on this topic to Please email feedback to Support


rcNormalPosition Field

rcNormalPosition Field
Namespaces ► VisualCron ► WINDOWPLACEMENT ► rcNormalPosition

[Missing <summary> documentation for F:VisualCron.WINDOWPLACEMENT.rcNormalPosition]

Declaration Syntax
C# Visual Basic Visual C++
public RECT rcNormalPosition
Public rcNormalPosition As RECT
public:
RECT rcNormalPosition

Send comments on this topic to Please email feedback to Support


showCmd Field

showCmd Field
Namespaces ► VisualCron ► WINDOWPLACEMENT ► showCmd

[Missing <summary> documentation for F:VisualCron.WINDOWPLACEMENT.showCmd]

Declaration Syntax
C# Visual Basic Visual C++
public int showCmd
Public showCmd As Integer
public:
int showCmd


WindowRestorationException Class

WindowRestorationException Class
Namespaces ► VisualCron ► WindowRestorationException

[Missing <summary> documentation for T:VisualCron.WindowRestorationException]

Declaration Syntax
C# Visual Basic Visual C++
public class WindowRestorationException : Exception
Public Class WindowRestorationException _
    Inherits Exception
public ref class WindowRestorationException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowRestorationException(WindowDescriptor) | Initializes a new instance of the WindowRestorationException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Descriptor |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | WindowRestorationException


WindowRestorationException Constructor (descriptor)

WindowRestorationException Constructor (descriptor)
Namespaces ► VisualCron ► WindowRestorationException ► WindowRestorationException(WindowDescriptor)
Initializes a new instance of the WindowRestorationException class
Declaration Syntax
C# Visual Basic Visual C++
public WindowRestorationException(
    WindowDescriptor descriptor
)
Public Sub New ( _
    descriptor As WindowDescriptor _
)
public:
WindowRestorationException(
    WindowDescriptor^ descriptor
)
Parameters
descriptor (WindowDescriptor)

[Missing <param name="descriptor"/> documentation for "M:VisualCron.WindowRestorationException.#ctor(VisualCron.WindowDescriptor)"]


Descriptor Property

Descriptor Property
Namespaces ► VisualCron ► WindowRestorationException ► Descriptor

[Missing <summary> documentation for P:VisualCron.WindowRestorationException.Descriptor]

Declaration Syntax
C# Visual Basic Visual C++
public WindowDescriptor Descriptor { get; }
Public ReadOnly Property Descriptor As WindowDescriptor
public:
property WindowDescriptor^ Descriptor {
    WindowDescriptor^ get ();
}


WindowsLocator Class

WindowsLocator Class
Namespaces ► VisualCron ► WindowsLocator
Finds windows based on the provided WindowDescriptor.
Declaration Syntax
C# Visual Basic Visual C++
public class WindowsLocator
Public Class WindowsLocator
public ref class WindowsLocator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WindowsLocator(WindowDescriptor) | Initializes a new instance of the WindowsLocator class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindAll()()() |
 | FindFirst()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WindowsLocator

Send comments on this topic to Please email feedback to Support


WindowsLocator Constructor (descriptor)

WindowsLocator Constructor (descriptor)
Namespaces ► VisualCron ► WindowsLocator ► WindowsLocator(WindowDescriptor)
Initializes a new instance of the WindowsLocator class
Declaration Syntax
C# Visual Basic Visual C++
public WindowsLocator(
    WindowDescriptor descriptor
)
Public Sub New ( _
    descriptor As WindowDescriptor _
)
public:
WindowsLocator(
    WindowDescriptor^ descriptor
)
Parameters
descriptor (WindowDescriptor)

[Missing <param name="descriptor"/> documentation for "M:VisualCron.WindowsLocator.#ctor(VisualCron.WindowDescriptor)"]


FindAll Method

FindAll Method
Namespaces ► VisualCron ► WindowsLocator ► FindAll()()()

[Missing <summary> documentation for M:VisualCron.WindowsLocator.FindAll]

Declaration Syntax
C# Visual Basic Visual C++
public List<IntPtr> FindAll()
Public Function FindAll As List(Of IntPtr)
public:
List<IntPtr>^ FindAll()
Return Value

[Missing <returns> documentation for M:VisualCron.WindowsLocator.FindAll]


FindFirst Method

FindFirst Method
Namespaces ► VisualCron ► WindowsLocator ► FindFirst()()()

[Missing <summary> documentation for M:VisualCron.WindowsLocator.FindFirst]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr FindFirst()
Public Function FindFirst As IntPtr
public:
IntPtr FindFirst()
Return Value

[Missing <returns> documentation for M:VisualCron.WindowsLocator.FindFirst]


WindowsLocatorWithMemory Class

WindowsLocatorWithMemory Class
Namespaces ► VisualCron ► WindowsLocatorWithMemory
Finds windows based on the provided WindowDescriptor the same way as WindowsLocator. Caches all search results internally so the cached window is returned on subsequent search requests.
Declaration Syntax
C# Visual Basic Visual C++
public class WindowsLocatorWithMemory
Public Class WindowsLocatorWithMemory
public ref class WindowsLocatorWithMemory
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WindowsLocatorWithMemory()()() | Initializes a new instance of the WindowsLocatorWithMemory class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindWindow(WindowDescriptor) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WindowsLocatorWithMemory

Send comments on this topic to Please email feedback to Support


WindowsLocatorWithMemory Constructor

WindowsLocatorWithMemory Constructor
Namespaces ► VisualCron ► WindowsLocatorWithMemory ► WindowsLocatorWithMemory()()()
Initializes a new instance of the WindowsLocatorWithMemory class
Declaration Syntax
C# Visual Basic Visual C++
public WindowsLocatorWithMemory()
Public Sub New
public:
WindowsLocatorWithMemory()


FindWindow Method (descriptor)

FindWindow Method (descriptor)
Namespaces ► VisualCron ► WindowsLocatorWithMemory ► FindWindow(WindowDescriptor)

[Missing <summary> documentation for M:VisualCron.WindowsLocatorWithMemory.FindWindow(VisualCron.WindowDescriptor)]

Declaration Syntax
C# Visual Basic Visual C++
public IntPtr FindWindow(
    WindowDescriptor descriptor
)
Public Function FindWindow ( _
    descriptor As WindowDescriptor _
) As IntPtr
public:
IntPtr FindWindow(
    WindowDescriptor^ descriptor
)
Parameters
descriptor (WindowDescriptor)

[Missing <param name="descriptor"/> documentation for "M:VisualCron.WindowsLocatorWithMemory.FindWindow(VisualCron.WindowDescriptor)"]

Return Value

[Missing <returns> documentation for M:VisualCron.WindowsLocatorWithMemory.FindWindow(VisualCron.WindowDescriptor)]


WindowState Class

WindowState Class
Namespaces ► VisualCron ► WindowState

[Missing <summary> documentation for T:VisualCron.WindowState]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class WindowState : ICloneable
<SerializableAttribute> _
Public Class WindowState _
    Implements ICloneable
[SerializableAttribute]
public ref class WindowState : ICloneable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowState()()() | Initializes a new instance of the WindowState class
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Location |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NormalSize |
 | State |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WindowState

Send comments on this topic to Please email feedback to Support


WindowState Constructor

WindowState Constructor
Namespaces ► VisualCron ► WindowState ► WindowState()()()
Initializes a new instance of the WindowState class
Declaration Syntax
C# Visual Basic Visual C++
public WindowState()
Public Sub New
public:
WindowState()


Clone Method

Clone Method
Namespaces ► VisualCron ► WindowState ► Clone()()()

[Missing <summary> documentation for M:VisualCron.WindowState.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public Object Clone()
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
Return Value

[Missing <returns> documentation for M:VisualCron.WindowState.Clone]


Location Property

Location Property
Namespaces ► VisualCron ► WindowState ► Location

[Missing <summary> documentation for P:VisualCron.WindowState.Location]

Declaration Syntax
C# Visual Basic Visual C++
public Point Location { get; set; }
Public Property Location As Point
public:
property Point Location {
    Point get ();
    void set (Point value);
}


NormalSize Property

NormalSize Property
Namespaces ► VisualCron ► WindowState ► NormalSize

[Missing <summary> documentation for P:VisualCron.WindowState.NormalSize]

Declaration Syntax
C# Visual Basic Visual C++
public Size NormalSize { get; set; }
Public Property NormalSize As Size
public:
property Size NormalSize {
    Size get ();
    void set (Size value);
}


State Property

State Property
Namespaces ► VisualCron ► WindowState ► State

[Missing <summary> documentation for P:VisualCron.WindowState.State]

Declaration Syntax
C# Visual Basic Visual C++
public int State { get; set; }
Public Property State As Integer
public:
property int State {
    int get ();
    void set (int value);
}


WindowTargetingCommand Class

WindowTargetingCommand Class
Namespaces ► VisualCron ► WindowTargetingCommand
Base class for all commands that target a specific window.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public abstract class WindowTargetingCommand : Command
<SerializableAttribute> _
Public MustInherit Class WindowTargetingCommand _
    Inherits Command
[SerializableAttribute]
public ref class WindowTargetingCommand abstract : public Command
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | WindowTargetingCommand()()() | Initializes a new instance of the WindowTargetingCommand class
 | Clone()()() | (Overrides Command.Clone()()().)
 | Description | (Inherited from Command.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TargetWindow |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TranslateToInstructions(InstructionsBuilder, TaskDesktopMacroClass..::.MacroSpeed) | (Inherited from Command.)
 | WindowState |
Inheritance Hierarchy
Object
 | Command
 |  | WindowTargetingCommand
 |  |  | KeyStrokes
 |  |  | MouseClick


WindowTargetingCommand Constructor

WindowTargetingCommand Constructor
Namespaces ► VisualCron ► WindowTargetingCommand ► WindowTargetingCommand()()()
Initializes a new instance of the WindowTargetingCommand class
Declaration Syntax
C# Visual Basic Visual C++
public WindowTargetingCommand()
Public Sub New
public:
WindowTargetingCommand()


Clone Method

Clone Method
Namespaces ► VisualCron ► WindowTargetingCommand ► Clone()()()

[Missing <summary> documentation for M:VisualCron.WindowTargetingCommand.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public override Object Clone()
Public Overrides Function Clone As Object
public:
virtual Object^ Clone() override
Return Value

[Missing <returns> documentation for M:VisualCron.WindowTargetingCommand.Clone]


TargetWindow Property

TargetWindow Property
Namespaces ► VisualCron ► WindowTargetingCommand ► TargetWindow

[Missing <summary> documentation for P:VisualCron.WindowTargetingCommand.TargetWindow]

Declaration Syntax
C# Visual Basic Visual C++
public WindowDescriptor TargetWindow { get; set; }
Public Property TargetWindow As WindowDescriptor
public:
property WindowDescriptor^ TargetWindow {
    WindowDescriptor^ get ();
    void set (WindowDescriptor^ value);
}


WindowState Property

WindowState Property
Namespaces ► VisualCron ► WindowTargetingCommand ► WindowState

[Missing <summary> documentation for P:VisualCron.WindowTargetingCommand.WindowState]

Declaration Syntax
C# Visual Basic Visual C++
public WindowState WindowState { get; set; }
Public Property WindowState As WindowState
public:
property WindowState^ WindowState {
    WindowState^ get ();
    void set (WindowState^ value);
}


VisualCronEventClass Class

VisualCronEventClass Class
Namespaces ► VisualCron ► VisualCronEventClass
VisualCron Event - watches internal events
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class VisualCronEventClass
<SerializableAttribute> _
Public Class VisualCronEventClass
[SerializableAttribute]
public ref class VisualCronEventClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisualCronEventClass()()() | Initializes a new instance of the VisualCronEventClass class
 | CloneType()()() | Clones the VisualCron Event
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId | Unique Id of a job
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WhenCompleted | If Completed event should be watched on the specified job
 | WhenStarted | If Started event should be watched on the specified job
Remarks
Inheritance Hierarchy
Object
VisualCronEventClass

Send comments on this topic to Please email feedback to Support


VisualCronEventClass Constructor

VisualCronEventClass Constructor
Namespaces ► VisualCron ► VisualCronEventClass ► VisualCronEventClass()()()
Initializes a new instance of the VisualCronEventClass class
Declaration Syntax
C# Visual Basic Visual C++
public VisualCronEventClass()
Public Sub New
public:
VisualCronEventClass()


CloneType Method

CloneType Method
Namespaces ► VisualCron ► VisualCronEventClass ► CloneType()()()
Clones the VisualCron Event
Declaration Syntax
C# Visual Basic Visual C++
public VisualCronEventClass CloneType()
Public Function CloneType As VisualCronEventClass
public:
VisualCronEventClass^ CloneType()
Return Value

[Missing <returns> documentation for M:VisualCron.VisualCronEventClass.CloneType]

Remarks

Send comments on this topic to Please email feedback to Support


JobId Property

JobId Property
Namespaces ► VisualCron ► VisualCronEventClass ► JobId
Unique Id of a job
Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


WhenCompleted Property

WhenCompleted Property
Namespaces ► VisualCron ► VisualCronEventClass ► WhenCompleted
If Completed event should be watched on the specified job
Declaration Syntax
C# Visual Basic Visual C++
public bool WhenCompleted { get; set; }
Public Property WhenCompleted As Boolean
public:
property bool WhenCompleted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


WhenStarted Property

WhenStarted Property
Namespaces ► VisualCron ► VisualCronEventClass ► WhenStarted
If Started event should be watched on the specified job
Declaration Syntax
C# Visual Basic Visual C++
public bool WhenStarted { get; set; }
Public Property WhenStarted As Boolean
public:
property bool WhenStarted {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


VisualCronProcessInfoClass Class

VisualCronProcessInfoClass Class
Namespaces ► VisualCron ► VisualCronProcessInfoClass

[Missing <summary> documentation for T:VisualCron.VisualCronProcessInfoClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class VisualCronProcessInfoClass
<SerializableAttribute> _
Public Class VisualCronProcessInfoClass
[SerializableAttribute]
public ref class VisualCronProcessInfoClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisualCronProcessInfoClass()()() | Initializes a new instance of the VisualCronProcessInfoClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MemoryUsed | Memory used by the VisualCron service
 | NoHandles | Number of active handles
 | NoThreads | Number of running threads
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
VisualCronProcessInfoClass

Send comments on this topic to Please email feedback to Support


VisualCronProcessInfoClass Constructor

VisualCronProcessInfoClass Constructor
Namespaces ► VisualCron ► VisualCronProcessInfoClass ► VisualCronProcessInfoClass()()()
Initializes a new instance of the VisualCronProcessInfoClass class
Declaration Syntax
C# Visual Basic Visual C++
public VisualCronProcessInfoClass()
Public Sub New
public:
VisualCronProcessInfoClass()


MemoryUsed Property

MemoryUsed Property
Namespaces ► VisualCron ► VisualCronProcessInfoClass ► MemoryUsed
Memory used by the VisualCron service
Declaration Syntax
C# Visual Basic Visual C++
public int MemoryUsed { get; set; }
Public Property MemoryUsed As Integer
public:
property int MemoryUsed {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NoHandles Property

NoHandles Property
Namespaces ► VisualCron ► VisualCronProcessInfoClass ► NoHandles
Number of active handles
Declaration Syntax
C# Visual Basic Visual C++
public int NoHandles { get; set; }
Public Property NoHandles As Integer
public:
property int NoHandles {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


NoThreads Property

NoThreads Property
Namespaces ► VisualCron ► VisualCronProcessInfoClass ► NoThreads
Number of running threads
Declaration Syntax
C# Visual Basic Visual C++
public int NoThreads { get; set; }
Public Property NoThreads As Integer
public:
property int NoThreads {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support


VisualCronTriggerResultClass Class

VisualCronTriggerResultClass Class
Namespaces ► VisualCron ► VisualCronTriggerResultClass

[Missing <summary> documentation for T:VisualCron.VisualCronTriggerResultClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class VisualCronTriggerResultClass
<SerializableAttribute> _
Public Class VisualCronTriggerResultClass
[SerializableAttribute]
public ref class VisualCronTriggerResultClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VisualCronTriggerResultClass()()() | Initializes a new instance of the VisualCronTriggerResultClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobId |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
VisualCronTriggerResultClass

Send comments on this topic to Please email feedback to Support


VisualCronTriggerResultClass Constructor

VisualCronTriggerResultClass Constructor
Namespaces ► VisualCron ► VisualCronTriggerResultClass ► VisualCronTriggerResultClass()()()
Initializes a new instance of the VisualCronTriggerResultClass class
Declaration Syntax
C# Visual Basic Visual C++
public VisualCronTriggerResultClass()
Public Sub New
public:
VisualCronTriggerResultClass()


JobId Property

JobId Property
Namespaces ► VisualCron ► VisualCronTriggerResultClass ► JobId

[Missing <summary> documentation for P:VisualCron.VisualCronTriggerResultClass.JobId]

Declaration Syntax
C# Visual Basic Visual C++
public string JobId { get; set; }
Public Property JobId As String
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}


XMLCommandClass Class

XMLCommandClass Class
Namespaces ► VisualCron ► XMLCommandClass

[Missing <summary> documentation for T:VisualCron.XMLCommandClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class XMLCommandClass
<SerializableAttribute> _
Public Class XMLCommandClass
[SerializableAttribute]
public ref class XMLCommandClass
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XMLCommandClass()()() | Initializes a new instance of the XMLCommandClass class
 | Command |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XMLCommandClass

Send comments on this topic to Please email feedback to Support


XMLCommandClass Constructor

XMLCommandClass Constructor
Namespaces ► VisualCron ► XMLCommandClass ► XMLCommandClass()()()
Initializes a new instance of the XMLCommandClass class
Declaration Syntax
C# Visual Basic Visual C++
public XMLCommandClass()
Public Sub New
public:
XMLCommandClass()


Command Property

Command Property
Namespaces ► VisualCron ► XMLCommandClass ► Command

[Missing <summary> documentation for P:VisualCron.XMLCommandClass.Command]

Declaration Syntax
C# Visual Basic Visual C++
public string Command { get; set; }
Public Property Command As String
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}


Message Property

Message Property
Namespaces ► VisualCron ► XMLCommandClass ► Message

[Missing <summary> documentation for P:VisualCron.XMLCommandClass.Message]

Declaration Syntax
C# Visual Basic Visual C++
public string Message { get; set; }
Public Property Message As String
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}


VisualCronAPI Namespace

VisualCronAPI Namespace
Namespaces ► VisualCronAPI

[Missing <summary> documentation for N:VisualCronAPI]

Declaration Syntax
C# Visual Basic Visual C++
namespace VisualCronAPI
Namespace VisualCronAPI
namespace VisualCronAPI
Types
All Types Classes Structures Interfaces Enumerations Delegates
Icon | Type | Description
 | Certificates..::.__Certificates |
 | ClientConnections..::.__ClientConnections |
 | Conditions..::.__Conditions |
 | Connections..::.__Connections |
 | Credentials..::.__Credentials |
 | Jobs..::.__Jobs |
 | NetworkDrives..::.__NetworkDrives |
 | Notifications..::.__Notifications |
 | Permissions..::.__Permissions |
 | PGPKeyRings..::.__PGPKeyRings |
 | Processes..::.__Processes |
 | Server..::.__Server |
 | Tasks..::.__Tasks |
 | TimeExceptions..::.__TimeExceptions |
 | Triggers..::.__Triggers |
 | Variables..::.__Variables |
 | Certificates..::._Certificates |
 | Client..::._Client |
 | ClientConnections..::._ClientConnections |
 | Conditions..::._Conditions |
 | Connection..::._Connection |
 | Connections..::._Connections |
 | Credentials..::._Credentials |
 | Jobs..::._Jobs |
 | License..::._License |
 | NetworkDrives..::._NetworkDrives |
 | Notifications..::._Notifications |
 | Permissions..::._Permissions |
 | PGPKeyRings..::._PGPKeyRings |
 | Processes..::._Processes |
 | Server..::._Server |
 | Tasks..::._Tasks |
 | TimeExceptions..::._TimeExceptions |
 | Triggers..::._Triggers |
 | Variables..::._Variables |
 | Certificates..::.CertificateNotFoundException |
 | Certificates | Base class for Certificates Properties, Methods and Events
 | Client | Use the Client class to connect to a Server
 | ClientConnections..::.ClientConnectionNotFoundException |
 | ClientConnections | Base class for Client connections
 | ClientLog |
 | Client..::.ClientLoginFailedException | Is throwed when client login failed
 | Computer |
 | ComputerInfoAPI |
 | Conditions | Base class for Condition Properties, Methods and Events
 | Conditions..::.ConditionSetNotFoundException |
 | Connection | Handles connection specific settings
 | Client..::.ConnectionLimitedException | Is throwed when the server connection is limited in some way
 | Connections..::.ConnectionNotFoundException |
 | Connections | Base class for Connection Properties, Methods and Events
 | Connection..::.ConnectionT | Different connection types
 | Client..::.ConnectionTypeNotSupportedException | Is throwed when the Connection type is not implemented.
 | Credentials..::.CredentialNotFoundException |
 | Credentials | Base class for Credential Properties, Methods and Events
 | Certificates..::.DelegateCertificateAdded |
 | Certificates..::.DelegateCertificateRemoved |
 | Certificates..::.DelegateCertificateUpdated |
 | ClientConnections..::.DelegateClientConnectionAdded |
 | ClientConnections..::.DelegateClientConnectionRemoved |
 | ClientConnections..::.DelegateClientConnectionUpdated |
 | Conditions..::.DelegateConditionAdded |
 | Conditions..::.DelegateConditionRemoved |
 | Conditions..::.DelegateConditionSetAdded |
 | Conditions..::.DelegateConditionSetRemoved |
 | Conditions..::.DelegateConditionSetUpdated |
 | Conditions..::.DelegateConditionUpdated |
 | Connections..::.DelegateConnectionAdded |
 | Connections..::.DelegateConnectionRemoved |
 | Connections..::.DelegateConnectionUpdated |
 | Credentials..::.DelegateCredentialAdded |
 | Credentials..::.DelegateCredentialRemoved |
 | Credentials..::.DelegateCredentialUpdated |
 | Server..::.DelegateEIPProgress |
 | Client..::.DelegateFileExplorerMessage |
 | Jobs..::.DelegateJobAdded |
 | Processes..::.DelegateJobProcessEnded |
 | Processes..::.DelegateJobProcessStarted |
 | Processes..::.DelegateJobProcessUpdated |
 | Jobs..::.DelegateJobUpdated |
 | License..::.DelegateLicenseUpdated |
 | ClientLog..::.DelegateLogAdded |
 | Log..::.DelegateLogAdded |
 | ClientLog..::.DelegateLogArrayAdded |
 | Log..::.DelegateLogArrayAdded |
 | NetworkDrives..::.DelegateNetworkDriveAdded |
 | NetworkDrives..::.DelegateNetworkDriveRemoved |
 | NetworkDrives..::.DelegateNetworkDriveUpdated |
 | Notifications..::.DelegateNotificationAdded |
 | Notifications..::.DelegateNotificationRemoved |
 | Notifications..::.DelegateNotificationUpdated |
 | Client..::.DelegateOnConnected |
 | Client..::.DelegateOnConnectionProgress |
 | Client..::.DelegateOnDisconnect |
 | Jobs..::.DelegateOnJobRemoved |
 | LogAPI..::.DelegateOnLog |
 | Client..::.DelegateOnMessageBox |
 | Client..::.DelegateOnSyncComplete |
 | Tasks..::.DelegateOnTaskUpdated |
 | PGPKeyRings..::.DelegatePGPKeyRingAdded |
 | PGPKeyRings..::.DelegatePGPKeyRingRemoved |
 | PGPKeyRings..::.DelegatePGPKeyRingUpdated |
 | Client..::.DelegateServerStatusChanged |
 | Tasks..::.DelegateTaskAdded |
 | Processes..::.DelegateTaskProcessEnded |
 | Processes..::.DelegateTaskProcessStarted |
 | Processes..::.DelegateTaskProcessUpdated |
 | Tasks..::.DelegateTaskRemoved |
 | ExceptionHandler..::.DelegateThrowException |
 | TimeExceptions..::.DelegateTimeExceptionAdded |
 | TimeExceptions..::.DelegateTimeExceptionCollectionAdded |
 | TimeExceptions..::.DelegateTimeExceptionCollectionRemoved |
 | TimeExceptions..::.DelegateTimeExceptionCollectionUpdated |
 | TimeExceptions..::.DelegateTimeExceptionRemoved |
 | TimeExceptions..::.DelegateTimeExceptionUpdated |
 | Notifications..::.DelegateTrayPopup |
 | Triggers..::.DelegateTriggerAdded |
 | Triggers..::.DelegateTriggerRemoved |
 | Triggers..::.DelegateTriggerUpdated |
 | Permissions..::.DelegateUserAdded |
 | Permissions..::.DelegateUserRemoved |
 | Permissions..::.DelegateUserUpdated |
 | Variables..::.DelegateVariableAdded |
 | Variables..::.DelegateVariableRemoved |
 | Variables..::.DelegateVariableUpdated |
 | EmailSettings |
 | ExceptionHandler |
 | ExitCodes |
 | Explorer |
 | FunctionsAPI |
 | ImpersonationClass |
 | InstallHelper |
 | IVariableReplacer |
 | Jobs..::.JobNotFoundException |
 | Jobs | Base class for Job Properties, Methods and Events
 | LangAPI |
 | License |
 | Log |
 | LogAPI |
 | LogAPI..::.LogEventType |
 | LogAPI..::.LogLevelType |
 | MessageQueueClass |
 | NetworkDrives..::.NetworkDriveNotFoundException |
 | NetworkDrives | Base class for Network Drive Properties, Methods and Events
 | Server..::.NotConnectedException | Is throwed when the server is not connected
 | Notifications..::.NotificationNotFoundException |
 | Notifications | Base class for Notification Properties, Methods and Events
 | Server..::.NotImplementedException | Is throwed when a function is not implemented yet
 | OpenProxyClass |
 | ComputerInfoAPI..::.OSBitSizeT |
 | PdhCategory |
 | Permissions..::.PermissionDeniedException | Is throwed when User lacks permission for the current operation
 | Permissions..::.PermissionResultT |
 | Permissions | Base class for Permission Properties, Methods and Events
 | PGPKeyRings..::.PGPKeyRingNotFoundException |
 | PGPKeyRings | Base class for PGPKeyRings Properties, Methods and Events
 | Processes | Base class for Process Properties, Methods and Events
 | ImpersonationClass..::.PROFILEINFO |
 | Client..::.ProtocolObsoleteException | Is throwed when client or server protocol is too old for communicating, i.e. new features and functions may have been added to server or client.
 | OpenProxyClass..::.ProxyT |
 | Server..::.ReplyTimeoutException | Is throwed when the API has not received
 | Server | A Server object that contains all base objects for the Server
 | Servers |
 | Server..::.StatusT | Enum that describes current connection status
 | Tasks..::.TaskNotFoundException |
 | Tasks | Base class for Task Properties, Methods and Events
 | TimeAPI |
 | TimeExceptions..::.TimeExceptionCollectionNotFoundException |
 | TimeExceptions | Base class for Time exception Properties, Methods and Events
 | License..::.TrialTimeExpired | Is throwed when trial time has expired on server
 | Triggers..::.TriggerNotFoundException | Is throwed when a Trigger is not found.
 | Triggers | Base class for Trigger Properties, Methods and Events
 | Permissions..::.UserNotFoundException | Is throwed when User is not found
 | Variables..::.VariableNotFoundException |
 | VariableReplacerClass |
 | VariableReplacerFoundationClass | Base class for Variables
 | Variables | Base class for Variable Properties, Methods and Events


Certificates Class

Certificates Class
Namespaces ► VisualCronAPI ► Certificates
Base class for Certificates Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Certificates : Certificates..::._Certificates
Public Class Certificates _
    Implements Certificates..::._Certificates
public ref class Certificates : Certificates..::._Certificates
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Certificates(Server) | Initializes a new instance of the Certificates class
 | Add(CertificateClass) | Adds a Certificate
 | CertificateAdded | This event is raised when a Certificate has been added
 | CertificateAddedStatic | This event is raised when a Certificate has been added
 | CertificateRemoved | This event is raised when a Certificatehas been removed
 | CertificateRemovedStatic | This event is raised when a Certificatehas been removed
 | CertificateUpdated | This event is raised when a Certificate has been updated
 | CertificateUpdatedStatic | This event is raised when a Certificate has been updated
 | Contains(String) | Returns a boolean telling if a specified Certificate exist
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Certificates based on the string key Id
 | GetAll()()() | Returns a List of Certificates
 | GetAll(CertificateClass..::.CertificateT) | Returns a List of Certificates
 | GetAllArray()()() | Returns an array of Certificates
 | GetAllArray(CertificateClass..::.CertificateT) | Returns an array of Certificates
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(CertificateClass) | Removes a Certificate
 | Remove(String) | Removes a Certificate
 | RemoveAll()()() | Removes all Certificates
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(CertificateClass) | Updates a Certificate
Remarks
Inheritance Hierarchy
Object
Certificates

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates Constructor (s)

Certificates Constructor (s)
Namespaces ► VisualCronAPI ► Certificates ► Certificates(Server)
Initializes a new instance of the Certificates class
Declaration Syntax
C# Visual Basic Visual C++
public Certificates(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
Certificates(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Certificates.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (cc)

Add Method (cc)
Namespaces ► VisualCronAPI ► Certificates ► Add(CertificateClass)
Adds a Certificate
Declaration Syntax
C# Visual Basic Visual C++
public CertificateClass Add(
    CertificateClass cc
)
Public Function Add ( _
    cc As CertificateClass _
) As CertificateClass
public:
virtual CertificateClass^ Add(
    CertificateClass^ cc
) sealed
Parameters
cc (CertificateClass)
a Certificate
Return Value
a Certificate
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateAdded Event

CertificateAdded Event
Namespaces ► VisualCronAPI ► Certificates ► CertificateAdded
This event is raised when a Certificate has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Certificates..::.DelegateCertificateAdded CertificateAdded
Public Event CertificateAdded As Certificates..::.DelegateCertificateAdded
public:
 event Certificates..::.DelegateCertificateAdded^ CertificateAdded {
    void add (Certificates..::.DelegateCertificateAdded^ value);
    void remove (Certificates..::.DelegateCertificateAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateAddedStatic Event

CertificateAddedStatic Event
Namespaces ► VisualCronAPI ► Certificates ► CertificateAddedStatic
This event is raised when a Certificate has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Certificates..::.DelegateCertificateAdded CertificateAddedStatic
Public Shared Event CertificateAddedStatic As Certificates..::.DelegateCertificateAdded
public:
static  event Certificates..::.DelegateCertificateAdded^ CertificateAddedStatic {
    void add (Certificates..::.DelegateCertificateAdded^ value);
    void remove (Certificates..::.DelegateCertificateAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateRemoved Event

CertificateRemoved Event
Namespaces ► VisualCronAPI ► Certificates ► CertificateRemoved
This event is raised when a Certificatehas been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Certificates..::.DelegateCertificateRemoved CertificateRemoved
Public Event CertificateRemoved As Certificates..::.DelegateCertificateRemoved
public:
 event Certificates..::.DelegateCertificateRemoved^ CertificateRemoved {
    void add (Certificates..::.DelegateCertificateRemoved^ value);
    void remove (Certificates..::.DelegateCertificateRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateRemovedStatic Event

CertificateRemovedStatic Event
Namespaces ► VisualCronAPI ► Certificates ► CertificateRemovedStatic
This event is raised when a Certificatehas been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Certificates..::.DelegateCertificateRemoved CertificateRemovedStatic
Public Shared Event CertificateRemovedStatic As Certificates..::.DelegateCertificateRemoved
public:
static  event Certificates..::.DelegateCertificateRemoved^ CertificateRemovedStatic {
    void add (Certificates..::.DelegateCertificateRemoved^ value);
    void remove (Certificates..::.DelegateCertificateRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateUpdated Event

CertificateUpdated Event
Namespaces ► VisualCronAPI ► Certificates ► CertificateUpdated
This event is raised when a Certificate has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Certificates..::.DelegateCertificateUpdated CertificateUpdated
Public Event CertificateUpdated As Certificates..::.DelegateCertificateUpdated
public:
 event Certificates..::.DelegateCertificateUpdated^ CertificateUpdated {
    void add (Certificates..::.DelegateCertificateUpdated^ value);
    void remove (Certificates..::.DelegateCertificateUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateUpdatedStatic Event

CertificateUpdatedStatic Event
Namespaces ► VisualCronAPI ► Certificates ► CertificateUpdatedStatic
This event is raised when a Certificate has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Certificates..::.DelegateCertificateUpdated CertificateUpdatedStatic
Public Shared Event CertificateUpdatedStatic As Certificates..::.DelegateCertificateUpdated
public:
static  event Certificates..::.DelegateCertificateUpdated^ CertificateUpdatedStatic {
    void add (Certificates..::.DelegateCertificateUpdated^ value);
    void remove (Certificates..::.DelegateCertificateUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strCertificateId)

Contains Method (strCertificateId)
Namespaces ► VisualCronAPI ► Certificates ► Contains(String)
Returns a boolean telling if a specified Certificate exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strCertificateId
)
Public Function Contains ( _
    strCertificateId As String _
) As Boolean
public:
virtual bool Contains(
    String^ strCertificateId
) sealed
Parameters
strCertificateId (String)

[Missing <param name="strCertificateId"/> documentation for "M:VisualCronAPI.Certificates.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (certificateId)

Get Method (certificateId)
Namespaces ► VisualCronAPI ► Certificates ► Get(String)
Returns a Certificates based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public CertificateClass Get(
    string certificateId
)
Public Function Get ( _
    certificateId As String _
) As CertificateClass
public:
virtual CertificateClass^ Get(
    String^ certificateId
) sealed
Parameters
certificateId (String)

[Missing <param name="certificateId"/> documentation for "M:VisualCronAPI.Certificates.Get(System.String)"]

Return Value
a Certificate
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Certificates ► GetAll()()()
Members
Icon | Member | Description
 | GetAll()()() | Returns a List of Certificates
 | GetAll(CertificateClass..::.CertificateT) | Returns a List of Certificates

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Certificates ► GetAll()()()
Returns a List of Certificates
Declaration Syntax
C# Visual Basic Visual C++
public List<CertificateClass> GetAll()
Public Function GetAll As List(Of CertificateClass)
public:
List<CertificateClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method (ct)

GetAll Method (ct)
Namespaces ► VisualCronAPI ► Certificates ► GetAll(CertificateClass..::.CertificateT)
Returns a List of Certificates
Declaration Syntax
C# Visual Basic Visual C++
public List<CertificateClass> GetAll(
    CertificateClass..::.CertificateT ct
)
Public Function GetAll ( _
    ct As CertificateClass..::.CertificateT _
) As List(Of CertificateClass)
public:
List<CertificateClass^>^ GetAll(
    CertificateClass..::.CertificateT ct
)
Parameters
ct (CertificateClass..::.CertificateT)

[Missing <param name="ct"/> documentation for "M:VisualCronAPI.Certificates.GetAll(VisualCron.CertificateClass.CertificateT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates.GetAll(VisualCron.CertificateClass.CertificateT)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Certificates ► GetAllArray()()()
Members
Icon | Member | Description
 | GetAllArray()()() | Returns an array of Certificates
 | GetAllArray(CertificateClass..::.CertificateT) | Returns an array of Certificates

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Certificates ► GetAllArray()()()
Returns an array of Certificates
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (ct)

GetAllArray Method (ct)
Namespaces ► VisualCronAPI ► Certificates ► GetAllArray(CertificateClass..::.CertificateT)
Returns an array of Certificates
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray(
    CertificateClass..::.CertificateT ct
)
Public Function GetAllArray ( _
    ct As CertificateClass..::.CertificateT _
) As ArrayList
public:
virtual ArrayList^ GetAllArray(
    CertificateClass..::.CertificateT ct
) sealed
Parameters
ct (CertificateClass..::.CertificateT)

[Missing <param name="ct"/> documentation for "M:VisualCronAPI.Certificates.GetAllArray(VisualCron.CertificateClass.CertificateT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates.GetAllArray(VisualCron.CertificateClass.CertificateT)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Certificates ► Remove()()()
Members
Icon | Member | Description
 | Remove(CertificateClass) | Removes a Certificate
 | Remove(String) | Removes a Certificate

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (certificateId)

Remove Method (certificateId)
Namespaces ► VisualCronAPI ► Certificates ► Remove(String)
Removes a Certificate
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string certificateId
)
Public Function Remove ( _
    certificateId As String _
) As Boolean
public:
virtual bool Remove(
    String^ certificateId
) sealed
Parameters
certificateId (String)
Id of Certificate
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (cc)

Remove Method (cc)
Namespaces ► VisualCronAPI ► Certificates ► Remove(CertificateClass)
Removes a Certificate
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    CertificateClass cc
)
Public Function Remove ( _
    cc As CertificateClass _
) As Boolean
public:
virtual bool Remove(
    CertificateClass^ cc
) sealed
Parameters
cc (CertificateClass)
a Certificate
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Certificates ► RemoveAll()()()
Removes all Certificates
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (cc)

Update Method (cc)
Namespaces ► VisualCronAPI ► Certificates ► Update(CertificateClass)
Updates a Certificate
Declaration Syntax
C# Visual Basic Visual C++
public CertificateClass Update(
    CertificateClass cc
)
Public Function Update ( _
    cc As CertificateClass _
) As CertificateClass
public:
virtual CertificateClass^ Update(
    CertificateClass^ cc
) sealed
Parameters
cc (CertificateClass)
a Certificate
Return Value
a Certificate
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates.__Certificates Interface

Certificates..::.__Certificates Interface
Namespaces ► VisualCronAPI ► Certificates ► Certificates..::.__Certificates

[Missing <summary> documentation for T:VisualCronAPI.Certificates.__Certificates]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Certificates
Public Interface __Certificates
public interface class __Certificates
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CertificateAdded(Server%, CertificateClass) |
 | CertificateRemoved(Server%, CertificateClass) |
 | CertificateUpdated(Server%, CertificateClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateAdded Method (server, cc)

CertificateAdded Method (server, cc)
Namespaces ► VisualCronAPI ► Certificates..::.__Certificates ► CertificateAdded(Server%, CertificateClass)

[Missing <summary> documentation for M:VisualCronAPI.Certificates.__Certificates.CertificateAdded(VisualCronAPI.Server@,VisualCron.CertificateClass)]

Declaration Syntax
C# Visual Basic Visual C++
void CertificateAdded(
    ref Server server,
    CertificateClass cc
)
Sub CertificateAdded ( _
    ByRef server As Server, _
    cc As CertificateClass _
)
void CertificateAdded(
    Server^% server,
    CertificateClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Certificates.__Certificates.CertificateAdded(VisualCronAPI.Server@,VisualCron.CertificateClass)"]

cc (CertificateClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Certificates.__Certificates.CertificateAdded(VisualCronAPI.Server@,VisualCron.CertificateClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateRemoved Method (server, cc)

CertificateRemoved Method (server, cc)
Namespaces ► VisualCronAPI ► Certificates..::.__Certificates ► CertificateRemoved(Server%, CertificateClass)

[Missing <summary> documentation for M:VisualCronAPI.Certificates.__Certificates.CertificateRemoved(VisualCronAPI.Server@,VisualCron.CertificateClass)]

Declaration Syntax
C# Visual Basic Visual C++
void CertificateRemoved(
    ref Server server,
    CertificateClass cc
)
Sub CertificateRemoved ( _
    ByRef server As Server, _
    cc As CertificateClass _
)
void CertificateRemoved(
    Server^% server,
    CertificateClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Certificates.__Certificates.CertificateRemoved(VisualCronAPI.Server@,VisualCron.CertificateClass)"]

cc (CertificateClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Certificates.__Certificates.CertificateRemoved(VisualCronAPI.Server@,VisualCron.CertificateClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CertificateUpdated Method (server, cc)

CertificateUpdated Method (server, cc)
Namespaces ► VisualCronAPI ► Certificates..::.__Certificates ► CertificateUpdated(Server%, CertificateClass)

[Missing <summary> documentation for M:VisualCronAPI.Certificates.__Certificates.CertificateUpdated(VisualCronAPI.Server@,VisualCron.CertificateClass)]

Declaration Syntax
C# Visual Basic Visual C++
void CertificateUpdated(
    ref Server server,
    CertificateClass cc
)
Sub CertificateUpdated ( _
    ByRef server As Server, _
    cc As CertificateClass _
)
void CertificateUpdated(
    Server^% server,
    CertificateClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Certificates.__Certificates.CertificateUpdated(VisualCronAPI.Server@,VisualCron.CertificateClass)"]

cc (CertificateClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Certificates.__Certificates.CertificateUpdated(VisualCronAPI.Server@,VisualCron.CertificateClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates._Certificates Interface

Certificates..::._Certificates Interface
Namespaces ► VisualCronAPI ► Certificates ► Certificates..::._Certificates

[Missing <summary> documentation for T:VisualCronAPI.Certificates._Certificates]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Certificates
Public Interface _Certificates
public interface class _Certificates
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(CertificateClass) |
 | Contains(String) |
 | Get(String) |
 | GetAllArray()()() |
 | GetAllArray(CertificateClass..::.CertificateT) |
 | Remove(CertificateClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | Update(CertificateClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (cc)

Add Method (cc)
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► Add(CertificateClass)

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.Add(VisualCron.CertificateClass)]

Declaration Syntax
C# Visual Basic Visual C++
CertificateClass Add(
    CertificateClass cc
)
Function Add ( _
    cc As CertificateClass _
) As CertificateClass
CertificateClass^ Add(
    CertificateClass^ cc
)
Parameters
cc (CertificateClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Certificates._Certificates.Add(VisualCron.CertificateClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.Add(VisualCron.CertificateClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strCertificateId)

Contains Method (strCertificateId)
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string strCertificateId
)
Function Contains ( _
    strCertificateId As String _
) As Boolean
bool Contains(
    String^ strCertificateId
)
Parameters
strCertificateId (String)

[Missing <param name="strCertificateId"/> documentation for "M:VisualCronAPI.Certificates._Certificates.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (certificateId)

Get Method (certificateId)
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
CertificateClass Get(
    string certificateId
)
Function Get ( _
    certificateId As String _
) As CertificateClass
CertificateClass^ Get(
    String^ certificateId
)
Parameters
certificateId (String)

[Missing <param name="certificateId"/> documentation for "M:VisualCronAPI.Certificates._Certificates.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► GetAllArray()()()
Members
Icon | Member | Description
 | GetAllArray()()() |
 | GetAllArray(CertificateClass..::.CertificateT) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (ct)

GetAllArray Method (ct)
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► GetAllArray(CertificateClass..::.CertificateT)

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.GetAllArray(VisualCron.CertificateClass.CertificateT)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray(
    CertificateClass..::.CertificateT ct
)
Function GetAllArray ( _
    ct As CertificateClass..::.CertificateT _
) As ArrayList
ArrayList^ GetAllArray(
    CertificateClass..::.CertificateT ct
)
Parameters
ct (CertificateClass..::.CertificateT)

[Missing <param name="ct"/> documentation for "M:VisualCronAPI.Certificates._Certificates.GetAllArray(VisualCron.CertificateClass.CertificateT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.GetAllArray(VisualCron.CertificateClass.CertificateT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► Remove()()()
Members
Icon | Member | Description
 | Remove(CertificateClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (certificateId)

Remove Method (certificateId)
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string certificateId
)
Function Remove ( _
    certificateId As String _
) As Boolean
bool Remove(
    String^ certificateId
)
Parameters
certificateId (String)

[Missing <param name="certificateId"/> documentation for "M:VisualCronAPI.Certificates._Certificates.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (cc)

Remove Method (cc)
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► Remove(CertificateClass)

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.Remove(VisualCron.CertificateClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    CertificateClass cc
)
Function Remove ( _
    cc As CertificateClass _
) As Boolean
bool Remove(
    CertificateClass^ cc
)
Parameters
cc (CertificateClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Certificates._Certificates.Remove(VisualCron.CertificateClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.Remove(VisualCron.CertificateClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (cc)

Update Method (cc)
Namespaces ► VisualCronAPI ► Certificates..::._Certificates ► Update(CertificateClass)

[Missing <summary> documentation for M:VisualCronAPI.Certificates._Certificates.Update(VisualCron.CertificateClass)]

Declaration Syntax
C# Visual Basic Visual C++
CertificateClass Update(
    CertificateClass cc
)
Function Update ( _
    cc As CertificateClass _
) As CertificateClass
CertificateClass^ Update(
    CertificateClass^ cc
)
Parameters
cc (CertificateClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Certificates._Certificates.Update(VisualCron.CertificateClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Certificates._Certificates.Update(VisualCron.CertificateClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates.CertificateNotFoundException Class

Certificates..::.CertificateNotFoundException Class
Namespaces ► VisualCronAPI ► Certificates ► Certificates..::.CertificateNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Certificates.CertificateNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class CertificateNotFoundException : Exception
Public Class CertificateNotFoundException _
    Inherits Exception
public ref class CertificateNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Certificates..::.CertificateNotFoundException(String) | Initializes a new instance of the Certificates..::.CertificateNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Certificates..::.CertificateNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates.CertificateNotFoundException Constructor (id)

Certificates..::.CertificateNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Certificates..::.CertificateNotFoundException ► Certificates..::.CertificateNotFoundException(String)
Initializes a new instance of the Certificates..::.CertificateNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public CertificateNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
CertificateNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Certificates.CertificateNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates.DelegateCertificateAdded Delegate

Certificates..::.DelegateCertificateAdded Delegate
Namespaces ► VisualCronAPI ► Certificates ► Certificates..::.DelegateCertificateAdded

[Missing <summary> documentation for T:VisualCronAPI.Certificates.DelegateCertificateAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateCertificateAdded(
    ref Server server,
    CertificateClass cc
)
Public Delegate Sub DelegateCertificateAdded ( _
    ByRef server As Server, _
    cc As CertificateClass _
)
public delegate void DelegateCertificateAdded(
    Server^% server,
    CertificateClass^ cc
)
Parameters
server ( Server %)
cc (CertificateClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates.DelegateCertificateRemoved Delegate

Certificates..::.DelegateCertificateRemoved Delegate
Namespaces ► VisualCronAPI ► Certificates ► Certificates..::.DelegateCertificateRemoved

[Missing <summary> documentation for T:VisualCronAPI.Certificates.DelegateCertificateRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateCertificateRemoved(
    ref Server server,
    CertificateClass cc
)
Public Delegate Sub DelegateCertificateRemoved ( _
    ByRef server As Server, _
    cc As CertificateClass _
)
public delegate void DelegateCertificateRemoved(
    Server^% server,
    CertificateClass^ cc
)
Parameters
server ( Server %)
cc (CertificateClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates.DelegateCertificateUpdated Delegate

Certificates..::.DelegateCertificateUpdated Delegate
Namespaces ► VisualCronAPI ► Certificates ► Certificates..::.DelegateCertificateUpdated

[Missing <summary> documentation for T:VisualCronAPI.Certificates.DelegateCertificateUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateCertificateUpdated(
    ref Server server,
    CertificateClass cc
)
Public Delegate Sub DelegateCertificateUpdated ( _
    ByRef server As Server, _
    cc As CertificateClass _
)
public delegate void DelegateCertificateUpdated(
    Server^% server,
    CertificateClass^ cc
)
Parameters
server ( Server %)
cc (CertificateClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client Class

Client Class
Namespaces ► VisualCronAPI ► Client
Use the Client class to connect to a Server
Declaration Syntax
C# Visual Basic Visual C++
public class Client : Client..::._Client
Public Class Client _
    Implements Client..::._Client
public ref class Client : Client..::._Client
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Client()()() | Initializes a new instance of the Client class
 | ClientMachineId | Unique Client machine Id
 | Connect(Connection, Boolean) | Connect to a server
 | Disconnect(Server) | Disconnects a Server
 | DisconnectAll()()() | Disconnects all Server connections
 | Encrypt(String) | Encrypts a string to a bytearray.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventOnConnected | This event is raised when a Server has been connected to the Client
 | EventOnConnectionProgress |
 | EventOnDisconnect | This is event is raised when a Server has been disconnected from the Client
 | EventOnOnMessageBox | This event is raised when a MessageBox has been received
 | EventOnServerStatusChanged | This event is raised when Server status has been changed
 | EventOnSyncComplete | This event is raised when a Server has been synced
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBuild()()() | Returns the current build of the the API
 | GetFullVersion()()() | Returns the version and build of the API
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVersion()()() | Returns the current version of the API
 | Id | Unique Id for the Client so communication can be returned
 | InstallHelper |
 | Log | Client specific log
 | LogToFile | If logging is turned on the log file will be written in working directory
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnFileExplorerMessage | This event is raised when a new FileExplorer message has been received
 | Protocol | Client protocol version
 | ReportError(ErrorReportClass, OpenProxyClass) |
 | Servers | All servers that the Client is connected to
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | User | Gets or sets permissions information of the Current user
 | Version | Version of the Client API
Remarks
Inheritance Hierarchy
Object
Client

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client Constructor

Client Constructor
Namespaces ► VisualCronAPI ► Client ► Client()()()
Initializes a new instance of the Client class
Declaration Syntax
C# Visual Basic Visual C++
public Client()
Public Sub New
public:
Client()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientMachineId Property

ClientMachineId Property
Namespaces ► VisualCronAPI ► Client ► ClientMachineId
Unique Client machine Id
Declaration Syntax
C# Visual Basic Visual C++
public string ClientMachineId { get; }
Public ReadOnly Property ClientMachineId As String
public:
virtual property String^ ClientMachineId {
    String^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connect Method (conn, SynchronizeServerObjects)

Connect Method (conn, SynchronizeServerObjects)
Namespaces ► VisualCronAPI ► Client ► Connect(Connection, Boolean)
Connect to a server
Declaration Syntax
C# Visual Basic Visual C++
public Server Connect(
    Connection conn,
    bool SynchronizeServerObjects
)
Public Function Connect ( _
    conn As Connection, _
    SynchronizeServerObjects As Boolean _
) As Server
public:
virtual Server^ Connect(
    Connection^ conn,
    bool SynchronizeServerObjects
) sealed
Parameters
conn (Connection)

[Missing <param name="conn"/> documentation for "M:VisualCronAPI.Client.Connect(VisualCronAPI.Connection,System.Boolean)"]

SynchronizeServerObjects (Boolean)

[Missing <param name="SynchronizeServerObjects"/> documentation for "M:VisualCronAPI.Client.Connect(VisualCronAPI.Connection,System.Boolean)"]

Return Value
a Server
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Disconnect Method (s)

Disconnect Method (s)
Namespaces ► VisualCronAPI ► Client ► Disconnect(Server)
Disconnects a Server
Declaration Syntax
C# Visual Basic Visual C++
public bool Disconnect(
    Server s
)
Public Function Disconnect ( _
    s As Server _
) As Boolean
public:
virtual bool Disconnect(
    Server^ s
) sealed
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Client.Disconnect(VisualCronAPI.Server)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client.Disconnect(VisualCronAPI.Server)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DisconnectAll Method

DisconnectAll Method
Namespaces ► VisualCronAPI ► Client ► DisconnectAll()()()
Disconnects all Server connections
Declaration Syntax
C# Visual Basic Visual C++
public bool DisconnectAll()
Public Function DisconnectAll As Boolean
public:
virtual bool DisconnectAll() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client.DisconnectAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Encrypt Method (strToEncrypt)

Encrypt Method (strToEncrypt)
Namespaces ► VisualCronAPI ► Client ► Encrypt(String)
Encrypts a string to a bytearray.
Declaration Syntax
C# Visual Basic Visual C++
public byte[] Encrypt(
    string strToEncrypt
)
Public Function Encrypt ( _
    strToEncrypt As String _
) As Byte()
public:
virtual array<unsigned char>^ Encrypt(
    String^ strToEncrypt
) sealed
Parameters
strToEncrypt (String)

[Missing <param name="strToEncrypt"/> documentation for "M:VisualCronAPI.Client.Encrypt(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client.Encrypt(System.String)]

Remarks
This function may be needed to create some classes with encrypted content.

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventOnConnected Event

EventOnConnected Event
Namespaces ► VisualCronAPI ► Client ► EventOnConnected
This event is raised when a Server has been connected to the Client
Declaration Syntax
C# Visual Basic Visual C++
public static event Client..::.DelegateOnConnected EventOnConnected
Public Shared Event EventOnConnected As Client..::.DelegateOnConnected
public:
static  event Client..::.DelegateOnConnected^ EventOnConnected {
    void add (Client..::.DelegateOnConnected^ value);
    void remove (Client..::.DelegateOnConnected^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventOnConnectionProgress Event

EventOnConnectionProgress Event
Namespaces ► VisualCronAPI ► Client ► EventOnConnectionProgress

[Missing <summary> documentation for E:VisualCronAPI.Client.EventOnConnectionProgress]

Declaration Syntax
C# Visual Basic Visual C++
public static event Client..::.DelegateOnConnectionProgress EventOnConnectionProgress
Public Shared Event EventOnConnectionProgress As Client..::.DelegateOnConnectionProgress
public:
static  event Client..::.DelegateOnConnectionProgress^ EventOnConnectionProgress {
    void add (Client..::.DelegateOnConnectionProgress^ value);
    void remove (Client..::.DelegateOnConnectionProgress^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventOnDisconnect Event

EventOnDisconnect Event
Namespaces ► VisualCronAPI ► Client ► EventOnDisconnect
This is event is raised when a Server has been disconnected from the Client
Declaration Syntax
C# Visual Basic Visual C++
public static event Client..::.DelegateOnDisconnect EventOnDisconnect
Public Shared Event EventOnDisconnect As Client..::.DelegateOnDisconnect
public:
static  event Client..::.DelegateOnDisconnect^ EventOnDisconnect {
    void add (Client..::.DelegateOnDisconnect^ value);
    void remove (Client..::.DelegateOnDisconnect^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventOnOnMessageBox Event

EventOnOnMessageBox Event
Namespaces ► VisualCronAPI ► Client ► EventOnOnMessageBox
This event is raised when a MessageBox has been received
Declaration Syntax
C# Visual Basic Visual C++
public static event Client..::.DelegateOnMessageBox EventOnOnMessageBox
Public Shared Event EventOnOnMessageBox As Client..::.DelegateOnMessageBox
public:
static  event Client..::.DelegateOnMessageBox^ EventOnOnMessageBox {
    void add (Client..::.DelegateOnMessageBox^ value);
    void remove (Client..::.DelegateOnMessageBox^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventOnServerStatusChanged Event

EventOnServerStatusChanged Event
Namespaces ► VisualCronAPI ► Client ► EventOnServerStatusChanged
This event is raised when Server status has been changed
Declaration Syntax
C# Visual Basic Visual C++
public static event Client..::.DelegateServerStatusChanged EventOnServerStatusChanged
Public Shared Event EventOnServerStatusChanged As Client..::.DelegateServerStatusChanged
public:
static  event Client..::.DelegateServerStatusChanged^ EventOnServerStatusChanged {
    void add (Client..::.DelegateServerStatusChanged^ value);
    void remove (Client..::.DelegateServerStatusChanged^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventOnSyncComplete Event

EventOnSyncComplete Event
Namespaces ► VisualCronAPI ► Client ► EventOnSyncComplete
This event is raised when a Server has been synced
Declaration Syntax
C# Visual Basic Visual C++
public static event Client..::.DelegateOnSyncComplete EventOnSyncComplete
Public Shared Event EventOnSyncComplete As Client..::.DelegateOnSyncComplete
public:
static  event Client..::.DelegateOnSyncComplete^ EventOnSyncComplete {
    void add (Client..::.DelegateOnSyncComplete^ value);
    void remove (Client..::.DelegateOnSyncComplete^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetBuild Method

GetBuild Method
Namespaces ► VisualCronAPI ► Client ► GetBuild()()()
Returns the current build of the the API
Declaration Syntax
C# Visual Basic Visual C++
public string GetBuild()
Public Function GetBuild As String
public:
virtual String^ GetBuild() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client.GetBuild]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetFullVersion Method

GetFullVersion Method
Namespaces ► VisualCronAPI ► Client ► GetFullVersion()()()
Returns the version and build of the API
Declaration Syntax
C# Visual Basic Visual C++
public string GetFullVersion()
Public Function GetFullVersion As String
public:
virtual String^ GetFullVersion() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client.GetFullVersion]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetVersion Method

GetVersion Method
Namespaces ► VisualCronAPI ► Client ► GetVersion()()()
Returns the current version of the API
Declaration Syntax
C# Visual Basic Visual C++
public string GetVersion()
Public Function GetVersion As String
public:
virtual String^ GetVersion() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client.GetVersion]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Id Property

Id Property
Namespaces ► VisualCronAPI ► Client ► Id
Unique Id for the Client so communication can be returned
Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; }
Public ReadOnly Property Id As String
public:
virtual property String^ Id {
    String^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InstallHelper Property

InstallHelper Property
Namespaces ► VisualCronAPI ► Client ► InstallHelper

[Missing <summary> documentation for P:VisualCronAPI.Client.InstallHelper]

Declaration Syntax
C# Visual Basic Visual C++
public InstallHelper InstallHelper { get; set; }
Public Property InstallHelper As InstallHelper
public:
virtual property InstallHelper^ InstallHelper {
    InstallHelper^ get () sealed;
    void set (InstallHelper^ value) sealed;
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log Property

Log Property
Namespaces ► VisualCronAPI ► Client ► Log
Client specific log
Declaration Syntax
C# Visual Basic Visual C++
public ClientLog Log { get; set; }
Public Property Log As ClientLog
public:
virtual property ClientLog^ Log {
    ClientLog^ get () sealed;
    void set (ClientLog^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogToFile Property

LogToFile Property
Namespaces ► VisualCronAPI ► Client ► LogToFile
If logging is turned on the log file will be written in working directory
Declaration Syntax
C# Visual Basic Visual C++
public bool LogToFile { get; set; }
Public Property LogToFile As Boolean
public:
virtual property bool LogToFile {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


OnFileExplorerMessage Event

OnFileExplorerMessage Event
Namespaces ► VisualCronAPI ► Client ► OnFileExplorerMessage
This event is raised when a new FileExplorer message has been received
Declaration Syntax
C# Visual Basic Visual C++
public static event Client..::.DelegateFileExplorerMessage OnFileExplorerMessage
Public Shared Event OnFileExplorerMessage As Client..::.DelegateFileExplorerMessage
public:
static  event Client..::.DelegateFileExplorerMessage^ OnFileExplorerMessage {
    void add (Client..::.DelegateFileExplorerMessage^ value);
    void remove (Client..::.DelegateFileExplorerMessage^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Protocol Property

Protocol Property
Namespaces ► VisualCronAPI ► Client ► Protocol
Client protocol version
Declaration Syntax
C# Visual Basic Visual C++
public string Protocol { get; }
Public ReadOnly Property Protocol As String
public:
virtual property String^ Protocol {
    String^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ReportError Method (ec, proxySettings)

ReportError Method (ec, proxySettings)
Namespaces ► VisualCronAPI ► Client ► ReportError(ErrorReportClass, OpenProxyClass)

[Missing <summary> documentation for M:VisualCronAPI.Client.ReportError(VisualCronAPI.VCWWW.ErrorReport.ErrorReportClass,VisualCronAPI.OpenProxyClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void ReportError(
    ErrorReportClass ec,
    OpenProxyClass proxySettings
)
Public Sub ReportError ( _
    ec As ErrorReportClass, _
    proxySettings As OpenProxyClass _
)
public:
virtual void ReportError(
    ErrorReportClass^ ec,
    OpenProxyClass^ proxySettings
) sealed
Parameters
ec (ErrorReportClass)

[Missing <param name="ec"/> documentation for "M:VisualCronAPI.Client.ReportError(VisualCronAPI.VCWWW.ErrorReport.ErrorReportClass,VisualCronAPI.OpenProxyClass)"]

proxySettings (OpenProxyClass)

[Missing <param name="proxySettings"/> documentation for "M:VisualCronAPI.Client.ReportError(VisualCronAPI.VCWWW.ErrorReport.ErrorReportClass,VisualCronAPI.OpenProxyClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Servers Property

Servers Property
Namespaces ► VisualCronAPI ► Client ► Servers
All servers that the Client is connected to
Declaration Syntax
C# Visual Basic Visual C++
public Servers Servers { get; set; }
Public Property Servers As Servers
public:
virtual property Servers^ Servers {
    Servers^ get () sealed;
    void set (Servers^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


User Property

User Property
Namespaces ► VisualCronAPI ► Client ► User
Gets or sets permissions information of the Current user
Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass User { get; internal set; }
Public Property User As SecUserClass
public:
virtual property SecUserClass^ User {
    SecUserClass^ get () sealed;
    void set (SecUserClass^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Version Property

Version Property
Namespaces ► VisualCronAPI ► Client ► Version
Version of the Client API
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; }
Public ReadOnly Property Version As String
public:
virtual property String^ Version {
    String^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client._Client Interface

Client..::._Client Interface
Namespaces ► VisualCronAPI ► Client ► Client..::._Client

[Missing <summary> documentation for T:VisualCronAPI.Client._Client]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Client
Public Interface _Client
public interface class _Client
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClientMachineId |
 | Connect(Connection, Boolean) |
 | Disconnect(Server) |
 | DisconnectAll()()() |
 | Encrypt(String) |
 | GetBuild()()() |
 | GetFullVersion()()() |
 | GetVersion()()() |
 | Id |
 | InstallHelper |
 | Log |
 | LogToFile |
 | Protocol |
 | ReportError(ErrorReportClass, OpenProxyClass) |
 | Servers |
 | User |
 | Version |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientMachineId Property

ClientMachineId Property
Namespaces ► VisualCronAPI ► Client..::._Client ► ClientMachineId

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.ClientMachineId]

Declaration Syntax
C# Visual Basic Visual C++
string ClientMachineId { get; }
ReadOnly Property ClientMachineId As String
property String^ ClientMachineId {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connect Method (conn, SynchronizeServerObjects)

Connect Method (conn, SynchronizeServerObjects)
Namespaces ► VisualCronAPI ► Client..::._Client ► Connect(Connection, Boolean)

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.Connect(VisualCronAPI.Connection,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
Server Connect(
    Connection conn,
    bool SynchronizeServerObjects
)
Function Connect ( _
    conn As Connection, _
    SynchronizeServerObjects As Boolean _
) As Server
Server^ Connect(
    Connection^ conn,
    bool SynchronizeServerObjects
)
Parameters
conn (Connection)

[Missing <param name="conn"/> documentation for "M:VisualCronAPI.Client._Client.Connect(VisualCronAPI.Connection,System.Boolean)"]

SynchronizeServerObjects (Boolean)

[Missing <param name="SynchronizeServerObjects"/> documentation for "M:VisualCronAPI.Client._Client.Connect(VisualCronAPI.Connection,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client._Client.Connect(VisualCronAPI.Connection,System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Disconnect Method (s)

Disconnect Method (s)
Namespaces ► VisualCronAPI ► Client..::._Client ► Disconnect(Server)

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.Disconnect(VisualCronAPI.Server)]

Declaration Syntax
C# Visual Basic Visual C++
bool Disconnect(
    Server s
)
Function Disconnect ( _
    s As Server _
) As Boolean
bool Disconnect(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Client._Client.Disconnect(VisualCronAPI.Server)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client._Client.Disconnect(VisualCronAPI.Server)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DisconnectAll Method

DisconnectAll Method
Namespaces ► VisualCronAPI ► Client..::._Client ► DisconnectAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.DisconnectAll]

Declaration Syntax
C# Visual Basic Visual C++
bool DisconnectAll()
Function DisconnectAll As Boolean
bool DisconnectAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client._Client.DisconnectAll]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Encrypt Method (strToEncrypt)

Encrypt Method (strToEncrypt)
Namespaces ► VisualCronAPI ► Client..::._Client ► Encrypt(String)

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.Encrypt(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
byte[] Encrypt(
    string strToEncrypt
)
Function Encrypt ( _
    strToEncrypt As String _
) As Byte()
array<unsigned char>^ Encrypt(
    String^ strToEncrypt
)
Parameters
strToEncrypt (String)

[Missing <param name="strToEncrypt"/> documentation for "M:VisualCronAPI.Client._Client.Encrypt(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client._Client.Encrypt(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetBuild Method

GetBuild Method
Namespaces ► VisualCronAPI ► Client..::._Client ► GetBuild()()()

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.GetBuild]

Declaration Syntax
C# Visual Basic Visual C++
string GetBuild()
Function GetBuild As String
String^ GetBuild()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client._Client.GetBuild]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetFullVersion Method

GetFullVersion Method
Namespaces ► VisualCronAPI ► Client..::._Client ► GetFullVersion()()()

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.GetFullVersion]

Declaration Syntax
C# Visual Basic Visual C++
string GetFullVersion()
Function GetFullVersion As String
String^ GetFullVersion()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client._Client.GetFullVersion]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetVersion Method

GetVersion Method
Namespaces ► VisualCronAPI ► Client..::._Client ► GetVersion()()()

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.GetVersion]

Declaration Syntax
C# Visual Basic Visual C++
string GetVersion()
Function GetVersion As String
String^ GetVersion()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Client._Client.GetVersion]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Id Property

Id Property
Namespaces ► VisualCronAPI ► Client..::._Client ► Id

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.Id]

Declaration Syntax
C# Visual Basic Visual C++
string Id { get; }
ReadOnly Property Id As String
property String^ Id {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InstallHelper Property

InstallHelper Property
Namespaces ► VisualCronAPI ► Client..::._Client ► InstallHelper

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.InstallHelper]

Declaration Syntax
C# Visual Basic Visual C++
InstallHelper InstallHelper { get; set; }
Property InstallHelper As InstallHelper
property InstallHelper^ InstallHelper {
    InstallHelper^ get ();
    void set (InstallHelper^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log Property

Log Property
Namespaces ► VisualCronAPI ► Client..::._Client ► Log

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.Log]

Declaration Syntax
C# Visual Basic Visual C++
ClientLog Log { get; set; }
Property Log As ClientLog
property ClientLog^ Log {
    ClientLog^ get ();
    void set (ClientLog^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogToFile Property

LogToFile Property
Namespaces ► VisualCronAPI ► Client..::._Client ► LogToFile

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.LogToFile]

Declaration Syntax
C# Visual Basic Visual C++
bool LogToFile { get; set; }
Property LogToFile As Boolean
property bool LogToFile {
    bool get ();
    void set (bool value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Protocol Property

Protocol Property
Namespaces ► VisualCronAPI ► Client..::._Client ► Protocol

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.Protocol]

Declaration Syntax
C# Visual Basic Visual C++
string Protocol { get; }
ReadOnly Property Protocol As String
property String^ Protocol {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ReportError Method (ec, proxySettings)

ReportError Method (ec, proxySettings)
Namespaces ► VisualCronAPI ► Client..::._Client ► ReportError(ErrorReportClass, OpenProxyClass)

[Missing <summary> documentation for M:VisualCronAPI.Client._Client.ReportError(VisualCronAPI.VCWWW.ErrorReport.ErrorReportClass,VisualCronAPI.OpenProxyClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ReportError(
    ErrorReportClass ec,
    OpenProxyClass proxySettings
)
Sub ReportError ( _
    ec As ErrorReportClass, _
    proxySettings As OpenProxyClass _
)
void ReportError(
    ErrorReportClass^ ec,
    OpenProxyClass^ proxySettings
)
Parameters
ec (ErrorReportClass)

[Missing <param name="ec"/> documentation for "M:VisualCronAPI.Client._Client.ReportError(VisualCronAPI.VCWWW.ErrorReport.ErrorReportClass,VisualCronAPI.OpenProxyClass)"]

proxySettings (OpenProxyClass)

[Missing <param name="proxySettings"/> documentation for "M:VisualCronAPI.Client._Client.ReportError(VisualCronAPI.VCWWW.ErrorReport.ErrorReportClass,VisualCronAPI.OpenProxyClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Servers Property

Servers Property
Namespaces ► VisualCronAPI ► Client..::._Client ► Servers

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.Servers]

Declaration Syntax
C# Visual Basic Visual C++
Servers Servers { get; set; }
Property Servers As Servers
property Servers^ Servers {
    Servers^ get ();
    void set (Servers^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


User Property

User Property
Namespaces ► VisualCronAPI ► Client..::._Client ► User

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.User]

Declaration Syntax
C# Visual Basic Visual C++
SecUserClass User { get; }
ReadOnly Property User As SecUserClass
property SecUserClass^ User {
    SecUserClass^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Version Property

Version Property
Namespaces ► VisualCronAPI ► Client..::._Client ► Version

[Missing <summary> documentation for P:VisualCronAPI.Client._Client.Version]

Declaration Syntax
C# Visual Basic Visual C++
string Version { get; }
ReadOnly Property Version As String
property String^ Version {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ClientLoginFailedException Class

Client..::.ClientLoginFailedException Class
Namespaces ► VisualCronAPI ► Client ► Client..::.ClientLoginFailedException
Is throwed when client login failed
Declaration Syntax
C# Visual Basic Visual C++
public class ClientLoginFailedException : Exception
Public Class ClientLoginFailedException _
    Inherits Exception
public ref class ClientLoginFailedException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Client..::.ClientLoginFailedException(String, LoginResultClass) | Initializes a new instance of the Client..::.ClientLoginFailedException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | LoginResult |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Client..::.ClientLoginFailedException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ClientLoginFailedException Constructor (strException, lrc)

Client..::.ClientLoginFailedException Constructor (strException, lrc)
Namespaces ► VisualCronAPI ► Client..::.ClientLoginFailedException ► Client..::.ClientLoginFailedException(String, LoginResultClass)
Initializes a new instance of the Client..::.ClientLoginFailedException class
Declaration Syntax
C# Visual Basic Visual C++
public ClientLoginFailedException(
    string strException,
    LoginResultClass lrc
)
Public Sub New ( _
    strException As String, _
    lrc As LoginResultClass _
)
public:
ClientLoginFailedException(
    String^ strException,
    LoginResultClass^ lrc
)
Parameters
strException (String)

[Missing <param name="strException"/> documentation for "M:VisualCronAPI.Client.ClientLoginFailedException.#ctor(System.String,VisualCron.LoginResultClass)"]

lrc (LoginResultClass)

[Missing <param name="lrc"/> documentation for "M:VisualCronAPI.Client.ClientLoginFailedException.#ctor(System.String,VisualCron.LoginResultClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LoginResult Property

LoginResult Property
Namespaces ► VisualCronAPI ► Client..::.ClientLoginFailedException ► LoginResult

[Missing <summary> documentation for P:VisualCronAPI.Client.ClientLoginFailedException.LoginResult]

Declaration Syntax
C# Visual Basic Visual C++
public LoginResultClass LoginResult { get; set; }
Public Property LoginResult As LoginResultClass
public:
property LoginResultClass^ LoginResult {
    LoginResultClass^ get ();
    void set (LoginResultClass^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ConnectionLimitedException Class

Client..::.ConnectionLimitedException Class
Namespaces ► VisualCronAPI ► Client ► Client..::.ConnectionLimitedException
Is throwed when the server connection is limited in some way
Declaration Syntax
C# Visual Basic Visual C++
public class ConnectionLimitedException : Exception
Public Class ConnectionLimitedException _
    Inherits Exception
public ref class ConnectionLimitedException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Client..::.ConnectionLimitedException(String) | Initializes a new instance of the Client..::.ConnectionLimitedException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Client..::.ConnectionLimitedException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ConnectionLimitedException Constructor (strException)

Client..::.ConnectionLimitedException Constructor (strException)
Namespaces ► VisualCronAPI ► Client..::.ConnectionLimitedException ► Client..::.ConnectionLimitedException(String)
Initializes a new instance of the Client..::.ConnectionLimitedException class
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionLimitedException(
    string strException
)
Public Sub New ( _
    strException As String _
)
public:
ConnectionLimitedException(
    String^ strException
)
Parameters
strException (String)

[Missing <param name="strException"/> documentation for "M:VisualCronAPI.Client.ConnectionLimitedException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ConnectionTypeNotSupportedException Class

Client..::.ConnectionTypeNotSupportedException Class
Namespaces ► VisualCronAPI ► Client ► Client..::.ConnectionTypeNotSupportedException
Is throwed when the Connection type is not implemented.
Declaration Syntax
C# Visual Basic Visual C++
public class ConnectionTypeNotSupportedException : Exception
Public Class ConnectionTypeNotSupportedException _
    Inherits Exception
public ref class ConnectionTypeNotSupportedException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Client..::.ConnectionTypeNotSupportedException()()() | Initializes a new instance of the Client..::.ConnectionTypeNotSupportedException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Client..::.ConnectionTypeNotSupportedException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ConnectionTypeNotSupportedException Constructor

Client..::.ConnectionTypeNotSupportedException Constructor
Namespaces ► VisualCronAPI ► Client..::.ConnectionTypeNotSupportedException ► Client..::.ConnectionTypeNotSupportedException()()()
Initializes a new instance of the Client..::.ConnectionTypeNotSupportedException class
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionTypeNotSupportedException()
Public Sub New
public:
ConnectionTypeNotSupportedException()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.DelegateFileExplorerMessage Delegate

Client..::.DelegateFileExplorerMessage Delegate
Namespaces ► VisualCronAPI ► Client ► Client..::.DelegateFileExplorerMessage

[Missing <summary> documentation for T:VisualCronAPI.Client.DelegateFileExplorerMessage]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateFileExplorerMessage(
    MessageClass mc,
    ref Server s
)
Public Delegate Sub DelegateFileExplorerMessage ( _
    mc As MessageClass, _
    ByRef s As Server _
)
public delegate void DelegateFileExplorerMessage(
    MessageClass^ mc,
    Server^% s
)
Parameters
mc (MessageClass)
s ( Server %)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.DelegateOnConnected Delegate

Client..::.DelegateOnConnected Delegate
Namespaces ► VisualCronAPI ► Client ► Client..::.DelegateOnConnected

[Missing <summary> documentation for T:VisualCronAPI.Client.DelegateOnConnected]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnConnected(
    Client c,
    ref Server s
)
Public Delegate Sub DelegateOnConnected ( _
    c As Client, _
    ByRef s As Server _
)
public delegate void DelegateOnConnected(
    Client^ c,
    Server^% s
)
Parameters
c (Client)
s ( Server %)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.DelegateOnConnectionProgress Delegate

Client..::.DelegateOnConnectionProgress Delegate
Namespaces ► VisualCronAPI ► Client ► Client..::.DelegateOnConnectionProgress

[Missing <summary> documentation for T:VisualCronAPI.Client.DelegateOnConnectionProgress]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnConnectionProgress(
    Client c,
    ref Server s,
    int percentDone
)
Public Delegate Sub DelegateOnConnectionProgress ( _
    c As Client, _
    ByRef s As Server, _
    percentDone As Integer _
)
public delegate void DelegateOnConnectionProgress(
    Client^ c,
    Server^% s,
    int percentDone
)
Parameters
c (Client)
s ( Server %)
percentDone (Int32)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.DelegateOnDisconnect Delegate

Client..::.DelegateOnDisconnect Delegate
Namespaces ► VisualCronAPI ► Client ► Client..::.DelegateOnDisconnect

[Missing <summary> documentation for T:VisualCronAPI.Client.DelegateOnDisconnect]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnDisconnect(
    Client c,
    ref Server s,
    bool bolIsException,
    string strError
)
Public Delegate Sub DelegateOnDisconnect ( _
    c As Client, _
    ByRef s As Server, _
    bolIsException As Boolean, _
    strError As String _
)
public delegate void DelegateOnDisconnect(
    Client^ c,
    Server^% s,
    bool bolIsException,
    String^ strError
)
Parameters
c (Client)
s ( Server %)
bolIsException (Boolean)
strError (String)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.DelegateOnMessageBox Delegate

Client..::.DelegateOnMessageBox Delegate
Namespaces ► VisualCronAPI ► Client ► Client..::.DelegateOnMessageBox

[Missing <summary> documentation for T:VisualCronAPI.Client.DelegateOnMessageBox]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnMessageBox(
    ref Server server,
    MessageBoxClass mb
)
Public Delegate Sub DelegateOnMessageBox ( _
    ByRef server As Server, _
    mb As MessageBoxClass _
)
public delegate void DelegateOnMessageBox(
    Server^% server,
    MessageBoxClass^ mb
)
Parameters
server ( Server %)
mb (MessageBoxClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.DelegateOnSyncComplete Delegate

Client..::.DelegateOnSyncComplete Delegate
Namespaces ► VisualCronAPI ► Client ► Client..::.DelegateOnSyncComplete

[Missing <summary> documentation for T:VisualCronAPI.Client.DelegateOnSyncComplete]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnSyncComplete(
    Client c,
    ref Server s
)
Public Delegate Sub DelegateOnSyncComplete ( _
    c As Client, _
    ByRef s As Server _
)
public delegate void DelegateOnSyncComplete(
    Client^ c,
    Server^% s
)
Parameters
c (Client)
s ( Server %)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.DelegateServerStatusChanged Delegate

Client..::.DelegateServerStatusChanged Delegate
Namespaces ► VisualCronAPI ► Client ► Client..::.DelegateServerStatusChanged

[Missing <summary> documentation for T:VisualCronAPI.Client.DelegateServerStatusChanged]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateServerStatusChanged(
    Client c,
    ref Server s,
    bool ServerOn
)
Public Delegate Sub DelegateServerStatusChanged ( _
    c As Client, _
    ByRef s As Server, _
    ServerOn As Boolean _
)
public delegate void DelegateServerStatusChanged(
    Client^ c,
    Server^% s,
    bool ServerOn
)
Parameters
c (Client)
s ( Server %)
ServerOn (Boolean)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ProtocolObsoleteException Class

Client..::.ProtocolObsoleteException Class
Namespaces ► VisualCronAPI ► Client ► Client..::.ProtocolObsoleteException
Is throwed when client or server protocol is too old for communicating, i.e. new features and functions may have been added to server or client.
Declaration Syntax
C# Visual Basic Visual C++
public class ProtocolObsoleteException : Exception
Public Class ProtocolObsoleteException _
    Inherits Exception
public ref class ProtocolObsoleteException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Client..::.ProtocolObsoleteException(String) | Initializes a new instance of the Client..::.ProtocolObsoleteException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Client..::.ProtocolObsoleteException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client.ProtocolObsoleteException Constructor (strException)

Client..::.ProtocolObsoleteException Constructor (strException)
Namespaces ► VisualCronAPI ► Client..::.ProtocolObsoleteException ► Client..::.ProtocolObsoleteException(String)
Initializes a new instance of the Client..::.ProtocolObsoleteException class
Declaration Syntax
C# Visual Basic Visual C++
public ProtocolObsoleteException(
    string strException
)
Public Sub New ( _
    strException As String _
)
public:
ProtocolObsoleteException(
    String^ strException
)
Parameters
strException (String)

[Missing <param name="strException"/> documentation for "M:VisualCronAPI.Client.ProtocolObsoleteException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections Class

ClientConnections Class
Namespaces ► VisualCronAPI ► ClientConnections
Base class for Client connections
Declaration Syntax
C# Visual Basic Visual C++
public class ClientConnections : ClientConnections..::._ClientConnections
Public Class ClientConnections _
    Implements ClientConnections..::._ClientConnections
public ref class ClientConnections : ClientConnections..::._ClientConnections
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientConnections(Server) | Initializes a new instance of the ClientConnections class
 | ClientConnectionAdded | This event is raised when a ClientConnection has been added
 | ClientConnectionAddedStatic | This event is raised when a ClientConnection has been added
 | ClientConnectionRemoved | This event is raised when a ClientConnection has been removed
 | ClientConnectionRemovedStatic | This event is raised when a ClientConnection has been removed
 | ClientConnectionUpdated | This event is raised when a ClientConnection has been updated
 | ClientConnectionUpdatedStatic | This event is raised when a ClientConnection has been updated
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a ClientConnection based on the string key Id
 | GetAll()()() | Returns a list of ClientConnections
 | GetAllArray()()() | Returns an array of ClientConnections
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAnyTrayClientConnected()()() | Returns true if any Tray Client is connected to the Server
 | IsTrayClientRunning()()() | Returns true if the Tray Client is running on the Server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
ClientConnections

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections Constructor (s)

ClientConnections Constructor (s)
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnections(Server)
Initializes a new instance of the ClientConnections class
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnections(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
ClientConnections(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.ClientConnections.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionAdded Event

ClientConnectionAdded Event
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnectionAdded
This event is raised when a ClientConnection has been added
Declaration Syntax
C# Visual Basic Visual C++
public event ClientConnections..::.DelegateClientConnectionAdded ClientConnectionAdded
Public Event ClientConnectionAdded As ClientConnections..::.DelegateClientConnectionAdded
public:
 event ClientConnections..::.DelegateClientConnectionAdded^ ClientConnectionAdded {
    void add (ClientConnections..::.DelegateClientConnectionAdded^ value);
    void remove (ClientConnections..::.DelegateClientConnectionAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionAddedStatic Event

ClientConnectionAddedStatic Event
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnectionAddedStatic
This event is raised when a ClientConnection has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event ClientConnections..::.DelegateClientConnectionAdded ClientConnectionAddedStatic
Public Shared Event ClientConnectionAddedStatic As ClientConnections..::.DelegateClientConnectionAdded
public:
static  event ClientConnections..::.DelegateClientConnectionAdded^ ClientConnectionAddedStatic {
    void add (ClientConnections..::.DelegateClientConnectionAdded^ value);
    void remove (ClientConnections..::.DelegateClientConnectionAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionRemoved Event

ClientConnectionRemoved Event
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnectionRemoved
This event is raised when a ClientConnection has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event ClientConnections..::.DelegateClientConnectionRemoved ClientConnectionRemoved
Public Event ClientConnectionRemoved As ClientConnections..::.DelegateClientConnectionRemoved
public:
 event ClientConnections..::.DelegateClientConnectionRemoved^ ClientConnectionRemoved {
    void add (ClientConnections..::.DelegateClientConnectionRemoved^ value);
    void remove (ClientConnections..::.DelegateClientConnectionRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionRemovedStatic Event

ClientConnectionRemovedStatic Event
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnectionRemovedStatic
This event is raised when a ClientConnection has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event ClientConnections..::.DelegateClientConnectionRemoved ClientConnectionRemovedStatic
Public Shared Event ClientConnectionRemovedStatic As ClientConnections..::.DelegateClientConnectionRemoved
public:
static  event ClientConnections..::.DelegateClientConnectionRemoved^ ClientConnectionRemovedStatic {
    void add (ClientConnections..::.DelegateClientConnectionRemoved^ value);
    void remove (ClientConnections..::.DelegateClientConnectionRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionUpdated Event

ClientConnectionUpdated Event
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnectionUpdated
This event is raised when a ClientConnection has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event ClientConnections..::.DelegateClientConnectionUpdated ClientConnectionUpdated
Public Event ClientConnectionUpdated As ClientConnections..::.DelegateClientConnectionUpdated
public:
 event ClientConnections..::.DelegateClientConnectionUpdated^ ClientConnectionUpdated {
    void add (ClientConnections..::.DelegateClientConnectionUpdated^ value);
    void remove (ClientConnections..::.DelegateClientConnectionUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionUpdatedStatic Event

ClientConnectionUpdatedStatic Event
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnectionUpdatedStatic
This event is raised when a ClientConnection has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event ClientConnections..::.DelegateClientConnectionUpdated ClientConnectionUpdatedStatic
Public Shared Event ClientConnectionUpdatedStatic As ClientConnections..::.DelegateClientConnectionUpdated
public:
static  event ClientConnections..::.DelegateClientConnectionUpdated^ ClientConnectionUpdatedStatic {
    void add (ClientConnections..::.DelegateClientConnectionUpdated^ value);
    void remove (ClientConnections..::.DelegateClientConnectionUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► ClientConnections ► Get(String)
Returns a ClientConnection based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionClass Get(
    string id
)
Public Function Get ( _
    id As String _
) As ClientConnectionClass
public:
virtual ClientConnectionClass^ Get(
    String^ id
) sealed
Parameters
id (String)
string key
Return Value
a Connection
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► ClientConnections ► GetAll()()()
Returns a list of ClientConnections
Declaration Syntax
C# Visual Basic Visual C++
public List<ClientConnectionClass> GetAll()
Public Function GetAll As List(Of ClientConnectionClass)
public:
List<ClientConnectionClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► ClientConnections ► GetAllArray()()()
Returns an array of ClientConnections
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsAnyTrayClientConnected Method

IsAnyTrayClientConnected Method
Namespaces ► VisualCronAPI ► ClientConnections ► IsAnyTrayClientConnected()()()
Returns true if any Tray Client is connected to the Server
Declaration Syntax
C# Visual Basic Visual C++
public bool IsAnyTrayClientConnected()
Public Function IsAnyTrayClientConnected As Boolean
public:
virtual bool IsAnyTrayClientConnected() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections.IsAnyTrayClientConnected]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTrayClientRunning Method

IsTrayClientRunning Method
Namespaces ► VisualCronAPI ► ClientConnections ► IsTrayClientRunning()()()
Returns true if the Tray Client is running on the Server
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTrayClientRunning()
Public Function IsTrayClientRunning As Boolean
public:
virtual bool IsTrayClientRunning() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections.IsTrayClientRunning]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections.__ClientConnections Interface

ClientConnections..::.__ClientConnections Interface
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnections..::.__ClientConnections

[Missing <summary> documentation for T:VisualCronAPI.ClientConnections.__ClientConnections]

Declaration Syntax
C# Visual Basic Visual C++
public interface __ClientConnections
Public Interface __ClientConnections
public interface class __ClientConnections
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ClientConnectionAdded(Server%, ClientConnectionClass) |
 | ClientConnectionRemoved(Server%, ClientConnectionClass) |
 | ClientConnectionUpdated(Server%, ClientConnectionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionAdded Method (server, cc)

ClientConnectionAdded Method (server, cc)
Namespaces ► VisualCronAPI ► ClientConnections..::.__ClientConnections ► ClientConnectionAdded(Server%, ClientConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionAdded(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ClientConnectionAdded(
    ref Server server,
    ClientConnectionClass cc
)
Sub ClientConnectionAdded ( _
    ByRef server As Server, _
    cc As ClientConnectionClass _
)
void ClientConnectionAdded(
    Server^% server,
    ClientConnectionClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionAdded(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)"]

cc (ClientConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionAdded(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionRemoved Method (server, cc)

ClientConnectionRemoved Method (server, cc)
Namespaces ► VisualCronAPI ► ClientConnections..::.__ClientConnections ► ClientConnectionRemoved(Server%, ClientConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionRemoved(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ClientConnectionRemoved(
    ref Server server,
    ClientConnectionClass cc
)
Sub ClientConnectionRemoved ( _
    ByRef server As Server, _
    cc As ClientConnectionClass _
)
void ClientConnectionRemoved(
    Server^% server,
    ClientConnectionClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionRemoved(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)"]

cc (ClientConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionRemoved(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnectionUpdated Method (server, cc)

ClientConnectionUpdated Method (server, cc)
Namespaces ► VisualCronAPI ► ClientConnections..::.__ClientConnections ► ClientConnectionUpdated(Server%, ClientConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionUpdated(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ClientConnectionUpdated(
    ref Server server,
    ClientConnectionClass cc
)
Sub ClientConnectionUpdated ( _
    ByRef server As Server, _
    cc As ClientConnectionClass _
)
void ClientConnectionUpdated(
    Server^% server,
    ClientConnectionClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionUpdated(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)"]

cc (ClientConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.ClientConnections.__ClientConnections.ClientConnectionUpdated(VisualCronAPI.Server@,VisualCron.ClientConnectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections._ClientConnections Interface

ClientConnections..::._ClientConnections Interface
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnections..::._ClientConnections

[Missing <summary> documentation for T:VisualCronAPI.ClientConnections._ClientConnections]

Declaration Syntax
C# Visual Basic Visual C++
public interface _ClientConnections
Public Interface _ClientConnections
public interface class _ClientConnections
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Get(String) |
 | GetAllArray()()() |
 | IsAnyTrayClientConnected()()() |
 | IsTrayClientRunning()()() |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► ClientConnections..::._ClientConnections ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ClientConnectionClass Get(
    string id
)
Function Get ( _
    id As String _
) As ClientConnectionClass
ClientConnectionClass^ Get(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.ClientConnections._ClientConnections.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► ClientConnections..::._ClientConnections ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsAnyTrayClientConnected Method

IsAnyTrayClientConnected Method
Namespaces ► VisualCronAPI ► ClientConnections..::._ClientConnections ► IsAnyTrayClientConnected()()()

[Missing <summary> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.IsAnyTrayClientConnected]

Declaration Syntax
C# Visual Basic Visual C++
bool IsAnyTrayClientConnected()
Function IsAnyTrayClientConnected As Boolean
bool IsAnyTrayClientConnected()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.IsAnyTrayClientConnected]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTrayClientRunning Method

IsTrayClientRunning Method
Namespaces ► VisualCronAPI ► ClientConnections..::._ClientConnections ► IsTrayClientRunning()()()

[Missing <summary> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.IsTrayClientRunning]

Declaration Syntax
C# Visual Basic Visual C++
bool IsTrayClientRunning()
Function IsTrayClientRunning As Boolean
bool IsTrayClientRunning()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientConnections._ClientConnections.IsTrayClientRunning]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections.ClientConnectionNotFoundException Class

ClientConnections..::.ClientConnectionNotFoundException Class
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnections..::.ClientConnectionNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.ClientConnections.ClientConnectionNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class ClientConnectionNotFoundException : Exception
Public Class ClientConnectionNotFoundException _
    Inherits Exception
public ref class ClientConnectionNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientConnections..::.ClientConnectionNotFoundException(String) | Initializes a new instance of the ClientConnections..::.ClientConnectionNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ClientConnections..::.ClientConnectionNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections.ClientConnectionNotFoundException Constructor (id)

ClientConnections..::.ClientConnectionNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► ClientConnections..::.ClientConnectionNotFoundException ► ClientConnections..::.ClientConnectionNotFoundException(String)
Initializes a new instance of the ClientConnections..::.ClientConnectionNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
ClientConnectionNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.ClientConnections.ClientConnectionNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections.DelegateClientConnectionAdded Delegate

ClientConnections..::.DelegateClientConnectionAdded Delegate
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnections..::.DelegateClientConnectionAdded

[Missing <summary> documentation for T:VisualCronAPI.ClientConnections.DelegateClientConnectionAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateClientConnectionAdded(
    ref Server server,
    ClientConnectionClass cc
)
Public Delegate Sub DelegateClientConnectionAdded ( _
    ByRef server As Server, _
    cc As ClientConnectionClass _
)
public delegate void DelegateClientConnectionAdded(
    Server^% server,
    ClientConnectionClass^ cc
)
Parameters
server ( Server %)
cc (ClientConnectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections.DelegateClientConnectionRemoved Delegate

ClientConnections..::.DelegateClientConnectionRemoved Delegate
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnections..::.DelegateClientConnectionRemoved

[Missing <summary> documentation for T:VisualCronAPI.ClientConnections.DelegateClientConnectionRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateClientConnectionRemoved(
    ref Server server,
    ClientConnectionClass cc
)
Public Delegate Sub DelegateClientConnectionRemoved ( _
    ByRef server As Server, _
    cc As ClientConnectionClass _
)
public delegate void DelegateClientConnectionRemoved(
    Server^% server,
    ClientConnectionClass^ cc
)
Parameters
server ( Server %)
cc (ClientConnectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections.DelegateClientConnectionUpdated Delegate

ClientConnections..::.DelegateClientConnectionUpdated Delegate
Namespaces ► VisualCronAPI ► ClientConnections ► ClientConnections..::.DelegateClientConnectionUpdated

[Missing <summary> documentation for T:VisualCronAPI.ClientConnections.DelegateClientConnectionUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateClientConnectionUpdated(
    ref Server server,
    ClientConnectionClass cc
)
Public Delegate Sub DelegateClientConnectionUpdated ( _
    ByRef server As Server, _
    cc As ClientConnectionClass _
)
public delegate void DelegateClientConnectionUpdated(
    Server^% server,
    ClientConnectionClass^ cc
)
Parameters
server ( Server %)
cc (ClientConnectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientLog Class

ClientLog Class
Namespaces ► VisualCronAPI ► ClientLog

[Missing <summary> documentation for T:VisualCronAPI.ClientLog]

Declaration Syntax
C# Visual Basic Visual C++
public class ClientLog
Public Class ClientLog
public ref class ClientLog
Members
All Members | Constructors | Methods | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClientLog(Client%) | Initializes a new instance of the ClientLog class
 | AddEvent(LogClass) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll()()() | Returns a list of all Log items
 | GetAllArray()()() | Returns an array of all Log items
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LastClientEvent |
 | LogAdded | This event is raised when a Log item is added
 | LogAddedStatic | This event is raised when a Log item is added
 | LogArrayAdded | This event is raised when a Log item array is added
 | LogArrayAddedStatic | This event is raised when a Log item array is added
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ClientLog

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientLog Constructor (c)

ClientLog Constructor (c)
Namespaces ► VisualCronAPI ► ClientLog ► ClientLog(Client%)
Initializes a new instance of the ClientLog class
Declaration Syntax
C# Visual Basic Visual C++
public ClientLog(
    ref Client c
)
Public Sub New ( _
    ByRef c As Client _
)
public:
ClientLog(
    Client^% c
)
Parameters
c ( Client %)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.ClientLog.#ctor(VisualCronAPI.Client@)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AddEvent Method (lc)

AddEvent Method (lc)
Namespaces ► VisualCronAPI ► ClientLog ► AddEvent(LogClass)

[Missing <summary> documentation for M:VisualCronAPI.ClientLog.AddEvent(VisualCron.LogClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddEvent(
    LogClass lc
)
Public Sub AddEvent ( _
    lc As LogClass _
)
public:
void AddEvent(
    LogClass^ lc
)
Parameters
lc (LogClass)

[Missing <param name="lc"/> documentation for "M:VisualCronAPI.ClientLog.AddEvent(VisualCron.LogClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► ClientLog ► GetAll()()()
Returns a list of all Log items
Declaration Syntax
C# Visual Basic Visual C++
public List<LogClass> GetAll()
Public Function GetAll As List(Of LogClass)
public:
List<LogClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientLog.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► ClientLog ► GetAllArray()()()
Returns an array of all Log items
Declaration Syntax
C# Visual Basic Visual C++
public LogClass[] GetAllArray()
Public Function GetAllArray As LogClass()
public:
array<LogClass^>^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ClientLog.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LastClientEvent Field

LastClientEvent Field
Namespaces ► VisualCronAPI ► ClientLog ► LastClientEvent

[Missing <summary> documentation for F:VisualCronAPI.ClientLog.LastClientEvent]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime LastClientEvent
Public LastClientEvent As DateTime
public:
DateTime LastClientEvent

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAdded Event

LogAdded Event
Namespaces ► VisualCronAPI ► ClientLog ► LogAdded
This event is raised when a Log item is added
Declaration Syntax
C# Visual Basic Visual C++
public event ClientLog..::.DelegateLogAdded LogAdded
Public Event LogAdded As ClientLog..::.DelegateLogAdded
public:
 event ClientLog..::.DelegateLogAdded^ LogAdded {
    void add (ClientLog..::.DelegateLogAdded^ value);
    void remove (ClientLog..::.DelegateLogAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAddedStatic Event

LogAddedStatic Event
Namespaces ► VisualCronAPI ► ClientLog ► LogAddedStatic
This event is raised when a Log item is added
Declaration Syntax
C# Visual Basic Visual C++
public static event ClientLog..::.DelegateLogAdded LogAddedStatic
Public Shared Event LogAddedStatic As ClientLog..::.DelegateLogAdded
public:
static  event ClientLog..::.DelegateLogAdded^ LogAddedStatic {
    void add (ClientLog..::.DelegateLogAdded^ value);
    void remove (ClientLog..::.DelegateLogAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogArrayAdded Event

LogArrayAdded Event
Namespaces ► VisualCronAPI ► ClientLog ► LogArrayAdded
This event is raised when a Log item array is added
Declaration Syntax
C# Visual Basic Visual C++
public event ClientLog..::.DelegateLogArrayAdded LogArrayAdded
Public Event LogArrayAdded As ClientLog..::.DelegateLogArrayAdded
public:
 event ClientLog..::.DelegateLogArrayAdded^ LogArrayAdded {
    void add (ClientLog..::.DelegateLogArrayAdded^ value);
    void remove (ClientLog..::.DelegateLogArrayAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogArrayAddedStatic Event

LogArrayAddedStatic Event
Namespaces ► VisualCronAPI ► ClientLog ► LogArrayAddedStatic
This event is raised when a Log item array is added
Declaration Syntax
C# Visual Basic Visual C++
public event ClientLog..::.DelegateLogArrayAdded LogArrayAddedStatic
Public Event LogArrayAddedStatic As ClientLog..::.DelegateLogArrayAdded
public:
 event ClientLog..::.DelegateLogArrayAdded^ LogArrayAddedStatic {
    void add (ClientLog..::.DelegateLogArrayAdded^ value);
    void remove (ClientLog..::.DelegateLogArrayAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientLog.DelegateLogAdded Delegate

ClientLog..::.DelegateLogAdded Delegate
Namespaces ► VisualCronAPI ► ClientLog ► ClientLog..::.DelegateLogAdded

[Missing <summary> documentation for T:VisualCronAPI.ClientLog.DelegateLogAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateLogAdded(
    LogClass lc,
    ref Client c
)
Public Delegate Sub DelegateLogAdded ( _
    lc As LogClass, _
    ByRef c As Client _
)
public delegate void DelegateLogAdded(
    LogClass^ lc,
    Client^% c
)
Parameters
lc (LogClass)
c ( Client %)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientLog.DelegateLogArrayAdded Delegate

ClientLog..::.DelegateLogArrayAdded Delegate
Namespaces ► VisualCronAPI ► ClientLog ► ClientLog..::.DelegateLogArrayAdded

[Missing <summary> documentation for T:VisualCronAPI.ClientLog.DelegateLogArrayAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateLogArrayAdded(
    LogClass[] lc,
    ref Client c
)
Public Delegate Sub DelegateLogArrayAdded ( _
    lc As LogClass(), _
    ByRef c As Client _
)
public delegate void DelegateLogArrayAdded(
    array<LogClass^>^ lc,
    Client^% c
)
Parameters
lc (array< LogClass >[]()[])
c ( Client %)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Computer Class

Computer Class
Namespaces ► VisualCronAPI ► Computer

[Missing <summary> documentation for T:VisualCronAPI.Computer]

Declaration Syntax
C# Visual Basic Visual C++
public class Computer
Public Class Computer
public ref class Computer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Computer(Server%) | Initializes a new instance of the Computer class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPrinterNames()()() | Retrieves a list of Printers on the Server
 | GetProcesses()()() | Returns a list of ProcessClass which contains running processes on the Server
 | GetProcessesArray()()() | Returns a list of ProcessClass which contains running processes on the Server
 | GetServerInfo(Boolean) | Returns server information such as CPU, operating system, VisualCron process info
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCluster | Gets or sets whether the Server hosting VisualCron is in a cluster environment
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperativeSystem | Retrieves operating system of the Server hosting VisualCron
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Computer

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Computer Constructor (s)

Computer Constructor (s)
Namespaces ► VisualCronAPI ► Computer ► Computer(Server%)
Initializes a new instance of the Computer class
Declaration Syntax
C# Visual Basic Visual C++
public Computer(
    ref Server s
)
Public Sub New ( _
    ByRef s As Server _
)
public:
Computer(
    Server^% s
)
Parameters
s ( Server %)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Computer.#ctor(VisualCronAPI.Server@)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetPrinterNames Method

GetPrinterNames Method
Namespaces ► VisualCronAPI ► Computer ► GetPrinterNames()()()
Retrieves a list of Printers on the Server
Declaration Syntax
C# Visual Basic Visual C++
public List<string> GetPrinterNames()
Public Function GetPrinterNames As List(Of String)
public:
List<String^>^ GetPrinterNames()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Computer.GetPrinterNames]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetProcesses Method

GetProcesses Method
Namespaces ► VisualCronAPI ► Computer ► GetProcesses()()()
Returns a list of ProcessClass which contains running processes on the Server
Declaration Syntax
C# Visual Basic Visual C++
public List<ProcessClass> GetProcesses()
Public Function GetProcesses As List(Of ProcessClass)
public:
List<ProcessClass^>^ GetProcesses()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Computer.GetProcesses]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetProcessesArray Method

GetProcessesArray Method
Namespaces ► VisualCronAPI ► Computer ► GetProcessesArray()()()
Returns a list of ProcessClass which contains running processes on the Server
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetProcessesArray()
Public Function GetProcessesArray As ArrayList
public:
ArrayList^ GetProcessesArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Computer.GetProcessesArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetServerInfo Method (bolRefresh)

GetServerInfo Method (bolRefresh)
Namespaces ► VisualCronAPI ► Computer ► GetServerInfo(Boolean)
Returns server information such as CPU, operating system, VisualCron process info
Declaration Syntax
C# Visual Basic Visual C++
public ServerInfoClass GetServerInfo(
    bool bolRefresh
)
Public Function GetServerInfo ( _
    bolRefresh As Boolean _
) As ServerInfoClass
public:
ServerInfoClass^ GetServerInfo(
    bool bolRefresh
)
Parameters
bolRefresh (Boolean)
If informations should be refreshed from server first (takes some extra seconds)
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Computer.GetServerInfo(System.Boolean)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsCluster Property

IsCluster Property
Namespaces ► VisualCronAPI ► Computer ► IsCluster
Gets or sets whether the Server hosting VisualCron is in a cluster environment
Declaration Syntax
C# Visual Basic Visual C++
public bool IsCluster { get; set; }
Public Property IsCluster As Boolean
public:
property bool IsCluster {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


OperativeSystem Property

OperativeSystem Property
Namespaces ► VisualCronAPI ► Computer ► OperativeSystem
Retrieves operating system of the Server hosting VisualCron
Declaration Syntax
C# Visual Basic Visual C++
public ServerSettingsClass..::.OperativeSystemT OperativeSystem { get; internal set; }
Public Property OperativeSystem As ServerSettingsClass..::.OperativeSystemT
public:
property ServerSettingsClass..::.OperativeSystemT OperativeSystem {
    ServerSettingsClass..::.OperativeSystemT get ();
    void set (ServerSettingsClass..::.OperativeSystemT value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ComputerInfoAPI Class

ComputerInfoAPI Class
Namespaces ► VisualCronAPI ► ComputerInfoAPI

[Missing <summary> documentation for T:VisualCronAPI.ComputerInfoAPI]

Declaration Syntax
C# Visual Basic Visual C++
public class ComputerInfoAPI
Public Class ComputerInfoAPI
public ref class ComputerInfoAPI
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ComputerInfoAPI()()() | Initializes a new instance of the ComputerInfoAPI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetOSBitSize()()() |
 | GetOSVersion()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OperativeSystem |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ComputerInfoAPI

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ComputerInfoAPI Constructor

ComputerInfoAPI Constructor
Namespaces ► VisualCronAPI ► ComputerInfoAPI ► ComputerInfoAPI()()()
Initializes a new instance of the ComputerInfoAPI class
Declaration Syntax
C# Visual Basic Visual C++
public ComputerInfoAPI()
Public Sub New
public:
ComputerInfoAPI()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetOSBitSize Method

GetOSBitSize Method
Namespaces ► VisualCronAPI ► ComputerInfoAPI ► GetOSBitSize()()()

[Missing <summary> documentation for M:VisualCronAPI.ComputerInfoAPI.GetOSBitSize]

Declaration Syntax
C# Visual Basic Visual C++
public static ComputerInfoAPI..::.OSBitSizeT GetOSBitSize()
Public Shared Function GetOSBitSize As ComputerInfoAPI..::.OSBitSizeT
public:
static ComputerInfoAPI..::.OSBitSizeT GetOSBitSize()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ComputerInfoAPI.GetOSBitSize]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetOSVersion Method

GetOSVersion Method
Namespaces ► VisualCronAPI ► ComputerInfoAPI ► GetOSVersion()()()

[Missing <summary> documentation for M:VisualCronAPI.ComputerInfoAPI.GetOSVersion]

Declaration Syntax
C# Visual Basic Visual C++
public static ServerSettingsClass..::.OperativeSystemT GetOSVersion()
Public Shared Function GetOSVersion As ServerSettingsClass..::.OperativeSystemT
public:
static ServerSettingsClass..::.OperativeSystemT GetOSVersion()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.ComputerInfoAPI.GetOSVersion]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


OperativeSystem Field

OperativeSystem Field
Namespaces ► VisualCronAPI ► ComputerInfoAPI ► OperativeSystem

[Missing <summary> documentation for F:VisualCronAPI.ComputerInfoAPI.OperativeSystem]

Declaration Syntax
C# Visual Basic Visual C++
public static ServerSettingsClass..::.OperativeSystemT OperativeSystem
Public Shared OperativeSystem As ServerSettingsClass..::.OperativeSystemT
public:
static ServerSettingsClass..::.OperativeSystemT OperativeSystem

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ComputerInfoAPI.OSBitSizeT Enumeration

ComputerInfoAPI..::.OSBitSizeT Enumeration
Namespaces ► VisualCronAPI ► ComputerInfoAPI ► ComputerInfoAPI..::.OSBitSizeT

[Missing <summary> documentation for T:VisualCronAPI.ComputerInfoAPI.OSBitSizeT]

Declaration Syntax
C# Visual Basic Visual C++
public enum OSBitSizeT
Public Enumeration OSBitSizeT
public enum class OSBitSizeT
Members
Member | Description
x64 |
x86 |
xUnknown |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions Class

Conditions Class
Namespaces ► VisualCronAPI ► Conditions
Base class for Condition Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Conditions : Conditions..::._Conditions
Public Class Conditions _
    Implements Conditions..::._Conditions
public ref class Conditions : Conditions..::._Conditions
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Conditions(Server%) | Initializes a new instance of the Conditions class
 | Add(ConditionSetClass) | Adds a ConditionSet
 | Add(ConditionClass) | Adds a Condition
 | ConditionAdded | This event is raised when a Condition has been added
 | ConditionAddedStatic | This event is raised when a Condition has been added
 | ConditionRemoved | This event is raised when a Condition has been added
 | ConditionRemovedStatic | This event is raised when a Condition has been added
 | ConditionSetAdded | This event is raised when a ConditionSet has been added
 | ConditionSetAddedStatic | This event is raised when a ConditionSet has been added
 | ConditionSetRemoved | This event is raised when a ConditionSet has been removed
 | ConditionSetUpdated | This event is raised when a ConditionSet has been updated
 | ConditionSetUpdatedStatic | This event is raised when a ConditionSet has been updated
 | ConditionUpdated | This event is raised when a Condition has been removed
 | ConditionUpdatedStatic | This event is raised when a Condition has been removed
 | DoConditionExist(ConditionSetClass, ConditionClass) | Returns true if a specified Condition exists
 | DoConditionExist(String, String) | Returns true if a specified Condition exists
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventConditionSetRemovedStatic | This event is raised when a ConditionSet has been removed
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a ConditionSet based on the string key Id
 | GetAll()()() | Returns a list of ConditionSets
 | GetAllArray()()() | Returns an array of ConditionSets
 | GetCondition(String, String) | Retrieves a certain Condition
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(ConditionSetClass) | Removes a ConditionSet
 | Remove(String) | Removes a ConditionSet
 | Remove(ConditionClass) | Removes a Condition
 | Remove(String, String) | Removes a Condition
 | RemoveAll()()() | Removes all Condition sets
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(ConditionSetClass) | Updates a ConditionSet
 | Update(ConditionClass) | Updates a Condition
Remarks
Inheritance Hierarchy
Object
Conditions

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions Constructor (s)

Conditions Constructor (s)
Namespaces ► VisualCronAPI ► Conditions ► Conditions(Server%)
Initializes a new instance of the Conditions class
Declaration Syntax
C# Visual Basic Visual C++
public Conditions(
    ref Server s
)
Public Sub New ( _
    ByRef s As Server _
)
public:
Conditions(
    Server^% s
)
Parameters
s ( Server %)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Conditions.#ctor(VisualCronAPI.Server@)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method

Add Method
Namespaces ► VisualCronAPI ► Conditions ► Add()()()
Members
Icon | Member | Description
 | Add(ConditionSetClass) | Adds a ConditionSet
 | Add(ConditionClass) | Adds a Condition

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (cc)

Add Method (cc)
Namespaces ► VisualCronAPI ► Conditions ► Add(ConditionClass)
Adds a Condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass Add(
    ConditionClass cc
)
Public Function Add ( _
    cc As ConditionClass _
) As ConditionClass
public:
virtual ConditionClass^ Add(
    ConditionClass^ cc
) sealed
Parameters
cc (ConditionClass)
A ConditionClass object
Return Value
a Condition
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (cs)

Add Method (cs)
Namespaces ► VisualCronAPI ► Conditions ► Add(ConditionSetClass)
Adds a ConditionSet
Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetClass Add(
    ConditionSetClass cs
)
Public Function Add ( _
    cs As ConditionSetClass _
) As ConditionSetClass
public:
virtual ConditionSetClass^ Add(
    ConditionSetClass^ cs
) sealed
Parameters
cs (ConditionSetClass)
A ConditionSetClass object
Return Value
a ConditionSet
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionAdded Event

ConditionAdded Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionAdded
This event is raised when a Condition has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Conditions..::.DelegateConditionAdded ConditionAdded
Public Event ConditionAdded As Conditions..::.DelegateConditionAdded
public:
 event Conditions..::.DelegateConditionAdded^ ConditionAdded {
    void add (Conditions..::.DelegateConditionAdded^ value);
    void remove (Conditions..::.DelegateConditionAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionAddedStatic Event

ConditionAddedStatic Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionAddedStatic
This event is raised when a Condition has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Conditions..::.DelegateConditionAdded ConditionAddedStatic
Public Shared Event ConditionAddedStatic As Conditions..::.DelegateConditionAdded
public:
static  event Conditions..::.DelegateConditionAdded^ ConditionAddedStatic {
    void add (Conditions..::.DelegateConditionAdded^ value);
    void remove (Conditions..::.DelegateConditionAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionRemoved Event

ConditionRemoved Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionRemoved
This event is raised when a Condition has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Conditions..::.DelegateConditionRemoved ConditionRemoved
Public Event ConditionRemoved As Conditions..::.DelegateConditionRemoved
public:
 event Conditions..::.DelegateConditionRemoved^ ConditionRemoved {
    void add (Conditions..::.DelegateConditionRemoved^ value);
    void remove (Conditions..::.DelegateConditionRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionRemovedStatic Event

ConditionRemovedStatic Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionRemovedStatic
This event is raised when a Condition has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Conditions..::.DelegateConditionRemoved ConditionRemovedStatic
Public Shared Event ConditionRemovedStatic As Conditions..::.DelegateConditionRemoved
public:
static  event Conditions..::.DelegateConditionRemoved^ ConditionRemovedStatic {
    void add (Conditions..::.DelegateConditionRemoved^ value);
    void remove (Conditions..::.DelegateConditionRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetAdded Event

ConditionSetAdded Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionSetAdded
This event is raised when a ConditionSet has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Conditions..::.DelegateConditionSetAdded ConditionSetAdded
Public Event ConditionSetAdded As Conditions..::.DelegateConditionSetAdded
public:
 event Conditions..::.DelegateConditionSetAdded^ ConditionSetAdded {
    void add (Conditions..::.DelegateConditionSetAdded^ value);
    void remove (Conditions..::.DelegateConditionSetAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetAddedStatic Event

ConditionSetAddedStatic Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionSetAddedStatic
This event is raised when a ConditionSet has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Conditions..::.DelegateConditionSetAdded ConditionSetAddedStatic
Public Shared Event ConditionSetAddedStatic As Conditions..::.DelegateConditionSetAdded
public:
static  event Conditions..::.DelegateConditionSetAdded^ ConditionSetAddedStatic {
    void add (Conditions..::.DelegateConditionSetAdded^ value);
    void remove (Conditions..::.DelegateConditionSetAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetRemoved Event

ConditionSetRemoved Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionSetRemoved
This event is raised when a ConditionSet has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Conditions..::.DelegateConditionSetRemoved ConditionSetRemoved
Public Event ConditionSetRemoved As Conditions..::.DelegateConditionSetRemoved
public:
 event Conditions..::.DelegateConditionSetRemoved^ ConditionSetRemoved {
    void add (Conditions..::.DelegateConditionSetRemoved^ value);
    void remove (Conditions..::.DelegateConditionSetRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetUpdated Event

ConditionSetUpdated Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionSetUpdated
This event is raised when a ConditionSet has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Conditions..::.DelegateConditionSetUpdated ConditionSetUpdated
Public Event ConditionSetUpdated As Conditions..::.DelegateConditionSetUpdated
public:
 event Conditions..::.DelegateConditionSetUpdated^ ConditionSetUpdated {
    void add (Conditions..::.DelegateConditionSetUpdated^ value);
    void remove (Conditions..::.DelegateConditionSetUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetUpdatedStatic Event

ConditionSetUpdatedStatic Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionSetUpdatedStatic
This event is raised when a ConditionSet has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Conditions..::.DelegateConditionSetUpdated ConditionSetUpdatedStatic
Public Shared Event ConditionSetUpdatedStatic As Conditions..::.DelegateConditionSetUpdated
public:
static  event Conditions..::.DelegateConditionSetUpdated^ ConditionSetUpdatedStatic {
    void add (Conditions..::.DelegateConditionSetUpdated^ value);
    void remove (Conditions..::.DelegateConditionSetUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionUpdated Event

ConditionUpdated Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionUpdated
This event is raised when a Condition has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Conditions..::.DelegateConditionUpdated ConditionUpdated
Public Event ConditionUpdated As Conditions..::.DelegateConditionUpdated
public:
 event Conditions..::.DelegateConditionUpdated^ ConditionUpdated {
    void add (Conditions..::.DelegateConditionUpdated^ value);
    void remove (Conditions..::.DelegateConditionUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionUpdatedStatic Event

ConditionUpdatedStatic Event
Namespaces ► VisualCronAPI ► Conditions ► ConditionUpdatedStatic
This event is raised when a Condition has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Conditions..::.DelegateConditionUpdated ConditionUpdatedStatic
Public Shared Event ConditionUpdatedStatic As Conditions..::.DelegateConditionUpdated
public:
static  event Conditions..::.DelegateConditionUpdated^ ConditionUpdatedStatic {
    void add (Conditions..::.DelegateConditionUpdated^ value);
    void remove (Conditions..::.DelegateConditionUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoConditionExist Method

DoConditionExist Method
Namespaces ► VisualCronAPI ► Conditions ► DoConditionExist()()()
Members
Icon | Member | Description
 | DoConditionExist(ConditionSetClass, ConditionClass) | Returns true if a specified Condition exists
 | DoConditionExist(String, String) | Returns true if a specified Condition exists

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoConditionExist Method (strConditionSetId, strConditionId)

DoConditionExist Method (strConditionSetId, strConditionId)
Namespaces ► VisualCronAPI ► Conditions ► DoConditionExist(String, String)
Returns true if a specified Condition exists
Declaration Syntax
C# Visual Basic Visual C++
public bool DoConditionExist(
    string strConditionSetId,
    string strConditionId
)
Public Function DoConditionExist ( _
    strConditionSetId As String, _
    strConditionId As String _
) As Boolean
public:
virtual bool DoConditionExist(
    String^ strConditionSetId,
    String^ strConditionId
) sealed
Parameters
strConditionSetId (String)

[Missing <param name="strConditionSetId"/> documentation for "M:VisualCronAPI.Conditions.DoConditionExist(System.String,System.String)"]

strConditionId (String)

[Missing <param name="strConditionId"/> documentation for "M:VisualCronAPI.Conditions.DoConditionExist(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.DoConditionExist(System.String,System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoConditionExist Method (csc, cc)

DoConditionExist Method (csc, cc)
Namespaces ► VisualCronAPI ► Conditions ► DoConditionExist(ConditionSetClass, ConditionClass)
Returns true if a specified Condition exists
Declaration Syntax
C# Visual Basic Visual C++
public bool DoConditionExist(
    ConditionSetClass csc,
    ConditionClass cc
)
Public Function DoConditionExist ( _
    csc As ConditionSetClass, _
    cc As ConditionClass _
) As Boolean
public:
virtual bool DoConditionExist(
    ConditionSetClass^ csc,
    ConditionClass^ cc
) sealed
Parameters
csc (ConditionSetClass)

[Missing <param name="csc"/> documentation for "M:VisualCronAPI.Conditions.DoConditionExist(VisualCron.ConditionSetClass,VisualCron.ConditionClass)"]

cc (ConditionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Conditions.DoConditionExist(VisualCron.ConditionSetClass,VisualCron.ConditionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.DoConditionExist(VisualCron.ConditionSetClass,VisualCron.ConditionClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventConditionSetRemovedStatic Event

EventConditionSetRemovedStatic Event
Namespaces ► VisualCronAPI ► Conditions ► EventConditionSetRemovedStatic
This event is raised when a ConditionSet has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Conditions..::.DelegateConditionSetRemoved EventConditionSetRemovedStatic
Public Shared Event EventConditionSetRemovedStatic As Conditions..::.DelegateConditionSetRemoved
public:
static  event Conditions..::.DelegateConditionSetRemoved^ EventConditionSetRemovedStatic {
    void add (Conditions..::.DelegateConditionSetRemoved^ value);
    void remove (Conditions..::.DelegateConditionSetRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Conditions ► Get(String)
Returns a ConditionSet based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetClass Get(
    string id
)
Public Function Get ( _
    id As String _
) As ConditionSetClass
public:
virtual ConditionSetClass^ Get(
    String^ id
) sealed
Parameters
id (String)
string key
Return Value
a ConditionSet
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Conditions ► GetAll()()()
Returns a list of ConditionSets
Declaration Syntax
C# Visual Basic Visual C++
public List<ConditionSetClass> GetAll()
Public Function GetAll As List(Of ConditionSetClass)
public:
List<ConditionSetClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Conditions ► GetAllArray()()()
Returns an array of ConditionSets
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCondition Method (strConditionSetId, strConditionId)

GetCondition Method (strConditionSetId, strConditionId)
Namespaces ► VisualCronAPI ► Conditions ► GetCondition(String, String)
Retrieves a certain Condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass GetCondition(
    string strConditionSetId,
    string strConditionId
)
Public Function GetCondition ( _
    strConditionSetId As String, _
    strConditionId As String _
) As ConditionClass
public:
virtual ConditionClass^ GetCondition(
    String^ strConditionSetId,
    String^ strConditionId
) sealed
Parameters
strConditionSetId (String)
Id of Condition Set
strConditionId (String)
Id of Condition
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.GetCondition(System.String,System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Conditions ► Remove()()()
Members
Icon | Member | Description
 | Remove(ConditionSetClass) | Removes a ConditionSet
 | Remove(String) | Removes a ConditionSet
 | Remove(ConditionClass) | Removes a Condition
 | Remove(String, String) | Removes a Condition

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (conditionSetId)

Remove Method (conditionSetId)
Namespaces ► VisualCronAPI ► Conditions ► Remove(String)
Removes a ConditionSet
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string conditionSetId
)
Public Function Remove ( _
    conditionSetId As String _
) As Boolean
public:
virtual bool Remove(
    String^ conditionSetId
) sealed
Parameters
conditionSetId (String)
Id of ConditionSet
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (strConditionSetId, conditionId)

Remove Method (strConditionSetId, conditionId)
Namespaces ► VisualCronAPI ► Conditions ► Remove(String, String)
Removes a Condition
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string strConditionSetId,
    string conditionId
)
Public Function Remove ( _
    strConditionSetId As String, _
    conditionId As String _
) As Boolean
public:
virtual bool Remove(
    String^ strConditionSetId,
    String^ conditionId
) sealed
Parameters
strConditionSetId (String)

[Missing <param name="strConditionSetId"/> documentation for "M:VisualCronAPI.Conditions.Remove(System.String,System.String)"]

conditionId (String)
Id of Condition
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.Remove(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (cc)

Remove Method (cc)
Namespaces ► VisualCronAPI ► Conditions ► Remove(ConditionClass)
Removes a Condition
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    ConditionClass cc
)
Public Function Remove ( _
    cc As ConditionClass _
) As Boolean
public:
virtual bool Remove(
    ConditionClass^ cc
) sealed
Parameters
cc (ConditionClass)
a Condition
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.Remove(VisualCron.ConditionClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (cs)

Remove Method (cs)
Namespaces ► VisualCronAPI ► Conditions ► Remove(ConditionSetClass)
Removes a ConditionSet
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    ConditionSetClass cs
)
Public Function Remove ( _
    cs As ConditionSetClass _
) As Boolean
public:
virtual bool Remove(
    ConditionSetClass^ cs
) sealed
Parameters
cs (ConditionSetClass)
a ConditionSet
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions.Remove(VisualCron.ConditionSetClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Conditions ► RemoveAll()()()
Removes all Condition sets
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method

Update Method
Namespaces ► VisualCronAPI ► Conditions ► Update()()()
Members
Icon | Member | Description
 | Update(ConditionSetClass) | Updates a ConditionSet
 | Update(ConditionClass) | Updates a Condition

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (cc)

Update Method (cc)
Namespaces ► VisualCronAPI ► Conditions ► Update(ConditionClass)
Updates a Condition
Declaration Syntax
C# Visual Basic Visual C++
public ConditionClass Update(
    ConditionClass cc
)
Public Function Update ( _
    cc As ConditionClass _
) As ConditionClass
public:
virtual ConditionClass^ Update(
    ConditionClass^ cc
) sealed
Parameters
cc (ConditionClass)
A ConditionClass object
Return Value
a Condition
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (cs)

Update Method (cs)
Namespaces ► VisualCronAPI ► Conditions ► Update(ConditionSetClass)
Updates a ConditionSet
Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetClass Update(
    ConditionSetClass cs
)
Public Function Update ( _
    cs As ConditionSetClass _
) As ConditionSetClass
public:
virtual ConditionSetClass^ Update(
    ConditionSetClass^ cs
) sealed
Parameters
cs (ConditionSetClass)
A ConditionSetClass object
Return Value
a ConditionSet
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.__Conditions Interface

Conditions..::.__Conditions Interface
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.__Conditions

[Missing <summary> documentation for T:VisualCronAPI.Conditions.__Conditions]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Conditions
Public Interface __Conditions
public interface class __Conditions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConditionAdded(Server%, ConditionClass) |
 | ConditionRemoved(Server%, ConditionClass) |
 | ConditionSetAdded(Server%, ConditionSetClass) |
 | ConditionSetRemoved(Server%, ConditionSetClass) |
 | ConditionSetUpdated(Server%, ConditionSetClass) |
 | ConditionUpdated(Server%, ConditionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionAdded Method (server, c)

ConditionAdded Method (server, c)
Namespaces ► VisualCronAPI ► Conditions..::.__Conditions ► ConditionAdded(Server%, ConditionClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions.__Conditions.ConditionAdded(VisualCronAPI.Server@,VisualCron.ConditionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConditionAdded(
    ref Server server,
    ConditionClass c
)
Sub ConditionAdded ( _
    ByRef server As Server, _
    c As ConditionClass _
)
void ConditionAdded(
    Server^% server,
    ConditionClass^ c
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionAdded(VisualCronAPI.Server@,VisualCron.ConditionClass)"]

c (ConditionClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionAdded(VisualCronAPI.Server@,VisualCron.ConditionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionRemoved Method (server, c)

ConditionRemoved Method (server, c)
Namespaces ► VisualCronAPI ► Conditions..::.__Conditions ► ConditionRemoved(Server%, ConditionClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions.__Conditions.ConditionRemoved(VisualCronAPI.Server@,VisualCron.ConditionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConditionRemoved(
    ref Server server,
    ConditionClass c
)
Sub ConditionRemoved ( _
    ByRef server As Server, _
    c As ConditionClass _
)
void ConditionRemoved(
    Server^% server,
    ConditionClass^ c
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionRemoved(VisualCronAPI.Server@,VisualCron.ConditionClass)"]

c (ConditionClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionRemoved(VisualCronAPI.Server@,VisualCron.ConditionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetAdded Method (server, cs)

ConditionSetAdded Method (server, cs)
Namespaces ► VisualCronAPI ► Conditions..::.__Conditions ► ConditionSetAdded(Server%, ConditionSetClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions.__Conditions.ConditionSetAdded(VisualCronAPI.Server@,VisualCron.ConditionSetClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConditionSetAdded(
    ref Server server,
    ConditionSetClass cs
)
Sub ConditionSetAdded ( _
    ByRef server As Server, _
    cs As ConditionSetClass _
)
void ConditionSetAdded(
    Server^% server,
    ConditionSetClass^ cs
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionSetAdded(VisualCronAPI.Server@,VisualCron.ConditionSetClass)"]

cs (ConditionSetClass)

[Missing <param name="cs"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionSetAdded(VisualCronAPI.Server@,VisualCron.ConditionSetClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetRemoved Method (server, cs)

ConditionSetRemoved Method (server, cs)
Namespaces ► VisualCronAPI ► Conditions..::.__Conditions ► ConditionSetRemoved(Server%, ConditionSetClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions.__Conditions.ConditionSetRemoved(VisualCronAPI.Server@,VisualCron.ConditionSetClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConditionSetRemoved(
    ref Server server,
    ConditionSetClass cs
)
Sub ConditionSetRemoved ( _
    ByRef server As Server, _
    cs As ConditionSetClass _
)
void ConditionSetRemoved(
    Server^% server,
    ConditionSetClass^ cs
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionSetRemoved(VisualCronAPI.Server@,VisualCron.ConditionSetClass)"]

cs (ConditionSetClass)

[Missing <param name="cs"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionSetRemoved(VisualCronAPI.Server@,VisualCron.ConditionSetClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionSetUpdated Method (server, cs)

ConditionSetUpdated Method (server, cs)
Namespaces ► VisualCronAPI ► Conditions..::.__Conditions ► ConditionSetUpdated(Server%, ConditionSetClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions.__Conditions.ConditionSetUpdated(VisualCronAPI.Server@,VisualCron.ConditionSetClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConditionSetUpdated(
    ref Server server,
    ConditionSetClass cs
)
Sub ConditionSetUpdated ( _
    ByRef server As Server, _
    cs As ConditionSetClass _
)
void ConditionSetUpdated(
    Server^% server,
    ConditionSetClass^ cs
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionSetUpdated(VisualCronAPI.Server@,VisualCron.ConditionSetClass)"]

cs (ConditionSetClass)

[Missing <param name="cs"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionSetUpdated(VisualCronAPI.Server@,VisualCron.ConditionSetClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionUpdated Method (server, c)

ConditionUpdated Method (server, c)
Namespaces ► VisualCronAPI ► Conditions..::.__Conditions ► ConditionUpdated(Server%, ConditionClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions.__Conditions.ConditionUpdated(VisualCronAPI.Server@,VisualCron.ConditionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConditionUpdated(
    ref Server server,
    ConditionClass c
)
Sub ConditionUpdated ( _
    ByRef server As Server, _
    c As ConditionClass _
)
void ConditionUpdated(
    Server^% server,
    ConditionClass^ c
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionUpdated(VisualCronAPI.Server@,VisualCron.ConditionClass)"]

c (ConditionClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Conditions.__Conditions.ConditionUpdated(VisualCronAPI.Server@,VisualCron.ConditionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions._Conditions Interface

Conditions..::._Conditions Interface
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::._Conditions

[Missing <summary> documentation for T:VisualCronAPI.Conditions._Conditions]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Conditions
Public Interface _Conditions
public interface class _Conditions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(ConditionSetClass) |
 | Add(ConditionClass) |
 | DoConditionExist(ConditionSetClass, ConditionClass) |
 | DoConditionExist(String, String) |
 | Get(String) |
 | GetAllArray()()() |
 | GetCondition(String, String) |
 | Remove(ConditionSetClass) |
 | Remove(String) |
 | Remove(ConditionClass) |
 | Remove(String, String) |
 | RemoveAll()()() |
 | Update(ConditionSetClass) |
 | Update(ConditionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method

Add Method
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Add()()()
Members
Icon | Member | Description
 | Add(ConditionSetClass) |
 | Add(ConditionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (cc)

Add Method (cc)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Add(ConditionClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Add(VisualCron.ConditionClass)]

Declaration Syntax
C# Visual Basic Visual C++
ConditionClass Add(
    ConditionClass cc
)
Function Add ( _
    cc As ConditionClass _
) As ConditionClass
ConditionClass^ Add(
    ConditionClass^ cc
)
Parameters
cc (ConditionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Add(VisualCron.ConditionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Add(VisualCron.ConditionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (cs)

Add Method (cs)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Add(ConditionSetClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Add(VisualCron.ConditionSetClass)]

Declaration Syntax
C# Visual Basic Visual C++
ConditionSetClass Add(
    ConditionSetClass cs
)
Function Add ( _
    cs As ConditionSetClass _
) As ConditionSetClass
ConditionSetClass^ Add(
    ConditionSetClass^ cs
)
Parameters
cs (ConditionSetClass)

[Missing <param name="cs"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Add(VisualCron.ConditionSetClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Add(VisualCron.ConditionSetClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoConditionExist Method

DoConditionExist Method
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► DoConditionExist()()()
Members
Icon | Member | Description
 | DoConditionExist(ConditionSetClass, ConditionClass) |
 | DoConditionExist(String, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoConditionExist Method (strConditionSetId, strConditionId)

DoConditionExist Method (strConditionSetId, strConditionId)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► DoConditionExist(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.DoConditionExist(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool DoConditionExist(
    string strConditionSetId,
    string strConditionId
)
Function DoConditionExist ( _
    strConditionSetId As String, _
    strConditionId As String _
) As Boolean
bool DoConditionExist(
    String^ strConditionSetId,
    String^ strConditionId
)
Parameters
strConditionSetId (String)

[Missing <param name="strConditionSetId"/> documentation for "M:VisualCronAPI.Conditions._Conditions.DoConditionExist(System.String,System.String)"]

strConditionId (String)

[Missing <param name="strConditionId"/> documentation for "M:VisualCronAPI.Conditions._Conditions.DoConditionExist(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.DoConditionExist(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoConditionExist Method (csc, cc)

DoConditionExist Method (csc, cc)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► DoConditionExist(ConditionSetClass, ConditionClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.DoConditionExist(VisualCron.ConditionSetClass,VisualCron.ConditionClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool DoConditionExist(
    ConditionSetClass csc,
    ConditionClass cc
)
Function DoConditionExist ( _
    csc As ConditionSetClass, _
    cc As ConditionClass _
) As Boolean
bool DoConditionExist(
    ConditionSetClass^ csc,
    ConditionClass^ cc
)
Parameters
csc (ConditionSetClass)

[Missing <param name="csc"/> documentation for "M:VisualCronAPI.Conditions._Conditions.DoConditionExist(VisualCron.ConditionSetClass,VisualCron.ConditionClass)"]

cc (ConditionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Conditions._Conditions.DoConditionExist(VisualCron.ConditionSetClass,VisualCron.ConditionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.DoConditionExist(VisualCron.ConditionSetClass,VisualCron.ConditionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ConditionSetClass Get(
    string id
)
Function Get ( _
    id As String _
) As ConditionSetClass
ConditionSetClass^ Get(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCondition Method (strConditionSetId, strConditionId)

GetCondition Method (strConditionSetId, strConditionId)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► GetCondition(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.GetCondition(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ConditionClass GetCondition(
    string strConditionSetId,
    string strConditionId
)
Function GetCondition ( _
    strConditionSetId As String, _
    strConditionId As String _
) As ConditionClass
ConditionClass^ GetCondition(
    String^ strConditionSetId,
    String^ strConditionId
)
Parameters
strConditionSetId (String)

[Missing <param name="strConditionSetId"/> documentation for "M:VisualCronAPI.Conditions._Conditions.GetCondition(System.String,System.String)"]

strConditionId (String)

[Missing <param name="strConditionId"/> documentation for "M:VisualCronAPI.Conditions._Conditions.GetCondition(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.GetCondition(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Remove()()()
Members
Icon | Member | Description
 | Remove(ConditionSetClass) |
 | Remove(String) |
 | Remove(ConditionClass) |
 | Remove(String, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (conditionSetId)

Remove Method (conditionSetId)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string conditionSetId
)
Function Remove ( _
    conditionSetId As String _
) As Boolean
bool Remove(
    String^ conditionSetId
)
Parameters
conditionSetId (String)

[Missing <param name="conditionSetId"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (strConditionSetId, conditionId)

Remove Method (strConditionSetId, conditionId)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Remove(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string strConditionSetId,
    string conditionId
)
Function Remove ( _
    strConditionSetId As String, _
    conditionId As String _
) As Boolean
bool Remove(
    String^ strConditionSetId,
    String^ conditionId
)
Parameters
strConditionSetId (String)

[Missing <param name="strConditionSetId"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Remove(System.String,System.String)"]

conditionId (String)

[Missing <param name="conditionId"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Remove(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (cc)

Remove Method (cc)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Remove(ConditionClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(VisualCron.ConditionClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    ConditionClass cc
)
Function Remove ( _
    cc As ConditionClass _
) As Boolean
bool Remove(
    ConditionClass^ cc
)
Parameters
cc (ConditionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Remove(VisualCron.ConditionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(VisualCron.ConditionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (cs)

Remove Method (cs)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Remove(ConditionSetClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(VisualCron.ConditionSetClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    ConditionSetClass cs
)
Function Remove ( _
    cs As ConditionSetClass _
) As Boolean
bool Remove(
    ConditionSetClass^ cs
)
Parameters
cs (ConditionSetClass)

[Missing <param name="cs"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Remove(VisualCron.ConditionSetClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Remove(VisualCron.ConditionSetClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method

Update Method
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Update()()()
Members
Icon | Member | Description
 | Update(ConditionSetClass) |
 | Update(ConditionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (cc)

Update Method (cc)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Update(ConditionClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Update(VisualCron.ConditionClass)]

Declaration Syntax
C# Visual Basic Visual C++
ConditionClass Update(
    ConditionClass cc
)
Function Update ( _
    cc As ConditionClass _
) As ConditionClass
ConditionClass^ Update(
    ConditionClass^ cc
)
Parameters
cc (ConditionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Update(VisualCron.ConditionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Update(VisualCron.ConditionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (cs)

Update Method (cs)
Namespaces ► VisualCronAPI ► Conditions..::._Conditions ► Update(ConditionSetClass)

[Missing <summary> documentation for M:VisualCronAPI.Conditions._Conditions.Update(VisualCron.ConditionSetClass)]

Declaration Syntax
C# Visual Basic Visual C++
ConditionSetClass Update(
    ConditionSetClass cs
)
Function Update ( _
    cs As ConditionSetClass _
) As ConditionSetClass
ConditionSetClass^ Update(
    ConditionSetClass^ cs
)
Parameters
cs (ConditionSetClass)

[Missing <param name="cs"/> documentation for "M:VisualCronAPI.Conditions._Conditions.Update(VisualCron.ConditionSetClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Conditions._Conditions.Update(VisualCron.ConditionSetClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.ConditionSetNotFoundException Class

Conditions..::.ConditionSetNotFoundException Class
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.ConditionSetNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Conditions.ConditionSetNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class ConditionSetNotFoundException : Exception
Public Class ConditionSetNotFoundException _
    Inherits Exception
public ref class ConditionSetNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Conditions..::.ConditionSetNotFoundException(String) | Initializes a new instance of the Conditions..::.ConditionSetNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Conditions..::.ConditionSetNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.ConditionSetNotFoundException Constructor (id)

Conditions..::.ConditionSetNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Conditions..::.ConditionSetNotFoundException ► Conditions..::.ConditionSetNotFoundException(String)
Initializes a new instance of the Conditions..::.ConditionSetNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public ConditionSetNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
ConditionSetNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Conditions.ConditionSetNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.DelegateConditionAdded Delegate

Conditions..::.DelegateConditionAdded Delegate
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.DelegateConditionAdded

[Missing <summary> documentation for T:VisualCronAPI.Conditions.DelegateConditionAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConditionAdded(
    ref Server server,
    ConditionClass c
)
Public Delegate Sub DelegateConditionAdded ( _
    ByRef server As Server, _
    c As ConditionClass _
)
public delegate void DelegateConditionAdded(
    Server^% server,
    ConditionClass^ c
)
Parameters
server ( Server %)
c (ConditionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.DelegateConditionRemoved Delegate

Conditions..::.DelegateConditionRemoved Delegate
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.DelegateConditionRemoved

[Missing <summary> documentation for T:VisualCronAPI.Conditions.DelegateConditionRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConditionRemoved(
    ref Server server,
    ConditionClass c
)
Public Delegate Sub DelegateConditionRemoved ( _
    ByRef server As Server, _
    c As ConditionClass _
)
public delegate void DelegateConditionRemoved(
    Server^% server,
    ConditionClass^ c
)
Parameters
server ( Server %)
c (ConditionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.DelegateConditionSetAdded Delegate

Conditions..::.DelegateConditionSetAdded Delegate
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.DelegateConditionSetAdded

[Missing <summary> documentation for T:VisualCronAPI.Conditions.DelegateConditionSetAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConditionSetAdded(
    ref Server server,
    ConditionSetClass cs
)
Public Delegate Sub DelegateConditionSetAdded ( _
    ByRef server As Server, _
    cs As ConditionSetClass _
)
public delegate void DelegateConditionSetAdded(
    Server^% server,
    ConditionSetClass^ cs
)
Parameters
server ( Server %)
cs (ConditionSetClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.DelegateConditionSetRemoved Delegate

Conditions..::.DelegateConditionSetRemoved Delegate
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.DelegateConditionSetRemoved

[Missing <summary> documentation for T:VisualCronAPI.Conditions.DelegateConditionSetRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConditionSetRemoved(
    ref Server server,
    ConditionSetClass cs
)
Public Delegate Sub DelegateConditionSetRemoved ( _
    ByRef server As Server, _
    cs As ConditionSetClass _
)
public delegate void DelegateConditionSetRemoved(
    Server^% server,
    ConditionSetClass^ cs
)
Parameters
server ( Server %)
cs (ConditionSetClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.DelegateConditionSetUpdated Delegate

Conditions..::.DelegateConditionSetUpdated Delegate
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.DelegateConditionSetUpdated

[Missing <summary> documentation for T:VisualCronAPI.Conditions.DelegateConditionSetUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConditionSetUpdated(
    ref Server server,
    ConditionSetClass cs
)
Public Delegate Sub DelegateConditionSetUpdated ( _
    ByRef server As Server, _
    cs As ConditionSetClass _
)
public delegate void DelegateConditionSetUpdated(
    Server^% server,
    ConditionSetClass^ cs
)
Parameters
server ( Server %)
cs (ConditionSetClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions.DelegateConditionUpdated Delegate

Conditions..::.DelegateConditionUpdated Delegate
Namespaces ► VisualCronAPI ► Conditions ► Conditions..::.DelegateConditionUpdated

[Missing <summary> documentation for T:VisualCronAPI.Conditions.DelegateConditionUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConditionUpdated(
    ref Server server,
    ConditionClass c
)
Public Delegate Sub DelegateConditionUpdated ( _
    ByRef server As Server, _
    c As ConditionClass _
)
public delegate void DelegateConditionUpdated(
    Server^% server,
    ConditionClass^ c
)
Parameters
server ( Server %)
c (ConditionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connection Class

Connection Class
Namespaces ► VisualCronAPI ► Connection
Handles connection specific settings
Declaration Syntax
C# Visual Basic Visual C++
public class Connection : Connection..::._Connection
Public Class Connection _
    Implements Connection..::._Connection
public ref class Connection : Connection..::._Connection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Connection()()() | Initializes a new instance of the Connection class
 | Address | Remote address/ip of the Server
 | ClientType | Gets or sets type of Client
 | ConnectionType | Gets or sets the current connection type
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsLocallyConnected | If the tcp connection is local
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord | Password that is needed for the authentication
 | Port | Remote port of the server, default 16444
 | Proxy | Gets or sets proxy information
 | TimeOut | Gets or sets send/receive timeout in seconds
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseCompression | If compression should be used
 | UserName | Username that is needed for the authentication
 | UserServerId | Optional value to use to track a Connection to a Server
Remarks
Inheritance Hierarchy
Object
Connection

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connection Constructor

Connection Constructor
Namespaces ► VisualCronAPI ► Connection ► Connection()()()
Initializes a new instance of the Connection class
Declaration Syntax
C# Visual Basic Visual C++
public Connection()
Public Sub New
public:
Connection()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Address Property

Address Property
Namespaces ► VisualCronAPI ► Connection ► Address
Remote address/ip of the Server
Declaration Syntax
C# Visual Basic Visual C++
public string Address { get; set; }
Public Property Address As String
public:
virtual property String^ Address {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientType Property

ClientType Property
Namespaces ► VisualCronAPI ► Connection ► ClientType
Gets or sets type of Client
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnectionClass..::.ClientT ClientType { get; set; }
Public Property ClientType As ClientConnectionClass..::.ClientT
public:
virtual property ClientConnectionClass..::.ClientT ClientType {
    ClientConnectionClass..::.ClientT get () sealed;
    void set (ClientConnectionClass..::.ClientT value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionType Property

ConnectionType Property
Namespaces ► VisualCronAPI ► Connection ► ConnectionType
Gets or sets the current connection type
Declaration Syntax
C# Visual Basic Visual C++
public Connection..::.ConnectionT ConnectionType { get; set; }
Public Property ConnectionType As Connection..::.ConnectionT
public:
virtual property Connection..::.ConnectionT ConnectionType {
    Connection..::.ConnectionT get () sealed;
    void set (Connection..::.ConnectionT value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsLocallyConnected Property

IsLocallyConnected Property
Namespaces ► VisualCronAPI ► Connection ► IsLocallyConnected
If the tcp connection is local
Declaration Syntax
C# Visual Basic Visual C++
public bool IsLocallyConnected { get; internal set; }
Public Property IsLocallyConnected As Boolean
public:
virtual property bool IsLocallyConnected {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PassWord Property

PassWord Property
Namespaces ► VisualCronAPI ► Connection ► PassWord
Password that is needed for the authentication
Declaration Syntax
C# Visual Basic Visual C++
public string PassWord { get; set; }
Public Property PassWord As String
public:
virtual property String^ PassWord {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks
Default empty string

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Port Property

Port Property
Namespaces ► VisualCronAPI ► Connection ► Port
Remote port of the server, default 16444
Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
virtual property int Port {
    int get () sealed;
    void set (int value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Proxy Property

Proxy Property
Namespaces ► VisualCronAPI ► Connection ► Proxy
Gets or sets proxy information
Declaration Syntax
C# Visual Basic Visual C++
public OpenProxyClass Proxy { get; set; }
Public Property Proxy As OpenProxyClass
public:
virtual property OpenProxyClass^ Proxy {
    OpenProxyClass^ get () sealed;
    void set (OpenProxyClass^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeOut Property

TimeOut Property
Namespaces ► VisualCronAPI ► Connection ► TimeOut
Gets or sets send/receive timeout in seconds
Declaration Syntax
C# Visual Basic Visual C++
public int TimeOut { get; set; }
Public Property TimeOut As Integer
public:
virtual property int TimeOut {
    int get () sealed;
    void set (int value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UseCompression Property

UseCompression Property
Namespaces ► VisualCronAPI ► Connection ► UseCompression
If compression should be used
Declaration Syntax
C# Visual Basic Visual C++
public bool UseCompression { get; set; }
Public Property UseCompression As Boolean
public:
virtual property bool UseCompression {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserName Property

UserName Property
Namespaces ► VisualCronAPI ► Connection ► UserName
Username that is needed for the authentication
Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
virtual property String^ UserName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks
Default "admin"

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserServerId Property

UserServerId Property
Namespaces ► VisualCronAPI ► Connection ► UserServerId
Optional value to use to track a Connection to a Server
Declaration Syntax
C# Visual Basic Visual C++
public string UserServerId { get; set; }
Public Property UserServerId As String
public:
virtual property String^ UserServerId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connection._Connection Interface

Connection..::._Connection Interface
Namespaces ► VisualCronAPI ► Connection ► Connection..::._Connection

[Missing <summary> documentation for T:VisualCronAPI.Connection._Connection]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Connection
Public Interface _Connection
public interface class _Connection
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Address |
 | ClientType |
 | ConnectionType |
 | IsLocallyConnected |
 | PassWord |
 | Port |
 | Proxy |
 | TimeOut |
 | UseCompression |
 | UserName |
 | UserServerId |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Address Property

Address Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► Address

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.Address]

Declaration Syntax
C# Visual Basic Visual C++
string Address { get; set; }
Property Address As String
property String^ Address {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientType Property

ClientType Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► ClientType

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.ClientType]

Declaration Syntax
C# Visual Basic Visual C++
ClientConnectionClass..::.ClientT ClientType { get; set; }
Property ClientType As ClientConnectionClass..::.ClientT
property ClientConnectionClass..::.ClientT ClientType {
    ClientConnectionClass..::.ClientT get ();
    void set (ClientConnectionClass..::.ClientT value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionType Property

ConnectionType Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► ConnectionType

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.ConnectionType]

Declaration Syntax
C# Visual Basic Visual C++
Connection..::.ConnectionT ConnectionType { get; set; }
Property ConnectionType As Connection..::.ConnectionT
property Connection..::.ConnectionT ConnectionType {
    Connection..::.ConnectionT get ();
    void set (Connection..::.ConnectionT value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsLocallyConnected Property

IsLocallyConnected Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► IsLocallyConnected

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.IsLocallyConnected]

Declaration Syntax
C# Visual Basic Visual C++
bool IsLocallyConnected { get; }
ReadOnly Property IsLocallyConnected As Boolean
property bool IsLocallyConnected {
    bool get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PassWord Property

PassWord Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► PassWord

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.PassWord]

Declaration Syntax
C# Visual Basic Visual C++
string PassWord { get; set; }
Property PassWord As String
property String^ PassWord {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Port Property

Port Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► Port

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.Port]

Declaration Syntax
C# Visual Basic Visual C++
int Port { get; set; }
Property Port As Integer
property int Port {
    int get ();
    void set (int value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Proxy Property

Proxy Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► Proxy

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.Proxy]

Declaration Syntax
C# Visual Basic Visual C++
OpenProxyClass Proxy { get; set; }
Property Proxy As OpenProxyClass
property OpenProxyClass^ Proxy {
    OpenProxyClass^ get ();
    void set (OpenProxyClass^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeOut Property

TimeOut Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► TimeOut

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.TimeOut]

Declaration Syntax
C# Visual Basic Visual C++
int TimeOut { get; set; }
Property TimeOut As Integer
property int TimeOut {
    int get ();
    void set (int value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UseCompression Property

UseCompression Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► UseCompression

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.UseCompression]

Declaration Syntax
C# Visual Basic Visual C++
bool UseCompression { get; set; }
Property UseCompression As Boolean
property bool UseCompression {
    bool get ();
    void set (bool value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserName Property

UserName Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► UserName

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.UserName]

Declaration Syntax
C# Visual Basic Visual C++
string UserName { get; set; }
Property UserName As String
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserServerId Property

UserServerId Property
Namespaces ► VisualCronAPI ► Connection..::._Connection ► UserServerId

[Missing <summary> documentation for P:VisualCronAPI.Connection._Connection.UserServerId]

Declaration Syntax
C# Visual Basic Visual C++
string UserServerId { get; set; }
Property UserServerId As String
property String^ UserServerId {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connection.ConnectionT Enumeration

Connection..::.ConnectionT Enumeration
Namespaces ► VisualCronAPI ► Connection ► Connection..::.ConnectionT
Different connection types
Declaration Syntax
C# Visual Basic Visual C++
public enum ConnectionT
Public Enumeration ConnectionT
public enum class ConnectionT
Members
Member | Description
Local |
Remote |
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections Class

Connections Class
Namespaces ► VisualCronAPI ► Connections
Base class for Connection Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Connections : Connections..::._Connections
Public Class Connections _
    Implements Connections..::._Connections
public ref class Connections : Connections..::._Connections
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Connections(Server) | Initializes a new instance of the Connections class
 | Add(ConnectionClass) | Adds a Connection
 | ConnectionAdded | This event is raised when a Connection has been added
 | ConnectionAddedStatic | This event is raised when a Connection has been added
 | ConnectionRemoved | This event is raised when a Connection has been removed
 | ConnectionRemovedStatic | This event is raised when a Connection has been removed
 | ConnectionUpdated | This event is raised when a Connection has been updated
 | ConnectionUpdatedStatic | This event is raised when a Connection has been updated
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exist(String) | Returns true if specified Connection Id exist
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Connection based on the string key Id
 | GetAll()()() | Returns a list of Connections
 | GetAllArray()()() | Returns an array of Connections
 | GetConnectionName(String) |
 | GetConnectionNameString(String) |
 | GetConnectionString(String) | Returns a verbose connection string
 | GetDataConnectionTypeString(ConnectionClass..::.DataConnectionT) |
 | GetDataProvider(String) |
 | GetFTPCommand(TaskClass, String) | Returns a FTP command
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetPortString(ConnectionClass) |
 | GetSQLConnectionString(String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(ConnectionClass) | Removes a Connection
 | Remove(String) | Removes a Connection
 | RemoveAll()()() | Removes all Connections
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(ConnectionClass) | Updates a Connection
Remarks
Inheritance Hierarchy
Object
Connections

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections Constructor (s)

Connections Constructor (s)
Namespaces ► VisualCronAPI ► Connections ► Connections(Server)
Initializes a new instance of the Connections class
Declaration Syntax
C# Visual Basic Visual C++
public Connections(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
Connections(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Connections.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (c)

Add Method (c)
Namespaces ► VisualCronAPI ► Connections ► Add(ConnectionClass)
Adds a Connection
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass Add(
    ConnectionClass c
)
Public Function Add ( _
    c As ConnectionClass _
) As ConnectionClass
public:
virtual ConnectionClass^ Add(
    ConnectionClass^ c
) sealed
Parameters
c (ConnectionClass)
A ConnectionClass object
Return Value
a Connection
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionAdded Event

ConnectionAdded Event
Namespaces ► VisualCronAPI ► Connections ► ConnectionAdded
This event is raised when a Connection has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Connections..::.DelegateConnectionAdded ConnectionAdded
Public Event ConnectionAdded As Connections..::.DelegateConnectionAdded
public:
 event Connections..::.DelegateConnectionAdded^ ConnectionAdded {
    void add (Connections..::.DelegateConnectionAdded^ value);
    void remove (Connections..::.DelegateConnectionAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionAddedStatic Event

ConnectionAddedStatic Event
Namespaces ► VisualCronAPI ► Connections ► ConnectionAddedStatic
This event is raised when a Connection has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Connections..::.DelegateConnectionAdded ConnectionAddedStatic
Public Shared Event ConnectionAddedStatic As Connections..::.DelegateConnectionAdded
public:
static  event Connections..::.DelegateConnectionAdded^ ConnectionAddedStatic {
    void add (Connections..::.DelegateConnectionAdded^ value);
    void remove (Connections..::.DelegateConnectionAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionRemoved Event

ConnectionRemoved Event
Namespaces ► VisualCronAPI ► Connections ► ConnectionRemoved
This event is raised when a Connection has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Connections..::.DelegateConnectionRemoved ConnectionRemoved
Public Event ConnectionRemoved As Connections..::.DelegateConnectionRemoved
public:
 event Connections..::.DelegateConnectionRemoved^ ConnectionRemoved {
    void add (Connections..::.DelegateConnectionRemoved^ value);
    void remove (Connections..::.DelegateConnectionRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionRemovedStatic Event

ConnectionRemovedStatic Event
Namespaces ► VisualCronAPI ► Connections ► ConnectionRemovedStatic
This event is raised when a Connection has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Connections..::.DelegateConnectionRemoved ConnectionRemovedStatic
Public Shared Event ConnectionRemovedStatic As Connections..::.DelegateConnectionRemoved
public:
static  event Connections..::.DelegateConnectionRemoved^ ConnectionRemovedStatic {
    void add (Connections..::.DelegateConnectionRemoved^ value);
    void remove (Connections..::.DelegateConnectionRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionUpdated Event

ConnectionUpdated Event
Namespaces ► VisualCronAPI ► Connections ► ConnectionUpdated
This event is raised when a Connection has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Connections..::.DelegateConnectionUpdated ConnectionUpdated
Public Event ConnectionUpdated As Connections..::.DelegateConnectionUpdated
public:
 event Connections..::.DelegateConnectionUpdated^ ConnectionUpdated {
    void add (Connections..::.DelegateConnectionUpdated^ value);
    void remove (Connections..::.DelegateConnectionUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionUpdatedStatic Event

ConnectionUpdatedStatic Event
Namespaces ► VisualCronAPI ► Connections ► ConnectionUpdatedStatic
This event is raised when a Connection has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Connections..::.DelegateConnectionUpdated ConnectionUpdatedStatic
Public Shared Event ConnectionUpdatedStatic As Connections..::.DelegateConnectionUpdated
public:
static  event Connections..::.DelegateConnectionUpdated^ ConnectionUpdatedStatic {
    void add (Connections..::.DelegateConnectionUpdated^ value);
    void remove (Connections..::.DelegateConnectionUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Exist Method (strConnectionId)

Exist Method (strConnectionId)
Namespaces ► VisualCronAPI ► Connections ► Exist(String)
Returns true if specified Connection Id exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Exist(
    string strConnectionId
)
Public Function Exist ( _
    strConnectionId As String _
) As Boolean
public:
virtual bool Exist(
    String^ strConnectionId
) sealed
Parameters
strConnectionId (String)

[Missing <param name="strConnectionId"/> documentation for "M:VisualCronAPI.Connections.Exist(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.Exist(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Connections ► Get(String)
Returns a Connection based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass Get(
    string id
)
Public Function Get ( _
    id As String _
) As ConnectionClass
public:
virtual ConnectionClass^ Get(
    String^ id
) sealed
Parameters
id (String)
string key
Return Value
a Connection
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Connections ► GetAll()()()
Returns a list of Connections
Declaration Syntax
C# Visual Basic Visual C++
public List<ConnectionClass> GetAll()
Public Function GetAll As List(Of ConnectionClass)
public:
List<ConnectionClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Connections ► GetAllArray()()()
Returns an array of Connections
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetConnectionName Method (strId)

GetConnectionName Method (strId)
Namespaces ► VisualCronAPI ► Connections ► GetConnectionName(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections.GetConnectionName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetConnectionName(
    string strId
)
Public Function GetConnectionName ( _
    strId As String _
) As String
public:
virtual String^ GetConnectionName(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections.GetConnectionName(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetConnectionName(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetConnectionNameString Method (strId)

GetConnectionNameString Method (strId)
Namespaces ► VisualCronAPI ► Connections ► GetConnectionNameString(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections.GetConnectionNameString(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetConnectionNameString(
    string strId
)
Public Function GetConnectionNameString ( _
    strId As String _
) As String
public:
virtual String^ GetConnectionNameString(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections.GetConnectionNameString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetConnectionNameString(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetConnectionString Method (strId)

GetConnectionString Method (strId)
Namespaces ► VisualCronAPI ► Connections ► GetConnectionString(String)
Returns a verbose connection string
Declaration Syntax
C# Visual Basic Visual C++
public string GetConnectionString(
    string strId
)
Public Function GetConnectionString ( _
    strId As String _
) As String
public:
virtual String^ GetConnectionString(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections.GetConnectionString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetConnectionString(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDataConnectionTypeString Method (dct)

GetDataConnectionTypeString Method (dct)
Namespaces ► VisualCronAPI ► Connections ► GetDataConnectionTypeString(ConnectionClass..::.DataConnectionT)

[Missing <summary> documentation for M:VisualCronAPI.Connections.GetDataConnectionTypeString(VisualCron.ConnectionClass.DataConnectionT)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetDataConnectionTypeString(
    ConnectionClass..::.DataConnectionT dct
)
Public Function GetDataConnectionTypeString ( _
    dct As ConnectionClass..::.DataConnectionT _
) As String
public:
virtual String^ GetDataConnectionTypeString(
    ConnectionClass..::.DataConnectionT dct
) sealed
Parameters
dct (ConnectionClass..::.DataConnectionT)

[Missing <param name="dct"/> documentation for "M:VisualCronAPI.Connections.GetDataConnectionTypeString(VisualCron.ConnectionClass.DataConnectionT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetDataConnectionTypeString(VisualCron.ConnectionClass.DataConnectionT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDataProvider Method (strId)

GetDataProvider Method (strId)
Namespaces ► VisualCronAPI ► Connections ► GetDataProvider(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections.GetDataProvider(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public SQLConnectionClass..::.DataProviderT GetDataProvider(
    string strId
)
Public Function GetDataProvider ( _
    strId As String _
) As SQLConnectionClass..::.DataProviderT
public:
virtual SQLConnectionClass..::.DataProviderT GetDataProvider(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections.GetDataProvider(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetDataProvider(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetFTPCommand Method (tc, strCommandId)

GetFTPCommand Method (tc, strCommandId)
Namespaces ► VisualCronAPI ► Connections ► GetFTPCommand(TaskClass, String)
Returns a FTP command
Declaration Syntax
C# Visual Basic Visual C++
public static FTPCommandClass GetFTPCommand(
    TaskClass tc,
    string strCommandId
)
Public Shared Function GetFTPCommand ( _
    tc As TaskClass, _
    strCommandId As String _
) As FTPCommandClass
public:
static FTPCommandClass^ GetFTPCommand(
    TaskClass^ tc,
    String^ strCommandId
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Connections.GetFTPCommand(VisualCron.TaskClass,System.String)"]

strCommandId (String)

[Missing <param name="strCommandId"/> documentation for "M:VisualCronAPI.Connections.GetFTPCommand(VisualCron.TaskClass,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetFTPCommand(VisualCron.TaskClass,System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetPortString Method (cc)

GetPortString Method (cc)
Namespaces ► VisualCronAPI ► Connections ► GetPortString(ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections.GetPortString(VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetPortString(
    ConnectionClass cc
)
Public Function GetPortString ( _
    cc As ConnectionClass _
) As String
public:
virtual String^ GetPortString(
    ConnectionClass^ cc
) sealed
Parameters
cc (ConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Connections.GetPortString(VisualCron.ConnectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetPortString(VisualCron.ConnectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetSQLConnectionString Method (strId)

GetSQLConnectionString Method (strId)
Namespaces ► VisualCronAPI ► Connections ► GetSQLConnectionString(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections.GetSQLConnectionString(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetSQLConnectionString(
    string strId
)
Public Function GetSQLConnectionString ( _
    strId As String _
) As String
public:
virtual String^ GetSQLConnectionString(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections.GetSQLConnectionString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.GetSQLConnectionString(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Connections ► Remove()()()
Members
Icon | Member | Description
 | Remove(ConnectionClass) | Removes a Connection
 | Remove(String) | Removes a Connection

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (connectionId)

Remove Method (connectionId)
Namespaces ► VisualCronAPI ► Connections ► Remove(String)
Removes a Connection
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string connectionId
)
Public Function Remove ( _
    connectionId As String _
) As Boolean
public:
virtual bool Remove(
    String^ connectionId
) sealed
Parameters
connectionId (String)
Id of Connection
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (c)

Remove Method (c)
Namespaces ► VisualCronAPI ► Connections ► Remove(ConnectionClass)
Removes a Connection
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    ConnectionClass c
)
Public Function Remove ( _
    c As ConnectionClass _
) As Boolean
public:
virtual bool Remove(
    ConnectionClass^ c
) sealed
Parameters
c (ConnectionClass)
a Connection
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections.Remove(VisualCron.ConnectionClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Connections ► RemoveAll()()()
Removes all Connections
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (c)

Update Method (c)
Namespaces ► VisualCronAPI ► Connections ► Update(ConnectionClass)
Updates a Connection
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionClass Update(
    ConnectionClass c
)
Public Function Update ( _
    c As ConnectionClass _
) As ConnectionClass
public:
virtual ConnectionClass^ Update(
    ConnectionClass^ c
) sealed
Parameters
c (ConnectionClass)
A ConnectionClass object
Return Value
a Connection
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections.__Connections Interface

Connections..::.__Connections Interface
Namespaces ► VisualCronAPI ► Connections ► Connections..::.__Connections

[Missing <summary> documentation for T:VisualCronAPI.Connections.__Connections]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Connections
Public Interface __Connections
public interface class __Connections
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConnectionAdded(Server%, ConnectionClass) |
 | ConnectionRemoved(Server%, ConnectionClass) |
 | ConnectionUpdated(Server%, ConnectionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionAdded Method (server, cc)

ConnectionAdded Method (server, cc)
Namespaces ► VisualCronAPI ► Connections..::.__Connections ► ConnectionAdded(Server%, ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections.__Connections.ConnectionAdded(VisualCronAPI.Server@,VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConnectionAdded(
    ref Server server,
    ConnectionClass cc
)
Sub ConnectionAdded ( _
    ByRef server As Server, _
    cc As ConnectionClass _
)
void ConnectionAdded(
    Server^% server,
    ConnectionClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Connections.__Connections.ConnectionAdded(VisualCronAPI.Server@,VisualCron.ConnectionClass)"]

cc (ConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Connections.__Connections.ConnectionAdded(VisualCronAPI.Server@,VisualCron.ConnectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionRemoved Method (server, cc)

ConnectionRemoved Method (server, cc)
Namespaces ► VisualCronAPI ► Connections..::.__Connections ► ConnectionRemoved(Server%, ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections.__Connections.ConnectionRemoved(VisualCronAPI.Server@,VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConnectionRemoved(
    ref Server server,
    ConnectionClass cc
)
Sub ConnectionRemoved ( _
    ByRef server As Server, _
    cc As ConnectionClass _
)
void ConnectionRemoved(
    Server^% server,
    ConnectionClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Connections.__Connections.ConnectionRemoved(VisualCronAPI.Server@,VisualCron.ConnectionClass)"]

cc (ConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Connections.__Connections.ConnectionRemoved(VisualCronAPI.Server@,VisualCron.ConnectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConnectionUpdated Method (server, cc)

ConnectionUpdated Method (server, cc)
Namespaces ► VisualCronAPI ► Connections..::.__Connections ► ConnectionUpdated(Server%, ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections.__Connections.ConnectionUpdated(VisualCronAPI.Server@,VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void ConnectionUpdated(
    ref Server server,
    ConnectionClass cc
)
Sub ConnectionUpdated ( _
    ByRef server As Server, _
    cc As ConnectionClass _
)
void ConnectionUpdated(
    Server^% server,
    ConnectionClass^ cc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Connections.__Connections.ConnectionUpdated(VisualCronAPI.Server@,VisualCron.ConnectionClass)"]

cc (ConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Connections.__Connections.ConnectionUpdated(VisualCronAPI.Server@,VisualCron.ConnectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections._Connections Interface

Connections..::._Connections Interface
Namespaces ► VisualCronAPI ► Connections ► Connections..::._Connections

[Missing <summary> documentation for T:VisualCronAPI.Connections._Connections]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Connections
Public Interface _Connections
public interface class _Connections
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(ConnectionClass) |
 | Exist(String) |
 | Get(String) |
 | GetAllArray()()() |
 | GetConnectionName(String) |
 | GetConnectionNameString(String) |
 | GetConnectionString(String) |
 | GetDataConnectionTypeString(ConnectionClass..::.DataConnectionT) |
 | GetDataProvider(String) |
 | GetPortString(ConnectionClass) |
 | GetSQLConnectionString(String) |
 | Remove(ConnectionClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | Update(ConnectionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (c)

Add Method (c)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► Add(ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.Add(VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
ConnectionClass Add(
    ConnectionClass c
)
Function Add ( _
    c As ConnectionClass _
) As ConnectionClass
ConnectionClass^ Add(
    ConnectionClass^ c
)
Parameters
c (ConnectionClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Connections._Connections.Add(VisualCron.ConnectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.Add(VisualCron.ConnectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Exist Method (strConnectionId)

Exist Method (strConnectionId)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► Exist(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.Exist(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Exist(
    string strConnectionId
)
Function Exist ( _
    strConnectionId As String _
) As Boolean
bool Exist(
    String^ strConnectionId
)
Parameters
strConnectionId (String)

[Missing <param name="strConnectionId"/> documentation for "M:VisualCronAPI.Connections._Connections.Exist(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.Exist(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ConnectionClass Get(
    string id
)
Function Get ( _
    id As String _
) As ConnectionClass
ConnectionClass^ Get(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Connections._Connections.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetConnectionName Method (strId)

GetConnectionName Method (strId)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetConnectionName(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetConnectionName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetConnectionName(
    string strId
)
Function GetConnectionName ( _
    strId As String _
) As String
String^ GetConnectionName(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections._Connections.GetConnectionName(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetConnectionName(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetConnectionNameString Method (strId)

GetConnectionNameString Method (strId)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetConnectionNameString(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetConnectionNameString(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetConnectionNameString(
    string strId
)
Function GetConnectionNameString ( _
    strId As String _
) As String
String^ GetConnectionNameString(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections._Connections.GetConnectionNameString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetConnectionNameString(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetConnectionString Method (strId)

GetConnectionString Method (strId)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetConnectionString(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetConnectionString(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetConnectionString(
    string strId
)
Function GetConnectionString ( _
    strId As String _
) As String
String^ GetConnectionString(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections._Connections.GetConnectionString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetConnectionString(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDataConnectionTypeString Method (dct)

GetDataConnectionTypeString Method (dct)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetDataConnectionTypeString(ConnectionClass..::.DataConnectionT)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetDataConnectionTypeString(VisualCron.ConnectionClass.DataConnectionT)]

Declaration Syntax
C# Visual Basic Visual C++
string GetDataConnectionTypeString(
    ConnectionClass..::.DataConnectionT dct
)
Function GetDataConnectionTypeString ( _
    dct As ConnectionClass..::.DataConnectionT _
) As String
String^ GetDataConnectionTypeString(
    ConnectionClass..::.DataConnectionT dct
)
Parameters
dct (ConnectionClass..::.DataConnectionT)

[Missing <param name="dct"/> documentation for "M:VisualCronAPI.Connections._Connections.GetDataConnectionTypeString(VisualCron.ConnectionClass.DataConnectionT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetDataConnectionTypeString(VisualCron.ConnectionClass.DataConnectionT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDataProvider Method (strId)

GetDataProvider Method (strId)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetDataProvider(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetDataProvider(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
SQLConnectionClass..::.DataProviderT GetDataProvider(
    string strId
)
Function GetDataProvider ( _
    strId As String _
) As SQLConnectionClass..::.DataProviderT
SQLConnectionClass..::.DataProviderT GetDataProvider(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections._Connections.GetDataProvider(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetDataProvider(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetPortString Method (cc)

GetPortString Method (cc)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetPortString(ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetPortString(VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
string GetPortString(
    ConnectionClass cc
)
Function GetPortString ( _
    cc As ConnectionClass _
) As String
String^ GetPortString(
    ConnectionClass^ cc
)
Parameters
cc (ConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Connections._Connections.GetPortString(VisualCron.ConnectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetPortString(VisualCron.ConnectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetSQLConnectionString Method (strId)

GetSQLConnectionString Method (strId)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► GetSQLConnectionString(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.GetSQLConnectionString(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetSQLConnectionString(
    string strId
)
Function GetSQLConnectionString ( _
    strId As String _
) As String
String^ GetSQLConnectionString(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Connections._Connections.GetSQLConnectionString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.GetSQLConnectionString(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Connections..::._Connections ► Remove()()()
Members
Icon | Member | Description
 | Remove(ConnectionClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (connectionId)

Remove Method (connectionId)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string connectionId
)
Function Remove ( _
    connectionId As String _
) As Boolean
bool Remove(
    String^ connectionId
)
Parameters
connectionId (String)

[Missing <param name="connectionId"/> documentation for "M:VisualCronAPI.Connections._Connections.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (c)

Remove Method (c)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► Remove(ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.Remove(VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    ConnectionClass c
)
Function Remove ( _
    c As ConnectionClass _
) As Boolean
bool Remove(
    ConnectionClass^ c
)
Parameters
c (ConnectionClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Connections._Connections.Remove(VisualCron.ConnectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.Remove(VisualCron.ConnectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Connections..::._Connections ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (c)

Update Method (c)
Namespaces ► VisualCronAPI ► Connections..::._Connections ► Update(ConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Connections._Connections.Update(VisualCron.ConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
ConnectionClass Update(
    ConnectionClass c
)
Function Update ( _
    c As ConnectionClass _
) As ConnectionClass
ConnectionClass^ Update(
    ConnectionClass^ c
)
Parameters
c (ConnectionClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Connections._Connections.Update(VisualCron.ConnectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Connections._Connections.Update(VisualCron.ConnectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections.ConnectionNotFoundException Class

Connections..::.ConnectionNotFoundException Class
Namespaces ► VisualCronAPI ► Connections ► Connections..::.ConnectionNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Connections.ConnectionNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class ConnectionNotFoundException : Exception
Public Class ConnectionNotFoundException _
    Inherits Exception
public ref class ConnectionNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Connections..::.ConnectionNotFoundException(String) | Initializes a new instance of the Connections..::.ConnectionNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Connections..::.ConnectionNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections.ConnectionNotFoundException Constructor (id)

Connections..::.ConnectionNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Connections..::.ConnectionNotFoundException ► Connections..::.ConnectionNotFoundException(String)
Initializes a new instance of the Connections..::.ConnectionNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public ConnectionNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
ConnectionNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Connections.ConnectionNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections.DelegateConnectionAdded Delegate

Connections..::.DelegateConnectionAdded Delegate
Namespaces ► VisualCronAPI ► Connections ► Connections..::.DelegateConnectionAdded

[Missing <summary> documentation for T:VisualCronAPI.Connections.DelegateConnectionAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConnectionAdded(
    ref Server server,
    ConnectionClass cc
)
Public Delegate Sub DelegateConnectionAdded ( _
    ByRef server As Server, _
    cc As ConnectionClass _
)
public delegate void DelegateConnectionAdded(
    Server^% server,
    ConnectionClass^ cc
)
Parameters
server ( Server %)
cc (ConnectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections.DelegateConnectionRemoved Delegate

Connections..::.DelegateConnectionRemoved Delegate
Namespaces ► VisualCronAPI ► Connections ► Connections..::.DelegateConnectionRemoved

[Missing <summary> documentation for T:VisualCronAPI.Connections.DelegateConnectionRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConnectionRemoved(
    ref Server server,
    ConnectionClass cc
)
Public Delegate Sub DelegateConnectionRemoved ( _
    ByRef server As Server, _
    cc As ConnectionClass _
)
public delegate void DelegateConnectionRemoved(
    Server^% server,
    ConnectionClass^ cc
)
Parameters
server ( Server %)
cc (ConnectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections.DelegateConnectionUpdated Delegate

Connections..::.DelegateConnectionUpdated Delegate
Namespaces ► VisualCronAPI ► Connections ► Connections..::.DelegateConnectionUpdated

[Missing <summary> documentation for T:VisualCronAPI.Connections.DelegateConnectionUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateConnectionUpdated(
    ref Server server,
    ConnectionClass cc
)
Public Delegate Sub DelegateConnectionUpdated ( _
    ByRef server As Server, _
    cc As ConnectionClass _
)
public delegate void DelegateConnectionUpdated(
    Server^% server,
    ConnectionClass^ cc
)
Parameters
server ( Server %)
cc (ConnectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials Class

Credentials Class
Namespaces ► VisualCronAPI ► Credentials
Base class for Credential Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Credentials : Credentials..::._Credentials
Public Class Credentials _
    Implements Credentials..::._Credentials
public ref class Credentials : Credentials..::._Credentials
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Credentials(Server) | Initializes a new instance of the Credentials class
 | Add(NetworkCredentialClass) | Adds a Credential
 | Contains(String) | Returns a boolean telling if a specified Credential exist
 | Count()()() | Returns the number of Credential objects on the Server
 | CredentialAdded | This event is raised when a Credental has been added
 | CredentialAddedStatic | This event is raised when a Credental has been added
 | CredentialRemoved | This event is raised when a Credential has been removed
 | CredentialRemovedStatic | This event is raised when a Credential has been removed
 | CredentialUpdated | This event is raised when a Credential has been updated
 | CredentialUpdatedStatic | This event is raised when a Credential has been updated
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Credential based on the string key Id
 | GetAll()()() | Returns a List of Credentials
 | GetAllArray()()() | Returns an array of Credentials
 | GetDescription(String) | Returns a verbose description of a Credential from a Credential Id
 | GetDescription(NetworkCredentialClass) | Returns a verbose description of a Credential from a Credential object
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(NetworkCredentialClass) | Removes a Credential
 | Remove(String) | Removes a Credential
 | RemoveAll()()() | Removes all Credentials
 | Test(String) | Tests a Credential to see if login/impersonation is possible
 | Test(NetworkCredentialClass) | Tests a Credential to see if login/impersonation is possible
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(NetworkCredentialClass) | Updates a Credential
Remarks
Inheritance Hierarchy
Object
Credentials

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials Constructor (s)

Credentials Constructor (s)
Namespaces ► VisualCronAPI ► Credentials ► Credentials(Server)
Initializes a new instance of the Credentials class
Declaration Syntax
C# Visual Basic Visual C++
public Credentials(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
Credentials(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Credentials.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (c)

Add Method (c)
Namespaces ► VisualCronAPI ► Credentials ► Add(NetworkCredentialClass)
Adds a Credential
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialClass Add(
    NetworkCredentialClass c
)
Public Function Add ( _
    c As NetworkCredentialClass _
) As NetworkCredentialClass
public:
virtual NetworkCredentialClass^ Add(
    NetworkCredentialClass^ c
) sealed
Parameters
c (NetworkCredentialClass)
a Credential
Return Value
a Credential
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (credentialId)

Contains Method (credentialId)
Namespaces ► VisualCronAPI ► Credentials ► Contains(String)
Returns a boolean telling if a specified Credential exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string credentialId
)
Public Function Contains ( _
    credentialId As String _
) As Boolean
public:
virtual bool Contains(
    String^ credentialId
) sealed
Parameters
credentialId (String)

[Missing <param name="credentialId"/> documentation for "M:VisualCronAPI.Credentials.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Count Method

Count Method
Namespaces ► VisualCronAPI ► Credentials ► Count()()()
Returns the number of Credential objects on the Server
Declaration Syntax
C# Visual Basic Visual C++
public int Count()
Public Function Count As Integer
public:
virtual int Count() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.Count]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialAdded Event

CredentialAdded Event
Namespaces ► VisualCronAPI ► Credentials ► CredentialAdded
This event is raised when a Credental has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Credentials..::.DelegateCredentialAdded CredentialAdded
Public Event CredentialAdded As Credentials..::.DelegateCredentialAdded
public:
 event Credentials..::.DelegateCredentialAdded^ CredentialAdded {
    void add (Credentials..::.DelegateCredentialAdded^ value);
    void remove (Credentials..::.DelegateCredentialAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialAddedStatic Event

CredentialAddedStatic Event
Namespaces ► VisualCronAPI ► Credentials ► CredentialAddedStatic
This event is raised when a Credental has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Credentials..::.DelegateCredentialAdded CredentialAddedStatic
Public Shared Event CredentialAddedStatic As Credentials..::.DelegateCredentialAdded
public:
static  event Credentials..::.DelegateCredentialAdded^ CredentialAddedStatic {
    void add (Credentials..::.DelegateCredentialAdded^ value);
    void remove (Credentials..::.DelegateCredentialAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialRemoved Event

CredentialRemoved Event
Namespaces ► VisualCronAPI ► Credentials ► CredentialRemoved
This event is raised when a Credential has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Credentials..::.DelegateCredentialRemoved CredentialRemoved
Public Event CredentialRemoved As Credentials..::.DelegateCredentialRemoved
public:
 event Credentials..::.DelegateCredentialRemoved^ CredentialRemoved {
    void add (Credentials..::.DelegateCredentialRemoved^ value);
    void remove (Credentials..::.DelegateCredentialRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialRemovedStatic Event

CredentialRemovedStatic Event
Namespaces ► VisualCronAPI ► Credentials ► CredentialRemovedStatic
This event is raised when a Credential has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Credentials..::.DelegateCredentialRemoved CredentialRemovedStatic
Public Shared Event CredentialRemovedStatic As Credentials..::.DelegateCredentialRemoved
public:
static  event Credentials..::.DelegateCredentialRemoved^ CredentialRemovedStatic {
    void add (Credentials..::.DelegateCredentialRemoved^ value);
    void remove (Credentials..::.DelegateCredentialRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialUpdated Event

CredentialUpdated Event
Namespaces ► VisualCronAPI ► Credentials ► CredentialUpdated
This event is raised when a Credential has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Credentials..::.DelegateCredentialUpdated CredentialUpdated
Public Event CredentialUpdated As Credentials..::.DelegateCredentialUpdated
public:
 event Credentials..::.DelegateCredentialUpdated^ CredentialUpdated {
    void add (Credentials..::.DelegateCredentialUpdated^ value);
    void remove (Credentials..::.DelegateCredentialUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialUpdatedStatic Event

CredentialUpdatedStatic Event
Namespaces ► VisualCronAPI ► Credentials ► CredentialUpdatedStatic
This event is raised when a Credential has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Credentials..::.DelegateCredentialUpdated CredentialUpdatedStatic
Public Shared Event CredentialUpdatedStatic As Credentials..::.DelegateCredentialUpdated
public:
static  event Credentials..::.DelegateCredentialUpdated^ CredentialUpdatedStatic {
    void add (Credentials..::.DelegateCredentialUpdated^ value);
    void remove (Credentials..::.DelegateCredentialUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (credentialId)

Get Method (credentialId)
Namespaces ► VisualCronAPI ► Credentials ► Get(String)
Returns a Credential based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialClass Get(
    string credentialId
)
Public Function Get ( _
    credentialId As String _
) As NetworkCredentialClass
public:
virtual NetworkCredentialClass^ Get(
    String^ credentialId
) sealed
Parameters
credentialId (String)
string key
Return Value
a Credential
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Credentials ► GetAll()()()
Returns a List of Credentials
Declaration Syntax
C# Visual Basic Visual C++
public List<NetworkCredentialClass> GetAll()
Public Function GetAll As List(Of NetworkCredentialClass)
public:
List<NetworkCredentialClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Credentials ► GetAllArray()()()
Returns an array of Credentials
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDescription Method

GetDescription Method
Namespaces ► VisualCronAPI ► Credentials ► GetDescription()()()
Members
Icon | Member | Description
 | GetDescription(String) | Returns a verbose description of a Credential from a Credential Id
 | GetDescription(NetworkCredentialClass) | Returns a verbose description of a Credential from a Credential object

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDescription Method (strNetworkCredentialId)

GetDescription Method (strNetworkCredentialId)
Namespaces ► VisualCronAPI ► Credentials ► GetDescription(String)
Returns a verbose description of a Credential from a Credential Id
Declaration Syntax
C# Visual Basic Visual C++
public string GetDescription(
    string strNetworkCredentialId
)
Public Function GetDescription ( _
    strNetworkCredentialId As String _
) As String
public:
virtual String^ GetDescription(
    String^ strNetworkCredentialId
) sealed
Parameters
strNetworkCredentialId (String)

[Missing <param name="strNetworkCredentialId"/> documentation for "M:VisualCronAPI.Credentials.GetDescription(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.GetDescription(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDescription Method (nc)

GetDescription Method (nc)
Namespaces ► VisualCronAPI ► Credentials ► GetDescription(NetworkCredentialClass)
Returns a verbose description of a Credential from a Credential object
Declaration Syntax
C# Visual Basic Visual C++
public string GetDescription(
    NetworkCredentialClass nc
)
Public Function GetDescription ( _
    nc As NetworkCredentialClass _
) As String
public:
virtual String^ GetDescription(
    NetworkCredentialClass^ nc
) sealed
Parameters
nc (NetworkCredentialClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.Credentials.GetDescription(VisualCron.NetworkCredentialClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.GetDescription(VisualCron.NetworkCredentialClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Credentials ► Remove()()()
Members
Icon | Member | Description
 | Remove(NetworkCredentialClass) | Removes a Credential
 | Remove(String) | Removes a Credential

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (credentialId)

Remove Method (credentialId)
Namespaces ► VisualCronAPI ► Credentials ► Remove(String)
Removes a Credential
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string credentialId
)
Public Function Remove ( _
    credentialId As String _
) As Boolean
public:
virtual bool Remove(
    String^ credentialId
) sealed
Parameters
credentialId (String)
Id of Credential
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (c)

Remove Method (c)
Namespaces ► VisualCronAPI ► Credentials ► Remove(NetworkCredentialClass)
Removes a Credential
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    NetworkCredentialClass c
)
Public Function Remove ( _
    c As NetworkCredentialClass _
) As Boolean
public:
virtual bool Remove(
    NetworkCredentialClass^ c
) sealed
Parameters
c (NetworkCredentialClass)
a Credential
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Credentials ► RemoveAll()()()
Removes all Credentials
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Test Method

Test Method
Namespaces ► VisualCronAPI ► Credentials ► Test()()()
Members
Icon | Member | Description
 | Test(String) | Tests a Credential to see if login/impersonation is possible
 | Test(NetworkCredentialClass) | Tests a Credential to see if login/impersonation is possible

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Test Method (strCredentialId)

Test Method (strCredentialId)
Namespaces ► VisualCronAPI ► Credentials ► Test(String)
Tests a Credential to see if login/impersonation is possible
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialTestResultClass Test(
    string strCredentialId
)
Public Function Test ( _
    strCredentialId As String _
) As NetworkCredentialTestResultClass
public:
virtual NetworkCredentialTestResultClass^ Test(
    String^ strCredentialId
) sealed
Parameters
strCredentialId (String)

[Missing <param name="strCredentialId"/> documentation for "M:VisualCronAPI.Credentials.Test(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.Test(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Test Method (nc)

Test Method (nc)
Namespaces ► VisualCronAPI ► Credentials ► Test(NetworkCredentialClass)
Tests a Credential to see if login/impersonation is possible
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialTestResultClass Test(
    NetworkCredentialClass nc
)
Public Function Test ( _
    nc As NetworkCredentialClass _
) As NetworkCredentialTestResultClass
public:
virtual NetworkCredentialTestResultClass^ Test(
    NetworkCredentialClass^ nc
) sealed
Parameters
nc (NetworkCredentialClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.Credentials.Test(VisualCron.NetworkCredentialClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials.Test(VisualCron.NetworkCredentialClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (c)

Update Method (c)
Namespaces ► VisualCronAPI ► Credentials ► Update(NetworkCredentialClass)
Updates a Credential
Declaration Syntax
C# Visual Basic Visual C++
public NetworkCredentialClass Update(
    NetworkCredentialClass c
)
Public Function Update ( _
    c As NetworkCredentialClass _
) As NetworkCredentialClass
public:
virtual NetworkCredentialClass^ Update(
    NetworkCredentialClass^ c
) sealed
Parameters
c (NetworkCredentialClass)
a Credential
Return Value
a Credential
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials.__Credentials Interface

Credentials..::.__Credentials Interface
Namespaces ► VisualCronAPI ► Credentials ► Credentials..::.__Credentials

[Missing <summary> documentation for T:VisualCronAPI.Credentials.__Credentials]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Credentials
Public Interface __Credentials
public interface class __Credentials
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CredentialAdded(Server%, NetworkCredentialClass) |
 | CredentialRemoved(Server%, NetworkCredentialClass) |
 | CredentialUpdated(Server%, NetworkCredentialClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialAdded Method (server, nc)

CredentialAdded Method (server, nc)
Namespaces ► VisualCronAPI ► Credentials..::.__Credentials ► CredentialAdded(Server%, NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials.__Credentials.CredentialAdded(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
void CredentialAdded(
    ref Server server,
    NetworkCredentialClass nc
)
Sub CredentialAdded ( _
    ByRef server As Server, _
    nc As NetworkCredentialClass _
)
void CredentialAdded(
    Server^% server,
    NetworkCredentialClass^ nc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Credentials.__Credentials.CredentialAdded(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)"]

nc (NetworkCredentialClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.Credentials.__Credentials.CredentialAdded(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialRemoved Method (server, nc)

CredentialRemoved Method (server, nc)
Namespaces ► VisualCronAPI ► Credentials..::.__Credentials ► CredentialRemoved(Server%, NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials.__Credentials.CredentialRemoved(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
void CredentialRemoved(
    ref Server server,
    NetworkCredentialClass nc
)
Sub CredentialRemoved ( _
    ByRef server As Server, _
    nc As NetworkCredentialClass _
)
void CredentialRemoved(
    Server^% server,
    NetworkCredentialClass^ nc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Credentials.__Credentials.CredentialRemoved(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)"]

nc (NetworkCredentialClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.Credentials.__Credentials.CredentialRemoved(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CredentialUpdated Method (server, nc)

CredentialUpdated Method (server, nc)
Namespaces ► VisualCronAPI ► Credentials..::.__Credentials ► CredentialUpdated(Server%, NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials.__Credentials.CredentialUpdated(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
void CredentialUpdated(
    ref Server server,
    NetworkCredentialClass nc
)
Sub CredentialUpdated ( _
    ByRef server As Server, _
    nc As NetworkCredentialClass _
)
void CredentialUpdated(
    Server^% server,
    NetworkCredentialClass^ nc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Credentials.__Credentials.CredentialUpdated(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)"]

nc (NetworkCredentialClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.Credentials.__Credentials.CredentialUpdated(VisualCronAPI.Server@,VisualCron.NetworkCredentialClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials._Credentials Interface

Credentials..::._Credentials Interface
Namespaces ► VisualCronAPI ► Credentials ► Credentials..::._Credentials

[Missing <summary> documentation for T:VisualCronAPI.Credentials._Credentials]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Credentials
Public Interface _Credentials
public interface class _Credentials
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(NetworkCredentialClass) |
 | Contains(String) |
 | Count()()() |
 | Get(String) |
 | GetAllArray()()() |
 | GetDescription(String) |
 | GetDescription(NetworkCredentialClass) |
 | Remove(NetworkCredentialClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | Test(String) |
 | Test(NetworkCredentialClass) |
 | Update(NetworkCredentialClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (c)

Add Method (c)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Add(NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Add(VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkCredentialClass Add(
    NetworkCredentialClass c
)
Function Add ( _
    c As NetworkCredentialClass _
) As NetworkCredentialClass
NetworkCredentialClass^ Add(
    NetworkCredentialClass^ c
)
Parameters
c (NetworkCredentialClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Add(VisualCron.NetworkCredentialClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Add(VisualCron.NetworkCredentialClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (credentialId)

Contains Method (credentialId)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string credentialId
)
Function Contains ( _
    credentialId As String _
) As Boolean
bool Contains(
    String^ credentialId
)
Parameters
credentialId (String)

[Missing <param name="credentialId"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Count Method

Count Method
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Count()()()

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Count]

Declaration Syntax
C# Visual Basic Visual C++
int Count()
Function Count As Integer
int Count()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Count]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (credentialId)

Get Method (credentialId)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkCredentialClass Get(
    string credentialId
)
Function Get ( _
    credentialId As String _
) As NetworkCredentialClass
NetworkCredentialClass^ Get(
    String^ credentialId
)
Parameters
credentialId (String)

[Missing <param name="credentialId"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDescription Method

GetDescription Method
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► GetDescription()()()
Members
Icon | Member | Description
 | GetDescription(String) |
 | GetDescription(NetworkCredentialClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDescription Method (strNetworkCredentialId)

GetDescription Method (strNetworkCredentialId)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► GetDescription(String)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.GetDescription(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetDescription(
    string strNetworkCredentialId
)
Function GetDescription ( _
    strNetworkCredentialId As String _
) As String
String^ GetDescription(
    String^ strNetworkCredentialId
)
Parameters
strNetworkCredentialId (String)

[Missing <param name="strNetworkCredentialId"/> documentation for "M:VisualCronAPI.Credentials._Credentials.GetDescription(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.GetDescription(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDescription Method (nc)

GetDescription Method (nc)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► GetDescription(NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.GetDescription(VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
string GetDescription(
    NetworkCredentialClass nc
)
Function GetDescription ( _
    nc As NetworkCredentialClass _
) As String
String^ GetDescription(
    NetworkCredentialClass^ nc
)
Parameters
nc (NetworkCredentialClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.Credentials._Credentials.GetDescription(VisualCron.NetworkCredentialClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.GetDescription(VisualCron.NetworkCredentialClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Remove()()()
Members
Icon | Member | Description
 | Remove(NetworkCredentialClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (credentialId)

Remove Method (credentialId)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string credentialId
)
Function Remove ( _
    credentialId As String _
) As Boolean
bool Remove(
    String^ credentialId
)
Parameters
credentialId (String)

[Missing <param name="credentialId"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (c)

Remove Method (c)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Remove(NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Remove(VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    NetworkCredentialClass c
)
Function Remove ( _
    c As NetworkCredentialClass _
) As Boolean
bool Remove(
    NetworkCredentialClass^ c
)
Parameters
c (NetworkCredentialClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Remove(VisualCron.NetworkCredentialClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Remove(VisualCron.NetworkCredentialClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Test Method

Test Method
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Test()()()
Members
Icon | Member | Description
 | Test(String) |
 | Test(NetworkCredentialClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Test Method (strCredentialId)

Test Method (strCredentialId)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Test(String)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Test(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkCredentialTestResultClass Test(
    string strCredentialId
)
Function Test ( _
    strCredentialId As String _
) As NetworkCredentialTestResultClass
NetworkCredentialTestResultClass^ Test(
    String^ strCredentialId
)
Parameters
strCredentialId (String)

[Missing <param name="strCredentialId"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Test(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Test(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Test Method (nc)

Test Method (nc)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Test(NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Test(VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkCredentialTestResultClass Test(
    NetworkCredentialClass nc
)
Function Test ( _
    nc As NetworkCredentialClass _
) As NetworkCredentialTestResultClass
NetworkCredentialTestResultClass^ Test(
    NetworkCredentialClass^ nc
)
Parameters
nc (NetworkCredentialClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Test(VisualCron.NetworkCredentialClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Test(VisualCron.NetworkCredentialClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (c)

Update Method (c)
Namespaces ► VisualCronAPI ► Credentials..::._Credentials ► Update(NetworkCredentialClass)

[Missing <summary> documentation for M:VisualCronAPI.Credentials._Credentials.Update(VisualCron.NetworkCredentialClass)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkCredentialClass Update(
    NetworkCredentialClass c
)
Function Update ( _
    c As NetworkCredentialClass _
) As NetworkCredentialClass
NetworkCredentialClass^ Update(
    NetworkCredentialClass^ c
)
Parameters
c (NetworkCredentialClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.Credentials._Credentials.Update(VisualCron.NetworkCredentialClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Credentials._Credentials.Update(VisualCron.NetworkCredentialClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials.CredentialNotFoundException Class

Credentials..::.CredentialNotFoundException Class
Namespaces ► VisualCronAPI ► Credentials ► Credentials..::.CredentialNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Credentials.CredentialNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class CredentialNotFoundException : Exception
Public Class CredentialNotFoundException _
    Inherits Exception
public ref class CredentialNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Credentials..::.CredentialNotFoundException(String) | Initializes a new instance of the Credentials..::.CredentialNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Credentials..::.CredentialNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials.CredentialNotFoundException Constructor (id)

Credentials..::.CredentialNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Credentials..::.CredentialNotFoundException ► Credentials..::.CredentialNotFoundException(String)
Initializes a new instance of the Credentials..::.CredentialNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public CredentialNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
CredentialNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Credentials.CredentialNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials.DelegateCredentialAdded Delegate

Credentials..::.DelegateCredentialAdded Delegate
Namespaces ► VisualCronAPI ► Credentials ► Credentials..::.DelegateCredentialAdded

[Missing <summary> documentation for T:VisualCronAPI.Credentials.DelegateCredentialAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateCredentialAdded(
    ref Server server,
    NetworkCredentialClass nc
)
Public Delegate Sub DelegateCredentialAdded ( _
    ByRef server As Server, _
    nc As NetworkCredentialClass _
)
public delegate void DelegateCredentialAdded(
    Server^% server,
    NetworkCredentialClass^ nc
)
Parameters
server ( Server %)
nc (NetworkCredentialClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials.DelegateCredentialRemoved Delegate

Credentials..::.DelegateCredentialRemoved Delegate
Namespaces ► VisualCronAPI ► Credentials ► Credentials..::.DelegateCredentialRemoved

[Missing <summary> documentation for T:VisualCronAPI.Credentials.DelegateCredentialRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateCredentialRemoved(
    ref Server server,
    NetworkCredentialClass nc
)
Public Delegate Sub DelegateCredentialRemoved ( _
    ByRef server As Server, _
    nc As NetworkCredentialClass _
)
public delegate void DelegateCredentialRemoved(
    Server^% server,
    NetworkCredentialClass^ nc
)
Parameters
server ( Server %)
nc (NetworkCredentialClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials.DelegateCredentialUpdated Delegate

Credentials..::.DelegateCredentialUpdated Delegate
Namespaces ► VisualCronAPI ► Credentials ► Credentials..::.DelegateCredentialUpdated

[Missing <summary> documentation for T:VisualCronAPI.Credentials.DelegateCredentialUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateCredentialUpdated(
    ref Server server,
    NetworkCredentialClass nc
)
Public Delegate Sub DelegateCredentialUpdated ( _
    ByRef server As Server, _
    nc As NetworkCredentialClass _
)
public delegate void DelegateCredentialUpdated(
    Server^% server,
    NetworkCredentialClass^ nc
)
Parameters
server ( Server %)
nc (NetworkCredentialClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EmailSettings Class

EmailSettings Class
Namespaces ► VisualCronAPI ► EmailSettings

[Missing <summary> documentation for T:VisualCronAPI.EmailSettings]

Declaration Syntax
C# Visual Basic Visual C++
public class EmailSettings
Public Class EmailSettings
public ref class EmailSettings
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmailSettings(Server) | Initializes a new instance of the EmailSettings class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromEmail | Default from address
 | FromName | Default from name
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Host | Default host
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord | Password for SMTP server
 | Port | Default port setting (25)
 | ToEmail | Default "to"-email(s)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseAuthentication | Default setting that controls if authentication should be used when sending email
 | UserName | Username for the SMTP server
Inheritance Hierarchy
Object
EmailSettings

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EmailSettings Constructor (s)

EmailSettings Constructor (s)
Namespaces ► VisualCronAPI ► EmailSettings ► EmailSettings(Server)
Initializes a new instance of the EmailSettings class
Declaration Syntax
C# Visual Basic Visual C++
public EmailSettings(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
EmailSettings(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.EmailSettings.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FromEmail Property

FromEmail Property
Namespaces ► VisualCronAPI ► EmailSettings ► FromEmail
Default from address
Declaration Syntax
C# Visual Basic Visual C++
public string FromEmail { get; set; }
Public Property FromEmail As String
public:
property String^ FromEmail {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FromName Property

FromName Property
Namespaces ► VisualCronAPI ► EmailSettings ► FromName
Default from name
Declaration Syntax
C# Visual Basic Visual C++
public string FromName { get; set; }
Public Property FromName As String
public:
property String^ FromName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Host Property

Host Property
Namespaces ► VisualCronAPI ► EmailSettings ► Host
Default host
Declaration Syntax
C# Visual Basic Visual C++
public string Host { get; set; }
Public Property Host As String
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PassWord Property

PassWord Property
Namespaces ► VisualCronAPI ► EmailSettings ► PassWord
Password for SMTP server
Declaration Syntax
C# Visual Basic Visual C++
public string PassWord { get; set; }
Public Property PassWord As String
public:
property String^ PassWord {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Port Property

Port Property
Namespaces ► VisualCronAPI ► EmailSettings ► Port
Default port setting (25)
Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
property int Port {
    int get ();
    void set (int value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ToEmail Property

ToEmail Property
Namespaces ► VisualCronAPI ► EmailSettings ► ToEmail
Default "to"-email(s)
Declaration Syntax
C# Visual Basic Visual C++
public string ToEmail { get; set; }
Public Property ToEmail As String
public:
property String^ ToEmail {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UseAuthentication Property

UseAuthentication Property
Namespaces ► VisualCronAPI ► EmailSettings ► UseAuthentication
Default setting that controls if authentication should be used when sending email
Declaration Syntax
C# Visual Basic Visual C++
public bool UseAuthentication { get; set; }
Public Property UseAuthentication As Boolean
public:
property bool UseAuthentication {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserName Property

UserName Property
Namespaces ► VisualCronAPI ► EmailSettings ► UserName
Username for the SMTP server
Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExceptionHandler Class

ExceptionHandler Class
Namespaces ► VisualCronAPI ► ExceptionHandler

[Missing <summary> documentation for T:VisualCronAPI.ExceptionHandler]

Declaration Syntax
C# Visual Basic Visual C++
public class ExceptionHandler
Public Class ExceptionHandler
public ref class ExceptionHandler
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExceptionHandler()()() | Initializes a new instance of the ExceptionHandler class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventThrowException |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RaiseException(Exception, Boolean) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExceptionHandler

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExceptionHandler Constructor

ExceptionHandler Constructor
Namespaces ► VisualCronAPI ► ExceptionHandler ► ExceptionHandler()()()
Initializes a new instance of the ExceptionHandler class
Declaration Syntax
C# Visual Basic Visual C++
public ExceptionHandler()
Public Sub New
public:
ExceptionHandler()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventThrowException Event

EventThrowException Event
Namespaces ► VisualCronAPI ► ExceptionHandler ► EventThrowException

[Missing <summary> documentation for E:VisualCronAPI.ExceptionHandler.EventThrowException]

Declaration Syntax
C# Visual Basic Visual C++
public static event ExceptionHandler..::.DelegateThrowException EventThrowException
Public Shared Event EventThrowException As ExceptionHandler..::.DelegateThrowException
public:
static  event ExceptionHandler..::.DelegateThrowException^ EventThrowException {
    void add (ExceptionHandler..::.DelegateThrowException^ value);
    void remove (ExceptionHandler..::.DelegateThrowException^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RaiseException Method (ex, bolThrowException)

RaiseException Method (ex, bolThrowException)
Namespaces ► VisualCronAPI ► ExceptionHandler ► RaiseException(Exception, Boolean)

[Missing <summary> documentation for M:VisualCronAPI.ExceptionHandler.RaiseException(System.Exception,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public static void RaiseException(
    Exception ex,
    bool bolThrowException
)
Public Shared Sub RaiseException ( _
    ex As Exception, _
    bolThrowException As Boolean _
)
public:
static void RaiseException(
    Exception^ ex,
    bool bolThrowException
)
Parameters
ex (Exception)

[Missing <param name="ex"/> documentation for "M:VisualCronAPI.ExceptionHandler.RaiseException(System.Exception,System.Boolean)"]

bolThrowException (Boolean)

[Missing <param name="bolThrowException"/> documentation for "M:VisualCronAPI.ExceptionHandler.RaiseException(System.Exception,System.Boolean)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExceptionHandler.DelegateThrowException Delegate

ExceptionHandler..::.DelegateThrowException Delegate
Namespaces ► VisualCronAPI ► ExceptionHandler ► ExceptionHandler..::.DelegateThrowException

[Missing <summary> documentation for T:VisualCronAPI.ExceptionHandler.DelegateThrowException]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateThrowException(
    Exception ex
)
Public Delegate Sub DelegateThrowException ( _
    ex As Exception _
)
public delegate void DelegateThrowException(
    Exception^ ex
)
Parameters
ex (Exception)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExitCodes Class

ExitCodes Class
Namespaces ► VisualCronAPI ► ExitCodes

[Missing <summary> documentation for T:VisualCronAPI.ExitCodes]

Declaration Syntax
C# Visual Basic Visual C++
public class ExitCodes
Public Class ExitCodes
public ref class ExitCodes
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExitCodes()()() | Initializes a new instance of the ExitCodes class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDescription(Int32) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Load()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExitCodes

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExitCodes Constructor

ExitCodes Constructor
Namespaces ► VisualCronAPI ► ExitCodes ► ExitCodes()()()
Initializes a new instance of the ExitCodes class
Declaration Syntax
C# Visual Basic Visual C++
public ExitCodes()
Public Sub New
public:
ExitCodes()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetDescription Method (intExitCode)

GetDescription Method (intExitCode)
Namespaces ► VisualCronAPI ► ExitCodes ► GetDescription(Int32)

[Missing <summary> documentation for M:VisualCronAPI.ExitCodes.GetDescription(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetDescription(
    int intExitCode
)
Public Shared Function GetDescription ( _
    intExitCode As Integer _
) As String
public:
static String^ GetDescription(
    int intExitCode
)
Parameters
intExitCode (Int32)

[Missing <param name="intExitCode"/> documentation for "M:VisualCronAPI.ExitCodes.GetDescription(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.ExitCodes.GetDescription(System.Int32)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Load Method

Load Method
Namespaces ► VisualCronAPI ► ExitCodes ► Load()()()

[Missing <summary> documentation for M:VisualCronAPI.ExitCodes.Load]

Declaration Syntax
C# Visual Basic Visual C++
public static void Load()
Public Shared Sub Load
public:
static void Load()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Explorer Class

Explorer Class
Namespaces ► VisualCronAPI ► Explorer

[Missing <summary> documentation for T:VisualCronAPI.Explorer]

Declaration Syntax
C# Visual Basic Visual C++
public class Explorer
Public Class Explorer
public ref class Explorer
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Explorer(Server) | Initializes a new instance of the Explorer class
 | CopyDirectory(String, String) |
 | CopyDirectoryContent(String, String) |
 | DirectorySize(DirectoryInfo) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Search(List<(Of <(String>)>)%, List<(Of <(String>)>)%, String, String) |
 | SendDelete(array<String>[]()[]) |
 | SendGetDirectoryContent(String) |
 | SendGetFileProperties(String) |
 | SendGetLogicalDrives()()() |
 | SendNewFolder(String, String) |
 | SendPasteToServer(String, array<Byte>[]()[], String) |
 | SendRemoteCopy(String, array<String>[]()[], String) |
 | SendRename(String, String, TargetT) |
 | SendSearch(String, String) |
 | SendSetAttributes(Boolean, Boolean, String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WildcardMatch(String, String) |
Inheritance Hierarchy
Object
Explorer

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Explorer Constructor (s)

Explorer Constructor (s)
Namespaces ► VisualCronAPI ► Explorer ► Explorer(Server)
Initializes a new instance of the Explorer class
Declaration Syntax
C# Visual Basic Visual C++
public Explorer(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
Explorer(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Explorer.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CopyDirectory Method (src, dst)

CopyDirectory Method (src, dst)
Namespaces ► VisualCronAPI ► Explorer ► CopyDirectory(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.CopyDirectory(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static void CopyDirectory(
    string src,
    string dst
)
Public Shared Sub CopyDirectory ( _
    src As String, _
    dst As String _
)
public:
static void CopyDirectory(
    String^ src,
    String^ dst
)
Parameters
src (String)

[Missing <param name="src"/> documentation for "M:VisualCronAPI.Explorer.CopyDirectory(System.String,System.String)"]

dst (String)

[Missing <param name="dst"/> documentation for "M:VisualCronAPI.Explorer.CopyDirectory(System.String,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CopyDirectoryContent Method (src, dst)

CopyDirectoryContent Method (src, dst)
Namespaces ► VisualCronAPI ► Explorer ► CopyDirectoryContent(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.CopyDirectoryContent(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static void CopyDirectoryContent(
    string src,
    string dst
)
Public Shared Sub CopyDirectoryContent ( _
    src As String, _
    dst As String _
)
public:
static void CopyDirectoryContent(
    String^ src,
    String^ dst
)
Parameters
src (String)

[Missing <param name="src"/> documentation for "M:VisualCronAPI.Explorer.CopyDirectoryContent(System.String,System.String)"]

dst (String)

[Missing <param name="dst"/> documentation for "M:VisualCronAPI.Explorer.CopyDirectoryContent(System.String,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DirectorySize Method (info)

DirectorySize Method (info)
Namespaces ► VisualCronAPI ► Explorer ► DirectorySize(DirectoryInfo)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.DirectorySize(System.IO.DirectoryInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public static long DirectorySize(
    DirectoryInfo info
)
Public Shared Function DirectorySize ( _
    info As DirectoryInfo _
) As Long
public:
static long long DirectorySize(
    DirectoryInfo^ info
)
Parameters
info (DirectoryInfo)

[Missing <param name="info"/> documentation for "M:VisualCronAPI.Explorer.DirectorySize(System.IO.DirectoryInfo)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Explorer.DirectorySize(System.IO.DirectoryInfo)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Search Method (resultDirectories, resultFiles, src, pattern)

Search Method (resultDirectories, resultFiles, src, pattern)
Namespaces ► VisualCronAPI ► Explorer ► Search(List<(Of <(String>)>)%, List<(Of <(String>)>)%, String, String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.Search(System.Collections.Generic.List{System.String}@,System.Collections.Generic.List{System.String}@,System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static void Search(
    ref List<string> resultDirectories,
    ref List<string> resultFiles,
    string src,
    string pattern
)
Public Shared Sub Search ( _
    ByRef resultDirectories As List(Of String), _
    ByRef resultFiles As List(Of String), _
    src As String, _
    pattern As String _
)
public:
static void Search(
    List<String^>^% resultDirectories,
    List<String^>^% resultFiles,
    String^ src,
    String^ pattern
)
Parameters
resultDirectories ( List <(Of <( String >)>) %)

[Missing <param name="resultDirectories"/> documentation for "M:VisualCronAPI.Explorer.Search(System.Collections.Generic.List{System.String}@,System.Collections.Generic.List{System.String}@,System.String,System.String)"]

resultFiles ( List <(Of <( String >)>) %)

[Missing <param name="resultFiles"/> documentation for "M:VisualCronAPI.Explorer.Search(System.Collections.Generic.List{System.String}@,System.Collections.Generic.List{System.String}@,System.String,System.String)"]

src (String)

[Missing <param name="src"/> documentation for "M:VisualCronAPI.Explorer.Search(System.Collections.Generic.List{System.String}@,System.Collections.Generic.List{System.String}@,System.String,System.String)"]

pattern (String)

[Missing <param name="pattern"/> documentation for "M:VisualCronAPI.Explorer.Search(System.Collections.Generic.List{System.String}@,System.Collections.Generic.List{System.String}@,System.String,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendDelete Method (strTargets)

SendDelete Method (strTargets)
Namespaces ► VisualCronAPI ► Explorer ► SendDelete(array<String>[]()[])

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendDelete(System.String[])]

Declaration Syntax
C# Visual Basic Visual C++
public void SendDelete(
    string[] strTargets
)
Public Sub SendDelete ( _
    strTargets As String() _
)
public:
void SendDelete(
    array<String^>^ strTargets
)
Parameters
strTargets (array< String >[]()[])

[Missing <param name="strTargets"/> documentation for "M:VisualCronAPI.Explorer.SendDelete(System.String[])"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendGetDirectoryContent Method (strTargetDirectory)

SendGetDirectoryContent Method (strTargetDirectory)
Namespaces ► VisualCronAPI ► Explorer ► SendGetDirectoryContent(String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendGetDirectoryContent(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendGetDirectoryContent(
    string strTargetDirectory
)
Public Sub SendGetDirectoryContent ( _
    strTargetDirectory As String _
)
public:
void SendGetDirectoryContent(
    String^ strTargetDirectory
)
Parameters
strTargetDirectory (String)

[Missing <param name="strTargetDirectory"/> documentation for "M:VisualCronAPI.Explorer.SendGetDirectoryContent(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendGetFileProperties Method (strTarget)

SendGetFileProperties Method (strTarget)
Namespaces ► VisualCronAPI ► Explorer ► SendGetFileProperties(String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendGetFileProperties(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendGetFileProperties(
    string strTarget
)
Public Sub SendGetFileProperties ( _
    strTarget As String _
)
public:
void SendGetFileProperties(
    String^ strTarget
)
Parameters
strTarget (String)

[Missing <param name="strTarget"/> documentation for "M:VisualCronAPI.Explorer.SendGetFileProperties(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendGetLogicalDrives Method

SendGetLogicalDrives Method
Namespaces ► VisualCronAPI ► Explorer ► SendGetLogicalDrives()()()

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendGetLogicalDrives]

Declaration Syntax
C# Visual Basic Visual C++
public void SendGetLogicalDrives()
Public Sub SendGetLogicalDrives
public:
void SendGetLogicalDrives()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendNewFolder Method (strParent, strNewName)

SendNewFolder Method (strParent, strNewName)
Namespaces ► VisualCronAPI ► Explorer ► SendNewFolder(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendNewFolder(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendNewFolder(
    string strParent,
    string strNewName
)
Public Sub SendNewFolder ( _
    strParent As String, _
    strNewName As String _
)
public:
void SendNewFolder(
    String^ strParent,
    String^ strNewName
)
Parameters
strParent (String)

[Missing <param name="strParent"/> documentation for "M:VisualCronAPI.Explorer.SendNewFolder(System.String,System.String)"]

strNewName (String)

[Missing <param name="strNewName"/> documentation for "M:VisualCronAPI.Explorer.SendNewFolder(System.String,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendPasteToServer Method (strTargetDirectory, zipBytes, strNodeToRefresh)

SendPasteToServer Method (strTargetDirectory, zipBytes, strNodeToRefresh)
Namespaces ► VisualCronAPI ► Explorer ► SendPasteToServer(String, array<Byte>[]()[], String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendPasteToServer(System.String,System.Byte[],System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendPasteToServer(
    string strTargetDirectory,
    byte[] zipBytes,
    string strNodeToRefresh
)
Public Sub SendPasteToServer ( _
    strTargetDirectory As String, _
    zipBytes As Byte(), _
    strNodeToRefresh As String _
)
public:
void SendPasteToServer(
    String^ strTargetDirectory,
    array<unsigned char>^ zipBytes,
    String^ strNodeToRefresh
)
Parameters
strTargetDirectory (String)

[Missing <param name="strTargetDirectory"/> documentation for "M:VisualCronAPI.Explorer.SendPasteToServer(System.String,System.Byte[],System.String)"]

zipBytes (array< Byte >[]()[])

[Missing <param name="zipBytes"/> documentation for "M:VisualCronAPI.Explorer.SendPasteToServer(System.String,System.Byte[],System.String)"]

strNodeToRefresh (String)

[Missing <param name="strNodeToRefresh"/> documentation for "M:VisualCronAPI.Explorer.SendPasteToServer(System.String,System.Byte[],System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendRemoteCopy Method (strTargetDirectory, strTargets, strNodeToRefresh)

SendRemoteCopy Method (strTargetDirectory, strTargets, strNodeToRefresh)
Namespaces ► VisualCronAPI ► Explorer ► SendRemoteCopy(String, array<String>[]()[], String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendRemoteCopy(System.String,System.String[],System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendRemoteCopy(
    string strTargetDirectory,
    string[] strTargets,
    string strNodeToRefresh
)
Public Sub SendRemoteCopy ( _
    strTargetDirectory As String, _
    strTargets As String(), _
    strNodeToRefresh As String _
)
public:
void SendRemoteCopy(
    String^ strTargetDirectory,
    array<String^>^ strTargets,
    String^ strNodeToRefresh
)
Parameters
strTargetDirectory (String)

[Missing <param name="strTargetDirectory"/> documentation for "M:VisualCronAPI.Explorer.SendRemoteCopy(System.String,System.String[],System.String)"]

strTargets (array< String >[]()[])

[Missing <param name="strTargets"/> documentation for "M:VisualCronAPI.Explorer.SendRemoteCopy(System.String,System.String[],System.String)"]

strNodeToRefresh (String)

[Missing <param name="strNodeToRefresh"/> documentation for "M:VisualCronAPI.Explorer.SendRemoteCopy(System.String,System.String[],System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendRename Method (strTarget, strNewName, tt)

SendRename Method (strTarget, strNewName, tt)
Namespaces ► VisualCronAPI ► Explorer ► SendRename(String, String, TargetT)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendRename(System.String,System.String,VisualCron.FileExplorer.FERename.TargetT)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendRename(
    string strTarget,
    string strNewName,
    TargetT tt
)
Public Sub SendRename ( _
    strTarget As String, _
    strNewName As String, _
    tt As TargetT _
)
public:
void SendRename(
    String^ strTarget,
    String^ strNewName,
    TargetT tt
)
Parameters
strTarget (String)

[Missing <param name="strTarget"/> documentation for "M:VisualCronAPI.Explorer.SendRename(System.String,System.String,VisualCron.FileExplorer.FERename.TargetT)"]

strNewName (String)

[Missing <param name="strNewName"/> documentation for "M:VisualCronAPI.Explorer.SendRename(System.String,System.String,VisualCron.FileExplorer.FERename.TargetT)"]

tt (TargetT)

[Missing <param name="tt"/> documentation for "M:VisualCronAPI.Explorer.SendRename(System.String,System.String,VisualCron.FileExplorer.FERename.TargetT)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendSearch Method (strTargetDirectory, strPattern)

SendSearch Method (strTargetDirectory, strPattern)
Namespaces ► VisualCronAPI ► Explorer ► SendSearch(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendSearch(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendSearch(
    string strTargetDirectory,
    string strPattern
)
Public Sub SendSearch ( _
    strTargetDirectory As String, _
    strPattern As String _
)
public:
void SendSearch(
    String^ strTargetDirectory,
    String^ strPattern
)
Parameters
strTargetDirectory (String)

[Missing <param name="strTargetDirectory"/> documentation for "M:VisualCronAPI.Explorer.SendSearch(System.String,System.String)"]

strPattern (String)

[Missing <param name="strPattern"/> documentation for "M:VisualCronAPI.Explorer.SendSearch(System.String,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendSetAttributes Method (bolIsReadonly, bolHidden, strTarget)

SendSetAttributes Method (bolIsReadonly, bolHidden, strTarget)
Namespaces ► VisualCronAPI ► Explorer ► SendSetAttributes(Boolean, Boolean, String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.SendSetAttributes(System.Boolean,System.Boolean,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendSetAttributes(
    bool bolIsReadonly,
    bool bolHidden,
    string strTarget
)
Public Sub SendSetAttributes ( _
    bolIsReadonly As Boolean, _
    bolHidden As Boolean, _
    strTarget As String _
)
public:
void SendSetAttributes(
    bool bolIsReadonly,
    bool bolHidden,
    String^ strTarget
)
Parameters
bolIsReadonly (Boolean)

[Missing <param name="bolIsReadonly"/> documentation for "M:VisualCronAPI.Explorer.SendSetAttributes(System.Boolean,System.Boolean,System.String)"]

bolHidden (Boolean)

[Missing <param name="bolHidden"/> documentation for "M:VisualCronAPI.Explorer.SendSetAttributes(System.Boolean,System.Boolean,System.String)"]

strTarget (String)

[Missing <param name="strTarget"/> documentation for "M:VisualCronAPI.Explorer.SendSetAttributes(System.Boolean,System.Boolean,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


WildcardMatch Method (input, pattern)

WildcardMatch Method (input, pattern)
Namespaces ► VisualCronAPI ► Explorer ► WildcardMatch(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Explorer.WildcardMatch(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool WildcardMatch(
    string input,
    string pattern
)
Public Shared Function WildcardMatch ( _
    input As String, _
    pattern As String _
) As Boolean
public:
static bool WildcardMatch(
    String^ input,
    String^ pattern
)
Parameters
input (String)

[Missing <param name="input"/> documentation for "M:VisualCronAPI.Explorer.WildcardMatch(System.String,System.String)"]

pattern (String)

[Missing <param name="pattern"/> documentation for "M:VisualCronAPI.Explorer.WildcardMatch(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Explorer.WildcardMatch(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FunctionsAPI Class

FunctionsAPI Class
Namespaces ► VisualCronAPI ► FunctionsAPI

[Missing <summary> documentation for T:VisualCronAPI.FunctionsAPI]

Declaration Syntax
C# Visual Basic Visual C++
public class FunctionsAPI
Public Class FunctionsAPI
public ref class FunctionsAPI
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FunctionsAPI()()() | Initializes a new instance of the FunctionsAPI class
 | ContainsWildcard(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FlushMemory()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Match(String, String) | Returns true if the string matches the pattern which may contain * and ? wildcards. Matching is done without regard to case.
 | Match(String, String, Boolean) | Returns true if the string matches the pattern which may contain * and ? wildcards.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidateEmail(String) |
Inheritance Hierarchy
Object
FunctionsAPI

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FunctionsAPI Constructor

FunctionsAPI Constructor
Namespaces ► VisualCronAPI ► FunctionsAPI ► FunctionsAPI()()()
Initializes a new instance of the FunctionsAPI class
Declaration Syntax
C# Visual Basic Visual C++
public FunctionsAPI()
Public Sub New
public:
FunctionsAPI()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ContainsWildcard Method (s)

ContainsWildcard Method (s)
Namespaces ► VisualCronAPI ► FunctionsAPI ► ContainsWildcard(String)

[Missing <summary> documentation for M:VisualCronAPI.FunctionsAPI.ContainsWildcard(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool ContainsWildcard(
    string s
)
Public Shared Function ContainsWildcard ( _
    s As String _
) As Boolean
public:
static bool ContainsWildcard(
    String^ s
)
Parameters
s (String)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.FunctionsAPI.ContainsWildcard(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.FunctionsAPI.ContainsWildcard(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FlushMemory Method

FlushMemory Method
Namespaces ► VisualCronAPI ► FunctionsAPI ► FlushMemory()()()

[Missing <summary> documentation for M:VisualCronAPI.FunctionsAPI.FlushMemory]

Declaration Syntax
C# Visual Basic Visual C++
public static void FlushMemory()
Public Shared Sub FlushMemory
public:
static void FlushMemory()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Match Method

Match Method
Namespaces ► VisualCronAPI ► FunctionsAPI ► Match()()()
Members
Icon | Member | Description
 | Match(String, String) | Returns true if the string matches the pattern which may contain * and ? wildcards. Matching is done without regard to case.
 | Match(String, String, Boolean) | Returns true if the string matches the pattern which may contain * and ? wildcards.

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Match Method (pattern, s)

Match Method (pattern, s)
Namespaces ► VisualCronAPI ► FunctionsAPI ► Match(String, String)
Returns true if the string matches the pattern which may contain * and ? wildcards. Matching is done without regard to case.
Declaration Syntax
C# Visual Basic Visual C++
public static bool Match(
    string pattern,
    string s
)
Public Shared Function Match ( _
    pattern As String, _
    s As String _
) As Boolean
public:
static bool Match(
    String^ pattern,
    String^ s
)
Parameters
pattern (String)

[Missing <param name="pattern"/> documentation for "M:VisualCronAPI.FunctionsAPI.Match(System.String,System.String)"]

s (String)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.FunctionsAPI.Match(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.FunctionsAPI.Match(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Match Method (pattern, s, caseSensitive)

Match Method (pattern, s, caseSensitive)
Namespaces ► VisualCronAPI ► FunctionsAPI ► Match(String, String, Boolean)
Returns true if the string matches the pattern which may contain * and ? wildcards.
Declaration Syntax
C# Visual Basic Visual C++
public static bool Match(
    string pattern,
    string s,
    bool caseSensitive
)
Public Shared Function Match ( _
    pattern As String, _
    s As String, _
    caseSensitive As Boolean _
) As Boolean
public:
static bool Match(
    String^ pattern,
    String^ s,
    bool caseSensitive
)
Parameters
pattern (String)

[Missing <param name="pattern"/> documentation for "M:VisualCronAPI.FunctionsAPI.Match(System.String,System.String,System.Boolean)"]

s (String)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.FunctionsAPI.Match(System.String,System.String,System.Boolean)"]

caseSensitive (Boolean)

[Missing <param name="caseSensitive"/> documentation for "M:VisualCronAPI.FunctionsAPI.Match(System.String,System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.FunctionsAPI.Match(System.String,System.String,System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ValidateEmail Method (strEmail)

ValidateEmail Method (strEmail)
Namespaces ► VisualCronAPI ► FunctionsAPI ► ValidateEmail(String)

[Missing <summary> documentation for M:VisualCronAPI.FunctionsAPI.ValidateEmail(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool ValidateEmail(
    string strEmail
)
Public Shared Function ValidateEmail ( _
    strEmail As String _
) As Boolean
public:
static bool ValidateEmail(
    String^ strEmail
)
Parameters
strEmail (String)

[Missing <param name="strEmail"/> documentation for "M:VisualCronAPI.FunctionsAPI.ValidateEmail(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.FunctionsAPI.ValidateEmail(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ImpersonationClass Class

ImpersonationClass Class
Namespaces ► VisualCronAPI ► ImpersonationClass

[Missing <summary> documentation for T:VisualCronAPI.ImpersonationClass]

Declaration Syntax
C# Visual Basic Visual C++
public class ImpersonationClass
Public Class ImpersonationClass
public ref class ImpersonationClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ImpersonationClass()()() | Initializes a new instance of the ImpersonationClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessage |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Impersonate(String, String, String, Boolean, Boolean, Boolean) |
 | IsLoggedOn |
 | LoadUserProfile(IntPtr, ImpersonationClass..::.PROFILEINFO%) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UndoImpersonation()()() |
 | UnloadUserProfile(IntPtr, IntPtr) |
Inheritance Hierarchy
Object
ImpersonationClass

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ImpersonationClass Constructor

ImpersonationClass Constructor
Namespaces ► VisualCronAPI ► ImpersonationClass ► ImpersonationClass()()()
Initializes a new instance of the ImpersonationClass class
Declaration Syntax
C# Visual Basic Visual C++
public ImpersonationClass()
Public Sub New
public:
ImpersonationClass()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ErrorMessage Field

ErrorMessage Field
Namespaces ► VisualCronAPI ► ImpersonationClass ► ErrorMessage

[Missing <summary> documentation for F:VisualCronAPI.ImpersonationClass.ErrorMessage]

Declaration Syntax
C# Visual Basic Visual C++
public string ErrorMessage
Public ErrorMessage As String
public:
String^ ErrorMessage

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Impersonate Method (strUserName, strPassWord, strDomain, SuppressFlow, DoLogonUser, NetworkLogon)

Impersonate Method (strUserName, strPassWord, strDomain, SuppressFlow, DoLogonUser, NetworkLogon)
Namespaces ► VisualCronAPI ► ImpersonationClass ► Impersonate(String, String, String, Boolean, Boolean, Boolean)

[Missing <summary> documentation for M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Impersonate(
    string strUserName,
    string strPassWord,
    string strDomain,
    bool SuppressFlow,
    bool DoLogonUser,
    bool NetworkLogon
)
Public Function Impersonate ( _
    strUserName As String, _
    strPassWord As String, _
    strDomain As String, _
    SuppressFlow As Boolean, _
    DoLogonUser As Boolean, _
    NetworkLogon As Boolean _
) As Boolean
public:
bool Impersonate(
    String^ strUserName,
    String^ strPassWord,
    String^ strDomain,
    bool SuppressFlow,
    bool DoLogonUser,
    bool NetworkLogon
)
Parameters
strUserName (String)

[Missing <param name="strUserName"/> documentation for "M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)"]

strPassWord (String)

[Missing <param name="strPassWord"/> documentation for "M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)"]

strDomain (String)

[Missing <param name="strDomain"/> documentation for "M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)"]

SuppressFlow (Boolean)

[Missing <param name="SuppressFlow"/> documentation for "M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)"]

DoLogonUser (Boolean)

[Missing <param name="DoLogonUser"/> documentation for "M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)"]

NetworkLogon (Boolean)

[Missing <param name="NetworkLogon"/> documentation for "M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.ImpersonationClass.Impersonate(System.String,System.String,System.String,System.Boolean,System.Boolean,System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsLoggedOn Field

IsLoggedOn Field
Namespaces ► VisualCronAPI ► ImpersonationClass ► IsLoggedOn

[Missing <summary> documentation for F:VisualCronAPI.ImpersonationClass.IsLoggedOn]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsLoggedOn
Public IsLoggedOn As Boolean
public:
bool IsLoggedOn

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LoadUserProfile Method (hToken, lpProfileInfo)

LoadUserProfile Method (hToken, lpProfileInfo)
Namespaces ► VisualCronAPI ► ImpersonationClass ► LoadUserProfile(IntPtr, ImpersonationClass..::.PROFILEINFO%)

[Missing <summary> documentation for M:VisualCronAPI.ImpersonationClass.LoadUserProfile(System.IntPtr,VisualCronAPI.ImpersonationClass.PROFILEINFO@)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool LoadUserProfile(
    IntPtr hToken,
    ref ImpersonationClass..::.PROFILEINFO lpProfileInfo
)
Public Shared Function LoadUserProfile ( _
    hToken As IntPtr, _
    ByRef lpProfileInfo As ImpersonationClass..::.PROFILEINFO _
) As Boolean
public:
static bool LoadUserProfile(
    IntPtr hToken,
    ImpersonationClass..::.PROFILEINFO% lpProfileInfo
)
Parameters
hToken (IntPtr)

[Missing <param name="hToken"/> documentation for "M:VisualCronAPI.ImpersonationClass.LoadUserProfile(System.IntPtr,VisualCronAPI.ImpersonationClass.PROFILEINFO@)"]

lpProfileInfo ( ImpersonationClass..::.PROFILEINFO %)

[Missing <param name="lpProfileInfo"/> documentation for "M:VisualCronAPI.ImpersonationClass.LoadUserProfile(System.IntPtr,VisualCronAPI.ImpersonationClass.PROFILEINFO@)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.ImpersonationClass.LoadUserProfile(System.IntPtr,VisualCronAPI.ImpersonationClass.PROFILEINFO@)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UndoImpersonation Method

UndoImpersonation Method
Namespaces ► VisualCronAPI ► ImpersonationClass ► UndoImpersonation()()()

[Missing <summary> documentation for M:VisualCronAPI.ImpersonationClass.UndoImpersonation]

Declaration Syntax
C# Visual Basic Visual C++
public void UndoImpersonation()
Public Sub UndoImpersonation
public:
void UndoImpersonation()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UnloadUserProfile Method (hToken, hProfile)

UnloadUserProfile Method (hToken, hProfile)
Namespaces ► VisualCronAPI ► ImpersonationClass ► UnloadUserProfile(IntPtr, IntPtr)

[Missing <summary> documentation for M:VisualCronAPI.ImpersonationClass.UnloadUserProfile(System.IntPtr,System.IntPtr)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool UnloadUserProfile(
    IntPtr hToken,
    IntPtr hProfile
)
Public Shared Function UnloadUserProfile ( _
    hToken As IntPtr, _
    hProfile As IntPtr _
) As Boolean
public:
static bool UnloadUserProfile(
    IntPtr hToken,
    IntPtr hProfile
)
Parameters
hToken (IntPtr)

[Missing <param name="hToken"/> documentation for "M:VisualCronAPI.ImpersonationClass.UnloadUserProfile(System.IntPtr,System.IntPtr)"]

hProfile (IntPtr)

[Missing <param name="hProfile"/> documentation for "M:VisualCronAPI.ImpersonationClass.UnloadUserProfile(System.IntPtr,System.IntPtr)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.ImpersonationClass.UnloadUserProfile(System.IntPtr,System.IntPtr)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ImpersonationClass.PROFILEINFO Structure

ImpersonationClass..::.PROFILEINFO Structure
Namespaces ► VisualCronAPI ► ImpersonationClass ► ImpersonationClass..::.PROFILEINFO

[Missing <summary> documentation for T:VisualCronAPI.ImpersonationClass.PROFILEINFO]

Declaration Syntax
C# Visual Basic Visual C++
public struct PROFILEINFO
Public Structure PROFILEINFO
public value class PROFILEINFO
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from ValueType.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InstallHelper Class

InstallHelper Class
Namespaces ► VisualCronAPI ► InstallHelper

[Missing <summary> documentation for T:VisualCronAPI.InstallHelper]

Declaration Syntax
C# Visual Basic Visual C++
public class InstallHelper
Public Class InstallHelper
public ref class InstallHelper
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstallHelper(Client) | Initializes a new instance of the InstallHelper class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetServiceStartMode()()() | Returns startup mode. If true is return it is automatic
 | GetTrayClientValue(Int32) | Gets the auto run value from registry
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVCServicePath(Int32) | Retrieves the full path to the VisualCron service
 | InstallTrayClient(Int32) | Installs the tray client for auto run
 | IsServiceInstalled()()() | Returns true if the VisualCron Server service is installed
 | IsServiceRunning()()() | Returns true if the VisualCron Server service is running
 | IsTrayClientInstalled(Int32) | Checks if the TrayClient of a specific version is installed for auto startup
 | IsTrayClientRunning()()() | Checks if the VCTray process is running
 | IsVC3ServiceInstalled()()() | Checks if VisualCron 3 service is installed or not
 | IsVC4ServiceInstalled()()() | Checks if VisualCron 4 service is installed or not
 | KillTrayClient()()() | Kills all instances of VCTray
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ServiceName |
 | SetServiceStartMode(Boolean) | Changes the service startup mode. Returns true on success
 | StartService()()() | Starts the VisualCron service
 | StartTrayClient(Int32) |
 | StopService()()() | Stops the VisualCron service
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UninstallTrayClient(Int32) | Uninstalls the TrayClient from auto run
Inheritance Hierarchy
Object
InstallHelper

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InstallHelper Constructor (c)

InstallHelper Constructor (c)
Namespaces ► VisualCronAPI ► InstallHelper ► InstallHelper(Client)
Initializes a new instance of the InstallHelper class
Declaration Syntax
C# Visual Basic Visual C++
public InstallHelper(
    Client c
)
Public Sub New ( _
    c As Client _
)
public:
InstallHelper(
    Client^ c
)
Parameters
c (Client)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.InstallHelper.#ctor(VisualCronAPI.Client)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetServiceStartMode Method

GetServiceStartMode Method
Namespaces ► VisualCronAPI ► InstallHelper ► GetServiceStartMode()()()
Returns startup mode. If true is return it is automatic
Declaration Syntax
C# Visual Basic Visual C++
public bool GetServiceStartMode()
Public Function GetServiceStartMode As Boolean
public:
bool GetServiceStartMode()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.GetServiceStartMode]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTrayClientValue Method (MajorVersion)

GetTrayClientValue Method (MajorVersion)
Namespaces ► VisualCronAPI ► InstallHelper ► GetTrayClientValue(Int32)
Gets the auto run value from registry
Declaration Syntax
C# Visual Basic Visual C++
public static string GetTrayClientValue(
    int MajorVersion
)
Public Shared Function GetTrayClientValue ( _
    MajorVersion As Integer _
) As String
public:
static String^ GetTrayClientValue(
    int MajorVersion
)
Parameters
MajorVersion (Int32)

[Missing <param name="MajorVersion"/> documentation for "M:VisualCronAPI.InstallHelper.GetTrayClientValue(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.GetTrayClientValue(System.Int32)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetVCServicePath Method (MajorVersion)

GetVCServicePath Method (MajorVersion)
Namespaces ► VisualCronAPI ► InstallHelper ► GetVCServicePath(Int32)
Retrieves the full path to the VisualCron service
Declaration Syntax
C# Visual Basic Visual C++
public static string GetVCServicePath(
    int MajorVersion
)
Public Shared Function GetVCServicePath ( _
    MajorVersion As Integer _
) As String
public:
static String^ GetVCServicePath(
    int MajorVersion
)
Parameters
MajorVersion (Int32)

[Missing <param name="MajorVersion"/> documentation for "M:VisualCronAPI.InstallHelper.GetVCServicePath(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.GetVCServicePath(System.Int32)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InstallTrayClient Method (MajorVersion)

InstallTrayClient Method (MajorVersion)
Namespaces ► VisualCronAPI ► InstallHelper ► InstallTrayClient(Int32)
Installs the tray client for auto run
Declaration Syntax
C# Visual Basic Visual C++
public static void InstallTrayClient(
    int MajorVersion
)
Public Shared Sub InstallTrayClient ( _
    MajorVersion As Integer _
)
public:
static void InstallTrayClient(
    int MajorVersion
)
Parameters
MajorVersion (Int32)

[Missing <param name="MajorVersion"/> documentation for "M:VisualCronAPI.InstallHelper.InstallTrayClient(System.Int32)"]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsServiceInstalled Method

IsServiceInstalled Method
Namespaces ► VisualCronAPI ► InstallHelper ► IsServiceInstalled()()()
Returns true if the VisualCron Server service is installed
Declaration Syntax
C# Visual Basic Visual C++
public bool IsServiceInstalled()
Public Function IsServiceInstalled As Boolean
public:
bool IsServiceInstalled()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.IsServiceInstalled]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsServiceRunning Method

IsServiceRunning Method
Namespaces ► VisualCronAPI ► InstallHelper ► IsServiceRunning()()()
Returns true if the VisualCron Server service is running
Declaration Syntax
C# Visual Basic Visual C++
public bool IsServiceRunning()
Public Function IsServiceRunning As Boolean
public:
bool IsServiceRunning()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.IsServiceRunning]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTrayClientInstalled Method (MajorVersion)

IsTrayClientInstalled Method (MajorVersion)
Namespaces ► VisualCronAPI ► InstallHelper ► IsTrayClientInstalled(Int32)
Checks if the TrayClient of a specific version is installed for auto startup
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsTrayClientInstalled(
    int MajorVersion
)
Public Shared Function IsTrayClientInstalled ( _
    MajorVersion As Integer _
) As Boolean
public:
static bool IsTrayClientInstalled(
    int MajorVersion
)
Parameters
MajorVersion (Int32)

[Missing <param name="MajorVersion"/> documentation for "M:VisualCronAPI.InstallHelper.IsTrayClientInstalled(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.IsTrayClientInstalled(System.Int32)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTrayClientRunning Method

IsTrayClientRunning Method
Namespaces ► VisualCronAPI ► InstallHelper ► IsTrayClientRunning()()()
Checks if the VCTray process is running
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsTrayClientRunning()
Public Shared Function IsTrayClientRunning As Boolean
public:
static bool IsTrayClientRunning()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.IsTrayClientRunning]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsVC3ServiceInstalled Method

IsVC3ServiceInstalled Method
Namespaces ► VisualCronAPI ► InstallHelper ► IsVC3ServiceInstalled()()()
Checks if VisualCron 3 service is installed or not
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVC3ServiceInstalled()
Public Shared Function IsVC3ServiceInstalled As Boolean
public:
static bool IsVC3ServiceInstalled()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.IsVC3ServiceInstalled]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsVC4ServiceInstalled Method

IsVC4ServiceInstalled Method
Namespaces ► VisualCronAPI ► InstallHelper ► IsVC4ServiceInstalled()()()
Checks if VisualCron 4 service is installed or not
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsVC4ServiceInstalled()
Public Shared Function IsVC4ServiceInstalled As Boolean
public:
static bool IsVC4ServiceInstalled()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.IsVC4ServiceInstalled]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTrayClient Method

KillTrayClient Method
Namespaces ► VisualCronAPI ► InstallHelper ► KillTrayClient()()()
Kills all instances of VCTray
Declaration Syntax
C# Visual Basic Visual C++
public static bool KillTrayClient()
Public Shared Function KillTrayClient As Boolean
public:
static bool KillTrayClient()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.KillTrayClient]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServiceName Property

ServiceName Property
Namespaces ► VisualCronAPI ► InstallHelper ► ServiceName

[Missing <summary> documentation for P:VisualCronAPI.InstallHelper.ServiceName]

Declaration Syntax
C# Visual Basic Visual C++
public string ServiceName { get; }
Public ReadOnly Property ServiceName As String
public:
property String^ ServiceName {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SetServiceStartMode Method (bolAutomatic)

SetServiceStartMode Method (bolAutomatic)
Namespaces ► VisualCronAPI ► InstallHelper ► SetServiceStartMode(Boolean)
Changes the service startup mode. Returns true on success
Declaration Syntax
C# Visual Basic Visual C++
public bool SetServiceStartMode(
    bool bolAutomatic
)
Public Function SetServiceStartMode ( _
    bolAutomatic As Boolean _
) As Boolean
public:
bool SetServiceStartMode(
    bool bolAutomatic
)
Parameters
bolAutomatic (Boolean)

[Missing <param name="bolAutomatic"/> documentation for "M:VisualCronAPI.InstallHelper.SetServiceStartMode(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.SetServiceStartMode(System.Boolean)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


StartService Method

StartService Method
Namespaces ► VisualCronAPI ► InstallHelper ► StartService()()()
Starts the VisualCron service
Declaration Syntax
C# Visual Basic Visual C++
public bool StartService()
Public Function StartService As Boolean
public:
bool StartService()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.StartService]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


StartTrayClient Method (MajorVersion)

StartTrayClient Method (MajorVersion)
Namespaces ► VisualCronAPI ► InstallHelper ► StartTrayClient(Int32)

[Missing <summary> documentation for M:VisualCronAPI.InstallHelper.StartTrayClient(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool StartTrayClient(
    int MajorVersion
)
Public Shared Function StartTrayClient ( _
    MajorVersion As Integer _
) As Boolean
public:
static bool StartTrayClient(
    int MajorVersion
)
Parameters
MajorVersion (Int32)

[Missing <param name="MajorVersion"/> documentation for "M:VisualCronAPI.InstallHelper.StartTrayClient(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.StartTrayClient(System.Int32)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


StopService Method

StopService Method
Namespaces ► VisualCronAPI ► InstallHelper ► StopService()()()
Stops the VisualCron service
Declaration Syntax
C# Visual Basic Visual C++
public bool StopService()
Public Function StopService As Boolean
public:
bool StopService()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.InstallHelper.StopService]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UninstallTrayClient Method (MajorVersion)

UninstallTrayClient Method (MajorVersion)
Namespaces ► VisualCronAPI ► InstallHelper ► UninstallTrayClient(Int32)
Uninstalls the TrayClient from auto run
Declaration Syntax
C# Visual Basic Visual C++
public static void UninstallTrayClient(
    int MajorVersion
)
Public Shared Sub UninstallTrayClient ( _
    MajorVersion As Integer _
)
public:
static void UninstallTrayClient(
    int MajorVersion
)
Parameters
MajorVersion (Int32)

[Missing <param name="MajorVersion"/> documentation for "M:VisualCronAPI.InstallHelper.UninstallTrayClient(System.Int32)"]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IVariableReplacer Interface

IVariableReplacer Interface
Namespaces ► VisualCronAPI ► IVariableReplacer

[Missing <summary> documentation for T:VisualCronAPI.IVariableReplacer]

Declaration Syntax
C# Visual Basic Visual C++
public interface IVariableReplacer
Public Interface IVariableReplacer
public interface class IVariableReplacer
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetTask(String) |
 | UserVariable[([(String])]) |
 | VariableExist(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTask Method (strId)

GetTask Method (strId)
Namespaces ► VisualCronAPI ► IVariableReplacer ► GetTask(String)

[Missing <summary> documentation for M:VisualCronAPI.IVariableReplacer.GetTask(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass GetTask(
    string strId
)
Function GetTask ( _
    strId As String _
) As TaskClass
TaskClass^ GetTask(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.IVariableReplacer.GetTask(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.IVariableReplacer.GetTask(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserVariable Property (strId)

UserVariable Property (strId)
Namespaces ► VisualCronAPI ► IVariableReplacer ► UserVariable[([(String])])

[Missing <summary> documentation for P:VisualCronAPI.IVariableReplacer.UserVariable(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
UserVariableClass UserVariable[
    string strId
] { get; }
ReadOnly Property UserVariable ( _
    strId As String _
) As UserVariableClass
property UserVariableClass^ UserVariable[String^ strId] {
    UserVariableClass^ get (String^ strId);
}
Parameters
strId (String)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableExist Method (strId)

VariableExist Method (strId)
Namespaces ► VisualCronAPI ► IVariableReplacer ► VariableExist(String)

[Missing <summary> documentation for M:VisualCronAPI.IVariableReplacer.VariableExist(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool VariableExist(
    string strId
)
Function VariableExist ( _
    strId As String _
) As Boolean
bool VariableExist(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.IVariableReplacer.VariableExist(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.IVariableReplacer.VariableExist(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs Class

Jobs Class
Namespaces ► VisualCronAPI ► Jobs
Base class for Job Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Jobs : Jobs..::._Jobs
Public Class Jobs _
    Implements Jobs..::._Jobs
public ref class Jobs : Jobs..::._Jobs
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Jobs(Server%) | Initializes a new instance of the Jobs class
 | Activate(JobClass) | Activates a Job
 | Activate(String) | Activates a Job
 | Add(JobClass) | Adds a Job
 | AddAsync(JobClass) | Adds a Job asynchrously
 | Contains(String) | Returns true if Job id exist
 | DeActivate(JobClass) | Deactivates a Job
 | DeActivate(String) | Deactivates a Job
 | DoJobNameExist(String) | Checks if name of Job already exists
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Job based on the string key Id
 | GetAll()()() | Returns an list of Jobs
 | GetAll(Boolean) | Returns an list of Jobs
 | GetAllArray()()() | Returns an array of Jobs
 | GetAllArray(Boolean) | Returns an array of Jobs
 | GetCreatedByName(JobClass) | Returns the user name of the creator of the Job
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJobName(String) | Returns a Job name based on the string key Id
 | GetModifiedByName(JobClass) | Returns the user name of the modifier of the Job
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | JobAdded | This event is raised when a Job has been added
 | JobAddedStatic | This event is raised when a Job has been added
 | JobRemoved | This event is raised when a Job has been removed
 | JobRemovedStatic | This event is raised when a Job has been removed
 | JobUpdated | This event is raised when a Job has been updated
 | JobUpdatedStatic | This event is raised when a Job has been updated
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(JobClass) | Removes a Job
 | Remove(String) | Removes a Job
 | RemoveAll()()() | Removes all Jobs
 | RemoveByName(String) | Removes a Job
 | Run(JobClass) | Runs a Job
 | Run(String) | Run a Job
 | Tasks | Base class for Task Properties, Methods and Events
 | TestFileFilter(FileFilterResultClass) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Triggers | Base class for Trigger Properties, Methods and Events
 | Update(JobClass) | Updates a Job
 | UpdateAsync(JobClass) | Updates a Job asynchrously
Remarks
Inheritance Hierarchy
Object
Jobs

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs Constructor (s)

Jobs Constructor (s)
Namespaces ► VisualCronAPI ► Jobs ► Jobs(Server%)
Initializes a new instance of the Jobs class
Declaration Syntax
C# Visual Basic Visual C++
public Jobs(
    ref Server s
)
Public Sub New ( _
    ByRef s As Server _
)
public:
Jobs(
    Server^% s
)
Parameters
s ( Server %)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Jobs.#ctor(VisualCronAPI.Server@)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method

Activate Method
Namespaces ► VisualCronAPI ► Jobs ► Activate()()()
Members
Icon | Member | Description
 | Activate(JobClass) | Activates a Job
 | Activate(String) | Activates a Job

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (strJobId)

Activate Method (strJobId)
Namespaces ► VisualCronAPI ► Jobs ► Activate(String)
Activates a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool Activate(
    string strJobId
)
Public Function Activate ( _
    strJobId As String _
) As Boolean
public:
virtual bool Activate(
    String^ strJobId
) sealed
Parameters
strJobId (String)
a Job Id
Return Value
Returns Job active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (j)

Activate Method (j)
Namespaces ► VisualCronAPI ► Jobs ► Activate(JobClass)
Activates a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool Activate(
    JobClass j
)
Public Function Activate ( _
    j As JobClass _
) As Boolean
public:
virtual bool Activate(
    JobClass^ j
) sealed
Parameters
j (JobClass)
a Job
Return Value
Returns Job active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (j)

Add Method (j)
Namespaces ► VisualCronAPI ► Jobs ► Add(JobClass)
Adds a Job
Declaration Syntax
C# Visual Basic Visual C++
public JobClass Add(
    JobClass j
)
Public Function Add ( _
    j As JobClass _
) As JobClass
public:
virtual JobClass^ Add(
    JobClass^ j
) sealed
Parameters
j (JobClass)
A JobClass object
Return Value
JobClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AddAsync Method (j)

AddAsync Method (j)
Namespaces ► VisualCronAPI ► Jobs ► AddAsync(JobClass)
Adds a Job asynchrously
Declaration Syntax
C# Visual Basic Visual C++
public bool AddAsync(
    JobClass j
)
Public Function AddAsync ( _
    j As JobClass _
) As Boolean
public:
virtual bool AddAsync(
    JobClass^ j
) sealed
Parameters
j (JobClass)
A JobClass object
Return Value
JobClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strJobId)

Contains Method (strJobId)
Namespaces ► VisualCronAPI ► Jobs ► Contains(String)
Returns true if Job id exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strJobId
)
Public Function Contains ( _
    strJobId As String _
) As Boolean
public:
virtual bool Contains(
    String^ strJobId
) sealed
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.Jobs.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method

DeActivate Method
Namespaces ► VisualCronAPI ► Jobs ► DeActivate()()()
Members
Icon | Member | Description
 | DeActivate(JobClass) | Deactivates a Job
 | DeActivate(String) | Deactivates a Job

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (strJobId)

DeActivate Method (strJobId)
Namespaces ► VisualCronAPI ► Jobs ► DeActivate(String)
Deactivates a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool DeActivate(
    string strJobId
)
Public Function DeActivate ( _
    strJobId As String _
) As Boolean
public:
virtual bool DeActivate(
    String^ strJobId
) sealed
Parameters
strJobId (String)
a Job Id
Return Value
Returns Job active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (j)

DeActivate Method (j)
Namespaces ► VisualCronAPI ► Jobs ► DeActivate(JobClass)
Deactivates a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool DeActivate(
    JobClass j
)
Public Function DeActivate ( _
    j As JobClass _
) As Boolean
public:
virtual bool DeActivate(
    JobClass^ j
) sealed
Parameters
j (JobClass)
a Job
Return Value
Returns a Job active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoJobNameExist Method (strName)

DoJobNameExist Method (strName)
Namespaces ► VisualCronAPI ► Jobs ► DoJobNameExist(String)
Checks if name of Job already exists
Declaration Syntax
C# Visual Basic Visual C++
public bool DoJobNameExist(
    string strName
)
Public Function DoJobNameExist ( _
    strName As String _
) As Boolean
public:
virtual bool DoJobNameExist(
    String^ strName
) sealed
Parameters
strName (String)

[Missing <param name="strName"/> documentation for "M:VisualCronAPI.Jobs.DoJobNameExist(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.DoJobNameExist(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Jobs ► Get(String)
Returns a Job based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public JobClass Get(
    string id
)
Public Function Get ( _
    id As String _
) As JobClass
public:
virtual JobClass^ Get(
    String^ id
) sealed
Parameters
id (String)
string key
Return Value
a Job
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Jobs ► GetAll()()()
Members
Icon | Member | Description
 | GetAll()()() | Returns an list of Jobs
 | GetAll(Boolean) | Returns an list of Jobs

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Jobs ► GetAll()()()
Returns an list of Jobs
Declaration Syntax
C# Visual Basic Visual C++
public List<JobClass> GetAll()
Public Function GetAll As List(Of JobClass)
public:
List<JobClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method (bolSort)

GetAll Method (bolSort)
Namespaces ► VisualCronAPI ► Jobs ► GetAll(Boolean)
Returns an list of Jobs
Declaration Syntax
C# Visual Basic Visual C++
public List<JobClass> GetAll(
    bool bolSort
)
Public Function GetAll ( _
    bolSort As Boolean _
) As List(Of JobClass)
public:
List<JobClass^>^ GetAll(
    bool bolSort
)
Parameters
bolSort (Boolean)

[Missing <param name="bolSort"/> documentation for "M:VisualCronAPI.Jobs.GetAll(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.GetAll(System.Boolean)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Jobs ► GetAllArray()()()
Members
Icon | Member | Description
 | GetAllArray()()() | Returns an array of Jobs
 | GetAllArray(Boolean) | Returns an array of Jobs

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Jobs ► GetAllArray()()()
Returns an array of Jobs
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (bolSort)

GetAllArray Method (bolSort)
Namespaces ► VisualCronAPI ► Jobs ► GetAllArray(Boolean)
Returns an array of Jobs
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray(
    bool bolSort
)
Public Function GetAllArray ( _
    bolSort As Boolean _
) As ArrayList
public:
virtual ArrayList^ GetAllArray(
    bool bolSort
) sealed
Parameters
bolSort (Boolean)

[Missing <param name="bolSort"/> documentation for "M:VisualCronAPI.Jobs.GetAllArray(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.GetAllArray(System.Boolean)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCreatedByName Method (j)

GetCreatedByName Method (j)
Namespaces ► VisualCronAPI ► Jobs ► GetCreatedByName(JobClass)
Returns the user name of the creator of the Job
Declaration Syntax
C# Visual Basic Visual C++
public string GetCreatedByName(
    JobClass j
)
Public Function GetCreatedByName ( _
    j As JobClass _
) As String
public:
virtual String^ GetCreatedByName(
    JobClass^ j
) sealed
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs.GetCreatedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.GetCreatedByName(VisualCron.JobClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobName Method (id)

GetJobName Method (id)
Namespaces ► VisualCronAPI ► Jobs ► GetJobName(String)
Returns a Job name based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public string GetJobName(
    string id
)
Public Function GetJobName ( _
    id As String _
) As String
public:
virtual String^ GetJobName(
    String^ id
) sealed
Parameters
id (String)
string key
Return Value
a Job
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetModifiedByName Method (j)

GetModifiedByName Method (j)
Namespaces ► VisualCronAPI ► Jobs ► GetModifiedByName(JobClass)
Returns the user name of the modifier of the Job
Declaration Syntax
C# Visual Basic Visual C++
public string GetModifiedByName(
    JobClass j
)
Public Function GetModifiedByName ( _
    j As JobClass _
) As String
public:
virtual String^ GetModifiedByName(
    JobClass^ j
) sealed
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs.GetModifiedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.GetModifiedByName(VisualCron.JobClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobAdded Event

JobAdded Event
Namespaces ► VisualCronAPI ► Jobs ► JobAdded
This event is raised when a Job has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Jobs..::.DelegateJobAdded JobAdded
Public Event JobAdded As Jobs..::.DelegateJobAdded
public:
 event Jobs..::.DelegateJobAdded^ JobAdded {
    void add (Jobs..::.DelegateJobAdded^ value);
    void remove (Jobs..::.DelegateJobAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobAddedStatic Event

JobAddedStatic Event
Namespaces ► VisualCronAPI ► Jobs ► JobAddedStatic
This event is raised when a Job has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Jobs..::.DelegateJobAdded JobAddedStatic
Public Shared Event JobAddedStatic As Jobs..::.DelegateJobAdded
public:
static  event Jobs..::.DelegateJobAdded^ JobAddedStatic {
    void add (Jobs..::.DelegateJobAdded^ value);
    void remove (Jobs..::.DelegateJobAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobRemoved Event

JobRemoved Event
Namespaces ► VisualCronAPI ► Jobs ► JobRemoved
This event is raised when a Job has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Jobs..::.DelegateOnJobRemoved JobRemoved
Public Event JobRemoved As Jobs..::.DelegateOnJobRemoved
public:
 event Jobs..::.DelegateOnJobRemoved^ JobRemoved {
    void add (Jobs..::.DelegateOnJobRemoved^ value);
    void remove (Jobs..::.DelegateOnJobRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobRemovedStatic Event

JobRemovedStatic Event
Namespaces ► VisualCronAPI ► Jobs ► JobRemovedStatic
This event is raised when a Job has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Jobs..::.DelegateOnJobRemoved JobRemovedStatic
Public Shared Event JobRemovedStatic As Jobs..::.DelegateOnJobRemoved
public:
static  event Jobs..::.DelegateOnJobRemoved^ JobRemovedStatic {
    void add (Jobs..::.DelegateOnJobRemoved^ value);
    void remove (Jobs..::.DelegateOnJobRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobUpdated Event

JobUpdated Event
Namespaces ► VisualCronAPI ► Jobs ► JobUpdated
This event is raised when a Job has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Jobs..::.DelegateJobUpdated JobUpdated
Public Event JobUpdated As Jobs..::.DelegateJobUpdated
public:
 event Jobs..::.DelegateJobUpdated^ JobUpdated {
    void add (Jobs..::.DelegateJobUpdated^ value);
    void remove (Jobs..::.DelegateJobUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobUpdatedStatic Event

JobUpdatedStatic Event
Namespaces ► VisualCronAPI ► Jobs ► JobUpdatedStatic
This event is raised when a Job has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Jobs..::.DelegateJobUpdated JobUpdatedStatic
Public Shared Event JobUpdatedStatic As Jobs..::.DelegateJobUpdated
public:
static  event Jobs..::.DelegateJobUpdated^ JobUpdatedStatic {
    void add (Jobs..::.DelegateJobUpdated^ value);
    void remove (Jobs..::.DelegateJobUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Jobs ► Remove()()()
Members
Icon | Member | Description
 | Remove(JobClass) | Removes a Job
 | Remove(String) | Removes a Job

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (jobId)

Remove Method (jobId)
Namespaces ► VisualCronAPI ► Jobs ► Remove(String)
Removes a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string jobId
)
Public Function Remove ( _
    jobId As String _
) As Boolean
public:
virtual bool Remove(
    String^ jobId
) sealed
Parameters
jobId (String)
Id of Job
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (j)

Remove Method (j)
Namespaces ► VisualCronAPI ► Jobs ► Remove(JobClass)
Removes a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    JobClass j
)
Public Function Remove ( _
    j As JobClass _
) As Boolean
public:
virtual bool Remove(
    JobClass^ j
) sealed
Parameters
j (JobClass)
a Job
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.Remove(VisualCron.JobClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Jobs ► RemoveAll()()()
Removes all Jobs
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveAll()
Public Function RemoveAll As Boolean
public:
virtual bool RemoveAll() sealed
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveByName Method (strName)

RemoveByName Method (strName)
Namespaces ► VisualCronAPI ► Jobs ► RemoveByName(String)
Removes a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveByName(
    string strName
)
Public Function RemoveByName ( _
    strName As String _
) As Boolean
public:
virtual bool RemoveByName(
    String^ strName
) sealed
Parameters
strName (String)
Name of the Job
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method

Run Method
Namespaces ► VisualCronAPI ► Jobs ► Run()()()
Members
Icon | Member | Description
 | Run(JobClass) | Runs a Job
 | Run(String) | Run a Job

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (jobId)

Run Method (jobId)
Namespaces ► VisualCronAPI ► Jobs ► Run(String)
Run a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool Run(
    string jobId
)
Public Function Run ( _
    jobId As String _
) As Boolean
public:
virtual bool Run(
    String^ jobId
) sealed
Parameters
jobId (String)
Id of a Job
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.Run(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (j)

Run Method (j)
Namespaces ► VisualCronAPI ► Jobs ► Run(JobClass)
Runs a Job
Declaration Syntax
C# Visual Basic Visual C++
public bool Run(
    JobClass j
)
Public Function Run ( _
    j As JobClass _
) As Boolean
public:
virtual bool Run(
    JobClass^ j
) sealed
Parameters
j (JobClass)
a Job
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.Run(VisualCron.JobClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks Property

Tasks Property
Namespaces ► VisualCronAPI ► Jobs ► Tasks
Base class for Task Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public Tasks Tasks { get; }
Public ReadOnly Property Tasks As Tasks
public:
virtual property Tasks^ Tasks {
    Tasks^ get () sealed;
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TestFileFilter Method (ffrc)

TestFileFilter Method (ffrc)
Namespaces ► VisualCronAPI ► Jobs ► TestFileFilter(FileFilterResultClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs.TestFileFilter(VisualCron.FileFilterResultClass)]

Declaration Syntax
C# Visual Basic Visual C++
public List<string> TestFileFilter(
    FileFilterResultClass ffrc
)
Public Function TestFileFilter ( _
    ffrc As FileFilterResultClass _
) As List(Of String)
public:
virtual List<String^>^ TestFileFilter(
    FileFilterResultClass^ ffrc
) sealed
Parameters
ffrc (FileFilterResultClass)

[Missing <param name="ffrc"/> documentation for "M:VisualCronAPI.Jobs.TestFileFilter(VisualCron.FileFilterResultClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs.TestFileFilter(VisualCron.FileFilterResultClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers Property

Triggers Property
Namespaces ► VisualCronAPI ► Jobs ► Triggers
Base class for Trigger Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public Triggers Triggers { get; }
Public ReadOnly Property Triggers As Triggers
public:
virtual property Triggers^ Triggers {
    Triggers^ get () sealed;
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (j)

Update Method (j)
Namespaces ► VisualCronAPI ► Jobs ► Update(JobClass)
Updates a Job
Declaration Syntax
C# Visual Basic Visual C++
public JobClass Update(
    JobClass j
)
Public Function Update ( _
    j As JobClass _
) As JobClass
public:
virtual JobClass^ Update(
    JobClass^ j
) sealed
Parameters
j (JobClass)
A JobClass object
Return Value
JobClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UpdateAsync Method (j)

UpdateAsync Method (j)
Namespaces ► VisualCronAPI ► Jobs ► UpdateAsync(JobClass)
Updates a Job asynchrously
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateAsync(
    JobClass j
)
Public Function UpdateAsync ( _
    j As JobClass _
) As Boolean
public:
virtual bool UpdateAsync(
    JobClass^ j
) sealed
Parameters
j (JobClass)
A JobClass object
Return Value
JobClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs.__Jobs Interface

Jobs..::.__Jobs Interface
Namespaces ► VisualCronAPI ► Jobs ► Jobs..::.__Jobs

[Missing <summary> documentation for T:VisualCronAPI.Jobs.__Jobs]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Jobs
Public Interface __Jobs
public interface class __Jobs
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | JobAdded(Server%, JobClass) |
 | JobRemoved(Server%, JobClass) |
 | JobUpdated(Server%, JobClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobAdded Method (server, j)

JobAdded Method (server, j)
Namespaces ► VisualCronAPI ► Jobs..::.__Jobs ► JobAdded(Server%, JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs.__Jobs.JobAdded(VisualCronAPI.Server@,VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
void JobAdded(
    ref Server server,
    JobClass j
)
Sub JobAdded ( _
    ByRef server As Server, _
    j As JobClass _
)
void JobAdded(
    Server^% server,
    JobClass^ j
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Jobs.__Jobs.JobAdded(VisualCronAPI.Server@,VisualCron.JobClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs.__Jobs.JobAdded(VisualCronAPI.Server@,VisualCron.JobClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobRemoved Method (server, j)

JobRemoved Method (server, j)
Namespaces ► VisualCronAPI ► Jobs..::.__Jobs ► JobRemoved(Server%, JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs.__Jobs.JobRemoved(VisualCronAPI.Server@,VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
void JobRemoved(
    ref Server server,
    JobClass j
)
Sub JobRemoved ( _
    ByRef server As Server, _
    j As JobClass _
)
void JobRemoved(
    Server^% server,
    JobClass^ j
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Jobs.__Jobs.JobRemoved(VisualCronAPI.Server@,VisualCron.JobClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs.__Jobs.JobRemoved(VisualCronAPI.Server@,VisualCron.JobClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobUpdated Method (server, j)

JobUpdated Method (server, j)
Namespaces ► VisualCronAPI ► Jobs..::.__Jobs ► JobUpdated(Server%, JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs.__Jobs.JobUpdated(VisualCronAPI.Server@,VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
void JobUpdated(
    ref Server server,
    JobClass j
)
Sub JobUpdated ( _
    ByRef server As Server, _
    j As JobClass _
)
void JobUpdated(
    Server^% server,
    JobClass^ j
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Jobs.__Jobs.JobUpdated(VisualCronAPI.Server@,VisualCron.JobClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs.__Jobs.JobUpdated(VisualCronAPI.Server@,VisualCron.JobClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs._Jobs Interface

Jobs..::._Jobs Interface
Namespaces ► VisualCronAPI ► Jobs ► Jobs..::._Jobs

[Missing <summary> documentation for T:VisualCronAPI.Jobs._Jobs]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Jobs
Public Interface _Jobs
public interface class _Jobs
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Activate(JobClass) |
 | Activate(String) |
 | Add(JobClass) |
 | AddAsync(JobClass) |
 | Contains(String) |
 | DeActivate(JobClass) |
 | DeActivate(String) |
 | DoJobNameExist(String) |
 | Get(String) |
 | GetAllArray()()() |
 | GetAllArray(Boolean) |
 | GetCreatedByName(JobClass) |
 | GetJobName(String) |
 | GetModifiedByName(JobClass) |
 | Remove(JobClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | RemoveByName(String) |
 | Run(JobClass) |
 | Run(String) |
 | Tasks |
 | TestFileFilter(FileFilterResultClass) |
 | Triggers |
 | Update(JobClass) |
 | UpdateAsync(JobClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method

Activate Method
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Activate()()()
Members
Icon | Member | Description
 | Activate(JobClass) |
 | Activate(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (strJobId)

Activate Method (strJobId)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Activate(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Activate(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Activate(
    string strJobId
)
Function Activate ( _
    strJobId As String _
) As Boolean
bool Activate(
    String^ strJobId
)
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Activate(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Activate(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (j)

Activate Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Activate(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Activate(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Activate(
    JobClass j
)
Function Activate ( _
    j As JobClass _
) As Boolean
bool Activate(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Activate(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Activate(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (j)

Add Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Add(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Add(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
JobClass Add(
    JobClass j
)
Function Add ( _
    j As JobClass _
) As JobClass
JobClass^ Add(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Add(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Add(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AddAsync Method (j)

AddAsync Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► AddAsync(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.AddAsync(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool AddAsync(
    JobClass j
)
Function AddAsync ( _
    j As JobClass _
) As Boolean
bool AddAsync(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.AddAsync(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.AddAsync(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strJobId)

Contains Method (strJobId)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string strJobId
)
Function Contains ( _
    strJobId As String _
) As Boolean
bool Contains(
    String^ strJobId
)
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method

DeActivate Method
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► DeActivate()()()
Members
Icon | Member | Description
 | DeActivate(JobClass) |
 | DeActivate(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (strJobId)

DeActivate Method (strJobId)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► DeActivate(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.DeActivate(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool DeActivate(
    string strJobId
)
Function DeActivate ( _
    strJobId As String _
) As Boolean
bool DeActivate(
    String^ strJobId
)
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.Jobs._Jobs.DeActivate(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.DeActivate(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (j)

DeActivate Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► DeActivate(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.DeActivate(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool DeActivate(
    JobClass j
)
Function DeActivate ( _
    j As JobClass _
) As Boolean
bool DeActivate(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.DeActivate(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.DeActivate(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoJobNameExist Method (strName)

DoJobNameExist Method (strName)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► DoJobNameExist(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.DoJobNameExist(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool DoJobNameExist(
    string strName
)
Function DoJobNameExist ( _
    strName As String _
) As Boolean
bool DoJobNameExist(
    String^ strName
)
Parameters
strName (String)

[Missing <param name="strName"/> documentation for "M:VisualCronAPI.Jobs._Jobs.DoJobNameExist(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.DoJobNameExist(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
JobClass Get(
    string id
)
Function Get ( _
    id As String _
) As JobClass
JobClass^ Get(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► GetAllArray()()()
Members
Icon | Member | Description
 | GetAllArray()()() |
 | GetAllArray(Boolean) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (bolSort)

GetAllArray Method (bolSort)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► GetAllArray(Boolean)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.GetAllArray(System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray(
    bool bolSort
)
Function GetAllArray ( _
    bolSort As Boolean _
) As ArrayList
ArrayList^ GetAllArray(
    bool bolSort
)
Parameters
bolSort (Boolean)

[Missing <param name="bolSort"/> documentation for "M:VisualCronAPI.Jobs._Jobs.GetAllArray(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.GetAllArray(System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCreatedByName Method (j)

GetCreatedByName Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► GetCreatedByName(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.GetCreatedByName(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
string GetCreatedByName(
    JobClass j
)
Function GetCreatedByName ( _
    j As JobClass _
) As String
String^ GetCreatedByName(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.GetCreatedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.GetCreatedByName(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobName Method (id)

GetJobName Method (id)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► GetJobName(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.GetJobName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetJobName(
    string id
)
Function GetJobName ( _
    id As String _
) As String
String^ GetJobName(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Jobs._Jobs.GetJobName(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.GetJobName(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetModifiedByName Method (j)

GetModifiedByName Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► GetModifiedByName(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.GetModifiedByName(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
string GetModifiedByName(
    JobClass j
)
Function GetModifiedByName ( _
    j As JobClass _
) As String
String^ GetModifiedByName(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.GetModifiedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.GetModifiedByName(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Remove()()()
Members
Icon | Member | Description
 | Remove(JobClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (jobId)

Remove Method (jobId)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string jobId
)
Function Remove ( _
    jobId As String _
) As Boolean
bool Remove(
    String^ jobId
)
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (j)

Remove Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Remove(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Remove(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    JobClass j
)
Function Remove ( _
    j As JobClass _
) As Boolean
bool Remove(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Remove(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Remove(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
bool RemoveAll()
Function RemoveAll As Boolean
bool RemoveAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.RemoveAll]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveByName Method (strName)

RemoveByName Method (strName)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► RemoveByName(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.RemoveByName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool RemoveByName(
    string strName
)
Function RemoveByName ( _
    strName As String _
) As Boolean
bool RemoveByName(
    String^ strName
)
Parameters
strName (String)

[Missing <param name="strName"/> documentation for "M:VisualCronAPI.Jobs._Jobs.RemoveByName(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.RemoveByName(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method

Run Method
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Run()()()
Members
Icon | Member | Description
 | Run(JobClass) |
 | Run(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (jobId)

Run Method (jobId)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Run(String)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Run(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Run(
    string jobId
)
Function Run ( _
    jobId As String _
) As Boolean
bool Run(
    String^ jobId
)
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Run(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Run(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (j)

Run Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Run(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Run(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Run(
    JobClass j
)
Function Run ( _
    j As JobClass _
) As Boolean
bool Run(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Run(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Run(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks Property

Tasks Property
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Tasks

[Missing <summary> documentation for P:VisualCronAPI.Jobs._Jobs.Tasks]

Declaration Syntax
C# Visual Basic Visual C++
Tasks Tasks { get; }
ReadOnly Property Tasks As Tasks
property Tasks^ Tasks {
    Tasks^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TestFileFilter Method (ffrc)

TestFileFilter Method (ffrc)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► TestFileFilter(FileFilterResultClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.TestFileFilter(VisualCron.FileFilterResultClass)]

Declaration Syntax
C# Visual Basic Visual C++
List<string> TestFileFilter(
    FileFilterResultClass ffrc
)
Function TestFileFilter ( _
    ffrc As FileFilterResultClass _
) As List(Of String)
List<String^>^ TestFileFilter(
    FileFilterResultClass^ ffrc
)
Parameters
ffrc (FileFilterResultClass)

[Missing <param name="ffrc"/> documentation for "M:VisualCronAPI.Jobs._Jobs.TestFileFilter(VisualCron.FileFilterResultClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.TestFileFilter(VisualCron.FileFilterResultClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers Property

Triggers Property
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Triggers

[Missing <summary> documentation for P:VisualCronAPI.Jobs._Jobs.Triggers]

Declaration Syntax
C# Visual Basic Visual C++
Triggers Triggers { get; }
ReadOnly Property Triggers As Triggers
property Triggers^ Triggers {
    Triggers^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (j)

Update Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► Update(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.Update(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
JobClass Update(
    JobClass j
)
Function Update ( _
    j As JobClass _
) As JobClass
JobClass^ Update(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.Update(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.Update(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UpdateAsync Method (j)

UpdateAsync Method (j)
Namespaces ► VisualCronAPI ► Jobs..::._Jobs ► UpdateAsync(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Jobs._Jobs.UpdateAsync(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool UpdateAsync(
    JobClass j
)
Function UpdateAsync ( _
    j As JobClass _
) As Boolean
bool UpdateAsync(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Jobs._Jobs.UpdateAsync(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Jobs._Jobs.UpdateAsync(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs.DelegateJobAdded Delegate

Jobs..::.DelegateJobAdded Delegate
Namespaces ► VisualCronAPI ► Jobs ► Jobs..::.DelegateJobAdded

[Missing <summary> documentation for T:VisualCronAPI.Jobs.DelegateJobAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateJobAdded(
    ref Server server,
    JobClass j
)
Public Delegate Sub DelegateJobAdded ( _
    ByRef server As Server, _
    j As JobClass _
)
public delegate void DelegateJobAdded(
    Server^% server,
    JobClass^ j
)
Parameters
server ( Server %)
j (JobClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs.DelegateJobUpdated Delegate

Jobs..::.DelegateJobUpdated Delegate
Namespaces ► VisualCronAPI ► Jobs ► Jobs..::.DelegateJobUpdated

[Missing <summary> documentation for T:VisualCronAPI.Jobs.DelegateJobUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateJobUpdated(
    ref Server server,
    JobClass j
)
Public Delegate Sub DelegateJobUpdated ( _
    ByRef server As Server, _
    j As JobClass _
)
public delegate void DelegateJobUpdated(
    Server^% server,
    JobClass^ j
)
Parameters
server ( Server %)
j (JobClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs.DelegateOnJobRemoved Delegate

Jobs..::.DelegateOnJobRemoved Delegate
Namespaces ► VisualCronAPI ► Jobs ► Jobs..::.DelegateOnJobRemoved

[Missing <summary> documentation for T:VisualCronAPI.Jobs.DelegateOnJobRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnJobRemoved(
    ref Server server,
    JobClass j
)
Public Delegate Sub DelegateOnJobRemoved ( _
    ByRef server As Server, _
    j As JobClass _
)
public delegate void DelegateOnJobRemoved(
    Server^% server,
    JobClass^ j
)
Parameters
server ( Server %)
j (JobClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs.JobNotFoundException Class

Jobs..::.JobNotFoundException Class
Namespaces ► VisualCronAPI ► Jobs ► Jobs..::.JobNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Jobs.JobNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class JobNotFoundException : Exception
Public Class JobNotFoundException _
    Inherits Exception
public ref class JobNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Jobs..::.JobNotFoundException(String) | Initializes a new instance of the Jobs..::.JobNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Jobs..::.JobNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs.JobNotFoundException Constructor (id)

Jobs..::.JobNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Jobs..::.JobNotFoundException ► Jobs..::.JobNotFoundException(String)
Initializes a new instance of the Jobs..::.JobNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public JobNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
JobNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Jobs.JobNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LangAPI Class

LangAPI Class
Namespaces ► VisualCronAPI ► LangAPI

[Missing <summary> documentation for T:VisualCronAPI.LangAPI]

Declaration Syntax
C# Visual Basic Visual C++
public class LangAPI
Public Class LangAPI
public ref class LangAPI
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LangAPI()()() | Initializes a new instance of the LangAPI class
 | ActiveProject |
 | ArchiveActionTypeToString(TaskArchiveClass..::.ArchiveActionT) |
 | ArchiveCompressionLevelToString(TaskArchiveClass..::.CompressionLevelT) |
 | ArchiveTypeToString(TaskArchiveClass..::.ArchiveT) |
 | CommandTypeToString(CommandType) |
 | ConditionCheckTypeToString(ConditionClass..::.ConditionCheckT) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorTypeToString(OnTaskErrorClass..::.ErrorT) |
 | EventMatchTypeToString(EventClass..::.EventMatchT) |
 | EventToString(EventClass..::.EventTy) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FTPCommandTypeToString(FTPCommandClass..::.FTPCommandT) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLang(Int32) |
 | GetLangId(String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetWord(String, Int32) |
 | GetYesNo(Boolean) |
 | IsBabelNothing()()() |
 | IsLeftToRight()()() |
 | JobStatusToString(JobStatsClass..::.StatusT) |
 | LoadLanguages(Int32) |
 | LoadProject()()() |
 | LogonTypeToString(TaskExecuteClass..::.LogonT) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotifyFilterToString(NotifyFilters) |
 | Reload(Server) |
 | Reload(Int32) |
 | ServiceStatusToString(ServiceControllerStatus) |
 | TaskStatusToString(TaskStatsClass..::.TaskStatusT) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WatchChangeTypeToString(WatcherChangeTypes) |
Inheritance Hierarchy
Object
LangAPI

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LangAPI Constructor

LangAPI Constructor
Namespaces ► VisualCronAPI ► LangAPI ► LangAPI()()()
Initializes a new instance of the LangAPI class
Declaration Syntax
C# Visual Basic Visual C++
public LangAPI()
Public Sub New
public:
LangAPI()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ActiveProject Field

ActiveProject Field
Namespaces ► VisualCronAPI ► LangAPI ► ActiveProject

[Missing <summary> documentation for F:VisualCronAPI.LangAPI.ActiveProject]

Declaration Syntax
C# Visual Basic Visual C++
public static Project ActiveProject
Public Shared ActiveProject As Project
public:
static Project^ ActiveProject

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ArchiveActionTypeToString Method (aat)

ArchiveActionTypeToString Method (aat)
Namespaces ► VisualCronAPI ► LangAPI ► ArchiveActionTypeToString(TaskArchiveClass..::.ArchiveActionT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.ArchiveActionTypeToString(VisualCron.TaskArchiveClass.ArchiveActionT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string ArchiveActionTypeToString(
    TaskArchiveClass..::.ArchiveActionT aat
)
Public Shared Function ArchiveActionTypeToString ( _
    aat As TaskArchiveClass..::.ArchiveActionT _
) As String
public:
static String^ ArchiveActionTypeToString(
    TaskArchiveClass..::.ArchiveActionT aat
)
Parameters
aat (TaskArchiveClass..::.ArchiveActionT)

[Missing <param name="aat"/> documentation for "M:VisualCronAPI.LangAPI.ArchiveActionTypeToString(VisualCron.TaskArchiveClass.ArchiveActionT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.ArchiveActionTypeToString(VisualCron.TaskArchiveClass.ArchiveActionT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ArchiveCompressionLevelToString Method (cl)

ArchiveCompressionLevelToString Method (cl)
Namespaces ► VisualCronAPI ► LangAPI ► ArchiveCompressionLevelToString(TaskArchiveClass..::.CompressionLevelT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.ArchiveCompressionLevelToString(VisualCron.TaskArchiveClass.CompressionLevelT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string ArchiveCompressionLevelToString(
    TaskArchiveClass..::.CompressionLevelT cl
)
Public Shared Function ArchiveCompressionLevelToString ( _
    cl As TaskArchiveClass..::.CompressionLevelT _
) As String
public:
static String^ ArchiveCompressionLevelToString(
    TaskArchiveClass..::.CompressionLevelT cl
)
Parameters
cl (TaskArchiveClass..::.CompressionLevelT)

[Missing <param name="cl"/> documentation for "M:VisualCronAPI.LangAPI.ArchiveCompressionLevelToString(VisualCron.TaskArchiveClass.CompressionLevelT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.ArchiveCompressionLevelToString(VisualCron.TaskArchiveClass.CompressionLevelT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ArchiveTypeToString Method (at)

ArchiveTypeToString Method (at)
Namespaces ► VisualCronAPI ► LangAPI ► ArchiveTypeToString(TaskArchiveClass..::.ArchiveT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.ArchiveTypeToString(VisualCron.TaskArchiveClass.ArchiveT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string ArchiveTypeToString(
    TaskArchiveClass..::.ArchiveT at
)
Public Shared Function ArchiveTypeToString ( _
    at As TaskArchiveClass..::.ArchiveT _
) As String
public:
static String^ ArchiveTypeToString(
    TaskArchiveClass..::.ArchiveT at
)
Parameters
at (TaskArchiveClass..::.ArchiveT)

[Missing <param name="at"/> documentation for "M:VisualCronAPI.LangAPI.ArchiveTypeToString(VisualCron.TaskArchiveClass.ArchiveT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.ArchiveTypeToString(VisualCron.TaskArchiveClass.ArchiveT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CommandTypeToString Method (ct)

CommandTypeToString Method (ct)
Namespaces ► VisualCronAPI ► LangAPI ► CommandTypeToString(CommandType)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.CommandTypeToString(System.Data.CommandType)]

Declaration Syntax
C# Visual Basic Visual C++
public static string CommandTypeToString(
    CommandType ct
)
Public Shared Function CommandTypeToString ( _
    ct As CommandType _
) As String
public:
static String^ CommandTypeToString(
    CommandType ct
)
Parameters
ct (CommandType)

[Missing <param name="ct"/> documentation for "M:VisualCronAPI.LangAPI.CommandTypeToString(System.Data.CommandType)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.CommandTypeToString(System.Data.CommandType)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ConditionCheckTypeToString Method (e)

ConditionCheckTypeToString Method (e)
Namespaces ► VisualCronAPI ► LangAPI ► ConditionCheckTypeToString(ConditionClass..::.ConditionCheckT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.ConditionCheckTypeToString(VisualCron.ConditionClass.ConditionCheckT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string ConditionCheckTypeToString(
    ConditionClass..::.ConditionCheckT e
)
Public Shared Function ConditionCheckTypeToString ( _
    e As ConditionClass..::.ConditionCheckT _
) As String
public:
static String^ ConditionCheckTypeToString(
    ConditionClass..::.ConditionCheckT e
)
Parameters
e (ConditionClass..::.ConditionCheckT)

[Missing <param name="e"/> documentation for "M:VisualCronAPI.LangAPI.ConditionCheckTypeToString(VisualCron.ConditionClass.ConditionCheckT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.ConditionCheckTypeToString(VisualCron.ConditionClass.ConditionCheckT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ErrorTypeToString Method (et)

ErrorTypeToString Method (et)
Namespaces ► VisualCronAPI ► LangAPI ► ErrorTypeToString(OnTaskErrorClass..::.ErrorT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.ErrorTypeToString(VisualCron.OnTaskErrorClass.ErrorT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string ErrorTypeToString(
    OnTaskErrorClass..::.ErrorT et
)
Public Shared Function ErrorTypeToString ( _
    et As OnTaskErrorClass..::.ErrorT _
) As String
public:
static String^ ErrorTypeToString(
    OnTaskErrorClass..::.ErrorT et
)
Parameters
et (OnTaskErrorClass..::.ErrorT)

[Missing <param name="et"/> documentation for "M:VisualCronAPI.LangAPI.ErrorTypeToString(VisualCron.OnTaskErrorClass.ErrorT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.ErrorTypeToString(VisualCron.OnTaskErrorClass.ErrorT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventMatchTypeToString Method (e)

EventMatchTypeToString Method (e)
Namespaces ► VisualCronAPI ► LangAPI ► EventMatchTypeToString(EventClass..::.EventMatchT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.EventMatchTypeToString(VisualCron.EventClass.EventMatchT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string EventMatchTypeToString(
    EventClass..::.EventMatchT e
)
Public Shared Function EventMatchTypeToString ( _
    e As EventClass..::.EventMatchT _
) As String
public:
static String^ EventMatchTypeToString(
    EventClass..::.EventMatchT e
)
Parameters
e (EventClass..::.EventMatchT)

[Missing <param name="e"/> documentation for "M:VisualCronAPI.LangAPI.EventMatchTypeToString(VisualCron.EventClass.EventMatchT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.EventMatchTypeToString(VisualCron.EventClass.EventMatchT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventToString Method (e)

EventToString Method (e)
Namespaces ► VisualCronAPI ► LangAPI ► EventToString(EventClass..::.EventTy)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.EventToString(VisualCron.EventClass.EventTy)]

Declaration Syntax
C# Visual Basic Visual C++
public static string EventToString(
    EventClass..::.EventTy e
)
Public Shared Function EventToString ( _
    e As EventClass..::.EventTy _
) As String
public:
static String^ EventToString(
    EventClass..::.EventTy e
)
Parameters
e (EventClass..::.EventTy)

[Missing <param name="e"/> documentation for "M:VisualCronAPI.LangAPI.EventToString(VisualCron.EventClass.EventTy)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.EventToString(VisualCron.EventClass.EventTy)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FTPCommandTypeToString Method (ct)

FTPCommandTypeToString Method (ct)
Namespaces ► VisualCronAPI ► LangAPI ► FTPCommandTypeToString(FTPCommandClass..::.FTPCommandT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.FTPCommandTypeToString(VisualCron.FTPCommandClass.FTPCommandT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string FTPCommandTypeToString(
    FTPCommandClass..::.FTPCommandT ct
)
Public Shared Function FTPCommandTypeToString ( _
    ct As FTPCommandClass..::.FTPCommandT _
) As String
public:
static String^ FTPCommandTypeToString(
    FTPCommandClass..::.FTPCommandT ct
)
Parameters
ct (FTPCommandClass..::.FTPCommandT)

[Missing <param name="ct"/> documentation for "M:VisualCronAPI.LangAPI.FTPCommandTypeToString(VisualCron.FTPCommandClass.FTPCommandT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.FTPCommandTypeToString(VisualCron.FTPCommandClass.FTPCommandT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetLang Method (intLangId)

GetLang Method (intLangId)
Namespaces ► VisualCronAPI ► LangAPI ► GetLang(Int32)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.GetLang(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static Lang GetLang(
    int intLangId
)
Public Shared Function GetLang ( _
    intLangId As Integer _
) As Lang
public:
static Lang^ GetLang(
    int intLangId
)
Parameters
intLangId (Int32)

[Missing <param name="intLangId"/> documentation for "M:VisualCronAPI.LangAPI.GetLang(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.GetLang(System.Int32)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetLangId Method (strLang)

GetLangId Method (strLang)
Namespaces ► VisualCronAPI ► LangAPI ► GetLangId(String)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.GetLangId(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static int GetLangId(
    string strLang
)
Public Shared Function GetLangId ( _
    strLang As String _
) As Integer
public:
static int GetLangId(
    String^ strLang
)
Parameters
strLang (String)

[Missing <param name="strLang"/> documentation for "M:VisualCronAPI.LangAPI.GetLangId(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.GetLangId(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetWord Method (strTag, intLength)

GetWord Method (strTag, intLength)
Namespaces ► VisualCronAPI ► LangAPI ► GetWord(String, Int32)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.GetWord(System.String,System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetWord(
    string strTag,
    int intLength
)
Public Shared Function GetWord ( _
    strTag As String, _
    intLength As Integer _
) As String
public:
static String^ GetWord(
    String^ strTag,
    int intLength
)
Parameters
strTag (String)

[Missing <param name="strTag"/> documentation for "M:VisualCronAPI.LangAPI.GetWord(System.String,System.Int32)"]

intLength (Int32)

[Missing <param name="intLength"/> documentation for "M:VisualCronAPI.LangAPI.GetWord(System.String,System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.GetWord(System.String,System.Int32)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetYesNo Method (bolValue)

GetYesNo Method (bolValue)
Namespaces ► VisualCronAPI ► LangAPI ► GetYesNo(Boolean)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.GetYesNo(System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetYesNo(
    bool bolValue
)
Public Shared Function GetYesNo ( _
    bolValue As Boolean _
) As String
public:
static String^ GetYesNo(
    bool bolValue
)
Parameters
bolValue (Boolean)

[Missing <param name="bolValue"/> documentation for "M:VisualCronAPI.LangAPI.GetYesNo(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.GetYesNo(System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsBabelNothing Method

IsBabelNothing Method
Namespaces ► VisualCronAPI ► LangAPI ► IsBabelNothing()()()

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.IsBabelNothing]

Declaration Syntax
C# Visual Basic Visual C++
public static Functions IsBabelNothing()
Public Shared Function IsBabelNothing As Functions
public:
static Functions^ IsBabelNothing()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.IsBabelNothing]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsLeftToRight Method

IsLeftToRight Method
Namespaces ► VisualCronAPI ► LangAPI ► IsLeftToRight()()()

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.IsLeftToRight]

Declaration Syntax
C# Visual Basic Visual C++
public static bool IsLeftToRight()
Public Shared Function IsLeftToRight As Boolean
public:
static bool IsLeftToRight()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.IsLeftToRight]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobStatusToString Method (s)

JobStatusToString Method (s)
Namespaces ► VisualCronAPI ► LangAPI ► JobStatusToString(JobStatsClass..::.StatusT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.JobStatusToString(VisualCron.JobStatsClass.StatusT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string JobStatusToString(
    JobStatsClass..::.StatusT s
)
Public Shared Function JobStatusToString ( _
    s As JobStatsClass..::.StatusT _
) As String
public:
static String^ JobStatusToString(
    JobStatsClass..::.StatusT s
)
Parameters
s (JobStatsClass..::.StatusT)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.LangAPI.JobStatusToString(VisualCron.JobStatsClass.StatusT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.JobStatusToString(VisualCron.JobStatsClass.StatusT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LoadLanguages Method (intLangId)

LoadLanguages Method (intLangId)
Namespaces ► VisualCronAPI ► LangAPI ► LoadLanguages(Int32)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.LoadLanguages(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static void LoadLanguages(
    int intLangId
)
Public Shared Sub LoadLanguages ( _
    intLangId As Integer _
)
public:
static void LoadLanguages(
    int intLangId
)
Parameters
intLangId (Int32)

[Missing <param name="intLangId"/> documentation for "M:VisualCronAPI.LangAPI.LoadLanguages(System.Int32)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LoadProject Method

LoadProject Method
Namespaces ► VisualCronAPI ► LangAPI ► LoadProject()()()

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.LoadProject]

Declaration Syntax
C# Visual Basic Visual C++
public static void LoadProject()
Public Shared Sub LoadProject
public:
static void LoadProject()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogonTypeToString Method (lt)

LogonTypeToString Method (lt)
Namespaces ► VisualCronAPI ► LangAPI ► LogonTypeToString(TaskExecuteClass..::.LogonT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.LogonTypeToString(VisualCron.TaskExecuteClass.LogonT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string LogonTypeToString(
    TaskExecuteClass..::.LogonT lt
)
Public Shared Function LogonTypeToString ( _
    lt As TaskExecuteClass..::.LogonT _
) As String
public:
static String^ LogonTypeToString(
    TaskExecuteClass..::.LogonT lt
)
Parameters
lt (TaskExecuteClass..::.LogonT)

[Missing <param name="lt"/> documentation for "M:VisualCronAPI.LangAPI.LogonTypeToString(VisualCron.TaskExecuteClass.LogonT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.LogonTypeToString(VisualCron.TaskExecuteClass.LogonT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotifyFilterToString Method (nf)

NotifyFilterToString Method (nf)
Namespaces ► VisualCronAPI ► LangAPI ► NotifyFilterToString(NotifyFilters)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.NotifyFilterToString(System.IO.NotifyFilters)]

Declaration Syntax
C# Visual Basic Visual C++
public static string NotifyFilterToString(
    NotifyFilters nf
)
Public Shared Function NotifyFilterToString ( _
    nf As NotifyFilters _
) As String
public:
static String^ NotifyFilterToString(
    NotifyFilters nf
)
Parameters
nf (NotifyFilters)

[Missing <param name="nf"/> documentation for "M:VisualCronAPI.LangAPI.NotifyFilterToString(System.IO.NotifyFilters)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.NotifyFilterToString(System.IO.NotifyFilters)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Reload Method

Reload Method
Namespaces ► VisualCronAPI ► LangAPI ► Reload()()()
Members
Icon | Member | Description
 | Reload(Server) |
 | Reload(Int32) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Reload Method (intLanguageId)

Reload Method (intLanguageId)
Namespaces ► VisualCronAPI ► LangAPI ► Reload(Int32)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.Reload(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public static void Reload(
    int intLanguageId
)
Public Shared Sub Reload ( _
    intLanguageId As Integer _
)
public:
static void Reload(
    int intLanguageId
)
Parameters
intLanguageId (Int32)

[Missing <param name="intLanguageId"/> documentation for "M:VisualCronAPI.LangAPI.Reload(System.Int32)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Reload Method (s)

Reload Method (s)
Namespaces ► VisualCronAPI ► LangAPI ► Reload(Server)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.Reload(VisualCronAPI.Server)]

Declaration Syntax
C# Visual Basic Visual C++
public static void Reload(
    Server s
)
Public Shared Sub Reload ( _
    s As Server _
)
public:
static void Reload(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.LangAPI.Reload(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServiceStatusToString Method (ss)

ServiceStatusToString Method (ss)
Namespaces ► VisualCronAPI ► LangAPI ► ServiceStatusToString(ServiceControllerStatus)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.ServiceStatusToString(System.ServiceProcess.ServiceControllerStatus)]

Declaration Syntax
C# Visual Basic Visual C++
public static string ServiceStatusToString(
    ServiceControllerStatus ss
)
Public Shared Function ServiceStatusToString ( _
    ss As ServiceControllerStatus _
) As String
public:
static String^ ServiceStatusToString(
    ServiceControllerStatus ss
)
Parameters
ss (ServiceControllerStatus)

[Missing <param name="ss"/> documentation for "M:VisualCronAPI.LangAPI.ServiceStatusToString(System.ServiceProcess.ServiceControllerStatus)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.ServiceStatusToString(System.ServiceProcess.ServiceControllerStatus)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskStatusToString Method (s)

TaskStatusToString Method (s)
Namespaces ► VisualCronAPI ► LangAPI ► TaskStatusToString(TaskStatsClass..::.TaskStatusT)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.TaskStatusToString(VisualCron.TaskStatsClass.TaskStatusT)]

Declaration Syntax
C# Visual Basic Visual C++
public static string TaskStatusToString(
    TaskStatsClass..::.TaskStatusT s
)
Public Shared Function TaskStatusToString ( _
    s As TaskStatsClass..::.TaskStatusT _
) As String
public:
static String^ TaskStatusToString(
    TaskStatsClass..::.TaskStatusT s
)
Parameters
s (TaskStatsClass..::.TaskStatusT)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.LangAPI.TaskStatusToString(VisualCron.TaskStatsClass.TaskStatusT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.TaskStatusToString(VisualCron.TaskStatsClass.TaskStatusT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


WatchChangeTypeToString Method (wct)

WatchChangeTypeToString Method (wct)
Namespaces ► VisualCronAPI ► LangAPI ► WatchChangeTypeToString(WatcherChangeTypes)

[Missing <summary> documentation for M:VisualCronAPI.LangAPI.WatchChangeTypeToString(System.IO.WatcherChangeTypes)]

Declaration Syntax
C# Visual Basic Visual C++
public static string WatchChangeTypeToString(
    WatcherChangeTypes wct
)
Public Shared Function WatchChangeTypeToString ( _
    wct As WatcherChangeTypes _
) As String
public:
static String^ WatchChangeTypeToString(
    WatcherChangeTypes wct
)
Parameters
wct (WatcherChangeTypes)

[Missing <param name="wct"/> documentation for "M:VisualCronAPI.LangAPI.WatchChangeTypeToString(System.IO.WatcherChangeTypes)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.LangAPI.WatchChangeTypeToString(System.IO.WatcherChangeTypes)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License Class

License Class
Namespaces ► VisualCronAPI ► License

[Missing <summary> documentation for T:VisualCronAPI.License]

Declaration Syntax
C# Visual Basic Visual C++
public class License : License..::._License
Public Class License _
    Implements License..::._License
public ref class License : License..::._License
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | License(Server) | Initializes a new instance of the License class
 | ActivateOffline(String, String) | Activates the Server offline - from the Client machine
 | ActivateOnline(String) | Actives the Server that the Client is connected to - from the Client machine
 | ActivationCode | The activation code used by the Server
 | DeActivateLicense()()() | Deactivates the Server that the Client is connected to - from the Client machine
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendTrial(String) | Extends the trial time
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTrialDaysLeft()()() | Returns number days left for Trial
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsValid()()() | Checks if Server license is still valid
 | LicenseStatus | The current status of the license trial/activated
 | LicenseUpdated | This event occurs when the license information has been updated
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrialEndTime | Returns the date the trial ends
Inheritance Hierarchy
Object
License

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License Constructor (s)

License Constructor (s)
Namespaces ► VisualCronAPI ► License ► License(Server)
Initializes a new instance of the License class
Declaration Syntax
C# Visual Basic Visual C++
public License(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
License(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.License.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ActivateOffline Method (strActivationCode, strPersonalID)

ActivateOffline Method (strActivationCode, strPersonalID)
Namespaces ► VisualCronAPI ► License ► ActivateOffline(String, String)
Activates the Server offline - from the Client machine
Declaration Syntax
C# Visual Basic Visual C++
public bool ActivateOffline(
    string strActivationCode,
    string strPersonalID
)
Public Function ActivateOffline ( _
    strActivationCode As String, _
    strPersonalID As String _
) As Boolean
public:
virtual bool ActivateOffline(
    String^ strActivationCode,
    String^ strPersonalID
) sealed
Parameters
strActivationCode (String)
Activation code provided at purchase
strPersonalID (String)
Code that is retrieved here: http://www.visualcron.com/activation/OfflineActivation.aspx
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ActivateOnline Method (strActivationCode)

ActivateOnline Method (strActivationCode)
Namespaces ► VisualCronAPI ► License ► ActivateOnline(String)
Actives the Server that the Client is connected to - from the Client machine
Declaration Syntax
C# Visual Basic Visual C++
public ActivationResult ActivateOnline(
    string strActivationCode
)
Public Function ActivateOnline ( _
    strActivationCode As String _
) As ActivationResult
public:
virtual ActivationResult ActivateOnline(
    String^ strActivationCode
) sealed
Parameters
strActivationCode (String)
Activation code provided at purchase
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License.ActivateOnline(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ActivationCode Property

ActivationCode Property
Namespaces ► VisualCronAPI ► License ► ActivationCode
The activation code used by the Server
Declaration Syntax
C# Visual Basic Visual C++
public string ActivationCode { get; internal set; }
Public Property ActivationCode As String
public:
virtual property String^ ActivationCode {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivateLicense Method

DeActivateLicense Method
Namespaces ► VisualCronAPI ► License ► DeActivateLicense()()()
Deactivates the Server that the Client is connected to - from the Client machine
Declaration Syntax
C# Visual Basic Visual C++
public ActivationResult DeActivateLicense()
Public Function DeActivateLicense As ActivationResult
public:
virtual ActivationResult DeActivateLicense() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License.DeActivateLicense]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExtendTrial Method (strCode)

ExtendTrial Method (strCode)
Namespaces ► VisualCronAPI ► License ► ExtendTrial(String)
Extends the trial time
Declaration Syntax
C# Visual Basic Visual C++
public typExtendTrialResult ExtendTrial(
    string strCode
)
Public Function ExtendTrial ( _
    strCode As String _
) As typExtendTrialResult
public:
virtual typExtendTrialResult ExtendTrial(
    String^ strCode
) sealed
Parameters
strCode (String)
Use trial extension code from support@visualcron.com
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License.ExtendTrial(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTrialDaysLeft Method

GetTrialDaysLeft Method
Namespaces ► VisualCronAPI ► License ► GetTrialDaysLeft()()()
Returns number days left for Trial
Declaration Syntax
C# Visual Basic Visual C++
public string GetTrialDaysLeft()
Public Function GetTrialDaysLeft As String
public:
virtual String^ GetTrialDaysLeft() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License.GetTrialDaysLeft]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsValid Method

IsValid Method
Namespaces ► VisualCronAPI ► License ► IsValid()()()
Checks if Server license is still valid
Declaration Syntax
C# Visual Basic Visual C++
public bool IsValid()
Public Function IsValid As Boolean
public:
virtual bool IsValid() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License.IsValid]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LicenseStatus Property

LicenseStatus Property
Namespaces ► VisualCronAPI ► License ► LicenseStatus
The current status of the license trial/activated
Declaration Syntax
C# Visual Basic Visual C++
public LicenseClass..::.LicStatus LicenseStatus { get; internal set; }
Public Property LicenseStatus As LicenseClass..::.LicStatus
public:
virtual property LicenseClass..::.LicStatus LicenseStatus {
    LicenseClass..::.LicStatus get () sealed;
    void set (LicenseClass..::.LicStatus value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LicenseUpdated Event

LicenseUpdated Event
Namespaces ► VisualCronAPI ► License ► LicenseUpdated
This event occurs when the license information has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event License..::.DelegateLicenseUpdated LicenseUpdated
Public Shared Event LicenseUpdated As License..::.DelegateLicenseUpdated
public:
static  event License..::.DelegateLicenseUpdated^ LicenseUpdated {
    void add (License..::.DelegateLicenseUpdated^ value);
    void remove (License..::.DelegateLicenseUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TrialEndTime Property

TrialEndTime Property
Namespaces ► VisualCronAPI ► License ► TrialEndTime
Returns the date the trial ends
Declaration Syntax
C# Visual Basic Visual C++
public DateTime TrialEndTime { get; internal set; }
Public Property TrialEndTime As DateTime
public:
virtual property DateTime TrialEndTime {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License._License Interface

License..::._License Interface
Namespaces ► VisualCronAPI ► License ► License..::._License

[Missing <summary> documentation for T:VisualCronAPI.License._License]

Declaration Syntax
C# Visual Basic Visual C++
public interface _License
Public Interface _License
public interface class _License
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ActivateOffline(String, String) |
 | ActivateOnline(String) |
 | ActivationCode |
 | DeActivateLicense()()() |
 | ExtendTrial(String) |
 | GetTrialDaysLeft()()() |
 | IsValid()()() |
 | LicenseStatus |
 | TrialEndTime |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ActivateOffline Method (strActivationCode, strPersonalID)

ActivateOffline Method (strActivationCode, strPersonalID)
Namespaces ► VisualCronAPI ► License..::._License ► ActivateOffline(String, String)

[Missing <summary> documentation for M:VisualCronAPI.License._License.ActivateOffline(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool ActivateOffline(
    string strActivationCode,
    string strPersonalID
)
Function ActivateOffline ( _
    strActivationCode As String, _
    strPersonalID As String _
) As Boolean
bool ActivateOffline(
    String^ strActivationCode,
    String^ strPersonalID
)
Parameters
strActivationCode (String)

[Missing <param name="strActivationCode"/> documentation for "M:VisualCronAPI.License._License.ActivateOffline(System.String,System.String)"]

strPersonalID (String)

[Missing <param name="strPersonalID"/> documentation for "M:VisualCronAPI.License._License.ActivateOffline(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.License._License.ActivateOffline(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ActivateOnline Method (strActivationCode)

ActivateOnline Method (strActivationCode)
Namespaces ► VisualCronAPI ► License..::._License ► ActivateOnline(String)

[Missing <summary> documentation for M:VisualCronAPI.License._License.ActivateOnline(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ActivationResult ActivateOnline(
    string strActivationCode
)
Function ActivateOnline ( _
    strActivationCode As String _
) As ActivationResult
ActivationResult ActivateOnline(
    String^ strActivationCode
)
Parameters
strActivationCode (String)

[Missing <param name="strActivationCode"/> documentation for "M:VisualCronAPI.License._License.ActivateOnline(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.License._License.ActivateOnline(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ActivationCode Property

ActivationCode Property
Namespaces ► VisualCronAPI ► License..::._License ► ActivationCode

[Missing <summary> documentation for P:VisualCronAPI.License._License.ActivationCode]

Declaration Syntax
C# Visual Basic Visual C++
string ActivationCode { get; }
ReadOnly Property ActivationCode As String
property String^ ActivationCode {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivateLicense Method

DeActivateLicense Method
Namespaces ► VisualCronAPI ► License..::._License ► DeActivateLicense()()()

[Missing <summary> documentation for M:VisualCronAPI.License._License.DeActivateLicense]

Declaration Syntax
C# Visual Basic Visual C++
ActivationResult DeActivateLicense()
Function DeActivateLicense As ActivationResult
ActivationResult DeActivateLicense()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License._License.DeActivateLicense]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExtendTrial Method (strCode)

ExtendTrial Method (strCode)
Namespaces ► VisualCronAPI ► License..::._License ► ExtendTrial(String)

[Missing <summary> documentation for M:VisualCronAPI.License._License.ExtendTrial(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
typExtendTrialResult ExtendTrial(
    string strCode
)
Function ExtendTrial ( _
    strCode As String _
) As typExtendTrialResult
typExtendTrialResult ExtendTrial(
    String^ strCode
)
Parameters
strCode (String)

[Missing <param name="strCode"/> documentation for "M:VisualCronAPI.License._License.ExtendTrial(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.License._License.ExtendTrial(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTrialDaysLeft Method

GetTrialDaysLeft Method
Namespaces ► VisualCronAPI ► License..::._License ► GetTrialDaysLeft()()()

[Missing <summary> documentation for M:VisualCronAPI.License._License.GetTrialDaysLeft]

Declaration Syntax
C# Visual Basic Visual C++
string GetTrialDaysLeft()
Function GetTrialDaysLeft As String
String^ GetTrialDaysLeft()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License._License.GetTrialDaysLeft]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsValid Method

IsValid Method
Namespaces ► VisualCronAPI ► License..::._License ► IsValid()()()

[Missing <summary> documentation for M:VisualCronAPI.License._License.IsValid]

Declaration Syntax
C# Visual Basic Visual C++
bool IsValid()
Function IsValid As Boolean
bool IsValid()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.License._License.IsValid]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LicenseStatus Property

LicenseStatus Property
Namespaces ► VisualCronAPI ► License..::._License ► LicenseStatus

[Missing <summary> documentation for P:VisualCronAPI.License._License.LicenseStatus]

Declaration Syntax
C# Visual Basic Visual C++
LicenseClass..::.LicStatus LicenseStatus { get; }
ReadOnly Property LicenseStatus As LicenseClass..::.LicStatus
property LicenseClass..::.LicStatus LicenseStatus {
    LicenseClass..::.LicStatus get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TrialEndTime Property

TrialEndTime Property
Namespaces ► VisualCronAPI ► License..::._License ► TrialEndTime

[Missing <summary> documentation for P:VisualCronAPI.License._License.TrialEndTime]

Declaration Syntax
C# Visual Basic Visual C++
DateTime TrialEndTime { get; }
ReadOnly Property TrialEndTime As DateTime
property DateTime TrialEndTime {
    DateTime get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License.DelegateLicenseUpdated Delegate

License..::.DelegateLicenseUpdated Delegate
Namespaces ► VisualCronAPI ► License ► License..::.DelegateLicenseUpdated

[Missing <summary> documentation for T:VisualCronAPI.License.DelegateLicenseUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateLicenseUpdated(
    Server s
)
Public Delegate Sub DelegateLicenseUpdated ( _
    s As Server _
)
public delegate void DelegateLicenseUpdated(
    Server^ s
)
Parameters
s (Server)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License.TrialTimeExpired Class

License..::.TrialTimeExpired Class
Namespaces ► VisualCronAPI ► License ► License..::.TrialTimeExpired
Is throwed when trial time has expired on server
Declaration Syntax
C# Visual Basic Visual C++
public class TrialTimeExpired : Exception
Public Class TrialTimeExpired _
    Inherits Exception
public ref class TrialTimeExpired : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | License..::.TrialTimeExpired()()() | Initializes a new instance of the License..::.TrialTimeExpired class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | License..::.TrialTimeExpired

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License.TrialTimeExpired Constructor

License..::.TrialTimeExpired Constructor
Namespaces ► VisualCronAPI ► License..::.TrialTimeExpired ► License..::.TrialTimeExpired()()()
Initializes a new instance of the License..::.TrialTimeExpired class
Declaration Syntax
C# Visual Basic Visual C++
public TrialTimeExpired()
Public Sub New
public:
TrialTimeExpired()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log Class

Log Class
Namespaces ► VisualCronAPI ► Log

[Missing <summary> documentation for T:VisualCronAPI.Log]

Declaration Syntax
C# Visual Basic Visual C++
public class Log
Public Class Log
public ref class Log
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Log(Server%) | Initializes a new instance of the Log class
 | AddEvent(LogClass) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtendedLogging | Gets or sets if extended debug logging should be performed
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FirstServerEvent |
 | FirstServerId |
 | FirstServerIdAtClient |
 | GetAll()()() | Returns a list of all Log items
 | GetAllArray()()() | Returns an array of all Log items
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogAdded | This event is raised when a Log item is added
 | LogAddedStatic | This event is raised when a Log item is added
 | LogArrayAdded | This event is raised when a Log item array is added
 | LogArrayAddedStatic | This event is raised when a Log item array is added
 | LogToFile | Gets or sets if the Server should log events to file or not
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SendLogChunkRequest(LogInfoClass) |
 | StartLogSubscription()()() | Starts real-time log subscription
 | StopLogSubscription()()() | Stops real-time log subscription
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Log

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log Constructor (s)

Log Constructor (s)
Namespaces ► VisualCronAPI ► Log ► Log(Server%)
Initializes a new instance of the Log class
Declaration Syntax
C# Visual Basic Visual C++
public Log(
    ref Server s
)
Public Sub New ( _
    ByRef s As Server _
)
public:
Log(
    Server^% s
)
Parameters
s ( Server %)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Log.#ctor(VisualCronAPI.Server@)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AddEvent Method (lc)

AddEvent Method (lc)
Namespaces ► VisualCronAPI ► Log ► AddEvent(LogClass)

[Missing <summary> documentation for M:VisualCronAPI.Log.AddEvent(VisualCron.LogClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddEvent(
    LogClass lc
)
Public Sub AddEvent ( _
    lc As LogClass _
)
public:
void AddEvent(
    LogClass^ lc
)
Parameters
lc (LogClass)

[Missing <param name="lc"/> documentation for "M:VisualCronAPI.Log.AddEvent(VisualCron.LogClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ExtendedLogging Property

ExtendedLogging Property
Namespaces ► VisualCronAPI ► Log ► ExtendedLogging
Gets or sets if extended debug logging should be performed
Declaration Syntax
C# Visual Basic Visual C++
public bool ExtendedLogging { get; set; }
Public Property ExtendedLogging As Boolean
public:
property bool ExtendedLogging {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FirstServerEvent Field

FirstServerEvent Field
Namespaces ► VisualCronAPI ► Log ► FirstServerEvent

[Missing <summary> documentation for F:VisualCronAPI.Log.FirstServerEvent]

Declaration Syntax
C# Visual Basic Visual C++
public DateTime FirstServerEvent
Public FirstServerEvent As DateTime
public:
DateTime FirstServerEvent

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FirstServerId Field

FirstServerId Field
Namespaces ► VisualCronAPI ► Log ► FirstServerId

[Missing <summary> documentation for F:VisualCronAPI.Log.FirstServerId]

Declaration Syntax
C# Visual Basic Visual C++
public long FirstServerId
Public FirstServerId As Long
public:
long long FirstServerId

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


FirstServerIdAtClient Field

FirstServerIdAtClient Field
Namespaces ► VisualCronAPI ► Log ► FirstServerIdAtClient

[Missing <summary> documentation for F:VisualCronAPI.Log.FirstServerIdAtClient]

Declaration Syntax
C# Visual Basic Visual C++
public long FirstServerIdAtClient
Public FirstServerIdAtClient As Long
public:
long long FirstServerIdAtClient

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Log ► GetAll()()()
Returns a list of all Log items
Declaration Syntax
C# Visual Basic Visual C++
public List<LogClass> GetAll()
Public Function GetAll As List(Of LogClass)
public:
List<LogClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Log.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Log ► GetAllArray()()()
Returns an array of all Log items
Declaration Syntax
C# Visual Basic Visual C++
public LogClass[] GetAllArray()
Public Function GetAllArray As LogClass()
public:
array<LogClass^>^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Log.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAdded Event

LogAdded Event
Namespaces ► VisualCronAPI ► Log ► LogAdded
This event is raised when a Log item is added
Declaration Syntax
C# Visual Basic Visual C++
public event Log..::.DelegateLogAdded LogAdded
Public Event LogAdded As Log..::.DelegateLogAdded
public:
 event Log..::.DelegateLogAdded^ LogAdded {
    void add (Log..::.DelegateLogAdded^ value);
    void remove (Log..::.DelegateLogAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAddedStatic Event

LogAddedStatic Event
Namespaces ► VisualCronAPI ► Log ► LogAddedStatic
This event is raised when a Log item is added
Declaration Syntax
C# Visual Basic Visual C++
public static event Log..::.DelegateLogAdded LogAddedStatic
Public Shared Event LogAddedStatic As Log..::.DelegateLogAdded
public:
static  event Log..::.DelegateLogAdded^ LogAddedStatic {
    void add (Log..::.DelegateLogAdded^ value);
    void remove (Log..::.DelegateLogAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogArrayAdded Event

LogArrayAdded Event
Namespaces ► VisualCronAPI ► Log ► LogArrayAdded
This event is raised when a Log item array is added
Declaration Syntax
C# Visual Basic Visual C++
public event Log..::.DelegateLogArrayAdded LogArrayAdded
Public Event LogArrayAdded As Log..::.DelegateLogArrayAdded
public:
 event Log..::.DelegateLogArrayAdded^ LogArrayAdded {
    void add (Log..::.DelegateLogArrayAdded^ value);
    void remove (Log..::.DelegateLogArrayAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogArrayAddedStatic Event

LogArrayAddedStatic Event
Namespaces ► VisualCronAPI ► Log ► LogArrayAddedStatic
This event is raised when a Log item array is added
Declaration Syntax
C# Visual Basic Visual C++
public static event Log..::.DelegateLogArrayAdded LogArrayAddedStatic
Public Shared Event LogArrayAddedStatic As Log..::.DelegateLogArrayAdded
public:
static  event Log..::.DelegateLogArrayAdded^ LogArrayAddedStatic {
    void add (Log..::.DelegateLogArrayAdded^ value);
    void remove (Log..::.DelegateLogArrayAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogToFile Property

LogToFile Property
Namespaces ► VisualCronAPI ► Log ► LogToFile
Gets or sets if the Server should log events to file or not
Declaration Syntax
C# Visual Basic Visual C++
public bool LogToFile { get; set; }
Public Property LogToFile As Boolean
public:
property bool LogToFile {
    bool get ();
    void set (bool value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendLogChunkRequest Method (li)

SendLogChunkRequest Method (li)
Namespaces ► VisualCronAPI ► Log ► SendLogChunkRequest(LogInfoClass)

[Missing <summary> documentation for M:VisualCronAPI.Log.SendLogChunkRequest(VisualCron.LogInfoClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void SendLogChunkRequest(
    LogInfoClass li
)
Public Sub SendLogChunkRequest ( _
    li As LogInfoClass _
)
public:
void SendLogChunkRequest(
    LogInfoClass^ li
)
Parameters
li (LogInfoClass)

[Missing <param name="li"/> documentation for "M:VisualCronAPI.Log.SendLogChunkRequest(VisualCron.LogInfoClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


StartLogSubscription Method

StartLogSubscription Method
Namespaces ► VisualCronAPI ► Log ► StartLogSubscription()()()
Starts real-time log subscription
Declaration Syntax
C# Visual Basic Visual C++
public void StartLogSubscription()
Public Sub StartLogSubscription
public:
void StartLogSubscription()
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


StopLogSubscription Method

StopLogSubscription Method
Namespaces ► VisualCronAPI ► Log ► StopLogSubscription()()()
Stops real-time log subscription
Declaration Syntax
C# Visual Basic Visual C++
public void StopLogSubscription()
Public Sub StopLogSubscription
public:
void StopLogSubscription()
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log.DelegateLogAdded Delegate

Log..::.DelegateLogAdded Delegate
Namespaces ► VisualCronAPI ► Log ► Log..::.DelegateLogAdded

[Missing <summary> documentation for T:VisualCronAPI.Log.DelegateLogAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateLogAdded(
    LogClass lc,
    ref Server s
)
Public Delegate Sub DelegateLogAdded ( _
    lc As LogClass, _
    ByRef s As Server _
)
public delegate void DelegateLogAdded(
    LogClass^ lc,
    Server^% s
)
Parameters
lc (LogClass)
s ( Server %)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log.DelegateLogArrayAdded Delegate

Log..::.DelegateLogArrayAdded Delegate
Namespaces ► VisualCronAPI ► Log ► Log..::.DelegateLogArrayAdded

[Missing <summary> documentation for T:VisualCronAPI.Log.DelegateLogArrayAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateLogArrayAdded(
    LogClass[] lc,
    ref Server s
)
Public Delegate Sub DelegateLogArrayAdded ( _
    lc As LogClass(), _
    ByRef s As Server _
)
public delegate void DelegateLogArrayAdded(
    array<LogClass^>^ lc,
    Server^% s
)
Parameters
lc (array< LogClass >[]()[])
s ( Server %)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAPI Class

LogAPI Class
Namespaces ► VisualCronAPI ► LogAPI

[Missing <summary> documentation for T:VisualCronAPI.LogAPI]

Declaration Syntax
C# Visual Basic Visual C++
public class LogAPI
Public Class LogAPI
public ref class LogAPI
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LogAPI()()() | Initializes a new instance of the LogAPI class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventOnLog |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
LogAPI

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAPI Constructor

LogAPI Constructor
Namespaces ► VisualCronAPI ► LogAPI ► LogAPI()()()
Initializes a new instance of the LogAPI class
Declaration Syntax
C# Visual Basic Visual C++
public LogAPI()
Public Sub New
public:
LogAPI()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventOnLog Event

EventOnLog Event
Namespaces ► VisualCronAPI ► LogAPI ► EventOnLog

[Missing <summary> documentation for E:VisualCronAPI.LogAPI.EventOnLog]

Declaration Syntax
C# Visual Basic Visual C++
public static event LogAPI..::.DelegateOnLog EventOnLog
Public Shared Event EventOnLog As LogAPI..::.DelegateOnLog
public:
static  event LogAPI..::.DelegateOnLog^ EventOnLog {
    void add (LogAPI..::.DelegateOnLog^ value);
    void remove (LogAPI..::.DelegateOnLog^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAPI.DelegateOnLog Delegate

LogAPI..::.DelegateOnLog Delegate
Namespaces ► VisualCronAPI ► LogAPI ► LogAPI..::.DelegateOnLog

[Missing <summary> documentation for T:VisualCronAPI.LogAPI.DelegateOnLog]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnLog(
    LogAPI..::.LogEventType lvt,
    string strText
)
Public Delegate Sub DelegateOnLog ( _
    lvt As LogAPI..::.LogEventType, _
    strText As String _
)
public delegate void DelegateOnLog(
    LogAPI..::.LogEventType lvt,
    String^ strText
)
Parameters
lvt (LogAPI..::.LogEventType)
strText (String)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAPI.LogEventType Enumeration

LogAPI..::.LogEventType Enumeration
Namespaces ► VisualCronAPI ► LogAPI ► LogAPI..::.LogEventType

[Missing <summary> documentation for T:VisualCronAPI.LogAPI.LogEventType]

Declaration Syntax
C# Visual Basic Visual C++
public enum LogEventType
Public Enumeration LogEventType
public enum class LogEventType
Members
Member | Description
Comm |
Debug |
Warning |
Critical |
Info |
Err |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LogAPI.LogLevelType Enumeration

LogAPI..::.LogLevelType Enumeration
Namespaces ► VisualCronAPI ► LogAPI ► LogAPI..::.LogLevelType

[Missing <summary> documentation for T:VisualCronAPI.LogAPI.LogLevelType]

Declaration Syntax
C# Visual Basic Visual C++
public enum LogLevelType
Public Enumeration LogLevelType
public enum class LogLevelType
Members
Member | Description
None |
Normal |
Extended |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


MessageQueueClass Class

MessageQueueClass Class
Namespaces ► VisualCronAPI ► MessageQueueClass

[Missing <summary> documentation for T:VisualCronAPI.MessageQueueClass]

Declaration Syntax
C# Visual Basic Visual C++
public class MessageQueueClass
Public Class MessageQueueClass
public ref class MessageQueueClass
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MessageQueueClass()()() | Initializes a new instance of the MessageQueueClass class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MC |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WaitSec |
Inheritance Hierarchy
Object
MessageQueueClass

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


MessageQueueClass Constructor

MessageQueueClass Constructor
Namespaces ► VisualCronAPI ► MessageQueueClass ► MessageQueueClass()()()
Initializes a new instance of the MessageQueueClass class
Declaration Syntax
C# Visual Basic Visual C++
public MessageQueueClass()
Public Sub New
public:
MessageQueueClass()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


MC Field

MC Field
Namespaces ► VisualCronAPI ► MessageQueueClass ► MC

[Missing <summary> documentation for F:VisualCronAPI.MessageQueueClass.MC]

Declaration Syntax
C# Visual Basic Visual C++
public MessageClass MC
Public MC As MessageClass
public:
MessageClass^ MC

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


WaitSec Field

WaitSec Field
Namespaces ► VisualCronAPI ► MessageQueueClass ► WaitSec

[Missing <summary> documentation for F:VisualCronAPI.MessageQueueClass.WaitSec]

Declaration Syntax
C# Visual Basic Visual C++
public int WaitSec
Public WaitSec As Integer
public:
int WaitSec

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives Class

NetworkDrives Class
Namespaces ► VisualCronAPI ► NetworkDrives
Base class for Network Drive Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class NetworkDrives : NetworkDrives..::._NetworkDrives
Public Class NetworkDrives _
    Implements NetworkDrives..::._NetworkDrives
public ref class NetworkDrives : NetworkDrives..::._NetworkDrives
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkDrives(Server) | Initializes a new instance of the NetworkDrives class
 | Add(NetworkDriveClass) | Adds a NetworkDrive
 | Contains(String) | Returns a boolean telling if a specified NetworkDrive exist
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a NetworkDrive based on the string key Id
 | GetAll()()() | Returns a List of NetworkDrives
 | GetAllArray()()() | Returns an array of NetworkDrives
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetNextAvailableDrive()()() | Returns the next free drive letter
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkDriveAdded | This event is raised when a Network Drive has been added
 | NetworkDriveAddedStatic | This event is raised when a Network Drive has been added
 | NetworkDriveRemoved | This event is raised when a Network Drive has been removed
 | NetworkDriveRemovedStatic | This event is raised when a Network Drive has been removed
 | NetworkDriveUpdated | This event is raised when a Network Drive has been updated
 | NetworkDriveUpdatedStatic | This event is raised when a Network Drive has been updated
 | Remove(NetworkDriveClass) | Removes a NetworkDrive
 | Remove(String) | Removes a NetworkDrive
 | RemoveAll()()() | Removes all Network Drives
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(NetworkDriveClass) | Updates a NetworkDrive
Remarks
Inheritance Hierarchy
Object
NetworkDrives

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives Constructor (s)

NetworkDrives Constructor (s)
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDrives(Server)
Initializes a new instance of the NetworkDrives class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDrives(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
NetworkDrives(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.NetworkDrives.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (c)

Add Method (c)
Namespaces ► VisualCronAPI ► NetworkDrives ► Add(NetworkDriveClass)
Adds a NetworkDrive
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass Add(
    NetworkDriveClass c
)
Public Function Add ( _
    c As NetworkDriveClass _
) As NetworkDriveClass
public:
virtual NetworkDriveClass^ Add(
    NetworkDriveClass^ c
) sealed
Parameters
c (NetworkDriveClass)
a NetworkDrive
Return Value
a NetworkDrive
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (NetworkDriveId)

Contains Method (NetworkDriveId)
Namespaces ► VisualCronAPI ► NetworkDrives ► Contains(String)
Returns a boolean telling if a specified NetworkDrive exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string NetworkDriveId
)
Public Function Contains ( _
    NetworkDriveId As String _
) As Boolean
public:
virtual bool Contains(
    String^ NetworkDriveId
) sealed
Parameters
NetworkDriveId (String)

[Missing <param name="NetworkDriveId"/> documentation for "M:VisualCronAPI.NetworkDrives.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (NetworkDriveId)

Get Method (NetworkDriveId)
Namespaces ► VisualCronAPI ► NetworkDrives ► Get(String)
Returns a NetworkDrive based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass Get(
    string NetworkDriveId
)
Public Function Get ( _
    NetworkDriveId As String _
) As NetworkDriveClass
public:
virtual NetworkDriveClass^ Get(
    String^ NetworkDriveId
) sealed
Parameters
NetworkDriveId (String)
string key
Return Value
a NetworkDrive
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► NetworkDrives ► GetAll()()()
Returns a List of NetworkDrives
Declaration Syntax
C# Visual Basic Visual C++
public List<NetworkDriveClass> GetAll()
Public Function GetAll As List(Of NetworkDriveClass)
public:
List<NetworkDriveClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► NetworkDrives ► GetAllArray()()()
Returns an array of NetworkDrives
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetNextAvailableDrive Method

GetNextAvailableDrive Method
Namespaces ► VisualCronAPI ► NetworkDrives ► GetNextAvailableDrive()()()
Returns the next free drive letter
Declaration Syntax
C# Visual Basic Visual C++
public string GetNextAvailableDrive()
Public Function GetNextAvailableDrive As String
public:
virtual String^ GetNextAvailableDrive() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives.GetNextAvailableDrive]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveAdded Event

NetworkDriveAdded Event
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDriveAdded
This event is raised when a Network Drive has been added
Declaration Syntax
C# Visual Basic Visual C++
public event NetworkDrives..::.DelegateNetworkDriveAdded NetworkDriveAdded
Public Event NetworkDriveAdded As NetworkDrives..::.DelegateNetworkDriveAdded
public:
 event NetworkDrives..::.DelegateNetworkDriveAdded^ NetworkDriveAdded {
    void add (NetworkDrives..::.DelegateNetworkDriveAdded^ value);
    void remove (NetworkDrives..::.DelegateNetworkDriveAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveAddedStatic Event

NetworkDriveAddedStatic Event
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDriveAddedStatic
This event is raised when a Network Drive has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event NetworkDrives..::.DelegateNetworkDriveAdded NetworkDriveAddedStatic
Public Shared Event NetworkDriveAddedStatic As NetworkDrives..::.DelegateNetworkDriveAdded
public:
static  event NetworkDrives..::.DelegateNetworkDriveAdded^ NetworkDriveAddedStatic {
    void add (NetworkDrives..::.DelegateNetworkDriveAdded^ value);
    void remove (NetworkDrives..::.DelegateNetworkDriveAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveRemoved Event

NetworkDriveRemoved Event
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDriveRemoved
This event is raised when a Network Drive has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event NetworkDrives..::.DelegateNetworkDriveRemoved NetworkDriveRemoved
Public Event NetworkDriveRemoved As NetworkDrives..::.DelegateNetworkDriveRemoved
public:
 event NetworkDrives..::.DelegateNetworkDriveRemoved^ NetworkDriveRemoved {
    void add (NetworkDrives..::.DelegateNetworkDriveRemoved^ value);
    void remove (NetworkDrives..::.DelegateNetworkDriveRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveRemovedStatic Event

NetworkDriveRemovedStatic Event
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDriveRemovedStatic
This event is raised when a Network Drive has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event NetworkDrives..::.DelegateNetworkDriveRemoved NetworkDriveRemovedStatic
Public Shared Event NetworkDriveRemovedStatic As NetworkDrives..::.DelegateNetworkDriveRemoved
public:
static  event NetworkDrives..::.DelegateNetworkDriveRemoved^ NetworkDriveRemovedStatic {
    void add (NetworkDrives..::.DelegateNetworkDriveRemoved^ value);
    void remove (NetworkDrives..::.DelegateNetworkDriveRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveUpdated Event

NetworkDriveUpdated Event
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDriveUpdated
This event is raised when a Network Drive has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event NetworkDrives..::.DelegateNetworkDriveUpdated NetworkDriveUpdated
Public Event NetworkDriveUpdated As NetworkDrives..::.DelegateNetworkDriveUpdated
public:
 event NetworkDrives..::.DelegateNetworkDriveUpdated^ NetworkDriveUpdated {
    void add (NetworkDrives..::.DelegateNetworkDriveUpdated^ value);
    void remove (NetworkDrives..::.DelegateNetworkDriveUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveUpdatedStatic Event

NetworkDriveUpdatedStatic Event
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDriveUpdatedStatic
This event is raised when a Network Drive has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event NetworkDrives..::.DelegateNetworkDriveUpdated NetworkDriveUpdatedStatic
Public Shared Event NetworkDriveUpdatedStatic As NetworkDrives..::.DelegateNetworkDriveUpdated
public:
static  event NetworkDrives..::.DelegateNetworkDriveUpdated^ NetworkDriveUpdatedStatic {
    void add (NetworkDrives..::.DelegateNetworkDriveUpdated^ value);
    void remove (NetworkDrives..::.DelegateNetworkDriveUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► NetworkDrives ► Remove()()()
Members
Icon | Member | Description
 | Remove(NetworkDriveClass) | Removes a NetworkDrive
 | Remove(String) | Removes a NetworkDrive

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (NetworkDriveId)

Remove Method (NetworkDriveId)
Namespaces ► VisualCronAPI ► NetworkDrives ► Remove(String)
Removes a NetworkDrive
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string NetworkDriveId
)
Public Function Remove ( _
    NetworkDriveId As String _
) As Boolean
public:
virtual bool Remove(
    String^ NetworkDriveId
) sealed
Parameters
NetworkDriveId (String)
Id of NetworkDrive
Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (c)

Remove Method (c)
Namespaces ► VisualCronAPI ► NetworkDrives ► Remove(NetworkDriveClass)
Removes a NetworkDrive
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    NetworkDriveClass c
)
Public Function Remove ( _
    c As NetworkDriveClass _
) As Boolean
public:
virtual bool Remove(
    NetworkDriveClass^ c
) sealed
Parameters
c (NetworkDriveClass)
a NetworkDrive
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► NetworkDrives ► RemoveAll()()()
Removes all Network Drives
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (c)

Update Method (c)
Namespaces ► VisualCronAPI ► NetworkDrives ► Update(NetworkDriveClass)
Updates a NetworkDrive
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveClass Update(
    NetworkDriveClass c
)
Public Function Update ( _
    c As NetworkDriveClass _
) As NetworkDriveClass
public:
virtual NetworkDriveClass^ Update(
    NetworkDriveClass^ c
) sealed
Parameters
c (NetworkDriveClass)
a NetworkDrive
Return Value
a NetworkDrive
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives.__NetworkDrives Interface

NetworkDrives..::.__NetworkDrives Interface
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDrives..::.__NetworkDrives

[Missing <summary> documentation for T:VisualCronAPI.NetworkDrives.__NetworkDrives]

Declaration Syntax
C# Visual Basic Visual C++
public interface __NetworkDrives
Public Interface __NetworkDrives
public interface class __NetworkDrives
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NetworkDriveAdded(Server%, NetworkDriveClass) |
 | NetworkDriveRemoved(Server%, NetworkDriveClass) |
 | NetworkDriveUpdated(Server%, NetworkDriveClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveAdded Method (server, nd)

NetworkDriveAdded Method (server, nd)
Namespaces ► VisualCronAPI ► NetworkDrives..::.__NetworkDrives ► NetworkDriveAdded(Server%, NetworkDriveClass)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveAdded(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)]

Declaration Syntax
C# Visual Basic Visual C++
void NetworkDriveAdded(
    ref Server server,
    NetworkDriveClass nd
)
Sub NetworkDriveAdded ( _
    ByRef server As Server, _
    nd As NetworkDriveClass _
)
void NetworkDriveAdded(
    Server^% server,
    NetworkDriveClass^ nd
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveAdded(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)"]

nd (NetworkDriveClass)

[Missing <param name="nd"/> documentation for "M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveAdded(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveRemoved Method (server, nc)

NetworkDriveRemoved Method (server, nc)
Namespaces ► VisualCronAPI ► NetworkDrives..::.__NetworkDrives ► NetworkDriveRemoved(Server%, NetworkDriveClass)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveRemoved(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)]

Declaration Syntax
C# Visual Basic Visual C++
void NetworkDriveRemoved(
    ref Server server,
    NetworkDriveClass nc
)
Sub NetworkDriveRemoved ( _
    ByRef server As Server, _
    nc As NetworkDriveClass _
)
void NetworkDriveRemoved(
    Server^% server,
    NetworkDriveClass^ nc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveRemoved(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)"]

nc (NetworkDriveClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveRemoved(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDriveUpdated Method (server, nc)

NetworkDriveUpdated Method (server, nc)
Namespaces ► VisualCronAPI ► NetworkDrives..::.__NetworkDrives ► NetworkDriveUpdated(Server%, NetworkDriveClass)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveUpdated(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)]

Declaration Syntax
C# Visual Basic Visual C++
void NetworkDriveUpdated(
    ref Server server,
    NetworkDriveClass nc
)
Sub NetworkDriveUpdated ( _
    ByRef server As Server, _
    nc As NetworkDriveClass _
)
void NetworkDriveUpdated(
    Server^% server,
    NetworkDriveClass^ nc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveUpdated(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)"]

nc (NetworkDriveClass)

[Missing <param name="nc"/> documentation for "M:VisualCronAPI.NetworkDrives.__NetworkDrives.NetworkDriveUpdated(VisualCronAPI.Server@,VisualCron.NetworkDriveClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives._NetworkDrives Interface

NetworkDrives..::._NetworkDrives Interface
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDrives..::._NetworkDrives

[Missing <summary> documentation for T:VisualCronAPI.NetworkDrives._NetworkDrives]

Declaration Syntax
C# Visual Basic Visual C++
public interface _NetworkDrives
Public Interface _NetworkDrives
public interface class _NetworkDrives
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(NetworkDriveClass) |
 | Contains(String) |
 | Get(String) |
 | GetAllArray()()() |
 | GetNextAvailableDrive()()() |
 | Remove(NetworkDriveClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | Update(NetworkDriveClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (c)

Add Method (c)
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► Add(NetworkDriveClass)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Add(VisualCron.NetworkDriveClass)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkDriveClass Add(
    NetworkDriveClass c
)
Function Add ( _
    c As NetworkDriveClass _
) As NetworkDriveClass
NetworkDriveClass^ Add(
    NetworkDriveClass^ c
)
Parameters
c (NetworkDriveClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.NetworkDrives._NetworkDrives.Add(VisualCron.NetworkDriveClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Add(VisualCron.NetworkDriveClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (NetworkDriveId)

Contains Method (NetworkDriveId)
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string NetworkDriveId
)
Function Contains ( _
    NetworkDriveId As String _
) As Boolean
bool Contains(
    String^ NetworkDriveId
)
Parameters
NetworkDriveId (String)

[Missing <param name="NetworkDriveId"/> documentation for "M:VisualCronAPI.NetworkDrives._NetworkDrives.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (NetworkDriveId)

Get Method (NetworkDriveId)
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkDriveClass Get(
    string NetworkDriveId
)
Function Get ( _
    NetworkDriveId As String _
) As NetworkDriveClass
NetworkDriveClass^ Get(
    String^ NetworkDriveId
)
Parameters
NetworkDriveId (String)

[Missing <param name="NetworkDriveId"/> documentation for "M:VisualCronAPI.NetworkDrives._NetworkDrives.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetNextAvailableDrive Method

GetNextAvailableDrive Method
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► GetNextAvailableDrive()()()

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.GetNextAvailableDrive]

Declaration Syntax
C# Visual Basic Visual C++
string GetNextAvailableDrive()
Function GetNextAvailableDrive As String
String^ GetNextAvailableDrive()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.GetNextAvailableDrive]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► Remove()()()
Members
Icon | Member | Description
 | Remove(NetworkDriveClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (NetworkDriveId)

Remove Method (NetworkDriveId)
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string NetworkDriveId
)
Function Remove ( _
    NetworkDriveId As String _
) As Boolean
bool Remove(
    String^ NetworkDriveId
)
Parameters
NetworkDriveId (String)

[Missing <param name="NetworkDriveId"/> documentation for "M:VisualCronAPI.NetworkDrives._NetworkDrives.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (c)

Remove Method (c)
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► Remove(NetworkDriveClass)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Remove(VisualCron.NetworkDriveClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    NetworkDriveClass c
)
Function Remove ( _
    c As NetworkDriveClass _
) As Boolean
bool Remove(
    NetworkDriveClass^ c
)
Parameters
c (NetworkDriveClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.NetworkDrives._NetworkDrives.Remove(VisualCron.NetworkDriveClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Remove(VisualCron.NetworkDriveClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (c)

Update Method (c)
Namespaces ► VisualCronAPI ► NetworkDrives..::._NetworkDrives ► Update(NetworkDriveClass)

[Missing <summary> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Update(VisualCron.NetworkDriveClass)]

Declaration Syntax
C# Visual Basic Visual C++
NetworkDriveClass Update(
    NetworkDriveClass c
)
Function Update ( _
    c As NetworkDriveClass _
) As NetworkDriveClass
NetworkDriveClass^ Update(
    NetworkDriveClass^ c
)
Parameters
c (NetworkDriveClass)

[Missing <param name="c"/> documentation for "M:VisualCronAPI.NetworkDrives._NetworkDrives.Update(VisualCron.NetworkDriveClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.NetworkDrives._NetworkDrives.Update(VisualCron.NetworkDriveClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives.DelegateNetworkDriveAdded Delegate

NetworkDrives..::.DelegateNetworkDriveAdded Delegate
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDrives..::.DelegateNetworkDriveAdded

[Missing <summary> documentation for T:VisualCronAPI.NetworkDrives.DelegateNetworkDriveAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateNetworkDriveAdded(
    ref Server server,
    NetworkDriveClass nd
)
Public Delegate Sub DelegateNetworkDriveAdded ( _
    ByRef server As Server, _
    nd As NetworkDriveClass _
)
public delegate void DelegateNetworkDriveAdded(
    Server^% server,
    NetworkDriveClass^ nd
)
Parameters
server ( Server %)
nd (NetworkDriveClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives.DelegateNetworkDriveRemoved Delegate

NetworkDrives..::.DelegateNetworkDriveRemoved Delegate
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDrives..::.DelegateNetworkDriveRemoved

[Missing <summary> documentation for T:VisualCronAPI.NetworkDrives.DelegateNetworkDriveRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateNetworkDriveRemoved(
    ref Server server,
    NetworkDriveClass nc
)
Public Delegate Sub DelegateNetworkDriveRemoved ( _
    ByRef server As Server, _
    nc As NetworkDriveClass _
)
public delegate void DelegateNetworkDriveRemoved(
    Server^% server,
    NetworkDriveClass^ nc
)
Parameters
server ( Server %)
nc (NetworkDriveClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives.DelegateNetworkDriveUpdated Delegate

NetworkDrives..::.DelegateNetworkDriveUpdated Delegate
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDrives..::.DelegateNetworkDriveUpdated

[Missing <summary> documentation for T:VisualCronAPI.NetworkDrives.DelegateNetworkDriveUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateNetworkDriveUpdated(
    ref Server server,
    NetworkDriveClass nc
)
Public Delegate Sub DelegateNetworkDriveUpdated ( _
    ByRef server As Server, _
    nc As NetworkDriveClass _
)
public delegate void DelegateNetworkDriveUpdated(
    Server^% server,
    NetworkDriveClass^ nc
)
Parameters
server ( Server %)
nc (NetworkDriveClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives.NetworkDriveNotFoundException Class

NetworkDrives..::.NetworkDriveNotFoundException Class
Namespaces ► VisualCronAPI ► NetworkDrives ► NetworkDrives..::.NetworkDriveNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.NetworkDrives.NetworkDriveNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class NetworkDriveNotFoundException : Exception
Public Class NetworkDriveNotFoundException _
    Inherits Exception
public ref class NetworkDriveNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | NetworkDrives..::.NetworkDriveNotFoundException(String) | Initializes a new instance of the NetworkDrives..::.NetworkDriveNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | NetworkDrives..::.NetworkDriveNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives.NetworkDriveNotFoundException Constructor (id)

NetworkDrives..::.NetworkDriveNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► NetworkDrives..::.NetworkDriveNotFoundException ► NetworkDrives..::.NetworkDriveNotFoundException(String)
Initializes a new instance of the NetworkDrives..::.NetworkDriveNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDriveNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
NetworkDriveNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.NetworkDrives.NetworkDriveNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications Class

Notifications Class
Namespaces ► VisualCronAPI ► Notifications
Base class for Notification Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Notifications : Notifications..::._Notifications
Public Class Notifications _
    Implements Notifications..::._Notifications
public ref class Notifications : Notifications..::._Notifications
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Notifications(Server) | Initializes a new instance of the Notifications class
 | Add(NotificationClass) | Adds a Notification
 | Contains(String) | Returns a boolean telling if a specified Notification exist
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Notification based on the string key Id
 | GetAll()()() | Returns a list of Notifications
 | GetAllArray()()() | Returns an array of Notifications
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NotificationAdded | This event is raised when a Notification has been added
 | NotificationAddedStatic | This event is raised when a Notification has been added
 | NotificationRemoved | This event is raised when a Notification has been removed
 | NotificationRemovedStatic | This event is raised when a Notification has been removed
 | NotificationUpdated | This event is raised when a Notification has been updated
 | NotificationUpdatedStatic | This event is raised when a Notification has been updated
 | Remove(NotificationClass) | Removes a Notification
 | Remove(String) | Removes a Notification
 | RemoveAll()()() | Removes all Notifications
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TrayPopup |
 | Update(NotificationClass) | Updates a Notification
Remarks
Inheritance Hierarchy
Object
Notifications

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications Constructor (s)

Notifications Constructor (s)
Namespaces ► VisualCronAPI ► Notifications ► Notifications(Server)
Initializes a new instance of the Notifications class
Declaration Syntax
C# Visual Basic Visual C++
public Notifications(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
Notifications(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Notifications.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (n)

Add Method (n)
Namespaces ► VisualCronAPI ► Notifications ► Add(NotificationClass)
Adds a Notification
Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass Add(
    NotificationClass n
)
Public Function Add ( _
    n As NotificationClass _
) As NotificationClass
public:
virtual NotificationClass^ Add(
    NotificationClass^ n
) sealed
Parameters
n (NotificationClass)
a Notification
Return Value
a Notification
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strId)

Contains Method (strId)
Namespaces ► VisualCronAPI ► Notifications ► Contains(String)
Returns a boolean telling if a specified Notification exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strId
)
Public Function Contains ( _
    strId As String _
) As Boolean
public:
virtual bool Contains(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Notifications.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Notifications ► Get(String)
Returns a Notification based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass Get(
    string id
)
Public Function Get ( _
    id As String _
) As NotificationClass
public:
virtual NotificationClass^ Get(
    String^ id
) sealed
Parameters
id (String)
string key
Return Value
a Notification
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Notifications ► GetAll()()()
Returns a list of Notifications
Declaration Syntax
C# Visual Basic Visual C++
public List<NotificationClass> GetAll()
Public Function GetAll As List(Of NotificationClass)
public:
List<NotificationClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Notifications ► GetAllArray()()()
Returns an array of Notifications
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationAdded Event

NotificationAdded Event
Namespaces ► VisualCronAPI ► Notifications ► NotificationAdded
This event is raised when a Notification has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Notifications..::.DelegateNotificationAdded NotificationAdded
Public Event NotificationAdded As Notifications..::.DelegateNotificationAdded
public:
 event Notifications..::.DelegateNotificationAdded^ NotificationAdded {
    void add (Notifications..::.DelegateNotificationAdded^ value);
    void remove (Notifications..::.DelegateNotificationAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationAddedStatic Event

NotificationAddedStatic Event
Namespaces ► VisualCronAPI ► Notifications ► NotificationAddedStatic
This event is raised when a Notification has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Notifications..::.DelegateNotificationAdded NotificationAddedStatic
Public Shared Event NotificationAddedStatic As Notifications..::.DelegateNotificationAdded
public:
static  event Notifications..::.DelegateNotificationAdded^ NotificationAddedStatic {
    void add (Notifications..::.DelegateNotificationAdded^ value);
    void remove (Notifications..::.DelegateNotificationAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationRemoved Event

NotificationRemoved Event
Namespaces ► VisualCronAPI ► Notifications ► NotificationRemoved
This event is raised when a Notification has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Notifications..::.DelegateNotificationRemoved NotificationRemoved
Public Event NotificationRemoved As Notifications..::.DelegateNotificationRemoved
public:
 event Notifications..::.DelegateNotificationRemoved^ NotificationRemoved {
    void add (Notifications..::.DelegateNotificationRemoved^ value);
    void remove (Notifications..::.DelegateNotificationRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationRemovedStatic Event

NotificationRemovedStatic Event
Namespaces ► VisualCronAPI ► Notifications ► NotificationRemovedStatic
This event is raised when a Notification has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Notifications..::.DelegateNotificationRemoved NotificationRemovedStatic
Public Shared Event NotificationRemovedStatic As Notifications..::.DelegateNotificationRemoved
public:
static  event Notifications..::.DelegateNotificationRemoved^ NotificationRemovedStatic {
    void add (Notifications..::.DelegateNotificationRemoved^ value);
    void remove (Notifications..::.DelegateNotificationRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationUpdated Event

NotificationUpdated Event
Namespaces ► VisualCronAPI ► Notifications ► NotificationUpdated
This event is raised when a Notification has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Notifications..::.DelegateNotificationUpdated NotificationUpdated
Public Event NotificationUpdated As Notifications..::.DelegateNotificationUpdated
public:
 event Notifications..::.DelegateNotificationUpdated^ NotificationUpdated {
    void add (Notifications..::.DelegateNotificationUpdated^ value);
    void remove (Notifications..::.DelegateNotificationUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationUpdatedStatic Event

NotificationUpdatedStatic Event
Namespaces ► VisualCronAPI ► Notifications ► NotificationUpdatedStatic
This event is raised when a Notification has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Notifications..::.DelegateNotificationUpdated NotificationUpdatedStatic
Public Shared Event NotificationUpdatedStatic As Notifications..::.DelegateNotificationUpdated
public:
static  event Notifications..::.DelegateNotificationUpdated^ NotificationUpdatedStatic {
    void add (Notifications..::.DelegateNotificationUpdated^ value);
    void remove (Notifications..::.DelegateNotificationUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Notifications ► Remove()()()
Members
Icon | Member | Description
 | Remove(NotificationClass) | Removes a Notification
 | Remove(String) | Removes a Notification

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (NotificationId)

Remove Method (NotificationId)
Namespaces ► VisualCronAPI ► Notifications ► Remove(String)
Removes a Notification
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string NotificationId
)
Public Function Remove ( _
    NotificationId As String _
) As Boolean
public:
virtual bool Remove(
    String^ NotificationId
) sealed
Parameters
NotificationId (String)
Id of Notification
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (n)

Remove Method (n)
Namespaces ► VisualCronAPI ► Notifications ► Remove(NotificationClass)
Removes a Notification
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    NotificationClass n
)
Public Function Remove ( _
    n As NotificationClass _
) As Boolean
public:
virtual bool Remove(
    NotificationClass^ n
) sealed
Parameters
n (NotificationClass)
a Notification
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications.Remove(VisualCron.NotificationClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Notifications ► RemoveAll()()()
Removes all Notifications
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TrayPopup Event

TrayPopup Event
Namespaces ► VisualCronAPI ► Notifications ► TrayPopup

[Missing <summary> documentation for E:VisualCronAPI.Notifications.TrayPopup]

Declaration Syntax
C# Visual Basic Visual C++
public static event Notifications..::.DelegateTrayPopup TrayPopup
Public Shared Event TrayPopup As Notifications..::.DelegateTrayPopup
public:
static  event Notifications..::.DelegateTrayPopup^ TrayPopup {
    void add (Notifications..::.DelegateTrayPopup^ value);
    void remove (Notifications..::.DelegateTrayPopup^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (n)

Update Method (n)
Namespaces ► VisualCronAPI ► Notifications ► Update(NotificationClass)
Updates a Notification
Declaration Syntax
C# Visual Basic Visual C++
public NotificationClass Update(
    NotificationClass n
)
Public Function Update ( _
    n As NotificationClass _
) As NotificationClass
public:
virtual NotificationClass^ Update(
    NotificationClass^ n
) sealed
Parameters
n (NotificationClass)
a Notification
Return Value
a Notification
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications.__Notifications Interface

Notifications..::.__Notifications Interface
Namespaces ► VisualCronAPI ► Notifications ► Notifications..::.__Notifications

[Missing <summary> documentation for T:VisualCronAPI.Notifications.__Notifications]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Notifications
Public Interface __Notifications
public interface class __Notifications
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NotificationAdded(Server%, NotificationClass) |
 | NotificationRemoved(Server%, NotificationClass) |
 | NotificationUpdated(Server%, NotificationClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationAdded Method (server, n)

NotificationAdded Method (server, n)
Namespaces ► VisualCronAPI ► Notifications..::.__Notifications ► NotificationAdded(Server%, NotificationClass)

[Missing <summary> documentation for M:VisualCronAPI.Notifications.__Notifications.NotificationAdded(VisualCronAPI.Server@,VisualCron.NotificationClass)]

Declaration Syntax
C# Visual Basic Visual C++
void NotificationAdded(
    ref Server server,
    NotificationClass n
)
Sub NotificationAdded ( _
    ByRef server As Server, _
    n As NotificationClass _
)
void NotificationAdded(
    Server^% server,
    NotificationClass^ n
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Notifications.__Notifications.NotificationAdded(VisualCronAPI.Server@,VisualCron.NotificationClass)"]

n (NotificationClass)

[Missing <param name="n"/> documentation for "M:VisualCronAPI.Notifications.__Notifications.NotificationAdded(VisualCronAPI.Server@,VisualCron.NotificationClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationRemoved Method (server, n)

NotificationRemoved Method (server, n)
Namespaces ► VisualCronAPI ► Notifications..::.__Notifications ► NotificationRemoved(Server%, NotificationClass)

[Missing <summary> documentation for M:VisualCronAPI.Notifications.__Notifications.NotificationRemoved(VisualCronAPI.Server@,VisualCron.NotificationClass)]

Declaration Syntax
C# Visual Basic Visual C++
void NotificationRemoved(
    ref Server server,
    NotificationClass n
)
Sub NotificationRemoved ( _
    ByRef server As Server, _
    n As NotificationClass _
)
void NotificationRemoved(
    Server^% server,
    NotificationClass^ n
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Notifications.__Notifications.NotificationRemoved(VisualCronAPI.Server@,VisualCron.NotificationClass)"]

n (NotificationClass)

[Missing <param name="n"/> documentation for "M:VisualCronAPI.Notifications.__Notifications.NotificationRemoved(VisualCronAPI.Server@,VisualCron.NotificationClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NotificationUpdated Method (server, n)

NotificationUpdated Method (server, n)
Namespaces ► VisualCronAPI ► Notifications..::.__Notifications ► NotificationUpdated(Server%, NotificationClass)

[Missing <summary> documentation for M:VisualCronAPI.Notifications.__Notifications.NotificationUpdated(VisualCronAPI.Server@,VisualCron.NotificationClass)]

Declaration Syntax
C# Visual Basic Visual C++
void NotificationUpdated(
    ref Server server,
    NotificationClass n
)
Sub NotificationUpdated ( _
    ByRef server As Server, _
    n As NotificationClass _
)
void NotificationUpdated(
    Server^% server,
    NotificationClass^ n
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Notifications.__Notifications.NotificationUpdated(VisualCronAPI.Server@,VisualCron.NotificationClass)"]

n (NotificationClass)

[Missing <param name="n"/> documentation for "M:VisualCronAPI.Notifications.__Notifications.NotificationUpdated(VisualCronAPI.Server@,VisualCron.NotificationClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications._Notifications Interface

Notifications..::._Notifications Interface
Namespaces ► VisualCronAPI ► Notifications ► Notifications..::._Notifications

[Missing <summary> documentation for T:VisualCronAPI.Notifications._Notifications]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Notifications
Public Interface _Notifications
public interface class _Notifications
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(NotificationClass) |
 | Contains(String) |
 | Get(String) |
 | GetAllArray()()() |
 | Remove(NotificationClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | Update(NotificationClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (n)

Add Method (n)
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► Add(NotificationClass)

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.Add(VisualCron.NotificationClass)]

Declaration Syntax
C# Visual Basic Visual C++
NotificationClass Add(
    NotificationClass n
)
Function Add ( _
    n As NotificationClass _
) As NotificationClass
NotificationClass^ Add(
    NotificationClass^ n
)
Parameters
n (NotificationClass)

[Missing <param name="n"/> documentation for "M:VisualCronAPI.Notifications._Notifications.Add(VisualCron.NotificationClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications._Notifications.Add(VisualCron.NotificationClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strId)

Contains Method (strId)
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string strId
)
Function Contains ( _
    strId As String _
) As Boolean
bool Contains(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Notifications._Notifications.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications._Notifications.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
NotificationClass Get(
    string id
)
Function Get ( _
    id As String _
) As NotificationClass
NotificationClass^ Get(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Notifications._Notifications.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications._Notifications.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications._Notifications.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► Remove()()()
Members
Icon | Member | Description
 | Remove(NotificationClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (NotificationId)

Remove Method (NotificationId)
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string NotificationId
)
Function Remove ( _
    NotificationId As String _
) As Boolean
bool Remove(
    String^ NotificationId
)
Parameters
NotificationId (String)

[Missing <param name="NotificationId"/> documentation for "M:VisualCronAPI.Notifications._Notifications.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications._Notifications.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (n)

Remove Method (n)
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► Remove(NotificationClass)

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.Remove(VisualCron.NotificationClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    NotificationClass n
)
Function Remove ( _
    n As NotificationClass _
) As Boolean
bool Remove(
    NotificationClass^ n
)
Parameters
n (NotificationClass)

[Missing <param name="n"/> documentation for "M:VisualCronAPI.Notifications._Notifications.Remove(VisualCron.NotificationClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications._Notifications.Remove(VisualCron.NotificationClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (n)

Update Method (n)
Namespaces ► VisualCronAPI ► Notifications..::._Notifications ► Update(NotificationClass)

[Missing <summary> documentation for M:VisualCronAPI.Notifications._Notifications.Update(VisualCron.NotificationClass)]

Declaration Syntax
C# Visual Basic Visual C++
NotificationClass Update(
    NotificationClass n
)
Function Update ( _
    n As NotificationClass _
) As NotificationClass
NotificationClass^ Update(
    NotificationClass^ n
)
Parameters
n (NotificationClass)

[Missing <param name="n"/> documentation for "M:VisualCronAPI.Notifications._Notifications.Update(VisualCron.NotificationClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Notifications._Notifications.Update(VisualCron.NotificationClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications.DelegateNotificationAdded Delegate

Notifications..::.DelegateNotificationAdded Delegate
Namespaces ► VisualCronAPI ► Notifications ► Notifications..::.DelegateNotificationAdded

[Missing <summary> documentation for T:VisualCronAPI.Notifications.DelegateNotificationAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateNotificationAdded(
    ref Server server,
    NotificationClass n
)
Public Delegate Sub DelegateNotificationAdded ( _
    ByRef server As Server, _
    n As NotificationClass _
)
public delegate void DelegateNotificationAdded(
    Server^% server,
    NotificationClass^ n
)
Parameters
server ( Server %)
n (NotificationClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications.DelegateNotificationRemoved Delegate

Notifications..::.DelegateNotificationRemoved Delegate
Namespaces ► VisualCronAPI ► Notifications ► Notifications..::.DelegateNotificationRemoved

[Missing <summary> documentation for T:VisualCronAPI.Notifications.DelegateNotificationRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateNotificationRemoved(
    ref Server server,
    NotificationClass n
)
Public Delegate Sub DelegateNotificationRemoved ( _
    ByRef server As Server, _
    n As NotificationClass _
)
public delegate void DelegateNotificationRemoved(
    Server^% server,
    NotificationClass^ n
)
Parameters
server ( Server %)
n (NotificationClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications.DelegateNotificationUpdated Delegate

Notifications..::.DelegateNotificationUpdated Delegate
Namespaces ► VisualCronAPI ► Notifications ► Notifications..::.DelegateNotificationUpdated

[Missing <summary> documentation for T:VisualCronAPI.Notifications.DelegateNotificationUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateNotificationUpdated(
    ref Server server,
    NotificationClass n
)
Public Delegate Sub DelegateNotificationUpdated ( _
    ByRef server As Server, _
    n As NotificationClass _
)
public delegate void DelegateNotificationUpdated(
    Server^% server,
    NotificationClass^ n
)
Parameters
server ( Server %)
n (NotificationClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications.DelegateTrayPopup Delegate

Notifications..::.DelegateTrayPopup Delegate
Namespaces ► VisualCronAPI ► Notifications ► Notifications..::.DelegateTrayPopup

[Missing <summary> documentation for T:VisualCronAPI.Notifications.DelegateTrayPopup]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTrayPopup(
    ref Server server,
    TrayPopupInfoClass tpi
)
Public Delegate Sub DelegateTrayPopup ( _
    ByRef server As Server, _
    tpi As TrayPopupInfoClass _
)
public delegate void DelegateTrayPopup(
    Server^% server,
    TrayPopupInfoClass^ tpi
)
Parameters
server ( Server %)
tpi (TrayPopupInfoClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications.NotificationNotFoundException Class

Notifications..::.NotificationNotFoundException Class
Namespaces ► VisualCronAPI ► Notifications ► Notifications..::.NotificationNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Notifications.NotificationNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class NotificationNotFoundException : Exception
Public Class NotificationNotFoundException _
    Inherits Exception
public ref class NotificationNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Notifications..::.NotificationNotFoundException(String) | Initializes a new instance of the Notifications..::.NotificationNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Notifications..::.NotificationNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications.NotificationNotFoundException Constructor (id)

Notifications..::.NotificationNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Notifications..::.NotificationNotFoundException ► Notifications..::.NotificationNotFoundException(String)
Initializes a new instance of the Notifications..::.NotificationNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public NotificationNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
NotificationNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Notifications.NotificationNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


OpenProxyClass Class

OpenProxyClass Class
Namespaces ► VisualCronAPI ► OpenProxyClass

[Missing <summary> documentation for T:VisualCronAPI.OpenProxyClass]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class OpenProxyClass
<SerializableAttribute> _
Public Class OpenProxyClass
[SerializableAttribute]
public ref class OpenProxyClass
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | OpenProxyClass()()() | Initializes a new instance of the OpenProxyClass class
 | Domain |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Host |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PassWord |
 | Port |
 | ProxyToOpenProxy(ProxyClass) |
 | ProxyType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseCredentials |
 | UserName |
Inheritance Hierarchy
Object
OpenProxyClass

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


OpenProxyClass Constructor

OpenProxyClass Constructor
Namespaces ► VisualCronAPI ► OpenProxyClass ► OpenProxyClass()()()
Initializes a new instance of the OpenProxyClass class
Declaration Syntax
C# Visual Basic Visual C++
public OpenProxyClass()
Public Sub New
public:
OpenProxyClass()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Domain Property

Domain Property
Namespaces ► VisualCronAPI ► OpenProxyClass ► Domain

[Missing <summary> documentation for P:VisualCronAPI.OpenProxyClass.Domain]

Declaration Syntax
C# Visual Basic Visual C++
public string Domain { get; set; }
Public Property Domain As String
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Host Property

Host Property
Namespaces ► VisualCronAPI ► OpenProxyClass ► Host

[Missing <summary> documentation for P:VisualCronAPI.OpenProxyClass.Host]

Declaration Syntax
C# Visual Basic Visual C++
public string Host { get; set; }
Public Property Host As String
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PassWord Property

PassWord Property
Namespaces ► VisualCronAPI ► OpenProxyClass ► PassWord

[Missing <summary> documentation for P:VisualCronAPI.OpenProxyClass.PassWord]

Declaration Syntax
C# Visual Basic Visual C++
public string PassWord { get; set; }
Public Property PassWord As String
public:
property String^ PassWord {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Port Property

Port Property
Namespaces ► VisualCronAPI ► OpenProxyClass ► Port

[Missing <summary> documentation for P:VisualCronAPI.OpenProxyClass.Port]

Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
property int Port {
    int get ();
    void set (int value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ProxyToOpenProxy Method (pc)

ProxyToOpenProxy Method (pc)
Namespaces ► VisualCronAPI ► OpenProxyClass ► ProxyToOpenProxy(ProxyClass)

[Missing <summary> documentation for M:VisualCronAPI.OpenProxyClass.ProxyToOpenProxy(VisualCron.ProxyClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void ProxyToOpenProxy(
    ProxyClass pc
)
Public Sub ProxyToOpenProxy ( _
    pc As ProxyClass _
)
public:
void ProxyToOpenProxy(
    ProxyClass^ pc
)
Parameters
pc (ProxyClass)

[Missing <param name="pc"/> documentation for "M:VisualCronAPI.OpenProxyClass.ProxyToOpenProxy(VisualCron.ProxyClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ProxyType Field

ProxyType Field
Namespaces ► VisualCronAPI ► OpenProxyClass ► ProxyType

[Missing <summary> documentation for F:VisualCronAPI.OpenProxyClass.ProxyType]

Declaration Syntax
C# Visual Basic Visual C++
public OpenProxyClass..::.ProxyT ProxyType
Public ProxyType As OpenProxyClass..::.ProxyT
public:
OpenProxyClass..::.ProxyT ProxyType

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UseCredentials Property

UseCredentials Property
Namespaces ► VisualCronAPI ► OpenProxyClass ► UseCredentials

[Missing <summary> documentation for P:VisualCronAPI.OpenProxyClass.UseCredentials]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseCredentials { get; set; }
Public Property UseCredentials As Boolean
public:
property bool UseCredentials {
    bool get ();
    void set (bool value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserName Property

UserName Property
Namespaces ► VisualCronAPI ► OpenProxyClass ► UserName

[Missing <summary> documentation for P:VisualCronAPI.OpenProxyClass.UserName]

Declaration Syntax
C# Visual Basic Visual C++
public string UserName { get; set; }
Public Property UserName As String
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


OpenProxyClass.ProxyT Enumeration

OpenProxyClass..::.ProxyT Enumeration
Namespaces ► VisualCronAPI ► OpenProxyClass ► OpenProxyClass..::.ProxyT

[Missing <summary> documentation for T:VisualCronAPI.OpenProxyClass.ProxyT]

Declaration Syntax
C# Visual Basic Visual C++
public enum ProxyT
Public Enumeration ProxyT
public enum class ProxyT
Members
Member | Description
NoProxy |
HTTP |
SOCKS4 |
SOCKS5 |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PdhCategory Class

PdhCategory Class
Namespaces ► VisualCronAPI ► PdhCategory

[Missing <summary> documentation for T:VisualCronAPI.PdhCategory]

Declaration Syntax
C# Visual Basic Visual C++
public class PdhCategory
Public Class PdhCategory
public ref class PdhCategory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CategoryName |
 | Counters |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetCategories()()() |
 | GetCategories(String) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instances |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PdhCategory

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CategoryName Property

CategoryName Property
Namespaces ► VisualCronAPI ► PdhCategory ► CategoryName

[Missing <summary> documentation for P:VisualCronAPI.PdhCategory.CategoryName]

Declaration Syntax
C# Visual Basic Visual C++
public string CategoryName { get; }
Public ReadOnly Property CategoryName As String
public:
property String^ CategoryName {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Counters Property

Counters Property
Namespaces ► VisualCronAPI ► PdhCategory ► Counters

[Missing <summary> documentation for P:VisualCronAPI.PdhCategory.Counters]

Declaration Syntax
C# Visual Basic Visual C++
public ICollection<string> Counters { get; }
Public ReadOnly Property Counters As ICollection(Of String)
public:
property ICollection<String^>^ Counters {
    ICollection<String^>^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCategories Method

GetCategories Method
Namespaces ► VisualCronAPI ► PdhCategory ► GetCategories()()()
Members
Icon | Member | Description
 | GetCategories()()() |
 | GetCategories(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCategories Method

GetCategories Method
Namespaces ► VisualCronAPI ► PdhCategory ► GetCategories()()()

[Missing <summary> documentation for M:VisualCronAPI.PdhCategory.GetCategories]

Declaration Syntax
C# Visual Basic Visual C++
public static ICollection<PdhCategory> GetCategories()
Public Shared Function GetCategories As ICollection(Of PdhCategory)
public:
static ICollection<PdhCategory^>^ GetCategories()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.PdhCategory.GetCategories]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCategories Method (machineName)

GetCategories Method (machineName)
Namespaces ► VisualCronAPI ► PdhCategory ► GetCategories(String)

[Missing <summary> documentation for M:VisualCronAPI.PdhCategory.GetCategories(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static ICollection<PdhCategory> GetCategories(
    string machineName
)
Public Shared Function GetCategories ( _
    machineName As String _
) As ICollection(Of PdhCategory)
public:
static ICollection<PdhCategory^>^ GetCategories(
    String^ machineName
)
Parameters
machineName (String)

[Missing <param name="machineName"/> documentation for "M:VisualCronAPI.PdhCategory.GetCategories(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PdhCategory.GetCategories(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Instances Property

Instances Property
Namespaces ► VisualCronAPI ► PdhCategory ► Instances

[Missing <summary> documentation for P:VisualCronAPI.PdhCategory.Instances]

Declaration Syntax
C# Visual Basic Visual C++
public ICollection<string> Instances { get; }
Public ReadOnly Property Instances As ICollection(Of String)
public:
property ICollection<String^>^ Instances {
    ICollection<String^>^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions Class

Permissions Class
Namespaces ► VisualCronAPI ► Permissions
Base class for Permission Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Permissions : Permissions..::._Permissions
Public Class Permissions _
    Implements Permissions..::._Permissions
public ref class Permissions : Permissions..::._Permissions
Members
All Members | Methods | Events
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(SecUserClass) | Adds a User
 | Check(SecSettingClass..::.SecSettingT) |
 | Contains(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a User based on the string key Id
 | GetAll()()() | Returns an list of Users
 | GetAllArray()()() | Returns an array of Users
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetUserName(String) |
 | GetUserName(ClientConnectionClass) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(SecUserClass) | Removes a User
 | Remove(String) | Removes a User
 | RemoveAll()()() | Removes all Users
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(SecUserClass) | Updates a User
 | UserAdded | This event is raised when a User has been added
 | UserAddedStatic | This event is raised when a User has been added
 | UserRemoved | This event is raised when a User has been removed
 | UserRemovedStatic | This event is raised when a User has been removed
 | UserUpdated | This event is raised when a User has been updated
 | UserUpdatedStatic | This event is raised when a User has been updated
Remarks
Inheritance Hierarchy
Object
Permissions

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (u)

Add Method (u)
Namespaces ► VisualCronAPI ► Permissions ► Add(SecUserClass)
Adds a User
Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass Add(
    SecUserClass u
)
Public Function Add ( _
    u As SecUserClass _
) As SecUserClass
public:
virtual SecUserClass^ Add(
    SecUserClass^ u
) sealed
Parameters
u (SecUserClass)
A SecUserClass object
Return Value
a User
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Check Method (sst)

Check Method (sst)
Namespaces ► VisualCronAPI ► Permissions ► Check(SecSettingClass..::.SecSettingT)

[Missing <summary> documentation for M:VisualCronAPI.Permissions.Check(VisualCron.SecSettingClass.SecSettingT)]

Declaration Syntax
C# Visual Basic Visual C++
public Permissions..::.PermissionResultT Check(
    SecSettingClass..::.SecSettingT sst
)
Public Function Check ( _
    sst As SecSettingClass..::.SecSettingT _
) As Permissions..::.PermissionResultT
public:
virtual Permissions..::.PermissionResultT Check(
    SecSettingClass..::.SecSettingT sst
) sealed
Parameters
sst (SecSettingClass..::.SecSettingT)

[Missing <param name="sst"/> documentation for "M:VisualCronAPI.Permissions.Check(VisualCron.SecSettingClass.SecSettingT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.Check(VisualCron.SecSettingClass.SecSettingT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strId)

Contains Method (strId)
Namespaces ► VisualCronAPI ► Permissions ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.Permissions.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strId
)
Public Function Contains ( _
    strId As String _
) As Boolean
public:
virtual bool Contains(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Permissions.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (userId)

Get Method (userId)
Namespaces ► VisualCronAPI ► Permissions ► Get(String)
Returns a User based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass Get(
    string userId
)
Public Function Get ( _
    userId As String _
) As SecUserClass
public:
virtual SecUserClass^ Get(
    String^ userId
) sealed
Parameters
userId (String)
string key
Return Value
a User
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► Permissions ► GetAll()()()
Returns an list of Users
Declaration Syntax
C# Visual Basic Visual C++
public List<SecUserClass> GetAll()
Public Function GetAll As List(Of SecUserClass)
public:
List<SecUserClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Permissions ► GetAllArray()()()
Returns an array of Users
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetUserName Method

GetUserName Method
Namespaces ► VisualCronAPI ► Permissions ► GetUserName()()()
Members
Icon | Member | Description
 | GetUserName(String) |
 | GetUserName(ClientConnectionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetUserName Method (userId)

GetUserName Method (userId)
Namespaces ► VisualCronAPI ► Permissions ► GetUserName(String)

[Missing <summary> documentation for M:VisualCronAPI.Permissions.GetUserName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetUserName(
    string userId
)
Public Function GetUserName ( _
    userId As String _
) As String
public:
virtual String^ GetUserName(
    String^ userId
) sealed
Parameters
userId (String)

[Missing <param name="userId"/> documentation for "M:VisualCronAPI.Permissions.GetUserName(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.GetUserName(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetUserName Method (cc)

GetUserName Method (cc)
Namespaces ► VisualCronAPI ► Permissions ► GetUserName(ClientConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions.GetUserName(VisualCron.ClientConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetUserName(
    ClientConnectionClass cc
)
Public Function GetUserName ( _
    cc As ClientConnectionClass _
) As String
public:
virtual String^ GetUserName(
    ClientConnectionClass^ cc
) sealed
Parameters
cc (ClientConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Permissions.GetUserName(VisualCron.ClientConnectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.GetUserName(VisualCron.ClientConnectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Permissions ► Remove()()()
Members
Icon | Member | Description
 | Remove(SecUserClass) | Removes a User
 | Remove(String) | Removes a User

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (userId)

Remove Method (userId)
Namespaces ► VisualCronAPI ► Permissions ► Remove(String)
Removes a User
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string userId
)
Public Function Remove ( _
    userId As String _
) As Boolean
public:
virtual bool Remove(
    String^ userId
) sealed
Parameters
userId (String)
Id of User
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (u)

Remove Method (u)
Namespaces ► VisualCronAPI ► Permissions ► Remove(SecUserClass)
Removes a User
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    SecUserClass u
)
Public Function Remove ( _
    u As SecUserClass _
) As Boolean
public:
virtual bool Remove(
    SecUserClass^ u
) sealed
Parameters
u (SecUserClass)
a User
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions.Remove(VisualCron.SecUserClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Permissions ► RemoveAll()()()
Removes all Users
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (u)

Update Method (u)
Namespaces ► VisualCronAPI ► Permissions ► Update(SecUserClass)
Updates a User
Declaration Syntax
C# Visual Basic Visual C++
public SecUserClass Update(
    SecUserClass u
)
Public Function Update ( _
    u As SecUserClass _
) As SecUserClass
public:
virtual SecUserClass^ Update(
    SecUserClass^ u
) sealed
Parameters
u (SecUserClass)
A SecUserClass object
Return Value
a User
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserAdded Event

UserAdded Event
Namespaces ► VisualCronAPI ► Permissions ► UserAdded
This event is raised when a User has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Permissions..::.DelegateUserAdded UserAdded
Public Event UserAdded As Permissions..::.DelegateUserAdded
public:
 event Permissions..::.DelegateUserAdded^ UserAdded {
    void add (Permissions..::.DelegateUserAdded^ value);
    void remove (Permissions..::.DelegateUserAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserAddedStatic Event

UserAddedStatic Event
Namespaces ► VisualCronAPI ► Permissions ► UserAddedStatic
This event is raised when a User has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Permissions..::.DelegateUserAdded UserAddedStatic
Public Shared Event UserAddedStatic As Permissions..::.DelegateUserAdded
public:
static  event Permissions..::.DelegateUserAdded^ UserAddedStatic {
    void add (Permissions..::.DelegateUserAdded^ value);
    void remove (Permissions..::.DelegateUserAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserRemoved Event

UserRemoved Event
Namespaces ► VisualCronAPI ► Permissions ► UserRemoved
This event is raised when a User has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Permissions..::.DelegateUserRemoved UserRemoved
Public Event UserRemoved As Permissions..::.DelegateUserRemoved
public:
 event Permissions..::.DelegateUserRemoved^ UserRemoved {
    void add (Permissions..::.DelegateUserRemoved^ value);
    void remove (Permissions..::.DelegateUserRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserRemovedStatic Event

UserRemovedStatic Event
Namespaces ► VisualCronAPI ► Permissions ► UserRemovedStatic
This event is raised when a User has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Permissions..::.DelegateUserRemoved UserRemovedStatic
Public Shared Event UserRemovedStatic As Permissions..::.DelegateUserRemoved
public:
static  event Permissions..::.DelegateUserRemoved^ UserRemovedStatic {
    void add (Permissions..::.DelegateUserRemoved^ value);
    void remove (Permissions..::.DelegateUserRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserUpdated Event

UserUpdated Event
Namespaces ► VisualCronAPI ► Permissions ► UserUpdated
This event is raised when a User has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Permissions..::.DelegateUserUpdated UserUpdated
Public Event UserUpdated As Permissions..::.DelegateUserUpdated
public:
 event Permissions..::.DelegateUserUpdated^ UserUpdated {
    void add (Permissions..::.DelegateUserUpdated^ value);
    void remove (Permissions..::.DelegateUserUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserUpdatedStatic Event

UserUpdatedStatic Event
Namespaces ► VisualCronAPI ► Permissions ► UserUpdatedStatic
This event is raised when a User has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Permissions..::.DelegateUserUpdated UserUpdatedStatic
Public Shared Event UserUpdatedStatic As Permissions..::.DelegateUserUpdated
public:
static  event Permissions..::.DelegateUserUpdated^ UserUpdatedStatic {
    void add (Permissions..::.DelegateUserUpdated^ value);
    void remove (Permissions..::.DelegateUserUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.__Permissions Interface

Permissions..::.__Permissions Interface
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::.__Permissions

[Missing <summary> documentation for T:VisualCronAPI.Permissions.__Permissions]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Permissions
Public Interface __Permissions
public interface class __Permissions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | UserAdded(Server%, SecUserClass) |
 | UserRemoved(Server%, SecUserClass) |
 | UserUpdated(Server%, SecUserClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserAdded Method (server, suc)

UserAdded Method (server, suc)
Namespaces ► VisualCronAPI ► Permissions..::.__Permissions ► UserAdded(Server%, SecUserClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions.__Permissions.UserAdded(VisualCronAPI.Server@,VisualCron.SecUserClass)]

Declaration Syntax
C# Visual Basic Visual C++
void UserAdded(
    ref Server server,
    SecUserClass suc
)
Sub UserAdded ( _
    ByRef server As Server, _
    suc As SecUserClass _
)
void UserAdded(
    Server^% server,
    SecUserClass^ suc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Permissions.__Permissions.UserAdded(VisualCronAPI.Server@,VisualCron.SecUserClass)"]

suc (SecUserClass)

[Missing <param name="suc"/> documentation for "M:VisualCronAPI.Permissions.__Permissions.UserAdded(VisualCronAPI.Server@,VisualCron.SecUserClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserRemoved Method (server, suc)

UserRemoved Method (server, suc)
Namespaces ► VisualCronAPI ► Permissions..::.__Permissions ► UserRemoved(Server%, SecUserClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions.__Permissions.UserRemoved(VisualCronAPI.Server@,VisualCron.SecUserClass)]

Declaration Syntax
C# Visual Basic Visual C++
void UserRemoved(
    ref Server server,
    SecUserClass suc
)
Sub UserRemoved ( _
    ByRef server As Server, _
    suc As SecUserClass _
)
void UserRemoved(
    Server^% server,
    SecUserClass^ suc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Permissions.__Permissions.UserRemoved(VisualCronAPI.Server@,VisualCron.SecUserClass)"]

suc (SecUserClass)

[Missing <param name="suc"/> documentation for "M:VisualCronAPI.Permissions.__Permissions.UserRemoved(VisualCronAPI.Server@,VisualCron.SecUserClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserUpdated Method (server, suc)

UserUpdated Method (server, suc)
Namespaces ► VisualCronAPI ► Permissions..::.__Permissions ► UserUpdated(Server%, SecUserClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions.__Permissions.UserUpdated(VisualCronAPI.Server@,VisualCron.SecUserClass)]

Declaration Syntax
C# Visual Basic Visual C++
void UserUpdated(
    ref Server server,
    SecUserClass suc
)
Sub UserUpdated ( _
    ByRef server As Server, _
    suc As SecUserClass _
)
void UserUpdated(
    Server^% server,
    SecUserClass^ suc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Permissions.__Permissions.UserUpdated(VisualCronAPI.Server@,VisualCron.SecUserClass)"]

suc (SecUserClass)

[Missing <param name="suc"/> documentation for "M:VisualCronAPI.Permissions.__Permissions.UserUpdated(VisualCronAPI.Server@,VisualCron.SecUserClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions._Permissions Interface

Permissions..::._Permissions Interface
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::._Permissions

[Missing <summary> documentation for T:VisualCronAPI.Permissions._Permissions]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Permissions
Public Interface _Permissions
public interface class _Permissions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(SecUserClass) |
 | Check(SecSettingClass..::.SecSettingT) |
 | Contains(String) |
 | Get(String) |
 | GetAllArray()()() |
 | GetUserName(String) |
 | GetUserName(ClientConnectionClass) |
 | Remove(SecUserClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | Update(SecUserClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (u)

Add Method (u)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Add(SecUserClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.Add(VisualCron.SecUserClass)]

Declaration Syntax
C# Visual Basic Visual C++
SecUserClass Add(
    SecUserClass u
)
Function Add ( _
    u As SecUserClass _
) As SecUserClass
SecUserClass^ Add(
    SecUserClass^ u
)
Parameters
u (SecUserClass)

[Missing <param name="u"/> documentation for "M:VisualCronAPI.Permissions._Permissions.Add(VisualCron.SecUserClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.Add(VisualCron.SecUserClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Check Method (sst)

Check Method (sst)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Check(SecSettingClass..::.SecSettingT)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.Check(VisualCron.SecSettingClass.SecSettingT)]

Declaration Syntax
C# Visual Basic Visual C++
Permissions..::.PermissionResultT Check(
    SecSettingClass..::.SecSettingT sst
)
Function Check ( _
    sst As SecSettingClass..::.SecSettingT _
) As Permissions..::.PermissionResultT
Permissions..::.PermissionResultT Check(
    SecSettingClass..::.SecSettingT sst
)
Parameters
sst (SecSettingClass..::.SecSettingT)

[Missing <param name="sst"/> documentation for "M:VisualCronAPI.Permissions._Permissions.Check(VisualCron.SecSettingClass.SecSettingT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.Check(VisualCron.SecSettingClass.SecSettingT)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strId)

Contains Method (strId)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string strId
)
Function Contains ( _
    strId As String _
) As Boolean
bool Contains(
    String^ strId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.Permissions._Permissions.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (userId)

Get Method (userId)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
SecUserClass Get(
    string userId
)
Function Get ( _
    userId As String _
) As SecUserClass
SecUserClass^ Get(
    String^ userId
)
Parameters
userId (String)

[Missing <param name="userId"/> documentation for "M:VisualCronAPI.Permissions._Permissions.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetUserName Method

GetUserName Method
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► GetUserName()()()
Members
Icon | Member | Description
 | GetUserName(String) |
 | GetUserName(ClientConnectionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetUserName Method (userId)

GetUserName Method (userId)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► GetUserName(String)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.GetUserName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetUserName(
    string userId
)
Function GetUserName ( _
    userId As String _
) As String
String^ GetUserName(
    String^ userId
)
Parameters
userId (String)

[Missing <param name="userId"/> documentation for "M:VisualCronAPI.Permissions._Permissions.GetUserName(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.GetUserName(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetUserName Method (cc)

GetUserName Method (cc)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► GetUserName(ClientConnectionClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.GetUserName(VisualCron.ClientConnectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
string GetUserName(
    ClientConnectionClass cc
)
Function GetUserName ( _
    cc As ClientConnectionClass _
) As String
String^ GetUserName(
    ClientConnectionClass^ cc
)
Parameters
cc (ClientConnectionClass)

[Missing <param name="cc"/> documentation for "M:VisualCronAPI.Permissions._Permissions.GetUserName(VisualCron.ClientConnectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.GetUserName(VisualCron.ClientConnectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Remove()()()
Members
Icon | Member | Description
 | Remove(SecUserClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (userId)

Remove Method (userId)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string userId
)
Function Remove ( _
    userId As String _
) As Boolean
bool Remove(
    String^ userId
)
Parameters
userId (String)

[Missing <param name="userId"/> documentation for "M:VisualCronAPI.Permissions._Permissions.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (u)

Remove Method (u)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Remove(SecUserClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.Remove(VisualCron.SecUserClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    SecUserClass u
)
Function Remove ( _
    u As SecUserClass _
) As Boolean
bool Remove(
    SecUserClass^ u
)
Parameters
u (SecUserClass)

[Missing <param name="u"/> documentation for "M:VisualCronAPI.Permissions._Permissions.Remove(VisualCron.SecUserClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.Remove(VisualCron.SecUserClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (u)

Update Method (u)
Namespaces ► VisualCronAPI ► Permissions..::._Permissions ► Update(SecUserClass)

[Missing <summary> documentation for M:VisualCronAPI.Permissions._Permissions.Update(VisualCron.SecUserClass)]

Declaration Syntax
C# Visual Basic Visual C++
SecUserClass Update(
    SecUserClass u
)
Function Update ( _
    u As SecUserClass _
) As SecUserClass
SecUserClass^ Update(
    SecUserClass^ u
)
Parameters
u (SecUserClass)

[Missing <param name="u"/> documentation for "M:VisualCronAPI.Permissions._Permissions.Update(VisualCron.SecUserClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Permissions._Permissions.Update(VisualCron.SecUserClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.DelegateUserAdded Delegate

Permissions..::.DelegateUserAdded Delegate
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::.DelegateUserAdded

[Missing <summary> documentation for T:VisualCronAPI.Permissions.DelegateUserAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateUserAdded(
    ref Server server,
    SecUserClass suc
)
Public Delegate Sub DelegateUserAdded ( _
    ByRef server As Server, _
    suc As SecUserClass _
)
public delegate void DelegateUserAdded(
    Server^% server,
    SecUserClass^ suc
)
Parameters
server ( Server %)
suc (SecUserClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.DelegateUserRemoved Delegate

Permissions..::.DelegateUserRemoved Delegate
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::.DelegateUserRemoved

[Missing <summary> documentation for T:VisualCronAPI.Permissions.DelegateUserRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateUserRemoved(
    ref Server server,
    SecUserClass suc
)
Public Delegate Sub DelegateUserRemoved ( _
    ByRef server As Server, _
    suc As SecUserClass _
)
public delegate void DelegateUserRemoved(
    Server^% server,
    SecUserClass^ suc
)
Parameters
server ( Server %)
suc (SecUserClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.DelegateUserUpdated Delegate

Permissions..::.DelegateUserUpdated Delegate
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::.DelegateUserUpdated

[Missing <summary> documentation for T:VisualCronAPI.Permissions.DelegateUserUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateUserUpdated(
    ref Server server,
    SecUserClass suc
)
Public Delegate Sub DelegateUserUpdated ( _
    ByRef server As Server, _
    suc As SecUserClass _
)
public delegate void DelegateUserUpdated(
    Server^% server,
    SecUserClass^ suc
)
Parameters
server ( Server %)
suc (SecUserClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.PermissionDeniedException Class

Permissions..::.PermissionDeniedException Class
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::.PermissionDeniedException
Is throwed when User lacks permission for the current operation
Declaration Syntax
C# Visual Basic Visual C++
public class PermissionDeniedException : Exception
Public Class PermissionDeniedException _
    Inherits Exception
public ref class PermissionDeniedException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Permissions..::.PermissionDeniedException()()() | Initializes a new instance of the Permissions..::.PermissionDeniedException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Permissions..::.PermissionDeniedException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.PermissionDeniedException Constructor

Permissions..::.PermissionDeniedException Constructor
Namespaces ► VisualCronAPI ► Permissions..::.PermissionDeniedException ► Permissions..::.PermissionDeniedException()()()
Initializes a new instance of the Permissions..::.PermissionDeniedException class
Declaration Syntax
C# Visual Basic Visual C++
public PermissionDeniedException()
Public Sub New
public:
PermissionDeniedException()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.PermissionResultT Enumeration

Permissions..::.PermissionResultT Enumeration
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::.PermissionResultT

[Missing <summary> documentation for T:VisualCronAPI.Permissions.PermissionResultT]

Declaration Syntax
C# Visual Basic Visual C++
public enum PermissionResultT
Public Enumeration PermissionResultT
public enum class PermissionResultT
Members
Member | Description
Granted |
Denied |
TrialExpired |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.UserNotFoundException Class

Permissions..::.UserNotFoundException Class
Namespaces ► VisualCronAPI ► Permissions ► Permissions..::.UserNotFoundException
Is throwed when User is not found
Declaration Syntax
C# Visual Basic Visual C++
public class UserNotFoundException : Exception
Public Class UserNotFoundException _
    Inherits Exception
public ref class UserNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Permissions..::.UserNotFoundException(String) | Initializes a new instance of the Permissions..::.UserNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Permissions..::.UserNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions.UserNotFoundException Constructor (strUserId)

Permissions..::.UserNotFoundException Constructor (strUserId)
Namespaces ► VisualCronAPI ► Permissions..::.UserNotFoundException ► Permissions..::.UserNotFoundException(String)
Initializes a new instance of the Permissions..::.UserNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public UserNotFoundException(
    string strUserId
)
Public Sub New ( _
    strUserId As String _
)
public:
UserNotFoundException(
    String^ strUserId
)
Parameters
strUserId (String)

[Missing <param name="strUserId"/> documentation for "M:VisualCronAPI.Permissions.UserNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings Class

PGPKeyRings Class
Namespaces ► VisualCronAPI ► PGPKeyRings
Base class for PGPKeyRings Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class PGPKeyRings : PGPKeyRings..::._PGPKeyRings
Public Class PGPKeyRings _
    Implements PGPKeyRings..::._PGPKeyRings
public ref class PGPKeyRings : PGPKeyRings..::._PGPKeyRings
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PGPKeyRings(Server) | Initializes a new instance of the PGPKeyRings class
 | Add(PGPKeyRingClass) | Adds a PGPKeyRing
 | Contains(String) | Returns true if specified Key Ring Id exists
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a PGPKeyRingClass based on the string key
 | GetAll()()() | Returns an list of PGPKeyRings
 | GetAllArray()()() | Returns an array of PGPKeyRings
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PGPKeyRingAdded | This event is raised when a PGPKeyRing has been added
 | PGPKeyRingAddedStatic | This event is raised when a PGPKeyRing has been added
 | PGPKeyRingRemoved | This event is raised when a PGPKeyRing has been removed
 | PGPKeyRingRemovedStatic | This event is raised when a PGPKeyRing has been removed
 | PGPKeyRingUpdated | This event is raised when a PGPKeyRing has been updated
 | PGPKeyRingUpdatedStatic | This event is raised when a PGPKeyRing has been updated
 | Remove(PGPKeyRingClass) | Removes a PGPKeyRing
 | Remove(String) | Removes a PGPKeyRing
 | RemoveAll()()() | Removes all PGP Key Rings
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(PGPKeyRingClass) | Updates a PGPKeyRing
Remarks
Inheritance Hierarchy
Object
PGPKeyRings

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings Constructor (s)

PGPKeyRings Constructor (s)
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRings(Server)
Initializes a new instance of the PGPKeyRings class
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRings(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
PGPKeyRings(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.PGPKeyRings.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (pkrc)

Add Method (pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings ► Add(PGPKeyRingClass)
Adds a PGPKeyRing
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingClass Add(
    PGPKeyRingClass pkrc
)
Public Function Add ( _
    pkrc As PGPKeyRingClass _
) As PGPKeyRingClass
public:
virtual PGPKeyRingClass^ Add(
    PGPKeyRingClass^ pkrc
) sealed
Parameters
pkrc (PGPKeyRingClass)
A PGPKeyRingClass object
Return Value
a PGPKeyRingClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strPGPKeyRingId)

Contains Method (strPGPKeyRingId)
Namespaces ► VisualCronAPI ► PGPKeyRings ► Contains(String)
Returns true if specified Key Ring Id exists
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strPGPKeyRingId
)
Public Function Contains ( _
    strPGPKeyRingId As String _
) As Boolean
public:
virtual bool Contains(
    String^ strPGPKeyRingId
) sealed
Parameters
strPGPKeyRingId (String)

[Missing <param name="strPGPKeyRingId"/> documentation for "M:VisualCronAPI.PGPKeyRings.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (strPGPKeyRingId)

Get Method (strPGPKeyRingId)
Namespaces ► VisualCronAPI ► PGPKeyRings ► Get(String)
Returns a PGPKeyRingClass based on the string key
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingClass Get(
    string strPGPKeyRingId
)
Public Function Get ( _
    strPGPKeyRingId As String _
) As PGPKeyRingClass
public:
virtual PGPKeyRingClass^ Get(
    String^ strPGPKeyRingId
) sealed
Parameters
strPGPKeyRingId (String)

[Missing <param name="strPGPKeyRingId"/> documentation for "M:VisualCronAPI.PGPKeyRings.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings.Get(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► PGPKeyRings ► GetAll()()()
Returns an list of PGPKeyRings
Declaration Syntax
C# Visual Basic Visual C++
public List<PGPKeyRingClass> GetAll()
Public Function GetAll As List(Of PGPKeyRingClass)
public:
List<PGPKeyRingClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► PGPKeyRings ► GetAllArray()()()
Returns an array of PGPKeyRings
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingAdded Event

PGPKeyRingAdded Event
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRingAdded
This event is raised when a PGPKeyRing has been added
Declaration Syntax
C# Visual Basic Visual C++
public event PGPKeyRings..::.DelegatePGPKeyRingAdded PGPKeyRingAdded
Public Event PGPKeyRingAdded As PGPKeyRings..::.DelegatePGPKeyRingAdded
public:
 event PGPKeyRings..::.DelegatePGPKeyRingAdded^ PGPKeyRingAdded {
    void add (PGPKeyRings..::.DelegatePGPKeyRingAdded^ value);
    void remove (PGPKeyRings..::.DelegatePGPKeyRingAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingAddedStatic Event

PGPKeyRingAddedStatic Event
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRingAddedStatic
This event is raised when a PGPKeyRing has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event PGPKeyRings..::.DelegatePGPKeyRingAdded PGPKeyRingAddedStatic
Public Shared Event PGPKeyRingAddedStatic As PGPKeyRings..::.DelegatePGPKeyRingAdded
public:
static  event PGPKeyRings..::.DelegatePGPKeyRingAdded^ PGPKeyRingAddedStatic {
    void add (PGPKeyRings..::.DelegatePGPKeyRingAdded^ value);
    void remove (PGPKeyRings..::.DelegatePGPKeyRingAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingRemoved Event

PGPKeyRingRemoved Event
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRingRemoved
This event is raised when a PGPKeyRing has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event PGPKeyRings..::.DelegatePGPKeyRingRemoved PGPKeyRingRemoved
Public Event PGPKeyRingRemoved As PGPKeyRings..::.DelegatePGPKeyRingRemoved
public:
 event PGPKeyRings..::.DelegatePGPKeyRingRemoved^ PGPKeyRingRemoved {
    void add (PGPKeyRings..::.DelegatePGPKeyRingRemoved^ value);
    void remove (PGPKeyRings..::.DelegatePGPKeyRingRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingRemovedStatic Event

PGPKeyRingRemovedStatic Event
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRingRemovedStatic
This event is raised when a PGPKeyRing has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event PGPKeyRings..::.DelegatePGPKeyRingRemoved PGPKeyRingRemovedStatic
Public Shared Event PGPKeyRingRemovedStatic As PGPKeyRings..::.DelegatePGPKeyRingRemoved
public:
static  event PGPKeyRings..::.DelegatePGPKeyRingRemoved^ PGPKeyRingRemovedStatic {
    void add (PGPKeyRings..::.DelegatePGPKeyRingRemoved^ value);
    void remove (PGPKeyRings..::.DelegatePGPKeyRingRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingUpdated Event

PGPKeyRingUpdated Event
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRingUpdated
This event is raised when a PGPKeyRing has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event PGPKeyRings..::.DelegatePGPKeyRingUpdated PGPKeyRingUpdated
Public Event PGPKeyRingUpdated As PGPKeyRings..::.DelegatePGPKeyRingUpdated
public:
 event PGPKeyRings..::.DelegatePGPKeyRingUpdated^ PGPKeyRingUpdated {
    void add (PGPKeyRings..::.DelegatePGPKeyRingUpdated^ value);
    void remove (PGPKeyRings..::.DelegatePGPKeyRingUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingUpdatedStatic Event

PGPKeyRingUpdatedStatic Event
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRingUpdatedStatic
This event is raised when a PGPKeyRing has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event PGPKeyRings..::.DelegatePGPKeyRingUpdated PGPKeyRingUpdatedStatic
Public Shared Event PGPKeyRingUpdatedStatic As PGPKeyRings..::.DelegatePGPKeyRingUpdated
public:
static  event PGPKeyRings..::.DelegatePGPKeyRingUpdated^ PGPKeyRingUpdatedStatic {
    void add (PGPKeyRings..::.DelegatePGPKeyRingUpdated^ value);
    void remove (PGPKeyRings..::.DelegatePGPKeyRingUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► PGPKeyRings ► Remove()()()
Members
Icon | Member | Description
 | Remove(PGPKeyRingClass) | Removes a PGPKeyRing
 | Remove(String) | Removes a PGPKeyRing

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (strPGPKeyRingId)

Remove Method (strPGPKeyRingId)
Namespaces ► VisualCronAPI ► PGPKeyRings ► Remove(String)
Removes a PGPKeyRing
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string strPGPKeyRingId
)
Public Function Remove ( _
    strPGPKeyRingId As String _
) As Boolean
public:
virtual bool Remove(
    String^ strPGPKeyRingId
) sealed
Parameters
strPGPKeyRingId (String)
Id of PGPKeyRing
Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (pkrc)

Remove Method (pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings ► Remove(PGPKeyRingClass)
Removes a PGPKeyRing
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    PGPKeyRingClass pkrc
)
Public Function Remove ( _
    pkrc As PGPKeyRingClass _
) As Boolean
public:
virtual bool Remove(
    PGPKeyRingClass^ pkrc
) sealed
Parameters
pkrc (PGPKeyRingClass)
a PGPKeyRing
Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings.Remove(VisualCron.PGPKeyRingClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► PGPKeyRings ► RemoveAll()()()
Removes all PGP Key Rings
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (pkrc)

Update Method (pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings ► Update(PGPKeyRingClass)
Updates a PGPKeyRing
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingClass Update(
    PGPKeyRingClass pkrc
)
Public Function Update ( _
    pkrc As PGPKeyRingClass _
) As PGPKeyRingClass
public:
virtual PGPKeyRingClass^ Update(
    PGPKeyRingClass^ pkrc
) sealed
Parameters
pkrc (PGPKeyRingClass)
A PGPKeyRingClass object
Return Value
a PGPKeyRingClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings.__PGPKeyRings Interface

PGPKeyRings..::.__PGPKeyRings Interface
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRings..::.__PGPKeyRings

[Missing <summary> documentation for T:VisualCronAPI.PGPKeyRings.__PGPKeyRings]

Declaration Syntax
C# Visual Basic Visual C++
public interface __PGPKeyRings
Public Interface __PGPKeyRings
public interface class __PGPKeyRings
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PGPKeyRingAdded(Server%, PGPKeyRingClass) |
 | PGPKeyRingRemoved(Server%, PGPKeyRingClass) |
 | PGPKeyRingUpdated(Server%, PGPKeyRingClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingAdded Method (server, pkrc)

PGPKeyRingAdded Method (server, pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings..::.__PGPKeyRings ► PGPKeyRingAdded(Server%, PGPKeyRingClass)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingAdded(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)]

Declaration Syntax
C# Visual Basic Visual C++
void PGPKeyRingAdded(
    ref Server server,
    PGPKeyRingClass pkrc
)
Sub PGPKeyRingAdded ( _
    ByRef server As Server, _
    pkrc As PGPKeyRingClass _
)
void PGPKeyRingAdded(
    Server^% server,
    PGPKeyRingClass^ pkrc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingAdded(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)"]

pkrc (PGPKeyRingClass)

[Missing <param name="pkrc"/> documentation for "M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingAdded(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingRemoved Method (server, pkrc)

PGPKeyRingRemoved Method (server, pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings..::.__PGPKeyRings ► PGPKeyRingRemoved(Server%, PGPKeyRingClass)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingRemoved(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)]

Declaration Syntax
C# Visual Basic Visual C++
void PGPKeyRingRemoved(
    ref Server server,
    PGPKeyRingClass pkrc
)
Sub PGPKeyRingRemoved ( _
    ByRef server As Server, _
    pkrc As PGPKeyRingClass _
)
void PGPKeyRingRemoved(
    Server^% server,
    PGPKeyRingClass^ pkrc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingRemoved(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)"]

pkrc (PGPKeyRingClass)

[Missing <param name="pkrc"/> documentation for "M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingRemoved(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRingUpdated Method (server, pkrc)

PGPKeyRingUpdated Method (server, pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings..::.__PGPKeyRings ► PGPKeyRingUpdated(Server%, PGPKeyRingClass)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingUpdated(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)]

Declaration Syntax
C# Visual Basic Visual C++
void PGPKeyRingUpdated(
    ref Server server,
    PGPKeyRingClass pkrc
)
Sub PGPKeyRingUpdated ( _
    ByRef server As Server, _
    pkrc As PGPKeyRingClass _
)
void PGPKeyRingUpdated(
    Server^% server,
    PGPKeyRingClass^ pkrc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingUpdated(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)"]

pkrc (PGPKeyRingClass)

[Missing <param name="pkrc"/> documentation for "M:VisualCronAPI.PGPKeyRings.__PGPKeyRings.PGPKeyRingUpdated(VisualCronAPI.Server@,VisualCron.PGPKeyRingClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings._PGPKeyRings Interface

PGPKeyRings..::._PGPKeyRings Interface
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRings..::._PGPKeyRings

[Missing <summary> documentation for T:VisualCronAPI.PGPKeyRings._PGPKeyRings]

Declaration Syntax
C# Visual Basic Visual C++
public interface _PGPKeyRings
Public Interface _PGPKeyRings
public interface class _PGPKeyRings
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(PGPKeyRingClass) |
 | Contains(String) |
 | Get(String) |
 | GetAllArray()()() |
 | Remove(PGPKeyRingClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | Update(PGPKeyRingClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (pkrc)

Add Method (pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► Add(PGPKeyRingClass)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Add(VisualCron.PGPKeyRingClass)]

Declaration Syntax
C# Visual Basic Visual C++
PGPKeyRingClass Add(
    PGPKeyRingClass pkrc
)
Function Add ( _
    pkrc As PGPKeyRingClass _
) As PGPKeyRingClass
PGPKeyRingClass^ Add(
    PGPKeyRingClass^ pkrc
)
Parameters
pkrc (PGPKeyRingClass)

[Missing <param name="pkrc"/> documentation for "M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Add(VisualCron.PGPKeyRingClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Add(VisualCron.PGPKeyRingClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strPGPKeyRingId)

Contains Method (strPGPKeyRingId)
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string strPGPKeyRingId
)
Function Contains ( _
    strPGPKeyRingId As String _
) As Boolean
bool Contains(
    String^ strPGPKeyRingId
)
Parameters
strPGPKeyRingId (String)

[Missing <param name="strPGPKeyRingId"/> documentation for "M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (strPGPKeyRingId)

Get Method (strPGPKeyRingId)
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
PGPKeyRingClass Get(
    string strPGPKeyRingId
)
Function Get ( _
    strPGPKeyRingId As String _
) As PGPKeyRingClass
PGPKeyRingClass^ Get(
    String^ strPGPKeyRingId
)
Parameters
strPGPKeyRingId (String)

[Missing <param name="strPGPKeyRingId"/> documentation for "M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► Remove()()()
Members
Icon | Member | Description
 | Remove(PGPKeyRingClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (strPGPKeyRingId)

Remove Method (strPGPKeyRingId)
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string strPGPKeyRingId
)
Function Remove ( _
    strPGPKeyRingId As String _
) As Boolean
bool Remove(
    String^ strPGPKeyRingId
)
Parameters
strPGPKeyRingId (String)

[Missing <param name="strPGPKeyRingId"/> documentation for "M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (pkrc)

Remove Method (pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► Remove(PGPKeyRingClass)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Remove(VisualCron.PGPKeyRingClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    PGPKeyRingClass pkrc
)
Function Remove ( _
    pkrc As PGPKeyRingClass _
) As Boolean
bool Remove(
    PGPKeyRingClass^ pkrc
)
Parameters
pkrc (PGPKeyRingClass)

[Missing <param name="pkrc"/> documentation for "M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Remove(VisualCron.PGPKeyRingClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Remove(VisualCron.PGPKeyRingClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (pkrc)

Update Method (pkrc)
Namespaces ► VisualCronAPI ► PGPKeyRings..::._PGPKeyRings ► Update(PGPKeyRingClass)

[Missing <summary> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Update(VisualCron.PGPKeyRingClass)]

Declaration Syntax
C# Visual Basic Visual C++
PGPKeyRingClass Update(
    PGPKeyRingClass pkrc
)
Function Update ( _
    pkrc As PGPKeyRingClass _
) As PGPKeyRingClass
PGPKeyRingClass^ Update(
    PGPKeyRingClass^ pkrc
)
Parameters
pkrc (PGPKeyRingClass)

[Missing <param name="pkrc"/> documentation for "M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Update(VisualCron.PGPKeyRingClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.PGPKeyRings._PGPKeyRings.Update(VisualCron.PGPKeyRingClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings.DelegatePGPKeyRingAdded Delegate

PGPKeyRings..::.DelegatePGPKeyRingAdded Delegate
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRings..::.DelegatePGPKeyRingAdded

[Missing <summary> documentation for T:VisualCronAPI.PGPKeyRings.DelegatePGPKeyRingAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegatePGPKeyRingAdded(
    ref Server server,
    PGPKeyRingClass pkrc
)
Public Delegate Sub DelegatePGPKeyRingAdded ( _
    ByRef server As Server, _
    pkrc As PGPKeyRingClass _
)
public delegate void DelegatePGPKeyRingAdded(
    Server^% server,
    PGPKeyRingClass^ pkrc
)
Parameters
server ( Server %)
pkrc (PGPKeyRingClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings.DelegatePGPKeyRingRemoved Delegate

PGPKeyRings..::.DelegatePGPKeyRingRemoved Delegate
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRings..::.DelegatePGPKeyRingRemoved

[Missing <summary> documentation for T:VisualCronAPI.PGPKeyRings.DelegatePGPKeyRingRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegatePGPKeyRingRemoved(
    ref Server server,
    PGPKeyRingClass pkrc
)
Public Delegate Sub DelegatePGPKeyRingRemoved ( _
    ByRef server As Server, _
    pkrc As PGPKeyRingClass _
)
public delegate void DelegatePGPKeyRingRemoved(
    Server^% server,
    PGPKeyRingClass^ pkrc
)
Parameters
server ( Server %)
pkrc (PGPKeyRingClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings.DelegatePGPKeyRingUpdated Delegate

PGPKeyRings..::.DelegatePGPKeyRingUpdated Delegate
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRings..::.DelegatePGPKeyRingUpdated

[Missing <summary> documentation for T:VisualCronAPI.PGPKeyRings.DelegatePGPKeyRingUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegatePGPKeyRingUpdated(
    ref Server server,
    PGPKeyRingClass pkrc
)
Public Delegate Sub DelegatePGPKeyRingUpdated ( _
    ByRef server As Server, _
    pkrc As PGPKeyRingClass _
)
public delegate void DelegatePGPKeyRingUpdated(
    Server^% server,
    PGPKeyRingClass^ pkrc
)
Parameters
server ( Server %)
pkrc (PGPKeyRingClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings.PGPKeyRingNotFoundException Class

PGPKeyRings..::.PGPKeyRingNotFoundException Class
Namespaces ► VisualCronAPI ► PGPKeyRings ► PGPKeyRings..::.PGPKeyRingNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.PGPKeyRings.PGPKeyRingNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class PGPKeyRingNotFoundException : Exception
Public Class PGPKeyRingNotFoundException _
    Inherits Exception
public ref class PGPKeyRingNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PGPKeyRings..::.PGPKeyRingNotFoundException(String) | Initializes a new instance of the PGPKeyRings..::.PGPKeyRingNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | PGPKeyRings..::.PGPKeyRingNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings.PGPKeyRingNotFoundException Constructor (id)

PGPKeyRings..::.PGPKeyRingNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► PGPKeyRings..::.PGPKeyRingNotFoundException ► PGPKeyRings..::.PGPKeyRingNotFoundException(String)
Initializes a new instance of the PGPKeyRings..::.PGPKeyRingNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRingNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
PGPKeyRingNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.PGPKeyRings.PGPKeyRingNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes Class

Processes Class
Namespaces ► VisualCronAPI ► Processes
Base class for Process Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Processes : Processes..::._Processes
Public Class Processes _
    Implements Processes..::._Processes
public ref class Processes : Processes..::._Processes
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Processes(Server) | Initializes a new instance of the Processes class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJobProcess(Int32) | Gets a specific JobProcess
 | GetJobProcesses()()() | Returns a list of all JobProcesses
 | GetJobProcesses(JobClass) | Returns an list of all JobProcesses from a specific Job
 | GetJobProcesses(String) | Returns a list of all JobProcesses from a specific Job
 | GetJobProcessesArray()()() | Returns an array of all JobProcesses
 | GetJobProcessesArray(JobClass) | Returns an array of all JobProcesses from a specific Job
 | GetJobProcessesArray(String) | Returns a list of all JobProcesses from a specific Job
 | GetTaskProcess(Int32) | Gets a specific TaskProcess
 | GetTaskProcesses()()() | Returns an array of all running Tasks
 | GetTaskProcesses(TaskClass) | Gets all TaskProcesses of a specific Task
 | GetTaskProcesses(String) | Gets all TaskProcesses of a specific Task
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsJobRunning(JobClass) | Checks if a certain Job is running or not
 | IsJobRunning(String) | Checks if a certain Job is running or not
 | IsTaskRunning(TaskClass) | Checks if a certain Task is running or not
 | IsTaskRunning(String) | Checks if a certain Task is running or not
 | JobProcessEnded | This event is raised when a JobProcess has been ended
 | JobProcessEndedStatic | This event is raised when a JobProcess has been ended
 | JobProcessStarted | This event is raised when a JobProcess has been started
 | JobProcessStartedStatic | This event is raised when a JobProcess has been started
 | JobProcessUpdated | This event is raised when a JobProcess has been updated
 | KilJobProcess(VCJobProcessClass) |
 | KilJobProcesses(VCJobProcessClass) |
 | KillJobProcess(Int32) |
 | KillJobProcesses(String) |
 | KillTaskProcess(VCTaskProcessClass) |
 | KillTaskProcess(Int32) |
 | KillTaskProcess(KillVCProcessClass) |
 | KillTaskProcesses(VCTaskProcessClass) |
 | KillTaskProcesses(String) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | obProcessUpdatedStatic | This event is raised when a JobProcess has been updated
 | TaskProcessEnded | This event is raised when a TaskProcess has been ended
 | TaskProcessEndedStatic | This event is raised when a TaskProcess has been ended
 | TaskProcessStarted | This event is raised when a TaskProcess has been started
 | TaskProcessStartedStatic | This event is raised when a TaskProcess has been started
 | TaskProcessUpdated | This event is raised when a TaskProcess has been updated
 | TaskProcessUpdatedStatic | This event is raised when a TaskProcess has been updated
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Remarks
Inheritance Hierarchy
Object
Processes

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes Constructor (s)

Processes Constructor (s)
Namespaces ► VisualCronAPI ► Processes ► Processes(Server)
Initializes a new instance of the Processes class
Declaration Syntax
C# Visual Basic Visual C++
public Processes(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
Processes(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Processes.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcess Method (jobProcessId)

GetJobProcess Method (jobProcessId)
Namespaces ► VisualCronAPI ► Processes ► GetJobProcess(Int32)
Gets a specific JobProcess
Declaration Syntax
C# Visual Basic Visual C++
public VCJobProcessClass GetJobProcess(
    int jobProcessId
)
Public Function GetJobProcess ( _
    jobProcessId As Integer _
) As VCJobProcessClass
public:
virtual VCJobProcessClass^ GetJobProcess(
    int jobProcessId
) sealed
Parameters
jobProcessId (Int32)
id of JobProcess
Return Value
VCJobProcessClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcesses Method

GetJobProcesses Method
Namespaces ► VisualCronAPI ► Processes ► GetJobProcesses()()()
Members
Icon | Member | Description
 | GetJobProcesses()()() | Returns a list of all JobProcesses
 | GetJobProcesses(JobClass) | Returns an list of all JobProcesses from a specific Job
 | GetJobProcesses(String) | Returns a list of all JobProcesses from a specific Job

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcesses Method

GetJobProcesses Method
Namespaces ► VisualCronAPI ► Processes ► GetJobProcesses()()()
Returns a list of all JobProcesses
Declaration Syntax
C# Visual Basic Visual C++
public List<VCJobProcessClass> GetJobProcesses()
Public Function GetJobProcesses As List(Of VCJobProcessClass)
public:
List<VCJobProcessClass^>^ GetJobProcesses()
Return Value
list of all JobProcesses
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcesses Method (jobId)

GetJobProcesses Method (jobId)
Namespaces ► VisualCronAPI ► Processes ► GetJobProcesses(String)
Returns a list of all JobProcesses from a specific Job
Declaration Syntax
C# Visual Basic Visual C++
public List<VCJobProcessClass> GetJobProcesses(
    string jobId
)
Public Function GetJobProcesses ( _
    jobId As String _
) As List(Of VCJobProcessClass)
public:
List<VCJobProcessClass^>^ GetJobProcesses(
    String^ jobId
)
Parameters
jobId (String)
id of Job
Return Value
List(Of VCJobProcessClass)
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcesses Method (j)

GetJobProcesses Method (j)
Namespaces ► VisualCronAPI ► Processes ► GetJobProcesses(JobClass)
Returns an list of all JobProcesses from a specific Job
Declaration Syntax
C# Visual Basic Visual C++
public List<VCJobProcessClass> GetJobProcesses(
    JobClass j
)
Public Function GetJobProcesses ( _
    j As JobClass _
) As List(Of VCJobProcessClass)
public:
List<VCJobProcessClass^>^ GetJobProcesses(
    JobClass^ j
)
Parameters
j (JobClass)
a JobClass
Return Value
list of all JobProcesses
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method

GetJobProcessesArray Method
Namespaces ► VisualCronAPI ► Processes ► GetJobProcessesArray()()()
Members
Icon | Member | Description
 | GetJobProcessesArray()()() | Returns an array of all JobProcesses
 | GetJobProcessesArray(JobClass) | Returns an array of all JobProcesses from a specific Job
 | GetJobProcessesArray(String) | Returns a list of all JobProcesses from a specific Job

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method

GetJobProcessesArray Method
Namespaces ► VisualCronAPI ► Processes ► GetJobProcessesArray()()()
Returns an array of all JobProcesses
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetJobProcessesArray()
Public Function GetJobProcessesArray As ArrayList
public:
virtual ArrayList^ GetJobProcessesArray() sealed
Return Value
array of all JobProcesses
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method (jobId)

GetJobProcessesArray Method (jobId)
Namespaces ► VisualCronAPI ► Processes ► GetJobProcessesArray(String)
Returns a list of all JobProcesses from a specific Job
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetJobProcessesArray(
    string jobId
)
Public Function GetJobProcessesArray ( _
    jobId As String _
) As ArrayList
public:
virtual ArrayList^ GetJobProcessesArray(
    String^ jobId
) sealed
Parameters
jobId (String)
id of Job
Return Value
List(Of VCJobProcessClass)
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method (j)

GetJobProcessesArray Method (j)
Namespaces ► VisualCronAPI ► Processes ► GetJobProcessesArray(JobClass)
Returns an array of all JobProcesses from a specific Job
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetJobProcessesArray(
    JobClass j
)
Public Function GetJobProcessesArray ( _
    j As JobClass _
) As ArrayList
public:
virtual ArrayList^ GetJobProcessesArray(
    JobClass^ j
) sealed
Parameters
j (JobClass)
a JobClass
Return Value
array of all JobProcesses
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcess Method (taskProcessId)

GetTaskProcess Method (taskProcessId)
Namespaces ► VisualCronAPI ► Processes ► GetTaskProcess(Int32)
Gets a specific TaskProcess
Declaration Syntax
C# Visual Basic Visual C++
public VCTaskProcessClass GetTaskProcess(
    int taskProcessId
)
Public Function GetTaskProcess ( _
    taskProcessId As Integer _
) As VCTaskProcessClass
public:
virtual VCTaskProcessClass^ GetTaskProcess(
    int taskProcessId
) sealed
Parameters
taskProcessId (Int32)
id of TaskProcess
Return Value
VCTaskProcessClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method

GetTaskProcesses Method
Namespaces ► VisualCronAPI ► Processes ► GetTaskProcesses()()()
Members
Icon | Member | Description
 | GetTaskProcesses()()() | Returns an array of all running Tasks
 | GetTaskProcesses(TaskClass) | Gets all TaskProcesses of a specific Task
 | GetTaskProcesses(String) | Gets all TaskProcesses of a specific Task

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method

GetTaskProcesses Method
Namespaces ► VisualCronAPI ► Processes ► GetTaskProcesses()()()
Returns an array of all running Tasks
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetTaskProcesses()
Public Function GetTaskProcesses As ArrayList
public:
virtual ArrayList^ GetTaskProcesses() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes.GetTaskProcesses]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method (taskId)

GetTaskProcesses Method (taskId)
Namespaces ► VisualCronAPI ► Processes ► GetTaskProcesses(String)
Gets all TaskProcesses of a specific Task
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetTaskProcesses(
    string taskId
)
Public Function GetTaskProcesses ( _
    taskId As String _
) As ArrayList
public:
virtual ArrayList^ GetTaskProcesses(
    String^ taskId
) sealed
Parameters
taskId (String)
Task Id
Return Value
VCTaskProcessClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method (tc)

GetTaskProcesses Method (tc)
Namespaces ► VisualCronAPI ► Processes ► GetTaskProcesses(TaskClass)
Gets all TaskProcesses of a specific Task
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetTaskProcesses(
    TaskClass tc
)
Public Function GetTaskProcesses ( _
    tc As TaskClass _
) As ArrayList
public:
virtual ArrayList^ GetTaskProcesses(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)
TaskClass
Return Value
VCTaskProcessClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsJobRunning Method

IsJobRunning Method
Namespaces ► VisualCronAPI ► Processes ► IsJobRunning()()()
Members
Icon | Member | Description
 | IsJobRunning(JobClass) | Checks if a certain Job is running or not
 | IsJobRunning(String) | Checks if a certain Job is running or not

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsJobRunning Method (jobId)

IsJobRunning Method (jobId)
Namespaces ► VisualCronAPI ► Processes ► IsJobRunning(String)
Checks if a certain Job is running or not
Declaration Syntax
C# Visual Basic Visual C++
public bool IsJobRunning(
    string jobId
)
Public Function IsJobRunning ( _
    jobId As String _
) As Boolean
public:
virtual bool IsJobRunning(
    String^ jobId
) sealed
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Processes.IsJobRunning(System.String)"]

Return Value
true if any instance of Job is running
Remarks
Note that there could be multiple instances of a Job running

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsJobRunning Method (j)

IsJobRunning Method (j)
Namespaces ► VisualCronAPI ► Processes ► IsJobRunning(JobClass)
Checks if a certain Job is running or not
Declaration Syntax
C# Visual Basic Visual C++
public bool IsJobRunning(
    JobClass j
)
Public Function IsJobRunning ( _
    j As JobClass _
) As Boolean
public:
virtual bool IsJobRunning(
    JobClass^ j
) sealed
Parameters
j (JobClass)
a JobClass
Return Value
true if any instance of Job is running
Remarks
Note that there could be multiple instances of a Job running

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTaskRunning Method

IsTaskRunning Method
Namespaces ► VisualCronAPI ► Processes ► IsTaskRunning()()()
Members
Icon | Member | Description
 | IsTaskRunning(TaskClass) | Checks if a certain Task is running or not
 | IsTaskRunning(String) | Checks if a certain Task is running or not

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTaskRunning Method (taskId)

IsTaskRunning Method (taskId)
Namespaces ► VisualCronAPI ► Processes ► IsTaskRunning(String)
Checks if a certain Task is running or not
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTaskRunning(
    string taskId
)
Public Function IsTaskRunning ( _
    taskId As String _
) As Boolean
public:
virtual bool IsTaskRunning(
    String^ taskId
) sealed
Parameters
taskId (String)
id of Task
Return Value
true if any instance of Task is running
Remarks
Note that there could be multiple instances of a Task running

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTaskRunning Method (tc)

IsTaskRunning Method (tc)
Namespaces ► VisualCronAPI ► Processes ► IsTaskRunning(TaskClass)
Checks if a certain Task is running or not
Declaration Syntax
C# Visual Basic Visual C++
public bool IsTaskRunning(
    TaskClass tc
)
Public Function IsTaskRunning ( _
    tc As TaskClass _
) As Boolean
public:
virtual bool IsTaskRunning(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)
a TaskClass
Return Value
true if any instance of Task is running
Remarks
Note that there could be multiple instances of a Task running

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessEnded Event

JobProcessEnded Event
Namespaces ► VisualCronAPI ► Processes ► JobProcessEnded
This event is raised when a JobProcess has been ended
Declaration Syntax
C# Visual Basic Visual C++
public event Processes..::.DelegateJobProcessEnded JobProcessEnded
Public Event JobProcessEnded As Processes..::.DelegateJobProcessEnded
public:
 event Processes..::.DelegateJobProcessEnded^ JobProcessEnded {
    void add (Processes..::.DelegateJobProcessEnded^ value);
    void remove (Processes..::.DelegateJobProcessEnded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessEndedStatic Event

JobProcessEndedStatic Event
Namespaces ► VisualCronAPI ► Processes ► JobProcessEndedStatic
This event is raised when a JobProcess has been ended
Declaration Syntax
C# Visual Basic Visual C++
public static event Processes..::.DelegateJobProcessEnded JobProcessEndedStatic
Public Shared Event JobProcessEndedStatic As Processes..::.DelegateJobProcessEnded
public:
static  event Processes..::.DelegateJobProcessEnded^ JobProcessEndedStatic {
    void add (Processes..::.DelegateJobProcessEnded^ value);
    void remove (Processes..::.DelegateJobProcessEnded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessStarted Event

JobProcessStarted Event
Namespaces ► VisualCronAPI ► Processes ► JobProcessStarted
This event is raised when a JobProcess has been started
Declaration Syntax
C# Visual Basic Visual C++
public event Processes..::.DelegateJobProcessStarted JobProcessStarted
Public Event JobProcessStarted As Processes..::.DelegateJobProcessStarted
public:
 event Processes..::.DelegateJobProcessStarted^ JobProcessStarted {
    void add (Processes..::.DelegateJobProcessStarted^ value);
    void remove (Processes..::.DelegateJobProcessStarted^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessStartedStatic Event

JobProcessStartedStatic Event
Namespaces ► VisualCronAPI ► Processes ► JobProcessStartedStatic
This event is raised when a JobProcess has been started
Declaration Syntax
C# Visual Basic Visual C++
public static event Processes..::.DelegateJobProcessStarted JobProcessStartedStatic
Public Shared Event JobProcessStartedStatic As Processes..::.DelegateJobProcessStarted
public:
static  event Processes..::.DelegateJobProcessStarted^ JobProcessStartedStatic {
    void add (Processes..::.DelegateJobProcessStarted^ value);
    void remove (Processes..::.DelegateJobProcessStarted^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessUpdated Event

JobProcessUpdated Event
Namespaces ► VisualCronAPI ► Processes ► JobProcessUpdated
This event is raised when a JobProcess has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Processes..::.DelegateJobProcessUpdated JobProcessUpdated
Public Event JobProcessUpdated As Processes..::.DelegateJobProcessUpdated
public:
 event Processes..::.DelegateJobProcessUpdated^ JobProcessUpdated {
    void add (Processes..::.DelegateJobProcessUpdated^ value);
    void remove (Processes..::.DelegateJobProcessUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KilJobProcess Method (vcjp)

KilJobProcess Method (vcjp)
Namespaces ► VisualCronAPI ► Processes ► KilJobProcess(VCJobProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KilJobProcess(VisualCron.VCJobProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void KilJobProcess(
    VCJobProcessClass vcjp
)
Public Sub KilJobProcess ( _
    vcjp As VCJobProcessClass _
)
public:
virtual void KilJobProcess(
    VCJobProcessClass^ vcjp
) sealed
Parameters
vcjp (VCJobProcessClass)

[Missing <param name="vcjp"/> documentation for "M:VisualCronAPI.Processes.KilJobProcess(VisualCron.VCJobProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KilJobProcesses Method (vcjp)

KilJobProcesses Method (vcjp)
Namespaces ► VisualCronAPI ► Processes ► KilJobProcesses(VCJobProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KilJobProcesses(VisualCron.VCJobProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void KilJobProcesses(
    VCJobProcessClass vcjp
)
Public Sub KilJobProcesses ( _
    vcjp As VCJobProcessClass _
)
public:
virtual void KilJobProcesses(
    VCJobProcessClass^ vcjp
) sealed
Parameters
vcjp (VCJobProcessClass)

[Missing <param name="vcjp"/> documentation for "M:VisualCronAPI.Processes.KilJobProcesses(VisualCron.VCJobProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillJobProcess Method (VCJobProcessId)

KillJobProcess Method (VCJobProcessId)
Namespaces ► VisualCronAPI ► Processes ► KillJobProcess(Int32)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KillJobProcess(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public void KillJobProcess(
    int VCJobProcessId
)
Public Sub KillJobProcess ( _
    VCJobProcessId As Integer _
)
public:
virtual void KillJobProcess(
    int VCJobProcessId
) sealed
Parameters
VCJobProcessId (Int32)

[Missing <param name="VCJobProcessId"/> documentation for "M:VisualCronAPI.Processes.KillJobProcess(System.Int32)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillJobProcesses Method (jobId)

KillJobProcesses Method (jobId)
Namespaces ► VisualCronAPI ► Processes ► KillJobProcesses(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KillJobProcesses(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void KillJobProcesses(
    string jobId
)
Public Sub KillJobProcesses ( _
    jobId As String _
)
public:
virtual void KillJobProcesses(
    String^ jobId
) sealed
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Processes.KillJobProcesses(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method

KillTaskProcess Method
Namespaces ► VisualCronAPI ► Processes ► KillTaskProcess()()()
Members
Icon | Member | Description
 | KillTaskProcess(VCTaskProcessClass) |
 | KillTaskProcess(Int32) |
 | KillTaskProcess(KillVCProcessClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method (VCTaskProcessId)

KillTaskProcess Method (VCTaskProcessId)
Namespaces ► VisualCronAPI ► Processes ► KillTaskProcess(Int32)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KillTaskProcess(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public void KillTaskProcess(
    int VCTaskProcessId
)
Public Sub KillTaskProcess ( _
    VCTaskProcessId As Integer _
)
public:
virtual void KillTaskProcess(
    int VCTaskProcessId
) sealed
Parameters
VCTaskProcessId (Int32)

[Missing <param name="VCTaskProcessId"/> documentation for "M:VisualCronAPI.Processes.KillTaskProcess(System.Int32)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method (kvcpc)

KillTaskProcess Method (kvcpc)
Namespaces ► VisualCronAPI ► Processes ► KillTaskProcess(KillVCProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KillTaskProcess(VisualCron.KillVCProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void KillTaskProcess(
    KillVCProcessClass kvcpc
)
Public Sub KillTaskProcess ( _
    kvcpc As KillVCProcessClass _
)
public:
virtual void KillTaskProcess(
    KillVCProcessClass^ kvcpc
) sealed
Parameters
kvcpc (KillVCProcessClass)

[Missing <param name="kvcpc"/> documentation for "M:VisualCronAPI.Processes.KillTaskProcess(VisualCron.KillVCProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method (vctp)

KillTaskProcess Method (vctp)
Namespaces ► VisualCronAPI ► Processes ► KillTaskProcess(VCTaskProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KillTaskProcess(VisualCron.VCTaskProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void KillTaskProcess(
    VCTaskProcessClass vctp
)
Public Sub KillTaskProcess ( _
    vctp As VCTaskProcessClass _
)
public:
virtual void KillTaskProcess(
    VCTaskProcessClass^ vctp
) sealed
Parameters
vctp (VCTaskProcessClass)

[Missing <param name="vctp"/> documentation for "M:VisualCronAPI.Processes.KillTaskProcess(VisualCron.VCTaskProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcesses Method

KillTaskProcesses Method
Namespaces ► VisualCronAPI ► Processes ► KillTaskProcesses()()()
Members
Icon | Member | Description
 | KillTaskProcesses(VCTaskProcessClass) |
 | KillTaskProcesses(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcesses Method (taskId)

KillTaskProcesses Method (taskId)
Namespaces ► VisualCronAPI ► Processes ► KillTaskProcesses(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KillTaskProcesses(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void KillTaskProcesses(
    string taskId
)
Public Sub KillTaskProcesses ( _
    taskId As String _
)
public:
virtual void KillTaskProcesses(
    String^ taskId
) sealed
Parameters
taskId (String)

[Missing <param name="taskId"/> documentation for "M:VisualCronAPI.Processes.KillTaskProcesses(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcesses Method (vctp)

KillTaskProcesses Method (vctp)
Namespaces ► VisualCronAPI ► Processes ► KillTaskProcesses(VCTaskProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.KillTaskProcesses(VisualCron.VCTaskProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void KillTaskProcesses(
    VCTaskProcessClass vctp
)
Public Sub KillTaskProcesses ( _
    vctp As VCTaskProcessClass _
)
public:
virtual void KillTaskProcesses(
    VCTaskProcessClass^ vctp
) sealed
Parameters
vctp (VCTaskProcessClass)

[Missing <param name="vctp"/> documentation for "M:VisualCronAPI.Processes.KillTaskProcesses(VisualCron.VCTaskProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


obProcessUpdatedStatic Event

obProcessUpdatedStatic Event
Namespaces ► VisualCronAPI ► Processes ► obProcessUpdatedStatic
This event is raised when a JobProcess has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Processes..::.DelegateJobProcessUpdated obProcessUpdatedStatic
Public Shared Event obProcessUpdatedStatic As Processes..::.DelegateJobProcessUpdated
public:
static  event Processes..::.DelegateJobProcessUpdated^ obProcessUpdatedStatic {
    void add (Processes..::.DelegateJobProcessUpdated^ value);
    void remove (Processes..::.DelegateJobProcessUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessEnded Event

TaskProcessEnded Event
Namespaces ► VisualCronAPI ► Processes ► TaskProcessEnded
This event is raised when a TaskProcess has been ended
Declaration Syntax
C# Visual Basic Visual C++
public event Processes..::.DelegateTaskProcessEnded TaskProcessEnded
Public Event TaskProcessEnded As Processes..::.DelegateTaskProcessEnded
public:
 event Processes..::.DelegateTaskProcessEnded^ TaskProcessEnded {
    void add (Processes..::.DelegateTaskProcessEnded^ value);
    void remove (Processes..::.DelegateTaskProcessEnded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessEndedStatic Event

TaskProcessEndedStatic Event
Namespaces ► VisualCronAPI ► Processes ► TaskProcessEndedStatic
This event is raised when a TaskProcess has been ended
Declaration Syntax
C# Visual Basic Visual C++
public static event Processes..::.DelegateTaskProcessEnded TaskProcessEndedStatic
Public Shared Event TaskProcessEndedStatic As Processes..::.DelegateTaskProcessEnded
public:
static  event Processes..::.DelegateTaskProcessEnded^ TaskProcessEndedStatic {
    void add (Processes..::.DelegateTaskProcessEnded^ value);
    void remove (Processes..::.DelegateTaskProcessEnded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessStarted Event

TaskProcessStarted Event
Namespaces ► VisualCronAPI ► Processes ► TaskProcessStarted
This event is raised when a TaskProcess has been started
Declaration Syntax
C# Visual Basic Visual C++
public event Processes..::.DelegateTaskProcessStarted TaskProcessStarted
Public Event TaskProcessStarted As Processes..::.DelegateTaskProcessStarted
public:
 event Processes..::.DelegateTaskProcessStarted^ TaskProcessStarted {
    void add (Processes..::.DelegateTaskProcessStarted^ value);
    void remove (Processes..::.DelegateTaskProcessStarted^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessStartedStatic Event

TaskProcessStartedStatic Event
Namespaces ► VisualCronAPI ► Processes ► TaskProcessStartedStatic
This event is raised when a TaskProcess has been started
Declaration Syntax
C# Visual Basic Visual C++
public static event Processes..::.DelegateTaskProcessStarted TaskProcessStartedStatic
Public Shared Event TaskProcessStartedStatic As Processes..::.DelegateTaskProcessStarted
public:
static  event Processes..::.DelegateTaskProcessStarted^ TaskProcessStartedStatic {
    void add (Processes..::.DelegateTaskProcessStarted^ value);
    void remove (Processes..::.DelegateTaskProcessStarted^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessUpdated Event

TaskProcessUpdated Event
Namespaces ► VisualCronAPI ► Processes ► TaskProcessUpdated
This event is raised when a TaskProcess has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Processes..::.DelegateTaskProcessUpdated TaskProcessUpdated
Public Event TaskProcessUpdated As Processes..::.DelegateTaskProcessUpdated
public:
 event Processes..::.DelegateTaskProcessUpdated^ TaskProcessUpdated {
    void add (Processes..::.DelegateTaskProcessUpdated^ value);
    void remove (Processes..::.DelegateTaskProcessUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessUpdatedStatic Event

TaskProcessUpdatedStatic Event
Namespaces ► VisualCronAPI ► Processes ► TaskProcessUpdatedStatic
This event is raised when a TaskProcess has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Processes..::.DelegateTaskProcessUpdated TaskProcessUpdatedStatic
Public Shared Event TaskProcessUpdatedStatic As Processes..::.DelegateTaskProcessUpdated
public:
static  event Processes..::.DelegateTaskProcessUpdated^ TaskProcessUpdatedStatic {
    void add (Processes..::.DelegateTaskProcessUpdated^ value);
    void remove (Processes..::.DelegateTaskProcessUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes.__Processes Interface

Processes..::.__Processes Interface
Namespaces ► VisualCronAPI ► Processes ► Processes..::.__Processes

[Missing <summary> documentation for T:VisualCronAPI.Processes.__Processes]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Processes
Public Interface __Processes
public interface class __Processes
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | JobProcessEnded(Server%, VCJobProcessClass) |
 | JobProcessStarted(Server%, VCJobProcessClass) |
 | JobProcessUpdated(Server%, VCJobProcessClass) |
 | TaskProcessEnded(Server%, VCTaskProcessClass) |
 | TaskProcessStarted(Server%, VCTaskProcessClass) |
 | TaskProcessUpdated(Server%, VCTaskProcessClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessEnded Method (server, pc)

JobProcessEnded Method (server, pc)
Namespaces ► VisualCronAPI ► Processes..::.__Processes ► JobProcessEnded(Server%, VCJobProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.__Processes.JobProcessEnded(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void JobProcessEnded(
    ref Server server,
    VCJobProcessClass pc
)
Sub JobProcessEnded ( _
    ByRef server As Server, _
    pc As VCJobProcessClass _
)
void JobProcessEnded(
    Server^% server,
    VCJobProcessClass^ pc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Processes.__Processes.JobProcessEnded(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)"]

pc (VCJobProcessClass)

[Missing <param name="pc"/> documentation for "M:VisualCronAPI.Processes.__Processes.JobProcessEnded(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessStarted Method (server, pc)

JobProcessStarted Method (server, pc)
Namespaces ► VisualCronAPI ► Processes..::.__Processes ► JobProcessStarted(Server%, VCJobProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.__Processes.JobProcessStarted(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void JobProcessStarted(
    ref Server server,
    VCJobProcessClass pc
)
Sub JobProcessStarted ( _
    ByRef server As Server, _
    pc As VCJobProcessClass _
)
void JobProcessStarted(
    Server^% server,
    VCJobProcessClass^ pc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Processes.__Processes.JobProcessStarted(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)"]

pc (VCJobProcessClass)

[Missing <param name="pc"/> documentation for "M:VisualCronAPI.Processes.__Processes.JobProcessStarted(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


JobProcessUpdated Method (server, pc)

JobProcessUpdated Method (server, pc)
Namespaces ► VisualCronAPI ► Processes..::.__Processes ► JobProcessUpdated(Server%, VCJobProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.__Processes.JobProcessUpdated(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void JobProcessUpdated(
    ref Server server,
    VCJobProcessClass pc
)
Sub JobProcessUpdated ( _
    ByRef server As Server, _
    pc As VCJobProcessClass _
)
void JobProcessUpdated(
    Server^% server,
    VCJobProcessClass^ pc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Processes.__Processes.JobProcessUpdated(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)"]

pc (VCJobProcessClass)

[Missing <param name="pc"/> documentation for "M:VisualCronAPI.Processes.__Processes.JobProcessUpdated(VisualCronAPI.Server@,VisualCron.VCJobProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessEnded Method (server, pc)

TaskProcessEnded Method (server, pc)
Namespaces ► VisualCronAPI ► Processes..::.__Processes ► TaskProcessEnded(Server%, VCTaskProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.__Processes.TaskProcessEnded(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TaskProcessEnded(
    ref Server server,
    VCTaskProcessClass pc
)
Sub TaskProcessEnded ( _
    ByRef server As Server, _
    pc As VCTaskProcessClass _
)
void TaskProcessEnded(
    Server^% server,
    VCTaskProcessClass^ pc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Processes.__Processes.TaskProcessEnded(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)"]

pc (VCTaskProcessClass)

[Missing <param name="pc"/> documentation for "M:VisualCronAPI.Processes.__Processes.TaskProcessEnded(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessStarted Method (server, pc)

TaskProcessStarted Method (server, pc)
Namespaces ► VisualCronAPI ► Processes..::.__Processes ► TaskProcessStarted(Server%, VCTaskProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.__Processes.TaskProcessStarted(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TaskProcessStarted(
    ref Server server,
    VCTaskProcessClass pc
)
Sub TaskProcessStarted ( _
    ByRef server As Server, _
    pc As VCTaskProcessClass _
)
void TaskProcessStarted(
    Server^% server,
    VCTaskProcessClass^ pc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Processes.__Processes.TaskProcessStarted(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)"]

pc (VCTaskProcessClass)

[Missing <param name="pc"/> documentation for "M:VisualCronAPI.Processes.__Processes.TaskProcessStarted(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskProcessUpdated Method (server, pc)

TaskProcessUpdated Method (server, pc)
Namespaces ► VisualCronAPI ► Processes..::.__Processes ► TaskProcessUpdated(Server%, VCTaskProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes.__Processes.TaskProcessUpdated(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TaskProcessUpdated(
    ref Server server,
    VCTaskProcessClass pc
)
Sub TaskProcessUpdated ( _
    ByRef server As Server, _
    pc As VCTaskProcessClass _
)
void TaskProcessUpdated(
    Server^% server,
    VCTaskProcessClass^ pc
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Processes.__Processes.TaskProcessUpdated(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)"]

pc (VCTaskProcessClass)

[Missing <param name="pc"/> documentation for "M:VisualCronAPI.Processes.__Processes.TaskProcessUpdated(VisualCronAPI.Server@,VisualCron.VCTaskProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes._Processes Interface

Processes..::._Processes Interface
Namespaces ► VisualCronAPI ► Processes ► Processes..::._Processes

[Missing <summary> documentation for T:VisualCronAPI.Processes._Processes]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Processes
Public Interface _Processes
public interface class _Processes
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetJobProcess(Int32) |
 | GetJobProcessesArray()()() |
 | GetJobProcessesArray(JobClass) |
 | GetJobProcessesArray(String) |
 | GetTaskProcess(Int32) |
 | GetTaskProcesses()()() |
 | GetTaskProcesses(TaskClass) |
 | GetTaskProcesses(String) |
 | IsJobRunning(JobClass) |
 | IsJobRunning(String) |
 | IsTaskRunning(TaskClass) |
 | IsTaskRunning(String) |
 | KilJobProcess(VCJobProcessClass) |
 | KilJobProcesses(VCJobProcessClass) |
 | KillJobProcess(Int32) |
 | KillJobProcesses(String) |
 | KillTaskProcess(VCTaskProcessClass) |
 | KillTaskProcess(Int32) |
 | KillTaskProcess(KillVCProcessClass) |
 | KillTaskProcesses(VCTaskProcessClass) |
 | KillTaskProcesses(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcess Method (jobProcessId)

GetJobProcess Method (jobProcessId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetJobProcess(Int32)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcess(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
VCJobProcessClass GetJobProcess(
    int jobProcessId
)
Function GetJobProcess ( _
    jobProcessId As Integer _
) As VCJobProcessClass
VCJobProcessClass^ GetJobProcess(
    int jobProcessId
)
Parameters
jobProcessId (Int32)

[Missing <param name="jobProcessId"/> documentation for "M:VisualCronAPI.Processes._Processes.GetJobProcess(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcess(System.Int32)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method

GetJobProcessesArray Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetJobProcessesArray()()()
Members
Icon | Member | Description
 | GetJobProcessesArray()()() |
 | GetJobProcessesArray(JobClass) |
 | GetJobProcessesArray(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method

GetJobProcessesArray Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetJobProcessesArray()()()

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcessesArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetJobProcessesArray()
Function GetJobProcessesArray As ArrayList
ArrayList^ GetJobProcessesArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcessesArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method (jobId)

GetJobProcessesArray Method (jobId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetJobProcessesArray(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcessesArray(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetJobProcessesArray(
    string jobId
)
Function GetJobProcessesArray ( _
    jobId As String _
) As ArrayList
ArrayList^ GetJobProcessesArray(
    String^ jobId
)
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Processes._Processes.GetJobProcessesArray(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcessesArray(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobProcessesArray Method (j)

GetJobProcessesArray Method (j)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetJobProcessesArray(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcessesArray(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetJobProcessesArray(
    JobClass j
)
Function GetJobProcessesArray ( _
    j As JobClass _
) As ArrayList
ArrayList^ GetJobProcessesArray(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Processes._Processes.GetJobProcessesArray(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetJobProcessesArray(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcess Method (taskProcessId)

GetTaskProcess Method (taskProcessId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetTaskProcess(Int32)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcess(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
VCTaskProcessClass GetTaskProcess(
    int taskProcessId
)
Function GetTaskProcess ( _
    taskProcessId As Integer _
) As VCTaskProcessClass
VCTaskProcessClass^ GetTaskProcess(
    int taskProcessId
)
Parameters
taskProcessId (Int32)

[Missing <param name="taskProcessId"/> documentation for "M:VisualCronAPI.Processes._Processes.GetTaskProcess(System.Int32)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcess(System.Int32)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method

GetTaskProcesses Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetTaskProcesses()()()
Members
Icon | Member | Description
 | GetTaskProcesses()()() |
 | GetTaskProcesses(TaskClass) |
 | GetTaskProcesses(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method

GetTaskProcesses Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetTaskProcesses()()()

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcesses]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetTaskProcesses()
Function GetTaskProcesses As ArrayList
ArrayList^ GetTaskProcesses()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcesses]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method (taskId)

GetTaskProcesses Method (taskId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetTaskProcesses(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcesses(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetTaskProcesses(
    string taskId
)
Function GetTaskProcesses ( _
    taskId As String _
) As ArrayList
ArrayList^ GetTaskProcesses(
    String^ taskId
)
Parameters
taskId (String)

[Missing <param name="taskId"/> documentation for "M:VisualCronAPI.Processes._Processes.GetTaskProcesses(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcesses(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskProcesses Method (tc)

GetTaskProcesses Method (tc)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► GetTaskProcesses(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcesses(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetTaskProcesses(
    TaskClass tc
)
Function GetTaskProcesses ( _
    tc As TaskClass _
) As ArrayList
ArrayList^ GetTaskProcesses(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Processes._Processes.GetTaskProcesses(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.GetTaskProcesses(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsJobRunning Method

IsJobRunning Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► IsJobRunning()()()
Members
Icon | Member | Description
 | IsJobRunning(JobClass) |
 | IsJobRunning(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsJobRunning Method (jobId)

IsJobRunning Method (jobId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► IsJobRunning(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.IsJobRunning(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool IsJobRunning(
    string jobId
)
Function IsJobRunning ( _
    jobId As String _
) As Boolean
bool IsJobRunning(
    String^ jobId
)
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Processes._Processes.IsJobRunning(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.IsJobRunning(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsJobRunning Method (j)

IsJobRunning Method (j)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► IsJobRunning(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.IsJobRunning(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool IsJobRunning(
    JobClass j
)
Function IsJobRunning ( _
    j As JobClass _
) As Boolean
bool IsJobRunning(
    JobClass^ j
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Processes._Processes.IsJobRunning(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.IsJobRunning(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTaskRunning Method

IsTaskRunning Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► IsTaskRunning()()()
Members
Icon | Member | Description
 | IsTaskRunning(TaskClass) |
 | IsTaskRunning(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTaskRunning Method (taskId)

IsTaskRunning Method (taskId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► IsTaskRunning(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.IsTaskRunning(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool IsTaskRunning(
    string taskId
)
Function IsTaskRunning ( _
    taskId As String _
) As Boolean
bool IsTaskRunning(
    String^ taskId
)
Parameters
taskId (String)

[Missing <param name="taskId"/> documentation for "M:VisualCronAPI.Processes._Processes.IsTaskRunning(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.IsTaskRunning(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsTaskRunning Method (tc)

IsTaskRunning Method (tc)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► IsTaskRunning(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.IsTaskRunning(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool IsTaskRunning(
    TaskClass tc
)
Function IsTaskRunning ( _
    tc As TaskClass _
) As Boolean
bool IsTaskRunning(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Processes._Processes.IsTaskRunning(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Processes._Processes.IsTaskRunning(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KilJobProcess Method (vcjp)

KilJobProcess Method (vcjp)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KilJobProcess(VCJobProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KilJobProcess(VisualCron.VCJobProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void KilJobProcess(
    VCJobProcessClass vcjp
)
Sub KilJobProcess ( _
    vcjp As VCJobProcessClass _
)
void KilJobProcess(
    VCJobProcessClass^ vcjp
)
Parameters
vcjp (VCJobProcessClass)

[Missing <param name="vcjp"/> documentation for "M:VisualCronAPI.Processes._Processes.KilJobProcess(VisualCron.VCJobProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KilJobProcesses Method (vcjp)

KilJobProcesses Method (vcjp)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KilJobProcesses(VCJobProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KilJobProcesses(VisualCron.VCJobProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void KilJobProcesses(
    VCJobProcessClass vcjp
)
Sub KilJobProcesses ( _
    vcjp As VCJobProcessClass _
)
void KilJobProcesses(
    VCJobProcessClass^ vcjp
)
Parameters
vcjp (VCJobProcessClass)

[Missing <param name="vcjp"/> documentation for "M:VisualCronAPI.Processes._Processes.KilJobProcesses(VisualCron.VCJobProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillJobProcess Method (VCJobProcessId)

KillJobProcess Method (VCJobProcessId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillJobProcess(Int32)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KillJobProcess(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
void KillJobProcess(
    int VCJobProcessId
)
Sub KillJobProcess ( _
    VCJobProcessId As Integer _
)
void KillJobProcess(
    int VCJobProcessId
)
Parameters
VCJobProcessId (Int32)

[Missing <param name="VCJobProcessId"/> documentation for "M:VisualCronAPI.Processes._Processes.KillJobProcess(System.Int32)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillJobProcesses Method (jobId)

KillJobProcesses Method (jobId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillJobProcesses(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KillJobProcesses(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void KillJobProcesses(
    string jobId
)
Sub KillJobProcesses ( _
    jobId As String _
)
void KillJobProcesses(
    String^ jobId
)
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Processes._Processes.KillJobProcesses(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method

KillTaskProcess Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillTaskProcess()()()
Members
Icon | Member | Description
 | KillTaskProcess(VCTaskProcessClass) |
 | KillTaskProcess(Int32) |
 | KillTaskProcess(KillVCProcessClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method (VCTaskProcessId)

KillTaskProcess Method (VCTaskProcessId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillTaskProcess(Int32)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KillTaskProcess(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
void KillTaskProcess(
    int VCTaskProcessId
)
Sub KillTaskProcess ( _
    VCTaskProcessId As Integer _
)
void KillTaskProcess(
    int VCTaskProcessId
)
Parameters
VCTaskProcessId (Int32)

[Missing <param name="VCTaskProcessId"/> documentation for "M:VisualCronAPI.Processes._Processes.KillTaskProcess(System.Int32)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method (kvcpc)

KillTaskProcess Method (kvcpc)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillTaskProcess(KillVCProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KillTaskProcess(VisualCron.KillVCProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void KillTaskProcess(
    KillVCProcessClass kvcpc
)
Sub KillTaskProcess ( _
    kvcpc As KillVCProcessClass _
)
void KillTaskProcess(
    KillVCProcessClass^ kvcpc
)
Parameters
kvcpc (KillVCProcessClass)

[Missing <param name="kvcpc"/> documentation for "M:VisualCronAPI.Processes._Processes.KillTaskProcess(VisualCron.KillVCProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcess Method (vctp)

KillTaskProcess Method (vctp)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillTaskProcess(VCTaskProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KillTaskProcess(VisualCron.VCTaskProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void KillTaskProcess(
    VCTaskProcessClass vctp
)
Sub KillTaskProcess ( _
    vctp As VCTaskProcessClass _
)
void KillTaskProcess(
    VCTaskProcessClass^ vctp
)
Parameters
vctp (VCTaskProcessClass)

[Missing <param name="vctp"/> documentation for "M:VisualCronAPI.Processes._Processes.KillTaskProcess(VisualCron.VCTaskProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcesses Method

KillTaskProcesses Method
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillTaskProcesses()()()
Members
Icon | Member | Description
 | KillTaskProcesses(VCTaskProcessClass) |
 | KillTaskProcesses(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcesses Method (taskId)

KillTaskProcesses Method (taskId)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillTaskProcesses(String)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KillTaskProcesses(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void KillTaskProcesses(
    string taskId
)
Sub KillTaskProcesses ( _
    taskId As String _
)
void KillTaskProcesses(
    String^ taskId
)
Parameters
taskId (String)

[Missing <param name="taskId"/> documentation for "M:VisualCronAPI.Processes._Processes.KillTaskProcesses(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


KillTaskProcesses Method (vctp)

KillTaskProcesses Method (vctp)
Namespaces ► VisualCronAPI ► Processes..::._Processes ► KillTaskProcesses(VCTaskProcessClass)

[Missing <summary> documentation for M:VisualCronAPI.Processes._Processes.KillTaskProcesses(VisualCron.VCTaskProcessClass)]

Declaration Syntax
C# Visual Basic Visual C++
void KillTaskProcesses(
    VCTaskProcessClass vctp
)
Sub KillTaskProcesses ( _
    vctp As VCTaskProcessClass _
)
void KillTaskProcesses(
    VCTaskProcessClass^ vctp
)
Parameters
vctp (VCTaskProcessClass)

[Missing <param name="vctp"/> documentation for "M:VisualCronAPI.Processes._Processes.KillTaskProcesses(VisualCron.VCTaskProcessClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes.DelegateJobProcessEnded Delegate

Processes..::.DelegateJobProcessEnded Delegate
Namespaces ► VisualCronAPI ► Processes ► Processes..::.DelegateJobProcessEnded

[Missing <summary> documentation for T:VisualCronAPI.Processes.DelegateJobProcessEnded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateJobProcessEnded(
    ref Server server,
    VCJobProcessClass pc
)
Public Delegate Sub DelegateJobProcessEnded ( _
    ByRef server As Server, _
    pc As VCJobProcessClass _
)
public delegate void DelegateJobProcessEnded(
    Server^% server,
    VCJobProcessClass^ pc
)
Parameters
server ( Server %)
pc (VCJobProcessClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes.DelegateJobProcessStarted Delegate

Processes..::.DelegateJobProcessStarted Delegate
Namespaces ► VisualCronAPI ► Processes ► Processes..::.DelegateJobProcessStarted

[Missing <summary> documentation for T:VisualCronAPI.Processes.DelegateJobProcessStarted]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateJobProcessStarted(
    ref Server server,
    VCJobProcessClass pc
)
Public Delegate Sub DelegateJobProcessStarted ( _
    ByRef server As Server, _
    pc As VCJobProcessClass _
)
public delegate void DelegateJobProcessStarted(
    Server^% server,
    VCJobProcessClass^ pc
)
Parameters
server ( Server %)
pc (VCJobProcessClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes.DelegateJobProcessUpdated Delegate

Processes..::.DelegateJobProcessUpdated Delegate
Namespaces ► VisualCronAPI ► Processes ► Processes..::.DelegateJobProcessUpdated

[Missing <summary> documentation for T:VisualCronAPI.Processes.DelegateJobProcessUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateJobProcessUpdated(
    ref Server server,
    VCJobProcessClass pc
)
Public Delegate Sub DelegateJobProcessUpdated ( _
    ByRef server As Server, _
    pc As VCJobProcessClass _
)
public delegate void DelegateJobProcessUpdated(
    Server^% server,
    VCJobProcessClass^ pc
)
Parameters
server ( Server %)
pc (VCJobProcessClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes.DelegateTaskProcessEnded Delegate

Processes..::.DelegateTaskProcessEnded Delegate
Namespaces ► VisualCronAPI ► Processes ► Processes..::.DelegateTaskProcessEnded

[Missing <summary> documentation for T:VisualCronAPI.Processes.DelegateTaskProcessEnded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTaskProcessEnded(
    ref Server server,
    VCTaskProcessClass pc
)
Public Delegate Sub DelegateTaskProcessEnded ( _
    ByRef server As Server, _
    pc As VCTaskProcessClass _
)
public delegate void DelegateTaskProcessEnded(
    Server^% server,
    VCTaskProcessClass^ pc
)
Parameters
server ( Server %)
pc (VCTaskProcessClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes.DelegateTaskProcessStarted Delegate

Processes..::.DelegateTaskProcessStarted Delegate
Namespaces ► VisualCronAPI ► Processes ► Processes..::.DelegateTaskProcessStarted

[Missing <summary> documentation for T:VisualCronAPI.Processes.DelegateTaskProcessStarted]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTaskProcessStarted(
    ref Server server,
    VCTaskProcessClass pc
)
Public Delegate Sub DelegateTaskProcessStarted ( _
    ByRef server As Server, _
    pc As VCTaskProcessClass _
)
public delegate void DelegateTaskProcessStarted(
    Server^% server,
    VCTaskProcessClass^ pc
)
Parameters
server ( Server %)
pc (VCTaskProcessClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes.DelegateTaskProcessUpdated Delegate

Processes..::.DelegateTaskProcessUpdated Delegate
Namespaces ► VisualCronAPI ► Processes ► Processes..::.DelegateTaskProcessUpdated

[Missing <summary> documentation for T:VisualCronAPI.Processes.DelegateTaskProcessUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTaskProcessUpdated(
    ref Server server,
    VCTaskProcessClass pc
)
Public Delegate Sub DelegateTaskProcessUpdated ( _
    ByRef server As Server, _
    pc As VCTaskProcessClass _
)
public delegate void DelegateTaskProcessUpdated(
    Server^% server,
    VCTaskProcessClass^ pc
)
Parameters
server ( Server %)
pc (VCTaskProcessClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server Class

Server Class
Namespaces ► VisualCronAPI ► Server
A Server object that contains all base objects for the Server
Declaration Syntax
C# Visual Basic Visual C++
public class Server : Server..::._Server
Public Class Server _
    Implements Server..::._Server
public ref class Server : Server..::._Server
Members
All Members | Constructors | Methods | Properties | Fields | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Server()()() | Initializes a new instance of the Server class
 | Active | Gets or sets if Server is active (ready for sending and receiving)
 | AllowLocalConnectionsOnly | Controls if the Server accepts Client connections from outside
 | Authenticated | True if login was successful
 | Certificates | Base object in Server that contain global certificates that can be used in various Tasks
 | Client | Retrieves information about the current Client
 | ClientConnections | Base object in Server that contain information about connected Clients
 | Computer | Base object in Server that contains methods and properties that provide access to the local computer system
 | Conditions | Base object in Server that contain methods and properties of global Conditions
 | Connected | Gets the current connection status of the Server
 | Connection | Gets information about the current Connection between the Client and the Server
 | Connections | Base object in Server that contain methods and properties of global Connections
 | Credentials | Base object in Server that contain methods and properties of global Credentials
 | Disconnect()()() |
 | EIPProgress |
 | EIPProgressStatic |
 | Email | Default settings for email
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Explorer | Base object in Server that helps with remote Explorer
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVar(String) | Gets the value of a given variable string
 | InSync | If Server objects has been transfered to Client or not
 | InvokeControl |
 | IP |
 | Jobs | Base object in Server that contain methods and properties of Jobs and Tasks
 | LanguageId | The language Id used by the Server
 | License | Base object in Server that contain license informatoin
 | LimitOutput | If the output should be limited in size or not
 | LimitOutputSize | The size in bytes which the output should be limited to
 | Log | Base object in Server that contain method and properties concerning logging from the Server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NetworkDrives | Base object in Server that contain methods and properties of global Network drives
 | Notifications | Base object in Server that contain methods and properties of global Notifications
 | On | Gets or sets if the Server should run according to schedule and activate triggers
 | Permissions | Base object in Server that contain methods and properties of permissions
 | PGPKeyRings | Base object in Server that contain methods and properties of PGPKeyRing objects
 | Ping()()() |
 | Port | Gets or sets the port that the Server is listening to, by default 16444
 | Processes | Base object in Server that contains methods and properties concerning running VC processes
 | Protocol | The protocol of the Server
 | Proxy | Outgoing proxy settings for Server
 | RaiseImportExportProgress(ExportImportProgressClass) |
 | Send(Object, Boolean) |
 | SendTestEmail(TestEmailClass) | Sends a test email request
 | ServerId | Unique Id of the Server
 | ServerName | Name of the server
 | ServerTime | Time and date at Server
 | ServerTimeDiff | Tick difference between Server and Client
 | ServerTimeString | Time and date at server (string represenation)
 | Start()()() | Activates the Server (make it run according to schedule)
 | Status | Current connection status of the client
 | Stop()()() | Deactivates the server (disable running according to schedule)
 | TimeExceptions | Base object in Server that contain methods and properties of global Time Exceptions
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UpdateServerSettings(ServerSettingsClass) | Updates the Server settings on the Server
 | UserServerId | Optional value to use to track a Connection to a Server
 | Variables | Base object in Server that contain methods and properties of global Variables
 | Version | Gets the Server version (build)
Remarks
Inheritance Hierarchy
Object
Server

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server Constructor

Server Constructor
Namespaces ► VisualCronAPI ► Server ► Server()()()
Initializes a new instance of the Server class
Declaration Syntax
C# Visual Basic Visual C++
public Server()
Public Sub New
public:
Server()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Active Property

Active Property
Namespaces ► VisualCronAPI ► Server ► Active
Gets or sets if Server is active (ready for sending and receiving)
Declaration Syntax
C# Visual Basic Visual C++
public bool Active { get; set; }
Public Property Active As Boolean
public:
virtual property bool Active {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AllowLocalConnectionsOnly Property

AllowLocalConnectionsOnly Property
Namespaces ► VisualCronAPI ► Server ► AllowLocalConnectionsOnly
Controls if the Server accepts Client connections from outside
Declaration Syntax
C# Visual Basic Visual C++
public bool AllowLocalConnectionsOnly { get; set; }
Public Property AllowLocalConnectionsOnly As Boolean
public:
virtual property bool AllowLocalConnectionsOnly {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Authenticated Property

Authenticated Property
Namespaces ► VisualCronAPI ► Server ► Authenticated
True if login was successful
Declaration Syntax
C# Visual Basic Visual C++
public bool Authenticated { get; internal set; }
Public Property Authenticated As Boolean
public:
virtual property bool Authenticated {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates Property

Certificates Property
Namespaces ► VisualCronAPI ► Server ► Certificates
Base object in Server that contain global certificates that can be used in various Tasks
Declaration Syntax
C# Visual Basic Visual C++
public Certificates Certificates { get; }
Public ReadOnly Property Certificates As Certificates
public:
virtual property Certificates^ Certificates {
    Certificates^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client Property

Client Property
Namespaces ► VisualCronAPI ► Server ► Client
Retrieves information about the current Client
Declaration Syntax
C# Visual Basic Visual C++
public Client Client { get; internal set; }
Public Property Client As Client
public:
virtual property Client^ Client {
    Client^ get () sealed;
    void set (Client^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections Property

ClientConnections Property
Namespaces ► VisualCronAPI ► Server ► ClientConnections
Base object in Server that contain information about connected Clients
Declaration Syntax
C# Visual Basic Visual C++
public ClientConnections ClientConnections { get; set; }
Public Property ClientConnections As ClientConnections
public:
virtual property ClientConnections^ ClientConnections {
    ClientConnections^ get () sealed;
    void set (ClientConnections^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Computer Property

Computer Property
Namespaces ► VisualCronAPI ► Server ► Computer
Base object in Server that contains methods and properties that provide access to the local computer system
Declaration Syntax
C# Visual Basic Visual C++
public Computer Computer { get; }
Public ReadOnly Property Computer As Computer
public:
virtual property Computer^ Computer {
    Computer^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions Property

Conditions Property
Namespaces ► VisualCronAPI ► Server ► Conditions
Base object in Server that contain methods and properties of global Conditions
Declaration Syntax
C# Visual Basic Visual C++
public Conditions Conditions { get; }
Public ReadOnly Property Conditions As Conditions
public:
virtual property Conditions^ Conditions {
    Conditions^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connected Property

Connected Property
Namespaces ► VisualCronAPI ► Server ► Connected
Gets the current connection status of the Server
Declaration Syntax
C# Visual Basic Visual C++
public bool Connected { get; internal set; }
Public Property Connected As Boolean
public:
virtual property bool Connected {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connection Property

Connection Property
Namespaces ► VisualCronAPI ► Server ► Connection
Gets information about the current Connection between the Client and the Server
Declaration Syntax
C# Visual Basic Visual C++
public Connection Connection { get; internal set; }
Public Property Connection As Connection
public:
virtual property Connection^ Connection {
    Connection^ get () sealed;
    void set (Connection^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections Property

Connections Property
Namespaces ► VisualCronAPI ► Server ► Connections
Base object in Server that contain methods and properties of global Connections
Declaration Syntax
C# Visual Basic Visual C++
public Connections Connections { get; }
Public ReadOnly Property Connections As Connections
public:
virtual property Connections^ Connections {
    Connections^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials Property

Credentials Property
Namespaces ► VisualCronAPI ► Server ► Credentials
Base object in Server that contain methods and properties of global Credentials
Declaration Syntax
C# Visual Basic Visual C++
public Credentials Credentials { get; }
Public ReadOnly Property Credentials As Credentials
public:
virtual property Credentials^ Credentials {
    Credentials^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Disconnect Method

Disconnect Method
Namespaces ► VisualCronAPI ► Server ► Disconnect()()()

[Missing <summary> documentation for M:VisualCronAPI.Server.Disconnect]

Declaration Syntax
C# Visual Basic Visual C++
public bool Disconnect()
Public Function Disconnect As Boolean
public:
virtual bool Disconnect() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server.Disconnect]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EIPProgress Event

EIPProgress Event
Namespaces ► VisualCronAPI ► Server ► EIPProgress

[Missing <summary> documentation for E:VisualCronAPI.Server.EIPProgress]

Declaration Syntax
C# Visual Basic Visual C++
public event Server..::.DelegateEIPProgress EIPProgress
Public Event EIPProgress As Server..::.DelegateEIPProgress
public:
 event Server..::.DelegateEIPProgress^ EIPProgress {
    void add (Server..::.DelegateEIPProgress^ value);
    void remove (Server..::.DelegateEIPProgress^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EIPProgressStatic Event

EIPProgressStatic Event
Namespaces ► VisualCronAPI ► Server ► EIPProgressStatic

[Missing <summary> documentation for E:VisualCronAPI.Server.EIPProgressStatic]

Declaration Syntax
C# Visual Basic Visual C++
public static event Server..::.DelegateEIPProgress EIPProgressStatic
Public Shared Event EIPProgressStatic As Server..::.DelegateEIPProgress
public:
static  event Server..::.DelegateEIPProgress^ EIPProgressStatic {
    void add (Server..::.DelegateEIPProgress^ value);
    void remove (Server..::.DelegateEIPProgress^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Email Property

Email Property
Namespaces ► VisualCronAPI ► Server ► Email
Default settings for email
Declaration Syntax
C# Visual Basic Visual C++
public EmailSettings Email { get; set; }
Public Property Email As EmailSettings
public:
virtual property EmailSettings^ Email {
    EmailSettings^ get () sealed;
    void set (EmailSettings^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Explorer Property

Explorer Property
Namespaces ► VisualCronAPI ► Server ► Explorer
Base object in Server that helps with remote Explorer
Declaration Syntax
C# Visual Basic Visual C++
public Explorer Explorer { get; set; }
Public Property Explorer As Explorer
public:
virtual property Explorer^ Explorer {
    Explorer^ get () sealed;
    void set (Explorer^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetVar Method (strVariable)

GetVar Method (strVariable)
Namespaces ► VisualCronAPI ► Server ► GetVar(String)
Gets the value of a given variable string
Declaration Syntax
C# Visual Basic Visual C++
public string GetVar(
    string strVariable
)
Public Function GetVar ( _
    strVariable As String _
) As String
public:
virtual String^ GetVar(
    String^ strVariable
) sealed
Parameters
strVariable (String)

[Missing <param name="strVariable"/> documentation for "M:VisualCronAPI.Server.GetVar(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server.GetVar(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InSync Property

InSync Property
Namespaces ► VisualCronAPI ► Server ► InSync
If Server objects has been transfered to Client or not
Declaration Syntax
C# Visual Basic Visual C++
public bool InSync { get; internal set; }
Public Property InSync As Boolean
public:
virtual property bool InSync {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InvokeControl Field

InvokeControl Field
Namespaces ► VisualCronAPI ► Server ► InvokeControl

[Missing <summary> documentation for F:VisualCronAPI.Server.InvokeControl]

Declaration Syntax
C# Visual Basic Visual C++
public Control InvokeControl
Public InvokeControl As Control
public:
Control^ InvokeControl

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IP Property

IP Property
Namespaces ► VisualCronAPI ► Server ► IP

[Missing <summary> documentation for P:VisualCronAPI.Server.IP]

Declaration Syntax
C# Visual Basic Visual C++
public string IP { get; }
Public ReadOnly Property IP As String
public:
virtual property String^ IP {
    String^ get () sealed;
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs Property

Jobs Property
Namespaces ► VisualCronAPI ► Server ► Jobs
Base object in Server that contain methods and properties of Jobs and Tasks
Declaration Syntax
C# Visual Basic Visual C++
public Jobs Jobs { get; }
Public ReadOnly Property Jobs As Jobs
public:
virtual property Jobs^ Jobs {
    Jobs^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LanguageId Property

LanguageId Property
Namespaces ► VisualCronAPI ► Server ► LanguageId
The language Id used by the Server
Declaration Syntax
C# Visual Basic Visual C++
public int LanguageId { get; set; }
Public Property LanguageId As Integer
public:
virtual property int LanguageId {
    int get () sealed;
    void set (int value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License Property

License Property
Namespaces ► VisualCronAPI ► Server ► License
Base object in Server that contain license informatoin
Declaration Syntax
C# Visual Basic Visual C++
public License License { get; }
Public ReadOnly Property License As License
public:
virtual property License^ License {
    License^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LimitOutput Property

LimitOutput Property
Namespaces ► VisualCronAPI ► Server ► LimitOutput
If the output should be limited in size or not
Declaration Syntax
C# Visual Basic Visual C++
public bool LimitOutput { get; set; }
Public Property LimitOutput As Boolean
public:
virtual property bool LimitOutput {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LimitOutputSize Property

LimitOutputSize Property
Namespaces ► VisualCronAPI ► Server ► LimitOutputSize
The size in bytes which the output should be limited to
Declaration Syntax
C# Visual Basic Visual C++
public int LimitOutputSize { get; set; }
Public Property LimitOutputSize As Integer
public:
virtual property int LimitOutputSize {
    int get () sealed;
    void set (int value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log Property

Log Property
Namespaces ► VisualCronAPI ► Server ► Log
Base object in Server that contain method and properties concerning logging from the Server
Declaration Syntax
C# Visual Basic Visual C++
public Log Log { get; }
Public ReadOnly Property Log As Log
public:
virtual property Log^ Log {
    Log^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives Property

NetworkDrives Property
Namespaces ► VisualCronAPI ► Server ► NetworkDrives
Base object in Server that contain methods and properties of global Network drives
Declaration Syntax
C# Visual Basic Visual C++
public NetworkDrives NetworkDrives { get; }
Public ReadOnly Property NetworkDrives As NetworkDrives
public:
virtual property NetworkDrives^ NetworkDrives {
    NetworkDrives^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications Property

Notifications Property
Namespaces ► VisualCronAPI ► Server ► Notifications
Base object in Server that contain methods and properties of global Notifications
Declaration Syntax
C# Visual Basic Visual C++
public Notifications Notifications { get; }
Public ReadOnly Property Notifications As Notifications
public:
virtual property Notifications^ Notifications {
    Notifications^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


On Property

On Property
Namespaces ► VisualCronAPI ► Server ► On
Gets or sets if the Server should run according to schedule and activate triggers
Declaration Syntax
C# Visual Basic Visual C++
public bool On { get; set; }
Public Property On As Boolean
public:
virtual property bool On {
    bool get () sealed;
    void set (bool value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions Property

Permissions Property
Namespaces ► VisualCronAPI ► Server ► Permissions
Base object in Server that contain methods and properties of permissions
Declaration Syntax
C# Visual Basic Visual C++
public Permissions Permissions { get; }
Public ReadOnly Property Permissions As Permissions
public:
virtual property Permissions^ Permissions {
    Permissions^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings Property

PGPKeyRings Property
Namespaces ► VisualCronAPI ► Server ► PGPKeyRings
Base object in Server that contain methods and properties of PGPKeyRing objects
Declaration Syntax
C# Visual Basic Visual C++
public PGPKeyRings PGPKeyRings { get; }
Public ReadOnly Property PGPKeyRings As PGPKeyRings
public:
virtual property PGPKeyRings^ PGPKeyRings {
    PGPKeyRings^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Ping Method

Ping Method
Namespaces ► VisualCronAPI ► Server ► Ping()()()

[Missing <summary> documentation for M:VisualCronAPI.Server.Ping]

Declaration Syntax
C# Visual Basic Visual C++
public PingClass..::.EnumPingResult Ping()
Public Function Ping As PingClass..::.EnumPingResult
public:
virtual PingClass..::.EnumPingResult Ping() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server.Ping]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Port Property

Port Property
Namespaces ► VisualCronAPI ► Server ► Port
Gets or sets the port that the Server is listening to, by default 16444
Declaration Syntax
C# Visual Basic Visual C++
public int Port { get; set; }
Public Property Port As Integer
public:
virtual property int Port {
    int get () sealed;
    void set (int value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes Property

Processes Property
Namespaces ► VisualCronAPI ► Server ► Processes
Base object in Server that contains methods and properties concerning running VC processes
Declaration Syntax
C# Visual Basic Visual C++
public Processes Processes { get; }
Public ReadOnly Property Processes As Processes
public:
virtual property Processes^ Processes {
    Processes^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Protocol Property

Protocol Property
Namespaces ► VisualCronAPI ► Server ► Protocol
The protocol of the Server
Declaration Syntax
C# Visual Basic Visual C++
public string Protocol { get; set; }
Public Property Protocol As String
public:
virtual property String^ Protocol {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Proxy Property

Proxy Property
Namespaces ► VisualCronAPI ► Server ► Proxy
Outgoing proxy settings for Server
Declaration Syntax
C# Visual Basic Visual C++
public ProxyClass Proxy { get; set; }
Public Property Proxy As ProxyClass
public:
virtual property ProxyClass^ Proxy {
    ProxyClass^ get () sealed;
    void set (ProxyClass^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RaiseImportExportProgress Method (eip)

RaiseImportExportProgress Method (eip)
Namespaces ► VisualCronAPI ► Server ► RaiseImportExportProgress(ExportImportProgressClass)

[Missing <summary> documentation for M:VisualCronAPI.Server.RaiseImportExportProgress(VisualCron.ExportImportProgressClass)]

Declaration Syntax
C# Visual Basic Visual C++
public void RaiseImportExportProgress(
    ExportImportProgressClass eip
)
Public Sub RaiseImportExportProgress ( _
    eip As ExportImportProgressClass _
)
public:
virtual void RaiseImportExportProgress(
    ExportImportProgressClass^ eip
) sealed
Parameters
eip (ExportImportProgressClass)

[Missing <param name="eip"/> documentation for "M:VisualCronAPI.Server.RaiseImportExportProgress(VisualCron.ExportImportProgressClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Send Method (obj, ForceNoCompression)

Send Method (obj, ForceNoCompression)
Namespaces ► VisualCronAPI ► Server ► Send(Object, Boolean)

[Missing <summary> documentation for M:VisualCronAPI.Server.Send(System.Object,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Send(
    Object obj,
    bool ForceNoCompression
)
Public Function Send ( _
    obj As Object, _
    ForceNoCompression As Boolean _
) As Boolean
public:
virtual bool Send(
    Object^ obj,
    bool ForceNoCompression
) sealed
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCronAPI.Server.Send(System.Object,System.Boolean)"]

ForceNoCompression (Boolean)

[Missing <param name="ForceNoCompression"/> documentation for "M:VisualCronAPI.Server.Send(System.Object,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server.Send(System.Object,System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendTestEmail Method (te)

SendTestEmail Method (te)
Namespaces ► VisualCronAPI ► Server ► SendTestEmail(TestEmailClass)
Sends a test email request
Declaration Syntax
C# Visual Basic Visual C++
public void SendTestEmail(
    TestEmailClass te
)
Public Sub SendTestEmail ( _
    te As TestEmailClass _
)
public:
virtual void SendTestEmail(
    TestEmailClass^ te
) sealed
Parameters
te (TestEmailClass)

[Missing <param name="te"/> documentation for "M:VisualCronAPI.Server.SendTestEmail(VisualCron.TestEmailClass)"]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerId Property

ServerId Property
Namespaces ► VisualCronAPI ► Server ► ServerId
Unique Id of the Server
Declaration Syntax
C# Visual Basic Visual C++
public string ServerId { get; internal set; }
Public Property ServerId As String
public:
virtual property String^ ServerId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerName Property

ServerName Property
Namespaces ► VisualCronAPI ► Server ► ServerName
Name of the server
Declaration Syntax
C# Visual Basic Visual C++
public string ServerName { get; internal set; }
Public Property ServerName As String
public:
virtual property String^ ServerName {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerTime Property

ServerTime Property
Namespaces ► VisualCronAPI ► Server ► ServerTime
Time and date at Server
Declaration Syntax
C# Visual Basic Visual C++
public DateTime ServerTime { get; }
Public ReadOnly Property ServerTime As DateTime
public:
virtual property DateTime ServerTime {
    DateTime get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerTimeDiff Property

ServerTimeDiff Property
Namespaces ► VisualCronAPI ► Server ► ServerTimeDiff
Tick difference between Server and Client
Declaration Syntax
C# Visual Basic Visual C++
public long ServerTimeDiff { get; set; }
Public Property ServerTimeDiff As Long
public:
virtual property long long ServerTimeDiff {
    long long get () sealed;
    void set (long long value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerTimeString Property

ServerTimeString Property
Namespaces ► VisualCronAPI ► Server ► ServerTimeString
Time and date at server (string represenation)
Declaration Syntax
C# Visual Basic Visual C++
public string ServerTimeString { get; }
Public ReadOnly Property ServerTimeString As String
public:
virtual property String^ ServerTimeString {
    String^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Start Method

Start Method
Namespaces ► VisualCronAPI ► Server ► Start()()()
Activates the Server (make it run according to schedule)
Declaration Syntax
C# Visual Basic Visual C++
public bool Start()
Public Function Start As Boolean
public:
virtual bool Start() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server.Start]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Status Property

Status Property
Namespaces ► VisualCronAPI ► Server ► Status
Current connection status of the client
Declaration Syntax
C# Visual Basic Visual C++
public Server..::.StatusT Status { get; internal set; }
Public Property Status As Server..::.StatusT
public:
virtual property Server..::.StatusT Status {
    Server..::.StatusT get () sealed;
    void set (Server..::.StatusT value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Stop Method

Stop Method
Namespaces ► VisualCronAPI ► Server ► Stop()()()
Deactivates the server (disable running according to schedule)
Declaration Syntax
C# Visual Basic Visual C++
public bool Stop()
Public Function Stop As Boolean
public:
virtual bool Stop() sealed
Return Value
True on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions Property

TimeExceptions Property
Namespaces ► VisualCronAPI ► Server ► TimeExceptions
Base object in Server that contain methods and properties of global Time Exceptions
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptions TimeExceptions { get; }
Public ReadOnly Property TimeExceptions As TimeExceptions
public:
virtual property TimeExceptions^ TimeExceptions {
    TimeExceptions^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UpdateServerSettings Method (ss)

UpdateServerSettings Method (ss)
Namespaces ► VisualCronAPI ► Server ► UpdateServerSettings(ServerSettingsClass)
Updates the Server settings on the Server
Declaration Syntax
C# Visual Basic Visual C++
public void UpdateServerSettings(
    ServerSettingsClass ss
)
Public Sub UpdateServerSettings ( _
    ss As ServerSettingsClass _
)
public:
virtual void UpdateServerSettings(
    ServerSettingsClass^ ss
) sealed
Parameters
ss (ServerSettingsClass)
a ServerSettingsClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserServerId Property

UserServerId Property
Namespaces ► VisualCronAPI ► Server ► UserServerId
Optional value to use to track a Connection to a Server
Declaration Syntax
C# Visual Basic Visual C++
public string UserServerId { get; set; }
Public Property UserServerId As String
public:
virtual property String^ UserServerId {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables Property

Variables Property
Namespaces ► VisualCronAPI ► Server ► Variables
Base object in Server that contain methods and properties of global Variables
Declaration Syntax
C# Visual Basic Visual C++
public Variables Variables { get; }
Public ReadOnly Property Variables As Variables
public:
virtual property Variables^ Variables {
    Variables^ get () sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Version Property

Version Property
Namespaces ► VisualCronAPI ► Server ► Version
Gets the Server version (build)
Declaration Syntax
C# Visual Basic Visual C++
public string Version { get; internal set; }
Public Property Version As String
public:
virtual property String^ Version {
    String^ get () sealed;
    void set (String^ value) sealed;
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.__Server Interface

Server..::.__Server Interface
Namespaces ► VisualCronAPI ► Server ► Server..::.__Server

[Missing <summary> documentation for T:VisualCronAPI.Server.__Server]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Server
Public Interface __Server
public interface class __Server
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EIPProgress(ExportImportProgressClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EIPProgress Method (eip)

EIPProgress Method (eip)
Namespaces ► VisualCronAPI ► Server..::.__Server ► EIPProgress(ExportImportProgressClass)

[Missing <summary> documentation for M:VisualCronAPI.Server.__Server.EIPProgress(VisualCron.ExportImportProgressClass)]

Declaration Syntax
C# Visual Basic Visual C++
void EIPProgress(
    ExportImportProgressClass eip
)
Sub EIPProgress ( _
    eip As ExportImportProgressClass _
)
void EIPProgress(
    ExportImportProgressClass^ eip
)
Parameters
eip (ExportImportProgressClass)

[Missing <param name="eip"/> documentation for "M:VisualCronAPI.Server.__Server.EIPProgress(VisualCron.ExportImportProgressClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server._Server Interface

Server..::._Server Interface
Namespaces ► VisualCronAPI ► Server ► Server..::._Server

[Missing <summary> documentation for T:VisualCronAPI.Server._Server]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Server
Public Interface _Server
public interface class _Server
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Active |
 | AllowLocalConnectionsOnly |
 | Authenticated |
 | Certificates |
 | Client |
 | ClientConnections |
 | Computer |
 | Conditions |
 | Connected |
 | Connection |
 | Connections |
 | Credentials |
 | Disconnect()()() |
 | Email |
 | Explorer |
 | GetVar(String) |
 | InSync |
 | IP |
 | Jobs |
 | LanguageId |
 | License |
 | LimitOutput |
 | LimitOutputSize |
 | Log |
 | NetworkDrives |
 | Notifications |
 | On |
 | Permissions |
 | PGPKeyRings |
 | Ping()()() |
 | Port |
 | Processes |
 | Protocol |
 | Proxy |
 | RaiseImportExportProgress(ExportImportProgressClass) |
 | Send(Object, Boolean) |
 | SendTestEmail(TestEmailClass) |
 | ServerId |
 | ServerName |
 | ServerTime |
 | ServerTimeDiff |
 | ServerTimeString |
 | Start()()() |
 | Status |
 | Stop()()() |
 | TimeExceptions |
 | UpdateServerSettings(ServerSettingsClass) |
 | UserServerId |
 | Variables |
 | Version |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Active Property

Active Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Active

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Active]

Declaration Syntax
C# Visual Basic Visual C++
bool Active { get; set; }
Property Active As Boolean
property bool Active {
    bool get ();
    void set (bool value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AllowLocalConnectionsOnly Property

AllowLocalConnectionsOnly Property
Namespaces ► VisualCronAPI ► Server..::._Server ► AllowLocalConnectionsOnly

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.AllowLocalConnectionsOnly]

Declaration Syntax
C# Visual Basic Visual C++
bool AllowLocalConnectionsOnly { get; set; }
Property AllowLocalConnectionsOnly As Boolean
property bool AllowLocalConnectionsOnly {
    bool get ();
    void set (bool value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Authenticated Property

Authenticated Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Authenticated

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Authenticated]

Declaration Syntax
C# Visual Basic Visual C++
bool Authenticated { get; }
ReadOnly Property Authenticated As Boolean
property bool Authenticated {
    bool get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Certificates Property

Certificates Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Certificates

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Certificates]

Declaration Syntax
C# Visual Basic Visual C++
Certificates Certificates { get; }
ReadOnly Property Certificates As Certificates
property Certificates^ Certificates {
    Certificates^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Client Property

Client Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Client

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Client]

Declaration Syntax
C# Visual Basic Visual C++
Client Client { get; }
ReadOnly Property Client As Client
property Client^ Client {
    Client^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ClientConnections Property

ClientConnections Property
Namespaces ► VisualCronAPI ► Server..::._Server ► ClientConnections

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.ClientConnections]

Declaration Syntax
C# Visual Basic Visual C++
ClientConnections ClientConnections { get; set; }
Property ClientConnections As ClientConnections
property ClientConnections^ ClientConnections {
    ClientConnections^ get ();
    void set (ClientConnections^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Computer Property

Computer Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Computer

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Computer]

Declaration Syntax
C# Visual Basic Visual C++
Computer Computer { get; }
ReadOnly Property Computer As Computer
property Computer^ Computer {
    Computer^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Conditions Property

Conditions Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Conditions

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Conditions]

Declaration Syntax
C# Visual Basic Visual C++
Conditions Conditions { get; }
ReadOnly Property Conditions As Conditions
property Conditions^ Conditions {
    Conditions^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connected Property

Connected Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Connected

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Connected]

Declaration Syntax
C# Visual Basic Visual C++
bool Connected { get; }
ReadOnly Property Connected As Boolean
property bool Connected {
    bool get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connection Property

Connection Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Connection

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Connection]

Declaration Syntax
C# Visual Basic Visual C++
Connection Connection { get; }
ReadOnly Property Connection As Connection
property Connection^ Connection {
    Connection^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Connections Property

Connections Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Connections

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Connections]

Declaration Syntax
C# Visual Basic Visual C++
Connections Connections { get; }
ReadOnly Property Connections As Connections
property Connections^ Connections {
    Connections^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Credentials Property

Credentials Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Credentials

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Credentials]

Declaration Syntax
C# Visual Basic Visual C++
Credentials Credentials { get; }
ReadOnly Property Credentials As Credentials
property Credentials^ Credentials {
    Credentials^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Disconnect Method

Disconnect Method
Namespaces ► VisualCronAPI ► Server..::._Server ► Disconnect()()()

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.Disconnect]

Declaration Syntax
C# Visual Basic Visual C++
bool Disconnect()
Function Disconnect As Boolean
bool Disconnect()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server._Server.Disconnect]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Email Property

Email Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Email

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Email]

Declaration Syntax
C# Visual Basic Visual C++
EmailSettings Email { get; set; }
Property Email As EmailSettings
property EmailSettings^ Email {
    EmailSettings^ get ();
    void set (EmailSettings^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Explorer Property

Explorer Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Explorer

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Explorer]

Declaration Syntax
C# Visual Basic Visual C++
Explorer Explorer { get; set; }
Property Explorer As Explorer
property Explorer^ Explorer {
    Explorer^ get ();
    void set (Explorer^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetVar Method (strVariable)

GetVar Method (strVariable)
Namespaces ► VisualCronAPI ► Server..::._Server ► GetVar(String)

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.GetVar(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetVar(
    string strVariable
)
Function GetVar ( _
    strVariable As String _
) As String
String^ GetVar(
    String^ strVariable
)
Parameters
strVariable (String)

[Missing <param name="strVariable"/> documentation for "M:VisualCronAPI.Server._Server.GetVar(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server._Server.GetVar(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InSync Property

InSync Property
Namespaces ► VisualCronAPI ► Server..::._Server ► InSync

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.InSync]

Declaration Syntax
C# Visual Basic Visual C++
bool InSync { get; }
ReadOnly Property InSync As Boolean
property bool InSync {
    bool get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IP Property

IP Property
Namespaces ► VisualCronAPI ► Server..::._Server ► IP

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.IP]

Declaration Syntax
C# Visual Basic Visual C++
string IP { get; }
ReadOnly Property IP As String
property String^ IP {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Jobs Property

Jobs Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Jobs

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Jobs]

Declaration Syntax
C# Visual Basic Visual C++
Jobs Jobs { get; }
ReadOnly Property Jobs As Jobs
property Jobs^ Jobs {
    Jobs^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LanguageId Property

LanguageId Property
Namespaces ► VisualCronAPI ► Server..::._Server ► LanguageId

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.LanguageId]

Declaration Syntax
C# Visual Basic Visual C++
int LanguageId { get; set; }
Property LanguageId As Integer
property int LanguageId {
    int get ();
    void set (int value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


License Property

License Property
Namespaces ► VisualCronAPI ► Server..::._Server ► License

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.License]

Declaration Syntax
C# Visual Basic Visual C++
License License { get; }
ReadOnly Property License As License
property License^ License {
    License^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LimitOutput Property

LimitOutput Property
Namespaces ► VisualCronAPI ► Server..::._Server ► LimitOutput

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.LimitOutput]

Declaration Syntax
C# Visual Basic Visual C++
bool LimitOutput { get; set; }
Property LimitOutput As Boolean
property bool LimitOutput {
    bool get ();
    void set (bool value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


LimitOutputSize Property

LimitOutputSize Property
Namespaces ► VisualCronAPI ► Server..::._Server ► LimitOutputSize

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.LimitOutputSize]

Declaration Syntax
C# Visual Basic Visual C++
int LimitOutputSize { get; set; }
Property LimitOutputSize As Integer
property int LimitOutputSize {
    int get ();
    void set (int value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Log Property

Log Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Log

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Log]

Declaration Syntax
C# Visual Basic Visual C++
Log Log { get; }
ReadOnly Property Log As Log
property Log^ Log {
    Log^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NetworkDrives Property

NetworkDrives Property
Namespaces ► VisualCronAPI ► Server..::._Server ► NetworkDrives

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.NetworkDrives]

Declaration Syntax
C# Visual Basic Visual C++
NetworkDrives NetworkDrives { get; }
ReadOnly Property NetworkDrives As NetworkDrives
property NetworkDrives^ NetworkDrives {
    NetworkDrives^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Notifications Property

Notifications Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Notifications

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Notifications]

Declaration Syntax
C# Visual Basic Visual C++
Notifications Notifications { get; }
ReadOnly Property Notifications As Notifications
property Notifications^ Notifications {
    Notifications^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


On Property

On Property
Namespaces ► VisualCronAPI ► Server..::._Server ► On

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.On]

Declaration Syntax
C# Visual Basic Visual C++
bool On { get; set; }
Property On As Boolean
property bool On {
    bool get ();
    void set (bool value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Permissions Property

Permissions Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Permissions

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Permissions]

Declaration Syntax
C# Visual Basic Visual C++
Permissions Permissions { get; }
ReadOnly Property Permissions As Permissions
property Permissions^ Permissions {
    Permissions^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


PGPKeyRings Property

PGPKeyRings Property
Namespaces ► VisualCronAPI ► Server..::._Server ► PGPKeyRings

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.PGPKeyRings]

Declaration Syntax
C# Visual Basic Visual C++
PGPKeyRings PGPKeyRings { get; }
ReadOnly Property PGPKeyRings As PGPKeyRings
property PGPKeyRings^ PGPKeyRings {
    PGPKeyRings^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Ping Method

Ping Method
Namespaces ► VisualCronAPI ► Server..::._Server ► Ping()()()

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.Ping]

Declaration Syntax
C# Visual Basic Visual C++
PingClass..::.EnumPingResult Ping()
Function Ping As PingClass..::.EnumPingResult
PingClass..::.EnumPingResult Ping()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server._Server.Ping]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Port Property

Port Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Port

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Port]

Declaration Syntax
C# Visual Basic Visual C++
int Port { get; set; }
Property Port As Integer
property int Port {
    int get ();
    void set (int value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Processes Property

Processes Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Processes

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Processes]

Declaration Syntax
C# Visual Basic Visual C++
Processes Processes { get; }
ReadOnly Property Processes As Processes
property Processes^ Processes {
    Processes^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Protocol Property

Protocol Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Protocol

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Protocol]

Declaration Syntax
C# Visual Basic Visual C++
string Protocol { get; set; }
Property Protocol As String
property String^ Protocol {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Proxy Property

Proxy Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Proxy

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Proxy]

Declaration Syntax
C# Visual Basic Visual C++
ProxyClass Proxy { get; set; }
Property Proxy As ProxyClass
property ProxyClass^ Proxy {
    ProxyClass^ get ();
    void set (ProxyClass^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RaiseImportExportProgress Method (eip)

RaiseImportExportProgress Method (eip)
Namespaces ► VisualCronAPI ► Server..::._Server ► RaiseImportExportProgress(ExportImportProgressClass)

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.RaiseImportExportProgress(VisualCron.ExportImportProgressClass)]

Declaration Syntax
C# Visual Basic Visual C++
void RaiseImportExportProgress(
    ExportImportProgressClass eip
)
Sub RaiseImportExportProgress ( _
    eip As ExportImportProgressClass _
)
void RaiseImportExportProgress(
    ExportImportProgressClass^ eip
)
Parameters
eip (ExportImportProgressClass)

[Missing <param name="eip"/> documentation for "M:VisualCronAPI.Server._Server.RaiseImportExportProgress(VisualCron.ExportImportProgressClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Send Method (obj, ForceNoCompression)

Send Method (obj, ForceNoCompression)
Namespaces ► VisualCronAPI ► Server..::._Server ► Send(Object, Boolean)

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.Send(System.Object,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
bool Send(
    Object obj,
    bool ForceNoCompression
)
Function Send ( _
    obj As Object, _
    ForceNoCompression As Boolean _
) As Boolean
bool Send(
    Object^ obj,
    bool ForceNoCompression
)
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:VisualCronAPI.Server._Server.Send(System.Object,System.Boolean)"]

ForceNoCompression (Boolean)

[Missing <param name="ForceNoCompression"/> documentation for "M:VisualCronAPI.Server._Server.Send(System.Object,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server._Server.Send(System.Object,System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SendTestEmail Method (te)

SendTestEmail Method (te)
Namespaces ► VisualCronAPI ► Server..::._Server ► SendTestEmail(TestEmailClass)

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.SendTestEmail(VisualCron.TestEmailClass)]

Declaration Syntax
C# Visual Basic Visual C++
void SendTestEmail(
    TestEmailClass te
)
Sub SendTestEmail ( _
    te As TestEmailClass _
)
void SendTestEmail(
    TestEmailClass^ te
)
Parameters
te (TestEmailClass)

[Missing <param name="te"/> documentation for "M:VisualCronAPI.Server._Server.SendTestEmail(VisualCron.TestEmailClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerId Property

ServerId Property
Namespaces ► VisualCronAPI ► Server..::._Server ► ServerId

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.ServerId]

Declaration Syntax
C# Visual Basic Visual C++
string ServerId { get; }
ReadOnly Property ServerId As String
property String^ ServerId {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerName Property

ServerName Property
Namespaces ► VisualCronAPI ► Server..::._Server ► ServerName

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.ServerName]

Declaration Syntax
C# Visual Basic Visual C++
string ServerName { get; }
ReadOnly Property ServerName As String
property String^ ServerName {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerTime Property

ServerTime Property
Namespaces ► VisualCronAPI ► Server..::._Server ► ServerTime

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.ServerTime]

Declaration Syntax
C# Visual Basic Visual C++
DateTime ServerTime { get; }
ReadOnly Property ServerTime As DateTime
property DateTime ServerTime {
    DateTime get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerTimeDiff Property

ServerTimeDiff Property
Namespaces ► VisualCronAPI ► Server..::._Server ► ServerTimeDiff

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.ServerTimeDiff]

Declaration Syntax
C# Visual Basic Visual C++
long ServerTimeDiff { get; set; }
Property ServerTimeDiff As Long
property long long ServerTimeDiff {
    long long get ();
    void set (long long value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ServerTimeString Property

ServerTimeString Property
Namespaces ► VisualCronAPI ► Server..::._Server ► ServerTimeString

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.ServerTimeString]

Declaration Syntax
C# Visual Basic Visual C++
string ServerTimeString { get; }
ReadOnly Property ServerTimeString As String
property String^ ServerTimeString {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Start Method

Start Method
Namespaces ► VisualCronAPI ► Server..::._Server ► Start()()()

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.Start]

Declaration Syntax
C# Visual Basic Visual C++
bool Start()
Function Start As Boolean
bool Start()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server._Server.Start]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Status Property

Status Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Status

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Status]

Declaration Syntax
C# Visual Basic Visual C++
Server..::.StatusT Status { get; }
ReadOnly Property Status As Server..::.StatusT
property Server..::.StatusT Status {
    Server..::.StatusT get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Stop Method

Stop Method
Namespaces ► VisualCronAPI ► Server..::._Server ► Stop()()()

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.Stop]

Declaration Syntax
C# Visual Basic Visual C++
bool Stop()
Function Stop As Boolean
bool Stop()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Server._Server.Stop]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions Property

TimeExceptions Property
Namespaces ► VisualCronAPI ► Server..::._Server ► TimeExceptions

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.TimeExceptions]

Declaration Syntax
C# Visual Basic Visual C++
TimeExceptions TimeExceptions { get; }
ReadOnly Property TimeExceptions As TimeExceptions
property TimeExceptions^ TimeExceptions {
    TimeExceptions^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UpdateServerSettings Method (ss)

UpdateServerSettings Method (ss)
Namespaces ► VisualCronAPI ► Server..::._Server ► UpdateServerSettings(ServerSettingsClass)

[Missing <summary> documentation for M:VisualCronAPI.Server._Server.UpdateServerSettings(VisualCron.ServerSettingsClass)]

Declaration Syntax
C# Visual Basic Visual C++
void UpdateServerSettings(
    ServerSettingsClass ss
)
Sub UpdateServerSettings ( _
    ss As ServerSettingsClass _
)
void UpdateServerSettings(
    ServerSettingsClass^ ss
)
Parameters
ss (ServerSettingsClass)

[Missing <param name="ss"/> documentation for "M:VisualCronAPI.Server._Server.UpdateServerSettings(VisualCron.ServerSettingsClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserServerId Property

UserServerId Property
Namespaces ► VisualCronAPI ► Server..::._Server ► UserServerId

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.UserServerId]

Declaration Syntax
C# Visual Basic Visual C++
string UserServerId { get; set; }
Property UserServerId As String
property String^ UserServerId {
    String^ get ();
    void set (String^ value);
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables Property

Variables Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Variables

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Variables]

Declaration Syntax
C# Visual Basic Visual C++
Variables Variables { get; }
ReadOnly Property Variables As Variables
property Variables^ Variables {
    Variables^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Version Property

Version Property
Namespaces ► VisualCronAPI ► Server..::._Server ► Version

[Missing <summary> documentation for P:VisualCronAPI.Server._Server.Version]

Declaration Syntax
C# Visual Basic Visual C++
string Version { get; }
ReadOnly Property Version As String
property String^ Version {
    String^ get ();
}

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.DelegateEIPProgress Delegate

Server..::.DelegateEIPProgress Delegate
Namespaces ► VisualCronAPI ► Server ► Server..::.DelegateEIPProgress

[Missing <summary> documentation for T:VisualCronAPI.Server.DelegateEIPProgress]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateEIPProgress(
    ExportImportProgressClass eip
)
Public Delegate Sub DelegateEIPProgress ( _
    eip As ExportImportProgressClass _
)
public delegate void DelegateEIPProgress(
    ExportImportProgressClass^ eip
)
Parameters
eip (ExportImportProgressClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.NotConnectedException Class

Server..::.NotConnectedException Class
Namespaces ► VisualCronAPI ► Server ► Server..::.NotConnectedException
Is throwed when the server is not connected
Declaration Syntax
C# Visual Basic Visual C++
public class NotConnectedException : Exception
Public Class NotConnectedException _
    Inherits Exception
public ref class NotConnectedException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Server..::.NotConnectedException()()() | Initializes a new instance of the Server..::.NotConnectedException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Server..::.NotConnectedException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.NotConnectedException Constructor

Server..::.NotConnectedException Constructor
Namespaces ► VisualCronAPI ► Server..::.NotConnectedException ► Server..::.NotConnectedException()()()
Initializes a new instance of the Server..::.NotConnectedException class
Declaration Syntax
C# Visual Basic Visual C++
public NotConnectedException()
Public Sub New
public:
NotConnectedException()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.NotImplementedException Class

Server..::.NotImplementedException Class
Namespaces ► VisualCronAPI ► Server ► Server..::.NotImplementedException
Is throwed when a function is not implemented yet
Declaration Syntax
C# Visual Basic Visual C++
public class NotImplementedException : Exception
Public Class NotImplementedException _
    Inherits Exception
public ref class NotImplementedException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Server..::.NotImplementedException()()() | Initializes a new instance of the Server..::.NotImplementedException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Server..::.NotImplementedException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.NotImplementedException Constructor

Server..::.NotImplementedException Constructor
Namespaces ► VisualCronAPI ► Server..::.NotImplementedException ► Server..::.NotImplementedException()()()
Initializes a new instance of the Server..::.NotImplementedException class
Declaration Syntax
C# Visual Basic Visual C++
public NotImplementedException()
Public Sub New
public:
NotImplementedException()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.ReplyTimeoutException Class

Server..::.ReplyTimeoutException Class
Namespaces ► VisualCronAPI ► Server ► Server..::.ReplyTimeoutException
Is throwed when the API has not received
Declaration Syntax
C# Visual Basic Visual C++
public class ReplyTimeoutException : Exception
Public Class ReplyTimeoutException _
    Inherits Exception
public ref class ReplyTimeoutException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Server..::.ReplyTimeoutException()()() | Initializes a new instance of the Server..::.ReplyTimeoutException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Server..::.ReplyTimeoutException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.ReplyTimeoutException Constructor

Server..::.ReplyTimeoutException Constructor
Namespaces ► VisualCronAPI ► Server..::.ReplyTimeoutException ► Server..::.ReplyTimeoutException()()()
Initializes a new instance of the Server..::.ReplyTimeoutException class
Declaration Syntax
C# Visual Basic Visual C++
public ReplyTimeoutException()
Public Sub New
public:
ReplyTimeoutException()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Server.StatusT Enumeration

Server..::.StatusT Enumeration
Namespaces ► VisualCronAPI ► Server ► Server..::.StatusT
Enum that describes current connection status
Declaration Syntax
C# Visual Basic Visual C++
public enum StatusT
Public Enumeration StatusT
public enum class StatusT
Members
Member | Description
Connected |
Connecting |
Disconnected |
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Servers Class

Servers Class
Namespaces ► VisualCronAPI ► Servers

[Missing <summary> documentation for T:VisualCronAPI.Servers]

Declaration Syntax
C# Visual Basic Visual C++
public class Servers
Public Class Servers
public ref class Servers
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Servers()()() | Initializes a new instance of the Servers class
 | Contains(String) | Returns true if the Server id exist
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAll | Returns all Servers that the client is connected to
 | GetAllArray | Returns all Servers that the client is connected to
 | GetByServerId(String) | Returns a Server based on Id
 | GetByUserServerId(String) | Returns as Server by UserServerId
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsConnectedToServer(String) | Returns true if the Client is connected to specified Server
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Servers

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Servers Constructor

Servers Constructor
Namespaces ► VisualCronAPI ► Servers ► Servers()()()
Initializes a new instance of the Servers class
Declaration Syntax
C# Visual Basic Visual C++
public Servers()
Public Sub New
public:
Servers()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strUserServerId)

Contains Method (strUserServerId)
Namespaces ► VisualCronAPI ► Servers ► Contains(String)
Returns true if the Server id exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strUserServerId
)
Public Function Contains ( _
    strUserServerId As String _
) As Boolean
public:
bool Contains(
    String^ strUserServerId
)
Parameters
strUserServerId (String)

[Missing <param name="strUserServerId"/> documentation for "M:VisualCronAPI.Servers.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Servers.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Property

GetAll Property
Namespaces ► VisualCronAPI ► Servers ► GetAll
Returns all Servers that the client is connected to
Declaration Syntax
C# Visual Basic Visual C++
public List<Server> GetAll { get; internal set; }
Public Property GetAll As List(Of Server)
public:
property List<Server^>^ GetAll {
    List<Server^>^ get ();
    void set (List<Server^>^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Property

GetAllArray Property
Namespaces ► VisualCronAPI ► Servers ► GetAllArray
Returns all Servers that the client is connected to
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray { get; internal set; }
Public Property GetAllArray As ArrayList
public:
property ArrayList^ GetAllArray {
    ArrayList^ get ();
    void set (ArrayList^ value);
}
Value
Return Value
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetByServerId Method (strServerId)

GetByServerId Method (strServerId)
Namespaces ► VisualCronAPI ► Servers ► GetByServerId(String)
Returns a Server based on Id
Declaration Syntax
C# Visual Basic Visual C++
public Server GetByServerId(
    string strServerId
)
Public Function GetByServerId ( _
    strServerId As String _
) As Server
public:
Server^ GetByServerId(
    String^ strServerId
)
Parameters
strServerId (String)

[Missing <param name="strServerId"/> documentation for "M:VisualCronAPI.Servers.GetByServerId(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Servers.GetByServerId(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetByUserServerId Method (strUserServerId)

GetByUserServerId Method (strUserServerId)
Namespaces ► VisualCronAPI ► Servers ► GetByUserServerId(String)
Returns as Server by UserServerId
Declaration Syntax
C# Visual Basic Visual C++
public Server GetByUserServerId(
    string strUserServerId
)
Public Function GetByUserServerId ( _
    strUserServerId As String _
) As Server
public:
Server^ GetByUserServerId(
    String^ strUserServerId
)
Parameters
strUserServerId (String)

[Missing <param name="strUserServerId"/> documentation for "M:VisualCronAPI.Servers.GetByUserServerId(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Servers.GetByUserServerId(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


IsConnectedToServer Method (strUserServerId)

IsConnectedToServer Method (strUserServerId)
Namespaces ► VisualCronAPI ► Servers ► IsConnectedToServer(String)
Returns true if the Client is connected to specified Server
Declaration Syntax
C# Visual Basic Visual C++
public bool IsConnectedToServer(
    string strUserServerId
)
Public Function IsConnectedToServer ( _
    strUserServerId As String _
) As Boolean
public:
bool IsConnectedToServer(
    String^ strUserServerId
)
Parameters
strUserServerId (String)

[Missing <param name="strUserServerId"/> documentation for "M:VisualCronAPI.Servers.IsConnectedToServer(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Servers.IsConnectedToServer(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks Class

Tasks Class
Namespaces ► VisualCronAPI ► Tasks
Base class for Task Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Tasks : Tasks..::._Tasks
Public Class Tasks _
    Implements Tasks..::._Tasks
public ref class Tasks : Tasks..::._Tasks
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tasks()()() | Initializes a new instance of the Tasks class
 | Activate(TaskClass) | Activates a Task
 | Activate(String) | Activates a Task
 | Add(TaskClass) | Adds a Task
 | AddAsync(TaskClass) | Adds a Task asynchrously
 | DeActivate(TaskClass) | Deactivates a Task
 | DeActivate(String) | Deactivates a Task
 | DoTaskExist(JobClass, TaskClass) | Checks if a certain Task exists
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Task based on the string key Id
 | Get(JobClass, String) | Returns a Task based on JobClass and strTaskId
 | GetAll(String) | Returns all Tasks in a Job based on Job Id
 | GetAllArray(String) | Returns all Tasks in a Job based on Job Id
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJobIdByTaskId(String) | Returns the JobId of a Task based on TaskId
 | GetTaskName(String, String) | Retrieves Task Name
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(TaskClass) | Removes a JTask
 | Remove(String) | Removes aTask
 | Run(TaskClass) | Runs a Task
 | Run(JobClass, TaskClass) | Runs a Task
 | Run(String, String) | Runs a Task
 | TaskAdded | This event is raised when a Task is added
 | TaskAddedStatic | This event is raised when a Task is added
 | TaskRemoved | This event is raised when a Task is removed
 | TaskRemovedStatic | This event is raised when a Task is removed
 | TaskTypeToString(TaskClass..::.TaskT) | Returns a translated string of the task type
 | TaskUpdated | This event is raised when a Task is updated
 | TaskUpdatedStatic | This event is raised when a Task is updated
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(TaskClass) | Updates a Task
 | UpdateAsync(TaskClass) | Updates a Task asynchrously
Remarks
Inheritance Hierarchy
Object
Tasks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks Constructor

Tasks Constructor
Namespaces ► VisualCronAPI ► Tasks ► Tasks()()()
Initializes a new instance of the Tasks class
Declaration Syntax
C# Visual Basic Visual C++
public Tasks()
Public Sub New
public:
Tasks()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method

Activate Method
Namespaces ► VisualCronAPI ► Tasks ► Activate()()()
Members
Icon | Member | Description
 | Activate(TaskClass) | Activates a Task
 | Activate(String) | Activates a Task

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (strTaskId)

Activate Method (strTaskId)
Namespaces ► VisualCronAPI ► Tasks ► Activate(String)
Activates a Task
Declaration Syntax
C# Visual Basic Visual C++
public bool Activate(
    string strTaskId
)
Public Function Activate ( _
    strTaskId As String _
) As Boolean
public:
virtual bool Activate(
    String^ strTaskId
) sealed
Parameters
strTaskId (String)
a Task Id
Return Value
Returns Task active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (t)

Activate Method (t)
Namespaces ► VisualCronAPI ► Tasks ► Activate(TaskClass)
Activates a Task
Declaration Syntax
C# Visual Basic Visual C++
public bool Activate(
    TaskClass t
)
Public Function Activate ( _
    t As TaskClass _
) As Boolean
public:
virtual bool Activate(
    TaskClass^ t
) sealed
Parameters
t (TaskClass)
a Task
Return Value
Returns Task active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (tc)

Add Method (tc)
Namespaces ► VisualCronAPI ► Tasks ► Add(TaskClass)
Adds a Task
Declaration Syntax
C# Visual Basic Visual C++
public JobClass Add(
    TaskClass tc
)
Public Function Add ( _
    tc As TaskClass _
) As JobClass
public:
virtual JobClass^ Add(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks.Add(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.Add(VisualCron.TaskClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AddAsync Method (tc)

AddAsync Method (tc)
Namespaces ► VisualCronAPI ► Tasks ► AddAsync(TaskClass)
Adds a Task asynchrously
Declaration Syntax
C# Visual Basic Visual C++
public bool AddAsync(
    TaskClass tc
)
Public Function AddAsync ( _
    tc As TaskClass _
) As Boolean
public:
virtual bool AddAsync(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks.AddAsync(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.AddAsync(VisualCron.TaskClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method

DeActivate Method
Namespaces ► VisualCronAPI ► Tasks ► DeActivate()()()
Members
Icon | Member | Description
 | DeActivate(TaskClass) | Deactivates a Task
 | DeActivate(String) | Deactivates a Task

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (strTaskId)

DeActivate Method (strTaskId)
Namespaces ► VisualCronAPI ► Tasks ► DeActivate(String)
Deactivates a Task
Declaration Syntax
C# Visual Basic Visual C++
public bool DeActivate(
    string strTaskId
)
Public Function DeActivate ( _
    strTaskId As String _
) As Boolean
public:
virtual bool DeActivate(
    String^ strTaskId
) sealed
Parameters
strTaskId (String)
a Task Id
Return Value
Returns Task active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (t)

DeActivate Method (t)
Namespaces ► VisualCronAPI ► Tasks ► DeActivate(TaskClass)
Deactivates a Task
Declaration Syntax
C# Visual Basic Visual C++
public bool DeActivate(
    TaskClass t
)
Public Function DeActivate ( _
    t As TaskClass _
) As Boolean
public:
virtual bool DeActivate(
    TaskClass^ t
) sealed
Parameters
t (TaskClass)
a Task
Return Value
Returns a Task active state.
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTaskExist Method (jc, tc)

DoTaskExist Method (jc, tc)
Namespaces ► VisualCronAPI ► Tasks ► DoTaskExist(JobClass, TaskClass)
Checks if a certain Task exists
Declaration Syntax
C# Visual Basic Visual C++
public bool DoTaskExist(
    JobClass jc,
    TaskClass tc
)
Public Function DoTaskExist ( _
    jc As JobClass, _
    tc As TaskClass _
) As Boolean
public:
virtual bool DoTaskExist(
    JobClass^ jc,
    TaskClass^ tc
) sealed
Parameters
jc (JobClass)
Job
tc (TaskClass)
Task
Return Value
true if existing
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method

Get Method
Namespaces ► VisualCronAPI ► Tasks ► Get()()()
Members
Icon | Member | Description
 | Get(String) | Returns a Task based on the string key Id
 | Get(JobClass, String) | Returns a Task based on JobClass and strTaskId

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Tasks ► Get(String)
Returns a Task based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass Get(
    string id
)
Public Function Get ( _
    id As String _
) As TaskClass
public:
virtual TaskClass^ Get(
    String^ id
) sealed
Parameters
id (String)
string key
Return Value
a Task
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (jc, strTaskId)

Get Method (jc, strTaskId)
Namespaces ► VisualCronAPI ► Tasks ► Get(JobClass, String)
Returns a Task based on JobClass and strTaskId
Declaration Syntax
C# Visual Basic Visual C++
public TaskClass Get(
    JobClass jc,
    string strTaskId
)
Public Function Get ( _
    jc As JobClass, _
    strTaskId As String _
) As TaskClass
public:
virtual TaskClass^ Get(
    JobClass^ jc,
    String^ strTaskId
) sealed
Parameters
jc (JobClass)

[Missing <param name="jc"/> documentation for "M:VisualCronAPI.Tasks.Get(VisualCron.JobClass,System.String)"]

strTaskId (String)

[Missing <param name="strTaskId"/> documentation for "M:VisualCronAPI.Tasks.Get(VisualCron.JobClass,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.Get(VisualCron.JobClass,System.String)]

Remarks
Faster than normal Get

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method (strJobId)

GetAll Method (strJobId)
Namespaces ► VisualCronAPI ► Tasks ► GetAll(String)
Returns all Tasks in a Job based on Job Id
Declaration Syntax
C# Visual Basic Visual C++
public List<TaskClass> GetAll(
    string strJobId
)
Public Function GetAll ( _
    strJobId As String _
) As List(Of TaskClass)
public:
List<TaskClass^>^ GetAll(
    String^ strJobId
)
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.Tasks.GetAll(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.GetAll(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (strJobId)

GetAllArray Method (strJobId)
Namespaces ► VisualCronAPI ► Tasks ► GetAllArray(String)
Returns all Tasks in a Job based on Job Id
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray(
    string strJobId
)
Public Function GetAllArray ( _
    strJobId As String _
) As ArrayList
public:
virtual ArrayList^ GetAllArray(
    String^ strJobId
) sealed
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.Tasks.GetAllArray(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.GetAllArray(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobIdByTaskId Method (strTaskId)

GetJobIdByTaskId Method (strTaskId)
Namespaces ► VisualCronAPI ► Tasks ► GetJobIdByTaskId(String)
Returns the JobId of a Task based on TaskId
Declaration Syntax
C# Visual Basic Visual C++
public string GetJobIdByTaskId(
    string strTaskId
)
Public Function GetJobIdByTaskId ( _
    strTaskId As String _
) As String
public:
virtual String^ GetJobIdByTaskId(
    String^ strTaskId
) sealed
Parameters
strTaskId (String)

[Missing <param name="strTaskId"/> documentation for "M:VisualCronAPI.Tasks.GetJobIdByTaskId(System.String)"]

Return Value
JobId
Remarks
returns string.empty when Task is not found

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskName Method (jobid, taskid)

GetTaskName Method (jobid, taskid)
Namespaces ► VisualCronAPI ► Tasks ► GetTaskName(String, String)
Retrieves Task Name
Declaration Syntax
C# Visual Basic Visual C++
public string GetTaskName(
    string jobid,
    string taskid
)
Public Function GetTaskName ( _
    jobid As String, _
    taskid As String _
) As String
public:
virtual String^ GetTaskName(
    String^ jobid,
    String^ taskid
) sealed
Parameters
jobid (String)

[Missing <param name="jobid"/> documentation for "M:VisualCronAPI.Tasks.GetTaskName(System.String,System.String)"]

taskid (String)

[Missing <param name="taskid"/> documentation for "M:VisualCronAPI.Tasks.GetTaskName(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.GetTaskName(System.String,System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Tasks ► Remove()()()
Members
Icon | Member | Description
 | Remove(TaskClass) | Removes a JTask
 | Remove(String) | Removes aTask

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (taskId)

Remove Method (taskId)
Namespaces ► VisualCronAPI ► Tasks ► Remove(String)
Removes aTask
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string taskId
)
Public Function Remove ( _
    taskId As String _
) As Boolean
public:
virtual bool Remove(
    String^ taskId
) sealed
Parameters
taskId (String)
Id of Task
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (tc)

Remove Method (tc)
Namespaces ► VisualCronAPI ► Tasks ► Remove(TaskClass)
Removes a JTask
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    TaskClass tc
)
Public Function Remove ( _
    tc As TaskClass _
) As Boolean
public:
virtual bool Remove(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)
a Task
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.Remove(VisualCron.TaskClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method

Run Method
Namespaces ► VisualCronAPI ► Tasks ► Run()()()
Members
Icon | Member | Description
 | Run(TaskClass) | Runs a Task
 | Run(JobClass, TaskClass) | Runs a Task
 | Run(String, String) | Runs a Task

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (jobId, taskId)

Run Method (jobId, taskId)
Namespaces ► VisualCronAPI ► Tasks ► Run(String, String)
Runs a Task
Declaration Syntax
C# Visual Basic Visual C++
public void Run(
    string jobId,
    string taskId
)
Public Sub Run ( _
    jobId As String, _
    taskId As String _
)
public:
virtual void Run(
    String^ jobId,
    String^ taskId
) sealed
Parameters
jobId (String)
a Job Id
taskId (String)
a Task Id
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (jc, tc)

Run Method (jc, tc)
Namespaces ► VisualCronAPI ► Tasks ► Run(JobClass, TaskClass)
Runs a Task
Declaration Syntax
C# Visual Basic Visual C++
public void Run(
    JobClass jc,
    TaskClass tc
)
Public Sub Run ( _
    jc As JobClass, _
    tc As TaskClass _
)
public:
virtual void Run(
    JobClass^ jc,
    TaskClass^ tc
) sealed
Parameters
jc (JobClass)
a Job class
tc (TaskClass)
a Task class
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (tc)

Run Method (tc)
Namespaces ► VisualCronAPI ► Tasks ► Run(TaskClass)
Runs a Task
Declaration Syntax
C# Visual Basic Visual C++
public void Run(
    TaskClass tc
)
Public Sub Run ( _
    tc As TaskClass _
)
public:
virtual void Run(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)
a Task class
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskAdded Event

TaskAdded Event
Namespaces ► VisualCronAPI ► Tasks ► TaskAdded
This event is raised when a Task is added
Declaration Syntax
C# Visual Basic Visual C++
public event Tasks..::.DelegateTaskAdded TaskAdded
Public Event TaskAdded As Tasks..::.DelegateTaskAdded
public:
 event Tasks..::.DelegateTaskAdded^ TaskAdded {
    void add (Tasks..::.DelegateTaskAdded^ value);
    void remove (Tasks..::.DelegateTaskAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskAddedStatic Event

TaskAddedStatic Event
Namespaces ► VisualCronAPI ► Tasks ► TaskAddedStatic
This event is raised when a Task is added
Declaration Syntax
C# Visual Basic Visual C++
public static event Tasks..::.DelegateTaskAdded TaskAddedStatic
Public Shared Event TaskAddedStatic As Tasks..::.DelegateTaskAdded
public:
static  event Tasks..::.DelegateTaskAdded^ TaskAddedStatic {
    void add (Tasks..::.DelegateTaskAdded^ value);
    void remove (Tasks..::.DelegateTaskAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskRemoved Event

TaskRemoved Event
Namespaces ► VisualCronAPI ► Tasks ► TaskRemoved
This event is raised when a Task is removed
Declaration Syntax
C# Visual Basic Visual C++
public event Tasks..::.DelegateTaskRemoved TaskRemoved
Public Event TaskRemoved As Tasks..::.DelegateTaskRemoved
public:
 event Tasks..::.DelegateTaskRemoved^ TaskRemoved {
    void add (Tasks..::.DelegateTaskRemoved^ value);
    void remove (Tasks..::.DelegateTaskRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskRemovedStatic Event

TaskRemovedStatic Event
Namespaces ► VisualCronAPI ► Tasks ► TaskRemovedStatic
This event is raised when a Task is removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Tasks..::.DelegateTaskRemoved TaskRemovedStatic
Public Shared Event TaskRemovedStatic As Tasks..::.DelegateTaskRemoved
public:
static  event Tasks..::.DelegateTaskRemoved^ TaskRemovedStatic {
    void add (Tasks..::.DelegateTaskRemoved^ value);
    void remove (Tasks..::.DelegateTaskRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskTypeToString Method (tt)

TaskTypeToString Method (tt)
Namespaces ► VisualCronAPI ► Tasks ► TaskTypeToString(TaskClass..::.TaskT)
Returns a translated string of the task type
Declaration Syntax
C# Visual Basic Visual C++
public static string TaskTypeToString(
    TaskClass..::.TaskT tt
)
Public Shared Function TaskTypeToString ( _
    tt As TaskClass..::.TaskT _
) As String
public:
static String^ TaskTypeToString(
    TaskClass..::.TaskT tt
)
Parameters
tt (TaskClass..::.TaskT)

[Missing <param name="tt"/> documentation for "M:VisualCronAPI.Tasks.TaskTypeToString(VisualCron.TaskClass.TaskT)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.TaskTypeToString(VisualCron.TaskClass.TaskT)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskUpdated Event

TaskUpdated Event
Namespaces ► VisualCronAPI ► Tasks ► TaskUpdated
This event is raised when a Task is updated
Declaration Syntax
C# Visual Basic Visual C++
public event Tasks..::.DelegateOnTaskUpdated TaskUpdated
Public Event TaskUpdated As Tasks..::.DelegateOnTaskUpdated
public:
 event Tasks..::.DelegateOnTaskUpdated^ TaskUpdated {
    void add (Tasks..::.DelegateOnTaskUpdated^ value);
    void remove (Tasks..::.DelegateOnTaskUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskUpdatedStatic Event

TaskUpdatedStatic Event
Namespaces ► VisualCronAPI ► Tasks ► TaskUpdatedStatic
This event is raised when a Task is updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Tasks..::.DelegateOnTaskUpdated TaskUpdatedStatic
Public Shared Event TaskUpdatedStatic As Tasks..::.DelegateOnTaskUpdated
public:
static  event Tasks..::.DelegateOnTaskUpdated^ TaskUpdatedStatic {
    void add (Tasks..::.DelegateOnTaskUpdated^ value);
    void remove (Tasks..::.DelegateOnTaskUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (tc)

Update Method (tc)
Namespaces ► VisualCronAPI ► Tasks ► Update(TaskClass)
Updates a Task
Declaration Syntax
C# Visual Basic Visual C++
public JobClass Update(
    TaskClass tc
)
Public Function Update ( _
    tc As TaskClass _
) As JobClass
public:
virtual JobClass^ Update(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks.Update(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.Update(VisualCron.TaskClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UpdateAsync Method (tc)

UpdateAsync Method (tc)
Namespaces ► VisualCronAPI ► Tasks ► UpdateAsync(TaskClass)
Updates a Task asynchrously
Declaration Syntax
C# Visual Basic Visual C++
public bool UpdateAsync(
    TaskClass tc
)
Public Function UpdateAsync ( _
    tc As TaskClass _
) As Boolean
public:
virtual bool UpdateAsync(
    TaskClass^ tc
) sealed
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks.UpdateAsync(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks.UpdateAsync(VisualCron.TaskClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks.__Tasks Interface

Tasks..::.__Tasks Interface
Namespaces ► VisualCronAPI ► Tasks ► Tasks..::.__Tasks

[Missing <summary> documentation for T:VisualCronAPI.Tasks.__Tasks]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Tasks
Public Interface __Tasks
public interface class __Tasks
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TaskAdded(Server%, JobClass, TaskClass) |
 | TaskRemoved(Server%, JobClass, TaskClass) |
 | TaskUpdated(Server%, JobClass, TaskClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskAdded Method (server, j, t)

TaskAdded Method (server, j, t)
Namespaces ► VisualCronAPI ► Tasks..::.__Tasks ► TaskAdded(Server%, JobClass, TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks.__Tasks.TaskAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TaskAdded(
    ref Server server,
    JobClass j,
    TaskClass t
)
Sub TaskAdded ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TaskClass _
)
void TaskAdded(
    Server^% server,
    JobClass^ j,
    TaskClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

t (TaskClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskRemoved Method (server, j, t)

TaskRemoved Method (server, j, t)
Namespaces ► VisualCronAPI ► Tasks..::.__Tasks ► TaskRemoved(Server%, JobClass, TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks.__Tasks.TaskRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TaskRemoved(
    ref Server server,
    JobClass j,
    TaskClass t
)
Sub TaskRemoved ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TaskClass _
)
void TaskRemoved(
    Server^% server,
    JobClass^ j,
    TaskClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

t (TaskClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TaskUpdated Method (server, j, t)

TaskUpdated Method (server, j, t)
Namespaces ► VisualCronAPI ► Tasks..::.__Tasks ► TaskUpdated(Server%, JobClass, TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks.__Tasks.TaskUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TaskUpdated(
    ref Server server,
    JobClass j,
    TaskClass t
)
Sub TaskUpdated ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TaskClass _
)
void TaskUpdated(
    Server^% server,
    JobClass^ j,
    TaskClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

t (TaskClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Tasks.__Tasks.TaskUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TaskClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks._Tasks Interface

Tasks..::._Tasks Interface
Namespaces ► VisualCronAPI ► Tasks ► Tasks..::._Tasks

[Missing <summary> documentation for T:VisualCronAPI.Tasks._Tasks]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Tasks
Public Interface _Tasks
public interface class _Tasks
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Activate(TaskClass) |
 | Activate(String) |
 | Add(TaskClass) |
 | AddAsync(TaskClass) |
 | DeActivate(TaskClass) |
 | DeActivate(String) |
 | DoTaskExist(JobClass, TaskClass) |
 | Get(String) |
 | Get(JobClass, String) |
 | GetAllArray(String) |
 | GetJobIdByTaskId(String) |
 | GetTaskName(String, String) |
 | Remove(TaskClass) |
 | Remove(String) |
 | Run(TaskClass) |
 | Run(JobClass, TaskClass) |
 | Run(String, String) |
 | Update(TaskClass) |
 | UpdateAsync(TaskClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method

Activate Method
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Activate()()()
Members
Icon | Member | Description
 | Activate(TaskClass) |
 | Activate(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (strTaskId)

Activate Method (strTaskId)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Activate(String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Activate(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Activate(
    string strTaskId
)
Function Activate ( _
    strTaskId As String _
) As Boolean
bool Activate(
    String^ strTaskId
)
Parameters
strTaskId (String)

[Missing <param name="strTaskId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Activate(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Activate(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Activate Method (t)

Activate Method (t)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Activate(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Activate(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Activate(
    TaskClass t
)
Function Activate ( _
    t As TaskClass _
) As Boolean
bool Activate(
    TaskClass^ t
)
Parameters
t (TaskClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Activate(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Activate(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (tc)

Add Method (tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Add(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Add(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
JobClass Add(
    TaskClass tc
)
Function Add ( _
    tc As TaskClass _
) As JobClass
JobClass^ Add(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Add(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Add(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


AddAsync Method (tc)

AddAsync Method (tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► AddAsync(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.AddAsync(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool AddAsync(
    TaskClass tc
)
Function AddAsync ( _
    tc As TaskClass _
) As Boolean
bool AddAsync(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.AddAsync(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.AddAsync(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method

DeActivate Method
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► DeActivate()()()
Members
Icon | Member | Description
 | DeActivate(TaskClass) |
 | DeActivate(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (strTaskId)

DeActivate Method (strTaskId)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► DeActivate(String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.DeActivate(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool DeActivate(
    string strTaskId
)
Function DeActivate ( _
    strTaskId As String _
) As Boolean
bool DeActivate(
    String^ strTaskId
)
Parameters
strTaskId (String)

[Missing <param name="strTaskId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.DeActivate(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.DeActivate(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DeActivate Method (t)

DeActivate Method (t)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► DeActivate(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.DeActivate(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool DeActivate(
    TaskClass t
)
Function DeActivate ( _
    t As TaskClass _
) As Boolean
bool DeActivate(
    TaskClass^ t
)
Parameters
t (TaskClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Tasks._Tasks.DeActivate(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.DeActivate(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTaskExist Method (jc, tc)

DoTaskExist Method (jc, tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► DoTaskExist(JobClass, TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.DoTaskExist(VisualCron.JobClass,VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool DoTaskExist(
    JobClass jc,
    TaskClass tc
)
Function DoTaskExist ( _
    jc As JobClass, _
    tc As TaskClass _
) As Boolean
bool DoTaskExist(
    JobClass^ jc,
    TaskClass^ tc
)
Parameters
jc (JobClass)

[Missing <param name="jc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.DoTaskExist(VisualCron.JobClass,VisualCron.TaskClass)"]

tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.DoTaskExist(VisualCron.JobClass,VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.DoTaskExist(VisualCron.JobClass,VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method

Get Method
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Get()()()
Members
Icon | Member | Description
 | Get(String) |
 | Get(JobClass, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (id)

Get Method (id)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass Get(
    string id
)
Function Get ( _
    id As String _
) As TaskClass
TaskClass^ Get(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (jc, strTaskId)

Get Method (jc, strTaskId)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Get(JobClass, String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Get(VisualCron.JobClass,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TaskClass Get(
    JobClass jc,
    string strTaskId
)
Function Get ( _
    jc As JobClass, _
    strTaskId As String _
) As TaskClass
TaskClass^ Get(
    JobClass^ jc,
    String^ strTaskId
)
Parameters
jc (JobClass)

[Missing <param name="jc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Get(VisualCron.JobClass,System.String)"]

strTaskId (String)

[Missing <param name="strTaskId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Get(VisualCron.JobClass,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Get(VisualCron.JobClass,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (strJobId)

GetAllArray Method (strJobId)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► GetAllArray(String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.GetAllArray(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray(
    string strJobId
)
Function GetAllArray ( _
    strJobId As String _
) As ArrayList
ArrayList^ GetAllArray(
    String^ strJobId
)
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.GetAllArray(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.GetAllArray(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJobIdByTaskId Method (strTaskId)

GetJobIdByTaskId Method (strTaskId)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► GetJobIdByTaskId(String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.GetJobIdByTaskId(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetJobIdByTaskId(
    string strTaskId
)
Function GetJobIdByTaskId ( _
    strTaskId As String _
) As String
String^ GetJobIdByTaskId(
    String^ strTaskId
)
Parameters
strTaskId (String)

[Missing <param name="strTaskId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.GetJobIdByTaskId(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.GetJobIdByTaskId(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTaskName Method (jobid, taskid)

GetTaskName Method (jobid, taskid)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► GetTaskName(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.GetTaskName(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetTaskName(
    string jobid,
    string taskid
)
Function GetTaskName ( _
    jobid As String, _
    taskid As String _
) As String
String^ GetTaskName(
    String^ jobid,
    String^ taskid
)
Parameters
jobid (String)

[Missing <param name="jobid"/> documentation for "M:VisualCronAPI.Tasks._Tasks.GetTaskName(System.String,System.String)"]

taskid (String)

[Missing <param name="taskid"/> documentation for "M:VisualCronAPI.Tasks._Tasks.GetTaskName(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.GetTaskName(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Remove()()()
Members
Icon | Member | Description
 | Remove(TaskClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (taskId)

Remove Method (taskId)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string taskId
)
Function Remove ( _
    taskId As String _
) As Boolean
bool Remove(
    String^ taskId
)
Parameters
taskId (String)

[Missing <param name="taskId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (tc)

Remove Method (tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Remove(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Remove(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    TaskClass tc
)
Function Remove ( _
    tc As TaskClass _
) As Boolean
bool Remove(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Remove(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Remove(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method

Run Method
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Run()()()
Members
Icon | Member | Description
 | Run(TaskClass) |
 | Run(JobClass, TaskClass) |
 | Run(String, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (jobId, taskId)

Run Method (jobId, taskId)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Run(String, String)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Run(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void Run(
    string jobId,
    string taskId
)
Sub Run ( _
    jobId As String, _
    taskId As String _
)
void Run(
    String^ jobId,
    String^ taskId
)
Parameters
jobId (String)

[Missing <param name="jobId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Run(System.String,System.String)"]

taskId (String)

[Missing <param name="taskId"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Run(System.String,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (jc, tc)

Run Method (jc, tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Run(JobClass, TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Run(VisualCron.JobClass,VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
void Run(
    JobClass jc,
    TaskClass tc
)
Sub Run ( _
    jc As JobClass, _
    tc As TaskClass _
)
void Run(
    JobClass^ jc,
    TaskClass^ tc
)
Parameters
jc (JobClass)

[Missing <param name="jc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Run(VisualCron.JobClass,VisualCron.TaskClass)"]

tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Run(VisualCron.JobClass,VisualCron.TaskClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Run Method (tc)

Run Method (tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Run(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Run(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
void Run(
    TaskClass tc
)
Sub Run ( _
    tc As TaskClass _
)
void Run(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Run(VisualCron.TaskClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (tc)

Update Method (tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► Update(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.Update(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
JobClass Update(
    TaskClass tc
)
Function Update ( _
    tc As TaskClass _
) As JobClass
JobClass^ Update(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.Update(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.Update(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UpdateAsync Method (tc)

UpdateAsync Method (tc)
Namespaces ► VisualCronAPI ► Tasks..::._Tasks ► UpdateAsync(TaskClass)

[Missing <summary> documentation for M:VisualCronAPI.Tasks._Tasks.UpdateAsync(VisualCron.TaskClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool UpdateAsync(
    TaskClass tc
)
Function UpdateAsync ( _
    tc As TaskClass _
) As Boolean
bool UpdateAsync(
    TaskClass^ tc
)
Parameters
tc (TaskClass)

[Missing <param name="tc"/> documentation for "M:VisualCronAPI.Tasks._Tasks.UpdateAsync(VisualCron.TaskClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Tasks._Tasks.UpdateAsync(VisualCron.TaskClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks.DelegateOnTaskUpdated Delegate

Tasks..::.DelegateOnTaskUpdated Delegate
Namespaces ► VisualCronAPI ► Tasks ► Tasks..::.DelegateOnTaskUpdated

[Missing <summary> documentation for T:VisualCronAPI.Tasks.DelegateOnTaskUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateOnTaskUpdated(
    ref Server server,
    JobClass j,
    TaskClass t
)
Public Delegate Sub DelegateOnTaskUpdated ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TaskClass _
)
public delegate void DelegateOnTaskUpdated(
    Server^% server,
    JobClass^ j,
    TaskClass^ t
)
Parameters
server ( Server %)
j (JobClass)
t (TaskClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks.DelegateTaskAdded Delegate

Tasks..::.DelegateTaskAdded Delegate
Namespaces ► VisualCronAPI ► Tasks ► Tasks..::.DelegateTaskAdded

[Missing <summary> documentation for T:VisualCronAPI.Tasks.DelegateTaskAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTaskAdded(
    ref Server server,
    JobClass j,
    TaskClass t
)
Public Delegate Sub DelegateTaskAdded ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TaskClass _
)
public delegate void DelegateTaskAdded(
    Server^% server,
    JobClass^ j,
    TaskClass^ t
)
Parameters
server ( Server %)
j (JobClass)
t (TaskClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks.DelegateTaskRemoved Delegate

Tasks..::.DelegateTaskRemoved Delegate
Namespaces ► VisualCronAPI ► Tasks ► Tasks..::.DelegateTaskRemoved

[Missing <summary> documentation for T:VisualCronAPI.Tasks.DelegateTaskRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTaskRemoved(
    ref Server server,
    JobClass j,
    TaskClass t
)
Public Delegate Sub DelegateTaskRemoved ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TaskClass _
)
public delegate void DelegateTaskRemoved(
    Server^% server,
    JobClass^ j,
    TaskClass^ t
)
Parameters
server ( Server %)
j (JobClass)
t (TaskClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks.TaskNotFoundException Class

Tasks..::.TaskNotFoundException Class
Namespaces ► VisualCronAPI ► Tasks ► Tasks..::.TaskNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Tasks.TaskNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class TaskNotFoundException : Exception
Public Class TaskNotFoundException _
    Inherits Exception
public ref class TaskNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Tasks..::.TaskNotFoundException(String) | Initializes a new instance of the Tasks..::.TaskNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Tasks..::.TaskNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Tasks.TaskNotFoundException Constructor (id)

Tasks..::.TaskNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Tasks..::.TaskNotFoundException ► Tasks..::.TaskNotFoundException(String)
Initializes a new instance of the Tasks..::.TaskNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public TaskNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
TaskNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Tasks.TaskNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeAPI Class

TimeAPI Class
Namespaces ► VisualCronAPI ► TimeAPI

[Missing <summary> documentation for T:VisualCronAPI.TimeAPI]

Declaration Syntax
C# Visual Basic Visual C++
public class TimeAPI
Public Class TimeAPI
public ref class TimeAPI
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeAPI()()() | Initializes a new instance of the TimeAPI class
 | DAYS |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitDays()()() |
 | InitMonths()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MONTHS |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
TimeAPI

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeAPI Constructor

TimeAPI Constructor
Namespaces ► VisualCronAPI ► TimeAPI ► TimeAPI()()()
Initializes a new instance of the TimeAPI class
Declaration Syntax
C# Visual Basic Visual C++
public TimeAPI()
Public Sub New
public:
TimeAPI()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DAYS Field

DAYS Field
Namespaces ► VisualCronAPI ► TimeAPI ► DAYS

[Missing <summary> documentation for F:VisualCronAPI.TimeAPI.DAYS]

Declaration Syntax
C# Visual Basic Visual C++
public static DayClass[] DAYS
Public Shared DAYS As DayClass()
public:
static array<DayClass^>^ DAYS

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InitDays Method

InitDays Method
Namespaces ► VisualCronAPI ► TimeAPI ► InitDays()()()

[Missing <summary> documentation for M:VisualCronAPI.TimeAPI.InitDays]

Declaration Syntax
C# Visual Basic Visual C++
public static void InitDays()
Public Shared Sub InitDays
public:
static void InitDays()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


InitMonths Method

InitMonths Method
Namespaces ► VisualCronAPI ► TimeAPI ► InitMonths()()()

[Missing <summary> documentation for M:VisualCronAPI.TimeAPI.InitMonths]

Declaration Syntax
C# Visual Basic Visual C++
public static void InitMonths()
Public Shared Sub InitMonths
public:
static void InitMonths()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


MONTHS Field

MONTHS Field
Namespaces ► VisualCronAPI ► TimeAPI ► MONTHS

[Missing <summary> documentation for F:VisualCronAPI.TimeAPI.MONTHS]

Declaration Syntax
C# Visual Basic Visual C++
public static MonthClass[] MONTHS
Public Shared MONTHS As MonthClass()
public:
static array<MonthClass^>^ MONTHS

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions Class

TimeExceptions Class
Namespaces ► VisualCronAPI ► TimeExceptions
Base class for Time exception Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class TimeExceptions : TimeExceptions..::._TimeExceptions
Public Class TimeExceptions _
    Implements TimeExceptions..::._TimeExceptions
public ref class TimeExceptions : TimeExceptions..::._TimeExceptions
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeExceptions(Server) | Initializes a new instance of the TimeExceptions class
 | Add(TimeExceptionCollectionClass) | Addss a Time Exception Collection
 | Add(TimeExceptionClass) | Adds a Time Exception
 | Contains(String) | Returns true if the list of Time Exception collections contain specified Id
 | DoTimeExceptionExist(TimeExceptionCollectionClass, TimeExceptionClass) | Checks if a certain TimeException exists
 | DoTimeExceptionExist(String, String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EventTimeExceptionUpdated | This event is raised when a TimeException has been updated
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Connection based on the string key Id
 | Get(String, String) | Return a specific TimeException
 | GetAll()()() | Returns an list of TimeExceptionCollections
 | GetAllArray()()() | Returns an array of TimeExceptionCollections
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RemoveAll()()() | Removes all Time Exception collections
 | RemoveCollection(TimeExceptionCollectionClass) | Removes a TimeExceptionCollection
 | RemoveCollection(String) | Removes a TimeExceptionCollection
 | RemoveException(TimeExceptionClass) | Removes a Time Exception
 | RemoveException(String, String) | Removes a Time Exception
 | TimeExceptionAdded | This event is raised when a TimeException has been added
 | TimeExceptionAddedStatic | This event is raised when a TimeException has been added
 | TimeExceptionCollectionAdded | This event is raised when a TimeExceptionCollection has been added
 | TimeExceptionCollectionAddedStatic | This event is raised when a TimeExceptionCollection has been added
 | TimeExceptionCollectionRemoved | This event is raised when a TimeExceptionCollection has been removed
 | TimeExceptionCollectionRemovedStatic | This event is raised when a TimeExceptionCollection has been removed
 | TimeExceptionCollectionUpdated | This event is raised when a TimeExceptionCollection has been updated
 | TimeExceptionCollectionUpdatedStatic | This event is raised when a TimeExceptionCollection has been updated
 | TimeExceptionRemoved | This event is raised when a TimeException has been removed
 | TimeExceptionRemovedStatic | This event is raised when a TimeException has been removed
 | TimeExceptionUpdatedStatic | This event is raised when a TimeException has been updated
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(TimeExceptionCollectionClass) | Updates a Time Exception Collection
 | Update(TimeExceptionClass) | Updates a Time Exception
Remarks
Inheritance Hierarchy
Object
TimeExceptions

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions Constructor (s)

TimeExceptions Constructor (s)
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions(Server)
Initializes a new instance of the TimeExceptions class
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptions(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
TimeExceptions(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.TimeExceptions.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method

Add Method
Namespaces ► VisualCronAPI ► TimeExceptions ► Add()()()
Members
Icon | Member | Description
 | Add(TimeExceptionCollectionClass) | Addss a Time Exception Collection
 | Add(TimeExceptionClass) | Adds a Time Exception

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (tec)

Add Method (tec)
Namespaces ► VisualCronAPI ► TimeExceptions ► Add(TimeExceptionClass)
Adds a Time Exception
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionClass Add(
    TimeExceptionClass tec
)
Public Function Add ( _
    tec As TimeExceptionClass _
) As TimeExceptionClass
public:
virtual TimeExceptionClass^ Add(
    TimeExceptionClass^ tec
) sealed
Parameters
tec (TimeExceptionClass)
a TimeException
Return Value
a TimeException
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (tecc)

Add Method (tecc)
Namespaces ► VisualCronAPI ► TimeExceptions ► Add(TimeExceptionCollectionClass)
Addss a Time Exception Collection
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionClass Add(
    TimeExceptionCollectionClass tecc
)
Public Function Add ( _
    tecc As TimeExceptionCollectionClass _
) As TimeExceptionCollectionClass
public:
virtual TimeExceptionCollectionClass^ Add(
    TimeExceptionCollectionClass^ tecc
) sealed
Parameters
tecc (TimeExceptionCollectionClass)
a TimeExceptionCollection
Return Value
a TimeExceptionCollection
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strCollectionId)

Contains Method (strCollectionId)
Namespaces ► VisualCronAPI ► TimeExceptions ► Contains(String)
Returns true if the list of Time Exception collections contain specified Id
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strCollectionId
)
Public Function Contains ( _
    strCollectionId As String _
) As Boolean
public:
virtual bool Contains(
    String^ strCollectionId
) sealed
Parameters
strCollectionId (String)

[Missing <param name="strCollectionId"/> documentation for "M:VisualCronAPI.TimeExceptions.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTimeExceptionExist Method

DoTimeExceptionExist Method
Namespaces ► VisualCronAPI ► TimeExceptions ► DoTimeExceptionExist()()()
Members
Icon | Member | Description
 | DoTimeExceptionExist(TimeExceptionCollectionClass, TimeExceptionClass) | Checks if a certain TimeException exists
 | DoTimeExceptionExist(String, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTimeExceptionExist Method (strCollectionId, strExceptionId)

DoTimeExceptionExist Method (strCollectionId, strExceptionId)
Namespaces ► VisualCronAPI ► TimeExceptions ► DoTimeExceptionExist(String, String)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions.DoTimeExceptionExist(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool DoTimeExceptionExist(
    string strCollectionId,
    string strExceptionId
)
Public Function DoTimeExceptionExist ( _
    strCollectionId As String, _
    strExceptionId As String _
) As Boolean
public:
virtual bool DoTimeExceptionExist(
    String^ strCollectionId,
    String^ strExceptionId
) sealed
Parameters
strCollectionId (String)

[Missing <param name="strCollectionId"/> documentation for "M:VisualCronAPI.TimeExceptions.DoTimeExceptionExist(System.String,System.String)"]

strExceptionId (String)

[Missing <param name="strExceptionId"/> documentation for "M:VisualCronAPI.TimeExceptions.DoTimeExceptionExist(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions.DoTimeExceptionExist(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTimeExceptionExist Method (tec, te)

DoTimeExceptionExist Method (tec, te)
Namespaces ► VisualCronAPI ► TimeExceptions ► DoTimeExceptionExist(TimeExceptionCollectionClass, TimeExceptionClass)
Checks if a certain TimeException exists
Declaration Syntax
C# Visual Basic Visual C++
public bool DoTimeExceptionExist(
    TimeExceptionCollectionClass tec,
    TimeExceptionClass te
)
Public Function DoTimeExceptionExist ( _
    tec As TimeExceptionCollectionClass, _
    te As TimeExceptionClass _
) As Boolean
public:
virtual bool DoTimeExceptionExist(
    TimeExceptionCollectionClass^ tec,
    TimeExceptionClass^ te
) sealed
Parameters
tec (TimeExceptionCollectionClass)
TimeExceptionCollection
te (TimeExceptionClass)
TimeException
Return Value
true if existing
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventTimeExceptionUpdated Event

EventTimeExceptionUpdated Event
Namespaces ► VisualCronAPI ► TimeExceptions ► EventTimeExceptionUpdated
This event is raised when a TimeException has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event TimeExceptions..::.DelegateTimeExceptionUpdated EventTimeExceptionUpdated
Public Event EventTimeExceptionUpdated As TimeExceptions..::.DelegateTimeExceptionUpdated
public:
 event TimeExceptions..::.DelegateTimeExceptionUpdated^ EventTimeExceptionUpdated {
    void add (TimeExceptions..::.DelegateTimeExceptionUpdated^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method

Get Method
Namespaces ► VisualCronAPI ► TimeExceptions ► Get()()()
Members
Icon | Member | Description
 | Get(String) | Returns a Connection based on the string key Id
 | Get(String, String) | Return a specific TimeException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (timeExceptionCollectionId)

Get Method (timeExceptionCollectionId)
Namespaces ► VisualCronAPI ► TimeExceptions ► Get(String)
Returns a Connection based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionClass Get(
    string timeExceptionCollectionId
)
Public Function Get ( _
    timeExceptionCollectionId As String _
) As TimeExceptionCollectionClass
public:
virtual TimeExceptionCollectionClass^ Get(
    String^ timeExceptionCollectionId
) sealed
Parameters
timeExceptionCollectionId (String)
string key
Return Value
a Connection
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (strId, strCollectionId)

Get Method (strId, strCollectionId)
Namespaces ► VisualCronAPI ► TimeExceptions ► Get(String, String)
Return a specific TimeException
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionClass Get(
    string strId,
    string strCollectionId
)
Public Function Get ( _
    strId As String, _
    strCollectionId As String _
) As TimeExceptionClass
public:
virtual TimeExceptionClass^ Get(
    String^ strId,
    String^ strCollectionId
) sealed
Parameters
strId (String)
id of TimeException
strCollectionId (String)
id of TimeExceptionCollection
Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions.Get(System.String,System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method

GetAll Method
Namespaces ► VisualCronAPI ► TimeExceptions ► GetAll()()()
Returns an list of TimeExceptionCollections
Declaration Syntax
C# Visual Basic Visual C++
public List<TimeExceptionCollectionClass> GetAll()
Public Function GetAll As List(Of TimeExceptionCollectionClass)
public:
List<TimeExceptionCollectionClass^>^ GetAll()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions.GetAll]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► TimeExceptions ► GetAllArray()()()
Returns an array of TimeExceptionCollections
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray()
Public Function GetAllArray As ArrayList
public:
virtual ArrayList^ GetAllArray() sealed
Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions.GetAllArray]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► TimeExceptions ► RemoveAll()()()
Removes all Time Exception collections
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveCollection Method

RemoveCollection Method
Namespaces ► VisualCronAPI ► TimeExceptions ► RemoveCollection()()()
Members
Icon | Member | Description
 | RemoveCollection(TimeExceptionCollectionClass) | Removes a TimeExceptionCollection
 | RemoveCollection(String) | Removes a TimeExceptionCollection

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveCollection Method (teccId)

RemoveCollection Method (teccId)
Namespaces ► VisualCronAPI ► TimeExceptions ► RemoveCollection(String)
Removes a TimeExceptionCollection
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveCollection(
    string teccId
)
Public Function RemoveCollection ( _
    teccId As String _
) As Boolean
public:
virtual bool RemoveCollection(
    String^ teccId
) sealed
Parameters
teccId (String)
Id of TimeExceptionCollection
Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions.RemoveCollection(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveCollection Method (tecc)

RemoveCollection Method (tecc)
Namespaces ► VisualCronAPI ► TimeExceptions ► RemoveCollection(TimeExceptionCollectionClass)
Removes a TimeExceptionCollection
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveCollection(
    TimeExceptionCollectionClass tecc
)
Public Function RemoveCollection ( _
    tecc As TimeExceptionCollectionClass _
) As Boolean
public:
virtual bool RemoveCollection(
    TimeExceptionCollectionClass^ tecc
) sealed
Parameters
tecc (TimeExceptionCollectionClass)
a TimeExceptionCollection
Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions.RemoveCollection(VisualCron.TimeExceptionCollectionClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveException Method

RemoveException Method
Namespaces ► VisualCronAPI ► TimeExceptions ► RemoveException()()()
Members
Icon | Member | Description
 | RemoveException(TimeExceptionClass) | Removes a Time Exception
 | RemoveException(String, String) | Removes a Time Exception

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveException Method (strCollectionId, strExceptionId)

RemoveException Method (strCollectionId, strExceptionId)
Namespaces ► VisualCronAPI ► TimeExceptions ► RemoveException(String, String)
Removes a Time Exception
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveException(
    string strCollectionId,
    string strExceptionId
)
Public Function RemoveException ( _
    strCollectionId As String, _
    strExceptionId As String _
) As Boolean
public:
virtual bool RemoveException(
    String^ strCollectionId,
    String^ strExceptionId
) sealed
Parameters
strCollectionId (String)
Id of Time Exception Collection
strExceptionId (String)
Id of Time Exception
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveException Method (tec)

RemoveException Method (tec)
Namespaces ► VisualCronAPI ► TimeExceptions ► RemoveException(TimeExceptionClass)
Removes a Time Exception
Declaration Syntax
C# Visual Basic Visual C++
public bool RemoveException(
    TimeExceptionClass tec
)
Public Function RemoveException ( _
    tec As TimeExceptionClass _
) As Boolean
public:
virtual bool RemoveException(
    TimeExceptionClass^ tec
) sealed
Parameters
tec (TimeExceptionClass)
A Time Exception object
Return Value
true on success
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionAdded Event

TimeExceptionAdded Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionAdded
This event is raised when a TimeException has been added
Declaration Syntax
C# Visual Basic Visual C++
public event TimeExceptions..::.DelegateTimeExceptionAdded TimeExceptionAdded
Public Event TimeExceptionAdded As TimeExceptions..::.DelegateTimeExceptionAdded
public:
 event TimeExceptions..::.DelegateTimeExceptionAdded^ TimeExceptionAdded {
    void add (TimeExceptions..::.DelegateTimeExceptionAdded^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionAddedStatic Event

TimeExceptionAddedStatic Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionAddedStatic
This event is raised when a TimeException has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event TimeExceptions..::.DelegateTimeExceptionAdded TimeExceptionAddedStatic
Public Shared Event TimeExceptionAddedStatic As TimeExceptions..::.DelegateTimeExceptionAdded
public:
static  event TimeExceptions..::.DelegateTimeExceptionAdded^ TimeExceptionAddedStatic {
    void add (TimeExceptions..::.DelegateTimeExceptionAdded^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionAdded Event

TimeExceptionCollectionAdded Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionCollectionAdded
This event is raised when a TimeExceptionCollection has been added
Declaration Syntax
C# Visual Basic Visual C++
public event TimeExceptions..::.DelegateTimeExceptionCollectionAdded TimeExceptionCollectionAdded
Public Event TimeExceptionCollectionAdded As TimeExceptions..::.DelegateTimeExceptionCollectionAdded
public:
 event TimeExceptions..::.DelegateTimeExceptionCollectionAdded^ TimeExceptionCollectionAdded {
    void add (TimeExceptions..::.DelegateTimeExceptionCollectionAdded^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionCollectionAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionAddedStatic Event

TimeExceptionCollectionAddedStatic Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionCollectionAddedStatic
This event is raised when a TimeExceptionCollection has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event TimeExceptions..::.DelegateTimeExceptionCollectionAdded TimeExceptionCollectionAddedStatic
Public Shared Event TimeExceptionCollectionAddedStatic As TimeExceptions..::.DelegateTimeExceptionCollectionAdded
public:
static  event TimeExceptions..::.DelegateTimeExceptionCollectionAdded^ TimeExceptionCollectionAddedStatic {
    void add (TimeExceptions..::.DelegateTimeExceptionCollectionAdded^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionCollectionAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionRemoved Event

TimeExceptionCollectionRemoved Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionCollectionRemoved
This event is raised when a TimeExceptionCollection has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event TimeExceptions..::.DelegateTimeExceptionCollectionRemoved TimeExceptionCollectionRemoved
Public Event TimeExceptionCollectionRemoved As TimeExceptions..::.DelegateTimeExceptionCollectionRemoved
public:
 event TimeExceptions..::.DelegateTimeExceptionCollectionRemoved^ TimeExceptionCollectionRemoved {
    void add (TimeExceptions..::.DelegateTimeExceptionCollectionRemoved^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionCollectionRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionRemovedStatic Event

TimeExceptionCollectionRemovedStatic Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionCollectionRemovedStatic
This event is raised when a TimeExceptionCollection has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event TimeExceptions..::.DelegateTimeExceptionCollectionRemoved TimeExceptionCollectionRemovedStatic
Public Shared Event TimeExceptionCollectionRemovedStatic As TimeExceptions..::.DelegateTimeExceptionCollectionRemoved
public:
static  event TimeExceptions..::.DelegateTimeExceptionCollectionRemoved^ TimeExceptionCollectionRemovedStatic {
    void add (TimeExceptions..::.DelegateTimeExceptionCollectionRemoved^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionCollectionRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionUpdated Event

TimeExceptionCollectionUpdated Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionCollectionUpdated
This event is raised when a TimeExceptionCollection has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event TimeExceptions..::.DelegateTimeExceptionCollectionUpdated TimeExceptionCollectionUpdated
Public Event TimeExceptionCollectionUpdated As TimeExceptions..::.DelegateTimeExceptionCollectionUpdated
public:
 event TimeExceptions..::.DelegateTimeExceptionCollectionUpdated^ TimeExceptionCollectionUpdated {
    void add (TimeExceptions..::.DelegateTimeExceptionCollectionUpdated^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionCollectionUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionUpdatedStatic Event

TimeExceptionCollectionUpdatedStatic Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionCollectionUpdatedStatic
This event is raised when a TimeExceptionCollection has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event TimeExceptions..::.DelegateTimeExceptionCollectionUpdated TimeExceptionCollectionUpdatedStatic
Public Shared Event TimeExceptionCollectionUpdatedStatic As TimeExceptions..::.DelegateTimeExceptionCollectionUpdated
public:
static  event TimeExceptions..::.DelegateTimeExceptionCollectionUpdated^ TimeExceptionCollectionUpdatedStatic {
    void add (TimeExceptions..::.DelegateTimeExceptionCollectionUpdated^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionCollectionUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionRemoved Event

TimeExceptionRemoved Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionRemoved
This event is raised when a TimeException has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event TimeExceptions..::.DelegateTimeExceptionRemoved TimeExceptionRemoved
Public Event TimeExceptionRemoved As TimeExceptions..::.DelegateTimeExceptionRemoved
public:
 event TimeExceptions..::.DelegateTimeExceptionRemoved^ TimeExceptionRemoved {
    void add (TimeExceptions..::.DelegateTimeExceptionRemoved^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionRemovedStatic Event

TimeExceptionRemovedStatic Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionRemovedStatic
This event is raised when a TimeException has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event TimeExceptions..::.DelegateTimeExceptionRemoved TimeExceptionRemovedStatic
Public Shared Event TimeExceptionRemovedStatic As TimeExceptions..::.DelegateTimeExceptionRemoved
public:
static  event TimeExceptions..::.DelegateTimeExceptionRemoved^ TimeExceptionRemovedStatic {
    void add (TimeExceptions..::.DelegateTimeExceptionRemoved^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionUpdatedStatic Event

TimeExceptionUpdatedStatic Event
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptionUpdatedStatic
This event is raised when a TimeException has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event TimeExceptions..::.DelegateTimeExceptionUpdated TimeExceptionUpdatedStatic
Public Shared Event TimeExceptionUpdatedStatic As TimeExceptions..::.DelegateTimeExceptionUpdated
public:
static  event TimeExceptions..::.DelegateTimeExceptionUpdated^ TimeExceptionUpdatedStatic {
    void add (TimeExceptions..::.DelegateTimeExceptionUpdated^ value);
    void remove (TimeExceptions..::.DelegateTimeExceptionUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method

Update Method
Namespaces ► VisualCronAPI ► TimeExceptions ► Update()()()
Members
Icon | Member | Description
 | Update(TimeExceptionCollectionClass) | Updates a Time Exception Collection
 | Update(TimeExceptionClass) | Updates a Time Exception

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (tec)

Update Method (tec)
Namespaces ► VisualCronAPI ► TimeExceptions ► Update(TimeExceptionClass)
Updates a Time Exception
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionClass Update(
    TimeExceptionClass tec
)
Public Function Update ( _
    tec As TimeExceptionClass _
) As TimeExceptionClass
public:
virtual TimeExceptionClass^ Update(
    TimeExceptionClass^ tec
) sealed
Parameters
tec (TimeExceptionClass)
a TimeException
Return Value
a TimeException
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (tecc)

Update Method (tecc)
Namespaces ► VisualCronAPI ► TimeExceptions ► Update(TimeExceptionCollectionClass)
Updates a Time Exception Collection
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionClass Update(
    TimeExceptionCollectionClass tecc
)
Public Function Update ( _
    tecc As TimeExceptionCollectionClass _
) As TimeExceptionCollectionClass
public:
virtual TimeExceptionCollectionClass^ Update(
    TimeExceptionCollectionClass^ tecc
) sealed
Parameters
tecc (TimeExceptionCollectionClass)
a TimeExceptionCollection
Return Value
a TimeExceptionCollection
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.__TimeExceptions Interface

TimeExceptions..::.__TimeExceptions Interface
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.__TimeExceptions

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.__TimeExceptions]

Declaration Syntax
C# Visual Basic Visual C++
public interface __TimeExceptions
Public Interface __TimeExceptions
public interface class __TimeExceptions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EventTimeExceptionUpdated(Server%, TimeExceptionClass) |
 | TimeExceptionAdded(Server%, TimeExceptionClass) |
 | TimeExceptionCollectionAdded(Server%, TimeExceptionCollectionClass) |
 | TimeExceptionCollectionRemoved(Server%, TimeExceptionCollectionClass) |
 | TimeExceptionCollectionUpdated(Server%, TimeExceptionCollectionClass) |
 | TimeExceptionRemoved(Server%, TimeExceptionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


EventTimeExceptionUpdated Method (server, t)

EventTimeExceptionUpdated Method (server, t)
Namespaces ► VisualCronAPI ► TimeExceptions..::.__TimeExceptions ► EventTimeExceptionUpdated(Server%, TimeExceptionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions.__TimeExceptions.EventTimeExceptionUpdated(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void EventTimeExceptionUpdated(
    ref Server server,
    TimeExceptionClass t
)
Sub EventTimeExceptionUpdated ( _
    ByRef server As Server, _
    t As TimeExceptionClass _
)
void EventTimeExceptionUpdated(
    Server^% server,
    TimeExceptionClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.EventTimeExceptionUpdated(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)"]

t (TimeExceptionClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.EventTimeExceptionUpdated(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionAdded Method (server, t)

TimeExceptionAdded Method (server, t)
Namespaces ► VisualCronAPI ► TimeExceptions..::.__TimeExceptions ► TimeExceptionAdded(Server%, TimeExceptionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionAdded(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TimeExceptionAdded(
    ref Server server,
    TimeExceptionClass t
)
Sub TimeExceptionAdded ( _
    ByRef server As Server, _
    t As TimeExceptionClass _
)
void TimeExceptionAdded(
    Server^% server,
    TimeExceptionClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionAdded(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)"]

t (TimeExceptionClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionAdded(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionAdded Method (server, t)

TimeExceptionCollectionAdded Method (server, t)
Namespaces ► VisualCronAPI ► TimeExceptions..::.__TimeExceptions ► TimeExceptionCollectionAdded(Server%, TimeExceptionCollectionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionAdded(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TimeExceptionCollectionAdded(
    ref Server server,
    TimeExceptionCollectionClass t
)
Sub TimeExceptionCollectionAdded ( _
    ByRef server As Server, _
    t As TimeExceptionCollectionClass _
)
void TimeExceptionCollectionAdded(
    Server^% server,
    TimeExceptionCollectionClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionAdded(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)"]

t (TimeExceptionCollectionClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionAdded(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionRemoved Method (server, t)

TimeExceptionCollectionRemoved Method (server, t)
Namespaces ► VisualCronAPI ► TimeExceptions..::.__TimeExceptions ► TimeExceptionCollectionRemoved(Server%, TimeExceptionCollectionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionRemoved(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TimeExceptionCollectionRemoved(
    ref Server server,
    TimeExceptionCollectionClass t
)
Sub TimeExceptionCollectionRemoved ( _
    ByRef server As Server, _
    t As TimeExceptionCollectionClass _
)
void TimeExceptionCollectionRemoved(
    Server^% server,
    TimeExceptionCollectionClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionRemoved(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)"]

t (TimeExceptionCollectionClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionRemoved(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionCollectionUpdated Method (server, t)

TimeExceptionCollectionUpdated Method (server, t)
Namespaces ► VisualCronAPI ► TimeExceptions..::.__TimeExceptions ► TimeExceptionCollectionUpdated(Server%, TimeExceptionCollectionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionUpdated(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TimeExceptionCollectionUpdated(
    ref Server server,
    TimeExceptionCollectionClass t
)
Sub TimeExceptionCollectionUpdated ( _
    ByRef server As Server, _
    t As TimeExceptionCollectionClass _
)
void TimeExceptionCollectionUpdated(
    Server^% server,
    TimeExceptionCollectionClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionUpdated(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)"]

t (TimeExceptionCollectionClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionCollectionUpdated(VisualCronAPI.Server@,VisualCron.TimeExceptionCollectionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptionRemoved Method (server, t)

TimeExceptionRemoved Method (server, t)
Namespaces ► VisualCronAPI ► TimeExceptions..::.__TimeExceptions ► TimeExceptionRemoved(Server%, TimeExceptionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionRemoved(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TimeExceptionRemoved(
    ref Server server,
    TimeExceptionClass t
)
Sub TimeExceptionRemoved ( _
    ByRef server As Server, _
    t As TimeExceptionClass _
)
void TimeExceptionRemoved(
    Server^% server,
    TimeExceptionClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionRemoved(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)"]

t (TimeExceptionClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.TimeExceptions.__TimeExceptions.TimeExceptionRemoved(VisualCronAPI.Server@,VisualCron.TimeExceptionClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions._TimeExceptions Interface

TimeExceptions..::._TimeExceptions Interface
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::._TimeExceptions

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions._TimeExceptions]

Declaration Syntax
C# Visual Basic Visual C++
public interface _TimeExceptions
Public Interface _TimeExceptions
public interface class _TimeExceptions
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(TimeExceptionCollectionClass) |
 | Add(TimeExceptionClass) |
 | Contains(String) |
 | DoTimeExceptionExist(TimeExceptionCollectionClass, TimeExceptionClass) |
 | DoTimeExceptionExist(String, String) |
 | Get(String) |
 | Get(String, String) |
 | GetAllArray()()() |
 | RemoveAll()()() |
 | RemoveCollection(TimeExceptionCollectionClass) |
 | RemoveCollection(String) |
 | RemoveException(TimeExceptionClass) |
 | RemoveException(String, String) |
 | Update(TimeExceptionCollectionClass) |
 | Update(TimeExceptionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method

Add Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Add()()()
Members
Icon | Member | Description
 | Add(TimeExceptionCollectionClass) |
 | Add(TimeExceptionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (tec)

Add Method (tec)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Add(TimeExceptionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Add(VisualCron.TimeExceptionClass)]

Declaration Syntax
C# Visual Basic Visual C++
TimeExceptionClass Add(
    TimeExceptionClass tec
)
Function Add ( _
    tec As TimeExceptionClass _
) As TimeExceptionClass
TimeExceptionClass^ Add(
    TimeExceptionClass^ tec
)
Parameters
tec (TimeExceptionClass)

[Missing <param name="tec"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Add(VisualCron.TimeExceptionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Add(VisualCron.TimeExceptionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (tecc)

Add Method (tecc)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Add(TimeExceptionCollectionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Add(VisualCron.TimeExceptionCollectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
TimeExceptionCollectionClass Add(
    TimeExceptionCollectionClass tecc
)
Function Add ( _
    tecc As TimeExceptionCollectionClass _
) As TimeExceptionCollectionClass
TimeExceptionCollectionClass^ Add(
    TimeExceptionCollectionClass^ tecc
)
Parameters
tecc (TimeExceptionCollectionClass)

[Missing <param name="tecc"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Add(VisualCron.TimeExceptionCollectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Add(VisualCron.TimeExceptionCollectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strCollectionId)

Contains Method (strCollectionId)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string strCollectionId
)
Function Contains ( _
    strCollectionId As String _
) As Boolean
bool Contains(
    String^ strCollectionId
)
Parameters
strCollectionId (String)

[Missing <param name="strCollectionId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTimeExceptionExist Method

DoTimeExceptionExist Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► DoTimeExceptionExist()()()
Members
Icon | Member | Description
 | DoTimeExceptionExist(TimeExceptionCollectionClass, TimeExceptionClass) |
 | DoTimeExceptionExist(String, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTimeExceptionExist Method (strCollectionId, strExceptionId)

DoTimeExceptionExist Method (strCollectionId, strExceptionId)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► DoTimeExceptionExist(String, String)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool DoTimeExceptionExist(
    string strCollectionId,
    string strExceptionId
)
Function DoTimeExceptionExist ( _
    strCollectionId As String, _
    strExceptionId As String _
) As Boolean
bool DoTimeExceptionExist(
    String^ strCollectionId,
    String^ strExceptionId
)
Parameters
strCollectionId (String)

[Missing <param name="strCollectionId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(System.String,System.String)"]

strExceptionId (String)

[Missing <param name="strExceptionId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTimeExceptionExist Method (tec, te)

DoTimeExceptionExist Method (tec, te)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► DoTimeExceptionExist(TimeExceptionCollectionClass, TimeExceptionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(VisualCron.TimeExceptionCollectionClass,VisualCron.TimeExceptionClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool DoTimeExceptionExist(
    TimeExceptionCollectionClass tec,
    TimeExceptionClass te
)
Function DoTimeExceptionExist ( _
    tec As TimeExceptionCollectionClass, _
    te As TimeExceptionClass _
) As Boolean
bool DoTimeExceptionExist(
    TimeExceptionCollectionClass^ tec,
    TimeExceptionClass^ te
)
Parameters
tec (TimeExceptionCollectionClass)

[Missing <param name="tec"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(VisualCron.TimeExceptionCollectionClass,VisualCron.TimeExceptionClass)"]

te (TimeExceptionClass)

[Missing <param name="te"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(VisualCron.TimeExceptionCollectionClass,VisualCron.TimeExceptionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.DoTimeExceptionExist(VisualCron.TimeExceptionCollectionClass,VisualCron.TimeExceptionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method

Get Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Get()()()
Members
Icon | Member | Description
 | Get(String) |
 | Get(String, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (timeExceptionCollectionId)

Get Method (timeExceptionCollectionId)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TimeExceptionCollectionClass Get(
    string timeExceptionCollectionId
)
Function Get ( _
    timeExceptionCollectionId As String _
) As TimeExceptionCollectionClass
TimeExceptionCollectionClass^ Get(
    String^ timeExceptionCollectionId
)
Parameters
timeExceptionCollectionId (String)

[Missing <param name="timeExceptionCollectionId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (strId, strCollectionId)

Get Method (strId, strCollectionId)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Get(String, String)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Get(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TimeExceptionClass Get(
    string strId,
    string strCollectionId
)
Function Get ( _
    strId As String, _
    strCollectionId As String _
) As TimeExceptionClass
TimeExceptionClass^ Get(
    String^ strId,
    String^ strCollectionId
)
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Get(System.String,System.String)"]

strCollectionId (String)

[Missing <param name="strCollectionId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Get(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Get(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method

GetAllArray Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► GetAllArray()()()

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.GetAllArray]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray()
Function GetAllArray As ArrayList
ArrayList^ GetAllArray()
Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.GetAllArray]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveCollection Method

RemoveCollection Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► RemoveCollection()()()
Members
Icon | Member | Description
 | RemoveCollection(TimeExceptionCollectionClass) |
 | RemoveCollection(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveCollection Method (teccId)

RemoveCollection Method (teccId)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► RemoveCollection(String)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveCollection(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool RemoveCollection(
    string teccId
)
Function RemoveCollection ( _
    teccId As String _
) As Boolean
bool RemoveCollection(
    String^ teccId
)
Parameters
teccId (String)

[Missing <param name="teccId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveCollection(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveCollection(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveCollection Method (tecc)

RemoveCollection Method (tecc)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► RemoveCollection(TimeExceptionCollectionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveCollection(VisualCron.TimeExceptionCollectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool RemoveCollection(
    TimeExceptionCollectionClass tecc
)
Function RemoveCollection ( _
    tecc As TimeExceptionCollectionClass _
) As Boolean
bool RemoveCollection(
    TimeExceptionCollectionClass^ tecc
)
Parameters
tecc (TimeExceptionCollectionClass)

[Missing <param name="tecc"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveCollection(VisualCron.TimeExceptionCollectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveCollection(VisualCron.TimeExceptionCollectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveException Method

RemoveException Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► RemoveException()()()
Members
Icon | Member | Description
 | RemoveException(TimeExceptionClass) |
 | RemoveException(String, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveException Method (strCollectionId, strExceptionId)

RemoveException Method (strCollectionId, strExceptionId)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► RemoveException(String, String)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveException(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool RemoveException(
    string strCollectionId,
    string strExceptionId
)
Function RemoveException ( _
    strCollectionId As String, _
    strExceptionId As String _
) As Boolean
bool RemoveException(
    String^ strCollectionId,
    String^ strExceptionId
)
Parameters
strCollectionId (String)

[Missing <param name="strCollectionId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveException(System.String,System.String)"]

strExceptionId (String)

[Missing <param name="strExceptionId"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveException(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveException(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveException Method (tec)

RemoveException Method (tec)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► RemoveException(TimeExceptionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveException(VisualCron.TimeExceptionClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool RemoveException(
    TimeExceptionClass tec
)
Function RemoveException ( _
    tec As TimeExceptionClass _
) As Boolean
bool RemoveException(
    TimeExceptionClass^ tec
)
Parameters
tec (TimeExceptionClass)

[Missing <param name="tec"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveException(VisualCron.TimeExceptionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.RemoveException(VisualCron.TimeExceptionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method

Update Method
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Update()()()
Members
Icon | Member | Description
 | Update(TimeExceptionCollectionClass) |
 | Update(TimeExceptionClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (tec)

Update Method (tec)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Update(TimeExceptionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Update(VisualCron.TimeExceptionClass)]

Declaration Syntax
C# Visual Basic Visual C++
TimeExceptionClass Update(
    TimeExceptionClass tec
)
Function Update ( _
    tec As TimeExceptionClass _
) As TimeExceptionClass
TimeExceptionClass^ Update(
    TimeExceptionClass^ tec
)
Parameters
tec (TimeExceptionClass)

[Missing <param name="tec"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Update(VisualCron.TimeExceptionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Update(VisualCron.TimeExceptionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (tecc)

Update Method (tecc)
Namespaces ► VisualCronAPI ► TimeExceptions..::._TimeExceptions ► Update(TimeExceptionCollectionClass)

[Missing <summary> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Update(VisualCron.TimeExceptionCollectionClass)]

Declaration Syntax
C# Visual Basic Visual C++
TimeExceptionCollectionClass Update(
    TimeExceptionCollectionClass tecc
)
Function Update ( _
    tecc As TimeExceptionCollectionClass _
) As TimeExceptionCollectionClass
TimeExceptionCollectionClass^ Update(
    TimeExceptionCollectionClass^ tecc
)
Parameters
tecc (TimeExceptionCollectionClass)

[Missing <param name="tecc"/> documentation for "M:VisualCronAPI.TimeExceptions._TimeExceptions.Update(VisualCron.TimeExceptionCollectionClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.TimeExceptions._TimeExceptions.Update(VisualCron.TimeExceptionCollectionClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.DelegateTimeExceptionAdded Delegate

TimeExceptions..::.DelegateTimeExceptionAdded Delegate
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.DelegateTimeExceptionAdded

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.DelegateTimeExceptionAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTimeExceptionAdded(
    ref Server server,
    TimeExceptionClass t
)
Public Delegate Sub DelegateTimeExceptionAdded ( _
    ByRef server As Server, _
    t As TimeExceptionClass _
)
public delegate void DelegateTimeExceptionAdded(
    Server^% server,
    TimeExceptionClass^ t
)
Parameters
server ( Server %)
t (TimeExceptionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.DelegateTimeExceptionCollectionAdded Delegate

TimeExceptions..::.DelegateTimeExceptionCollectionAdded Delegate
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.DelegateTimeExceptionCollectionAdded

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.DelegateTimeExceptionCollectionAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTimeExceptionCollectionAdded(
    ref Server server,
    TimeExceptionCollectionClass t
)
Public Delegate Sub DelegateTimeExceptionCollectionAdded ( _
    ByRef server As Server, _
    t As TimeExceptionCollectionClass _
)
public delegate void DelegateTimeExceptionCollectionAdded(
    Server^% server,
    TimeExceptionCollectionClass^ t
)
Parameters
server ( Server %)
t (TimeExceptionCollectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.DelegateTimeExceptionCollectionRemoved Delegate

TimeExceptions..::.DelegateTimeExceptionCollectionRemoved Delegate
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.DelegateTimeExceptionCollectionRemoved

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.DelegateTimeExceptionCollectionRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTimeExceptionCollectionRemoved(
    ref Server server,
    TimeExceptionCollectionClass t
)
Public Delegate Sub DelegateTimeExceptionCollectionRemoved ( _
    ByRef server As Server, _
    t As TimeExceptionCollectionClass _
)
public delegate void DelegateTimeExceptionCollectionRemoved(
    Server^% server,
    TimeExceptionCollectionClass^ t
)
Parameters
server ( Server %)
t (TimeExceptionCollectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.DelegateTimeExceptionCollectionUpdated Delegate

TimeExceptions..::.DelegateTimeExceptionCollectionUpdated Delegate
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.DelegateTimeExceptionCollectionUpdated

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.DelegateTimeExceptionCollectionUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTimeExceptionCollectionUpdated(
    ref Server server,
    TimeExceptionCollectionClass t
)
Public Delegate Sub DelegateTimeExceptionCollectionUpdated ( _
    ByRef server As Server, _
    t As TimeExceptionCollectionClass _
)
public delegate void DelegateTimeExceptionCollectionUpdated(
    Server^% server,
    TimeExceptionCollectionClass^ t
)
Parameters
server ( Server %)
t (TimeExceptionCollectionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.DelegateTimeExceptionRemoved Delegate

TimeExceptions..::.DelegateTimeExceptionRemoved Delegate
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.DelegateTimeExceptionRemoved

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.DelegateTimeExceptionRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTimeExceptionRemoved(
    ref Server server,
    TimeExceptionClass t
)
Public Delegate Sub DelegateTimeExceptionRemoved ( _
    ByRef server As Server, _
    t As TimeExceptionClass _
)
public delegate void DelegateTimeExceptionRemoved(
    Server^% server,
    TimeExceptionClass^ t
)
Parameters
server ( Server %)
t (TimeExceptionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.DelegateTimeExceptionUpdated Delegate

TimeExceptions..::.DelegateTimeExceptionUpdated Delegate
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.DelegateTimeExceptionUpdated

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.DelegateTimeExceptionUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTimeExceptionUpdated(
    ref Server server,
    TimeExceptionClass t
)
Public Delegate Sub DelegateTimeExceptionUpdated ( _
    ByRef server As Server, _
    t As TimeExceptionClass _
)
public delegate void DelegateTimeExceptionUpdated(
    Server^% server,
    TimeExceptionClass^ t
)
Parameters
server ( Server %)
t (TimeExceptionClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.TimeExceptionCollectionNotFoundException Class

TimeExceptions..::.TimeExceptionCollectionNotFoundException Class
Namespaces ► VisualCronAPI ► TimeExceptions ► TimeExceptions..::.TimeExceptionCollectionNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.TimeExceptions.TimeExceptionCollectionNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class TimeExceptionCollectionNotFoundException : Exception
Public Class TimeExceptionCollectionNotFoundException _
    Inherits Exception
public ref class TimeExceptionCollectionNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TimeExceptions..::.TimeExceptionCollectionNotFoundException(String) | Initializes a new instance of the TimeExceptions..::.TimeExceptionCollectionNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | TimeExceptions..::.TimeExceptionCollectionNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TimeExceptions.TimeExceptionCollectionNotFoundException Constructor (id)

TimeExceptions..::.TimeExceptionCollectionNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► TimeExceptions..::.TimeExceptionCollectionNotFoundException ► TimeExceptions..::.TimeExceptionCollectionNotFoundException(String)
Initializes a new instance of the TimeExceptions..::.TimeExceptionCollectionNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public TimeExceptionCollectionNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
TimeExceptionCollectionNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.TimeExceptions.TimeExceptionCollectionNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers Class

Triggers Class
Namespaces ► VisualCronAPI ► Triggers
Base class for Trigger Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Triggers : Triggers..::._Triggers
Public Class Triggers _
    Implements Triggers..::._Triggers
public ref class Triggers : Triggers..::._Triggers
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Triggers()()() | Initializes a new instance of the Triggers class
 | DoTriggerExist(JobClass, TriggerClass) | Checks if a certain Trigger exists
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a Trigger based on the string key Id
 | Get(JobClass, String) | Returns a Trigger based on a Job and trigger Id
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerAdded | This event is raised when a Trigger has been added
 | TriggerAddedStatic | This event is raised when a Trigger has been added
 | TriggerRemoved | This event is raised when a Trigger has been removed
 | TriggerRemovedStatic | This event is raised when a Trigger has been removed
 | TriggerUpdated | This event is raised when a Trigger has been updated
 | TriggerUpdatedStatic | This event is raised when a Trigger has been updated
Remarks
Inheritance Hierarchy
Object
Triggers

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers Constructor

Triggers Constructor
Namespaces ► VisualCronAPI ► Triggers ► Triggers()()()
Initializes a new instance of the Triggers class
Declaration Syntax
C# Visual Basic Visual C++
public Triggers()
Public Sub New
public:
Triggers()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


DoTriggerExist Method (jc, tc)

DoTriggerExist Method (jc, tc)
Namespaces ► VisualCronAPI ► Triggers ► DoTriggerExist(JobClass, TriggerClass)
Checks if a certain Trigger exists
Declaration Syntax
C# Visual Basic Visual C++
public static bool DoTriggerExist(
    JobClass jc,
    TriggerClass tc
)
Public Shared Function DoTriggerExist ( _
    jc As JobClass, _
    tc As TriggerClass _
) As Boolean
public:
static bool DoTriggerExist(
    JobClass^ jc,
    TriggerClass^ tc
)
Parameters
jc (JobClass)
Job
tc (TriggerClass)
Trigger
Return Value
true if existing
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method

Get Method
Namespaces ► VisualCronAPI ► Triggers ► Get()()()
Members
Icon | Member | Description
 | Get(String) | Returns a Trigger based on the string key Id
 | Get(JobClass, String) | Returns a Trigger based on a Job and trigger Id

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (strTriggerId)

Get Method (strTriggerId)
Namespaces ► VisualCronAPI ► Triggers ► Get(String)
Returns a Trigger based on the string key Id
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass Get(
    string strTriggerId
)
Public Function Get ( _
    strTriggerId As String _
) As TriggerClass
public:
virtual TriggerClass^ Get(
    String^ strTriggerId
) sealed
Parameters
strTriggerId (String)
string key
Return Value
a Trigger
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (jc, strTriggerId)

Get Method (jc, strTriggerId)
Namespaces ► VisualCronAPI ► Triggers ► Get(JobClass, String)
Returns a Trigger based on a Job and trigger Id
Declaration Syntax
C# Visual Basic Visual C++
public TriggerClass Get(
    JobClass jc,
    string strTriggerId
)
Public Function Get ( _
    jc As JobClass, _
    strTriggerId As String _
) As TriggerClass
public:
virtual TriggerClass^ Get(
    JobClass^ jc,
    String^ strTriggerId
) sealed
Parameters
jc (JobClass)

[Missing <param name="jc"/> documentation for "M:VisualCronAPI.Triggers.Get(VisualCron.JobClass,System.String)"]

strTriggerId (String)

[Missing <param name="strTriggerId"/> documentation for "M:VisualCronAPI.Triggers.Get(VisualCron.JobClass,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Triggers.Get(VisualCron.JobClass,System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerAdded Event

TriggerAdded Event
Namespaces ► VisualCronAPI ► Triggers ► TriggerAdded
This event is raised when a Trigger has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Triggers..::.DelegateTriggerAdded TriggerAdded
Public Event TriggerAdded As Triggers..::.DelegateTriggerAdded
public:
 event Triggers..::.DelegateTriggerAdded^ TriggerAdded {
    void add (Triggers..::.DelegateTriggerAdded^ value);
    void remove (Triggers..::.DelegateTriggerAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerAddedStatic Event

TriggerAddedStatic Event
Namespaces ► VisualCronAPI ► Triggers ► TriggerAddedStatic
This event is raised when a Trigger has been added
Declaration Syntax
C# Visual Basic Visual C++
public static event Triggers..::.DelegateTriggerAdded TriggerAddedStatic
Public Shared Event TriggerAddedStatic As Triggers..::.DelegateTriggerAdded
public:
static  event Triggers..::.DelegateTriggerAdded^ TriggerAddedStatic {
    void add (Triggers..::.DelegateTriggerAdded^ value);
    void remove (Triggers..::.DelegateTriggerAdded^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerRemoved Event

TriggerRemoved Event
Namespaces ► VisualCronAPI ► Triggers ► TriggerRemoved
This event is raised when a Trigger has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Triggers..::.DelegateTriggerRemoved TriggerRemoved
Public Event TriggerRemoved As Triggers..::.DelegateTriggerRemoved
public:
 event Triggers..::.DelegateTriggerRemoved^ TriggerRemoved {
    void add (Triggers..::.DelegateTriggerRemoved^ value);
    void remove (Triggers..::.DelegateTriggerRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerRemovedStatic Event

TriggerRemovedStatic Event
Namespaces ► VisualCronAPI ► Triggers ► TriggerRemovedStatic
This event is raised when a Trigger has been removed
Declaration Syntax
C# Visual Basic Visual C++
public static event Triggers..::.DelegateTriggerRemoved TriggerRemovedStatic
Public Shared Event TriggerRemovedStatic As Triggers..::.DelegateTriggerRemoved
public:
static  event Triggers..::.DelegateTriggerRemoved^ TriggerRemovedStatic {
    void add (Triggers..::.DelegateTriggerRemoved^ value);
    void remove (Triggers..::.DelegateTriggerRemoved^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerUpdated Event

TriggerUpdated Event
Namespaces ► VisualCronAPI ► Triggers ► TriggerUpdated
This event is raised when a Trigger has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Triggers..::.DelegateTriggerUpdated TriggerUpdated
Public Event TriggerUpdated As Triggers..::.DelegateTriggerUpdated
public:
 event Triggers..::.DelegateTriggerUpdated^ TriggerUpdated {
    void add (Triggers..::.DelegateTriggerUpdated^ value);
    void remove (Triggers..::.DelegateTriggerUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerUpdatedStatic Event

TriggerUpdatedStatic Event
Namespaces ► VisualCronAPI ► Triggers ► TriggerUpdatedStatic
This event is raised when a Trigger has been updated
Declaration Syntax
C# Visual Basic Visual C++
public static event Triggers..::.DelegateTriggerUpdated TriggerUpdatedStatic
Public Shared Event TriggerUpdatedStatic As Triggers..::.DelegateTriggerUpdated
public:
static  event Triggers..::.DelegateTriggerUpdated^ TriggerUpdatedStatic {
    void add (Triggers..::.DelegateTriggerUpdated^ value);
    void remove (Triggers..::.DelegateTriggerUpdated^ value);
}
Remarks
Static

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers.__Triggers Interface

Triggers..::.__Triggers Interface
Namespaces ► VisualCronAPI ► Triggers ► Triggers..::.__Triggers

[Missing <summary> documentation for T:VisualCronAPI.Triggers.__Triggers]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Triggers
Public Interface __Triggers
public interface class __Triggers
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TriggerAdded(Server%, JobClass, TriggerClass) |
 | TriggerRemoved(Server%, JobClass, TriggerClass) |
 | TriggerUpdated(Server%, JobClass, TriggerClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerAdded Method (server, j, t)

TriggerAdded Method (server, j, t)
Namespaces ► VisualCronAPI ► Triggers..::.__Triggers ► TriggerAdded(Server%, JobClass, TriggerClass)

[Missing <summary> documentation for M:VisualCronAPI.Triggers.__Triggers.TriggerAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TriggerAdded(
    ref Server server,
    JobClass j,
    TriggerClass t
)
Sub TriggerAdded ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TriggerClass _
)
void TriggerAdded(
    Server^% server,
    JobClass^ j,
    TriggerClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

t (TriggerClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerAdded(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerRemoved Method (server, j, t)

TriggerRemoved Method (server, j, t)
Namespaces ► VisualCronAPI ► Triggers..::.__Triggers ► TriggerRemoved(Server%, JobClass, TriggerClass)

[Missing <summary> documentation for M:VisualCronAPI.Triggers.__Triggers.TriggerRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TriggerRemoved(
    ref Server server,
    JobClass j,
    TriggerClass t
)
Sub TriggerRemoved ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TriggerClass _
)
void TriggerRemoved(
    Server^% server,
    JobClass^ j,
    TriggerClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

t (TriggerClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerRemoved(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerUpdated Method (server, j, t)

TriggerUpdated Method (server, j, t)
Namespaces ► VisualCronAPI ► Triggers..::.__Triggers ► TriggerUpdated(Server%, JobClass, TriggerClass)

[Missing <summary> documentation for M:VisualCronAPI.Triggers.__Triggers.TriggerUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)]

Declaration Syntax
C# Visual Basic Visual C++
void TriggerUpdated(
    ref Server server,
    JobClass j,
    TriggerClass t
)
Sub TriggerUpdated ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TriggerClass _
)
void TriggerUpdated(
    Server^% server,
    JobClass^ j,
    TriggerClass^ t
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

t (TriggerClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.Triggers.__Triggers.TriggerUpdated(VisualCronAPI.Server@,VisualCron.JobClass,VisualCron.TriggerClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers._Triggers Interface

Triggers..::._Triggers Interface
Namespaces ► VisualCronAPI ► Triggers ► Triggers..::._Triggers

[Missing <summary> documentation for T:VisualCronAPI.Triggers._Triggers]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Triggers
Public Interface _Triggers
public interface class _Triggers
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Get(String) |
 | Get(JobClass, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method

Get Method
Namespaces ► VisualCronAPI ► Triggers..::._Triggers ► Get()()()
Members
Icon | Member | Description
 | Get(String) |
 | Get(JobClass, String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (strTriggerId)

Get Method (strTriggerId)
Namespaces ► VisualCronAPI ► Triggers..::._Triggers ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Triggers._Triggers.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass Get(
    string strTriggerId
)
Function Get ( _
    strTriggerId As String _
) As TriggerClass
TriggerClass^ Get(
    String^ strTriggerId
)
Parameters
strTriggerId (String)

[Missing <param name="strTriggerId"/> documentation for "M:VisualCronAPI.Triggers._Triggers.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Triggers._Triggers.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (jc, strTriggerId)

Get Method (jc, strTriggerId)
Namespaces ► VisualCronAPI ► Triggers..::._Triggers ► Get(JobClass, String)

[Missing <summary> documentation for M:VisualCronAPI.Triggers._Triggers.Get(VisualCron.JobClass,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
TriggerClass Get(
    JobClass jc,
    string strTriggerId
)
Function Get ( _
    jc As JobClass, _
    strTriggerId As String _
) As TriggerClass
TriggerClass^ Get(
    JobClass^ jc,
    String^ strTriggerId
)
Parameters
jc (JobClass)

[Missing <param name="jc"/> documentation for "M:VisualCronAPI.Triggers._Triggers.Get(VisualCron.JobClass,System.String)"]

strTriggerId (String)

[Missing <param name="strTriggerId"/> documentation for "M:VisualCronAPI.Triggers._Triggers.Get(VisualCron.JobClass,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Triggers._Triggers.Get(VisualCron.JobClass,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers.DelegateTriggerAdded Delegate

Triggers..::.DelegateTriggerAdded Delegate
Namespaces ► VisualCronAPI ► Triggers ► Triggers..::.DelegateTriggerAdded

[Missing <summary> documentation for T:VisualCronAPI.Triggers.DelegateTriggerAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTriggerAdded(
    ref Server server,
    JobClass j,
    TriggerClass t
)
Public Delegate Sub DelegateTriggerAdded ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TriggerClass _
)
public delegate void DelegateTriggerAdded(
    Server^% server,
    JobClass^ j,
    TriggerClass^ t
)
Parameters
server ( Server %)
j (JobClass)
t (TriggerClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers.DelegateTriggerRemoved Delegate

Triggers..::.DelegateTriggerRemoved Delegate
Namespaces ► VisualCronAPI ► Triggers ► Triggers..::.DelegateTriggerRemoved

[Missing <summary> documentation for T:VisualCronAPI.Triggers.DelegateTriggerRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTriggerRemoved(
    ref Server server,
    JobClass j,
    TriggerClass t
)
Public Delegate Sub DelegateTriggerRemoved ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TriggerClass _
)
public delegate void DelegateTriggerRemoved(
    Server^% server,
    JobClass^ j,
    TriggerClass^ t
)
Parameters
server ( Server %)
j (JobClass)
t (TriggerClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers.DelegateTriggerUpdated Delegate

Triggers..::.DelegateTriggerUpdated Delegate
Namespaces ► VisualCronAPI ► Triggers ► Triggers..::.DelegateTriggerUpdated

[Missing <summary> documentation for T:VisualCronAPI.Triggers.DelegateTriggerUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateTriggerUpdated(
    ref Server server,
    JobClass j,
    TriggerClass t
)
Public Delegate Sub DelegateTriggerUpdated ( _
    ByRef server As Server, _
    j As JobClass, _
    t As TriggerClass _
)
public delegate void DelegateTriggerUpdated(
    Server^% server,
    JobClass^ j,
    TriggerClass^ t
)
Parameters
server ( Server %)
j (JobClass)
t (TriggerClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers.TriggerNotFoundException Class

Triggers..::.TriggerNotFoundException Class
Namespaces ► VisualCronAPI ► Triggers ► Triggers..::.TriggerNotFoundException
Is throwed when a Trigger is not found.
Declaration Syntax
C# Visual Basic Visual C++
public class TriggerNotFoundException : Exception
Public Class TriggerNotFoundException _
    Inherits Exception
public ref class TriggerNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Triggers..::.TriggerNotFoundException(String) | Initializes a new instance of the Triggers..::.TriggerNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Remarks
Inheritance Hierarchy
Object
 | Exception
 |  | Triggers..::.TriggerNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Triggers.TriggerNotFoundException Constructor (id)

Triggers..::.TriggerNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Triggers..::.TriggerNotFoundException ► Triggers..::.TriggerNotFoundException(String)
Initializes a new instance of the Triggers..::.TriggerNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public TriggerNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
TriggerNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Triggers.TriggerNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableReplacerClass Class

VariableReplacerClass Class
Namespaces ► VisualCronAPI ► VariableReplacerClass

[Missing <summary> documentation for T:VisualCronAPI.VariableReplacerClass]

Declaration Syntax
C# Visual Basic Visual C++
public class VariableReplacerClass : VariableReplacerFoundationClass,
    IVariableReplacer
Public Class VariableReplacerClass _
    Inherits VariableReplacerFoundationClass _
    Implements IVariableReplacer
public ref class VariableReplacerClass : public VariableReplacerFoundationClass,
    IVariableReplacer
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariableReplacerClass(Server, JobClass, TaskClass, String) | API constructor
 | VariableReplacerClass(JobClass, TaskClass, String) | Service constructor
 | VariableReplacerClass()()() | Initializes a new instance of the VariableReplacerClass class
 | ContainsVariable(String) | (Inherited from VariableReplacerFoundationClass.)
 | CountOcurrencies(String, String) | (Inherited from VariableReplacerFoundationClass.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArgumentArray(String) | (Inherited from VariableReplacerFoundationClass.)
 | GetArguments(String) | (Inherited from VariableReplacerFoundationClass.)
 | GetCreatedByName(JobClass) | (Overrides VariableReplacerFoundationClass.GetCreatedByName(JobClass).)
 | GetCredentialDescription(String) | (Overrides VariableReplacerFoundationClass.GetCredentialDescription(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJob(String) | (Overrides VariableReplacerFoundationClass.GetJob(String).)
 | GetModifiedByName(JobClass) | (Overrides VariableReplacerFoundationClass.GetModifiedByName(JobClass).)
 | GetSQLConnectionString(String) | (Overrides VariableReplacerFoundationClass.GetSQLConnectionString(String).)
 | GetTask(String) |
 | GetTriggerResult(String) | (Overrides VariableReplacerFoundationClass.GetTriggerResult(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Job | (Inherited from VariableReplacerFoundationClass.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewRegExReplace(Match) | (Overrides VariableReplacerFoundationClass.NewRegExReplace(Match).)
 | ReplaceEnter(String) | (Inherited from VariableReplacerFoundationClass.)
 | rx | (Inherited from VariableReplacerFoundationClass.)
 | server | (Inherited from VariableReplacerFoundationClass.)
 | SetVar(String, Boolean) | Function for retrieving string variables (Inherited from VariableReplacerFoundationClass.)
 | SetVarDate(String) | Function for retrieving date variables (Inherited from VariableReplacerFoundationClass.)
 | Task | (Inherited from VariableReplacerFoundationClass.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerResultId | (Inherited from VariableReplacerFoundationClass.)
 | UserVariable[([(String])]) |
 | VariableCOMPUTER(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableDATE(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableDATEADD(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableDATEFORMAT(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableDATENOWADD(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableDIRECTORY(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableExist(String) |
 | VariableFILE(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableJOB(JobClass, array<String>[]()[]) | (Inherited from VariableReplacerFoundationClass.)
 | VariableMATH(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableMEMORY(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariablePATH(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableREGEX(String) | (Inherited from VariableReplacerFoundationClass.)
 | VariableSTRING(Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableTASK(TaskClass, array<String>[]()[], Match) | (Inherited from VariableReplacerFoundationClass.)
 | VariableTRIGGER(TriggerClass, array<String>[]()[], Match, Boolean) | (Inherited from VariableReplacerFoundationClass.)
 | VariableUSER(Match) | (Inherited from VariableReplacerFoundationClass.)
Inheritance Hierarchy
Object
 | VariableReplacerFoundationClass
 |  | VariableReplacerClass

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableReplacerClass Constructor

VariableReplacerClass Constructor
Namespaces ► VisualCronAPI ► VariableReplacerClass ► VariableReplacerClass()()()
Members
Icon | Member | Description
 | VariableReplacerClass(Server, JobClass, TaskClass, String) | API constructor
 | VariableReplacerClass(JobClass, TaskClass, String) | Service constructor
 | VariableReplacerClass()()() | Initializes a new instance of the VariableReplacerClass class

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableReplacerClass Constructor

VariableReplacerClass Constructor
Namespaces ► VisualCronAPI ► VariableReplacerClass ► VariableReplacerClass()()()
Initializes a new instance of the VariableReplacerClass class
Declaration Syntax
C# Visual Basic Visual C++
public VariableReplacerClass()
Public Sub New
public:
VariableReplacerClass()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableReplacerClass Constructor (j, t, trid)

VariableReplacerClass Constructor (j, t, trid)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► VariableReplacerClass(JobClass, TaskClass, String)
Service constructor
Declaration Syntax
C# Visual Basic Visual C++
public VariableReplacerClass(
    JobClass j,
    TaskClass t,
    string trid
)
Public Sub New ( _
    j As JobClass, _
    t As TaskClass, _
    trid As String _
)
public:
VariableReplacerClass(
    JobClass^ j,
    TaskClass^ t,
    String^ trid
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.VariableReplacerClass.#ctor(VisualCron.JobClass,VisualCron.TaskClass,System.String)"]

t (TaskClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.VariableReplacerClass.#ctor(VisualCron.JobClass,VisualCron.TaskClass,System.String)"]

trid (String)

[Missing <param name="trid"/> documentation for "M:VisualCronAPI.VariableReplacerClass.#ctor(VisualCron.JobClass,VisualCron.TaskClass,System.String)"]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableReplacerClass Constructor (s, j, t, trid)

VariableReplacerClass Constructor (s, j, t, trid)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► VariableReplacerClass(Server, JobClass, TaskClass, String)
API constructor
Declaration Syntax
C# Visual Basic Visual C++
public VariableReplacerClass(
    Server s,
    JobClass j,
    TaskClass t,
    string trid
)
Public Sub New ( _
    s As Server, _
    j As JobClass, _
    t As TaskClass, _
    trid As String _
)
public:
VariableReplacerClass(
    Server^ s,
    JobClass^ j,
    TaskClass^ t,
    String^ trid
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.VariableReplacerClass.#ctor(VisualCronAPI.Server,VisualCron.JobClass,VisualCron.TaskClass,System.String)"]

j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.VariableReplacerClass.#ctor(VisualCronAPI.Server,VisualCron.JobClass,VisualCron.TaskClass,System.String)"]

t (TaskClass)

[Missing <param name="t"/> documentation for "M:VisualCronAPI.VariableReplacerClass.#ctor(VisualCronAPI.Server,VisualCron.JobClass,VisualCron.TaskClass,System.String)"]

trid (String)

[Missing <param name="trid"/> documentation for "M:VisualCronAPI.VariableReplacerClass.#ctor(VisualCronAPI.Server,VisualCron.JobClass,VisualCron.TaskClass,System.String)"]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCreatedByName Method (j)

GetCreatedByName Method (j)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► GetCreatedByName(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.GetCreatedByName(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
public override string GetCreatedByName(
    JobClass j
)
Public Overrides Function GetCreatedByName ( _
    j As JobClass _
) As String
public:
virtual String^ GetCreatedByName(
    JobClass^ j
) override
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.VariableReplacerClass.GetCreatedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.GetCreatedByName(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCredentialDescription Method (strCredentialId)

GetCredentialDescription Method (strCredentialId)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► GetCredentialDescription(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.GetCredentialDescription(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public override string GetCredentialDescription(
    string strCredentialId
)
Public Overrides Function GetCredentialDescription ( _
    strCredentialId As String _
) As String
public:
virtual String^ GetCredentialDescription(
    String^ strCredentialId
) override
Parameters
strCredentialId (String)

[Missing <param name="strCredentialId"/> documentation for "M:VisualCronAPI.VariableReplacerClass.GetCredentialDescription(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.GetCredentialDescription(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJob Method (strJobId)

GetJob Method (strJobId)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► GetJob(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.GetJob(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public override JobClass GetJob(
    string strJobId
)
Public Overrides Function GetJob ( _
    strJobId As String _
) As JobClass
public:
virtual JobClass^ GetJob(
    String^ strJobId
) override
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.VariableReplacerClass.GetJob(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.GetJob(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetModifiedByName Method (j)

GetModifiedByName Method (j)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► GetModifiedByName(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.GetModifiedByName(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
public override string GetModifiedByName(
    JobClass j
)
Public Overrides Function GetModifiedByName ( _
    j As JobClass _
) As String
public:
virtual String^ GetModifiedByName(
    JobClass^ j
) override
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.VariableReplacerClass.GetModifiedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.GetModifiedByName(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetSQLConnectionString Method (strConnectionId)

GetSQLConnectionString Method (strConnectionId)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► GetSQLConnectionString(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.GetSQLConnectionString(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public override string GetSQLConnectionString(
    string strConnectionId
)
Public Overrides Function GetSQLConnectionString ( _
    strConnectionId As String _
) As String
public:
virtual String^ GetSQLConnectionString(
    String^ strConnectionId
) override
Parameters
strConnectionId (String)

[Missing <param name="strConnectionId"/> documentation for "M:VisualCronAPI.VariableReplacerClass.GetSQLConnectionString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.GetSQLConnectionString(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTask Method (strId)

GetTask Method (strId)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► GetTask(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.GetTask(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public TaskClass GetTask(
    string strId
)
Public Function GetTask ( _
    strId As String _
) As TaskClass
public:
virtual TaskClass^ GetTask(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.VariableReplacerClass.GetTask(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.GetTask(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTriggerResult Method (strTriggerResultId)

GetTriggerResult Method (strTriggerResultId)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► GetTriggerResult(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.GetTriggerResult(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public override TriggerResultClass GetTriggerResult(
    string strTriggerResultId
)
Public Overrides Function GetTriggerResult ( _
    strTriggerResultId As String _
) As TriggerResultClass
public:
virtual TriggerResultClass^ GetTriggerResult(
    String^ strTriggerResultId
) override
Parameters
strTriggerResultId (String)

[Missing <param name="strTriggerResultId"/> documentation for "M:VisualCronAPI.VariableReplacerClass.GetTriggerResult(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.GetTriggerResult(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NewRegExReplace Method (m)

NewRegExReplace Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► NewRegExReplace(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.NewRegExReplace(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public override string NewRegExReplace(
    Match m
)
Public Overrides Function NewRegExReplace ( _
    m As Match _
) As String
public:
virtual String^ NewRegExReplace(
    Match^ m
) override
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerClass.NewRegExReplace(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.NewRegExReplace(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


UserVariable Property (strId)

UserVariable Property (strId)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► UserVariable[([(String])])

[Missing <summary> documentation for P:VisualCronAPI.VariableReplacerClass.UserVariable(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public UserVariableClass UserVariable[
    string strId
] { get; }
Public ReadOnly Property UserVariable ( _
    strId As String _
) As UserVariableClass
public:
virtual property UserVariableClass^ UserVariable[String^ strId] {
    UserVariableClass^ get (String^ strId) sealed;
}
Parameters
strId (String)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableExist Method (strId)

VariableExist Method (strId)
Namespaces ► VisualCronAPI ► VariableReplacerClass ► VariableExist(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerClass.VariableExist(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool VariableExist(
    string strId
)
Public Function VariableExist ( _
    strId As String _
) As Boolean
public:
virtual bool VariableExist(
    String^ strId
) sealed
Parameters
strId (String)

[Missing <param name="strId"/> documentation for "M:VisualCronAPI.VariableReplacerClass.VariableExist(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerClass.VariableExist(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableReplacerFoundationClass Class

VariableReplacerFoundationClass Class
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass
Base class for Variables
Declaration Syntax
C# Visual Basic Visual C++
public abstract class VariableReplacerFoundationClass
Public MustInherit Class VariableReplacerFoundationClass
public ref class VariableReplacerFoundationClass abstract
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | VariableReplacerFoundationClass()()() | Initializes a new instance of the VariableReplacerFoundationClass class
 | ContainsVariable(String) |
 | CountOcurrencies(String, String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetArgumentArray(String) |
 | GetArguments(String) |
 | GetCreatedByName(JobClass) |
 | GetCredentialDescription(String) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetJob(String) |
 | GetModifiedByName(JobClass) |
 | GetSQLConnectionString(String) |
 | GetTriggerResult(String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Job |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NewRegExReplace(Match) |
 | ReplaceEnter(String) |
 | rx |
 | server |
 | SetVar(String, Boolean) | Function for retrieving string variables
 | SetVarDate(String) | Function for retrieving date variables
 | strNewRegEx |
 | Task |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TriggerResultId |
 | VariableCOMPUTER(Match) |
 | VariableDATE(Match) |
 | VariableDATEADD(Match) |
 | VariableDATEFORMAT(Match) |
 | VariableDATENOWADD(Match) |
 | VariableDIRECTORY(Match) |
 | VariableFILE(Match) |
 | VariableJOB(JobClass, array<String>[]()[]) |
 | VariableMATH(Match) |
 | VariableMEMORY(Match) |
 | VariablePATH(Match) |
 | VariableREGEX(String) |
 | VariableSTRING(Match) |
 | VariableTASK(TaskClass, array<String>[]()[], Match) |
 | VariableTRIGGER(TriggerClass, array<String>[]()[], Match, Boolean) |
 | VariableUSER(Match) |
Remarks
Inheritance Hierarchy
Object
 | VariableReplacerFoundationClass
 |  | VariableReplacerClass

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableReplacerFoundationClass Constructor

VariableReplacerFoundationClass Constructor
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableReplacerFoundationClass()()()
Initializes a new instance of the VariableReplacerFoundationClass class
Declaration Syntax
C# Visual Basic Visual C++
public VariableReplacerFoundationClass()
Public Sub New
public:
VariableReplacerFoundationClass()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ContainsVariable Method (strValue)

ContainsVariable Method (strValue)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► ContainsVariable(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.ContainsVariable(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsVariable(
    string strValue
)
Public Function ContainsVariable ( _
    strValue As String _
) As Boolean
public:
bool ContainsVariable(
    String^ strValue
)
Parameters
strValue (String)

[Missing <param name="strValue"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.ContainsVariable(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.ContainsVariable(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


CountOcurrencies Method (text, searchfor)

CountOcurrencies Method (text, searchfor)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► CountOcurrencies(String, String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.CountOcurrencies(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public int CountOcurrencies(
    string text,
    string searchfor
)
Public Function CountOcurrencies ( _
    text As String, _
    searchfor As String _
) As Integer
public:
int CountOcurrencies(
    String^ text,
    String^ searchfor
)
Parameters
text (String)

[Missing <param name="text"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.CountOcurrencies(System.String,System.String)"]

searchfor (String)

[Missing <param name="searchfor"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.CountOcurrencies(System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.CountOcurrencies(System.String,System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetArgumentArray Method (strVariable)

GetArgumentArray Method (strVariable)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetArgumentArray(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetArgumentArray(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string[] GetArgumentArray(
    string strVariable
)
Public Function GetArgumentArray ( _
    strVariable As String _
) As String()
public:
array<String^>^ GetArgumentArray(
    String^ strVariable
)
Parameters
strVariable (String)

[Missing <param name="strVariable"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetArgumentArray(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetArgumentArray(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetArguments Method (strVariable)

GetArguments Method (strVariable)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetArguments(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetArguments(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string GetArguments(
    string strVariable
)
Public Function GetArguments ( _
    strVariable As String _
) As String
public:
String^ GetArguments(
    String^ strVariable
)
Parameters
strVariable (String)

[Missing <param name="strVariable"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetArguments(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetArguments(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCreatedByName Method (j)

GetCreatedByName Method (j)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetCreatedByName(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetCreatedByName(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract string GetCreatedByName(
    JobClass j
)
Public MustOverride Function GetCreatedByName ( _
    j As JobClass _
) As String
public:
virtual String^ GetCreatedByName(
    JobClass^ j
) abstract
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetCreatedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetCreatedByName(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetCredentialDescription Method (strCredentialId)

GetCredentialDescription Method (strCredentialId)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetCredentialDescription(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetCredentialDescription(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract string GetCredentialDescription(
    string strCredentialId
)
Public MustOverride Function GetCredentialDescription ( _
    strCredentialId As String _
) As String
public:
virtual String^ GetCredentialDescription(
    String^ strCredentialId
) abstract
Parameters
strCredentialId (String)

[Missing <param name="strCredentialId"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetCredentialDescription(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetCredentialDescription(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetJob Method (strJobId)

GetJob Method (strJobId)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetJob(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetJob(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract JobClass GetJob(
    string strJobId
)
Public MustOverride Function GetJob ( _
    strJobId As String _
) As JobClass
public:
virtual JobClass^ GetJob(
    String^ strJobId
) abstract
Parameters
strJobId (String)

[Missing <param name="strJobId"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetJob(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetJob(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetModifiedByName Method (j)

GetModifiedByName Method (j)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetModifiedByName(JobClass)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetModifiedByName(VisualCron.JobClass)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract string GetModifiedByName(
    JobClass j
)
Public MustOverride Function GetModifiedByName ( _
    j As JobClass _
) As String
public:
virtual String^ GetModifiedByName(
    JobClass^ j
) abstract
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetModifiedByName(VisualCron.JobClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetModifiedByName(VisualCron.JobClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetSQLConnectionString Method (strConnectionId)

GetSQLConnectionString Method (strConnectionId)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetSQLConnectionString(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetSQLConnectionString(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract string GetSQLConnectionString(
    string strConnectionId
)
Public MustOverride Function GetSQLConnectionString ( _
    strConnectionId As String _
) As String
public:
virtual String^ GetSQLConnectionString(
    String^ strConnectionId
) abstract
Parameters
strConnectionId (String)

[Missing <param name="strConnectionId"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetSQLConnectionString(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetSQLConnectionString(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetTriggerResult Method (strTriggerResultId)

GetTriggerResult Method (strTriggerResultId)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► GetTriggerResult(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetTriggerResult(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract TriggerResultClass GetTriggerResult(
    string strTriggerResultId
)
Public MustOverride Function GetTriggerResult ( _
    strTriggerResultId As String _
) As TriggerResultClass
public:
virtual TriggerResultClass^ GetTriggerResult(
    String^ strTriggerResultId
) abstract
Parameters
strTriggerResultId (String)

[Missing <param name="strTriggerResultId"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.GetTriggerResult(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.GetTriggerResult(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Job Field

Job Field
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► Job

[Missing <summary> documentation for F:VisualCronAPI.VariableReplacerFoundationClass.Job]

Declaration Syntax
C# Visual Basic Visual C++
public JobClass Job
Public Job As JobClass
public:
JobClass^ Job

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


NewRegExReplace Method (m)

NewRegExReplace Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► NewRegExReplace(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.NewRegExReplace(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract string NewRegExReplace(
    Match m
)
Public MustOverride Function NewRegExReplace ( _
    m As Match _
) As String
public:
virtual String^ NewRegExReplace(
    Match^ m
) abstract
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.NewRegExReplace(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.NewRegExReplace(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


ReplaceEnter Method (strToReplace)

ReplaceEnter Method (strToReplace)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► ReplaceEnter(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.ReplaceEnter(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string ReplaceEnter(
    string strToReplace
)
Public Function ReplaceEnter ( _
    strToReplace As String _
) As String
public:
String^ ReplaceEnter(
    String^ strToReplace
)
Parameters
strToReplace (String)

[Missing <param name="strToReplace"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.ReplaceEnter(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.ReplaceEnter(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


rx Field

rx Field
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► rx

[Missing <summary> documentation for F:VisualCronAPI.VariableReplacerFoundationClass.rx]

Declaration Syntax
C# Visual Basic Visual C++
public Regex rx
Public rx As Regex
public:
Regex^ rx

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


server Field

server Field
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► server

[Missing <summary> documentation for F:VisualCronAPI.VariableReplacerFoundationClass.server]

Declaration Syntax
C# Visual Basic Visual C++
public Server server
Public server As Server
public:
Server^ server

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SetVar Method (strToReplace, bolReplaceEnter)

SetVar Method (strToReplace, bolReplaceEnter)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► SetVar(String, Boolean)
Function for retrieving string variables
Declaration Syntax
C# Visual Basic Visual C++
public string SetVar(
    string strToReplace,
    bool bolReplaceEnter
)
Public Function SetVar ( _
    strToReplace As String, _
    bolReplaceEnter As Boolean _
) As String
public:
String^ SetVar(
    String^ strToReplace,
    bool bolReplaceEnter
)
Parameters
strToReplace (String)

[Missing <param name="strToReplace"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.SetVar(System.String,System.Boolean)"]

bolReplaceEnter (Boolean)

[Missing <param name="bolReplaceEnter"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.SetVar(System.String,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.SetVar(System.String,System.Boolean)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SetVarDate Method (strToReplace)

SetVarDate Method (strToReplace)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► SetVarDate(String)
Function for retrieving date variables
Declaration Syntax
C# Visual Basic Visual C++
public DateTime SetVarDate(
    string strToReplace
)
Public Function SetVarDate ( _
    strToReplace As String _
) As DateTime
public:
DateTime SetVarDate(
    String^ strToReplace
)
Parameters
strToReplace (String)

[Missing <param name="strToReplace"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.SetVarDate(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.SetVarDate(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


strNewRegEx Field

strNewRegEx Field
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► strNewRegEx

[Missing <summary> documentation for F:VisualCronAPI.VariableReplacerFoundationClass.strNewRegEx]

Declaration Syntax
C# Visual Basic Visual C++
public const string strNewRegEx
Public Const strNewRegEx As String
public:
literal String^ strNewRegEx

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Task Field

Task Field
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► Task

[Missing <summary> documentation for F:VisualCronAPI.VariableReplacerFoundationClass.Task]

Declaration Syntax
C# Visual Basic Visual C++
public TaskClass Task
Public Task As TaskClass
public:
TaskClass^ Task

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


TriggerResultId Field

TriggerResultId Field
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► TriggerResultId

[Missing <summary> documentation for F:VisualCronAPI.VariableReplacerFoundationClass.TriggerResultId]

Declaration Syntax
C# Visual Basic Visual C++
public string TriggerResultId
Public TriggerResultId As String
public:
String^ TriggerResultId

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableCOMPUTER Method (m)

VariableCOMPUTER Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableCOMPUTER(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableCOMPUTER(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableCOMPUTER(
    Match m
)
Public Function VariableCOMPUTER ( _
    m As Match _
) As String
public:
String^ VariableCOMPUTER(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableCOMPUTER(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableCOMPUTER(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableDATE Method (m)

VariableDATE Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableDATE(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATE(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableDATE(
    Match m
)
Public Function VariableDATE ( _
    m As Match _
) As String
public:
String^ VariableDATE(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATE(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATE(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableDATEADD Method (m)

VariableDATEADD Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableDATEADD(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATEADD(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableDATEADD(
    Match m
)
Public Function VariableDATEADD ( _
    m As Match _
) As String
public:
String^ VariableDATEADD(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATEADD(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATEADD(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableDATEFORMAT Method (m)

VariableDATEFORMAT Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableDATEFORMAT(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATEFORMAT(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableDATEFORMAT(
    Match m
)
Public Function VariableDATEFORMAT ( _
    m As Match _
) As String
public:
String^ VariableDATEFORMAT(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATEFORMAT(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATEFORMAT(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableDATENOWADD Method (m)

VariableDATENOWADD Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableDATENOWADD(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATENOWADD(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableDATENOWADD(
    Match m
)
Public Function VariableDATENOWADD ( _
    m As Match _
) As String
public:
String^ VariableDATENOWADD(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATENOWADD(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDATENOWADD(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableDIRECTORY Method (m)

VariableDIRECTORY Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableDIRECTORY(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDIRECTORY(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableDIRECTORY(
    Match m
)
Public Function VariableDIRECTORY ( _
    m As Match _
) As String
public:
String^ VariableDIRECTORY(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableDIRECTORY(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableDIRECTORY(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableFILE Method (m)

VariableFILE Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableFILE(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableFILE(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableFILE(
    Match m
)
Public Function VariableFILE ( _
    m As Match _
) As String
public:
String^ VariableFILE(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableFILE(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableFILE(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableJOB Method (j, args)

VariableJOB Method (j, args)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableJOB(JobClass, array<String>[]()[])

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableJOB(VisualCron.JobClass,System.String[])]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableJOB(
    JobClass j,
    string[] args
)
Public Function VariableJOB ( _
    j As JobClass, _
    args As String() _
) As String
public:
String^ VariableJOB(
    JobClass^ j,
    array<String^>^ args
)
Parameters
j (JobClass)

[Missing <param name="j"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableJOB(VisualCron.JobClass,System.String[])"]

args (array< String >[]()[])

[Missing <param name="args"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableJOB(VisualCron.JobClass,System.String[])"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableJOB(VisualCron.JobClass,System.String[])]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableMATH Method (m)

VariableMATH Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableMATH(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableMATH(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableMATH(
    Match m
)
Public Function VariableMATH ( _
    m As Match _
) As String
public:
String^ VariableMATH(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableMATH(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableMATH(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableMEMORY Method (m)

VariableMEMORY Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableMEMORY(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableMEMORY(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableMEMORY(
    Match m
)
Public Function VariableMEMORY ( _
    m As Match _
) As String
public:
String^ VariableMEMORY(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableMEMORY(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableMEMORY(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariablePATH Method (m)

VariablePATH Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariablePATH(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariablePATH(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariablePATH(
    Match m
)
Public Function VariablePATH ( _
    m As Match _
) As String
public:
String^ VariablePATH(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariablePATH(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariablePATH(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableREGEX Method (strValue)

VariableREGEX Method (strValue)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableREGEX(String)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableREGEX(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableREGEX(
    string strValue
)
Public Function VariableREGEX ( _
    strValue As String _
) As String
public:
String^ VariableREGEX(
    String^ strValue
)
Parameters
strValue (String)

[Missing <param name="strValue"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableREGEX(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableREGEX(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableSTRING Method (m)

VariableSTRING Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableSTRING(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableSTRING(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableSTRING(
    Match m
)
Public Function VariableSTRING ( _
    m As Match _
) As String
public:
String^ VariableSTRING(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableSTRING(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableSTRING(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableTASK Method (Task, args, m)

VariableTASK Method (Task, args, m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableTASK(TaskClass, array<String>[]()[], Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableTASK(VisualCron.TaskClass,System.String[],System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableTASK(
    TaskClass Task,
    string[] args,
    Match m
)
Public Function VariableTASK ( _
    Task As TaskClass, _
    args As String(), _
    m As Match _
) As String
public:
String^ VariableTASK(
    TaskClass^ Task,
    array<String^>^ args,
    Match^ m
)
Parameters
Task (TaskClass)

[Missing <param name="Task"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableTASK(VisualCron.TaskClass,System.String[],System.Text.RegularExpressions.Match)"]

args (array< String >[]()[])

[Missing <param name="args"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableTASK(VisualCron.TaskClass,System.String[],System.Text.RegularExpressions.Match)"]

m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableTASK(VisualCron.TaskClass,System.String[],System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableTASK(VisualCron.TaskClass,System.String[],System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableTRIGGER Method (Trigger, args, m, GetActiveResultId)

VariableTRIGGER Method (Trigger, args, m, GetActiveResultId)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableTRIGGER(TriggerClass, array<String>[]()[], Match, Boolean)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableTRIGGER(VisualCron.TriggerClass,System.String[],System.Text.RegularExpressions.Match,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableTRIGGER(
    TriggerClass Trigger,
    string[] args,
    Match m,
    bool GetActiveResultId
)
Public Function VariableTRIGGER ( _
    Trigger As TriggerClass, _
    args As String(), _
    m As Match, _
    GetActiveResultId As Boolean _
) As String
public:
String^ VariableTRIGGER(
    TriggerClass^ Trigger,
    array<String^>^ args,
    Match^ m,
    bool GetActiveResultId
)
Parameters
Trigger (TriggerClass)

[Missing <param name="Trigger"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableTRIGGER(VisualCron.TriggerClass,System.String[],System.Text.RegularExpressions.Match,System.Boolean)"]

args (array< String >[]()[])

[Missing <param name="args"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableTRIGGER(VisualCron.TriggerClass,System.String[],System.Text.RegularExpressions.Match,System.Boolean)"]

m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableTRIGGER(VisualCron.TriggerClass,System.String[],System.Text.RegularExpressions.Match,System.Boolean)"]

GetActiveResultId (Boolean)

[Missing <param name="GetActiveResultId"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableTRIGGER(VisualCron.TriggerClass,System.String[],System.Text.RegularExpressions.Match,System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableTRIGGER(VisualCron.TriggerClass,System.String[],System.Text.RegularExpressions.Match,System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableUSER Method (m)

VariableUSER Method (m)
Namespaces ► VisualCronAPI ► VariableReplacerFoundationClass ► VariableUSER(Match)

[Missing <summary> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableUSER(System.Text.RegularExpressions.Match)]

Declaration Syntax
C# Visual Basic Visual C++
public string VariableUSER(
    Match m
)
Public Function VariableUSER ( _
    m As Match _
) As String
public:
String^ VariableUSER(
    Match^ m
)
Parameters
m (Match)

[Missing <param name="m"/> documentation for "M:VisualCronAPI.VariableReplacerFoundationClass.VariableUSER(System.Text.RegularExpressions.Match)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.VariableReplacerFoundationClass.VariableUSER(System.Text.RegularExpressions.Match)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables Class

Variables Class
Namespaces ► VisualCronAPI ► Variables
Base class for Variable Properties, Methods and Events
Declaration Syntax
C# Visual Basic Visual C++
public class Variables : Variables..::._Variables
Public Class Variables _
    Implements Variables..::._Variables
public ref class Variables : Variables..::._Variables
Members
All Members | Constructors | Methods | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Variables(Server) | Initializes a new instance of the Variables class
 | Add(UserVariableClass) | Adds a Variable
 | Contains(String) | Returns true if the Variable name (Id) exist
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get(String) | Returns a OwnVariableClass based on the string key Name
 | GetAll(Boolean) | Returns an list of OwnVariables
 | GetAllArray(Boolean) | Returns an array of OwnVariables
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetVariableValue(UserVariableClass) | Retrieves a specific value from a Variable
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(UserVariableClass) | Removes a Variable
 | Remove(String) | Removes a Variable
 | RemoveAll()()() | Removes all Variables
 | SetVariableValue(UserVariableClass%, String) | Sets a specific value on Variable
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Update(UserVariableClass) | Updates a Variable
 | VariableAdded | This event is raised when a Variable has been added
 | VariableRemoved | This event is raised when a Variable has been removed
 | VariableUpdated | This event is raised when a Variable has been updated
Remarks
Inheritance Hierarchy
Object
Variables

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables Constructor (s)

Variables Constructor (s)
Namespaces ► VisualCronAPI ► Variables ► Variables(Server)
Initializes a new instance of the Variables class
Declaration Syntax
C# Visual Basic Visual C++
public Variables(
    Server s
)
Public Sub New ( _
    s As Server _
)
public:
Variables(
    Server^ s
)
Parameters
s (Server)

[Missing <param name="s"/> documentation for "M:VisualCronAPI.Variables.#ctor(VisualCronAPI.Server)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (uvc)

Add Method (uvc)
Namespaces ► VisualCronAPI ► Variables ► Add(UserVariableClass)
Adds a Variable
Declaration Syntax
C# Visual Basic Visual C++
public UserVariableClass Add(
    UserVariableClass uvc
)
Public Function Add ( _
    uvc As UserVariableClass _
) As UserVariableClass
public:
virtual UserVariableClass^ Add(
    UserVariableClass^ uvc
) sealed
Parameters
uvc (UserVariableClass)
A OwnVariableClass object
Return Value
a OwnVariableClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strVariableName)

Contains Method (strVariableName)
Namespaces ► VisualCronAPI ► Variables ► Contains(String)
Returns true if the Variable name (Id) exist
Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string strVariableName
)
Public Function Contains ( _
    strVariableName As String _
) As Boolean
public:
virtual bool Contains(
    String^ strVariableName
) sealed
Parameters
strVariableName (String)

[Missing <param name="strVariableName"/> documentation for "M:VisualCronAPI.Variables.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables.Contains(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (name)

Get Method (name)
Namespaces ► VisualCronAPI ► Variables ► Get(String)
Returns a OwnVariableClass based on the string key Name
Declaration Syntax
C# Visual Basic Visual C++
public UserVariableClass Get(
    string name
)
Public Function Get ( _
    name As String _
) As UserVariableClass
public:
virtual UserVariableClass^ Get(
    String^ name
) sealed
Parameters
name (String)
string key
Return Value
a OwnVariableClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAll Method (bolSorted)

GetAll Method (bolSorted)
Namespaces ► VisualCronAPI ► Variables ► GetAll(Boolean)
Returns an list of OwnVariables
Declaration Syntax
C# Visual Basic Visual C++
public List<UserVariableClass> GetAll(
    bool bolSorted
)
Public Function GetAll ( _
    bolSorted As Boolean _
) As List(Of UserVariableClass)
public:
List<UserVariableClass^>^ GetAll(
    bool bolSorted
)
Parameters
bolSorted (Boolean)

[Missing <param name="bolSorted"/> documentation for "M:VisualCronAPI.Variables.GetAll(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables.GetAll(System.Boolean)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (bolSorted)

GetAllArray Method (bolSorted)
Namespaces ► VisualCronAPI ► Variables ► GetAllArray(Boolean)
Returns an array of OwnVariables
Declaration Syntax
C# Visual Basic Visual C++
public ArrayList GetAllArray(
    bool bolSorted
)
Public Function GetAllArray ( _
    bolSorted As Boolean _
) As ArrayList
public:
virtual ArrayList^ GetAllArray(
    bool bolSorted
) sealed
Parameters
bolSorted (Boolean)

[Missing <param name="bolSorted"/> documentation for "M:VisualCronAPI.Variables.GetAllArray(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables.GetAllArray(System.Boolean)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetVariableValue Method (uv)

GetVariableValue Method (uv)
Namespaces ► VisualCronAPI ► Variables ► GetVariableValue(UserVariableClass)
Retrieves a specific value from a Variable
Declaration Syntax
C# Visual Basic Visual C++
public Object GetVariableValue(
    UserVariableClass uv
)
Public Function GetVariableValue ( _
    uv As UserVariableClass _
) As Object
public:
virtual Object^ GetVariableValue(
    UserVariableClass^ uv
) sealed
Parameters
uv (UserVariableClass)

[Missing <param name="uv"/> documentation for "M:VisualCronAPI.Variables.GetVariableValue(VisualCron.UserVariableClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables.GetVariableValue(VisualCron.UserVariableClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Variables ► Remove()()()
Members
Icon | Member | Description
 | Remove(UserVariableClass) | Removes a Variable
 | Remove(String) | Removes a Variable

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (variableName)

Remove Method (variableName)
Namespaces ► VisualCronAPI ► Variables ► Remove(String)
Removes a Variable
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    string variableName
)
Public Function Remove ( _
    variableName As String _
) As Boolean
public:
virtual bool Remove(
    String^ variableName
) sealed
Parameters
variableName (String)
name of variable
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables.Remove(System.String)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (ovn)

Remove Method (ovn)
Namespaces ► VisualCronAPI ► Variables ► Remove(UserVariableClass)
Removes a Variable
Declaration Syntax
C# Visual Basic Visual C++
public bool Remove(
    UserVariableClass ovn
)
Public Function Remove ( _
    ovn As UserVariableClass _
) As Boolean
public:
virtual bool Remove(
    UserVariableClass^ ovn
) sealed
Parameters
ovn (UserVariableClass)
a Variable
Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables.Remove(VisualCron.UserVariableClass)]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Variables ► RemoveAll()()()
Removes all Variables
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveAll()
Public Sub RemoveAll
public:
virtual void RemoveAll() sealed
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SetVariableValue Method (uv, strValue)

SetVariableValue Method (uv, strValue)
Namespaces ► VisualCronAPI ► Variables ► SetVariableValue(UserVariableClass%, String)
Sets a specific value on Variable
Declaration Syntax
C# Visual Basic Visual C++
public void SetVariableValue(
    ref UserVariableClass uv,
    string strValue
)
Public Sub SetVariableValue ( _
    ByRef uv As UserVariableClass, _
    strValue As String _
)
public:
virtual void SetVariableValue(
    UserVariableClass^% uv,
    String^ strValue
) sealed
Parameters
uv ( UserVariableClass %)

[Missing <param name="uv"/> documentation for "M:VisualCronAPI.Variables.SetVariableValue(VisualCron.UserVariableClass@,System.String)"]

strValue (String)

[Missing <param name="strValue"/> documentation for "M:VisualCronAPI.Variables.SetVariableValue(VisualCron.UserVariableClass@,System.String)"]

Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (uvc)

Update Method (uvc)
Namespaces ► VisualCronAPI ► Variables ► Update(UserVariableClass)
Updates a Variable
Declaration Syntax
C# Visual Basic Visual C++
public UserVariableClass Update(
    UserVariableClass uvc
)
Public Function Update ( _
    uvc As UserVariableClass _
) As UserVariableClass
public:
virtual UserVariableClass^ Update(
    UserVariableClass^ uvc
) sealed
Parameters
uvc (UserVariableClass)
A OwnVariableClass object
Return Value
a OwnVariableClass
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableAdded Event

VariableAdded Event
Namespaces ► VisualCronAPI ► Variables ► VariableAdded
This event is raised when a Variable has been added
Declaration Syntax
C# Visual Basic Visual C++
public event Variables..::.DelegateVariableAdded VariableAdded
Public Event VariableAdded As Variables..::.DelegateVariableAdded
public:
 event Variables..::.DelegateVariableAdded^ VariableAdded {
    void add (Variables..::.DelegateVariableAdded^ value);
    void remove (Variables..::.DelegateVariableAdded^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableRemoved Event

VariableRemoved Event
Namespaces ► VisualCronAPI ► Variables ► VariableRemoved
This event is raised when a Variable has been removed
Declaration Syntax
C# Visual Basic Visual C++
public event Variables..::.DelegateVariableRemoved VariableRemoved
Public Event VariableRemoved As Variables..::.DelegateVariableRemoved
public:
 event Variables..::.DelegateVariableRemoved^ VariableRemoved {
    void add (Variables..::.DelegateVariableRemoved^ value);
    void remove (Variables..::.DelegateVariableRemoved^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableUpdated Event

VariableUpdated Event
Namespaces ► VisualCronAPI ► Variables ► VariableUpdated
This event is raised when a Variable has been updated
Declaration Syntax
C# Visual Basic Visual C++
public event Variables..::.DelegateVariableUpdated VariableUpdated
Public Event VariableUpdated As Variables..::.DelegateVariableUpdated
public:
 event Variables..::.DelegateVariableUpdated^ VariableUpdated {
    void add (Variables..::.DelegateVariableUpdated^ value);
    void remove (Variables..::.DelegateVariableUpdated^ value);
}
Remarks

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables.__Variables Interface

Variables..::.__Variables Interface
Namespaces ► VisualCronAPI ► Variables ► Variables..::.__Variables

[Missing <summary> documentation for T:VisualCronAPI.Variables.__Variables]

Declaration Syntax
C# Visual Basic Visual C++
public interface __Variables
Public Interface __Variables
public interface class __Variables
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | VariableAdded(Server%, UserVariableClass) |
 | VariableRemoved(Server%, UserVariableClass) |
 | VariableUpdated(Server%, UserVariableClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableAdded Method (server, ovn)

VariableAdded Method (server, ovn)
Namespaces ► VisualCronAPI ► Variables..::.__Variables ► VariableAdded(Server%, UserVariableClass)

[Missing <summary> documentation for M:VisualCronAPI.Variables.__Variables.VariableAdded(VisualCronAPI.Server@,VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
void VariableAdded(
    ref Server server,
    UserVariableClass ovn
)
Sub VariableAdded ( _
    ByRef server As Server, _
    ovn As UserVariableClass _
)
void VariableAdded(
    Server^% server,
    UserVariableClass^ ovn
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Variables.__Variables.VariableAdded(VisualCronAPI.Server@,VisualCron.UserVariableClass)"]

ovn (UserVariableClass)

[Missing <param name="ovn"/> documentation for "M:VisualCronAPI.Variables.__Variables.VariableAdded(VisualCronAPI.Server@,VisualCron.UserVariableClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableRemoved Method (server, ovn)

VariableRemoved Method (server, ovn)
Namespaces ► VisualCronAPI ► Variables..::.__Variables ► VariableRemoved(Server%, UserVariableClass)

[Missing <summary> documentation for M:VisualCronAPI.Variables.__Variables.VariableRemoved(VisualCronAPI.Server@,VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
void VariableRemoved(
    ref Server server,
    UserVariableClass ovn
)
Sub VariableRemoved ( _
    ByRef server As Server, _
    ovn As UserVariableClass _
)
void VariableRemoved(
    Server^% server,
    UserVariableClass^ ovn
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Variables.__Variables.VariableRemoved(VisualCronAPI.Server@,VisualCron.UserVariableClass)"]

ovn (UserVariableClass)

[Missing <param name="ovn"/> documentation for "M:VisualCronAPI.Variables.__Variables.VariableRemoved(VisualCronAPI.Server@,VisualCron.UserVariableClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


VariableUpdated Method (server, ovn)

VariableUpdated Method (server, ovn)
Namespaces ► VisualCronAPI ► Variables..::.__Variables ► VariableUpdated(Server%, UserVariableClass)

[Missing <summary> documentation for M:VisualCronAPI.Variables.__Variables.VariableUpdated(VisualCronAPI.Server@,VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
void VariableUpdated(
    ref Server server,
    UserVariableClass ovn
)
Sub VariableUpdated ( _
    ByRef server As Server, _
    ovn As UserVariableClass _
)
void VariableUpdated(
    Server^% server,
    UserVariableClass^ ovn
)
Parameters
server ( Server %)

[Missing <param name="server"/> documentation for "M:VisualCronAPI.Variables.__Variables.VariableUpdated(VisualCronAPI.Server@,VisualCron.UserVariableClass)"]

ovn (UserVariableClass)

[Missing <param name="ovn"/> documentation for "M:VisualCronAPI.Variables.__Variables.VariableUpdated(VisualCronAPI.Server@,VisualCron.UserVariableClass)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables._Variables Interface

Variables..::._Variables Interface
Namespaces ► VisualCronAPI ► Variables ► Variables..::._Variables

[Missing <summary> documentation for T:VisualCronAPI.Variables._Variables]

Declaration Syntax
C# Visual Basic Visual C++
public interface _Variables
Public Interface _Variables
public interface class _Variables
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Add(UserVariableClass) |
 | Contains(String) |
 | Get(String) |
 | GetAllArray(Boolean) |
 | GetVariableValue(UserVariableClass) |
 | Remove(UserVariableClass) |
 | Remove(String) |
 | RemoveAll()()() |
 | SetVariableValue(UserVariableClass%, String) |
 | Update(UserVariableClass) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Add Method (uvc)

Add Method (uvc)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► Add(UserVariableClass)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.Add(VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
UserVariableClass Add(
    UserVariableClass uvc
)
Function Add ( _
    uvc As UserVariableClass _
) As UserVariableClass
UserVariableClass^ Add(
    UserVariableClass^ uvc
)
Parameters
uvc (UserVariableClass)

[Missing <param name="uvc"/> documentation for "M:VisualCronAPI.Variables._Variables.Add(VisualCron.UserVariableClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.Add(VisualCron.UserVariableClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Contains Method (strVariableName)

Contains Method (strVariableName)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► Contains(String)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Contains(
    string strVariableName
)
Function Contains ( _
    strVariableName As String _
) As Boolean
bool Contains(
    String^ strVariableName
)
Parameters
strVariableName (String)

[Missing <param name="strVariableName"/> documentation for "M:VisualCronAPI.Variables._Variables.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.Contains(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Get Method (name)

Get Method (name)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► Get(String)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.Get(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
UserVariableClass Get(
    string name
)
Function Get ( _
    name As String _
) As UserVariableClass
UserVariableClass^ Get(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:VisualCronAPI.Variables._Variables.Get(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.Get(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetAllArray Method (bolSorted)

GetAllArray Method (bolSorted)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► GetAllArray(Boolean)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.GetAllArray(System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
ArrayList GetAllArray(
    bool bolSorted
)
Function GetAllArray ( _
    bolSorted As Boolean _
) As ArrayList
ArrayList^ GetAllArray(
    bool bolSorted
)
Parameters
bolSorted (Boolean)

[Missing <param name="bolSorted"/> documentation for "M:VisualCronAPI.Variables._Variables.GetAllArray(System.Boolean)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.GetAllArray(System.Boolean)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


GetVariableValue Method (uv)

GetVariableValue Method (uv)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► GetVariableValue(UserVariableClass)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.GetVariableValue(VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
Object GetVariableValue(
    UserVariableClass uv
)
Function GetVariableValue ( _
    uv As UserVariableClass _
) As Object
Object^ GetVariableValue(
    UserVariableClass^ uv
)
Parameters
uv (UserVariableClass)

[Missing <param name="uv"/> documentation for "M:VisualCronAPI.Variables._Variables.GetVariableValue(VisualCron.UserVariableClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.GetVariableValue(VisualCron.UserVariableClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method

Remove Method
Namespaces ► VisualCronAPI ► Variables..::._Variables ► Remove()()()
Members
Icon | Member | Description
 | Remove(UserVariableClass) |
 | Remove(String) |

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (variableName)

Remove Method (variableName)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► Remove(String)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.Remove(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    string variableName
)
Function Remove ( _
    variableName As String _
) As Boolean
bool Remove(
    String^ variableName
)
Parameters
variableName (String)

[Missing <param name="variableName"/> documentation for "M:VisualCronAPI.Variables._Variables.Remove(System.String)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.Remove(System.String)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Remove Method (ovn)

Remove Method (ovn)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► Remove(UserVariableClass)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.Remove(VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
bool Remove(
    UserVariableClass ovn
)
Function Remove ( _
    ovn As UserVariableClass _
) As Boolean
bool Remove(
    UserVariableClass^ ovn
)
Parameters
ovn (UserVariableClass)

[Missing <param name="ovn"/> documentation for "M:VisualCronAPI.Variables._Variables.Remove(VisualCron.UserVariableClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.Remove(VisualCron.UserVariableClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


RemoveAll Method

RemoveAll Method
Namespaces ► VisualCronAPI ► Variables..::._Variables ► RemoveAll()()()

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.RemoveAll]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveAll()
Sub RemoveAll
void RemoveAll()

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


SetVariableValue Method (uv, strValue)

SetVariableValue Method (uv, strValue)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► SetVariableValue(UserVariableClass%, String)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.SetVariableValue(VisualCron.UserVariableClass@,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void SetVariableValue(
    ref UserVariableClass uv,
    string strValue
)
Sub SetVariableValue ( _
    ByRef uv As UserVariableClass, _
    strValue As String _
)
void SetVariableValue(
    UserVariableClass^% uv,
    String^ strValue
)
Parameters
uv ( UserVariableClass %)

[Missing <param name="uv"/> documentation for "M:VisualCronAPI.Variables._Variables.SetVariableValue(VisualCron.UserVariableClass@,System.String)"]

strValue (String)

[Missing <param name="strValue"/> documentation for "M:VisualCronAPI.Variables._Variables.SetVariableValue(VisualCron.UserVariableClass@,System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Update Method (uvc)

Update Method (uvc)
Namespaces ► VisualCronAPI ► Variables..::._Variables ► Update(UserVariableClass)

[Missing <summary> documentation for M:VisualCronAPI.Variables._Variables.Update(VisualCron.UserVariableClass)]

Declaration Syntax
C# Visual Basic Visual C++
UserVariableClass Update(
    UserVariableClass uvc
)
Function Update ( _
    uvc As UserVariableClass _
) As UserVariableClass
UserVariableClass^ Update(
    UserVariableClass^ uvc
)
Parameters
uvc (UserVariableClass)

[Missing <param name="uvc"/> documentation for "M:VisualCronAPI.Variables._Variables.Update(VisualCron.UserVariableClass)"]

Return Value

[Missing <returns> documentation for M:VisualCronAPI.Variables._Variables.Update(VisualCron.UserVariableClass)]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables.DelegateVariableAdded Delegate

Variables..::.DelegateVariableAdded Delegate
Namespaces ► VisualCronAPI ► Variables ► Variables..::.DelegateVariableAdded

[Missing <summary> documentation for T:VisualCronAPI.Variables.DelegateVariableAdded]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateVariableAdded(
    ref Server server,
    UserVariableClass ovn
)
Public Delegate Sub DelegateVariableAdded ( _
    ByRef server As Server, _
    ovn As UserVariableClass _
)
public delegate void DelegateVariableAdded(
    Server^% server,
    UserVariableClass^ ovn
)
Parameters
server ( Server %)
ovn (UserVariableClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables.DelegateVariableRemoved Delegate

Variables..::.DelegateVariableRemoved Delegate
Namespaces ► VisualCronAPI ► Variables ► Variables..::.DelegateVariableRemoved

[Missing <summary> documentation for T:VisualCronAPI.Variables.DelegateVariableRemoved]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateVariableRemoved(
    ref Server server,
    UserVariableClass ovn
)
Public Delegate Sub DelegateVariableRemoved ( _
    ByRef server As Server, _
    ovn As UserVariableClass _
)
public delegate void DelegateVariableRemoved(
    Server^% server,
    UserVariableClass^ ovn
)
Parameters
server ( Server %)
ovn (UserVariableClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables.DelegateVariableUpdated Delegate

Variables..::.DelegateVariableUpdated Delegate
Namespaces ► VisualCronAPI ► Variables ► Variables..::.DelegateVariableUpdated

[Missing <summary> documentation for T:VisualCronAPI.Variables.DelegateVariableUpdated]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void DelegateVariableUpdated(
    ref Server server,
    UserVariableClass ovn
)
Public Delegate Sub DelegateVariableUpdated ( _
    ByRef server As Server, _
    ovn As UserVariableClass _
)
public delegate void DelegateVariableUpdated(
    Server^% server,
    UserVariableClass^ ovn
)
Parameters
server ( Server %)
ovn (UserVariableClass)

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables.VariableNotFoundException Class

Variables..::.VariableNotFoundException Class
Namespaces ► VisualCronAPI ► Variables ► Variables..::.VariableNotFoundException

[Missing <summary> documentation for T:VisualCronAPI.Variables.VariableNotFoundException]

Declaration Syntax
C# Visual Basic Visual C++
public class VariableNotFoundException : Exception
Public Class VariableNotFoundException _
    Inherits Exception
public ref class VariableNotFoundException : public Exception
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Variables..::.VariableNotFoundException(String) | Initializes a new instance of the Variables..::.VariableNotFoundException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | Variables..::.VariableNotFoundException

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Variables.VariableNotFoundException Constructor (id)

Variables..::.VariableNotFoundException Constructor (id)
Namespaces ► VisualCronAPI ► Variables..::.VariableNotFoundException ► Variables..::.VariableNotFoundException(String)
Initializes a new instance of the Variables..::.VariableNotFoundException class
Declaration Syntax
C# Visual Basic Visual C++
public VariableNotFoundException(
    string id
)
Public Sub New ( _
    id As String _
)
public:
VariableNotFoundException(
    String^ id
)
Parameters
id (String)

[Missing <param name="id"/> documentation for "M:VisualCronAPI.Variables.VariableNotFoundException.#ctor(System.String)"]

Send comments on this topic to Please email feedback to Support

Homepage of VisualCron

Assembly: VisualCronAPI (Module: VisualCronAPI) Version: 1.0.2.20512


Select Method

Select Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► Select()()()
Members
Icon | Member | Description
 | Select()()() | Gets an array of all DataRow objects.
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order.
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state.


GetParentRows Method

GetParentRows Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► GetParentRows()()()
Members
Icon | Member | Description
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation.
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream.
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader.
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file.
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader.


SetColumnError Method

SetColumnError Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► SetColumnError()()()
Members
Icon | Member | Description
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index.
 | SetColumnError(String, String) | Sets the error description for a column specified by name.
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream.
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter.
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter.
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file.
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.


Load Method

Load Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter.
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


DetermineSchemaSerializationMode Method

DetermineSchemaSerializationMode Method
Namespaces ► VisualCron ► DSNetworkCredentials ► DetermineSchemaSerializationMode()()()
Members
Icon | Member | Description
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet.
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet.


IsNull Method

IsNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► IsNull()()()
Members
Icon | Member | Description
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value.
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value.
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value.
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream.
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter.
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file.
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSConditions ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSNetworkCredentials ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object.
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object.
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object.
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file.


GetParentRow Method

GetParentRow Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► GetParentRow()()()
Members
Icon | Member | Description
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation.
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSMAC ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


SetColumnError Method

SetColumnError Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► SetColumnError()()()
Members
Icon | Member | Description
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index.
 | SetColumnError(String, String) | Sets the error description for a column specified by name.
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


GetChildRows Method

GetChildRows Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► GetChildRows()()()
Members
Icon | Member | Description
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation.
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSConditions ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


HasChanges Method

HasChanges Method
Namespaces ► VisualCron ► DSConditions ► HasChanges()()()
Members
Icon | Member | Description
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSMAC ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream.
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter.
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter.
 | WriteXml(String) | Writes the current data for the DataSet to the specified file.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.


Item Property

Item Property
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index.
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name.
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn.
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve.
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column.
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn.


GetColumnError Method

GetColumnError Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► GetColumnError()()()
Members
Icon | Member | Description
 | GetColumnError(Int32) | Gets the error description for the column specified by index.
 | GetColumnError(String) | Gets the error description for a column, specified by name.
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn.


Load Method

Load Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter.
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate.


SetColumnError Method

SetColumnError Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► SetColumnError()()()
Members
Icon | Member | Description
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index.
 | SetColumnError(String, String) | Sets the error description for a column specified by name.
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSCopyFiles ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream.
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter.
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter.
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file.
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSMAC ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object.
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object.
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object.
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSConditions ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream.
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter.
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter.
 | WriteXml(String) | Writes the current data for the DataSet to the specified file.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.


InferXmlSchema Method

InferXmlSchema Method
Namespaces ► VisualCron ► DSMAC ► InferXmlSchema()()()
Members
Icon | Member | Description
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet.
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet.
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet.
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet.


Item Property

Item Property
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index.
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name.
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn.
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve.
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column.
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSNetworkCredentials ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream.
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter.
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter.
 | WriteXml(String) | Writes the current data for the DataSet to the specified file.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.


SetParentRow Method

SetParentRow Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► SetParentRow()()()
Members
Icon | Member | Description
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow.
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation.


CreateDataReader Method

CreateDataReader Method
Namespaces ► VisualCron ► DSNetworkCredentials ► CreateDataReader()()()
Members
Icon | Member | Description
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable.


CreateDataReader Method

CreateDataReader Method
Namespaces ► VisualCron ► DSConditions ► CreateDataReader()()()
Members
Icon | Member | Description
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable.


Load Method

Load Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter.
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate.


GetChildRows Method

GetChildRows Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► GetChildRows()()()
Members
Icon | Member | Description
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation.
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion.


Load Method

Load Method
Namespaces ► VisualCron ► DSMAC ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet.


CreateDataReader Method

CreateDataReader Method
Namespaces ► VisualCron ► DSMAC ► CreateDataReader()()()
Members
Icon | Member | Description
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSCopyFiles ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current data for the DataSet using the specified Stream.
 | WriteXml(TextWriter) | Writes the current data for the DataSet using the specified TextWriter.
 | WriteXml(XmlWriter) | Writes the current data for the DataSet to the specified XmlWriter.
 | WriteXml(String) | Writes the current data for the DataSet to the specified file.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified Stream and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataSet to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSNetworkCredentials ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


GetColumnError Method

GetColumnError Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► GetColumnError()()()
Members
Icon | Member | Description
 | GetColumnError(Int32) | Gets the error description for the column specified by index.
 | GetColumnError(String) | Gets the error description for a column, specified by name.
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn.


SetParentRow Method

SetParentRow Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► SetParentRow()()()
Members
Icon | Member | Description
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow.
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream.
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter.
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter.
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file.
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.


GetParentRow Method

GetParentRow Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► GetParentRow()()()
Members
Icon | Member | Description
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation.
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion.


GetParentRow Method

GetParentRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► GetParentRow()()()
Members
Icon | Member | Description
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation.
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion.


Load Method

Load Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter.
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate.


Item Property

Item Property
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index.
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name.
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn.
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve.
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column.
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable.
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSNetworkCredentials ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet.
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet.
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet.
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet.


SetParentRow Method

SetParentRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► SetParentRow()()()
Members
Icon | Member | Description
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow.
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation.


SetParentRow Method

SetParentRow Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► SetParentRow()()()
Members
Icon | Member | Description
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow.
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file.
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader.


GetChildRows Method

GetChildRows Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► GetChildRows()()()
Members
Icon | Member | Description
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation.
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion.


GetColumnError Method

GetColumnError Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► GetColumnError()()()
Members
Icon | Member | Description
 | GetColumnError(Int32) | Gets the error description for the column specified by index.
 | GetColumnError(String) | Gets the error description for a column, specified by name.
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn.


HasChanges Method

HasChanges Method
Namespaces ► VisualCron ► DSCopyFiles ► HasChanges()()()
Members
Icon | Member | Description
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState.


SetParentRow Method

SetParentRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► SetParentRow()()()
Members
Icon | Member | Description
 | SetParentRow(DataRow) | Sets the parent row of a DataRow with specified new parent DataRow.
 | SetParentRow(DataRow, DataRelation) | Sets the parent row of a DataRow with specified new parent DataRow and DataRelation.


GetChildRows Method

GetChildRows Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► GetChildRows()()()
Members
Icon | Member | Description
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation.
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion.


DetermineSchemaSerializationMode Method

DetermineSchemaSerializationMode Method
Namespaces ► VisualCron ► DSMAC ► DetermineSchemaSerializationMode()()()
Members
Icon | Member | Description
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet.
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet.


LoadDataRow Method

LoadDataRow Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► LoadDataRow()()()
Members
Icon | Member | Description
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable.
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSNetworkCredentials ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream.
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter.
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter.
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file.
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.


Load Method

Load Method
Namespaces ► VisualCron ► DSCopyFiles ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file.
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader.


IsNull Method

IsNull Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► IsNull()()()
Members
Icon | Member | Description
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value.
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value.
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value.
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSCopyFiles ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet.
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument.
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments.
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet.
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.


Select Method

Select Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► Select()()()
Members
Icon | Member | Description
 | Select()()() | Gets an array of all DataRow objects.
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order.
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state.


LoadDataRow Method

LoadDataRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► LoadDataRow()()()
Members
Icon | Member | Description
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.


GetParentRows Method

GetParentRows Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► GetParentRows()()()
Members
Icon | Member | Description
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation.
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream.
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader.
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file.
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream.
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter.
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file.
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file.
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the current data structure of the DataTable as an XML schema to the specified stream.
 | WriteXmlSchema(Stream, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified stream. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(TextWriter) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter.
 | WriteXmlSchema(TextWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified TextWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(XmlWriter) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter.
 | WriteXmlSchema(XmlWriter, Boolean) | Writes the current data structure of the DataTable as an XML schema using the specified XmlWriter. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXmlSchema(String) | Writes the current data structure of the DataTable as an XML schema to the specified file.
 | WriteXmlSchema(String, Boolean) | Writes the current data structure of the DataTable as an XML schema to the specified file. To save the schema for the table and all its descendants, set the writeHierarchy parameter to true.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable.
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSMAC ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet.
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument.
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments.
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet.
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream.
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader.
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file.
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader.


GetChildRows Method

GetChildRows Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► GetChildRows()()()
Members
Icon | Member | Description
 | GetChildRows(String) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation.
 | GetChildRows(String, DataRowVersion) | Gets the child rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation.
 | GetChildRows(DataRelation, DataRowVersion) | Gets the child rows of a DataRow using the specified DataRelation, and DataRowVersion.


Select Method

Select Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► Select()()()
Members
Icon | Member | Description
 | Select()()() | Gets an array of all DataRow objects.
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order.
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state.


Load Method

Load Method
Namespaces ► VisualCron ► DSConditions ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet.


IsNull Method

IsNull Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► IsNull()()()
Members
Icon | Member | Description
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value.
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value.
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value.
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value.


DetermineSchemaSerializationMode Method

DetermineSchemaSerializationMode Method
Namespaces ► VisualCron ► DSCopyFiles ► DetermineSchemaSerializationMode()()()
Members
Icon | Member | Description
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet.
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet.


InferXmlSchema Method

InferXmlSchema Method
Namespaces ► VisualCron ► DSNetworkCredentials ► InferXmlSchema()()()
Members
Icon | Member | Description
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet.
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet.
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet.
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


Select Method

Select Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► Select()()()
Members
Icon | Member | Description
 | Select()()() | Gets an array of all DataRow objects.
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order.
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state.


GetParentRows Method

GetParentRows Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► GetParentRows()()()
Members
Icon | Member | Description
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation.
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSCopyFiles ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader.
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file.
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode.
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode.
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode.
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable.
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSMAC ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet.
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet.
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet.
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSMAC ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader.
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file.
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode.
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode.
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode.
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSMAC ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


GetParentRow Method

GetParentRow Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► GetParentRow()()()
Members
Icon | Member | Description
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation.
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion.


IsNull Method

IsNull Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► IsNull()()()
Members
Icon | Member | Description
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value.
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value.
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value.
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file.
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader.


Load Method

Load Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsDataTable ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows.
 | Load(IDataReader, LoadOption) | Fills a DataTable with values from a data source using the supplied IDataReader. If the DataTable already contains rows, the incoming data from the data source is merged with the existing rows according to the value of the loadOption parameter.
 | Load(IDataReader, LoadOption, FillErrorEventHandler) | Fills a DataTable with values from a data source using the supplied IDataReader using an error-handling delegate.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSCopyFiles ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object.
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object.
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object.
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file.


LoadDataRow Method

LoadDataRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► LoadDataRow()()()
Members
Icon | Member | Description
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(Stream) | Reads XML schema and data into the DataTable using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataTable using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataTable from the specified file.
 | ReadXml(XmlReader) | Reads XML Schema and Data into the DataTable using the specified XmlReader.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSConditions ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet.
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet.
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet.
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSConditions ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader.
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file.
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode.
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode.
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode.
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesDataTable ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream.
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter.
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file.
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.


Item Property

Item Property
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index.
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name.
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn.
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve.
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column.
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataTable that contains all changes made to it since it was loaded or AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataTable containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSCopyFiles ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(XmlReader) | Reads the XML schema from the specified XmlReader into the DataSet.
 | ReadXmlSchema(Stream) | Reads the XML schema from the specified Stream into the DataSet.
 | ReadXmlSchema(TextReader) | Reads the XML schema from the specified TextReader into the DataSet.
 | ReadXmlSchema(String) | Reads the XML schema from the specified file into the DataSet.


GetParentRows Method

GetParentRows Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► GetParentRows()()()
Members
Icon | Member | Description
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation.
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion.


GetColumnError Method

GetColumnError Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► GetColumnError()()()
Members
Icon | Member | Description
 | GetColumnError(Int32) | Gets the error description for the column specified by index.
 | GetColumnError(String) | Gets the error description for a column, specified by name.
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn.


GetParentRows Method

GetParentRows Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsRow ► GetParentRows()()()
Members
Icon | Member | Description
 | GetParentRows(String) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRows(String, DataRowVersion) | Gets the parent rows of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRows(DataRelation) | Gets the parent rows of a DataRow using the specified DataRelation.
 | GetParentRows(DataRelation, DataRowVersion) | Gets the parent rows of a DataRow using the specified DataRelation, and DataRowVersion.


DetermineSchemaSerializationMode Method

DetermineSchemaSerializationMode Method
Namespaces ► VisualCron ► DSConditions ► DetermineSchemaSerializationMode()()()
Members
Icon | Member | Description
 | DetermineSchemaSerializationMode(SerializationInfo, StreamingContext) | Determines the SchemaSerializationMode for a DataSet.
 | DetermineSchemaSerializationMode(XmlReader) | Determines the SchemaSerializationMode for a DataSet.


HasChanges Method

HasChanges Method
Namespaces ► VisualCron ► DSMAC ► HasChanges()()()
Members
Icon | Member | Description
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


LoadDataRow Method

LoadDataRow Method
Namespaces ► VisualCron ► DSMAC..::.DTMACDataTable ► LoadDataRow()()()
Members
Icon | Member | Description
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataTable) | Merge the specified DataTable with the current DataTable.
 | Merge(DataTable, Boolean) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes in the current DataTable.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merge the specified DataTable with the current DataTable, indicating whether to preserve changes and how to handle missing schema in the current DataTable.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSConditions ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet.
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument.
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments.
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet.
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.


SetColumnError Method

SetColumnError Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► SetColumnError()()()
Members
Icon | Member | Description
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index.
 | SetColumnError(String, String) | Sets the error description for a column specified by name.
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn.


GetParentRow Method

GetParentRow Method
Namespaces ► VisualCron ► DSConditions..::.ConditionsRow ► GetParentRow()()()
Members
Icon | Member | Description
 | GetParentRow(String) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation.
 | GetParentRow(String, DataRowVersion) | Gets the parent row of a DataRow using the specified RelationName of a DataRelation, and DataRowVersion.
 | GetParentRow(DataRelation) | Gets the parent row of a DataRow using the specified DataRelation.
 | GetParentRow(DataRelation, DataRowVersion) | Gets the parent row of a DataRow using the specified DataRelation, and DataRowVersion.


Dispose Method

Dispose Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► Dispose()()()
Members
Icon | Member | Description
 | Dispose()()() | Releases all resources used by the MarshalByValueComponent.
 | Dispose(Boolean) | Releases the unmanaged resources used by the MarshalByValueComponent and optionally releases the managed resources.


HasChanges Method

HasChanges Method
Namespaces ► VisualCron ► DSNetworkCredentials ► HasChanges()()()
Members
Icon | Member | Description
 | HasChanges()()() | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows.
 | HasChanges(DataRowState) | Gets a value indicating whether the DataSet has changes, including new, deleted, or modified rows, filtered by DataRowState.


LoadDataRow Method

LoadDataRow Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► LoadDataRow()()()
Members
Icon | Member | Description
 | LoadDataRow(array<Object>[]()[], Boolean) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.
 | LoadDataRow(array<Object>[]()[], LoadOption) | Finds and updates a specific row. If no matching row is found, a new row is created using the given values.


GetChanges Method

GetChanges Method
Namespaces ► VisualCron ► DSCopyFiles ► GetChanges()()()
Members
Icon | Member | Description
 | GetChanges()()() | Gets a copy of the DataSet that contains all changes made to it since it was loaded or since AcceptChanges()()() was last called.
 | GetChanges(DataRowState) | Gets a copy of the DataSet containing all changes made to it since it was last loaded, or since AcceptChanges()()() was called, filtered by DataRowState.


InferXmlSchema Method

InferXmlSchema Method
Namespaces ► VisualCron ► DSCopyFiles ► InferXmlSchema()()()
Members
Icon | Member | Description
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet.
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet.
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet.
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet.


WriteXmlSchema Method

WriteXmlSchema Method
Namespaces ► VisualCron ► DSConditions ► WriteXmlSchema()()()
Members
Icon | Member | Description
 | WriteXmlSchema(Stream) | Writes the DataSet structure as an XML schema to using the specified Stream object.
 | WriteXmlSchema(TextWriter) | Writes the DataSet structure as an XML schema to a TextWriter object.
 | WriteXmlSchema(XmlWriter) | Writes the DataSet structure as an XML schema to an XmlWriter object.
 | WriteXmlSchema(String) | Writes the DataSet structure as an XML schema to a file.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream.
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter.
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file.
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.


Select Method

Select Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► Select()()()
Members
Icon | Member | Description
 | Select()()() | Gets an array of all DataRow objects.
 | Select(String) | Gets an array of all DataRow objects that match the filter criteria in order of primary key (or lacking one, order of addition.)
 | Select(String, String) | Gets an array of all DataRow objects that match the filter criteria, in the specified sort order.
 | Select(String, String, DataViewRowState) | Gets an array of all DataRow objects that match the filter in the order of the sort that match the specified state.


IsNull Method

IsNull Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► IsNull()()()
Members
Icon | Member | Description
 | IsNull(Int32) | Gets a value that indicates whether the column at the specified index contains a null value.
 | IsNull(String) | Gets a value that indicates whether the named column contains a null value.
 | IsNull(DataColumn) | Gets a value that indicates whether the specified DataColumn contains a null value.
 | IsNull(DataColumn, DataRowVersion) | Gets a value that indicates whether the specified DataColumn and DataRowVersion contains a null value.


GetColumnError Method

GetColumnError Method
Namespaces ► VisualCron ► DSMAC..::.DTMACRow ► GetColumnError()()()
Members
Icon | Member | Description
 | GetColumnError(Int32) | Gets the error description for the column specified by index.
 | GetColumnError(String) | Gets the error description for a column, specified by name.
 | GetColumnError(DataColumn) | Gets the error description of the specified DataColumn.


ReadXml Method

ReadXml Method
Namespaces ► VisualCron ► DSNetworkCredentials ► ReadXml()()()
Members
Icon | Member | Description
 | ReadXml(XmlReader) | Reads XML schema and data into the DataSet using the specified XmlReader.
 | ReadXml(Stream) | Reads XML schema and data into the DataSet using the specified Stream.
 | ReadXml(TextReader) | Reads XML schema and data into the DataSet using the specified TextReader.
 | ReadXml(String) | Reads XML schema and data into the DataSet using the specified file.
 | ReadXml(XmlReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified XmlReader and XmlReadMode.
 | ReadXml(Stream, XmlReadMode) | Reads XML schema and data into the DataSet using the specified Stream and XmlReadMode.
 | ReadXml(TextReader, XmlReadMode) | Reads XML schema and data into the DataSet using the specified TextReader and XmlReadMode.
 | ReadXml(String, XmlReadMode) | Reads XML schema and data into the DataSet using the specified file and XmlReadMode.


Merge Method

Merge Method
Namespaces ► VisualCron ► DSNetworkCredentials ► Merge()()()
Members
Icon | Member | Description
 | Merge(DataSet) | Merges a specified DataSet and its schema into the current DataSet.
 | Merge(DataSet, Boolean) | Merges a specified DataSet and its schema into the current DataSet, preserving or discarding any changes in this DataSet according to the given argument.
 | Merge(DataSet, Boolean, MissingSchemaAction) | Merges a specified DataSet and its schema with the current DataSet, preserving or discarding changes in the current DataSet and handling an incompatible schema according to the given arguments.
 | Merge(DataTable) | Merges a specified DataTable and its schema into the current DataSet.
 | Merge(DataTable, Boolean, MissingSchemaAction) | Merges a specified DataTable and its schema into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.
 | Merge(array<DataRow>[]()[]) | Merges an array of DataRow objects into the current DataSet.
 | Merge(array<DataRow>[]()[], Boolean, MissingSchemaAction) | Merges an array of DataRow objects into the current DataSet, preserving or discarding changes in the DataSet and handling an incompatible schema according to the given arguments.


SetColumnError Method

SetColumnError Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsRow ► SetColumnError()()()
Members
Icon | Member | Description
 | SetColumnError(Int32, String) | Sets the error description for a column specified by index.
 | SetColumnError(String, String) | Sets the error description for a column specified by name.
 | SetColumnError(DataColumn, String) | Sets the error description for a column specified as a DataColumn.


Item Property

Item Property
Namespaces ► VisualCron ► DSCopyFiles..::.CopyFilesRow ► Item
Members
Icon | Member | Description
 | Item[([(Int32])]) | Gets or sets the data stored in the column specified by index.
 | Item[([(String])]) | Gets or sets the data stored in the column specified by name.
 | Item[([(DataColumn])]) | Gets or sets the data stored in the specified DataColumn.
 | Item[([(Int32, DataRowVersion])]) | Gets the data stored in the column, specified by index and version of the data to retrieve.
 | Item[([(String, DataRowVersion])]) | Gets the specified version of data stored in the named column.
 | Item[([(DataColumn, DataRowVersion])]) | Gets the specified version of data stored in the specified DataColumn.


CreateDataReader Method

CreateDataReader Method
Namespaces ► VisualCron ► DSCopyFiles ► CreateDataReader()()()
Members
Icon | Member | Description
 | CreateDataReader()()() | Returns a DataTableReader with one result set per DataTable, in the same sequence as the tables appear in the Tables collection.
 | CreateDataReader(array<DataTable>[]()[]) | Returns a DataTableReader with one result set per DataTable.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream.
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader.
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file.
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader.


InferXmlSchema Method

InferXmlSchema Method
Namespaces ► VisualCron ► DSConditions ► InferXmlSchema()()()
Members
Icon | Member | Description
 | InferXmlSchema(XmlReader, array<String>[]()[]) | Applies the XML schema from the specified XmlReader to the DataSet.
 | InferXmlSchema(Stream, array<String>[]()[]) | Applies the XML schema from the specified Stream to the DataSet.
 | InferXmlSchema(TextReader, array<String>[]()[]) | Applies the XML schema from the specified TextReader to the DataSet.
 | InferXmlSchema(String, array<String>[]()[]) | Applies the XML schema from the specified file to the DataSet.


Load Method

Load Method
Namespaces ► VisualCron ► DSNetworkCredentials ► Load()()()
Members
Icon | Member | Description
 | Load(IDataReader, LoadOption, FillErrorEventHandler, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<DataTable>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of DataTable instances to supply the schema and namespace information.
 | Load(IDataReader, LoadOption, array<String>[]()[]) | Fills a DataSet with values from a data source using the supplied IDataReader, using an array of strings to supply the names for the tables within the DataSet.


ReadXmlSchema Method

ReadXmlSchema Method
Namespaces ► VisualCron ► DSConditions..::.ConditionCollectionsDataTable ► ReadXmlSchema()()()
Members
Icon | Member | Description
 | ReadXmlSchema(Stream) | Reads an XML schema into the DataTable using the specified stream.
 | ReadXmlSchema(TextReader) | Reads an XML schema into the DataTable using the specified TextReader.
 | ReadXmlSchema(String) | Reads an XML schema into the DataTable from the specified file.
 | ReadXmlSchema(XmlReader) | Reads an XML schema into the DataTable using the specified XmlReader.


WriteXml Method

WriteXml Method
Namespaces ► VisualCron ► DSNetworkCredentials..::.NetworkCredentialsDataTable ► WriteXml()()()
Members
Icon | Member | Description
 | WriteXml(Stream) | Writes the current contents of the DataTable as XML using the specified Stream.
 | WriteXml(Stream, Boolean) | Writes the current contents of the DataTable as XML using the specified Stream. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter) | Writes the current contents of the DataTable as XML using the specified TextWriter.
 | WriteXml(TextWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified TextWriter. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(XmlWriter, Boolean) | Writes the current contents of the DataTable as XML using the specified XmlWriter.
 | WriteXml(String) | Writes the current contents of the DataTable as XML using the specified file.
 | WriteXml(String, Boolean) | Writes the current contents of the DataTable as XML using the specified file. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(Stream, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(Stream, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable to the specified file using the specified XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(TextWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(TextWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified TextWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(XmlWriter, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(XmlWriter, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified XmlWriter and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.
 | WriteXml(String, XmlWriteMode) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema.
 | WriteXml(String, XmlWriteMode, Boolean) | Writes the current data, and optionally the schema, for the DataTable using the specified file and XmlWriteMode. To write the schema, set the value for the mode parameter to WriteSchema. To save the data for the table and all its descendants, set the writeHierarchy parameter to true.